封面

中华佛典宝库制作 V1.00


目录

第一章 教理

第一节 佛法僧三宝
第二节 五位百法

一、心法
二、心所法

(一)心所名义
(二)别释六位

甲、遍行
乙、别境
丙、善
丁、根本烦恼
戊、随烦恼
己、不定

三、色法
四、心不相应行法
五、无为法
六、百法无我
七、五位唯识

第三节 蕴处界三科

一、五蕴

(一) 五蕴名义
(二) 别释体用

甲、色蕴
乙、受蕴
丙、想蕴
丁、行蕴
戊、识蕴

(三) 五蕴与百法相摄

二、十二处
三、十八界
四、佛说三科的意趣
五、三科名次
六、诸门分别

第四节 四谛

一、苦谛
二、集谛
三、灭谛
四、道谛
五、总分别十六行相
六、四谛的因果次第

第五节 十二有支
第六节 三法印与一实相印

第二章 人天行果

第一节 行

一、皈依三宝

(一)皈依的意义
(二)所皈依境的选择
(三)皈依者应具的认识和意志
(四)皈依后的正行
(五)皈依三宝所获功德

二、受持五戒

(一)深信业果决定
(二)业道名义
(三)十恶业道决择
(四)十善业道决择
(五)一多果业的差别

第二节 果

第三章 声闻行果

第一节 行

一、出离心
二、修集涅槃法缘
三、顺解脱分
四、顺抉择分

第二节 果

一、圣位所断烦恼
二、圣果差别
三、圣位功德

第四章 菩萨行果

第一节 菩萨乘的发心和誓愿

一、略说大乘名义及其殊胜
二、菩提心
三、发弘誓愿

第二节 行位
第三节 修断

一、所修胜行—六波罗蜜多
二、所断二障

第四节 果德


第一节 佛法僧三宝

    佛教基本知识（上）
    正果法师著

    第一章 教理
    第一节 佛法僧三宝
    佛法僧三宝，为学习佛法的人应该具有的根本认识，所以这里首先提出来解说。
    一、世间最初有三宝
    佛陀在菩提树下成等正觉以后，三七日间，唯自受用解脱的妙乐。自念所证法理，寂静微妙，甚深难见，非寻思境界，唯智者所觉；众生深着我见，爱乐烦恼，虽然为他们说法，恐亦不能了解，徒劳无益，不如默住。后经大梵天王劝请说法，世尊才往波罗捺斯城外鹿野苑，为先时舍佛而来这里修苦行的五个侍者：阿若憍陈如、頞鞞、跋提、十力迦叶、摩男俱利，说苦、集、灭、道四谛法门。五人听法以后，漏尽意解，成阿罗汉，于是世间开始有了三宝：大圣佛陀是佛宝，四谛法轮是法宝，五阿罗汉是僧宝。
    二、佛法僧的名义
    （一）佛，梵语‘佛陀’，译为觉者，或智者。即真正圆满觉悟诸法事理，了了分明，究竟无余的一切智人。觉有正觉、等觉、无上觉三义。正觉简别凡夫的不觉，和外道的错觉。凡夫对于事物的真相不明，起种种颠倒，所以名不觉。外道依于寻思推度，或有限的定力和通力，见着了事物的某些部分道理，妄执为全部的、真实的，而建立种种的错误理论，自命是觉者，实际上仍然是有漏分别心的错觉。佛陀以无漏无分别智亲证诸法的真如实相，对于诸法的事相理体无增无减地平等如实觉了，是真正觉悟的人，所以是正觉者。等觉即遍觉义，简别二乘圣人。他们虽然是正觉，而未遍觉；因为二乘圣人自己虽然得了正觉，但不能起广大的慈悲心去觉悟别人，仅仅限于自觉而无遍觉。佛陀如大良医，自医医人，兴运大慈大悲，以自觉去遍觉一切有情，所以是遍觉者。无上觉简别菩萨。登地的菩萨，虽然是正觉者而亦觉悟其他有情，但因烦恼障和所知障还没断尽，福德智慧两种资粮尚须进修，虽是自觉觉他的遍觉者，未到圆满无上。唯有佛陀，自觉觉他的悲智行愿皆已究竟圆满，无有过上，无有与之可比并的人，所以是无上觉者。诸经中说，如果证得阿耨多罗三藐三菩提，义即无上正等正觉者。总起来说：自觉、觉他、觉行圆满，故名为佛。如《佛地论》说：‘于一切法、一切种相，能自开觉，亦开觉一切有情，如睡觉醒，如莲花开，故名为佛。’
    （二）法，梵语‘达磨’，译名为法，是轨则义。《成唯识论》说：‘法谓轨持。’《成唯识论述记》解释说：‘轨谓轨范，可生物解；持谓任持，不舍自相。’这就是说：凡是一种事物，能固持自性，如花有花的体，树有树的体，而又能表现其在一定范围内的情况，使其他有情见之即可了解其为何物，合此任持自性、轨范物解两义，即名为法。故这个‘法’字，实即概括了宇宙间一切的东西。佛法的法，是指佛陀依如实所觉而宣示于世间众生的善巧教法；这些教法，有它的自体，可以为一切众生的轨则，与‘达磨’的意义相当，所以名之为法。论其正体，应该是三乘无漏所摄的教、理、行、果。教即文字声音，理即二谛四谛等义理，行即三乘所修的二利行，果即三乘无学所得的二转依果。若就所化的机来说，则法可以为五乘：为人乘说五戒法，为天乘说十善法，为声闻乘说四谛法，为独觉乘说十二因缘法，为菩萨乘说六波罗密多法。若就对治的法门来说，则有八万四千法；就修持的总纲来说，则只有戒定慧三学。
    佛陀入灭以后，由大迦叶尊者为领导，召集佛弟子们，把佛陀垂示众生的一切教法，由阿难诵出，结集起来，总分为三藏：
（1）‘素呾览’，译言契经，即是经藏。
（2）‘毗奈耶’，译言调伏，即是律藏。
（3）‘阿毗达磨’，译言对法，即是论藏。藏是含摄义，即三藏中含摄了一切所应知、应行、应证的法义。考其所诠，各有通局。就局而言，经诠定学，律诠戒学，论诠慧学。以通言之，则各相交摄，三藏是能诠教，三学是所诠义，以教摄义，无有遗余。
    又从如来对机说法的多种形式和事义的差别，分为十二分教：
（1）契经。即诸经宣说五蕴、十二处、十八界、缘起、四谛、菩提分法等法义的长行文句。
（2）应颂。即诸经长行文的中间或最后，以一定的字数组成颂文，重行概括长行文句已说的法义，或显示未明了究竟的法义。
（3）记镃。即诸经中记说诸弟子命终以后生处的差别，或授记菩萨何时何处成佛等事。
（4）讽颂。有的经典，宣说法义，不用长行文句，而是以颂文的形式体裁宣说。这是纯粹颂文体的经典，所以又名孤起颂，如法句经等。
（5）自说。为令正法久住，或为令众生得大利益，有的殊胜法门，不因请求，如来自然宣说，这就是不列诸请法人的经典，如阿弥陀经等。
（6）因缘。即一切摄有因缘事相而说的教法，如别解脱经等。
（7）譬喻。即诸经中以譬喻来显了本义而说的教法。
（8）本事。就是佛陀宣说弟子们过去世因缘事的诸经典。
（9）本生。如来说自己过去世种种生死，行菩萨行等事。
（10）方广。诸经中宣说能证无上菩提的诸菩萨道，令证十力、四无所畏等功德。这是方正广大的真实事义，所以名为方广。
（11）稀法。佛陀宣说弟子们最殊胜奇特的神通功德，和甚深的法义。这都是稀有的，不可以常情思议的，所以名为稀法。
（12）论义。即研究解释诸经的宗要和意义的经典。
    这十二分教中，契经、应颂、讽颂三种，约经文上的体裁而立名；其余的九种，是从经文所载的各别的事义而立名。从多分义摄来说，契经、应颂、记镃、讽颂、自说、譬喻、本事、本生、方广、稀法，是为素呾览藏；因缘是毗奈耶藏；论议是为阿毗达磨藏。
    （三）僧，梵语‘僧伽’，译和合众，三人以上的名称（旧译四人为众）；即是奉行佛陀教法的出家弟子。为什么称为和合众呢？和合有两种意义：
（1）理和，同证择灭理故。
（2）事和，具有六种：[1]戒和同修。即对于所受的戒法，善护受持，无杂无秽，称赞不毁，与诸同修清净梵行的道伴们，平等共同受持。由此法故，发起尊重爱敬，欢喜悦意，无违无诤，和合共住。[2]见和同解。即对于出离尽苦的圣道法，能善巧如理的通达于如是见。与诸同修清净梵行的道伴们，见解一致的共同修学。由此法故，发起尊重爱敬，欢喜悦意，无违无诤，和合共住。[3]利和同均。即对于获得的如法利养（财物），个人不别藏隐，与诸同修清净梵行的道伴们，平等受用。由此法故，发起尊重爱敬，欢喜悦意，无违无诤，和合共住。[4]）身和同住。即对于同修清净梵行的道伴们，修习身慈业，有疾病等违缘，互相照顾。由此法故，发起尊重爱敬，欢喜悦意，无违无诤，和合共住。[5]口和无诤。即对于同修清净梵行的道伴们，修习语慈业，有善法功德互相赞叹鼓励，有过失互相善意的谏止举发。由此法故，发起尊重爱敬，欢喜悦意，无违无诤，和合共住。[6]意和同悦。即对于同修清净梵行的道伴们，修习意慈业，念诸道伴，皆是替佛宣扬教法者，受行正法者，思惟正法者，是正法的住持人，是自己不容易得到的善友，是帮助自己成就道业的善知识。由此法故，发起尊重爱敬，欢喜悦意，和合共住。
    僧的分类，有两种：
（1）声闻僧，即修习小乘三学，剃发染衣，具足出家沙门的形相。（2）菩萨僧，即修习大乘三学者，有出家和在家的形相。还有三种的分法：[1]声闻僧。[2]缘觉僧，有麟喻、部行两种，部行成僧众。[3]菩萨僧，即修习大乘的人。还有世俗僧、胜义僧，和四种僧等的分法，这里就不去多说了。
    三、称为宝的意义
    佛法僧三种为什么称为‘宝’呢？因为他是指示众生断恶修善，离苦得乐，解脱系缚，得大自在的导首，极为尊贵，如世间的珍奇宝物，所以称之为宝，《宝性论》中，用世间珍宝的六种譬喻，来说明佛法僧称为宝的意义：
（一）稀有义。如世间宝物，贫穷的人不能得到；三宝也是这样，没有善根的众生，百千万劫不能值遇。
（二）离尘义。如世间的珍宝，体质上没有瑕秽；三宝也是这样，绝离一切有漏的尘染，最极明净，故名为宝。
（三）势力义。如世间珍宝，能除贫困，医治病毒等，有大势力；三宝也是这样，具足不可思议的神通威力，故名为宝。
（四）庄严义。如世间珍宝，可以庄严世间，令世间美妙；三宝也是这样，具有无量的无漏功德，能庄严出世间，故名为宝。
（五）最胜义。如世间宝璧，在一切物中最为殊胜；三宝也是这样，是出世间的无漏法，最极殊胜无上，故名为宝。
（六）不改义。如世间的真金，烧打磨等，本质不能改变；三宝也是这样，是无漏法故，不为世间的称、讥、苦、乐、利、衰、毁、誉八风所倾动，恒常不变，故名为宝。《心地观经》报恩品以坚牢、无垢、与乐、难遇、能破、威德、满愿、庄严、最妙、不变十义说明佛法僧得名为宝的意义，结语说：‘佛法僧宝，具足无量神通变化，利乐有情，暂无休息，以是义故，诸佛法僧，说名为宝。’
    四、三宝的种类
    三宝的种类有六种：（一）同体，（二）别体，（三）一乘，（四）三乘，（五）真实，（六）住持。
    （一）同体三宝。亦名一体三宝，亦名同相三宝。体即清净法界真如法身；佛性即是法性，法性即是僧性，古名同体。今就一一体上皆具有佛法僧三义显示如表一：

    （表一）
    （二）别体三宝，亦名化相三宝。佛陀在《涅槃经》中自说，佛法僧三种名义俱异，说一为三，或说三为一，是诸佛境界，非诸声闻缘觉所知。《瑜伽师地论》也说，现正等觉佛宝相，佛所证果法是法宝相，随他教授而正修行是僧宝相，所以三宝各别有体。
    （三）一乘三宝。如来所说教法，以一乘为究竟，如《胜鬘经》说：‘说一乘道法，得究竟法身，于上更无说一乘法事。’《法华经》说：‘十方佛土中，唯有一乘法。’故依究竟归趣来说，唯有一乘三宝，说二说三皆为权化而设。
    此中根本唯取一乘所有三宝为体，约摄持来说，方便所修若法若僧，亦是一乘三宝体摄。
    （四）三乘三宝。即为教化三乘人所现的身、所说的法、所化的僧众，名为三乘三宝。
    （五）真实三宝。即前面所说的同体、别体、一乘、三乘所有三宝的实义，所以不取有漏的法和僧。
    （六）住持三宝。佛入灭后，住于世界者，即舍利、佛像，三藏文句教理，一切出家僧众，为世间利乐，传持佛法不失，是为住持三宝。
    三宝名数的决定和次第，在经论中说有多义，今总取经论中说：佛如良医，法如妙药，僧如看病人，故此三宝不增不减。
    五、三宝的差别
    佛法僧三种的差别，《瑜伽师地论》以六种相来显示它：
（一）由自相差别。不由他教，自然觉悟相是佛宝；佛觉悟的果法相是法宝；随他人教授而正修行相是僧宝。
（二）由作业差别。善转正法教业，是佛宝；断除烦恼的所缘法为业，是法宝；勇猛精进地修持，增长善法业，是僧宝。
（三）由信解差别。于佛宝应树立亲近承事的信解，于法宝应树立希求证得的信解，于僧宝应树立和合同一法性共住的信解。
（四）由修行差别。于佛宝应修供养承事的正行，于法宝所应修瑜伽方便的正行，于僧宝所应修共同受用财法的正行。
（五）由随念差别。念佛宝是无上正遍觉者、是世尊，具足十力、四无所畏、十八不共佛法等；念法宝是清净无漏的出世善法，是断除一切过患行，生一切功德的所依等；念僧宝是修清净梵行的正觉行者，是住持佛法，弘扬佛法，自性清净，远离诸恶者。
（六）由生福差别。于佛宝皈依供养等，是依一个有情生最胜福；于法宝皈依供养受持等，即依此法生最胜福；于僧宝皈依供养承事等，是依多有情生最胜福。


一、心法

    第二节 五位百法
    学习佛法的第一个困难，就是为不了解名相的含义所障碍，并且法相名词多以万计，更不容易从各个名相之间得到系统的认识。但是我们假若能够从某些有系统性的名相去学习，而弄清楚其意义和联系性，也很容易克服这一困难。大小乘的论典中，多以心、心所、色、不相应行、无为五位法来作为说明和统摄一切法的规范。如小乘的《俱舍论》以五位七十五法来说明和统摄一切法。（色法十一、心法一、心所有法四十六、不相应行十四、无为法三。）《成实论》以五位八十四法来说明和统摄一切法。（色法十四、心王一、心所四十九、不相应行法十七、无为法三。）大乘法相宗，以五位百法来说明和统摄一切法。这里举出大乘的五位百法来作一简单地介绍，就可以知道佛典中所说的一切法的基本意义和系统了。
    又一切众生，由于无始以来的内在和外诱的实执习气的熏习，计执诸法为实有固性的自体，起人法二种我执。我你他、情非情，一切的一切，凡所见闻者，莫不以为有独立的我法自性。由这种妄执，起惑造业，流转生死，不得解脱。但是观察这包括一切法尽的五位法类，无论为事为理，或各别的单位，积聚的总和，以理推证，都找不出如众生所计执的固性我法的自体。所以明白了五位百法，也就能够从道理上通达人法二种无我的意义。这里分别地解说如下：
    一、心法
    （一）心法的通义
    第一位心法：共有八种，即眼识、耳识、鼻识、舌识、身识、意识、末那识、阿赖耶识。心的意义有六：
（1）集起名心。集诸法种子，起诸法现行故。此义唯属第八心王阿赖耶识，其他心法没有这种功能。若就现行集起，则通其余的诸识。
（2）积集名心。属前七转识。此有能集所集的意义，但此处唯取能集名心，能熏积诸法种子于第八阿赖耶识故，所以不属第八心王。
（3）缘虑名心。八个心王俱能缘虑自分境故。
（4）心又名为识。识是了别义，即于自所缘境分别了达。细了别通于诸识，粗了别唯局于前六识。
（5）心又可名意。意即思量，有无间觉与现思量二义，无间觉通于诸识，现思量唯局于第七。
（6）据特胜的别义，则唯第八名心，第七名意，前六名识。如《楞伽经》说：‘藏识说名心，思量性名意，能了诸境相，是说名为识。’如表二：

    （表二）
    （二）心法的别义
    心法的通义如上所说有六种，但八个心王还有各别得名的别义：
（1）眼识。依止眼根，缘四显色为境，以生了别，随所依根立名眼识；亦可随自所缘境立名色识。
（2）耳识。依止耳根，缘声尘为境，以生了别，随所依根立名耳识；亦可随自所缘境立名声识。
（3）鼻识。缘香尘为境，以生了别，随所依根立名鼻识；亦可随自所缘境立名香识。
（4）舌识。依止舌根，缘味尘为境，以生了别，随所依根立名舌识；亦可随自所缘境立名味识。
（5）身识。依止身根，缘触尘为境，以生了别，随所依根立名身识；亦可随自所缘境立名触识。
（6）意识。依止意根，意根即第七末那，缘一切法为境，以生了别，随依根立名意识；亦可随自所缘境立名法识。
    以上六识，虽然可以随根随境以立名，但随根立名，具依、发、属、助、如的五义，特为殊胜，已转依位、未转依位都无相滥的过失；所以虽可随境立名色识等，但如已转依位，诸根互用，一根发识，缘一切境，立名色识等即有相滥的过失。故经论中，多不依随境立名，而取随根立名为眼识乃至意识。总起来说，眼等六识，皆是从所依得名。
    六个识中的第六意识，有四种差别：[1]明了意识，又名五俱意识。与五识俱时而起的意识，故名五俱意识，能助五识令起；由意识力引，五识方得生故。亦令五识明了取境，故名明了意识；以眼等五识不能明了分别，深取所缘，由意识令五识明了，深取其相。（定中意识虽是明了，但不能助五令起，故稍有不同。）[2]定中意识，即与定相应的意识。行相明了，能深取所缘。[3]独散意识。独简五俱，散简定心，即普通单独生起的散乱意识。[4]梦中意识。这也是独散意识，因其行相昧略，不同于醒寤之时，故别立一名。后三种又皆名独头意识，以皆不与五识俱起，唯是意识单独的活动，故名独头意识。定位意识，唯是现量；散位独头，即独散意识和梦中意识，通比量和非量。因为散位独头，名有分别，故决非现量。五俱意识，诸处据多分说唯是现量，据实而论，应说通于三量，以五俱意识亦有妄执故。
    （7）末那识：末那是梵语，具足应云‘论利瑟吒耶末那’。华言‘染污意’；‘意’即思量，因为此识与我痴、我见、我慢、我爱四惑相应，恒审思量第八识的见分以为自内我相，故名‘染污意’。
    这第七末那的差别，略有三位：
[1]人我见相应位，通一切异生相续。二乘有学、七地以前一类菩萨（除二乘无学、回心菩萨）有漏心位，彼第七缘阿赖耶识起补特伽罗我见，即一切有漏心，皆是此位。
[2]法我见相应位，通一切异生、声闻、独觉相续（有学无学），及一切菩萨法空智果（法空智即法空无分智，果即法空后得智和法空智引起的灭尽定）不现前时，彼法执心缘异熟识起法我见，皆是此位。[3]平等性智相应位，通一切如来相续。菩萨见道（必证二空故）及修道中法空智果现在前时，彼智缘无垢、异熟识等（一切有为及真如），起平等性智，皆是此位。立表如下（表三）：

    （表三）
    （8）阿赖耶识：阿赖耶识是梵语，华言藏识，有能藏、所藏、执藏三义。能藏即第八识能含藏前七转识诸法的种子；种子是所藏，第八识即名能藏。所藏即由前七转识熏习诸法的种子在第八识中；诸法是能藏，第八识即名所藏。这就是约第八识的受熏义边名所藏，约持种义边名能藏。执藏即第八识恒常被第七末那爱执为自内我体，故名执藏。由第八识具有三藏的功能，所以第八得名藏识。
    这第八识，有三相三位的差别：
[1]三相：三相即自相、果相、因相。自相即阿赖耶。具有能藏、所藏、执藏义故；此即显示第八识所有自相。果相即异熟识。此识是能引诸界趣生善不善业的异熟果故，说名异熟；此即显示第八识不共的果相。因相即一切种子识。此现行识能执持诸法种子令不失故，名一切种；此即显示第八识不共的因相。自相即自体义，在三种藏中，执藏义的过失最重，故以阿赖耶显示第八自相，是特约执藏义说。因为第八识的自体上具有因果二义，为了显示第八识体上有此差别义，所以《成唯识论》里建立第八识三相的差别。问：‘能藏即因义，所藏即果义。因果之外，岂更无别体吗？’答：‘自体是总，因果是别；总为别所依，别为总所包。包二为一，以总摄别，自相即摄持因果二相为自体故。’‘若这样说来，自相应是假有了？’答：‘这却不然！若有条然的因果两相合为自相，刖自相可成假有；这因果相即第八识自体上的别义，故非假有。’
[2]三位：这第八识，从凡夫发心到圆证佛果，由于断证有异，因此第八识的名义亦有三位的差别：(1)我爱执藏现行位。即七地以前菩萨、二乘有学、一切异生，从无始来，名阿赖耶，此云执藏。至无人执位，这阿赖耶的名称就舍掉了。(2)善恶业果位。即从无始至金刚道时，乃至二乘无学位，名毗播迦，此云异熟。至无所知障位，第八纯善无漏，这异熟识的名称也就舍掉了。(3)相续执持位。即从无始乃至如来，尽未来际利乐有情位，名阿陀那，此云执持。执持种子根身等，永无弃舍。总起来说，七地以前的菩萨，二乘有学圣者，及一切异生，这第八识的三名完全具有。菩萨八地以上和二乘无学，我执伏灭永不现行，阿赖耶的名称便舍去了，只有后二位的名称存在。到了佛果位，二障种习都已永尽，刖只有阿陀那一名存在了。这里把三位的宽狭立表如下（表四）：

    （表四）


(一)心所名义

    二、心所法
    （一）心所名义
    第二位心所法，心所法的全义名称，应当名为心所有法。具足三种意义名为心所：（1）恒依心起，（2）与心相应，（3）系属于心。如属我法，立我所名；心家所有的法，故名心所有法。
（1）恒依心起：即说心若没有，心所决不能独立生起，要以心为依，才能生起作用。
（2）与心相应：简别心王虽恒与遍行心所相应，但心王不与心王相应，不名心所。又相应须具足时、依、缘、事之四平等义，由此色法等亦非心所。
（3）系属于心：即简别心法虽具四义，与遍行心所相应，但不名心所；以心是主故，能独立自在，心所不自在，随从于心，以心为主，故名心所。
由此三义，简别心、色、不相应行等，不名心所。心法是主，为心所依，如王如领袖。心所依心，如臣如部属，助成心事，得名心所。约一聚心心所而言，心王起时，心所必起；心所起时，心王亦必起。缘境的时候，心王缘总相，如王如领袖之于国家大事总揽枢要。心所缘总别相，如臣如部属之于大事兼详细则。又如画师资，师绘作模型，弟子填彩，尽完全貌。
    心所法总有遍行五、别境五、善十一、烦恼六、随烦恼二十、不定四等六类，共五十一个，如表（表五）：

    （表五）


甲、遍行

    （二）别释六位
    甲、遍行
    （一）遍行名义
    触等五个心所，周遍行起于一切心，故得名遍行。即凡有心起时，无论是那一个心王生起，这五个心所都与它相应俱起。因为这五个心所，具遍四一切为所行故。‘四一切’即一切性、一切地、一切时、一切俱。性谓善、恶、无记三性。地即有寻有伺地、无寻唯伺地、无寻无伺地，或总取九地。时即凡是有心起时，此五皆与心王同一刹那缘境。俱即遍诸心王，与八识俱生。别境五数，唯具通三性与九地二义，然阙后二。善十一但遍九地，性、时、俱三义均阙。不定四唯具一切性，余三义俱缺。根本烦恼与随烦恼，四义皆无。如表（表六）：

    （表六）
    （二）解说体业
    （1）触：谓三和合，分别变异，令心心所触境为性，受想思等所依为业。（这是《成唯识论》裹解释心所性业的原文，因为简明切要，便于记诵，所以这样引用，以下的心所准此例知。）性是体性（下准此释），业是作用（下准此释）。根境识三法，不相乖离，更互交涉，故是‘三和合’。触依报等交涉的力量生起，同时亦给予根境识三种和合的力量。根等三法和合，就有了相顺生起一切心心所的功能，这种功能，在三法未和合的时候是不会有的，由和合而有，所以三法体上‘变异’的作用，触心所也领似了这种顺生心心所的变异作用，所以名为‘分别变异’。分别就是承领似有的意思，触心所既然领似了这种作用，所以能够令心心所触所缘境相。由此引生领纳所缘境的受心所，采取所缘形相的想心所等，所说受想思等所依为业。总起来说，和合一切心心所，依根缘境，不相离散，令同触境，即能的自性；为受等心所生起之依托，即是其作用。
    （2）作意：谓能警心为性，于所缘境引心为业。这个心所，能够作动于意，故名作意。它能警觉策动逢缘应起的心心所，引导它们趣于自己的所缘境，这就是作意的体用。
    （3）受：谓领纳顺违俱非境相为性，起爱为业。领是领取，纳是纳受，领受的境相，有于我们身心相顺益的适悦境，和违损身心逼迫境，及非适非逼的中庸境，由此有苦乐舍三受的差别。在这三种境上生起不同的爱欲，即对于顺境，未得起欣求欲，已得起不离欲；对违境，未得起不合欲，已得起乖离欲；于中庸境起不合不离欲。所以总说起爱为业。又受总分为五，即苦、乐、忧、喜、舍。这是把三受中的苦乐二受各分为二；由逼迫身心和适悦身心的行相有异故，又由无分别有分别成差别故，又尤重轻微有差别故。
    （4）想：谓于境取像为性，施设种种名言为业。取像印取所缘色等的青、非青、大、小等像状。施设就是安立，即由想取青非青等分齐界限的相状为因，安立为是青非青等名言果法。
    （5）思：谓令心造作为性，于善品等役心为业。思能取善恶等境相，由了解这善恶境为因，令心起邪正等的身语业行；即由思故驱役自心心所令造善等，倘若没有这思，心心所就决不能够造善恶等业。


乙、别境

    乙、别境
    （一）别境名义
    欲等五个心所，缘各别的境相而得生起，故名别境。别即是境，或别指欲等五法，境即是五法的所缘。这五个心所，不像遍行五法周遍行于一切境起，只能对于各别的所乐（欲），决定（胜解），曾习（念），所观（定慧）的四种境界而起作用，所以独得别境的名称。但这五法，不是绝对地不能俱起，有时不俱，有时亦俱，或一或二，乃至五法俱转，总别合有三十一句。在第三段中解释。
    （二）解说体业
    （1）欲：于所乐境，希望为性，勤依为业。所乐境即所观境。对于一切事，凡是欲观察的，有希望故，即有欲生，这是性的作用。若不欲观，随因境势力任运起缘，即全无有欲。因位中的七八二识全及六识异熟心等一分，但随因境势力任运起缘，皆全无欲。其余的皆由欲生。欲通三性，若善法欲，能发正勤，由精进助成一切善事；故说勤依为业。
    （2）胜解：于决定境，印持为性，不可引转为业。即由邪教、邪理、邪证等（诸识现量等心）力，或正教、正理、正证等力，或非邪正教理证的迅所缘力，对于所取的境相，审决印可摄持此事这样的或不是这样的；如说此木是木而非石等。这就是胜解的性用，由这道理审决印可故，更有不同的差别因缘，即不能牵引转动，令心中于已印定的事更生疑惑。故犹豫境，则胜解全无，非审决心，亦无胜解。
    （3）念：于曾习境，令心明记不忘为性，定依为业。内心中数数回忆摄持曾经所领受过的境相，令心明记不忘失，这就是念的性用；由这念力拥引生正定，是念的业用。这是约善念说的，若散心的念，即不能引生定了。故论文说定依为业，是约四法迹说的。四法迹是：[1]无贪、[2]无嗔、[3]念、[4]定。迹是基础的意思。戒、定、慧三种，以无贪等为依，故譬喻为迹，无贪无嗔与戒为迹、念与定为迹、定与慧为迹，这样的配释，故说念为定依。对于未曾领受过的体境（近亲取缘境）和类境（疏远取缘如涅槃等）中，全不起念。又虽然是曾经领受过的境界，但不能明记（如七八识境），念亦不生。
    （4）定：于所观境，令心专注不散为性，智依为业。即于所观察的功德、过失、俱非境相上，由定令心专注不散，这是性的作用；依这定力，便有抉择智生，故说智依为业。这也是约四法迹定能生慧的意义而言，即约净分定说，并非一切定皆有这样的功能，定后亦有起愚痴心的人故。心专注的意义，是说随其所注心的多少境，随所欲住即便能住，深取所缘，定即得生，并不是说前后心决定唯缘一境才名为定，若不作这样的解释，则在相见道的时候，十六心历观诸谛，前后境别，就应当没有等持了。若不系心专住境位，便无定起。
    （5）慧：于所观境，简择为性，断疑为业。即于所观察的功德、过失、俱非境中，由慧推求得到决定，这是性的作用；由此消除疑惑，所以说断疑为业。论说由慧断疑，也是约殊胜的慧说，实际上疑心俱时亦有慧故，于非所观察的境，愚昧心中，则无慧起；但非一切愚皆无，以邪见者痴增上故，虽愚亦有慧俱。若愚而又昧的心即没有慧了。
    （三）诸门分别
    （1）独生俱起。这别五所，有时只起一个：即于所乐境，唯起希望。于决定境，唯起即解。于曾习境，唯起忙念。于所观境，唯起专注。（有类愚昧的众生，为了止息散心，虽然专注所缘，但不能起简择的智慧，所以有定无慧。）于所观境，唯起简择。（即不专注，驰于散乱的推求。）或时起两个：即于所乐，决定境中，起欲胜解。于所乐、曾习境中，起欲及念。如是乃至于所观境中，起定及慧。合有十个二数。或时起三个：即于四境起三数。于所乐、决定、曾习境中，起欲解念。如是乃至于曾习、所观境中，起念定慧。合有十个三数。或时起四个：即于四境中，更互除去一种。于所乐、决定、曾习、所观境中，起欲解念室前四种。如是乃至于决定、曾习、所观境中，起胜解念定慧后四种。合有五个四数。或时五个俱起：即于四境上，合起五种，于所乐、决定、曾习、所观境中，俱起五种。如上所说，五个心所，一一别起，到俱起五种，总别合有三十一句，列表如下（表七）：

    （表七）
    （2）八识分别。别境五所，与因位第八识，全不相应：以第八任运缘境，故无有欲；行相盲昧，故无胜解；恒缘任运现境，故无有念；任运刹那别缘，故无有定；行相微昧，故无简择。若在果位，五所全得相应：常乐证知所观境，故有欲；于所观境恒印持，故有胜解；于曾受境明记，故有念；世尊无不定心，故有定；于一切法常抉择，故有慧。第七识在因位，唯与别境中慧心所相应，我见即染慧。故为什么不与欲等四法相应呢？以第七识缘遂合境，无所希望，故无有欲；无始以来，恒缘定事，经所印持，故无胜解；恒缘现所受境，无所记忆，故无有念；任运刹那别缘，不深趣求专缘一法，故无有定。若在果位，别境五所都与相应，义如第八果位所说。前六转识，无论在有漏无漏位皆欲等五所相应无违。
    （3）五受俱起。欲等五所皆与五受相应。欲既是于所乐境希望为性，怎么会与逼迫性的忧苦二受相应呢？因为修习圣道的人于无上法思慕憾求欲证，即善法欲与忧受俱起，由此证知余时亦得相应。纯受苦处，希求解脱彼苦，故欲与苦俱。并且对注《瑜伽》第七、卷五十九卷皆说贪与忧苦受相应，贪爱俱起，必有欲数，由此亦可证知欲与忧苦必然相应了。


丙、善

    丙、善
    （一）善的定义
    善是顺益义，和顺理义，即顺益此世他世的有漏无漏行法，性离垢秽，清净无染，故名为善。这有四类：（1）自性善，即信等十一个善心所。（2）相应善，即与自性善的性等相应而起的心心所法。（3）等起善，即由自性善和相应善引起而成为善性的身语二业及不相应行和种子。（4）胜义善，即无为涅槃，体性毕竟清净，最极寂静安稳，是胜义法，故名胜义善。这裹所说的信等心所，自体清净，故是属于自性善类。
    （二）解说体业
    （1）信：于实德能，深忍乐欲，心净为性；对治不信，乐善为业。‘忍’即胜解，是信的因；‘乐欲’即欲心所，是信的果。由对于诸法真理和三宝功德忍可为因，才生起深厚信乐和希望欲得成就的乐欲果法故。这信的体性澄清，能清净心心所等，如水清珠，能清浊水，故信体自净，亦清净他。但因为心体殊胜，所以论中唯说心净为性。有这净信，就能对治不信，爱乐修证世出世间的善法，所以论说乐善为业。这信的差别，略有三种：[1]信‘实’有。即对于一切法的实事和空理，深信忍可为有。就是‘忍’义。[2]信有‘德’。即对于佛法僧三宝具有的真实清净的功德，深信为有，生起爱乐。就是‘乐’义。[3]信有‘能’。即对于一切世出世间的有漏无漏善法，深信自己及他人，只要肯精进的学习，都能获得和成就，因而生起希望能得能成的善法欲。就是‘欲’义。若连信的依处业用加在一起来说，则解信的文句共有五义：[1]‘于实德能’，是说信的依处。[2]‘深忍乐欲’，是说信的因果。[3]‘心净为性’，是说信的体性。[4]‘对治不信’，[5]‘乐善为业’两句，是说信的业用。
    （2）惭：依自法力，崇重贤善为性；对治无惭，止息恶行为业。即依于自身生起自尊爱的增上力，于法生起贵重的增上力。由这自增上及法增上的两种力量，对于具有贤德的圣者和凡夫，就能够生起崇敬；对于一切有漏无漏的善法，就能够生起崇重。有了崇贤重善的心理，就能羞耻过恶不作，对治无惭而止息恶行了。
    （3）愧：依世间力，轻拒暴恶为性；对治无愧，止息恶行为业。即依于世间的法律、舆论、呵斥、讥毁等的增上力，和自己厌嫌恶染法的增上力，而轻拒暴恶，羞耻过罪，息诸恶行。轻是轻视一切有暴行的人而不去亲他，拒是拒绝一切恶法业而不接近，即不亲暴人，不近恶行，这是性用。由这力量就能够对治无愧，止息恶行，这就是业用。
    崇重贤善，是惭的别相；轻拒暴恶，是愧的别相；羞耻过恶，则是惭愧两法的共通相。善心起时，随其缘虑什么境界，皆有崇重贤善，和轻拒暴恶的意义，所以惭愧两种，俱遍善心。
    （4）无贪：于有有具，无著为性；对治贪着，作善为业。‘有’是三有，即欲有、色有、无色有，就是三界；三有就是三界有漏果。‘有具’就是能生三有的资具，即三有的因；如依资具造成事物，故喻因如具。相顺的因，唯是有漏法；为缘的因，亦通无漏。如在有漏心上以涅槃为缘，亦能引发贪等，故亦是具。中有、业行、烦恼，皆是有具。对于三有果和有具，遍知生死过失，故起厌患，面不生贪着，就是无贪。由无贪着故，恶行不起，所以能作善业。
    （5）无嗔：于苦苦具，无恚为性；对治嗔恚，作善为业。苦是三苦，即苦苦、坏苦、行苦，皆是有漏的苦果。苦具即苦果的资具，是能生三苦的因缘，如饥寒疾病等。随顺的苦具，一切有漏诸法皆是。为缘的因，亦通无漏；因为憎嫉灭道的人，对于灭道二谛亦生嗔恚，故灭道亦是苦具。无嗔就是对于苦苦具不起嗔恚，由此无嗔对治恚，息诸恶行，能作善业。
    （6）无痴：于诸理事，明解为性；对治愚痴，作善为业。无痴是对于一切事相和理体，都能够明白了解而不迷惑，作善止恶，是其体性和业用。
    这无贪、无嗔、无痴三法，为生起善法的根本，经论中称之为三善根。立为善根的理由有二：[1]近对治故。无贪等三法，是贪嗔痴三不善根的近别对治。（对治有二：１．近对治，又名别对治。２．远对治，又名通对治。通对治即有漏无漏慧的正见。）即简别其余的善心所等虽然是善法，而不可以名为善根。它们不是不善根的近别对治故。[2]生善胜故。此正释根义。由无贪对于有等不起染着，无嗔对于苦等不起憎恚，无痴对于事理明解不违，故能止恶作善，为出生善法的殊胜所依，所以得名为善根。即简别余善心所等，虽亦生善而无殊胜义，故不可以名为善根。
    （7）精进：于善恶品修断事中，勇悍为性；对治懈怠，满善为业。精是精纯，简别四无记中的无爱净无记，彼非染故，纵然可以名纯，不可以名精。进是升进，表念念高胜，非如染法，设虽增长，望于善法，皆名为退，亦不名进，以无进益故。进是进成圣者之身，简除一切染法。由这精纯、胜进两义，即显精进唯是善法所摄。勇是勇健，即升进义；悍是强悍，即坚牢义。勇而无惰，能够自励策发；悍而无惧，能够忍耐劳倦。精进具有勇悍性，所以对于应修的善品法，和应断的恶品法，能修能断，对治懈怠，圆满成就一切善法。
    精进的差别有五种：[1]被甲精进，即经中所说的有势。[2]加行精进，即经中所说的有勤。[3]无下精进，即经中所说的有勇。[4]无退精进，即经中所说的坚猛。[5]无足精进，即经中所说的不舍善轭。这五种精进的立名和意义，是以譬喻来说明修行的过程和进度的。修行者对于断恶修善，最初发起猛利乐欲，名为被甲，如古时作战者在入阵之前先着好铠甲，然后入阵，能无所畏，刖有大势力；故经说名有势。其次随其所欲发起坚固勇悍的方便，各为加行；经名有勤。次为证得所受诸法，不自轻蔑，亦无怯惧，是名无下；经名有勇。次能堪忍寒热等苦，对于微劣的善法不生喜足，欣求后后转胜转妙的功德法，故名无退；经名坚猛。次后乃至渐次悟入谛现观等后后胜道，名为无足；经名不舍善轭。轭是车轭，用来驾御牛的东西，令牛工作不致出离正轨；喻修行人以善法为轭，不越善品，能直往涅槃之宫。
    （8）轻安：远离粗重，调畅身心，堪任为性；对治昏沉，转依为业。粗犷沉重，故名粗重，即无所堪能的不调柔相是粗重相。离重名轻，调畅名安。由离粗重，身心调畅，轻松安稳，故名轻安。这有两种：[1]无漏的轻安，除遣有漏粗重，则粗重通于三性。[2]有漏轻安，除遣烦恼粗重，则粗重唯不善性。以有漏轻安，不能伏有漏善及无记上定障，以力劣故。有漏轻安伏一切能障碍定的法，无漏轻安除一切能障碍定的法，令所依身转去粗犷沉重，得到轻快安稳，故论说转依为业。昏沉由粗重而有，是无堪任性；轻安是堪任，故能对治昏沉，得到有漏无漏的转依。这轻安唯在定地，调畅身心，余位无故；由定滋养，才有调畅故。故十一种善法中，唯这轻安一法，不遍善心。除此一种，其余十法，皆遍善心起。
    （9）不放逸：精进三根，于所断修，防修为性；对治放逸，成满一切世出世间善事为业。这不放逸，没有别的体性，即以精进、无贪、无嗔、无痴四法为体。由精进三善根的力量，于所断的恶法，防令不起：于所修的善法，修令增长。故不放逸的体，即于四法的功能上假施设有。由不放逸对治了放逸，所以能够成为圆满世间一切有漏的善法，出世间一切无漏的善法。
    （10）行舍：精进三根，令心平等正直，无功用住为性；对治掉举，静住为业。行是行蕴，行蕴中的舍，简别受蕴中的舍，故说名行舍。这行舍，也是以精进三根四法为体。即由四法令心远离掉举等障定之法，寂静安住名舍。说平等正直，无功用住，有约初、中、后三位辨舍的差别相。即初位由舍与心相应，远离掉举等高下的不平等性，心得平等。其次远离加行，即离分别作意的偏曲相，心得平等自然相续，不偏不倚的正直住。由心正直，善心相续，于诸杂染无怯，绝思绝虑，无发动性地任用而转，放心得无功用住。静住，即不容染义，由舍与心相应，故心心所能够寂静安住。
    （11）不害：于诸有情，不为损恼，无嗔为性；能对治害，悲愍为业。不害是依于无嗔，对于有情不作损恼的意义上假名安立。不害既然是无嗔，为什么要各别建立呢？因为无嗔正翻对断物命的嗔，不害正违于但损恼物而不断物命的害；是这两法的粗相差别。又无嗔与有情乐，是慈心的体；不害拔众生苦，是悲心的体。有这些差别，所以各别建立。但实际说来，无嗔实有自体，不害是依无嗔一分的意义假立；为了显示慈悲二相的差别，和慈悲两种在利乐有情中的极胜功德，故依无嗔别立不害。
    （三）诸门略义
    这十一善法，不放逸、行舍、不害三种，无有别体，故是假有；其余八种，各有自体，皆是实有。十一法中，十遍善心，轻安不遍，要在定位才有轻安故。散位粗重无定，所以没有轻安。十一善法，第七八识有漏位中，不与相应；已转依住，皆具足有。前六识中，定位皆具；若非定位，唯缺轻安。五识的体性散动，为什么有轻安呢？因为由定所引起的善五识，亦有调畅。如天眼天耳，善者有轻安故（无记者无）。十一善中，十种与五受相应；轻安一种，除忧苦二受。因为忧苦皆是逼迫性，既然有逼迫性，就没有调畅了。十一种皆与别境五所相应，信等与欲等不相违故。轻安非欲界有；其余十种，遍通三界。此十一善，有学无学的圣者，和非学非无学的常人，一切皆通。信等十一，非邪教邪师之所引生，不是障碍见道的法，所以非见所断，唯是修道断。


丁、根本烦恼

    丁、根本烦恼
    （一）名义
    烦是扰义，恼是乱义。贪等烦恼，扰乱有情的身心，使有情恒处生死，不得解脱。贪等六惑，为一切烦恼的根本，能生随惑，故名根本烦恼。
    （二）解说体业
    （1）贪：于有有具，染着为性；能障无贪，生苦为业。有即三有异熟果，有具即中有烦恼业及器世间等三有资具因。为缘的因，无漏法亦是；爱佛贪灭，皆是染污故。与见俱生，缘无漏起贪，则无漏有缘亦能资助增长三有果报；所以无漏法亦名为俱。于三有果及三有因生起染着，是名为贪。由这贪着，能障无贪，于五取蕴爱着执取，因此生死轮回不息，在三界中长受轮转的痛苦；所以论说生苦为业。
    （2）嗔：于苦苦具，憎恚为性；能障无嗔，不安稳性，恶行所依为业。苦就是三苦，皆生于嗔。憎恚的唯是苦受；乐受乖离的时候，嗔心亦依之生起。苦具即一切有漏及无漏法。凡是能生苦果的法，皆是苦具，依之生嗔。有漏顺苦法，正是苦具。无漏虽然不是随顺的苦具，但从与邪见等俱起缘无漏生苦来说，则无漏法亦是苦具；如憎嫉灭道二谛，毁拨无漏，即招恶趣苦果，故亦说无漏为苦具。凡是嗔心生起，即障碍无嗔，必定令身热恼，心不安宁，不能寂静，起诸恶业。所依即嗔自体；不安稳及恶行是能依。能依依所依生起，故论说‘能障无嗔，不安稳性，恶行所依为业’。
    （3）痴：于诸事理，迷暗为性；能障无痴，一切杂染所依为业。痴即无明，独头无明迷理，相应无明迷理迷事。总由无明，对于四谛、业果、三宝等理事愚迷暗昧，生起疑惑，引起邪见，毁拨为无，其余贪等烦恼次第生起，造诸恶业，乃至招感后有苦果，生诸杂染。所以痴为一切杂染法生起的所依。
    （4）慢：恃己于他，高举为性：能障不慢，生苦为业。从根本上说，由有我执故心高举，于殊胜的功德法，和有功德的人，心不谦下；由此生死，轮转无穷，受诸痛苦。所以说生苦为业。不慢即善心所中惭一分摄，若崇重于他，即不起慢了。慢障不慢，亦即没有崇重贤善的惭心之故。
    这慢有七种和九种差别，依于下中上三品及我处与德处五法上生起。
    七慢即[1]慢、[2]过慢、[3]慢过慢、[4]我慢、[5]增上慢、[6]卑慢、[7]邪慢。依下品及中品处，生起第一‘慢’：于劣计己胜，于等计己等，心高举为性。依中品及上品处，生起第二‘过慢’：于等计己胜，于胜计己等，心高举为性。依上品处，生起第三‘慢过慢’：于胜计己胜，心高举为性。依于我蕴处，生起第四‘我慢’：于五取蕴随计为我、我所，心高举为性。依辨胜德处，生起第五‘增上慢’：于未得的增上殊胜所证之法，及虽得少分，于所未得，谓我已得，心高举为性。增上殊胜所证法，指圣无漏果，及三摩地等超过常人的法，未得谓得，而自矜倨。依上品处，生起第六‘卑慢’：对于他多分殊胜功德，计自己仅少分下劣，如是心高举为性。依辨胜德处，生起第七‘邪慢’：自己实在没有功德，妄计自己有功德，如是心高举为性。
    第五‘增上慢’与第七‘邪慢’，都是于未得的功德处生起。这有什么差别呢？有三种差别：1.增上慢于他相等功德或他殊胜功德生起，邪慢是于无功德处生起。2.增上慢内外道皆起，邪慢唯外道起。3.增上慢异生圣者皆起，邪慢唯异生起。
    九慢在大乘不见文说，唯小乘中建立。如《俱舍论》第十九卷说：‘然本论说慢类有几：[1]我胜慢类，[2]我等慢类，[3]我劣慢类，[4]有胜我慢类，[5]有等我慢类，[6]有劣我慢类，[7]无胜我慢类，[8]无等我慢类，[9]无劣我慢类。’这九种慢，从前七慢中的慢、过慢、卑慢三种分出。过慢、慢、卑慢，如其次第即前三种。卑慢、慢、过慢，如其次第即中三种。慢、过慢、卑慢，如其次第即后三种。这里把七慢九慢的差别，列表八如下：（表八）

    （5）疑：于诸谛理，犹豫为性；能障不疑，善品为业。依《瑜伽》五十八卷，说疑有五相差别，即于他世作用（从此世往他世的作用）、因、果、四谛、三宝中，心怀犹豫。这里说诸谛，亦摄尽《瑜伽》所说的五相。因为谛是真实义，他世作用等皆是真实事理，即缘事缘理俱起疑惑。由有疑故，令慧于事理不决；怀犹豫心，则善法不生，故论说障不疑及善品为业。
    （6）恶见：于诸谛理，颠倒推度，染慧为性；能障善见，招苦为业。恶有两种意义：{1}善恶相翻的恶，则唯是不善。{2}毁责名恶，则恶通有覆无记。这裹所说的五见皆名为恶见，是毁訾名恶的意思。于诸谛理颠倒推度，即唯迷于理，由染污慧颠倒推度而起恶见，因而障碍正慧的善见不生。由分别的恶见发起招感苦处的业，故恶见者，多生于苦。所以论说招苦为业。
    这恶见的差别相有五种：
    [1]萨迦耶见：于五取蕴，执我我所，一切见趣所依为业。萨迦耶见就是身见，经部师说名为身见，有部师说名有身见，大乘义说为‘移转见’（我境有转变，所以能缘我见得移转名-成唯识论述记义演），包括我我所见，或总缘五取蕴起，或别缘五取蕴起，通俱生与分别。以这我见为所依的根本，诸见得生，故说一切见趣所依为业。趣就是所归处的意思。
    这萨迦耶见的差别行相有二十句、六十五句等分别起所摄。二十句如计色蕴是我，我有色，色属我，我在色中，一个蕴有四句，五个蕴就成为二十句。二十句中，五句是我见，十五句是我所见。为什么五句是我见，十五句是我所见呢？因为第一句计为我，余三句是相应我所，随逐我所，不离我所，故十五种是我所见。六十五见是约蕴处界来分别，如以五蕴来分别，以色蕴为我，余四蕴各有三所，即计为我的缨珞（庄严），我的僮仆（服务人），我的器具（所依托的东西），即有十二句；色蕴为一我，总起来为十三句；如是五蕴总起来有五个我见，六十个我所见，共为六十五见。这二十句和六十五句，都是分别所起，不是俱生我见；因为俱生我见，不分别起计故。为了醒目，列（表九）如下：

    （表九）
    ‘三我所’即：初想应我所，次随逐我所，后不离我所。
    ‘各有三所’即：我缨珞，我僮仆，我器具。
    [2]边执见：谓即于彼，随执断常，障处中行，出离为业。由于前我见，执我已，随逐我见之后，生起边见，执为断常。由有这断常的边见，就障碍了非断非常而说有因果处的中行道谛，及出离的灭谛。这是边见的总相。
    边见的差别行相如《成唯识论》卷六说：‘此见差别，诸见趣中，有执前际四编常论，一分常论，及计后际有想十六，无想、俱非各有八论，七断灭论等，分别趣摄。’这文中所说的边见差别摄六十二见中四十七见，即四编常论乃至非有想非无想论，四十见是常见，七断灭论是断见；‘等’字是等取十四不可记事中，四常等是常见，无常等是断见。除边见等四，它是属邪见所摄故。如来死后四中，亦有等是常，非有等是断，命一身异等是我见。这六十二见皆唯是分别所起，所以论说分别趣摄。唯苦谛断，缘苦谛为我，增长边见，随我断故。详细的解释，可以参看《成唯识述记》卷三十六，《瑜伽师地论》第六、第七、第八、第五十八、第八十七等。列表十如下：

    （表十）
    [3]邪见：谓谤因、果、作用、实事，及非四见诸余邪执。如增上缘，名义遍故。谤因即拨无善恶业因行，谤果即拨无善恶业行所招的异熟果。谤作用是谤无此世他世、无父无母、无化生有情等，即拨无从此世间往他世间的作用，谤无父母的作用。父母各有二德：1.可敬福田。若供养奉事，增长福业；若杀害损恼等，成大重罪。2.任持相续。即托父亲的种子，母亲能任持相续生长。拨无化生有情（中有身），即谤结生相续的作用。谤实事，即否认世间有真阿罗汉等。除此所说谤因果等外，五见中凡非其余四见所摄的一切邪执，都在这邪见中摄。这有两种意义：1.名宽。不正名邪，一切不正的见，皆可入这邪见所摄。2.义遍。诸邪解的见解，皆可摄入这邪见中。如四缘中的增上缘，因等三缘所不摄的法，皆可在增上缘中摄的道理一样。
    这邪见的差别行相，如《成唯识论》说：‘此见差别，诸见趣中，有执前际二无因论，四有边等，不死矫乱，及计后际五现涅槃（参看前六十二见表）。或计自在（自在天）、世主（大自在天）、释（帝释）、梵（梵王），及余物类（自性等），常恒不易；或计自在等是一切物因；或有横计诸邪解脱；或有妄执非道为道。诸如是等，皆邪见摄。’二无因论唯是集谛下邪见，五现法涅槃唯是灭谛下邪见，迷有漏因，迷涅槃果故。有边无边等四，是苦灭二谛下邪见，迷有漏无漏果生故。不死矫乱，通四谛下断问答四谛及迷四谛故。计自在世主等常恒不变，是计苦谛下邪见。计非道无道，是道谛下邪见。‘诸如是等’的‘等’字，等取十四不可记中有边等四，是这邪见中摄故。详细的解释，可以参看《成唯识论述记》卷三十六，《瑜伽师地论》五十八、八十七等。
    [4]见取：谓于诸见，及所依蕴，执为最胜，能得清净；一切斗争所依为业。取是执取义。即于身、边、邪等一切恶见，及恶见所依的五取蕴，执为最殊胜，是能得涅槃清净法的因，是为见取。由这恶见取着，各各互执为胜，一切外道的斗争因此而起，故见取为斗争的所依。若执非恶见及眷属外的余法为殊胜，能得涅槃；或但执为殊胜，而不计为能得涅槃清净法的因，则是邪见，而非见取所摄。应知执一切恶见及眷属为最胜（唯此真实，余皆虚妄），而又是清净因才是见取相。
    [5]戒禁取：谓于随顺诸见戒禁，及所依蕴，执为最胜，能得清净；无利勤苦所依为业。即对于依随者见而所受的戒禁，及戒所依的五取蕴眷属执为最胜，及能得涅槃清净法，是为戒禁取。戒即是禁，故名戒禁。戒性遮别，即性戒名戒，遮戒名禁。外道以恶见为先，受持远离杀盗淫等七种恶法的性戒，及受持拔发、执三交杖、守牛狗禁等遮戒。受持这些戒禁，并非殊胜，亦不是能得涅槃的清净因，是没有任何真实义利的勤苦，所以论说戒禁取是无利勤苦的所依。除戒各眷属外，执余一切法为胜，及能为因，或得清净，不执为最胜，但说能为因，皆非戒禁取摄。应知执取戒禁及眷属为最胜谛实，而又是得涅槃清净的因，才是戒禁取相。
    （三）诸门分别
    （1）俱生分别：十种烦恼中，贪、嗔、痴、慢、身见、边见六种，通俱生及分别起，任运、思察俱得生故。任运起故，是俱生：思察生故，是分别。疑、邪见、见取、戒禁取四种，唯是分别起，要由恶友力、邪教力及自分别三缘，才能生起故。列表十一如下：
    （表十一）

    （2）自类相应：
     1.贪：贪与嗔、疑两法，定不俱起，所爱的境和所憎恚的境，必不相同故。两法的行相亦别，故不相应。为什么不与疑俱起呢？因为所爱境，必是于境已得决定；疑是于境不决，所以贪着不生。贪与慢、见，或得相应：若于他人起爱，则必不慢他。因为所爱的境与所慢的境，不是同一个境，行相亦别，所以贪慢不俱起。但缘自己的身体起爱名为所染境，与所恃之我慢境，可同一境上俱起，约这方面的意义来说，所以说贪慢或得相应。五见所著的境，皆是可爱的境，所以贪与五见相应无失。列表十二如下：
    （表十二）

     2.嗔：嗔与慢、疑或得俱起。若于内境起慢，则所恃的境非嗔，所憎所恃的境非同一故，嗔与慢就不会相应。若于外境起陵蔑心，亦于彼境起憎恚心，则所蔑所憎的境可以同一，故说嗔慢或得相应。对于所缘境上，最初犹豫起疑的时候，心尚轻微，未即憎恚，所以嗔与疑不俱起；若于所缘境久思不决，心即沉重，便愤发起嗔，由这意义，说嗔疑相应。
    （表十三）

    又疑顺违事与嗔相应也是这样：若疑顺己的事情，或可以不起嗔恚，即疑苦集二谛。若疑违己的事情，便与嗔相应，即疑灭道二谛。
    嗔与身见、边见、邪见或得相应，如身见与边见中的常见，若缘乐受俱行的五蕴为我及常见，则不生嗔恚。因为与自己相随顺故。若于苦处，即缘苦受俱行的五蕴为我及常见，便生憎恚，心里起这样的观念：我要这受苦的身子干什么！边见中的断见，则相翻地说为与嗔便不俱起，即对于乐受俱行的五蕴执为断时，得与嗔恚相应。恐怕失掉了乐受俱行的五蕴身故。若于苦受相应的五蕴执为断时，便不起腹恚，喜欢自己的苦已尽故。邪见诽拨恶事好事，如其次第说与嗔相应不相应：即诽拨恶事无，便不与嗔相应，喜欢苦受没有故；拨无乐蕴，便与嗔俱起，憎恚乐受无故。列（表十三）如上：
     3.痴：痴即是无明，无明总有两种：[1]相应无明，与贪等俱起，一切惑生，必由痴故。[2]独行无明，则不与贪等烦恼相应。列（表十四）如下：

    （表十四）

    （表十五）
    ○…按五见总明皆容俱起行相展转不相违故
     4.慢：慢与贪嗔俱不俱起，如前已说，慢与疑定不相应，因为起高慢心，必是于所陵慢的境已得决定；若不决定的境，还在疑他胜负，则不敢起慢。慢若起时，必自高举，其境亦是决定了的。
    慢与五见，皆容许相应，行相俱高，缘顺境起，不相违故。但与边见中的断见，定不相应，执我断灭时，心灭意冷，必不自持高举而陵慢他了。慢与身见、邪见的一分，亦不相应。以约粗相而言，慢心多缘乐蕴生起；与缘苦俱蕴我见一分，及邪见拨无苦集谛理一分，则不与慢俱；即身见中执极苦蕴为我，这一分，与邪见中拨无乐蕴这一分，皆不与慢俱起。违己情故。若身见中缘乐俱蕴为我这一分，及邪见中拨无灭道这一分，即可与慢俱，依恃己乐陵慢灭道故。列表十五如上：
     5.疑：疑与贪等便不俱，如前已说，疑与五见，定不相应，见是审决，疑是犹豫，行相相返，所以定不俱起。列表十六如下：

    （表十六）
     6.五见：五见与贪等俱不俱，如前已说。五见自类，必不相应，因为五见都是以慧为体，不能在一个心中容许有多慧体并起故。列（表十七）如下：

    （表十七）
    （3）诸识相应：贪等十种烦恼，第八识全无，因为藏识的体性无记，不与染法相应故。第七识有四，即痴、见、慢、爱。第六意识具有十种，遍与一切心所相应故。五识但三，即贪、嗔、痴。五识无分别，故无慢等，慢等必由有随念分别和计度分别才能生起故。又慢由称量门起，疑犹豫门起，见推求门起，五识没有这些行相，所以皆不相应。
    （4）诸受相应：受有五种，即苦、乐、忧、喜、舍。十种烦恼与五受相不相应，有粗相和实义两方面的不同。随粗相来说，贪、慢、四见（除邪见）行相唯欣，非忧、苦俱，唯与乐、喜、舍三受相应。嗔唯戚行，唯与苦、忧、舍三受俱起。痴与五受皆俱，因为它与诸惑相随顺故。邪见及疑行通欣戚，除苦之外，其余四受皆得相应。除苦有二因：1.邪见分疑，唯意识有，五识中无，故非苦俱。2.邪见与疑，非纯苦处（地狱）有，无理与意苦俱起，是故除苦。
    若约实义来说，贪、嗔、痴三，无论俱生分别，一切皆容许与五受相应。因为贪心生起，在遇着违缘的时候，如失掉财物等也与苦、忧二受俱起。嗔心起时，遇着了顺境，如怨敌受灾死，亦与喜、乐受相应。
    慢俱生起的，亦与苦、忧受俱，持苦劣蕴起慢，故与忧相应；在纯苦处，意迫名苦，故亦与苦受相应。分别慢心，纯苦趣无，不与苦受相应，所以唯与乐、喜、忧、舍四受俱起。在苦趣中，恃苦劣蕴起慢的时候，与忧得相应，看见苦境，怕其逼身而生忧故。

    （表十八）
    疑、见取、戒禁取、邪见四种，除苦受外，与乐、忧、喜、舍四受相应。疑与后三见，皆分别起，地狱中无分别惑，所以不与苦受相应。欲界的疑，若先作恶行，疑苦集谛等，亦与喜受俱起，喜后无苦故。上界的疑，亦有乐受俱，意地有乐故。二取若缘忧俱见戒，及所依蕴为殊胜能得涅槃清净法，则与忧受相应，忧其不速得涅槃故。
    身、边见二，若是俱生的与五受相应，二见虽然不是五识俱有。但在纯受苦处，缘极苦蕴，亦与苦受相应，以地狱中没有分别的二见故。分别起的身边二见，除苦容许与四受相应，在苦趣中执苦俱蕴为我我所，及常见者，与忧相应，境可忧故。断见者执乐俱蕴，断亦与忧俱起，恐怕失掉快乐故。分别二见不在五识，及纯苦处，故不与苦受相应。列（表十八）如上：
    （5）别境相应：十烦恼中，贪、嗔、痴、慢容许与别境五所俱起。与欲等相应，容易了解，为什么贪等也与定相应呢？因为贪等四法专注一境，得有定故。前面在解定心所时说过，非唯缘一境才名定，专注一境亦得名定故。疑及五见六法，各各容许与别境五中四个心所相应。疑除胜解，疑不决定，胜解决定，境与行相皆是相违，故不俱起。五见不与慧俱，五见的体即慧，自体不并生，所以不相应。
    （6）三性分别：十烦恼中，嗔唯不善，不起即已，起必损恼自他，感不可爱果，现世他世皆名为损故。其余的九种，通善无记二性。在上二界系的贪等九种烦恼，不问俱生分别，定唯无记，由定力所摄伏故。在欲界系的贪等九种，若分别起的，唯不善性摄，一向发动恶行故。若是俱生起的有二：发动恶行的亦是不善，因为损恼自他故。余则无记性摄，（唯除嗔、二见定唯无记，余三少分），有其四因：[1]由极微细。[2]不障善法，善位亦起故，如第七识俱起的四种烦恼。[3]非极损自他，即一分任运而起，不发业的贪等。[4]数数现行故。这里还应当知道，俱生的身边二见，唯无记摄，不发恶业。虽然数数现起，但并不障碍善法。
    （7）界系分别：这十种烦恼，嗔唯在欲界，以唯是不善性故。其余九种，通三界所系。
     1.下起上惑：在这通三界系的烦恼中，有上下相起和上下缘别的四种差别。生在下地的有情，倘若末离下地的欲染，则上地的烦恼不会现起；要得了上地根本定的有情，上地的烦恼，不论俱生分别，皆容许现起。（这里所说的起，唯定烦恼，非生烦恼。定烦恼即爱味所得的定等。生烦恼即生在彼地所起烦恼。）
     2.上起下惑：生在上地、下地的诸惑，不论俱生分别，皆容许现起。如得第四定的增上慢比丘，妄计为已得第四果，命终的时候，中有现起，既受中有已，即色界身起下邪见，谤释种无有真实的涅槃，便下堕地狱中。此中有位起谤时，有邪见、无明，或许有嗔，嗔涅槃故，由是可知生上能起下惑。又身在上地，将下生时，必起下地润生的俱生爱及慢、无明等，亦是上起下惑。《瑜伽》五十八卷等文说生上不起，是依多分义和随转门说，故与这里所说的上起下惑没有相违。
     3.下惑缘上：下地烦恼，亦缘上地，举四义说明：[1]贪缘上。以欲界系的贪，贪味胜定，求生上地故。[2]嗔缘上。嗔恚亲迷灭道，《瑜伽》五十八卷既然说嗔恚憎嫉灭道，以此类推，亦应憎嫉离欲地；灭道理深，嗔尚憎嫉，离欲事浅，当亦憎嫉，故嗔亦缘上。[3]身边及慢缘上。我见、边见、慢三种，总缘诸行，即三界合缘，不观差别，总则为我我所，起断、常、慢者，得缘上故。[4]痴、疑、邪见、二取缘上，其义共许，不须理成。诸论中有处说贪嗔慢等不缘上起，皆依粗相说；依别缘说，与这里所说的缘上义，没有相违之处。
     4.上惑缘下：上地烦恼，亦缘下地，《瑜伽师地论》五十九卷说，生在上地的有情，对于下地有情，恃己胜德，而陵下地，亦起慢故。又总缘诸行执我我所，起断常爱者得缘下故。痴缘下共许不说。疑及邪见、见取、戒取四法，亦得缘下，于欲界佛、世尊起疑惑故。或复邪执，得有邪见，拨疑下地苦集理故。得上定已，起彼二取，执昔时欲界闻思为胜因故。《瑜伽》五十八等说上惑不缘下，是依多分或别缘义说，与此无违。
    （8）学无学非二门：贪等十种烦恼，在有学圣者、无学圣者、非学非无学的凡夫三门中，属那一门摄呢？唯属第三非学非无学。有学无学虽然通有漏无漏，但唯善性，贪等染污，故非所属。
    （9）三断分别：贪等十种烦恼，是染污法，通见修断，不通非所断；分别起的贪等唯见道所断，以行相粗，容易断故。若俱生起的，唯修道所断，行相微细，难断灭故。
    （10）缘有事无事：十种烦恼现起的时候，都有亲所缘缘的相分，但它所仗托的本质则可以是有，可以是无，有本质的名缘有事的烦恼，无本质的名缘无事的烦恼。
    （11）缘有漏无漏分别：贪等烦恼的亲所缘缘，虽然都是有漏的，但在所仗托的本质境方面亦通无漏；如疑、邪见、无明及与这相应而起的嗔、慢等，以无漏灭道为缘时，虽然亲所缘的影像相是有漏，但所仗的本质则通无漏。故本影二境合说，名缘有漏无漏的烦恼。
    （12）缘事境名境分别：贪等缘自地法，亲所缘的影像相分似于本质，名缘分别所起事境，事是体义，即有体境。缘灭道谛，及他地法，名缘分别所起名境，以灭道深远，地处远故，亲所缘的影像相分，与本质不相似，唯以名言为所缘故。


戊、随烦恼

    戊、随烦恼
    （一）名义
    随烦恼，即随从根本烦恼而起，故名随烦恼。其义有二：一唯是惯恼分别差别义，即忿等十种，及忘念、不正知、放逸十三法，都是贪等根本烦恼的粗行差别分位上假立，依随根本烦恼而起，故名随烦恼。二是根本烦恼的等流，等流是同类义，就是随惑与本惑同类，被其所引而生起，即无惭、无愧、掉举、昏沉、散乱、不信、懈怠七法，虽然别有体性，不是从根本烦恼的分位假立，但它们是根本烦恼的同类染污法，由本惑为因而得随有，所以得名随烦恼。
    这二十随惑，随其它们起用的宽狭，分为小、中、大三类。忿等十种，自类不并，只能各别生起，既不遍于染心，亦不遍于不善心，行位局故，名之为小随烦恼。无惭、无愧两种，自得俱生，行通忿等，唯遍不善，行位比小十稍宽而狭于后八，故得名中随烦恼。掉举等八，自得俱生，凡染皆遍，得俱生故，不可名小，染皆遍故，不可名中，二义既殊，作用广大，故得名大随烦恼。

    （二）解说体业
    （1）忿：依对现前不饶益境，愤发为性，能障不忿，执仗为业。即依现在可见闻的违缘事相境，或是有情，或是他见，即缘事生；由是愤恚，发起粗暴的身语表业。仗是器杖，论唯说执仗为业，是从粗猛多分说，实亦色括恶语表业。不忿即无嗔，忿恚故无嗔不生，故说为障。这忿即嗔恚一分为体，离去嗔心，没有别的体相业用。
    （2）恨：由忿为先，怀恶不舍，结怨为性；能障不恨，热恼为业。由忿对现前违缘事为先，心怀恶念不舍，是为恨相；由恨结怨，不能含忍，因而生起热恼。这很也是嗔恚一分为体，离嗔别无相用。
    （3）覆：于自作罪，恐失利誉，隐藏为性；能障不覆，悔恼为业。自己作了有罪恶行之后，恐失掉财利名誉，所以覆藏不自发露。凡是覆藏罪恶的人，心里必然忧悔热恼，由此身心皆不得安稳而住。这覆以贪痴一分为体：不惧当来苦果而覆藏罪恶，这是愚痴；但覆藏罪恶，也是恐其失掉财利、名誉，这是贪心作怪，故亦贪分所摄。
    （4）恼：忿很为先，追触暴热，狠戾为性；能障不恼，蛆螯为业。由忿恨为先，追忆往恶，忿很之境，接触到现前的违缘，心便傲狠□戾，多发嚣暴、凶险鄙恶的粗言，犹如蛆蛰，能致毒害。故论说蛆蛰为业。这恼也是嗔恚一分为体，离嗔以外，无别相用。
    （5）嫉：徇自名利，不耐他荣，妒忌为性；能障不嫉，忧戚为业。嫉是嫉妒，徇是谋求，有嫉妒心的人，为了谋求自己的名利，听闻或见到别人有光荣事的时候，心起妒忌，深怀忧戚，令身心不能安稳而住。光荣事即世间的富贵和出世的解脱品功德，通有为无为。这嫉亦是嗔恚一分为体，离嗔无别相用。不嫉即无嗔，非别有体。
    （6）悭：耽着财法，不能惠舍，秘吝为性；能障不悭，鄙蓄为业。秘是秘藏，吝是吝借，即悭的异名。财即资其荣位等事，皆名为财。法即理教行果，皆名为法。悭吝的人，于财于法皆秘藏吝惜，不能惠施求者，所以产生鄙蓄的行业。鄙是鄙恶，蓄是蓄积，正是悭的体相。悭是贪爱一分为体，离贪无别相用。
    （7）诳：为获利誉，矫现有德，诡诈为性；能障不诳，邪命为业。矫是不实。诡诈即虚伪。矫诳的人，为了获得财利名誉，心怀异谋，没有功德，矫现有德，是诡诈现相的邪命事业，以贪痴一分为体。
    （8）谄：为罔他故，矫说异仪，险曲为性；能障不谄，教诲为业。险是不实，曲是不直。谄由的人，为了贪图名利，罔冒他人，虽事不合，曲顺时宜，矫说方便，为取好他人的意思，掩藏自己的过失，而伪现特异的威仪，使师友不能认识他的本来之相，所以不堪任师友们的正教诲训。这谄也是贪痴一分为体：贪名利故，谄是贪分；无智故谄，即是痴分。
    （9）害：于诸有情，心无悲愍，损恼为性；能障不害，通恼为业。由对于有情所，没有悲愍心，所以损害逼恼有情。此亦嗔恚一分为体，离嗔无别害相用。嗔障无嗔，正障于慈：害障不害，正障于悲。嗔能断物命，害俱损他，是嗔害别相，准前善心所中说。
    （10）憍：于自盛事，深生染着，醉傲为性：能障不骄，染依为业。自盛事，即暂获世间荣利长寿等事，便深生染着，心恃高举，骄醉傲逸，由是生长一切杂染污法，所以说染依为业。此亦是以贪爱一分为体，离贪无别相用。
    以上十种，名为小随烦恼。
    （11）无惭：不顾自法，轻拒贤善为性；能障碍惭，生长恶行为业。对于自己没有自尊心，和对于有漏无漏的善法没有宝贵敬重心的人，即是于自身于善法都无顾念者，自然地就会轻视和远离有贤德的人，拒绝善法，不羞耻过恶，而生诸恶行了。这是返惭的相用，准惭相翻应知。
    （12）胜无愧：不顾世间，崇重暴恶为性；能障碍愧，生长恶行为业。对于世间的道德、法律、兴论等，皆无顾忌的人，就会崇拜有暴恶行的人，和爱重恶法，不羞耻过恶，而生起一切的恶行。这是返愧的相用，准愧相翻应知。
    无惭、无愧，是中随烦恼。轻拒贤善，崇重暴恶，是这两法的别相，不耻过恶，是两法的通称，所以这二法各有自体。不善心起时，随缘何境，皆有轻拒善及崇重恶义，故此二法，俱遍恶心。
    （13）掉举：令心于境不寂静为性；能障行舍，奢摩他为业。不寂静即扰乱，是烦恼的共相。掉举令心不静，即显掉举非唯不寂静，它的自性嚣动，由其嚣掉举动，令俱生的心心所法不寂静，障碍心平等正直住的行舍奢摩他。奢摩他就是止品。
    （14）昏沉：令心于境无堪任为性；能障轻安，毗钵舍那为业。昏沉的自性懵重，皆是昏懵，重是沉重，由昏懵沉重，令俱生的心心所法于所缘境无堪能任持，因此障碍轻快安稳的毗钵舍那。毗钵舍那就是观品。
    （15）不信：于实德能，不忍乐欲，心秽为性；能障净信，惰依为业。惰就是懈怠，不信者多懈怠，故不信为懈怠的所依。不信三相，翻善中信应知。不信的自相浑浊，又能恽浊其余的心心所，如极秽的东西，自秽秽他，是故说名心秽为性。由不信故，于实、德、能、不忍、不乐、不欲，非别实有不忍等自性。若对于染法起忍、乐、欲，体即欲等，不是不信的自体，仅是不信的因果而已。若对于无记法起忍、乐等，但是欲胜解，非与余法为因为果。
    （16）无懈怠：于善恶品修断事中，懒惰为性：能障精进，增染为业。于应修的善品事，和应断的恶品事，而懒惰不修不断，是为懈怠：由懈怠故，滋长染法，故说增染为业。还应该知道，非但于善不精进名为懈怠，即于恶法染事而策励的去作，亦是懈怠，退失善法故。若于无记事策励，于诸善品无进无退，是欲、胜解，非别有体。
    （17）放逸：不染净品，不能防修，纵荡为性；障不放逸，憎恶损善所依为业。纵是纵恣，荡是荡逸，由纵荡故，于染品不能防止，于净品不能进修，就是放逸。因此增长恶法，损减善法。这是由懈怠及贪嗔痴，不能防恶及修善，总名放逸。慢疑等亦有纵荡性，为什么不依慢疑等上建立放逸呢？这是因为慢疑等虽然亦有纵荡性，不能防恶修善，但与懈怠及贪、嗔、痴等四种此较，则四法障碍精进及无贪等三善根的势用力胜，所以做懈怠等四法建立放逸，而不依慢等。
    （18）失念：于诸所缘，不能明记为性；能障正念，散乱所依为业。对于所缘善等不能明记，名为失念。由失念故，生起散乱，故失念为散乱的所依。痴令念失，故名失念，所以失念以痴念为体。
    （19）散乱：于诸所缘，令心流荡为性；能障正定，恶慧所依为业。流是驰流，即散功能义；荡是荡逸，即乱功能义。散乱的自性躁扰，令俱生的心心所法流荡，于所缘法心不能安住，发生恶慧，所以能障正定，为生起恶慧的所依。掉举与散乱的作用有什么差别呢？掉举是令俱生的心心所于一种所缘境上解数转易，即一境多解。散乱令心心所易缘各别境，即一心易多境。易解易缘，义成差别。
    （20）不正知：于所观境，谬解为性；能障正知，毁犯为业。对于所观，非是迷暗，而是错谬邪解，名不正知。由不正知多发恶身语业而毁犯戒等，故论说毁犯为业。知即是慧。但由痴故，令知不正，名不正知，故以痴慧两法合为自性。
    以上八种，名八大随烦恼。
    （三）诸门分别
    （1）废立：上来已说二十个随烦恼的体相业用，但在经论中所说的随烦恼，并不仅止这二十个，如贪、嗔、痴等，邪欲、邪胜解等，趣向、前行等，都名随烦恼。既有多种，为什么这里只说二十个呢：这有三种意义：[1]简别非是根本烦恼，显其唯是随烦恼。贪等虽然是随，但非唯是随烦恼，所以不说贪等。[2]显其唯是染污。即简别邪欲、邪胜解等，及不定四种，虽然是随，但体通三性，非唯染污，所以不说邪欲等。[3]唯粗动起。趣向、前行等虽亦是随，但行相微细，不是粗动，所以不说。具足这三义，是故唯说二十，不更说余。又其余的随烦恼，或是这二十种的分位，或是这二十种的等流，皆不出此二十种可摄。如邪欲、邪解等，依不信等分位假立：如愤发等，即忿等同类；趣向、前行等，依无惭等分位假立。由此可以知道，有这二十种随惑，就可以摄尽一切所余的随烦恼，所以唯说二十种就足够了。
    （2）假实：二十随烦恼中，小十种及八大中的忘念、放逸、不正知三种，都是假有；依贪嗔痴等分位假立故，如释体用中已说。中二随惑，及八大中的掉举等五种，皆是实有，各有自体故。
    （3）俱生分别：二十随惑，皆通俱生分别，因为随惑是依随俱生分别两类根本烦恼的势力而起，所以皆通俱生分别。
    （4）自类相应：小十随惑，各自相望，定不俱起，因为体性相违，行相粗猛，一一各自为主，故不并生。中二随惑，自得俱生，通一切不善心起。但不善心皆定有故。随其所应皆得与小十、大八俱起。八大随惑，通一切染污心，展转自类相望，及与小十、中二皆容俱起，行相不相违故。
    （5）诸识俱起：二十随惑，皆唯染污，故非第八识俱，第八识体性无记故。第七识中唯大八，大八遍诸染心，第七有覆，故必俱起。第六意识，容有一切。小十的行相粗猛，五识中无，以五识相望于小十，行相即细。中二、大八、五识容许，中二遍不善，大八遍染污故。
    （6）五受相应：中二、大八，皆与五受相应，（受是遍行中一个心所。遍行中余四心所义定俱起，故不必说；受有差别，故特分辨。）因为中二遍于不善，大八遍诸染心，故说中、大遍五受俱起，五受皆通不善和染污故。
    小十随惑，若约审细义说，忿等七种，皆、忧、喜、舍四受相应，在欲界意识无乐，忿等又不与五识相应，故不与乐受俱起。谄、诳、憍三种，色界中有意有乐受，以初静虑中有意乐故，而欲界地狱中意有苦受，故谄等三法，五受俱起。若随粗相来说，忿、很、恼、嫉、害五法，唯忧及舍相应，忿等是嗔分，忧受是戚行，所以得与俱起。覆、悭两法，唯喜、舍二受俱起，覆、悭是贪、痴分，喜是欣行，故得相应。谄、诳、憍三法，喜、乐、舍三受俱起。谄等三法，上地有故，所以有乐。谄、诳、憍三，都是欣行，所以除苦、除忧。
    （7）别境俱起：二十随惑，皆容许与别境五所相应，行相不相违故。
    失念怎么与念相应呢？因为失念是以痴、念为体，以念体那一分，不与念俱起，通痴那一分，亦得相应。不正知怎么可以与别境中的慧俱起呢？因为不正知有痴分，所以相应。忿缘现在境，念缘曾习境，两法怎么可以相应呢？因为念亦曾习现在之境，是过去曾习的同类故，忿亦缘刹那过去境，故忿与念，亦得相应。如见旧怨，起忿念法故。定是专一，散乱多缘，怎么相应呢？染污起的时候，既名染污，心亦躁扰，不相违故，相应无失。非是散乱，就泱定要多缘，以躁扰是散乱的自性故。
    （8）根本相应：中二大八，十烦恼俱起，中二遍不善故，大八遍一切染故。但俱生随惑者与俱生本惑者相应，分别随惑与分别根本俱起，故分别不与俱生并，便生不与分别并。俱生之中，除身边二见，不与无惭无愧俱起，性相违反，中二唯不善，俱上二见唯无记故。其余的都容许相应。小十定非见、疑俱起，因为小十行相粗动，见疑两法行相审细，故不相应。忿、很、恼、嫉、害五法容许与慢、嫉二法俱起，不与贪、嗔二法并。因为忿等是嗔分，与贪的行相违故；嗔是忿等的自体相故。悭与嫉慢二法容俱。非贪俱起，是自性故；非嗔俱起，性相违故。憍唯嫉俱，是贪分故。不与贪并，是自性故。不与嗔并，行相摄故。憍慢解别，不与慢俱；憍缘自高举生，慢亦缘他下逸起，故不俱生。覆、诳与谄，贪痴慢俱，行相无违，故得俱起。因为覆、诳、谄三，都是以贪痴一分为体，由是贪痴分故，所以不与嗔并；是贪分故，可与痴俱；是痴分故，可与贪俱。
    （9）三性分别：小七中二，唯不善摄，以唯是欲界系，唯发恶行故。小十中的诳、谄、憍三，及大八亦通无记，因为它们都通色界有诳等三法及大八皆遍染无记故。
    （10）三界分别：这有三门：[1]界有摄。小七中二，唯欲界摄；唯发恶行，唯粗卑故。谄、诳，欲色界有，有王臣等的处所，才有谄、诳故。余通三界，即憍及后八，唯缘自起等，遍诸染心故。[2]下上相起。生在下地的有情，容评起上地十一种，躺定故起憍一法。于他欲界有情起诳谄故。即矫现有德于欲界有情起诳，为罔冒故于他下地有情起谄曲。要得了上界的定，才能起这些随惑。如已得定的人，起上界诳谄，诳谄欲界有情，诳他令从己，谄他我得膀法等。其余大八通染，润生心等皆有彼故。若生在上地的有情，起下后十种，即中二大八。为什么有无惭无愧呢？因为中有身位，有谤灭谛的邪见有情（如增上慢比丘），因此定有无惭无愧。又命终起爱时，虽是无记，而大八决定俱起，以八法皆遍染心故。小十忿等，生在上地决不起下，因为小十非正润生惑，下十唯不善润生是无记，故不与爱俱，所以不起。又不是让灭谛惑，故不与邪见并，所以不起。除此二时，生在上地的有情，必不起下地烦恼，此二时中既无忿等，所以定知上不起下。[3]上下相缘。中二大八，下亦缘上，与前根本惑中所说上缘贪等相应起故。小十中忿等七法，定不缘上。嫉、悭、憍三法，亦缘上起，于胜地法生嫉等故。嫉他所得静虑无色定故；憍恃所证，知解胜地法故；悭所证知解上地法故。诳谄二法，定无上缘，无诳谄色有情故。大八谄诳，上亦缘下，与前本惑中所说下缘慢等相应起故。梵王于释子起谄诳，如梵王执马胜比丘手，是谄诳故。唯憍不缘下，下地法劣，非所恃故。
    （11）学等分别：二十随惑，皆非有学摄，随惑唯染，学无学唯净故。
    （12）三断分别：中二大八十种，唯通见修道断，不通非断，与俱生分别两种根本烦恼起故。忿等十种，亦通见修所断，依俱生分别两类势力起，故通二种，非但缘粗事境，任运生，亦缘他人我见上生忿等故，非唯修断而亦通见道所断。
    （13）有事无事：忿等十种，但缘有事，要记本质才能生起。不与我见俱起，我见俱起的心心所，名缘无事，本质我无故。中二大八通缘有事无事，
    （14）有漏无漏：二十随惑的亲所缘缘虽然都是有漏，但是它所仗托的本质境，亦通无漏，如前根本惑中所说应知。


己、不定

    己、不定
    （一）名义
    不定心所有四个，即悔、眠、寻、伺这四个心所，于识、界、性等皆不定故，所以得名不定。不像遍行的触等定遍诸识，以悔等四法，唯第六识中有，余识皆无；亦不如别境的欲等定遍诸地，以悔眠唯在欲界，寻伺二禅以上即无；又不像善十一及染惑二十六唯一善染性，以悔等遍通三性，所以名为不定。
    （二）解说体业
    （1）悔：悔谓恶作，恶所作业，追悔为性，障止为业。悔就是追悔，恶是嫌恶，作是措作，嫌恶所作的事业，故名恶作。由恶作故，生追悔心，故悔名恶作。这是从因立名，即恶作是因，悔体是果，由先嫌恶所作事业，然后才生起追悔，故说悔名恶作，即是于果法上假立因名。悔先不作，亦是恶作所摄。如追悔说：‘我先不作某一件事，真是可惜！’恶作既然是追悔先时所作和不作，故通于三性。若追悔先时所作恶业，即悔是善性；若追悔过去所作善业，即悔成恶性；追悔无记事，即悔成无记性。如是追悔先时未作善、和未作恶、及未作无记事，悔成善、恶、无记应知。由悔故令心不能安住，所以说障止为业。这里所说的止即奢摩他。
    （2）眠：眠谓睡眠，令身不自在，昧略为性，障观为业。睡眠令身不自在，坐亦睡故；令心极其暗昧轻略，不明利而沉重，都无五识，唯意识一门转，这就是睡眠的行相。昧简在定，定虽然是专住微细一门转，但不暗昧。略简醒悟时的散心位，悟时散心虽有暗相，但非轻略。这里所说的睡眠，非定专指长卧才是睡眠，凡令身不自在，令心昧略而沉重都是睡眠，坐倚等皆可是睡眠故。由睡眠令心昧略，不能生起明利的观慧，所以说障观为业。观即是毗钵舍那。
    （3）寻：寻谓寻求，令心匆遽，于意言境，粗转为性。
    （4）伺：伺谓伺察，令心匆遽，于意言境，细转为性。此二（寻、伺）俱以安、不安住身心分位所依为业。匆遽，是匆迫遽急义。意言境，即一切法。意是意识，言是名言，以意识遍缘一切法，名言诠表一切法，故说意言境，即摄尽一切法。这有三种意义：[1]喻。意识及相应的心所法，能缘取一切境，与能诠表一切境的言说名言相似，所以名为意言境。[2]从境。言说的言，以声为体性，这言为意识的所取性，从言为名，故名意言；即言是意之境，名意言境。[3]从果。由意识能生起言说，故名意言；言说是所起的果法，从果立名，名意言境。第二解约心境，第三据因果，故义成差别。这意言境，亦通一切心所法等，而意是其主，胜故遍说。身心若安，徐缓为业；身心不安，匆遽为业。身心前后有安不安，皆依寻伺而起，故名安不安住身心分位所依为业。寻伺两法，都是以思、慧一分为体，由寻对于意言境粗转，即不深推度，伺对于意言境细转，即起深推度，义成差别。
    （三）诸门分别
    （1）假实：不定四中，悔、眠两种，各有自体。寻、伺两法，定是假有，俱以息慧一分为体故。
    （2）自类相应：四法之中，寻伺两法，定不俱起，体俱思慧，用俱推度，不可同体同用，仅粗细相违的法而得并生，如上下受不得一心中并起一样。寻向与悔、眠俱得相应。悔、眠亦有互相应义，行相不相违故，但无四法一时并起义。
    （3）语识相应：悔等四法，皆不与第七、八识相应，四中虽然有无记性，以有间断故，定非七八识俱。悔眠两种，非五识法，唯第六识有，因为悔眠不是任运生法，皆由加行才能生
    （4）五受相应：悔与苦、忧、舍三受相应。唯戚行转，故与忧受相应，不与喜乐相应；通无记性故，与舍受相应。悔是意识法，为什么与苦受相应呢？以于地狱中有悔，悔先所作恶业，地狱意有苦受，故悔虽是意识中法，然可与悔相应。眠与苦、忧、喜、舍四受相应，以睡眠行相通欢，故与喜受俱，通戚故与忧受并，中庸故与舍受俱。眠是意识中法，为什么与苦受相应呢？因为眠是昏昧义，在极苦处的有情，亦有昏昧的眠故。寻伺与五受相应：寻伺行相通欣、戚、中庸，故与喜、忧、舍三受俱起；初静虑中意有乐故；纯苦趣中意苦俱故，所以寻伺得与苦乐二受相应。
    （5）别境相应：悔等四法，皆容许与别境五所相应，行相所缘不相违故。
    （6）善法俱起：悔、眠但与十善容许俱起，不与轻安相应：以悔眠唯在欲界，欲界无轻安。寻伺容与十一善俱，初静虑中有轻安故。
    （7）烦恼俱起：悔但容许与无明相应，因为悔的行相粗，必独生起，不与贪等九法并生，贪等行相细故。此约组相不俱，据实亦得。如邪见者悔修定，邪见与嗔俱，故悔亦与邪见嗔俱。又如悔先行施，则悔与贪俱。更由悔贪俱而作这样的言说：‘我前时为何作这样的事呀！’即分别我见亦与悔俱。睡眠并伺，十烦恼俱，此彼行相，展转不相违故。
    （8）随惑相应：悔与中二大八随惑，皆容俱起，以中大遍与不善心故。相粗悔行不与忿等十并，以忿等行相粗猛，各自为主，如忿等十法，自不相应。睡眠、寻、伺三法，容与二十相应，眠等位中，皆容起忿等二十随惑故。
    （9）三性分别：悔等四法，皆通善恶无记三性；于无记亦起追悔故。
    （10）界系分别：恶作、睡眠唯欲界有，以上二界妙胜，没有身体上的疲劳及内心忧虑等，所以没有悔眠。寻伺在欲界及初静虑，余上地法皆是寂静，寻伺嚣繁，故静处没有。
    （11）上下相起：悔眠二法，生在上地，必不现起，是极粗恶法故，无所用故。寻伺通二地，下得起上，上得起下；欲界有情入初禅定，亦得起初禅寻伺，名下起上。第二定以上至第四定，起初定及欲界邪见；无色界起下色界，欲界润生心等，亦有初禅寻伺及欲界寻伺，名上起下。
    （12）下上相缘：下地寻伺与上地寻伺，互得缘上缘下，境界宽故，下上能得五缘；欲界寻伺，可缘上二界境，色界寻伺可缘上下二界境。悔眠二法，亦缘上境。悔何以缘上呢？有邪见者，初学修定，多用功夫而不得定，则心悔修定，故悔得缘上。梦怎么缘上呢？梦能着缘
    （13）学等分别：悔不通无学，通有学中初二果人得有悔，第三果即无，以离欲时即舍忧悔故。第三果岂无悔先时身作恶行等呀？此即是厌，非是悔故。（恶作即通四果人皆有。）睡眠、寻、伺通有学、无学、非学非无学三种人皆有。
    （14）见等所断：悔、眠唯通见修所断，不通不断，小乘宗悔眠，唯是修道断，何以言通见道断呀？因为悔眠亦有由邪见等势力所起故。寻、伺二法，通见修非所断摄，为什么通非所断呢？因为寻伺二法，虽然不与无分别智的真无漏道相应，由加行位中，寻伺能引真无漏道，后得智中同时亦引起寻伺，故寻伺通无漏名非所断。
    （15）缘有事无事：悔等四法，皆缘有事境，除悔一法外，寻、伺及眠，亦缘无事境。因为悔唯与本惑中的无明相应，其我见、边见能缘无事有无漏的名境，唯悔不与俱生身边二见俱起，所以不缘无事。有漏无漏，准此应知。
    总上六位五十一个心所法，若依世俗，离心之外，别有自体，若依胜义，与心王体性，非即非离。诸识相望也是这样。


三、色法

    三、色法
    第三位色法，色是质碍义，即物质法，简略分别，有十一种：（一）眼根、（二）耳根、（三）鼻根、（四）舌根、（五）身根、（六）色境、（七）声境、（八）香境、（九）味境、（十）触境、（十一）法处所摄色。
（一）～（五）：根是增上出生义，眼等五根，皆以四大种所造清净色为体，为眼等五识的所依色，与眼等五识作威势，五识借它为增上缘而得生起了别的作用。
（六）色境，即眼识依眼根所缘的境。这有三种：[1]显色，即青黄等色。[2]形色，即长短等色。[3]表色，即取舍等色。三种色中，唯显色实有，形表皆是依显色分位上假立，故无别体。
（七）声境，即耳识依耳根所缘的境，有因执受、因不执受、及因俱生，可意、不可意、俱相违六种，非分位法，皆别有体。
（八）香境，即鼻识依鼻根所缘的境，有好香、恶香、平等香三种，非分位法，皆别有体。
（九）味境，即舌识依舌根所缘的境，有苦酸辛咸淡等，非分位法皆别有体。
（十）触境，即身识依身根所缘的境，有地水火风四大能造触及所造滑涩轻重等假触。地等四大，各别有体；所造假触，是四大种的分位，无别体性。
（十一）法处所摄色，即意识依意根所缘的法尘。这有五种：[1]极略色、[2]极迥色、[3]受所引色、[4]遍计所起色、[5]定所引色。五种色中，前四种是假法，无别实体，定所引色，有假有实；五种皆是第六意识的所缘境，其定果色之实者，亦眼等识所缘。极略色，就是极微。极迥色，即空界色（物隙明暗色）。受所引色，即无表色。遍计所起色，即水月镜像等。定所引色，即定力所变的色等五尘。
    总上十一种色，前五种是五识的所依色，后六种是识的所缘色。后六种名色名声等，是与眼耳等相对以名境，即眼所取故名之为色，乃至意所取故名之为法。唯法处所摄色，名稍有别；法是轨持义，处是处所，即十二处中之一色。虽然色声等亦名法及处，但以对根故名色、声等，没有相滥的过失，所以唯极略等名法处所摄色。色法的详义，下又色蕴中再说。


四、心不相应行法

    四、心不相应行法
    （一）名义
    第四位心不相应行法。心即八识心王，行是迁流义、造作义，通指一切有为法，在五蕴中即是行蕴。行蕴有二：（1）相应行，即遍行等五十一个心所法，与心王相应随转，故名相应行。（2）不相应行，即‘得’等二十四法与心法不相应，简别相应行的心所法，故名不相应行。其全义名称，应该是非色非心不相应行，这样就可以简别非四聚法：非色简别色，非心简别心王，不相应简别心所，行简别无为。总起来说，即‘得’等二十四法，是于色、心、心所三种的分位上假立，不与心王相应，是行蕴所摄的假法，故名心不相应行。又不相应，即不相似义，‘得’等不相似于色有质碍，不相似于心有缘虑，故名不相应；生灭无常，故名为行；是行蕴所摄的不相应法，故名不相应行。这不相应行，总有二十四种：一得、二命根、三众同分、四异生性、五无想定、六灭尽定、七无想异熟、八名身、九句身、十文身、十一生、十二老、十三住、十四无常、十五流转、十六定异、十七相应、十八势速、十九次第、二十时、二十一力、二十二数、二十三和合性、二十四不和合性。
    （二）别解体相
    （1）得：得就是获得，能得的是人，所得的是法，在这能所得上，假立得义。故《成唯识论》说，依诸有情身上可成诸法分位，假立三种成就[1]种子成就，[2]自在成就，[3]现行成就。
     [1]种子成就：就是在有情身中，某一些法虽然不现行，但有它的潜在势力的功能种子，是为种子成就。如凡夫身中，成就三无漏根的种子。（ｉ未知当知根，从资粮位至三心相见道第二心；※已知根，从相见道第三心，至金刚无间道；※具知根，在佛果位。）未离欲界染的有情身中，成就上界诸法种子。《瑜伽师地论》五十二卷说：‘若所有染污法、诸无记法、生得善法，不由功用而现行者，彼诸种子，若未为奢靡他之所损伏（语染污法），若未为圣道之所永害（无记法），若不为邪见损伏诸善，如断善根者（生得善），如是名为种子成就。’
     [2]自在成就：就是于现行法上依禅定神通等的势力成就自在转变的力量，即依定通力故转变土木为金宝等，是名自在成就。如《瑜伽师地论》五十二卷说：‘若加行所生善法，及一分无记法（工巧处变化心等），生缘所摄受增盛因种子，（《成唯识论述记演秘》云：种是生果之因缘，名为生缘。由种有生果之功能，果方得有，种名摄受。即所生果名为增盛。或种有生果势用，名为增盛。）名自在成就。’自在即能得的人，成就是所成就的法，由加行力得到自在，自在者之所成就，故名自在成就。
    [3]现行成就：就是正成就一切现行法，即所依身在欲界，则成就欲界法。又所依身纵然在欲界，若已离欲界染时，以欲界身成就上界现行法，乃至依欲界身，无漏法现起，皆是现行成就。如《瑜伽师地论》五十二卷说：‘若现在诸法自相现前转，名现行成就。’《对法论》第五说：‘诸蕴界处法，随所现前，若善、若不善、若无记，彼由现行成就故成就。’
    应该知道，种子若断损了，现行亦不成就，故现行成就必然具足种子成就，而现行则现起时名成就，不起位名不成就。三种成就中，前二唯是种子，后一唯是现行。为什么种分为二，现行唯一呢？因为种相隐微难知，分说为二；现行相显易了，故合为一。三种成就，皆通有漏；若无漏法，唯后二种。
    （2）命根：就是有情的寿命，依先业所行异熟住时决定的功能上，假立命根。在第八识自体分亲生名言种子上，由先业所行有二功能：一生果功能，二住识功能。依生果功能生起现行，由住识功能任持所生现行令住，及持一期色身；依此令色心等住时决定的功能，说名命根。不取生现义说，唯于名言种子中取住识一边义说。以此种子，若无这住持色心的功能，身便烂坏，现行的识亦不得有了。故《成唯识论》卷一说：‘然依亲生此识种子，由业所行功能差别，住时决定，假立命根。’
    （3）众同分：依有情身心相似分位差别，假立同分。众是种类义，同是一义，分是相似义，即人人相似，天天相似，法法相似。此等各异，所以名众：五趣有情，各同类相望，五蕴和合身形彼此相似分位，名众同分。故众同分是依色心二法上假立，离色心法外，无别同分法。诸论中唯于有情内处安立同分，乃据胜为论，实亦通于外法，故《瑜伽论》五十二卷中约界、趣、生、种类、分位、体性、容色、形貌、音声等建立同分。
    （4）异生性：异生是凡夫的异名，异生性即凡夫性。这是依于三界见所断种未永害位说，即在不善、无记的分别二障惑种上，假立异生性体，故性唯染污。无漏圣法现起的时候，分别二障的种子永断，即成圣者，异生性于此位后即永远不复存在了。凡夫为什么名为异生呢？因为三界异类有情，妄执种种异见而受诸生死，故名异生；圣者们同证圣无漏智而得生，故名同生。故《十地论》说凡圣二众：一名异生，一名同生。异有两义：[1]别异名异，圣人唯生人天趣，凡夫通于五趣受生故；[2]变异名异，圣者同证圣无漏智，见无转变，异生见不决定，可能转变为邪见等故。生通五趣，故生是总，性是五趣各别之性，故性是别；异生之性，故名异生性（别体依主释）。
    （5）无想定：即外道所人的无心定，《成唯识论》卷七说：‘谓有异生，伏遍净贪，末伏上染，由出离想作意为先，令不恒行心心所灭，想灭为首，立无想名。令身安和，故亦名定。’有类外道，以想为生死的根源，灭想尽净，就可以得到涅槃。入这定的有情必须是已离掉第三静虑遍净天的贪欲，入第四定修背想作意，观想如病、如痈、如箭，对于所生起的种种想中厌背欣求无想寂静，于无想中持心而住，这样地渐次离掉一切所缘乃至微心，极至微微心，心便寂灭，即入无心。这无心位，不单是灭除想，是把非恒常现行而有间断的前六识心法及相应的心所法皆消灭尽净，所以名为无心；但因为最初修这定的加行作意，是以厌离想为首，因此得名无想定。定是第六意识相应心所，既然已无心了，为什么又叫定呢？这应该知道，有心定令身心平等安和名之为定，这无心定由定前的加行力量亦令身心平等安和，所以亦得名定。论其体，即从彼厌心种子上具有的遮防功能立名无想定。这定属于第四静虑广果天，体是有漏，唯外道所修，圣者们是不修这定的。
    （6）灭尽定：这是由无漏圣智引起的无心定。《成唯识论》卷七说：‘谓有无学，或有学圣，已伏或离无所有负，上贪不定，由止息想作意为先，令不恒行染污心心所灭，立灭尽名；令身安和，故亦名定。由偏厌受想，亦名灭彼定。’这灭尽定，是第三果以上的圣人所入的无心定。最初修习生起这定，唯在人中，因为最初生起这定，必须依靠佛陀或佛弟子，演说修习灭定的教授方法，和人中特别具有的猛利慧解，即说力及慧解力，才能生起。若生在上二界的圣者，后起亦得现前（即已在人中修起灭定者）。修习灭定的圣者，必须是已经伏除或已经断除无色界第三无所有处的贪烦恼，依有顶游观无漏心（即不断烦恼的无漏心）为加行；若二乘人厌患六识有漏劳虑，或观无漏心粗动；若菩萨亦欲发生无心寂静似于涅槃的功德，由止息想作意为先，欣求无心三昧，乃至微微心，遂入无心。令不恒行的前六转识心心所和恒行无间的第七末那的染污心心所都完全灭尽，所以名为灭尽定。若是二乘生空灭尽定，则六识及我执相应末那皆灭，唯除人空染法。若是菩萨法空灭尽定，则六识并有漏末那皆灭，亦除法空染法。虽是无心亦得名定，义如前说。论其体即从厌心种子遮防功能上立名为定。修这灭定，是以有顶天非想非非想处为所依地，所以论说上贪不定，即上有顶天的烦恼伏离已否，皆能修起灭定。灭定虽然属于有顶，因为是无漏心引起，故体是无漏。若修此定已得自在，依着其余的下七地（四禅三无色）心亦得现前。
    （7）无想异熟：即无想天，在色界第四禅的第三广果天中别有高楼处，是修习无想定者所得的果报。外道因为欣求无想果报而修习无想定，命终的时候，依所修习的定力生到无想天中。以在人间修习无想定时，微微心所熏习的厌心俱行思心所种子为不动业，先感广果天总报第八识果，在这初生本有的初位，彼处异熟生无记转识暂时现起，然依于宿时所修习的无心定力，令彼异熟第六识灭无，引起异熟无记无心分位，五百劫间，不恒行的心心所皆不现起，即以此无心分位立名无想别报果。这就是于第六识报心种子具有的遮防用上假立无想别报。无想报尽，转识生起，然后命终，彼必现起下界润生的爱故。所以无想天的有情，在初生和命终的时候皆有转识心心所生起。
    （8）名身，（9）句身，（10）文身。名句文皆是声上的音韵屈曲。名诠诸法的自性，如说眼耳鼻舌等；句诠诸法的差别，如说诸行无常、诸法无我等义；文体是字，为名句的所依，不能诠表自性事及差别义。名句文三种，都是依语声分位差别假立，唯直径声体才是实有。身是聚集义，即合集多字多名多句，总说为身。如以字为首，即多刹那的语声聚集成为一个字，集多字为所依而成为名，集多名才成为句。
    （11）生，（12）老，（13）住，（14）无常。即于众同分诸行本无今有假立为生，于众同分诸行相续变异假立为老，于众同分诸行相续未变坏假立为住，于众同分诸行相续变坏假立无常。这生等四种，是有为法的四相，皆是于色心法上假立，离色心以外无别体性。这四相有约一期（即一个有情从生到死）与刹那（一念）的差别，这里是依一期说的。外法诸色等亦有生等四相，这里为什么单举众同分来说呢？这是因为外法诸色等有为相，由成坏等显示，内法诸行有为相，由生老等显示，故特约有情色心相续上建立生等有为之相。（对法义）
    （15）流转：一切有为法能生余法，故名为因：从余所生，故名为果。即于因果相续不间断上，假立流转。为什么唯独于相续不间断上安立，而不于一刹那上安立呢？因为在一刹那上无流转可说故。
    （16）定异：异就是差别，即于因果的种种差别相上假立。如可爱果，妙行为因；不可爱果，恶行为因；在这些种种因果，展转差别相上，假立定异。
    （17）相应：即于因果法相称的意义上，假立相应。相称即相顺，如修布施行因，招感大富财果等。
    （18）势速：即于因果法上迅急流转，假立势速。
    （19）次第：即于因果法一一流转上，假立次第。
    （20）时：即于因果相续流转，假立为时。由有因果相续故，若此因果已生已灭，立过去时；若末生，立未来时：若已生未灭，立现在时。
    （21）方：即于东西南北，四维上下，因果差别，假立为方。当知此中唯说色法所摄因果（大种所造）；无色之法，遍布处所，无有方义。
    （22）数：即依色心诸行众多品类的一一差别上，假立为数。
    （23）和合：即于因果众缘集会，假立和合。且如识法，因果相续，必借众缘和会：须根不坏，境界现前，能生识的作意正起。余一切法，如理应知。
    （24）不和合：翻对和合，假立不和合，其义可知。从流转至不和合这十法中，流转、势速、次第、时四法，唯依前后因果以辨；其余定异、相应、方、数、和合、不和合六法，通三世建立。虽以妙行恶行各招自果为其定异，然俱生法亦能为因，生受想等，岂非定异？故通三世。
    （三）诸门分别
    （1）假实分别：‘得’等二十四种心不相应行法，于诸事中为起言说故，依色心心所分位差别建立，当知唯是假有。依心心所建立五种：即无想定、灭尽定、无想异熟、命根及异生性。依色法上建立四种：即名身、句身、文身及方。其余的十五种，都是通依色、心、心所三法分位上假立。如以‘得’来说，得智慧等是心心所分位上假立，得容貌等是色分位上假立。其余的可以准此例知。
    （2）漏无漏辨：二十四种中，一法唯是无漏，即灭尽定。唯圣人的无漏慧为加行所引入故。无想定、无想异熟、异生性三种，唯是有漏。其余二十种，通有漏无漏，如理应思。
    （3）三性分别：二十四中，三种唯一性：即无想定、灭尽定，唯是善性；无想异熟，唯是无记性。六种通二性：即名身、句身、文身、命根、异生性及方，无记及善性。即有漏名等唯无记，无漏名等是善性。异生性通不善有覆故，见道断法通二性故。方在因中，色法唯无记，果位是善性。命根在因位唯无记，果位是善性。（圆镜智中可立命故。）其余的十五种，通善恶无记三性，文理无违。
    （4）见断等分别：二十四中，一法唯不断，即灭尽定。一法唯见道断，即异生性。二法唯见修断，即无想定、无想异熟。其余的二十种通见修道断及不断。
    （5）三界九地：灭尽定非界，是非想地，无想定与无想异熟，唯色界第四定。名句文三种，即语声的差别，故唯欲色二界初定欲地有。方唯二界下五地有。余十三种通三界九地。


五、无为法

    五、无为法
    （一）无为名义
    第五位无为法，为是造作的意思，一切有生灭的法，均由众缘造作而有生、有灭，故名有为。真如等六种，寂寞冲虚，湛然常住，无生灭造作，故名无为。略有四义：
（1）不生不灭，即简生住异灭四相。
（2）无去无来，即简非属三世。
（3）无彼无此，即显没有自他对待。
（4）无得无失，即显无增无减。真如等法离生灭、去来、彼此、得失，无造无作，所以得名无为。有虚空、择灭、非择灭、不动、想受灭、真如六种。
    （二）列名别释
    （1）虚空无为：即空无我所显的真如，不落有无、俱非，心言路绝，与一切法非一、非异等，是诸法的真理，即此真如无相，周遍，离诸障碍，犹如虚空，故于真如上假名虚空无为。
（2）择灭无为：择是简择，灭是断障，即由无漏智力灭诸杂染，究竟证会真实，名择灭无为。
（3）非择灭无为：即不由智力的简择，约诸法性清净，或由缘缺不生所显，名非择灭无为。
（4）不动无为：即第四禅中，苦乐受灭，出离动性所显，故名不动无为。苦乐受是变异法，其性动转，第四定中已离掉这种动转性的受故，假名不动无为。
（5）想受灭无为：若离掉无所有处欲，想受不现行所显的真如，名想受灭无为。
（6）真如无为：此即诸法的实性，是前五种无为的所依，真实如常的理体。真简别妄，如简别倒，理非妄倒，所以名真如无为。
    （三）料简
    上述六种无为，唯后一种真如无为是诸法的真实性，其余五种无为皆是依真如上假立其名。若论实性，真如之名，亦是假说；真胜义中，离有离无，非有非无，怎么可以说名为真如呢？故说名真如，亦无非借言显理，假说而已。


六、百法无我

    六、百法无我
    上述五位共计一百法，无论心、心所、色、不相应行、无为，都没有众生计执的我法二种实性。‘我’有实、常、主宰、自在义，然以心、心所、色等积集组合而成的有情，决无坚实、不变、主宰自在的体性。法是轨持义，轨是轨范，可生物解，持是任持，不舍自性，一切法只有依他如幻缘生的虚假作用，亦决无坚实不变的自性胜用存在。这里分别略述其义：倘若有情法中有我，所计的我以何为体？若言以色为体，则色不应是无常，因为我是常一主宰者故。反之，我是常一主宰者故，色亦应是常一主宰自在。如是则色法不应有迁变坏灭。但事实却与常识学理相反，眼见无有一色法埘古而不变不坏者。若承认色法是有迁变坏灭，又许为我的体性，则我性应当随色之迁变坏灭而迁变坏灭。若如是者，则常一主宰自在的我性便不复存在了。其余眼耳根等，皆以此理推征可以例知。若我是以长短等为体者，长短等是色尘分位，色尘尚且是无常变坏的，没有我体的存在，依色尘分位积聚的长短等，离色尘外既无别体，更不可以为常一主宰自在的我体了。其余滑涩等触尘等分，皆以此理推征可以例知。若谓我是以心心所为体者，八识心王五十一心所，都是无常的，没有常一主宰自在的势用，都是互相资助观待而得生起。要是有我之体性存在其中，则总八识心王五十一心所，或总聚，或一王一所，应是常一主宰自在不变的存在。但是我们以常识学理的观察，心心所之总聚一多的作用，均非常一主宰自在，而是无常苦空无我。又纵许以心心所为法我体，而心王有八，心所有五十一，其我是以一心一所为体，还是以多心多所为体？抑是和合心心所为体？实则依一依多依和合，皆是说不通的。因为无论为一为多、为和合，心心所法都是无常苦空无我，决无常一主宰自在的我性，且依多依和合以为我体，则过失更多。所以从心从色，从内从外，从头至足，从皮至髓，六腑五脏，骨肉皮脉等，一切诸物，乃至所有种种心识念念等中，一一推求，众生所计执的常一主宰自在的实我，终不可得，毕竟都无，仅是无常苦空的心心所色声香味等，故云无我。
    心、心所、色等法和合假有的有情，已如上说无常一主宰的我性，而心、心所、色等法，亦唯是依他众缘所成，如幻缘生，只有虚假事相，亦无主宰自在的我性。然其虚假轨持体用，念念生起，相续流来，相似有坚实自性胜用，众生迷妄，不了解其依他缘生如幻，假有作用，即执为实有色声等法，起常一主宰自在的法我见。而实则一切法，无论心色，都是待缘而成，依他而起；一一作用，皆由互相资助，相依相待，显现存在，相似有一实体，实则坚实自性了不可得。要是诸法有坚实的自性，就不应该借缘而成，依他以起；应该是恒时常住，自力独存。但以常识的观察，道理的推征，圣教的印证，任何一法，无论为心为物，都无不是依赖他缘而存在者，缘聚以生，缘散则灭，决无常一主宰、自在不变的固性存在，所以诸法亦是无我的。
    五位法中，色心心所是实法，尚无我性存在，非色不相应行，既是心、心所、色三法的分位，更明显易知的不会有我性的存在了。无为法是诸法的真如实性，众生从无始以来即未触见过，更不会有众生计执的我性了。
    问：如上所说，一切诸法皆是虚假，无有主宰自在的我性，则诸法中应常无假实种种的差别，何以前说色心心所等法时，又言有实有假？答：此言虚假如幻如梦，乃推入真门空理而谈，若依世俗谛道理门说，自有种子所生诸法，多名为有为实法。此处唯就真门生理而言，皆名假法，故与前文依世俗谛道理门说有假有实全不相违。


七、五位唯识

    七、五位唯识
    既然五位百法都无人法二种我性，为何现见世间有诸有情，人畜等之形状宛然当眼？而五蕴法体，事相显然，色可见，声可闻，乃至识能分别了知，体性作用，一一显然存在。若全皆虚假，诸如人法相状作用等，都不应该存有，五位有法亦无可说了。解此疑惑，就须明了唯识的意义。所谓色心心所等是虚假幻有，无人法的我性，只是破除情计增益的二种我性实执，并不拨无色心心所等法依他缘生的作用。虽然人法的我体实性求不可得，但五蕴和合的假补特伽罗，与依他众缘所成，有虚假事相作用的法，却并非全无，都宛然存在。怎样存在的呢？就是假我假法，俱是依识所变。前文所说的五位百法，皆从有情自心现起。总要而言，从熏习与转变的两种道理，五位百法之总别相状，人法的作用，一切的一切，都显现起来了。所以五位百法虽然都无人法的我性，由唯识的熏习与转变的两种道理，而业果不亡，亦无紊乱，人法诸相的总别相状作用，宛然显现存在。而五位百法何以唯识呢？如《成唯识论》卷七说：（一）识言，总显一切有情各有八识，六位心所，所变相见，分位差别，及彼空理所显真如。识自相故，识相应故。（二）所变故；（三）分位故；（四）实性故。如是诸法，皆不离识，总立识名。’五位法中，第一位心法，是识的自相，自相即是自体。这就是说，八个心王是识自体相故以为唯识。第二位心所法，决不能离开心王单独存在，凡有心起，心所即起而与心王相应，助成心王分别缘境，所以心所是相应故以为唯识。第三位色法，为心王心所二种所变的相分。心王心所为能变，根尘等色为所变，故色法是识所变故以为唯识。第四位二十四不相应行法，是心、心所、色三种的分位，以此二十四法不能自起，借前心、心所、色三位差别假立故是分位。前三位法是实，此即假法，故不相应行是三分位故以为唯识。第五位无为法，是识实性，识性即真知。以真如为识性的别名，如《三十论》说：‘此诸法胜义，亦即是真如，常如其性故，即唯识实性。’所以无为是识实性故以为唯识。前文曾经说过，五位百法包括一切法尽。但五位百法如《成唯识论》所说，又皆不离识，故五位百法皆是唯识变现。
    总上所说五位百法，前四位为事相，后一位为理性，而五法事理皆不离识，故一切法唯识。列（表十九）如下：

    （表十九）
    如是一切法中，虽无人法的我性，以诸法归有为之王，一切皆唯识故，因果不乱，作受不失。了知一切法皆从自心现起，诸法如梦幻义忽然现前，则无始妄心忽改，实我法执速除，增益损减，一异等一切妄执，皆得止息，无分别智忽然现前，冥合一真法界理，而证得无生法忍，入圣者位，生如来家。


(一)五蕴名义

    第三节 蕴处界三科
    一、五蕴
    （一）五蕴名义
    前面所说的五位百法，在大小乘共通的法相名词的蕴、处、界三科里可以摄尽。因此在说了百法之后，说蕴等三科。这里先说五蕴。五蕴即色、受、想、行、识五聚有为法。有为是有造作、作为、生灭的意思。蕴是积聚义，即色等五法，都是因缘和合积聚，前灭后生，相续不断地显现生起；色法有形质的积聚，心心所等有分限的积聚。例如色法，已灭的过去色，未生的未来色，已生未谢的现在色，眼等五根的内色，色等五尘的外色，有对的粗色，无对的细色，不染污的胜色，染污的劣色，去来的远色，现前的近色，都是总略的积聚显现的差别。总摄这一切品类差别的色法，即说名为色蕴。如是受想行识，亦都具有这样的积聚义，所以色等五种总说为蕴。从这蕴的定义，就可以知道，五蕴不能够摄持无为法，因为无为法是恒常不变的，与蕴的积聚义不相符合，所以《俱舍论界品颂》说：‘蕴不摄无为，义不相应故。’但是，一切有为法，五蕴就可摄尽。前一聚色，摄尽了物质界；后四聚心法，摄尽了精神界。不相应行，是色心心所分位上假立的法，更无别体，即在色等法中所摄。所以五蕴这个名相，色括了有情世间和器世间，并且以蕴义肯定了一切有为法都是因缘和合积聚的显现。因此学佛的人，假若能够对于五蕴有清楚的了解，也就能够认识自己和世间的真相。


甲、色蕴

    （二）别释体用
    甲、色蕴
    色有变碍二义：变指一切物体的本质和现象都是时刻不停的在变动；碍指一切物质的体质互相障碍，如手与手碍，物与物碍；凡具有这质碍的东西，皆名之为色。由此可以知道，佛典中所说的色，不是专指青黄赤白等显色的色，而是概括了一切的物质。所以色之一字，把整个的物质界都摄尽了。同时变碍义，即简别了心心所不相应行和无为法，因为心心所等有变义而无碍义，无为法则变碍两义俱无，唯独色法变而有碍，所以变碍二义，是色法特有的定义。
    色蕴是什么？总括地说：就是四大种所造色。

    （表二十）
    （一）四大种是：地界、水界、火界、风界。地界以坚劲为体性，水界以流湿为体性，火界以温热为体性，风界以轻动为体性。界是能持义，即地等能持自相及所造色，令其相似相续不绝。大有四义：一为所依大，与一切所造色为所依处。二体性宽广大，地等四种，遍在一切色上，无一物而非所造。三形相大，大地大由，为地大的增盛；大江大海，为水大的增盛；猛焰赤火，为火大的增盛；疾猛大风，为风大的增盛。四起用大，地界能持，水界能摄，火界能熟，风界能长，乃至成坏世界，作用广大。地等具有这四种大义，所以各得大的名称。种是因义、类义。地等四大，能为生、依、立、持、养五因，起造众色，是为因义。种类各别不同，是为类义。《大乘法苑义林章》大种造色章说：‘虚空虽大，不能为因；内种子等，虽能为因，体相非大；所余诸法，非大非种；由此地等，亦大亦种，故名大种。’这是对于大种的四句分别，列（表二十）如上：
    这四大种，与我们通常所说的地水火风不同：四大种是起造一切色法的基本元素，常人的肉眼是看不见的，是身根所觉的一分触尘境界，以纯一的坚湿暖动为体性，略近于科学上所说的质力。通常看见的地水火风，不是纯一的坚湿暖动，而是一一之中都有坚湿暖动的体遍相入，属于所造的显色和形色，是眼根所见的色境，不过由地等各别的增盛而显现为地水火风的相状。四大是能造色，通常所见的地水等是所造色，两者的区别明显可知。
    四大种几识能缘呢？有三识能缘，即身识、同时意识、阿赖耶识。
    四大种普遍于五根五尘，由此可以大概地分为二类：一有执受大种，就是根身。二非执受大种，就是器界。这二类大种，贝通有漏无漏的依正二报，如佛有清净圆明的报身四大，和微妙庄严的净土四大。
    （二）所造色是：眼根、耳根、鼻根、舌根、身根、色、声、香、味、所触一分、及法处所摄色。这十一种色，皆是四大种起造而有，四大种是能造，十一色是所造，所以名为所造色。
    造是因义，由四大种为因，所造色生起，即摄在一处是造义。故《瑜伽师地论》五十四卷说：是同一处，摄持彼义，名之为造。四大种为因的意义有五种：[1]生因，即是起因。四大种一切时皆将带诸造色生起，一切造色若离开了大种，决不能单独生起。[2]依因，即是转因。一切所造色，以大种为依住，假若舍去了大种，就没有功能力量依据于别处而生起。[3]立因，即是随转因，一切造色，假若大种起了转异变坏的时候，也就随之而转异变坏；即所依的大种与能依的造色，损益安危是共同随转的。[4]持因，即是住因。一切所造色能够相似相续的生起不绝，是由大种摄持令住的力量，若大种不摄持令住，则一切造色当即间断。[5]养因，即是长因。由大种资养的功能，一切造色得以增长，造色由大种养而长，所以是养因。
    以上五种，即四大种具有的五种因力（皆依《对法论》），能起造诸色，所以得名四大种。这五种因力，虽然四大种完全具有，但诸所造色，却不必完全具足五因。
    所造色中的第一眼根，乃至第五身根的根，是增上义、出生义；即由眼等根为有力的增上，才能出生眼识等的了别作用。如草木等，由有所依托的根为主力，枝叶等才能生长；眼等根于眼等识的生起作用也是这样，所以名之为根。
    眼等五根，都是以四大种所造的清净色为体，是前五识的俱有不共所依根，（五识的俱有依有四种：即同境、分别、染净、根本，在识蕴中说。）所以名眼根乃至名身根。眼以照了为义，以色为境，为眼识的所依。耳以能闻为义，以声为境，为耳识的所依。鼻以能嗅为义，以香为境，为鼻识的所依。舌以能尝为义，以味为境，为舌识的所依。身是积聚义、依止义，（虽然根、大种、造色并皆积聚，但身根为彼等多法依止积聚其中，所以独得身名），以触为境，为身识的所依。
    根有两种：一净色根，二浮尘根。浮尘根，又名世俗根、粗色根、根依处，或名扶根尘。浮尘根浮露在外面，与外尘交接，如眼球、耳轮、鼻腔等的浮根四尘，及身根的四肢百骸都是，为有见有对的粗色。净色根，又名胜义根，体是殊胜微妙，无见有对的清净色。眼等五根，是属于净色根，体是不可见而有发识作用的清净色，是佛菩萨的天眼所见的境界。有这清净的色根，眼等识即生；没有这清净的色根，眼等识即不生。如眼根已坏的人，虽然浮尘根没有变异，也不能发起眼识的作用；故清净色根，为发识的主力。五净色根安住的情形，《广五蕴记》和《俱舍论》都说，舌身二根的净色周遍在所依的浮尘根处，眼耳鼻三根的净色，则于所依处一分安住。但是《对法》和《瑜伽》两论，则没有周遍和一分的简别。
    眼的差别有五种：一肉眼、二天眼、三慧眼、四法眼、五佛眼。五眼中的初二眼属于色蕴所摄，后三眼非蕴所摄；于中慧眼、法眼二种为无漏慧根，佛眼一种通于前四。这里所说的眼根即肉、天二眼。以上说眼等五根竟。

    （表二十一）
    第六、色，是眼根所对眼识所缘的境界。有显色、形色、表色三类。显色即青、黄、赤、白四种，是分明显现的色相，所以名为显色，是色的实体。形色即显色积聚的分位差别的长、短、方、圆、粗、细、高、下、正、不正、光、影、明、暗、云、烟、尘、雾、迥色、空一影色等二十种有比较对待的形状，所以名为形色。表色即有情的动作，是有所表示的，所以名为表色。这有取、舍、屈、伸、行、住、坐、卧八种。表色即显形的差别业用，离开了显形二色，并无别体。显形表三类色，又各通妙、不妙、俱相违三种，这是从诸色的共有相上而建立的三种色间。《对法》说青等诸色，由六因建立：一相故、二安立故、三损益故，四作所依故、五作相故、六庄严故。如（表二十一）：
    前表是依《杂集论》第一卷说青等二十五色，由六因相配建立而列。即彼论中说显色四、形色二十、表色一，共为二十五种，对于表色则未开说。若依《瑜伽师地论》第一卷两说中的后一说法，则开显色为十三种，即青等四色以外，加光等八种，及空一显色为九，共青等四总为十三。开形为十种，即长短等。开表为八，即取舍等。为了对于表色明显易知，故依《瑜伽》开表为八而列入表中。
    第七、声，是耳根所对，耳识所缘的境界，《对法论》说十一种声：即可意、不可意、俱相违，因受大种、因不受大种、因俱大种，世所共成、成所引、遍计所执，圣言所摄、非圣言所摄。因受大种等三，是从能发声的因上显其差别。受是执受，是有情的名称，非执受是无情的名称，具是通有情无情两种。执是摄持义，受是领觉义。心法是能执受，色法是所执受。由心法摄持的色法，在领纳受境的时候能生起苦乐感觉的大种为因发出来的声音，是为执受大种因声；如两手相击、说话歌唱等的声音。没有心法执受的色法为因发出来的声音，是为非执受大种因声：如树林流水等声音。由有执受的大种和没有执受的大种同时起用而发出来的声音，是为俱大种因声：如用手击鼓相桌等的声音。这声的分类多少，《五蕴论》、《显扬圣教论》、《瑜伽师地论》、《杂集论》各有不同。《五蕴论》唯说因受等三。《显扬》第一说声有九：可意等三、手击、扣弦、世俗、养命、宣法、谷响。《瑜伽》第一说有三类：初有十八，即螺、鼓、舞、歌、乐、戏、女、男、风林等，明了、不明了、有义、无义、下中上、江河等，斗争、喧杂、受持演说、论议决择。次类有三，即因受等。后类有三，即可意等。《对法》说十一声更以五种因相配显示其差别，这里依《对法》所说列表：（见表二十二）

    （表二十二）
    可意等三种，由境有胜劣，情有顺违，故成益成损；可意的益，不可意的损，俱则通于二种。因受等三，由发声的音大种别故，声成差别。世成等三，其言虽同，依人成别。或由人有别故亦成差。世所共成，就是世间所说的谛实非谛实语为世俗共所许故，名世所共成。成所引的成，是成满义，由诸圣共许的因而成起言说，名成所引。外道执心，称为遍计，因彼执心而起言说，名遍计起。这世所共成等三，即依世俗、胜义、有执而分。圣言等二，由情有顺违，言成差别。这里所说的圣以所言不虚，契实名圣，非是证果名圣。即圣言量，是可信的至实之言，故名圣言。非圣翻此可知。
    第八、香，是鼻根所对，鼻识所缘的境界。有好香、恶香、平等香、俱生香、和合香、变异香六种。通常以香为臭的对此气氛，实际说来，香亦摄臭，故说为恶香。所嗅的气味与鼻识结合的时候，对于五蕴有顺适的作用，是为好香；如沉麝等。所嗅的气味与鼻识结合的时候，对于五蕴身起违逆损害的作用，是为恶香；如腐秽的臭气等。若所嗅的气味与鼻识结合的时候，对于五蕴身没有利益和损害就是平等香；如块石等。俱生香即旃檀等，其香气与本质俱时生起，故名俱生香。和合香即由各种香料和合制成的线香末香等。变异香即水果变异成熟而增盛的气氛等。好恶等三，若依境说好益恶损，平等双非。若依情说，香臭具有益损的意义。前面所说的眼耳所取的色声二境，都是有空间距离而缘取其境，鼻舌身三识缘境的时候，都是合中取境，故说与鼻识结合而缘。关于香的建立，《瑜伽师地论》和《五蕴论》同举好香、恶香、俱非三种，《显扬》说略有二类，好恶等三，俱生等三，共为六种，与《对法》相同。《对法》立大种，如上所说，并以三因相配。列表如（表二十三）：

    （表二十三）
    这六种香，都是实有，经论中没有明文说香是假法故。问：好恶等三，摄法已尽，何须更立俱生等三呢？答：事类不同，安立初三种：起用时别，复立后三种。或将境就心，安立初三种：忘心说境，复立后三种。
    第九、味，是舌根所对，舌识所缘的境界。《对法论》立十二种：苦、醋、甘、辛、碱、淡、可意、不可意、俱相违、俱生、和合、变异，这十二种味，无文说假，故皆实有。《五蕴论》仅立苦醋等前六种，无有后六；《显扬圣教论》中有可意等后六，没有前六；《瑜伽论》第一卷立前九种，不立俱生等三。诸论这样不同的建立，并不相违，仅仅是总别的开合而已。苦醋等六种，是味的差别体相。可意等三种，是味上损益差别的共相。俱生等三种，是味上起用的差别相。总即别故，《五蕴论》不说后六种。别即总故，《显扬圣教论》不说初六种。总别义具，《瑜伽论》、不说俱生等三，可意等总已摄尽故。《对法》依有情、事相，起用时的差别，在可意等外，建立俱生等三种；总别周悉，最为无诤。并以三因相配建立，故十二种味，不增不减。列表如（表二十四）：

    （表二十四）
    第十、所触一分，是身根所对，身识所缘的境界。《对法》说二十二种：滑、涩、轻、重、软、暖、急、冷、饥、渴、饱、力、劣、闷、痒、黏、病、老、死、疲、怠、勇。触有二种：一能触、二所触。能触中又二：一触心所法，二能触身根。所触有二：一能造四大种，二所造触处。为了简别能触，故说所触。所触中有能造的地等四大，如前已说，这里唯是分辨所造的滑涩等，所以说言一分。这所触一分，《五蕴论》里，列滑性、涩性、重性、轻性、冷、饥、渴等七种。但有等字，若据《对法》，即等软暖等十五法，总为二十二种。《瑜伽论》第一及五十四、《显扬论》第一等，除一二法外，大体相同。（《瑜伽》第一增怯立二十三，五十四减暖急立二十，《显扬》第一立二十二，有暖无软。）《五蕴论》列七触名中，前四种安置性字，后三种则没有性字：《瑜伽》第一列名中，也是在滑、涩、重、轻、软五触后加性字，其余的则都无性字。《瑜伽》五十四卷摄决择分里举触的依因也是这样，《对法》列二十二触，则都没有性字。关于有性字无性字的道理，是因为滑涩等是从自性立名，以滑即性，故言滑性。涩性等准例可知。其余触法，皆从果上立名，所以不置性字。如《广五蕴论》说：‘暖欲为冷，触是冷因，此即于因立其果称……。欲食为饥，欲饮为渴，说亦如是。’这就是说，由内身有触力令欲暖，有触力令欲食，有触力令欲饮，所令的欲名冷饥渴；即能令的触从果为名，名冷饥渴。因为冷饥渴等相隐难知，若不约果以明其体，则无从显现，故以因从果而立触名。《对法论》以相故、摩故、称故、触故、执故、杂故、界不平等故、界平等故八因相配建立二十二触，《瑜伽》五十四卷摄决择分中说有诸触建立的依因十八种。这里共列如下（表二十五）：

    （表二十五）
    《瑜伽论》摄决择分所举的十八依因，是依大种六位差别而说，即一净不净位、二坚不坚位、三慢暖位、四和合位、五不平等位、六平等位。随其所应建立前触，不增不减。
    第十一、法处所摄色，是意根所对意识所缘的色。略有五种：（1）极略色、（2）极迥色、（3）受所行色、（4）遍计所起色、（5）自在所生色。这五种色，是意识的所缘境，在十二处中的法处所摄，故名法处所摄色。这里分别解释如下：
    （1）极略色：《对法论》说极微为体，即除迥色等余五色根五色境及四大种法处实色极微为性。极是至义、穷义，略有二义：一总义，总略众色分析至极微名极略色。二少义，分析眼等诸根色等诸境至极少处名极略色。略是总略，略色之极故不称极微，而称名极略。色即极略，或色之极略，故名极略色。
    （2）极迥色：《杂集论》说：‘即此离余碍触色。’以空界色极微为体。即于空界明暗色析至极微总名极迥，故迥色即明暗色，但非一切明暗色都是迥色，因为明暗色有两种：一空一显色，即在上的明暗，大虚空所现的明色。二迥色，即在下的明暗，屋宅等间所现的明暗色。
    （3）受所引色：《对法论》说：无表色为体。无表总有三种：一律仪无表，二不律仪无表，三非律仪非不律仪无表，皆以善恶思心所种子为体。律仪是善；不律仪是恶；非律仪非不律仪是处中无表，即若有布施或打击等是律仪不律仪所不摄业，皆是非律仪非不律仪所收。但其思心所种子即属于善恶类中，故没有别的处中无表的思心所种子。律仪无表总有三种：一别解脱无表，即七众别解脱戒。二定俱无表，即八等至俱有诸有漏戒。此亦名为静虑律仪，色界戒胜故以为名。三无漏无表，即等至俱有的诸无漏戒。律仪无表、不律仪无表、处中无表，都是依发动和防止身语善恶的思心所种子上建立的。这思心所的功能种子，本来不是色法，就它所发动和所防护的身语色边假说名色。思心所种子，是潜藏在心识中的功能。不能表示自己内心的善恶令他知故，所以名为无表。约不能表示善恶业与所发所防的身语色二义，总合说名无表色。这些无表，为受所引起。受是领受，引是引发，因教理或从师所领受其义，而引起发防身语色的思心所种子，是受之所引，故名受所引色。虽然定共戒、道共戒得不从他受，但约得定道的方便时亦从师教来说，亦名受所引。不律仪由自发誓定期，或从他受，皆是受所引。
    （4）遍计所起色：《杂集论》说是影像色，即散位独生意识，通三性能遍计度心所变的根尘而无根尘用，乃至水月镜像等境，没有实用的影像景色，就是遍计所起色的体。影像色境从能遍计度的意识所起，故名遍计所起色。
    （5）自在所生色：又名定果色，《杂集论》说以解脱静虑所行境色为体。解脱指四解脱，即四无色定。静虑即四静虑。即由殊胜的定力于一切境色皆得自在，随意转变色声香味触等境色生起。定通无拥滞障碍，若为自在，果色从彼定力生起，故名所生，所生即色、或自在之所生色，故名自在所生色。
    这五种色，前四皆假。极微无体，由现行者的智慧分析粗色至最细边际，建立极微，非为有体。如《瑜伽师地论》第三卷说：‘复次于色聚中，曾无极微生，若从自种生时，唯聚集生或细或中或大。又非极微集成色聚，但由觉慧分析诸色极量边际，分别假立以为极微。’故极略极迥两色俱是假有。据《成唯识论》说，无表是依思愿善恶分限假立，《成业论》也说依善恶二思种子未损坏位假立善恶律仪无表，故知受所行色亦是假有。遍计所起色是假无疑。定自在所生色，有实有假，圣者可变，皆能成实有用，极殊胜故。异生所变，唯令他见，不堪受用，故是假有。
    总上所说的四大种及大种所造的十一种色法，就是整个的色蕴。在《广五蕴论》中，把它总略起来摄为三种：一可见有对色，二不可见有对色，三不可见无对色。这里所说的可见不可见，是指眼所见的色法为可见，意识所缘为不可见。有对无对，是说有能所碍者为有对，非能所碍者为无对。可见有对的色法，即显色与一切的形色和表色。不可见有对，即眼耳等五胜义根，和声香味触。不可见无对，即法处所摄色。以《显扬圣教论》十八卷说法处色有十二相中，第三无见相等四无对相。又《瑜伽师地论》六十六卷：‘问：世尊说有无见无对色，当言何等大种所造？答：若彼定心思惟欲界有色诸法，影像生起，当言欲界大种所造。若彼定心思惟色界有色诸法，影像生起，当言色界大种所造。’由这答中明定果色大种所造差别，故知法处所摄色总是无见无对。


乙、受蕴

    乙、受蕴
    受是领纳义，这是一个领取纳受所缘境界的心所，能生起欣求的爱欲。在我们所缘的境界方面有与我们身心上相违、相顺和中庸的三种，所以能缘的心上也就生起了苦、乐、舍三种不同的感受。因此有苦乐舍三受的差别建立，是为三受门。即领纳相违境相逼迫身心，说名苦受；领纳相顺的境相适悦身心，说名乐受；领纳中庸境相对于身心非逼非悦，说名舍受。对于乐受未得的时候，有希望和合的爱欲，已得有不愿乖离的爱欲；于苦受未得的时候，有不愿会合的欲，已得时有乖离的欲：于舍受起不合不离的非二欲。
    诸论中又于苦乐两受里从所依根上分出忧受喜受，成为苦乐忧喜舍五受门。从苦乐中分出忧喜，根据《成唯识论》卷五所说有三个理由：一由逼悦身心的行相有所不同，逼悦于身上，说名苦受乐受；逼悦于心上，说名忧受喜受。二由无分别有分别的不同；即逼迫和适悦在前五识上，都没有随念分别和计度分别，说名为苦受乐受；逼迫和适悦在意识上是有分别的，说名为忧为喜。三由粗重轻微有差别，即在五识上的逼悦，都是粗重的。说名为苦为乐；在意识上的逼悦都是轻微的，说名为忧受喜受。
    为什么舍受不分为两种呢？因为非逼非悦的舍相在五识和六识上都没有差别，平等无异，所以不分。
    总起来说，三受是约领受义边建立的，五受是约从根生义边建立的。列表如（表二十六）：

    （表二十六）
    又《对法论》在建立受蕴门中，依四因、五位、七类的差别，总说二十七受。第一位和第一类有六种：即眼触所生受、耳触所生受、鼻触所生受、舌触所生受、身触所生受、意触所生受，这是约所依的根生义边来说的。第二位和第二类有三种：即苦受、乐受、舍受，这是约受的自体而说的。第三位和第三类有六种：即乐身受、苦身受、不苦不乐身受，这是依五识相应的关系来说的。乐心受、苦心受、不苦不乐心受，这是依意识相应的关系来说的。舍心受并包括七八二识。第四位有第四和第五两类。第四类三种：即乐有味受、苦有味受、不苦不乐有味受。味是贪着，有味受即自体爱相应的受。这是约攀缘自己内身起味着的染行相来说的。第五类有三种：即乐无味受、舌无味受、不苦不乐无味受。无味是无贪着，即自体爱不相应的受，这是约缘虑自己内身不起味着的清净行相来说的。第五位有第六和第七两类，第六类有三种：即乐依耽嗜受、苦依耽嗜受、不苦不乐依耽嗜受。耽嗜受是贪爱，耽嗜受即妙五欲爱相应的受。这是约缘外境欲尘生起杂染行相来说的。第七类有三种：即乐依出离受、苦依出离受、不苦不乐依出离受。出离是不贪爱、出离受即贪爱不相应受。这是约缘虑外境不生贪爱的清净行相来说的。
    总上五位七类共计二十七受，由四因建立，所以不增不减：（1）由所依故，建立第一位的六种，即约生起受的所依六根建立六受。（2）由自体故，建立第二位的三种，即依苦乐舍三受的行相类别显示受的自体。（3）由集所依故，建立第三位的六种，集是总揽义，总揽别法为一，故名为集。集五色根类，总名为身，集六七八三心根类，总名为心，从色心二种所依生起身心二受：即集色根所依建立乐苦舍三种身受，集无色根所依建立乐苦舍三种心受。（4）由杂染清净故，建立第四位的六种，和第五位的六种，染是有漏，清净是无漏。杂染与清净，各摄两门，杂染中摄第四位中的乐有味受等三种，和第五位中的乐依耽嗜受等三种；因为有味与耽嗜，俱是杂染行相，仅仅是从缘内身和外境的不同上分为两类，所以都在杂染门中所摄建立。清净中摄第四位的乐无味受等三种，和第五位中的乐依出离受等三种，因为无味与出离俱是清净行相，仅仅是从缘内身和外境的不同上分为二类，所以都在清净门中所摄建立。
这五位七类由四因建立的二十七受，又可总为八义：（1）约根生义说眼触所生受等六种，（2）约自体说苦等三种，（3）依五识身相应说乐身受等三种，（4）依意识身相应说乐心受等三种，（5）约缘内身染行相说乐有味受等三种，（6）约缘内身净行相说乐无味受等三种，（7）约缘外境染行相，说乐依耽嗜受等三种，（8）约缘外境净行相说乐依出离受等三种。（如列表二十七）

    （如列表二十七）


丙、想蕴

    丙、想蕴
    想是取像为性，能生起种种的言说为用。我们内心缘虑境界的时候，最初一刹那，并没有形相的感觉，由这想心所生起，才勾画出种种的相状：如色相、声相、香相、味相、触相、男相、女相、生相、异相、灭相等差别决定相。并且随其所见所闻所觉所知的相状而安立种种名言，起种种言说。
    总起来说，想有二种：（1）有相想，（2）无相想。
（1）有相想，就是能够取境界相状随起种种言说的一切想，具有明了和分别两种意义，所以名为有相。在这有相想里，又有种种差别，约所依根可以分为眼触所生想，乃至意触所生想等六种。约境界可以分为欲界想、色界想、空无边处想等的差别。
（2）无相想，就是能缘心上或所缘境上，缺明了或缺分别，或二种俱缺，是为无相想。这有三种：[1]不善言说想，如欲界的婴儿等，因未学语言，在缘色等境界的时候，虽然境界有相，但不能分别了解它为色等，故名无相想。[2]无相界定想，即远离色、声、香、味、触、男、女、生、异、灭十相的无相涅槃想，涅槃无相，缘涅槃的想，名无相想。并不是能缘彼境的相分没有，而是境无相，故名无相。与定相应，所以名无相定。[3]有顶想，顶是极义，三有之极，故名有顶。即非想非非想处定。有顶定虽有分别，想不明利，不能于境勾画种种相状，故名无相想。这里把有相想和无相想的差别，与明了分别的差别，列表如（表二十八）：

    （表二十八）
    《对法论》第一卷，在建立想蕴文中，详说诸想，述记根据《显扬圣教论》第五卷想蕴建立差别的，三位义配释，显示诸想的差别：第一位约所依差别，建立眼触所生想乃至意触所生想：第二位约作意差别，建立有相想和无相想；第三位约境界差别，建立小想、大想、无量想、无所有处想。如列表（见表二十九）

    （见表二十九）


丁、行蕴

    丁、行蕴
    在五十一个心所中，除去受想两个心所之外，其余相应的心所法和不相应行法，总集起来，都是行蕴所摄。行有迁流、造作两义：迁流义通一切有为法，一切有为法皆念念不住的在迁变流动着，故名为行。造作又约广义来说，亦通一切有为法，因为一切有为法皆是因缘造作而有故，若就特胜的造作义来说，即唯是思心所了。思以造作为相，能令心心所造作善染等故。诸论中说行蕴的体，有总别两种：总以一切相应的心所法和不相应行法为体，如《广五蕴论》说：‘云何行蕴：谓除受想，诸余心法及心不相应行。云何余心法？谓与心相应诸行。’即总相出体。别即以遍行中的思心所为主，在相应法中，思力最胜，与一切行为导首，能作令心法等成善染等：约以胜说，即以一思为行蕴之主，故诸论中据胜为论，以思为行蕴。如《对法论》等皆是。
    《对法论》在建立行蕴门中说：‘云何建立行蕴？谓六思身，眼触所生思，乃至意触所生思。由此思故，思作诸善，思作杂染，思作分位差别。又即此思，除受及想。与余心所有法，并心不相应行，总名行蕴。虽除受想一切心所有法及心不相应行皆行蕴相，然思最胜，与一切行为导首，是故遍说。’思作善即信等心所。杂即贪等烦恼和随烦恼，虽然思亦作令遍行等，因遍说性类，所以但说善染。又思亦能造作无记性，以无别体类，故论不说。分位差别，即不相应行。
《显扬圣教论》第五卷依三种差别建立行蕴：
（1）由胜差别，即取思心所为主，一切行中，思力最胜，作令心等成杂染清净法故。
（2）由依差别，即从眼等所依建立六思身，即眼触所生思，乃至意触所生思。
（3）由诸行施设差别，建立诸余相应法和不相应法。这施设差别有三种：[1]杂染施设，建立烦恼及随烦恼。[2]清净施设，建立信等十一法。[3]分位施设，建立二十四种不相应行。
《瑜伽论》五十三卷说行蕴自性，由五种类令心造作：‘一为境随与，二为彼合会，三为彼别离，四能发杂染业，五令心自在转。’
又五十三卷末说行蕴差别有五种：（1）由境界说六思身，（2）由分位说二十四不相应，（3）由杂染说根本烦恼及随烦恼，（4）由清净说信等十一法，（5）由造作说遍行别境等。如上《杂集》、《显扬》、《瑜伽》三处所说行蕴的体相和差别，完全一致。为了醒目，如列表（见表三十）：
    问：心所相应法及不相应法皆行蕴所摄，为什么唯除受想两个心所别建立为蕴？答：外道等计执受想二法为生死因，修八等至定，此受想二种殊胜故，—色界静虑有殊胜的喜、乐等，受相显了；三无色中取空等相，想相显了，所以别成二蕴。据理而论，受想两个心所，实亦由思作令成善染法，此约据胜为论，根据《俱舍论》的说法，受想二种别建为蕴，有三个理由：如《俱舍论》界品颂说：‘净根、生死因、及次第因故，于诸心所法，受想别为蕴。

    （表三十）
    （1）净根：净就是烦恼，根是根本，意说在家人对于五欲起贪等烦恼，都由有受心所；出家人起我执妄见，都由有想心所，起颠倒想；故受想二法为生起烦恼最胜的根，所以别立为蕴。
（2）生死因：生死是迷的结果，招引这迷果最胜的因，即受想心所；众生流转生死，即由于耽着受乐，生起倒想，故受想为流转生死的根本，所以别立为蕴。
（3）由次第：《俱舍论颂》说：‘随粗、染、器等，界别、次第生。’即由见色法已生起领受，由领受而生取像的想，由想而起造作行，乃至生诸了别。受想为领境取像的生造作行及了别识的主要过种的心所法，故特立为蕴。《俱舍论》文说：‘谓受与想，于诸行中，相粗、生染，类食、同助，二界中强，故别立蕴。’
    问：若据造作或迁流为行义，则其余的四蕴亦名为行，为什么唯行蕴独得行名呢？答：其余的四蕴，虽然也具行义，但摄行甚少，并且又各以特义别立蕴名，故不名行蕴；而行蕴摄行多故（七十三法）所以独得行名。
    行蕴所摄的四十九个心所相应法的体性业用，和二十四个不相应行法的意义，皆如五位百法中已释，这里就不再说了。


戊、识蕴

    戊、识蕴
    识是了别义，即于所缘境分别了达为性：有心、意、识三种名义的差别。这心意识三义，对于八个识来说，有通有别，通则三义皆通八识，如《二十唯识论》说：‘心意识了，名之差别。’别则唯第八名心，第七名意，前六名识，如《成唯识论》第五卷说：‘集起名心，思量名意，了别名识，是三差别；如是三义，虽通八识，而随胜显。第八名心，集诸法种，起诸法故；第七名意，缘藏识等恒审思量为我等故：余六名识，于六别境，粗动间断，了别转故。’名义差别，已如五位百法第一心法中辨释，这里不再重说。
    在这识蕴中略述十二义如下：
    （一）得名：识的差别有八种：一眼识，二耳识，三鼻识，四舌识，五身识，六意识，七末那识，八阿赖耶识。眼等六识，都是从所依的根得名眼识，乃至得名意识。第七末那，译言为意，是思量义，因为这恒与我痴、我见、我慢、我爱四惑相应，思量第八见分为自内我，所以得名末那，是从相应立号。第八阿赖耶，译言为藏，具有能藏、所藏、执藏三义，这是第八识的当体功能，所以得名阿赖耶，是从功能受称。又八个识中，唯第八阿赖耶得名根本识，如树之根，为枝干花叶等所依的根本。第八识为心系的总主，为一切法的种现所依处，所以独得名根本识。前七种识，则名转识，因为前七识的体性都不能如第八识之一切时处（除已转依位）恒常无记，而有三受故转，三性转变，缘境转易，所以总得名转识。
    （二）所依：八识在生起现行作用的时候，都有所依，所依就是依止、仗托的东西。所依总有三种：
    （1）因缘依，即种子依，体即亲生自体现行作用的种子，这是心心所法各自熏在阿赖耶识中的功能势力，一切心心所法，离去了这亲因缘种，就决定不能生起现行作用。因为这种子是生起体用的亲切力量，所以名为因缘依。
    （2）增上缘依，即俱有依，眼根等内之处，一切心心所法，皆必须凭托这个所依，才能生起现行作用，离去了俱有所依，必不生起。俱有依，即能依所依俱时而有的意思。前五识的俱有所依，决定有四种：[1]同境依，就是眼等五色根。这五色根与眼等五识同取现境，即眼识依眼根同取色境，乃至身识依身根同取触境，所以得名同境依。[2]分别依，即第六意识。眼等五识，只有自性分别，缘境的时候，不能明了分别，深取所缘相，必由五俱意识助令五识明了取境，故第六意识，是前五识的分别依。[3]染净依，即第七识。五识的行相浅，没有计执，所以五识本身无染，由受第七识的染污而成有漏；若第七识究竟清净时，前五识亦转为成所作智而成无漏，所以第七识是前五识的染净依。[4]根本依，即第八识。第八识恒常不断地相续现起，为诸心心所生起现行根本，故第八识是前五识的根本依。四种俱有所依中，前第一种是不共依，即眼识唯依眼根，乃至意识唯依意根，所以得名不共；后三种是前五识的共同所依，故名共依。第六意识得俱有所依只有两种：即第七识及第八识，第七识是不共依，第八识是共依。前面说五识亦以第七为染净依，又第八识亦以第七为俱有依，怎么说第七是第六的不共依呢？这是因为第六依第七，具有亲近和相顺两义，前五识和第八识之依第七，就不具足这两种意义。近是亲近，即第六识生起现行作用的时候，由第七识给与殊胜的增上力量，如眼等识之依眼等根，故第七是第六亲近的所依根。非如眼等识之依第七是疏运的所依。相顺是有漏无漏相同随顺，就是第七有漏的时候，第六决定是有漏，第七转成无漏时，第六亦决定转成无漏。第八虽以第七为俱有依，但第八识则不与第七同起计度，故没有相顺的意义。第六依第七俱这亲近和相顺两义，所以是不共的俱有所依。第七末那的俱有依，只有一种，即第八识，假若没有阿赖耶识，末那决不能生起作用，第六识间断对于第七之生起，不能给与力量故。如《楞伽经》第九说：‘阿赖耶识为依，故有末那转，依止心及意，余转识得生。’第八识的俱有依，也只一种，即第七识，第七末那常时相续，所以对于第八的生起能给与力量，这就是七八二识更互为俱有依的意义。所以《瑜伽论》说，藏识恒与末那俱时而转。
    （3）等无间缘依，即开导依，体即无间灭意，就是八个识各各前念的自识。诸心心法生起，皆须仗托这个所依，离去开导依，决不能生起现用。开是开避或离开，就是让出空位的处所；导是引导令生，即前念心法谢灭下去，当体即让出了后念心心所生起来的道路，后念心心所依着这空隙无阻的道路生起现行作用。假若前念心不灭，则后念心心所决无生起之可能，所以一切心心所法，离去开导依，决不能生起作用来。
    总上所说，八识各有一因缘依，离了亲办自体作用的功能种子，决不生起故。俱有依前五识有四种，即同境、分别、染净、根本四种所依。第六意识有二种，即第七第八。七八二识各有一种，即二识更互为依。等无间缘依，各有一种，即前念谢灭的意。《枢要》总摄所依颂说：‘五四六有二，七八一俱依；及开导因缘，一一皆增二。’列表如（表三十一）：

    （表三十一）
    （三）缘境：八识从三种所依生起现用，对于所缘的境界，各有宽狭。眼缘色，乃至意缘法，第七缘第八，第八缘三类境。眼缘色境，是缘青黄赤白等显色，不缘长短方圆等形色。以前五识任运起，唯缘五尘实法，不缘假法故。耳缘声境，唯缘径直声，不缘屈曲，屈曲是声波上的转折假法故。鼻缘香境，缘好香、恶香、俱生香、和合香等。舌缘味境，即缘甘、辛、苦、醋等。身缘触境，即冷、暖、滑、涩等。第六意识具自性、随念、计度等一切分别了别识中最为胜故，能缘一切境界，色心过未有无假实等法，没有不能缘虑的。第七末那缘第八识见分，恒常无间地执为自内我，不缘相分识中种子及相应法以为我所，我我所执不俱起故；以此识俱萨迦耶见任运一类恒相续生，无容别起我所执故。第八识缘三类境：一有根身，二器世界，三种子。有根身，是指诸大种造色等合聚名身，或依止义名身，根即净色及根依处，有根的身，名有根身。器世界即有情所依的世界，如器具为事物的所依，故世界名器。种子即第八识中保藏的一切亲生自果的功能，这功能遇缘和合能起现行作用，如世间豆麦等种，遇着水土阳光等助缘，即能生起苗芽等作用，内识功能也是这样，从譬喻得名，故名种子。第八识缘这三类境，是于境生起执受。执有摄持两义：一摄为自体，二持令不坏。受有领觉二义：一领以为境，二令生觉受。第八识在缘种子方面，具有执的两义，即摄为自体，持令不坏；具有受的一义，即领以为境。第八识在缘根身方面，则四义具足。在前三义上，更加令生觉受。第八识在缘器世界方面，于执受中各具一义：执一义即但持令不坏，受一义即但领以为境。这是第八识缘三类境的差别意义。列表如（表三十二）：

    （表三十二）
    （四）生缘：八识生起现行作用依托的因缘等可依，与缘虑的境界，及协助生起了别的作意等，通称为识的生缘。由于诸识行相有粗细、缘内缘外、间断不间断等的不同，因此借助的生缘也就有多少的差别。眼识现行，若依肉眼来说，必须具足九缘才能生起：即空、明、根、境、作意、根本、染净、分别、种子。空就是眼识，缘色境时必有的一定的距离的空间，明就是光明，根即净色根，境即色尘，作意即遍行中警动眼识在遇缘时生起了别用的心所，根本即根本依第八识，染净即染净依第七末那，分别即分别依第六意识，种子即亲生眼识自体的功能。在这九个缘中，任随缺少一种，眼识就不能生起作用。若依天眼来说，则除空明两缘，虽有墙壁等障，和黑暗之中，因天眼的视力特殊，仍然彻见无碍。耳识从八缘生，在前九缘中，除去光明。鼻、舌、身三识，依七缘生，在前九缘中除去空和明两种。第六识依五缘生，即根、境、作意、根本、种子。根就是俱有依第七末那，亦即是第六识的染净依，摄染净于俱有根中，故略去不说。七八二识从四缘生：即俱有根、所缘境、作意、能生种子。这七八二识都不说根本依，因为在第七识望第八识来说，第八就是第七亲近的俱有依，在第八识来说，根本依就是它的自体，所以七八二识也就不必再立根本依了。
    （五）心所相应：八识心王生起缘境用的同时，还有很多心所生起来帮助它了别所缘境相的差别部分。因为心王在缘境的作用上，只能取境的总体相，而心所则取境的总相和差别的义相，能帮助心王于所取境相完成了别总体和差别的任务。所以心王生起，同时必有很多心所生起，这叫做王所相应。相应就和合俱转，即心所与心具四平等义，非定一异，故成相应。就是时间、所依、所缘、体事四义平等：（1）时间平等，即一聚心王心所必同一刹那俱起，才得名相应，这就简去王所虽同一聚，但在时间上是前后相望，则不名相应。（2）所依平等，即王所必依于同一的俱有依和等无间缘依，方得名相应。若不同一所依，如异识的王所相望，便非相应。（3）所缘平等，就是一聚王所的所缘相分虽各有其体，但是其相分必是相似的，方得名相应。简除那不相似的相分和别异的见分，不名相应。（4）体事平等，体事即自证分，就是王所各一自体相似，得名相应。简别体，虽具上三义，也不名相应。上四义中，前二义是同一平等，后二义是相似平等，故《成唯识论》说，时依同所缘事等，名相应义。
    八识相应的心所各有多少呢？第八识唯与遍行五所相应。为什么不与别境等心所相应呢？因为互相违逆，所以不能相应。如《成唯识论》卷三说：欲是希望，于所爱乐的事相上起，第八任运缘境，无所欣求。胜解是印持，于决定的事相上起，第八识的行相懵昧，境非先不定，故不需印持。念唯明记曾所经过的事，第八识昧劣，恒缘任运现在境相，不能明记曾所受境。定能令心专注一境，第八任运，随业转起，刹那别缘新起境相，并非一境专注。慧唯简择功德过失俱非的事理，第八行相，微细昧劣，不能简择。所以第八识不与别境心所相应。第八识唯是异熟无覆无记性，故信等十一个善心所，贪等二十六个染污心所，都不相应。恶作等四个心所，虽有无记性分，但非一切时常起，有间断故，亦定不相应。
    第七识与十八个心所相应：即我痴、我见、我慢、我爱四惑，遍行五数，八大随烦恼，并别境中的慧。我痴即无明，愚于我相，迷无我理。我见即我执，于非我法，妄计为我。我慢就是倨傲，倚恃所执的我，令心高举。我爱即我贪，于所执我，深生耽着。根本烦恼有十种，为什么只有四种相应呢？如《成唯识论》四卷说：有了我见，其余的四见不生，因为见是从染慧为体，在同一心中，不能容许有两慧并生。为什么第七于五见中唯有我见呢？五见中的见取和戒禁取及邪见，是分别心生，唯见道所断，这第七识相应的烦恼，唯是任运俱生，是修道所断故。我所见及边见都是依有我见以后生起来的，第七相应的我见，任运恒缘，内相续生，不假借边见等后起。前二通缘内外，第七恒内执我，无有间断，不容余见互相续起，故唯有我见。为什么不与疑和嗔相应呢？由见力审决，疑行犹豫，两相乖返，故无容俱起。爱着我故，嗔慧不生。故第七识在根本烦恼中，唯具四种。遍行五所，凡有心起，皆定相应，八大随惑，遍诸染心，有覆末那，是染污心，所以相应。我见虽是别境慧摄，由义差别故开为二：慧是别境，通三性九地。见唯染污，通九地等，有宽狭义别，故得俱起。为什么第七识不与别境四、十小随惑、中二随惑、不定四所相应呢？因为：别境中欲，希望未遂合事，第七任运缘遂合境，故无有欲。胜解印持曾未定境，第七无始以来，皆恒缘定事，故无胜解。念唯记忆曾所更事，第七恒缘现前所领受境，无所记忆，故无有念。定唯系心专注一境，第七任运刹那别缘，故无有定。信等十一善心所，唯是清净，第七染污，故不相应。十小随惑，行相粗动，第七审细，故非相应。无惭、无愧，唯是不善，第七无记，故不俱起。四种不定：恶作追悔先所造业，第七任运恒缘现境，非悔先业，故无恶作。睡眠必依身上沉重昏昧的内缘，和光暗风凉等外缘，有时暂起，第七无始一类内执，不借外缘，故无睡眠。寻伺俱依外缘事暂浅深推度，引起粗细发言，第七唯依内门转起，一类执我，所以不有。
    第六意识，体通三性，具一切分别，遍缘内外三世一切诸法，故与五十一个心所皆得相应。
    眼等五识，与三十四个心所相应：即遍行五、别境五、善十一、根本惑中贪、嗔、痴三、中二随惑、和八大随烦恼。五识为什么不与其余的心所相应呢？因为根本惑中的慢、疑、恶见，必由随念、计度二种分别才能生起，五识只有自性分别，所以不俱。又慢是观待自他，由称量门起，疑是于犹豫简择门起，恶见是于推求门起，五识没有这些行相，故皆不相应。小十随惑，行相粗猛，五识望彼则细，故不俱起。悔眠二所，都是由强思加行才能生起，不是任运现行，五识任运现起，故不相应。寻伺两法，皆以名身等为所缘境，五识不缘名等假法，所以亦不相应。
    上来所说的八识相应的心所，皆约有漏因位中说，若在无果位，转八识成智，唯是善性，一切心起皆与二十一个心所相应，即遍行五、别境五、善十一。为什么有遍行五？触等与一切心恒相应故。为什么有别境五？常乐证知所观境故有欲，于所观境恒印持故有胜解，于曾习境恒明记故有念，世尊无不定心故有定，于一切法常决择故有慧。为什么有善十一？极净信等常相应故。何故不与贪相应：无染污故。为什么不与不定四相应？无散动故。所以佛果位上，唯二十一所相应。若未至究竟佛果的菩萨和二乘圣者，在教化众生时，对于能治病的法药、和所治的病，未能遍知，后得智中为他说法，必假寻伺，所以有无漏寻伺，这样通无漏的心所则有二十三个。但在佛果位上一切心行皆无功用，不假寻伺，故无漏心所就唯有二十一个了。
    （六）四分：一切心心所法，都有四分：一相分，二见分，三自证分，四证自证分。分是分量、分限，心用分限有四种差别，故名四分。
    相是相状，所缘为义。即能缘心自体转变起用的时候，无记缘心法、色法、有法、无法，一切皆有相分，以能缘心必定转变起所缘用的相分才能缘虑散；纵缘于心，亦以心为相分，其相分心，亦唯是所缘，决不能起能缘的作用。相分若是相状义，缘青黄长短等显形色时，可以有形貌相状，怎么说一切皆有相分呢？因为法的相状有多义，并不限于青黄长短等显形的色相，如声尘有执受非执受、可意不可意等相状，香尘有好香恶香等相状，味尘有廿辛苦醋等相状，触尘有坚湿滑涩等相状，法尘随其所应有色心等相状，第七缘第八见分常带我法二执相状，第八缘根身器界种子，皆各带其相状，如镜照物，自体上带影相起，心心所起缘虑用时也是这样，故诸心体转变起用缘境之时，一切皆有相分。问：缘有体法时可许有相分，缘无体法怎么会有相分呢？答：有漏散心缘无法，必是强有力的分别心，分别强故，自变似无的影相，其相即是相分，即有似无的相状。问：正智缘真知，既是绝诸思虑，智境冥合，亦有相分吗：又后二分相缘的时候亦有相分吗？
    答：正智缘如，并后二分相缘的时候，皆不变相分，不离自法，即自体性故。
    见是见照，能缘为义，即心自体转变起来的能缘作用。明了见照前境相分，名之为见。
    自语是心的自体，是见相二的所依，能缘见分；见分是心体的自能缘用，自体分极为明净，能证知自能缘见分外照的作用，故名自证分。
    证自证是心自体暂变能起知自体的作用；第三分是心的体用。名为自证，这第四分能证知它，所以名为证自证分。
    这四分中，第一分唯是所缘，第二分唯缘第一相分，第三分能缘第二第四，第四唯缘第三；此中有所量、能量、量果义别。譬如有人用尺量布，布为所量，尺为能量，了解尺数的智慧为量的结果。心体起用缘色等境也是这样，色等相分为所量，见分为能量，自证分为量果，自证缘见之不错，又以第四证自证分为量果。第四分心性明净，能够证知自体用，名证自证分；若无第四，第三即无量果，则知自证分不为满足，故必有第四证自证分。假若以为第三分须有证知的量果而有第四分，那末第四分亦应有量果而建立第五分的话，这是不需要的。因为后二分纯是现量，功能相同，可互证知，故第四分缘第三分的时候，即以所缘的第三分为量果，所以不必更立第五分了。
    四分的建立，是就识的义用而分，非是约体立名，若欲勉强指其体，则唯有自证分可以称为用中的体。四分之中，前二分是外，后二分是内。第一分唯是所缘，后三分通能所缘。即第二但缘第一，通现量、比量、非量。一～五八识的见分，一向是现量；第七识的见分，一向是非量；第六识的见分，则通于现量、比量、非量。第三能缘第二分和第四分，证自证分，唯缘第三，不缘第二，以无用故。第三第四，皆唯现量。如是四分，或摄为三，第四摄入自证分，果体一故。或摄为一，后三分俱是能缘性，皆见分摄。或摄为一，体无别故。
    这四分对于八识怎样分别呢？八识及一切心所，一一皆具有四分，如眼识起用缘境，即转变起青黄等色为相分，了知青等的作用为见分，知这见之用的为自证分，证知自证分之用的为证自证分，而自证分还知此证自证分。如是耳识变声为相分，鼻识舌识身识，如其次第变香味触为相分，意识随时变一切法为相分，末那识变阿赖耶识的见分为相分，阿赖耶识变根身器界种子为相分。后三行皆如眼识可以准知。八识相应的心所，亦皆如心王各具四分。
    佛果位上的四分怎样呢？佛果位的诸心心所，皆是纯无漏清净性，亦皆具足四分，四分都是无漏清净，后三分皆唯现量，更没有比量非量的见分了。相见等的名义与因位无别，但缘虑的作用，有两种说法：（1）说三通缘三。即后三一一分皆通缘其余的三分；见分通缘相分、自证分、证自证分；自证分通缘相分、见分、证自证分；证自证分通缘相分、见分、自证分。（2）说三通缘四，即后三分一一分通缘四分，即于前说通缘三外更加能缘分还缘自义，故皆缘四。
    （七）受俱：苦、乐、忧、喜、舍五受之中，第八识唯与舍受相应，根据《成唯识》第三卷所说：有七种意义：（1）第八行相极不明了，是舍受相；若苦乐等受，必是明了故。（2）第八不能分别顺违境相，取中庸境，是舍受相；若是余受，应取顺违境故。（3）第八行相微细，若是余受，行相必粗。（4）第八行相一类，即三受不易，三性不易，境界不易，相续不易，故行相决定；若是余受，必是易脱。（5）第八相续而转，若是余受，必有间断。（6）第八是真异熟，随先业引转，不待现缘，任随善恶业势力转起；若苦乐受，是异熟生，非真异熟，待现缘而起，故非第八相应。（7）第八识，常无转变；有情恒时执为自内我，若与苦乐二受相应，便有转变，岂能执为自内的我？由上七义，故知第八唯与舍受相应，第七识亦唯与舍受相应。这有两个理由，如《成唯识论》卷五说：一由任运，即第七识行相任运恒转。二由一类，即恒常唯缘第八见分一类内境，执为自我，没有转易，故唯是舍受。若与余受俱起，则非任运，以须借待现缘起故；亦有变异，以有易脱故。第六意识与五受相应，亦如前论卷五所说：一切逼迫受与意识俱起的，于人天中恒常名之为忧，以非尤重故。若在傍生鬼界，则名忧名苦，杂受苦处与纯受苦处的逼迫有轻重故，捺落迦中唯名为苦，是纯受苦处，其苦尤重，无分别故。诸适悦受与意识俱起的，若在欲界和初二静虑近分定，唯名为喜，但悦心故。若在初二静虑根本定中，则名乐名喜，适悦身心故。若在第三静虑的近分定和根本定中，则皆名为乐，以其适悦安静尤重及无分别故。舍受与意识相应，通在三界。若第三静虑意识唯于末位舍受相应，余位无舍，是纯乐地故。捺那迦中意识，唯于末位舍受相应，《对法论》等说嗔于末位与舍俱故。或无有舍，唯苦相应。眼等五识与苦乐舍三受相应，以缘境易脱（间断转变）不定（欣戚舍行互相引起），皆容与三受相应。
    （八）二执：二执就是我执和法执。
于诸我执，略有二种：（1）俱生我执，（2）分别我执。（1）俱生我执：无始时来，虚妄分别重习内因力故，恒与有情身心俱时而生，不待邪教及邪分别任运转起，故名俱生。这有两种：[1]常相续。在第七识中，缘第八识见分为本质。生起自心影相执为实我。[2]有间断。在第六识中，缘第八识所变五取蕴相为本质，或总缘虑，或别缘虑，生起自心影相，执为实我。这两种我执，无始串习，体相微隐，细故难断，见道以后的修道位中，数数不断地修习胜生空观，才能除灭。（2）分别我执：内缘必借亦由现在外缘力故，非是与身恒常俱时而有，要借邪教及邪分别，然后才能现起，故名分别，唯在第六意识中有。这也有两种：[1]缘邪教所说蕴相，起自心相，分别计度，执为实我。就是‘即蕴计我’二十句等。[2]缘邪教所说我相，以名教为本质，起自心相，分别计度执为实我。就是离蕴计我的诸执。这两种我执，望俱生我执来说，行相粗猛，粗故易断，最初真见道时，观一切生空真如，即能除灭。
于诸法执，略有二种：（1）俱生，（2）分别。（1）俱生法执：无始时来，虚妄熏习内因力故，恒与身俱，不持邪教及邪分别，任运而转，故名俱生。这亦有两种：[1]常相续。在第七识，缘第八识，起自心相执为实法。[2]有间断。在第六识，缘识所变蕴处界相，或总缘或别缘，起自心相，执为实法。此二法执，细故难断，见道以后的十地位中，数数修习胜法空观，才能除灭。（2）分别法执：内缘必借亦由现在外缘力故，非与身俱，要待邪教及邪分别，然后才能现起，故名分别。唯在第六意识中有。这亦有两种：[1]缘邪教所说蕴处界相，起自心相，分别计度，执为实法。[2]缘邪教所说自性等相，起自心相，分别计度，执为实法。此二法执，粗故易断，人初地时，观一切法，法空真如，即能除灭。
    上面所说的我法二执，都是在第六七心品中。眼等五识，和第八识，则没有二执。这有三个理由：（1）我法二执，是能遍计度的计度分别，五八识既然没有计度分别，故不起执。因为《摄大乘论》说唯意识是能计度有分别故（意及意识俱名意识）。（2）执我法者，必由有慧，第八不与慧俱，五识虽与慧俱，但任运缘，无计度故。又非恒常与慧相应，岂能容许有执。（3）二执必与无明相应，第八没有无明，前五识中善性不与无明相应，性相违故，如痴与无痴等，不可俱起。问：五八既然没有计度分别，则后识生时应无我法之相？答：若然没有计度分别，则后识生时应无我法之相？答：若约分别，五八可得无我法相，但由无始以来第六七识生时横计我法，种种分别熏习力所染，五八生时亦带似我法相，但这是有见相二分似六七识的我法相见，非是起二执名似我法相，具如《了义灯》所辨。列表如（表三十三）：

    （表三十三）
    （九）三性：这里说八识在善恶无记三性之中各属于何性，先说善等三性的意义：（1）善性：若法能为此世他世顺益的，是名为善。即招感可爱果的性，如受持五戒十善等，今世顺益，后世亦益，便得乐果，为人天所仰，是为有漏善。无漏有为法和无为法，于此世他世都是违越生死，有得有证，及由涅槃获得二世利益，是为无漏善。已得的人天乐果，虽然对于此世能为随顺的利益，极尽即完，唯益一世，非益二世，故不名为善；因为它是无记的果法，当体并不是善，于后世中亦作衰损故。（2）不善：若法能为此世他世违损的，是名不善。即招感非可爱果的法，如杀生偷盗等业，对于今世后世皆能违损，俱得苦果，所以非善。已得的恶趣苦果，虽然对于此世能为违损而令身苦根尽即完，不能违损于他世，故非不善，但是无记的苦果。问：修行布施波罗蜜多，财物尽时，有饥寒等苦，从什么理由说顺益二世呢？作不善的人现前得到享受，从什么理由说违损二世呢？答：益指的意义，亦约他处而言有益有损，不唯约自己来说，故益损义二世得成（3）无记：若法体非殊胜，不能招感可爱果或非可爱果，于善不善益损的意义中不可记别为善为恶，故名无记。无记有两类：[1]有覆无记，[2]无覆无记。覆是障蔽义，即染污法能覆障无漏圣道不生，及能覆蔽心心所令不清净，故名为覆。若法其性染污而不是善恶，就是有覆无记。若法体性不是染污，亦非善恶，即名无覆无记。这有四种：即异熟、威仪、工巧、及变化心。
    第八识是无覆无记，因为第八是善恶业所招的真异熟果，异熟若是善恶法，则流转还灭皆不能成立；以善趣既然是善，就应当不生不善，这样恒常生善故，即没有流转可说了，由集故生死流，由苦故生死转的杂染因果就不能建立，恶趣反面的为难也是这样，既然恶趣是恶，就应当恒时不能生善，则永无还灭可说。由道故还，由灭故灭的清净因果也就不能建立了。又第八识是善染法的所依，若体是善染，则互相违逆，应当不为善染二法的所依。又第八识是所熏性故，若体性是善染如极香极臭的物体应不受熏。无熏习故，染净因果都不能成立了。故第八体性，唯是无覆无记。第七识是有覆无记，因为末那恒与四惑相应，四惑是染污法，覆蔽圣道无漏智不起，使自心不得清净，故是有覆；但末那的行相微细，任运转起，不障善故，遍三性故，非善不善，故是无记。前六转识，遍三性心起，与信等十一心所相应，是善性摄，与无惭等十法相应，不善性摄，俱不相应，无记性摄。故前六转识，体通三性。若在果位，则诸识皆唯无漏善性了。
    （十）界系：在八个识中，鼻舌两识，唯在欲界所系，不通上界；因为鼻舌二识，以香味为所缘境，唯欲界中有段食有香味，初禅以上，已离段食，无复香味，二识缺境无用，故唯在欲界中有。眼耳身三识，唯在欲界及初禅，因为二禅以上，已离寻伺，不取外境，三识没有用处，所以无有。故二禅以上五识皆无。后三识则沩通三界而有，七八二识随其生在那一界就决定为那一界所系，第六意识则下可起上，上可起下，是其差别。
    （十一）起灭：眼等五识，唯缘色等外境，数数转易，行相粗动，而所借的众缘，又在很多时候都不具足，所以生起现行的时候少，不起现行的时候多。由于所借外缘在和合上有顿有渐，故眼等五识，起五、四、三、二、一识生，或俱起不俱起，没有决定。第六意识，于内外两门转，虽然亦是粗动，但以缘内事理等亦有细相，所借缘少，无时不具，唯除五位，常能现起。故间断的时候少，生起的时候多。五位即五无心位，是第六识的违缘：（1）无想天：就是修习无想定的人，由厌粗动想的力量，死后生在第四禅的第三广果天中，不恒行的心心所法皆不现行，以想灭为首，名无想天。除其最初生时及命终位，中间位上前六转识皆不现行，故第六意识在这一位上不起现用。（2）无想定：就是入无想定的人，由彼厌心定力不恒行的心心所法皆灭不起，故第六意识在这个定中不能生起。（3）灭尽定：即定慧俱解脱的无学，和第三果位的有学圣人，已经伏灭或断尽了无所有处的贪惑，上面有顶天的贪断与未断皆可，依有顶游观无漏为加行，由止息想的作意为先，令不恒行与恒行的染污心心所皆灭，所以得名灭尽定，第六意识在这定位中，不起现行。（4）无心睡眠，就是极重的睡眠。（5）无心闷绝，就是极重的闷绝。这两个位中，俱违令前六转识不得现行，故第六识不能生起。上述的五位，是约不恒行的心心所和恒行的染污心心所来说，总名五无心位。所以《唯识三十颂》说：‘意识常现起，除生无想天，及无心二定，睡眠与闷绝。’第七识和第八识，行相微细，所借的生缘，一切时候都具足无缺，所以没有违缘碍令总不现起。三位无末那，虽然灭掉第七的染污一分不起，但并不是总灭全无，所以不同第六识以粗动故为违缘总碍不起。
    （十二）无漏：八个识在什么时位上它的体才能转成无漏呢：这有因位转和果位转的不同：六七二识是在因位改转，五识八识必须在佛果中才能转成无漏。第六意识，在证初地真见道时，转成妙观察智，善观诸法的自相共相，无碍而转，说法断疑，令一切有情皆能获得利乐。但在出观位中，有漏意识，还忧生起，因为俱生的我法二执未断，犹时现行，故无漏智不能无间一味地相续，必须至第八不动地无相无功用住，无分别智任运相续现起，有漏意识才永灭不生，而成为纯无漏体。第七识在第六识转成无漏的同时，由第六意识于真见道位具证二空真如的观智，势力强盛，阻碍了第七的我法二执不能现行。因此第七无漏净识与第六无漏同时发起，而得名平等性智。观一切法及自他有情悉皆平等，慈悲等德恒共相应随诸有情所乐示现受用身土影像差别。由观诸法及有情平等，故名平等性智。这第七识也是在未得无相无功用行位以前，我执犹得现起，出真观位，智不相续，有漏复生，到了第八地无相无功用住，我执执力才永灭不起，但法执犹可现行，必入金刚无间道时，二障种子永断，然后无漏第七平等性智才能长时相续无穷无尽。第八异熟识为染净法之所依，在未成佛以前，均为世间三业所招感，故名异熟识。必至金刚道永断世间二障随眠已，于解脱道亦舍世间善无记种，和劣无漏法，即有大圆镜智同时发起，能遍身土智影，无忘无失，而成一切智智。如大圆镜。


(三)五蕴与百法相摄

    （三）五蕴与百法相摄
    不起一切加行，而能显现众色影像，从喻立号，故名大圆镜智。故第八识，要在成佛的果位上才能转成无漏。在第八转成大圆镜智的同时，前五识亦得转为成所作智。为什么五识转成无漏必须与第八转智同时呢？因为五识必依五根才能起用，五根因位唯是有漏、以是异熟识之所变故，异熟能变识是有漏，所变的根亦决定唯是有漏。所依根既是有漏，能依识亦决定是有漏，以有漏根发无漏识理不相应故，识有漏故，无漏的成所作智不起。所以必待异熟能变识体转成无漏而变起无漏的五根，才能发起无漏的清净五识！
    总上所说，十一色法立为色蕴；遍行中受心所立为受蕴；想心所立为想蕴；其余的四十九个心所，二十四个不相应行，共七十三法，立为行蕴；八个心王，立为识蕴。无为无积聚义，不在蕴门中摄，故五蕴共摄百法中九十四法，如有颂说：‘色摄十一全，受想各当一，七十三行蕴，八王识蕴收，无为无积聚，不向蕴门摄。’立表如（表三十四）：

    （表三十四）


二、十二处

    二、十二处
    十二处：即眼处、色处、耳处、声处、鼻处、香处、舌处、味处、身处、触处、意处、法处。眼、耳、鼻、舌、耳、意为六根处，色、声、香、味、触、法为六境处。眼等五处及色声香味处，如五蕴里的色蕴中所摄，没有相滥之处，不必再说。触处是指所触的能造四大种，及所造的滑涩轻重等二十二法不包括能触的身根和心所。以上内五处外五处，即摄色蕴中前十种色。意处即识蕴，法处即受、想、行三蕴，并极略色等五种法处所摄色，及诸无为。（无为诸宗不同，小乘中大众部、一说部、说出世部、鸡胤部立九种无为。化地部亦立九种无为。正量部、经量部、及萨婆多立三种无为。大乘中诸论不同，《瑜伽师地论》五十三说二无为。《瑜伽》第三、《集法论》第二、《显扬圣教论》第一等说八种无为。《五蕴论》说四种无为。《百法明门论》、《成唯识论》说六种无为。诸论所立虽然有多有少，都是开合不同，皆于真如上假名安立。）
    处是生长门义，生是初生，长是旧长，门是出生通法的处所，显示十二处的六根为心心所的所依，六境为心心所的所缘，而能生起六识的了别用：即诸识生长的门处是处义。如《杂集论》第二卷：‘问：处义云何？答：识生长门义，是处义。当知种子义，摄一切法差别义，亦是处义。’又《杂集论》第一卷‘问：何因处唯十二？答：唯身及具，能与未来六行受用为生长门故。’身即眼等六根，具即色等六境，行即念念迁流的识。所说的生长，并不新生心心所的体，仅仅是生长其作用而已。如表（表三十五）：

    （表三十五）
    问：为什么依根境建立处，而不依六识立处呢？《对法述记》以两义解答，第一义以界处相待义作解释，即能持各界，根境能持六识，六识亦能持自己的自体，根境识各有能持义，故界立十八法。出生义名处，根境能生六识，六识自体不能生自体，由缺出生义故，所以眼识等不立为处。第二义据胜为论，即根境生识各别，说之为门，识体虽亦生用，然是一体义别，为门义劣，所以不立为处。问：意即是识，为什么又立为处呢？答：意极为因居于异世，名过去意，已不名为识，同世能生起后三种现识（六七八），约此义边，故立为处。
    十二处与五位百法相摄，可以完全摄尽：内五处外五处摄前十种色法，意处摄八识心王，法处摄四类法：（1）法处所摄色，（2）相应心所有五十一个，（3）不相应行法二十四种，（4）无为六种，合有八十二法。如有颂说：‘根尘各五处，十色随自名，八王意处收，八十二皆法。’如表（表三十六）：

    （表三十六）


三、十八界

    三、十八界
    十八界就是：眼界、色界、眼识界，耳界、声界、耳识界，鼻界、香界、鼻识界，舌界、味界、舌识界，身界、触界、身识界，意界、法界、意识界。眼等诸界及色等诸界如十二处中说，六识界即依眼等根缘色等境了别为性的前六转识，意界即无间灭意及七八二识。
    界是种子义、能持义。种子义是约阿赖耶识中能生起诸法的功能名界，即十八界法各由自种生起而有差别相。能持义是约能持诸法自相义名界，即十八界法各持自相不乱，所以名界。更有别义，如《杂集论》、《瑜伽师地论》等说。
    十八界与百法相摄是：五根五尘为十色界，眼等六识归于六识界，七八二识归于意界，法界所摄，同于法处。如有颂说：‘根尘各五处，十色随自名，八王归七心，八十二皆法。’如表（表三十七）

    （表三十七）


四、佛说三科的意趣

    四、佛说三科的意趣
    如来说蕴、处、界三科的意趣，经论中说有多种，这里且举《俱舍论》所说的三义，如该论界品颂说：‘愚根乐三故，说蕴处界三。’这就是说，世尊说三科法门的意趣有三：
（一）由众生的愚执不同，愚是愚暗，对于所缘境界，不能明了认识，体即无明。这愚执有三类：一唯愚心所总执为我，二唯愚色法执为实我，三愚执色心二法以为实我；如来为了对破这三类众生的愚执，所以说蕴处界三科，五蕴破愚执心所，以五蕴中色法与心王各为一蕴，心所别开三蕴，独详于心所之相故。十二处中，除意法二处外，其余十处皆是色法，为愚执色法有情，广详色相故。十八界中，破色心之愚，故广详色心二法。
（二）由众生的根器不同，这亦有三种，一利根，智慧敏利，略说法义，便能了解，如来为他们说五蕴法门。二中根，智慧稍钝，对于法义必须稍加开演，才能受益，故为他们说十二处法门。三钝根，其性暗钝，必须广说，才能了解，所以如来为他们广说十八界法门。
（三）由众生乐欲不同，亦有三种：一乐略说的有情，为说五蕴。二乐中说的有情，为说十二处。三乐广说的有情，为说十八界。立表如表三十八：

    （表三十八）


五、三科名次

    五、三科名次
    （一）五蕴次第
    五蕴中以色蕴为首，识蕴为末，这样的次第，在建立上是有确定意义的。如《俱舍论》界品颂说：‘随粗染器等，界别次第立。’这半个颂文显示五蕴的次第有四种意义：
（1）随粗次第：五蕴文中，色蕴有碍有对，观待无形无对的后四蕴，其相最粗，故居第一。无色的四蕴中唯受形相最粗，以于触境的时候，即首先生起苦乐等感觉的受，故居第二。由受生起取像的想，比较后二蕴为粗，故居第三。行蕴中贪等烦恼，行相易知，较识蕴为粗，故居第四。识蕴最细，总取境相，难分别故，所以立在末位。
（2）随染次第：染是染污，就是贪等烦恼。众生从无始生死以来，男女之间，对于色相更相爱乐，爱乐色相，由于欣求乐爱，于乐耽着，由起倒想，倒想生起，由行蕴中烦恼，烦恼以识为依，依识而生，如是随于染污法的生起次第而建立五蕴次第。
（3）随器等次第：这是以譬喻说明五蕴次第，如人宴客，先备食器，次承受饮食，次以盐酱等助味，次由厨师制造，后则食者享用其食而了别之。如其次第配释五蕴次第的意义是：色蕴为受的所依，与器物为饮食的所依相同：受蕴中苦乐等受能损益身心，亦如饭食能损益人的身心一样；想蕴生起亲怨等想而引起苦乐等受，亦如甘醋盐酱等能助生种种食味；行蕴中业烦恼能造能得异熟果，亦如厨师能制作饮食；识蕴之感受果报，正如食者享受食物，依这譬喻显示五蕴次第的决定意义。
（4）随界别次第：三界之中，有诸妙欲，色相显了，故第一说色蕴。色界静虑有殊胜的喜乐等，受相显了，故第二说受蕴。无色界中，前三无色取空等想为所缘境，想相显了，故第三说想蕴。第一有中，其业能感八万大劫果报，思为最胜行相显了，故第四说行蕴。前四蕴为识的所住，识为能住，如世间田为所住，撒播的种子为能住，故识蕴在最后说。此即依于界别说五蕴次第。
    依上随粗、随染、随器等、随界别四义，说五蕴次第如是，由此五蕴不增不减。
    依《对法论》第一卷说：‘何因蕴唯有五？答：为显五种我事故。为显身具我事，受用我事，言说我事，造作一切法非法我事，彼所依止自体我事。于此五中，前四是我所事，第五即我相事。’身具即内外色蕴所摄：即内根色蕴我所依止说名为身，外境色蕴我之资释名之为具，世间众生多计识蕴为我，色为我身具，我能受用境，我能起言说，我能造诸行，受想行三皆是我的作用，我是彼主。佛为遮彼一性我执说蕴有五：身为识所依，或体有积聚，具为根之境，非是我的身具；受能领纳，想能起说，思能造法，皆非我所；识能了别，非是我体；由此五蕴次第建立不增不减。立表如表三十九：

    （表三十九）
    （二）处界次第
    十二处和十八界的次第意义，如《俱舍论》界品颂说：‘前五境唯现，四境唯所造，余用远速明，或随处次第。’这个颂说依二义建立处界的次第：（1）约根取境义，次第决定，即颂文前三句。（2）约根所依处义，次第决定，即颂文后一句。
（1）根取境义：六根之中，眼耳鼻舌身前五根唯取现前境，是故先说。意根取境不定，过去未来现在三世及无为法，皆能缘取，缘境最宽，故在五根后说。颂文前五境唯现，就是显示这个意义。在五根中，前四根所取的色声香味四境，唯是所造色，是故先说。第五身根所取的触境，包括能造的四大种和所造的滑涩轻重等，或唯取大种，或唯取造色，或二俱取，境不决定，所以在前四根之后说。颂文四境唯所造就是显示这个意义。又除身意两根外，其余四根的作用有远、速、明的不同，故次第成先成后，即眼根耳根俱取远境，故先说二根。在二根取远境的作用中，眼用尤远，远见山河不闻声故。又眼根的作用迅速，先远见人撞击钟鼓，后时才能闻声故。在这远速的作用不同上，如次先说眼耳二根。鼻舌二根取境的作用，俱不是远，由速明故，成先后次第；鼻根的作用，此之舌根，速而且明，如对香美的饮食，鼻先嗅香，舌后尝味；鼻能嗅味中的细香，舌不取香中的细味，故先说鼻后说舌。颂文余（除身意二根之余，眼等四根）用远速明就是显示这个意义。
（2）根所依处义：即于身中，随所依处上下差别，说根次第，即眼所依处最居其上，次耳鼻舌身，身的中央在脐，故次于舌。意根无形，没有方处，依上诸根而生，故居最未。
    由上说两义，处界次第决定，不增不灭。
    依《对法论》第一废立界处文说：‘问：何因界唯十八？由身具等能持过现六行受用性故。身者，谓眼等六根，具者谓色等六境。过现六行受用者，谓六识。能持者，谓六根六境能持六识，所依所缘故。过现六识能持受用者，不舍自相故。当知十八以能持义，故说名界。问：何因处唯十二？答：唯身及其能与未来六行受用为生长门故。谓如过现六行受用相，为眼等所持，未来六行受用相，以根及义（境）为生长亦尔。所言‘唯’者，谓唯依根境立十二处，不依六种受应相识。’由六根为识的所依所缘，能持六识，故依次建立十八界不增不减。唯由身具能与未来六识受用为生长门，故依根境如次建立十二处不增不减。


六、诸门分别

    六、诸门分别
    蕴处界的名义等，已如上说，但三科中还有很多的差别意义应该分别，故诸论中在说了蕴处界的名义之后，总有诸门分别一科。如《瑜伽师地论》五十五、五十六两卷中，以五十八门分别：《显扬圣教论》第五卷，以三十四门分别；《对法论》第三卷，以二十六门分别。在三科中，十八界具足根境识三种的差别最为显著，故《俱舍论》等，皆依十八界作义门分别，于蕴于处，则准例推知。这里只想介绍三科中一些比较简要的差别，且依《五蕴论》就十八界略举十二义如下：
    （一）有色无色门：十八界中‘几有色？谓十界、一少分：即色蕴自性。几无色？谓所余界。’（这是《五蕴论》原文，不准此知。）十界即五根五境十界全，一少分即法界中一分的法处所摄色。十界及法处所摄色皆各具色的自性，故论说言即色蕴自性。所余界是指十界等之所余，即眼等六识界及意意全，并法界中一分，皆是无色。法界中除法处所摄色，其余五十一个心所法、二十四种不相应行法、六种无为，都是无色性的法！故论说言一分。
    （二）有见无见门：‘几有见？谓一色界。几无见？谓所余界。’一色界即色尘差别中显色、形色、表色，皆是眼根所取眼识所缘的可见色境，故是有见法。有见相违是无见义，色界之所余界，即十七界全、皆是无见法。
    （三）有对无对门：‘几有对？谓十色界，若彼于此有所碍故。几无对？谓所余界。’对是障碍义，若法为能所碍，是为有对。十色界即五根五境，皆是有碍的法，故是有对。无对就是不为能所碍。所余界即六识界与意界及法界，皆无能所碍，故是无对法。有对的差别有三种：（1）障碍有对，如手碍手、石碍石等，障碍即名有对，如前所举的五根五境就是。（2）境界有对，非约境界自身称为有对，是指十二界及法界一分诸有境法为境界（色等五境及法界一分）所拘碍束缚，于取境之用，不得自在，是名境界有对。（3）所缘有对，亦非约所缘自身称为有对，因心心所为自所缘（五根五境及法界一分）所拘碍束缚，于所缘起执，不得自在，是名所缘有对。前面说的十色界为有对，只约障碍有对分别，非约拘碍有对义说，故准举十色界而不及余界。境界所缘有什么差别呢？如《俱舍论》说：‘若于彼法此有功能，即说彼为此法境界，心心所法执彼而起，彼于心等名为所缘。’
    （四）有漏无漏门：‘几有漏？谓十五界，及后三少分，谓于是处烦恼起故，现所行处故。几无漏？谓后三少分。’有烦恼随增，是为有漏。十五界即五根界、五境界及五识界。后三少分即意根界、意识界及法界。后三界通有漏无漏，这里唯取通有漏义边，故说言少分。无漏即没有烦恼相应，无漏中取后三界摄于道谛的通无漏义边，故亦说言后三少分。但于十八界这样作有漏无漏的分别，不是究竟的说法。若依据大乘究竟义，十八界皆通有漏无漏，以《大般涅槃经》及《庄严论》等，皆说如来功德身土，纯无漏法，如其所应的摄在蕴处界中，故蕴处界三科，皆全通有漏无漏，至于《杂集论》等中说前十五界唯是有漏，那是依二乘粗浅境说，故不相违。
    （五）界系不系门：‘几欲界系？谓一切。几色界系？谓十四；除香味及鼻舌识。几无色界系？谓后三，几不系？谓即彼无漏。’系是系属，即被系缚义，被欲界贪等系缚名欲界系。欲界所系，具足十八界，故说一切。色界中没有段食，故无香味二境，境无识不生，故能缘二识亦随之无有，所以除香味二境，及鼻舌二识；有所余十四界全。问：即无香味境，亦应无鼻舌根？答：如《俱舍论》说：‘不尔！二根于彼有用，谓起言说及庄严身。’又说：‘鼻舌二根于彼非无，但无香味，以六根爱依内身生，非依境界而得现起。’无色界中，不但没有色声香味触五种境界，亦无眼耳鼻舌身五种根界，因为五识的所依根和所缘境都没有了，故五识亦不生，因此无色界所系者，唯有后三界。不系即非系属于三界之无漏的十八界法，故说即彼无漏。‘彼’字所指，若依《五蕴》、《杂集》、《俱舍》等论，即唯指后三界通无漏的一分；因为《俱舍》等说十五界唯有漏故。若依大乘究竟义，则‘彼’指全分无漏的十八界法。
    （六）蕴取蕴门：‘几蕴所摄？谓除无为，几取蕴所摄？谓有漏。’无为无积聚义，不在蕴门摄，故除去它，即除法界中所摄的六种无为。取是执取义，若约增胜，欲贪名取，通则一切烦恼，故取是烦恼的总名；由蕴与贪等烦恼更相随顺生长，蕴与取合，故名取蕴；因为蕴通有漏无漏，故以取字简别无漏五蕴而立有漏名取蕴。《杂集论》第一卷说：问：云何名取蕴：答：以取合故，若为取蕴。取者，谓诸蕴中所有欲贪。何故欲贪说名为取？谓于未来现在诸蕴，能引不舍故，希求未来，染着现在。欲贪名取，欲者，希求相；贪者，染着相。由欲希求未来自体为方便故，引取当蕴，令起现行：由贪染着现在自体为方便故，执取现蕴，令不舍离；是故此二，说名为取。问：何故界处说有取法？答：应如蕴说，当知界处与取合故，名有取法。
    （七）善等三性门：‘几善？几不善？几无记？谓十通三性；七心界，色、声、及法界一分。八无记。’三性就是善性、不善性、无记性。十八界中，有十界通三性，即七心界、色界、声界，及法界一分。七心界就是六识界和意界。色声二界通三性，非约它的自性说，而是约能发动色声的心说的。如《显扬圣教论》第十八卷说：‘色非自体有善恶性，随能发心假说善恶。’法界一分，即相应法中除去唯一性的善十一、本惑六、随惑二十；指所余的遍行、别境等，故说言一分。八无记性，即眼等五根和香味触八法，唯是无记性。法界中所除的善十一和本随惑，如其所应配善恶可知，故论中不说。问：色声香味触五种，同为色法，为什么色声通三性，香等唯无记呢？答：成善恶的身语两种表业，唯色声二界，身表业即色，语表业即声，约表示能发心的善恶，故假说色声通于三性。实际说来，一切有漏位中，色声等五法皆唯自性无记，在无漏位一切唯善。
    （八）内外门：‘几是内？谓十二，除色声香味触及法界（疑脱‘一分’二字）。几是外？谓所余六。’六根、六识、十二界名之为内，色等六境名之为外。法界中相应法五十一种唯内，余通内外，故法界下应有‘一分’二字。所余六即前所除的色声香味触及法界中一分，这些都还外法，故是外界。
    （九）有缘无缘门：‘几有缘？谓七心界，及法界少分心所法性。几无缘？谓余十，及法界少分。’缘是攀缘，心心所法名能缘，境是所缘，有彼所缘，名为有缘。六识界、意界，及法界中诸心所法名有所缘，能取境故。余十即十色界，法界少分，即法界中所摄不相应行等，不能取境，故名无所缘。
    （十）有无分别门：‘几有分别？谓意识界、意界及法界少分。’此中是就五识说为无分别，因为五识无计度随念两种分别故。虽然五识有细分别，以微劣故说言无分别。意界少分即除第八识，取所余二：即第七识和无间灭意。法界少分，即取相应法五十一数。所余界皆是无分别所摄，约举一示一，故不举无分别法。
    （十一）执受非执受门：‘几有执受？谓五内界，及四界少分：谓色香味触。几非执受？谓余九及四少了。’心心所任持不舍，说名执受。五内界即眼等五根界。四界少分，即除五境中声，余色香味触一分为有执受。因为色等四法通内外，内根色等有执受，外尘色等无执受，故说言少分。余九即七心界、法界、及声界。四少分即色香味触四中唯属外尘的一分。此等皆非所执受的法，故非执受。
    （十二）同分彼同分门：‘几同分？谓五内有色界与彼自识等境界故。几彼同分？谓彼自识空时与自类等故。’什么是同分彼同分？即根境识三，各作自业，名为同分；不作自业，名彼同分。如眼根取色境，眼识缘色境，与色境之为眼根眼识所取，皆为自业，是名同分。其余的根境识相对各作自业，皆名同分。反之，若根境识各不作自业，名彼同分。因为分是指自己的作用，根境识三同有自己作用之分，故名同分。若非同分，与其他的同分种类相同，名彼同分。如《俱舍论》第二卷说：‘云何同分彼同分义？根境识三，更相交涉，故名为分。或复分者，是已作用。或复分者，是所生触。同有此分，故名同分。与此相违，名彼同分；由非同分与彼同分种类同，名彼同分。’五内有色界即五根，自识，即五根各自的能依五识，境界即五根五识各自的所缘境，等显同分义，即根境识交涉作自业时，三法行相彼此相同，故名同分。若三中随灭一法，则所灭一法行相不同故，不可名同分，而种类与彼同故，名彼同分。论说自识空时与自类等，即以种类相同义，解释彼同分。自识空即眼等识不依眼等根生起缘境用之时，就是根境识不相和合作自业，唯自体相似相续生，根根相似义，说名彼同分。十八界中分别同分彼同分，正据根取境名同分。如《瑜伽》五十六说：‘问：此十八界几是同分？几彼同分？答：有识眼界各为同分，所余服界名彼同分。如眼界乃至身界亦尔。唯根所摄内诸界中，思量同分及彼同分非于色等外诸界中，当知法界诸有所缘如心界说，诸无所缘如色等说。’由这论文很明显地可以知道分辨同分彼同分不约境说了。
    大乘唯就五识说同分、彼同分，义如上说。若依《俱舍》，则通约六识解说。知彼颂说：‘法同分余二，作不作自业。’就是法界为第六意识所缘的境，第六意识通缘三世，广为分别有为无为一切法，这样则法界为意识之缘，没有非作自业的时候而无彼同分了。故说法界唯同分，余十七界通同分彼同分二种。


一、苦谛

    第四节 四谛
    佛陀在菩提树下成等正觉以后，最初在波罗捺斯城外鹿野苑说四谛法轮教化五比丘，令他们观察世出世间的因果道理，而知苦、断集、证灭、修道。五八听闻了这四谛法门，漏尽意解，成阿罗汉，究竟解脱了生死流转的痛舌。如来入灭的时候，亦以四谛法门为最后的垂示（遗教经）。故四谛教法，为声闻乘观理修行的中心法门。四谛即苦谛、集谛、灭谛、道谛。这四种法，皆真实不虚，所以名谛。又唯是圣人无漏智慧的亲证亲知，所以又名四圣谛。
    一、苦谛
    （一）苦谛总相
    苦是逼迫义，即世间一切有漏的果报，皆为三苦八苦等逼迫，所以名苦。这苦果法包括有情世间和有情所依处的器世间。
    有情界有五趣的差别，即地狱、饿鬼、畜生、人、天。或别开阿修罗，成为六趣。这五趣有情，从胎、卵、湿、化四生中受生。地狱等三趣，是由不善业所招的非可爱果，是为恶趣。人天二趣，是由善业所招感的可爱果，名为善趣。
    有情趣生，有三界九地的差别。三界即欲界、色界、无色界。九地即欲界五趣杂居地。色界离生喜乐地、定生喜乐地、离喜妙乐地、舍念清净地。无色界空无边处地、识无边处地、无所有处地、非想非非想处地。欲界为五趣有情之所杂居，所以名为五趣杂居地。欲界有饮食、睡眠、情爱三欲，故名欲界。欲界有六天：即四王天、忉利大、夜摩天、兜率天、化乐天、他化自在天。前二是地居天，后四是空居天。色界有十八天，初禅摄离生喜乐地，有三天：即梵众天、梵辅天、大梵天。二禅摄定生喜乐地，有三天：即少光天、无量光天、极光天。三禅摄离喜妙乐地，有三天：即少净天、无量净天、遍净天。四禅摄舍念清净地，有九天：即无云天、福生天、广果天、无想天、无烦天、无热天、善现天、善见天、色究竟天。这四禅十八天，皆依禅定而住，无诸欲尘，唯有净妙的色身，故名色界。无色界有四天，即空无边处等四天。无色四天的有情，唯有无色四蕴，没有色身的形质，所以名为无色界。欲界由散业所招感，故又名散地。上二界由不动的定业所招感，所以又名定地。色界上五天，名为五净居天，是三界圣人所居，故名圣天。余则皆是凡天。其色界中无想一天，则唯是外道所居。
    诸天的相状各有差别，四王天、忉利天有忿怒相，其余上天皆是善相。欲界六天，皆有男女，上界一类相，没有男女的差别。初禅以下，有王臣差别；二禅以上，皆无王臣。三禅以下，皆有喜乐；四禅则无，唯有舍受而已。初禅有火灾，二禅有水灾，三禅有风灾；四禅以上，即离三灾、绝八患了。下二界皆有身形器界；无色界则没有身形器界，唯有无色四蕴心心所法而已。除圣天以外，其余诸天业报有尽，天报尽时，仍入诸趣受生。
    所依处，即器世界，谓水轮依风轮，地轮依水轮，依此地轮有苏迷卢山、七金山、四大洲、八中洲、内海、外海，并轮围山等，广如《瑜伽师地论》第二卷、《对法》卷四、《俱舍论分别世间品》所说。
    总上所说的有情世间和器世间，都是由业烦恼的势力所生，和业烦恼的势力所起，俱是苦性，故名苦谛。
    （二）苦相的差别
    甲、三苦
    由于顺苦、顺乐、顺不苦不乐三种受相的差别，经中说三种苦相，即苦苦相、坏苦相、行苦相。由此道理，佛说诸受皆名为苦。
    （1）苦苦：即逢苦缘逼迫所生的苦受，和随顺苦受法，即能生起苦受的所依根与所缘境及相应的心心所等，是为苦苦；总合苦受和随顺苦受的法即苦苦的体性义。一切有漏的法，性自逼迫，苦更增逼迫，即成苦苦；如于热疮上加淋热汤，或增火灸，是逼迫中更加逼迫，故名苦苦。在诸法之中，一切一分是苦苦性；即一切法中除坏苦、行苦，及无漏法，余皆苦苦。
    （2）坏苦：即乐受变坏位，和随顺乐的所依根与所缘境及相应的心心所法，于变坏位能生忧恼，是为坏苦：故乐受变坏和随顺乐法变坏，即坏苦的体性义。在诸法之中，一切一分是坏苦性；即一切法中除去苦苦，行苦及无漏法，余皆坏苦。
    （3）行苦：一切有为有漏法迁流变动，是为行苦；即不苦不乐受自相，和随顺不苦不乐受的所依根、所缘境，及相应心心所，和随顺此受的诸行，即苦受乐受和一切有为有漏法，为苦苦、坏苦，两种粗重（种子）所随逐故，为无常所随逐故，由不安稳义，是为行苦的体性义。不安稳义，就是一切有漏诸行，不能解脱苦苦和坏苦故，或于一时，堕在苦受位，或于一时，堕在乐受位，不能一切时候，保持不苦不乐的舍受位，是故无常所随逐就是不安稳的行苦性。《瑜伽师地论》六十六卷说，行苦遍行于苦、乐、舍三受中，然于不苦不乐的舍受中，此行苦粗重性分明显现，所以但说不苦不乐受中由行苦故苦。于苦乐二受中，爱恚二法扰乱心故，这行苦性不易了知，故于苦乐二受中不说行苦，非是彼二受中没有行苦啊！在诸法之中，一切一分是行苦，即一切法中，除去无漏之法，皆是行苦。
    三苦之中，前二苦唯欲界有（约多逼迫说），后一种苦遍通三界。
    乙、八苦
    如来为令有情了解生死流转的过患，引起厌离生死，欣求解脱向上心，故说八苦：即生苦、老苦、病苦、死苦、怨憎会苦、爱别离苦、求不得苦、略摄一切五取蕴苦。
    （1）生苦：略有二义：[1]生为众苦所逼，即在母胎之中，经过十个月的时间，内热煎煮，身形渐成，住在生脏的下面，熟脏的上面，夹压如狱，具受种种不净物的逼迫。正出胎的时候，肢体又受逼迫的痛苦。出胎以后，柔嫩的肌肤，受到冷风热汤等的刺激，无异遍体针灸，苦难言状。[2]生是余苦所依，因为有了生身以后，其余的老苦、病苦、死苦等都跟随着来了。应该知道，生苦不是说生的自体是苦，是说由生为苦因缘，引生身心上种种的苦受，故名为苦。其余七苦之说名为苦的道理，也应准此例知。
    （2）老苦：由时分变坏故苦，即从少至壮、从壮至老、色相、气力、根用等，时时刻刻都向衰损方面转变，最后以至于朽坏，令身心生起种种的苦受，故老为苦。
    （3）病苦：由大种变异故苦，有情的色身，是由地、水、火、风四大种组织而成的，若四大不调，则众病发生。地大不调，身体僵硬沉重：水大不调，身体虚浮肿胖；火大不调，遍身蒸热高烧；风大不调，举身战掉倔强。由于大种变异而产生各种的疾病，引起身心上种种的苦受，故病是苦。
    （4）死苦：由寿命变坏故苦，即由内身的疾病为因缘，寿命变坏而死，或由外在的恶缘逼迫，及遭受水火灾等为因缘，寿命变坏而死，引起身心上极难忍受的苦痛，故死是苦。
    （5）怨憎会苦：心目中常时怨恨的仇敌，憎恶的坏人，希望他长时远离，心理才感觉畅快，但偏有凑巧的因缘，反而集聚会合，引起身心上的种种苦受，故怨憎会是苦。
    （6）爱别离苦：自己亲爱的人，希望常相聚会，不愿其乖违离散，但偏有违缘逆境，使其乖离分散，引起心中的种种苦受，故爱别离是苦。
    （7）求不得苦：对于世间希求想得的财物、名位，及一切心中所爱乐的事而不能有，引起心里种种苦受，故希求不得是苦。
    （8）略摄一切五取蕴苦：五取蕴刹那迁流变坏，为生老病死等众苦之所集聚，成为总略摄受一切苦法的重担，故五取蕴是苦。
    丙、六苦
    上面所说的八苦，又可以摄为六苦，如《集论》说：‘如是八种，略摄为六，谓逼迫苦、转变苦、合会苦、别离苦、所希不果苦、粗重苦。如是六种，广开为八，若六若八，平等平等。’逼迫苦摄生苦，生苦之住胎出胎，俱受种种逼迫，逼迫苦盛，故生苦名逼迫苦。转变苦摄老苦、病苦、死苦三种，老苦由时分转异变坏，病苦由大种转异变坏，死苦由寿命转异变坏，故老病死三种俱摄于转变苦中。合会苦摄怨憎会苦，由怨憎的仇人合会，即引生苦故。别离苦摄爱别离苦，由亲爱的人分别乖离，即引生苦故。所希不果苦摄求不得苦，由希求所得而不果其所愿，即引生苦故。粗重苦摄五取蕴苦，粗重即种子，五取蕴为三界烦恼种子所随逐生起，故五取蕴名粗重苦。
    丁、二苦
    上面所说的三苦、八苦、六苦，又可以摄为二苦：即世俗谛苦、胜义谛苦。世俗谛苦，即世间人的智慧所能了知的苦，即苦苦和坏苦；如老病饥渴和三恶趣是苦，世间皆知，故名世俗谛苦。胜义谛苦，是圣人无漏后得智的证知境，即行苦性；如享受五欲乐和人天善趣是苦，则非世间人的智慧所能了知，唯是圣人殊胜智慧证知的境界：由胜智证知有漏诸行皆苦，故名胜义谛苦。
    戊、诸苦相摄
    前面所说的三苦、八苦、六苦、二苦，都可以展转相摄；如八苦中的生苦、老苦、病苦、死苦、怨憎会苦，是顺苦受法，苦自相义故，能显示出苦苦的意义，故生苦等五种，与三苦中的苦苦相摄。八苦中的爱别离苦和求不得苦，是已得和末得的顺乐受法，坏自相义故，能显示出坏苦的意义，故与三苦中的坏苦相摄。八苦中的略摄五取蕴苦，由于五取蕴不能解脱苦苦和坏苦的二无常性所随逐，是不安稳义故，能显示出行苦的意义，故与三苦中的行苦相摄。
    八苦与世俗谛苦、胜义谛苦怎样相摄呢？如《杂集论》所说，生苦乃至求不得苦，是世俗谛苦所摄；因为生等是苦，世间人的智慧可以了知故。略摄一切五取蕴苦，是胜义谛苦摄：因为五取蕴苦是约行苦义说，有漏行是苦性的道理，唯是出世间胜义后得智的证知境故。八苦与六苦相摄，已如六苦中说。这里把诸苦相摄总立一表如表四十：

    （表四十）
    除上说的苦相差别外，诸经论中还说有许多苦相的差别，如《菩萨藏经》说十苦，《智度论》说内外二苦，《显扬圣教论》说五十五苦、《瑜伽师地论》说一百一十苦等，若欲广博求知，当看彼等典籍，这里就不说了。
    （三）苦谛四行相
    修观行的人，为了彻底了知苦相，依作意力寻思观察由四种行了知苦谛相，即：无常相、苦相、空相、无我相。分别解说如下：
    （1）无常相：无是除遣义、非有义；常是一切时义，不变义；无常即无有常住不变之义，即否定了常性的存在，常性无故，名为无常。无常相如《集论》说略有十二种：[1]非有相，[2]坏灭相，[3]变异相，[4]别离相，[5]现前相，[6]法尔相，[7]刹那相，[8]相续相，[9]病等相，[10]种种心行转相，[11]资产兴衰相，[12]器世成坏相。
    [1]非有相：非有是无常义，相指我我所性：非有相就是说五蕴十二处十八界中，于一切时，我我所性，常非有故，是名非有无常相。
    [2]坏灭相：由于诸行没有常住不变的固实性，所以生已即灭，暂有还无，不能相似相续地生住，是名为坏灭无常相。
    [3]变异相：即诸有为法的变异生，由不相似相续转，就是一物在前后刹那中，形质起了不相似的变化，如前刹那是固体，后刹那转成液体，前刹那是青色，后刹那转变成黄色，前刹那是生长，后刹那转成朽坏等，都是诸行前后不同的异异相续转生，是名为变异无常相。
    [4]别离相：即于诸行失去了主权和受用等，如于资助生活的财物和人与人之间的主从的关系等，或由自己不能主宰、自在、受用；或为盗贼等恶势力之所侵夺，失去主宰、自在、受用；或由自然灾害的侵袭等，失掉主宰、自在、受用；由如是等因缘而引起与诸行别离，是名为别离无常相。
    [5]现前相：即诸行现前正处于变异无常、坏灭无常、别离无常的时候，令受无常故，是名为现前无常相。
    [6]法尔相：即当来无常，即当来有的法，所有变异无常、坏无常、别离无常，于现在世虽然犹未合会，但由诸行法尔性故，于未来世当有法性，决定当受变异、坏灭、别离、死亡等无常，是名为法尔无常相。
    [7]刹那相：即诸行自体刹那变易，念念坏灭，势不能暂时停住，由于无间必坏故，过去诸行，决不能留住于现在，是名为刹那无常相。
    [8]相续相：即从无始以来，有情生死展转相乘，生死死生轮回不绝，是名为相续无常相。
    [9]病等相：等字等老死二相，即由粗根四大变异有病根，时分变异有老相，寿命变异有死相。由四大、时分、寿命变异故，了知分段生死的转无常，是名为病等无常相。
    [10]种种心行转相：这是说心理的活动无常，一个有情有时对于可爱境起贪着心，有时即于如是境相远离贪着心；有时对于可憎境起嗔恚心，有时又于同样境相远离嗔恚心。如是有痴心、离痴心；若略缘，如止行的专一境心；若散缘，如于外五欲境起散心。若掉举心、离掉举心，若善心，若恶心，千差万别的心行流转，是由心识住于能治所冶分位而生起的差别。是名种种心行转动的无常相。
    [11]资产兴衰相：资产就是世间富贵荣华诸兴盛的事，终归衰变，不可爱乐，非究竟故。是名为资产兴衰无常相。
    [12]器世成坏相：这是说有情所依住的器世间，有成、住、坏、空、大三灾、小三灾等无常相；如器世界成的时候，水轮依风轮，地轮依水轮，渐次而成，壤的时候，火烧坏初禅天，水淹坏第二禅天，风台坏第三禅天，广如《瑜伽师地论》第二卷，及《杂集论》、《俱舍论》等所说。是名为器世界的成坏无常相。
    总上十二种无常相，可以分为三类：初七种通观内法（有情）和外法（无情）无常。八、九、十三种，唯观内法无常。十一、十二两种，唯观外法无常。在初七中又分为两类：初一相观所无，因为我我所性是本来没有的。次六相观所有，即于如幻有的法上观无常。在观所有中，又分为三种：初二种观微细无常。次一种观粗显无常。后三种观现在、当来、过去三世无常。次三观内法中，初总观自体无常，次观分段转变无常，后观微细心行无常。后二观外法中，初观资产无常，后观器世界无常。为了醒目，列表如表四十一：

    （表四十一）
    （2）苦相：苦是逼迫义。苦相差别，有三种、八种、六种等，已如前说，不再重覆。这里说一说由了知无常相则能够进而了知苦相意义。修观行的人，由作意力寻思观察，于无常行得决定。由三分无常为缘，苦相可以了知。[1]由生分无常为缘故，苦苦性可以了知。生是本无今有，就是本来无有的法而今现起为有，修观行的人，就于这本无今有的新生法上，作意思惟，如是诸行既是生法，即有生苦，既有生苦，当知亦有老病死苦、怨憎会苦、爱别离苦、求不得苦。苦品诸行，体是逼迫，不可爱乐，由此生分无常为缘，而了知苦苦性。[2]由灭分无常为缘故，坏苦性可以了知。灭是已有还无，就是已经生起的有法，坏灭无有了。修观行的人，于诸行坏灭作意思惟：已有的法还归坏灭，了知乐品诸行，亦不可爱乐，以乐品法终归坏灭故，由此灭分无常为缘，而了知坏苦性。[3]由俱分无常为缘故，行苦性可以了知。俱分即生灭二分，粗重的有漏诸行相续流转，无论是生起与坏灭，俱不可乐。由此俱分为缘，而了知行苦性。
    其次，修观行的人，由生灭二无常故，了知八苦。就是由作意力思惟有生灭二法所随逐的诸行中，就有生等八种苦性，故佛陀在经说言，若无常的法即是苦性。
    如上所说，观行者由思惟无常，就能够悟入佛陀在经中说的由无故苦的意义。但是应该知道，经教中说无常故苦，不是指一切有为行法来说，而是专指有为行中的有漏杂染法，否则圣道法是无常故，也应该是苦了。
    （3）空相，空是非有义，无所得义。即于五蕴、十二处、十八界，了知唯是依因托缘而现起的如幻有法。没有常恒凝住不变的固实性和我我所相；固实性非有故，我我所相不可得故，所以说名为空。但空并不是一切都无所有，仅仅是在蕴处界法上空去虚妄计执的固实性和我我所相，由因缘和合的如幻法则宛然而有。这样解空，才是正观空相；若说空是一切皆无，那就堕到顽空断见上去了。《集论》说：‘于蕴界处常恒凝住不变坏法我我所等非有，由此理彼皆是空。’《瑜伽师地论》三十四卷说：‘复作是念，我于今者，唯有诸根，唯有境界，唯有从彼（根境）所生诸受，唯有其心，唯有假名我我所法，唯有其见，唯有假立此中可得，除此更无若过若增；如是唯有诸蕴可得，于诸蕴中，无有常恒坚住主宰，或说为我，或说为有情，或复于此说为生者、老者、病者及以死者，或复说彼能造诸业，能受种种果及异熟，由是诸行皆悉是空，无有我故。如是名为由无所得行趣入空行。’
    （4）无我相：我是实有、常一、主宰、自在义，一般众生和有我论的外道，都于蕴处界中虚妄计执有我我所相，但以正慧观察，正理推征，蕴处界中，无论是内事和外事，都没有实有常一主宰自在的我我所相，所以如来在经中说，一切法无我。《集论》说：‘由蕴界处我相无故，名无我相。’《瑜伽师地论》三十四卷说：‘复作是念：所有诸行与其自相，及无常相苦相相应，彼亦一切从缘生故，不得自在，不自在故，皆非是我，如是名为由不自在行入无我行。’
    修观行的人，为什么对于苦谛需要修四行相观呢？为了对治常、乐、净、我四种颠倒的虚妄执着故。由观无常行相，对治当倒；观苦行相，对治乐净二倒；观空、无我行相，对治我倒。如《瑜伽师地论》五十五卷说：‘何故于苦谛为四行观？答：为欲对治四颠倒故；谓初一行对治初一颠倒，次一行对治次二颠倒，后二行对治后一颠倒。’


二、集谛

    二、集谛
    （一）集谛总相
    集是招集义，即招感集起苦果的因；包括一切烦恼，和烦恼增上所生诸业，俱说名集谛。集为什么是苦的因呢？由此烦恼及有漏业集起生死苦故。但佛陀在经中，随最胜义唯说爱为集谛。最胜是遍行义，由爱具有六遍行义，是流转生死最胜的染污法，故佛说若爱，若后有爱，若贪喜俱行爱，若彼彼喜乐爱，是名集谛。
    六遍行是：（1）事遍行、（2）位遍行、（3）世遍行、（4）界遍行、（5）求遍行、（6）种遍行。这里分别略释如下：
    （1）事遍行：事是体境二义，遍行是周遍起义，即爱于一切已得未得的自身和境界事遍行起；于已得的自身起自体爱，于未得的自身起后有爱，于已得的境界起贪喜俱行爱，于未得的境界起彼彼喜乐爱。
    （2）位遍行：位是苦苦性等三位，即爱于苦苦性等三位诸行中遍随行起：于已得苦苦性位，起希求别离爱；于未得苦苦性位，起希求不和合爱。于可乐法坏苦性位，已得起希求不别离爱，及未得起和合爱。于渐衰的行苦位法，起愚痴爱。
    （3）世遍行：世是过现未三世，即爱于三世中遍随行起。于过去世，起追忆遍随行爱；于未来世，起希乐行遍随行爱；于现在世，起耽着行遍随行爱。
    （4）界遍行：界是三界，即爱于欲界、色界、无色界，次第遍行起故。
    （5）求遍行：即由贪爱遍于三界起欲求、有求、邪梵行求故：因欲求力，不能解脱欲界缠，招欲界苦：因有求力，不能解脱离三界烦恼，招色界无色界苦；由邪梵行求力，（非解脱生死的清净行，妄执为清净行），不能解脱生死，仍在三界五趣中流转。欲求通善染，有求唯善，邪求遍善染。
    （6）种遍行：种是种类，即希求后有爱，希求无后有爱，是遍行于常断见之各种类妄执见故。
    （二）体性差别
    甲、烦恼
    （1）烦恼的名数，烦恼总有六种：即贪、嗔、痴、慢、疑、恶见。或分为十种：前五种如前，第六恶见别开为五种：即萨迦耶见、边执见、邪见、见取、戒禁取。
    （2）烦恼的自相，即贪嗔等的自体，广如五位百法中说应翻阅参考。
    （3）烦恼的共相，一切烦恼生时，皆能令身心相续不寂静转，故不寂静性，是诸烦恼的共相，《杂集论》借随烦恼六个名数显示诸烦恼的共相有六种差别：即散乱不寂静性、颠倒不寂静性、掉举不寂静性、昏沉不寂静性、放逸不寂静性、无耻不寂静性。无耻通三界，非无惭愧，以染心散乱皆有微薄的不羞耻故。
    （4）烦恼的生缘，烦恼生缘有六种：一由所依故，即由烦恼的种子未能永断，因此烦恼得以生起。二由所缘故，即由顺生烦恼的境界法现前，引发烦恼生起。三由亲近故，即由亲近恶友，引生种种的烦恼。四由邪教故，即由听闻不正的邪法，引生种种的烦恼。五由数习故，即由先时数数近习熏殖烦恼势力，因此生起种种烦恼。六由作意力故，即由不正思惟，于所缘境界取净妙等相，由此生起贪嗔等烦恼。
    （5）烦恼的颠倒，烦恼颠倒所摄有七：一想倒，二见倒、三心倒、四于无常起常倒、五于苦起乐倒、六于不净起净倒、七于无我起我倒。想倒，即于无常、苦、不净、无我中、起常、乐、净、我妄想分别。见倒，即于前妄想所分别中，忍可欲乐，建立执看。心倒，即于前所执着中贪等烦恼生起。这有三种差别：有的烦恼，是颠倒的根本，就是无明。有的烦恼，是颠倒的自体，即萨迦耶见，和边见的一分，及见取，戒禁取，并贪。有的烦恼，是倒的等流，即邪见和边执见的一分，与恚、慢及疑。此中的萨迦耶见，是无我执我倒。边执见一分，是无常执常倒。见取是不净执净倒。戒禁取是于苦执乐倒。贪通二种，即于不净执净倒，及于苦执乐倒。
    （6）烦恼的差别，由于烦恼有多种的差别义，依差别义的不同，而安立种种的差别名，依《瑜伽师地论》第八卷所说有如下的二十六种：[1]结、[2]缚、[3]随眠、[4]随烦恼、[5]缠、[6]暴流、[7]辄、[8]取、[9]系、[10]盖、[11]株杌、[12]垢、[13]常害、[14]箭、[15]所有、[16]根、[17]恶行、[18]漏、[19]匮、[20]烧、[21]恼、[22]诤、[23]火、[24]炽然、[25]稠林、[26]拘碍。分别解释如下：
     [1]结，有九种：1.爱结、2.恚结、3.慢结、4.无明结、5.见结、6.取结、7.疑结、8.嫉结、9.悭结。能和合苦故，名之为结：据实义来说，一切烦恼皆能合苦，唯爱等九法增盛，故特立结名。
     1.爱结：就是对于三界的贪，由贪结所系故，不厌离三界；由不厌离故，广行不善。由此不善业能招未来世的苦果，与苦和合相应。这就是爱结的自性、作用、行位；即贪是爱结的自性，广行不善是爱结的作用，招感后世苦果与苦果相应是爱结的生位。以下恚结等八种，皆准此例知，有相、用、位三种差别。
     2.恚结：是对于苦事与顺生苦受的根境和相应心所及一切有漏无漏但能生苦的法，心起损害。由恚结所系故，于可恚境心不弃舍；不弃舍故，广行不善，不行诸善。由此不善业，能招未来世的苦果，与苦相应。
     3.慢结：是依恃自己所长，于他有情高举傲慢。有七种九种的差别，可参看前五位百法中所说。慢结所系故，于我我所不知；不了知故，执我我所，广行不善，不行诸善。由此不善业，能招未来世苦果，与苦相应。
     4.无明结：即于三界无智。由无明所系故，于苦果法和集因法有漏诸行所有过患不能了解；不了解故，广行不善，不行诸善。由此不善业，能招未来世苦果，与苦相应。
     5.见结：见是三见：即萨迦耶见、边执见、邪见。见结所系故，于邪出离法，妄计追求，说我当解脱，我所解脱，这是身见。既解脱已，我当常住，或我当断灭，这是边见。又诽谤佛法中没有解脱，这是邪见。这样地执着邪出离已，广行不善，不行诸善。由此不善业，能招未来世苦果，与苦相应。
     6.取结：取是见取，和戒禁取。取结所系故，对于邪出离的方法，妄计执着，弃舍能真正出离行的八圣道，妄执萨迦耶见等及见取为先的戒禁取为清净道。由妄执着邪出离方法故，广行不善，不行诸善。由此不善业，能招未来世苦果，与苦相应。
     7.疑结：疑是于四谛三宝犹豫不决。疑结所系故，对于佛法僧三宝，不能修习正行，广行不善，不行诸善。由此不善业，能招未来世苦果，与苦相应。
     8.嫉结：嫉是嫉妒，即由于耽着利养的心很强，见到其他有情得到利养的时候，就不能忍耐地起嫉妒心。嫉结所系故，则爱重利养，而不尊敬善法；广行不善，不行诸善。由此不善业，能招未来世苦果，与苦相应。
     9.悭结：悭是腾惜，由耽着利养故，于资助生活的财物等，心生腾惜不舍。悭结所系故，爱重蓄积，不尊重远离；广行不善，不行诸善。由此不善业，能招未来世苦果，与苦相应。
     [2]缚：有三种：1.贪缚、2.嗔缚、3.痴缚。缚是缠缚义，即于欲贪等境界现前或不现前，而其根识不能弃舍，故名为缚。1.由贪缚故缚诸众生，令处坏苦；即为贪缚所缠缚故，对于随顺乐受的境界心不能弃舍，境界坏时，引生忧恼，故处于坏苦。2.由嗔缚故，缚诸众生，令处苦苦：即为嗔缚所系故，对于能随顺苦受的境界心不弃舍，境界苦相现前，心生苦受，故处于苦苦。3.由痴缚故，缚诸众生，令处行苦；即为痴缚所缚故，对于能随顺非苦非乐受的中庸境界，心不弃舍，为刹那迁流行相的不安稳性之所逼迫，故令众生处于行苦。由上说三义，故立贪等三种名之为缚。又依贪嗔痴故，于善法加行不得自在，亦名为缚。如《瑜伽》第八卷说：‘令于善行不随所欲，故名为缚。’
     [3]随眠：有七种：1.欲爱随眠、2.嗔恚随眠、3.有爱随眠、4.慢随眠、5.无明随眠、6.见随眠、7.疑随眠。随眠就是烦恼种子，即烦恼品所有的势力，随逐依附在有情身心中眠伏着，能为种子而生起一切烦恼现行，故立名随眠。欲爱随眠，就是欲界贪品烦恼的种子。嗔恚随眠，就是欲界嗔品烦恼的种子。有爱随眠，就是色界无色界贪品烦恼的种子。慢随眠，就是慢品烦恼种子。无明随眠，就是无明烦恼品的种子。见随眠，就是见品烦恼的种子。疑随眠，就是疑品烦恼的种子。这七种随眠，依未离欲界贪求的众生，由欲爱、嗔恚随眠之所随增故，建立欲爱随眠和嗔恚随眠。依未离邪梵行求的众生，由慢、无明、见、疑随眠之所随增长，建立慢、无明、见、疑随眠；即由彼众生得到二十分的对治法，便上起憍慢立慢随眠，对于圣谛愚迷不知立无明随眠，由此虚妄计度心外的邪解脱（前三见）和邪解脱的方便（二取见），因此对于佛圣教正法犹豫疑惑，如其次立慢、无明、见、疑随眠。
     [4]随烦恼：随烦恼即除去根本烦恼以外的所余染污心所，依《百法明门》所立有二十种：即忿、恨、覆、恼、嫉、悭、诳、谄、害、骄、无惭、无愧、掉举、昏沉、不信、懈怠、放逸、失念、散乱、不正知。这二十种随惑，都是从根本烦恼而起，所以名随烦恼。它的体性业用如五位百法中所解，这里不重说了。又随烦恼名，亦摄根本烦恼，如《集论》谛品中：‘又贪嗔痴，名随烦恼心所法，由此随烦恼随恼于心，令不离染，令不解脱，令不断障，故名随烦恼。’虽然随烦恼这个名称亦摄根本烦恼，但有此随烦恼却只能叫随烦恼，而不能称做根本烦恼；如忿恨等二十随惑皆是。
     [5]缠，有八种：1.昏沉、2.睡眠、3.掉举、4.恶行、5.痴、6.悭、7.无惭、8.无愧。缠是缠绕，由昏沉等诸缠，数数现行增盛，缠绕一切行者的心，于修善品诸法为大障碍，故名为缠。这八缠于四个时位数数现行，即于修习戒学的时候，无惭无愧为障，由具有无惭无愧二法，则犯诸学处，不生羞耻的心。修习定学的时候，昏沉睡眠为障，由此二法，于内心中引起沉没。修习慧学的时候，掉举恶作为障，由此二法数起现行，于外尘境界引心散乱。于同法者展转受用财法时，嫉悭二法为障，由有嫉悭，于财于法生起悭腾嫉妒，数数动摇其心。
     [6]暴流，有四种：1.欲暴流、2.有暴流、3.见暴流、4.无明暴流。随生死暴流水漂溺鼓动，是暴流义。即随顺生死杂染的意思。《瑜伽》第八说：‘深难渡故，顺漂流故，故名暴流。’就是有欲求的有情，对于欲界所系的上品烦恼未知未断，为欲界生死流漂溺鼓动，名欲暴流。已得离欲而习有求行的有情，于上二界所系上品烦恼未断未遍知，为上二界生死流漂溺鼓动，名有暴流。近习邪梵行求的有情，由于恶见虚妄计度邪外解脱及邪解脱方便，为恶见流漂溺鼓动，诸恶见略摄为一，名见暴流。起诸恶见，由有愚痴颠倒推求解脱（三见）及加行（二取）法，是起恶见的因缘，为无明流漂溺鼓动，诸恶见因缘略摄为一，名无明暴流。这后二种暴流，取三界外道的上品见痴为体。四暴流都取上品烦恼为体而不取中下品，是因为与暴流的名义不相当，以中下品烦恼非是暴流故。
     [7]轭，有四种：1.欲轭、2.有轭、3.见轭、4.无明轭。轭是系轭，用来轭牛的项领，令其拉车不能出驾，譬喻烦恼障碍离系，不得解脱。故障碍离系，违背清净，系碍于生死苦中，是为轭义。有情为四暴流所漂溺已，复为四轭和合系碍，便能够荷担生死苦。四轭的体相如《瑜伽师地论》八十九卷说：‘若诸烦恼等分行者，非增非减，即上所说的一切烦恼，（四暴流中的烦恼）说名为轭。’这就是说，四轭即取中品烦恼为体，不取下品烦恼，因为下品烦恼相非暴流非轭故。四轭的建立，如其次第，即依习欲求行、习有求行、习邪梵行求行三类有情而说，义如四暴流中的解释例知。
     [8]取，有四种：1.欲取、2.见取、3.戒禁取、4.我语取。取是执取，有两义：一执取诤根，二执取后有，是为取义。这四种取：是依在家众，和外道出家众而建立。由贪着五欲，系缚耽染为因，为得诸欲及为受用，诸在家众，互相斗诤，这诤的根本，是第一欲取。由贪着见，系缚耽染为因，诸外道出家众，更相斗诤，这诤的根本，是后三种取。六十二见（如五位百法中说）趣是见取。各别禁（遮戒）戒（性戒）多分苦行，是戒禁取。见取和戒禁取所依止的萨迦耶见，是我语取。我语取的语是增语义，就是由第六意识分别所计的作者受者流转还灭的工夫相所起的增益语为我语，于这我语上起贪着，名我语取。由于见取和戒禁取，诸外道众互相诤论，因为对于十二取处的见解不一致故。由于我语取，诸外道众互相诤论，因为对于我有自体性的见解相同，引起常、遍、大、小、与蕴一异等的诤论。由我语取，诸外道等与奉行佛教正法的人互起诤论，因为外道们不信无我理故。如上执着争论的根本即贪爱，由这贪爱为缘，复能引取后有苦异熟果法，故名为取。
     [9]系，有四种：1.贪欲身系、2.嗔恚身系、3.戒禁取身系、4.此实执取身系。系是缚缠身义、结生义，由贪欲等四系，缚有情身，结生相续。瑜伽第八卷说：‘难可解脱，故名为系。’《集论》说：‘此能障碍定意性身，故名为系。’定意性身简别非散心及非色身，即贪欲等四种皆说名身系，是指定心自性之身，约自体义名身，所依义名身。就是显贪欲等四种能为心的散乱因，而障碍定心。1.贪欲身系，由贪爱财物等为因，令心散乱。2.嗔恚身系，由于斗诤的事，不正行为因，令心散乱。3.戒禁取身系，由于难行的戒禁，苦恼为因，令心散乱。4.此实执取身系，由不如理的作意，推求境界妄生执着，执我及世间为常、无常等，计唯此真实，余皆愚妄，由此为因，令心散乱。因为对于贪欲等未断未遍知，为它所系缚，所以说名为系。
     [10]盖，有五种：1.贪欲盖、2.嗔恚盖、3.昏沉睡眠盖、4.掉举恶作盖、5.疑盖。盖是覆障义，覆蔽其心，障诸善品，令善法不得显了故。五盖在五位中障善法：1.贪欲盖，于乐出家位为障。就是一个有情在发起乐欲出家的时候，由贪欲盖，对于色声香味触五种妙欲境界，随逐净相、欲见、欲闻、乃至欲触，希求受用。牵引心识向外尘境界散乱，对于出家不生欣乐。2.嗔恚盖，于觉邪行位为障，觉是发觉，就是自己由于邪行犯了学处，同梵行的道伴们正发觉或举发的时候，心生嗔恚。由心嗔恚，不正修学，障碍诃谏正行。3.昏沉睡眠盖，于修习专注的止位为障。由不守根门，食不知量等，引起身心昏昧的昏沉和心极昧略的睡眠，障碍明静的止，无由得定。4.掉举恶作盖，于修习观慧的举位为障。举是策举，就是策举其心，于所缘境上思惟修观，由掉举心于亲属国土等生起寻思，由恶作于别离亲属国土等生起追悔，障碍观心于所观境上明静专注的思惟修，观慧无由生起。5.疑盖，于修习平等正直住的舍位为障。舍是平等正直住，在修习止观的时候，若已经远离了昏沉掉举，心安明静，则应当平等正直住；由疑心犹豫猜度，于所学的法和所证的功德境界，疑惑不决，心怀二分，远离决定，障碍舍故。五盖之中，昏沉睡眠是近而相顺的法，若生昏昧，必引起睡眠，故合立一盖。掉举恶作，同依亲属国土等寻思境而怀念追悔，同一境转，故合立一盖。又《瑜伽师地论》八十九卷约违背五处建立五盖，如彼论说：‘复次违背五处，当知建立五盖差别：一为在家诸欲境界漂沦故，违背圣教，立贪欲盖。二不堪忍诸同法者，诃谏驱摈教诫等故，违背所有可爱乐法，立嗔恚盖。三由违背奢摩他故，立昏沉睡眠盖。四由违背毗钵舍那故，立掉举恶作盖。五由违背于法议论，无倒决择审查诸法大师圣教，涅槃胜解故，建立疑盖。’
     [11]株杌，有三种：1.贪、2.嗔、3.痴。株杌是秃树根，譬喻贪等三种根本烦恼坚固难拔，对治道犁难以破坏故。因为众生从无始以来，串习贪等以成贪等的业行，引起心不调顺的贪，无所堪能的嗔，难可解脱的痴；由于众生难断这根深蒂固的贪等行，故立贪等为株杌。
     [12]垢，有三种：1.贪、2.嗔、3.痴。垢是不净义。由依止贪嗔痴故，毁犯戒行学处，作诸恶行，染污不净，故立名为垢。
     [13]常害，有三种1.贪、2.嗔、3.痴。贪等三种，常能为害，由此招感生老病死等苦。常为害故，立名常害。《集论》说名烧害，如《集论》说：‘由依止贪嗔痴故，长时数受生死烧恼，故名烧害。’
     [14]箭，有三种：1.贪、2.嗔、3.痴。由依止贪嗔痴故，于有果法及三有的因，深起追求：于佛法僧，若集灭道，常生疑惑。由此生死相续不绝，而不知希求解脱。于有有具和三宝四谛，随爱疑门，违背三宝四谛，顺趋生死轮回，贪等三毒，能射伤诸行，故立名为箭。
     [15]所有，有三种：1.贪、2.嗔、3.痴。所有是从果法立名，贪嗔痴三应名能有，由贪等故，能积集所有资财，恒常与怖畏等相应，多住散乱，故名所有。
     [16]根，有三种：1.贪、2.嗔、3.痴。贪等三法，是三不善根，即贪不善根、嗔不善根、痴不善根。由贪等故，生起一切的不善法，为一切不善法生起的所依根本，故名为根。
     [17]恶行，有三种：1.贪、2.嗔、3.痴。行是业行，即身语意的造作。由依止贪嗔痴故，恒行身语意恶行，是邪行自性，故名恶行。由贪进求财利等，多行恶行。由怀嗔恚，不忍他过，多行恶行。由怀愚痴，起颠倒的邪见，因而杀生祠祀天神等，行诸恶行。
     [18]漏，有三种：1.欲漏、2.有漏、3.无明漏。漏是流散义。《瑜伽论》第八卷说：‘流动其心，故名为漏。’《集论》说：‘令心连注流散不绝，故名为漏。’依外门流注：即心于五欲外尘境界中流散，建立欲漏。体即欲界一切烦恼唯除无明，说明欲漏。依内门流注，即于内根身等上流散，建立有漏。体即色无色界一切烦恼唯除无明，说有漏。依彼二所依门流注故，立无明漏。体即三界所有无明，总摄为一，名无明漏。
     [19]匮，有三种：1.贪、2.嗔、3.痴。匮是缺乏、不足。《瑜伽师地论》第八说：‘无有厌足故名为匮。’由依止贪嗔痴故，于资助生命的财物等，恒起追求，没有满足。因为贪得无厌，故常为贫乏众苦之所恼乱。由贪嗔痴，能令身心恒感觉贫乏，是故立名为匮。
     [20]烧，有三种：1.贪、2.嗔、3.痴。烧是烧热。由贪嗔痴于所缘境界不如正理，执着相好、起强烈地爱染故，烧热身心，故名为烧。
     [21]恼，有三种：1.贪、2.嗔、3.痴。恼是恼乱。由贪嗔痴于诸可爱境相爱乐耽看，若可爱境相变坏的时候，便引起种种的愁叹等忧苦，恼乱身心，故名为恼。
     [22]有诤，有三种：1.贪、2.嗔、3.痴。诤是斗诤，贪嗔痴能为斗讼诤竞的因，由贪嗔痴故，执持刀杖等，兴诸战诤，种种斗讼，所以贪等，说名有诤。
     [23]火，有三种：1.贪、2.嗔、3.痴。火是烧毁义，由贪嗔痴故，烧坏所积集的善根薪，故说贪等名火。
     [24]炽然，有三种：1.贪、2.嗔、3.痴。炽然是大火，这里譬喻恶业。由负嗔痴故，为非法贪的大火所烧：非法贪就是贪着十种不善业道。由贪嗔痴故，又为不平等贪的大火所烧；不平等贪就是非法非理的贪求境界。由贪嗔痴故，又为邪法大火所烧；邪法大火就是一切外道的恶说法律。因为非法贪等能够引发身心中的炽然大火，如猛火烈焰，故名炽然。
     [25]稠林，有三种：1.贪、2.嗔、3.痴。大树聚集，名为稠林。由贪嗔痴故，于生死根本的烦恼，和杂染的业行，广兴染着，令诸有情，感种种身，流转五趣，长夜处于生死轮回中，如行走在大树稠林里，难可出离。生死因即贪等三毒，三毒果即生死，生死即稠林，稠林由大树，大树即三毒，三毒起生死稠林故。所以贪等，说名稠林。
     [26]拘碍，有三种：1.贪、2.嗔、3.痴。拘碍是拘束障碍。《瑜伽》第八卷说：‘能令众生乐着种种妙欲尘故，能障证得出世法故，若为拘碍。’由贪嗔痴故，依于五处起拘碍：一顾恋内身，二顾恋诸欲，三乐相杂住，四缺于随顺教诫教授，五于诸善品得少为足。于上说五处拘碍心故，不能自在地修诸善法，故名拘碍。
    乙、烦恼增上所生业
    （一）业的体性
    集谛体性的第二部分是烦恼增上所生的业，也就是有漏业，若不与烦恼相应的无漏业，则非集谛所摄了。业是造作义，它的总相，即思业和思已业。思业就是心内的种种分别思虑，心性界的造作。思已业即由分别思虑的意业发现于外的身体上的动作和言语动作。这思业和思已业，都是以思心所为体性。思有三种：（1）审虑思，即将发动身语作业时审虑此事应当作否的思。（2）决定思，即于将要作的事情，起决定心的思。（3）动发胜思，就是正动身发语势用强胜的思。前二思是意业，亦即名思业。《集论》里说：‘思已业云何：谓身业、语业、意业。’意业即指贪嗔邪见，由思引发，故名思已业。第三动发思是身语业，亦即名思已业，以身业等体非即思，但由思所引发，故名思已业。身语二业，以第三动发善不善的思为体，意业以前二思为体，如《成唯识论》卷一说：‘能动身思，说名身业：能发语思，说名语业；审决二思，意相应故，作动意故，说名意业。’
    （二）业类差别
    （1）二业类
    [1]善业与恶业：恶业即十种不善业道：一杀生、二不与取、三欲邪行、四虚诳语、五离间语、六粗恶语、七杂秽语、八贪欲、九嗔恚、十邪见。善业即十善业道，就是远离杀生，乃至远离杂秽语、无贪、无嗔、正见。业以思为体，十善十恶有所造作共名为业，是思所游履故，通生苦乐异熟果故，故名为道。
    [2]引业与满业：六趣有情各有总报和别报的差别，总报即各趣有情得到的色心相续；别报就寿夭智愚，色形的好丑全缺等。引发总报的强业名为引业；成满别报的业。名为满业。如《杂集论》谛品中说：‘又善不善业，于善趣恶趣中，感生异熟时，有两种差别：谓招引业、圆满业；招引业者，谓由此业，能牵异熟果。圆满业者，谓由此业生已，领受爱不爱果。’
    [3]作业与不作业：作就是起造现行，作业即意思业，和思已所起的身业语业。不作业，即不思业和不思已不起身业语业。
    [4]黑业与白业：黑业就是招感秽恶不净的苦果业，白业就是招感净妙清白的乐果业。
    [5]增长业与不增长业：不增长业《瑜伽师地论》第九卷说有十种：‘一梦所作业，二无知所作业，三无故思所作业，四不利不数所作业，五狂乱所作业，六失念所作业，七非乐欲所作业，八自性无记业，九悔所损业，十对治所损业。’除开上面十种业，所余诸业，能有增进长养的力量，名为增长业。
    [6]故思业与不故思业：故思业就是经过故意思惟以后而起的业，即经过审虑思、决定思、动发思而起造的业，是为故思业。若非经过故意思惟，由刹那任运起和不知不觉地误起的业，是为不故思业。如《瑜伽师地论》第九十卷说：‘故思所造业者，谓先思量已，随寻思已，随伺察已，而有所作。……若异此业，是即名为非故思造。’这故思所造业，为《集论》说略有五种：‘谓他所教敕故思造业，他所动请故思造业，无所了知故思造业，根本执着（为贪等蔽心执着发起故思）故思造业。颠倒分别（依不平等因见受等发起故思）故思造业。’这五种故思所造业的解释，详在《杂集论》中。
    [7]定受业与不定受业：《瑜伽》第九十卷说，定受业就是故思所造的重业，不定受业就是故思所造的轻业。《瑜伽》第九卷说：‘顺定受业者，谓故思已，若作若增长业。顺不定受业者，谓故思已，作而不增长业。’作与增长的解释，如《杂集》论：‘作者，谓起造诸业，令其现行。增长者，谓令习气增益。’这定受业，又有作业决定、受异熟决定、分位决定的差别。解释详如《杂集论》中。
    [8]异熟已熟业与异熟未熟业：异熟已熟业就是已经与果的业，异熟未熟业，就是未与果的业。
    [9]重业与轻业：无论是善业与恶业，都有轻重的差别，《瑜伽论》第九十卷说：‘由三因缘，令业成重：一由意乐故，二由加行故，三由田故。’由意乐故成重，就是在作业的时候，由极猛利的意念对于所作的事情寻思伺察而起造作。由加行故成重，就是对于所念的事业长时无间地去作，和很殷勤尊重的去作。由田故成重，田是造作事业的对境，如田中播下种子决定会长出苗芽的果实，若对于自己有恩的有情，如父母师长等，与他们为造作事业的对境田，无论作善行恶行都成重业。与上所说相违的所作业，则名为轻业。
    [10]共业与不共业：共业就是能令器世间成种种差别的业，因为器世间是一切有情共有的，故招感此共相世间的业称为共业。不共业就是能令有情世间成种种差别业，即各个有情招感各自所依根等的业，所招感的根等唯属己有，不为其他有情所受用，故名不共业。这有共中共、共中不共、不共中共、不共中不共的差别，详辩在《成唯识论》第二卷述记中。
    （2）三业类
    [1]身业、语业、意业。身业即身体上的造作，语业即口上的造作，意业即思于意中的造作。
    [2]善业、不善业、无记业。由无贪无嗔无痴为因缘而起造的业，招感可爱的乐果，是为善业。由贪嗔痴为因缘而起造的业，招感非可爱的苦果，是为不善业。非无贪无嗔无痴为因缘，亦非贪嗔痴为因缘而任运起的业，不招感爱非爱果，于善不善二种行相不可记别故，是为无记业。
    [3]律仪业、不律仪业、非律仪非不律仪业。律是法式、仪是轨范，由内心发誓遵守一定的法式和轨范而起造的业，是为律仪业和非律仪业。律仪业有三种：1.别解脱律仪所摄业，就是佛弟子所受的律仪：即比丘律仪、比丘尼律仪、式叉摩那（正学女）律仪、勤策（沙弥）律仪、勤策女律仪、邬波索迦（近事男）律仪、邬波斯迦（近事女）律仪、近住律仪（即受八戒者，为不能远离恶行，及不远离欲行的人，受一日夜戒，使其暂近依止，故名近住）。2.静虑律仪所摄业，即由四种静虑能够损害伏除那发起犯戒的烦恼种子的所有远离功能，是为静虑律仪所摄的身语业性。3.无漏律仪所摄业，即已见谛的圣者由无漏作意力量所得的无漏远离的戒性，是名无漏律仪所摄业。不律仪是一种恶戒法，受持不律仪的人，就是由于生在不律仪事业种姓中而造彼业，或由于誓愿定期受持不律仪事而造彼业，这不律仪事业，《集论》中说有十五种：一屠羊、二养鸡、三养猪、四捕鸟、五捕鱼、六猎鹿、七置兔、八劫盗、九魁脍、十害牛、十一缚象、十二立坛咒龙、十三守狱、十四谗讲、十五好为损等。论文既然说好为损等，其等字之义，即摄取一切损害水陆生命等事皆为不律仪事业。非律仪非不律仪所摄业，除前三种律仪业及不律仪业之所余的一切善不善与无记业。就是不受持律仪亦不受持不律仪的普通人所作的布施爱语等业。和欧打恶语等业，不为律仪不律仪所摄，故名非律仪非不律仪业。
    [4]施性业、戒性业、修性业。施性业，就是无贪无嗔无痴为因缘俱行的思，所起的能舍所施物的身业和语业。戒性业，就是律仪所摄的身语业等。修性业，就是由三摩地为因缘俱行引发的定思，是为修性业。
    [5]福业、非福业、不动业。福是殊胜义，即业自体及果俱可爱乐，相殊胜故，名为福业：就是欲界可系的善业。非福业即自体及果俱不可爱乐，相鄙劣故，名非福业；就是欲界所系的不善业。不动业即色界无色界所系的善业，因为上二界定地业在受异熟果时，界地决定，不可改转，故名不动。虽然上二界善也应名福业，但约其比前福业更为殊胜的意义，所以特立不动的名称；因为欲界中余趣圆满的善不善业，会遇缘时可能改转得余趣果故。
    [6]顺乐受业、顺苦受业、顺不苦不乐受业，顺乐受业。就是从欲界乃至第三静虑所有的善业；此业能顺乐受而招感异熟乐故。顺苦受业，就是欲界所系的不善业；此业能顺苦受而招感异熟果故。顺不苦不乐受业，就是从第四静虑以上乃至有顶诸地所有的善业，因为第四禅以上诸地，没有苦乐，唯与不苦不乐的舍受相应，这些地中所有的善业，亦唯招感与舍受粗应的异熟果故。
    [7]顺现法受业、顺生受业，顺后受业。顺现法受业，就是能招感现法果的业，如对于佛或阿罗汉等，造作善不善业，必得现法异熟；又由猛利意乐，猛利的加行去造作善不善业，于现法中亦得异熟成就；所以名顺现法受业。因为在现生中作现生即受果故。顺生受业，就是所作的善不善业，在现生中异熟未熟，于无间生中异熟成熟，即次生中当生异熟，所以名为顺生受业。顺后受业，就是所作的善不善业，于现法中和次生中异熟果俱未成熟，从次生以后的生中异熟方才成熟，即名为顺后受业。
    [8]过去业、未来业、现在业。过去业，就是住于习气位的业种，或已经与果，或还未与果，皆名过去业。未来业，就是未生未灭的业。现在业，就现前已造已思而未谢灭的业。
    [9]欲系业、色系业、无色系业。欲系业，即能招感欲界异熟果的业。色系业，即能招感色界异熟果的业。无色系业，即能招感无色界异熟果的业。
    [10]学业、无学业、非学非无学业。学业即有学圣人相续中，于时时间依增上戒、依增上心、依增上慧，修学无漏，及此后得的善有漏业。无学业，就是所作已办的无学果阿罗汉相续中所有的善业。非学非无学业，就是一般凡夫身心中所有善不善和无记业。
    [11]见所断业、修所断业、无断业。见所断业，就是由见道所断的烦恼相应所发思等诸业，及一切能往诸恶趣业，皆名见所断业。修所断业，就是由修道所断的烦恼相应所发思等诸业，及受善趣的善不善无记业，皆是修所断业。无断业亦名非所断业，就是一切有学无学相续中的出世间诸无漏业。
    [12]三曲业：依谄曲为因而生起的身语意业，名为曲业。即修行邪道者所有一切善不善业，由邪见所起，邪见增上力所生故，能障碍正直的八圣道支令不生长，故名曲业。又邪行者堕在断常二边，违处中行，故名曲业。
    [13]三秽业：依猛利贪嗔为因而生起的身语意业，能污秽相续，能障碍清净的八圣道支，令不生长，故名秽业。又异生对于圣教中，起颠倒见者，住自见取者，起邪决定者，起犹豫分别者所有的善不善业，皆名秽业。
    [14]三浊业：依猛利愚痴，上品钝根忘失念者，萨迦耶见为因而生起的身语意业，能障碍通达真无我义故，名为浊业。又依止外道生起颠倒见，能障碍通达真如义故，是一切如来清净圣教之所对治，为‘不信’混浊之所摄故，亦名浊业。
    以上三业，都是总约一切无漏业所有能为障碍体性而建立为曲秽浊诸染污业。
    [15]三清净业：一切能往善趣的妙行，由清净尸罗与正直见之所摄的身语意三业，远离毁犯戒见的垢故，所以名为清净业。又有异生于圣教中，起正决定者，不犹豫分别者所有的善业，亦名为清净业。
    [16]三牟尼业：《瑜伽》第九卷说名寂静业，第九十卷说名默然业。牟尼是梵语，汉文译言寂默，即诸烦恼寂灭之义。一切能往涅槃的妙行，即有学无学圣人所有的无漏身语意业，契证寂静理故，所以名为牟尼业。
    以上二业，都是总约一切无漏业随顺体性而建立的。
    （3）四业类
    复有四种业：一黑黑异熟业，二白白异熟业，三黑白黑白异熟业，四非黑白无异熟业能尽诸业。黑黑异熟业，就是欲界中的不善业，体即十种不善业，其性染污，故名为黑；又依此黑业能招感不可爱的异熟果，故总说名黑黑异熟业。白白异熟业，就是三界的善业，性不染污，不杂恶法，故名为白；又依此业能招感可爱的异熟果，故总说名白白异熟业。黑白黑白异熟业，即欲界所系的杂业，由善不善相杂故，非纯善纯恶，所以立名黑白黑白异熟业。黑白异熟之业，以恶强故，可名黑白，不可立名白黑，以善劣故。非黑白无异熟业能尽诸业，体即出世间的无漏诸业。说非黑白，是约遮烦恼表白净两义共合立名。非黑遮除烦恼，显示无漏业远离烦恼垢秽；白即表其体性情净；无异熟即显其与生死相违；能尽诸业，显其是诸有漏业的能对治者。由无漏业的力量，能永拔黑等有漏业招果的习气故。此无漏业在《瑜伽》中又名非黑非白无异熟业，这是就双简前二种业而立名，义无相违。
    （4）十业类
    十业就是十种业道，这有两类：一、十不善业道：即杀生、不与取、欲邪行、虚诳语、离间语、粗恶语、杂秽语、贪欲、嗔恚、邪见。二、十善业道：即离杀生、离不与取、离欲邪行、离虚诳语、离离间语、离粗恶语、离杂秽语、无贪、无嗔、正见。这十种业道，在下面说人天行果中将作比较细地解释，这里就不说了。
    除上所说业类差别以外，还有强力业、劣力业、可思议业、不可思议业，取受业、作用业、加行业、转变业、证得业，地狱业、畜生业、饿鬼业、人业、天业、不定业。《集论》《成实论》等，皆不出前已说业类所摄，恐太繁琐，且止不说。
    （三）集谛四行相
    如上所说集谛，总有四种行相：一因相，二集相，三生相，四缘相。集谛所有的惑业，是引起后有苦果的原因，即能引发后有的习气因，如种子是生起苗芽的亲因，故名因相。由诸有情所集积的惑业习气，在人天等有情类中，能为相似的形貌种类的平等现起因，而使其现行；如人与人相似，牛与牛相似，马与马相似等，即集起之义，故名集相。又由业烦恼的力量使各别有情内身相续生起无量品类差别，是决定于五趣四生三界九地等的生因故，是名生组。又一切有情身心中，虽然同时具有三界五趣四生的种子，但现在世唯生于此界此趣此生中，而非余界余趣余生，皆由业烦恼为助缘成此差别，因此有情舍已得自体而取未曾得的自体，即诸有情别别的得舍因，是名缘相。
    为什么于集谛说四行相呢？是为修观行的人于集谛修四行观，可以对治四种贪爱，四爱就是：一我爱，即于自体爱着；二后有爱，即希求当来自体差别：三喜贪俱行爱，即于现前的或已经得到的可爱的色声香味触法起贪着爱；四彼彼喜乐爱，即于所余未现前未得到的可爱色等起希求爱。这四种爱，是从常、乐、净、我四种颠倒而产生的，我爱就是我倒，后有爱就是常倒，喜贪俱行爱就是乐倒，彼彼喜乐爱就是净倒。修观行的人以智慧观察因等四相，就是对治四爱，亦即对治四倒；观察因相，对治我爱；观察集相，对治后有爱；观察生相和缘相通治四种爱。《杂集论述记》说：‘前二别治、后二通治故。’《瑜伽师地论》五十五卷说：‘问：何故于集谛为四行观？答：由有四种爱故。此四种爱，当知由常、乐、净、我爱差故建立差别：初爱为缘，建立后有爱；第二第三爱为缘，建立喜贪俱行爱，及彼彼喜乐爱；最后爱为缘，建立独爱；当知此爱随逐自体，又爱云何？谓于自体亲昵藏护。后有爱云何？谓求当来自体差别。喜贪俱行爱云何？谓于现前或于已得可爱色声香味触法起贪着爱。彼彼喜乐爱云何？谓于所余可爱色等起希求爱。’


三、灭谛

    三、灭谛
    （一）灭谛体相
    灭是灭尽义，即择灭无为，由圣无漏智慧的简择力，灭尽惑、业、苦三种杂染法，究竟证会静妙安稳的寂灭果，是即灭谛体相。《集论》解灭谛相文说：‘相者，谓真如，圣道，烦恼不生，若灭依，若能灭，若灭性；是灭谛相。’这是以灭所依的真如，能灭烦恼的圣道，和烦恼灭尽的灭性，总出灭谛体相。约实际来说，灭谛体性就是断尽烦恼，绝诸戏论，究竟寂灭的涅槃。如《瑜伽师地论》六十六卷说：‘复沈此烦恼粗重永灭，是有余依涅槃增上所立灭谛。又因永断，未来不生；及先世因受用尽已，现在诸行，任运谢灭：是无余依涅槃增上所立灭谛。’又《瑜伽论》六十八卷说：‘问：何等法灭故名灭谛耶：答：略有二种：一烦恼灭故，二依灭故。烦恼灭故，得有余依灭谛。依灭故，得无余依灭谛。’
    （二）灭相甚深
    有为绝诸戏论，究竟寂灭的灭相，甚深最甚深，望有为诸行，不可说异，不可说不异，不可说亦异亦不异，不可说非异非不异。说异则应离开诸有为法而有寂灭，则寂灭与诸行，不相系属，各别异体了。说不异则有为诸行应即寂灭，如是则寂灭应同诸行是有为，是有漏，是杂染，是不净等，与诸行相无有差别。说亦异亦不异，过同异不异；说非异非不异，过同不异异；即具有不相系属的染净无别等过失。故寂灭相，离四句，绝百非，言语道断，心行处灭，唯正智证知。
    （三）立名差别
    诸经论中，就灭相摄义差别，施设种种的异名，这里依《集论》所说差别的名称，略述如下：
    甲、依所灭法辨名差别，即依无余永断的总义，立有七种名称：第一‘名永出，永出诸缠故’；这是依永断现行烦恼的缠缚而立名。第二，‘名永吐，永吐随眠故’；这是依断烦恼的种子而立名。第三，‘名尽，见道对治，得离系故’；在烦恼聚中，唯有所余修所断的迷事烦恼存在，迷理烦恼见道已顿断尽，亦名为尽。第四，‘名离欲，修道对治，得离系故’；由修道渐断诸地烦恼，离诸地欲贪，渐次所显，故名离欲。第五，‘名灭，当来彼果苦不生故’；由烦恼永尽，当来的苦果，亦永灭不生，故名为灭。第六，‘名寂静，于现法中，彼果心苦，永不现故’；彼果即离系果，在证得离系果的有余依位，由证得心解脱故，心苦永不现行，心无扰动，故名寂静。第七，‘名没，余所有事，永灭没故’；即证寂灭以后，无为之余的所有宿业烦恼所感的有漏诸蕴事，自然灭尽，入无余依位，唯有清净真如离相湛然为依为住，余所有依事，皆永灭没，故名为没。
    以上七名，亦显示断惑的次第：即断惑的人，先伏现行，次断种子，所以先说永出永吐。在断种中，见惑顿断，修惑渐断，所以次说尽及离欲。见修二惑种子俱断尽已，当来的苦果决定不生，故次说灭。在证灭的时候，先证有余依，后证无余依，所以最后说寂静与没。
    乙、释自通名，这有二十一种名称的差别：（1）‘名无为，离三相故’；即寂灭无为，与生异灭三有为相究竟相违，故名无为。（2）‘名难见，超过肉眼、天眼境故’；即寂灭无为，不是肉眼和天眼的所见境，唯是圣无漏慧眼的所行境界，故名难见。（3）‘名不转，永离诸趣差别转故’；寂灭无为远离那落迦等诸趣往来流转，恒常安住不动，故名不转。（4）‘名不卑屈，离三爱故’；寂灭无为永离欲爱色爱无色爱，于诸有中无所有卑屈，故名不卑屈。（5）‘名甘露，离蕴魔故’；寂灭无为永离一切死所依蕴，故名甘露。（6）‘名无漏，永离一切烦恼魔故’；烦恼魔是有漏，寂灭无为永离烦恼，故名无漏。（7）‘名舍宅，无罪喜乐所依事故’；无罪喜乐即清净的解脱喜乐，寂灭无为是解脱喜乐的所依止，故名舍宅。（8）‘名州渚，三界隔绝故’；寂灭无为，于三界生死大海能为高原之隔绝，依譬喻立号，故名州渚。（9）‘名弘济，能遮一切大苦灾横故’；证得寂灭，生老病等诸苦灾横，永远绝离，故名弘济。（10）‘名皈依，无有虚妄，意乐，加行，所依止故’；寂灭无为是无有虚妄性之意乐及正加行的所依处，所依止，是皈依义，故名皈依。（11）‘名胜归趣，能为归趣一切最胜圣性所依处故’；归是归投归依，趣是趣向趣入。圣性即无漏圣道，寂灭无为，能为趣证最殊胜的圣性之所依止处，是阿罗汉证得涅槃的加行所缘境界，故名胜归趣。（12）‘名不死，永离生故’；有生必有死，寂灭无为无生，故名不死。（13）‘名无热恼，永离一切烦恼热故’；寂灭无为，永离一切求不得苦的大热恼故。（14）‘名无炽然，永离一切愁叹忧苦诸恼乱故’；寂灭无为极清凉，一切愁等炽然永息，故名无炽然。（15）‘名安稳，离怖畏住，所依处故’；寂灭无为，无老病死等一切怖异，是离怖的圣住所依处，即空住，无愿住，无相住，灭尽定住名圣住（瑜伽三十四卷），圣住离怖畏，不为老病等所动，故名安稳。（16）‘名清凉，诸利益事所依处故’；寂灭无为是一切无热恼的清凉善之所依，故名清凉。（17）‘名乐事，第一义乐事故’；第一义乐即出世间乐，寂灭无为是出生出世间乐的所依事，故名乐依。（18）‘名趣吉祥，为证得彼易修方便所依处故’；趣是趣入趣证，吉祥即涅槃，寂灭无为是趣入证得彼涅槃易修加行的所缘境，故名趣吉祥。（19）‘名无病，永离一切障碍病故’；寂灭无为远离恼烦等诸障碍病，故名无病。（20）‘名不动，永离一切散动故’；寂灭无为，离诸境界戏论散动，故名不动。（21）‘名涅槃，无相寂灭大安乐住，所依处故’；寂灭无为，永离一切色受想行识等一切有相，是究竟寂灭大安乐住的所缘境界，故名涅槃。
    丙、对苦谛辨名，这有五名差别：（1）‘名无生，离续生故’；苦谛相，就是于彼彼处有情类中，相继而生，寂灭无为与彼相义相违反，离续生相，故名无生。（2）‘名起，永离此后渐生起故’；苦谛相在有情续生已后，自身六根众分渐次圆满，寂灭无为，与彼相义相违反，永离渐次生起相，故名起。（3）‘名无造，永离前际诸业烦恼势力所引故’；苦谛相，有宿业烦恼的势力所造，寂灭无为与彼相义相违反，永离前际诸业烦恼势力，故名无造。（4）‘名无作，不作现在诸业烦恼所依处故’；现在苦谛，是能造作招感余生有异熟果的诸业烦恼之所依止，寂灭无为，与彼相义相违反不作现在诸业烦恼的所依处，故名无作。（5）‘名不生，永离未来相续生故’；苦相是后有异熟相续生起，无有间断，寂灭无为，永离未来相续生，故名不生。
    以上所说灭谛名义差别，皆依《集论》和《杂集论》说，在《瑜伽师地论》八十三卷中，亦有详细的解释。
    （四）灭谛四行相
    灭谛亦有四种行相：（1）灭相，就是为流转生死因的烦恼，灭尽无余，得离系故名灭相。（2）静相，就是行苦所摄的不寂静的五取蕴相，得离系故名静相。（3）妙相，于诸烦恼苦，究竟离系，自然乐净以为自体，净妙无喻，故名妙相。（4）离相，出众过患，常利益事，不复退转，最极安稳，故名为离。《俱舍论》二十六卷解灭谛四相说：‘诸蕴尽故灭，三火（贪嗔痴）息故静，无众患故妙，脱众灾故离。’为什么于灭谛说四种行相呢？《瑜伽论》五十五说：‘问：何故于灭论为四行观？答：由四爱灭所显故。’即灭相静相由灭我爱所显，第三妙相，由灭喜贪俱行爱（乐）和彼彼喜乐爱（净）所显，第四离相，由灭后有爱（常）所显。


四、道谛

    四、道谛
    （一）道谛体相
    道是能通义，即证得灭果的因，由道能通往涅槃城故。《俱舍论》卷二十五说：‘道义云？何谓涅槃路，乘此能往涅槃城故。或复道者，谓求所依依此寻求涅槃果故道，与余处立通行名；以能通达趣涅槃故道。’有正道和助道，正道即诸无漏的智慧，助道即诸有漏无方便对治诸善品法。由此道故，知苦、断集、证灭、修道，即为道体总相。
    （二）道谛差别
    甲、五相差别道
    道谛差别，总有五种：（1）资粮道，（2）加行道，（3）见道，（4）修道，（5）究竟道。
    （1）资粮道
    资粮道，即诸异生，由具自他圆满（论行中当说）为缘，发起希求解脱的善法欲，具足尸罗，守护根门，欲食知量，初夜后夜常勤修习止观，正知而住等，（《瑜伽》二十一卷说有十种，在下文说行中当详解释）即资粮道的体性。复有所余进习诸善，即闻思修所生三慧等。修习此故，得成见道位现观、修道位解脱的所依器性（内身相续堪任性）。《瑜伽师地论》二十二卷说：‘若自圆满，若他圆满，若善法欲，若戒律仪，若根律仪，若于食知量，若初夜后夜常勤修习觉寤瑜伽，若正知而住，若善友性，若闻正法，若思正法，若无障碍，若修惠舍，若沙门庄严，如是等法，是名世间及出世间诸离欲道趣向资粮。’具足尸罗等，都是资益希求解脱者成道的善法，如古时人行路有粮，能到所向处所，故名资粮，这资粮是顺趣解脱的远因，故亦名顺解脱分。
    （2）加行道
    加行道，即已积集资粮道者，为证道故加功用行，而进修暖等四法，故名加行道。前面说的资粮道，也有加行的意义，可以安立加行的名称。但这里的加行却非资粮，是已积集资粮者为得见道而安立名加行故。这加行有四位差别：（1）暖法位，由净定心，依谛增上契经等法为所缘，生起明得三摩地般若及彼定慧相应等法，是为暖位。是道火的前相，如古时钻木取火先有暖相，故名为暖。（2）顶法位，即于诸谛所缘中，智慧力增进，明相转胜，得明增三摩地般若及彼定慧相应等法，是为顶位。由前定慧展转增进居上位故，在有动的善根中最为殊胜，如上山至顶，故名为顶。（3）顺谛忍法位，由各别内自所证，于诸谛所缘中，一分已入于无所取，一向忍解故，一分随顺于无能取，随顺通达故，三摩地般若及彼相应等法，是为忍位。深忍印解，故名为忍。（4）世第一法位，由各别内自所证，于诸谛中，得无间心三摩地般若，及彼定慧相应等法，从此无间，必起最初出世道，是世间最殊胜的第一善法，故名世第一法位。这暖等四善根位，是顺趣真实决择分（见道）故，亦名顺决择分。
    （3）见道
    见道，由世第一法无间，引起无所得三摩地般若及彼相应等法，是见道体性。由无分别智最初照见诸法真理，故名见道。由真智通真如故，亦名通达位。又见道差别，如《瑜伽》五十八卷说一心见道，如《瑜伽》五十五卷及《显扬圣教论》十七卷说三心见道，《瑜伽》五十八卷复说九心见道，及《集论》等说十六心见道。但真见道位，无多心差别，故说多心见道差别，皆是假立，非真实尔。以出世位中，各别内证，绝诸戏论故。
    （4）修道
    修道，即从见道以上，所有世间道、出世间道、软道、中道、上道、方便道、无间道、解脱道、胜进道，皆名名修道。因为佛弟子们，已得见道，顿断三者迷理烦恼，从此以上，为断迷事烦恼，以胜方便数数修习世间道等，故名修道。这里把世间道等的差别意义略述如下：
    {一}九道
    {1}世间道，即有漏道，就是世间的初静虑、第二静虑、第三静虑、第四静虑、空无边处、识无边处、无所有处、非想非非想处。
    静虑即心体寂静，能审虑所缘的意思。《瑜伽师地论》三十二卷说：‘言静虑者，于一所缘系念寂静正审思虑，故名静虑。’空无边处等，是无色界的四定，就所依的境，心无分别，摄心一境，离诸色碍，故名无色定。又因四定都有心住于空，所以又名四空定。
    四空定的解释，广如《瑜伽师地论》三十三卷中，这里简单地解说如下：一空无边处定，即修定的人，已得第四静虑，厌患色质的障碍，心欲出离，即修观智灭除色相，缘空入定，心与无边际的虚空相应，是为空无边处定。二识无边处定，已得空无边处定的行者，感觉心住虚空，仍有相对的空相存在，尚非静妙，乃进而厌患虚空，泯除空相，转心缘识，住识无边相，名识无边处定。三无所有处定，已得识无边处的行者，感觉住识，仍有所依，乃厌患心识，舍识泯心，依无所有，寂然而住故，名无所有处定。四非想非非想处定，识无边处即想，无所有处即非想，已得无所有处定的行者，厌患无所想如痴如暗，厌患有想处如病如箭，如痈如疮；唯有非想非非想中，与上相违，寂静美妙；即舍无所有处定，心与非有想非无想法相应入定，名非想非非想处定。在此定中，由想昧劣，无下地胜想，得非想名，有昧劣的想存在，故名非非想。外道得了此定，执为涅槃。前三无色处，约加行立名；第四非想，当体立号。
    四静虑和四无色定，有四种相应当分别：一杂染，二清白，三建立，四清净。
    [1]杂染，由四无记根相应，定成杂染。四无记根即：爱、见、慢、无明，定地烦恼为定所伏，不发恶行，是有覆摄，故名无记。由此四惑，杂污其心，以诸染污静虑定为门，令色无色界一切有覆无记的烦恼随烦恼生长不绝，为能生起散烦恼的根本，说名为根。这是第六识中四种定烦恼，非是第七中相应的四惑。1.‘由有爱故，味上静虑，杂染所染’；（集论，以下同。）即贪味净定的轻安快乐。2.‘由有见故，见上静虑，杂染所染’；即依止静虑发起计度前际等六十二见。3.‘由有慢故，慢上静虑，杂染所染’；即依所证胜定，于下界生慢，计自地为胜等。4.‘由无明故，疑上静虑，杂染所染’；疑是疑烦恼，由无明增故而起疑，故由无明疑上静虑。即希求解脱的人，由于未通达真实道理，对于自己所证的殊胜品法，常生疑惑，疑所证是解脱呀？不是解脱呀？（广释四无记根，如《瑜伽论》十二卷。）由于爱等四惑，染污其心，令色无色界本随二惑相续流转。
    [2]清白，即清净的四静虑和四无色定，由体性是善故，说名清白。虽然是有漏的世间禅定，因其远离烦恼缠垢故，亦名为净。
    [3]建立，建立有四种：一支分建立，二等至建立，三品类建立，四名想建立。于色界诸静虑，具有四种建立。诸无色定，唯有三种，除支分建立，以无色定无支分故。
1.支分建立，初静虑有五支：一寻，二伺，三喜，四乐，五心一境性。系心于一所缘境，名心一境性。第三静虑有四支：一内等净，二喜，三乐，四心一境性。内等净的体即舍、念、正知，由摄念欲心于内，具有舍故，得心平等性：又已远离寻伺浊法，心得清净；即于内门中，远离沉浮寻伺，以念、正知、舍三平等令心品清净，所以总立名为内等净。第三静虑有五支：一舍、二念、三正知、四乐、五心一境性。第二静虑未离喜贪，故不别显舍念正知，第三静虑已离喜贪，故别显舍念正知的自相。第四静虑有四支：一舍清净，二念清净，三不苦不乐受，四心一境性。第四静虑超过寻伺、喜、乐三地（初二三禅）一切扰动故，心得平等性，正直性，无动转地安住，故具舍清净。又第四定已超过寻伺喜乐三地一切动法故，心无忘失而明静，故具念清净。
    在四种静虑中，为什么只建立这些支分呢？这里引《杂集论》决择分谛品文解答这一问题：‘问：法有无量，何故唯立寻等为支？答：对治支故，利益支故，彼二（对治、利益）所依自性支故，由此三种，支分满足，不待余故。初静虑中，寻伺二种，是对治支；能断欲界欲恚害等寻伺故。喜乐二种，是利益支；由寻伺支治所治已，得离生喜乐故。（离欲恶不善法而生起初禅喜乐。）心一境性，是彼二所依自性支；依止定力，寻等转故。第二静虑中，内等净是对治支；由此能治寻伺故。喜乐是利益支，心一境性，是彼二所依自性支。义如前说。第三静虑中，舍、念、正知是对治支，由此三能治喜故。乐是利益支。心一境性，是彼二所依自性支。义如前说。第四静虑中，舍清净，念清净，是对治支；由此二能对治乐故。不苦不乐受，是利益支。心一境性，是彼二所依自性支。诸无色中，不立支分，以奢摩他一味性故。’
     2.等至建立，就是由七种作意才能获得四种静虑及四无色定。七作意是：一了相作意，即由定作意，见欲界中过患等，了达粗相，见初静虑中，无有欲界粗相过患，寂静妙，名为静相，是名了相作意。二胜解作意，即从了相作意之后，超过闻思（了相作意为闻思所杂），唯用修行，于所缘的粗相静相发起胜解，是名胜解作意，三远离作意，由于胜解作意善修善习，善多修习为因缘，最初生起断烦恼的道，与道俱行的作意，是名远离作意。由这断道俱行的作意，能断欲界先所应断的烦恼及能远离烦恼品的粗重故。四摄乐作意，即从远离作意以后，修观行的人，能爱乐于断，爱乐远离，于诸断中见胜功德，触证少分远离的喜乐，为了除去昏沉掉举等，时时修习净妙作意，以悦其心，是名摄乐作意。五观察作意，修观行的人，由乐断乐修的正加行善品所资持故，令欲界所击的烦恼不复现行，为了想考验自己是否真正已断欲界烦恼，复更作意观察能生起烦恼的可爱净相，若心生烦恼，即知未正解脱，为欲断除烦恼故，正勤安住乐断乐修，是名观察作意。六方便究意作意，即从观察作意之后，为令欲界一切烦恼，于系时间得离系故，倍勤精进地修习奢摩他与毗钵舍那，由是因缘，从欲界系的烦恼中心得离系，这是初静虑最后的方便。故名方便究竟作意。《瑜伽》声闻地名加行究竟作意。七方便究竟果作意，修观行者，从方便究竟作意无间，证得根本最初静虑俱行作意，是名方便究竟果作意。声闻地名加行究意果作意。这七种作意的详细解说，可参看《瑜伽师地论》三十三卷，这里不繁引了。如上所说为证入初静虑，修习七种作意，如是应知乃至为证入非想非非想处定，亦皆修习七种作意。
     3.品类建立，就是修定的人，在修习的功行上有三品的差别，所以在生起异熟果时亦有三品差别，由因行品类不同，果位品类亦异。于初静虑定，具有下中上三品熏修，生果时即生下中上三品异熟，如是其余静虑，都有三品熏修，和三品异熟的差别，如在欲界修下中上初静虑，即生梵众天、梵辅天、大梵天，广如《瑜伽师地论》第四卷及《显物圣教论》第二卷中所说。无色界中，没有色贪，因此亦无安诸宫殿等处所，故不建立生果差别。然由三品熏修无色定故，彼异熟生时，有离下差别，即寿命任时满不满等，有劣胜差别，即染污不染污等。
     4.名想建立，于四静虑中三摩地的差别名字是无量无数的不可算数、不可思议，因为于初静虑所摄定中，诸佛世尊及已得究竟的大威德菩萨摩诃萨所入的三摩地，一切声闻及独觉等尚不能了解其名称，更不用说知其数量差别和证入了。如般若经及诸大乘经中，都以种种名称显示三摩地其数无量。如于初静虑所摄定，有无量名想差别，于其余静虑无量所摄定也是这样。如是所说差别，皆是依于静虑波罗蜜多而说。
    [4]清净，就是得根本定已，能引发胜品功德，无一切烦恼时，是名清净。即初静虑中边际定，乃至非想非非想处边际定，是名清净的静虑，清净的无色定。边显无越义，际显究竟。即已得的根本定其殊胜性至极究竟无可超越了。
    {2}出世间道，就是无漏道，即于修道中法智类智所摄的苦智、集智、灭智、道智，及彼相应的三摩地，皆是出世间道。其所依定，或者是未至定所摄，或者是初静虑乃至无所有处所摄。非想非非想处，唯是世间，因为非想定由不明了想恒时现前，没有猛利取所缘相的作用，不能作极明了现行的圣道之所依止，故非想地一向是世间所摄。所以世尊在经中说，只有有想的三摩钵底，才能如实照了通达无漏圣道。灭尽定亦是出世间摄，因为灭定是圣道后之所证得故。
    {3}软道，就是下品道，显其力量不够充足，故名软道。这软道中又分三品：即软软品道、软中品道、软上品道、由此三品道，能舍三界所系地地中，上上、上中、上下三品烦恼。
    {4}中道，亦有中软、中中、中上三品差别。由此三品道，能舍三界所系地地中，中上，中中，中软三品烦恼。
    {5}上道，亦有上软，上中，上上三品差别。由此三品道，能舍三界所系地地中，软上、软中、软软三品烦恼。
    对于软中上品道，复各别分为软等三类，建立九品，是为了显示修道所断的烦恼，是由渐次而断故。又缘软软品道，能断上上品烦恼，即身中极猛利粗重现行的烦恼，名上品烦恼。由于易可觉了，易可分别，犹如粗垢。微少对治，即能够除遣，故说软软品道能断上上品烦恼。下下品烦恼，即身中微隐现行的烦恼，难可觉了，难可分别，如微隐的尘垢，大力对治，才能除遣，故说上上品道，对治下下品烦恼。准此道理，当知所余的能治道与所治烦恼皆是相翻建立，也是这样的了。
    {6}加行道，即修道中，加功用行欣求断道，名加行道。由于正修行此道能渐舍离各别的上品等烦恼，转舍粗重一分，渐得转依。是名修道中的加行道，这里的加行道，通有漏无漏，通伏惑断惑，得择灭等。
    {7}无间道，即修道中更无隔越正能断惑的道。由这无间道，能永断上品等烦恼，令无所余，转粗重依，得无粗重。是名修道中的无间道。
    {8}解脱道，即证无为时，离缚自在。由这解脱道，能证烦恼永断所得的解脱，是名修道中的解脱道。
    {9}胜进道，即证得解脱道后，更修所余殊胜升进的道。观行者为了断除余品烦恼而进修的加行道、无间道、解脱道，望于前品是殊胜的升进，故名升进道。又复弃舍断烦恼的诸方便，但正思惟契经等法：或复于先所思所证法中，安住观察；或复进修余品胜定，诸如是等，亦名胜进道。又为引发神通等无量圣品功德；或彼神通等生已，现前安住，亦名胜进道。这里顺便说一下修道的修义。修的差别义，本来无量无边，略说有其四种：一得修，二习修，三除去修，四对治修。得修，即于未生善法，修习令生。为得故修，名为得修，由此修力，得所未得诸善法故。习修，即于已生善法，修令坚住不忘，倍复增广。习即是修，名为习修。由此修力，数习已得诸善法故。除去修，即于已生恶不善法，修令永断。为除去故修，名为除去修。由此修力，除去现行位诸不善故。欲界烦恼，能堕恶趣，故名为恶，能障善故，名为不善。对治修，即于未生恶不善法，修令不生。修习对治，名对治修。对治未来诸不善法，令成不生故。又由具有四种对治故，名为对治修：一厌坏对治，即于有漏诸行，见多过患，观察如病如痛等，由此厌患五取蕴。二断对治，由加行道及无间道，能断诸烦恼故。三持对治，即解脱道能任持所得无为功德。四远分对治，即解脱道后的诸道，能令先所断烦恼转远离故。这四种对治差别，是前对治修的差别义。
    {二}十一道
    {1}略说十一道
    又道差别，有十一种：一观察道、二勤功用道、三修治定道、四现观方便道、五亲近现观道、六现观道、七清静出离道、八依根差别道、九净修三学道、十发诸功德道、十一遍摄诸道道。这里是依于菩提分法等的差别而建立十一种，如其次第即三十七菩提分法，四种正行，四种法迹，奢摩他，毗钵舍那，三无漏根。
    十一道怎样配属菩提分法等的意义昵？《杂集论》中说得很清楚，这里抄录如下：‘观察事道者，谓四念住，由此最初以不净等行，观察一切身受心法事故。勤功用道者，谓四正断，由遍观察一切事已，为断诸障，发勤精进故。修治定道障者，谓四神足，如是净除一切障已，复由欲勤心观门，修三摩地令成调顺堪任性故。现观方便道者，谓信等五根，如是修治三摩地已，为欲证得无漏圣道，勤修增上缘暖顶方便故。亲近现观道者，谓信等五力，如是已得增上缘者，为欲无间通达谛理，修习摧伏不信等障，忍等第一法近方便故。现观道者，谓七觉支，由此最初内证觉真理故。清净出离道者，谓圣八支道。由从此后，为令修道取断烦恼永得清净，修出离道故。由此道理，菩提分法，如是次第。依根差别道者，谓四正行，由依近分根本等地差别，及利钝根差别故。苦正行者，依止未至及无色定，如其次第止观劣故。乐正行者，依止根本静虑双道转故。一（苦乐）迟通者，谓钝根依苦乐。二速通者，谓利根依苦乐。净修三学道者，谓四法迹，由此净修增上戒等三学故。无贪，无恚，能净修治增上戒学，终不于贪欲嗔恚门，毁犯所学处故。正念，能净修治增上心学，由不忘所缘，持心令定故。正定，能净修治增上慧学，由心得定，能证如实智故。发诸功德道者，谓奢摩他毗钵舍那，由此能成办一切功德故。摄诸道道者，谓三无漏根，由此能摄初、中、究竟一切道故。未知欲知根，摄方便道及见道。已知根，摄修道。俱知根，摄究竟道。’
    {2}五门立菩提分法
    一切菩提分法无差别地皆由五门而得建立：一所缘，二自体，三助伴，四修习，五修果。这里分别解说如下：
    [1]四念住
    由慧令念住身等四境，故名四念住。1.所缘，即身、受、心、法。这就是于四事起缘，即缘我所依事、我受用事、我自体事、我染净事。为什么四念住唯以身等为所缘境呢？因为颠倒众生多分计执我依止有根身，受用苦乐等，取了境为相，于相上由贪等染污，由信等清净。为令观行者，最初正观察真实事相，所以建立身等四事为所缘境。2.自体，即慧及念，由于身等随观的慧与念俱起，故用慧念为体。3.助伴，即念慧相应的心心所等。4.修习，即于内身等修循身等观。就是于内色、外色、内外色，以分别影像身，与本质身，平等循观。如是于受、心、法亦修循受等观总起来说，即观身不净、观受是苦、观心无常、观法无我，广如《集论》卷六与《杂集论》决择分谛品及《瑜伽师地论》二十八卷所说。5.修果，由于内身等修循身等观，如其次第能断除四种颠倒，趣入四谛，身等离系，是名修果。断四颠倒，即由修四念住随其次第，能断除净、乐、常、我四种颠倒。于身修不净故，断除净倒。于了知诸受皆是苦故，断除乐倒。通达诸识依根缘境，念念变异故，断除常倒。观察染净，唯有诸法，无作用的主宰故，断除我倒。又修四念住，如其次第，趣入四谛，亦是修果。由身念住，趣入苦谛；所有色身，皆是行苦相粗重所显故。由受念住，趣入集谛：以乐等诸受，是和合受（于坏苦性位起和合受）等所依处故。由心念住，趣入灭谛；观离我之识当来无所有，恐惧我断灭，于涅槃所生的恐怖永远离掉故。由法念住，趣入道谛；为断所治法，为修能治法故。又修四念住，如其次第，能证得身受心法离系果：由修习念住，渐渐地能远离身等粗重故。
    [2]四正断
    四正断，又名四正勤，由精进力能断自所除的懈怠障碍法，故名四正断。1.所缘，即已生、末生、所治、能治法。初正断已生所治的恶不善法为境。第二正断，缘未生所治的恶不善法为境。第三正断，缘未生能治的善法为境。第四正断，缘已生能治的善法为境。2.自体，正断的自体就是精进。3.助伴，即彼相应的心心所等。4.修习，《集论》说：‘修习者，如契经说：生欲，策励，发起正勤，策心，持心。此中诸句，显修正勤，及所依止。所依止者，谓欲。正勤者，谓策励等。’这就是说以欲为依而发起策励等正勤。据《杂集论述记》说，前三句在闻思位，后二句在修位。生欲，即于已生的恶不善法，生起乐断欲，于未生的恶不善法，起遮令不现行欲；于未生和已生的善法，皆生起证得欲。策励就是于已生的恶不善法不忍受励力趣断，于未生的恶不善法不忘住正念令不现行；于未生的善法以正方便策励生起，于已生的善法以正方便摄持不失。发起正勤，就是于已生和未生的恶不善法，一心精进，修正方便，令生令长。策心持心，就是于已生和未生的恶不善法而修观慧的时候，若心昏沉没，当策练其心令举，除遣昏沉等烦恼的染污。若心掉举，当制持其心令下，除遣掉举诸过，令修慧得生。5.修果，由修正断，能尽弃舍一切所治法，于能治法，能得能生。即初二正断，能尽舍一切所治的恶法；第三正断，得能对治的未生善法；第四正断，增长能对治的已生善法。
    [3]四神足
    四神足，即欲勤心观四种三摩地。神即神通，神是妙用莫测，通是无碍自在，神通有不可推测的微妙作用，一切如意自在，所以名神通，实即智慧的作用。足是基础义，即欲等胜定是发生神通妙用的因，是神通的基础，所以名神足。四神足的所缘境，即缘由已经成办圆满的殊胜定力，而发起的种种神变功德事。它的自体，即殊胜的三摩地。助件，即欲、勤、心、观，及彼相应的心心所等。欲三摩地，即由猛利乐欲增上力起正便而成就的心一境性。勤三摩地，即由恒常精进，无时暂间的增上力而成就的一境性。心三摩地，即由于前生数修定力，令彼种子功能增长，今时由种子功能，令心专注于内法的增上力，任运于三摩地随顺而转，由此速证心一境性。观三摩地，即由听闻他人教法，依智慧内自简择观察的增上力而成就的心一境性。修习，即数数修习八种断行。八断行就是：欲、精进、信、安、正念、正知、思、舍。《辩中边论辩修对治品》说欲等八法，能治懈怠、忘圣言，及昏沉掉举、不作行、作行五种过失，故名八断行。即为灭除懈怠，修欲、勤、信、安四种断行。为断除后四种过失，如其次第修习念、正知、思、舍四种断行。这八种断行。略摄为四类：一加行，二摄受，三继属，四对治。加行摄欲、精进、信三种。欲为精进的所依，由对于三摩地乐欲，才肯精进修习故。信为欲因，由想求得三摩地的乐欲，是依于信受有三摩地可得和能得故。摄受就是轻安，由于轻安摄益身心故。继属就是正念、正知，由正念不忘失所缘，能安心于一境故。由有正知，于有放逸生，则能如实了知故。对治摄思和舍，由思能策举心，舍能制持心。由策心持心两种力量，于修习止观品中已生沉掉能远离故。即由思对治昏沉，舍对治掉举。《瑜伽师地论》二十九卷解八断行中说：‘七者思，谓心造作，于断未断正观察时造作其心，发起能顺止观二品身业语业。八者舍，谓引过去、未来、现在随顺诸恶不善法中，心无染污，心平等性。’修果，总说有三：一由已善修治三摩地故，于随已所乐欲证得和所欲通达的法，即能随心通达变现。二证得堪能，具自作用，即远离已生未生的不善法，修集已生未生的善法，故《集论》说：‘于别别处所法中证得堪能。’由证堪能心有自在作用，如已所愿的乐欲而能成办种种神通等事。三能引发种种殊胜功德。
    [4]五根
    信、勤、念、定、慧五法，名五根。根是增上义，由这五法能出生一切善法，为一切善法生起的根本，故总名为根。五根的所摄境，就是四圣谛。由此五根是修起现观的加行所摄而作此行相故。五根的自体即：信、精进、念、定、慧。助伴，即彼相应的心心所等。修习是：信根，于诸谛生起忍可行的修习。精进根，于诸谛生起忍可已后，为觉悟诸谛，发起精进的修习。念根，是于诸谛发精进已，起不忘失行的修习。定根，是于诸谛既系念已，起心一境性行的修习。慧根，是于诸谛既得定已，起简择行的修习。修果是：能速发谛现观；因为由于修习五根的增上力，不久即能生起见道故。又能修治暖法和顶法，引发忍法和世第一法。即于现在此身入顺择分位—加行道。
    [5]五力
    五力，即前五根法，所缘境和自体、助伴、修习，皆与根相似，但果有差别，即由于清净的信等五法力量增盛，能损减不信等所对治障，不可屈伏，能破他恶法，能修治忍法和世第一法，转立名力。即于天、魔不能转，业、烦恼不能屈，故名为力。如《杂集论》说：‘如说果者，谓能损减不信等障故，胜过于前，虽与五根所缘境界自体等相似，然不可屈伏，义有差别故，别立力分（菩提分）。’
    [6]七觉支
    七觉支是：念觉支、择法觉支、精进觉支、喜觉支、轻安觉支、定觉支、行舍觉支。觉即是智慧，支是分类，分类不同而有十种，故名七觉支。七觉支的所缘境，即四谛如实性。如实性就是清净所摄的胜义真实性。觉支自体是，念、择法、精进、喜、安、定、行舍。念是所依支，由系念故，令诸善法皆不忘失。择法是自体支，是觉的自相，慧以简择为性故。精进是出离支，由精进努力，能达到所欲到的处所故。喜是利益支，由喜适悦势力，令身心调畅故。安、定、行舍是不染污支，如其次第，由轻安故不染污，以轻安能除粗重过失故。由依定故不染污，依止于定得到转依故。舍是不染污体，由舍永除贪忧不染污位为自性故。如《集论》说：‘安定舍是不染污支，由此不染污故，依此不染污故，体是不染污故。’觉支助伴，即彼相应的心心所等。觉支修习，如《集论》说：‘修习者，谓依止远离，依止无欲，依止寂灭，回向弃舍修念觉支，如念觉支，乃至行舍觉支亦尔。如是四句，次第显示缘四谛境修习觉支。’如以念缘苦体法为恼苦（苦谛）时，于苦境界，必求远离，即名‘依止远离’修念。若以念缘可爱相苦集法认为是苦集（集谛）时，于此可爱相境界，必求远离，即名‘依止离欲’修念。若以念缘苦灭为苦灭（灭谛）时，于此苦灭境界，必求作证，即名‘依止寂灭’修念。若以念缘趣入苦灭行（道谛），知由行势力弃舍苦故，于此趣苦灭行境界，必求修习，即名‘回向弃舍’修念。回是回转，而不随顺生死流，向是趣向，即趣向于能灭苦集的道，弃舍烦恼业苦。觉支修果，即见道所断烦恼永尽断灭，因为七觉支是见道的自体故。大乘说七觉支在见道位，如《瑜伽师地论》二十九卷说：‘彼于尔时，最初获得七觉支故名初有学，见圣谛迹，已永断灭，见道所断一切烦恼，唯余修道所断烦恼。’
    [7]八圣道支
    八圣道即正见等八法。得无漏智慧，契证真理，名之为圣。运载游履，称之为道。正见等八法，是圣人所游行的迹路，所以名为圣道。八圣道的所缘境，即是见道后的四圣谛如实性，由于见道以后所缘的境界，即以先前见道时所见诸谛如实性为体故。道支自体即：正见、正思惟、正语、正业、正命、正精进、正念、正定。正见是分别支，如先前见道所证起真实简择故。正思惟是诲示他支，如（相似相称义）其所证，而方便善巧地安立名言以教诲开示他人故。正语、正业、正命是令他信支，如其次第能令他人对于已证真理者决定信有正见、正戒、正命清净性故。即由发正语，随自所证真实义，善能问答论议决择，听闻的人，由此了知证理者有见清净。由于正业，往来进止，正行具足，能令见闻的人，了知证理者有戒清净。由正命故（即远离五种邪命的如法生活。五种邪命是：一为利养故，诈现奇特。二为利养故，数自说功德，三为利养故，占相吉凶为人说法。四为利养故，高声现威，令人畏敬。五为利养故，称得供养，以动人心。邪缘活命，名为邪命），如法乞求佛所听许的衣钵资具，见闻的人，由此了证理者有命清净。正精进是净烦恼障支，由此永断一切烦恼结故。正念是净随烦恼障支，由有正念，不忘失正止、正举、正舍相，永不容受掉举等随烦恼故。正定是能净最胜功德障支，由具正定，能引发神通等无量殊胜功德故。道支助件，即彼相应的心心所等。道支修习，与七觉支修习相同，即‘依止远离，依止无欲，依止寂灭，回向弃舍’，修习正见，乃至修习正定。道支修果，即分别、诲示他、令他信、烦恼净、随烦恼障净、最胜功德净。
    以上依《集论》五门建立三十七菩提分法竟，详细的解说，可参看《瑜伽师地论》二十八卷和二十九卷。
    {3}四正行
    四正行是依根差别道：一苦迟通行，二苦速通行，三乐迟通行，四乐速通行。迟速是约能修道人的钝利根以辨差别。通是修行义，行即智、见，为尽诸漏所修智见，故名正行。《俱舍论》二十五卷说：‘道于余处，立通行名。以能趣涅槃故。’《集论》说：‘初谓钝根（迟）未得根本静虑（苦）。第二谓利根（速）未得根本静虑（苦）。第三谓钝根（迟）已得根本静虑（乐）。第四谓利根（速）已得根本静虑（乐）。’这就是说，苦正行者，依于未至定、中间定，或无色地三定修无漏道名苦通行，以所依的定无喜乐等支作功德，未至定奢摩他微劣，无色地毗钵舍那微劣，止观不等，转进艰辛，故名苦通行，但有利钝二根差别，钝根者名苦迟通行，利根者名苦速通行。乐正行者，即已得根本静虑的行者，依于四根本定起无漏道，以所依定是止观平等的双运转道，具现法乐住，故名乐通行者，由于利钝二根差别，钝根的人，名乐迟通行，利根的人，名乐速通行。如《显扬圣教论》卷二说：‘一苦迟谓钝根者已得现法乐住，为尽诸漏苦见苦行。四乐速通，谓利根者，余如前说。’
    {4}四法迹
    四法迹是净修三学道，即无贪、无嗔、正念、正定，此四法是戒定慧三增上学的所依因，故名为迹，无贪无嗔，为戒学的所依因，能令增上戒学清净：不因贪欲嗔恚而毁犯学处故。正念是定学的所依因，能令增上心学清净；由于所缘无所忘失，持心令定故。正定是慧学的所依因，能令增上慧学清净：由定心者，能证如实智故。
    {5}奢摩他毗钵舍那
    奢摩他毗钵舍那是发诸功德道，由这止观能够成办一切功德故。
    奢摩他有九种住心差别：一于内摄心令住（《瑜伽》三十卷名内住），即摄敛其心，不向外攀缘，令住于内所摄境，离内散乱，最初系心，故名令住。二等住，由内住最初系缚粗动心已，未能令心于所摄境，相等续住，今即以清净方便挫令微细，令心于所缘境相续系念，故名等住。三安住，由方便力虽然能够令心于所缘相内住等住，但有时会失掉正念，于外境驰流散乱，即以正知还复摄录，安置于内所缘境，故名安住。四近住，安住之后，为令其心，于外不散，数数作意，内住其心，亲近于内所缘境，不远住于外，故名近住。五调顺，由清净方便，虽然内心能勉强内住，乃至近住，但心未调柔，于强盛的色声香味触相，及贪嗔痴男女等相，乃会生起散乱，故于散乱之因的色等相，起过患想，由此增上力，调伏其心，令不流散，故名调顺。六寂静，这是进一步调制内心，即在修定中有种种欲患害等诸恶寻思，贪欲盖等诸随烦恼，令心扰动，今即取彼诸法，深见过患，由这想增上力，于诸寻思及随烦恼，止息其心，令不流散，故名寂静。七最极寂静，在寂静住中，有时失念，寻思等率尔现行，即随所生起的诸恶寻思，及随烦恼，能不忍受，让它相续，即便制伏断除，令不更起，故名最极寂静。八专注一趣，即于最极寂静住中，由精进加行，无间无缺地相续安住于胜三摩地，故名专注一趣。九平等摄持（《瑜伽》名等持）由数修数习善修习故，得无行用任运道转，由是因缘，不由加行，不由功用，心三摩地，任运相续，离乱散转，故名平等摄持。
    毗钵舍那总的差别有四种：一简择诸法，二最极简择，三普遍寻思，四周审观察。简择诸法，即缘诸法尽所有性的观行；尽所有性，即蕴处界的事边际相。最极简择，即缘诸法如所有性的观行；如所有性，即四圣谛、十六行相、真如、一切行无常、一切法无我、涅槃寂静、空、无愿、无相。普遍寻思，即由有分别作意，随寻思行慧思量推察所闻所受持的法相。周审观察，即委细推求，就是以随伺察行慧审细观察所闻所受持的法相。如是四种观行，为欲对粗相结故，依净行所缘境界而修；为欲制伏诸颠倒故，依善巧所缘境界而修；令无倒心善安住故，依净惑所缘境而修。如《瑜伽师地论》第三十卷说：‘于诸法中，能正思择，最极思择，周遍寻思，周遍伺察，是名四种毗钵舍那。云何名为能正思择？谓于净行所缘境界，或于善巧所缘境界，或于缘所缘境界，能正思尽所有性。云何名为最极思择？谓即于彼所缘境界，最极思如所有性。云何名为周遍寻思？谓即于彼所缘境界，由慧俱行有分别作意，取彼相状周遍寻思。云何名为周遍伺察：谓即于彼所缘境界，审谛推求周遍伺察。’净行所缘有五种：一不净所缘境，对治多贪行。二慈悲所缘境，对治多嗔行。三缘起性所缘境，对治多痴行。四界差别所缘境，对治骄慢行。五入出息念所缘境，对治寻思行。由观这五种所缘，可以对治贪等粗重相结。善巧所缘亦有五种：一蕴善巧，二界善巧，三处善巧，四缘起善巧，五处非处善巧。令于诸法远离无因生，不平等因生，是缘起善巧观。于诸法了知因果相称摄受生，是处非处善巧观。由这五种善巧观，能对治诸颠倒妄执。净惑所缘，即依世间道观下地粗性，上地静性，能制伏烦恼不起现行：观真如及四圣谛，能永净烦恼：是名净惑所缘。
    又奢摩他毗钵舍那建立四种道：[1]一类行者，已得奢摩他未得毗钵舍那，这就是已得世间定的行者，由于未得简择诸法的慧，乃依奢摩他进修圣教所有性和如所说简择诸法尽所有性的毗钵舍那道。[2]一类行者，已得毗钵舍那未得奢摩他，这是已得圣教闻思二慧，或修慧中的胜解作意，乃至方便究竟作意位。而未证得三摩地。这类行者，即依闻思慧而进修奢摩他道。[3]一类行者，未得奢摩他亦未得毗钵舍那，这一类行者，必须由听闻正法，如理作意，宴坐住心，专心制伏昏沉掉举，双修二道。[4]一类行者，已得奢摩他和毗钵舍那，这一类行者，则能止观二道和合平等双转，
    {6}三无漏根
    三无漏根：即未知当知根、已知根、具知根。这三根是遍摄诸道道。三无漏根，是二十二根（二十二根义可参阅《瑜伽师地论》五十七卷）中的最后三根。体即意根、乐根、喜根、舍根及信、勤、念、定、慧九根。《杂集论》虽说在加行道时，有于解脱希求欲证愁戚所摄的忧根，但忧根体性唯是有漏，非三无漏正根的体，故多不说。依意等九根，于见修无学三道中作增上，如其次第建立三无漏根。[1]未知欲知根，即于加行道及于见道十五心刹那中，于未见谛作见增上，即欲知先所未知的真实谛理而修习转，故名未知欲知根。《成唯识论》则分为三位，如该论卷七说：‘未知当知根体，位有三种：一根本位，谓在见道（前十五心时），除后刹那（第十六心），无所未知可当知故。二加行位，谓暖、顶、忍、世第一法，近能引发根本位（见道）故。三资粮位，谓从为得谛现观故，发起决定胜善法欲，乃至未得顺决择分所有善根，名资粮位。能远资生根本位（见道）故。于此三位，信等五根，意、喜、乐、舍为此根性。加行等位（资粮位、七地以前未离欲者，小乘初二果末离欲者），于后胜法，求证愁戚，亦有忧根，非正善根，故多不说。’[2]已知根，即从第十六见道心刹那以上，乃至金刚喻定，一切有学道中所有诸根，于断障作增上，即数数修习见道中已知的境，无所未知可当知故，名已知根。[3]具知根，即于无学道中作现法乐住增上的所有诸根，即阿罗汉等所有的信等九根，无学身中，所应学无故，应知的已知，具有其知，故名具知根。
  （5）究竟道
    究竟道就是无学道，《集论》卷六说：‘依金刚喻定，一切粗重，永已息故；一切系得，永已断故；永证一切离系得故；从此次第无间转依；证得尽智及无生智、十无学法等……如是等法，名究竟道。’金刚喻定，即居修道最后断结道位所有三摩地，能坏一切障，极其坚猛，故喻如金刚。粗重，在《集论》里说有二十四种，总起来说，就是一切有漏种子习气和一切有漏不安稳性。系得，就是一切的有漏法。离系得，就是涅槃。无间转依，即已证得无学道的三种所依：一心转依，即已得无学道，证得法性心，自性清净，永离一切客尘烦恼故，名为转依，就是真如转依义。二道转依，就是从前的世间道，在现观时转成出世，说名有学，若永除一切所治，永离三界贪欲时，此道自体究竟圆满，名为转依。三粗重转依，即阿赖耶识中，一切烦恼随眠永远离故，名为转依。尽智，即由因尽所得智，名为尽智；就是于无学位中，由永断集，令无有余所得的智，故名尽智。或缘尽为境，名为尽智；就是缘招感苦果的集因尽为境，故名尽智。无生智，即由果断所得智；就是由有当来一切苦果毕竟不生法性故而得此智。名无生智。或缘果不生为境，名无生智，即缘苦谛无生为境，名无生智。十无学法，即无学身中的无学正见、无学正思惟、无学正语、无学正业、无学正命、无学正精进、无学正念、无学正定、无学正解脱、无学正智。无学正见，即阿罗汉于苦思惟苦，于集思惟集，于灭思惟灭，于道思惟道，无漏作意相应，简择法，最简择等是名无学正见。正思惟等，准此例知。详细的解释，可以参阅《集异门论》第二十卷。无学正解脱，即无学身心上离一切烦恼粗重的调柔堪忍法。无学正智，即阿罗汉的尽智及无生智。又十无学法，当知依无学戒蕴、定蕴、慧蕴、解脱蕴、解脱知见蕴说。无学正语、正业、正命，是无学戒蕴摄。无学正念、正定，是无学定蕴摄。无学正见、正思惟、正精进，是无学慧蕴摄。无学正解脱，是无学解脱蕴摄。无学正智，是无学解脱知见蕴摄。
   （三）道谛四行相
    道谛有四种行相：即道相、如相、行相、出相，这四相如其次第即资粮道、加行道、见道、修道、究竟道所摄。（1）道相，即由这圣道是圣者们证得涅槃真义游履的迹路，所以名道。（2）如相，即一切烦恼皆由不如理作意所起，这道谛是如理作意所起，由此如理的道谛，能正对治不如理的诸烦恼，所以名如。（3）行相，由行善能成办净心，令不颠倒，即成办（造作义）名行：以心不觉悟真实，是由于无常等法，生起常等的颠倒妄执，此道行善能修治这颠倒心，令其远离颠倒而觉悟真实，故名为行。（4）出相，即由此圣道，能趣出离的究竟涅槃，永离烦恼业苦，故名为出。
    为甚么于道谛作四行相观昵？由作此四观，能证得常、乐、净、我四种爱之永灭故。如《瑜伽师地论》五十五卷说：‘问：何故于道谛为四行观？答：由能证彼四爱灭故。’


五、总分别十六行相

    五、总分别十六行相
    前面所说的四谛十六行相观，皆通世间与出世间，其差别点有三：
（一）世间行相，于所知境，不善悟入。出世间行相善巧悟入。
（二）世间行相有障碍，出世间行相无障碍。
（三）世间行相有分别，出世间行相无分别。就是于诸谛中的无常苦等十六种所缘境界，起世间智行相作观察的时候，不能善巧地通达真如实性，故不善悟入。由于不能通达真如实性，即不能断除烦恼，故世间行相为烦恼所随逐，是有障碍。世间行相依名言门生起无常苦等戏论，故是有分别。出世间智行相现前的时候，现证无常等义，断除烦恼，远离障碍，但不依名言戏论门，见此是无常等义。故出世间行相于所缘境界，善巧悟入，无障碍性，无有分别。


六、四谛的因果次第

六、四谛的因果次第
    上来已将四谛的义理，概略地介绍完了，这里说一说它的因果次第。四谛中的前二谛，是世间因果，也就是杂染因果，流转因果，集谛是因，若谛是果。后二谛是出世间因果，也就是清净因果，还灭因果；道谛是因，灭谛是果。这四谛的世出世间因果次第，为什么都是先说果法后说因法呢？这是因为在观理修行的时候，必须首先了知一切有漏果报皆苦，其次求知招致此苦的原因；了知灭苦，心须灭因，所以先说苦谛，后说集谛。灭道二谛也是这样，了解究竟寂灭的解脱为乐，因而生起要求证灭的仰慕之心，由此而寻求解脱方法的正道，所以先说灭谛，后说道谛。故四谛的因果次第，不是依于法相生起的因果次第而建立，乃是依于观理修行的因果次第而说的。


第五节 十二有支

    第五节 十二有支
    一、名义
    佛陀成道，悟得有情之流转生死，皆由无明为缘，造业受果，而轮转不息。观其循环的因果关系，不出十二有支，即：无明、行、识、名色、六处、触、受、爱、取、有、生、老死。有即三有，支是支分，无明等十二法，是有情流转三有的支分，故名有支。又有情自体，总名为有，自体中的一分说明为支，总十二支说一自体，折一自体为十二支，是故说名十二有支。这十二有支，又名十二因缘、十二缘起、十二缘生。因是顺益义，无明等十二法，展转能为顺益生果，故名为因。缘，是相借义，由十二法互相借助，生死相续无有穷尽。缘起偏重因义，如《俱舍论》九卷说：‘诸支因分，说名缘起；由此为缘，能起果故。’若依大乘义，即无明等一一支各各别法，依自种子为因生起自法现行，说名缘起。《瑜伽师地论》第十卷以五义释缘起，如该论说：‘何故缘起说为缘起？答：由烦恼系缚往诸趣中数数生起，故名缘起。此依字释名。复次，依托众缘速谢灭已，还和合生，故名缘起。此依刹那义释。复次，众缘过去而不舍离，依自相续有得生起，故名缘起。（此约长时生死相续）。如说此有故彼有，此生故彼生非余。此依义故，释名应知。复次，数数谢灭，复相续起，故名缘起。此依数坏数灭义释。复次，于过去世觉缘性已，等相续起，故名缘起。如世尊言，我已觉悟，正起宣说，即由此名展转传说，故名缘起。’缘生偏重果法，如前《俱舍论》说：‘诸支果分，说缘已生。’若依大乘义，即前前支为缘生起后后支，由无名现行生故生起行支现行，乃至生支现行为缘生起老死，前支为缘生起后支，说名缘生。《瑜伽师地论》五十六卷说：‘复次，云何名缘生法？谓无主宰，无有作者，无有受者，无自作用，不得自在，从因而生，托众缘转，本无而有，有已散灭，唯法所显，唯法能润，唯法所润堕在相续，如是等相，名缘生法。当知此中，因名缘起，果名缘生。’又如《瑜伽师地论》第十卷说：‘云何缘起？云何缘生？谓诸行生起法性，是名缘起。即彼生已，说名缘生。’总起来说，有支、因缘、缘起、缘生等名义，皆是显示无我：缘起显无我理，缘生显无我相，有支、因缘兼显无我理和无我相。所以佛陀说十二缘起的道理，主要地就是显示有情的流转生死，并没有主宰、自在固实的我体，和外道所计的作者、受者，唯是烦恼、业行、苦果的相依，循环的因缘相续而已。如世尊在缘起经里说：‘依此有故彼有，此生故彼生。所谓无明缘行、行缘识、识缘名色、名色缘六处、六处缘触、触缘受、受缘爱、爱缘取、取缘有。有缘生、生缘老死，起愁、叹、苦、忧、恼，是名纯大苦蕴集。’
    二、支分略释
    （一）无明支，这是根本烦恼之一，迷暗为性；对于四谛、三宝、善恶业果等愚迷暗昧，不能如实了知，故于所知真实能为覆障。这略有两种：（1）迷理无明，即异熟愚。（2）相应无明，即境界愚。这无明支，唯取能发动正感后世善恶的迷理无明，立以为支。由迷理故，发业势力增盛，取以立支，相应无明不尔，所以不立。此通现行及种子为体。《十地经》说无明有二，谓子时果时故。通不善无记。即有覆无记，上二界无明亦能正发行故。
    （二）行支，行是造作义，即由前无明所发动的招感总报的身语意三业，体即第六意识相应的思心所。这业有善、恶、无记三性的差别，和招感总报业与招感别报业的差别。这行支，唯取招感总报的善恶业立支，不取招感别报业及无记业立支，因为无记业不感果，别报业非正感生死的主力故。此亦通现行及种子为体。《十地经》说行有二种，谓如无明有子时果时，行亦尔故。唯善不善性。
    （三）识支，识就是心王，若依小乘说，即总取六识为识支。若依大乘，此识是最初入胎的识，即唯取第八阿赖耶识安立为支，结生相续唯是第八阿赖耶，其余诸识无此功能故。
    （四）名色支，这是结生以后，在胎内四周中间的一个分位，总以五蕴为性。名是受、想、行、识四蕴，包括心王心所，属于精神系的法。因此位在胎内不久，心的作用昧劣，又非如色法有见有对可得，由名诠显，才能了知，故称为名。色即色蕴，包括五根及根依处，即属于物质系的法。在此法中，身体支节尚未形成，故总称为色。总摄具有精神和物质的胞胎，合立名色。
    （五）六处支，处是十二处中的内六根处，体即名色。这是胎内五七日以至出胎之间的分位。前名色支，六处初起尚未圆满，但名名色，今此位中，身体支节，渐已成形，眼根、耳根、鼻根、舌根、身根、意根，圆满具足，已能生长眼等诸识，故转立名处。处是生长门义，由根为识的所依，令识得生及长，故名为处。与前名色行相有别，故别立支。
    （六）触支，触是遍行心所之一，即出胎后由根境识三和合而生起的触。这触有两种：（1）无明相应触，（2）明慧相应触。唯取无明触立支，明慧触非流转生死法故。
    （七）受支，受也是遍行心所之一，以领纳为性。由触为缘，于顺乐诸根境界生起适悦受，名乐受；于顺苦诸根境界生起逼迫受，名苦受；于顺不苦不乐诸根境界，生起非苦非乐的舍受。此有无明触所生受，与明慧触所生受两种差别，唯依无明触所生受立以为支，明慧所生受，非流转法故。
    识、名色、六处、触、受五支，经论中多说现种为体，若依《瑜伽师地论》第七（说为胎脏苦故）及《成唯识论》卷八所说，皆唯取种子为体。如《成唯识》说：二所引支：谓本识内亲生当来异熟果摄识等五种，是前二支所引发故。唯无覆无记性摄。
    （八）爱支，即由爱为缘而于三界诸行生起染着希求，体即是贪。这有两种：（1）自体爱，即迷内异熟果愚，发起的贪爱。（2）境界爱，即迷外增上果愚，缘境界爱，发起的贪爱。由此二爱润发亲生当来生老死位的识等五果种子，转更增盛，是为爱支。虽然其余的烦恼也有润发当来苦果种子的功能，然就胜而论以贪为本，贪爱如水，于种子有特殊的润生势力，故立爱为支。此通取现种为体。
    （九）取支，《十地经》等说爱增名取，体即是贪。由爱为缘，于三界贪着，由是贪心发展增盛。复生起欲取、见取、戒禁取、我语取，是为取支。于诸欲所有欲贪名欲取，三界中的见取名见取，三界中的戒禁取名戒禁取，三界中的身见名我语取。所执的我无有实体，唯有我名的空语，故名我语取。据实而论，取支通取一切烦恼，《瑜伽论》说：一切烦恼令生相续故，即通见修所有烦恼令生相续。《十地经》等虽说爱增名取，是约爱润胜说，非无余惑。此通取种现为体。
    （十）有支，即积集的善恶业种，及识名色六处触受五名言种，由爱取滋润摄受，有大势力，能引生后有苦果，转名为有；以能有当生，令生有将入现在，故总合由爱取合润的业种及名言种，立为有支。此唯取种子为体。由前六法种子转名为有故。
    （十一）生支，生是二十四种不相应行法之一，体即五蕴现行果法。即依现有爱取有三支为因，又引起当来世于四生中结生，是名为生。就是从中有初生以后，至本有中未衰变位，皆是生支所摄。以异熟五蕴为体。
    （十二）老死支，心色等衰变位，总名为老。身坏命终，入灭相位，即名为死。老非定有，附于死支中，故合老死立支，此亦以异熟五蕴为体。
    三、次第
    如来于十二有支为什么最初宣说无明，最后宣说老死，这样的次第建立有何意趣呢？《瑜伽师地论》第十卷约三义说缘起次第，这里且约当来世引生五果为因的次第略说如下：一个有情之流转生死，首先是对于所应知的事相理体愚迷无知。由此无知发起定招三有果报的业行善恶，这种业行违于还灭，论中总称为邪行。起邪行故，令心识颠倒：由心颠倒故，结生相续而有名色；由有名色，诸根渐次圆满而有六处；由此有触，由触引受，触为受依；由此触受二法受用境界，于境界耽染爱着，希求追取，由是烦恼滋长，发后有业行；业滋长故，五趣果生，生已变坏，老死生起，故十二支如是次第。如《瑜伽师地论》第十卷：‘问：何因缘故，无明等诸有支作如是次第说？答：诸愚痴者，要先愚于所应知事，次即于彼发起邪行；由邪行故，令心颠倒；心颠倒故，结生相续；生相续故，诸根圆满：根圆满故，二受用境；受用境故，若耽着、若希求；由希求故，于方觅时，烦恼滋长；烦恼滋长故，发起后有爱非爱业；由所起业滋长力故，于五趣生死中苦果生；苦果生已，有老死等苦，谓由身变异所引老死苦，及境界变异所引忧叹苦。是故世尊，如是次第说十二支。’
    四、总别业用
    总起来说，十二有支能令有情生死流转。生死的体即生老死二支，前十支为因能令生等转起，使有情生死轮转无穷，此即十二有支的总业用。别业用，在《十地经》和《集论》中于各支都说两种，这里依集论卷三所说略运如下：
（一）无明有二种业：[1]令诸有情于有愚痴；已得未得的自体名有，由无明覆蔽故，于前际、中际、后际不能如实了知，因而生起这样地疑惑：我于过去世曾有呀？非有呀？曾经得过什么有情的体性？生何种姓族类？广如《缘起经》及《瑜伽师地论》卷九所说无明差别。[2]与行作缘由无明的势力为增上，令后有业得增长故。
（二）行有二种业：[1]令诸有情于诸趣中种种差别，由业行的势力，令诸有情趣于种种不同的则异趣类中，领受差别的生死果报。[2]与识作缘，由业习气势力增上，令第八识现行相续，并能使当来名色等生起种子，得增长故。
（三）识有二种业：[1]持诸有情所有业缚，诸有情由造善不善业流转生死，不得解脱，是名业缚。即第八识与业行所引的习气俱生俱灭，使业种不失不坏，故说彼识能持业缚。[2]与名色作缘，由第八总报识入母胎后，名色得增长故。
（四）名色有二种业：[1]摄诸有情自体，有色无名，但是非情，由有名色，然后才能名为有情，得预入于有情众同分的差别之类，故说名色摄有情自体。据实而论，唯第八识才真正是有情的自体性。[2]与六处作缘，由名色等前支为依止，六处等后支得生起故。
（五）六处有二种业：[1]摄诸有情自体圆满，由六处生已诸根具足，无有缺减，故说为自体圆满。[2]与触作缘，依根发触，相显易知，由根变异生触近胜故。
（六）触有二种业：[1]令诸有情于所受用境界流转，依触为门，受用顺乐受等三种境界而流转三界故。[2]与受作缘，由触为依引生受故。
（七）受有二种业：[1]令诸有情于所受用生果流转，由受为依，诸有情领受种种可爱不可爱等业所招感的异熟果故。[2]与爱作缘，由受故引起和合及乖离的希求诸爱生故。
（八）爱有二种业：[1]引诸有情流转生死，由爱势力，如水润发业种及识等五种，引令有情生死流转无有断绝。[2]与取作缘，由爱味求欲为门，于三界四取中贪欲转起。
（九）取有二种业：[1]为取后有，令诸有情发有取识，有取识的有，是有无之有，取是爱为缘取的取，有爱为缘取的异熟果识，说名有取识。以有所持的被润种子，说能持识为有取识即为取五趣后有相续不断，取令业习气得决定果故，发起有取识，说名发有取识。[2]与有作缘，由取势力增上，诸行习气能转变成熟为有故。
（十）有有二种业：[1]令诸有情后有现前，由有故能引起后有自体现前，从此趣命终已，无间隔地生余趣中故。[2]与生作缘，由有势力，余众同分即未来自体得转起故。
（十一）生有二种业：[1]令诸有情名色、六处、触、受次第生起，由于生故，能引起名色等后后位差别生起。[2]与老死作缘，由有此生，彼相续变坏皆得有故。
（十二）老死有二种业：[1]数令有情时分变异，由有老故，破坏少壮盛色，衰朽形腐，诸根老耋。[2]数令有情寿命变异，由有死故，离解支节，破坏寿命，弃舍诸蕴。
    五、因果差别
    诸经论所说十二有支因果总有五种：
（一）等起因果，即前前支为因，后后支为果，由前前支势力为因，平等引起后后支得生起故。十二支中无明唯因，老死唯果，其余十支亦因亦果。无明为什么唯是因支呢？因为无明以前再无分支，无所从起，故唯是因支。老死为作么唯是果支呢？约一期相续说，老死无所再起，故唯是果支。其余行等十支，前有所从的因支，后有所起的果支，对前所从的因支，自己是果，对后所起的果支，自己是因，是故亦因亦果。如《瑜伽师地论》第十卷说：‘问：几唯是因，几唯是果？几通因果：答：初一唯因，后一唯果，余通因果。’
    （二）本末因果，无明、爱、取三支，体即烦恼，是生起业、苦的根本，故无明等三唯是因支。生、老死二，唯是果支，因为生与老死，体即苦法，是惑业的果，及识等五种之果故。其余识等七支，亦因亦果，是烦恼之果，生老死之因故。如《瑜伽师地论》第十卷说：‘三唯是因，二唯是果，当知所余，亦因亦果。’又生与老死。唯是果末，前六支即爱、取、有三乃是因本，受支通因果通本末。如《瑜伽师地论》第十卷说：‘几说为因分：谓前六，无明乃至触，及爱、取、有三说为因分。几说为果分？谓后二说为果分。几说为杂因果分？谓所余支说为杂分。所以者何？有二种受名为杂分：一谓后法以触为缘因受，二谓现法与爱为缘果受，此二杂说为触缘受。’受种子以触为缘，是后际现行受果的因，故后因受。现世生死位的现起报受为缘生爱，是前际受种之果，故名果受。受通种现，故说为杂分。问：识等五支，皆通因果，何以偏说受为杂分呢？答：识等五支，唯取种子，从受起爱，多因现起果受而生，故于受中通说因果，识等四支，唯种为缘，不要起现方生后支，故不为例。
    （三）异熟非异熟因果，即识、名色、六处、触、受及生老死七法是果，识等五支种子望生老死二支来说，虽然五种是未来生老死苦果的因，但于现世位亦说五支为现行，即约在生老死位中的识等五现行法而说，故七支皆是其果，异熟法故，亦正果体。其余无明行及爱取有五支，则唯是因法，非异熟果故。如《瑜伽师地论》五十六卷说：‘又现在果所摄五支，及未来果所摄二支，总名果所摄缘起。当知余支是因所摄缘起。’
    （四）熟未熟因果，这里所说的熟，是熟变和正熟：未熟名因熟变正熟名果。十二支中，前七支是因，犹未熟故；后五支是果，由已熟故。即爱取是前无明之增长，故爱取是无明之成熟，有支是前业等种为爱等所润将熟得果，是行等六法熟故；生老死二支正是熟时；故皆后果。《杂业论》本事分中三法品说：‘于因时有能引所引，于果时有能生所生。’于因时有能引所引，即无明等前七支是因，犹未熟故。于果时有能生所生，即后五支是果。名已熟故。
    （五）正熟非正熟因果，正熟即正成熟时，非正熟是因，正熟是果，即前十支是因，非正熟故；后二支是果，是正熟故。《瑜伽师地论》第九第十卷等，皆说能引支的无明行，所引支的识等五种，俱是牵引因，引生老死二种果故。爱取有是能生因，近生老死故。生老死是引生二因之果，是正熟果体。故《成唯识论》卷八说：‘以十二支，十因二果，定不同世。’若约识等五当生位说，虽然亦是果法，然此明正熟时分定体，故不取说。
    以上所说十二支相望的五门因果，摄诸经论所说因果意义，更无增减。
    六、能所引生
    十二有支，在远近因果，和已润未润的因果关系上，诸支相望。《缘起经》、《瑜伽论》、《对法论》、《成唯识论》等，皆略摄为四支：一能引支、二所引支、三能生支、四所生支。
    （一）能引支，体即无明行。由无明于诸谛境无智为先，造诸业行，熏习在第八识中，能引熏识、名色、六处、触、受五果的种子，故名能引支。如《成唯识论》卷八说：‘一能引生，谓无明行，能引识等五果种故。’虽无明行二与生老死为引因体，然前十支俱是因故，不可远望生死老二果为能引支，故但望近所熏增的识等五种名为能引。
    （二）所引支，体即第八本识内，由前六无明行为增上缘所熏习的亲生当来的识、名色、六处、触、受五果的因缘种。识等五种虽是当来五果的亲因缘性，正是当来五果的引因，识等五果种子未被行支熏时，不能堪生现行，由加行支熏发，即堪生现行。故从前二支为增上缘的引发势力，说名所引支。如《成唯识论》说：‘二所引支，谓本识内亲生当来异熟果摄识等五种，是前二所引故。’《集论》中说识亦是能引，那是指业种名识支而说，故与《成唯识论》说识种名识支是所引全不相违，在《分别缘起初胜法门经》业种说俱名识故，所以彼经亦说识支通能所引。
    问：识等五种是前后熏发呀？还是一时熏发呀？答：一时熏发。既然是一时熏发，为何说有七后呀？这在《成唯识论》里有二义答释。第一识如论说：‘识等五种，由业熏发，虽是同时，而依伴主、总别、胜劣、因果、相异，故诸圣教假说前后。’《成唯识论述记》解释这段文义说：‘谓本识为主，异熟主故。谓伴，非主异熟，助伴生故。就彼四中（名色、六处、触、受），名色是总，体性宽故；余三是别，义用狭故。就后三中，六处是胜，爱等依故；余二是劣，依处生故。就后二中，触是因胜，能生受故；受是果体，触所生故。由此五支摄如是等就各相异，故诸圣教假说前后，体实同时。’第二答释如论说：‘或依当来现起分位有次第故，说有前后。’这就是说，依于当来世识等五果法生起分位有次第，假说因五种有前后：或依现在已现起分位有次第，说因五种前后不同，不是行熏习时，及实生果有其前后。
    （三）能生支，体即爱、取、有。能近生当来世生老死果，故名能生。由迷内异熟愚，迷外增上果愚、以境界受为缘，发起贪爱烦恼，缘爱复生欲取、见取、戒禁取、我语取。即由此爱取势力，合润前能引中的业种，及所引中的识等五种转名为有，有当果故，唯有支种子正名能生因，但经爱取合润后，才能令其种子近生当来世生老死果，故爱等皆名能生因。《成唯识论》说：‘三能生支，谓爱取有，近生当来生老死故。谓缘迷内异熟果愚，发正能招后有诸业为缘。引发亲生当来生老死位五果种已。复依迷外增上果愚，缘境界受，发起贪爱。缘爱复生欲等四取。爱取合润，能引业种及所引因，转名为有。有后有果故。’虽然受取二支亦能润前能引因中行种，及所引因识等五果种子，约这一意义来说，爱取亦应当名能润因；但由爱取近润有支，有支中种子堪生现行，爱取能令他生，以近生当来果，约此特胜意义，但说名能生而不名能润。
    （四）所生支，体即生老死。是爱取有近所生的果，故名所生。从中有初生以后，至本有中随其寿命长短的未衰变位，皆是生支。诸衰变位随其多少时间内心色俱衰总名为老。身坏命终，入灭相位，即名为死，如《成唯识论》说：‘四所生支，谓生老死；是爱取有近所生故。谓从中有，至本有中，未衰变来，皆生支摄。诸衰变位，说名为老。身坏命终，乃名为死。’生老死二支，虽然亦为前能所引因的果法，但以果望因远，未润之时，无生果堪能，近由爱等生故，但名所生，而不名引果。
    以上根据《成唯识论》把十二有支略摄为能引、所引、能生、所生四支。立表如（表四十二）：

    （表四十二）
    七、废立
    （一）老死，十二支中，为什么诸支各别建立，唯老与死合立支呀？《成唯识论》说：‘老非定有，附死支立。’因为有情在一期相续中，不一定由老而后死，胎儿、婴孩、少年、壮年皆有死者，为显离老得有死故，所以老附死立支。此即由缺定义故不立。问：亦离老得有生，何不附生立老呀？答：老是变异，死是离灭，老与死相顺，故附死立支。生位未衰，不依生立。问：老支不定，附死合立，病亦不定，亦应合立？这如《成唯识论》说：‘病何非文？不遍定故。’病法第一是不遍三界五趣。上二界全无疾病，六欲天亦无，以诸天五衰相现皆死，非是疾病。地狱极苦逼迫。疾苦即是轻微苦，地狱无病苦故。故病苦不遍界趣的。第二是不定，唯人、畜、鬼三趣有病，但亦不定皆有，如尊者薄拘罗年过八十曾无小疾。由病不遍不定，故不立支。老在有情中虽然也不定有，但因其遍诸界趣，故立为支。因为诸界趣中，除中夭者外，非中夭的有情，临命终时根识皆有衰朽行故，如《涅槃注》卷十九说：‘释提桓因，命将欲终，有五相现：一者衣裳垢腻，二者头上花萎，三者身体臭秽，四者腋下汗出，五者不乐本座。’由老遍三界，故立为支，所以不同于病。
    （二）名色，问：若由遍故老得立支，病不遍故不得立支，则名色亦呈不遍，以无色有情，但有意处，何有色名？有色界中色界全分，及欲界化生有情，皆六处顿起，无有名色，既是不遍，何故立支？依三义答释：（1）定故立支，随具趣生所应有名色处的有情必定有名色故。病即不定，不可为例。在四生中的胎卵湿三类生的有情，乃至六处未圆满以前，决定有名色。非是胎等三生有而不定，故名色亦得建立为支。（2）遍故立支，因为名色亦是遍有，有色界中的化生有情，初受生位，虽然顿具色等五根，而未有明利的作用，尚未生触，但名名色，不名六处。故名色支亦定亦遍。（3）无色界有，初生无色的有情，虽然定有意根，而不明了，未名意处，是名色摄。如《瑜伽论》九十三卷说：‘在无色界，诸有情类，识依于名及色种子，名及色种依识而转。由彼识中有色种故，色虽间断，后当更生。’由此教证，故知无色界亦有名色支。
    （三）爱支，问：若遍立支，爱非遍有，岂可立支？以生于恶趣的有情，于彼恶趣处不生希求的爱故。答：由定故立支。以凡是不求无后有的有情，生在善趣中决定有爱故。其得不还果的圣人，命终生他地润生，虽不现起爱，有爱取种子润生（有烦恼处方生彼处）定有种故，亦名为定。又生恶趣有情，虽彼不爱当生处身，于现在自身及以我为缘的现在境，亦起贪爱，故爱亦遍有。至于《分别缘起初胜法门经》中说恶趣有情无有希求，那是依无有希求当来恶趣身爱说，不是说彼趣有情全无有爱。
    （四）生引，问：为什么于所生支合立生老死，于所引支乃别开立识等五支呢？答：识等五支正在因位，差别之相难以了知，乃依当来生起现行位别立五支。果位既是现行，差别相易了，故总立生老死二支以显三苦。如《分别缘起初胜法门经》上卷说：‘复言，世尊！生显何苦？世尊告曰：生显出苦。复言，世尊！老显何苦？世尊告曰：老显坏苦。复言，世尊！死显何苦？世尊告曰：死显苦苦。’
    （五）发润，
｛1｝问：一切烦恼皆能发业，为什么总立无明：答：虽诸烦恼皆能发业，而无明发业作用增盛，以具十一殊胜故：（1）所缘殊胜，遍缘染净品法故。（2）行相殊胜，隐覆真实，显现虚妄以为行相故。（3）因缘殊胜，普于惑业生杂染，能作因缘根本依处故。（4）等起殊胜，能发起能引所引，能生所生缘起法故。（5）转异殊胜，即此无明能转作四种无明缘：[1]随眠转异无明，[2]缠缚转异无明，[3]相应转异无明，[4]不共转异无明。（6）邪行殊胜，于诸谛中能发起增益损减二种邪行故。（7）相状殊胜，无明有二种相：[1]微细自相，体性微隐难知。[2]遍于爱、非爱、俱非境界，共相转故。（8）作业殊胜，无明略有二种所作事业：[1]普能造作一切流转所依事业。[2]普能造作一切寂止能障事业故。（9）障碍殊胜，障碍慧根胜法，及闻所成智等广法故。（《成唯识论述记钞》谓胜法即四菩提法，广法即真如，遍一切法故。）（10）随缚殊胜，三界中乃至有顶有情，无明随眠随缚，未缺未灭故。（11）对治殊胜，二种妙智所对治故。即少分无量法界智（声闻独觉）和全分无量法界智（菩萨佛）。十一殊胜义，广如《分别缘起初胜法门经》中说，这里不广引证。
    ｛2｝问：润生遍诸惑，何以但立爱呢？答：虽然一切烦恼皆能润生，但于润业位爱力遍增，故唯说爱。诸论唯说四爱为集谛故：（1）自体爱，即于现果起贪爱。（2）后有爱，即于当来世果身起贪爱。（3）喜贪俱行爱，即于已得六尘境界起贪爱。（4）彼彼希爱，即于未得六尘境界起贪爱。这四爱在《瑜伽师地论》五十五卷中，如前集谛所引，又经论中皆说贪爱如水，于业种能沃能润，故不说其余的烦恼。
    ｛3｝问：发业的烦恼亦多，而只立一无明，润生的惑为什么分立爱取呢：答：如豆生芽，要以水数数灌溉方生苗芽。爱润业种也足这样，要数沃润，方生有芽。且依爱的初后，分立爱取二种。发业之义，不可重发，所以但一无明支；如一芽生，不可再生。
    ｛4｝问：取摄行惑，体既通余烦恼，如何但说爱增名取呢？答：虽然取支中摄诸烦恼，爱润生胜，说是爱增，非说绝无其余诸惑。《瑜伽论》八十九卷说：‘当知此中若所取，若能取，若所为取，如是一切总说为取故。’
    （六）无明，问：诸缘起支，若生此地中十二支，皆唯与同地十二支为缘呢？亦容许与他地十二支为缘呢？答：总起来说，诸缘起支皆与自地支为缘，但所发行支，亦有依他地无明为缘的，如下地无明发上地行支。这就是说，十二支中，十一支全，无明一支少分，皆唯与自地缘起为缘，无明少分下地能发上地行支。如身在欲界初伏欲界烦恼的有情，能起上地未至定，既名行支，应是下地无明所发，以初伏下地染者，未离尽下地九品烦恼，不能得上根本定而起上地无明故。所以身在欲界初起初禅未至定行支，即是欲界不善无明能发初未至定行支。如是初禅起二禅未至定，即由初禅无明支能发第二禅中未至定行支。乃至非想地未至定，即是无所有处无明支能发非想地行支。《成唯识论》卷八说：‘诸缘起支，皆依自地。有所发行，依他无明。如下无明，发上地行。不尔（若不许无明发上地行）初伏下地染者，所起上（未至）定，应非行支；彼地无明，犹未起故。’这里应该注意的有两点：（1）异地无明发异地行支，唯指下一地无明发上一地说，如欲界无明只能发初禅未至定行支，不能发初禅根本定行支，更不能发第二禅未至定行支。唯得邻次，不得隔越。（2）必无上地无明能发下地一切行支的道理，假若退起下地心，即有自地烦恼，由自地无明发自地行支故。
    （七）受爱，问：既许无明与异地行支为缘，亦应异地受支得与异地爱支为缘，则从上地生到下地，从下地生到上地的有情，其能润当生的爱，是以当生地受为缘呢？还是以现居地受为缘呢？答：异地受不与异地爱为缘，润生爱皆依自地爱。若自地死生于自地，其润生爱定依自地受为缘。若异地死生于异地，其润生爱，亦定依当生地爱为缘；如欲界死生初禅地，即依当生初禅地受为缘而生爱。故润生爱皆依同地受为缘。《成唯识论》说：‘从上下地，生下上者，彼缘何受而起爱支？彼爱亦缘当生地受，若现若种，于理无违。’这就是说，俱时现行受和前时种子受，都能为缘生爱。与现行受同时相应的染受，就是境界受，境界受即无明触为缘所生染受，此染受即触为缘生爱。种子受即识等五果中异熟受支种子。及境界受种子，亦能为缘生爱。问：发业的惑既可与异地为缘，为什么润生的惑就不可以依异地为缘呢？答：发业是等起因，疏故通异地；润生是生起因，亲故唯自地。故受为缘生受。与无明为缘发行，不可例同。
    八、定世
    总上所说十二有支，在小乘一切有部论中，都是以五取蕴为体，建立为三世两重因果。无明、行两支，是过去世的惑业，为招感现世识等五支果法的因，故无明行是过去二世。识、名色、六处、触、受，是由过去世无明行所招感的现在世的五支果法，故识等五支，是现在五果。这是一重因果关系。爱、取、有三支，是现在世的因，爱取是烦恼，有是业行，现在世中由爱趣有起惑造业，为招感未来世苦果的因，故爱取有三支是属于现在世的三因。生老死二支，是由现在爱取有决定招感的属于未来世的苦果支，故生老死是未来的二果。这又是一重因果。如是十二有支，就成为过去、现在、未来，三世两重因果。列表如（表四十三）：
    《大乘唯识论》中，于十二有支唯立二世一重因果。十二支中，前十支是因，后二支是果，这前十因支，与后二果支，定不同世。以十二有支是约分段生死的异熟因果来说的，异熟因非造业之身即可受果。既然异熟因果是约有情身生死以为世，故因果支定不同世。以造因时非即受果时故。亦非现业得果可以是十二支故，但十支因中，前十支与爱、取、有三支，可以异世，可以同世。若顺生受的业（即下一生）其世必同；即现世身中由无明发业，熏成

    （表四十三）
    业种及识等五果种子，又起爱取润发六转名为有，故前支与爱、取、有，成为同世。若顺后受业（第二生）乃至后后报业，则前七支与爱、取、有，定是异世；以在现世身造业，虽熏成种，至后后世将受果报的前一世，才起爱取润发转成有支故。有部论师，爱、取、有三支，与前七支中无明行二支，定不同世，与识等五支定得同世，故现在有八支决定同世。若《唯识论》中，现在必无八支同世的。但可以有十支、七支、三支，定得同世。即现在十支因，未来二支果，是十支同世。若现在起无明行等七支因，下一世起爱取有，第三生起生老死果，是七支同世。若过去起无明行七支，现在世起爱取有三因，未来起生老死二果，是三支同世。故定无现世有八支同世者。
    十二支中，若生老死二支，爱取有三支，无明行等七支，各定同世。由无明发业熏报种必定同世，故前七支不得别世。起爱取润前六种转名为有，亦非异时，故爱取有三决定同世。生老死同世可知。故二、三、七支各定同世。
    此上所说因果，即《成唯识论》对于十二有支定世的说法。即十支是因，二支是果，因在过去世，果在现在世，或未来世。因在现在世，果在未来世。此即二世一重因果。若约因果贯遇过去现在，和现在未来的两门道理来说，因果实亦通于三世：即约过现门说，十因是过去世，二果是现在世。约现未门说，十因是现在世，二果是未来世。由此十二有支，但立一重因果，即显三世俱有。建立轮迥，和破除断常二执。说有十支因，即破常见，说有二支果，即破断见。因为既是有因，因必招果；既是有果，果必是因所招，由此破除断常二见而贯三世，故不必如有部论师安立两重因果。如《成唯识论》说：‘此十二支，十因二果，定不同世。因中前七，与爱、取、有，或异或同。若二、三、七，各定同世。如是十二，一重因果，足显轮回，及离断常。施设两重，实为无用。或应过此，便致无穷。’立表如（表四十四）：

    （表四十四）
    九、刹那缘起
    定世中所说的缘起义，是约有情的异熟因果而说，由三世异故，名分段缘起。实际说来，在有情的生活活动中，一刹那间亦具足十二支，名之为刹那缘起。即：痴为无明支，思为行支，心为识支，余为名色支，六根为六处支，触心所为触支，领纳的受心所为受支，于受起贪为爱支，其余的烦恼为取支，身业语业为有支，诸法起用名生支，变异相名老，无常为死，是为老死支。
    十、杂染相摄
    有情生死相续，总起来说，由惑、业、苦三杂染；发业润生的烦恼名惑，能感后有的诸业名业，业所引生的众苦名苦。这惑业苦三，应知总摄十二有支；即无明、爱、取三支，属于惑摄；行、有二支，属于业摄；其余七支，属于苦摄。如有颂说：爱取无明惑，行有二名业，除五余七支，一一皆名苦。立表如（表四十五）：

    （表四十五）
    若细分别，无明爱取三支是惑所摄，行全支及有支一分是业所摄，有支中除识等五种，以非业故。识等五和生老死共七全支，及有支中一分，即已润的识等五种，是苦所摄，如《成唯识论》说：‘惑、业、苦三，摄十二者，无明、爱、取，是惑所摄。行、有一分，是业所摄。七、有一分，是苦所摄。’立表如（表四十六）：

    （表四十六）
    十一、诸门分别
    （一）假实门：十二文中，无明等九支是实有：有、生、老死三支是假？有支为什么是假呢？因为它是为爱取已润的行、识、名色。六处、触、受六支种子，合名为有故，离行等六支，别无自体，所以是假。所润的行等六支中的识等五种至现起时，显生、异、灭三相位的差别，初起名生，变异名老，离灭名死，其体即识等五支，故生老死是假非实。《瑜伽师地论》五十六卷说：‘当知有生及老死支是假有法，所余有支是实有法。’
    （二）一事非一事门：事就是体，一法为体的有支，即各一事。二法以上为体的有支，即非一事。十二支中，无明、识、触、受、爱五支是一事，以无明支唯无明为体，识唯本识为体，触、受、爱三支各唯以触、受、爱心所为体，五支皆不通他法，故皆唯是一事。所余诸支，其体皆通二法以上，故非一事。如行支通色心，即行支中身语二业是色，思心所即心，故行体是多法。取支通余诸惑。名色等通多法可知。故除无明等五支是一事外，所余诸支皆非一事。《成唯识论》卷八说：‘五是一事，谓无明、识、触、受、爱五。余非一事。’《瑜伽论》第十卷说：‘几一事为自性：谓五。几非一事为自性？谓余。’
    （三）染不染门：染即烦恼，不染通善无记。十二支中，无明、爱、取三支唯是染污，是烦恼性故。识、名色、六处、触、受、及生、老死七支，体性唯是不染，是无覆无记性故。行、有二支，通染不染；行通善染，有亦通无记故。《成唯识论》说：‘三唯是染，烦恼性故。七唯不染，异熟果故。…余通二种。’
    （四）独杂分别门：独是此体为支，不与余支相交杂，即名独相。与余支交杂，名为杂相。十二支中，无明、爱、取三支、自体为支，不与余支交杂故。其余九支，皆是杂相：行支及识等五支转名为有支及生老病死故。即有支及生老支亦名为杂，体无异故，用他成故。《成唯识论》说：‘无明爱取说名独相，不与余支相交杂故。余是杂相。’
    （五）色非色门：十二支中，无明、识、触、受、爱、取六支，唯是心法，不通色法。其余六支，通色心二法。行支通三业，意业是心法，身语二业是色摄。名色支总括五蕴，心色全具。六处支通二蕴，五根名色蕴，意处即识蕴，行等六支，转名有支，故有通色非色。五蕴现行名生支，五蕴衰变名老，五蕴坏灭名死，故生老死皆通色心。
    （六）有漏无漏门：十二有支，皆是有漏，唯有为摄。无漏无为非有支故。
    （七）三性分别门：三性即善恶无记。十二支中，无明、爱、取三支，唯通不善和有覆无记。欲界无明正发业者，唯是不善性故（助可无记）。欲界爱取，亦通不善无记二性；爱通不善可知，为什么通无记呢？因为润生位爱是有覆，故爱通无记。取中包括一切烦恼，通无记可知。但欲界四取（欲取、戒取、见取、我语取）则唯是不善性。若上二界，无明、爱、取（唯有见取、戒取、我语取）三支，皆唯无记。行支唯通善恶，不通无记，无记业不感果故。有支通三性。行等六支合为有故。其余识等五及生老死七支，唯无记性，是异熟性故。虽然七支在分位中容起善染，但非体染，故七支体唯是无记性摄。
    （八）三界分别门：十二支皆通三界。虽通三界，但有分有全，欲界摄十二支全，色无色界摄十二支少分。这里简略地分别解说如下：
    （1）欲界：无明支中，具有世俗愚和胜义愚，世俗愚发欲界中非福行，胜义愚发欲界中福行，通不善性和有覆无记性。行支，有福行和非福行，无不动行，有身等三业，通善不善性。识支具五趣、四生。名色支，有五蕴及五趣四生。六处支，全皆具有，亦有五趣、四生。触支，有可意触、不可意触、具相违触，亦有五趣、四生。受支中，具有苦、乐、喜、舍四受。忧受非根，唯善恶性，不通无记，不得名异熟，故此除之。爱支，通不善性和有覆无记性。取支，具有根本烦恼及随烦恼，通不善性及有覆无记性。有及生老死三支，即合前行等六支作法，准前可知。
    （2）色界：无明支，唯有胜义愚，无世俗愚，无不善性，唯有覆无记性。行支中，唯有不动行，无福非福行，若初禅中，有身语意三业，二禅以上，唯有意业，皆唯善性。识支中，唯有天趣，唯是化生。名色支中，色中无香味二尘，名中无鼻舌二识。二禅以上，五识皆无，亦无五尘，又唯有生天趣摄。六处支中，唯有化生，唯是天趣，唯有意识名意处，色界初受生时，五根顿起，五色根悉皆具足。触支中，唯有可意触、俱相违触，无不可意触。四禅以上，唯有俱相违触。受支中，初二禅有喜、乐、舍三受，第三禅有乐、舍受，无喜受。第四禅以上唯有舍受。爱支和取支，唯是有覆无记性。有及生老死，合行等六支说，思之可知。
    （3）无色界：无明支中，唯有胜义愚，有覆无记性。行支中，唯有不动行，唯有意业。识支，唯是化生天趣。名色支中，唯有名无有色。名中又无五识。六处支中，唯有意处。触支中，唯有俱相违触。受支中，唯有舍受。爱支中，唯有有覆无记性。取支中，概摄一切烦恼，在根本烦恼中，唯有九种，除去嗔心。随烦恼中，除小七（忿、恨、覆、恼、嫉、悭、害）中二（无惭、无愧）是不善性，唯欲界有故。诳、谄通欲界及初禅，憍及大八通三界。故随烦恼中，唯有憍及大八。有及生老死，准色界可知。
    十二有支在三界中有如上所说差别，故《瑜伽师地论》第十卷说：‘间：几支欲界系？答：一切支，和合等起故。问：几支色界系？答：一切一分。问：云何应知彼有老耶？答：彼诸行有朽坏腐败故。如色界系。当知无色界亦尔。’
    （九）能所治门：上地行支，能伏下地一切支。什么是上地行支呢？即观粗苦等的六种行相。有求得上地法的有情，由观下界十二支为粗、苦、障，观上界一切为静、妙、离，即由下地无明所发行支，观粗苦障等能观行相，由厌下故，正能对治下地一切支。具观上静、妙、离，虽有能观行相，但是行支，非正对治，非厌下故。
    （十）学等分别门：十二有支，皆流转法，非有学及无学，唯非学非无学摄。圣者们虽然有所起的有漏善业，但他是以无漏明慧为缘所起，与流转相违，违有支故。由此应知，圣者必不造招感后有果的业，因为圣者们于后有苦果不迷不求，不迷故知可厌，不求故不欣生：所以诸有学圣人身中的有漏善业，定非行支。《瑜伽师地论》卷十说：‘问：几支是学？答：无。问：几友是无学：答：亦无。问：几支是非学非无学？答：一切。问：所有善有漏支，彼何故非学耶？答：堕流转故。若学所有善有漏法，彼与流转相违故，及用明为缘故非支。’
    （十一）圣断分别门：十二有支，在有学无学身中，已断未断的支分，各有差别。初二果的有学圣者，于欲界一切有支中已断一分，如三恶趣及八难女人身等的有支，即已永断，第三果的有学圣者，则欲界一切有支已全断尽，因为他已断尽欲界九品修惑，不再来欲界受生故。色无色界的有支能断多少则无决定，这须看他于色无色二界的烦恼断至何地而定。阿罗汉果，已断尽三界烦恼，永不受后有，故三界一切有支皆已断尽。如《瑜伽师地论》卷十说：‘问：预流果当言几支已断耶？答：一切一分，无全断者。如预流果，如是一来果亦尔。问：不还果当言几支已断耶？答：欲界一切，色无色界不定。问：阿罗汉当言几支已断耶？答：三界一切。’
    （十二）三断门：十二有支，一切皆通见修二道断，不通不断。总起来说，诸恶趣业果及无想定、无想天、半择迦身等有支，皆见道所断。彼等唯是分别烦恼发起，故入见道时一切皆断，有漏善业及无覆无记的若现若种诸有支，皆修道所断。又断有三种：（1）自性断，即诸烦恼及彼相应的诸心心所不善性，和有覆无记染污性法，是自性应断者，见修二道生起现行时，彼即永断。一切有漏不染污的善法，和无覆无记法，非自性应断，体非暗法，不违圣道故。（2）离缚断，即断除能缘有漏善无记法的烦恼缠缚，能缘心不为所缘善无记法缠缚，说名离缚断，即前所说一切有漏善法和无覆无记法是离缚断。（3）不生断，断彼所缘因，令果永不生起，即由因断故，果法不生，是名不生断。如诸恶果异熟趣体，及无想定、无想天等，由圣者见道时，彼等惑业因断故，彼等果法永不得生，故名不生断。此亦包括前说善无记法之一分。在上三种断义中，大概地说，十二有支的无明、爱、取三支染污性故，是自性断，亦即通见修断。虽然亦通离缚断位不生断，以弱故不说。行、有二支，通自性、离缚、不生三断；亦即通见修所断。染污性的自性断，非染污的通不生断和离缚断。若行支中的善业，及有支中的识等五果无记种子，即通离缚断和不生断，不生断即是见道断，离缚断即是修道断。识等七支，唯通离缚断和不生断，体非染污，故不属自性断。即识等五果种及生老死既是无记法，其通不生断的，即是见道所断，如恶趣异热果及女人身等，唯是见道不生断。其通离缚断的，即是修道所断，如人天异熟果，唯是修道离缚断。立表如（表四十七）：

    （表四十七）
    （十三）三受俱起门：十二支中，依当来生起位，有十支与乐受舍受俱起。此中除去受支及老死支，以受不与受相应，是自体故。这是约一识说，若约多识来说，即得随与受俱起。老死位中，多分无乐，及客舍（非说第八主舍亦无）故，所以除去。十二支中，除受支外，有十一支与苦受相应。受不受俱起故。
    （十四）三苦分别门：十二支中，除老死支，余十一支少分坏苦所摄。本来十二支通有苦苦、坏苦、行苦，这里除苦苦、行苦，唯取坏苦，故说十一支少分。为作么除老死呢？因为老死位中，多分无乐受，依乐立坏苦，故不说彼老死支中亦为坏苦。十二支分苦苦所摄，一切支中有苦苦故。十二支全分行苦所摄，诸有漏法，皆行苦故。又依三受门舍受说行苦，除老死支，余十一支少分是行苦。除老死支的理由是：老死位中多分无舍受，故不立彼为行苦。这里与老死位中多分无乐受，不立彼为坏苦的道理一样。
    此上所说，是约实义摄苦，若诸圣教，随其有支中某一苦相增盛，则所说不足。如《缘起初胜法门经》则说，生显行苦，老显坏苦，死显苦苦。《十地经》第八则说无明、行、识、名色、六处名为行苦，触、受名为苦苦，爱、取、有、生、老死名为坏苦。《缘起经》但约果时相显以辨三苦。《十地经》通约果因以辨，故不相违。
    （十五）四谛门：十二有支，皆苦谛摄，以是有漏的取蕴性故。其十二支中的行、有、及无明、爱、取五支，亦是集谛所摄。行、有二支是业，无明、爱、取是烦恼性故。十二支皆非灭道谛摄，与无漏无为的灭道二谛意义不相应故。
    （十六）四缘门：在因缘、等无间缘、所缘缘、增上缘中，诸支相望，增上缘决定皆有，以增上缘义最宽故。其余三缘，有无不定，义较狭故。又三缘中，因缘最狭，爱支望于取支，有支望于生支，有因缘义。爱增名取，爱种能生取，故爱望于取有因缘义。识等五种转名为有，所生现行名生，故有望于生有因缘义。问：老死亦是有支现行，为什么不说有望老死，为因缘呢？答：今约邻次说因缘，不约隔越及当生分位，老死隔生支，故不说有因缘。若如《集论》说识支是业种，则行支望于识支亦为因缘。现行行支望行种识支，有因缘义故。除此三支外，余支相望，皆无因缘义，以不亲办自体故。无明望行支，爱望于取，生望老死，有等无间缘及所缘缘。则前念无明为缘，引起后念取支，故爱望于取，有等无间缘。后念取支，能缘前念爱支，故有所缘缘。生支位中心心所法为缘，引起老死位中心心所法，是等无间缘，老死位中能缘心心所以生位心心所法为所缘境，即是所缘缘。有望于生，受望于爱，无等无间缘，有所缘缘。生支中现行心心所，能缘前有支故，有所缘缘。爱支能缘前受支故，有所缘缘。有支爱支，皆是种子，种望于现行的生支和爱支，没有引起开导的作用，故无等无间缘。余支相望，二俱非有。即行望于识等五支，及触望爱，取望有，皆无等无间缘及所缘缘二义。以识支等既是种子皆非现行心心所相引起的法，故无等无间缘。又识支等皆非现行心心所，不能起缘虑用，故非所缘缘。以上所说诸支相望为缘的意义，是依邻近、顺次、因果前后不相杂乱的缘起义说，若异此相望，如约隔越、超一、超二、超多，与逆次，相杂假说缘起，则为缘不定，如理应思。
    上来所说十二有支，多依《成唯识论》、《瑜伽师地论》、《对法论》等的意义而说。详细的意义，应参看《缘起经》、《缘起圣道经》、《分别缘起初胜法门经》、《稻竿经》、《瑜伽师地论》卷九、卷十、卷九十三，《杂集论》第四卷，与天亲菩萨所造的《十二因缘论》，及《成唯识论》卷八，《成唯识论述记》卷四十七、四十八、四十九等。
    从十二有支的三世因果关系来看，即惑业苦，如环无端，令有情于三界六趣中生死相续，循环不息，故名生死轮回。倘若我们想从轮回中解脱，当于缘起义勤修观行，广如《缘起圣道经》，及《瑜伽师地论》三十一卷缘起观中所说。简捷的用功下手处，应当于现前一念上对治爱取二支，能够于自体及境界不起贪爱，则于境界不起希求追取，烦恼与杂染的业行，即可止息。如是则生死可了，菩提涅槃可证，轮回永绝了。


第六节 三法印与一实相印

    第六节 三法印与一实相印
    佛法与外道的差别，大乘与小乘的差别。龙树菩萨在《大智度论》里以小乘说三法印，大乘说一实相法印为肯定的判别。如《大智度论》二十二卷说：‘问曰：何等是佛法印？答曰：印法印有三种：一者一切有为法，念念生灭皆无常。二者一切法无我。三者寂灭涅槃。……初印中说五众，二印中说一切法皆无我，第三印中说二印果。’又说：‘摩诃衍中说诸法不生不灭一相，所谓无相。’即小乘经中，若有无常、无我、涅槃三印，就是佛说的法，依教修行，可以证道。若没有三法印，就不是佛法，是魔所说。大乘经中，但有一法印，即诸法实相，是佛所说，名了义经。若无实相印，即是魔说。关于三法印，如佛陀在《莲花面经》里说：‘一切行无常，一切法无我，及寂灭涅槃，以三是法印。’如佛陀在《法华经方便品》里说：‘我以相严身，光明照世间，无量众所尊，为说实相印。’由这两处的经文看来，三法印与一实相印是佛法与外道理论的不共区别，的确是如来亲口宣说的。得着这法印的人，即能于一切法通达无碍。如《大智度论》说：‘得佛法印故，通达无碍，如得王印，则无所留难。’由此也就可以知道，合乎三法印与一实相印的道理是佛法，与三法印一实相印不符的道理，就不是佛法。
    此三及一为什么都称名印呢？即是楷定义，是真实故，一切论者不能改移，不能破坏；这真实义理，楷定一切法，所以名印，如《大智度论》二十二卷说：‘一切有为法无常，一切法无我，寂灭涅槃，是佛法义，是三印，一切论议师所不能坏，虽种种多有所说，亦无能转诸法性者，如冷相无能转令热，诸法性不可坏，假使能伤虚空，是诸法印如法不可坏。’学佛的人，对于具有这正印的教法，即可信受奉行。
    一、三法印
    （一）诸行无常印：行是造作迁流义，指一切的有为法。有为有生、异、灭三相相应，为生异灭三相作为，刹那不停地在迁流变动，所以说之为行。常是恒时固实不变义，无常就说明诸有为法上没有这种固实不变性，所以无常；即是否定一切常义。因为一切有为法的存在，当体就是因缘和合而有的生灭法；无论是物质的色法，精神的心法，都是刹那迁流相续地显现，所以总说它为诸行无常。但众生对有为法的存在，不是这样地认识它，而是从主观妄情意识上执以为常的，如来为了破除众生这种错误的妄执，就有为法现实事变的规律，说明它是变的，无常的；因此以诸行无常一印印定一切有为法相，使众生听闻了这一法印，从实执的迷网中解脱出来，对于无常的三界业果不生贪着，而发起出离生死趣求解脱的向上心。
    （二）诸法无我印：我是实有、主宰、自在义。一切法的显现，都是因缘和合而有，这是诸法存在的规律。净法是清净因缘和合的组成，染法是杂染因缘和合的组成，染净法中，无论是色法、心心所等法，皆没有实性的可以主宰自在的我体，在四蕴没有，十二处中没有，十八界中也没有，但众生由于无始以来的无明烦恼熏染，妄执诸法有实体自性，在有情法中妄执有能够主宰自在的我体，因此起自体的爱执，由自体爱执生起欲贪等种种烦恼，造业受果，轮回不息。所以自体的我爱执，是流转生死的根本，假若能觉破这我体实无，则自体爱不生，没有自体爱，则能不为欲境缠缚，断除烦恼而得解脱。返之，我爱执生，则境界爱起而流转生死。所以虽有第一个无常法印，可以打破境界爱，若不了解无我法印，有自体爱在内心里作怪，仍不能解脱境界的贪求。所以不觉知无我，烦恼决不能断，生死也不能了。因此如来以亲证诸法无我的真实相，印定我体没有，而说诸法无我，使众生悟得我空而引生无我的智慧，破除生死根本的我执，是为第二法印。
    （三）涅槃寂静印：涅槃翻为寂灭，它的含义很广，这里是指由智慧的简择力而证得的择灭无为，体相寂静，为永久安稳，净妙无扰的境界。众生内迷于我，外迷于境，于我不知空，于境不知无常，因而起惑造业，流转生死，招来虚妄幻化的生老病死、忧喜悲欢等种种的扰恼乱动，由听闻了第一法印，了知无常的道理，听闻了第二法印，了知我相本空，如是我爱执不起，则内无我相，虽有外境不为所扰，由是我空慧起，三毒永尽，解脱了生死轮回的苦恼动乱，而证得寂静安宁的涅槃，唯这涅槃才是真正究竟寂静无扰的境界，所以说涅槃寂静。
    这三法印，是苦集灭道四谛变相的收摄，诸行无常，是苦谛；其生苦之因即集谛；涅槃寂静即灭谛；其证灭之因即道谛。无我则贯通四谛。如《大智度论》二十二卷说：‘佛说三种实法印，广说则四种，略说则一种。无常印是苦谛、集谛、道谛说。无我则一切法说。寂灭涅槃，即是灭谛。’立表知（表四十八）：

    （表四十八）
    一般来说，都认为三法印是属于小乘的所观理，实际上是三乘人的共修法门，因为三乘人都必须观修诸行无常、诸法无我、涅槃寂静的理观，才能发起出离生死的向上心，乃至于知无常故苦而发起救度一切有情的菩提心，以期成佛证得圆满的无住大般涅槃。所以三法印实是三乘的共法。即大乘的一实相印，亦是三法之究竟所依，三法印无非是依一实相印之三方面分别的解释而已，故三印与一印，并不相违。如《大智度论》二十二卷说：‘问：摩诃衍中说诸法不生不灭一相，所谓无相。此中云何说一切有为作法无常名为法印？二法云何不相违：答曰：观无常即是观空因缘，如观色念念无常，即知为空。过去色灭坏不可见故无色相，未来色不生无作用不可见故无色相，现在色亦无住不可见，不可分别故知无色相，无色相即是空。空即是无生无减，无生离灭及生灭其实是一，说有广略。’又说：‘佛三种实法印，广说则四种，略说则一种……复次，有为法无常，念念生灭故。皆属因缘无有自在，无有自在故无我，无常无我无相故心不着，无相不着故，即是寂灭涅槃。以是故摩诃衍中，虽说一切法不生不灭一相，所谓无相，无相即寂灭涅槃。’由上论义，可知三法印实可贯通为一实相印。
    二、一实相印
    一实相印，即诸法圆满真实的理体，离言诠，绝对待，平等一味，无二无别，远离一切虚妄的无相之相。如《大涅槃经》第八如来性品说：‘无二之性。即是实性。’《思益梵天所问经》说：‘一切法平等，无有差别，是诸法实相义。’实相是诸佛自内亲证的圆满究竟的真理，十地菩萨虽有分证，亦不圆满究竟：所以《法华经》说：‘唯佛与佛，乃能究竟诸法实相。’这实相境界，超有无，非异一，绝寻思，无卜度，是不可思议的最高无上的境界。是诸法本具的真实相，唯佛的智慧圆满，所以能究竟证会。如来欲令一切有情皆能证会，即如其所证而以种种的名言来显示它。诸经论里所说的空性、无我、真如、法界、法性、一乘、中道、圆成实、胜义谛、三无性、四真实、四悉檀等，名相虽异，无非是显示这诸法平等一味的实相。由此就可以知道，实相离言，如来说空，说有，说真如、法界、菩提、涅槃等名言，都是借权显实的假说言辞，皆非究竟。虽非究竟，若不假借言说显示，又没有更好的方便可以令众生悟入真实相。因此，以一实相为依，随顺众生的根器，演出无量的教法，说出种种不同的法门，横说竖说，浅说深说，广说略说，都是借方便引导众生悟入实相。不但说空以遣除众生的实有妄执，也可以说有以遣除众生空无的断见。不但在有为有漏方面说生、灭、垢、染，依一实相也可以说不生、不灭、不垢、不净。不但在对治众生的颠倒妄执上说苦、空、无常、无我，依一实相也可说常、乐、我、净。一切皆是遣除众生的妄情计执，与借权显实而欲令众生悟入实相。唯此一事实，余二即非真，此即一实相印其所以不同于小乘而为大乘特法，殊胜于三法印的原因了。由此也可以知道，诸大乘经论，以及各宗各派之所说所立，亦无非是遣除众生的妄情计执，对治众生的杂染因缘，而欲令其悟入实相而已。


(一)皈依的意义

佛教基本知识（下）
    正果法师著
    人天行果—行
    人天行果—果
    声闻行果—行
    声闻行果—果
    菩萨行果—菩萨乘的发心和誓愿
    菩萨行果—行位
    菩萨行果—修断
    菩萨行果—果德
    第二章 人天行果
    第一节 行
    一、皈依三宝
    （一）皈依的意义
    学佛必从受三皈依起，三皈依即：皈依佛、皈依法、皈依僧。受了三皈依，就是佛教徒，若不受三皈依，虽然研究佛教的典籍，但仍不能算是佛教徒，故学佛的入门，以受三皈依为根本。如《演道俗业经》中给孤独长者问佛：‘初学道者，始以何志？佛言：先习五戒，自皈于三。何谓五戒？一曰慈心，恩仁不杀。二曰清廉，节用不盗。三曰贞良，鲜洁不染。四曰笃信，性和不欺。五曰要达，志明不乱。何谓三自皈？一曰皈佛，无上正真。二日皈法，以自御心。三曰皈众，圣众之中，所以广大，犹如大海，靡所不包。’又《大乘理趣六波罗密经皈依三宝品》中，如来答弥勒菩萨的问话也说：‘若欲求于阿耨多罗三藐三菩提涅槃者，应当皈依佛法僧。’
    皈依是什么意义呢？皈是皈投，皈向；依是依托，依止；皈投三宝，以三宝为依托，是名为皈依。在所皈的境——三宝方面来说，皈依即救护义。如《大毗婆沙论》三十四卷说：‘救护义是皈依义……诸有皈依佛法僧宝，不破学处，不犯律仪，不违法制，便能救护。彼破学处，毁犯律仪，违越法制，虽皈依三宝而不为救护。’学佛的人，为了解脱三恶趣的怖畏，和流转生死的痛苦，皈依三宝，仰求救护，就必须以佛为师，以法为药，以僧为友，好好的学习佛陀，奉行教法，亲近僧众，就能得到救护。否则，如《毗婆沙论》所说，是不能得到救护的。


(二)所皈依境的选择

    （二）所皈依境的选择
    甲、五处观察
    所皈依境，就是皈依的处所。所皈依境既然是我们发心皈投依靠的处所，那我们就必须慎重的选择，观察它是否可以作为我们真正的皈依处。否则，若是一个三业不净，有诸过失的人，他自救之不暇，我们以他为皈投依靠，那是永远也不会得到真实的好处的。《瑜伽师地论》六十四卷说，选择皈依处，应当从五方面去观察，如彼论说：‘谓由五处观察所皈，乃可皈依：一、由身业清净故；二、由语业清净故；三、由意业清净故；四、于诸有情起大悲故；五、由成就无上法故。’三业不清净的人，必有过失；没有大悲心的人，必有偏私；没有成就无上法的人，于自利利他就不能究竟圆满。故不符合这五种观察条件的人，我们就决不应该皈依他。
    依据经论中说，只有诸佛如来才经得起这五方面的观察，因为在如来具有的十八不共佛法中，说如来的三业，皆以智为导首，随智慧行，所以三业清净。就是如来的现行身业，在一切时间，一切处所，皆是妙善清净，勿须覆藏。为所化有情说正法时，现种种胜相，调伏众生，能以胜力折伏摄受一切徒众，是为如来身业清净。如来一切意业，与智俱转，入大众中，生起清净心为大众说法，除灭众生的无明烦恼，是为意业清净。又说如来具足大悲，于一切众生，平等化度，于任何一个众生，未有不简择了知而暂时弃舍者，故如来究竟不舍有情。如《摄大乘论》赞如来利乐有情的大悲颂说：‘昼夜常六返，观一切世间，与大悲相应，利乐意皈礼。’《显扬圣教论》卷四说：‘如来大悲者，谓如来悲，由四种因缘，说名大悲：一、依上一切种妙善清净转依，所作成就故；二、长时修习所得故；三、妙善清净智所引故；四、缘极深固种种坚牢一切相苦境界故。’余如《瑜伽师地论》四十四卷、《杂集论》十四卷等广说如来具有不共大悲的意义及显示如来成就最极清净的一切种妙智。如《显扬圣教论》第四卷说：‘一切种妙智者，谓证得如来最极清净智断故；谓于染污清净二法，一切种数相差别中，无碍智性，及彼相应等持诸心心所法，又复如来住无漏界，为作一切有清所作事故，于十方士，示佛生有，现身言说，心有所行，有所宣说，成等正觉，转妙法轮，入大寂灭，无碍智性，及彼相应等持诸心心所法，是亦名为一切种妙智。’除了诸佛世尊，没有任何人证得一切种智，故亦无成就无上法者。如上所说，唯诸佛如来经得起五法观察，可以作我们的真正皈依处。
    乙、诸天神等非所皈依
    六趣有情之中，天趣最高，所以很多的人，都以天神为皈依处。但彼诸天，由于能力不够，本身具诸障碍，不能为诸众生作大利益，故不能作我们真正的皈依处《瑜伽师地论》七十四卷．与《显扬圣教论》卷六，都说由五种因缘，诸天神等非是所皈依处。
    （1）由形相故，诸天非所皈依。此有五义：
     1.‘谓诸天神，世不现见，无谈论故’：（《显扬论》卷六文）诸天神等与人趣类别，非人类肉眼所行境界，因此诸天不能与人类相见，亦无交谈，故亦不能与人宣说法义。
     2.‘容色奋发，有怖异故’：诸天神等，容貌色相奋发时，形相暴恶，现前虽然受乐，恐惧当来生苦，故有怖畏。
     3.‘染习放逸，有贪爱故’：诸天由有贪爱，于妙欲境，染习放逸。
     4.‘舍他利益，无悲愍故’：诸天神等，于一切有情所，无悲愍心，故不能平等饶益，而弃舍利他。
     5.‘不能解了，作与不作，不达定义故’：诸天神等具有烦恼，于应作不应作的诸业不能了知，以于善不善业能招爱非爱果的真实义未现证觉，未能通达故。
    由此五种道理，诸天‘不可皈依’。返观如来，由形相故，可作皈依。
     1.‘世间现见，有谈论故’：（《显扬论》卷六文）佛在世时，世间现见，为众生宣说正法，与诸人等有所谈论。
     2.‘容色和静，无怖畏故’：如来容貌慈祥，清净无欲，和悦安静，具四无畏，心无怯劣，无所疑虑，所以都无惊惧恐怖。
     3.‘远离放逸，无贪爱故’：如来于贪等烦恼，永害习气，于欲尘无染，具无忘失法，故能远离放逸。
     4.不舍利他，有人悲故’：如来以大悲心昼夜六返观察世间众生的善根增灭，于利乐有情事业，无时暂舍。
     5.‘善能了解作与不作，通达实义故’：‘如来已通达善恶业决定招感爱非爱果的真实义理，故于应作不应作的善恶业和作而有受，不作无受，皆善了知，以此教化众生断恶修善，进趣解脱。如是五相非诸天所有，故如来是真皈依处。《瑜伽》《显扬》二论复说由五相故，如来是真皈依处。
     1.‘为利有情，证大菩提故’：如来在往昔因中，最初发菩提心时，是为了利益有情而决定希求无上菩提。如《瑜伽师地论》：三十五卷发心品说：‘又诸菩萨，起正愿心，求菩提时，发如是心，说如有言：愿我决定证无上正等菩提，能作有情一切义利，毕竟安处究竟涅槃，及以如来广大智中。’
     2.‘现处大众，开正法眼故’：如来善转法轮，令众听闻正法，开悟众生法眼，如实现证无我实义，成为有学无学的圣者。
     3.‘怨亲有情，平等利益故’：如《瑜伽师地论》四十六卷说：‘又诸菩萨，由五种相，当知普于一切有情其心平等。何等为五：一者菩萨最初发心愿大菩提，如是亦为利益一切诸有情故，起平等心。二者菩萨于诸有情，住哀愍俱平等之心。三者菩萨于诸有情，深心发起一子爱俱平等之心。四者菩萨于众有缘已生诸行，知其所想有情事已，知一切有情所有法性，即是一切有清所有法性，以法平等俱行之心于诸有情住平等心。五者菩萨如于一有情行利益行，于一切有情行利益行亦复如是，以利俱心于诸有情住平等心。由此五相，是诸菩萨于诸有情其心平等。’
     4.‘于诸家室摄，舍离贪者，诸根寂静故’：如来由贪爱习气永尽，舍离一切家宅亲属财物等的摄受，由此诸根不于所行境中执取相好而游行流散，故能诸根寂静。
     5.‘善除一切众生疑网故’：如来是一切智者，于诸众生正善开示，善能除遣众生一切疑惑。
    （2）由自性故，诸天非所皈依。由于诸天神等烦恼随逐，具诸有漏，性非清净，倘不能自己调御，岂能调御他人？故非皈处。如来永断诸漏：永害习气，具三（身、语、意）不护，性极调善，亦能调御一切有情，故可皈依。
    （3）由作业故，诸天神等非所皈依。诸天神等，安住受用众妙五欲中，恒为歌舞等声之所牵引，故于诸欲安住为业；又诸天常与非天互相战斗，或被诸天自类陵蔑驱摈，起如是等损害有情的恶业，故诸天神非所皈处。如来安住于广大无垢、寂静等业，因为如来于天住中多住第四静虑，依此静虑领受舍乐，超胜下地，故是广大。第四定舍念清净，寂静无动，故名无垢。又如来能作有情利益为业，故如来是所皈依处。
    （4）由法尔故，诸天神等非所皈依。即依诸法的法尔道理来讲，世间的长寿、相好、财富、安乐、辩才等功德和出世间的无怨怼、无灾横、无烧恼、断后世大苦，得大解脱等功德，皆有自己勤用功力修诸正行而获得，并不由于事天神等而可得彼恩赐。若不勤用功力，虽于天神等极申敬事，亦不能得。此即说由法尔道理，一切功德皆依自力成办，非他力赐予，故知天神，非是所皈依处。
    （5）由因果故，诸天神等非所皈依。《显扬圣教论》卷六说：‘今问事天神者：天神体性，为由天业感得？为由供养天得？为无因得？若天业得者，即应归业，非天。若无因得者，应归无因，非天。若供养天神得者，为唯因供养，感天神体？为唯因天神？为因二种（即由自供养及由天摄受）？若唯因供养者，即徒事天神；随处供养，皆应能感天报。（此说供天无益，只要自己随处设供即应感得天身。）若唯因天神者，即徒设供养；虽不供养，但由天神应得天报。若俱因二种者，但设供养，天神摄受，诸所祈愿，悉应果遂。又于七种所祈愿事，不定果遂，是故不然。一于供养事摄受；二于信解缘摄受；三于信解彼者，发起信解，能感最胜天神自体；四于能感最胜所受富乐；五于摧坏阿素洛等怨敌；六于出生；七于终殁。’
    最后七种所祈愿事不定果遂，意思是说以供养诸天，信解诸天为缘，祈求诸天摄受，招感天体，招感富乐，摧坏怨敌，出生天趣，及生天后常住彼处求不终殁，皆不能满其所愿求的果事。
    由上述五种道理，故知诸天神等，非是真正的皈依处。诸天尚不可作皈依，其余鬼神则更不足道了。
    丙、真正的皈依处
    真正的皈依处，唯有三种，即佛、法、僧。《瑜伽师地论》六十四卷说：‘问：皈依有几种？……答：皈依有三种，谓佛法僧。四缘故，有尔所皈依：一由如来性极调善故，二于一切种所调能调善方便故，三具大悲故，四以一切财而兴供养未将为喜，要以正行而供养乃生欢喜；由如是故，彼所立法，彼弟子众，皆可皈依。’
    第一义是说如来证得四无所畏——（1）一切智无所畏，（2）漏尽无所畏，（3）说障道无所畏，（4）说尽苦道无所畏。惑业生死俱尽，一切漏尽安稳，故性极调善，是可皈依处。否则，自未解脱，有生死怖畏，我们纵皈依他，亦不能从生死畏中得其救护。
    又如来具有三念住，摄受所化众时，于三种徒众的行为差别中，住最殊胜的舍念，不起爱心，不起恚心，不起染心。就是说正法时，一类弟子，恭敬属耳，心住于教，精进修行，如来于彼，无悦无喜，心不踊跃，但住胜舍。一类弟子，于如来说正法时，不生恭敬，乃至不精进修行，如来于彼，不生憎恚，不生不忍，非不保住，但住胜舍。一类弟子，于如来说正法时，亦生恭故，亦不恭敬，乃至亦精进修行，亦不精进修行，如来于彼，其心无二，即不喜悦，亦不憎恚，但住胜舍。如来已永尽烦恼习气，无爱恚痴等烦恼现行，故于三类徒众能遍住妙舍，是性极调善的调御师，故是真正的皈依处。
    第二义是说如来于所化度的一切不同根器的众生，具足善巧方便，若无契机说法应病与药的方便，纵然皈依他，亦不能给予皈依者的所愿所求。如来于一切所调伏的有情界和能调伏的方便，皆具无量善巧。如所调伏界中，有具缚、不具缚的差别；有钝根、中根、利根的差别；有刹帝利、婆罗门等的差别；有贪行、嗔行、痴行、慢行、寻思行的差别，乃至有色、无色、有想、无想、非想、非非想等无量差别的有情，如来皆能善巧了知，各予应病与药，的能调伏的善巧方便而调伏之。故《维摩经佛国品》说如来‘为大医王，善疗众病，应病与药，令得服行。’广如《瑜伽师地论》四十六卷所说应知。
    这里引《显扬圣教论》卷三文如下：‘四、所调伏无量作意。谓诸菩萨，乃至思惟十方无量世界，所化有情，种种行、种种性，或声闻种性、或独觉种性、或如来种性。诸如是等，所调种性，既思惟已，如实了知所调伏者，此软根、此中根、此利根，此下劣胜解、此广大胜解，此贪行贪阿世耶，此嗔行嗔阿世耶，此痴行痴阿世耶，此等分行等分阿世耶，此升进阿世耶，此不升进阿世耶，此微薄尘垢贤善阿世耶，此增盛随眠，此微薄随眠，此极细随眠，此羸损随眠，此不羸损随眠，此全随眠，此不全随眠，此广说方解，此略闻即解，此摈遣所调伏，此摄受所调伏，此软所调伏，此粗所调伏，此粗软俱调伏，此应舍置，方乃调伏。如是等处，如实了知。五、调伏方便无量作意。谓诸善萨乃至思惟十方无量世界所化有情，调伏方便。既思惟已，如实了知此因说秘密之法，方能调伏；此因显了之法，方能调伏；此因摄受方便，此因折伏方便，此转方便，此随转方便，此应随顺，此应违逆；此因不同分阿世耶；此应作恩报恩，此应示威奋威；此因清净，此因示现奇特神变，此因示现奇特记别，此因示现奇特教诫，此因示现种种威势，此因善诱种种教授，此因粗相，此因软相，此因粗软俱相，此因舍置，此因略说法要，能令调伏；此因广演法要，方令调伏。如是等方便，如实了知。’
    第三是说如来具足大悲，所以对于一切有情能无偏党地平等摄持化度。如《宝云经》卷六说：‘佛言：如来大慈，等与一切众生乐，若于一众生起慈悲时，乃至十方众生亦复如是。遍一切众生界，亦满虚空界，无能遍知如来甚深境界边际。如来有大悲心，不与声闻辟支佛共，如来于一众生起于悲心，乃至一切众生亦复如是，为作利益。如来大悲无有边际，非诸二乘所能究竟。’又《宝雨经》卷五说如来成就三十二种大悲，能于十方无量无边一切世界诸有情中，为作利益，如彼广说应知。又由四种因缘悲名大悲，如《瑜伽师地论》四十四卷广说应知。
    第四是说如来以大悲利乐有情，为令有情究竟离苦证得菩提为目的，故如来不以有情之财物供养为喜，必以正行供养为喜。正行供养即依教奉行，是十种供养中，最殊胜的供养。即皈依者，若能于少分时间内，于一诸行修无常想、苦想、空想、无我想，于涅槃修最胜想等，是名于如来所修正行供养。如是供养最为第一，最为无上。详如下文三宝所勤修供养中说。反之，若希求皈依的人以财物供养为喜者，其欲贪未断，定有偏私，则于送财物供养，或送丰厚财物供养者生大欢喜，为作利益，而弃舍虽修正行，但无财物供养的正行者了。故以财物供养为喜的人，不可皈依。
    由于唯有如来具足上述四种功德，故唯有如来是真正的皈依处。由此道理，如来所说的教法，和奉行教法的弟子众，也是最极清净的，真正能够利乐有情，令有情离苦得乐，俱可皈依，所以真正的皈依处唯有神法僧三宝。如《瑜伽师地论》说：‘由如是故，彼所立法，彼弟子众，皆可皈依。’
    丁、所皈依的正体
    上面已经说真正的皈依处，唯有佛法僧三宝。这里应该指明所皈依的主体，使我们明确的了解正所皈依的三宝体胜。在大小乘的经论中，说到所皈依三宝的主体时，都说皈依佛宝，是皈依佛的法身。皈依法宝，是皈依清净寂灭的涅槃（灭谛）。皈依僧宝，是皈依圣僧自证的无漏无为法。这里引小乘一论，大乘一经为证。
    《大毗婆沙论》三十四卷说：‘诸皈依佛善，何以皈依？答：若法义实有、现有、想、等想、施设、言说，名为佛陀。皈依彼所有学无学成菩提法，名皈依佛。……诸皈依法者，何所皈依？答：若法实有、现有、想、等想、施设、言说，说名为达磨。皈依如是爱尽离灭涅槃，名皈依法。……诸皈依僧者，何所皈依？答：若法实有、现有、想、等想、施设、言说，名为僧伽。皈依彼所有学无学成僧伽法，名皈依僧。’
    《大乘理趣六波罗密多经皈依三宝品》中，如来告慈氏菩萨说：‘者有善男子善女人皈依佛者，当皈诸佛清净法身。若欲求于佛法身者，当作如是发大誓愿：愿我及彼一切有情，当得如是功德法身。云何乃令发如是愿？为佛应身刹那迁变，化身佛者，疾入涅槃；功德法身，湛然常住，以是皈依清净法身。……一切众生，应常皈依无为法宝。一切法中，最尊最胜莫过无为。何以故？以于生死大苦海中，能为船筏，能作有情甘露良药，又是殑伽沙等诸佛菩萨三无数劫六度万行所证之果。如是妙法功德圆满，以是皈依无为法宝。是三僧宝（第一义僧，诸佛圣僧；第二圣僧，须陀洹等；第三福田僧，比丘，比丘尼等。）一切有情云何皈依？应作是说，当令皈依第一义谛无为僧宝。所以者何？以是无为常住僧故。而此僧宝无漏无为，不变不异自证之法，皈依如是无漏僧宝，能灭有情一切苦故。
    所皈依的主体，如上经论所说，都是以无漏无为法为体性；这是指究竟的皈依正体来说的。若佛报身化身等功德，与道谛法（证灭时法尚应舍，故非皈依正体）和预流等圣僧功德，虽然不是所皈依的正体，但从救护义与助道缘来说，仍然皆是殊胜的所皈依境。至于我们现前见到的佛像、经书、比丘僧尼，是住持三宝的形相，虽然不是真实的三宝，但他在现时环境之下，代表了三宝，故我们从其跟前承受皈依，即应于佛像作大师想，于经书作法宝想，于比丘僧尼作圣僧想．依之为师，尊重恭敬应如佛宝，法宝、僧宝。
    还应该知道，皈依佛，是皈依一切佛；皈依法，是皈依一切佛所证的涅槃法；皈依僧，是皈依一切佛弟子。如《大毗婆沙论》三十四卷说：‘问：皈依佛者，为皈依一佛？为一切佛耶？……答：应作是说：皈依佛者，皈依一切过殑伽沙数量诸佛。……问：皈依法者，为皈依自相续诸蕴灭耶？为皈依他相续诸蕴灭？为皈依无尽数诸蕴藏？……答：应作是说：皈依自他相续及无尽数一切蕴灭。……问：皈依僧者，为皈依一佛弟子？为皈依一切佛弟子耶？……答：应说皈依一切佛弟子。’《大乘理趣六波罗密多经皈依三宝品》也说：‘皈依法身者，即是皈依过去未来现在诸法。’说到所皈依的法宝，‘是殑伽沙等诸佛菩萨三无数劫六度万行果之所证。’说到所皈依的僧宝是‘第一义僧，所谓诸佛圣僧，如法而住。’由上经论所说，故知皈依三宝是皈依一切三宝。但是应该知道，若约依止和出家来说，则唯以一佛一僧为师了。


(三)皈依者应具的认识和意志

    （三）皈依者应具的认识和意志
    《瑜伽师地论》六十四卷说：‘齐四缘故，说能皈依：一、知功德故。二、知差别故。三、自誓愿故。四、更不说有余大师故。’这里正确地说明了能皈依的人，对于所皈依的境，应该具有的认识，与皈依的意志和坚定的立场。
    （1）知功德，如来的身语意三业，皆具足清净圆满无上的功德。身相功德，如诸经中说，具有三十二相，八十种随形好。如《摄大乘论》颂说：‘诸众生见尊，皆审知善士，暂见便深信，开导者皈礼。’语业功德，如《金刚经》说：‘如来是真语者、实语者、如语者、不诳语者、不异语者。’《光明童子因缘经》说：‘星日可处地，山石可飞空，大海可令枯，佛语诚无妄。’这两处经文，都是显示佛语清净真实。佛语更有不可思议的妙用，如《维摩经佛国品》说：‘佛以一音演说法，众生随类各得解。’《宝云经》卷三也说：‘如来能以一音演说诸法，随其类根悉除疑惑，而诸众生皆谓世尊独为己说。’
    意业功德，总说有二种，即智慧与大悲。大悲如前已说。智慧功德，如来已究竟证知世俗胜义二谛，于一切所知境界，周遍无碍。如《摄大乘论》说：‘解脱一切障，牟尼胜世间，智周遍所知，心解脱皈礼。’‘无功用、无著、无碍、常寂定，于一切问难，能解释皈礼。’‘遍一切行住，无非圆智事，一切时遍知，实义者皈礼。’又如《宝云经》卷六说…‘如来复有无量无边无碍智慧，无与等者，不可为譬，一切众生若心念所知，随其根性种种差别，如来于一刹那倾悉分别知，随彼众生各各所念，各各所作，随造善恶所得业报，如来能以三达无碍智慧，于刹那倾悉分别知。’总起来说，如来具足相好壮严、十力、四无所畏、十八不共佛法等无量功德，难以尽述。在第四章谈到佛果位上功德，可以介绍一些。
    这里仅依《瑜伽师地论》七十四卷，以六相略摄如来功德，简略地蓥述如下：
    [1]圆满，如来成就三界及出世间的一切功德，出世间所有功德，犯过一切语言诠表，所以如来的圆满功德，一切歌唱杧赞所不能及。由此因缘，天上人间，一切有情，普遍敬仰赞叹。
    [2]无垢，普通有情的功德，有七种垢染：1.欲、2.见、3.疑、4.慢、5.憍、6.随眠、7.悭。这些垢染，如来已永害无有，所以如来具有的清净圆满的功德。以无欲贪故，不求他知，故无欲垢。于所成就的功德，不起执见，故无见垢。于所成就的功德，自知究竟清净圆满，不疑为是功德，非功德，是清净，是过失等，已无疑惑，故无疑垢。又不以己所有功德，与他有情作较量，故无慢垢。又不观己所有功德憍醉掉举，生欣生喜，故无憍垢。如来已永害烦恼的种子和习气，故彼功德，无诸烦恼之所随眠，故无随眠垢。如来于己所证功德，愿一切有情同证同得，故于功德无悭吝心，不怕令其他有情同所证得，故无悭垢。
    [3]不动，如来究竟证得清净圆满的功德，诸外道不能扰动，一切盗贼不能劫夺，一切亲属不能摧坏，一切国王不能毁坏，水、火、风大不能转变，色身寿命虽尽，亦无动转，由诸如来功德无尽，是故不动。
    [4]无等，如来所有功德，极广大故，极尊重故，大威力故，无论是清净或不清净的一切有情，都无等者，是故无等。
    [5]能作有情利益事业，如来为了利乐有情，弃舍所得广大清净无罪的所有安乐，适应各种根器的众生，方便教示利他加行，是故能作利益他事。
    [6]功能，如来于所作利益有情事业时，不借待作意发愿而作，因为如来于利乐有情事业已圆满觉证无碍故，由菩萨行位无量劫来作有情利益事业的加行智为亲属故，于彼利益有情事业无量劫来恒时专志而作故，所以如来于利益有情事业的功能，是任连、无间、无穷无尽的。
  （2）知差别，知差别是能皈依者，对于所皈依的三宝应该知道的差别相，大略的意义，已如第一章中所说，这里再引《瑜伽师地论》六十四卷原文如下：‘复次，由六种相，佛法僧宝差别应知；一由相故，二业故，三信解故，四修行故，五随念故，六生福故。’
    [1]由相差别：‘云何相故，三宝差别？谓自然觉悟相，是佛宝。觉悟果相，是法宝。随他所教正修行相，是僧宝。’这三相中，初相说如来无师，自然修三十七菩提分法现等正觉。第二相说如来自觉悟已，能说正法，如实宣说是道非道，令诸有情趣于是道，不趣非道。所说法义，皆是觉悟的果法，故法宝是觉悟果相。这两相的意义，广如《瑜伽师地论》八十七卷中说。第三相说佛教中出家僧众，由于从如来所，从圣弟子所，听闻正法已，净信出家，受具足戒，圆满修习世出世正行，因为是随他（如来及圣弟子）所教导而修正行，故随他所教正修行相是僧宝。广如《瑜伽师地论》二十二卷所说。
    [2]由业差别：‘云何业故，三宝差别？谓转正教业，是佛宝。舍烦恼苦所缘境业，是法宝。勇猛增长业，是僧宝。’第一业说，由诸佛世尊出现于世，哀愍一切有情故，宣说真实苦集灭道无量教法，此即如来将自所证真实法义，为有情宣说，转正法轮，所以说此，是佛宝所作业。如《瑜伽师地论》二十一卷所说。第二业说，如来宣说的真实教法，是舍弃烦恼及一切苦的所缘境，故说此为法宝业。第三业说，即僧众修习应理行、质直行、和敬行、随法行等正行，能令勇猛增长一切善法，乃至证得三菩提果，是为僧宝业。广如《瑜伽师地论》八十四卷中说。
    [3]由信解差别：‘云何信解故，三宝差别？谓于佛宝，应树亲近承事信解。于法宝所，应树希求证得信解。于僧宝所，应树和合，同一法性，共住信解。’这是说皈依者于三宝所，各应树立其正确的差别信解。第一信解中亲近义，下文正行中说。承事即敬事的异名。略有三相，即：尊重、恭敬、供养。如《瑜伽论》九十九卷说：‘又由三相，应知敬事，由能体彼功德胜利，故起尊童。随所体悉，以身语意三种正行，而修供养。复设种种幢幡盖等，而为供养。’于法宝应以涅槃为首，发愿希求证得，故说于法宝应树立希求证得的信解。僧宝共住，由内心远离贪等所有扰恼，无违无诤，和同水乳，故善和合。如《瑜伽论》九十卷所说。僧众皆由如法所生、法所化、法等分（相似义），是故同一法性。如《瑜伽论》八十四卷说：‘大师子……口所生者，从说法音而诞生故；法所生者，如理作意，法随法行之所生故；法所化者，从法身路而得成立相似法故；法等分者，受用无漏法之财宝相似法故。’共住即六和敬法，由修六种爱敬法，柔顺调和，易可共住，如第一章已说。皈依者对于僧宝应树立这样正确的信解。
    [4]修行差别：‘云何修行故，三宝差别？谓于佛宝，应修供养承事正行。于法宝所，应修瑜伽方便正行。于僧宝所，应修共受财法正行。’承事如前已解，供养当在下文供养中说。瑜伽是相应义，包括一切乘的境行果等所有诸法，一切并有方便善巧相应义故。如《瑜伽师地论》中广说。又如《瑜伽论》八十三卷说：‘言瑜伽者，受持、读诵、问论、决择、正修加行。’总略地说，有其四种：如《瑜伽》二十八卷：‘云何瑜伽？谓四瑜伽。何等为四：一信、二欲、三精进、四方便。’所说瑜伽方便，即增进成就瑜伽的正确方法，即住清净尸罗等。如《瑜伽论》二十八卷说：‘谓尸罗律仪增上力故，善守其念，善守念故，能无放逸，防护其心修诸善法，无放逸故，心正于内修奢摩他，增上慧法毗钵舍那。’这就是说，于法宝所，应修如是正行。共受财法，即同梵行者，同受利养，名共受财。同趣尸罗，同趣正见，名共受法。如其次第能治于利养起争，对治违越学处，对治于法义颠倒执着。如《瑜伽师地论》十四卷所说应知，这是对于僧宝应修的正行。
    [5]由随念差别：‘云何随念故，三宝差别？应以余相，随念佛宝；应以余相，随念法宝；应以余相，随念僧宝。’皈依者于一切时处，应各起别行，念三宝功德。佛功德不同于法僧，故念佛功德相，是法僧之余相。法功德不同于佛功德和僧功德，故念法功德是佛僧功德之余相。僧功德不同于佛功德和法功德，故念僧功德是佛法功德之余相。为显三宝功德差别，故从辗转相望说余相。念佛世尊是正等觉者，具足十号，有大慈大悲，是一切智者，神通无量，于诸众生，能拔苦与乐等，我欲成佛，愿与佛同，是于佛宝起随念行。念法是如来亲证真理，为利乐有情，施设三藏十二分教，有大功德，是清净所缘，为诸众生离苦得乐的无上妙药，能灭烦恼，引证菩提，我欲亲证，施诸众生，是于法宝起随念行。念僧为佛弟子，奉行如来教法，住持圣教，是清净行者，得无漏法，具戒定慧，能为世间无上福田，我欲同住，修习僧行，是于僧宝起随念行。
    [6]由生福差别：‘云何生福故，三宝差别？谓于佛宝，依一有情，生最胜福。于法宝所，即依此法，生最胜福。于僧宝所，依多有情，生最胜福。’这是说于佛宝供养承事，恭敬体拜等，是依一有情生最胜福。因为在一佛世界中，没有二如来同时出现，约此意义，故说依一有情生最胜福。于法宝恭敬、供养、书写、受持、流通等，即依此法生最胜福，简别非于外道法供养等能生福德，故说法宝名为此法。和合共住，是名为僧，故于僧宝恭敬、供养、亲近、体拜等，说依多有情生最胜福。
    皈依三宝的人，若能从上述六种相中了知佛法僧三宝的差别，则于三宝功德，能够得决定的和不共的认识，也就能够对于三宝生起不可动摇的坚定信心，故从六种因相来认识三宝的差别，是学佛的人最应该尊重学习的。
    （3）由自誓愿，发心皈依三宝，必须是自觉自愿，由自己内在因力发正愿心，为证菩提，誓志愿受皈依。自誓依佛为师，依法为师，依僧为师。以这样自发的誓愿而皈依三宝，是为清净的正行皈依。
    （4）更不说有余大师，由四因缘，是大师性，是可皈依处，已如前说。由五因缘，诸天外道，非可皈依，亦已如前说，即已了知如来与天神外道，及其教法，与弟子所有胜劣差别，唯于三宝自誓皈依，不说有余大师与教法及彼弟子为可皈依处。故皈依佛以后，以佛为师，更不皈依天魔外道。皈依法以后，以法为师，更不皈依魔外典籍。皈依僧以后，以僧为师，更不皈依魔外眷属。如《优婆塞戒经》卷第三受戒品说：‘若皈佛已，宁舍身命，终不依于自在天等。若皈法已，宁舍身命，终不依于外道典籍。若皈僧已，宁舍身命，终不依于外道邪众。’


(四)皈依后的正行

    （四）皈依后的正行
    甲、第一四正行
    皈依三宝，可以得其救护，但必须修习正行，才能真正得救护。正行有两类，各有四种。第一四正行，如《瑜伽师地论》六十四卷说：‘当知皈依，有四正行：{一}亲近善士。{二}听闻正法。{三}如理作意。{四}法随法行。’这里分别略述如下：
    {一}亲近善士
    （1）善知识的德相
    善士即善友的异名，亲近善士，就是通常所说的亲近善知识。圆满的善友，必须具足八种功德。如《瑜伽师地论》二十五卷说：‘云何名善友性：谓八因缘故，应知一切种圆满善友性。何等为八？谓有一安住禁戒，具足多闻，能有所证，性多哀愍，心无厌倦，善能堪忍，无有怖畏，语具圆满。’
    1.安住禁戒：即安住具戒，善能守护别解脱律仪。于所受学的所有学处，不亏身业，不亏语业，无缺无穿，是名安住禁戒。
    2.具足多闻：即于如来教法，多所听闻通达，于诸求法者，有多法宣说开示，并且讲说时，于文义善巧，于众多妙法，能善受持，言善通利，意善寻思，见善通达，如是名为具足多闻。
    3.能有所证：即能证四禅八定，无常想，无常苦想，苦无我想，一切世间不可乐想，有过患想，又能证慈悲喜舍，或预流果等，六神通，八解脱等，是名为能有所证。
    4.性多哀愍，即于诸众生，常起哀怜悲愍，乐与其义，乐与其利，乐与其乐，乐与安稳，如是名为性多哀愍。
    5.心无厌倦：即于弟子善能教导，于弟子善行，善能赞叹鼓励，性勤精进，为大众宣说正法，不辞劳倦，是名心无厌倦。
    6.善能堪忍：他骂不报骂，他嗔不报嗔，他打不报打，他弄不报弄，于诸逼迫苦事，自推己过，以业之成熟为所依趣，终不于他发生愤恚，如是虽遭轻陵毁辱，堪能忍受，而其本性都无改变，唯常于彼有情，思为利益。又能于修道等时，堪忍寒热饥渴，蚊虻风日等苦，如是名为善能堪思。
    7.无有怖畏：处大众中，说正法时，心无怯劣，声无战掉，辩无误失，腋不流汗，身毛不竖，不为诸畏怖之所逼切，故名无有怖畏。
    8.语具圆满：即成就极美妙的语言，甚显了的语言，容易悟解的语言，众生乐欲听闻的语言，善辩善说，如是名为语具圆满。
    《大乘庄严经论亲近品》，更说具足十德为圆满的善知识，如彼论说：‘若善知识，具足十种功德者，应堪亲近。何谓为十？一者调伏，二者寂静，三者除惑，四者德增，五者有勇，六者经富，七觉真，八善说，九悲深，十离退。调伏者，与戒相应，由根调故。寂静者，与定相应，由内摄故。除惑者，信念与慧相应，烦恼断故。德增者，戒定慧具，不缺减故。有勇者，利益他时，不疲倦故。经富者，得多闻故。觉真者，了实义故。善说者，不颠倒故。悲深者，绝希望故。离退者，于一切时恭敬说故。’此中十德，全为《瑜伽》八德所摄，仅名相开合有差别而已，如寂静、除惑、觉真，可以摄入《瑜伽论》八德的能有所证中，德增可以摄入安住禁戒、能有所证等中。故二论所说，皆是善友的圆满德相。但此时际，具足这样圆满德相的善知识，实不可得，若有具此十方之五德，或十分之三德，我们即当欣庆求为亲近依止的善士了。
    （2）思念善知识的功德
    善知识是指导我们修善断恶，离一切苦，得一切乐的导师，故他于我们的恩德极大，能够依法思念其功德和恩德，则能引起我们对于善知识如法亲近、如法依止、如法恭敬承事的坚定意念。否则，虽然遇着了具德的善知识，亦不知如法亲近，自己的善法功德亦无由增长，故于善知识念恩念德极为重要。这里引证几段赞叹善知识恩和德的经文，以启发我们对于善知识知恩知德的善净意乐。《增一阿含经九众生居品》说：‘尔时阿难，白世尊言：所谓善知识者，即是半梵行之人也，将引善道，以至无为。佛告阿难：勿作是言！言善知识者，即是半梵行之人！所以然者？夫善知识之人，即是全梵行之人，与共从事，将视好道。我亦由善知识，成无上正等正觉，以成道果，度脱众生，不可称计，皆悉免生老病死。以此方便，知夫善知识之人，全梵行之人也。’这是赞说善知识是具足全梵行功德的人。
    如四十《华严经普贤行愿品》说：‘善财白言：圣者！唯愿慈悲，广为我说，我应云何学菩萨行？应云何修菩萨行？应云何起菩萨行？应云何观察菩萨行？应云何增广菩萨行？应云何成就善萨行？应云何令普贤行速得圆满！……尔时文殊师利苦萨，说此偈已，告善财童子言：善哉！善哉！善男子！若有众生，能发阿耨多罗三藐三菩提心，是事为难，能发心已，复欲勤求菩萨行，倍更为难。善男子！汝今发心，求菩萨道，为欲成就一切智智，应当勤求真善知识。善男子！求善知识，勿生疲懈！见善知识，勿生厌足！于善知识，所有教诲，当念随顺，不应违逆！于善知识，善巧方便，但应恭敬，勿见过失！’这是说欲求成佛的人，当勤求善知识，但应恭敬，勿见过失。一个依止弟子，假若以寻求过失的心去观察善知识，则唯见师长过失，覆障其清净信心，而于善知识之敬信退失，自己善法功德亦不复增长了。
    前经又说：‘复次，善男子！善知识者，犹如慈母，出生一切佛法种姓故。善知识者，犹知严父，广大利益亲属故。善知识者，犹如乳母，守护不令作恶法故。善知识者，犹如教师，示诸菩萨所应学故。善知识者，犹如善导，能示甚深波罗密故。善知识者，犹如良医，能治种种烦恼病故。善知识者，犹如雪山，增长一切种智药故。善知识者，犹如勇将，殄除一切识恐怖故。善知识者，犹如船师，令度众生大瀑流故。善知识者，犹如商主，令到一切智宝洲故。善男子！汝今若能如是作意，正念思惟，当得亲近诸善知识。’
    又说：‘一切佛法，如是皆由善知识力而得圆满，以善知识，而为根本。从善知识来，依善知识生，依善知识长，依善知识住，依善知识为因缘，善知识能发起。’
    以上两段经文，都是所说善知识于亲近的弟子有大恩德，作弟子者应当正念思惟，如法亲近。余诸经论中，所说善知识功德者甚多，这里不繁引了。
    （3）于善知识如法亲近
    学佛者寻求善知识时，在未亲近和请求为依止以前，可以尽量的观察其有德无德，是否可以亲近依止，若经过观察以后，认为是有德的善知识，确可为自己亲近的师长，而后正式亲近依止，那就不应当再观察师长的过失了。故遇着了具德的善知识，要如法亲近，当弟子的善法功德，才可以新生和增长。否别，以观察过失的心去亲近依止，自己的心先有烦恼成见，对于善知识的言行，不会虚心接受和体行，那么，自己的善法功德，也就不会生长了！佛法之中，非常重视如法亲近善知识。要做好如法亲近善知识，首先必须注意三件事：1.认识善知识与弟子的关系。2.应该发什么心来亲近。3.圆满亲近的方法。
    1.善知识与弟子的关系：在小乘经论中，多说如父子想。在大乘经论中，则多说弟子于师作佛想。如《宝云经》第六卷说：‘我今依怙师僧增广善法，以是因缘，于和上所，若持戒，若破戒，若多闻，若少闻，若聪明，若无智，悉皆恭敬，生世尊想。于诸世尊恭敬、供养、信乐、欢喜，于和上亦复如是。’如八十《华严经入法界品》中更具体的说明了于师于法于已于修行所作的心念，如彼经说，于己身生病苦想，远行想，求度想，儿子想等。于善知识生医王想，导师想，船师想，父母想等。于所说法生良药想，正道想，舟楫想，家业想等。于所修行生除病想，远达想，到岸想，绍续想等。如经七十七卷广说十类四十种想应知。
    学佛人亲近善知识，依止善知识，主要的是从善知识的教授教诫和他的实践生活中，来改造自己杂染的三业，丰富自己清净的生活。使自己一天一天的生长着善法功德，故善知识是自己黑暗中的灯塔，从恶趣中救护自己的大恩人，是自己法身慧命的除障者和源泉，故对于善知识应当如经所说而作念恭敬承事。
    2.应该发什么心来亲近：对于亲近善知识的发心相《华严经》七十七卷《入法界品》说：‘复次，善男予！汝承事一切善知识，应发如大地心，荷负重任，无疲倦故。应发如金刚心，志愿坚固，不可坏故。应发如铁围山心，一切诸苦，无能动故。应发如给侍心，所有教令，皆随顺故。应发如弟子心，有所训诲，无违逆故。应发如僮仆心；不厌一切诸作务故。应发如母心，受诸勤苦，不告劳故。应发如佣作心，随所受教无违故。应发如除粪心，离憍慢故。应发如已熟稼心，能低下故。……。’
    经中所说为二十种心，这里只节录了前十种，足以显示弟子对于善知识的亲近意志之坚毅、诚厚、任劳、无动，这是因为自己彻底了解，一切佛法，皆以善知识为根本而生、而长、而住、而圆满，故能发起一切恭敬承事的心意来亲近善知识。但是，应该知道，这是指对于具足圆满德相的善知识而说的，若不是一个具德的善知识，我们则不应当毫无观察简择地尽弃主宰而任其支配。
    3.圆满亲近法：圆满亲近善知识的方法，《瑜伽师地论》四十四卷说有四种，如彼论说：‘当知菩萨由四种相，方得圆满亲近善及。一于善友，有病无病，随时供侍，恒常发起爱敬净信。二于善友，随时敬问、体拜、奉迎、合掌、殷勤、修和敬业，而为供养。三于善友，如法衣服、饮食、卧具、病缘医药、资身什物，随时供养。四于善友，若正依止，于如法义，若合若离，随自在转，无有倾动，如实显发，作奉教心，随时往诣，恭敬承事，请问听受。’
    这四种亲近别中，前三事容易了解，不必再加解释。第四义是说，于正所依止的师长，如其所说的教授教诫的法义，有与旧说相同的名合，或依经论而说的名合，不与旧说相同名离，成不依经论而别说自己见解的名离。作弟子者，如师所说法义，无论其与经论或旧说，若同若别，凡师所说，若开许的，若遮止的，皆应无倒随顺信受奉行。如所开许的进取修持，如所遮止的止息不作。随师所说自在，不为一切异论所引夺倾动，若有违犯，师长如实显发时，无恼乱之心，唯欲进求了解，作奉教心，到师长跟前，恭敬承事，请问听受。
    {二}听闻正法
    （1）闻法的重要
    皈依者的第二正行，是听闻正法。什么是正法呢？即佛世尊，或佛弟子宣说开示的法义，是至正善士丈夫所说，至正的教法，故名正法。即契经、重颂、记别第十二分教，如第一章第一节佛法僧三宝中已说，广如《瑜伽师地论》，二十五卷应知。皈依三宝者，对于十二分教法，听闻其文，听闻其义，并受持读诵，是为听闻正法。
    学佛的人为什么须要听闻正法呢？因为我们凡大，愚迷痴暗，对于善恶法认识不清，在作为一切事的时候，是非不同，常想莫辨，因此于善不知取，于恶不知断，现前三业，多成颠倒，虽然以好心作事，反成恶行恶因，这都是由于不知法义的过失。如来在十二分教中，很清楚明白地开示什么是善法，什么是想法，善如何修，恶如何舍，有漏法怎样断，无漏功德如何修证，皆详尽无余。学佛的人，为了断恶修善，舍有漏而取证无漏，必须清楚地认识善恶，认识有漏无漏，故须要听闻正法，依之起行，使自己的所行成为正行而招感胜果。
    如《大宝积经》卷五十说：‘如人入暗室，覆蔽绝光明，虽有众色像，非明眼所具。如是虽有人，内具诸明解，不闻于正法，善恶何能晓。多闻解了法，多闻不造恶，多闻舍无义，多闻得涅槃。善听增长闻，闻能增长慧，慧能修净义，得义能招乐。聪慧得义已，证现法涅槃，净觉法相应，证得第一乐。菩萨闻法已，正法善安住，为世大光明，行菩提妙行。’此经前两颂说不听闻正法的过失，后三颂是说听闻正法的义利，其中第三颂总赞多闻的功德。在《瑜伽师地论本地分》卷十九中广有解释，可检阅参考。
    又如彼论声闻地说：‘多闻能知法，多闻能远恶，多闻舍无义，多闻得涅槃。’《华严经普贤行愿品》说：‘不知三世事，亦寡法财宝，饱腹资欲心，人形畜无别。’前颂是说多闻的好处，由听闻正法，可以了知一切法，而知道断除恶因恶果舍弃无义有漏法，证得寂静安稳的涅槃。后颂是说，不听闻正法的坏处，连三世因果的事理也不会知道，心识中除了知世间的财宝之外，一点法宝也没有，这样的人，在享乐衣服饮食以外，什么高尚的意志都没有，等同于畜生，因为他只知道愚迷的生活，而不知善恶的三世因果和有漏无漏法的过失和功德。
    又《华严经普贤行愿品》对于少学的过失说：‘少学或心高，易满如牛迹。如鼠手持物，自谓己能多。智海广难量，不测及增谤。牛饮水成乳，蛇饮水成毒。智学成菩提，愚学为生死。如是不了知，斯由少学过。’由上经论所说多闻的胜利，不闻与少学的过失，可以知道听闻正法的重要了。
    （2）恭敬说法师
    知道了听闻正法的重要，其次就是实际地从善知识跟前去听受。但要使自己听闻正法能得殊胜的利益，对于说法师与所说的法和听法的心理，都应该发起恭敬心，正确的思想，和清净的心理，才能得到真实的听闻利益。这里先说对于说法师的心念。
    对于说法师，经中往往说应作医生想，极应恭敬，唯以纯净心属耳听法，不起不正确的作意。在《瑜伽师地论菩萨地》四十四卷中，说名为于说法师由五种处不作异意：
    1.于坏戒不作异意，即于戒行有损坏的说法师，不应起这样的观念：他是坏戒者，不住律仪，我不应当从他听法。
    2.于坏族不作异意，就是有些说法师，出生的族性不高贵，听法者不应心想：这说法师是卑贱族姓家庭出身，我不应当从他听法。
    3.于坏色不作异意，即说法师色相容貌不庄严，不应嫌其丑恶，而不从其听法。
    4.于坏文不作异意，即说法师的文词不美妙，不应嫌其鄙俗，而不从其听法。
    5.于坏美不作异意，即说法师的言语不好，不应嫌其粗陋，而不从其听法。
    听法的人，若于说法师，用意寻求上述五过，则自然不愿从其听闻法义了。故听法者，应于己作病人想，于法作药物想，于说法师作医生想，但应恭敬，听受正法，不应于说法师追求过失，影响闻法善心，而退失胜慧利益。
    （3）尊重正法
    诸经中多说于法存药物想，为疗治烦恼业病，于正法药极应尊重。《瑜伽师地论》说，听闻正法时，于法师所说的正法，应作五种想念：
    1.作宝想：我们从无始以来，在三界中生死流转，最缺的是善法财，佛法是能够于生死中救拔我们出离三界的宝物，百千万劫难遭难遇，现在遇着了，凭借他的力量，就可以超脱生死，证大菩提，故佛法是无上的至宝，今得听闻，应生极大的尊重心。
    2.作眼想：我们在三界中轮转，得善趣果报的时候少，堕诸恶趣的时候多，更不知解脱生死，这都是自己愚痴无智，于善法恶法，不知取舍，如盲人无眼，于正道险道，无能辨别，今得听闻正法，得到了辨别是非善恶的妙慧，如盲人眼开，应生无比的庆幸。
    3.作明慧想：听闻正法，即已得广大慧眼，于一切所知境界，能如实不错地了知，如光明照了诸物，现在自己得着这正法光明，照彻事理，不再为所迷，应知恩怀感。
    4.作大果胜功德想：正法是得涅槃大果的因性，是证得声闻独觉佛果三种菩提胜果的因性，听闻正法，就是已经得到菩提涅槃殊胜果法功德的因性，应生无上欢喜心。
    5.作无罪大适悦想：所闻的正法，是证得菩提涅槃的因，现前自己虽然还未证得涅槃及三种菩提，但是已得正法慧眼，能于诸法如实简择而修习止观，现世中可得远离欲界粗垢罪过的静虑大乐，因性已得，应生适悦的大乐想。
    这五种想，广如《瑜伽师地论》四十四卷菩萨地所说应知。
    （4）闻法乐意
    听闻正法时，对于说法师和所说正法，有清净正确的想念外，还必须澄清自己的心念，发起纯正的闻法、意乐，即应该以无杂染心，无散乱心，去听闻正法。
    如《瑜伽师地论》三十八卷《菩萨地力种姓品》说：‘往法师所，无杂染心，无散心，听闻正法。云何菩萨无杂染心听闻正法？谓听法时，其心远离贡高杂染，其心远离轻慢杂染，其心远离怯弱杂染。由六种相，其心远离贡高杂染。由四种相，其心远离轻慢杂染。由一种相，其心远离性弱杂染。谓听法时：应时而听，殷重而听，恭敬而听，不为损害，不为随顺，不求过失，由此六相，其心远离贡高杂染。又听法时，恭敬正法，恭敬说法补特伽罗，不轻正法，不轻说法补特伽罗，由此四相，其心远离轻慢杂染。又听法时，不自轻蔑，由此一相，其心远离怯弱杂染。菩萨如是无杂染心听闻正法。云何菩萨无散乱心听闻正法？谓由五相：一者，求悟解心听闻正法；二者，专一趣心听闻正法；三者，聆音属耳听闻正法；四者，扫涤其心听闻正法；五者，摄一切心听闻正法。菩萨如是求闻正法。菩萨何故求闻正法？谓诸菩萨求内明时，为正修行法随法行，为广开示利悟于他。’
    论文中所说的‘不为损害’，即于说法师不作障碍违缘。‘不为随顺’，就是于听闻的正法有未了解的意义，或有疑惑，不唯随顺师说，必须以求其悟解的清净心而真诚请问。若自己于正法义不能悟解，或复怀疑，终不讥诮于师，是为‘不求过失’。这些意义，如《瑜伽师地论》八十四卷摄异门广说应知。
    {三}如理作意
    亲近善士与听闻正法的自的，在以所闻法义引起如理作意。因为发动三业最初有力的心所是作意，故欲求三业清净，必须于所闻正法中所说的应修应断的善恶法义，与真实非真实的道理，依所闻法理引起如实不谬的作意，此即名为如理作意。有此作意，则知见自能清净，不起颠倒邪见，而引起如理的正行。
    如《法蕴足论》第一卷说‘云何名为如理作意？谓从善士，闻正法已，内自庆慰，欢喜踊跃。奇哉世尊！能说如是深妙正法。佛所说苦，实为真苦；佛所说集，实为真集；佛所说灭，实为真灭；佛所说道，实为真道。彼由如是内自庆慰，欢喜踊跃，引摄其心，随摄等摄作意发意，审正观察深妙自义，如是名为如理作意。’这如理作意总有两种，即不增益非真实有的作意和亦不损减诸真实有的作意。
    如《瑜伽师地论》第一卷说：‘如理所引者，谓不增益非真实有，如四颠倒。谓于无常，常倒；于苦，乐倒；于不净，净倒；于无我，我倒。亦不损减诸真实有，如诸邪见。谓无施与等诸邪见行。或法住智如是了知诸所知事。或善清净出世间智如实觉知所知诸法。如实名为如理所引。与此相违，当知不名为如理所引。’
    常、乐、净、我四种妄执，非所知事上真实所有，是愚夫于所知事上不如实知所引起的增益倒执，故是非理作意。如理作意，是如其所闻正法理而了知诸行无常，有漏皆苦，身器不净，人法无我。于所知事不起四种非真实有的颠倒见，故是如理作意。持戒生天，布施招感大福财，乃至修无漏行可证阿罗汉等，皆真实事，邪见的人，毁谤无有，这是损减真实有的非理作意。听闻正法的人，于布施持戒等有果报的真实事，如正法理思惟信受，不损减为无、是名如理作意。
    ‘法住智’，即如佛所说法义而无倒了知，如《瑜伽师地论》卷十说：‘云何以法住智？谓如佛施设开示，无倒而知。’
    ‘所知事’，即不净、慈愍、缘性缘起、界差别、阿那波那念、蕴善巧、界善巧、处善巧、缘起善巧，处非处善巧等，于这些事理能正了知，是名如实了知。广如《瑜伽师地论》二十六卷《声闻地》所说。
    ‘出世间智’，即如理智，此智住有学位名为清净，住无学位名善清净。此出世间于所知诸法，能亲证真实，故名‘如实觉知’。
    ‘所知诸法’，即色心心所等有为无为法。如前第一章已说。如上所说两种如理所引，是名如理作意。学佛的人，应依教奉行。
    {四}法随法行
    皈依三宝者的第四种正行是‘法随法行’。法是指所证的涅槃，在一切法中，涅槃最胜，故得名法。随法即道谛，它是能证涅槃的法，随顺于涅槃，故名随法。行是学佛人的自心中受持此法，为求涅槃精进修行圣道，是名为法随法行。又如理作意所引出离远离所生的诸胜善法，皆名为法，于此善法修习坚住。无间精进，随法义行故，如是名为法随法行（《集异门论》卷六）。又世亲《摄大乘论释》说：‘如教行故，名法随法行。即一切学处名法，随顺学法修行，是为法随法行。’此如教法，略有五位。即身语意三业如教行故。无倒随转，是为三种，于法正思，为第四种，于法正修，为第五种。
    如《瑜伽师地论》三十八卷说：‘云何菩萨法随法行？当知此中略有五种。谓如所求，如所受法，身语意业，无倒随转，正思、正修。若佛世尊，于彼诸法制身语意，令不造作；于此诸法，开身语意，令其造作。即于如是二种法中，身语意业，无倒远离，无倒修证，是名菩萨于诸法中身语意业无倒随转法随法行。
    云何菩萨于法正思？谓诸菩萨，独居闲静，随所闻法，乐欲思惟，乐欲称量，乐欲观察，先当远离不思议处，思惟彼法，恒常思惟，无间加行，殷重加行，而无慢缓。是诸苦萨，勇猛精进思惟法时，于其少分，以理观察，而随悟入，于其少分，但深信解，凡所思惟，但依其义，不依其文，如实了知默说大说，正能悟入最初思惟。既悟入已，数数作意，令得坚固。是诸菩萨，由能远离，不应思议而思惟故，其心不随迷闷错乱。由能恒常无间殷重加行无缓而思惟故，先未知义，得正了知，得正决了。先已知义，得无失坏，得不忘失。由于少分以理观察随悟入故，于随正理观察法中，不由他缘。由于少分但信解故，于极甚深，自少觉慧不能达法，仰推如来，言如是法，是佛所行，非我境界。如是于法不生诽谤，不自损害，远离衰患，无诸过罪。由诸菩萨，思惟法时但依其义不依文故，于佛世尊一切所说密意言语，能随悟入。由诸菩萨，普于一切默说大说得善巧故，于真实义，无物无法，能倾能动，是诸菩萨正能悟入初思惟故，能得先来所未得忍。是诸菩萨，由即于此已所得忍，数数作意，令坚牢故，能于其修，随顺趣入。菩萨由是八种相故，能正修行思所摄法随法行。
    云何菩萨于法正修？当知此修，略有四相：一者，奢摩他；二者，毗钵舍那；三者，修习奢摩他毗钵舍那；四者，乐修习奢摩他毗钵舍那。
    云何奢摩他？谓诸菩萨，由八种思善依持故，于离言说唯事唯义所缘境中，系心令住，离诸戏论，离心扰乱，想作意故，于诸所缘而作胜解，于诸定相，令心内住、安住、等住，广说乃至一趣等持，是名奢摩他。云何毗钵舍那？谓诸菩萨，由奢摩他熏修作意，即是如是所思惟法，思惟其相，如理简择，最极简择，极简择法，广说乃至觉明慧行，是名毗钵舍那。云何修习奢摩他毗钵舍那？谓诸菩萨，于奢摩他毗钵舍那，无间加行，殷重加行，恒常修习，是名修习奢摩他毗钵舍那。云何乐修习奢摩他毗钵舍那？谓诸菩萨，即于如是止观相中，其心无动，于无功用离诸加行任运转处，摄受无乱，是名乐修习奢摩他毗钵舍那。
    当知此中，是诸菩萨，如如修习奢摩他毗钵舍那，如是如是乐住奢摩他毗钵舍那；如如乐住奢摩他毗钵舍那，如是如是奢摩他毗钵舍那清净；如如奢摩他清净，如是如是身安心安增长广大；如如毗钵舍那清净，如是如是若知若见增长广大。齐此名为修所应作。谓于所依中，应除遣粗重，及于一切所知，应修清净知见，如是一切修所作业，菩萨由前四种修相，时能成办。’
    论文中，‘谓如所求’乃至‘法随法行’一段，是说菩萨于所求所受的法，如教修行的身语意三种法随法行。从‘云何菩萨于法正思’以下，至‘能正修行正思所摄法随法行’，是说菩萨第四种法随法行。于法正思文中，总有八相，从‘云何菩萨于法正思’至‘令得坚固’是正解八相，从‘是诸菩萨’至‘随顺趣入’，是成立八相。为了醒目，把解和成的论文对照立表如下：（见表一）

    （见表一）
    第六相‘如实了知默说大说’，指声闻乘不了义教名默说；大乘教中了义宣说，是名大说。‘能得先来所未得忍’，指胜解行位菩萨所得的下中上忍，前时未得，创初获得，故名先来所未得忍。
    ‘云何菩萨于法正修’以下，是说菩萨第五种法随法行。‘于离言说唯事唯义’等，是说法性绝离言说相，菩萨由前八种正思为依持故，于离言法性，如实智生，不取少法而起分别，唯取其事，唯取真如，系心专住。
    ‘如理简择，最极简择，极简择法，广说乃至觉明慧行。’这些意义，如《瑜伽师地论》八十三卷《摄异门分》中自释说：‘言简择者，总取一切苦法种类为苦圣谛故。最极简择者，各别分别取诸苦故，谓生苦老苦等，极简择法者，依此处所简择契经等法故。所以者何？依止此故，先修所作。又简择者，谓审解了。最极简择者，谓审定等解了。极简择法者，谓审定近解了。前是寻求道，今是决定道，复有差别，言解了者，于所知事作意发悟。等解了者，既发悟已，方便寻求。近解了者，求已决定。……觉者，谓堪能简择俱生之慧，明者，谓习所得慧。慧行者，谓能受持读诵问论胜决择等增上了别，即于彼义转增明了勤修习慧。’《摄异门分》中，说到毗钵舍那的异名，尚有黠了、通达、审察、聪睿等差别名称，这里略去不说，故说‘乃至’二字。余文易知，不繁解释。
    乙、第二种四正行
    皈依三宝的佛弟子，除了学习前面所说的四种正行之外，还有四种正行。如《瑜伽师地论》六十四卷说：‘当知复有四种正行：{一}诸根不掉，{二}受学学处，{三}悲愍有情，{四}应时时无间于三宝所勤修供养。’这里分别略说如下：
    {一}诸根不掉
    诸根不掉，就是根律仪。根是眼等六根，掉是掉举，不让诸根在色等境相上掉动，是为诸根不掉。六根如门，为出生六识缘虑一切境界的增上依托处，要想使内心不生烦恼或少烦恼，就必须从密护根门作起。故修行用功最初的下手处，应该修行根律仪。根律仪修法的简单说明，如《瑜伽师地论》二十一卷《声闻地》说：‘云何根律仪？谓即依此尸罗律仪，守护正念，修常委念，以念防心，行平等位，眼见色已，而不取相，不取随好。恐依是处，由不修习眼根律仪，防护而住，其心漏泄，所有贪爱恶不善法，故即于彼，修律仪行，防护眼根，依于眼根，修律仪行。如是行者，耳闻声已，鼻嗅香已，舌尝味已，身觉触已，意了法已，而不取相，不取随好。恐依是处，由不修习意根律仪，防护而住，其心漏泄，所有贪爱恶不善法，故即于彼，修律仪行，防护意根，依于意根，修律仪行，是名根律仪’。
    ‘尸罗’即戒，义译清凉。‘律仪’就是轨则。‘守护正念’即于闻思修所得念，正勤修习，不息加行，于时时中善能防守，是名防守正念。‘常委念’就是恒常委细的修习正念。‘行平等位’，即住于善舍心位，或无记舍心位。‘不取相’，即于色等境界中不执取其相。‘不取随好’，即于色等境上不取其随附于境上的可爱等相，即由眼根色境为缘生起眼识，眼识无间生起方别意识，由此分别意识，于眼所缘色中，执取其相已，更取可爱不可爱等的随逐相，于可爱的种种色境相，生起染着，于不可爱的种种色境，生起憎恚，由此生起种种烦恼恶行。
    修行的人依戒律仪，时时以正念防心，令根于色境远离，虽见亦不执取其相。于色境界正现前时，不取随好，分别意识于可爱色等将生染着，于不可爱色等将生憎恚。即以正念增上力，能防护此非理分别的烦恼相应意识，令其不生所有烦恼，令住于平等舍位，是为防护眼根，于眼根修律仪行，如是乃至意根法尘为缘，生起意识，即此意识有与非理分别俱行能起烦恼，由此意识于可爱的色法将生染着，于不可爱的色法将生憎恚，亦由正念增上力，能防护此非理分别将生烦恼的意识，令其不生所有烦恼，令住于平等舍位，如是名为正念防护意根，于意根修律仪行。
    修根律仪行，略有五种差别相：1.能防护，即防守正念，及所修习常委正念，能防护诸根，令不掉动。2.所防护，即眼、耳、鼻、舌、身、意根。3.从何防护，即从可爱不可爱的色境中防护，乃至于从可爱不可爱的法境而正防护。4.如何防护，即于色等境上不取其相，不取随好。若于色等境相上，将发生种种恶不善法，令心流漏，即于此境处修行律仪，防守其根。5.正防护，即由正念防护意根，于一切境住平等舍位。这样精勤修习根律仪，如其所有防守正念，如是即于念能不忘失；如其所有常委正念，如是即于无忘失念获得任持力；即由是功能势力，则能成办奢摩他毗钵舍那进趣所证。如上所说的意义，广如《瑜伽师地论》二十三卷应知。
    {二}受学学处
    受学学处，就是戒律仪。皈依三宝的佛弟子，在受皈依以后，随其自己的能力，应受学如来所制的学处，既受学学处，为了保证清净，无有垢染毁坏，就必须修行戒律仪。修戒律仪应该注意的事，总略地说有三方面：
    （1）安住净戒，即于自己所受学的所有学处，不亏损身业，不亏语业，于身语二业防护清净，无缺损，无穿漏，是名安住净戒。
    （2）善能守护别解脱律仪，别解脱律仪，即七众弟子所受学的别解脱戒。于此别解脱善能守护，是名善能守护别解脱律仪。于此应修行：
[1]轨则圆满，即于行、住、坐、卧四威仪中，成就轨则，随顺于毗奈耶，不为世间人之所讥嫌毁谤，不为持律者、学律者之所呵责，见者闻者，皆生欢喜赞叹，说名轨则圆满。
[2]所行圆满，即不行于五处：1.唱令家，2.淫女家，3.酤酒家，4.国王家，5.旃荼罗（译屠者）羯耻那（译断狱官）家。守护别解脱律仪者，于此五处不行，于余清净无罪处行，是名所行圆满。五种非所行处，虽是如来为比丘而制，但皈依三宝受持五戒的人，也应远离。如《优婆塞戒经》第三卷《受戒品》说：‘善男子！受优婆塞戒，有五处所，所不应游：屠儿、淫女、酒肆、国王、旃陀罗舍。’故于此五处善能远离，亦是最殊胜的所行圆满。
[3]于微小罪见大怖畏，即于诸小随小学处，若有毁犯，应见为生起大罪恶的根源。如《大般涅槃经》说：‘莫轻小罪，以为无殃，滴水虽微渐盈大器，且受报不爽。’又如《地藏菩萨本愿经》说：‘众生莫轻小恶，以为无罪，死后有报，纤毫受之。’故不应轻小罪，若有所犯，急速忏悔，令其还净。于三事能够如法而行，是名为善能守护别解脱律仪。
    （3）受学学处，即于一切所应学处，皆发心受学。受别解脱戒者，虽从戒师所获得别解脱律仪，得闻少分学处，但于学处未能多知善巧，复应于一切所应学处，自誓皆当修学。从亲教师、轨范师，诸善知识，听闻学习，求得善巧，求得晓悟，并如所教诲，复能受学，是名为受学学处。
    {三}悲愍有情
    前面说五处观察所皈依境中，如来由具大悲故，成所皈依处。此大慈悲，亦是如来与外道差别不共功德之一。如《大般涅槃经梵行品》赞佛说：‘大慈愍众生，故令我皈依。’又如《增一阿含经》第三十一力品说：‘诸佛世尊，成大慈悲，以大悲为力，弘益众生。’故皈依三宝的，应学如来，于诸有情，断除损害而修悲愍心。于诸有情，先修悦意慈，见诸有请，皆甚可悦意，复修行极亲厚心，极爱念心，欲作恩心，欲拔苦心，无厌倦心，代受苦心，令心调柔自在。
    于诸有情生起拔苦与乐的堪能意乐，这有三种修相差别，如《瑜伽师地论》四十四卷说：‘一、有情缘慈，即普缘一切有情，发起与乐的增上意乐，修慈俱心，当知是名有情缘慈。二、法缘慈，即善于一切有情，住唯法想增上意乐，不起有情相，正观唯于法上假说有情，修慈俱心，当知此名法缘慈。三、无缘慈，修慈行者，复于诸法，远离分别，不起法相，修慈俱心，当知即此名无缘慈。如有情缘、法缘、无缘三慈差别，如是菩萨普缘一切有苦有情，发起除苦增上意乐，修悲俱心，即是有情缘悲。若住唯法想，修悲俱心，即法缘悲。若不起法想，住于无相，修悲俱心，即无缘悲。’如《大般涅槃经》卷十四梵行品说：‘慈之所缘一切众生，如缘父母妻子亲属，如是义故，名众生慈。法缘者，不见父母妻子亲属，见一切法，皆从缘生，是名法缘。无缘者，不住法相及众生相，是名无缘。悲喜舍心，亦复如是。’
    修慈悲心，能断嗔恚，是成圣的种姓，而且所得福报，无量无尽，如《大般涅槃经》卷十四说：‘若于一众生，不生嗔恚心，而愿与彼乐，是名为慈善。一切众生中，若起于悲心，是名圣种性，得福报无量。设使五通仙，悉满此大地，有大自在主，奉施其安乐，象马种种物，所得福果报，不及修一慈，十六分中一。’皈依三宝的佛弟子，为了成就证圣的种姓，和获得殊胜庄严的大福报，应急起修行慈愍有情的心行。
    {四}于三宝所勤修供奉
    （1）总说
    学佛的人，在皈依三宝之后，应随时以清净信心，忆念三宝的功德，随己力能以其或少或多的诸供养具而为供养。这是培养自己福德的事，也是自己依正二报的庄严因行，所以应该欢喜虔诚地时时无间于三宝前随力勤修供养。
    《瑜伽师地论》四十四卷《戒品》中说：‘于日日中，应于三宝前，以其或少或多诸供养具而为供养。’若未广设供养，最低限度亦应做到‘下至以身一拜礼敬，下至以语一四句颂赞佛法僧真实功德，下至以心一清净信随念三宝真实功德。’这就是说，若无财物设供，即以身语意三业供养。《宝云经》中，很具体地指示了对于三宝的供养方法，如经第一卷说：‘云何名菩萨恭敬施具足？供养佛，供养法，供养僧。香花伎乐绕如来塔，涂扫佛地，若诸朽故崩落，修治严饰，如是名为恭敬佛。恭敬法者，听法、读诵、受持、书写、解说，思惟其义，如法修行，不颠倒取义，是名恭敬法。恭敬僧者，衣服、饮食、卧具、汤药，种种杂物，供给所须，奉施于僧，乃至贫下无所有时，当用净水敬心持施，如此施者，名恭敬僧施。若能如是供养三宝，是名菩萨恭敬施具足。’
    （2）供养差别相
    供养有十种差别，如《瑜伽师地论》四十四卷说：‘当知供养，略有十种：一、设利罗供养，二、制多供养，三、现前供养，四、不现前供养，五、自作供养， 六、教他供养，七、财敬供养，八、广大供养，九、无染供养，十、正行供养。’
    分别略释如下：
    [1]设利罗供养：设利罗旧译为舍利，这里是指如来的色身。设利罗供养，就是供养者亲身现前供养如来的色身，是名设利罗供养。
    [2]制多供养：制多义翻塔庙，就是于为如来所造的一切塔庙前，无论为新为旧，设诸供养，是名制多供养。
    [3]现前供养：就是供养者，于如来色身，或于如来的塔庙，亲身面对其前现见而设供养，是名现前供养。
    又若供养者，于如来所，或如来制多所，现前施设供养品时，发起增上意乐相应的清净心，作如是的思惟：‘若一如来法性，即是去来今世一切如来法性。若一如来制多法性，即是十方无边无际一切世界所有如来制多法性。是故我今供现如来，即是供养其余三世一切如来。供现制多，即是供养其余十方无边无际一切世界，若窣堵波、若龛、若台、若故制多、若新制多，当知是名菩萨俱供现不现前一切如来及以制多。’
    [4]不现前供养：即供养者，于不现前一切如来，及如来塔庙，作如是的观想：‘我现前普为三世一切如来，一切十方如来塔庙，施设供养，当知是名唯供不现前如来及塔庙。又若于佛涅槃后，为供养如来故，为如来造立形像，或塔庙，或龛台，随己能力，造一造二，乃至百、千、万、亿，而设供养，亦是不现前供养。’
    《瑜伽师地论》说，唯供现前佛及塔庙，获得广大福果。若唯供不现前佛及以塔庙，获得大大福果。若俱供养现不现前佛及制多，应知获得最大福果。为无有上。
    [5]自作供养：即供养者，于如来所，或如来塔庙所，欲设供养，为了恭敬，唯自已亲手作供，不使人代作或帮供，是名自作供养。
    [6]教他供养：供养者为令所余有情皆能培植福德，发心供养三宝，于如来所，或如来塔庙所，欲设供养时，于诸供品，非唯自作，亦劝父母、妻子、朋友等，令于如来所，或如来塔庙所，随力随能，作诸供养，当知是名教他供养。若于贫苦无力兴办供养的有情，兴慈愍心，将自己供品，布施与他，令其于如来前及如来塔庙前持用供养，愿其招感福乐果报，但自己无所供养，是名唯教他供养。若自己于佛及塔供养，亦施他令供，其名自他俱共供养。
    《瑜伽师地论》说，若唯自己供养，应知获得广大福果。若唯教他供养，应知获得大大福果。若能自他俱共供养，应知获得最大福果。为无有上。
    [7]财敬供养：若于如来及如来塔庙，以诸衣服、饮食、卧具、医药、熏香、末香、华鬘、伎乐、幢、盖、幡、灯、金、银、琉璃、真珠、玛瑙等而为供养，是名财物供养。
    [8]广大供养：即于前面所说财物供养，长时施设。此复七种：若众多、若微妙、若现在前、若不现在前、若自造作、若教他造作、若淳净心，猛利胜解现前；而为供养。即以如是供养所种善根，回向无上正等菩提，是名广大供养。
    [9]无染供养：这有六种：1.自手供养，即于施设供品，不怀轻慢心，令他代供，为虔诚恭敬，唯自手供养。2.殷重供养，即令他供养时，自己不住于放逸懈怠，而住于恭敬供养心。3.不散漫心供养，即于供品，不轻弃掷，而善陈设。4.无杂染心供养，即施设供品，不杂贪等烦恼而为供养。5.不于信佛国王大臣诸贵胜前，为得财位等故，诈设种种虚事供养。6.以清净物供养，不以三宝不受用的东西，如孙蒜等，及一切有毒之物设供养，唯以清净物品而为供养。如是六种，说名无染供养。
    以上所说财物供养，于诸财物，若自力所集，或从他求得，由胜解心，从具自在所得等，能为供养，当作观想化身千、百、万、亿于十方一切如来及塔庙供养，恭敬体拜，则能获得广大福德资粮。又若自己无力集诸财物，亦无从他求得，及无众具自在，而可施设供养，以净信胜解心随喜一切有情，供养一切如来及塔庙的功德，如是少用功力，亦能集获摄受菩提的无量福德资粮，学佛的人，于此善巧方便，应勤修学。
    [10]正行供养：依正法修行，以此正行为供养，是为正行供养。如于少时分，普于一切有情，修慈悲喜舍四无量心，于一切诸行修无常苦空无我想，于涅槃修胜利想，于佛法僧修随念想，于一切法发生忍智信解，于离言法性的真如生起无分别无相心住，于所受尸罗守护无犯，于奢摩他毗钵舍那精进修学，于一切波罗蜜多及诸摄事精进修学，如是等正法行，虽以少少时分修习，其功德亦最胜最妙，最为无上，长时修习，则功德不可思议，能迅速圆证无上菩提。
    上来所说十种供养，是以如来为供养境说，如是于法于僧，亦应修学十种供养。如《瑜伽师地论》四十四卷说：‘由此十相，应知是名具一切种供养如来；如供养佛，如是供养若法若僧，随其所应，当知亦尔。’
    （3）供养的重心
    已说十种供养差别，其中应该注意两点：
    第一、修财物供养，应以至诚恭敬，及广大菩提心为主，物品丰盛美妙，则其次要。如《阿阇世王授决经》中，贫女供一灯，如来为他受成佛的记，即是最好的例证。如彼经说：‘一时，佛在罗阅祗国（王舍城）耆阇崛山（灵鹫山）中，时阿阇世王（未生怨王）请佛。饭食已讫，佛还祗洹。王与祗婆议曰：“今日请佛，佛饭已竟，更佛所宜？’祗婆言：“惟多燃灯也。”于是王乃敕具百斛麻油膏，从宫门至祗洹精舍。时复有贫穷老母，常有至心，欲供养佛，而无资财，见王作功德，乃更感激，行乞得两钱，以至麻油家买膏。膏主日：“母人大贫穷，乞得两钱，何不买食？”母日：“我闻佛生难值，百劫一遇，我幸逢佛世，而无供养，今日见王作大功德，巍巍无量，激起我意，虽家贫穷，故欲燃一灯，为后世根本也。’于是膏主，知其至意，与两钱膏，应得二合，特益三合，凡得五合。母则往当佛前，燃之。心计此膏不足半夕，乃自誓言：“若我后世，得道如佛，膏当通夕，光明不消。”作体而去。王所燃灯，或灭或尽，虽有人侍，恒不周匝。老母所燃一灯，光明特朗，殊胜诸灯，通夕不灭，膏又不尽。至明朝旦。佛告目连：“今天已晓，可灭诸灯！”目连承教，以次灭诸灯。灯皆已灭，惟此母一灯，三灭不灭，便举袈裟以扇之，灯光益明。佛告目连：‘止！止！此当来佛之光明功德，非汝威神之所毁灭。”王闻之，向祗婆曰：“我作功德，魏魏如此，而佛不与我决（决定当来果报，就是受记）；此母燃一灯，便受决，何以尔也？’只婆曰：“王所作虽多，心不专一，不如此母注心于佛也。”’
    第二、应该知道，诸供养中，以正行供养为最上。亦即诸经论中所说的法供养。如《宝云经》卷六说：‘善男子！菩萨复有十法，名善供养佛。何等为十？以法供养于佛，以救拔济众生供养于佛，以教化众生令立诸善根供养于佛，常与一切众生利供养于佛，不舍愿行供养于佛，不舍菩萨所行供养于佛，言行相应供养于佛，心无疲厌供养于佛，不舍菩提供养于佛，不以财施供养于佛。何以故？善男子！如来法身不待财施供养，唯以法施供养为上，以具足供养利益众生，令得安乐常获善利。善男子！若不能利益众生，放舍善法，所作无无厌，好喜妄语，志意下劣，心生疲厌，离菩提心，有如是等，不能为诸众生而作利益。何以故？菩萨要依众生修诸功德，乃至成阿耨多罗三藐三菩提。若无众生，终不能成阿耨多罗三藐三菩提无上正觉。为具佛道，以法供养为最第一，不以财施为真供养。善男子！具此十事，是名菩萨能善供养。’
    《瑜伽师地论》四十四卷在说完十种供养以后也说：‘如是供养（正行供养），为最第一，最上最胜，最妙无上。如是供养，过前所说具一切种财物供养，百倍千倍，乃至邬波尼杀昙（此云数极义微细义）倍。’由上经论所说，可知正行供养之殊胜。故佛弟子，应该以修学正行供养为主，尤其出家佛弟子，为住持佛法，教化众生，成办自己的道业，更应该特重修学正行供养。


(五)皈依三宝所获功德

    （五）皈依三宝所获功德
    甲、依经总说
    皈依三宝的功德，其殊胜广大难可校量。如《希有校量功德经》中，阿难请问世尊，若善男子善女人，皈依佛、皈依法、皈依僧，得几所功德？‘尔时世尊告阿难言：“此阎浮提地纵广七千由旬，形如车箱，南陕北广，假使善男子善女人，满一百年，持于世间一切所有娱乐之具，尽给施与，复以四事具足供养，恭敬体拜，乃至灭度之后，收其舍利起七宝塔，一一塔庙，皆以香花酥油灯烛，作倡伎乐，绘彩幡盖，种种供养，于汝意云何？彼善男子善女人得福多否？”阿难白佛言：“甚多，世尊！”佛言阿难：“不，如是善男子善女人以淳净作如是言：我今皈依佛、皈依法、皈依僧所得功德于彼福德百分不及一，百千万分不及一，乃至算数譬喻所不能及。”’
    《法华经》说：‘若人散乱心，入于塔庙中，一称南无佛，皆已成佛道。’
    《金刚经》说：‘若人满三千大千世界七宝，以用布施。……若复有人，于此经受持，乃至四句偈等，为他人说，其福胜彼。’
    《大悲经》卷三礼拜品说：‘阿难，我法中但使性是沙门，污沙门行，自称沙门，形似沙门，当有披着袈裟者，于此贤劫弥勒为首，乃至最后卢遮如来，彼诸沙门如是佛所，于无余涅槃界，次第当得入般涅槃，无有遗余。何以故？阿难，如是一切诸沙门中，乃至一称佛名，一生信者，所作功德，终不虚设。’
    第一种经，是总说皈敬三宝的功德，后三种经，是各别赞说皈敬佛、皈敬法、皈敬僧的功德。诸经中赞叹皈敬三宝的文句很多，这里仅引四经，以作皈依三宝所获功德无量的圣教证据。
    乙、依论别说
    {一}第一四德
    皈依三宝的功德，在《瑜伽师地论》六十四卷中，说获两类四种功德。第一四德如彼论说：‘受皈依者，获四功德：一获广大福，二获大欢喜，三获三摩地，四获大清净。’
    （1） 获广大福：即皈依者，由供养现前佛，不现前佛，及塔庙，与法僧，当知获得无量大福德果报，摄受无量广大梵福，由此能于无量大劫中不堕恶趣，圆满无上正等菩提的资粮。广如《瑜伽师地论》四十四卷所说供养三宝功德应知。
    （2）获大欢喜：即皈依者，于佛法殊胜功德田，作意思惟发生欢喜。由皈依三宝故，了知世出世间道，于此事作意思惟发生欢喜。由皈依三宝故，能远离众苦及苦因，引发众乐，及与乐因，如是思惟，发生欢喜。又思惟随顺修道，便能证得速疾通慧，发生欢喜。如是等无量欢喜灌溉其心，数数作意思惟，心常欢喜住，故为获大欢喜。广如《瑜伽师地论》第二十卷所说应知。
    （3）获三摩地：这有三种差别：1.得三摩地。2.三摩地圆满。3.三摩地自在。‘皈依三宝者，由发起希求证得殊胜功德的善法欲，具足尸罗，守护根门，饮食知量，初夜后夜常勤修止观，正知而住等，对治障碍三摩地的所治法已，创获初静虑未至定，是为得三摩地。其次，由已得三摩地，于少分微妙定中，不生喜足，于殊胜的根本定，见胜功德，更起希求意愿，勇猛精进，策励而住，依正方便，获根本静虑，得离生喜乐，遍诸身分，无不充满，无有间隙，远离诸欲，远离一切恶不善法，于初静虑圆满五支具足安住，是名三摩地圆满。复次，行者虽然已经证得根本三摩地，但其心中犹为三摩地生起爱、慢、见、疑、无明等烦恼之所染污，其心于入住出未能随意自在，未名圆满清净鲜白。为了使诸烦恼不现起故，为练心调心故，誓证心自在性，定自在性，依乐断乐修，正勤方便，常勤修习。由如是正修行故，于三摩地获得自在，依止彼定自在性，其心清白，无有瑕秽，乃至获得第四静虑，及能引发神通智慧，是名三摩地自在。这得三摩地，三摩地圆满及三摩地自在，总名无上的世间一切种清净。’广如《瑜伽师地论》二十卷所说应知。
    （4）获大清净：这是说获得出世间一切种清净，此略有五种：1.入圣谛现观。2.入圣谛现观已，离诸障碍。3.入圣谛现观已，为欲证得速疾通慧，作意思惟诸欢喜事。4.修如所得道。5.证得极清净道及果功德。
    1.现观，就是明了现前观无戏论界境，此境是圣无漏无分别智所证真实，故名圣谛。明了现前观此圣谛境，故名入圣谛现观。入圣谛现观时，光明的无漏智慧生地，如黑暗的有分别烦恼障碍，即时除灭，种种恶不善业，永不现起，于爱尽的寂灭涅槃界中，心善安住，无复退转，如是心安住时，名已入圣谛现观。
    2.入圣谛现观以后，为远离诸余障碍法，于行住坐卧中，勤修对治，于障碍法，随所生起，即便远离，如是名为远离障碍。
    3.复为证得神通智慧，作意思惟诸欢喜事，如于佛法僧戒已得证净，即以证净为依止故，于佛法僧田作意思惟发生欢喜，由思随顺修道欢喜事故，更能证得速疾通慧，是为入圣谛现观已为欲证得速疾通慧，作意思惟诸欢喜事。
    4.由所生起广大欢喜灌溉其心，为断除余障，为证所余无漏功德，于少分殊胜所证，心无喜足，于诸善法转上转胜微妙处希求而住，复修习如前所得类道，由此修道，获得殊胜所证法，是名修习如所得道。
    5.由精进无间地修道故，所有烦恼无余永断，证得五无学蕴，即戒蕴（无漏戒），定蕴（无漏定），慧蕴（无漏慧），解脱蕴（无学胜解），解脱知见蕴（无学正见），名极清净道。由得无学清净知见，于无明爱永断无余。无明断故，于现法中证慧解脱；爱断尽故，于现法中证心解脱。入无学位，名为证得极清净道果。由证极清净道果，远离诸过，住圣所住处，名为功德。如是极清净道及果与功德，总略说名证得极清净道及果与功德。
    总上所说入圣谛现观等五种，皆是出世间清净，故说大清净。广如《瑜伽师地论》二十卷所说。皈依三宝的佛弟子，现前虽然未得这些大清净法，但只要自己依教奉行，是决定可以证得的。
    ｛二｝第二四德
    皈依三宝的第二类四种功德，如《瑜伽师地论》六十四卷说：‘复获四德：一、大护圆满。二、于一切种邪信解障，皆得轻微，或永灭尽。三、得入聪睿正行正至善士众中，所谓大师同梵行者。四、为于圣教净信诸天欢喜爱念，谓彼天众心生欢喜唱如言：我等成就三皈依故，从彼处没来生此间，是诸人等今既成就多住皈依，亦当来我众同分中。’
    （1）大护圆满，是说由皈依三宝故获得生圆满。生圆满依内有五，依外有五，合有十种。
    依内五种是：
    1.众同分圆满，即生在人中，得丈夫身。
    2.处所圆满，即生在中国，不生边地（有四众弟子游行处）。
    3.依止圆满，即诸根具足。
    4.无业障圆满，即无五无间随一业障。
    5.无信解障圆满，即于圣教发生清净信解，不于邪恶处发生信解。
    以上五种，都是有情内身上所具的圆满相，故名内圆满。
    依外五种是：
    1.大师圆满，即值遇大师出世。
    2.世俗正法施设圆满，即佛正演说正法，依世俗相安立十二分教法。
    3.胜义正法随转圆满，即依大师开示的正法修行，于沙门果证得圆满。
    4.正行不灭圆满，即世尊虽已入般涅槃，世俗正法未灭，可依之修行正行。
    5.随顺资缘圆满，即依正法修行，有信心善士奉施衣服、饮食、卧具、医药、资生之具。
    十圆满义，如《瑜伽师地论》第二十卷广说。
    （2）于邪信解障皆得轻微或永灭尽，有外道建立种种恶见、毁谤，无有布施果报，无有后世，无善恶行因果，乃至无真阿罗汉，此为邪解，于此邪解信受，即成为听闻正法的障碍，故名邪信解障。由皈依三宝故，于正法信解领悟，这些障碍，即得轻微，乃至无漏慧生，邪信解障，即永灭不生，广如《瑜伽师地论》二十一卷中说。
    （3）得入聪睿正行正至善士众中，聪睿即聪明睿哲。聪明即与引发慧相应。睿哲即与俱生慧相应。远离邪行的无颠倒行名为正行。已趣各别烦恼寂静，故名正至。善士即佛及弟子，或有具戒具德，善守好学，柔和质直的人，亦名善士。皈依三宝的人，由亲近善士，听闻正法，如理作意，法随法行，成就引发慧，和俱生慧，行无倒行，趣闻于烦恼寂静处，故得人于聪明睿哲的正行正至的善士众中。
    （4）为于圣教净信诸天欢喜爱念，诸天多由皈敬三宝、受五戒、修行十善而得生天中，故见有人皈依三宝，皆欢喜爱念，知道皈依三宝的人，死后必来生天上，为增加自己同类而欢喜。
    如《佛说嗟蔑曩法天子受三皈依获免恶道经》说：‘有一天子名嗟蔑曩法，天报将尽，唯余七日，现五衰相：一、身无威德。二、垢秽旋生。三、华鬘萎萃。四、身出臭气。五、两腋流汗。自知命终以后，堕阎浮提王舍大城，以宿业故而受猪身，由是之故，宛转于地，悲哀啼位。后由帝释天主劝其皈依三宝，告嗟蔑曩法天子言：贤者！汝可诚心皈命三宝，应作是言：“皈依佛两足尊。皈依法离欲尊。皈依僧众中尊。”时彼嗟蔑曩法天子，以死怖故，畏堕傍生猪身故，以至诚心遥念礼敬，皈依三宝，受三皈已，心不间断，以至命终，生绉史多（此云知足）天，受五欲乐。诸天天眼能见其下，不能观上，故帝释天于嗟蔑曩法天子死后观其生处，因绉史多天在帝释以上，尽天眼力，不能观见，乃往世尊前请问，佛告彼已生绉史多天，帝释闻已，欢喜地赞叹以颂说：‘若皈依于佛，彼不堕恶道，弃舍人身已，当获得天身。若皈依于法，彼不随恶道，弃舍人身已，当获得天身。若皈依于僧，彼不堕恶道，弃舍人身已，当获得天身。”又说：‘诚心皈命佛，彼人当所得，若昼若夜中，佛心常忆念。诚心皈命法，彼人当所得，若昼若夜中，法力常加持。诚心皈命僧，彼人当所得，若昼若夜中，僧威常覆护。’世尊印可帝释所说，而说言如是如是。’由上经文所说，故知于圣教净信的诸天，见着皈依三宝的人，必欢喜爱念。


二、受持五戒

    二、受持五戒
    （一）总说受戒功德
    学佛的人，在皈依三宝以后，其具体的实践规则，即为受持不杀、不盗、不邪淫、不妄语、不饮诸酒五种戒法。如《大宝积经》八十二卷《郁长者会》说：‘复次，长者！在家菩萨，应受善戒，所谓五戒。’《阿难问事佛吉凶经》说：‘受佛五戒者，是福德之人，无所畏避。’
    《辩意长子经》说：‘有五事行得生天上，何谓为五：
    一者慈心，不杀群生，善养物命，令众得安。
    二者贤良，不盗他物，布施无贪，济诸穷乏。
    三者贞洁，不犯外色男女，护戒奉斋精进。
    四者诚信，不欺于人，护口四过，无得贪欺。
    五者不饮酒，不过口行。此五乃得生天。’
    《最胜无比经》说：‘尔时世尊，复告阿难：若善男子，或善女人，皈依佛竟、皈依法竟、皈依僧竟，乃至复能尽形寿，受持五戒，获福转胜。阿难当知，如前所说，一曰一夜八戒福德，比尽形寿五戒福德，复于百分不及其一，于千分中亦不及一，于百千分、数分、算分、喻分、乃至邬波尼杀昙分，亦不及一。’
    《优婆塞五戒相经》中，佛答净饭王请求分别五戒可悔不可悔相说：‘憍昙（即翟昙）！我本心念，久欲与优婆塞分别五戒，若有善男子受持不犯者，以是因缘当成佛道。’
    《大智度论》卷十三说：‘大恶病中，戒为良药。大恐怖中，戒为守护。死暗冥中，戒为明灯。于恶道中，戒为桥梁。死海水中，戒为大船。’论长行文中并说：‘譬如大地，为生长一切万物的依处，戒亦如是，为生长一切世出世间善法的依处。下品持戒，得生人中；中品持戒，生于天上；上品持戒清净可得阿罗汉果，辟支佛果，乃至证得无上菩提。故受持戒法的人，若守护无犯，则能远离一切灾难恐怖，具足一切善法顺缘，常为善神之所守护，三宝之所加持，可得之愿，随其所求，皆得成办。’所以《大智度论》说：‘持戒之人，无事不得。破戒之人，一切皆失。’
    （二）略说五戒
    甲、戒的意义
    五戒，即从大德师长前乞受：‘尽形寿不杀生，尽形寿不偷盗，尽形寿不邪淫，尽形寿不妄语，尽形寿不饮酒。’这五条戒，为得人天善趣异熟报身的根本，也是修行圣道与成就无上菩提的基础。所以学佛的人，在皈依三宝之后，就应该受持五戒。戒是防止义，能防非止恶，故名为戒。
    五条戒中，前四条是性戒。性是体性义，即杀生等四种事情，本性上即是一种恶法，不管受不受戒，谁作了都是恶性的罪行，于此恶性行守护不作，故是性戒。最后一条，属于遮戒。就是在饮酒的本性上说，不是恶行，本性非罪，故饮酒不是性罪，但饮酒乱性，开不善之门，是生罪之因，可以导致罪行，障碍定等善法，佛陀为了防护修行人的净行，遮令不饮诸酒，所以制戒，故名遮戒。
    乙、别说戒相
    （1）杀生戒
    不杀生戒相。生是有情的生命，杀是用刀枪木石毒药等东西，断绝有情的生命，这是一种残忍的罪恶行动。佛法以慈悲为根本，杀害有情的生命，是违反佛法的慈悲本怀的，所以应当戒杀。这杀罪在受持五戒的人犯了的时候，有可以忏悔和不可以忏悔的差别，假若杀的是一个人，或人胎，而自己的精神又是清醒地知道自己所要杀的是实有的人，由于烦恼相应，内心里发起了断绝他生命的杀念，无论是自己杀，或教人杀，在方法上，用刀用枪，用毒药，势力逼迫等，只要自己蓄意想般的人，因此而死了，即构成不可忏悔的根本罪。受戒的人不作这样的事，即是守持不杀戒。
    若于上说条件不具足，如所杀非人，或精神错乱，或不知是人，或无杀心而误断彼命，皆是可以忏悔的杀罪。若仅仅于人或畜生系缚、禁闭、打伤等，是杀生的方便罪而不是正罪。应该知道，五戒中的杀戒，原则上是不应该杀一切众生，如《大宝积经》八十二卷《郁伽长者会》，说到五戒文中就说：‘不杀一切诸众生等。’这是说在家菩萨受了五戒，修习慈心不应该杀一切众生，但并不是凡杀了一个众生都是犯了杀戒的根本罪不可忏悔。这以下对于五条戒相都依《优婆塞五戒相经》作一简略地抉择。
    《优婆塞五戒相经》说：‘佛告诸比丘，犯杀有三种夺人命：一者自作，二者教人，三者遣使。自作者，自身作夺他命。教人者，教语他人言，捉是人系缚夺命。遣使者，语他人言：“汝识某甲不？汝捉是人系缚夺命。”是使随语夺彼命时，优婆塞犯不可悔罪。’
    经文是说，杀戒由五种因缘成不可悔罪，一是人，即所杀的人，或人胎，非是畜生等。二人想，即能杀者的想不错乱，意识上清楚地知道所杀的是人，而作人想，非作畜生等想。三有杀心，即意识中发起断绝其人生命的杀心。四兴方便，即杀害的加行，如置刀、购枪、配药、计划等，为达到究竟断绝人命的种种方法，是为方便。五被杀人命断，即被杀的人因能杀者刀杀，或枪击，或毒药等而死了。只要这五个条件具足，其被杀死的人，无论是自己杀的，或教人杀的，遣使杀的，被杀的人生命断绝时，杀者即犯了杀戒的不可悔罪，而失掉戒体，不复成为优婆塞了。还应该知道，劝赞人死，其人因此而自杀了，也是不可悔罪。持戒者于此应该特别注意。若五个条件不具足，被杀者虽然死了，亦是可以忏悔的杀罪。余打伤、系缚等为方便罪，皆可忏悔，广如经说应知。于上说杀生事不作，就是守持不杀生戒。
    （2）偷盗戒
    不偷盗戒相。偷盗是不与取，即他人的财物等，不给与自己，自己以盗窃心，将其取离本处而据为己有，是为偷盗。包括教别人替自己偷盗，或以势力夺取，或以方法侵占，或借用抵赖不还，或拐骗、贪污、漏税等，皆是偷盗，只要价值满足数量，生起得心，即犯盗戒根本罪，成不可悔。自己不作这样的事，就是守持不偷盗戒。若盗窃未成，或价值不满数量，或以破坏心而破坏他人财物等，皆是方便罪，可以忏悔。于上说偷盗行不作，就是守持不偷盗戒。
    《优婆塞五戒相经》说：‘佛告诸比丘，优婆塞以三种取他重物，犯不可悔：一者用心，二者用身，三者离本处。用心者，发心思惟欲为偷盗。用身分等取他物。离本处者，随物在处，举着余处。’经中所说重物，即价值五钱。此盗戒，以六种因缘成不可悔罪：
    1.他物，即所偷盗的东西，自己无主权。
    2.他物想，即思想不错乱，意识上清楚地知道所偷盗之物是他人所有。
    3.盗心，即由贪烦恼相应，于他人物生起偷盗心。
    4.兴方便，即进行偷盗的种种方法，包括自取、教人取、遣使取。这三种取中，又有苦切取、轻慢取、诈称他人名字取、强夺取、受寄取六种。
    5.值五钱，即价值满足。律摄中说五磨洒，古德说是八十小钱，或八分白银。
    6.离本处，即将他人物取移原放处所。
    六缘具足的偷盗事，即犯盗戒不可忏悔的根本罪，而失掉戒体了。若六缘不具，取了他人的东西，或以破坏心毁坏他人之物，皆是可以忏悔的罪。经中又说以七种因缘虽取他人物无犯，即：1.己想—于所取物误认为是自己的。2.同意—所取物的主人，与己亲厚，知己取用，其心欢喜。3.暂用—取物时无盗心，只是暂时借用即还。4.无主—即不知所取物有人摄属。5.狂。6.心乱。7.病坏心。最后三种，皆由神经错乱而取他物。盗戒可悔不可悔罪，《优婆塞五戒相经》中分别很详，应阅读参考。
    （3）邪淫戒
    不邪淫戒相。淫是两交会法，邪淫是指与非自己的妻子之外的女人行两交会法。若女人为父母兄弟儿女亲眷等所守护，或者为国家法律所保护，出家修行女为戒法所守护等，与这些人行两交会法，乃至与傍生行交会法，都是邪淫。即自己的妻子，若受持一日的戒法中，或有娠、乳儿及非时、非道、非处（地点如清净道场处）行两交会法，也是邪淫，作这些两交会的时候，自己的精神是清楚的，无错乱想，起爱乐心，即得根本罪。若只摩触，言语调戏等，是邪淫的方便罪。自己不作这样的事，就是守持不邪淫戒。
    《优婆塞五戒相经》说：‘佛告诸比丘，优婆塞不应生欲想欲觉，尚不应生心，何况起欲？恚痴结缚根本不净恶业。是中犯邪淫有四处：男、女、黄门、二根（一身中具有男女根的人）。女者：人女、非人女、畜生女。男者：人男、非人男、畜生男。黄门二根，亦同于上类。若优婆塞与人女、非人女、畜生女，三处行邪淫，犯不可悔。若人男、非人男、畜生男、黄门、二根二处行淫，犯不可悔。若发心欲行淫未和合者，犯小可悔（远方便故）。若二身和合止不淫，犯中可悔（近方便故）。若优婆塞婢使已经嫁有主，于中行邪淫者，犯不可悔。余犯如上说。三处者：口处、大便、小便处。除是三处，余处行欲皆可悔。若优婆塞婢使未配缘，于中非道（即非三处）行淫者，犯可悔罪，后生受报罪重。若优婆塞有男子僮使人等，共彼行淫，二处（口及大便处）犯不可悔罪。余轻犯罪同上说。若优婆塞共淫女行淫，不与值者，犯邪淫不可悔。与值无犯。若人死乃至畜生死者，身根未坏，共彼行淫行，女者三处犯不可悔。轻犯同上说。若优婆塞自受八支（一日一夜八关斋戒）行淫者，犯不可悔。八支无复邪正，一切皆犯。若优婆塞虽都不受戒，犯佛弟子净戒人者，虽无犯戒之罪，然后永不得受五戒，乃至出家受具足。’这邪淫戒，以三种因缘成不可悔：
    1.有淫心，即行淫时，心极爱乐，如饥得食，如渴得饮。
    2.是道，道即口及大小便处，于此三处行淫是名为道。
    3.事遂，正行交会。
    经中仅说自受八关斋戒行淫犯不可悔，应知己妻受八关斋戒共彼行淫亦不可悔，以是破他梵行故。
    （4）妄语戒
    不妄语戒相。妄语即虚妄不实的语言，自己意识不错乱，意欲欺诳他人，对于能够了解语言意义的一人或多人，说自己得了禅定神通等功德，或说证得预流果等，这叫妄说上人法，即超过普通人的常识以上的法。只要听的人了解自己所说的意义，不管其信与不信，即犯了妄语戒的本罪，这里面包括他人以如上所说的事来向自己询问，而自己用语言答认，或现相默认等，都是大妄语的本罪。假若自己说的话，听的人不了解所说语言的意义，或自己说得不具体等，虽是不实的语言，但只是妄语的方便罪。若平常小事见言不见，不见言见，闻言不闻，不闻言闻，觉言不觉，不觉言觉，知言不知，不知言知，皆是可以忏悔的小妄语罪。自己不说如上诸妄语，即是守持不妄语戒。
    《优婆塞五戒相经》说：‘佛告诸比丘，吾以种种呵妄语，赞叹不妄语者，乃至戏笑尚不应妄语，何况故妄语！是中犯者，若优婆塞不知不见过人圣法，自言我是罗汉，向罗汉者，犯不可悔。若言我是阿那含、斯陀含、若须陀洹，乃至向须陀洹。若得初禅、第二禅、第三禅、第四禅，若得慈悲喜舍无量心，若得无色定、虚空定、识处定、无所有处定、非想非非想处定，若得不净观，阿那般那念。诸天来到我所，诸龙、夜叉、薛荔、毗舍阇、鸠盘茶、罗刹来到我所，彼问我，我答彼，我问彼，彼答我，皆犯不可悔。若本欲言罗汉，误言阿那含者，犯中可悔。余亦如是说。若优婆塞，人问言：汝得道耶？若默然，若以相示者，犯中可悔（未决定了解故言可悔）。乃至言旋风土鬼来至我所者，犯中可悔。若优婆塞，实闻而言不闻，实见而言不见，疑有而言无，无而言有，如是等妄语皆犯可悔。若发心欲妄语未言者（远方便罪），犯下可悔。言而不尽意者（近方便罪），犯中可悔。若向人自言得道者，便犯不可悔。若狂，若心乱，不觉语者无犯。’此中妄说上人法的大妄语，以五缘成不可悔：
    1.所向是解义的人等。
    2.是人等想。
    3.有欺诳心。
    4.说重事，即说是罗汉等。
    5.听者解义。若向聋人、痴人、不解语人说，及向畜生等说，并属中可悔罪。
    （5）饮酒戒
    不饮酒戒相。酒是一种有刺激性的饮料，喝了以后，扰乱人的神经，使人容易失掉本来平静的心行，引起躁动、烦恼，乃至使人颠倒狂乱，生事肇祸。佛陀意在令修行的人，不致于逸乱性，而造作恶行，所以制令不饮酒戒。这里所说的酒，包括一切可以醉人的酒，无论是粮食作的、果子作的、药物等作的、干的、湿的，都在戒禁之内。于诸酒不饮，即是守持不饮酒戒。
    《优婆塞五戒相经》中说：‘诸比丘、优婆塞不得饮酒者，有二种：谷酒、木酒。木酒者，或用根、茎、叶、花、果，用种子，诸药草杂作酒，酒色、酒香、酒味，饮能醉人，是名为酒。若优婆塞尝咽者，亦名为饮，犯罪。若饮谷酒，咽咽犯罪。若饮醋酒，随咽咽犯。若饮甜酒，随咽咽犯。若啖曲能醉者，随咽咽犯。若啖滴糟，随咽咽犯。若饮酒淀，随咽咽犯。若饮似酒、酒色、酒香、酒味，能令人醉者，随咽咽犯。若但作酒色，无酒香，无酒味，不能醉人，及余饮，皆不犯。’酒戒但是遮罪，为防护过患，所以与前四性戒同制，实是可以忏悔的戒。此酒戒三缘成犯：
    1.是醉性，即饮之醉人。
    2.酒想，即想无错乱，心知是酒，或酒和合的饮料等。
    3.入口，入口尝咽即成犯罪。
    咽咽犯罪，即结归可以忏悔的罪。若饮食不知有酒，或虽是酒煮之物，但以失去酒性，不能醉人，饮食之并皆无罪。
    （三）杀生等过患
    杀生等五事，是残忍、犯法、不道德、不诚实、放逸散乱的罪行。犯之轻者，自心中常怀恐惧、疑畏、眷属不和、朋友不信、失事处悔等。为善人所呵，为法律所制裁，为舆论所声讨，为社会所憎恶，为智者所厌嫌等。从业果上来说，杀生种短命业因缘，偷盗种贫穷业因缘，邪淫种怨家业因缘，妄语种诽谤业因缘，饮酒种愚痴业因缘。若于杀生等事犯之重者，则成三恶趣因，未来人身尚且不保，更想于善趣中得到康乐财富等善法顺缘，那是从梦想中也不会得到的。学佛的人，其最高目标，固在圆证无上佛果，但能作此佛果因行基础的所依体，以人身为最善最胜。杀生等事既然是三恶趣的因，与学佛人应修的正行相反，而且于众生有大损害，于自己有很多过患，故必须戒除。
    如《优婆塞戒经》第三卷《受戒品》说：‘人有五事现在不能增长财命。何等为五？一者乐杀、二者乐盗、三者邪淫、四者妄语、五者饮酒。一切众生因杀故，现在获得恶色、恶力、恶名、短命、财物耗减、眷属分离、贤圣呵责、人不信用、他人作罪、横罹其殃，是名现在恶业之果。舍此身已，当堕地狱，多受苦恼饥渴、长命、恶色、恶力、恶名等事，是名后世恶业之果。若得人身，复受恶色、短命、贫穷，是一恶人因缘力故，令外一切五谷果瓜悉皆减少，是人殃流，及一天下。若人乐偷，是人亦得恶色、恶力、恶名、短命、财物耗减、眷属分离，他人失物，于己生疑，虽亲附人，人不见信，常为贤圣之所呵责，是名现在恶业之果。舍此身已，堕于地狱，受得恶色、恶力、恶名、饥渴苦恼，寿命长远，是名后世恶业之果。若得人身，贫于财物，虽得随失，不为父母、兄弟、妻子之所爱念，身常受苦，心怀愁恼，是一恶人因缘力故，一切人民凡所食啖不得色力，是人恶果，殃流万姓。若复有人乐于妄语，是人现得恶口、恶色，所言虽实，人不信受，众皆憎恶，不喜见之，是名现世恶业之报。舍此身已，入于地狱，受大苦楚，饥渴热恼，是名后世恶业之报。若得人身，口不具足，所说虽实，人不信受，见者不乐，虽说正法，人不乐闻，是一恶人因缘力故，一切外物资产减少。善男子！若复有人乐饮酒者，是人现世喜失财物，身心多病，常乐斗诤，恶名远闻，丧失智慧，心无惭愧，得恶色力，常为一切之所呵责，人不乐见，不能修善，是名饮酒现在恶报。舍此身已，处在地狱，受饥渴等无量苦恼，是名后世恶业之果。若得人身，心常狂乱，不能系念思惟善法，是一恶人因缘力故，一切外物资产臭烂。善男子！若复有人乐为邪淫，是人不能护自他身，一切众生，见皆生疑，所作之事，妄语在先，于一切时，常受苦恼，心常散乱，不能修善，喜失财物，所有妻子，心不恋慕，寿命短促，是名邪淫现在恶果。舍此身已，处在地狱，受恶色力，饥渴长命，无量苦恼，是名后世恶业果报。若得人身，恶色、恶口，人不喜见，不能守护妻妾男女，是一恶人因缘力故，一切外物不得自在。’
    《大智度论》第十三卷中，依经所说，于杀生列举十罪，于偷盗列举十罪，于邪淫列举十罪，于妄语列举十罪，乃饮酒列举三十五失。《出家缘经》，于饮酒说三十五恶。《分别善恶所起经》中，于饮酒醉，得三十六失。爱乐广详者，可取经论披读。
    （四）受持五戒的利益
    五戒是远离一切恶法，生长一切善法的基础，能受持五戒，则能渐断一切恶因恶果，生长一切善因善果。故经中说五戒行是世间庄严具中的殊胜庄严，是无上微妙的宝藏。如《优婆塞戒经》第三卷说：‘善男子！优婆塞戒，名为璎珞，名为庄严，其香微妙，熏无边界，遮不善法，为善法律，即是无上妙宝之藏。’
    受持五戒，能远离修习善法的障难，具足增长善法的顺缘。如来在《灌顶经》里说，若持五戒，有二十五位善神护卫，在人左右，守于宫门宅户之上，使万事吉祥，故严持五戒的人，非人、灾害等不能侵犯，因而能够顺利地断除恶法，进修善法。如《法句譬喻经》卷四说：‘戒德可恃怙，福报常随己，见法为人长，终远三恶道。戒慎除苦畏，福德三界尊，鬼龙邪毒害，不犯持戒人。’又持五戒者，是于一切众生不作损害恼乱，清廉守正，贞洁不乱，诚实不欺，无迷乱误失，由此之故，心安理得，喜乐无苦。所以《大般涅槃经》十一卷说：‘持戒则为乐，身不受众苦，睡眠得安稳，寤则心欢喜。’
    五戒的有漏果报，能招感殊胜的人天福报，如《辩意长者子经》说：‘不杀得长寿，无病常鲜肥，一切受天位，身安光景至。不盗常大富，自然钱财宝，七宝为宫殿，娱乐心常好。男女俱不淫，身体香洁净，所生常端正，德行自然明。不欺口气香，言语常聪明，谈论不謇吃，所说众奉行。酒肉不过口，无有误乱意，若当所生处，天人常奉侍。若其寿终后，二十五神迎，五福自然来，光影自炜炜。’
    又严持五戒，即为得一切戒的根本，证得一切无漏功德和圣界的所依器。如《优婆塞戒经》卷三说：‘善男子！优婆塞戒极为甚难，何以故？是戒能为沙弥十戒，大比丘戒，及菩萨戒，乃至阿耨多罗三藐三菩提而作根本。至心受持优婆塞戒，则能获得如是等戒无量利益。’又说：‘善男子！僧已和合听汝受持优婆塞戒。是戒即是一切善法之根本也。若有成就如是戒者，当得须陀洹果，乃至阿那含果。’由持五戒有如是功德，故《大智度论》第十三卷也说：‘持戒之人，常得令世人所敬养，心乐不悔，衣食无乏，死得生天，后得佛道。持戒之人，无事不得，破戒之人，一切皆失。’论中还用多种譬喻，赞叹持戒功德，呵责破戒过失，当检论披读，以广闻慧。
    由上经论所说持戒功德，可以知道，无论求现世与后世的利益，有漏与无漏的功德，皆当以清净受持五戒为根本，由此道理，凡是受了五戒的优婆塞与优婆夷，都应当严持净戒。
    （五）分满受持
    经律论三藏中，都说对于五戒可以一分受持，多分受持，乃至圆满受持。因为近士男女，居于在家，受世间乐，兼修福德戒行，限于自己能力环境等，难于圆满受持五戒，故如来特地开许其发心受持一戒二戒，乃至圆满受持。
    如《优婆塞戒径》第三卷说：‘若受三皈受持一戒，是名一分。受三皈已受持二戒，是名少分。若受三皈持二戒已，若破一戒，是名无分。若受三皈受持四戒，是名多分。若受三皈受持五戒，是名满分。’《大智度论》第十三卷说：‘是五戒有五种受，名五种优婆塞。一者一分行优婆塞，二者少分行优婆塞，三者多分行优婆塞，四者满行优婆塞，五者断淫优婆塞。一分行者，于五戒中受一戒，不能受持四戒。少分行者，若受二戒，若受三戒。多分行者，受四戒。满分行者，尽持五戒。断淫者，受五戒已，师前更作誓言：“我于自妇不复行淫。’是名五戒。’五戒之中，于杀盗淫不饮酒四罪不作，是身善律仪。妄语不作，是口善律仪。受一分多分，皆得戒律仪。如《成实论》第八卷说：‘佛说优婆塞有五戒，问曰：“有人言，具受则得戒律仪，是事云何？”答曰：“随受多少，皆得律仪，但取要有五。”’


(一)深信业果决定

    三、修行十善业
    （一）深信业果决定
    佛法所说的义理，在世俗谛中，最重要的一法，就是业果决定。即世出世间的果报，都是由染净业力为缘而显现，依业流转，依业出离，此理决定不虚。
    如《佛说十善业道经》说：‘尔时！世尊告龙王言：一切众生，心想异故，造业亦异，由是故有诸趣轮转。龙王！汝见此会及大海中，形色种类，各别不耶？如是一切，靡不由心造善不善身业语业意业所致。而心无色不可见取，但是虚妄诸法集起，毕竟无主，无我我所，虽各随业所现不同，而实于中无有作者。故一切法，皆不思议，自心如幻。智者知已，应修善业，以是所生蕴处界等，皆悉端正，见者无厌。龙王！汝观佛身，从百千亿福德所生，诸相庄严，光明显曜，蔽诸大家，设无量亿自在梵天，悉不复现，其有瞻仰如来身者，岂不目眩！汝又观此诸大菩萨，妙色严净，一切皆由修习善业福德而生。又诸天龙八部众等，大威势者，亦因善业福德所生。今大海中，所有众生，形色粗鄙，或大或小，皆由自心种种想念，作身语意诸不善业，是故随业，各自受报。汝今常应如是修学，亦令众生了达因果，修习善业。汝当于此正见不动，勿复堕在断常见中。’
    业是身语意的造作，顺理利人的造作，是善业。违埋损人的造作，是恶业。善业有生乐果的力用，恶业有生恶果的力用。善恶业招感果报的功能势力，如善业未为邪见损害，恶业未修善法对治，纵经百千万亿大劫，也不会消失，到因缘成熟的时候，决定感受果报不虚。所以如来在诸经中说：‘假令经百劫，所作业不亡，因缘会遇时，果报还自受。’
    善恶业行是由自己造作的，果报成熟的时候，也是自己领受，决无他人能够代替。如《地藏菩萨本愿经》说：‘众生莫轻小恶，以为无罪，死后有报，纤毫受之。父子至亲，歧路各别，纵然相逢，无肯代受。’又如《妙法圣念处经》卷第一说：‘业果善不善，所作受决定，自作自鸿缚，如蚕等无异。’又《法句经．身受品》说：‘恶自受罪，善自受福，亦各须熟，彼不相代。’又《佛般泥洹经》卷下说：‘善恶随身，父有过恶，子不获殃；子有过恶，父不获殃。各自之死，善恶殃咎，各随其身。’而且业力成熟了的时候，是无法避免逃脱的。如《有部毗奈耶》四十六卷说：‘不思议业力，虽远必相牵，果报成熟时，求避终难脱。’
    于前诸经所说善恶业果决定的道理，学佛的人能够信受不疑，即是于佛法中生起了世俗道理的正见（胜义正见即无我理）。得了这一正见，学佛就有了稳固的基础，知道掌握自己的业行而断恶修善，乃至转染成净，圆证无上的佛果、菩提，这也就是真正掌握了自己净化的命连。


(二)业道名义

    （二）业道名义
    业行的体相差别，非常深广复杂，声闻与菩萨的智慧也都不能详尽了解，唯有佛陀的一切种智才能够究竟穷知。但是如来在经中说，一切业行，以十业道为根本。十业道中有善有恶，恶的名十恶业道，善的名十善业道。十恶业道即：杀生、偷盗、邪淫、妄语、离间语、粗恶语、绮语、贪欲、嗔恚、邪见。杀生等三种是身恶业，妄语等四种是语恶业，贪等三种是意恶业。十善业道即：离杀生、离偷盗、离邪淫、离妄语、离离间语、离粗恶语、离绮语、无贪、无嗔、正见。以身口意去造作杀生等，离杀生等，就是善业恶业。
    业以思心所为体，十善十恶皆是业行，是思心所的游履处，业之道故，立名业道。依《俱舍论》及《瑜伽师地论》六十卷说，思是业非业道；杀生乃至绮语七支，其业亦是业道；贪嗔邪见，是业道非业。又善恶业行，使人趣向于六趣，通生苦乐异熟果故名为业道。即造作名业，能通名道。学佛的人，于信解业果决定之后，即应当在受持五戒的基础上，进一步修行十种善业，作为获得人天身、声闻、独觉、无上菩提的根本。
    如《十善业道经》说：‘龙王当知！菩萨有一法，能断一切诸恶道苦。何等为一？谓于昼夜，常念思维观察善法，令诸善法，念念增长，不容毫分不善间杂，是即能令诸恶永断，善法圆满，常得亲近诸佛菩萨，及余圣众。言善法者，谓人天身、声闻菩提、独觉菩提、无上菩提，皆依此法以为根本而得成就，故名善法。此法即是十善业道。’修行十善业道，既然是首重永断十种恶业，即必于十恶业道分别了解，才能清楚地知其如何永离而净修十善业，故此先须分别十恶业道。


(三)十恶业道决择

    （三）十恶业道决择
    甲、业道自相
    《瑜伽师地论决择分》五十九卷说五种相，建立十恶业道自性差别。即：事、想、欲乐、烦恼、方便究竟。《杂集论决择谛品》亦说五相。如彼论说：‘又杀生等，应以五门分别其相、谓事故、意乐故、加行故、烦恼故、究竟故。’此中意乐摄《瑜伽师地论》的想和欲乐，想与乐所作欲，俱是意乐故。《瑜伽师地论》加行究竟为二，加行是方便，究竟是圆满，分开别说，更为显了。并且《瑜伽师地论本地分》第八卷也是这样分法，如彼论说：‘云何杀生？谓于他众生（事），起杀欲乐，起染污心（烦恼），若即于彼起杀方便（加行），及即于彼杀究竟中所有身业。’于余九业道，皆作如是分别。故《杂集论》所说五相即《瑜伽师地论本地分》五相，又与《决择分》五相无违，并且便于说明业道自相建立的差别，故这里依之决择十恶业道，但次第则依《本地分》而说。
    （1）事：即起杀生等业的所依处事，《瑜伽师地论》、《杂集论》俱说于有情数，非有情数，随其所应，十恶业道依之而转。实通三处起，即杀生、邪淫、妄语、离间语、粗恶语、嗔恚大业道，于有情处起。绮语业道，依名身处起，即依非情处起。偷盗、贪欲、邪见三种，通情非情处起。
    （2）意乐：就是于造作业行的所做事上，生起想意乐，及起当作此业道的意乐。《瑜伽师地论》说：‘想有四种，谓于彼彼非彼想，非于彼彼彼想，于彼彼想，非于彼彼非彼想。’四种想中，唯第三想是业道，以无错乱故。《瑜伽师地论》说：‘欲乐者，或有倒想，或无倒想，乐所作欲。’乐所作欲，即乐欲所作。这里的意乐，即包括《瑜伽师地论决择分》所说的想与欲乐。
    （3）烦恼：即贪嗔痴，如其所应，或总起，或别起。即造杀生等业时，由贪等烦恼相应，或贪嗔同起，或贪痴同起，或嗔痴同起，或贪嗔痴一切皆具。
    （4）加行：即杀生等业的作用，或由自己，或教他人发起身语意三业，进行杀生等的方便，即于乐欲所作发起的三业，如策划、布置等，皆为究竟完成乐欲所作业的加功用行，故名加行。
    （5）究竟：即于乐所作业，由彼彼加行、杀生等业道，或于当时圆满，或于后时圆满，是为究竟。
    杀生等恶业，若上述五相不具，此业即非圆满业道所摄。若五相具足，此业即是圆满业道所摄。
    此下以五相分别建立十恶业道：
    （1）杀生：杀生业道以有情数众生为事。意乐即能害者于众生所，作众生想，及起必杀害的乐欲。这种想即名于彼众生不颠倒想，依此想作如是欲心：我当杀害彼众生，如是名为杀生意乐。这能杀害众生的人，或由贪烦恼所蔽，或由嗔烦恼所蔽，或由痴烦恼所蔽，或贪等二种烦恼所蔽，或贪等三种烦恼所蔽，而起杀生的造作心，是名烦恼。用意乐与烦恼，由自己、或教他人，发起方便加害众生，是为加行。若由加害之时，被害众生当即命终，便于当尔之时说名成就究竟业道。若加害之时，被害众生未即命终，于后时舍命，由此方便彼众生命终时，说名后时成就业道。
    （2）偷盗：偷盗业道以他人主权所摄的有情数与非有情数为事。意乐，即于他人所摄事起想，及于彼起偷盗乐欲。烦恼，即贪等三毒，或起一或起二或具起三种。加行，即自作教他作等种种偷盗业行。如挖墙窃盗，伏道劫夺，拒债不偿，受寄不还，谄诳诈取，以势力胁迫等。究竟，《瑜伽师地论》说移离本处，《杂集论》说取为己有。二义兼取为善，以为利他而盗，或由憎嫉等，以嗔恚心破坏他人所摄之物，虽不取为己有，亦成业道故。
    （3）邪淫：邪淫业道事，即非所应行欲行之女，或虽所应行，于非支、非时、非处、非量，及不应理的一切男与不男。支是支分，除产门外，所有余分，皆名非文。非时有五，若秽下时、胎圆满时、饮儿乳时、受斋戒时、有疾病时、是名非时。非处，即诸尊重所集会处、或塔寺中、或大众前、或地高下，如是等处，说名非处。过量行欲行，名为非量。此上即说，虽是自己妻妾，若于非支、非时、非处、非量行欲行，亦是邪淫。除己妻妾，于一切男及不男，无论其属自属他，皆不应行欲行，若于彼等行欲行，是不守世间体法的非理邪行，故说名不应理。意乐，即于彼彼女男等起彼彼想，是想不错乱，及依此想起近习乐行之欲，总为意乐。烦恼，即贪等三毒，或具或不具。加行，即自行、教他，或公显、或隐窃、或因谄诳方便、或因委托，或由威势等而行邪行。究竟，即两两交会。
    （4）妄语：妄语业道事，即见闻觉知，不见不闻不觉不知。意乐，即于见闻等翻作不见闻等想，不见闻等，翻作见闻等想，即别异想；起覆藏想乐说之欲，即欲别异说；总为意乐。烦恼，即贪等三毒，或具不具。加行，即用语言自说，或教他说，或书写文字，或默默表认，或动肢体表相，或为作证等。无论为自己或为他人，而于见闻觉知言不见闻觉知，于不见闻觉知而言见闻觉知，乃至默认现相等，都是妄语。究竟，即听者，或对论者领解其义。
    （5）离间语：离间语业道事，即诸有情，若本和合，若不和合。意乐中的想，即俱于彼和合有情不和合有情，起乖离及不和合想。欲乐，即依此想而起乐彼有情乖离及不和合欲。烦恼，即贪等三毒，或具或不具。加行，即为乖离故，以实事或非实事毁訾于他，而发语言，或自说，或教他说。《瑜伽师地论》五十九卷说：‘复次，若以实事毁訾于他，为乖离故而发此言，名离间语。或以不实假合方便以为依止，为损坏他而有陈说。或依亲近施与，或依知友给侍而有陈说，名离间语。若自利缘，或损他缘，或由他教，或现破德（宣说他无实德），或现怖畏，为乖离故，或自发言，或令他发，如是皆名离间语罪。’究竟，即所破的人领解其义。
    （6）粗恶语：粗恶语业道事，即于诸有情能引起恚恼损害。意乐，即覆善语说粗语想，及起乐粗言欲。烦恼，即贪等三毒，或具不具。加行，即自说或教他说粗恶语言。《瑜伽师地论》五十九卷说：‘复次，若有对面发辛楚言，名粗恶语。或不现前，或对大众，或幽僻处，或随实过，不随实过，或书表示，或假现相，或依自说，或依他说，或因掉举，或因不静、或依种族过失，或依止过失，或依作业，戒禁现行过失，或自发起辛楚之言，或令他发，如是皆名粗恶语罪。’即依于环境与彼有情的实有过失，及其操业过失等而说非可爱语，皆是加行。究竟，《瑜伽师地论》说：‘谓呵骂彼’。妄语离间语，必令他了解才成业道。此粗恶语不待他解，但发即成，以所说恶语不必对境了解，或虽了解，彼不生恚恼，皆可成业道故。
    （7）绮语：绮语业道事，即能引发无利之义。意乐，即起说绮语想，及起乐说绮语之欲。烦恼，即贪等三毒，或具或不具。加行，即勤勇地以种种声音宣说无义利语。《瑜伽师地论》五十九巷说：‘复次，若有依舞而发歌词，名为绮语。或依作乐，或复俱依（舞乐），或俱不依，而发歌词，名为绮语。若佛法外能引无义所有书论，以爱乐心，受持赞美，以大声音而为讽颂，广为他人开示分别，皆名绮语。若依斗讼诤竞发言，或乐处众宣说王论、臣论、贼论、广说乃至国土等论，皆名绮语。若说妄语或离间语、或粗恶语，下至不思不择发无义言，皆名绮语。又依七事而发绮语，谓斗讼诤竞语，诸婆罗门恶咒术语，苦所逼语，戏笑乐游之语，处众杂语，颠狂语，邪命语，如是一切名绮语罪。’究竟，《杂集论》说：‘正发此言’。即正说绮语，便成业道，以不待他有情了解故。
    （8）贪欲：贪欲业道事，即他所摄财产。意乐，即于他财起耽求想，及起欲为己有的爱欲。烦恼，即贪等三毒，或具或不具。加行，即思量筹度，欲为己有，乃至于所思想的事，发起种种欲念，皆是加行所摄的非圆满的贪欲业道。如起欲念：‘如何能令他家父母妻子财产等归属于我。怎样能令他知道我是少欲知足者，住正念者，是聪慧者，是多闻者，是持戒者。怎样能令他人恭敬我，供养我。怎样能令自己当来生于天上，以胜妙五欲为游戏。’
    广如《瑜伽师地论》五十九卷所说应知。究竟，《瑜伽师地论》说：‘谓于彼事定期属己。’《杂集论》说：‘决定执为己有。’又贪欲圆满，须具五相，如《瑜伽师地论》五十九卷说：‘复次，略由五相，建立贪欲、嗔恚、邪见圆满自相。何等名为贪欲五相？一有耽着心，谓于自财所。二有贪婪心，谓乐积财物。三有饕餮心（贪财为饕，贪食为餮），谓于属他资财等事，计为华好，深生爱味。四有谋略心，谓作是心，凡彼所有，何当属我。五有覆蔽心，谓贪欲缠之所覆故，不觉羞耻，不知过患，及与出离。设于自财，有耽着心，无余心现，当知此非圆满贪欲意恶行相。如是有耽着心及贪婪心，无余心现，亦非圆满贪欲之相，如是广说，乃至如前所说诸相，随缺一种，即非圆满贪欲之相，若全分摄，乃名圆满贪欲之相。’
    （9）嗔恚：嗔恚业道事，即于诸有情能为恚恼损害。意乐，起覆善心作损害想，及起损害等欲。烦恼，即贪等三毒，或具或不具。加行，即起损害思等。如作是思：彼于我有无义欲，故我于彼当作无义。又作是思：彼于我所已作、正作、当作无义，我亦于彼当作无义。又作是思：云何令我于能损害怨家恶友而得自在，缚害驱摈，或行鞭挞、或散财产、或夺妻妾、朋友、眷属及家宅等。又作是思：云何令彼能损于我之怨家恶友，自遭诸苦恼事。乃至思维：愿怨家等，发起某种身语恶行而丧失财产、眷属、善法；身坏命终，生诸恶趣。如是等思，皆是加行所摄的非圆满的嗔恚业道。
    如《瑜伽师地论》五十九卷广说应知。究竟，即决定加害，或损害的日期决定。又嗔恚圆满，亦须具三相，如《瑜伽师地论》五十九卷说：‘何等名为嗔恚五相？一有憎恶心，谓于能损害相，随法分别故。二有不堪耐心，谓于不饶益，不堪忍故。三有怨恨心，谓于不饶益，数不如理随忆念故。四有谋略心，谓于有情，作如于是意：何当捶打，何当杀害，乃至广说故。五有覆蔽心，谓如前说（贪欲中，更贪为嗔即是）。于此五相，随缺一种，即非圆满嗔恚之相。若具一切，方名圆满。’
    （10）邪见：邪见业道事，即实有义。意乐，即于实有义起非有想，即于彼诽谤起爱欲。烦恼，即贪等三毒，或具不具。加行，即起诽谤因果等之思等。总有四种：即谤因、谤果、谤作用、谤实有事。谤因，即诽谤无有善恶行等。谤果，即诽谤无有善恶所招的异熟果。
    谤作用有三种：一谤无父母作用，父母各有二德：一可敬福田，若供养承事，增长福业，若杀害损恼等，成大重罪。二任持相续，即托父亲的种子，母亲能任持，相续生长。谤无父母的殖种和持种用，及极重的善恶业因用，是为诽谤无父母作用。二谤无往来作用，即否认有前世后世。三谤受生作用，即谤无结生相续的化生有情。
    谤实有事，即诽谤无真阿罗汉等。如《瑜伽师地论》五十九卷说：‘复次，若作是思：决定无施，是名邪见。广说乃至谤因、谤用、谤果、坏真善事，如是一切皆名邪见根本业道。’
    问：一切不正的执见皆名邪见，为什么如来于恶业道之中唯说诽谤因果等四种名邪见呢？《瑜伽师地论》五十九卷有此问答文，兹节录如下：‘问：一切倒见皆名邪见，何故世尊于业道中但说如是诽谤之见名为邪见？答：由此邪见，诸邪见中最为殊胜，何以故？由此邪见为依止故！有一沙门，若婆罗门，断诸善根。又此邪见，最顺苦业，怀邪见者于诸恶法随意所行，是故此见偏说在彼恶业道中。当知余见，非不邪见自相相应’。究竟，即决定诽谤。此邪见圆满，亦须具五相，如《瑜伽师地论》五十九卷说：‘何等名为邪见五相？一有愚痴心，谓不如实了所知故。二有暴酷心，谓乐作诸恶故。三有越流行心，谓于诸法不如理分邪推求故。四有失坏心，谓无施与、爱养、祠祀等，诽谤一切妙行等故。五有覆蔽心，谓邪见缠之所覆蔽，不觉羞耻，不知过患，及出离故。于此五相随缺一种，即非圆满邪见之相！具一切分，乃名圆满。’
    乙、三根发业与究竟差别
    以上所说十恶业道，每一支都是由贪嗔痴三根为发业的烦恼。为加行时各支皆有三种的差别，究竟则唯由贪、或唯由嗔、或唯由痴，或贪嗔痴随一究竟。这里分述如下：
    （1）杀生业道：若为求得血肉等，或为夺取财物等，或受他人雇用，或为报他人思，或为朋友，或希望作朋友，或为衣食等奉主人等教命，或想彼能衰损，或想彼能障碍财利等，而行杀害，如是一切，名贪所生杀生业道。
    若想彼于己乐为无义，或想彼于已曾为无义，或恐彼于己当为无义，或见彼于己正为无义，而行杀害。或依于己身、于亲友、于仇怨，在过去现在未来，已为无义，正为无义，当为无义，共为九恼事，而行杀害。如是一切，名嗔所生杀生业道。
    若妄计杀生为正法，谓己是其余众生的善友，彼因我杀，身坏命终当生天上。或心作是念；为尊长故，法应杀害，如为尊长生日等事而杀生等。或作是心：谓有诽毁天神、梵世主、骂婆罗门，法应杀害。或计于杀生业，作及增长，皆无异熟果报，向他人宣说，劝其行杀害，彼人由劝故，遂行杀害，能劝者得杀生罪。由如是等心而行杀害，是名从痴所生杀业。此后所说谬计杀生，作及增长，皆无异熟果等，是从痴所生杀生的道理，于诸余业道，乃至邪见，当知亦尔。即妄计偷盗无异熟果，乃至妄计邪见无异熟果，皆是从痴所生偷盗，乃至是从痴所生邪见。或有妄计以其父母、亲爱眷属掷置火中，或断食、投岩、弃于旷野，是真正法。如是一切，皆名痴所生杀生业道。
    （2）偷盗业道：于他财食饕餮而取，即凶暴地贪取他人的财食。或为他人雇用，或为思所摄，或祈求后思，或为衣食等奉主人等教命，或为得称誉，或为得安乐，而行劫盗，如是一切不与取业，皆是从贪所生。
    若作是思：彼于我所，乐行无义，广说乃至行九恼害事增上力，而行劫盗。不必贪着彼所有财，不必希求诸余财物，是嗔恚所生不与取业。或由憎恚他故，焚烧聚落、舍宅、财物、珍玩、资具，当知是触嗔恚所生，是盗相似罪。或此盗罪更为增强，或由憎彼故，令他劫夺，破散彼财，他受教命依行其事时，能教的人所得不与取罪，是从嗔恚所生。如上所说，不与取业，皆是从嗔所生。
    若作是心：为尊长故而行劫盗，是为正法。或作是心：若有诽毁天神，大梵天王，骂婆罗门，于法应夺彼财物。或作是心：若为祠祀支分，或为祠祀事具，于法应行劫盗，如是等不与取业，皆是从痴所生，余妄计于偷盗作及增长无异熟果等，亦是从痴所生业，准杀生中说应知。
    （3）邪淫业道：若见到或听闻到有不应行的事，便起不如理的作意，分别取相，由贪欲缠之所缠缚而行非法欲邪行，或欲摄受朋友，或为衣食等承主教命，或为存活希求财谷、金银、珍宝而行邪行，如是一切，名贪所生欲邪行罪。
    若作如是思：彼于我所，乐行无义，广说乃至九恼害事以为依止，而行邪行，非彼先有欲缠所缠，然于相违非所行事，为报怨故，勉励而行邪行，若嗔所生欲邪行罪。或由憎彼故，以彼人妻妾令他人毁辱。若受教者，行欲邪行，能教人便触嗔恚所生相似欲邪行罪，或更尤重。如是一切，名嗔所生欲邪行业。
    若作是心：由母及父亲，或他妇女，命为邪欲事，若不作者，便获大罪，若行此者，便获大福，这是以非法为法，而行邪行。是名从痴所生欲邪行罪。余妄计于欲邪行作及增长无异熟果等，亦是从痴所生业，准杀生中所说应知。
    （4）妄语业道：若为利养，或为称誉，或为安乐，而说妄语，如是一切，若贪所生妄语业道。
    若有依九恼害事，而说妄语，名嗔所生妄语业道。
    若作是思：为诸尊长，或复持牛戒者为牛，或祠祀天者为祠具，于法应说妄语。如是妄语，从痴所生。若作是心：诸有沙门，若婆罗门，违背诸天，违梵世主，违婆罗门，于彼等人说妄语，称顺正法。如是妄语，从痴所生。若作是计：于正法，作正法想；于毗奈耶，作毗奈耶想；以覆藏想，妄语破僧，无有非法。如是妄语，亦从痴生。余妄计于妄语业作及增长，无异熟果等，亦是从痴所生业，准杀生中所说应知。
    （5）离间语业道。（6）粗恶语业道。如妄语业道所说由贪等为加行发业，有三种差别，如是离间语业和粗恶语业，亦有三种差别，准例应知。若妄计离间语业、粗恶语业，作及增长，无异熟果等，亦是从痴所生离间语业和粗恶语业。如杀生中广说应知。
    （7）绮语业道：若为戏乐，或为显己是聪睿者，或为财利、称誉、安乐而行绮语，是名贪所生绮语业道。
    若有依止九恼害事，而说绮语，名嗔所生绮语业道。
    若有于中欲求真实，为求坚固，为求出离，为求正法，而行绮语业，是名从痴所生绮语业道。若妄计于绮语业，作及增长，无异熟果等，亦是从痴所生绮语业。如杀生中广说应知。
    （8）贪欲业道：若有人于他非怨有情所有的财物资具，先取其相，希望追求的增上力故，起如是心：凡彼所有，愿当属我。此是‘于他资财决定执己有’《杂集论》的贪爱之前而生的贪爱，即立此名贪加行，名贪所生贪欲业道。
    若于他人财物不计为好，但由九恼事增上力故，起如是心：凡彼所有，皆当属我。此是从嗔恚而生贪爱，名嗔所生贪欲业道。
    若作如是的计执：大自在天，遍净天，帝释天，大梵天王等注心多住，能获大福佑，作如是意，注心多住，若痴所生贪欲业道。若妄计于贪欲业作及增长，无异熟果等，亦是从痴所生贪欲业。如杀生中广说应知。
    （9）嗔恚业道：若为财利、称誉、安乐，于他有情起损害心，是从贪爱而生嗔恚，名贪所生嗔恚业道。
    若由九恼事增上力故，从怨怼想而起损害心，名嗔所生嗔恚业道。
    若住于此法，及外道法的所有沙门与婆罗门，憎恶他人受持的执见，于他见所，及受持彼见的沙门与婆罗门所，起损害心，名痴所生嗔恚业道。若妄计于嗔恚业作及增长，无异熟果等，亦是从痴所生嗔恚业。如杀生中广说应知。
    （10）邪见业道：若作是心，诸人有拨无妙行恶行因果等的执见，彼于王等能获大供养及衣服等，即以此事增上力故，起拨无因果等见，名贪所生邪见业道。
    若作是心：持说有布施、有受者的因果等见的某人，违害于我，我今不应与怨怼人同志，由憎恚故，起如是见说：无施与、无受者的因果等，名嗔所生邪见业道。
    若由非理作意，于法思惟、筹量、观察，由此方便所引寻伺发起邪见，名痴所生邪见业道。若妄计于邪见业作及增长，无异熟果等，亦是从痴所生邪见业。如杀生中广说应知。
    如上所说十恶业道，为加行时虽有贪嗔痴三种发生差别，但究竟时圆满业道则各有不同。杀生、粗恶语、嗔恚业道，贪嗔痴为加行，由嗔究竟。若有慈悲，必不杀害，损害他有情故。偷盗、邪淫，贪欲业道，贪等三毒为加行，由贪究竟。若有无贪善根，必不造作偷盗、邪淫、贪欲业故。妄语、离间语、绮语三种，贪嗔痴为加行，于三毒中随由一种究竟。具三善根有情，必不说妄语等三恶业故。邪见业道，贪嗔痴为加行，由痴究竟。起邪见有情，由有迷理无明故。《瑜伽师地论略纂》卷第四摄颂说：‘杀粗嗔由恚；盗邪贪由贪：三三邪见痴；恶业道究竟。’
    还应该知道，贪等三不善根正发业的，唯是无明。助发业者则不决定。这里依据《瑜伽师地论》第六十卷所说三不善根发十不善业，是随增义说，非不用痴。《缘起经》中说无明具十一种殊胜事故，如理应思。
    丙、十恶业道轻重差别
    《瑜伽师地论》第六十卷说：十恶业道，由五因缘成重。即：一由意乐，二由方便，三由无治，四由邪执，五由其事。分别蓥述如下：
    （1）杀生业道：由五因缘故，杀生成重：一由意乐故重，即由猛利的贪欲、嗔恚、愚痴意乐所作。二由方便（加行）故重，即于杀生事应作、正作、已作，心便踊跃。心生欢悦。或有自作，或复劝他作，于所作杀生事称扬赞叹，见着同行杀生的人，意便欣庆。或由长时思量，长时蓄积怨恨心已，杀彼众生。或于杀生不休息地无间所作，殷重所作。或于一时间内，损杀很多众生。或以坚固发业因缘而行杀害。或令被杀众生起大恐怖，无所依投而后杀害。或于孤苦贫弱哀戚悲泣等有情而行杀害。如是一切由方便，名重杀生。三由无治故重，无治就是无对治法。若人唯行杀害，不能于日日中，乃至极少时分受持一学处（一条戒）。或亦不能于每月的初八日、十四日、十五日，及半月等受持斋戒。或亦不能于时时间修惠施作福，及问讯、体拜、迎送、合掌、和敬业等。又亦不能于时时间获得猛利增上惭愧，悔所作恶。又不能证得世间离欲的禅定等。又不能证实法现观，而成初果圣人。如是一切，由无对治法故，名重杀生。四由邪执故重，若诸沙门，或婆罗门，于邪祠祀，执为正法而行杀害。又作是念，杀羊等无罪，由彼羊等，是梵天王为资助人类生活所化，起此邪见而行杀害。诸如是等，皆由邪执故，名重杀生。五由事故重，若杀害大身众生，或有杀害人与人胎，或父或母，及余可尊敬崇重的师长等，或有杀害归投于己的有情，或委托信任于己的有情，或杀害诸有学无学圣者、杀害菩萨、杀害阿罗汉、杀害独觉，或知道如来性命杀不着，于如来作杀害意，恶心出佛身血，如是一切由其事故，名重杀生。与如上所说因缘相违而杀生者，名轻杀生。
    以上所说由五因缘成重杀业，准知余九恶业亦由五因缘成重业道。唯第五由事故轻重差别不同，故此下唯说偷盗等由事故成重的意义。
    （2）偷盗业道：若多劫盗，劫盗妙好物，劫盗委托信任于己之人的财物等，劫盗孤贫人财物，劫盗佛法中出家众，入聚落而行劫盗，劫盗有学圣者，或阿罗汉，或诸独觉，或僧众、佛塔、寺庙，所有财物。如是一切皆由事故，名重偷盗业。
    （3）邪淫业道：行不应行中，若己母，母之亲戚，及朋友委托信任于己之他妻。或住禁戒、或比丘尼、或沙弥尼、或正学女，如是一切，由其事故，名重欲邪行。非支行中，若由面门，是由其事故，名重欲邪行。非时行中，若受斋戒，若胎圆满，若有重病，是由其事故，名重欲邪行。非处行中，若佛塔、若寺庙，是由其事故，名重欲邪行。
    （4）妄语业道：若为了诳惑以多取他财，或妙胜物而说妄语。若于委托信任自己的朋友，或父母、或师长，乃至于佛前而说妄语。或有妄语令他杀生，或有妄语令他损失财物，及与妻妾。或有妄语成办极重杀生，成办重不与取，重欲邪行。如是一切，皆由事重故，名重妄语。或有妄语，能破坏和合僧，于诸妄语，此最尤重。
    （5）离间语业道：若对于长时积习的亲爱有情而行破坏，或破坏他人令离别善友、父母、男女，破坏和合僧。若离间语能引起杀生、不与取、欲邪行。或有离间语成办极重杀生，成办重不与取，成办重欲邪行。如是一切，皆于事重故，名重离间语。
    （6）粗恶语业道：若于父母及余师长，发粗恶言，或以不实不真的妄语，如现前毁骂呵责他人为盗贼等，皆是由事故，名粗重恶语。
    （7）绮语业道：绮语有两类：一是属于妄语、离间语、粗恶语所摄的绮语，此等绮语，随妄语等三种的轻重而名轻重。故《瑜伽师地论》第六十卷说：‘凡诸绮语随妄语等，此语轻重，如彼应知。’二是能引发无义利的绮语，若依斗讼诤竞等事而发绮语。若以染污心于能引无义外道典籍，及于彼典籍承受、读诵、赞咏，广为他说，皆是由其事故，名重绮语。若于父母、眷属、师长调弄轻笑，现作语言，不近道理，亦由事重，名重绮语。
    （8）贪欲业道：若于僧伽佛塔所有财物，起贪欲心。若于自己功德起增上慢，而自谓是智者，乃至于国王、大臣、豪贵、师长及诸聪睿同梵等，起增上欲，贪求利养，皆是由其事故，名重贪欲。
    （9）嗔恚业道：若于父母、眷属、师长起损害心。于无过贫穷孤苦可哀愍者，起损害心。于至诚心来归投于己者，及于有恩者，起损害心。皆是由其事故，名重嗔恚。
    （10）邪见业道：若此邪见能引发诽谤一切事的邪见，名极重邪见。又诽谤无世间真阿罗汉、无圣果、无圣行、无因果等，皆是由其事故，名重邪见。
    除如上所说五因缘相，随其所应，与彼相违的十种恶业，皆为轻业。
    丁、十不善业果报
    果相差别，总有五种：（1）异熟果，即依有漏的善不善业，所招感的自相续的异熟无记法。因是善恶，果是无记，异性而熟故名异熟。（2）等流果，即三性色心等法，由亲因缘所生起的，是名等流果。等是同义，流是类义，果因同类，故名等流。即种子生现行，与现行熏种子，及种子生种子，皆由亲因缘所生，是真等流果。或似先业，后果随转，亦是等流果，如由杀生得短命报，果报与因行有相似义，由令他有情短命，以致自命亦短，短命相似，故得名等流果。但此生得短命报，实是增上果，取其生命的短长分限相似，假立等流果名。（3）离系果，即依无漏道断障的善无为法，永离系缚，故名离系果。（4）士用果，士是士天，即有情的异名，由诸有情，借诸工具所成办的事业，如工业品和农作物等都是士夫力用所成办的，故名士用果。（5）增上果，即除前四果外，余所得果，皆名增上果。此体甚宽，通有漏无漏等，这五果名义，广如《成唯识论述记》四十六卷所说应知。
    十不善业的果报，在五种果中，无离系果，唯有余四。于余四中，唯说三种果报：一异熟果，二等流果，三增上果。为什么不说士用果呢？因为离开异熟等三果之外，无别增相故。
    （1）异熟果：在《瑜伽师地论本地分》第八卷，及《对法论》都说，于三恶趣中，随下中上品，受傍生、饿鬼、地狱异熟。《华严经十地品》则说下品是饿鬼因。
    （2）等流果：即造十不善业者，受异熟果已，由三恶趣中来生人同分中，余业未尽，每一恶业，复受两种果报。
    如《大方广佛华严经十地品》第三十五卷说：‘于中杀生之罪，能令众生堕于地狱、畜生、饿鬼。
    若生人中，得二种果报，一者短命，二者多病。偷盗之罪，亦令众生，堕三恶道。
    若生人中，得二种果报，一者贫穷，二者共财不得自在。邪淫之罪，亦令众生，堕三恶道。
    若生人中，得二种果报，一者妻不贞良，二者得不随意眷属。妄语之罪亦令众生，堕三恶道。
    若生人中，得二种果报，一者多被诽谤，二者为他所诳。两舌之罪，亦令众生，堕三恶道。
    若生人中，得二种果报，一者眷属乖离，二者亲族弊恶。恶口之罪，亦令众生，堕三恶道。
    若生人中，得二种果报，一者常闻恶声，二者言多诤讼。绮语之罪，亦令众生，堕三恶道。
    若生人中，得二种果报，一者言无人受，二者语不明了。贪欲之罪，亦令众生，堕三恶道。
    若生人中，得二种果报，一者心不知足，二者多欲无厌。嗔恚之罪，亦令众生，堕三恶道。
    若生人中，得二种果报，一者常被他人求其长短，二者恒被于他之所恼害。邪见之罪，亦令众生，堕三恶道。若生人中，得二种果报，一者生邪见家，二者其心谄曲。’
    （3）增上果：1.由杀生业增上力故，于外所得器世界不美好庄严，饮食、果实、药物等皆少光泽，本质势力和成熟量皆微劣不佳，吃了不易消化，或生长疾病。由此因缘，无量有情未尽寿量，非时中夭而死。2.由偷盗业增上力故，众果鲜少，果不滋长、果多朽坏、果不贞实，多无雨泽，诸果干枯，或全无果。3.由邪淫业增上力故，所得的住处环境，多诸便秽，泥粪不净，臭处迫窄，多生不净的臭恶之物，凡诸所有，皆不可乐。4.由妄语业增上力故，在陆地做农作物等，在水道中经营舟船事业等，皆不能得丰盛的收获和利息，事多艰辛，人事亦不和合，多诸怖畏恐惧等因缘。5.由离间语业增上力故，依住的器世界处，丘坑间隔，险阻难行，多诸怖畏恐惧因缘。6.由粗恶语业增上力故，所依器世界住处，多诸株杌，荆棘毒刺，瓦石沙砾，枯槁无润，无有池沼，河泉干竭，土田碱卤，丘陵坑险，多诸怖畏恐惧因缘。7.由绮语业增上力故，所有果树不结果实，非时结实，时不结实，或虽结实生而似熟，根不坚牢，势不久伫，园林池沼，多不可乐。多诸怖畏恐惧因缘。8.由贪欲业增上力故，世间所有的盛事，经历每月日时，渐渐衰微，唯减不增。9.由嗔恚业增上力故，多诸疫疠，灾横扰恼，怨敌惊怖，狮子虎狼，杂恶禽兽，蟒蛇蝮蝎，蚰蜒百足，魍魉药叉，诸恶贼等。10.由邪见业增上力故，世间所有的第一胜妙花果悉皆隐没，诸不净物乍似清净，诸苦恼物乍似安乐，非安居所，非救护所，非归依所。此等增上果义，皆依《瑜伽师地论》第六十卷而说。


(四)十善业道决择

    （四）十善业道决择
    甲、十善业道五相
    十善业道，即离杀生乃至离邪见。十种善法业道，如《瑜伽师地论本地分》第八卷说：‘云何离杀生：谓于杀生，超过患欲解，起胜善心，若于彼起静息方便，及于彼静息究竟中所有身业，如离杀生，如是离不与取，乃至离邪见，当知亦尔。’了知杀生等业的过患，是名起过患欲解。远离杀生等心，与无贪无嗔无痴相应而起，是名起胜善心。受戒律，永远止息杀生等加行，名起静息方便。究竟远离杀生等事，是名于彼究竟静息。这也就是说，离杀生等十种善业，亦由五相差别建立，如远离杀生业道事，即他有情，于杀生业起过患想，及远离欲，是为意乐。于杀生业起静息方便，即是加行。正静息杀生的圆满身业，是为究竟。
    如远离杀生有五相差别建立，于偷盗乃至邪见九种，准例应知。
    乙、护持十善业道的范例
    初学佛的人，于十善业道，不知如何护持，这里钞录《华严经十地品》第三十五卷，说菩萨护持十善业道的用心，作为学习的范例。
    经说：‘佛子！菩萨住离垢地，性自远离一切杀生：不蓄刀杖，不怀怨恨，有惭有愧，仁怨具足，于一切众生，有命之者，常生利益慈念之心。是菩萨，尚不恶心恼诸众生，何况于他起众生想，故以重意而行杀害。性不偷盗：菩萨于自资财，常知止足，于他慈恕，不欲侵损，若物属他，起他物想，终不于此，而生盗心。乃至草木，不与不取，何况其余资生之具。性不邪淫：菩萨于自妻知足，不求他妻，于他妻妾，他所护女，亲族媒定，及为法所护，尚不生于贪染之心，何况从事，况于非道。性不妄语：菩萨常作实语、真语、时语，乃至梦中亦不思作覆藏之语，无心欲作，何况故犯。性不两舌：菩萨于诸众生，无离间心，无恼害心，不将此语，为破彼故，而向此说，未破者不令破，已破者不增长。不喜离间，不乐离间，不作离间语，不说离间语，若实若不实。性不恶口：所谓毒害语、粗犷语、苦他语、令人嗔恨语、现前语、不现前语、鄙恶语、庸贱语、不可乐闻语、闻者不悦语、嗔忿语、如火烧心语、怨结语、热恼语、不可爱语、不可乐语、能坏自身他身语，如是等语，皆悉舍离。常作润泽语、柔软语、悦意语、可乐闻语、闻者喜悦语、善入人心语、风雅典则语、多人爱乐语、多人悦乐语、身心踊悦语。性不绮语：菩萨常乐思审语、时语实语、义语法语、顺道理语、巧调伏语、随时筹量决定语。是菩萨，乃至戏笑，常恒思审，何况故出散乱之言。性不贪欲：菩萨于他财物，他所资用，不生贪心，不愿不求，性离嗔恚。菩萨于一切众生，恒起慈心、利益心、哀愍心、欢喜心、和润心、摄受心，永舍嗔恨，怨害热恼，常思顺行，仁慈祐益。又离邪见：菩萨住于正道，不行占卜，不取恶戒，心见正直，无诳无陷，于佛法僧，起决定信。佛子！菩萨摩诃萨，如是护持十善业道，常无间断。’
    丙、异熟等果报
    十善业道的果报，亦有三种差别，如《杂集论决择谛品》说：‘又十善业道异熟果者，谓于天趣中，受人天异熟、等流果者，谓即于彼处，各随其相，感得自身众具兴盛。增上果者，谓即于彼处，各随其相，感得处事兴盛。如不善业道建立异熟果等三种差别，如是有漏善业道，于人天中，三果差别，如其所应，亦当建立。’异熟果报，《瑜伽师地论》第八卷说，由下品善业，生于人中。由中品善业，生欲界天中。由上品善业（兼修禅定业），生色无色二界。其等流果及增上果，即翻十恶业报差别随相建立，如离杀生等流果，即得长寿无病。增上果，即一切外物悉多光泽，长时坚住等。
    丁、成就殊胜功德
    修习十善业道，由各别远离杀生等业，亦各别成就殊胜功德法。
    如《十善业道经》说：‘龙王（娑竭龙王）！若离杀生，即得成就十离恼法。何等为十？一于诸众生，普施无畏。二常于众生，起大慈心。三永断一切嗔恚习气。四身常无病。五寿命长远。六恒为非人之所守护。七常无恶梦，寝觉快乐。八灭除怨结，众怨自解。九无恶道报。十命终生天。是为十。若能回向阿耨多罗三藐三菩提者，后成佛时，得佛随心自在寿命。复次龙王！若离偷盗，即得十种可保信法。何等为十？一资财盈积，王贼水火，及非爱子，不能散灭。二多人爱念。三人不欺侮。四十方赞美。五不忧损害。六善名流布。七处众无畏。八财命色力安乐，辩才具足无缺。九常怀施意。十命终生天。是为十。若能回向阿耨多罗三藐三菩提者，后成佛时，得证清净大菩提智。复次龙王！若离邪行，即得四种智人所赞法。何等为四？一诸根调顺。二永离諠掉。三世所称叹。四妻莫能侵。是为四。若能回向阿耨多罗三藐三菩提者，后成佛时，得丈夫隐密藏相。复次龙王！若离妄语，即得八种人天所赞法。何等为八？一口常清净，优钵花香。二为诸世间之所信服。三发言成证，人天爱敬。四常以爱语，安慰众生。五得胜意乐，三业清净。六言无误失，心常欢喜。七发言尊重，人天奉行。八智慧殊胜，无能制伏。是为八。若能回向阿耨多罗三藐三菩提者，后成佛时，即得如来真实语。复次龙王！若离两舌，即得五种不可坏法。何等为五？一得不坏身，无能害故。二得不坏眷属，无能破故。三得不坏信，顺本业故。四得不坏法行，所修坚固故。五得不坏善知识，不诳惑故。是为五。若能回向阿耨多罗三藐三菩提者，后成佛时，得正眷属，诸魔外道不能阻坏。复次龙王！若离恶　，即得成就八种净业。何等为八？一言不乖度。二言皆利益。三言必契理。四言词美妙。五言可承领。六言则信用。七言无可讥。八言尽爱乐。是为八。若能回向阿耨多罗三藐三菩提者，后成佛时，具足如来梵音声相。复次龙王！若离绮语，即得成就三种决定。何等为三？一定为智人所爱。二定能以智如实答问。三定于人天威德最胜，无有虚妄。是为三。若能迥向阿耨多罗三藐三菩提者，后成佛时，得如来诸所授记，皆不唐捐。复次龙王！若离贪欲，即得成就五种自在。何等为五？一三业自在，诸根具足故。二财物自在，一切怨贼不能夺故。三福德自在，随心所欲物皆备故。四王位自在，珍奇妙物皆奉献故。五所获之物，过本所求百倍殊胜，由于昔时，不悭吝故。是为五。若能回向阿耨多罗三藐三菩提者，后成佛时，三界特尊，皆共敬养。复次龙王！若离嗔恚，即得八种喜悦心法。何等为八？一无损恼心。二无嗔恚心。三无诤讼心。四柔和质直心。五得圣者慈心。六常作利益安众生心。七身相端严，众共尊敬。八以和忍故，速生梵世。是为八。若能迥向阿耨多罗三藐三菩提者，后成佛时，得佛无碍心，观者无厌。复次龙王！若离邪见，即得成就十功德法。何得为十？一得真善意乐，真善等侣。二深信因果，宁殒身命，终不作恶。三惟皈依佛，非余天等。四直心正见，永离一切吉凶疑网。五常生人天，不更恶道。六无量福慧，转转增胜。七永离邪道，行于圣道。八不起身见，舍诸恶业。九住无碍见。十不堕诸难。是为十。若能回向阿耨多罗三藐三菩提者，后成佛时，速证一切佛法，成就自在神通。’
    戊、成就五乘的共法
    《十善业道经》说：‘人天身、声闻菩提、独觉菩提、无上菩提皆以十善业道为根本而得成就。’成就人天身的意义如上已说，这里，钞录宣说三乘菩提皆依十善业道成就的经文如下：
    ‘尔时世尊复告龙王言：若有菩萨依此善业，于修道时能离杀害而行施故，常富财宝，无能侵夺，长寿无夭，不为一切怨贼损害。离不与取而行施故，常富财宝，无能侵夺，最胜无比，悉能备集诸佛法藏。离非行而行施故，常富财宝，无能侵夺，其家贞顺，母及妻子，无有能以欲心视者。离虚妄语而行施故，常富财宝，无能侵夺，离众毁谤，摄持正法，如其誓愿，所作必果。离离间语而行施故，常富财宝，无能侵夺，眷属和睦，同一志乐，恒无乖诤。离粗恶语而行施故，常富财宝，无能侵夺，一切众会欢喜归依，言皆信受，无违拒者。离无义语而行施故，常富财宝，无能侵夺，言不虚设，人皆敬爱，能善方便断诸疑惑。离贪求心而行施故，常富财宝，无能侵夺，一切所有，悉以惠舍，信解坚固，具大威力。离念怒心而行施故，常富财宝，无能侵夺，速自成就无碍心智，诸根严好，见皆敬爱。离邪倒心而行施故，常富财宝，无能侵夺，恒生正见敬信之家，见佛闻法，供养众僧，常不忘失大菩提法。是为大士修菩萨道时，行十善业，以施庄严，所获大利。如是龙王：举要言之，行十善道，以戒庄严故，能生一切佛法义利，满足大愿。忍庄严故，得佛圆音，具众相好。精进庄严故，能破魔怨，入佛法藏。定庄严故，能生念慧，惭愧轻安。慧庄严故，能断一切分别妄见。’
    以上经文，是说菩萨六度，依十善法而得成就。由持戒等五度庄严而修行十善业，亦各有不杀果报，长寿无夭，不为一切怨贼损害，乃至不邪见果报，恒生正见，见闻佛法等，因于布施度中已详细分别，故于余五度略说，举要言之。
    又说：‘慈庄严故，于诸众生，不起恼害。悲庄严故，愍诸众生，常不厌舍。喜庄严故，见修善者，心无嫌嫉。舍庄严故，于违顺境，无爱恚心。’这是说菩萨的四无量心，依十善法成就。
    又说：‘四摄庄严故，常勤摄化一切众生。’这是说菩萨的四摄法，依十善业道成就。
    又说：‘念摄庄严故，善能修习四念处观。正勤庄严故，悉能断除一切不善法，成就一切善法。神足庄严故，恒令身心轻安快乐。五根庄严故，深信坚固，精修匪懈，常无迷妄，寂然调顺断诸烦恼。力庄严故，众惑灭尽，无能坏者。觉支庄严故，常善觉悟一切诸法。正道庄严故，得正智慧，常现在前。’以上经文是说，声闻人所修的四念处、四正勤、四神足、五根、五力、七觉支、八正道、三十七道品，依十善业道成就。
    又说：‘止庄严故，悉能涤除一切结使。观庄严故，能如实知诸法自性。方便庄严故，速得成满为无为乐。’以上是三乘共修的止观，方便三法，依十善业道成就。
    又说：‘龙王当知：此十善业，乃至能令十力、无畏、十八不共，一切佛法，皆得圆满。是故汝等，应当修学。’这是说一切佛法，皆依善业道成就。
    《华严经十地品》第三十五卷，也说十善业道是人天、声闻、独觉、菩萨及一切佛法成就的净因，知彼经说：‘十善业道，是人天乃至有顶处受生因。又此上品十善业道，以智慧修习，心狭劣故，怖三界故，阙大悲故，从他闻声而了解故，成声闻乘。又此上品十善业道，修治清净，不从他教，自觉悟故，大悲方便不具足故，悟解甚深因缘法故，成独觉乘。又此上品十善业道修治清净，心广无量故，具足悲愍故，方便所摄故，发生大愿故，不舍众生故，希求诸佛大智故，净治菩萨诸地故，净修一切诸度故，成菩萨广大行。又此上上十善业道，一切种清净故，乃至证十力四无畏故，一切佛法皆得成就。是故我今，等行十善，应令一切具足清净，如是方便，菩萨当学。’
    己、成就严净佛土之因
    修十善业道，又是严净佛土的根本。如《大般涅槃经．光明遍照高贵德王菩萨品》卷第二十二说：‘云何名为净佛国土？菩萨摩诃萨，修大涅槃微妙经典，为阿耨多罗三藐三菩提，度众生故，离杀害心，以此善根，愿与一切众生共之，愿诸众生得寿命长，有大势力，获大神通。以是誓愿因缘力故，于未来世成佛之时，国土所有一切众生，得寿命长，有大势力，获大神通。复次善男子！菩萨摩诃萨，修大涅槃微妙经典，为阿耨多罗三藐三菩提，度众生故，离偷盗心，以此善根，愿与一切众生共之，愿诸佛国土所有，纯是七宝，众生富足，所欲自恣。以此誓愿因缘力故，于未来世成佛之时，所得国土，纯是七宝，众生富足，所欲自恣。复次善男子：菩萨摩诃萨，修大涅槃微妙经典，为阿耨多罗三藐三菩提，度众生故，离淫欲心，以此善根，愿与一切众生共之，愿诸佛土所有众生，无有贪欲、嗔恚、痴心、亦无饥渴、苦恼之患。以是誓愿因缘力故，于未来世成佛之时，国土众生，远离贪淫、嗔恚、痴心，一切无有饥渴苦恼。复次善男子！菩萨摩诃萨，修大涅槃微妙经典，为阿耨多罗三藐三菩提，度众生故，离妄语心，以此善根，愿与一切众生共之，愿诸佛土，常有茂林花果香树，所有众生，得妙音声。以是誓愿因缘力故，于未来世成佛之时，所有国土，常有茂林花果香树，其中众生，悉得清净上妙音声。复次善男子！菩萨摩诃萨，修大涅槃微妙经典，为阿耨多罗三藐三菩提，度众生故，远离两舌，以此善根，愿与一切众生共之，愿诸佛土，所有众生，常共和合，讲说正法。以是誓愿因缘力故，于未来世成佛之时，国土所有一切众生，悉共和合，讲论法要。复次善男子！菩萨摩诃萨，修大涅槃微妙经典，为阿耨多罗三藐三菩提，度众生故，远离恶口，以此善根，愿与一切众生共之，愿诸佛土，地平如掌，无有石沙荆棘，所有众生其心平等。以是誓愿因缘力故，于未来世成佛之时，所得国土，地平如掌，无有石沙荆棘恶刺，所有众生其心平等。复次善男子！菩萨摩诃萨，修大涅槃微妙经典，为阿耨多罗三藐三菩提，度众生故，离无义语，以此善根，愿与一切众生共之，愿诸佛土，所有众生，无有苦恼，以是誓愿因缘力故，于未来世成佛之时，国土所有一切众生，无有苦恼。复次善男子菩萨摩诃萨，修大涅槃微妙经典，为阿耨多罗三藐三菩提，度众生故，远离贪嫉，以此善根，愿与一切众生共之，愿诸佛土，一切众生，无有贪嫉、恼害、邪见。以此誓愿因缘力故，于未来世成佛之时，国土所有一切众生，悉无贪嫉、恼害、邪见。复次善男子！菩萨摩诃萨，修大涅槃微妙经典，为阿耨多罗三藐三菩提，度众生故，远离恼害，以此善根，愿与一切众生共之，愿诸佛土所有众生，悉共修习大慈大悲，得一子地。以是誓愿因缘力故，于未来世成佛之时，世界所有一切众生，悉共修习大慈大悲，得一子地。复次善男子！菩萨摩诃萨，修大涅槃微妙经典，为阿耨多罗三藐三菩提，度众生故，远离邪见，以此善根，愿与一切众生共之，愿诸佛土，所有众生，悉得摩诃般若波罗密。以是誓愿因缘力故，于未来世成佛之时，世界众生，悉得受持摩诃般若波罗密，是名菩萨修净佛土。’
    总上所说，可知十善业道，是世出世善法的根本，一切有漏无漏的功德，皆依十善而生、而长、而住、而成就。如《十善业道经》最后说：‘龙王！譬如一切城邑聚落，皆依大地而得安住，一切药草卉木丛林，亦皆依地而得生长。此十善业道，亦复如是。一切人天，依之而立。一切声闻、独觉菩提，诸菩萨行一切佛法，咸共依十善大地而得成就。’诸佛弟子，欲成就一切功德善法，于十善业得勤修学，爱乐安住，自住其中，亦劝他人，令住其中。


(五)一多果业的差别

    （五）一多果业的差别
    总上所说善不善业，于善恶趣中，应生异熟果的时候，有两种差别：一是招引业，即牵引生死的主力业，由此业力，能牵引总报异熟果，令有情于各趣中得到色心相续。二是圆满业，即圆满别报的业，由此业力，能成满寿夭智愚，色形好丑等，令有情领受爱非爱果。引业牵生死，又有一业牵引一生，一业牵引多生，多业牵引一生，多业牵引多生的差别。如《杂集论决择谛品》说：‘复次：或有业，由一业力牵得一身；谓由一业力，长养一生异熟种子故。或有业，由一业力牵得多身；谓由一业力，长养多生异熟种子故。或有业，由多业力牵得一身；谓由多业刹那数数长养一生异熟种重子故。或有业，由多业力牵得多身；谓多刹那业，更相资待，辗转长养多生异熟种子故。问：若一有情成就多业，云何次第受异熟果耶？答：彼于身中，重者先熟。或将死时现在前者，或先所数习者，或最初所引者，被异熟先熟。’《瑜伽师地论》第六十卷，并以一缕系花，流水经步，酢滴酢水三种譬喻说明此义，应检阅参考。


第二节 果

    第二节 果
    前面所说的皈依三宝、受持五戒、修行十善，就能得到人天善趣的异熟果报身，并得殊胜的等流果，和殊胜的增上果，及成就殊胜的功德法，与圆满未来世成佛的净土庄严，都是或顺现受、或顺生受、或顺后受的殊胜果法。现前将来，必能获得，不是这里所再要说的。这里所说的果法，是由皈依三宝、受持五戒、修行十善，而为求解脱行，修菩萨法，所必须获得暇满的人身。因为修学佛法最须要的条件，就是暇满的人身。暇满人身，必须由皈依三宝，受持五戒、修行十善，才能获得。所以为了获得暇满人身，能够顺利的修学佛法，就必须从皈依三宝、受持五戒、修行十善作起。
    也就是说，学佛人之所以皈依三宝、受持五戒、修行十善，仰止虽在佛陀，但基本目的即为获得暇满人身。暇是闲暇，指远离修学佛法之障难的八种无暇。满是圆满，指得人身，诸根具足，生在中国等十种圆满。生在人趣中，远离八种无暇，具足十种圆满，就是暇满人身，也就是能够顺利修学佛法的殊胜果报之身。
    八无暇是：一地狱、二饿鬼、三畜生、四诸根不具、五邪执倒见、六佛前佛后、七边地、八长寿天。地狱、饿鬼、畜生，是三恶趣，因为报障和苦缘逼迫的关系，很难遇着佛法和发心修行。生在人趣中，倘若诸根不具足，如本性痴呆，生来的盲聋喑哑等，也不能够听闻佛法，依理修行，或者诸根虽然不缺，但是内心里存在着邪执倒见，不相信因果！三宝、四谛等，也不能够听闻佛法，依理修行。纵然前面的五种障难都没有，但生在人趣的时候，是佛未降生以前，或佛入灭以后（包括佛法已灭），也没有见佛闻法修行的机会。又前面的六种障难都没有，虽然生在有佛法的时候，但自己生在没有四种佛弟子游行化度的边地处所，也没有见佛闻法修行的因缘。长寿天，是说的无想天，在第四静虑的广果天中，寿长五百大劫。在这长远的岁月里，都在无想的异熟报中，人间有佛出世，他也不会知道，所以长寿天也是见佛闻法修行的障难处。一个有情，倘若遭遇到上说八种障难中的任何一种，就没有闲暇修学佛法，在学佛方面来说，也就叫落于八无暇中。远离了上说八种障难，就是闲暇的人身。
    十圆满，是说一个有情远离了八无暇，在修学佛法的因缘上还具有十种优胜的条件。有能够修学佛法的圆满相，故名圆满。依内有五种，依外有五种，即自圆满与他圆满，总合为十种圆满。依《瑜伽师地论》第二十卷《修所成地》所说分述如下：
    依内五种：
    一、众同分圆满：即生在人中，得人趣众同分的丈夫身，或得女人身，如是名为众同分圆满。《声闻地》名善得人身。
    二、处所圆满：如一有情，生在人趣中，又处在中国，不生边地。中国，是指有比丘、比丘尼、近士男、近士女四众佛弟子游行处所。边地，是指没有四众佛弟子游行的处所。因为有四众佛弟子游行的处所，也就决定有佛法。这是学习佛法的增上缘，生在这样的地方，即得到了处所圆满。《声闻地》名生于圣处。
    三、依止圆满：依止就是所依根身，如一有情，生处中国，诸根具足，不缺眼耳随一支分，能见闻佛法，性不愚钝，亦不顽呆，又不喑哑，堪能了解善说恶说所有法义，能于善品精勤修集，如是名为依止圆满。《声闻地》名诸根无缺。
    四、无业障圆满：如一有情，依上圆满，而能远离五无间业，即于害父、害母、害阿罗汉、破和合僧，于如来所恶心出血，不自作、不教他作，是为无业障圆满。若于五无间业有随一所作，即于现生中必非证得贤圣的法器，于现法中障碍转得般涅槃，障碍生起圣道故。《声闻地》说名离诸业障。
    五、无信解障圆满：如一有情，必不成就五无间业，不于恶处而生信解。不于种种邪天，及于种种外道，诸恶处所，发清净心。由彼有情前生中，于佛圣教善说法处，修习净信，长时相续，由此因缘，于今生中，唯于圣处，发生信解，起清净心。这就是无邪见倒执，故于圣教善说，能除一切所有烦恼垢秽的清净法，发生清净信胜解，是为无信解障圆满。《声闻地》说名胜处净信。
    以上五种圆满，是有情自内所摄的修学佛法的殊胜增上缘，故是依内五种圆满。《声闻地》说名自圆满。
    依外五种：
    一、大师圆满：即彼有情，具内五种生圆满已，复得值遇大师出世。即有一普于一切诸有情类，起善利益增上意乐，修习千万难行的苦行。经三大阿僧祇劫，积集广大福德智慧二种资粮，获得一切智，于一切境界得无障碍，现证无上正等觉者，是为大师出世。值遇这样的大师，是为大师圆满。《声闻地》说名诸佛出世。
    二、世俗正法施设圆满：即彼有情，值佛出世，佛又广开示善不善法，有罪无罪，乃至宣说四圣谛教，诸缘起法等无量法教，及广分别：契经、应颂、记别、讽诵、自说、缘起、譬喻、本事、本生、方广、希法，及与论议。诸佛世尊及圣弟子，一切正士皆乘此法而得出离，故是正法。如来为他宣说，依世俗语言文字施设安立此正法教，故名世俗正法施设圆满。《声闻地》名说正法教。
    三、胜义正法随转圆满：即大师如其所证善为开示世俗正法已，诸弟子众依此正法，复为他随转随顺教授教诫，由是他人能证得沙门果，及诸功德，由所证法理是离文字语言相的胜义正法，故名胜义正法随转圆满。《声闻地》说名法住随转。
    四、正行不灭圆满：即如来虽然已般涅槃，但世俗正法还住在世间未灭，胜义正法也还没有断绝，就是文字教法还存在，依著文字教法所说的道理而修行证果的人也还有，即是正行不灭圆满。《声闻地》说名法教久住。
    五、随顺资粮圆满：衣服、饮食、卧具、医药四种，是随顺修行办道的资粮，必须具备才能无挂碍地修行用功。于此四事，有正信居士布施供给，或自备无缺，是名随顺资粮圆满。《声闻地》说名他所哀愍。
    以上五种圆满，是属于修学佛法的外法殊胜增上缘，故名依外五种圆满。《声闻地》说名他圆满。这后五种圆满，我们现在除了大师圆满不具之外，其余圆满还有相似的形相存在，也算是很幸连的了！
    人身是最可宝贵的，最初发心学佛，与初证圣果，都以人身为最殊胜。如《显扬圣教论》卷十六颂说：‘极戚非恶趣，极欣非上二；处欲界人天，佛出世、现观。’这是说最初生起现观，和佛陀出现世间，在三界中唯以欲界为依处。即唯欲界人天二趣有佛出世，能起现观证得圣果。但欲天多放逸，不如人趣殊胜，故释迦世尊亦于人间示现成佛。我们为了生生世世都能够随遇佛法，修学佛法，就必须发起坚固的誓愿，直至菩提永远皈依三宝，受持五戒，修行十善，才能不失暇满人身，以致达到究竟成佛。


一、出离心

    第三章 声闻行果
    第一节 行
    一、出离心
    第二章中说皈依三宝，受持五戒，修行十善，可以保证未来世得到殊胜的人天善趣身，在六道轮回中来说，是很好的善报。但是，仍然没有超出三界，还是在生死中流转，善报尽时，还不免轮入恶道，受三恶趣的苦报。即在人天善趣中，亦常为诸苦所逼迫，不是究竟安稳的乐处。如《法华经譬喻品》说：‘三界无安，犹如火宅，众苦充满，甚可怖畏，常有生老病死忧患，如是等火，炽然不息。’这就是说，只要是在三界中流转，不论是善趣恶趣，都有生老病死等苦恼逼迫，如处在火宅里一样地不安。因此，声闻种性的有情，视三界如牢狱，如火宅，怖畏生死轮迥，厌舍世间，观察诸行无常，有漏皆苦，诸法无我，涅槃寂静，四种法蕴的道理，而发起出离心，希求解脱，誓证清净寂灭的涅槃，得到究竟的安稳处。如《增一阿含经》第二十三《增上品》说：‘诸比丘！欲得免死者，当思惟四法本。云何为四？一切行无常，是谓初法本，当念修行。一切行苦，是谓第二法本，当共思惟。一切法无我，此第三法本，当共思惟。灭尽为涅槃，是谓第四法本，当共思惟。如是诸比丘！当共思惟此四法本。所以然者，便脱生老病死愁忧苦恼。此是苦之元本。是故诸比丘！当求方便，成此四法。如是诸比丘，当作是学。’
    声闻乘人，既然志在解脱生死，求证涅槃，所以厌舍三界，发出离心，是声闻行的根本心要。引发出离心的方便，最殊胜的有二种，分别略述如下：
    （一）思惟无常
    无常的意义，已在第一章第四节说苦谛四相中无常相时解说过，应检阅参考。这里所说的思惟无常，主要的是思惟死殁无常。由于思惟死殁无常，引发出离心则更为有力，这可从三方面来思惟：一、思惟人身决定有死，如《无常经》说：‘生者皆归死，容颜尽变衰，强力病所侵，无能免死者。假使妙高山，劫尽皆坏散；大海深无底，亦复皆枯竭；大地及日月，时至皆归尽；未曾有一事，不被无常吞。’《一切有部毗奈耶》第六卷说：‘积聚皆消散，崇高必堕落，会合终别离，有命咸归死。’《出曜经无常品》卷第二说：‘今观此土境，及诸众果树，山河流泉源，江海逝不停，昔人瞻固守，今为斯何在？宁转尊法轮，示现天世人，不乐取命终，竟知趣何方？欲寻昔时人，如今不见一！’《法句譬喻经》卷第一说：‘所行非常，谓兴衰法：夫生辄死，此灭为乐。’《无常经》说：‘无上诸世尊，独觉声闻众，尚舍无常身，何况于凡夫‘父母及妻子，兄弟并眷属，目睹生死隔，云何不愁叹！是故劝诸人，谛听真实法，共舍无常处，当行不死门。佛法如甘露，除热得清凉，一心善谛听，能灭诸烦恼。’二、思惟死无定期，如《出曜经》卷第一说：‘晨所睹见，夜则不现；昨所胆者，今夕则无；我今少壮，无可怙恃，少者亦死，男女无数。’又说：‘诸老少壮，及中间人，渐渐以次，如果持熟。’又说：‘或有在胎丧，已生在外殁，盛壮不免死，老耋甘心受；犹树生狂花，结实时希有，志故必欲舍，伺命召不忍。’卷第二又说：‘是日已过，命则随减；如少水鱼，斯有何乐？’《金色男子因缘经》卷第一说：‘若昼若夜中，或行或复住，如大河迅流，念念无停止。寝宿过是夜，寿命随减少，犹如少水鱼，斯有何其乐？’《摩诃摩耶经》卷上说：‘譬如旃陀罗，驱牛就屠所，步步近死地；人命疾于是。’《坐禅三昧经》卷上说：‘今日营此业，明日造彼事，乐者不观苦，不觉死贼悉。匆匆为己务，他事亦不闲，死贼不待时，至则无脱缘。’三、思惟死时无可怙恃，如《尸迦罗越大方礼经》说：‘无亲可怙恃，无处可隐藏；天福尚有尽，人命岂长久。’《出曜经无常品》第二卷说：‘非有子恃，亦非父兄，为死所迫，无亲可怙。千百非一，族姓男女，贮聚财产，无不衰丧。’这些经文是说，无论父母兄弟，亲戚眷属，财产高位等，皆不能抵挡死殁无常。到死的时候，一切皆必舍离而去。不但亲属财产等不能致其不死，即神通妙术亦不能避免死亡。佛在世时，王舍城有梵志兄弟四人，各得五通，自知七日后皆当命尽，欲避死亡，商议各以神通力分别藏住于虚空、大海、大山、大石中，既至七日期满，各从其处而皆命终。故《出曜经》中《无常品》说：‘非空非海中，非入山石间，无有地方所，脱止不受死。’又第三卷说：‘无常势力，不可恃怙，知死命终，然不久住，一切皆尽，无觉知者，为世所毁，流转诸趣。’从以上诸无常偈义，多加思惟，则能引发出离三界的解脱心。
    （二）思惟诸苦
    在思惟诸苦中，特别是思惟生老等八苦，最能引发出离心。生等八苦，在《瑜伽师地论．摄决择分》第六十一卷中，各说五相，修解脱行的人，应如理思惟。
    （1）生苦五相：1.众苦所随故苦，即有情生于地狱趣，及一向受苦的饿鬼趣中，并诸胎生和卵生有情生时，为种种逼迫忧苦之所随逐故。2.粗重所随故苦。由三界诸行，为烦恼品粗重所随逐；由此随逐，三界有情诸蕴生起，性不调柔，不自在转，故名粗重所随故苦。3.众苦所依故苦。即生为众苦的所依，由有生故，衰老病痛等众苦差别依之而起。4.烦恼所依故苦，有情既受生已，于可爱境生爱，于憎恨境起嗔，于中庸境起痴；由是因缘，身心昏荡，不能寂静安隐而住，生起种种烦恼，是名烦恼所依故苦。5.不随所欲，离别法故苦。即诸有情，生者皆死，所有寿命，死为边际，死为终极，如是死事，非诸有情所爱，然死苦必受，是为不随所欲，离别法故说生为苦。
    （2）老苦五相：即诸有情，由五处衰退故苦：1.盛色衰退故。即肤黑发白，皱纹充满等，诸非可爱的衰老色现。2.气力衰退故。于诸事业，无操作能力，及容易染患疾病等。3.诸根衰退故。即眼昧耳聋，身体尪羸等。4.受用境界衰退故。即于可食可用的境物，由力能衰朽，或由于不利于衰老的人，不能受用。5.寿量衰退故。时分已过，寿量唯减，命将终极。
    （3）病苦五相：1.身性变坏故。由四大乖违，肿胀羸劣，壮热煎寒，疼痛僵硬，麻痹瘫痪等。2.忧苦增多，由于病苦缠身故。于身逼迫，引起内心无限忧苦，与时日俱增地住于痛苦中，悲愁地度过日夜。3.于可意境不喜受用故。人在害了病的时候，平时心意中喜爱好乐的饮食等境界，由病苦逼迫，不再喜爱受用：或由于有增加病苦的危险而不能受用。这就是受用不自在苦。4.于不可意境，非其所欲，强受用故。由于有病，于不可爱乐的药物、针灸、刀割等境，虽非所欲，为了治病，也得勉强受用，引生领纳苦境之苦。5.能令命根离坏故。由于见到自己病重难治的时候，多知自己命根将很快地舍离根身而断坏，趣于死亡，引起悲哀痛苦。
    （4）死苦五相：1.离别所爱盛财宝故。由于死时舍离自己一生辛勤劳苦营谋追求积聚守护的丰盛财产宝物，心生痛苦。2.离别所爱盛朋友故。许多知交善友，一生得其协助，成就了自己的知识事业等，情长谊深，死则永舍悲痛。3.离别所爱盛眷属故。至亲至爱的父母妻子儿女等，团聚欢乐，在生不愿暂时有别，死则永远舍离，痛切心腑。（注）5.于命终时备受种种极重忧苦故。死时四大分离，众苦交加，故其忧悲痛苦，至极尤重。
    【注】原书漏列了第四相，今依《瑜伽师地论》补录：‘四、离别所爱盛自身故。’
    （5）怨僧会苦五相：1.与彼会生忧苦故。即与怨憎的人相会之时，心怀怨结，引生忧苦。2.治罚畏所依止故。倘若与已有怨恨的人有权有势，一朝会面，畏其假借权势治罚于己，于治罚生起怖畏故苦。或由自己对于怨家曾作不善恶行，畏其报复，受到治罚。所依，就是说怨憎的人会面是产生治罚畏的所依止缘。3.恶名畏所依止故。与怨憎人相会，恐其诽谤自己为作恶事的坏人，诬加种种恶名恶称，心生忧苦。或自己曾作恶事，为怨憎人所知，畏其揭露自己的丑恶名称，心生忧苦。4.苦逼迫命终怖畏所依止故。即由与怨憎人相会，怖畏其治罚等苦逼迫以致于命终，心生忧苦。5.越正法恶趣怖畏所依止故。与怨憎人相见，由怀怨结不舍，为了报复怨恨，造作种种恶行，违越了善恶因果律的正法，当堕恶趣，心生恐惧故苦。
    （6）爱别离苦五相：1.舍离亲爱人苦。2.由此舍离为因缘，引生语声忧愁叹息等苦。3.由此忧叹等为因缘，身受扰乱苦。4.念其恩德等思恋其人，引生心意热恼苦。5.由其人远离故，应当受用的快乐事，如聚首谈心，戏论欢娱等，皆有所缺乏故苦。
    （7）求不得苦五相：《瑜伽师地论》说，如爱别离苦，求不得苦，当知亦尔。即1.谋求不得苦，2.语生愁叹，3.身受扰乱，4.意生热恼，5.受用缺乏。
    （8）五取蕴苦五相：1.生苦器故，即五取蕴是受生的苦器。2.依生苦器故，即五取蕴为老病死等苦的生起之所依止器。3.苦苦器，4.坏苦器，即五取蕴是苦苦、坏苦的相重性之所随逐（依附）器，遇缘即能现起。5.行苦性，五取蕴体性刹那迁流不住，非安稳法，故是行苦性。
    这里抄录一段《法句譬喻经》第三《安宁品》的经文，助解五取蕴身为苦本的意义。经说：‘昔佛在舍卫国精舍，时有四比丘，坐于树下，共相问言：一切世间，何者最苦？一人言：天下之苦，无过淫欲。一人言：世间之苦，无过嗔恚。一人言：世间之苦，无过饥渴。一人言：天下之苦，无过惊怖。共诤苦义，云云不止。佛知其言，往到其所，问诸比丘，属论何事。即起作体，具白所论。佛言：比丘！汝等所论，不究苦义；天下之苦，莫过有身。饥渴寒热，嗔恚惊怖，色欲怨祸，皆由于身。夫身者，众苦之本，患祸之元；劳心极虑，忧畏万端：三界蠕动，更相残贼，吾我缚着，生死不息，皆由身兴；欲离世苦，当求寂灭。摄心、守正，泊然无想，可得泥洹，此为最乐。’
    其余诸苦的意义，应参看第一章第四节所说苦相差别。修解脱行的人，应如理思惟，引生出离心，趣求解脱道。


二、修集涅槃法缘

    二、修集涅槃法缘
    声闻乘人，目的在证得解脱生死的般涅槃法。但一个有情从发心到证得究竟般涅槃，极速也需要经过三生，至迟则须六十劫。经三生是：第一生最初趣入资粮道，第二生修加行道，第三生预入圣位，乃至证得解脱。总有七贤四圣五位的差别。立表如表一：

    （表一）
    在没有趣入顺解脱分以前，必须修习证得般涅槃法的增上缘，才能顺利地趣贤入圣。涅槃法缘，在《瑜伽师地论》第二十一卷中，总说二种：一是胜缘，二是劣缘。胜缘如论说：‘谓正法增上他音，及内如理作意。’就是由闻他宣说超胜四谛法的言音，引发自内如理所引作意，便能悟入真实现观。这种胜缘，非今日众生根器所具，可略不说。劣缘在论中说有如下十二种：一自圆满，二他圆满，三善法欲，四正出家，五戒律仪，六根律仪，七于食知量，八初夜后夜常勤修习觉寤瑜伽，九正知而住，十乐远离，十一清净诸盖，十二依三摩地。分别略释如下：
    （一）自圆满，即善得人身、生于圣处、诸根无缺、胜处净信、离诸业障五种圆满。
    （二）他圆满，即诸佛出世、说正法教、法教久住、法住随转、他所哀愍五种圆满。
    上两种圆满，已于第二章人天行果第二节中解说过，这里不再说了。乐广知者，可参考《瑜伽师地论》第二十卷和第二十一卷。
    （三）善法欲，即对于涅槃善法生起信解和希求证得的爱乐。如一个声闻种性的人，在佛陀跟前，或佛弟子跟前，听闻了正法教理，生起了清净的信心，希求能够如法修行，证得解脱：于是感觉在家庭中，对于妻室有淫欲相应贪着，对于子女亲属及诸财宝有受用相应的爱执，烦扰缠缚，不能闲静修行，证得解脱。为了有利于修行正法，决心舍家而出家，精进修行，断除烦恼，证得真实圆满的解脱。于如是事生起信解爱乐，就是善法欲。如《瑜伽师地论》二十一卷说：‘云何善法欲：谓如有一，或从佛所，或从弟子所，闻正法已，获得净信。得净信已，应如是学：在家烦扰，若居尘宇；出家闲旷，犹处虚空。是故我今应舍一切妻子眷属财谷珍宝，于善说法毗奈耶中，正舍家法，趣于非家。既出家已，勤修正行，令得圆满。于善法中，生如是欲，名善法欲。’调伏自己心中所有的烦恼，名修正行。证得真实圆满的解脱，名得圆满。
    （四）正出家，由前殊胜的善法欲为增上力量，体请大德为亲教师，经白四羯磨受具足戒，或沙弥戒，是名正出家。梵语羯磨，译言作业，或译办事，是僧众团体中作行事务的民主方式，有如现在的开会报告通过。白四羯磨是作行最重要事务所用的方式，即执事人先把所要作的事向集会的僧众们告白一遍，其次更三问其可否而决定其事，合一白三问，故名白四羯磨。亦即报告一遍，而三问通过决定的意思。
    （五）戒律仪，此有六种差别：（1）安住具戒，（2）善能防护别解脱律仪，（3）轨则圆满，（4）所行圆满，（5）于微小罪见大怖畏，（6）受学学处。
    （六）根律仪，此有四种差别：（1）防守正念，（2）常委正念，（3）念防护意，（4）行平等位。
    戒律仪与根律仪的意义，已在第二章第一节皈依三宝后的第二四正行中简略地讲过，这里不再说了。乐广知者，可参阅《瑜伽师地论》第二十二卷和二十三卷论文。
    （七）于食知量，《偷伽师地论》第二十一卷说：‘云何于食知量？谓彼如是守诸根已，以正思择，食于所食；不为倡荡，不为骄逸，不为饰好，不为端严，食于所食。然食所食，为身安住，为暂支持，为除饥渴，为摄梵行，为断故受，为令新受当不更生，为当存养力乐无罪安稳而住。如是名为于食知量。’正思择食，即于进食时，以正智慧观察段食的受用、变易、追求、防护等过患，深生厌恶，发出离想，然后吞咽。倡荡，就是与女人共为嬉戏、欢娱、受乐、倡掉、纵逸。不为倡荡食，即不为欲贪所引、淫逸所引，诸恶不善寻思而食所食。不为骄逸食，即不为无病、少壮、长寿等骄逸而食所食。不为饰好食，为不为沐浴、理发、妙香涂身等而食所食。不为端严食，即不为着种种上妙衣服、种种花鬘等庄严具庄饰其身而食所食。为身安住食，即受食时如是作念：‘我今受此所有饮食，寿命得存，当不夭殁；由是因缘，身得安住，能修正行。’为暂支持食，即远离有罪有染等追求饮食的方法，仅为暂时支持色身的安住，以正法追求饮食；既获得已，亦不染爱耽着而食其所食。为摄梵行食，即为令有力断除恶法，堪任修行善法，迅速获得三摩地，由是有力有能、得所未得、证所未证，如是名为摄受梵行而食所食。为断故受食，即由过去食不知量，食所非宜，及不易消化等食物，由此因缘，于其身中引起种种疾病苦受；为欲息除由食物引起的疾病苦受，随顺医师所说而食医药及相宜食物：由此能断除已生疾病，及其疾病所生苦受。如是名为断故受食。为令新受当不更生食，即由现在安乐无病，气力充足，食诸食时，不过量食，不食于己身所不相宜的食物，如是就不会由饮食更引起新的苦受，是名为令新受当不更生而受诸饮食。为当存养力乐无罪安隐而住食，即于适宜饮食知量食已，寿命得到生存长养，是名存养；消除饥瘦，气力充足，是名为力：断除苦受，新受不生，是名为乐；以正法追求饮食、不染不受等，是名无罪；受食以后，身无沉重，有所堪能，修善断恶，令心速得三摩地等，是名安隐而住。如上所说，由正思择食，不为倡荡食，乃至为当存养力乐无罪安隐而住，受诸饮食，是为于食知量。广如《瑜伽师地论》二十三卷所说应知。
    （八）初夜后夜常勤修习觉寤瑜伽，《瑜伽师地论》二十四卷说：‘复次，初夜后夜常勤修习觉寤瑜伽者，云何初夜？云何后夜？云何觉寤瑜伽？云何常勤修习觉寤瑜伽？言初夜者，谓夜四分中过初一分是夜初分。言后夜者，谓夜四分中过后一分是夜后分。觉寤瑜伽者，谓如说言：于昼日分经行宴坐，从顺障法净修其心；净修心已，出住处外，洗濯其足，还入住处，右筚而卧，重累其足，住光明想，正念正知思惟起想，巧便而卧。至后夜分，速疾觉寤经行宴坐，从顺障法净修其心。’寤是从睡眠中醒觉的意思，修习觉寤瑜伽，是说修行者在入睡前必修习警策醒寤的觉起想，才能及时醒觉而免于耽误用功。佛法中昼夜各立三时，印度古代世俗昼夜各立四分；此依世俗，以夜三时略分为四分，名夜四分。从日出时到日没时为昼日，余即夜时。夜四分中最初一分名夜初分，中间二分名夜中，最后一分名夜后分。论中义显从初向后齐至中间，故名过初一分。从后向初齐至中间，故名过后一分。所说住光明想、正念正知思惟起想等，显示由正念正知二缘，即得成就无染污心而近习睡眠：由正念故，于善所缘摄敛而卧；由正知故，于善所缘，若心退失，起诸烦恼，便能迅速的正确了知；由住光明想（《瑜伽论》十一卷说三种光明：一治暗光明，二法光明——如理思惟法义，三依身光明。）及思惟起想，即无深重的睡眠缠缚，由此二缘，便能及时觉寤，起不过时。宴坐即加趺坐。障碍法即五盖，顺障法即净妙相等。净妙相顺贪欲盖；嗔恚相顺嗔恚盖；黑暗相顺昏沉睡眠盖；亲属国土不死寻思，顺掉举盖；追忆昔时戏笑等，顺恶作盖：疑三世等，顺疑盖。于此等顺障法，在经行宴坐中修不净观等而对治诸盖，是为净修其心 。广如《瑜伽师地论》二十四卷所说应知。
    （九）正知而住，《瑜伽师地论》第二十一卷说：‘云何正知而住？谓彼如是常勤修习觉寤瑜伽已，若往若来正知而住，若睹若瞻正知而住，若屈若伸正知而住，持僧伽胝（大衣，即通常所说的祖衣）及以衣钵正知而住，若食若饮若啖若尝正知而住，若行若住若坐若卧正知而住，于觉寤时正知而住，若语若默正知而住，如解劳睡时正知而住，如是名为正知而住。’即于往来瞻睹等，是所应住等，非所应住等，能正了知，不犯轨则威仪，如是住心，是名正知而住。广如《瑜伽师地论》第二十四卷所说应知。
    （十）乐远离，远离主要的有两方面：（1）是身远离，即不与在家及出家众，共相杂住，独一无侣，住于阿练若（寂静处）或空闲室，或树林下，或山谷岩穴，或空回家间等处，是名身远离。（2）是心远离，即远离一切染污无记所有作意，修习一切其性是善，能够引发定地作意，及定资粮加行作意，是名心远离。修习这两种远离，必须修习四圣种才能使身心得到清净。四圣种就是：（1）衣服喜足圣种，即于随其所得的衣服喜足少欲。（2）饮食喜足圣种，即于随其所得的饮食喜足少欲。（3）卧具喜足圣种，即于随其所得的卧具（床单等）喜足少欲。（4）乐断乐修圣种，即爱乐断除烦恼，爱乐修行圣道。喜足，即于所得的衣服饮食卧具，无论为少为劣，心皆知足。少欲，就是无大欲，即于所未得的衣服饮食卧具，不求妙不求多，不希望追求，是为少欲。此四圣种皆以无贪为体，为对治四种爱故，世尊为求解脱行者说四圣种，即于衣服喜足，对治衣服爱；于饮食喜足，对治饮食爱；于卧具喜足，对治卧具爱：乐断乐修，对治三界有见和无有见爱。此四法行，能生众圣，故名圣种。修解脱行的人，依此修习的增上力，即能为堪任修持圣道的所依器。修习远离的详细意义，应参考《瑜伽师地论》第二十一卷、第二十五卷、第三十卷，及《俱舍论．分别贤圣品》。
    （十一）清净诸盖，《瑜伽师地论》二十一卷说：‘云何清净诸盖？谓彼如是住阿练若，或复树下，或空室等，于五种盖净修其心，所谓贪欲、嗔恚、昏沉睡眠、掉举恶作、及以疑盖。从彼诸盖净修心已，心离诸盖，安住贤善胜三摩地。如是名为清净诸盖。’五盖是三摩地之障碍法，心有五盖，三摩地即无成就的可能，为了获得三摩地，必须思惟青瘀等相，对治内心中的贪欲等盖，是名清净诸盖，净修其心。
    （十二）依三摩地，由于断除诸盖，欲贪等诸恶不善法不起现行，得初静虑具足安住，第二静虑具足安住，第三静虑具足安住，第四静虑具足安住。如是名为依三摩地。四静虑的差别相，在第一章第四节中已略说，此不再述。乐广知者，当参阅《瑜伽师地论》第三十三卷论文。


三、顺解脱分

    三、顺解脱分
    （一）五停心位
     求解脱的行者，在修集涅槃法缘已，即已成为修行圣道的所依器，由此正式入于资粮位，修集解脱的资粮。在这一位中，首先修习的法门，为五停心观；即依胜解作意，思惟观察不净等五法，以停止内心的贪欲等五种过患，便能获得定地作意，引发观察四谛的观慧，而进趣加行道。五停心观是：（1）不净观，即观内外境界的不净相，对治贪欲过患，而停止其心。贪欲心重的人，宜修此观。（2）慈悲观，即于亲品、怨品、中品有情，观其可怜愍相，而修与乐拔苦的慈悲意乐，对治嗔恚过患，而停止其心。嗔恚心重的人，宜修此观。（3）因缘观，即观十二因缘，三世相续的道理，唯法唯事，唯因唯果，无我体我相，无作者受者，对治愚痴过患，而停止其心。愚痴心重的人，宜修此观。（4）界差别观，即以观心分析地水火风空识六界，或十八界，对治一合想的我慢过患，而停止其心。我慢心重的人，宜修此观。五持息念，即以念持出入息，令心意相依，计算息数，对治散乱过患，而停止其心。寻行散乱心重的人，宜修此观。（5）停心观详细的说明，可以参看《瑜伽师地论》第二十六卷、第二十七卷，及第三十卷和第三十一卷。这里只简略地解说一下不净观和持息念。因为人们修定不易得到成就的最大障碍，就是欲贪和散乱，能够对治这两种过患，则心容易停止而定。故《俱舍论．分别贤圣品》称说不净观和持息念为正入修要的二门。如彼论说：‘入修要二门，不净观息念：贪寻增上者，如次第应修。’本此论义，分别略述二观修法如下：
    （1）不净观：不净观在《瑜伽师地论》第二十六卷中说有六种：1.朽秽不净、2.苦恼不净、3.下劣不净、4.观待不净、5.烦恼不净、6.速坏不净。这里只说第一种朽秽不净。因为修行圣道最粗重的贪爱，就是对于内身起欲贪，与于外身淫欲起贪。观朽秽不净，就能对治内外两种欲贪，所以特说朽秽不净相。朽秽不净又有两种，如《瑜伽师地论》第二十六卷说：‘云何名为朽秽不净？谓此不净，略依二种：一者依内，二者依外。云何依内朽秽不净？谓内身中发毛爪齿，尘垢皮肉，骸骨筋脉，心胆肝肺，大肠小肠，生藏熟藏，肚胃脾肾，脓血热痰，肪脂膏髓，脑膜涕唾，烬汗屎尿，如是等类，名为依内朽秽不净。云何依外朽秽不净？谓或青瘀，或复脓烂，或复变坏，或复膨胀，或复食啖，或复变赤，或复散坏，或骨或锁，或复骨锁，或屎所作，或尿所作，或唾所作，或涕所作，或血所涂，或脓所涂，或便秽处，如是等类，名为依外巧秽不净。如是依内朽秽不净，及依外朽秽不净，总说为一朽秽不净。’依这二种朽秽不净为所缘而修，就能够对治于内身起欲贪，与于外淫欲起贪。如论说：‘谓由依内朽秽不净所缘故，令于内身欲欲贪，心得清净；由依外朽秽不净所缘故，贪于外身淫欲贪，心得清净。淫相应贪复有四种：一显色贪，二形色贪，三妙触贪，四承事贪。由依四外不净所缘，于此种相应淫贪，心得清净：若于青瘀，或于脓烂，或于变坏，或于膨胀，或于食啖作意思惟，于显色贪令心清净。若于变赤作意思惟，于形色贪令心清净。若于其骨，若于其锁，若于骨锁作意思惟，于妙触贪令心清净。若于散坏作意思惟，于承事贪令心清净。如是四种名于淫贪令心清净。’显色贪，就是见到女人身上显现的粉黛朱红、青黄赤白等美好颜色而起贪爱。此观想死尸的青瘀脓烂等相，即能对治其贪心。形色贪，就是见到女人秀丽窈窕，体态轻盈，娥眉凤眼，纤指细腰等而起贪爱。此观想死尸皮肉爆裂，血筋缠裹等的变赤相，即能对治其贪心。妙触贪，就是与女人身摩触拥抱等，于其肌肤柔软滑腻等而起贪爱。此观想死尸经过数日为虫蛆蝇蚋所聚啖，及骨锁想等，即能对治其贪心。承事贪，即于他身行动威仪，奉承供事而起贪爱。此观想死尸僵直不动，千足等骨离散坏灭，即能对治其贪心。《俱舍论．分别贤圣品》中把外朽秽不净，分为别治法与通治法两类。如上所说的四种不净观想，是各别对治法，即修各别的四种不净相，对治各别的四种贪爱。通治法，即观骨锁不净相，能为通治四种贪爱。因为不论其为贪爱显色、形色、妙触、承事，若心中能取一骨锁相现前作意思惟，则一切贪爱皆可不生，心得清净；如《俱舍论．分别贤圣品》说：‘修不净观，正为治贪。然贪差别，略有四种：一观色贪，二形色贪，三妙触贪，四供奉贪。缘青瘀等修不净观，治第一贪。缘被食等（被雕鹫狼狗等食）修不净观，治第二贪。缘虫蛆等修不净观，治第三贪。缘尸不动修不净观，治第四贪。若缘骨锁修不净观，通能对治如是四贪，以骨锁中无四贪境。’
    修习不净观的方法，即先由于内外不净之相亲见或听闻的增上力，引起如理作意了解其义，发起胜解，而思惟观察，乃至引起定地作意，是名不净观成。广如《瑜伽师地论》第三十卷中所说。骨锁观既然能够通治四贪，其所缘的境相亦容易看到，如博物馆中陈列的全具人体骨锁，与圹野古墓中暴露的尸骨，及医学上所用的人体骨骼的塑像、挂图等，都足为修观人的取相境。于外所取相境，数数取缘其相，令心于相熟习，则于正修观时，于内心中起假相作意思惟观察，则甚为容易。这里抄录《俱舍论．分别贤圣品》所说从自身中修习骨锁不净的具体观法如下，简便易行，欲修此观的人，可依之修习。论说：‘然瑜伽师，修骨锁观总有三位：一初习业，二已熟修，三超作意。谓观行者欲修如是不净观时，应先系心于自身分，或于足指，或额或余，随所乐处心得住已，依胜解力，于自身分假想思惟皮肉烂堕，渐令骨净，乃至具观全身骨锁。见一具已，复观第二，如是渐次，广至一房、一寺、一园、一村、一国、乃至遍地，以海为边，于其中间骨锁充满。为令胜解得增长故，于所广事渐略而观，乃至唯观一具骨锁，齐此渐略不净观成，若瑜伽师初习业位。为令略观胜解力增，于一具中先除足骨，思惟余骨系心而住，渐次乃至除头半骨，思帷半骨系心而住，齐此转略不净观成，名瑜伽师已熟修位。为令略观胜解自在，除半头骨，系心眉间专注一缘，湛然而住，齐此极略不净观成，名瑜伽师超作意位。’在三位中，第一位为作意未熟，第二位为作意已熟，第三位为超作意。前二位中观不净相，必须由作意策励才能现起：第三位中，观心已极淳熟，不须作意策励，其不净行相，能任运现前，故名超作意。
    如上所说的不净观，以无贪为自性。依四静虑与四近分，及中间定和欲界心十地生起，以无色界无缘色法的不净观故。唯缘欲界所见色境，唯人趣能生起此观，天中无青瘀等不净相故。此观唯是胜解作意相应，非十六行摄，但唯假想，故唯是有漏。
    （2）持息念：持息念，通常称为数息观，为对治散乱心的最好观行。持息念的相，实有六种差别，数息观法不过是其中的一种而已。持息念在经中名阿那阿波那念。阿那义即持息入，是引外风令人身中的意思；阿波那义即持息出，是引内风令出身外的意思。此持息念本以慧为体，应名持息慧，但慧由念力记持助慧观息为境，故名持息念。
    此观的差别行相，有其六种：1.数、2.随、3.止、4.观、5.转、6.净。前三是止，后三是观。分别略述如下：
    1.数息，即系心于息，放舍身心，不用强持之力，任运地以念忆持入出而心数之。从一至十，不减不增。因恐于心引起急促，故其数不应减少于十：恐于心引起散乱，故其数不应增加于十。这数息之法，又有四种，如《瑜伽师地论》第二十七卷说：‘云何名为算数修习？谓略有四种算数修习。何等为四：一者以一为一算数，二者以二为一算数，三者顺算数，四者逆算数。云何以一为一算数？谓若入息入时，由缘入意，出息住念，（出息住而未生，名出息住。）数以为一。若人息灭，出息生，出向外时，数为第二。如是展转数至其十，由此算数非略非广，故说唯十，是名以一为一算数。云何以二为一算数？谓若入息入而已灭，出息生而已出，尔时总合数以为一。即由如是算数道理，数至其十，是名以二为一算数。入息出息说名为二，总合二种数之为一，故名以二为一算数。云何顺算数？谓或由以一为一算数，或由以二为一算数，顺次展转数至其十，名顺算数。云何逆算数？谓即由二种算数，逆次展转从第十数，次九、次八、次七、次六、次五、次四、次三、次二、次数其一，名逆算数。’
    修数息时，在算数方面有三种过失应当纠正，如《俱舍论．分别贤圣品》说：‘然于此中，容有三失：一数减失，于二谓一。二数增失，于一谓二。三杂乱失，于人谓出，于出谓入。若离如是三种过失，名为正数。若十中间心散乱者，复应从一次第数之，终而复始，乃至得定。若十中间等文，就是说的纠正三种过失的方法。
    修数习观时，在持息的方法上，还有两种过患，应该注意避免，不让其产生，产生以后，应注意调和。如《瑜伽师地论》第二十七卷说：‘修入出息者，有二过患。何等为二？一太缓方便，二太急方便。由太缓方便故，生起懈怠；或为昏沉睡眠缠扰其心；或令其心于外散乱。由太急方便故，或令其身生不平等；谓强用力持入出息，由入出息被执持故，便令身中不平风转；由此最初于诸支节皆生战掉，名能战掉；此战掉风若增长时，能生疾病，由是因缘，于诸支节生诸疾病，是名令身生不平等。云何令心生不平等？谓或令心生诸散乱，或为极重忧恼逼切，是名令心生不平等。’方便就是方法，数习的时候，心念于息的摄持太松缓，名太缓方便。心把息摄持得太紧急了，名太急方便。太缓太急，都要产生过患，调和之法，即在意念上宽放身心，心息相依，任运地记数，则身心自然安稳寂静。
    2.随息：修数息的人，若算数已极串习，其心自然能够任连地展转相续流注，无有动摇，无散乱行，有适悦相应。至此心已微细，即应弃舍算数，进修随息。系心于息，不加功力，于入出息任运随顺而转。其简单的方法是：先随息从外入内，即从鼻入流至咽喉，复从咽喉流至心胸，从心胸流至脐轮，如是展转乃至流至足指，心皆随逐。复随息从内出外，行至一麻一麦，半指一指，半张手一张手，一尺二尺，乃至多尺，息去近远，心皆随逐。如《俱舍论．分别贤圣品》说：‘随谓系心缘入出息，不作加行，随息而行，念息入出时各远至何所：谓念息入，为行遍身，为行一分，随彼息入行至喉、心、脐、髋、髀、胫，乃至足指，念恒随逐。若念息出，离身乃至一磔、一寻，随所至方，念恒随逐。’髋即胯骨，髀即左右大腿骨，胫即小腿。一磔是一张手，一寻是五尺。余文易解可知。总起来说，入息至身内何处，出息至身外远近，皆以念随逐，明静觉知。这个方法很简要，能够依之修习，收效极为快速。若修之如法，又能精进恒常，在不久的时期内，即能引起身轻安，证心一境性，而入三摩地。
    3.止：止是把心专住一处。随息虽好，但尚有起念之失，若久修习而未得定，宜于随息澄静无扰之后，进而专住修止。即把心于于自己身中的某一处所，专一注念，凝然不动。或随息于身中所止之处，心住观之。或观息住身中如串珠的线，是冷是热，于身为损害为利益。如此观息湛然而住，安稳明静，久久相续，自能得定。《俱舍论》说：‘止谓系念唯住在鼻端，或在眉间，乃至足，随所乐处，安止其心；观息住身如珠中缕，为冷为暖，为损为益。’系心之处，以自身正中各处为宜，除论说鼻端眉间外，如心窝、肚脐，皆是很适宜的住心之处。
    4.观：观是观察，即随息至鼻口咽喉，乃至足指，都能审虑观察。并观察息俱时有四大种，此四大种生诸造色，此所造是心心所的所依处。如是观行者，以观息为先，乃至展转能遍观五取蕴。《俱舍论》说：‘观，谓观察此息风已，更观息俱大种造色，及依色住心及心所，具观五蕴以为境界。’具观五蕴如《瑜伽师地论》第二十七卷说：‘谓于入息出息及息所依身作意思惟，悟入色蕴；于彼入息出息能取念相应领纳作意思惟，悟入受蕴；即于彼念相应等事作意思惟，悟入想蕴；即于彼念若念相应思及慧等作意思惟，悟入行蕴；若于彼念相应诸心意识作意思惟，悟入识蕴。如是行者，于诸蕴中乃至多住，名已悟入，是名悟入诸蕴修习。’如果观察修习，即能成就毗钵舍那，而引生所修慧。
    5.转：转就是转此入出息观、起身念住观、受念住观，心念住观，法念住观等后后的殊胜善根中，乃至四加行位中最后世第一法任中，如《俱舍论》说：‘转谓移转缘息风觉，安置后后胜善根中，乃至世间第一法位。’觉就是观心，把观心转移到五停心位之后的四念住等后后位而修音之，故名为转。
    6.净：净是清净，即观心至见道位等，能断烦恼。故名为净。如《俱舍论》说：‘净谓升进，入见道等。’见道以前的观行不能断烦恼，故不可以名之为净。在《毗婆舍论》第二十六卷中，有的论师还说从四念住位，乃至金刚喻定，皆是转摄。有烦恼未断尽故，未名为净；必须无学位尽智生起后，才名为净。
    以上所说持息念的六种差别相，在五停心位，为得定故，重在修习数随止三相；后面三种观行，当于后后位中修习。
    （二）别相念住位
    修解脱行者，由修五停心观，心便得定。既已成就了殊胜的奢摩他，为了成就毗钵舍那，则应进一步修习四念住观。四念住是：身念住、受念住、心念住、法念住。于身等四相别别观察，故名别相念住。为什么须修此观呢？因为修解脱行的障碍，首先是于色身执净，于诸受执乐，于心行执常，于诸法执我。为了对治四种颠倒，故必须先修四念住观。此观有两种差别：
（1）自相别离，即观身受心法各别的自性，故名自相观。身念住，即观大种：造色、五根、五境，总括十色处及法处所摄色，皆是不净，对治于色身妄计为清净的颠倒。受念住，即观六受，身所有领纳皆是其苦，对治于诸受妄计为乐的颠倒。心念住，即观六识心集起染净生灭无常，对治于六识心王妄计为常的颠倒。法念住，即观除色蕴、受蕴、识蕴之外的所余一切法，无有常一主宰固实不变的我性，对治于一切法妄计为我的颠倒。如《大毗婆沙论》第一百八十七卷决择佛说四念住的意趣说：‘谓对治于不净，净想颠倒故，说身念处。对治于苦，乐想颠倒故，说受念处。对治于无常，常想颠倒故，说心念处。对治于无我，我想颠倒故，说法念处。’
    （2）共相别观，即身念住观身与其余有为法俱是无常性，与余有漏法俱是苦性，与余一切法俱是空、无我性。如是受念住、心念住、法念注，皆别别观受心法与其余有为法俱是无常性，与余有漏法俱是苦性，与一切法俱是空、无我性。无常，是有为法的共相，苦是有漏法的共相，空、无我是一切法的共相，四念住别别于身受心法观其无常苦空无我，故名共相观。如《俱舍论．分别贤圣品》说：‘如何修习四念住耶？谓以自共相观身受心法。身受心法各别自性，名为自相。一切有为皆非常性，一切有漏皆是苦性，及一切法空、非我性，名为共相。
    上述两种别相观中，又有杂缘不杂缘的差别。单观一法是不杂缘：观察法时并缘身等而修，是为杂缘。四念住中，前三种唯是不杂缘，第四一种通杂不杂缘。如《俱舍论》说：‘四中三种，唯不杂缘，第四所缘，通杂不杂。若唯观法，名不杂缘；若于身等二三或四，总而观察，名为杂缘。’关于杂缘修法，依《慧晖钞》立表如表二：

    （表二）
    修观行的人，最初观心未淳熟，只应先修不杂缘观，到观心已熟，为增进观智力量，方可渐次进修二二合缘、三三合缘，或总观四法的杂缘观。
    （三）总相念住位
    修观行的人，在别相念住位中，各别修习身等念住，观身等自相，或观身等共相，并于身等修习杂缘观行，经过这样的修习，观心已经淳熟，为了增强观智的力量，则应更进一步修习总相念住观。总相念住，即总缘身受心法四种所缘，而直观其共有的无常苦空无我四种行相。这种观法，比前杂缘别观，更升进了一步；以杂缘别观，虽能杂缘二三四法而修，但仍然是别观身等所缘的自相或共相，非是总集四法直观而修，因此，为了锻练观智，必须进修总相念住，才能增进观智的殊胜力量，而奠定生起四善根的基础。如《俱舍论》说：‘如是熟修杂缘身等法念住已，复何所值？颂曰：彼居法念住，总观四所缘，修非常及苦，空、非我行相。’
    以上所说四种念住，就自性出体来说，皆以慧为其体。既然是以慧为体，则应名慧住，为什么立名念住呢？因为由慧观察力令念于身等安住，慧力是因，念明记所缘是果，从果为名，故名念住。如《俱舍论》说：‘自性念住以慧为体。……何缘于慧立念住名？毗婆沙师说，此品念增故，是念力持慧得转义。如斧破木，由楔力持。理实应音，慧令念住，是故于慧立念住名，随慧所观能明记故。由此无灭（阿那律尊者）作如是言：若有能于身住循身观，缘身念得住，乃至广说。世尊亦说，若有于身住循身观者，念便住不谬。’
    四念住的次第依什么道理如此建立呢？这有两种理由：一是由所缘境的粗细次第而建立的。即粗境先观，最细境最后观。于四种境中，色粗先观。于后三种境中，受粗先观，如觉手痛等。于后二后境中，心粗先观。法最细故，所以后观。法中的想等心所，虽然比心王更粗，但法中包括涅槃，最极微细，与极细法合并施设，据细为论，故最后说。
    二是由于诸欲贪烦恼之生起，而建立其次第。先是于身起贪，故四念住观在初；然贪于身，由欣乐于受，故观观受第二；欣乐于受，由心不调，故第三观心；心之不调，由惑末断，惑是法摄，故第四观法。
    又由于四念住观，如其次第即能于身等四法起净乐常我四种颠倒，故四念住不增不减。
    四念住建立的次第，及唯有四观的意义，如《俱舍论》说：‘此四念住，说次随生。生复何缘次第如是？随境粗者，应先观故。或诸欲贪于身处转，故四念住观身在初；然贪于身，由欣乐受；欣乐于受，由心不调，心之不调，由惑未断，故观受等如是次第。此四念住如次治彼净乐常我四种颠倒，故唯有四不增不减。’
    以上所说四念住观，是依据《俱舍论》略说其义，爱乐广详意义者，应参阅《大毗婆沙论》一百八十七卷，及《瑜伽师地论》第二十九卷。
    总上所说五停心观、别相念住、总相念住，皆是顺解脱分摄。解脱是涅槃，分是因义。五停心观等善法，是顺彼涅槃之因，故名顺解脱分。亦名资粮道，此从譬喻得名，如古人行路，必须积持道粮，才能到达所欲至处：修解脱行的人，为至涅槃，修习善法，资益善根，是证彼涅槃的道粮，故名资粮道。
    顺解脱分善法，依有部师说，唯闻思二慧，通三业为体。如《俱舍论》说：‘传说如是顺解脱分，唯闻思所成，通三业为体。虽就最胜唯是意业，而此思愿摄起身语亦得名为顺解脱分；有施一食、持一戒等，深乐解脱愿力所持，便名种植顺解脱分。’理实亦有修慧，如《俱舍论》说修四念住的颂文中说：‘依已修成止，为观修念住。’论文说：‘依已修成满胜奢摩他，为毗婆舍那修四念住。’又说：‘自性念住，以慧为体。此慧有三种，谓闻等所成，即此亦名三种念住。’由此文证，故知俱舍论师于顺解脱分体亦说修慧。
    种种顺解脱分善根，需要深厚的厌离心与殊胜的智慧，故创植此善根，唯在人趣三洲。其余三恶趣、天趣、北俱卢洲，皆无此能。三恶趣以厌苦故，虽有厌离心，但以慧劣故，无殊胜的智慧。天趣虽有殊胜的智慧，但以苦轻故，无有深厚的厌离心。北洲苦轻，故无深厌：以其慧劣，故无殊胜智慧。因此，除三洲人外，皆不能种植顺解脱分善根。如《俱舍论》说：‘植顺解脱分，唯人三洲，余厌离般若，如应无故。’
    种植顺解脱分之缘，必须遇着佛出世间的时代。如《俱舍论》说：‘遇佛出世，植此善根。’此所说遇佛出世，是指亲见佛，或遇教法，乃至佛已入灭，有教法住世，值遇教法，俱能种植顺解脱分善根。为什么必须遇佛或遇教法才能种此善根呢？因为必须了知生死可厌，了知涅槃可欣，才能种植顺解脱分善根故。


四、顺抉择分

    四、顺抉择分
    （一）暖位
    修解脱行者，在修习总相念住之后，其观智渐次成熟，乃至增进成为上上品，即能引生顺抉择分四善根位的初位善根，名为暖法。无漏圣道，犹如于火，能烧毁其粗硬不调如柴薪的烦恼。此位善根，初得圣道火的前相，犹如世间钻木取火，其暖气是火前相，故初位善根立名为暖。如《俱舍论颂》圆晖说：‘圣道如火，能烧惑薪，圣火前相，故名为暖。’此暖位善根，因时分长故，能够具足观察苦集灭道四圣谛境，及能具足观修十六行相。即以观智观苦圣谛修四行相：非常、苦、空、无我。观集圣谛修四行相：因、集、生、缘。观灭圣谛修四行相：灭、静、妙、离。观道圣谛修四行相：道、如、行、出。此十六行相的解释，如《俱舍论．分别智品》说：‘谓苦圣谛有四相：一非常、二苦、三空、四非我；待众缘故非常，逼迫性故苦，违我所见故空，违我见故非我。集圣谛有四相：一因、二集、三生、四缘；如种理故因（种子生芽道埋），等现理故集（由因果相等的集力令果显现），相续理故生（由集令果相续），成办理故缘（由集为缘令果成办）。灭圣谛有四相：一灭、二静、三妙、四离；诸蕴尽故灭，三火息故静（贪嗔痴火），无众患故妙，脱众灾故离。道圣谛有四相：一道、二如、三行、四出；通行义故道，契正理故如，正趣向故行，能永超出故出。’此十六行相，在《俱舍论》中，总有四释，应检阅参考。关于四圣谛的意义，已在第一章第四节中广说，这里不再解释。为了醒目，列表于表三：
    暖位中具观四谛十六行相而修习，可以得到什么样的功德呢？《俱舍论．分别贤圣品》颂说：‘暖必至涅槃。’这就是说暖位善根，是奠定必得涅槃的基础。在这个位次上虽然还有退起邪见、毁断善根、造无间业、堕恶趣等的过失，但肯定地成就了必至涅槃这一功德，所以不会在生死中长久流转。如《俱舍论》说：‘四善根中，若能暖法，离有退断善根、造无间业、堕恶趣等，而无久流转，必至涅槃故。’
    （二）顶位

    （表三）
    修习暖善根时，其观智由下品转成中品，中品转上品，到最极成满时，以其观智的转胜，有殊胜善根性起，名为顶法。亦即四善根中的第二位。此位亦如暖法具足观察四谛为境，具修十六行相。为什么立名为顶呢？这有两种意义：（1）四善根中，暖顶二位是动善根，以有退起邪见，造无间业，堕入恶趣的动摇性故；但顶位善根，是由暖法渐次增长至上品而转胜的善法，在动善根之中，最为殊胜，已至极高之处，如人身的头顶，故立名为顶。（2）顶位善根，是进趣获得不动善根忍位，和退住暖位的两际处，譬如山顶，在进退两者之间，故名为顶。如《俱舍论．分别贤圣品》说：‘此暖善根下中上品，渐次增长至成满时，有善根生名为顶法。此转胜故，更立异名，动善根中此法最胜，如人顶故，名为顶法。或由此是进退两际，如山顶故，说名为顶。此亦如暖具观四谛及能具修十六行相。’
    修此顶善根所获功德，《俱舍论》颂说：‘顶终不断善。’就是获得顶位善法。虽然还有退起无间业，堕入三恶趣的动摇性，但对前暖法来说，更增加了毕竟不断善根的功德。如《俱舍论》说：‘若得顶法，虽有退等，而增毕竟不断善根。’由此可知，顶位不起邪见，以唯有上品邪见才能断善根故。
    （三）忍位
    修顶善根，由下品而中品而上品，渐次增长至最极成满时，有殊胜善根生起，名为忍法。为什么立名为忍呢？以此位善法，于四谛道理能信解忍可中，最为殊胜，故得名为忍。又此位善根坚忍无退堕故，名为忍法。此忍善根，有下中上三位差别。下中二位，同前顶法，具观四谛，修十六行相。（暖顶及下中忍皆能具缘三界苦等。）上品忍位，唯观欲界苦谛，以一行一刹生起世第一法，名为上忍。
    下中忍位，虽然都是如暖顶二位具观四谛理，修十六行相，但有差别；即向欲界四谛与上界四谛各起十六行相，合修三十二行相，是为下忍位。中忍位则是减缘减行的修法。
    中忍位怎样减缘减行呢？上下八谛，是所缘境故，名之为缘。上界四谛有十六行，欲界四谛有十六行，总计合成三十二行，是能缘行解故，名之为行。以上下八谛为所缘，而起三十二行解，于三十二行相中，如其次第，从后向前逆次渐渐减行减缘，乃至最后唯留欲界苦谛一行，比拟人于见道，计有七周减缘，二十四周减行，总称为减缘减行。即以四行观欲界苦谛，如是乃至以四行相观欲界道谛，后以三行观上界道谛，减除上界道谛一行相（出相）是为第一周。又以四行观欲界苦，如是乃至后以二行观上界道，复减一行，是为第二周。又以四行观欲界苦，如是乃至以一行相观上界道，复减一行，是为第三周。又以四行观欲界苦，如是乃至以四行观上界灭，不观上界道，名为减缘。减缘之时，虽亦减行，是减缘摄故，不名减行，唯名减缘，是为第四周。如减上界道谛，三周减行，第四周减缘，如是于余七谛行缘亦照样逆次减除，唯于缘中，不减欲界苦谛，及与一行相（非常相）是名为七周减缘，三八二十四减行，据实际道理来说，三十一周皆减行，因每一谛之最后一行与缘同减，属减缘摄故，所以但言二十四周减行。于减行中，初减一行，名中忍位初。如是直至三十一周时，唯留欲界苦谛下一行相，以二刹那心观欲界苦谛，比拟如见道时生起苦法忍、苦法智位故称为一行二刹那，名中忍位满。表示如表四：

    （表四）
    以上所说减缘减行最后观留欲界苦谛下一非常行相拟入见道，仅是举例而言，实际入见道时，虽然都是从苦谛下一行相悟入，但由于修行人根器有异，所观留的行相亦有所不同。依《毗婆沙论》一百九十卷说，人见道人，有利钝二根。利根人有两类：一是着我者，依无我行悟入见道。二是着我所者，依空行悟人见道。钝根人亦有两类：一是我慢增者，依无常行悟入见道。（以别知身无常，不自恃起慢故。）二懈怠增者，依苦行悟入见道。（以知苦相，即精进求出离故。）如上所说四类行者，应以何行拟入见道，即留何行而观察修习，广如《毗婆沙论》所说应知。
    中忍位要作减缘减行的原因是：下忍位修三十二行解，观智散漫，不能成为引发无漏智的殊胜增上缘，为了锻炼观智，故于上下八谛行相习减缘减行，由渐减略，使其智力明锐猛利，成为引发见道无漏智的殊胜增上缘。
    得此下中忍位善根有什么功德呢？《俱舍论．分别贤圣品颂》说：‘忍不堕恶趣。’若依论义，望前顶法增加三种功德：一不退失善根，二不造无间业，三不堕恶趣。如彼论说：‘若得忍时，虽命终舍，住异生位，而增无退，不造无间，不堕恶趣。然颂但说不堕恶趣言，义准已知不造无间业，造无间业者必堕恶趣故。忍位无退，如前已辩。’得中忍位若不命终，必入见道而证圣位，纵然命终，弃舍了忍善根，此生不能入见道，虽住于异生位，亦能得如前所说三种功德。
    从中忍满位，无间引起殊胜善根，名上品忍。此位以一刹那心观欲界苦谛起一行相，道入世第一法，称为一行一刹那。因为上品忍与世第一法相邻接故，唯有一念，不容相续。如《俱舍论》说：‘从此位（中忍）无间起胜善根，一行一刹那，名上品忍，此善根起，不相续故。’得上品忍，由于必入见道故，更得五种功德，即于生、处、身、有、惑五法得非择灭，称为五种不生：（1）生，即卵生湿生。（2）处，即无想天、北俱卢洲、大梵大王三处。（3）身，即扇搋半择迦（男根不具的人）、二形身。（4）有，即第八有等。（见道以后的圣者，充其极只有七翻生死，故无第八次的后有等。）（5）惑，即见道所断惑。如《俱舍论．分别贤圣品》说：‘若至圣位，于少趣生处身有惑中，得不生法故。趣谓诸恶趣。生谓卵、湿生。处谓无想、北俱卢大梵处。身谓扇搋半择迦、二形身。有谓第八等有。惑谓见所断惑。’
    （四）世第一位
    从上品忍，无间引生最极殊胜的善根，名世第一法。此世第一法，亦如上品忍唯缘欲界苦谛，唯有一行一刹那心，即直入见道。此位善根仍是有漏，故名世间。但在世间善法中，已至极顶，能与苦法智忍作等无间缘，开圣道门，引圣道性，最极殊胜，故名第一。是世间最胜法故，名为世第一法。如《俱舍论》说：‘上品忍无间，生世第一法，如上品忍缘欲苦谛修一行相，唯一刹那。此有漏故，名为世间：是最胜故，名为第一：此有漏法世间中胜，是故名为世第一法。有士用力，离同类因，引圣道生，故名最胜。’
    此位善根所得功德，《俱舍论颂》说：‘第一入离生。’即得世第一法已，虽住异生位，必定能够趣入‘正性离生’—见道。
    以上所说暖等四善根，皆以慧为体。名顺决择分。见、修、无学三种圣道，皆名决择。决是决断，能断疑故；择是简择，能分别四谛相故。分是分段。见道名决择分，是决择中的一分故。暖等四种善根，能为胜缘，引生见道，能顺益彼见道故；顺是其因，决择是果，从因及果为名，故名顺决择分。亦名加行道，为入见道而加功用行修习四善根故。
    此四善根，皆依定地生起，故是修所成慧，而非闻思所成散慧。依六定生起，即未至定、四静虑，及中间定，欲界中无此四法，以非定地故。无色界也没有，以暖等是见道的眷属法，无色界无见道故，唯欲界人天身能生起四善根，别的界趣都无缘生起。广如《俱舍论．分别贤圣品》所说应知。
    总上所说的五停心观等三资粮，及暖等四加行，又名七方便，以皆为趣证圣果的方便行故。


一、圣位所断烦恼

    第二节 果
    一、圣位所断烦恼
    声闻乘行者，从世第一位善根之间发起真无漏智，即能断尽三界的见惑而成为初果圣人。此后更不断地数数修习无漏圣道，即能渐次地断尽修惑而证得阿罗汉果。故圣位中所断的烦恼虽然很多（本惑随惑），但总起来说，只有两类，即见惑与修惑，只要把见修二惑的根本烦恼断除了，其余的随惑也就随之而断除了。
    根本烦恼总有六种，即：贪、嗔、痴、慢、疑、恶见。又开为十种，即：贪、嗔、痴、慢、疑、身见、边见、邪见、见取见、戒禁取见。这十种烦恼之中，身边邪见戒五种，使有情在三界中流转生死的力量极为猛利，故称为五利使。贪嗔痴慢疑五种，力量则比较迟钝，故称为五钝使。在这利钝使中，又有迷理与迷事的差别。迷理，即贪等十种烦恼，皆迷于迷悟因果的四谛道理。迷事，就是贪嗔痴慢四种烦恼（大乘迷事烦恼有六，即贪嗔痴慢身见边见，如下大乘行果中说），迷于宇宙万物的事相。为明了其差别，列表如表五：

    （表五）
    此中迷理的烦恼，名为见所断惑，初见谛理，彼即断故。开之成为八十八使。迷事的烦恼，名为修所断惑，要见道以后，数数修习圣道才能断除故。开之为八十一品，分别简述如下：
    （一）见惑
    迷理的见惑，依《俱舍论．分别随眠品》，依五钝使与五利使之十种烦恼，于三界中就所迷谛理的差别，开为八十八使。即苦集灭道四谛为所迷的真理，迷其真理而起贪等烦恼，迷欲界四谛理起三十二，迷色界四谛理起二十八，迷无色界四谛理起二十八，总合三界为八十八使。欲界三十二是：迷于苦谛理起十惑：一、身见，即于五蕴和合的苦果身，迷执为常一的我见。二、边见，即妄执此我体死后常住，或死后断绝，各执一边而起边见。三、邪见，即于现在之身，是过去业因所感的果报的道理，拨为无有。四、见取见，即迷执前三见为正见。五、戒禁取见。即迷执现在的苦身受持种种邪戒苦行，为当来生于人天乐处的因。六、贪，受执前五见为是。七、嗔，以前五见为非而起嗔恚。八、痴，不知道五见是不如理。九、慢，以五见为是而生慢心。十、疑，于苦谛道理疑惑不决。以上十惑中，五见与疑直接迷于谛理，故说为亲迷之惑。贪嗔痴慢四种，以其五见为所迷，不是亲迷谛理，故说为疏迷之惑。迷于集谛理起七惑：即于前十惑中，除去身见、边见和戒禁取见。集谛是苦果的业因，诸有情没有执业因为我体的，故无身见。无身见故，也就无边见。戒禁取见，是于非生人天的业因妄执为是生人天的业因，虽然有迷于集谛而起的道理，但就实际情况来说，外道修种种戒禁时，是迷执其现前身上，自以其苦行之身为人天的生因，故摄之于苦谛，而不入于集谛，所以无戒禁取见。其七惑中的邪见，是拨无烦恼业为生死之因的道理。见取见，是迷执其邪见为正见。疑，是疑集谛之理。其余贪嗔痴慢四惑，以邪见、见取见、疑三惑为所迷而起，如前苦谛所说准知。迷于灭谛理起七惑：迷灭谛理所起惑与迷集谛七惑相同。灭谛是涅槃，拨无涅槃，即是邪见。以此邪为正见，是见取见。于涅槃怀疑不信，是疑。以邪见、见取见、疑为缘而起贪嗔痴四烦恼，合为七惑。迷于道谛理起八惑：于前七惑之外，加戒禁取见。有一类外道，以修习无想定为入涅槃的正道，即是由迷于道谛之理而起的非道妄计为道的戒禁取见。其余七惑，准集谛例知。以上总为欲界的三十二惑。迷色界与无色的四谛道理，各起二十八惑：即于四谛下之惑各除一嗔；因为上二界是定地，由定力压伏关系，不起粗动的嗔恚烦恼。故上二界中，迷苦谛而起者各有九惑，迷集谛而起者各有六惑，迷灭谛而起者亦各六惑，迷道谛而起者各有八惑。以上所说三界迷四谛惑，欲界三十二，色无色界各二十八，总合成为八十八使。于见道十五心之间一时断尽。列表如表六：

    （表六）
    （二）修惑
    修道所断惑，就是迷事的烦恼。依《俱舍论》建立，总有十种，即于欲界有贪、嗔、痴、慢四种；于上二界除嗔，各有贪、痴、慢三惑，合为六种；共合三界而为十种。（大乘立十六；欲界有贪、嗔、痴、慢、身见、边见六惑；上二界除嗔，各有五惑，合为十惑，共合三界为十六惑。）修惑微细，不能如见惑一时顿断，必须数数修习圣道来渐次断除，故分十惑为九地之九品而分断之。因此修惑有八十一品的差别。即欲界五趣杂居地，色界初禅离生喜乐地，二禅定生喜乐地，三禅离喜妙乐地，四禅舍念清净地，无色界空无边处地、识无边处地、无所有处地、非想非非想处地，合为九地。这九地所起的贪等烦恼，各有上中下三品的差别；于每一品中，更分为上中下三品，即成为上上、上中、上下，中上、中中、中下，下上、下中、下下，共为九品。总合三界九地，合有八十一品。列表如表七：

    （表七）
    修道所断惑，虽然有八十一品的差别，但约其惑体来说，欲界起贪嗔痴慢四种烦恼，色界与无色界，各起贪痴慢三种烦恼，总合三界只有十种烦恼。故《俱舍论．分别随眠品》中，说此修惑之十种，与见惑之八十八使，合称为九十八种随眠。


二、圣果差别

    二、圣果差别
    （一）预流向及预流果
    声闻乘行者，由世第一位无间发起无漏真智，断尽了三界见惑以上的位次，皆名圣者，亦即无漏的圣果。因为无漏正智断除的烦恼有差别，果亦成为四级：（1）预流果，（2）一来果（3）不还果，（4）阿罗汉果。趣向于这四级果位的因行位，名为四果向。
    梵语须陀洹，译言预流，是初果圣位的名称。《俱舍论》说：‘诸无漏道总名为流，由此为因趣涅槃故。预言为观最初至得，彼预流故，说名预流。’预是人义，流是类义，这个位上的圣人，初见真理，得入圣道的流类，所以名为预流。预流圣者，是由世第一法无间发起无漏真智，亲证四谛境，于诸谛境现前观见，称为圣谛现观。此现观位发起无漏十六心；观上下八谛（上即上二界四谛，下即欲界四谛）真理，而断尽三界见惑八十八使，即成为预流圣者。十六心是：缘欲界苦谛境起二心：一苦法智忍、二苦法智。缘上二界苦谛境起二心：一苦类智忍、二苦类智。缘欲界集谛境起二心：一集法智忍、二集法智。缘上二界集谛境起二心：一集类智忍、二集类智。缘欲界灭谛境起二心：一灭法智忍、二灭法智。缘上二界灭谛境起二心：一灭类智忍、二灭类智。缘欲界道谛境起二心：一道法智忍、二道法智。缘上二界道谛境起二心：一道类智忍、二道类智。总上十六心，称为八忍八智。从第一心苦法智忍到道类智，无别心间隔，皆是次第无间而起，于诸圣谛境现见分明，现前实现总说名为圣谛现观。苦法智忍的意义是：苦法即欲界苦谛法，无漏圣慧忍缘苦谛法，见彼唯是苦法性，忍可现前，名苦法忍；此无漏忍复能引生后念决断了知苦法的法智，是法智的因，故得名苦法智忍。苦法智的意义是：智缘苦法故，名苦法智。类忍类智的意义是：上二界的苦法等境和能缘的智，与下界境智相似，是下界境智的同类，故立名为类忍类智。其余集灭道忍智的意义，准释应知。《俱舍论》说：‘得苦法智忍，名“入正性离生”。’正性即涅槃，或指圣道。生即见惑烦恼，能令有情生诸恶趣，障碍善根不熟；见道能证涅槃，能越烦恼，故名正性离生。苦法智忍生已，得圣者名，至此位中，说名为入。忍是正断惑位，忍可谛理，断除惑体，名无间道。智是已断惑位，智于苦法已决了知，离系证灭，名解脱道。此二次第，道理决定，如《俱舍论》第二十三卷说：‘十六心中，忍是无间道，约断惑得，无能隔碍故。智是解脱道，已解脱惑得，与离系得俱得俱时起故。具二次第，理应然；犹如世间驱贼闭户。’如上所说无漏十六心，观上下八谛，各起无间解脱二道，即忍与智；乃至断尽三界的见惑八十八使之位，名预流果。此分因果二位，因即预流向，果即预流果。即十六心中前十五心位，名为见道：以于四谛真理，从无始以来都未曾见过，而今于每一谛理初次创见，故得名见道。这见道位十五心，是趣向预流果的因行道位，故名预流同。其第十六心道类智，于诸谛理皆已尽见，无所未见。由重见故，如修习曾经所见，故属于修道摄，名预流果。列表如表八：

    （表八）
    关于十六心中分为见道和修道，与道类智为什么不是见道摄？及前七智是忍可谛理以后之智，既是已见今见，为什么也是见道摄？今抄录《俱舍论颂疏》文解释如下：‘论云：此十六心，皆见谛理，一切可说见道摄耶？不尔！云何？颂曰：前十五见道，见未曾见故。释曰：除道类智，前十五心，名为见道。于四谛理，未见今见，见未曾见，故得见名。至道类智，无一谛理未见今见，如修曾见，故修道摄。问：如道类忍是道谛理。此道类智缘道类忍，于道类忍未见今见，何故道类智非真见道摄耶？答：此中约谛，不约刹那，虽于道类忍一刹那心，未见今见，于上下八谛，皆已曾见，故修道摄，如刈畦稻，唯余一科，不可名为一畦未刈。问：忍于谛理未见今见，可名见道：中间七智，已见今见，何缘七智亦见道摄：答：知谛未尽，中间起故，亦见道摄。’末段义说，士智虽是重见谛理，但尚有未见的谛理，以是于已见的谛理和未见的谛理的中间生起，见未周遍究竟，故非修道所摄。
    住预流果的圣者，速即现生证得无学果位。最迟亦只经欲界七返生死，即人间天上往返各七生，必证阿罗汉果，入般涅槃。《俱舍论》说，在七返生死中，所有圣道，必得成就。故论二十三卷说：‘至第七有，逢无佛法时，彼在居家，得阿罗汉果。即得果已，必不住家，法尔必得比丘形相。’
    （二）一来向及一来果
    梵语斯陀合，译言一来，是二果圣人的名称。住预流果的圣者，虽然断尽了三界的见惑，但对于欲界的九品修惑，一品也没有断除。为了进趣二级圣位，再前进修习，断除了欲界六品修惑，则能证得二果圣位，名一来果。如前所说，迷事烦恼是修道所断惑，于九地中，每一地各有九品。如欲界五趣杂居地根本品有上中下，此三又各分三品，故成九品。下品分三是：下下、下中、下上。中品分三是：中下、中中、中上。上品分三是：上下、上中、上上。其余八地，依此照分，三界九地，九九总有八十一品无间道，八十一品解脱道。其能治道与所治烦恼的对比是：下下品道，能断上上品障，乃至上上品道，能断下下品障。原因是：上上品障是粗惑，容易断除，故下下品道能断。下下品惑是细惑，微细难断，故须上上品道才能断除。如洗衣物，粗垢先除，后除细垢。圣道与惑障相对，也是这样。以白法力强，黑法为弱；故刹那顷的下下品道，能断无始以来的上上品惑。一来果圣者，只断了欲界九品修惑中的前六品，有后三品烦恼存在；由于后三品烦恼的润生力量，现生死后，必须于欲界天上受生一次，更来人间受生一次，欲界的生死才能了结。以其死后还要在欲界天上人间往来受生一次，故得名一来果。若只断了欲界修惑一品乃至五品的圣者，是趣向于一来果的因行道位，故名一来向。
    一来向的圣者，由于进断修惑的品数有差别，因而名称亦异。断欲界修惑三四品的，总名家家。家是指受生的处所，即从天上人间三处二处受生，故名家家。断了欲界三品修惑的，名三生家家。断了四品修惑的，名二生家家。原因是：欲界九品修惑的润生势力，能润七生：上上品，能润两生。上中品，上下品，中上品，各润一生。中中品，中下品，合润一生。下三品惑，共润一生。既然上三品惑能润四生，故断了上三品惑的一来向人，四生便已损害，只在欲界中受三生，故名三生家家。既然中上品润一生，故断了中上品惑，复损害一生。故断了四品修惑的一来向人，总损五生；在欲生死中，唯余二生，故名二生家家。这三生家家和二生家家，又各分为天家家与人家家两种：（1）天家家，即于欲界天处，生三二家，此是从一天处，受三二生，或从二三天处，受三生二生，而证圆寂，故名天家家。（2）人家家，即于人趣，生三二家；此是从人趣一洲处，或二洲处，或三洲处，受三生二生，而证圆寂，故名人家家。天家家中，若是三生家家，其受生处，天三人二；即于天处受三生，于人间受二生。若是二生家家，其受生处，天二人一；即于天处受二生，于人间受一生。此天家家，都是在人中得见道者。人家家中，若是三生家家，即其受生处，人三天二；即于人间受三生，天上受二生。若是二生家家，其受生处，人二天一；即于人间受二生，天上受一生。此人家家，都是在天中得见道者。如天家家中，称天三人二者，先于人中得见道已，进断三品修惑，从此命终，而生天处，受天一生（大一）：又从天中死殁，来生人间，受人一生（人一）；又从人死，而生天处，受天一生，并前一生，名为二生（天二）；复从天死，来生人间，受人一生，兼前一生，名人二生（人二）；又从人死，复生天处，更受一生，并前二生，名天三生（天三），故是天三生，人二生。此天家家即于第三生天中断尽烦恼，而证阿罗汉果。又如人家家中，称人三天二者，先于天中得见道已，进断三品修惑，从天死殁，生于人间（人一）；又从人死，生于天中（天一）：再从天死，生于人间（人二）；复从人死，三生于天中（天二）；最后从天死殁，来生人间（人三），故是人三生，天二生。此人家家，即于第三生人中，断尽烦恼，而证阿罗汉果。其余二生家家中的天二人一，及人二天一，准前例释应知。今总摄前义，列表如表九：

    （表九）
    如上所说，一来向中断欲界修惑三四品的，名为家家。为什么没有断一品、二品、五品修惑立名为家家的呢？其理由是：一来向人在断烦恼的进趣中，必无有只断一品二品不断三品的中间而有生死的事，亦无仅断第五品不断第六品而有生死的事。因为证得初果的圣者，为了进断欲界修惑，起大加行，必无未断一大品结（三品名一大品），而有生死故。所以断一品二品，必断第三品：断第五品，必断第六品。又断第六品，即证一来果，以无一品惑能够障得果者，故断五品必断第六品。
    总上所说的意义，如《俱舍论．分别贤圣品颂》说：‘断欲三、四品，三、二生家家；断至五、二向；断六，一来果。’证得一来果的圣者，亦名薄贪嗔；已断上中六品重贪嗔痴，唯有下三品薄贪嗔痴故。
    （三）不还向及不还果
    梵语阿那含，译言不还，是第三果圣人的名称。这个位上的圣人，已经断尽了欲界第九品修惑，更没有欲界的烦恼了，在欲界死殁以后，有生色界，必不还来欲界受生，去而不还，所以名为不还果。从得一来果以后，进而断除了欲界修惑第七八品的圣人，是趣向不还果的因行道位，故名不还向。此不还向，名为一间。间是间隔，由彼圣人尚有一生为间隔而不能证圆寂故；惑由尚余一品欲界修行断惑，为间隔故，不得不还果，由此二义，说名一间。此不还果，总说有七种差别：
    （1）中般涅槃：有一类不还圣者，于欲界死后，在往生色界的中有位上，能起圣道，断尽了上二界的修惑，而证阿罗汉果，即入无余依般涅槃。由住中有位便般涅槃，故得名中般。
    （2）生般涅槃：有一类不还圣者，于欲界死后，受色界生，由具勤修、速进二道故，生已不久，断尽了上界的烦恼，而证阿罗汉果，得有余依般涅槃，尽其寿量，方入无余依般涅槃。故说生般，是约有余依而说，非才生已便入无余依般涅槃。《俱舍论》说：‘彼于舍寿，无自在故。’
    （3）有行般涅槃：有一类不还圣者，于欲界死后，往生色界己，长时加行不息，由多功用，勤修圣道，才般涅槃（有余依），故名有行般。此类圣者，唯有勤修道，无速进道。唯有勤修道，故名为有行。复由于无有速进道，故在生般之后。
    （4）无行般涅槃：有一类不还圣者，于欲界死后，往生色界已，经过长久的时间，都不勇猛加功用行，由于懈怠，无功用行，任运地便般涅业（有余依），故名无行般。此类圣者，缺勤修速进二道，故在有行般后。
    （5）上流：上流是上行义，有一类不还圣者，于欲界殁往色界生，未即于彼生中能证圆寂，要转生上，才能般涅槃，故名上流。前面所说的生般等，离生上界，但即于彼生处而般涅槃，更不上生，无上行义，故生般等不名上流。上流差别有两类：[1]乐慧者，此类圣人，爱乐智慧，于静虑有杂修，以色界智慧殊胜，故唯受生于色界：最后上生色究竟天（色界最末一重天），才般涅槃。此乐慧上流，复有三种：1.全超，2.半超，3.遍殁。全超者是：先在欲界，于四静虑已具杂修（于定中起无漏有漏念间杂而修），遇缘而退失了上三静虑，唯爱味初禅，因此在欲界命终后，生于梵众天（初禅第一天）：由先世杂修的习气力量，复能杂修第四静虑。（阿罗汉，或不还圣者，凡欲杂修四静虑，必先杂修第四静虑，以第四静虑定慧均等，最堪能故。所以复亦如此。）从梵众死殁，直生色究竟天，顿超中间诸天，故名全超。半超者是：从梵众天死殁，生究竟天，其中有十四天（《俱舍》于色界立十七天，将无想天摄于广果天故。圣人必不生大梵天处，故有十六天，从最初到最后，中间有十四天。）为间隔。而在受生中，或超越一天，后生色究竟：或超越二天，后生色究竟：乃至或超越十三天处，后生色究竟。由于超非全故，皆名半超。遍殁者是：于色界十六天中，尽遍受生；一切处死，故名遍殁。[2]乐定者，此是爱乐禅定的上流圣者，无杂修定，遍生色界，唯不能往生五净居天（第四禅的后五天：无热、无烦、善现、善见、色究竟五天。此五天由杂修静虑所感，唯三果圣人所居，故名五净居天。）从广果天殁，直往无色界，于三无色次第受生，最后生有顶天，才般涅槃。这里说乐慧上流往生色究竟天才般涅槃，与乐定上流上生有顶天才般涅槃，皆是指其极处而说，以超过于彼，再无行处故。若就实际情况来说，二种上流，皆容许于中间诸天而般涅槃。由上所说二种上流的上行道理，可以知道：‘于色界中，下十一天，乐定乐慧，俱得受生。于广果天，便分二路：若乐慧者，生五净居：若乐定者，生无色界。’（《俱舍论颂疏》）。
    此上所说中般、生般、有行般、无行般、上流等五种不还，名为行色界者。乐定那含虽生无色界方般涅槃，但由于经历色界生故，亦是色界所摄。
    （6）行无色：此类不还圣者，在欲界已离色界贪，从欲界殁巳，不经色界即直生无色界，而般涅槃。这有四种差别：1.生般、2.有行般、3.无行般、4.上流。无有中般，因为无色界无中有故。
    （7）现般涅槃：此类不还圣者，不生色界无色界，即住于此欲界得般涅槃，名现般那含；于现身中，得涅槃故。
    上说七种不还，通约欲、色、无色三界安立：即前五种于色界般涅槃，第六种于无色界般涅槃，第七种于欲界般涅槃。
    这里顺便说明三点应该知道的道理：（1）不还圣者，不但不还来欲界，即于上界，亦决不于已生处受第二生，更不会于下处受生；以彼之生，唯是胜进，非等非劣故。即由此理，不还的名义亦才能圆满。（2）凡是在圣位经过欲界生死的，由于厌苦心强，必不往生色无色界；证得不还果已，定于现身般涅槃。由此义故，预流经生欲界，决无多出七生者。（3）若于色界经生的圣者，容许有上生无色界义，以色界无苦，厌心劣故；所以容许上生无色界天。
    除上说七种不还之处，还有九种不还，七善士趣，经生不还，身证不还等名义，为恐太繁，且止不说。
    （四）阿罗汉向及阿罗汉果
    得了不还果的圣者，进断色界及无色界修所断惑，从断色界初定一品为初，至断无色界有顶地第八品为后，都是趣向阿罗汉果的因行道位，皆名阿罗汉向。即此阿罗汉向中，断有顶地第九品惑的无间道，亦说名为金刚喻定：此定能破除一切烦恼。犹如金刚能摧一切，故名金刚喻定。定虽有力能破一切，因余惑先已断除，故今唯断第九品惑。《俱舍论》说：‘此定既能断有顶地第九品惑，能引此惑尽“得”俱行“尽智”令起。’即金刚喻定断有顶地第九品惑尽的同时引令尽智生起。金刚喻定是断惑中最后的无间道，所生尽智是解脱道。
    由此解脱道与诸漏尽‘得’最初俱生，故名尽智。尽智生已，便成无学阿罗汉果。若是不动种姓的利根罗汉，于尽智后，必起无生智，以永不退故。若退法等五种钝根罗汉于尽智后，或生尽智，或生无学正见（正见一切阿罗汉皆有），但没有无生智，以容许有退故。阿罗汉是梵语，译言应供、杀贼、不生等义。由于阿罗汉已断除三界见修惑尽，是声闻乘的极果，因此，说他用智慧的刀剑已杀尽了烦恼贼；有漏的惑业都尽，圆寂以后不再来三界受生，所以名为不生：所应学者已毕，唯应作利他事，具足无漏功德，堪受人天的广大供养，所以得名应供。今摄前义列表如表十：

    （表十）
    阿罗汉果的差别有六种：
    （1）退法，在证了阿罗汉以后，一旦遇着退缘，又忽起修惑，便退失所得之果，而降至不还果、或一来果、或预流果等。
    （2）思法，在证了阿罗汉以后，恒作是思：勿遇病等便于正念有所忘失，由此失念，令我有退。恐惧所得之果退失，因此常思自害毕命，而入无余涅槃。
    （3）护法，在证了阿罗汉之后，于所得果法，为令不退，精进防护。
    （4）安住法，在证了阿罗汉以后，能安住于所得果法；无胜退缘，虽不自防，亦能不退；无胜加行，亦不增进。
    （5）堪达法，即已证阿罗汉之圣者，其性质堪能调顺，好修练根，能迅速达到不动种姓。
    （6）不动法，在证得阿罗汉果后，无论遇着什么事情，于行自在，不为一切烦恼所退动。这是最利根的阿罗汉。
    六种阿罗汉中，前五种总名‘时爱心解脱’。恒时爱护所得法，故名时爱；心解脱烦恼缠缚，故名解脱。亦说名为时解脱者，以要待时才能入定及心解脱故。所待之时，《大毗婆沙论》一百零一卷说略有六种：一得好衣时，二得好食时，三得好卧具时，四得好处所时，五得好说法时，六得好补特伽罗时（好共住人，即同学）。前五种阿罗汉根钝，要待前六种胜缘会合时，才能证得阿罗汉果，故得名时解脱。第六种不动法阿罗汉，名为不动心解脱，以不为烦恼退动，及心解脱故。亦说名为不时解脱，以不动法阿罗汉是利根性，不须待资具等胜缘会合时便能入定及心解脱故。
    又说退法种姓，非是必定有退；乃至堪达，非是必定能达至不动；但约容许有的道理而建立此等名称。
    六种阿罗汉中，不动种姓，必无退理；前之五种，皆有退义。退有退性与退果的差别：
    第一种退法阿罗汉，只有退果，而无退性；由于退法种姓，本身已住退性，最居下故，无可再退，退果即退失无学果而退住不还果等。思法等四种阿罗汉，有退性和退果两义。退性，是从思法种姓退入退法种姓，或从护法退入思法，或从安住退入护法，或从堪达退人安住，是名为退性。退果，即由阿罗汉果退住不退果、一来果等位，是名为退果。总起来说，退法等五种阿罗汉，皆有退果之义，其中思法等四种，并有种姓退失。《俱舍论》说，假若思法等四种阿罗汉，先前在有学位中，即住于思法等四性，现今至到无学位上，亦住于思法等四性，此类阿罗汉，则种性与果法，皆无有进。原因是，这样的四种阿罗汉，是由有学无学二种道力所成，极为坚固，故必无退理。若单于无学位上，由退法等种姓进修而成思法等四种种姓，则种性与果法，皆容许有退：唯由无学道之所成故。
    又退果的意义，依有部宗说，只有后三果容许有退，初果则定无退理。如《俱舍论颂疏》说：‘依萨婆多宗，唯预流果，必定无退，以断迷理见道惑故；谛理真实，楷定可依，圣慧已证，必无退理。后之三果，许有退果，以修道惑，是迷事故；事相浮伪，无定可依，断迷彼惑，有失念退。’这是说，见所断惑，妄计有我等，以无事相所依，名依无事，既证无我真理故必无过。修所断惑，迷各别事起，即是可意不可意等所缘境，此相非无，名依有事，虽已断迷彼之惑，但容有失念之退。若依经部师说，预流与阿罗汉必无退果，是圣道证故。中间二果（一来、不还），容有退失，以许有漏道证故。《俱舍论》注，认为经部师所说合理。经部师会通经中所说阿罗汉有六种差别，皆约现法乐住有退不退而安立，如《俱舍论颂疏》说：‘依经部宗，阿罗汉果有六种者，约现法乐住有退不退，非约退果。若得果姓，皆名不动，无六种也。现法乐住者，有漏四静虑也。退此静虑，名为退法。思此静虑，名为思法。护此静虑，名为护法。安住静虑，名为安住法。堪达静虑，名堪达法。不退静虑，名不退法。约现法乐住，分六种也。’即依有部宗有退果的意义来说，诸阿罗汉从果退失后，由惭愧增故，在很短的时间内，就能够复得，决无从果退后至未复得中间而有命终者。若有退而未复即命终者，则修梵行果，应非安稳可委信处了。
    六种阿罗汉，依解脱不同，又安立为两类：一、慧解脱，即依唯由无漏慧力，断尽见修二惑，于烦恼障得解脱者，立名慧解脱。二俱解脱，即先由无漏慧断尽了见修二惑，离烦恼障；又兼得灭尽定，离解脱障（即灭定障，以不染污无知为体），名俱解脱离定慧障，名之为俱。前慧解脱者，未离定障，故不得名俱。
    阿罗汉果虽然有六种差别，但都是断尽了三界见修二惑的声闻乘的最高级的果位，在断烦恼和证般涅槃所应学者，都已究竟无可学修，故得名无学。前面所说的初二三果及四向的圣者，有烦恼未尽，有圣道须学，所以通名有学。
    上来所说的四向四果，都是就次第断证而说的，此外还有超越断证者，略述如下：若在凡夫位，先已由世间道断除欲界修惑一品至五品，而后发起无漏慧入见谛者，在见道位中，与次第证者相同，名预流向。趣预流果故。至第十六心道类智，住预流果。若先已由有漏道断欲界修惑第六品或七八品，而后发起无漏慧入见谛者，在见道位中，名一来向。趣一来果故。至第十六心道类智，住一来果。此名超越的一来，亦名位离欲者。若先在凡夫位中，已由有漏道断欲界修惑第九品尽，或断初定一品，乃至断无所有处惑尽，而后发起无漏慧入见谛者，在见道位中，名不还向。趣不还果故。至第十六心道类智，住不还果。此名超越的不还，亦名全离欲者。但阿罗汉果，必无超证的道理，如《俱舍论》说：‘阿罗汉果，必无初得；见道无容断修惑故，世道无容离有顶故。’论文的意思是说，见道位中，见谛时速，故见道无漏慧，不容许有时间断除修惑，故凡是超证的圣者，都是在凡夫位时已用世间道断了若干品修惑，但世间道断修惑，必须是上地心断下地惑，不能自地心断自地惑：但有顶惑，已再没有比其更上的世间道心生起，故有顶惑必须在入见道以后，再修无漏圣道来断除，才能证得阿罗汉果。


三、圣位功德

    三、圣位功德
    （一）断德
    证得阿罗汉果的无学圣者，诸趣因果灭尽解脱，证得清净寂灭的涅槃，是阿罗汉断尽生死因果所得的功德，故名断德。涅槃又云泥洹、涅畔、涅槃那等。体即寂灭无为。义即灭生死因果，渡生死瀑流，无惑业因缘之造作，生死苦果永不再生，空寂无相，安稳快乐。依声闻乘义，解脱以得灭为主，故涅槃正翻为灭，余均义译。大乘的涅槃，有圆满功德，寂灭诸患义，故正翻圆寂。《成唯识论述记》卷一说：‘西域梵音云波利匿缚喃，波利者圆也，匿缚喃言寂，即是圆满体寂灭义。旧云涅槃，皆讹略也。今或顺古，亦云涅槃。’在声闻乘中，涅槃只有两种：（1）有余依涅槃，依指有漏的依身，对于已尽的惑业说名为余：即生死之因的惑业已尽，犹余有漏依身的苦果，故名有余依。（2）无余依涅槃，即更灭尽依身的苦果，无有所余，故名无余依。住于现世还未入灭的阿罗汉，已断尽生死之因的惑业，证得寂灭的涅槃。以其尚有宿业所感的依身存在，故只得有余依涅槃。至依身亦灭，毕竟不起不生，即得无余依涅槃。
    （二）智德
    如上所说阿罗汉，已到究竟无学位，成就十无学法，即无学正见、正思惟、正语、正业、正命、正精进、正念、正定、正解脱、正智。这十无学法的意义，已于第一章第四节四谛之道谛的究竟道中略说，可因翻译复习。这里只说诸圣所成就的智慧，和智慧所成就的功德。
    甲、成智差别
    智的差别异名很多，如见、明、觉、解、慧、光、观、照等，皆是智的异名，简单地可以类括为忍、智、见三个名称。忍智见都是以慧心所为体，就其作用的不同，而安立三名的差别。即依慧心所有推度的作用，立名为见：有推度忍可的作用，立名为忍。于慧心所中，有是忍而非智的，如前面所说缘上下八谛的苦法智忍、苦类智忍等八种圣慧忍，正起推度，是可见性摄，与自疑得俱起，推度忍可未究竟故，未成决断，故是忍非智。又尽智与无生智，皆无学位所起的决断智，已止息求心，于境不推度故，是已决断之智，不可名见。除了前说的八忍与二智，其余的无漏诸慧，皆通智与见之二性，不可名忍；以彼既断自疑，故名为智；有推度性，故得名见。诸有漏慧，皆是智而非忍，因为忍是于从来未曾见过的四谛真理创见忍可，有漏慧对于无始以来的所缘境数数重观，故是决断智摄。在有漏慧中，身见、边见、邪见、见取见、戒禁取见五种染污见，与有漏的正见，共为六种，亦皆是见性所摄，以是推度性故。
    以上是说智的差别名称，此下说智的种类。智有十种：（1）世俗智，即世间普通人的智慧，多取瓶衣等事物为所缘境。（2）法智，以欲界四谛真理为所缘境，作十六行相，即断迷欲界四谛真理所起的烦恼之智。（3）类智，缘上二界的四谛真理，亦作十六行相，即断迷上二界四谛真理所起的烦恼之智。（4）苦智，（5）集智、（6）灭智，（7）道智。此四智由缘四谛境有差别故，分为四智，各对谛作四种行相，如其次第断四谛下所起的烦恼。（8）他心智，此智由前世俗智、法智、类智及道智四种而成立，能知他心，故名他心智。若知他有情的无漏心，以法、类、道他心智去了知，这是属于无漏性质的他心智。若知他有情的有漏心，以世俗他心智去了知，这是属于有漏性质的他心智。故他心智由四智所成。（9）尽智，（10）无生智。此二智都是无学位的圣者所起。即无学位，若正自知：我已知苦，我已断集，我已证灭，我已修道；有此尽行相之智，是名尽智。若正自知；我已知苦，不复更知；我已断集，不复更断；我已证灭，不复更证：我已修道，不复更修；于四谛知、断、证、修的作用，得了非择灭名无生，观此无生之智，是名无生智。此尽智与无生智，即以前法智、类智、苦智、集智、灭智、道智六种智为体。阿罗汉中的钝根罗汉，由于有退堕故，不能生无生智。利根的不动阿罗汉，无退堕故，能生无生智。上说十智，总分为有漏无漏两类：一有漏智，即第一种世俗智，遍缘一切有为无为之法为所缘境，是与烦恼杂染俱生的智慧，不能断迷理的惑障，故是有漏智，二无漏智，即法智等九种，是远离了烦恼过失的清净无垢的智慧，故是无漏智。
    在十智之中，从凡夫到圣者，谁成就几智呢？依《俱舍论．分别智品》说的差别是：（1）从凡夫位至圣见道十五心中的第一念苦法智忍位，此诸凡夫及初念圣者，皆定成就一智，即世俗智。初念圣人，虽然已经成就无漏慧的苦法忍，但尚未决断，是忍非智，故于十智中，只成一智。（2）入见道至第二念苦法智位的圣者，定成三智：1.世俗智，2.法智，3.苦智。（3）入见道至第四念苦类智位的圣者，于前三智之上，增加类智，总成四智。（4）入见道至第六念集法智位，于前四智之上，又增集智，总成五智。（5）入见道至第十念灭法智位，于前五智之上，又增灭智，总成六智。（6）入见道至第十四念道法智位，于前五智之上，更增灭智，总成七智。由上所说可以知道，见道位人总成七智。（7）至修道位的圣者，若尚未全离欲界修惑，亦定成七智，与见道位相同。（8）若已离欲位，成前七智之外，更增他心智，总成八智。若在凡夫位时已离欲界修惑者，及见道位乃至修道位，则一一位中皆增一他心智。（9）无学钝根圣者，定成九智，即时解脱阿罗汉，于十智中除去无生智，成就余九智。（10）无学利根的不时解脱阿罗汉，定成十智。
    乙、智所成功德
    {1}唯圣功德
    在声闻圣者成就的诸功德中，有唯圣功德和共凡功德两类。唯圣功德，即诸无漏功德，唯诸圣者才能成就。共凡功德，则凡夫亦可具有。这里先说几种唯圣功德。
    （1）无诤行，利根的不动阿罗汉，在行动之前，观察有情诸苦，那是由烦恼所生，自知己身是殊胜福田，恐他有情复缘己身引生贪嗔等烦恼而招苦果，故思引发无诤相智，由此方便，令他有情不缘己身生贪嗔等。此行能止息诸有情类烦恼斗诤，故名无诤。此行但以俗为体性，第四静虑为其所依。六种无学中，唯利根不动阿罗汉能生起无诤智。退法等五种阿罗汉，尚不能自防不退起烦恼过失，故亦不能止息他有情的烦恼斗诤。
    （2）愿智，利根不动阿罗汉，欲知诸法自相共相，或过去未来现在三世事等，以求知的愿力为先，入第四静虑，引起胜妙的智慧，即于诸法的自相共相等，能够如愿而了知，是愿之智，故名愿智。此智亦是俗智为体，以第四定为依，唯不动性阿罗汉能起。以一切法为所缘境，皆现量如实而知。
    （3）三明，即：1.宿命明，但知过去宿世受生的事，名宿命通；复知宿世从一生乃至多生的族姓名字，及所经历的事情和受苦受乐等，是为宿命明。2.天眼明，但知有情死此生彼，名天眼通；复见自己和众生死时生时，及一切所作善恶业行，和由此业生于善恶趣的那一趣中，是为天眼明。3.漏尽明，但知自已他人的有漏烦恼断尽，名漏尽通；复能悉知漏尽以后更不受于生死，是为漏尽明。三明皆以慧为性。如其次第即以六通中有殊胜作用的宿命通、天眼通、漏尽通为体。由于此三通能对治前后中三际愚痴故，特建立为三明。即宿命通能对治前际愚，天眼通能对治后际愚，漏尽通能对治中际愚，后一种容有是真，因为是无漏故。其余二种，但是假说。三明唯在无学身中起，故皆名无学明，有学身中虽有知宿命的智和知生死的天眼智，以尚有暗惑未尽，但可名通，不得立之为明。
    （4）四无碍解，无碍解有四种：1.法无碍解，2.义无碍解，3.辞无碍解，4.辩无碍解。此四无碍解，总起来说，皆以利根不退种姓阿罗汉所发于自分境不退转的无退智为自性。其中缘能诠名句文身的无退智，立名法无碍解。此无碍解通依五地起，即欲界及四静虑，无色界无名等故。缘所诠义理的无退智，立名义无碍解。此通依一切地，即依九地起。缘方域言辞的无退智，立名辞无碍解。此唯依二地生起，即欲界和初静虑；二禅以上，都无寻伺故。缘契合正理的无滞言说，及起此言之因的定慧二道的无退智，立名辩无碍解。此无碍解，亦通依一切地起。由无退智缘名等决断无碍，故皆名无碍解。以十智摄说，法无碍解与辞无碍解，十智之中，唯以世俗智为体：因为这两种无碍解，是缘名身等及世间言辞事相为境界故，所以唯属世俗智摄。义无碍解，若以诸法皆名为义，则具十智为体，若唯以涅槃名之为义，则以六智为体：一世俗智、二法智、三类智、四灭智、五尽智、六无生智。辩无碍解，九智为体；于十智中除去灭智，以缘有为法故。此四种无碍解，唯利根阿罗汉能成就。随得一种时，必皆具四。
    {2}共凡功德
    与凡夫共同的功德，有六通、四静虑、四无色定、三三摩地、四无量、八解脱、八胜处、十遍处等。四静虑和四无色定，如前第一章第四节中已说，今略述六通等义如下：
    （1）六通是：1.神境智证通，即能领受和示现种种神妙境界的智用，如身能无碍地飞行于山间海内，于此界入，从彼界出，由彼界没，于此界现，于大作小，于小作大，随意变现等。2.天眼智证通，能见六道众生死此生彼，受苦受乐等相，及见一切世间远近种种形色无有障碍。3.天耳智证通，能听闻六道众生心中所念的事情，皆能如实了知。5.宿住随念智证通，能忆念自己过去一世乃至多世宿命和所经历的事。6.漏尽智证通，漏即贪嗔痴等烦恼，烦恼断尽，不受三界生死，无碍自在，是名漏尽通。六通之中，后一种唯圣人有，前五种通凡夫亦得。故《俱舍论》中，依其总相说名为共凡功德，如是六通，解脱道摄，皆以智慧为体。神境等四通，唯世俗智摄，他心通五智所摄，即法智、类智、道智、世俗智、他心智。漏尽通由六智或十智摄，若但缘漏尽为境，则除苦、集、道、他心四智，以余六智为体。若漏尽身中所得，则以十智为体。
    【注】此处原书中漏列‘他心智通’一项，今补注如下：‘四、他心智证通，能知他人之心念而无碍者。’（依丁福保‘佛学大辞典’）[出版者注]
    （2）三三摩地是：1.空三摩地，即缘苦谛中空和非我两种行相相应的等持。空是空我所，非我空其我，故二行相，俱得名空。2.无愿三摩地，即缘十种行相相应的等持，十相即缘苦谛中的非常与苦二相，和集谛下因、业、生、缘四相，及道谛下道、如、行、出四相。非常相与苦相，和集谛下四相，都是可厌患的，故于彼无所愿乐欣求；道谛如船筏，必应舍故，亦无愿乐。故能缘彼定，得无愿之名。3.无相三摩地，即缘灭谛下灭、尽、妙、离四种行相相应的等持。灭谛即涅槃，涅槃远离色、声、香、味、触、男、女、生、异、灭十相，故名无相。缘彼之定，故得名无相三摩地。此上三种等持，俱通净有漏和无漏。无漏性的三种等持，又名三解脱门；能与解脱的涅槃为入门故。
    （3）四无量心，即慈、悲、喜、舍四种。第一慈无量心，即与乐作意相应，与诸有情乐之心，以无嗔为体，能对治嗔恚烦恼。由于一切有情心起爱念，随彼所求乐事，给予饶益，故名慈无量心。第二悲无量心，即除苦作意相应，拔除有情苦之心，以不害为体，能对治害烦恼。由愍念一切有情受种种苦，常怀悲心，拯救济拔，令其得脱，故名悲无量心。第三喜无量心，即欣慰作意相应，见诸有情离苦得乐，生大喜心；以喜受为体，能对治不欣慰。由于见诸有情离苦得乐，庆慰欣喜，故名喜无量心。第四舍无量心，即平等作意相应，于诸有情一视平等，无亲怨分别之心；以无贪无嗔二法为体，能对治欲界的贪嗔烦恼。由于所缘一切有情，心无爱憎，住平等舍，故名舍无量心。这四种心为什么皆名无量呢？依《俱舍论》和《大毗婆沙论》八十一卷说：1.以无量有情为所缘故，2.能引生无量善法故，3.能招感无量殊胜异熟果故。具此三义，故名无量。至于只立四种无量的道理和修习方法等，广如《俱舍论定品》、《大毗婆沙论》八十一卷、《瑜伽师地论》第十二卷及四十四卷所说应知。
    （4）八解脱是：1.内有色想观外色解脱，即于内身有色想之贪着，为令遣除，观外界不净的青瘀等色相，令贪不起，故名解脱。2.内无色想观外色解脱，即由前观虽已除遣内色之贪，于内身无色想贪着，为令坚牢故，亦观外界不净的青瘀等色相，令贪不起，故名为解脱。3.净解脱身作证具足住，即观净光鲜白的清净色相，令贪不起，名净解脱；观净色的人，证得此净解脱于身中，名身作证；具足圆满，得住此定，故名具足住。4.空无边处解脱，5.识无边处解脱，6.无所有处解脱，7.非想非非想处解脱。此四解脱，各能弃舍下地的贪，名为解脱。8.灭受想定解脱身作证具足住，此即灭尽定由此定厌背受想等，住于无心，故名解脱。八解脱中，前三种以无贪善根为体，以近能对治贪故。四无色处解脱，以四无色的善定为体。第八解脱，体即灭定。此中所说的解脱，不是灭尽烦恼，证得离系名解脱，而是弃背义，背舍义名为解脱。《大毗婆沙论》八十四卷说：‘问：何故名解脱？解脱是何义？答：弃背义是解脱义。问：若弃背故名解脱者，何等解脱，弃背何心？答：初二解脱，弃背色贪心。第三解脱，弃背不净观心。四无色处解脱，各自弃背次下地心。想受灭解脱，弃背一切有所缘心。’
    （5）八胜处是：1.内有色想观外色少，2.内有色想观外色多。3.内无色想观外色少，4.内无色想观外色多，5.内无色想观外色青，6.内无色想观外色黄，7.内无色想观外色赤，8.内无色想观外色白。这八胜处是从八解脱中的前三种解脱开出来的，所以体性境地等，都同于前三解脱。故《俱舍论》说：‘初二如初解脱，次二如第二解脱，后四如第三解脱。’观外色少多等，即于外界清净妙好的胜色和不净恶陋的劣色，意解思惟，用奢摩他道起胜知，用毗婆舍那道起胜见，具此胜知胜见能制伏所缘的境，随所乐观，自在而转，惑终不起，心胜境处，故名胜处。修八解脱，唯能弃背贪心，不能制境，此八胜处，能制伏所缘之境，故更殊胜。
    （6）十遍处是：1.地大遍一切处，2.水大遍一切处，3.火大遍一切处，4.风大遍一切处，5.青色遍一切处，6.黄色遍一切处，7.赤色遍一切处，8.白色遍一切处，9.空无边遍一切处，10.识无边遍一切处。这十遍处中的前八种遍处，如八解脱中的第三‘净解脱身作证具足住’一样，以无贪为体，皆依第四静虑，缘可见的假四大和四显色为境。后二遍处，如其次第以空识二无边处善定为体，各缘自界的四蕴为境。此十为什么立名为遍处呢？《俱舍论》说，由修观行者起胜解作意，‘于一切处，周遍观察，无有间隙，故名遍处。’修此十遍处，比前解脱胜处更为殊胜。如《俱舍论颂疏》说：‘应知此中修观行者，从诸解脱，入诸胜处；从诸胜处，入诸遍处；以后后起，胜前前故，谓修解脱。但于所缘总取净相，未能分别青黄赤白；后四胜处，虽能分别青黄赤白，而未能作无边行相：前四遍处，谓观青等（《大毗婆沙论》八十五卷和一百四十一卷都把青黄赤白列为前四遍处）一一无边。复思青等为何所依？知依大种故，次观地等一无边。复思此所觉色，由何广大？知由名空故，次观空无边处。复思此能觉谁为所依？知依广识故，观识无边处。此所依识，无别所依故，别更不修上为遍处。


一、略说大乘名义及其殊胜

    第四章 菩萨行果
    第一节 菩萨乘的发心和誓愿
    一、略说大乘名义及其殊胜
    梵语‘菩提萨埵’，略言菩萨，义译觉有情。‘菩提’是觉义，即智所求果；‘萨埵’是有情义，即悲所度生。就是以大智上求无上正觉果，以大悲利益安乐一切有情，具有这种自觉觉他的修行者，是名菩萨。菩萨法是佛教三种乘中的大乘，如《大集经》说：‘其乘广大，故名大乘。’乘是运载义，菩萨所乘的因行果德俱大，故《摄大乘论．无性释》说：‘亦乘亦大，故名大乘。’《瑜伽师地论》和《显扬圣教论》等，都以七种大性相应解释大乘的意义。即：一、法大性，菩萨法是十二分教中，属于断除二障，利乐有情，获得无上佛果的方正广大的教法所摄。二、发心大性，修学菩萨行的有情，已于无上正等菩提发起广大的正愿心。三、胜解大性，菩萨于大乘方广教法，已生起坚定忍可，不可转移的殊胜信解。四、增上意乐大性，一类菩萨已超过胜解行地，证入清净无漏的殊胜意乐地。五、资粮大性，由于修集无量的福德智慧二种广大资粮，圆满时即能证得无上正等菩提。六、时大性，修菩萨行者，要经于三无数大劫，才能证得无上正等菩提。七、圆证大性，菩萨所证无上菩提，是最极圆满无上的大果。前六种大性，是圆证大性的因，圆证大性是前六种大性的果。
    因为苦萨乘的境、行、果都是无上的，所以又称为无上乘。如《辩中边论．辩无上乘品》说：‘此大乘中，总由三种无上义故，名无上乘。三无上者：一、正行无上，二、所缘无上，三、修证无上。’
    诸经论中，还就大乘法的殊胜体用，标列许多异名。如《华严经．如来出现品》说：‘汝等当知，过二乘位，更有胜道名为大乘。菩萨所行，顺六波罗蜜，不断菩萨行，不舍菩提心，处无量生死而不疲厌，过于二乘，名为大乘、第一乘、胜乘、最胜乘、上乘、无上乘、利益一切众生乘。’
    大乘法是最极殊胜的法门，如《大宝积经．胜鬘夫人会》说：‘一切声闻独觉，世出世间所有善法，皆依大乘而得生长。’又如《大集经．海慧菩萨品》说：‘诸乘之中大乘最，犹如虚空无边际，远离一切生死有，趣菩提树无障碍。于诸众生心平等，常观烦恼诸罪过，能胜一切下劣乘，调伏众生于大乘。所有一切世间法，及以无上出世法，若有学法无学法，一切摄于大乘中。若欲了知众生行，一切众生诸界根，菩萨一念能通达，是故大乘难思议。若有人能行大乘，是则不断三宝种，能为众生作利益，破坏贫穷诸苦恼。能到十方诸世界，现见无量佛世尊，如是趣向大乘者，是人即得无量福。一切世间无能胜，趣向无上大乘者，具足大力坏众魔，是故大乘难思议。’
    《摄大乘论》中，以十种殊胜赞说大乘：一、所知依殊胜，二、所知相殊胜，三、入所知相殊胜，因、彼入因果殊胜，五、彼因果修差别殊胜，六、增上戒殊胜，七、增上心殊胜，八、增上慧殊胜，九、彼果断殊胜，十、彼果智殊胜。此中阿赖耶识，说名所知依体。三种自性（一依他起自性，二遍计所执自性，三圆成实自性），说名所知相体。唯识性，说名入所知相体。六波罗蜜多，说名彼入因果体。菩萨十地，说名彼因果修差别体。菩萨律仪，说名增上戒体。首楞伽摩虚藏等诸三摩地，说名增上心体。无分别智，说名增上慧体。无住涅槃，说名彼果断体。三种佛身（一自性身，二受用身，三变化身），说名彼果智体。以上十种殊胜相，声闻乘的教法中不曾见说，唯大乘法中处处见说，故十相即显大乘体大，亦显最胜。
    从上经论赞说大乘的殊胜乘，可以信知大乘确是最极殊胜的无上教法。修学佛法的人们，无论从希求圆满究竟的解脱果说，从利益安乐一切有情说，从绍隆三宝住持正法说，都应该以大乘教理行果为学修求证，才能算是一个真实的佛子，也才是一个具有伟大志愿的学佛者。《大集经．海慧菩萨品》说：‘声闻宝中不出三宝，三宝要从菩萨宝出。’《大般若经》卷一百三十说：‘若教有情令趣无上正等菩提，则令世间佛眼不断。所以者何？由有菩萨摩诃萨故，便有预流、一来、不还、阿罗汉果、独觉菩提。由有菩萨摩诃萨故，便有如来应正等觉证得无上正等菩提。由有菩萨摩诃萨故，便有佛宝、法宝、僧宝一切世间皈依供养故。’于此等经义，学佛者应深思之。


二、菩提心

    二、菩提心
    菩提心是菩萨行的根本法，至极重要。今依据经论方述十五义如下：
    （一）重要：修学菩提道，首先必须发起菩提心。由有发心，才能有目的地欣求趣向，修习福德智慧两种资粮，断除烦恼所知二障，证得无上菩提涅槃，故《华严经》说菩萨十种住中第一为发心住。《成唯识论》说菩萨十资粮位‘从发深固大菩提心’。由发心故，入于阿僧祇数。趣入大乘之门，正行菩萨道，有菩提心，是真实的大乘菩萨；没有菩提心，纵然有通达无我的智慧，也是小乘人。故菩提心是成佛的根本，也是大小乘人的区别法。《大集经．虚空藏菩萨品》说：‘菩提心是安一切佛法根本，一切法住菩提心故，便得增长。’《华严经．入法界品》说：‘发阿耨多罗三藐三菩提心，是人难得，若能发心，是人则能求菩提行。’经七十八卷又说：‘欲修菩萨一切行愿，先当发起菩提之心。’《出生菩提心经》说：‘若有众生等，欲转于法轮，欲触上菩提，须发菩提心。’《瑜伽师地论．菩萨地》说．‘又诸菩萨初发心已，即名趣入无上菩提，预在大乘诸菩萨数。此据世俗言说道理，是故发心趣入所摄。又诸菩萨，要发心已，方能渐次速证无上正等菩提，非未发心。是故发心能为无上菩提根本。’
    （二）受法：菩萨为欲利益十方世界一切有情，于阿耨多罗三藐三菩提发誓求证，故发菩提心是极其尊重庄严伟大的矢志大事，应以真诚纯洁欢喜踊跃的清净意乐请师作证受发。《显扬圣教论》说受发心有两种，如彼论说：‘此受发心，复有二种：一、世俗发心，二、证法性发心。世俗发心者，谓如有一随智者前恭敬而住，起增上意，发誓愿言：长老忆念，或言圣者忆念，或言邬波柁耶，我如是名，从今日始，发阿耨多罗三藐三菩提心，为欲饶益诸有情故。从今已往，凡我所修布施、持戒、忍辱、正勤、静虑及慧，一切皆为证得阿耨多罗三藐三菩提故。我今与诸菩萨摩诃萨和合出家，愿尊证知我是菩萨。第二、第三亦复如是。证法性发心者，谓如有一已过第一劫阿僧企耶，已证菩萨初极喜地，已入菩萨定无上位，已如实知无上菩提及菩提方便，已悟自身将近等近大菩提果，证解自他悉平等故得大我意，已至不住流转寂灭菩萨道故得四广大意。由如是故，于大菩提愿不退转，是谓证法性发心。’证法性发心是约地上菩萨说，初发心人，只可依第一种世俗发心受发。
    （三）体性：大菩提心，从自性出体来说，即以别境中的善性欲心所为其体性。如《瑜伽师地论．菩萨地》说：‘菩萨最初发心，于诸菩萨所有正愿是其初正愿，（此于菩萨五正愿中依顺次数，说名为初。五正愿是：一、发心愿，二、受生愿，三、所行愿，四、正愿，五、大愿，是名菩萨所有正愿。如《瑜伽师地论》四十五卷说。）普能摄受其全正愿；是故发心，以初正愿为其自性。’初正愿就是‘定自希求无上菩提，及求能作有情义利’的发心愿。体即希求为相的欲心所。若约显胜义说，即以欲心所相应的最胜第六意识心王为体。故《现观庄严论略释》说：‘一谓发菩提心，即为利他而希求大菩提欲相应所起入大乘门所显之最胜第六意识心王，是大乘发心之相。界限从大乘资粮道，乃至佛地。’成佛之后，于大菩提已证故，不再有希求，虽穷未来际利乐有情，但皆任运自在起，不作意加行故，亦无希求；因此，菩提心的希求相界限，只从大乘资粮道乃至佛地。
    从相应出体来说，大菩提心，即以信、精进、正念、正定、正慧为体。如《摄大乘论》在说明菩萨最初修行颂说：‘清净增上力，坚固心升进，名菩萨初修，无数三大劫。’《成唯识论述记》中引释这一颂文时说：‘大菩提心以善根为其自体，以大愿为缘，不退屈为其策发，方能发起故。善根力名清净力，是因；能降伏所治故。大愿力名增上力，是缘；常值善友故。坚固心升进者，虽遇恶友方便破坏，终不弃舍大菩提心，所修善根运运增长，大菩提心坚固不退，齐此方名初劫之始。’文中所说的善根，不是无贪等三善根，是指的信等五根，故大菩提心即以信进念定慧为其体性。
    （四）因缘：发菩提心，在诸论中说有种种因缘，但最能引发菩提心、巩固菩提心的根本法，是大悲心。如《优婆塞戒经》说：‘善男子！一切众生发菩提心，或有生因，或有了因，或有生因了因。汝今当知，夫生因者，即是大悲。因是悲故，便能发心，是故悲心为生因也。’《华严经．入法界品》说：‘发菩提心者，所谓发大悲心。’《大般涅槃经．梵行品》说：‘若于一众生，不生嗔恚心，而愿与彼乐，是名为慈善。一切众生中，若起于悲心，是名圣种姓，得福报无量。’《大集经．无尽意菩萨品》说：‘如人命根，即以出息入息为根本；菩萨如是修学大乘，以大悲为本。’《大毗卢遮那成佛神变经》说佛成就一切智智是以‘菩提心为因，大悲为根本，方便为究竟。’《瑜伽师地论．菩萨地》说：‘又诸菩萨悲愍一切有苦众生，为欲济拔发菩提心。是故发菩提心是悲等流。’《发菩提心论》说：‘菩萨发心，慈悲为首。’《大乘庄严经论》说：‘菩萨发心，以大悲为根本。’
    大悲的意义如《摄大乘论．无性释》说：‘言大悲者，谓于有情，利乐意乐。’此即显示大悲利益安乐为体。又说昼夜六时，常遍观世间一切有情善法增减等，平等地拔苦与乐，是大悲所作业用。悲依何义为大悲呢？《瑜伽师地论》四十四卷说：‘由四缘故，悲名大悲。一、缘甚深微细难了诸有情苦为境生故。二、于长时积习成故。谓诸菩萨，经于无量百千大劫，积习所成。三、于所缘猛利作意而发起故。谓诸菩萨，由如是作息，悲所执持，为息诸有情众苦因缘，尚能弃舍百千身命，况一身命，及以资财，于一切种治罚大苦，为诸有情，悉能堪忍。四、极清净故。谓诸菩萨，已到究竟菩萨清净。若诸如来，已到佛地如来清净。’
    大悲心要怎样才能生起呢？主要是由于观察世间众生诸苦。如《瑜伽师地论》四十四卷说：‘又诸菩萨，于大苦蕴，缘十九苦，发起大悲。何等名为十九种苦？一愚痴异熟苦，二行苦所摄苦，三毕竟苦，四因苦，五生苦，六自作逼恼苦，七戒衰损苦，八见衰损苦，九宿因苦，十广大苦，十一那落迦苦，十二善趣所摄苦，十三一切邪行所生苦，十四一切流转苦，十五无智苦，十六增长苦，十七随逐苦，十八受苦，十九粗重苦。’诸经中亦说菩萨恒以各种心观察众生而生起大悲。如《华严经．离世间品》说：‘佛子！菩萨摩诃萨以十种观察众生而起大悲。何等为十？所谓：观察众生无依无怙而起大悲，观察众生性不调顺而起大悲，观察众生贫无善根而起大悲，观察众生长夜睡眼而起大悲，观察众生行不善法而起大悲，观察众生欲缚所缚而起大悲，观察众生没生死海而起大悲，观察众生长婴疾苦而起大悲，观察众生无善法欲而起大悲，观察众生失诸佛法而起大悲，是为十。菩萨恒以此心观察众生。’
    大悲心不但是菩提心的根本，也是大乘佛法初中后三位的根本。初能引发大菩提心，令入大乘；中能坚固菩提心，不退菩萨行；后能不住涅槃，穷未来际常作一切有情的利益安乐事故。《无尽慧经》说：‘如人命根即以出入息为根本。菩萨如是修学大乘，以大悲为根本。’《大般涅槃经．现病品》说：‘三世诸佛尊，大悲为根本，若无大悲者，是则不名佛。’大悲心在大乘佛法中，既然如是之重要，因此，意欲发大菩提心者，当修大悲心。已正修学菩萨行的人，为了巩固菩提心，不退菩萨行，更应常修大悲心。
    其次，世亲菩萨在《发菩提心论》中说，菩萨将欲发心，须具足十种胜德，才能发起。如彼论说：‘若菩萨亲近善知识，供养诸佛，修习善根，志求正法，心常柔和，遭苦能忍，慈悲深厚，深心平等，信乐大乘，求佛智慧。若人能具如是十法，乃能发阿耨多罗三藐三菩提心。’
    复次《华严经．离世间品》说菩萨发菩提心由十种因缘。如彼经说：‘菩萨摩诃萨有十种发菩提心因缘。何等为十？所谓：为教化调伏一切众生故发菩提心，为除灭一切众生苦聚故发菩提心，为与一切众生具足安乐故发菩提心，为断一切众生愚痴故发菩提心，为与一切众生佛智故发菩提心，为恭敬供养一切诸佛故发菩提心，为随如来教令佛欢喜故发菩提心，为见一切佛色身相好故发菩提心，为入一切佛广大智慧故发菩提心，为显现诸佛力无所畏故发菩提心。是为十。’
    复次《大集经．不可说菩萨品》说众生成就十六法能发阿耨多罗三藐三菩提心：（1）常修上心，莹磨诸根；（2）勤修诸苦，庄严功德；（3）至心持戒，不生悔厌；（4）修集大悲，怜愍众生；（5）信佛世尊有大慈悲；（6）为诸众生受行诸菩；（7）能坏众生所有苦恼；（8）调伏诸根，具足正念；（9）心类所畏，不求诸有；（10）乐求佛智，不乐二乘；（11）受乐不慢，受苦无悔；（12）恭敬智慧，破坏骄慢；（13）知恩报恩；（14）具足身力；（15）护持正法；（16）不断三宝。
    又《瑜伽师地论．菩萨地》说，菩萨最初发心，由四种缘、四因、四力而能发菩提心。
    四缘是：（1）诸善男子或善女人，由于看见诸佛菩萨有不可思议的神通变化的威力，或虽未亲见诸佛菩萨的神变威力，由于听到可以信任的人说诸佛菩萨具有这种神变威力，于大菩提深生信解，因此发起大菩提心。（2）或有一类人，虽然不曾见闻过诸佛菩萨的神变威力等功德，由于听闻读诵菩萨藏教法，深生信解，为得如来微妙智故，发起菩提心。（3）或有一类人，见到菩萨藏教法将欲灭没，心中便作是念：菩萨藏法久住世间，能灭无量众生的大苦，我应当住持菩萨藏法，因此发起菩提心。此即为灭无量众生大苦故；为护持菩萨藏教法故；于如来智深生信解，为得如来微妙智故，而得发心。（4）或有一类人，虽不由观见正法欲灭，而是于末劫见诸浊恶众生身心为十种随烦恼之所恼乱，即：多愚痴、多无惭愧、多诸悭嫉、多诸忧苦、多诸粗重、多诸烦恼、多诸恶行、多诸放逸、多诸懈怠、多诸不信，见到这些事相后，便作这样想念：大浊恶世众生，为诸随烦恼所恼乱时，能够发起下劣的声闻、独觉菩提心，尚且难得，于无上大菩提心岂能发起？我应当发大菩提心，令无量有情随我学习，发起大菩提愿。此即由见末劫发心人难得而发菩提心。
    四因是：（1）由诸菩萨具足菩萨种姓，是名第一初发心因。（2）由诸菩萨依赖佛和菩萨为善友摄受，是名第二初发心因。（3）由诸菩萨于诸众生多起悲心，是名第三初发心因。（4）由诸菩萨于极长远时间的生死大苦难行苦行无有怯畏，是名第四初发心因。
    四力是：一者自力，二者他力，二者因力，四者加行力，谓诸菩萨由于自己功力，能于无上正等菩提深生爱乐，是名第一初发心力。又诸菩萨由于他人功力，能于无上正等菩提深生爱乐，是名第二初发心力。又诸菩萨由于宿世修习大乘相应善法为因，今世暂时得见诸佛菩萨，或暂时得听闻别人对于佛菩萨的功德称扬护叹，即能发起大菩提心，是名第三初发心力。又诸菩萨于现法中，亲近善士，听闻正法，于所闻正法义理审谛思惟等，长时修业种种善法，由这些加行力发起大菩提心，是名第四初发心力。
    （五）行相：菩提心以希求为行相。希求有二：（1）求无上菩提，（2）求利益众生。如《瑜伽师地论．菩萨地发心品》说：‘又诸菩萨起正愿心求菩提时，发如是心，说如是言：愿我决定当证无上正等菩提，能作有情一切义利，毕竟安处究竟涅槃及以如来广智中。如是发心，定自希求无上菩提，及求能作有情义利。是故发心，以定自希求为行相。’
    《大乘庄严经论》分别菩萨发菩提心相说：‘菩萨发心有四种大：一、勇猛大，谓弘譬精进甚深难作，长时随顺故。二、方便大，谓被弘譬铠已，恒时方便勤精进故。三、利益大，谓一切时作自他利故。四、出离大，谓求无上菩提故。复次：此四种大，显示三种功德。第一第二大显示作丈夫所作功德，第三大显示作大义功德，第四大显示受果功德。此三功德以二义为缘，所谓无上菩提及一切众生；由此思故发菩提心。’这也是说菩提心以希求无上菩提及希求利益一切众生为相。
    《华严经．入法界品》说菩萨发大菩提心是：‘欲教化调伏一切众生悉无余故，发菩提心。欲承事供养一切诸佛悉无余故，发菩提心。欲严净一切诸佛国土悉无余故，发菩提心。欲护持一切诸佛正教悉无余故，发菩提心。欲成满一切如来誓愿悉无余故，发菩提心。欲往一切诸佛国土悉无余故，发菩提心。欲入一切诸佛众会悉无余故，发菩提心。欲知一切众生心海悉无余故，发菩提心。欲知一切众生根海悉无余故，发菩提心。欲知一切众生业海悉无余故，发菩提心。欲知一切众生行海悉无余故，发菩提心。欲灭一切众生诸烦恼海悉无余故，发菩提心。欲拔一切众生烦恼习海悉无余故，发菩提心。’这经是说菩萨以许多的方便行，发起菩提心。但概括起来说，也只是求证无上菩提及求利一切众生两种善胜意乐。由此可以知道，诸大乘经论所说菩萨发心虽有种种所欲所为，综集起来，不外是‘为利有情愿成佛’！皆以决定希求二利为发菩提心的行相。
    （六）所缘：菩提心既然是以希求为行相，则其所缘甚可了知，即恒以所求所度而为所缘。所求即无上正等菩提，所度即一切众生，故菩提是以大菩提及诸有情义利为所缘境。如《华严经．净行品》说：‘常欲利乐诸众生，庄严国土供养佛，受持正法修诸智，证菩提故而发心。’《瑜伽师地论．菩萨地》说：‘又诸菩萨缘大菩提及缘有情一切义利发心希求，非无所缘。是故发心以大菩提及诸有情一切义利为所缘境。’
    （七）功德：菩萨发心，从所求上说，不为人天福报，不为声闻缘觉，唯为证得无上正等菩提。从所度众生说，不为一个众生而发心，不为十个百个众生而发心，不为千万个众生而发心，乃为利乐一切世界一切众生而发心。既上所求者，至极无上；下所度者，无量无边；以无限量的心，求无上果，度是无量众，故菩提心的功德胜利也是无上无量的。如《大集经．宝女品》说：‘若乐喜发菩提心，如是乃能断恶有，能为人天开正路，能闭八难邪险径。诸根具足不盲聋，皆由至心发菩提。能见十方诸佛尊，能闻无上甘露味。若能至心发菩提，是人能破疑骄慢。无量智慧得自在，能为众生说法界。众生见之如父母，亦如良医师友想。能疗众生烦恼病，教诲令趣菩提道。’《瑜伽师地论．菩萨地》说：‘最初发心坚固菩萨，由初发心求菩提故，所摄善法比余一切所摄善法有二种胜：一者因胜，二者果胜。谓诸菩萨所摄善法，皆是无上正等菩提能证因故，所证无上正等菩提是此果故，比余一切声闻独觉所摄善法尚为殊胜，何况比余一切有情所摄善法。’又说：‘最初发心坚固菩萨有二种发心胜利：一者，初发菩提心已，即是众生尊重福田，一切众生皆应供养，亦作一切众生父母。二者，初发菩提心已，即能摄受无恼害福。由此菩萨成就如是无恼害福，得倍轮王护所守护。由得如是护所护故，若寝若寤若迷若闷等，一切魍魉药叉宅神人非人等不能娆害。’《华严经．十住品》说：‘发心功德不可量，充满一切众生界，众智共说无能尽，何况所余诸妙行。’《发心功德品》又说：‘众生心行可数知，国土微尘亦复然，处空边际乍可量，发心功德无能测。’《发菩提心论》说：‘如来说言：如诸菩萨最初发心下劣一念果报，百千万劫说不能尽，况复一曰一月一步乃至百步所习诸心福德果报，岂可说尽。何以故：菩萨所行无尽，欲令一切众生皆住无生法忍，得阿耨多罗三藐三菩提故。’《华严经．入法界品》说：‘善男子！菩提心者，成就如是无量功德。举要言之，应知悉与一切佛法诸功德等。何以故？因菩提心出生一切诸菩萨行，三世如来从菩提心而出生故。是故善男子，若有发阿耨多罗三藐三菩提心者，则已出生无量功德，普能摄取一切智道。’《大集经．宝女品》说：‘如恒河沙等世界，满中妙宝持用施，虽有如是无量福，不如怜愍发菩提。无量亿等恒沙佛，净妙香花以供养，如是福德尤不如，发菩提心七单步。’《大集经．海慧菩萨品》又说：‘若有能发菩提心，是则能胜一切乘，能净一切众生心，亦能演说无上道。’诸大乘经论中，说到菩提心的功德与诸余功德较量胜劣处，都是以最胜、最高、最上、最妙、无量、无边、不可思议等来赞叹菩提心。说如恒河沙等众生悉住声闻独觉乘，欲比菩萨初发菩提心的功德，百分千方乃至百千万亿分不可为喻。如《大般若波罗蜜多经》卷三百六十四说：‘尔时具寿善现白佛言：世尊！若菩萨摩诃萨普为度脱诸有情故，初发无上正等觉心，获几许所福？佛言：善现！若诸菩萨摩诃萨普为度脱诸有情故，初发无上正等觉心，其所获福无量无边，算数譬喻所不能及。善现！假使充满小千世界一切有情皆趣声闻或独觉地，于意云何？是诸有情其福多否？善现的答言：甚多，世尊！甚多，善逝！彼所获福无量无边。佛言：善现！彼所获福，于为度脱一切有情初发无上正等觉心一菩萨摩诃萨所获福聚，百分不及一，千分不及一，百千分不及一，俱胝分不及一，百俱胝分不及一，千俱胝分不及一，百千俱胝那庾多分亦不及一。何以故？善现！声闻独觉皆因菩萨摩诃萨有，非菩萨摩诃萨因诸声闻独觉而有。’如是广说乃至假使充满三千大千世界一切有情皆住独觉地，其所获福比之于初发菩提心的功德也是百千俱胝那庾多亦不及一。这样的胜劣校量，在《华严经》、《大集经》、《宝积经》、《报恩经》、《出生菩提心经》、《佛说发菩提心破诸魔经》等经和诸大乘论中皆广有所说。
    （八）譬喻：世亲菩萨的《发菩提心论》中，在赞叹菩提心的功德的最后说：‘假令无量一切诸佛于无量阿僧祇劫，赞其功德亦不可尽。何以故？是菩提心无有齐限，不可尽故。’由于菩提心的功德说不可尽，故诸经论中施设种种譬喻，以显示它少分功德威力，令诸见闻众生，生起欢喜希求，发起大菩提心。故譬喻施设，大有胜妙作用。这里依《大乘庄严经论》所说二十二喻，略显菩提心的殊胜。（1）譬如大地，能生长万物；菩提心亦如是，于一切佛法能生长摄持故。（2）譬如净金，色质不坏；菩提心亦如是，利益安乐一切有情永无退坏故。（3）譬如新月，渐增圆明；菩提心亦如是，与勤相应，于一切善法渐渐增长故。（4）譬如增火，火势炽盛；菩提心亦如是，以智火烧诸烦恼，愈修智力愈胜故。（5）譬如大藏，取物无尽；菩提心亦如是，修行而施波罗蜜多，周济有情亦无尽故。（6）譬如宝矿，出生种种珍宝；菩提心亦如是，修持净戒波罗蜜多，出生种种功德故。（7）譬如大海，能容受一切；菩提心亦如是，修习忍辱波罗蜜多，虽遭遇违逆众缘，皆能忍受，心不动故。（8）譬如金刚，坚不可坏；菩提心亦如是，修习精进波罗蜜多，勇猛坚牢，他不能坏故。（9）譬如山王，无物能动；菩提心亦如是，修习静虑波罗蜜多，于诸境相，心不散乱故。（10）譬如药王，能治诸病；菩提心亦如是，修习般若波罗蜜多，能对治烦恼所知二种障故。（11）譬如善友，不舍友人；菩提心亦如是，修习四无量心，一切时候不舍众生故。（12）譬如如意珠，随所欲求皆能满足；菩提心亦如是，修习四摄法成熟众生故。【出版者注】（14）譬如美乐，能吸引听者；菩提心亦如是，与四无碍辩相应，说法教化，能摄引众生故。（15）譬如国王，能制定国法；菩提心亦如是，演说正量，能为正道不坏因故。（16）譬如仓库，是财物聚积处；菩提心亦如是，修习福智二种资粮，能聚积无量财法故。（17）譬如王路，王者先行，余人随行；菩提心亦如是，修习菩提分法，是大圣世尊先所行道，余人随行故。（18）譬如车乘，二轮具足，能到处去；菩提心亦如是，止观相应，能往安乐处故。（19）譬如涌泉，取水无尽；菩提心亦如是，总持门相应，闻法者虽多，说法无尽故。（20）譬如喜声，众生爱乐听闻；菩提心亦如是，说佛法印，希求解脱的众生爱乐听闻故。（21）譬如河流，其水自然；菩提心亦如是，自性相应，不起作意，无生法忍智自然流出。（22）譬如大云，能变现多种形相，注雨润泽万物；菩提心亦如是，能示八相成道，化度众生故。
    【出版者注】原书漏印了第十三喻，今谨依《大乘庄严经论》补录原文如下：‘譬如盛日，摄相应发心亦如是，如白熟谷，成熟众生故。’
    这二十二喻，是以菩提心与二十二法相应作用显示它的功德，故在《大乘庄严经论》中，每一譬喻都有‘相应’二字。第六喻原名‘宝筮’，为了立名含义更为明显，今依《现观庄严论略释》改名‘宝矿’。诸大乘经论中，称赞菩提心功德的譬喻很多，如《华严经．入法界品》、《大集经．海慧菩萨品》等皆广有所说，文长不录。
    （九）助法：已发大菩提心，还必须修习种种胜法来扶助它，才能坚固增长，直至取证无上菩提。在《悲华经》卷第五中，说有二十八种助菩提法，经说‘是名摄取助清净，度生死法门’。‘如是修行，即是系念得菩提’。二十八法是：（1）布施是助菩提法，以能调伏众生故。（2）持戒是助菩提法，由戒清净，随其所欲皆能成就故。（3）忍辱是助菩提法，是具足三十二相八十随形好的因故。（4）精进是助菩提法，能具足一切诸事教化众生故。（5）禅定是助菩提法，令心得善调伏故。（6）智慧是助菩提法，能知能断一切烦恼故。（7）多闻是助菩提法，于诸法中得无碍解故。（8）福德是助菩提法，成就一切众生之所须故。（9）智业是助菩提法，得具足无碍智故。（10）寂灭（静）是助菩提法，柔软善心得成就故。（11）思惟是助菩提法，成就断疑的慧业故。（12）慈心是助菩提法，于诸众生成就无碍心故。（13）悲心是助菩提法，拔除众生诸苦，教化众生心无厌故。（14）喜心是助菩提法，于正法中生爱乐故。（15）舍心是助菩提法，断除爱憎故。（16）听法是助菩提法，灭除五盖故。（17）出世是助菩提法，舍除一切世间故。（18）阿兰若是助菩提法，离诸匆务，灭不善业，增长善根故。（19）专念是助菩提法，得陀罗尼，成就总持故。（20）正意是助菩提法，成就善巧分别诸法的意识故。（21）摄持是助菩提法，成就思议之醒寤心故。（22）念处是助菩提法，成就分别身受心法的观慧故。（23）正勤是助菩提法，离一切不善法，修一切善法故。（24）如意足是助菩提法，成就身心轻利故。（25）诸根是助菩提法，摄取诸根，能生一切善法故。（26）诸力是助菩提法，摧灭一切烦恼故。（27）觉支是助菩提法，觉知如实法相故。（28）六和是助菩提法，调伏众生令清净故。除上二十八法外，在本经卷九更增说多种助菩提法，应取阅参考。
    （十）懈怠：已发大菩提心者，若不善护保任，近习诸障碍法，则成懈怠行者，不能速证无上菩提。《悲华经》卷五说菩萨有四种懈怠法，如彼经说：‘菩萨有四懈怠法，若菩萨成就如是四法者，贪着生死，于生死狱受诸苦恼，不能疾成阿耨多罗三藐三菩提。何等为四？下行、下伴、下施、下愿。云何菩萨下行？或有菩萨破身口戒，不能善护，是名下行。云何下伴？亲近声闻及辟支佛，与共从事，连名菩萨下伴。云何下施？不能一切舍诸所有，于受者中，心生分别，为得天上受快乐故而行布施，是名菩萨下施。云何下愿？不能一心愿取诸佛净妙世界，所作誓愿不为调伏一切众生，是名菩萨之下愿也。’
    又《瑜伽师地论》卷四十六说有五退分法，能令菩萨不能速证无上菩提。如彼论说：‘又诸菩萨，顺退分法当知有五：何等为五？一者，不敬正法及说法师：二者，放逸懈息：三者，于诸烦恼亲近执着：四者，于诸恶行亲近执着；五者与余菩萨校量功德起增上慢，及于法颠倒起增上慢。’
    （十一）退缘：《瑜伽师地论》卷三十五说：‘有四因缘，能令菩萨退菩提心。何等为四？一、种姓不具；二、恶友所摄；三、于诸众生悲心微薄；四、于极长时种种猛利无间无缺生死大苦难行苦行，其心极生怯畏惊怖。’
    又《大宝积经》卷七十七《富楼那会》说有四种法令菩萨退失菩提心：（1）由于菩萨亲近恶友故，令其远离佛法正行，损坏善根。恶友对菩萨说：‘你何用这样发菩提心呢？三界生死长远，苦恼无量，修菩萨行，希望成佛，是很艰难的事。若出家修菩萨行。则更为困难。劳心受苦，很是长远，你不要再修菩萨行了吧！况且，你又未曾经佛授过成佛的记，善根力量微弱，未得决定不退，不能决定得大涅槃，如此轮转五趣，岂不徒劳无益？’菩萨听了恶友这些说话，便心颓意丧，于菩萨行不复乐趣，由此退失菩提心而住于声闻乘了。（2）由于菩萨不听闻菩萨乘相应法藏，即宣说发菩提心胜利的经，摄持菩萨事相的经，六波罗蜜多广大行相应的经。由于不听闻故，即不能如经所说而行，不能如经所说而学。这种人，也不知道菩萨对什么法应亲近，对什么法应远离，对什么法应受持，对什么法不应受持。因为对于这些不知道，不能了达分别，所以对于菩萨应该亲近的法而不亲近，不应该亲近的法而去亲近。由于应该亲近的法而不亲近，不应该亲近的法而亲近故，菩提善根渐渐损减，内心回惶，意志衰颓，遂厌舍本愿，退失菩提心而住于声闻乘了。（3）由于菩萨对于诸法妄生异计，执有实法可得，贪著有我，或修行邪见，或堕在边见，或沉没在恶邪行中，难可拔出。偶得听闻无上甚深经教，本应悔悟，但应妄执深重，违逆不信，反生诽谤。以谤法罪故，死堕难处，无复见佛闻法，不复更修大乘。不值遇诸佛所教化众生的正法故，不得善知识故，亲近恶友，与共从事，忘失本念，舍菩提心而退住声闻乘了。（4）由于菩萨虽听闻甚深经典，其心退没，但乐独行，不愿为众生解说。以此悭惜佛法，不摄众生的不善因缘，失智慧念，不能思惟经典法义，与他人共同读诵，亦不堪任受持法分。这种人，到舍身命终，失菩提心，忘菩萨念而退住声闻乘了。
    （十二）守护：已发菩提心的菩萨行者，为了能够顺利地直证无上正等菩提，应当善于守护菩提心。《大般若经》中说，菩萨常勤守护菩提心，犹如世人守护独一的儿子，亦如瞎一目者护惜另一只好眼睛。因其善自守护，能无退屈地直得阿耨多罗三藐三菩提。《华严经》卷七十八说：‘如人护身，先护命根；菩萨摩诃萨亦复如是，护持佛法，亦当先护菩提之心。善男子！譬如有人命根若断，不能利益父母宗亲；菩萨摩诃萨亦复如是，舍菩提心，不能利益一切众生，不能成就诸佛功德。’菩萨若不守护菩提心，既不能真正地利益一切众生，亦不能证得无上菩提，而且还是可呵的欺诳众生的妄语者。如《法集经》卷三中，无所发菩萨告奋迅菩萨说：‘诸菩萨以实谛智以为法业。善男子！何者是实谛？善男子！菩萨发阿耨多罗三藐三菩提心，乃至舍身命，不舍彼心，不舍诸众生，是名菩萨摩诃萨实谛。善男子！若菩萨发阿耨多罗三藐三菩提心，又时舍心、舍众生者，如是菩萨则为可呵。是人名为最上妄语！’
    （十三）不退：菩萨行者，在认识到守护菩提心的重要意义之后，还必须修学圣教中所说的不退菩提心的方便行来巩固它，才能不会中途退失。《大宝积经》卷一百十一《弥勒菩萨问入法会》说，菩萨成就八法，能不退转大菩提心：（1）成就深心。若菩萨听闻他人赞叹佛法僧及毁訾佛法僧，于阿耨多罗三藐三菩提其心坚固不动，是为毕竟成就深心。（2）成就行心。若菩萨能毕竟远离杀生、偷盗、邪淫、妄语、恶口、绮语身语清净行，是为毕竟成就行心。（3）成就舍心。若菩萨能成施主，施诸有情衣服、饮食、卧具、医药，是为毕竟成就舍心。（4）成就善知回向方便心。若菩萨以身语意三业所修一切善根，皆悉回向阿耨多罗三藐三菩提，是为毕竟成就善知回向方便心。（5）成就大慈心。若菩萨成就大慈身业、大慈语业、大慈意业，是为毕竟成就大慈心。（6）成就大悲心。若菩萨成就不可讥嫌呵责的身业，不可讥嫌的语业，不可讥嫌呵责的意业，是为毕竟成就大悲心。（7）成就善知方便。若菩萨善知世俗谛，善知第一义谛，善知二谛，是为毕竟成就善知方便。（8）成就般若波罗蜜。若菩萨如是觉知：依于此法有故彼法有，此法生故彼法生，所谓无明缘行、行缘识等，如是唯有大苦聚集的缘起缘生道理；此法无故彼法无，此法灭故彼法灭，所谓无明灭则行灭，行灭则识灭等，如是唯有大苦聚灭的还灭道理：是为毕竟成就般若波罗蜜。经说菩萨成就上述八法，则‘不退阿耨多罗三藐三菩提，于胜进法中不退不转，行菩萨行时，降伏一切诸魔怨敌，如实知一切法自体相，于诸世间心不疲倦，以心不疲倦故不依他智，速疾成就阿耨多罗三藐三菩提。’
    又《思益梵天所问经》卷第一说：‘菩萨有四法，世世不失菩提心。何等为四？一者，常忆念佛：二者，所作功德，常为菩提；三者，亲近善知识；四者，称扬大乘。’
    又《大宝积经》卷一百十二《普明菩萨会》说：菩萨有四法，世世不失菩提心，乃至道场自然现前。何谓为四？失命因缘不以妄语，何况戏笑；常以直心与人从事，离诸谄曲；于诸菩萨生世尊想，能于四方称扬其名；自不爱乐诸小乘法，所化众生皆悉令住无上菩提。’
    已发菩提心的菩萨行者，既应现前善护菩提心勿令退失，也要决志依经教导遵行四法，誓愿生生世世皆不退失菩提心。又《大方广大集经》卷第十三说，菩萨修行三十二业，能终不退失菩提之心。诸爱乐菩萨行者，应取阅修学。
    （十四）增长：诸大乘经论中，广说增长菩提之法，若诸菩萨依教奉行，必能令菩提心迅速增长，决定得证无上正等正觉。这里录《大集经》所说三十二法如下：《大方等大集经》卷第十三说：‘善男子；有三十二法，向菩提心而得增长。何等三十二？一者，至心；二者，定心；三者，净；四者，欲心；五者，不放逸心；六者，修集善法；七者，庄严趣向无上菩提；八者，能以四摄摄取众生；九者，乐行方便；十者，调伏众生；十一者，能热众生；十二者，能知因缘；十三者，勤行精进；十四者，亲近善友；十五者，具足信心；十六者，具足信心故便生欢喜；十七者，供养恭敬师长、和上、有德之人；十八者，能瞻病苦；十九者，能善思惟：二十者，如法而住；二十一者，为护法故不惜身命；二十二者，成就总持；二十三者，具足念心；二十四者，能说深法；二十五者，具足智慧；二十六者，具足诸力；二十七者，愿于菩提；二十八者，不舍众生；二十九者，修集慈悲喜舍之心；三十者，游于生死，心不生悔；三十一者，为受身故庄严福德，为发净愿庄严智慧；三十二者，知一切法不可宣说。是名三十二。菩萨若能增长是法，必得阿耨多罗三藐三菩提。’
    （十五）速证：发菩提心的两大希求，即为利乐一切有情和愿证无上正等菩提。故菩萨行者，为了能够圆满自在地利乐有清，受用圆满清净无上的法乐，都必须于无上菩提希求速证。诸大乘经论中，广说速证方便，菩萨行者能依教奉行，定能速证无上正等菩提。《大乘理趣六波罗蜜多经．发菩提心品》说，菩萨发五种胜心能速证阿耨多罗三藐三菩提。如彼经说：‘尔时薄伽梵告慈氏菩萨摩诃萨言：欲度有情置大涅槃，应当先发五种胜心。云何为五？一者，于诸有情普发平等大慈悲心：二者，于一切种智心不退转；三者，于诸有情起亲友想，于险难中誓当救护；四者，常于有情起负债想：五者，恒怀惭愧何时偿毕。能发如是五种心，速能证得阿耨多罗三藐三菩提。’
    《大宝积经》卷百十一中，弥勒菩萨问佛，菩萨成就几法，离诸恶道及恶知识，而能速证阿耨多罗三藐三菩提。‘佛告弥勒菩萨：菩萨成就一法，离诸恶道及恶知识，速能证得阿耨多罗三藐三菩提。云何为一？所谓发胜意乐菩提之心。是名为一。弥勒！复有二法，离诸恶道及恶知识，速能证得阿耨多罗三藐三菩提。云何为二？一者，于奢摩他常勤修习；二者，于毗钵舍那而得善巧。是名为二。弥勒！复有三法，离诸恶道及恶知识，速能证得阿耨多罗三藐三菩提。云何为三？一者，成就大悲；二者，修习空法；三者，于一切法不生分别。是名为三。’如是说到菩萨成就十法，速能证得阿耨多罗三藐三菩提。乐广行者，应取阅修学。
    《大般若波罗蜜多经》卷一百二十九说：是菩萨摩诃萨于菩萨摩诃萨，以无所得为方便，修习般若波罗蜜多：于菩萨摩诃萨行，以无所得为方便，修习般若波罗蜜多，由此因缘无所执着，令所修习速得圆满。是菩萨摩诃萨于三藐三菩提，以无所得为方便，修习般若波罗蜜多，由此因缘无所执着，令所修习速得圆满。’卷一百三十又说：‘菩萨种姓补特伽罗修学此法（般若波罗蜜多），速入菩萨正性离生，渐次修行诸菩萨行，证得无上正等菩提。’又卷四百零二说：‘若菩萨摩诃萨，欲疾证得一切智智，当学般若波罗蜜多。’又卷四百二十八说：‘若善男子、善女人等，发心定趣无上正等菩提，精勤修习趣菩提行，欲住菩萨不退转地，速证无上正等菩提无留难者，应于如是甚深般若波罗蜜多，数数听闻、受持、读诵，精勤修习，如理思惟。’又卷四百三十说：‘三世诸佛皆依般若波罗蜜多精勤修学，证得无上正等菩提。’又卷四百四十二说：‘一切如来应证等觉，依深般若波罗蜜多，证一切法真如究竟，乃得无上正等菩提；由此故说，甚深般若波罗蜜多能生诸法，是诸佛母。’诸已发心菩萨，为欲疾证无上正等菩提，当依教奉行，精勤修学般若波罗蜜多。


三、发弘誓愿

    三、发弘誓愿
    修学菩萨行的人，在发起菩提心之后，为于坚固菩提心，制伏烦恼，遮止放逸，勤修六度，成就无上正等菩提，应当发弘誓愿。诸圣教中所说菩萨广大弘愿，种种非一，这里略举几种，以便依学。
    （一）四弘誓愿，即：‘众生无边誓愿度，烦恼无尽誓愿断，法门无量誓愿学，佛道无上誓愿成’。这四种誓愿，就是菩萨以自己观察得到的四谛真实道理为缘展开来普及一切有情而发起的。第一誓愿，即使未出苦界的众生，解脱众苦。第二誓愿，即使未断烦恼的众生，皆令断灭。第三誓愿，即使未安住圣道的众生，皆安住圣道。第四誓愿，即使未证灭谛的众生，皆证得涅槃。如《菩萨璎珞本业经》说：‘未度苦谛，令度苦谛；未解集谛，令解集谛；未安道谛，令安道谛：未得涅槃，令得涅槃。’《大般若波罗蜜多经》卷第四百五十六说到菩萨发起种种坚固大愿中也说：‘我既自度生死大海，亦当精勤度未度者；我既自解生死系缚，亦当精勤解未解者；我于种种生死怖畏既自安稳，亦当精勤安未安者；我既自证究竟涅槃，亦当精勤令未证者皆同证得。’这四弘誓愿，是菩萨行者的总愿，凡是修学菩萨行的人，都必须修学。如《心地观经．功德庄严品》说：‘一切菩萨复有四愿，成熟有情，住持三宝，经大劫海，终不退转。云何为四？一者，誓度一切众生；二者，誓断一切烦恼；三者，誓学一切法门；四者，誓证一切佛果。善男子！如是四法，大小菩萨，皆应修学，三世菩萨所学处故。’这四种誓愿，广大周遍，所以叫弘；自利其心，意志坚猛，所以叫誓；以清净意乐，希求满足，所以叫愿。
    （二）《发菩提心论》所说十大正愿：‘一者，愿我先世及以今身所种善根，以此善根施与一切无边众生，悉共回向无上菩提；令我此愿念念增长，世世所生常系在心，终不忘失，为陀罗尼之所守护。二者，愿我迥向大菩提已，以此善根，于一切生处常得供养一切诸佛，不生无佛国土。三者，愿我得生诸佛国已，常得亲近随侍左右，如影随形，无刹那顷远离诸佛。四者，愿我得亲近佛已，随我所应为我说法，即得成就菩萨五通。五者，愿我成就菩萨五通已，即通达世谛假名流布，解了第一义谛如真实性，得正法智。六者，愿我得正法智已，以无厌心为众生说，示教利喜，皆令开解。七者，愿我能开解诸众生已，以佛神力，遍至十方无余世界，供养诸佛，听受正法，广摄众生。八者，愿我于诸佛所受正法已，即能随转清净法轮，十方世界一切众生听我法者，闻我名者，即得舍离一切烦恼，发菩提心。九者，愿我能令一切众生发菩提心已，常随将护，除无利益，与无量乐，舍身命财摄受众生，荷负正法。十者，愿我能荷负正法已，虽行正法心无所行，如诸菩萨行于正法而无所行亦无不行，为化众生不舍正愿。’
    （三）《瑜伽师地论．菩萨地》中，说菩萨发十种大愿：一、愿当获得上妙供具供养诸佛，二、愿护正法传持不绝，三、愿如诸佛八相化现，四、愿行一切菩萨正行，五、愿普成熟一切有情，六、愿诸世界皆能示明，七、愿能净修一切佛土，八、愿诸菩萨同趣大乘，九、愿所修行皆不虚弃，十、愿当速证无上菩提。
    上面依经所说四弘誓愿和依论所说的两种十大正愿，皆遍众生界，摄受一切诸愿，菩萨行者，应依修学。


第二节 行位

    第二节 行位
    一、总说行位
    菩萨行位，就因果合说，总有四十一位。即十住、十行、十迥向、十地、佛果。若开十住中第一发心住所修信等十心为十信，于第十地终别开顿觉，则总为五十二位。但十信是十住中发心住所修，等觉是法云地摄，故不别开。今且依慈恩大师立四十一位。此四十一位，又束为五位：一、资粮位，即地前住行向之三十心位：二、加行位，即修暖顶忍世第一法的四善根位；三、通达位，即初地入心（地地各有入住出三心）通达二空无我理的见道位；四、修习位，即自初地住心至第十地出心（即等觉）中间，修习妙观以断除余障的修道位；五、究竟位，即究竟断惑证理的无学位。前四位是因，后一位是果。资粮加行二位，是初阿僧祇劫：从通达位至七地终，是第二阿僧祗劫：从第八地至第十地满，是第三阿僧祗劫。时经三劫，行备四位，方证究竟的菩提大果。立表如表一：
    二、别说五位
    （一）资粮位
    菩萨为趣证无上菩提，修集种种殊胜的福德智慧行，是资益己身成佛之粮，故名资粮位。亦名顺解脱分。解脱即涅槃。永离烦恼的缠缚，得大自在，名为解脱，即菩萨所求的果。顺是随顺不违，分是因义，即所修习的福智二种资粮，不违于果，是果的因，故名顺解脱分。此资粮位，有三十心：
    （表一）

    （1）十住：菩萨在此位中，于无上大菩提创发安住之心，虽修六度等行，还未至殊胜，故但得名住。十住是：一、发心住，此位菩萨初发大菩提心，故名发心住，此即三大阿僧祇劫的最初时。于此位中修习十信：1、信心，闻大乘法，心无疑惑。2、精进心，策励三业，离于懈怠。3、念心，忆念三宝，明记不忘。4、慧心，简择邪正，不起恶见。5、定心，心能湛寂，离于散乱。6、施心，等施财法，离于悭贪。7、戒心，住净尸罗，三业无犯。8、护心，护持正法，并余九心。9、愿心，发四弘誓愿。10、迥向心，所修善报，回向无上菩提。以上十心，以信为主，其余九种皆为信心所引，故名十信。二、治地住，菩萨净治三业，悲愍一切有情，由此能生一切功德，如地能生万物，故名治地住。三、修行住，菩萨修习殊胜的真如理观，起上妙的六波罗密多行，故名修行住。四、生贵住，菩萨听闻圣法正教，生起解脱，名生佛家，从圣法正教中生，种姓高贵，故名生贵住。五、方便具足住，菩萨所修善根，皆为救度有情，具有利他的善巧方便，故名方便具足住。六、正心住，菩萨虽然听到于己称赞毁谤的语言，心定不动，正直安住，故名正心住。七、不退住，菩萨听闻入说三宝有无，三世有无，心皆坚定，不为动转，故名不退住。（不退有四位：一、十信中的第六信以上名信不退；二、第七住以上名住不退；三、初地以上名证不退；四、八地以上名行不退。）八、童真住，童表无垢，真简虚伪；菩萨三业清净，于有情世界和器世界皆得悟解，能远离两种世间的染着，如童子真心无垢，故名童真住。九、法王子住，菩萨解了真俗二谛，觉悟法王如来所说的教法，有所承袭，故名法王子住。十、灌顶住，此位菩萨，行渐殊胜，如世间的王太子堪受王位，受灌顶体，故名灌顶住。
    （2）十行：此位菩萨，于六度等行增殊胜，故名为行。一、欢喜行，此位菩萨，为大施主，于财、法、无畏一切能舍。于施加行、正行、施已，三时无悔，不求名利，纯为慈愍有情，仰求菩提而布施，见闻的人，皆生欢敬，故名欢喜行。二、饶益行，菩萨常持净戒，不染五欲，能伏众魔，令一切众生住于无上的菩萨戒中；住净戒已，于一切智，心无退转，有情得大饶益，故名饶益行。三、无恚行，菩萨常修忍辱，谦卑恭敬，和颜爱语，不害自他；悟身空寂，怨对能忍；故名无恚行。四、无尽行，菩萨求法利生，假设须经多劫，领受各种剧烈的痛苦，于求法度生的事业，亦念念不息，故名无尽行。五、无痴行，菩萨常住正念，恒无散乱，于世出世间一切法，乃至死此生彼，乃入住出胎，皆无痴乱，故名无痴行。六、善现行，菩萨善解悟入人法皆无定实的性相，远离烦恼粗动，因而三业寂灭，无缚无著；但又能不舍化度众生之心，方便善巧地随顺众生机宜，而现生救度，故名善现行。七、无著行，菩萨经历诸尘刹土，供佛求法，传灯度生，心无厌足；此即涉有广大行。然以寂灭相观诸法故，而于一切心无所著：此即达空甚深见。起有行而无所著，故名无著行。八、尊重行，菩萨于最难得的尊善根，与智慧等法，皆悉成就；由尊重法故，自他二利之行，更增修习，故名尊重行。九、善法行，菩萨得法义辞辩四无碍陀罗尼门诸善慧法，以种种方便饶益有情，能为众生作清凉池，涤除烦恼的热恼，令其流入佛法大海中；此即善能守护正法，使佛种不绝之行，故名善法行。十、真实行，菩萨成就第一诚谛语言，学习三世诸佛的真实语，言行不二语，如说能行，如行能说，语行相应，三业皆顺，故名真实行。
    （3）十回向：菩萨在此位已，凡所修行，皆为回行，故立回向名。一、救护众生离众生相回向，此位菩萨修行六度四摄等，悉以大悲平等心为救护，摄受一切有情，令离生死苦，得到涅槃乐，故名救护众生。以大智无颠倒心，入平等观，不见怨亲众生等相，名离众生相。二、不坏回向，菩萨于三宝所，深信坚固，得不坏信，以此善根回向众生，获善法义利，故名不坏回向。三、等诸佛回向，菩萨学习三世诸佛，不着生死，不离菩提（智慧）而修回向事（悲心），如三世诸佛，悲智双运行，故名等诸佛回向。四、至一切处回向，菩萨修习一切诸善根时，以彼善根作如是的回向：令此善根功德之力，至于十方一切三宝前作诸供养；至于一切世界众生前，作诸利益；譬如诸法真如，无处不有。故名至一切处回向。五、无尽藏功德回向，菩萨修悔过善根，离一切善障，于诸如来一切众生所有善根，皆悉随喜；以此善根，皆悉回向，庄严一切诸佛的清净刹上，常作佛事。菩萨这样的回向最为善巧方便，具诸功德，离诸虚妄，而无所著；由回向已得无尽善根，名无尽藏功德回向。六、随顺一切坚固善根回向，菩萨以内摄的根身性命，和外摄的衣食等，随顺众生需求的意乐，而惠予施舍；见诸有苦众生，悲以身代，此是于内外财惠施，坚固安住自在功德。以如是等诸善功德而迥向已，令一切众生得大智慧，除灭大苦，名随顺一切坚固回向。七、等心随顺一切众生回向，菩萨能增长一切善根，修习一切善根，究竟一切善根，而能不为倾动，安住忍力，闭恶趣门，永离颠倒，不着诸行，于一切善根，皆悉回向，为一切众生作功德藏，此功德普遍覆荫一切，拔出生死，令得众善，等无差异，名等心随顺一切众生回向。八、如相回向，菩萨成就念智（定慧），安住不动，心无所依，寂然无乱，不违一切平等法而庄严刹土，化度众生，以所修诸善，皆顺真如平等无差别相而为回向，名如相回向。九、无著无缚解脱回向，菩萨所摄善根，远离骄慢等所有缠缚贪着，得解脱心，修学德周法界至顺调善的普贤行；于所习诸善，无私自他地不为己有，及以他人，以无缚无著的解脱之心回向饶益一切众生，故名无缚无著解脱回向。十、法界无尽回向，此位菩萨由离垢秽故，以白缯系顶，表彰定心皎洁，蒙佛授与大法师记，法施众生，严净世间，出生智等，悉同虚空，而无限量；凡有善根修于回向，悉等法界，故名法界无尽回向。
    （二）加行位
    第二加行位，即第十迥向满心之位。此位菩萨为趣见道而加功用行，故名加行。亦名顺决择分，顺是趣向欣求，决择是智，分是支分；决择体即见道，是七觉支中的一分，加行位中暖等善根，欣求趣向决择分，故名顺法择分。此位菩萨依明得定，发起下品寻思，观所取的名、义、自性、差别四法，皆自心变现，假施设有，实不可得，初获见道慧火前相，故名明得。因见道体断烦恼，如火烧薪，故喻见道智慧如火；此位菩萨，未得火体，而得火相，故立名为暖。二、顶位，此位菩萨，依明增定发起上品寻思，重观所取的名义自性差别四法皆自心变现，假施设有，实不可得，慧火明相转盛，故名明增。三、忍位，此位菩萨，依印顺定发起下品如实智观，于所取空，决定印持；于能取空，亦乐顺忍；忍即印可达悟之义，印前顺后，故名印顺。此位菩萨知妄识及心外境，其体皆空，印可达悟，故名为忍。四、世第一位，此位菩萨，依无间定发起上品如实智，双印能所二取空，从此无间，必入见道，故名无间。此位菩萨所得智等，是一切世间所有法中最殊胜的善法，故名世第一法。
    （三）通达位
    第三通达位，通达即证会义。此位菩萨，以无漏无分别智，体会真如，故名通达。此通达位，即是见道；照理名见，游履通运名道，由无漏智照见真理，通运行人，至于极果，故名见道。此有真见道和相见道两种差别：一、真见道位，由无漏无分别根本智，亲证真如，智与真如平等平等，俱离能所取相，实证二空所显真理，实断二障分别随眠，故名为真。二、相见道位，相是类似义，即由无漏有分别后得智，于真见道后，仿效真见道所有功能而起的行解，不能证理断障，类似于真，故名为相见道。菩萨得此二见道时，生如来家，住极喜地，善达法界，得诸平等，常生诸佛大集会中，于多百门，已得自在，自知不久证大菩提，能尽未来，利乐一切。
    （四）修习位
    菩萨出相见道之后，自初地中的住心出心至第十地终金刚无间道，为断除俱生二障，证得转依，复数数习无分别智，所以得名为修习位。此修习位，有十地差别：一、极喜地：此位菩萨，由无漏无分别智，断除了二障分别种子的凡性，最初获得无漏无分别智的圣性；具证二空所显的真如实理；能利益自己和其他一切有情；由此三因，生大欢喜，故名极喜地。此是布施波罗蜜多圆满之位。二、离垢地：此位菩萨，具清净戒，远离了能够引起误犯净戒的微细烦恼染污垢，故名离垢地。此是戒波罗蜜多圆满之位。三、发光地：此位菩萨，成就胜定，及殊妙教法，和法、义、咒、忍四种总持。以此为因，能起三慧，三慧能照法显现，名之为光；此地定等能起慧光，故名发光地。此是忍波罗蜜多圆满之位。四、焰慧地：此位菩萨，安住最胜菩提分法，能断烦恼，（即伏除第六识等中的俱生身见，非断一切烦恼），如火焚薪，慧焰增盛，故名焰慧地。此是精进波罗蜜多圆满之位。五、极难胜地：此位菩萨，能令俗谛有分别智与真谛无分别智同时俱起，以于真俗两智行相互违之法，令不相违而成相应，一时并生，故名为难；此种自在，以前四地，皆未能得，今乃得到，故名为胜；是故此地名极难胜地。此是静虑波罗蜜多圆满之位。【出版者注】七、远行地：此地菩萨，唯修无相，于加功用行，已至最后边际。始从初地，至到七地，经历了第二个阿僧祇的长远时间，才证得此无缺无间无相作意。故名远行地。此是方便波罗蜜多圆满之位。八、不动地：此位菩萨，无分别智任运相续，不为一切有相、一切功用、一切烦恼之所鼓动，故名不动地。此是愿波罗蜜多圆满之位。九、善慧地：此位菩萨，得胜妙智慧，成就微妙的四无碍解，能普遍十方善巧说法，以利有情，故名善慧地。此是力波罗蜜多圆满之位。十、法云地：此地菩萨，有殊胜智，能藏众德，能断诸障，法身圆满，譬如大云，能覆蔽广如虚空般的二障粗重（种子）而含众功德水，菩萨的大法智如云，故名法云地。此是智波罗蜜多圆满之位。如上十地功德，与所修行为胜依持，令得生长，故名为地。
    【出版者注】原书漏印了‘六、现前地’，今谨依‘相宗纲要’（梅光义居士着）补录如下：‘第六现前地，住缘起智，引无分别最胜般若，令现前故。此地菩萨能起胜智，观十二缘不作染净二差别行。：：：据地论意，此位菩萨，无分别智不恒相绩，必须作意方得现起。又此位是般若波罗蜜圆满位。’又‘唯识研究’（周叔迦居士着）云：‘由能明了十二因缘甚深的道理，令无分别智现前，所以叫作现前地。这位中能知一切法无染无净，能治一切粗相现行障。’
    （五）究竟位
    究竟即是佛果。佛位所得的菩提涅槃转依妙果，是究竟的无漏界，诸漏永尽，性净圆明，唯佛具足，所作皆办。功德最胜无上，功成事毕，故得名究竟。
    三、五位体性
    资粮加行二位，皆以有漏的加行智为体。见道位以根本后得无漏二智为体。修习位十地，皆以有为无为诸功德法为体。究竟位即以如来菩提涅槃以为其体。


一、所修胜行—六波罗蜜多

    第三节 修断
    一、所修胜行—六波罗蜜多
    菩萨于诸行位中，修习无量法门，若随类摄，六种波罗蜜多可以摄尽；所以六波罗蜜多，是菩萨的正道，也是摄尽一切菩萨道的总行。如《解密经》经中佛告观自在菩萨说：‘善男子！菩萨学事，略有六种，所谓：布施、持戒、忍辱、精进、静虑、智慧到彼岸。’六度的意义很多，诸大乘经论中广有解说，这里略说十二义如下：
    （一）辨列：（1）布施，有财施、无畏施、法施三种。财施是布施一切财物，资益有情的根身。无畏施是帮助有情解脱水火野兽等和人为的逼迫等灾害恐怖，资益有情的心意。法施是为有情宣说如理的正法，使有情知道止恶修菩，断染证净，资益有情的善报。（2）持戒，有律仪戒、摄善法戒、饶益有情戒三种。律仪戒，即菩萨所受的防非止恶的戒法，包括五戒、十戒等七众所受的别解脱戒。摄善法戒，即菩萨所应修学的六波罗蜜多等善法学处。饶益有情戒，即菩萨应以善法资财神通等利乐有情等学处。（3）忍辱，有耐怨害忍、安受苦忍、谛察法忍三种。耐怨害忍，即菩萨能忍耐他有情对于自己所作的怨对损害。安受苦忍，即菩萨自己修行道法的时候，于所遭受的饥渴寒热障碍等苦痛，能安然忍受，修道不退。谛察法忍，即菩萨对于甚深难解的法义，能以坚忍的意志审谛观察思惟，以求悟入。（4）精进，有被甲精进、摄善法精进、饶益有情精进三种。被甲精进，即于所修善行发起大譬意乐，勇悍不退，如古人入阵打仗，先行被宠铠甲，即有威力，不生怯弱。摄善法精进，即正修行善法时进趣不息。饶益有情精进，即为利乐一切有情作诸事业，勇悍策进。（5）静虑，有安住静虑、引发静虑、办事静虑三种。安住静虑，即远离昏沉掉举等障定法，引生轻安寂静的等持现前，而能安住领受其乐，故名安住静虑。引发静虑，即由定力为依止，引发种种神通功德。办事静虑，即由定为依，消除有情的饥渴寒热水火疾病等痛苦，成办有情一切的利乐事情。（6）智慧，有缘世俗谛慧、缘胜义谛慧、缘饶益有情慧三种。缘世俗慧，即通达声明、因明、医方明、工巧明、内明的五明智慧。缘胜义慧，即通达人法二种无我真实的智慧。缘饶益有情慧，即为有情作助伴等俱行的妙慧。
    又《解深密经》等，说十种波罗蜜多，即从第六度中开出后四度。第七方便善巧波罗蜜多，此有两种：一迥向方便善巧（般若），二拔济方便善巧（大悲）。第八愿波罗蜜多，此有两种：一求菩提愿，二利乐他愿。第九力波罗蜜多，此有两种：一思择力（思慧），二修习力（修慧）。第十智波罗蜜多，此有两种：一受用法乐智，二成熟有情智。就六开十来说，则第六度唯是无分别智，后四度皆是后得智摄，唯缘世俗故。
    （二）出体：施以无贪及相应思并彼所起三业为性，戒以受学菩萨时的三业为性，忍以无嗔、精进、审慧及彼所起三业为性，精进以勤及彼所起三业为性，静虑但以等持为性，后五皆以择法为性。此是约自性出体而说，若并眷属来说，则每一度皆以一切俱行的功德为体。
    （三）释名：波罗蜜多得名，有总有别。总名者，波罗蜜多是梵语，波罗是彼岸义，蜜多是到义，随顺中国的语法，译言到彼岸。彼岸指佛果位的菩提涅槃，乃至一切的所知境界；由六波罗蜜多可以觉了一切事理性相诸所知境，达到佛果位的菩提涅槃，所以名波罗蜜多。《解深密经》说，由五因缘故，说名波罗蜜多：一、无染着故，即不染着波罗蜜多诸相违事。二、无顾恋故，即于一切波罗蜜多诸果异熟及报恩中，心无系缚。三，无罪过故，即于如是波罗蜜多，无间杂法，离非方便行。（间杂法，经中自说四种：（1）无悲加行，（2）不如理加行，（3）不常加行，（4）不殷重加行。非方便行，经说但摄财物饶益众生，便为喜足，而不令其出不善处，安置善处。）四、无分别故，即于如是波罗蜜多，不如言词执着自相故。五、正回向故，即以如是所作所集波罗蜜多，回求无上大菩提果。释别名者，《摄大乘论》说：于因中能破悭腾，于果中能裂贫穷，引得广大财位福德，故名为施。于因时能息灭恶戒，引得等持；于果时能息灭恶趣，引得善趣，故名为戒。能灭尽自己忿怒怨仇之心，及能无恚地自住安稳和不损于他而令他安稳住，故名为忍。能远离所有懈怠恶不善法，及能出生无量善法，故名精进。能消除所有散动，及能引得内心安住，故名静虑。能除遣一切见趣诸邪恶慧，及能如理的真实知法和如量的品别知法，故名为慧。
    （四）辨相：布施等十种波罗蜜多之所以得名波罗蜜多，是有一定的因缘条件的，否则普通的善心凡夫和修解脱行的二乘人，也能修行布施持戒等，是否也可以称他们所行所作就是波罗蜜多呢？不能，这些人之所行，只能叫布施等，不能称为波罗蜜多。如《成唯识论》说：‘要由七最胜之所摄受，方可建立波罗蜜多。一、安住最胜，谓要安住菩萨种姓。二、依止最胜，谓要依止大菩提心。。三、意乐最胜，谓要悲愍一切有情。四、事业最胜，谓要具行一切事业。五、巧便最胜，谓要无相智所摄受。六、回向最胜，谓要回向无上菩提。七、清净最胜，谓要不为二障间虽。若非此七所摄受者，所行施等（但名施等）非到彼岸。’
    （五）不增不灭：波罗蜜多，总有十种，分之为二：（1）说明六度无增无减。（2）说明后四度无增无减。六度由两义因缘故，数目确定，即（1）由于饶益有情，（2）由于对治烦恼。六度中的布施、持戒、忍辱，是饶益有情的波罗蜜多。精进、静虑、般若，是对治烦恼的波罗蜜多。所以数目确定，无增无灭。如《解深密经》说：‘观自在菩萨复白佛言：世尊！何因缘故，施设如是所应学事，但有六数？佛告观自在菩萨曰：善男子！二因缘故。一者饶益诸有情故，二者对治诸烦恼故。当知前三饶益有情，后三对治一切烦恼。前三饶益有情者，谓诸菩萨由布施故，摄受资具，饶益有情；由持戒故，不行损害、逼迫、烦乱，饶益有情；由忍辱故，于彼损害、逼迫、恼乱，堪能忍受，饶益有情。后三对治烦恼者，谓诸菩萨由精进故，虽未永伏一切烦恼，亦未永害一切随眠，而能勇猛修诸善品，彼诸烦恼，不能倾动善品加行；由静虑故，永伏烦恼；由般若故，永害随眠。’
    下面说明后四度数目无增无减。如《解深密经》继续说：‘观自在菩萨复白佛言：世尊！何因缘故，施设所余波罗蜜多，但有四数？佛告观自在菩萨曰：善男子！与前六种波罗蜜多为助伴故。谓诸菩萨，于前三种波罗蜜多所摄有情，以诸摄事，方便善巧而摄受之，安置善品。是故我说方便善巧波罗蜜多，与前三种而为助件。若诸菩萨，于现法中烦恼多故；于修无间，无有堪能，羸劣意故，下界胜解（欲界散位胜解）故，于内心住，无有堪能。于菩萨藏，不能闻缘善修习故；所有静虑，不能引发出世间慧，彼便摄受少分狭劣福德资粮，为未来世烦恼轻微，心生正愿；如是名愿波罗蜜多。由此愿故，烦恼轻薄，能修精进。是故我说愿波罗蜜多，与精进波罗蜜多而为助件。若诸菩萨亲近善士，听闻正法，如理作意为因缘故，转劣意乐成胜意乐，亦能获得上界胜解，如是名力波罗蜜多。由此力故，于内心住，有所堪能。是故我说力波罗蜜多，与静虑波罗蜜多而为助伴。若诸菩萨于菩萨藏，已能闻缘，善修习故，能发静虑，如是名智波罗蜜多。由此智故，堪能引发出世间慧，是故我说智波罗蜜多，与慧波罗蜜多而为助伴。’
    ‘观自在菩萨复白佛言：世尊！何因缘故，宣说六种波罗蜜多如是次第？佛告观自在菩萨曰：善男子！能为后后引发依故。谓诸菩萨，若于身财无所顾腾，便能受持清净禁戒。为护禁戒，便修忍辱。修忍辱已，能发精进。发精进已，能办静虑。具静虑已，便能获得出世间慧。是故我说波罗蜜多如是次第。’
    （六）与三学相摄：十波罗蜜多与戒定慧三学互相摄持者，如《成唯识论》卷九说：‘戒学有三：一、律仪戒，谓正远离所应离法。二、摄善法戒，谓正修证应修证法。三、饶益有情戒，谓正利乐一切有情。此与二乘有共不共。甚深广大，如余处说。定学有四：一、大乘光明定，谓此能发照，大乘理教行果智光明故。二、集福王定，谓此自在集无边福，如王势力无等双故。三、贤发首定，谓此能守世出世间贤善法故。四、健行定，谓佛菩萨，大健有情之所行故。此四所缘，对治堪能，引发作业，如余处说。慧学有三：一、加行无分别慧，二、根本无分别慧，三、后得无分别慧。此三自性，所依因缘，所作行等，如余处说。如是三慧，初三位中，种具有三，现唯加行。于通达位，现二种三。见道位中，无加行故。于修习位，七地以前，若种若现，俱通三种。八地以去，现二种三，无功用道，违加行故。所有进趣，皆用后得无漏观中，任运起故。究竟位中，现种俱二。加行现种，俱已舍故。若自性摄，戒唯摄戒，定摄静虑，慧摄后五。若并助件，皆具相摄。若随用摄，戒摄前三，资粮、自体、眷属性故。定摄静虑。慧摄后五。精进三摄，遍摄三故。若随显摄，戒摄前四，前三如前，反守护定故。定摄静虑。慧摄后五。’
    （七）加行：菩萨将修习六波罗蜜多时，要用什么加行才能进行修习呢？那就必须以自利利他的二利心来进习。如《大般若波罗蜜多经》一百零二卷说：‘菩萨摩诃萨行六波罗蜜时，当作是念：我若不行布施波罗蜜多，当生贫贱家，尚无势力，何由成就有情严净佛土？况当能得一切智智！我若不护净戒波罗蜜多，当生诸恶趣，尚不能得下贱人身，乃至况当能得一切智智！我若不修安忍波罗蜜多，当生诸根残缺，容貌丑陋，不具菩萨圆满色身。若得菩萨圆满色身，行菩萨行，有情见者，必获无上正等菩提；若不得此圆满色身，则不能成熟一切有情，严净佛土，况当能得一切智智！我若懈怠不起精进波罗蜜多，尚不能获菩萨胜道；何由成熟一切有情，严净佛上？况当能得一切智智！我若心乱不入静虑波罗蜜多，尚不能得菩萨胜定，何由成熟一切有情，严净佛上？况当能得一切智智！我若无智不学般若波罗蜜多，尚不能得诸巧便慧，超二乘地，何由成熟一切有情，严净佛土？况当能得一切智智！’又此经卷第三百五十一说：‘诸菩萨摩诃萨于此六种波罗蜜多勤修学时，恒作是念：世间有情，心皆颠倒，没生死苦，不能自脱，我若不修善巧方便，不能解脱彼生死苦。我当为彼诸有情类，精勤修学布施、净戒、安忍、精进、静虑、般若波罗蜜多善巧方便。’菩萨以此作念思惟，即能于六种波罗蜜多勇悍地精勤修习。
    （八）修习：修习差别，略有五种：（1）依止任持修，（2）依止作意修，（3）依止意乐修，（4）依止方便修，（5）依止自在修。
    （1）依止任持修，依止是依仗义，任持是不散义，即依仗五种法而修习六度。由种姓力等四种能摄持六度不散不没，故名依止任持修。此有四种，如《对法论》卷十二说：‘依止任持修复有四种：一、依止因修，谓由种姓力，于波罗蜜多修习正行。二、依止报修，谓由胜自体力，于波罗蜜多修习正行。二、依止愿修，谓由本愿力，于波罗蜜多修习正行。四、依止简择力修，谓由慧力，于波罗蜜多修习正行。’
    （2）依止作意修，如前论说：‘依止作意修亦有四种：一、依止胜解作意修，谓于一切波罗蜜多相应经教，起增上胜解。二、依止爱味作意修，谓于已得波罗蜜多，见胜功德，起深爱味。三、依止随喜作意修，谓于一切世界一切有情所行施等，深生随喜。四、依止喜乐作意修，谓于自他当来胜品波罗蜜多，深生愿乐。’
    （3）依止意乐修，如前论说，有六种意乐：一、无厌意乐，二、广大意乐，三、欢喜意乐，四、恩德意乐，五、无染意乐。诸菩萨以恒河沙界满中七宝和以恒河沙等身命，于刹那顷，或经恒河沙等大劫布施一有情乃至一切有情，皆令彼于菩提速成；修行这样差别施时，菩萨意乐犹不满足，是名无厌意乐。又诸菩萨修行施时，展转相续无一刹那有退有断，乃至证得无上菩提都是如此，是名广大意乐。又诸菩萨修行施时，于施所摄诸有情所生大欢喜，是名欢喜意乐。又诸菩萨修行布施时，观察布施所摄一切有情，于我己身有大恩德，不见己身于彼有恩，由彼一切有情助我证得无上大菩提故，是名恩德意乐。又诸菩萨修行施时，虽于无量诸有情所兴大施福，而不希求报恩和当来异熟果，是名无染意乐。又诸菩萨修行施时，所得异熟施诸有情，不自为己；又以此福，共诸有情回向无上菩提，是名好善意乐。菩萨修行布施波罗蜜多时具此六种意乐，修行余度也是这样，准此例知。
    （4）依止方便修如前论说，复有三种，即由无分别观察三轮皆清净故，由此方便，一切作意所修诸行速得成满。观三轮清净如《八大般若波罗蜜多经》卷第百二十九说：‘菩萨摩诃萨以无所得为方便，具行六种波罗蜜多：行布施时，不得施者，不得受者，不得施及施物；行净戒时，不得净戒，不得恶戒，不得持净戒者；行安忍时，不得安忍，不得忿恚，不得行安忍者；行精进时，不得精进，不得懈怠，不得行精进者；行静虑时，不得静虑，不得散乱，不得行静虑者；行般若时，不得般若，不得恶慧，不得行般若者。’这就是说，能行所行及彼行修，皆无我无人，亦无色声香味触法，无住生心，则三轮皆清净了。
    （5）依止自在修，如前论说，亦有三种：一、身自在，即诸如来的自性身和受用身。二、行自在，即诸如来的变身，由此能示现一切有情和一切种同法行故。三、说自在，即能宣六波罗蜜多一切差别义，无有滞碍。诸菩萨缘求依止此三种自在故修行六波罗蜜多，故名依止自在修。
    （九）净相：修行波罗蜜多清净之相，《解深密经》中说有总别二种，如彼经说：‘总说一切波罗蜜多清净相者，当知七种。何等为七？一者，菩萨于此诸法，不求他知。二者，于此诸法，见已不生执着。三者，即于如是诸法不生疑惑，谓为能得大菩提不？四者，终不自赞毁他，有所轻蔑。五者，终不骄傲放逸。六者，终不少有所得，便生喜足。七者，终不由此诸法，于他发起嫉妒悭腾。
    ‘别说一切波罗蜜多清净相者，亦有七种。何等为七？谓诸菩萨，如我所说七种布施清净之相，随顺修行：一者，由施物清净，行清净施。二者，由戒清净，行清净施。三者，由见清净，行清净施。四者，由心清净，行清净施。五者，由语清净，行清净施。六者，由智清净，行清净施。七者，由垢清净，行清净施。是名七种清净相。
    ‘又诸菩萨，能善了知制立律仪一切学处；能善了知出离所犯；具常尸罗；坚固尸罗；常作尸罗；常转尸罗；受学一切所有学处。是名七种戒清净相。
    ‘若诸菩萨，于自所有业果异熟，深生依信，一切所有不饶益事现在前时，不生愤发：亦不反骂，不嗔不打，不恐不弄，不以种种不饶益事反相加害；不怀怨结；若谏诲时，不令恚恼；亦复不待他来谏诲，不由恐怖，有染爱心而行忍辱；不以作恩，而便放舍。是名七种忍清净相。
    ‘若诸菩萨，通达精进平等之性；不由勇猛勤精进故，自举凌他；具大势力；具大精进；有所堪能；坚固勇猛；于诸善法，终不舍轭。如是名为七种精进清净之相。
    ‘若诸菩萨，有善通达相三摩地静虑；有圆满三摩地静虑；有俱分三摩地静虑；有运转三摩地静虑；有无所依三摩地静虑；有善修治三摩地静虑；有于菩萨藏闻缘修习无量三摩地静虑。如是名为七种静虑清净之相。
    ‘若诸菩萨，远离增益损减二边，行于中道，是名为慧；由此慧故，如实了知解脱义门，谓空、无愿、无相三解脱门；如实了知有自性义，谓遍计所执，若依他起，若圆成实三种自性；如实了知无自性义，谓相、生、胜义三种无自性性；如实了知世俗谛义，谓于五明处；如实了知胜义谛义，谓于七真如；又无分别离诸戏论，纯一理趣多所住故，无量总法为所缘故，及毗钵舍那故；能善成办法随法行。是名七种慧清净相。’
    （十）相摄：诸菩萨修行六种波罗蜜多时，有相资相顺，互相助成的意义，故一一度皆摄一切波罗蜜多。如《摄大乘论》说：‘如是六种波罗蜜多互相决择，云何可见？世尊于此一切六种波罗蜜多，或有处所以施声说，或有处所以戒声说，或有处所以忍声说，或有处所以勤声说，或有处所以定声说，或有处所以慧声说。如是所说有何意趣？谓于一切波罗蜜多修加行中，皆有一切波罗蜜多互相助成。如是意趣。’更互相助的意义，如修布施时，于三业防非止恶，就是持戒；能忍受诸苦困难，就是安忍；于布施勇猛策励，就是精进：意无扰乱地专心布施，就是静虑；于布施能善了知业果相属，是为智慧。这样修行布施，即有其余诸度随转。若修习戒度时，远离悭腾、忿恚、懈怠、散动、邪见，如是戒中，即有余度随转。修习所余波罗蜜多，亦如是说。如有颂说：‘施时无贪无犯戒，无嫉无恚起慈心，诸来求者便施与，无无倦乱无异见。’诸度相摄的意义，在《大般若波罗蜜多经》卷第四百五十九中广有解说，可翻阅参考。
    （十一）分位：六波罗蜜多，五位皆具，但在修习位中，其相最显。在资粮和加行两位中，若是顿悟菩萨所修六度，种子通有漏无漏，现行则唯是有漏。若是渐悟菩萨所修六度，则种子与现行俱通有漏无漏二性，以渐悟菩萨已得生空无漏观故。在通达位中，种通有漏无漏，现行则唯是无漏。于修习位，七地已前所修六度，种子与现行，俱通有漏无漏，以尚有有漏心行间杂起故。八地已去，种通漏无漏二种，现行唯是无漏。以纯无漏观任运无间地现起故。究竟位中，若现若种，俱唯无漏。此六度行，由于因位中三劫修习有别，故三劫得名亦别：一、名波罗蜜多，即初无数劫，此位菩萨所修施等，势力尚微，被烦恼所损伏，未能伏彼烦恼，由此烦恼不觉悟地会起现行，故但可名波罗蜜多。二、名近波罗蜜多，即第二无数劫，此位菩萨所修施等，势力渐增，非烦恼伏，而有力能伏除烦恼，由此烦恼要故意才能现行，渐近大菩提果，故得名近波罗蜜多。三、名大波罗蜜多，即第三无数劫，此位菩萨所修施等，势力转增，能毕竟伏除一切烦恼，由此烦恼永不现行，无功用地任运修行六度，修一一行中皆起无量行故，所以得大波罗蜜多。
    （十二）胜利：六波罗蜜多的胜德果利，诸大乘经论中广有赞说，今依《解深密经》说：‘一切波罗蜜多，各有四种最胜威德：一者，于此波罗蜜多正修行时，能舍悭腾、犯戒、心愤、懈怠、散乱、见趣所治。二者，于此正修行时，能为无上正等菩提真实资粮。三者，于此正修行时，于现法中，能自摄受饶益一切有情。四者，于此正修行时，于未来世，能得广大无尽可诸爱果异熟。’
    言其果利，由于修行六度而为殊胜因，即能招感当来世种种妙果，远即大菩提，近即人天等胜报。故《华严经》第五卷颂说：‘佛威神力遍十方，广大示现无分别，大菩提行波罗蜜，昔所满足皆令见。昔于众生起大悲，修行布施波罗蜜，以是其身最殊胜，能令见者生欢喜。昔在无边大劫海，修治净戒波罗蜜，故获净身遍十方，普灭世间诸重苦。往昔修行忍清净，信解真实无分别，是故色相皆圆满，皆放光明照十方。往昔勤修多劫海，能转众生深重障，故能分身遍十方，悉现菩提树王下。佛久修行无量劫，禅定大海普清净，故令见者心欢喜，烦恼障垢悉除灭。如来往昔诸行海，具足般若波罗蜜，是故舒光普照明，克殄一切愚痴暗。’此即赞说由修行六度胜因，具足佛位果德。
    又《解深密经》说：‘世尊！如是一切波罗蜜多何果异熟？善男子！当知此亦略有六种：一者，得大财富；二者，往生善趣；三者，无怨无坏，多诸喜乐；四者，为众生主；五者，身无恼害；六者，有大宗叶。’如其次第配属六度：由施力故，得大财富：由持戒故，往生善趣；由忍辱故，无怨无坏，多诸欢喜；由精进故，得大尊贵身位，为众生主：由静虑故，伏除烦恼，感得身无怨害；由般若故，广解五明，得大宗叶。宗叶即宗族。
    又《杂集论》第十二卷具说六度各得五果，如彼论说：‘功德者，谓依五果无量无边称赞胜利，皆名功德。谓：能永断自所对治，是诸波罗蜜多离系果；于现法中，由此施等摄受自他，是士夫用果；于当来世后后增胜，展转生起，是等流果；大菩提是增上果；感大富财，往生善趣，无怨无坏多诸喜乐，有情中尊，身无损害，广大宗族，随其次第，是施等波罗蜜多异熟果。’
    又《成唯识论》第九卷说：‘有漏有四，除离系果。无漏有四，除异熟果。而有处说具五果者，或互相资，或二合说。’此中后因句，即会释《杂集论》所说六度各得五果义，是依无漏资助有漏亦得异熟，有漏资助无漏亦得离系；故说六度各得五果，是‘互相资’。或依有漏无漏二种合说，故得五果；非有漏无漏体各能亲得五果故。
    六度义海，非说可尽，略述十二要义，以显殊胜。欲学菩萨行者，于此六度，必须修学，以此能摄尽一切善法故。如《摄大乘论》说：‘如是相摄，云何可见？由此能摄一切善法。是其相故，是随顺故，是等流故。’‘是其相故’，即六度自相，如无贪等善心所，是六度自相所摄。‘是随顺故’，即与六度随转的增上缘，如信惭等善心所，是六度随顺法所摄。‘是等流故’，即六度的果法，如六神遇及十力等诸余功德，皆是六度等流果摄。故一切善法，皆摄入六度，六度中慧为自性的，皆名为智，非慧为体的，并名为福，六波罗蜜多就通相说，俱通福智二种。若约则相说，前五度是福德，第六一度是为智慧。于此六度，若为利益他有情而修习者，六度皆是利他行。若为自利而修习者，六皆自利。六度与三学，若随用摄，戒学摄前三度：布施是戒的资粮，戒是戒学自体，忍是戒的眷属。定学摄定。慧学摄慧。精进三摄，遍策三学故。由此可知，菩萨修习六波罗蜜多，即具足一切善法，也就是具修福智、二利、三学等一切功德。故《大般若波罗蜜多经》卷第四百六十说：‘若菩萨摩诃萨，欲于诸法不借他缘而自悟解，欲能成熟一切有情，欲于佛土能善严净，欲疾安坐妙菩提座，欲能降伏一切魔军，欲疾证得一切智智，欲转法转脱有情众生老病死，证得常住毕竟安乐，应学六种波罗蜜多。’


二、所断二障

    二、所断二障
    （一）我法二执
    菩萨所断，总有二种，即烦恼障和所知障。二障依我法二执为根本而生起，故今先说我法二执。
    （1）我执：一切我执，略有二种：1.俱生我执，2.分别我执。俱生我执的生起，不依赖外缘，它是从无始时来，由第六第七两识的虚妄熏习内因种子力故，恒常与五蕴身俱时生起，故名俱生。这又有二种：1.常相续生起的俱生我执。此执在第七识上，依于第七识生起的执用，缘虑第八识的见分以为所缘的本质境，生起自识上的影像相分心相，执为实我。2.有间断的俱生我执。此执在第六识上，依于第六识生起执用，缘虑诸识所变的本质境，生起自识上的影像相分心相，执为实我。这两种俱生我执，是无始时来熏习的惯习势力，体相微隐，行粗极细，故很难断除，要在见道以后的修道十地位中，数数不断地修习殊胜的生空观，才能除灭。
    分别我执，既须借待内因种子的势力，亦由现在的外缘条件助成生起；它是非与身俱时而有，要借待外缘的邪师和邪教及自己心中的邪思惟分别，然后才能生起，故名分别我执。此执唯在第六意识中有。这亦有两种：一、缘邪师邪教所说的蕴相以为所缘的本质境，生起自识上的影像相分心相，分别计度，执为实我。这是即蕴计我，以为常住，如二十句等。二、缘邪师邪教所说的我相以为所缘的本质境，生起自识上的影像相分心相，分别计度，执为实我。这是离蕴计我，即执五蕴之外另有一个常住的我体存在。这两种分别我执，行相粗猛，容易断除，在真见道时，观一切法生空真如，即能除灭。
    （2）法执：一切法执，略有二种：一、俱生法执，二、分别法执。
俱生法执的生起，不依赖外缘，是无始时来，由第六第七两识的虚妄熏习内因种子力故，恒常与有情五蕴身俱时生起。由于此执是不借待邪师和邪教及自己内心邪分别，任运自然地与身俱时生起，故名俱生。这又有两种：1.常相续生起的俱生法执，此执在第七识中，依于第七识生起执用，缘虑第八识以为本质境，生起自心上的影像相分心相，执为实法。2.有间断，此执在第六意识中，依第六意识生起执用，缘虑诸识所变的蕴处界总相或别相以为本质境，生起自识上的影像相分心相，执为实法。这两种法执，行相微细，故难断除，要在见道以后的十地位中，数数不断地修习殊胜的法空观，才能除灭。
    分别法执，既须借待内因种子的势力，亦由现在外缘条件助成生起；因其不是与有情根身俱时而生，要借待邪师邪教及自己内心中的邪思惟分别才能生起，故名分别。以分别法执，唯在第六意识中有。这亦有两种：1.缘虑邪教所说的蕴处界相以为本质境，生起自识上的影像相分心相，分别计度，执为实法。2.缘虑邪教所说的自性（数论计）实性（胜论计）等相以为本质境，生起自识上的影像相分心相，分别计度，执为实法。此二法执，行相粗故易断，入初地入心真见道时，观一切法的法空真如，即能除灭。
    （二）烦恼所知二障
    （1）烦恼障：烦是扰义，恼是乱义，扰乱有情身心，不令出离生死苦海，故名烦恼。障是覆蔽义，即烦恼覆蔽涅槃不得解脱，是名为障，烦恼即障，故名烦恼障。其体即遍计所执实我萨迦耶见而为上首的一百二十八个根本烦恼，及彼根本烦恼同类所引起的等流诸随烦恼。一百二十八数是，见道所断惑有十种，即、贪、嗔、痴、慢、疑、身见、边见、邪见、见取见、戒禁取见，这十种烦恼，各障欲界苦集灭道四谛之理，故有四十。障色界四谛理的只有三十六个，因为色界无嗔烦恼，于每一谛下除去嗔惑，故成三十六。障无色界四谛理的烦恼，与色界相同。总合起来，障三界四谛理的烦恼共有一百一十二个。更加上修道所断惑十六种，即成为一百二十八数。十六惑是：欲界六个，上二界各五个。贪、嗔、痴、慢、身见、边见，是欲六惑，上二界无嗔，各有五惑，故三界修道所断惑合有十六个。等流随惑，即二十种。此上所说，唯是自性出体，若据眷属，即同时相应的诸余心心所及五蕴，亦皆是烦恼障摄。
    （2）所知障：此障之体，同烦恼障；即遍计所执法萨迦耶见而为上首，其数与烦恼障同。由烦恼依于所知障立，能依所依，故数相等，此从所障以立障名。有漏无漏有为无为一切诸法，是所应知的境界，由障障彼所知之境，碍能缘心，令心于境，不能解了，障大菩提，是所知之障。若论正障，烦恼障障生空，所知障障法空。若论兼障，则互彼此，当知经教依殊胜作用而说各有所知障。
    还应该知道，轨我执法的萨迦耶见，体无有异，同一种生；现行见分，亦复同一，但以义用有别，故分为二：如一眼识体，缘青黄两境，即是两行相生。唯烦恼障，发业润生，体是缚法。其所知障，义即不然。由烦恼障，缚诸有情恒处生死，其所知障则不如是。补特伽罗我见起位，彼法我见亦必现前，因为我执必依法执而起，如先要迷杌等认识不清，然后才会错误地执为是人等故。能持自体说名为法，即一切法皆持自体。有常一用，方名为我，非一切法皆是常一，如计外境非情诸物为法，而并不计为是我故。是故可以知道，人执起时，必带法执；法执起时，不必皆带人执。这烦恼所知二障皆有分别起和俱生起的差别，分别起的粗，俱生起的细。强思计度而生起的，名为分别；与身俱生任运而起的，名为俱生。分别的二障先断，于见道时一时顿断；俱生的二障后断，修道位中分分断，至金刚心时才能断尽。二乘人唯断烦恼障，大乘人则双断二障。
    （3）伏断位次：灭现行名伏，除种子及习气名断。断的意义，约能断说，是除害义；约所断说，是不续义；自类相生的种子后生的作用不相续，即是断惑。过去未来的法无体，故无所断；现在惑智俱起，亦无所断；但由教行因缘引起正见相应的能治心，此心生时，所治惑种即灭，智生惑灭同一刹那，犹如世间明生暗灭，断惑义成。烦恼所知的分别二障，资粮位渐伏，加行位顿伏。少分伏名渐伏，犹有余故；全分伏名顿伏，更无余故。资粮位伏其粗者，由胜解力折伏；加行位伏其细者，由四寻思四如实观制伏。因邪师邪教所引起的名粗，由自分别所引起的细。分别二障的种子与习气，俱初地断；即于真见道位中的无间道断除种子，解脱道断除习气。
    俱生烦恼障种，亦即修道所断的烦恼障种，由于不障十地，和菩萨须留惑济生，所以不除，但伏现行不起，直待将成佛时，金刚喻定现在前时一切顿断。习气则于十地间地地除之。总起来说，俱生烦恼的现行，地前渐伏，以道力微劣，失念的时候，烦恼现行尚得起故。初地以上，能顿伏尽，如同阿罗汉一样，令永不现行。但菩萨为了化度众生，在前七地中，由故意力，使烦恼种子暂生现行，虽暂现起，而不为过失。如《解深密经》说：‘是诸菩萨于初地中，定于一切诸法法界已善通达；由因此缘，菩萨要知方起烦恼，非为不知，是故说名无染污相。于自身中，不能生苦，故无过失。菩萨生起如是烦恼，于有情界能断苦因，是故彼有无量功德。’但应该知道，故起烦恼的，是不怖烦恼的悲增菩萨。有怖烦恼的智增菩萨，则不起烦恼。到八地以上，道力胜故，纯是无漏观心相续生起，则无论是智增菩萨与悲增菩萨，烦恼都毕竟永不现行了。
    俱生所知障种，亦即修道所断的所知障种，于十地中渐次断灭，金刚喻定现在前时才永断尽。习气则于解脱道中永断。此障的现行，地前加行位能渐制伏，乃至十地才永伏尽。八地以上，与前六识俱起者，不复现行；无漏观心及果相续，违彼障故。无漏观心即第六识中人法二空相本智，果即后得与灭尽定。八地以上，人空无漏恒时相续无有间断，法空无漏多分相续少分间断，故能令第六识中法空无漏不起的时候，唯人空无漏现前，对第七识法执来说，即为粗观，不能制伏细执，故第七识俱生的法执，仍能现行。若法空无漏智及彼所引起的后得智和灭尽定位，则能伏令不起。兹将俱生二障的伏断地位表示如表二：

    （表二）


第四节 果德

上一页 目录 全文完

第四节 果德

    第四节 果德
    一、菩提
    佛位圆证二转依果，为菩提涅槃。菩提是能证的无漏智，涅槃是所证的真如理。菩提是所生得，涅槃是所显得。
    菩提是转有漏杂染的八识而成的四智相应心品：（一）大圆镜智：此智为一切现行功德的所依，如大圆镜，影现种种色像，故名大圆镜智。如《成唯识论》说：‘一、大圆镜智相应心品，谓此心品，离诸分别，所缘行相微细难知，不妄不愚一切境相：性相清净，离诸杂染；纯净圆德，现众依持；能现能生身土智影；无间无断，穷未来际；如大圆镜，现众色像。’（二）平等性智：此智证得诸法平等的理性，及自他平等，变现他受用土，故名平等性智。如《成唯识论》说：‘二、平等性智相应心品，谓此心品观一切法，自他有情，悉皆平等；大慈悲等恒共相应：随诸有情所乐，示现受用身土影像差别；妙观察智不共所依，无住涅槃之所建立；一味相续，穷未来际。’（三）妙观察智：此智善能观察诸法的自相、共相及众生根器，说法断疑，故名妙观察智。如《成唯识论》说：‘三、妙观察智相应心品，谓此心品，善观诸法自相共相，无碍而转，摄观无量总持定门，及所发生功德珍宝，于大众会，能现无边作用差别，皆得自在；雨大法雨，断一切疑；令诸有情，皆获利乐。’（四）成所作智：成就为欲利乐有情的本愿所能作的事，故名成所作智。如《成唯识论》说：‘四、成所作智相应心品，谓此心品，为欲利乐诸有情故，普于十六示现种种变化三业，成本愿力所应作事。’
    菩萨入见道时，转有漏的第六识，成无漏的妙观察智；转有漏的第七识，成平等性智。到佛果位时，转有漏的前五识，成成所作智；转有漏的第八识，成大圆镜智。四智圆满就是佛果位上具有的四智菩提，立表如表三：

    （表三）
    二、涅槃
    证佛位四智圆满的时候，所证的真如妙理，完全显现，即具得四种涅槃：（一）本来自性清净涅槃，这是说一切诸法的真如实性，虽然是由于客尘烦恼障覆令不显现，但其习性本来清净，不生不灭，其性本寂，故名涅槃。如《成唯识论》说：‘一、本来自性清净涅槃，谓一切法相真如理，虽有客染，而本性净，具无数量微妙功德，无生无灭，湛若虚空，一切有情平等共有，与一切法不一不异，离一切相一切分别，寻思路绝，名言道断，唯真圣自内所证，其性本寂，故名涅槃。’（二）有余依涅槃，即由断烦恼障而显现的真知，但有残余所依的异熟法存在，所以名为有余依涅槃。如《成唯识论》说：‘二、有余依涅槃，谓即真如出烦恼障，虽有微苦所依未灭，而障永寂，故名涅槃。’（三）无余依涅槃，即断尽生死苦而显现的真如，烦恼既尽，残余的所依亦灭，众苦永寂，故名涅槃。如《成唯识论》说：‘三、无余依涅槃，谓即真如出生死苦，烦恼既尽，余依亦灭，众苦永寂，故名涅槃。’（四）无住涅槃，即断尽所知障而显现的真知。证这涅槃时，即生起大悲大智。因有大悲故，不住于寂灭的涅槃，而在三界中利乐众生；有大智故，虽在三界里教化众生，以已脱离迷界故，不为生死所染污、所系缚，用而常寂，故称为无住涅槃。如《成唯识论》说：‘四、无住处涅槃，谓即真如出所知障，大悲般若常所□翼，由斯不住生死涅槃，利乐有情，穷未来际，用而常寂，故名涅槃。’
    以上四种涅槃，是依着一实真如的显现义边的差别而安立前四种，实即一清净法界而已。第一种凡亦具有，二乘无学并得前三，唯佛世尊具有四种。立表如表四：

    （表四）
    三、三身
    这四种涅槃，总束为清净法界，加前四智，以为五法。这五法就成为佛果位的自性、受用、变化三身。清净法界是自性身（法身）。如《成唯识论》说：‘一、自性身，谓诸如来真净法界，受用、变化平等所依，离相绝然，绝诸戏论，具无边际真常功德，是一切法平等实性。即此自性，亦名法身：大功德法所依止故。’受用身分自受用和他受用，自受用身是大圆镜智所现，恒自受用广大法乐。他受用身是平等性智所现，为十地菩萨现通说法，决众疑网，令他受用大乘法乐。如《成唯识论》说：‘二、受用身，此有二种：（一）自受用，谓诸如来三无数劫，修集无量福慧资粮所起无边真实功德，及极圆净常遍色身，相续湛然，尽未来际，恒自受用广大法乐。（二）他受用，谓诸如来由平等智示现微妙净功德身，居纯净土，为住十地诸菩萨众，现大神通，转正法轮，决众疑网，令彼受用大乘法乐。合此二种，名受用身。’变化身是成所作智所现，为未登地菩萨众，及二乘异生，随类示现化身，称机说法，令各获得诸利乐事。如《成唯识论》说：‘三、变化身，谓诸如来由成事智变现无量随类化身，居净秽上，为未登地诸菩萨众，二乘异生，称彼机宜，现通说法，令各获得诸利乐事。’妙观察智，于大集会中，说法断疑。立表如表五：

    （表五）
    四、十力
    如来证得实相的妙智，能够了达一切境相，坚固最胜，没有可以破坏和超胜他者，故名为力。力有十种：一、知是处非处智力。处，即合道理义，非处即不合道理的意思。如来于一切因缘果报审实了知，如造作善业，即知其决定得可乐的果报，名为知是处。若造作恶业，能够得到可乐的果报，决定无有是处，名知非处。如是种种，皆悉遍知，故名知是处非处智力。二、知过现未来业报智力，如来于一切众生过去、未来、现在三世的业缘果报生处，皆悉遍知，故名知过现未来业报智力。三、知诸禅解脱三昧智力，如来于诸禅定自在无碍，其浅深次第，如实遍知，故名知诸禅解脱三昧智力。四、知诸根胜劣智力，如来于一切众生的根性胜劣，得果大小，皆实遍知，故名知诸根胜劣智力。五、知种种解智力，如来于诸众生，种种欲乐胜解，善恶不同，皆如实遍知，故名知种种解智力。六、知种种界智力，如来于世间众生，种种界分不同，即种姓差别，与贪嗔等行随眠差别，如实遍知，故名知种种界智力。七、知一切至处道智力，如来于有为无漏行，各知其所至之处，故于至得人间天上的有漏道，至得涅槃的无漏道，如实遍知，故名知一切至处道智力。八、知天眼无碍智力，如来证知天眼清净，见诸众生死时，生时端正丑陋等善恶业缘，尽知无碍，故名知天眼无碍智力。九、知宿命无漏智力，如来于众生种种宿命，从一世乃至百千万世，一劫乃至百千万劫，死此生彼，死彼生此，其姓名饮食苦乐寿命等，如实遍知，故名知宿命无漏智力。十、知永断习气智力，如来于一切惑余习气，永断不生，如实遍知，故名知永断习气智力。
    五、四无所畏
    无所畏是：一、说一切智无所畏，一切智即于世间出世间一切诸法尽知尽见的妙智，如来于大众中自说我是一切智人，余人虽有难言，佛无所畏，以如来实是正等觉者，已证得妙善清净的一切种智故。二、说漏尽无所畏，漏尽即生死惑业俱尽，如来于大众中自说我已永尽诸漏，余人虽作难言，佛无所畏，以如来实已证得妙善清净，于烦恼习气等诸有漏法毕竟永尽故。三、说障道无所畏，如来于大众中说染法是障碍圣道的法，若有难言，习此染法，不能为障，佛通释无果：以如来妙智，于一切所治染法，皆已遍知故。四、说尽苦道无所提，尽苦道即能灭尽诸苦的圣道，如来于大众中自言我所说的圣道，能出离世间，能尽诸苦，余人虽有诘难，说虽修此道不能出离，佛无所畏，以如来于一切种能对治法，已如实遍知故。四无所畏中，前二无畏，依自利德说，后二无畏，依利他德说。无畏即无怯惧，如来智力内充明了，凡有所说，皆安稳清净，不可倾动，无惊怖恐惧，故名为无所畏。
    六、十八不共佛法
    十八不共佛法是：一、身无失，佛从无始劫来，常用戒定慧慈悲以修治其身，这种功德已至满足，一切烦恼俱尽，身无误失业，是名身无失。二、口无失，佛具无量智慧辩才，所说教法，随众机宜，皆得证悟，是名口无失。三、念无失，佛三大阿僧祇劫，修习诸甚深禅定，心不散乱，于诸法中，心无所著，得第一安稳处，故名念无失。四、无异想，佛于一切众生平等普渡，心无拣择；于流转证灭中，证得无分别，无差别智，是名无异想。五、无不定心，佛于行住坐卧一切威仪中，常不离甚深胜定，是名无不定心。六、无不知已舍，佛于一切法，悉皆照知方舍，未有一法不了知而舍弃者；于利益有情事，观察其根性未熟者，虽暂时舍置，终无究竟舍有情事。是名无不知已舍。七、欲无减，佛具众善，常欲度诸众生，心无厌足，是名欲无减。八、精进无减，佛身心精进满足，常度一切众生，无有休息，是名精进无减。九、念无减，佛于三世诸佛之法，一切智慧，相应满足，无有退转，是名念无减。十、慧无减，佛具一切智慧，无量无际不可尽故：随慧而说，亦无有尽。是名慧无减。十一、解脱无减，佛远离一切执着，具二种解脱：（一）有为解脱，即无漏智慧相应的解脱；（二）无为解脱，即一切烦恼净尽无余的解脱，是名解脱无减。十二、解脱知见无减，佛于一切解脱中知见明了，分别无碍，是名解脱知见无减。十三、一切身业随智慧行，佛的身业智为导首，随智而称，示现各种殊胜形相，调伏众生，由智发起演说一切诸法，令其各得解悟证入，是名身业随智慧行。十四、一切语业随智慧行，佛的微妙清净语言，智为导首，随智而转，化导利益一切众生，是名语业随智慧行。十五、一切意业随智慧行，佛的清净意业，智为导首，随智而转，入众生心而为说法，除灭其无明痴惑，是名意业随智慧行。十六、智慧知过去世无碍，佛的智慧照知过去世所有一切，若有情法，若无情法，皆无障碍，是名智慧知过去世无碍。十七、智慧知未来世无碍，佛的智慧照知未来世所有一切，若有情法，若无情法，皆无障碍，是名智慧知未来世无碍。十八、智慧知现在世无碍，佛的智慧照知现在世所有一切，若有情法，若无情法，皆无障碍，是名智慧知现在世无碍。此上十八种功德法，唯佛具有，不共于声闻、独觉、菩萨，故名十八不共佛法。
    如来功德，无量无际，不可具述。如三十二相，八十种好，三不护，三念住，四清净，永断诸习气，无忘失法，大悲，一切种妙智等，清净殊胜，圆满无上。如《大般若经》三百八十一卷和四百六十九卷，《大方等大集经》卷第六，《大宝积经》三十八卷至四十卷，《中阿含三十二相经》，《大智度论》八十八卷，《瑜伽师地论》四十九卷至第五十卷，《显扬圣教论》第四卷和《杂集论》卷十四等，广有解说，乐多知者，应取读诵。

上一页 目录 全文完