《摄大乘论》要义

说这个《摄大乘论》，是咱们早就定下来的，所以就不用多罗索。但实在来说，对唯识典籍我近来一段时间没有费心思了，因为唯识的根本大典我都看过了好多遍，而且也有那么一点儿心得。我发觉现在有不少唯识研究者成了雕虫，有人在雕龙，我们来雕虫，钻到里边儿出不来了。去年咱们开永明延寿法师研讨会，卢璕先生问我一个问题，是四分的问题，安慧论师是一分说，难陀论师是二分说，陈那论师是三分说，护法论师是四分说。相分是认识对象，见分认识相分，自证分认识见分、证自证分，证自证分认识自证分。安慧论师这么说，难陀论师这么说，陈那论师这么说，护法论师又这么说，那么我们该怎么看呢？我记得好象他是问的这个，当时是在虎跑那儿问的，这问的就是雕虫问题，我找了个借口就走了，没回答。还有一个先生，其实我不认识他，可能是他认识我，他问我种子的本有、新熏问题，说有的认为本有，有的认为新熏，有的认为既有本有又有新熏，那么实际情况到底是如何？这问题给卢璕先生的问题一样，都是气死人的雕虫问题。卢璕先生我认识，所以我避开，这位先生我不认识，所以我说你这是“笨家伙问些笨问题，论师们给你了一个笨答案”。在当时就有人问这笨问题，不是现在你才有。论师们给了你一个笨答案了，何必我再给呢？论师们的答案是笨答案，是不对的答案，但起到了堵口的作用，我再给你一个新的答案，也是一个根本就不对的笨答案，仅只是起堵口的作用。越往后来，在起堵口的作用的同时，弊端越明显――给你加了一种分别，第一个答案的时候，只有一个答案，虽然是笨答案，但你是一个笨家伙，所以完全封住了你的口，但第二个笨答案，就有分别了，因为有两个笨答案了，答案又不一样，你就分别了。当然，可能是问者并不知道前边儿已经有一个答案了。现在人已经知道有好几种答案了。越往后分别越多。因为答案越多，这分别还给以前的分别不一样，前边儿是在问题上分别，现在是在答案上分别，现在在《成唯识论》上已经有三、四个笨答案了，还要多少？所以，这雕虫问题就是根本就不值得回答的问题，但他又是认认真真地问，你若是回答，永远没个完，当然，不会没个完的，我要是真的给他回答了，说实在的，只是给他添了一个分别而已。前天从肉身殿过来一个师父，他在五明佛学院呆了好几年，他过来竟然也问这四分问题，真怪透了。

在你们听过之后，我不奢望有多大收获，只要你们听过之后不再问一些雕虫问题，就是很好的了。

这《摄大乘论》实际上不多，咱们手里拿的这个本子，虽然有这么厚，五百六十七页，但真正的论文才七十页，后边儿的是世亲的释和无性的释。这本书印的字儿又这么大，所以说看起来比较多。

我这是第二次讲这《摄大乘论》了，第一次是在九华山讲的，那一次讲得太详细了，而且发挥也多，到最后也没有讲完。这一回讲，我就只是带你们通一下字句而已。尽可能的少扯。因为说实在的，真正的心得很难用话表述得好。

翻开第一页。

摄大乘论本卷一

这是典籍的题目。“摄”就是总持，“总”是概括、总合，或者说是全部，就是这意思。“持”，持的本义应该是握、执，这里引申为掌管、把握。所以，“摄大乘”就是把大乘（佛法）通通都掌管住了、把握住了。你把这部《摄大乘论》学好了，整个大乘佛法就全部掌管在你的手心里了，你就把握住了整个大乘佛法的精要。然后看“大乘”这两个字儿，“大”是得与小对比方能显出来的，它没有绝对。“乘”就是车乘，运载的意思。合起来就是大的车乘。妙老法师说《大般若经》上说“能出能动，名之为乘”，“出”就是从烦恼中出去，“动”是断除你的烦恼。不过我实在记不得《大般若经》中有“能出能动”这样一个词儿，你们自己也有电脑，自己查一下。这里的“大”不单单是大小的意思，还有殊胜的意思。与大乘对应的就是小乘，小乘就不是那么大、不是那么殊胜的意思。大乘可以运载的众生就要比小乘运载的众生多，不然你不叫大乘。大乘也不单单是运载的众生多，而且大乘是可以把你运载到佛地去的，小乘就不行。咱们也得注意，大乘与小乘的关系，小乘是被大乘包含的，这个逻辑关系可不要搞错了。这个乘还有一个意思，就是舍弃。佛教有一个比喻，一个人要过河，过河就得用渡船，当渡船把你渡过了河，你是不用背着渡船走路的，一定要把渡船给舍弃。现在你是要用大乘佛法去渡生死苦海的，同样的道理，大乘教法最终也是得舍弃的，你不能死死的执著这个。再看“论”，“论”就是圣贤的讨论、议论。三藏就是经、律、论，经是理论的基础，比如象《阿含经》、《般若经》、《解深密经》、《法华经》等，这就是佛教的基础，至于佛教常说的绳墨义、贯穿义等等，其实都是比喻义、引申义，说凭经可以把佛教义理给贯穿起来，这是咱们听惯了的说法，其他书上都有。律，是我们的行为规矩，没有规矩不成方圆，规矩一定得要。但我们得知道律的精神――止恶、行善、利他，只要是可以起到止恶、行善、利他这个作用的就是律，现在有人把律讲坏了，尽在一些杂事儿上追究。论，是圣贤们对经义的阐释、开演。经典是原则，它是一个宝藏。现实在不断演化的，但经是不变的，这就要求在经典与现实之间需要沟通，起沟通作用的就是论、疏之类的，当然我们现在的讲记也是，不过讲记得经过时间的验证才行。也就是说，经是教主的行迹，而论是论师们阐释而得到大众普遍接受的权威教义，也就是说，实际上佛教的教义是在论典中体现得最充分，经典中只有原则。“本”，“本”就是原典的意思。有本当然还得有对它的解释，最权威的解释是世亲论师的解释和无性论师的解释。就是我们手边儿的这一本，福建莆田广化寺印的，原文和二个释文都有了。无性论师比世亲晚一些儿，他在作释的时候，参照了世亲的释，有一些补充，所以，我们两个都要看。“卷”，这没啥好说的，以前没有纸，是用的竹木简、帛等，写好以后卷起来就是一捆儿，这就叫“卷”，读平声，可现在都读成仄声了，这是语言的演化。“一”，这儿的“一”是个序数词，是次序、第一。

无著菩萨造

这是作者，这位菩萨是大乘瑜伽学派的创立者，他的生卒时间不清楚，象沈剑英先生、姚南强先生、郑伟宏先生等的书上，都是写成作四世纪，韩廷杰老师是写成四、五世纪，但周文英的《因明在印度的发生和发展》中是写成了310年至390年。吕澂先生说是400至470，还说，也有人说是320至420年之间的人，我还见过说360年等等，这我们不管它。这无著论师先是在小乘化地部出家，或者是在有部出家，不过我估计在有部出家的可能性更大，为什么？这是从唯识教理中觉察的。这记载不一样，象西域记中说是化地部，婆薮槃豆传中说是萨婆多部。当然了，化地部本就是从有部分出来的，所以咋说都没有关系。不管怎么着，反正是小乘。他出家以后，当时呢，中观还是比较流行的，他就也接触到了中观，但因为当时的中观已经堕入了恶取空，无著接触了这所谓的中观之后，觉得不对劲儿，但到底什么是空观（观就是用心的思维），他不知道，他为这个问题费了很大的心神，他的这精神感得宾头卢尊者示现，来给他讲空观。说，比如说，这一张桌子，你把它一分，分成板、钉之类，桌子就空了，你再把板、钉往下分，板、钉又空了……说这就是空。当然，这个是析空观，不是大乘的当体即空。析空观的这种作法，实际上是首先承认有桌子，然后才能分，这个前提就不对。把一个东西一直往下分析，说最后分析出空，这根本是不可能的。因为任何东西都是因缘聚合而成的，只要分析就有因缘存在，如果分析到哪一步没有因缘存在了，那这个东西是怎么来的？这就违反因果规律，如果说分析下去永远有因缘存在，那就永远分析不成空。要不然成为“一尺之棰，日取其半，万世不竭”，这永远也分析不成空。要不然分析到不可再分，承认因果断了，推翻因果律。这两种说法都是违背佛教的。于是无著就到山中独自修定，因为当来下生是弥勒成佛，所以无著就祈求弥勒，说，当来下生你要成佛，你是补处菩萨，你应该来教我空观。他在山中修定一修就是九年，终于见到了弥勒菩萨，弥勒菩萨就为他讲中道空观，从此，无著菩萨就大力弘扬这教法，人们习惯上称之为瑜伽学派，我们要把它与婆罗门教的瑜伽派分清，不要搞混淆了。无著菩萨的瑜伽学派传到中国之后变成了法相唯识宗。

唐三藏法师玄奘奉诏译

玄奘法师是不用多说，都知道。玄奘法师译的经文应该来说是比较严谨的。玄奘法师译经的译场与鸠摩罗什法师的译场比较起来，可能规模小得多，而且没有文士来给润文，所以玄奘法师的译文比较生涩、难读。一般说起来都说玄奘法师还有一个功绩，就是创立唯识宗，我觉得这一个不算。创宗立派实际上就是把佛教进行系统整理。佛教在印度的时候，他有一个先后，先是原始佛教，再是部派佛教，然后是大乘佛教，这次第是清楚的，所以不乱。但在传到中国的时候，他没有次序，是大、小乘在汉朝时候一古脑都进来了。佛教的教典是很庞杂的，一同进来一下子让人无所适从，比如念佛，我是该念还是不该念，是念好还是不念好，有些典籍上说念了有多少多少利益，而有些典籍上说，“以音声求我，是人行邪道，不能见如来”，怎么把这些不同的说法给圆融起来？就需要大师们来对佛教进行系统整理。于是大师们就把这些典籍给排了一下顺序，为啥这样排？就得给说出个理由，这理由就是自己这个宗派的教义。这个工作史称判教工程。作判教工作的大师很多，也就是说宗派很多，我们算一下有好几十个，但成气候的不多。玄奘法师一定不会这样作的，为啥？我们看大师们的判教，其实是大师们自己根据自己的理解在给排序，在佛教中谁最圆满？释迦牟尼！可释迦牟尼在《解深密经》中已经把顺序说出来了，所以玄奘法师只要把这经译出来就行了，根本不用自己来排。自己不用排当然也就不用自己解释这样排的理由，所以他没有创宗立派。有人说，“玄奘法师作为一个译经大师是很成功的，但作为一个创宗立派的大师是很失败的”。这有点儿废话。

这个《摄大乘论》的经本一般来说有四个，现在又多了一个，就五个。一个是佛陀扇多译的，有二卷。一个是真谛法师译的，有三卷。一个就是玄奘法师译的，三卷。这三个译本都是收在大正藏第31册里边儿。另外达摩笈多也译过，你们翻到76页，这是《世亲摄论释叙》，在倒数第五行中说，“译斯本论，凡有四本。一为后魏佛陀扇多。二陈真谛。三隋笈多。四唐玄奘。”这里就举了四个。第五个是韩老译的，弥勒网站上有，叫《总摄大乘纲领论》。

注释呢，常用的有二个，就是世亲释、无性释。世亲释有三个译本，563年真谛法师在译《摄大乘论》的同时译出了世亲释，后来成了摄论宗的根本所依。第二个译本是答摩笈多等译出来的，第三个是玄奘法师译的。至于无性的释则只有玄奘法师的一个译本。

现在有王恩洋的一个疏，印顺老法师的一个讲记，网上有妙老的讲记，还有韩老的讲记，我手边儿还有一个正刚法师的《摄大乘论讲义》，是正刚法师在中国佛学院讲课的记录稿，不过校对的不是甚仔细（补充：罗时宪先生有一个《摄大乘论疏》，是在《罗时宪全集》第六卷里边儿，不过罗先生的疏只是一点儿，《所知依》也没有讲完。罗时宪先生一九九三年去世，其在世时曾被称为第一唯识大家）。参考资料大概就这么多。王恩洋的疏比较难，印顺法师其实是中观家，他讲的唯识实在不纯，拿中观来套。我们知道，中观家讲的唯识实际上不是唯识，他们讲唯识的目的是为了弘中观，他们破唯识的目的实际上是为了在破唯识的过程中显示中观，唯识他们说的根本不对，我们可以以法尊法师的《四宗要义》为标本来观察，确实是这样的。你可以看看妙老法师的和韩老的。在大正藏里还有几个参考资料：有一个《摄大乘论略疏》，在第六十九册，日本人写的；第八十五册也还有几篇，《摄大乘论疏》、《摄大乘论抄》、《摄大乘论章》、《摄论章》等。

这部《摄大乘论》虽然说叫“论”，但它实际上是一个经释，是无著菩萨对《阿毗达磨大乘经·摄大乘品》的一个解释。另外咱们知道，谁解释佛法也不能自己瞎解释，都得有圣言量依据，那么，无著菩萨在这个《摄大乘论》中也引用了不少经论。引用的有《解深密经·心意识相品》，在第三页中说，“如《解深密经》说：阿陀那识甚深细，一切种子如瀑流，我於凡愚不开演，恐彼分别执为我。”这个《解深密经》在唯识宗中占的地位是最重要的，它是根本大典。我们常说的唯识宗所依的经典有六经十一论，实际上有点儿扯，比如《华严经》，说实在的，它与唯识的关系不是十分密切，只不过华严中说到，“应观法界性，一切唯心造”而已，其实在其他经中对唯心论述得更充分。我们说唯识所依的典籍有六经十一论，实际上是窥基法师在《成唯识论述记》中引用的经典有六经十一论而已。《摄大乘论》中对《华严经》的引用如第二十一页中说，“如《十地经》薄伽梵说如是三界皆唯有心。”这《十地经》就是《华严经·十地品》。还引用有增一阿笈摩的经文，在第五页中说，“如彼增一阿笈摩说，世间众生，爱阿赖耶、乐阿赖耶、欣阿赖耶、喜阿赖耶。”还引用有《如来出现功德经》，在第五页的最后一行，“於声闻乘如来出现四德经中，由此异门密意已显阿赖耶识。”接着还引用了大众部阿笈摩，说：“於大众部阿笈摩中，亦以异门密意说此忙根本识”。还引用有《辨中边颂》、《分别瑜伽论》等等。

下边儿就开始说正文。


《摄大乘论》要义

总标纲要分第一

在无著论师本来的著作中，并没有这样的分法，这是后人给分的。现在我们看佛教典籍，发现不少都有科判，这总标纲要分第一、所知依分第二……其实就是简单的科判了。佛教的经论一般情况下有序分、正宗分、流通分，这个总标纲要分第一就相当于序分。这个序分是纲要。

一上来无著论师先成立大乘是佛说。大乘到底是不是佛说的问题，确实是一个古老的问题。到现在人们还提。无著论师在这里成立大乘是佛说，不是用的旁的方法，而是用大乘自身来证大乘。我们就看论文。咱们手里的这本书印的不错，已经把段儿给断了一下子。咱们一般情况下就按这断过的段儿。

阿毗达磨大乘经中，薄伽梵前，已能善入大乘菩萨，为显大乘体大故说。谓依大乘，诸佛世尊有十相殊胜殊胜语：一者、所知依殊胜殊胜语；二者、所知相殊胜殊胜语；三者、入所知相殊胜殊胜语；四者、彼入因果殊胜殊胜语；五者、彼因果修差别殊胜殊胜语；六者、即於如是修差别中增上戒殊胜殊胜语；七者、即於此中增上心殊胜殊胜语；八者、即於此中增上慧殊胜殊胜语；九者、彼果断殊胜殊胜语；十者、彼果智殊胜殊胜语。由此所说诸佛世尊契经诸句，显于大乘真是佛语。

第一句话是“阿毗达磨大乘经中，薄伽梵前，已能善入大乘菩萨，为显大乘体大故说。”这一句话是无著论师在介绍自己造这部论的目的。在一般的说法中，都说利乐有情故如何如何的，这里呢，无著论师没那么说。《阿毗达磨大乘经》是无著论师写这部《摄大乘论》的根本所依，所以，一上来无著论师就先说明了这个，也就是说，我下边儿文字的思想都是有来源的。可惜的是，这部《阿毗达磨大乘经》没有翻译到中国来，所以我们只能凭无著论师的这个《摄大乘论》来了解这部经。“阿毗达磨”是梵语的音译，用汉语说就是“对法”，“对”就是向、趣向，趣向什么呢？趣向于“法”，这里的“法”当然是指佛法了，不是指别的什么，当你趣向于佛法的时候，你才可以得涅槃、证菩提。罗时宪先生疏中说，当阿毗达磨作对法讲的时候，“法”应该指无住涅槃。“阿毗达磨”的“阿毗”还有“伏”的意思，那么，“达磨”这个“法”就应该是指一切的种种邪论。“薄伽梵”，就是佛陀，有好多意思。能破义：就是说薄伽梵可以摧破一切烦恼。有德义：佛具足无量的功德。有名声义：世出世间都知道佛。巧分别义：佛可以善巧地分别一切法、非法。自在义：没有烦恼。等等，还有不少说法。“已能善入大乘菩萨”就是圣者了，可不是指我们这些初发心菩萨。“菩萨”是觉有情，就是可以使有情觉悟者。“体大”就是指教、理、行、果全都是最殊胜的。教就是语言文字。理是佛法之理。这是很重要的，我常说大乘佛教的语殊胜、义殊胜，这两个是联系在一起的，可不能分开，象现在有人把《心经》配上流行音乐在大街上传唱，还要搞一些白话佛经之类，这都是损害佛教的殊胜语，语损失义也随之损失，这都是要不得的。行就是行持。大乘的行持也是殊胜的，有六度万行。果是果位。大乘的果也是殊胜的，是得大菩提。这一句话就是说，那些圣位菩萨，在佛陀面前，为了劝我们学习大乘教法、发无上心而说了《阿毗达磨大乘经》。我无著现在来解说这《阿毗达磨大乘经·摄大乘品》当然也是这个目的。当时我们学这部论的时候，老师说这句话有两个暗示，一个是暗示这部经不是佛所说，是菩萨所说而被佛印可了。另一个是暗示无著论师自己已经不是凡夫，而是善入大乘的菩萨。这个我们不管。

“谓依大乘，诸佛世尊有十相殊胜殊胜语。”再看这一句。上一句说为了显示大乘体大故说，这一句就具体地说说了什么。说根据大乘教法，诸佛有十种特别殊胜之处。这个“十相”的“相”就是表现出来可以被我们认识者。这个“殊胜殊胜”的第一个殊胜，应该是“摩诃”的同意词，超越义。也就是所显示的法。第二个殊胜是能显示的教，也就是语言文字。也就是说，第一个殊胜是理，第二个殊胜是教。也就是义殊胜、语殊胜。世亲说，“义因殊胜，故语果是殊胜”，也就是说，第一个殊胜是因，第二个殊胜是果。具体的十种殊胜之处是什么呢？就是“一者、所知依殊胜殊胜语。二者、所知相殊胜殊胜语。三者、入所知相殊胜殊胜语。四者、彼入因果殊胜殊胜语。五者、彼因果修差别殊胜殊胜语。六者、即于如是修差别中增上戒殊胜殊胜语。七者、即于此中增上心殊胜殊胜语。八者、即于此中增上慧殊胜殊胜语。九者、彼果断殊胜殊胜语。十者、彼果智殊胜殊胜语。”其实这部《摄大乘论》就是讲了这十相，下边儿就是按照这十相来讲的。因为表现出了这十相，所以我们才说他殊胜。现在咱们只简单知道一下，后边儿再详细说。“由此所说诸佛世尊契经诸句，显于大乘真是佛语。”大乘是不是佛说，通过这十相就可以显示出来，确实是佛说！

复次，云何能显？由此所说十处，于声闻乘曾不见说，唯大乘中处处见说，谓阿赖耶识，说名所知依体。三种自性：一、依他起自性，二、遍计所执自性，三、圆成实自性，说名所知相体。唯识性，说名入所知相体。六波罗蜜多，说名彼入因果体。菩萨十地，说名彼因果修差别体。菩萨律仪，说名此中增上戒体。首楞伽摩，虚空藏等诸三摩地，说名此中增上心体。无分别智，说名此中增上慧体。无住涅槃，说名彼果断体。三种佛身：一、自性身，二、受用身，三、变化身，说名彼果智体。由此所说十处，显于大乘异声闻乘；又显最胜，世尊但为菩萨宣说。是故应知但依大乘，诸佛世尊有十相殊胜殊胜语。

“复次，云何能显？由此所说十处，于声闻乘曾不见说，唯大乘中处处见说。”大乘法是殊胜的，凭什么说大乘法殊胜呢？就是因为这十相殊胜在声闻乘、缘觉乘里都是没有的，只是在大乘中说得是相当的充分，所以这才是殊胜殊胜语。“谓阿赖耶识，说名所知依体。”这是所知依殊胜殊胜语。所知依殊胜殊胜语中的“所知”就是“所应可知”，这是世亲论师这么说的。什么是所应可知的呢？就是“杂染清净诸法”，也就是一切现行法，不管你是清净的还是杂染。现行法的所依呢，就是阿赖耶。阿赖耶有能藏、所藏、执藏之义，它是因，一切都是依此而成立的，阿赖耶就是所知依。在小乘教中间也曾提到过阿赖耶，只不过当时的人们没有留心过它而已，佛陀也没有郑重其事地讲过。只有在大乘教中佛陀才开演了，所以说这阿赖耶超越于小乘教，所以传载这一法门的语言也是殊胜的，这就叫所知依殊胜殊胜语。这儿有一点儿不同的说法，在世亲论师的释中说是指一切清净杂染诸法，你们翻一下，在八十四页。而无性释不是这么说的，说是“不取无为”，在三百Ｏ四页，你们自己看一下就行了。“三种自性：一、依他起自性，二、遍计所执自性，三、圆成实自性，说名所知相体。”这是所知相殊胜殊胜语。这里边儿就是讲了三性，说遍计执是我们的妄执，根本就不存在，一点儿影子也没有，但我们不知道它虚幻，老认为它有。依他起是指依因托缘而生的法，它本身是没有的，因为有了因缘所以就现出了它。圆成实是二空所显的最真实性。三性可以界定一切法，但在小乘教中没有说到三性，只有在大乘教法中才说到，所以这是殊胜的，传载这一法门的语言也是殊胜的，这就叫所知相殊胜殊胜语。这也就是把所知依分成三自性来说明。“三自性”的“自”就是事物本身、事实本身；“性”就是相，性与相在佛教中是互训的，就是相貌。咱们老把中观叫性宗，把唯识叫相宗，这是习惯叫法，但不妥当。中观所依的是根本是般若，唯识是瑜伽，“瑜伽者，乃般若之异名也”，根本就是一回事儿。“三自性”就是事物自身的相貌有三种情况。我们现在所面对的实际上通通都是遍计执，但如果说我们都是遍计执我们会害怕，所以佛就说其中的某一些是依他起，但实际上依他起是登地之后才能见到的，现在一点儿也没有。你看，佛教是不是很奇特？它是如此的与我们格格不入，我们说是实在的，他非说是虚幻的，我们认为是虚假的，他非说是真实的。这给照镜子是一样的，我是左，镜子里就是右，我是右，镜子里就是左，刚好给我们是反着的。我们认为这张桌子是如此的真实，他非说“桌子”虚幻。把“佛教”这两个字换成“唯识”，唯识是如此的奇妙，它与我们平常的观念是如此的不相容，以致于我们在实际应用的狭隘背景中根本无法理解它。“唯识性，说名入所知相体。”这是第三入所知相殊胜殊胜语。由无漏般若智慧悟入所知的实性，真正悟入诸法的真实性，这就通达了胜义唯识性。这得凭唯识观的修行才可以，第一步是先明白面对的一切是内心的分别，所分别的这些境界都是虚假的、空幻的，这样思惟观察。要是在定中观察更好，观察见闻觉知的一切事情，都虚妄不实，说离开了我们的分别心就没有见闻觉知了。第二步观察这一念分别心也了不可得，这时能所双泯，圆成实性显现，这就是唯识性。能所双泯就是不二法门，就是一合相。但我们现在却是先设一个二，然后再把它合起来，这方法是绝对错误的。这修行主要是凭加行智来修行的。这入所知相在小乘教中是没有提到过的，大乘中方才有，这是殊胜的地方，传载这一法门的语言也是殊胜的，叫入所知相殊胜殊胜语。“六波罗蜜多，说名彼入因果体。”这是第四彼入因果殊胜殊胜语。在第三中说要悟入唯识性，要想悟入唯识性，那就得有六波罗密，也就是布施、持戒、忍辱、精进、禅定、般若。六波罗密就是帮助你悟入唯识性的。在地前是修世间波罗密，这个时候所修的六波罗密，是“因”，对六波罗密不断地修，就悟入唯识性、登地。登地后还修六波罗密，这是出世波罗密，这时则是“果”。六波罗密法门在小乘教中是没有的，只有大乘教法中才有，所以是殊胜的，传载这一法门的语言也是殊胜的，这叫彼入因果殊胜殊胜语。“菩萨十地，说名彼因果修差别体。”这是第五彼因果修差别殊胜殊胜语。菩萨的十地，就是：一、欢喜地，或者说是极喜地；二、离垢地；三、发光地；四、焰慧地；五，难胜地；六、现前地；七、远行地；八、不动地；九、善慧地；十、法云地。地前菩萨修波罗密分分不同，但登地以后，地地修波罗密，地地展转增上。这因果修差别小乘教中没有，是大乘教中才有的，所以殊胜，传载这一法门的语言也是殊胜的，这叫因果修差别殊胜殊胜语。注意，“彼因果修差别体”的因是十地，十地都是因，而果是佛果。“菩萨律仪，说名此中增上戒体。”这是第六如是修差别中增上戒殊胜殊胜语。这菩萨戒，有摄律仪戒、摄善法戒、饶益有情戒，就是我们常说的三聚净戒。小乘戒说有所不为，菩萨戒不但要有所不为，而且还要有为所应为，这是小乘教中所没有的，这是殊胜的，传载这一法门的语言是殊胜的，这叫增上戒殊胜殊胜语。“首楞伽摩，虚空藏等诸三摩地，说名此中增上心体。”这第七增上心殊胜殊胜语是讲定的。定是心的安定，所以叫增上心。说，十地菩萨在内心依定而学，心定了才能修学佛法。比如首楞严三昧，象这种大定在小乘教中是没有的，只有大乘教才有，所以殊胜，传载这一法门的语言也是殊胜的，这叫增上心殊胜殊胜语。这“首楞伽摩”就是通常说的楞严大定。一般是说成“健行”，“健”就是健康，健康的人就是圣者，我们都不算健康的人，我们都有无明大病。“行”就是行为、修行，这是健康的人的行为，也就是说楞严大定是圣者的修行，境界非常非常高。“虚空藏”也是一种定，是指菩萨与法性相应了的三摩地，在真如三昧里修六波罗蜜，这就叫做虚空藏三昧。不是有一位菩萨叫虚空藏菩萨吗？是有的。“无分别智，说名此中增上慧体。”这是第八增上慧殊胜殊胜语。这讲的无分别智，有三种，加行无分别智、根本无分别智、后得无分别智。在咱们一般的说法中，“分别”就是遇到境界后用心观察思维，“无分别”是指对分别的超越，可不是没有分别的意思。我们现在一般说的“无分别”实际上是如理作意而已，不是这儿要求的增上慧无分别。理解成了对分别的否定，说不分别这在小乘教中没有，是殊胜的，传载这个法门的语言是殊胜的，这就叫增上慧殊胜殊胜语。“无住涅槃，说名彼果断体”，第九是彼果断殊胜殊胜语，讲的是无住涅槃，无住涅槃就是不住生死、不住涅槃。二乘行者修行到涅槃后，就安住于涅槃了，菩萨行者则因为大悲心，观察到众生之苦，他还要度众生，所以他不住于涅槃，这叫无住涅槃。前面第一、第二殊胜殊胜语是唯识观，用境、行、果来说，是境；从第三到第八增上慧一直是在修行，用境、行、果来说，是行。这第九和下边儿的第十是证果。这在小乘教中没有，是殊胜的，传载这一法门的语言也是殊胜的，所以这叫彼果断殊胜殊胜语。“三种佛身：一、自性身，二、受用身，三、变化身，说名彼果智体。”这是第十彼果智殊胜殊胜语。三种佛身就是自性身、受用身、变化身。自性身是真如、是本来面目。受用身是为十地菩萨说法的。因为菩萨的功德还没有圆满，还得向佛学法。这受用身各地所见皆不相同。变化身是为地前菩萨及凡夫、二乘说法的。为加行位现千丈大身，为资粮位菩萨及二乘现丈六金身，为其他的则各随其类而现。这是在小乘教中也没有的，所以殊胜，传载这一法门的语言也是殊胜的，叫彼果智殊胜殊胜语。“由此所说十处，显于大乘异声闻乘；又显最胜，世尊但为菩萨宣说。是故应知但依大乘，诸佛世尊有十相殊胜殊胜语。”这十相是不同于声闻、缘觉的，是佛陀单为菩萨开的小灶。我们知道，大乘和小乘最重要的不同是大悲心，这一点儿要记住。因为与小乘不同，所以说，这十相是殊胜殊胜语。其中的不同于声闻乘、缘觉乘是殊胜的第一个意思：分别、差别。而佛陀单为菩萨开小灶是殊胜的第二义：超胜义。下边儿就挨着说大乘是佛说了。

复次，云何由此十相殊胜殊胜如来语故，显于大乘真是佛语，遮声闻乘是大乘性？由此十处于声闻乘曾不见说，惟大乘中处处见说。谓此十处，是最能引大菩提性；是善成立；随顺无违；为能证得一切智智。

要证明大乘是佛说，我们通常会用的方法，可能就是举出一些旁证，而无著菩萨呢，在这里则是凭大乘自身来证明大乘是佛说的，这个思路是与一般人不一样。有些人用因明方法来证明，你们翻到三百六十五页，这是无性释的卷三，左边儿这个框里边儿，第三行儿，“大乘教真是佛语，一切不违补特伽罗无我性故”，这里没有同喻。在大正藏第六十九册里，有一部《四种相违私记（上）》，署名是“东南权大僧都记”，里边儿有这么几句话，“胜军论师云有过，改‘两俱极成非诸佛语’；玄奘亦云有能过，后改‘自许极成非诸佛语’……”就是说，胜军论师认为无性论师的式子有过，把无性论师的式子的因支给改成了“两俱极成非诸佛语所不摄故”，玄奘法师见到以后，说胜军论师改过后还是有毛病，就给改成了“自许极成非诸佛语所不摄故。”看，用因明法子来论证是多么麻烦。无著论师用的法子呢，则简洁得多了，他是用大乘自己来证明自己是佛说。

“复次，云何由此十相殊胜殊胜如来语故，显于大乘真是佛语，遮声闻乘是大乘性？”说，凭这十相殊胜就可以证明大乘是佛说了？“遮声闻乘是大乘性”是指，因为有人不承认大乘是佛说，他们说佛也是按阿含教法修行而成就的，他们就说，如果把成佛的教法叫大乘的话，阿含教法就是大乘，现在无著菩萨的这句话就是说，阿含教法是声闻乘而不是大乘。在《大乘庄严经论》中举出了五条：发心不同，教授不同，方便不同，住持不同，时节不同。因为有这五条不同，所以阿含教法之类是声闻乘，绝对不是大乘。“由此十处于声闻乘曾不见说，唯大乘中处处见说。”这十相殊胜殊胜语在声闻教法里没有，唯独大乘佛法里面才有说，而且在很多地方说到过·。“谓此十处，是最能引大菩提性；是善成立；随顺无违；为能证得一切智智。”这十相殊胜为什么是佛说呢？就因为它能够引发大菩提性。“大菩提”就是无上菩提。这十相殊胜有此功能。“是善成立”，就是“能引大菩提性”这件事是能成立的。“随顺无违”，你按照这十相去修行，它能随顺无上菩提，能趣向于无上菩提。“无违”是没有障碍的意思。“为能证得一切智智”，你只要按这十相修行，就能够证得无上菩提，所以这是大乘，所以这就是佛说。除了佛还有谁能说出这样圆满的教法呢？如果这不是佛说，那么啥才是佛说的呢？所以这一定是佛说！“能引大菩提性”是因，是发无上菩提心；这个“随顺无违”，就是你随顺它去修行，这是行，“能证得一切智智”就是果了。“一切智智”的“一切智”是根本智，第二个“智”是后得智。《仁王护国般若波罗蜜多经·菩萨行品》中说，“自性清净名本觉性，即是诸佛一切智智”。《大日经疏》卷一释中说，“今谓一切智智，即是智中之智也”（大正藏第39册第585页上栏）

此中二颂：

所知依及所知相 彼入因果彼修异

三学彼果断及智 最上乘摄是殊胜

此说此余见不见 由此最胜菩提因

故许大乘真佛语 由说十处故殊胜

这二个颂子要这样读，“所知依及所知相，彼入因果，彼修异，三学，彼果断及智，最上乘摄是殊胜。此说此余见不见，由此最胜菩提因，故许大乘真佛语，由说十处故殊胜。”

这颂子的前三句举列十相，后一句显十相殊胜。“所知依”是第一相殊胜殊胜语。“及所知相”是第二相。“彼入因果彼修异”是第三相入所知相殊胜殊胜语、第四相彼入因果殊胜殊胜语、第五相彼因果修差别殊胜殊胜语。“三学”是指第六相增上戒殊胜殊胜语、第七相增上心殊胜殊胜语、第八增上慧殊胜殊胜语。“彼果断及智”是第九相果断殊胜殊胜语、第十果智殊胜殊胜语。“最上乘摄是殊胜”是说这十相属于最上乘、最殊胜的。“此说此余见不见”，“此说” 就是这说法，也就是指十相殊胜殊胜语。“此余见不见”应该是“此见余不见”，“此见”是指大乘教法里有，“余不见” 是指小乘教法里没有。“由此最胜菩提因”，就是前面“能引大菩提性”，此十相是最殊胜菩提的因，按它来修习，就可以证悟菩提。“故许大乘真佛语”，所以大乘一定是佛说。“由说十处故殊胜”，所以说这十相殊胜殊胜语。

复次，云何如是次第说此十处？谓诸菩萨于诸法因要先善已，方于缘起应得善巧。次后于缘所生诸法，应善其相，善能远离增益损减二边过故。次后如是善修菩萨应正通达，善所取相，令从诸障心得解脱。次后通达所知相已，先加行位六波罗蜜多，由证得故应更成满，增上意乐得清净故。次后清净意乐所摄六波罗密多，于十地中分分差别，应勤修习；谓要经三无数大劫。次后于三菩萨所学，应令圆满。既圆满已，彼果涅槃及与无上正等菩提，应现等证。故说十处如是次第。又此中说一切大乘皆得究竟

“复次，云何如是次第说此十处？”为什么十相的次序要这样安排呢？佛教是讲顺序的，宗喀巴大师说，“一失次第，即成魔业”，律典中说，“无前无后，愚痴之人”。那么，现在为什么要把所知依放在第一位，把所知相放在第二位，乃至把果断放第九、果智放第十呢？这次序能不能打乱再来排排呢？你既然这么排了，就得给出一个理由来。“谓诸菩萨于诸法因要先善已，方于缘起应得善巧。”这一句是说为什么要先说所知依――阿赖耶。说，干什么就要先知道其因，所以“诸法因”要先知道，阿赖耶是因，当然得先知道这个，当你知道了阿赖耶识，你就知道了一切法缘起，“应得善巧”就是应该能够通达，“应得”是应该能够知道、得到，就是自然得到了的意思。当你知道了因――阿赖耶，很自然就可以知道（缘起）了。“善巧”就是没有谬误。没有谬误的“谬误”最主要的有这么一些，一个是不平等因，比如说，一切都是上帝造的，那么上帝是谁造的？我们都有因――上帝，只有上帝不需要因！这不平等。另一个是偶然而生、自然而生，不需要因，没因。就是万法自在――本来就存在！佛教说要把因缘搞清楚，乐有乐的因缘，苦有苦的因缘，万法自有因，不相混乱。没有谬误也就是正知正见。另外一个，“善巧”不但是自己有正知正见，而且在对别人说的时候也能说得好，不会给别人形成障碍。现在有不少这样的人，在说法的时候，老背包（河南方言），佛教是要利益众生的，为了达到这个目的，你就一定得走些弯路，世间根本不存在直线，所以你不可能走直路的。对于“善巧”，这个更常用。“次后于缘所生诸法，应善其相，善能远离增益损减二边过故。”这是为什么要在第二说所知相。说，我们对诸法因得了善巧之后，那么对于诸缘所生之诸法，要了解其体相。“于缘所生诸法”当然是果，是依他起的。依他起是说诸法都是因缘所生的，遍计执是没有体性的。我们执著因缘生法里面有我可得、有法可得，这都是我们的虚妄分别、无中生有。“善能远离增益损减二边过故”的“增益”是增益执，就是根本没有的你却非给加上去，也就是我们常说的头上安头。“减损”是减损执，就是本来有的，你非说没有，这当然也是错误。“善能远离增益损减二边过”就是指我们认清诸法的本质，不要在诸法上加上什么或减损什么，人家是什么样就是什么样儿，说实在的，你想加也加不上去，你想减也减不掉！但我们现在都是在费尽心神做一些根本就不可能做到的事。你说傻不傻！不过这儿的增益执、减损执是说的什么呢？是说，遍计执是根本就没有的，它是我们强加上去的，我们要去掉。遍计执只有增益执。圆成实你是去不掉的～～圆成实上只有减损执。依他起呢？你要是说无，那是减损执，你要是说它实有，那是增益执。那你说我们到底该怎么说？要当说有时说有，当说无时说无！随着情况的变化而变化！“二边过”的“边”是指非中道，佛教是讲中道的。这儿要注意，佛教的中道与儒家的中庸，这不一样，从本质上就不一样。自从南北朝、唐宋之后，三教合一思潮大流行，就使人们看不清二者本质的不同之处了。当时的三教合一刻意地模糊三教的本质差异，说三教本质上一致，纯粹瞎扯，要是三教一致的话，我们的祖师大德历尽千辛万苦到西天求法，西天的祖师大德又历尽千辛万苦东来弘法，他们不是吃饱了撑得吗？正因为不一样所以才需要祖师们西来东去，他们的所为才有了意义。三教合一在现在该退出历史舞台了。中道是必须这样、必须那样，是不同时的；中庸是既可以这样、也可以那样，是同时的。“次后如是善修菩萨，应正通达善所取相，令从诸障心得解脱。”这是第三。前边儿所知依、所知相是说明缘起缘生的，下边儿就该说修行的事了。“次后如是善修菩萨”，对于所知依、所知相通达了以后，就该好好地修行，发心修学圣道，把我们的正知正见发扬光大。前边儿是说你在认识上分清了正见邪见，但在行为上因为惯性的力量，你控制不住，所以要修，用修来加强正知正见的力量。这就叫做“善修菩萨”。你能够修行了，但是该怎么修行呢？“应正通达，善所取相”，要时时注意自己的心，因为一切都是心变现的，对所变现的这一切法，要善巧通达，知道所变现的这一切都是虚幻的。“善所取相”就是指对我们的心所取的一切相的境界都清清楚楚，知道它们其实是我们的虚妄分别。这就是说，要调整我们自己的心态。“令从诸障心得解脱”，使我们的心从诸障中解脱出来。“诸障”就是烦恼障、所知障。烦恼障是指我们情绪方面的不如意，所知障是指障碍我们认识的。现在很多人说，知道得越多，障碍越大，这就叫所知障，把知道的知识变成了所知障，这是把所知障弄错了。你可以下去再查一下佛学词典。到啥时候才能从诸障中解脱出来？入圣位，就是登初地。当然了，登初地后你还是会有障的，不过你正念一提起来，障就没有了。现在我们凡夫，正念根本提不起来。“次后通达所知相已，先加行位六波罗密多，由证得故应更成满，增上意乐得清净故。”修唯识观，由加行位到了见道位，然后呢？“次后通达所知相已”，你已经善巧通达了一切法的真实相，知道它们是空。“先加行位”，“先”是指还没有见道的时候，那时候，你还是在加行位，在加行位就是努力修行六波罗密，毫不懈怠，然后你就证得了，“由证得故”，证得就是入圣位。入了圣位之后，“应更成满”，你应该再努力，尽量使你一切圆满。“增上意乐”的“意乐”，从本质上来说，就是欲、胜解。“欲”，就是希望，强烈的希望，我强烈的希望证得圣果。你们可能以前也知道，欲有善法欲之类的分法，我们现在只说善法欲，实际上在这儿你也不会有别的，只会有善法欲。“胜解”就是对一个事儿的认识极其深刻，不单单是在文字上理解了。这里是指对佛法的胜解。“增上意乐”的“增上”，应该是个使动词，使意乐增上，也就是使善法欲增上，使对佛法的胜解增上。“得清净故”，是说，在我们还没有得无生法忍的时候，这个增上意乐虽然是我们的功德，但是有一点不清净，我们的我执还有、分别心还是有，现在呢，因为修行六波罗密多，证得了无生法忍，把分别的我执消灭了，这样就清净了。不过并不是究竟清净。“次后清净意乐所摄六波罗密多，于十地中分分差别，应勤修习；谓要经三无数大劫。”这是第五。在第四的时候修唯识观得无生法忍，这第五是说，得了无生法忍之后，初地、二地、三地……一直往上，这时六波罗密展转。“清净意乐所摄六波罗密多”是指得无生法忍之后，因为般若，所以六波罗密多都摄在了清净意乐里，这是以无上菩提心为先导，以无所得为方便，以般若统摄六波罗密多。“于十地中分分差别”，初地、二地、三地……的波罗密多各不相同，一地比一地殊胜。这样的精进修行，得有三无数大劫。三大劫一般这样划分：从发菩提心开始修行到登初地是一大阿僧祇劫，从登初地开始到登八地是一大阿僧祇劫，从八地到成佛是一大阿僧祇劫。“次后于三菩萨所学，应令圆满。”这是第六、第七、第八，放在一起说了。“三菩萨所学”就是增上戒、增上心、增上慧，这三学实际上还是六波罗密的开合，得把三菩萨所学，学得圆满究竟。“既圆满已，彼果涅槃及与无上正等菩提，应现等证。”这是第九、第十，“既圆满已”就是指六波罗密圆满、三学圆满，“彼果涅槃”就是“彼果断”，“及与无上正等菩提”就是“彼果智”。“彼果断”是断德，就是烦恼障、所知障究竟清净了。“彼果智”是自性身、受用身、变化身三身显现了。“应现等证”就是彼果断圆满、彼果智圆满。“故说十处如是次第。”这次序实际上是从因地修行到究竟圆满的次地，所以不可乱。“又此说中一切大乘皆得究竟。”这十相就包括了一切大乘义理，信、解、行、证都具足了。“皆得究竟”就是指一切都包括，当然是指一切大乘教法都包括。

这一段儿呢，消文就是这样的。我再稍微说一下。十相为什么要这样排？因为菩萨修学的关键是认识宇宙人生的真实相，怎么认识？只能用三量认识，现量就是无漏般若智亲证，还有圣教量和比量，除了这三量以外，你没有别的法子。注意这里我说的现量，我们因明中说的现量与这是有差距的，注意区别。也就是说，我们现在只能凭圣教量、比量，目下我们还用不上现量。我们依圣教量引发大菩提的因性，了解佛法的真实义，依之修行，积聚资粮，得般若智，以般若智来把握宇宙人生的真实，这就可以转凡成圣。要认识宇宙人生的真理，就要能界定真实，真正了知缘起，缘起有亲因有助缘，我们得知道因缘，什么是真因实缘呢？阿赖耶识种子习气，在佛没有说阿赖耶的时候，我们不知道真因实缘，不知道真因实缘，我们就不能真正认识缘起，所以所知依要排在第一。诸现行法，我们也得知道，我们得知道哪是真实的哪是虚幻的，不要增益遍计执，不要减损圆成实，对于依他起也得认清。在我们的认识世界里，有许多都是我们主观构造出来的，我们在增益遍计执，也就减损了真实，当然真实是减损不了的，但在内心中我们给减损了。我们要认识缘生法的依他起相，才能够远离增益、减损二执，这是所知相。要真正知道缘起因、缘生法（缘起是强调因、缘生是强调果），是很不容易的，必须透过无漏般若智，所以第三是入所知相。所知依、所知相是依言教了解佛法的真实，未涉及具体修行方法，在入所知相为通达真实阐说如何悟入真实方法，也就是修方便唯识观。在修行佛法的过程中，为了着重说明修行的具体方法，于是对于整个佛法的修行历程，从初发心到成佛，具体的修行应该怎样，六波罗密就是一个概括性的总述。以悟入真实为分界线，在地前修六波罗密，是世间有漏心修的。加行位是从初发心到见道、登地，这是入唯识性的因。地上修六波罗密是出世间无漏心修的，八地根本智亲证真如，就可证得清净增上意乐，清净增上意乐摄受六波罗密。菩萨修学佛法不仅以无漏根本智亲证真如，最终要获得菩提大果，所以必须修习圆满清净增上意乐所摄的六波罗密，这是入唯识性的果。清净增上意乐说明菩萨在地上修六波罗密，都是在清净无漏智慧的摄持下，对佛法有强有力的胜解、希求，称彼入因果。这是第四。第五呢是彼入因果修差别。在修习佛法的过程中，总的修行是六波罗密，但前后是不一样的，后边儿比前边儿更殊胜。前边儿说修行的方法是六波罗密，也可以用三学概括。六波罗密能够显示自他俱利的功能，三学只表示自己的成佛，所以圣教中把六波罗密放在前而三学放在后。六度中的布施、持戒、忍辱、精进是定的加行，属于戒学，禅定就是定学，般若是慧学。第六、第七、第八就是戒、定、慧，增上戒、增上心、增上慧。在因中修六波罗密（三学），究竟圆满，永断一切障，得断果的无住涅槃；得三种佛身的显现，证得无上菩提智果，所以，第九、第十是果断、果智，把这二个放在最后。

咱们看了这个，就应该知道一点儿，无著菩萨要论证大乘是佛说，所用的方法非同一般，

总标纲要分到此就结束了。


《摄大乘论》要义

所知依分第二

在总标纲要分中已经把线索标出来了，现在还得详细地说明。标题“所知依分第二”中的“所知依”，就是阿赖耶。“第二”是次序，第一是总标纲要，第二是所知依。看正文。

此中最初且说所知依即阿赖耶识。

本论一开始正文就要先说所知依――阿赖耶。“此中”就是这里；“且说”的“且”是将要的意思，表示下边儿马上就要开始说了，这个“且”要是放在句首的话，是做语助，这里不是句首。这里要先说说所知依就是阿赖耶。关于阿赖耶，大乘要成立它，你就得有理由，无著论师是先用圣教量成立，再用比量成立。下边儿我们就看。

世尊何处说阿赖耶识名阿赖耶识？

这是一个问，是大乘模拟反对派的口气而发问。说：你说阿赖耶不行，得释迦牟尼佛说那才行，我只信服释迦牟尼，你们说的不管用。释迦牟尼说过阿赖耶吗？这一个问呢，实际上是这样的，先是说：释迦牟尼说所知依是阿赖耶吗？就是说我们所面对的一切的所依处是阿赖耶，这是佛说的吗？在哪儿说的呢？再是说：阿赖耶真的就是阿赖耶吗？也就是说，释迦牟尼说的阿赖耶真的就是阿赖耶吗？就是说，佛这话是不是方便说呢？

谓薄伽梵于阿毘达磨大乘经伽陀中说：无始时来界，一切法等依，由此有诸趣，及涅槃证得。

外人问了，说佛在哪儿说的阿赖耶？小乘说我怎么没听说过呢～～现在就是说，释迦牟尼佛确实是说过阿赖耶，这不是我们瞎编的。说，比如说在《阿毗达磨大乘经》中，就有这样的话：无始时来界，一切法等依，由此有诸趣，及涅槃证得。说，我们从这几句话中就可以知道。“薄伽梵”就是佛。“伽陀”就是颂子。说我们从这个颂子中就可以知道阿赖耶。“无始时来界”的“始”就是开头，“无始”就是没有开头，“无始时”就是没有开始的时间，你向前找，根本就找不到一个开头，找不到一个开始。对时间的理解，印度和中国的民族习俗差异很大，印度不注意时间，中国相对来说注意得多。经典中间常是“如是我闻，一时，佛在舍卫国”之类，就是有那么一个时候，到底啥时候，不知道。法师们讲经的时候，说这是时成就，说要是有具体的时间的话就不是时成就了，你可能会说，那是某个年代的情况了，现在已经不合适了，现在是“一时”，根本不说具体时间，你怎么比？这是有些侃了。你写“一时”也不耽误这问题的出现，这其实是民族特点而已。根本不用那么玄的，但宗教必须保持神秘，没有神秘感就不是宗教了。为什么不说具体时间呢？主要是人们的思维会不由自主的联想，比如我给你说秦朝时，你立马就想到秦朝的某事儿，这是“法尔俱思维”。我记得说过一个咒语为什么尽用冷僻字的事儿，就是为了挡住你的思维。现在不说具体时间也是这个意思。

“界”就是因，就是所知依的依，也就是种子，就是阿赖耶里边儿的种子。这里的种子包括染污的种子也包括清净的种子。“一切法等依”，“一切法”就是所有的法，“等”是说法有很多很多。“依”就是依靠，一切法都得依靠它。“由此有诸趣”，“由此”就是由“无始时来界”，“此”就是“界”，就是种子，由于染污的种子而有“诸趣”，诸趣就是六道，三恶道、三善道，这就是因为无始以来贪、瞋、痴等烦恼的熏习，所以我们在六道里流转不停。因为无始以来的种子，所以就有了六道轮回的变现。“及涅槃证得”，因为我们在生死里流转，有的众生感觉到苦恼了，于是要解脱，而有些呢，他不是想解脱，而是麻痹自己的神经，苦中作乐，在苦中找出一些相对的快乐，要不然就骗骗自己，这些人我们不说他。我们只说想要解脱的这一部分众生，他们要解脱，就去修学圣道，由戒、定、慧而灭除了无始时来的“界”，那么就证得涅槃了。从这一个偈颂，就可以知道阿赖耶识就是所知依，所知依就是阿赖耶识。有了阿赖耶才有六道轮回，才有涅槃证果。记好：“界”就是种子，种子集起来就是阿赖耶。

即于此中复说颂曰：由摄藏诸法，一切种子识，故名阿赖耶，胜者我开示。

刚才引了《阿毗达磨大乘经》中的一个颂子，来证明所知依就是阿赖耶识。现在再引一个颂子来证明阿赖耶真的是阿赖耶。“即于此中”，说，还是这《阿毗达磨大乘经》中，“复说颂曰”在《阿毗达磨大乘经》中还说有这样一个颂子，“由摄藏诸法，一切种子识，故名阿赖耶，胜者我开示”。“摄藏诸法”就是指一切种子识摄藏诸法。因为一切种子识能够摄藏诸法，所以我们叫它阿赖耶。阿赖耶就是藏的意思。“摄”是持的意思，我们把一个东西捏到手里、掌握住了，就叫持。前六识的一切活动，都被阿赖耶摄持，也就是说都在阿赖耶的掌握之中。当然，不是说阿赖耶这会儿高兴了，说耳识你活动活动，耳识就得起来活动活动，不是这样的，它的掌握可不是这样掌握的，它是有一定的规则的。

前六识的活动，被阿赖耶识摄持，阿赖耶接受前六识那个印象就叫摄，接受了以后不使它失坏就叫“藏”。无始以来，阿赖耶识里摄持了无量无边的种子，这些种子遇到因缘，它就会成为果报。从这一方面来说，阿赖耶识有摄藏一切法的种子的这种功能，我们叫它“一切种子识”。我们经常说种子，种子是什么？你们接触过唯识了，应该知道习气，种子就是习气，就是无始以来所形成的种种习气。习气用现在的话说就是经验，经验有很多，对我们来说，有人生的经验、有修行的经验。这都是种子。种子与本识的关系，被后来的论师们给解释的可复杂了，本论说是不一不异，但有人说种子不是本识，摄持种子的才是本识等等，以后再说。“一切种子识”的“识”，按传统的说法，就是了别，就是觉了、分别，这里先按传统的说法来说。种子组合起来就是一切种子识，这些种子不是死的，是一直在活动着的，妙老法师在讲的时候说，“如果阿赖耶识不在，就是死亡了”，说实在的，我不喜欢这说法，因为人死了也不是阿赖耶识不在了，只是某一业种子势力用尽而已，阿赖耶识是种子流，所以我觉得这说法不好。“种子识”不断地摄藏诸法的种子，“故名阿赖耶”，因为它不断地摄藏诸法的种子，所以就叫“阿赖耶”。最后一句是“胜者我开示”，“胜者”就是发无上菩提心的菩萨。说，阿赖耶识这个事儿呢，佛只对大菩萨们说，对其他人是不说的。

以上是无著论师引用经中的说法来证明阿赖耶，说这也是佛陀说的。人们对权威才臣服，所以必须拿出权威来，臣服权威是成熟的标志，所以你拿出权威了，我就信了。在佛教中，最大的权威的佛陀，是圣教量，你得拿出这个来，无著论师这里就是拿出的《阿毗达磨大乘经》。

如是且引阿笈摩证，复何缘故此识说名阿赖耶识？

前边儿拿出来了经典，但里面的具体内含还是得说说的。“如是且引阿笈摩证”，这是指前面引的一段经文，说经文已经引过了。“复何缘故此识说名阿赖耶识？”为什么把此识叫阿赖耶呢？下边儿说了摄藏、执藏两个意思。咱们一个一个来看。

一切有生杂染品法，于此摄藏为果性故。

这是说的摄藏义。“一切有生杂染品法”，“有生”，就是指有为法，有为法是有生有灭的。“杂染品法”，好，就是有漏的那一些。“品”就是种类，法有有漏、无漏两类，“杂染品法”就是有漏这一类。我们现在所作的一切，坏事儿也罢、好事儿也罢，因为有“我见”在里边儿，所以都是有漏的。“于此摄藏为果性故”，世亲论师把摄藏解释成“于中转故”，这句话在九十一页。“于中转”就是说，这些有生杂染品法都是在一切种子识里边儿活动的。“转”就是生起现行，就是活动，也就是刹那生灭。这一个“于此摄藏为果性故”是说，这些杂染品法是一切种子识的果性，阿赖耶是一切杂染品法的因性。这就是因为杂染品法是种子的变现。不过我们要知道，阿赖耶识和种子不可分离的，就是说，杂染品法是种子的果性，杂染品法是阿赖耶识的果性。

又即此识，于彼摄藏为因性故，是故说名阿赖耶识。

上一句说杂染品法是种子识阿赖耶的果性，这一句是说阿赖耶是一切杂染品法的因性，或者说阿赖耶识里面摄藏的种子是杂染品法的因性。种子是因，一切杂染品法是果。“是故说名阿赖耶识”，所以叫做藏识。“摄藏”印顺法师、妙老都说成共生共灭、俱生俱灭，这本没什么，可他们说是阿赖耶与杂染品法俱生俱灭，我想应该是某种子与这种子现行的法。要是说成阿赖耶的话，则阿赖耶包括太广。当然了，我们没有办法把种子和阿赖耶识分开，因为阿赖耶本就是种子组合体，离了种子就没有阿赖耶可得，但我们用语言说的时候还是得注意的。大乘佛教建立阿赖耶，就是要替流转还灭的一切法找一个立足点，有了阿赖耶，才可以说明万法的生起，及灭后功能的存在。阿赖耶是一切法的所依，诸法从之而生起，诸法的功能因之而保存，它有摄藏的性能，所以称为阿赖耶。我们往下看。

或诸有情摄藏此识为自我故，是故说名阿赖耶识。

刚才说了摄藏，现在说的是执藏义。“或诸有情”，这个“或”可不是或者的意思，而是有、有的的意思，又的意思，咱们古汉语中的用法。有人把这个“或”，讲成或者，很不顺。“诸有情”的“诸”当然是很多，这就给“或”对应上了。说，有的人、有的众生，“摄藏此识”，“摄藏此识”就是执著这阿赖耶，以为这阿赖耶就是自我。这一“摄藏此识为自我”，就是说执著这个阿赖耶识是有我的体性的意思，如果说只是假名为我的话，那就没有多大关系了，以为是有真实体性的“我”，这可就大大的不妙了。阿赖耶识不是无为法，无为法是没有生住异灭的。而阿赖耶识，它是剎那剎那生住异灭，因为它刹那刹那生住异灭，以致于我们认为它不生住异灭了。就是这样，比如说我，我是一个十分纯粹的佛教徒，是一个有正知见的佛教徒，一个不愚蠢的佛教徒，但他们非说我不是一个好佛教徒，说我是一个游戏人生者。就是说，我是一个最好的，好得就象一个坏蛋一样。阿赖耶识剎那剎那生住异灭，这样相似相续，就引起了人们的误会，认为它就是我，于是来执著于它。因为它相似相续，人们执著于它，“是故说名阿赖耶识”，所以叫它阿赖耶识。人们在它上生起我见，只有无我才能解脱，无我者才是圣人，我们只有不执它是我才行。印顺法师、妙老在这儿都说到，我们修行可不是破除外道说的我见就行了，而是要修无我观，破除末那识对阿赖耶的执著。执著阿赖耶是我，这主要是末那识的作用。在一般的典籍上都说到，就不多说了。

《阿毗达磨大乘经》中的“无始时来界，一切法等依，由此有诸趣，及涅槃证得”，“由摄藏诸法，一切种子识，故名阿赖耶，圣者我开示”这两个颂子，并没有点明执藏这个意思，现在无著论师就给我们说了，无著论师也不是乱说的，无著论师现在是在解释《阿毗达磨大乘经·摄大乘品》，他在解释的时候，就把其他经中讲到阿赖耶时说的这个意思在这儿给说了一下。无著论师他看过的经典，因为时代的关系，很多我们已经看不到了，现在无著论师给我们说了，那我们就知道了。

接下来，说阿赖耶还可以叫阿陀那。无著论师还是先用圣教量证明。我们看。

复次，此识亦名阿陀那识。此中阿笈摩者，如解深密经说：阿陀那识甚深细，一切种子如瀑流，我于

凡愚不开演，恐彼分别执为我。

佛说阿赖耶是所知依，佛还说阿赖耶有好多名字，这儿就说了一个阿陀那。无著论师首先引了一下经典，说阿陀那这个名字也是佛说的，不是我无著在瞎扯的。“复次，此识亦名阿陀那识”，一切种子识叫阿赖耶，也叫“阿陀那识”。这些名字是不是乱叫的？不是！是依据此识的不同作用而给取了不同的名字。也就是说，不同的名字侧重于不同的作用。比如阿赖耶这个名字，就是侧重于藏――摄藏、执藏，而阿陀那呢？我们照原文慢慢说。先说“阿陀那识”这名字出现在哪部经上。“此中阿笈摩者，如解深密经说”，“阿笈摩”就是经典，不过一般都给说成阿笈摩指阿含，其实所有佛经都是阿笈摩。说，比如说在《解深密经·心意识相品》上说到这样一个颂子，“阿陀那识甚深细，一切种子如瀑流，我于凡愚不开演，恐彼分别执为我。”这里就有“阿陀那识”这样的名字。“阿陀那识甚深细”是说阿陀那识是非常深奥微细的。“一切种子如瀑流”，上一句说此识的总体，这一句说此识里的细节，说，此识里的种子一直在刹那刹那的生灭，就象瀑流一样，所谓瀑流，也就是古希腊的赫拉克利特说的：“人不能两次踏入同一条河流。”河水在不停地流动，当人第二次踏入这条河流时，接触的已不是原来的水流，而是变化了的新的水流。世间万物都这样，像奔腾不息的河流，处于不停的流动变化之中。你认为还是这阿赖耶，但实际上已经不是原来的了，就是因为里边儿的种子已经有一部分生灭换过了。种子有名言种子，有业种子，其实所有的种子都是名言种子，不过因为其中有一部分有较强的善恶业势力，所以就叫它作业种子，还有投生怎么投生呀等，这你们应该都知道，我就不多说了。种子的数量很多很多，每个种子都要生灭变异，所以才能够成为瀑流。

“我于凡愚不开演”，“凡”，就是咱们这样的人，都是凡夫。“愚”是指二乘人，因为他们还没有通达佛法。有时候把“凡愚”说成八地之前者。“不开演”，不说。佛陀就说了，关于甚深的阿赖耶识教法，这境界太深奥了、太微细了，所以我不能够对凡夫、对二乘人说。为什么呢？“恐彼分别执为我”，就是因为阿赖耶识相续不断，就好象那个常恒不变的我似的，特别容易引起误会，会让人认为这就是“我”。在佛教中是根本没有“我”的，就是要破我的，结果一说这样的佛法，反倒引起了“我”执，所以，佛顾虑凡夫、二乘会起分别，说这就是“我”，于是，干脆就不对他们说这阿赖耶教法。这个确实是很麻烦的，有不少唯识学者，对教典读了不少，但这一点儿仍然转不过弯儿，他讲的根本就不是“唯识”，实际上就讲的是“唯我”，只不过是把“唯我”打扮了一番而已，马甲一穿，你认不出来他了。是不是他象商羯罗一样是有心来破坏佛法的？不是，他还没那能耐，主要是他自己胡涂，以己浑浑，使人昏昏。比如说某老师，《成唯识论校释》还是他的成名作，可他对阿赖耶的说法根本就是错的。在散步时我开玩笑地对他说，等你去世了之后我会写一篇文章来纪念你，就是说你害人慧命。他哈哈大笑：现在可别让我看，我会气死的。所以说，学生们要是学唯识，我一般不久就会给他们开出一串单子，告诉他们哪些人的著作绝对不准看，哪些人的著作可看，我就先给他们说。你们是居士，听这么一段时间，以后不会再看的，所以没必要费那心思，就不给你们开列了。

注意一下，在第四行的“或诸有情摄藏此识为自我故”，这是第七识执阿赖耶为我，是俱生我执。这“恐彼分别执为我”的“我”是第六识所起的分别我执，这是不一样的地方，知道一下。

何缘此识亦复说名阿陀那识？

阿赖耶为什么要叫阿陀那呢？“阿陀那”是“执持”的意思，因为此识有执持的作用，所以叫阿陀那识。下边儿具体解释。

执受一切有色根故，一切自体取所依故。

刚才问为什么叫阿陀那呢？这儿就说了理由。“执受一切有色根故”，阿陀那是执持、执受的意思，它的执受这里说了两个，第一是“有色根”，所谓有色根，就是物质所成就的根，就是五根――眼根、耳根、鼻根、舌根、身根，这五根都是由地水火风构成的，我们一般称之为“色根”。“有色根”，则表示一个简别，简别无色根，无色根就是第六意识的根，第六意识的根、意根它不是四大组成的。现在说有色根就表示不能是那个意根。这“有色根”就是由阿陀那识来执受的，因为此识执受一切有色根，所以叫它做执持识、阿陀那识。执受怎么执受呢？比如说我们，就是由于过去的业力招感，在五根上表现得特别明显，此识执持五根，所以你的五根才能有觉受，并且在这一期生命中间不坏，当然了，比如半路瞎子，这也是有的。我们是欲界，色界众生也是这样的。“一切自体取所依故”。刚才是执受一切有色根，现在说执受自体。自体指生命体。“一切自体”就是指所有生命体都这样，都是由阿陀那识执持。六道众生的生命体都是这样的。这两句话是先把理由给标出来，接着再解释。

所以者何？

什么是“执受一切有色根故”？什么是“一切自体取所依故”？

有色诸根，由此执受，无有失坏，尽寿随转。

这是解释什么是执受一切有色根。说，眼根、耳根、鼻根、舌根、身根，因为此识的执受，此识有执持的能力。“受”是感觉、感受，因为有此识的执持所以五根才能够起感觉、感受，有感受你就是一个活泼泼的生命体，要是一点儿感受都没有，一点儿反应都没有，那你不成个尸体了～～此识要是不执受五根，你就不成一个活人了。“由此执受，无有失坏”，此识能执持住，你五根就不坏，要是执持不住，它就坏了。比如说把你的眼睛挖掉一个，被挖掉的眼睛此识就执持不住它了，那它就要坏了，烂了。要是五根都不被执持了，你的身体就要烂了。“尽寿随转”只要你活着，此识就一直执持着你的五根，你的五根就一直起作用。其实这一个就是说，我们的生命体，它一直活泼泼地存在着，就是因为此识的执持。

又於相续正结生时，取彼生故执受自体。

“相续”就是说，我们这一生结束之后，还有来生，三世因果不断轮转。这轮转就是此阿陀那的作用。“结生”就是投胎，一个新生命形成就叫结生。“正结生时”就是指投胎的那一刹那。“取彼生故”阿陀那识执取受精卵。就是说，当投胎的时候，如果没有阿赖耶，胎就不能够成就，阿赖耶识执持受精卵了，这个小生命才是活的。先是执取受精卵，小生命活了，然后接着执持生命体，一刹那接一刹那，一直到住胎、出胎、从婴儿到长大，到最后死，一直执持。

是故此识亦复说名阿陀那识。

对于阿陀那，无著论师先引圣教，说阿陀那的出处是经典，不是我瞎说的，然后又解释了为什么叫阿陀那，就是因为它执受一切有色根、执受一切自体，这一句就是说，所以说此识可以叫阿陀那。下边儿呢，无著论师说此识还有叫心的。咱们看原文。

此亦名心，如世尊说心意识三。

此识也可以叫心，比如说世尊就说过心意识。“此亦名心”，就是此阿赖耶识又可以叫心。“如世尊说”，就像佛在经里面说的。比如说《解深密经》就说，“亦名为心，何以故？由此识色声香味触等，积聚（集）滋长故。”看，这就有心这样的名字，这可不是我无著瞎说的。世尊说心、意、识，有时候还心、意、识混用，但正儿八经来说的话，心是指阿赖耶的，意和识其实不是指阿赖耶的。先说说意是怎么回事儿。

此中意有二种：第一、与作等无间缘所依止性，无间灭识能与意识作生依止。

无著论师在这儿，对于心、意、识，是先说意、识，最后才解释心的。意一般是指第七识，识是指前六识，心是指第八识。“此中意有二种”，要开始说意了，说这个意有两种，哪两种呢？“第一、与作等无间缘所依止性”，这是第一种。一般称为无间灭意。“等无间缘所依止性”就是说，心不是恒常的，它是无常的，是刹那生灭的，生起的当下就灭，如果说生起的当下它不灭的话，那么下一刹那就没有办法生起，前一刹那要给后一刹那让位，前一刹那的灭是后一刹那生的一个条件。“等无间缘”就是平等而没有间隔，间隔是指念头间隔。等无间缘本就是前后念的相续，前念就是后念的等无间缘，前念给后念让出位子，并大体上对后念有一个规定性。“无间灭识能与意识作生依止”，“无间”就是没有间隔，前一剎那灭去，后一剎那立马就生起，中间没有别的念头来作间隔。妙老举了个例子，说一个人入了定，眼耳鼻舌身前五识不活动，他入定了七天，七天之后一出定，眼识、耳识、鼻识、舌识、身识又活动起来了，从时间上来说，这中间有七天的间隔，但是从心念上来说，是没有其它的心念在中间间隔的，这中间没有间隔，就叫做“等无间缘所依止性”。

“无间灭”就是指前一剎那的眼识为后一剎那的眼识作等无间缘的依止性，耳识、鼻识、舌识、身识、意识，都是这样儿的。前一刹那的心念和后一剎那的心念，中间是没有间隔的，但是它必须得前一念灭掉后一念才能生起。在佛教中是生即是灭，生的当下就必须得灭。不过在阿罗汉入涅槃的时候，在入涅槃的剎那，是前一念灭但后一念不生，那就不是“无间灭识能与意识作生依止”了。注意这个等无间缘，等无间缘必须是前念眼识作后念眼识的等无间缘，前念耳识作后念耳识的等无间缘，鼻识、舌识、身识都是这样的，可不能乱套，你不能让前念眼识作后念耳识的等无间缘，也不能作后念意识的等无间缘。但《正理滴点论》给现量进行分类时，给第二类意识现量下的定义是“自境无间具有能俱起境由根智等无间缘能生起之意识”，这就是把前念根智作了后念意识的等无间缘，这就成了五识可以作意识的等无间缘。这一个说法是怎么回事儿呢？这里是把前五识看作意识的特殊形式了，在这个说法中，是只有意识的，所以前五识可以作意识的等无间缘。等无间缘的“等”不是绝对相等，是大致就可以了，象在初果将入二果的刹那，前念时还是在初果，后念就到二果了，这时的心念还照样可以作等无间缘。前念有漏后念无漏也可以作等无间缘。“无间灭识能与意识作生依止”这句话里说的意识，包括前六识在内，只不过各识作各识的等无间缘。从等无间缘上来说，因为识刹那生灭，所以“能与意识作生依止”――就是前一念要给后一念腾出位置。这就是第一个，“无间灭意”：前一剎那识可以作后一刹那识的依止，前一刹那识灭掉了，能与后一剎那识生起的依止，这个“意”是依止的意思，这是通于六识的。当然，第八识、第七识都有这样的等无间缘。

第二、染污意与四烦恼恒共相应：一者、萨迦耶见，二者、我慢，三者、我爱，四者、无明。此即是

识杂染所依

刚才说了第一种意，无间灭意，现在说的是第二个意，染污意。染污就是不清净。为什么不清净？就是因为“与四烦恼恒共相应”。“恒”就是老在一起，“共”就是四烦恼一个也不少，“相应”就是互相随顺、互相照应。因为这四烦恼“恒共相应”，所以使“意”不清净，这就叫“染污意”。接着就是说到底是哪四种烦恼。“一者、萨迦耶见”，萨迦耶见就是我见。“萨”是败坏，“迦耶”是和合、聚积。合起来就是随时可以破坏，又随时可以借缘而和。什么东西如此呢？四大、五蕴可以如此，即执著于四大、五蕴和合的我、我所是实有的、恒常的。这里说的是第七识的我见，是俱生的我执，和第六识分别我执不同。“二者、我慢”，就是自以为了不起，自以为比别人高明。“三者、我爱”，爱就是贪着，对这个我深深地耽着。“四者、无明”，就是痴，对于无我不明白。这四烦恼中，无明是根本。这四种烦恼是俱生的，是与生俱来的，来染污了这个“末那识”，所以末那识就叫“染污意”。“此即是识杂染所依”，说，这四种烦恼，就是末那识杂染的原因。应该来说是这样的，无明是根本，无明与染污意相应，使我们的认识作用稀里糊涂。所以，当缘阿赖耶的时候，把阿赖耶当成了我，这就有了我见，由我见而生起自我的傲慢，就是我慢，深深的耽着这我相，就是我爱。这与四烦恼相应的染污意，执本识为自我，因此，前六识所起的善心，也受染污意势力的影响，成不了清净的无漏，所以它是前六识的“杂染所依”。杂染是通于善、恶、无记三性的，而污染则是唯通于恶，以及有覆无记，这得知道。

识复由彼第一依生，第二杂染；了别境义故。

刚才已经说过，“意”有两种，一个是“无间灭意”，在这一个意义上，“意”不单单指第七识，《成唯识论》上说是通于八个识的，八个识都是剎那灭剎那生。要是专说第七识的话，那就是染污意，就是因为四烦恼常俱。“第一依生”就是无间灭意，等无间缘依之而生。“第二杂染”是说染污意。“了别境义故”是说识能够分别清楚色、声、香、味、触、法各个境界。

等无间义故，思量义故，意成二种。

“等无间义故”，意有等无间义而叫无间灭意。“思量义故”，意有思量而叫染污意。这里的思量主要是指思量我见、我慢、我爱、我痴（我痴就是无明）这四种烦恼。所以，意就有二种差别。无间灭意就不多说了，因为它是通于八个识的。这里对于染污意再多说一些。

复次，云何得知有染污意？

我们怎么知道有第七识这染污意呢？在小乘佛法中根本就没有提到这个。所以无著论师就来解说。

谓此若无，不共无明则不得有，成过失故。

无著论师是用了六个理由来证明有第七末那识的，这是第一个理由。无著论师就说，末那识必须得有，为什么呢？要是没有末那识的话，有这样几个问题就解决不了。既然这几个问题是可以解决的，当然末那识就是存在的。“谓此若无”，如果没有这染污意的话，则会出现“不共无明则不得有”这样的情况。“不共无明”你外人也是承认的呀～～无明是我们之所以是凡夫的根本原因，是我们流转生死的祸根，它绝对是有的。无明就是痴，它是心所法，它必须得有相应的心王来调配。无明有二种，一个是相应无明，这是可以与贪、嗔、痴等烦恼法一起活动的，前六识都有相应无明。第二个是不共无明，或者叫独行无明。是不与贪等本惑一起活动的，只是因为对于苦、集、灭、道不能如理作意，它只与有漏意识相应。这不共无明还可以分为恒行不共无明与独行不共无明。恒行不共无明，是指与第七末那识相应之无明，即与贪等根本烦恼相应而起，此无明无始以来恒行，障碍真义智，故称恒行，又自一切凡夫心常无间之观点言，乃与相应于第六意识之无明有异，故称为不共。独行不共无明，系与第六意识相应之无明，以其与其他根本烦恼不相应，单独而起，故亦称不共。这独行不共无明再根据它是否与随烦恼俱起，更细分为有主独行无明与非主独行无明。没有强烈分别心的随烦恼伴随一起来活动的无明，叫有主独行不共无明，有强烈分别心的小随烦恼伴随一起活动，就是非主独行不共无明。“不共无明”的“不共”，就是不于其它的烦恼一起起作用。不共无明是生死的根本，它障碍圣道的生起，令你流转生死。只要你没有得证圣道，这不共无明就一直起作用，不会间断，这要是没有第七末那识的染污意，这不共无明就没办法相应了。既然没办法相应，那就没有了，（不共）无明没有了，那我们都是圣人了，这就与事实不符，所以一定得有不共无明，要有不共无明，就一定得有末那识。

总结一下，这第一条是说，如果没有染污意，那么不共无明就没有了，这显然是不符合事实的，我们都知道有不共无明。大、小乘都是这样说的。咱们再分析一下为什么没有染污意就会导致没有不共无明呢？首先，不共无明是心所法，它要与心王相应，前五识是有间断的，这是都知道的事实。睡着了，你的眼识就不现行了，这就是断了，还有成语中的视而不见、听而不闻等都可以证明前五识的间断。既然前五识是间断的，所以不共无明不能与它相应，要是它一间断，不共无明就没法儿了。那么第六意识呢？第六意识能不能一直与不共无明相应呢？也不行，为什么呢？不共无明就是染污的，可第六意识却是有时为善、有时为恶，有时候它还无记，如果说不共无明一直与第六意识相应的话，第六意识就没有为善的时候了，善与恶是汉贼不两立的。可是第六意识确实是有为善的时候，所以说染污意不能与第六意识一直相应。所以必须建立一个可以与不共无明一直相应的识――末那识、染污意。

又五同法亦不得有，成过失故。

这是染污意存在的第二个理由。眼识、耳识、鼻识、舌识、身识、意识是六识，在这六识之中，眼识、耳识、鼻识、舌识、身识、都有“根”来作为它的“不共俱有依”，第六意识也是识，为什么它要特殊？它也得有根！别人都有，你也必须得有！就象在官场中间，大家都吃喝拿，你就必须也得吃喝拿，这就是官场潜规则。“不共俱有依”的“俱有”就是指眼识和眼根是同时的，同时有就叫“俱有”，而“不共”是指眼根只能为眼识依止，不能为耳识、鼻识、舌识、身识、意识作依止，它不能给其它识作依止，就叫作“不共”。第六意识不能搞特殊化，你也必须有一个不共俱有依――意根。长行中的“五同法”就是指意识也得和前五识一样，也得有不共俱有依。要是没有染污意来作意根，第六意识就搞特殊化了，所以它必须得有第七末那识、染污意。

所以者何？

为什么呢？

以五识身必有眼等俱有依故。

就因为眼识、耳识、鼻识、舌识、身识都有不共俱有依，要有都得有，这样才公平。我们有不共俱有依，你第六意识就一定得有，你不能另类，所以一定得有第七末那识――它就是意根。

又训释词亦不得有，成过失故。

这是第三个理由。所谓“训释词”就是解释。有一个词叫“训诂”，给这挺象的，“训”就是用通俗的话来解释词义；“释”就是解释。解释这个义的名词就叫“训释词”。心、意、识的这个“意”，怎么来解释它呢？说，“意”者，“思量义”，就是说，意就是思量的意思。“心”者，“集起义”。“识”者，“了别义”。这就是训释，心、意、识三个词各有各的解释。“心”，集起义，是指阿赖耶识的。“识”，了别义，是指前六识的。这个“意”，是“思量义”，它指谁？他就是指第七末那识这个染污意。如果没有这第七末那的染污意，“‘意’者，思量义”还有意思吗？根本就没有内容，就是一句空话。佛不会没事儿逗人玩儿，他说话是有用意的。那么，意前边儿说过，有两种，一是无间灭意，二是染污意，没有染污意，用无间灭意来训释“意”行不行呢？不行，因为无间灭意是指等无间缘，等无间缘就是前后念的相续，前念作后念的等无间缘，前念它必须得灭掉才行，它灭掉之后为后念腾出位置来。前念灭了，它怎么思量？思量什么呀？根本就不可能了。所以用无间灭意是不行的。意有两种，一种不能用，只能另一种了，就是染污意，染污意必须承担起训释“思量”的责任。所以说要是没有第七末那识、染污意，那么“训释词亦不得有。”

又无想定与灭尽定差别无有，成过失故。

第四个理由。要是没有这个染污意、第七末那识，那么无想定和灭尽定就成一回事儿了。“无想定”是外道定，而“灭尽定”是佛教的圣者所修的定，传说窥基法师前生就是修灭尽定的一个圣者，在玄奘法师去西天取经的路上，在一个山洞中遇见一个在修禅定的修行者，玄奘法师把它叫醒后，这修行者就问玄奘法师，“释迦牟尼佛出世了没有？我在等他出世后帮他弘扬佛法。”玄奘法师说，“释迦牟尼佛已经入灭一千多年了”，老修行就说，“那我就再入定等弥勒佛出世吧，等弥勒佛出世后帮弥勒佛弘扬佛法”。玄奘法师说，“算了，到弥勒佛出世的时候你又错过了。既然是要弘扬佛法，那你就干脆帮助我弘扬佛法吧，我现在到西天取经去，你现在身体已经朽了，你就到东土转世等我，我取经回来就找你。”这老修行就到东土重新转世，就是窥基法师。窥基法师当时就是修的灭尽定。灭尽定与无想定是不同的，说，如果没有第七识染污意的话，这两种定就成一样的了。灭尽定就是使与第七识相应的烦恼法也不现行了。根本没有第七识的话，不就麻烦了～～

谓无想定染意所显，非灭尽定；若不尔者，此二种定应无差别。

“无想定”是只灭前六识相应的心、心所，他是得到了色界第四禅，得了第四禅的时候，他厌恶“想”，他就把这个“想”灭掉了，想灭掉想，就得把前六识都灭掉，都不让现行，他们把这就当成了涅槃境界。当然了，这只是他自认为的涅槃，实际上这不是，在这时候其实第七末那识染污意还存在。第七末那识染污意存在，则萨迦耶见，我慢，我爱，无明的情况还有。“染意所显”就是说染污意还在，那根本还不是清净的涅槃。“非灭尽定”，无想定不是灭尽定，“灭尽定”小乘圣者所修，得灭尽定者至少得是三果罗汉，四果罗汉当然更能入这灭尽定了。这些圣者在这儿休息一下，所以他把内心的识灭掉，不让现行。圣人是无我的，这些修灭尽定者当然也是，他的染污意没有。这就是无想定与灭尽定的差别：一个有染污意，一个没有。“若不尔者，此二种定应无差别”，要不是这样，根本没有第七识染污意，这二种定就没有差别了。

又无想天一期生中，应无染污成过失故，于中若无我执我慢。

这是第五个理由。“无想天”，刚才已经说过了无想定，当无想定修好之后，这个人因为修无想定，就生到无想天了。到了无想天之后，如果没有染污意的话，“一期生中，应无染污成过失故”，没有染污意，他在生到无想天上的五百大劫之中（生到无想天寿命最长是五百大劫，下品无想定则不到五百大劫），就应该没有染污心，要是没有染污心，没有我见、我慢、我爱、我痴四种烦恼，他就是一个圣人了，这当然是说不过去的。“于中若无我执我慢”，指在一期生命的五百大劫之中，他要是没有我见、我慢、我爱、无明，那就和圣人的灭尽定一样了，这是不对的。所以必须得建立染污意第七末那识，这才能把它们分别开来。

又一切时我执现行现可得故，谓善、不善、无记心中；若不尔者，唯不善心彼相应故，有我我所烦恼现行，非善无记。

这是第六个理由。“又一切时我执现行现可得故”，我们在没有修学圣道证得果位的时候，一直是有我执的。到我们证得果位了，比如说证得初果了，在圣道现前的时候，也就没有我执了。在圣道不现前的时候，还是有我执的。也就是说，凡夫是一直有我执的，这我们都能觉察得出。“现可得故”就是现在就可以认识到。“谓善、不善、无记心中”，当我们作善事儿的时候、作不善事儿的时候、作无记事儿的时候，当我们作善事儿的时候，我们就起的善心，作不善事儿的时候，就起的不善之心，作无记事儿的时候，就起的无记心。当我们作善事儿的时候、作不善事儿的时候、作无记事儿的时候，我们都是有我执的。“我在作善事”，“我在作不善事”，这还是分别心。凡夫都是这样子的。既然这样子，就说明了我们有染污意，这就是有染污意的证明，要是没有染污意的话，第六意识是会间断的，可为什么我们的我执一直有呢？“若不尔者”，要是没有第七染污意末那识的话，那么就应该“唯不善心彼相应故”，就应该只有在作不善事儿，起不善心的时候才有我执相应，因为不善心才是染污的。这就是“一切时我执现行”，凡夫都是这样的，要是没有第七识，只有第六识的话，第六识是不能“一切时现行”的，因为第六识本身就会间断，比如极度闷绝。要是没有第七识染污意，就应该在起不善心的时候才有我执相应，因为不善心本来就是烦恼，“非善、无记”，不能在善心起的时候、无记心起的时候，烦恼法来相应。

是故若立俱有现行，非相应现行，无此过失。

所以你只有承认末那识染污意，不承认是不行的。 “若立俱有现行”，“俱有”是俱时而有，就是说，在你作善的时候有，作不善的时候也有、作无记的时候也有，有什么？我执！接着的这个“相应现行”，“相应现行”的意思是指行善的时候只有善心所来与之相应，行不善的时候只有烦恼心所来与之相应，不能混淆。因为是俱有现行，而不是相应现行，所以染污意自然得存在。只有是俱有现行的时候，才是染污意，要是相应现行的话，就是第六意识了。看第六意识，在作功德的时候，烦恼法就不来现行，当作恶的时候，善心所也现行不了。

因为这六个理由，所以第七末那识染污意必须存在。下边儿无著论师用了几句颂子来把这六个理由概括了一下。

此中颂曰：

不用说了。

若不共无明 及与五同法 训词，二定别 无皆成过失

“若不共无明”是第一个理由。“及与五同法”是第二个理由。“训词”就是训释词，意以思量为义，这是第三个理由。“二定别”，这是无想定和灭尽定的差别，这是第四个理由。“无皆成过失”，要是没有第七末那识染污意，这四条都成过失了。

无想生应无 我执转，成过 我执恒随逐 一切种无有。

“无想生”是指第五个理由，就是说，修无想定的人生到无想天之后，在他的一期生命中，“应无我执”，“转”是生起，就是说，生到无想天的人就应该没有我执生起，要是没有染污意的话，确实就没有我执生起。这就不对了。“我执恒随逐，一切种无有”，这是第六个理由。凡夫的我执是一直随逐着有情的，“一切种”，就是善心、恶心、无记心里，都有我执的随逐。要是没有第七末那识，我执想一直随逐，就是不可能的。

离染意无有 二三成相违 无此，一切处 我执不应有

这第三个颂是把前面六种过失，分了分类，是分成了三类。“离染意无有，二三成相违”，这是一类，说，要是没有了第七末那识，“离”就是远离、没有。“染意”就是第七末那识、染污意。要是没有了第七末那识，会怎么样呢？就没有那“二”个的存在。也就是说，要是没有末那识，第一条理由不共无明和第二条理由五同法就不能够成立。“三成相违”是指第三条理由训释词、第四条理由无想定和灭尽定的差别、第五条理由无想天中染污意问题，这三个就也有矛盾，也说不过去了。指与圣教相违。“无此，一切处我执不应有”，要是没有第七末那识，“无此”就是没有末那识；“一切处”就是指作善、作不善、作无记。这一句就是说，要是没有末那识染污意，那么就不应该是一切处有我执，也就是说，要是没有染污意，当你作善的时候就没有我执，但是我们在作善的时候也是有我执的，这个我们都觉察得到。“二”、“三”、“我执不应有”，这就是三类。前二条是一类，接下来的三条是一类，最后的一条是一类。

真义心当生 常能为障碍 俱行一切分 谓不共无明

这最后一个颂子，把不共无明又说了说。“真义”指真理。“心”，指觉悟真理的无分别智，说这个无分别智是应该生起的，凭它来觉悟真理的。“常能为障碍”，本来无分别智要来觉悟真理，但是一个东西老来障碍无分别智的生起，使我们一直在流转生死。“俱行一切分”，说，这个障碍无分别智生起的东西，你行善时他活动，你行不善他也活动，你行无记他还活动，这个东西是什么呢？“谓不共无明”，这个东西就是不共无明。

此意染污故，有覆无记性，与四烦恼常共相应。

这是说染污意的性类。性类有三，善、恶、无记，无记又分有覆无记、无覆无记，这样呢，就成了四类。现在说末那识染污意属于这四类的哪一类。“此意染污故，有覆无记性”，一开始就先说了，它是属于有覆无记性这一类。“覆”就是障碍圣道。为什么呢？就因为它与我见、我爱、我慢、我痴四烦恼一直相应着。

如色无色二缠烦恼，是其有覆无记性摄

既然末那识与四烦恼常俱，为什么不是恶性，而是有覆无记？下边儿无著论师举了个例子来说明，说，比如色界天、无色界天，这两个地方的众生，他们的内心也有烦恼，这句长行中说是“缠烦恼”，“缠”就是拿绳捆捆，绑住，也就是“系”，“系”是比较正规的语言。色界天、无色界天众生也有烦恼，但他们有烦恼也不能说是恶，只能说是“有覆无记”，我们这儿是欲界，欲界众生的烦恼就是恶，但色界、无色界不能。为什么呢？

色、无色缠为奢摩他所摄藏故；此意一切时微细随逐故。

为什么色界天、无色界天的烦恼不能说是恶呢？就是因为色界天、无色界天的烦恼，能够被他们“奢摩他”的力量“所摄藏故”，所镇伏。“奢摩他”就是定、止。也就是说，虽然色界天、无色界天的烦恼也是烦恼，但他们禅定的力量很强，烦恼能够被折伏，以至于烦恼特别不明显。所以不能说他是恶，虽然不能说它是恶，但它毕竟是烦恼，总不能说是善吧～～于是只能说它是无记的，只要是烦恼，烦恼就障碍圣道，所以是有覆无记。而末那识染污意呢？它也是有烦恼的，“四烦恼常俱”，三十颂中的一句颂子。虽然有四烦恼常俱，但末那识太微细了，微细得你觉察不到它，它这么微细，随逐它的四烦恼也就特别地微细，就因为太微细了，所以不明显，所以不能说它是恶，当然也不能说它是善，也就只能说它是有覆无记性。

说，阿赖耶又叫心，书本第四页上说，“此亦名心，如世尊说，心、意、识三”，心意识三个名字虽然有时候混用，实际上严格来说还是不一样的。就说了说意、识，当然主要是说了说意。因为识是指前六识，这是人们都能觉察到的，不用怎么说。意是指第七识，心是指第八识。大乘建立第七识、第八识，所以得说说。意已经说过了，是第七识，下边儿正儿八经说心，心才是指阿赖耶的。

心体第三，若离阿赖耶识，无别可得。是故成就阿赖耶识以为心体，由此为种子，意及识转。

“心体”就是心的体性。“第三”是顺序，倒着数，第一是识，第二是意，第三就是心。意和识都是有体性的，意是末那识，识是前六识，心就是阿赖耶。要是没有阿赖耶，就没有别的心体了，所以就成立阿赖耶来作为心体。就是说，心这一个名字，所指的体性就是阿赖耶识。“由此为种子，意及识转”，阿赖耶不单单是心的体性，它对于“意”和“识”来说，也是很重要的，意也好，识也好，都得以“心”为种子才能生起的。就是说，“心”是种子，“意”、“识”是现行。

何因缘故亦说名心？

第八识叫阿赖耶不是挺好吗？为什么又要叫心呢？

由种种法熏习种子所积集故。

这一句话就说了，“心”就是“积集”的意思，心就有积集的功能，阿赖耶有积集的功能，正因为它有这个功能，所以我们叫它心。也就是说，当我们叫它心的时候，就是在强调它的积集功能。它有积集的功能，它积集什么呢？这句长行中说是积集“种种法熏习种子”，这很明白，它积集的是种种法所熏习的种子。它就是积集这个的。“种种法”就是指善法也好，恶法也罢，无记法也行。“种子”是譬喻我们心里的活动，这前七转识的活动，被阿赖耶识积集。种种法的熏习，就有种种法的种子，这些种子就是心来积集的，也就是阿赖耶识来积集的。也就是说，阿赖耶识是所熏，前七转识是能熏。阿赖耶识、心是能积集，种种法的种子是所积集，就因为有积集的功能，所以把它称为“心”。“熏习”是很重要的概念，简单来说就是，它们互相有影响。具体的解释后边儿再说。种子是什么？其实就是无始以来所形成的种种人生经验。

这里说了阿赖耶、阿陀那、心三个名字，虽然说东西只有一个，但叫不同的名字则表示不同的重点儿、不同的侧面，叫阿赖耶时主要是体现在八地以前被当成我；叫阿陀那主要是体现它摄持色身、使根身成为活的生命体，使各感官生起觉；叫心的时候主要体现它是无量现行法所熏种子的积集处。

复次，何故声闻乘中不说此心名阿赖耶识，名阿陀那识？

心、意、识大小乘佛法里都有，但把“心”解释成积集一切种子等，这种解释法在小乘中没有。在小乘中没有把心说成阿赖耶（藏）、阿陀那（执）的，没有说他们是同一体，甚至阿赖耶的名字也很少出现，至于阿陀那这个名字，则就干脆没有出现过。现在大乘这么说了，就得给出个理由来。

由此深细境所摄故。

这一句话对应的实际上就是《唯识三十颂》中的“不可知”三个字儿。就是说，阿赖耶太深奥了、太微细了，所以佛陀在小乘教中只说了一下心这个名字，并没有给说阿赖耶、阿陀那这层意思。

所以者何？

为什么佛对小乘不说呢？

由诸声闻，不于一切境智处转，是故于彼，虽离此说，然智得成，解脱成就，故不为说。

就是说，因为小乘不需要。小乘人不发无上菩提心（其实不是不发，而是他把自己所发的出离心当成了菩提心），他根本发不起无上菩提心。他不能成佛，他只能入无余涅槃。这些人呢，“不于一切境智处转”，就是说，他们不去广度众生，当然也就用不着去通达无量无边的佛法，当然他就不需要一切种智。“一切境智处”就是一切种智，就是通达一切法的智慧。佛的一切种智，是通达一切佛法，通达一切众生的根性，通达一切众生的烦恼，通达一切众生何因缘得解脱等等。这一切都通达了，就是“于一切境智处转”。但小乘人，是不用成就一切种智的，所以佛对这小乘根性众生，就不说这大乘阿赖耶法门，不用再给他们说阿赖耶就是心，一切种子识就是心。“虽离此说，然智得成”，说，佛虽然没有为他们说阿赖耶识法门，但是他们学习四谛、修学四念处等，他们也可以得到他们想要得到的解脱，“解脱成就”，小乘人也可以消灭分段生死，可以入无余涅槃，这就已经达到他们的目的了，“故不为说”，所以佛没有为他宣说阿赖耶识法门。

若诸菩萨，定于一切境智处转，是故为说。

若是对于发无上菩提心的菩萨，他们要得无上菩提，要普度一切众生，这就需要阿赖耶识法门。“是故为说”，所以佛要为诸菩萨说阿赖耶识法门，给他们说阿赖耶识就是心，又叫阿陀那等。

若离此智，不易证得一切智智。

要是不了达这阿赖耶识，那就不能够成就这通达一切境的智慧。“不易证得一切智智”是说，菩萨虽然发了无上菩提心，但是他不容易成就佛的一切种智，只有凭阿赖耶识这个法门，才可以。

这里我补充一点儿，有几个名词，知道一下。一切智、道种智、一切种智、一切境界智、一切智智。一切智是指二乘知一切法的总相智；道种智是菩萨知一切法差别相的智，即后得智；一切种智指通达一切法的总相、别相智，是修道断惑的智，即根本智，又称一切境界智；一切智智是佛的圆满大智。

复次，声闻乘中亦以异门密意，已说阿赖耶识。

这是说实际上佛对二乘人也暗示过阿赖耶，当时佛是“异门密意”而说的。“异门”就是不同的门、不同的方式，或者说，是以不同的能诠名来诠表同一个所诠对象。“密意”就是不明明白白地说，只是约略提示，轻描淡写地提到了。佛陀这种说法方式对于程度高的人一样可以听得懂。佛用这种说法方式是因为对程度高的不得不说，但又不能增加那一部分程度不够的听众的虚妄分别。佛为声闻乘说法时是将异门和密意结合起来，为能回小向大众生而隐密的用不同能诠名而说。有人也可能这么说，既然佛在声闻乘中就“异门密意”地说到了阿赖耶，你无著凭什么又说阿赖耶教法比小乘殊胜呢？是这么回事儿，佛在声闻乘中异门密意说了阿赖耶，但那不是对定性声闻说的，而是为不定性说的，所以，拿这“在声闻乘中就说了阿赖耶”恰恰可以证明阿赖耶教法殊胜。

如彼增一阿笈摩说：世间众生，爱阿赖耶，乐阿赖耶，欣阿赖耶，喜阿赖耶；为断如是阿赖耶故，说

正法时，恭敬摄耳，住求解心，法随法行：如来出世，如是甚奇希有正法，出现世间。

“增一阿笈摩”就是增一阿含，我们现在说阿含有增一阿含、中阿含、长阿含、杂阿含。无著论师说增一阿含中有这样的话，但你现在不用在我们的增一阿含中找，我们汉本增一阿含中没有这话，据《成唯识论》中说，是一切有部的经典中有这样的话，其他部派的增一阿含中没有。在增一阿含经中就说到，说“世间众生，爱阿赖耶，乐阿赖耶，欣阿赖耶，喜阿赖耶”，在这经中只说阿赖耶，没有说阿赖耶识。“爱阿赖耶，乐阿赖耶，欣阿赖耶，喜阿赖耶”，世亲论师说，“爱”是总说，下边儿的乐、欣、喜是分说。“爱”就是觉得这阿赖耶很可爱，离不开了。“乐阿赖耶”是指现在世爱阿赖耶；“欣阿赖耶”是指过去世爱阿赖耶；“喜阿赖耶”指未来世爱阿赖耶，总之，一直爱阿赖耶。也有人这么说，说爱阿赖耶是指胎生者，乐阿赖耶是指卵生，欣阿赖耶是指湿生，喜阿赖耶是化生。这也没关系，愿这么说就这么说好了。

“为断如是阿赖耶故”，因为众生爱、乐、欣、喜着这阿赖耶，所以流转生死而不得解脱，我们为了解脱，就要断这个阿赖耶，不要对它产生爱、乐、欣、喜。注意，是断对阿赖耶的爱、乐、欣、喜，不要搞错了，要是说阿赖耶，只有“转（识成智）”而没有“咔”，把它给断掉。“故说正法时，恭敬摄耳，住求解心，法随法行”，“说正法”是指佛在宣说，下边儿的“恭敬摄耳”等是指众生。“恭敬”指恭敬心，对佛的恭敬、对法的恭敬。“摄耳”指专心地听法，心不散乱。“住求解心”，内心一直要安住在希求解脱的心情上，要以这样的心来听法。“法随法行”，前面这个“法”就是圣人所证悟的法。“随法行”就是随顺圣者教导给你的法而修行，也就是你的行为要与圣者所教导的一样，这样你才能够证道，你要是违背圣者的教导，那就不是随法行了。也就是说，圣者让你干什么你就干什么，不要自作主张。有些人不是圣者让作什么就作什么，而是根据自己的修行经验而进行取舍的，这不对！“恭敬摄耳”是闻。“住求解心”是思。“法随法行”是修。这样闻、思、修三学就完备了。“如来出世，如是甚奇希有正法，出现世间”，佛为了断灭众生的执著，所以为众生宣说正法。听法的人，为了断灭对阿赖耶的误执，所以在佛说法的时候“恭敬摄耳，住求解心，法随法行”，这样他就感觉到，如来出现世间，演说正法，是很难得的，佛要是不出现，则根本就听不到这样的正法。

于声闻乘如来出现四德经中，由此异门密意，已显阿赖耶识。

在《如来出现四德经》里面，已经说到了阿赖耶，《如来出现四德经》就是增一阿含中的一部小经，刚才说的爱阿赖耶、乐阿赖耶……这一段经文就是《如来出现四德经》里面的。也就是说，释迦牟尼在声闻乘中间实际上已经说到了阿赖耶，只不过是没有详细给说而已。

于大众部阿笈摩中，亦以异门密意，说此名根本识，如树依根。

刚才引用了有部增一阿含中《如来出现四德经》来证明，现在又拿了大众部阿笈摩，到下边儿还有化地部的说法等，反正就是说各部都有。有部说到了阿赖耶，大众部也说到，不过大众部经典中不是叫阿赖耶，而是说它叫根本识。“根本识”是指它是前六识的依止处。“如树依根”，前六识依止这根本识，就象树依止于根一样，要是没有根，树就不得活了，要是没有根本识，前六识就不能起现行了。就是说，大众部说的“根本识”，其实就是阿赖耶识，只不过是名字不同罢了。这就是“以异门密意，说此名根本识，如树依根。”

化地部中，亦以异门密意，说此名穷生死蕴。

这是化地部的说法，在化地部其实也说到了阿赖耶，不过他用的名字是“名穷生死蕴”，他说的“穷生死蕴”实际上就是阿赖耶。在化地部经典中，这个“蕴”有三种：一念顷蕴、一期生蕴、穷生死蕴。“一念顷蕴”就是指我们现在现行着的色、受、想、行、识，他们是剎那生灭的。“一期生蕴”是指在这一期生命之中，这一期生命就是几个月、一年、到几十年、好多年等，有些小生命寿命很短，有些有情的寿命很长，这不一定，和这一期生命共存亡的叫一期生蕴。“穷生死蕴”是指有情的寿命虽然有限，但它得一直到你得了无学道才尽，这就是穷生死蕴――只要你在生死中流转，它就一直与你相伴。

有处有时见色心断，非阿赖耶识中彼种有断。

说，化地部说的穷生死蕴就是阿赖耶识。“有处有时见色心断”，这一句话实际上是“有处见色断、有时见心断”，“有处”，指的是无色界，在无色界的众生，他的生命体中没有色，没有地、水、火、风的组合，物质的生理组织断了。“有时”是指无想定，无想定是色界第四禅里的，说，入了这无想定的时候，六识就断了，这断是不起现行的意思。眼识、耳识、鼻识、舌识、身识、意识，这六个识都不活动了。不过，无色界众生的色身没有、无想天众生的心识没有，可不是阿赖耶识里的种子没有了，种子还是有的，因为种子还有，所以说当你从无色界到欲界、色界的时候，你的色身就又有了，当你从无想定出来的时候，六识就又活动了，这就是“非阿赖耶识中彼种有断”。也就是说有时有处色、心断，但换个时间、换的地方色、心就又有了，这就是因为种子还在，它断的只是现行而已。一切种子就是阿赖耶。

如是所知依，说阿赖耶识为性，阿陀那识为性，心为性，阿赖耶为性，根本识为性，穷生死蕴为性等；

由此异门，阿赖耶识成大王路。

这是对前边儿的说法的总结，说这所知依，也就是“无始时来界”的“界”，把阿赖耶识说成他的体性，把阿陀那识说成他的体性，把心说成他的体性，把阿赖耶说成他的体性，把根本识说成他的体性，把穷生死蕴说成他的体性等等，这在经典中都说过。把阿赖耶识说成他的体性，把阿陀那识说成他的体性，把心说成他的体性这是大乘佛教中说的。把阿赖耶说成他的体性，把根本识说成他的体性，把穷生死蕴说成他的体性等是小乘中说过的。长行中还有一个“等”字儿，就是指正量部的“果报识”，上座部分别论者的“有分识”之类的。“有分识”的“有”就是三界：欲界、色界、无色界；“分”就是因。说这个识是普遍的，是三界之因。也就是阿赖耶识了。“由此异门，阿赖耶识成大王路”，有这么多的理由，是完全可以证明阿赖耶的。“成大王路”就是指理由很充足，不容否定。大王路当然是很坚固、很宽阔的了，没有障碍（即没有否定的理由）。接下来是无著论师纠正了一些错误的说法。

复有一类，谓心意识义一文异。是义不成。

刚才说阿赖耶识是大王路，建立阿赖耶识的理由是很充足的，你不能指望所有人都同意自己，永远没有100%的，所以还是有些人提出了不同的看法，只要有人提出来，你就得给解答一下。“复有一类”，就是说有些人这么说，还有这样的一些人。“谓心意识义一文异”，他们说，心、意、识这三个名字，他们所诠显的根本就是一回事儿，只不过是在文字上叫心、叫意、叫识，意思其实是一样的。无著论师当然不同意这说法了，说，“是义不成”，这说法是不对的，为什么不对呢？

意识两义差别可得，当知心义亦应有异。

前面已经说过，“意”有等无间灭意和染污意两种，而“识”是了别性，就是前六识，在《唯识三十颂》中有一句，“了别于自境界识”，这是韩老译本中的句子，前六识各自了别自己的境界，谁也别帮助谁，你根本就帮不了别人。各扫自己门前雪，休管他人瓦上霜。说，意和识它们两个所诠显的道理不一样。既然意和识不一样，你却说心、意、识三者一样，这对吗？当然不对！既然你说的不对，所以说“当知心义亦应有异”，也就是说，心与意、与识也应该不一样，它也应该有它自己的所诠义。

复有一类，谓薄伽梵所说众生爱阿赖耶，乃至广说，此中五取蕴说名阿赖耶。

无著论师把用“义一文异”来否认有阿赖耶识的小乘论师说倒了，又有一个小乘论师来说话了。说，你用大乘义理来解释增一阿含不是行的，这方法不对。“复有一类”，又有一些人这样说，“谓薄伽梵所说众生爱阿赖耶，他们说佛在增一阿含里所说的“众生爱阿赖耶、乐阿赖耶、欣阿赖耶、喜阿赖耶”，乃至于广说的，佛在那儿说的阿赖耶不能象你大乘这样的解释。增一阿含里说的阿赖耶，实际上应该是指我们众生的五取蕴，五取蕴就是色、受、想、行、识，这才是一切众生的爱着处。我们所说的了生死就是要把这色、受、想、行、识给消灭掉。对于这种说法，无著论师到下边儿再破。

有余复谓贪俱乐受名阿赖耶。

又有人说，“贪俱乐受名阿赖耶”，“乐受”是三受之一，或者五受之一，三受就是苦受、乐受、舍受，要是再加上忧受、喜受就是五受。“贪俱乐受”则是指对乐受的贪爱，贪是能爱，乐受是所爱，能爱与所爱同时就叫作“俱”。这贪俱乐受就是阿赖耶。“贪俱乐受”当然和五取蕴关系很铁，因为贪爱乐受，所以爱着五蕴。

有余复谓萨迦耶见名阿赖耶。

还有人说这个萨迦耶见就是阿赖耶。萨迦耶见就是我见，认为五蕴里一定有我，然后去爱这个我。现在人家就说，这个我见就是阿赖耶，根本就不是你大乘的那么个说法。下边儿无著论师要来破斥了。

此等诸师，由教及证，愚阿赖耶，故作此执。

“此等诸师”，你们这些人。“由教及证，愚阿赖耶”，你们所学的阿含教典，佛在里边儿没有给你们说清楚阿赖耶识的道理。你们对佛法的领悟，都没有达到一定的程度，所以你们对阿赖耶识的道理不明白。佛没给你们说清楚，你们自己也没有领悟对，所以“愚阿赖耶”，愚阿赖耶就是说，对阿赖耶识识的道理有误解。“故作此执”，所以有这样那样的执著，比如说五取蕴就是阿赖耶，比如说贪俱乐受是阿赖耶，比如说萨迦耶见是阿赖耶等。

如是安立阿赖耶名，随声闻乘安立道理，亦不相应。

你们这样的说法，把五取蕴说成阿赖耶，把贪俱乐受说成阿赖耶，把萨迦耶见说成阿赖耶，即使用小乘的道理来说，也是不对的，与阿含教义也是相违的。

若不愚者，取阿赖耶识安立彼说阿赖耶名，如是安立则为最胜。

“若不愚者”，就是指教、证都好的、都对的，教就是指对教义的领悟，证是指修行的境界。要是这样的人，则一定把阿赖耶解释成我大乘说的这样。把阿赖耶解释成我大乘这样的，这样才是最殊胜的、最圆满的、最正确的。

云何最胜？

为什么我说我这说法才是最殊胜的呢？

若五取蕴名阿赖耶，生恶趣中一向苦处，最可厌逆，众生一向不起爱乐，于中执藏不应道理，以彼常

求速舍离故。

要说我大乘的解释法的殊胜之处，我就先说说刚才你们这几位的说法的错误之处在啥地方。第一个先来说说把五取蕴当阿赖耶识的错误在哪儿。阿赖耶识是普遍的，一切众生都有。比如说我生到了恶道中，那可是连一点儿的快乐也没有，“一向苦处”就是一直是苦，连一点儿的乐也没有。生到了这样的地方，那是“最可厌逆”的，我一点儿也不喜欢，“一向不起爱乐”，对于这五蕴我可不爱乐，那么你说五取蕴是爱乐处对吗？不对吧～～也就是说，阿赖耶应该是一切众生都爱执的，但五取蕴不是一切众生都爱执的，它只有一部分众生爱执，生到地狱里的众生，“以彼常求速舍离故”，时时希望赶快脱离这苦恼的五取蕴，哪里还有爱着呢？“于中执藏不应道理”，所以说你的说法不对，不应该说五取蕴是爱着处，是阿赖耶识。

若贪俱乐受名阿赖耶，第四静虑以上无有。具彼有情常有厌逆，于中执藏亦不应理。

这是对“贪俱乐受是阿赖耶”的破斥。说在第三静虑以上根本就没有这贪俱乐受，这贪俱乐受是欲界众生，以及色界的初禅、二禅、三禅有的，但第四静虑以上者就没有这贪俱乐受了。如果说贪俱乐受是阿赖耶识的话，那么得了四禅以上的众生怎么办？他们没有贪俱乐受，他们不就没有阿赖耶识了～～这不合理。

若萨迦耶见名阿赖耶，于此正法中信解无我者，恒有厌逆，于中执藏亦不应理。

这是破把萨迦耶见说成阿赖耶识的。“于此正法中，信解无我者”，就是指修行佛法者，在这些修行者中间，有些人对于无我的道理已经有了绝的信心，只不过是还没有证悟，这就是加行位修行者。这些修行人，他们常常修无我观，“恒有厌逆”，他们对于我执是厌患的，既然他们没有我执、没有萨迦耶见，是不是他们就没有阿赖耶识了～～“于中执藏不应道理”，所以说，把萨迦耶见当成阿赖耶识是不对的。阿赖耶识是相似相续的、流转的、前后很密切的，但是它不是我。我是独立存在，它不依靠旁的，但阿赖耶识是要依靠旁的的，前边儿说过的，阿赖耶与前七识是互相依存、互为因缘的。你所认为的我，跟阿赖耶识有差别：你所认为的我实际上根本不存在，一点儿影子都没有的。萨迦耶见是一种能执著的，阿赖耶识是被执著的，但能执著和被执著在这儿不相合。

阿赖耶识内我性摄。

阿赖耶识到底是什么呢？首先，他非常微细，凭前六识是不能觉知的。前边儿说过的，第七识执第八识的见分为我，它是内我。实际上它不是我，他也是因缘生法，也不是有真实性的。

虽生恶趣一向苦处求离苦蕴，然彼恒于我爱随缚，未尝求离。

众生虽然说生到了一直是苦的恶趣，他需求脱离这令他苦恼的五蕴，但在内心深处还时时爱着“我”，这种系缚还是不曾求离的，他没有一刻要远离这种执著，从来就没有想过要离开这我执。也就是说，众生是要远离恶道的苦蕴，但恶道的苦蕴只是前六识觉知的境界，所以，对于前六识不觉知的阿赖耶识，他根本就没有厌离。因为他没有厌离这阿赖耶，所以不得解脱。

虽生第四静虑以上，于贪俱乐恒有厌逆，阿赖耶识我爱随缚。

有些修行人他到了色界第四静虑以上，他对贪俱乐受倒是“恒有厌逆”，可是他的第七末那识还是爱着阿赖耶识，这个我爱还是随时系缚着他，他还解脱不了。生到色界四禅以上，这还是第六意识的境界，所以他对阿赖耶识还是有我爱的。

虽于此正法信解无我者厌逆我见，然于藏识我爱随缚。

虽然我们佛教徒对于正法里说的无我的道理，心里是信解了，也一方面修止观、修无我观，厌逆这我见，但是对于阿赖耶识这我爱还是随逐系缚。

是故安立阿赖耶识名阿赖耶，成就最胜。

这样，五取蕴、贪俱乐受、萨迦耶见都不够格是阿赖耶识，只有我们大乘说的阿赖耶识才是真正的阿赖耶识，这才是对的、殊胜的、圆满的。前边儿都是从圣教中成立阿赖耶的，接下来开始从道理上来成立阿赖耶识了。

如是已说阿赖耶识安立异门。安立此相云何可见？

根据佛陀的圣教量是可以建立阿赖耶识的，按陈那论师的说法，即使是佛陀所说的，也必须得符合现量、比量，能够凭现量、比量来验证这才行。下边儿的道理上成立阿赖耶实际上就是用比量来成立。“安立此相云何可见？”阿赖耶识的体相究竟是什么样子？我们怎么可以觉察得到呢？

安立此相略有三种。

阿赖耶识的体相，有三种不同。“安立”就是假安立。说本来就有阿赖耶，我们来给取个名字，这个名字是我们假安立的。这个意思要搞对。“相”是表现出来的，我们就根据这三种“相”来认识阿赖耶的。

一者、安立自相，二者、安立因相，三者、安立果相。

一是自相，二是因相，三是果相。在《唯识三十颂》中就说过。下边儿有解释。

此中安立阿赖耶识自相者，谓依一切杂染品法所有熏习为彼生因，由能摄持种子相应。

先说阿赖耶识的自相。自相就是它本身的相貌。阿赖耶识实在是非常微细，论文上说，“谓依一切杂染品法所有熏习”，这个呢，其实就是现行熏种子。“杂染品法”实际上就是我们这些凡夫由虚妄分别心而造的惑、业、苦之类，也可以说，这杂染品法从本质上说就是我们的虚妄分别，或者说，就是世界上所有的东西、我们现在认识到的一切。这杂染品法的熏习就是我们的虚妄分别心在不断地活动，它的活动影响到阿赖耶识，这影响就是熏习，一熏习，就在阿赖耶识里留下了印象，这就是种子。这一个过程：虚妄分别心一活动就留下种子――叫作熏习。虚妄分别就是我们的意识分别。就是说阿赖耶识里的种子是依一切显性杂染品法的熏习而有的，不是凭空而来的。接着的“为彼生因”是种子生现行，指现行熏成的种子就是一切杂染品法生起的亲因缘。也就是说，一切显性现行法都有生因，不是无因而生的。这样呢，现行熏成种子，种子生成现行，这么一个互相熏习的过程就是阿赖耶识的自相。“由能摄持种子相应”，为什么现行会熏成种子，种子又能够生成现行呢？就是因为阿赖耶识“由能摄持种子相应”，“摄”是能接受，“持”是能保持。也就是说，因为阿赖耶识它有摄持种子的功能，与这个功能相应的就可以说是阿赖耶识的自相，不能相应就不是，前六识不能与摄持种子的功能相应，它就不是阿赖耶识的自相。这就说明了我们现在的所为，就是我们的虚妄分别心在阿赖耶识里熏成种子，这种子又生出虚妄分别心来，我们现在就干了这么一件事儿，别的什么都没干。

此中安立阿赖耶识因相者，谓即如是一切种子阿赖耶识，于一切时与彼杂染品类诸法现前为因。

这是阿赖耶识的因相。在《唯识三十颂》中有“初阿赖耶识，异熟一切种”，那个“一切种”就是因相。现在无著论师在这里就说了，说因相就是“谓即如是一切种子阿赖耶识”，也就是一切法的种子的阿赖耶识，阿赖耶识就是种子的综合体，我以前一直把阿赖耶识说成种子流，这是一样的。这阿赖耶识要“于一切时与彼杂染品类诸法现前为因”，“一切时”就是随时，随便啥时候，过去、现在、未来都一样。“彼杂染品类诸法”就是有漏的诸法。说，阿赖耶识和彼杂染品类诸法在一起，受这杂染法的熏习。然后呢？“现前为因”，就是说，当一切杂染品类诸法要现行的时候，这一切种子识来作为它的因。也就是说，因为有阿赖耶识，所以一切杂染法才能现行。我现在正在念佛，忽然出现了一念贪心，这贪心为什么会现行？就是因为阿赖耶识里有贪的种子。一个无恶不作的坏蛋，也会冷不丁地生出一念善心来，这也是因为阿赖耶识里有善的种子。只要阿赖耶里有种子，相应地某法就会现行。

此中安立阿赖耶识果相者，谓即依彼杂染品法无始时来所有熏习，阿赖耶识相续而生。

这是果相。果相是啥呢？“谓即依彼杂染品法无始时来所有熏习”，虚妄的分别心，无始以来一直在熏习着这阿赖耶识，使得“阿赖耶识相续而生”，“相续”是相似相续，可不是一成不变的相续，这就是阿赖耶的“果相”。刚才老说熏习，到底什么是熏习？下边儿就说了。

复次，何等名为熏习？熏习能诠何为所诠？谓依彼法俱生俱灭，此中有能生彼因性，是谓所诠。

“复次，何等名为熏习？”啥样儿才是熏习呢？“熏习能诠”，熏习这个名词，他是能诠显、能有所表示的。“何为所诠？”他所诠显的是什么呢？能诠是指名，所诠是指义。熏习这个能诠名所诠的义呢？“谓依彼法俱生俱灭，此中有能生彼因性，是谓所诠”，“依彼法俱生俱灭”的“彼法”是指阿赖耶识和与阿赖耶在一起的一切杂染品类诸法。阿赖耶识是所熏的，一切品类杂染诸法是能熏习的。“俱生俱灭”就是指阿赖耶识和杂染品类诸法一起“俱生俱灭”。“俱”就是同时地在那里，不能有前后的差别。“生、灭”是说他们都是无常变化的，阿赖耶识剎那剎那的生灭变化，一切杂染品类诸法也剎那剎那生灭变化的。因为杂染品类诸法与阿赖耶识一起俱生俱灭，所以“此中有能生彼因性”，说，阿赖耶识里就有了“能生彼因性”，“能生彼因性”就是指能生起彼杂染诸法的功能性。“是谓所诠”，这就是“熏习”的这个名词所显示的义，这就是熏习的意思。熏习就是我们的虚妄分别心与阿赖耶识俱生俱灭，一直在一起，一刻也不分离，只要前七转识一动，同时就熏习阿赖耶识，虚妄分别心怎么动，就怎么熏习，这记录是十分的真实，一点儿也不出错、一点儿也不隐藏，咱们中国叫它什么？叫三尸神不是？或者是三焦神，我记不清了，佛经上有些地方不说阿赖耶而说善恶童子，也是这意思。自己的虚妄分别心对于阿赖耶识来说，是一点儿也不隐藏的。没有办法能造伪的，没有办法能隐藏的。这个“俱生俱灭”是最重要的了，它有两个要点儿：一、同时俱有的，二、无常生灭的。

如苣蕂中有华熏习，苣蕂与华俱生俱灭，是诸苣蕂带能生彼香因而生。

这是无著论师来举了一个例子，说，比如“苣蕂中有华熏习”，“苣蕂”就是胡麻，可以榨油，现在有人就给说成芝麻，也没关系。这儿举苣蕂出来，这是印度的一个风俗习惯，印度天热，人们要擦防晒油，当时的防晒油就是用苣蕂作的，是把苣蕂和花放在一起，埋在地下，等一段时间这花烂了之后，把苣蕂和烂花在一起压油，用这油来作防晒油。如果没有花而只用苣蕂的话，这防晒油就没有香味儿，把苣蕂和花放在一起，花的香味就熏到苣蕂上了。“苣蕂与华俱生俱灭”，我们是把苣蕂和花放在一起，埋在地下的。“是诸苣蕂带能生彼香因而生”，当我们把苣蕂再拿出来压油的时候，这油就有了花的香味。这就是说，苣蕂本来没有香味儿，因为花熏而有了香味儿。这是一个比喻，说前七识和第八识也是这样熏习的。

又如所立贪等行者，贪等熏习，依彼贪等俱生俱灭，此心带彼生因而生。

“又如所立贪等行者”，再比如说释迦牟尼佛说的，有些贪行者、嗔行者等，这些都是释迦牟尼佛观察众生的根性而说出来的众生的各种差别，有些人贪心特别，释迦牟尼佛就说这是贪行者，有些人嗔心特别，释迦牟尼就说这是嗔行者等等。贪行者就是因为贪烦恼来熏习的最多，嗔行者就是嗔来熏习的最多……但是，并不是你在贪心现行的时候才是贪行者，嗔心现行的时候才是嗔行者。“依彼贪等俱生俱灭”，当你的贪心起来的时候，马上熏习，心和贪俱生俱灭。“此心带彼生因而生”，当贪念现行的时候，马上熏到心里，心就“带彼生因而生”，“带彼生因而生”就是挟带那能生贪心的功能性――就是种子――而继续存在。这种功能――种子，在不活动的时候，这个人就象没有贪心，一遇到缘，那个“生因”一下子就发生作用了，贪心就表现出来了。我在《唯识三十颂》中说过，炒作，就是这样，你每起一次贪，贪就加重一点儿，就是炒作一次，贪的力量就得到一次壮大。

或多闻者，多闻熏习，依闻作意俱生俱灭。此心带彼记因而生。由此熏习能摄持故，名持法者。

“或多闻者”，“或”是有、有的，“多闻者”就是博学多闻的人，知道的事情很多，也都能记得住。他为什么会是多闻者呢？就是因为“多闻熏习”。什么是“多闻熏习”？无著论师解释说是“依闻作意俱生俱灭”，就是指我们的一念心，依“闻”进行作意，对所闻到的进行作意，你常去听别人的讲解、自己多读书，你心里这样活动，“作意”就是注意，当然就是心动了，心的闻作意与心是俱生俱灭的。“此心带彼记因而生”，你经常听法，你心里就带有你所闻的那些法“而生”，你所听闻的法，就在你心里熏成种子而存在，他不会消失。由于你这样闻作意的熏习，当然了，佛教是要求正闻，不能瞎闻，尽闻些乱七八糟的就不好了。因为正闻，你的内心就能摄持你所熏习的而不忘失，这就是“持法者”，持法者就是心里摄持很多的知识，这些知识都是以种子的形态存在的，平时也不显现，但当你想要的时候，他就会显现出来。这就是三个比喻，一个是外边的苣蕂，另外两个是内心的事儿。外边儿的苣蕂这个比喻主要是突出同时，贪行者的比喻是突出染熏，多闻者的比喻是突出净熏。

阿赖耶识熏习道理，当知亦尔。

阿赖耶识为一切杂染品类诸法的熏习，也是这样子。

复次，阿赖耶识中诸杂染品法种子，为别异住？为无别异？

现在要来说明种子与阿赖耶识的关系了。说，种子与阿赖耶到底是一还是异呢？“复次，阿赖耶识中诸杂染品法种子”，阿赖耶识因为有显现的杂染品法，也就是前七转识的熏习，就有了能现起杂染品法的种子。“为别异住？为无别异？”阿赖耶与种子是别异呢还是无别异？别异就是不同，无别异就是相同。妙老在这儿的说法不是这样的，他是说，这别异、无别异是指种子与种子之间的关系是什么？是别异还是无别异？他举了这样的例子，譬如说贪心的种子，贪心当然是烦恼法了，是坏的，但有时候贪心也会做好事。当然了，贪心为善也是有漏善。所以贪心作的好事所熏的种子，贪心作的坏事所熏的种子，这两种种子是别异还是无别异？

非彼种子有别实物于此中住，亦非不异。

种子就是以识为自性的功能性，它并不是离开阿赖耶而有另外的自体，所以它不是异。“有别实物此中住”就是说，并不是有一个真的东西进到了阿赖耶里面。所谓真的东西――“别实物”，就是指自己有体，种子是以阿赖耶识为体的，它没有单独的体。现行诸法熏成种子，在熏成的时候，它和阿赖耶识同是无记性的，根本就没有善恶之分，不能说它和阿赖耶识是别异的。“亦非不异”，虽然说不是异，但能不能说它不异呢？也不能说！为什么？因为在熏习的时候是有善恶差别的，每一现行法都是可以判定善、恶、无记的，每一法都有他各自的体性、相貌，都是差别。实际上我们这么说反而好理解。一滴水放到大江里边儿，异吗？都是水！不异吗？一滴水、一江水～～阿赖耶还有藏的功能，他把每一个种子放到里边儿储藏，但每一个种子是没有藏的功能的。就是说，每一个种子都没有储藏的功能，但把这些个种子综合起来就有了。用语言表述总是有偏差的，熏习种子是功能性，说实在的，不应该用“个”来说。

然阿赖耶识如是而生，有能生彼功能差别，名一切种子识。

“然阿赖耶识如是而生”，当阿赖耶识与杂染品类诸法俱生俱灭这样熏习的时候，他自然就有了种子，这种子在阿赖耶识熏习了以后，就有“有能生彼功能差别”了，所以可以叫“一切种子识”。杂染品类诸法一直是染污的，这就造成了其种子也是善、恶不一，但阿赖耶识咱们在《唯识三十颂》中就知道，它是无记的、是无覆无记。

复次，阿赖耶识与彼杂染诸法同时更互为因，云何可见？

这是开始说阿赖耶识与杂染品类诸法互为因缘，它们是互相为缘而生起的。阿赖耶识与杂染诸法是同时存在的，而且同时互为因缘。你是怎么知道它同时存在，同时互为因缘呢？

譬如明灯，焰炷生烧，同时更互。

这是一个比喻。举的灯的例子，比如说灯，灯在着的时候，既有灯火，又有灯芯，灯芯燃烧的同时发光，它是同时的，没有先后。灯芯生出灯火，灯芯是灯火的因，灯火烧灯芯，灯火又是灯芯燃烧的因，互为因缘，而且同时。这就是“譬如明灯，焰炷生烧”。灯芯发出灯焰，灯焰又来烧灯芯，是同时的。就是灯芯不离火苗，火苗不离灯芯。杂染诸法和阿赖耶识的同时更互为因关系给这差不多，也象这一样。

又如芦束互相依持，同时不倒。

把芦苇割下来捆成捆儿。一捆儿芦苇中的每一棵都是互相依持的。单独的一根芦苇，它是立不起来的，但是一捆儿的芦苇是可以立起来的。什么意思？就是说它们互相依持，“同时不倒”，也就是说，离开了杂染诸法也就没有阿赖耶识，离开了阿赖耶识也就没有杂染诸法。这就是因果的平等。

应观此中更互为因，道理亦尔。如阿赖耶识为杂染诸法因，杂染诸法亦为阿赖耶识因。

说过了两个比喻，就说要用这道理去观察阿赖耶识与杂染诸法互相为因的道理。阿赖耶识是杂染诸法的因，要是没有阿赖耶识，杂染诸法就生不起来。同时，杂染诸法也是阿赖耶识的因，要是没有杂染诸法，也就没有阿赖耶识了。阿赖耶识里有很多种子，这种子就是一切杂染诸法现起的的因，杂染诸法就是靠阿赖耶识里的种子才生起现行的。杂染诸法能熏习阿赖耶识，熏习了才有阿赖耶识里的种子，要是不熏习就没有种子了，没有种子就称不上一切种子识了。

唯就如是安立因缘，所余因缘不可得故。

四缘生法，其中的亲因缘只能是这个，其他的都不是亲因缘。也就是说，只有阿赖耶识里的种子才是亲因缘，其他的只是方便说而已。比如我们说菩提心乃成佛之因，其实成佛之因乃是法尔本具的无漏种子，说菩提心那只是方便说。有的人是发不起菩提心的，发了又没有了，发了又没有了……这就是说他根本就没有发起菩提心来，为了鼓励他我们说他发了，那只是我们说他发了而已，实际上根本就不是发起了菩提心，要是真发起了菩提心是不会再没有的，那不是果位，要到八地才不退的。

云何熏习无异无杂，而能与彼有异有杂诸法为因？

说，在熏习的时候，杂染的品类诸法各不相同，但是，熏到种子识以后，我们看不出有什么不同。就是说，善恶诸法我们能看出不同，看得出这是好事儿，那是不好的事儿，但成种子后，我们也不知道了。阿赖耶识无覆无记。就象这是黄河水，这是长江水，这是什么河的水，但当流入大海大洋之后，你还能分出这是黄河来的，这是幼发拉底河来的吗？分不出来～～杂染品类诸法的各不相同叫“异”，不是纯一的行相就叫“杂”。说，在熏习的时候，本是有异有杂的，但经过熏习，成了无异无杂的了――无覆无记性――那个无异无杂的那个情形，阿赖耶识就是这样，它“能与彼有异有杂诸法为因”，前边儿已经说过了，阿赖耶识可以作杂染诸法的因，杂染诸法也可以作阿赖耶识的因，互为因果。为什么无异无杂的阿赖耶识能够成为有异有杂的诸法的因呢？下边儿无著论师是举了一个例子来说明的。

如众缬具缬所缬衣，当缬之时，虽复未有异杂非一品类可得，入染器后，尔时衣上便有异杂非一品类染色绞络文像显现。

“缬（xie）”,在玄应法师的《一切经音义》中说，“谓以丝缚缯，染之，解丝成纹曰缬也。”，这话在《一切经音义》第十卷。据说给咱们中国古法染布是一样的，可我还真不知道中国古法是怎么染布的。印顺法师说了半天我仍然不明白，反正是一个比喻，不明白就算了，知道他说的是什么就行了。

阿赖耶识亦复如是，异杂能熏之所熏习，于熏习时虽复未有异杂可得，果生染器现前已后，便有异杂无量品类诸法显现。

“阿赖耶识亦复如是”，阿赖耶识也是这样的，本来是无异无杂的，但表现出来的杂染诸法是有异有杂的。我想要是说成布是一样的，但作出的衣服是各不相同的，这样可能更好理解。“异杂能熏之所熏习”，这个杂染品类诸法的熏习，“于熏习时”这杂染品类诸法在熏习的时候，熏成了种子，就表现不出差别相了，“虽复未有异杂可得”，就是指阿赖耶识里的种子没有异杂相。“果生染器现前已后，便有异杂无量品类诸法显现”，熏习的时候成了种子，这个种子成熟了的时候，就果报现前，这果报现前的时候，“便有异杂无量品类诸法显现”，便有各式各样的果报。还是这句话：在阿赖耶识的时候是无异无杂的，但他得果的时候、现行的时候，就有异有杂了。

如是缘起，于大乘中极细甚深。

这儿是说的与阿赖耶相关的缘起相。大乘佛法中说的缘起是“极细甚深”的，不但凡夫不知道，就连二乘也不是十分的清楚。现在在这儿就要注意一点儿，有人在这儿老讲不对，就是把阿赖耶当成了最后因，这也是错误的。这样讲阿赖耶识实际上是把阿赖耶识等同于上帝、等同于梵了。阿赖耶是现行诸法之因，但现行诸法又是阿赖耶的因，它仍然有因，它不是没因。

又若略说有二缘起：一者、分别自性缘起，二者、分别爱非爱缘起。

在这里简单给说说大乘的缘起。其实前边儿说的阿赖耶三相就是缘起的境界，说这缘起实际上是阿赖耶识与杂染品类诸法互为因果这么一个缘起。说真正的缘起就是阿赖耶缘起。注意我的说法，阿赖耶识与杂染品类诸法，其实就是种子与现行，可不是把阿赖耶识与杂染品类诸法分成二。现在再略括一下，分成两类来解释，一个是分别自性缘起，一个是分别爱非爱缘起。

此中依止阿赖耶识诸法生起，是名分别自性缘起。以能分别种种自性为缘性故。

啥是分别自性缘起呢？实际上很简单，就是依止阿赖耶识里面的种子而现起一切法。“自性”就是自体，也就是此事物不同于他事物的本质。每一法的自性都是因缘生起的。“以能分别种种自性”，事物本身就可以证明自己存在，事物本身就能够使事物本身显现出来。咱们都知道笛卡尔的一句话，“我思故我在”，要按佛教说的话，就是思只能证明思在，思证明不了我在。“分别”就是显现，每个种子都不相同，它显现出来的不同表相，就可以证明它不相同。妙老说分别就是不混乱。无始以来，杂染品类诸法熏习了太多的种子，但这些种子不会因为时间太长，你弄不清了，它就混乱了，这是绝对不会的。也不会说它忽然间发了昏，贪的现行熏成嗔的种子了，这也不会。妙老说这不混乱就叫“分别”。“分别种种自性”就是把事物本质上的不同统统不差一毫地显现出来，一点儿也不歪曲。你作的是好事儿绝对不会让你得苦报的，放心好了。

复有十二支缘起，是名分别爱非爱缘起。

这爱非爱缘起就不是直接的是什么就是什么了，他是加上了我们的歪曲。“爱”就是可爱的，认为好的，喜欢的，“非爱”就是反过来。这爱非爱是怎么来的？就是造业而来。刚才说的分别自性缘起，是阿赖耶识里的种子表现到外边儿来了，现在说的这分别爱非爱缘起，无著论师说是“十二支缘起”，就是常说的十二因缘，无明、行、识、名色、六入、触、受、爱、取、有、生、老死，所得的果报是可爱的就叫爱缘起，所得的果报是非可爱的，就叫非爱缘起。分别自性缘起是直接的，分别爱非爱缘起则是曲折的，你想作某事儿的时候，费心费力，一点儿也不好，但得的是果报是可爱的，现在享乐挺好，但得的果报是非可爱的。

以于善趣恶趣能分别爱非爱种种自体为缘性故。

你做善法，你就到人天善道受生，你做恶事，就到三恶道去受生。长行中的“以于”是因为，“自体”是生命体，因为你造了善业、恶业的不同，所以你到善道、恶道去受生，你到了善道你觉得可爱，到了恶道你觉得不可爱。你这个阿赖耶识能够很分明地为爱非爱种种自体生起的因缘，所以就叫“分别爱非爱缘起”。习惯上我们叫“分别爱非爱缘起”为业感缘起，业感缘起的本质还是阿赖耶识缘起。在亲因缘、等无间缘、所缘缘、增上缘四缘里，“分别自性缘起”是亲因缘，是一切法生起的真正原因，而“分别爱非爱缘起”则是增上缘，也是非常重要的。这两种缘起，一个主要是亲因缘，一个主要是增上缘，所以无著论师给分成两种缘起来讲，但实际上分不开的。

于阿赖耶识中，若愚第一缘起，或有分别自性为因。

这儿是要纠正外人的一些错误。“于阿赖耶识中，若愚第一缘起”，有些人对于分别自性缘起不明白，认识不清，认识不清这个就导致对名言种子的道理认识不清。“或有分别自性为因”，就说诸法之因是自性，不知道其实应该是阿赖耶识里的种子。注意这一个“自性”，在数论派的理念里，“自性”是客观世界的最终原因。数论派是二十五谛。数论派说，世界上所有的事物，都是由特定元素结合所产生的，我们所看到的世界就是一系列的结果，既然有结果，必然有原因，原因是什么呢？显然不可能是神我，因为神我既不是事物的原因也不是结果，所以原因一定是非神我的。数论派说，地、水、火、风等物质性极微并不能解释自然界微细东西的起源，比如心、智、我，这是地、水、火、风等所不能解释的，他们就要找一种既能解释粗大的东西又能解释微细的东西的起源的原理。他们说，这原因自己一定得没有原因、永恒。他们就建立了自性，说自性是所有一切的第一因，它没有原因，它是永恒的，是无所不在的，因为任何受限制的、非常住的都不是第一因。数论派说，自性有三种性质：喜、忧、暗。我们不详细说数论派，还说这《摄大乘论》。“自性”就是数论派的自性，它是第一因。自性就创造出世间万物。“分别自性为因”就是说数论派说世间万物的原因是自性。在佛教中，说阿赖耶识是万物之因，万物又是阿赖耶识之因。我做恶熏习阿赖耶识，阿赖耶识就给我一个苦的果报，我用善来熏习阿赖耶识，则它给我乐的果报，这苦、乐果报是自己创造的。要是以自性为因，道理该咋讲呢？用阿赖耶识为因，自己就可以改造自己，我不要有坏的熏习就可以把我自己改变了。要是用自性为因，它给我一个天堂、地狱，这与我自己的思想行为完全没有关系。所以还是阿赖耶好一些儿。

或有分别宿作为因。

刚才说的是数论派的说法，这一个是尼犍子外道的说法。尼犍子外道就是无惭外道、裸形外道，其实就是耆那教，耆那教后来分成两派――白衣派、天衣派，天衣派说修行者得放弃任何财产，甚至衣服，这样就没有衣服穿了，而白衣派则说修行人也还是得穿上白衣的。白是善、清净的意思，是表法的。在尼犍子外道来说，我们现在的一切，都是过去世的定业使得我们有了现在的遭遇，不是我们现在的思想行为所能改变的，也就是说是命中注定的，这就叫“宿作”。你过去世做了很多罪，所以你现在受苦，你现在就多受苦，这样慢慢就把你过去的罪消了，啥时候消完你就啥时候解脱。佛教当然不同意这说法了，佛教说解脱最重要的是内心的解脱。

或有分别自在变化为因。

“自在变化”，有一类外道，他们认为一切都是大自在天（是一个人格神）的变化而有的，它是宇宙万有的根源，它变出什么就有什么，但它自己是不变的。

或有分别实我为因。

大自在天的变化是外在的，就是执外，而这分别实我为因则是执内。这一类外道（指吠檀多派）说，在我们的生命体之内，有一个真实的我，现在的一切都是实我的所为，这实我是真因。

或有分别无因无缘。

这一类外道说根本就没有因缘，事实本来就是如此，根本就没有因缘。这就抹刹了人为的努力。以上这些就是对分别自性缘起的不解而造成的错误。

若愚第二缘起。

如果对分别爱非爱缘起的道理不明白的话。

复有分别我为作者，我为受者。

因为你对分别爱非爱缘起的道理不明白，你就执著我是作者，我是受者。注意，我为作者、我为受者这说的是胜论派和数论派。分别爱非爱缘起是偏重于增上缘的力量，就是业种子……刚才我说了没有？分别自性缘起是名言种子，分别爱非爱缘起是业种子。没有？那现在说了。名言种子是亲因缘，只有亲因缘是不行的，还得有增上缘，增上缘就是爱非爱的烦恼和业力，凭这烦恼和业力来增上帮助才可以。胜论派、数论派就不明白这个道理。胜论派说我是作者，数论派说我为受者。数论派自性是第一因，自性造出东西给神我受用，这个我就是受者。胜论派则说我是作者。“分别我为作者，我为受者”，“作”就是造业，“受”就是受果报，作业、受报，外道说是我的力量，佛教说是烦恼和业的力量，根本就没有我，我只是虚妄分别。

譬如众多生盲士夫，未曾见象，复有以象说而示之。彼诸生盲，有触象鼻，有触其牙，有触其耳，有触其足，有触其尾，有触脊梁。诸有问言：象为何相？或有说言象如犁柄，或说如杵，或说如箕，或说如臼，或说如帚，或有说言象如石山。

这些外道，他们也知道有生死轮回，但他们对生死轮回的解释、认识是错误的，佛教说，所有的错误都是我们认识的错误，这些外道认为有我、有大自在天等，佛教说这都是不对的。现在无著论师说了一个比喻：“譬如众多生盲士夫”，“生盲”就是生来眼睛就瞎了，不能是半路瞎子；“士夫”就是人，就是众生。他们因为是生来瞎子，从来就没有见过大象是啥样儿。“复有以象说而示之”，有一个人要给他们解释清楚大象的样儿，这个好眼人不但用语言给介绍大象的样儿，并且牵来了一头大象。可是这些瞎眼人呢，在触摸大象的时候，有人摸到象的鼻子，有的摸到了象的牙，有的摸到了象耳朵，有的摸到了象的脚，有的摸到了象的尾巴，有的摸到了象的脊梁。每一个人都是只摸到了一部分。等他们摸完之后，明眼人让他们说说象是什么样子，结果他们说的答案是五花八门。这就是盲人摸象的故事。至于中间的如犁柄、如杵、如箕、如臼、如帚等，其实盲人也不知道什么是犁柄，什么是杵，什么是箕等，这只是拿我们的语言来说而。这些生盲者，各人所说的都是自己认识到的一部分，他们把自己认识到的就当成了整个儿大象。这当然是不对的。

若不解了此二缘起，无明生盲亦复如是。

外道不明白二种缘起――分别自性缘起、分别爱非爱缘起，所以就象生盲摸象一样。“无明生盲”就不单是外道，是指所有无明众生。

或有计执自性为因，或有计执宿作为因，或有计执自在为因，或有计执实我为因，或有计执无因无缘；或有计执我为作者，我为受者。阿赖耶识自性，因性，及果性等，如所不了象之自性。

大象只是一个比喻，它就是比喻阿赖耶识，阿赖耶识的自性、因性、果性，我们不明白阿赖耶识，就像盲人不明白象一样。缘起是微细甚深的，凡夫乃至二乘都说不清楚，只有佛菩萨才能认清。因为凡夫、外道认识不清，所以有了各种各样的执著。

又若略说，阿赖耶识用异熟识，一切种子为其自性，能摄三界一切自体，一切趣等。

这一句话是把前面说的作了一个简要的总结。“阿赖耶识用异熟识，一切种子为其自性”，“异熟识”就是阿赖耶识，它是阿赖耶识是果相。“异熟”有好几个意思，一个是异时而熟，就是过去造业，以后感果，这就异时而熟。还有异类而熟，就是因有善恶，但果唯无记。还有一个是变异而熟，就是说我是一个人，我造了业，后来感得我到饿鬼道去受生，人造业可饿鬼受苦，这就是变异而熟。异熟识是果相，就是杂染品类诸法从无始以来这样熏习，阿赖耶识这样相续地存在，就叫果相。说异熟识是果相，也就是说阿赖耶识就是这样存在的。“一切种子为其自性”，这是说异熟识果相，是因为有一切种子的关系，无始以来这杂染品类诸法的熏习，而有了很多很多的种子，所以他能够成为异熟识，所以又能接受杂染品类诸法的熏习，又成为一切种子……因为因，所以果，因为果，所以因……缘起就是这样一回事儿。果是由一切种子的因而来的，一切种子是由杂染品类诸法的熏习而有的，所以，我们可以从因着手修行。“能摄三界一切自体，一切趣等”，说，异熟识可以摄尽三界，因为三界都是阿赖耶识的种子变现的。“一切自体”的“自体”是指生命体，就是众生。“一切趣”就是六道。这就是说，阿赖耶识统摄三界、六道。下边儿说种子。

此中五颂：

接下来有五个颂子。

外、内。不明了 于二唯世俗

胜义。诸种子 当知有六种

剎那灭、俱有 恒随转应知

决定、待众缘 唯能引自果。

这是前两个颂子。我们在读的时候，要把颂子打散读。先看“外内”，它是说，种子有两类，一类是外种子，一是是内种子。外种子就是麦种、玉米种等这一些，这是随世间说法而说的，内种就是阿赖耶识里面的种子。再看“不明了、于二”，“不明了”是说外种子的性质没有善、恶，统统是无记的。“于二”是说内种子是有清净、杂染之分的。整体阿赖耶是无覆无记，但单说里边儿的种子，那是有善、恶的。“唯世俗、胜义”，世俗是指外种子，胜义是指内种子。“诸种子当知有六种”，种子六义。下边儿就要说了，符合六义的是种子，否则就不是。

“剎那灭、俱有，恒随转应知、决定、待众缘、唯能引自果”，这就是六义。接着稍微介绍一下。“剎那灭”，这是第一个条件。某一法一出现，一下子它就得灭，剎那生、剎那灭，如果它生起来后要停一下再灭，那是不行的，没有生灭，就成无为法，更不能作种子了。这刹那灭就是说生灭只是刹那间的事儿，生灭刹那，永无停息。干脆就说是生灭同时，生即是灭。生起后不能停留，立马就得灭。它生的时候就是它灭的时候。佛教说的生、住、异、灭，中间有个“住”，这个“住”是指前后念的差异太小而已，根本就没有停的时候，必须刹那刹那都变，假如说在某一个刹那它停住了，那么后边儿的变化过程就没有办法继续。刹那灭是念念生灭，但不一不异，无多大差别。第二个是“果俱有”，就是指因与果是同时有的。如果说这个种子灭掉了，灭掉了就没有了，没有了它咋再去生果呢？所以一定得“俱有”。灭了后它就不能生果了。种子生起现行，刹那即灭，但并不是灭后才生成果，而是刹那生灭之际，因果同时。这果实际上就是新熏的种子。果俱有，就是说不是因果前后相生，也不是因果相离他身而生，为啥？因为异时——因果前后相生就是异时，还有异处——因果相离他身而生就是异处，若异时异处的话，就不能和合。所以，果俱有就是：不是种子灭了，现行才起，而是只要众缘具备，因果立马同时俱存，而且不只同时还要同地，即“同时同地俱生俱灭”。

第三是“恒随转”，种子起现行，刹那即灭，但不是灭了就完了，而是前灭后生，刹那刹那，相似随转。种子后念的生灭与前念的生灭中间没空隙，其性类似，相续不断。种子、现行与果同时俱有，才生即灭，但在灭了之后，现行成为新熏种子，再起现行，这叫做“种子自类相生”。换句话说，种子、现行、新熏种子，三者一类相续转起，没有间断转易。这恒随转说明了种子在未得对治时，余势不绝，还说明有转易间断之法不能做种子。种子一直随逐阿赖耶识继续地存在，它生果的功能是不会失掉的。只有当感了果之后，那它就没有了。还有一种就是对治，你把这种子对治了，它也就不感果了。不然的话它就一直存在。

颂子的“恒随转”后边儿有两个字儿――“应知”，就是说我们应该注意这个、应该知道这个。第四是“性决定”。就是说作了善只能感得好的果报，作了恶只能感得苦的果报，绝对不会作善得苦报、作恶得乐报，是不会有这样的事儿的。也就是说，现行的苦、乐、无记是由种子本身的善、恶、无记决定的。善种生起乐的现行，恶种生起苦的现行，这个因果法则不能混乱。就是说，一旦有了种子之后，直到现行，它的性质不会改变。我们做好事，就种下的善因，我们做好事是善种子产生的现行，我们做好事本身又熏习善的种子，这个熏习的过程使我们的生命中的善的力量得到一次壮大，然后我们又做一次好事，又是善的种子的现行，善的力量在我们的生命中就又得到一次壮大，这种力量是不会变的，它不会说因为你做了一次坏事就使得它变成了恶。你干了坏事是恶因在现行，是恶的力量在壮大，这是两回事儿。恶种子不会因为善的力量而消除，善种子也不会因为恶的力量而消除。种子与现行相互熏习，而且同性熏习，善种生乐现行，苦现行熏恶种子。这说明种子的性类是不同的，也说明种子与异性现行是不能成因的。也就是说，一个东西一定有它特定的原因，必须是这个东西生起这个东西，这个决定了。种瓜就得瓜，种豆就得豆。

第五是“待众缘”，就是指种子要生起现行，必须众缘和合。缘若不具，绝对生不起果报。种子的功能虽然是任运而转的，但法不孤起，种子必须有众缘配合方可生果。也可以这么说，一个东西要生起现行，不可能什么时间都能生起，一定得等到缘具的时间。这是必然的，必然是这样子，它决定不能一切时都可以，它要众缘具备。生起是必然要生起的，必然生起这个而不是那个，但又不是随时想要随时就有。猫生下的必然是小猫，但绝不是随时就可以生只小猫出来，一定得经过三个月怀胎孕育。第六是“引自果”，种子不是一因生众果，而是各各引生自果。就是说色法种子只能引生色法，心法种子只能引生心法，此一法则不能混乱。种子六义就是这个，下边儿就是熏习的问题。

坚、无记、可熏 与能熏相应

所熏非异此 是为熏习相

这个颂子是说熏习的，说到熏习，咱们知道，有能熏、有所熏，能熏有什么条件？所熏又有什么条件？这个颂子就说了条件。先看所熏四要件。第一是“坚”，坚住性，强调不间断。这坚住性就要求无始以来一直相似相续，一刹那也不能停止，而且还不能有太大的变动，就是稳定、稳当。世亲释中举了风的例子，翻开书110页：“坚者，坚住方可受熏，非如动风。所以者何？风性流动，不能任持，所有熏气一踰膳那彼诸熏气亦不随转，占博迦油能持香气百踰膳那彼诸香气亦能随转。”什么意思？就是说，风的流动性太大，它任持、摄持香气的能力就很小，风吹花香，风能吹到很远的地方，但是香气不会随风跑到很远的地方！油里面有香的时候，它就能够一直执持香气不散，把油拿到百踰膳那，香也能随着到百踰膳那远的地方去，就是因为油比风稳定一点。这阿赖耶识是始终一味的、无记的，长时期不间断，它比较坚住、比较稳定，所以它有摄持种子的功能。前六识不行，前六识一下善，一下恶，一下又间断，它就没有坚住性。

“无记”是第二个条件。不能是善，不能是恶。只有这样它才能够善的、恶的都接受。若它本身是善，那恶的来了它就排斥，若它本身是恶，那善的来了它也会排斥，所以不行。“可熏”是第三个条件。就是它可以受熏，它有容受种子的功能，它能接受种子。阿赖耶识就是一切种子识。这可熏主要说了两个问题，一个是自主，就象心所，心所没有自主，就不行；一个是不坚密常住，坚密常住就是顽固不化、固定不变的东西。他已经固定了，就不可再造就了。这是剔除无为法，说无为法不行。象《大乘起信论》里边儿说的真如无明互相熏习，就是不对的。这可熏性就要求它既有自主权，又不是顽固分子。“与能熏相应”是第四个条件。就是可以与能熏相和合。“相应”就是“同时同处，非一非异，不相分离”。同处就是说我自己的前七识与第八识，不可能我的前七识造下业种子却熏习到你们的第八识里；同时就是因果同时。或者说是“同时同处俱生俱灭”，必须同时，不能是前后。

“所熏非异此，是为熏习相。”就是说，具足了这四个条件的才是所熏。我们看符合这四个条件是是谁呀？是阿赖耶识。就是说，阿赖耶识是所熏，前七转识都不够格儿。在《成唯识论》中补充了能熏的四个条件，这《摄大乘论》中是没有的。能熏的四个条件就是：一、有生灭。有生灭就是无常法，恒常的东西是不能起作用的。为什么人永远不能与上帝平等，就因为上帝恒常如一。受熏的坚住、稳重，能熏的就活泼，二者互补，就构成完美的事件。二、有胜用。这个有胜用主要是排除异熟心心所，因为这异熟心心所势力太弱，受熏的无记，能熏也无记，就都成老好人儿了，那怎么行？三、有增减。这个有增减有点儿象马太效应，你若是个穷人，穷得叮铛响，只剩两个硬币在口袋中碰，那么我就要把你仅有的两个硬币夺过来，把你逼入死路，就是古话说的“逼入死地而后生”。你若是富人，富得流油，我还要把穷人的那两个硬币也给你富人，也就是让你香的更香，臭的更臭。四、与所熏处相和合。也就是说得和所熏不即不离。把能熏、所熏都说了，这更圆满。

六识无相应 三差别相违

二念不俱有 类例余成失

这是第四个颂子，就是说转识是不能够受熏的，它不符合所熏的条件。第一句说“六识无相应”，前六识是不够格儿的，为什么呢？“三差别相违”，三差别是指所依、所缘、作意。前六识各有各的所依，都不相同。所缘也是各不相同。作意也是。因为所依、所缘、作意都不相同，使得前六识各自为政，随时变动，这就与所熏要件不符。“二念不俱有”，这一句是对小乘的譬喻论师说的话，因为譬喻论师认为，前六识的前后念就可以受熏，不需要建立阿赖耶识。无著论师这儿就说了，前一念和后一念是不能同时存在的，既然不能同时存在，这就不符合受熏定义“同时同处、俱生俱灭”的“同时”，前一念存在的时候，后一念还没有生起，后一念生起的时候，前一念已经灭了，这根本就没有办法俱生俱灭，它咋受熏呢？“类例余成失”，“类”是指，譬喻论师说，前一念识和后一念识是同一类的，同一类就是可以受熏的。无著论师说这不对，说，如果是同一类就可以受熏的话，那么眼根、耳根、鼻根、舌根、身根，这都是根、净色根，是不是也可以熏习呢？色法与色法之间是不是可以相互熏习？心法与心法之间是不是也可以相互熏习？善法与善法之间是不是可以相互熏习？无为法与无为法之间是不是可以相互熏习？等等，多了。所以要是按你说的，只要是一类就可以相互熏习的话，就会出现这样的错误。

此外内种子 能生、引应知

枯丧由能引 任运后灭故

这是第五个颂子，是说种子的生因和引因。啥是生因？啥是引因？颂子中的“枯”，就是比如说一棵树，长着长着它枯了，“丧”，就是这个生命体死。说，枯、丧是引因的证据，如果没有引因的话，死了， 不该慢慢枯，不该留下尸体，而应该一下子顿时消散。生因就是如种生芽，这是生因。但生起以后我们觉得它是渐渐变的，这就是因为引因。“后灭”就是延长了一段时间，逐渐地灭。所以，生因、引因都是有的。人从投胎后一直活着，这是生因在起作用，但死的时候，死了，尸体也要保留一段时间，这是引因。一棵树，长出来了，一直活着，就是生因在一直起作用，到死的时候，有好长时间它不腐朽，这是引因的作用。这是世亲的说法。无性的说法有点儿不一样。我们不管这个，反正生因、引因都有。

为显内种非如外种，复说二颂

种子有六义，但内种与外种还是有点儿不同的地方，为了显示这不同，下边儿又说了两个颂子。

外或无熏习 非内种应知

闻等熏习无 果生非道理

作不作失得 过故成相违

外种内为缘 由依彼熏习

“外或无熏习，非内种应知”，说，外种子或者有熏习，或者没有熏习，这不一定，要具体情况具体对待。“或”就是不绝对。比如前边儿说到苣蕂，它可以受花的熏习而造出香油，可以用来擦身，但是莲花长在淤泥里，莲花的香怎么也熏不到淤泥上。外种的这一点儿就和内种不一样，内种子是一定要有熏习才能成就的，也就是说，必须得修学才能成就道业的。“应知”，这是应该知道的。下边儿举了一个例子，就是“闻等熏习无，果生非道理”，就是说，一个佛教徒，要是你不努力地修学，没有闻思修的熏习，你是绝对得不到想要成就的道业的。一定要有熏习才能成就。“作不作失得，过故成相违”，这一句实际上是“作失不作得，过故，成相违”，就是说，你努力地修行，没有结果，你没有修行，却成就了道业，这是有过失的，所以说一定得承认内种子熏习。你努力修行却没有结果，这是有因无果，断灭见；你不修行，却有结果，这成无因有果了，当然不对。“外种内为缘，由依彼熏习。”外种子其实是随顺约定俗成而说，实际上只是假名种子而已。它是以内种为因缘的。为啥？“由依彼熏习”！就是说一切众生要依彼阿赖耶的熏习才有外种的出现，外种子也是阿赖耶识的变现。这玉米生芽了，芽也是阿赖耶识的变现。如果众生的业力是应该受饥馑之苦，种子就不生芽了，或者生芽了但不开花结果。这业力就是阿赖耶识的（内）种子，所以还是以阿赖耶识为万法的生因。也就是说，内种、阿赖耶识的种子是真实的，外面的种子是随顺世俗约定俗成的假名而已，它不是真实的。

复次，其余转识普于一切自体诸趣，应知说名能受用者。

这一段儿要用四缘来分析，四缘就是亲因缘、增上缘、所缘缘、等无间缘。要用四缘来说，先来说说受用问题，或者说是受用缘起问题。能受用者是转识！“复次，其余转识”，前边儿是说阿赖耶识，现在不说阿赖耶识了，要说其他的识，其他的识就是转识。“转识”指前七识，但相对来说，前六识的变化更明明显。“其余转识普于一切自体诸趣，应知说名能受用者”。转识是普遍地存在于一切诸趣的自体，或者说是三界的一切生命体，欲界、色界、无色界的生命体，都有转识。“应知说名能受用者”，三界六道的生命体都是阿赖耶识的种子识所变现的，种子识变现了以后，由转识依止这个生命体来享受苦乐的果报。转识与阿赖耶识就这样一个关系。阿赖耶识变现了苦乐的境界，也变现了根、身、器界，然后转识依止根身，或受乐，或受苦，所以转识是能受用者,它来享受阿赖耶识所变现的一切。转识在活动的时候，同时又再造业，这就又熏习了阿赖耶识，阿赖耶识因为它的熏习又显现三界一切自体，这就成就了六道轮回。这是受用缘起和阿赖耶识的关系，要是没有阿赖耶识的变现，转识就没有什么可享受的。阿赖耶识自己是不享受的，因为阿赖耶识不去分别苦、乐。

如中边分别论中说伽陀曰：一则名缘识，第二名受者，此中能受用、分别、推心法。

这是无著论师引用《中边分别论》中的说法，意思就是说，转识受用可不是我无著乱说的，这是有典籍依据的。《中边分别论》就是《辨中边论》，是弥勒菩萨说的。这《辨中边论》中有这样的颂子。“一则名缘识，第二名受者”，《辨中边论》中把众生的识分成两类：一类是“缘识”，一类是“受者”。“缘识”就是指阿赖耶识，因为它是万法的因缘，万法都是因阿赖耶识的种子而显现的。“第二名受者”，这就是指转识。“此中能受用、分别、推心法”，缘识和受者识两类，受者识能受用，为啥它能受用？就因为它能分别。就是识，转识可以分别出来这是苦的，那是乐的，它在受的时候可以分清苦乐果报、境界。受用的“用”字儿，就是指发生作用，因受的关系而发生作用。比如说因为贪求这个乐受，所以就发生作用，要增加这个乐受。还有一个意思是指受就是用，能够起受的作用，这个境界能发出作用给我享受，给我享受就是它的作用。实际上咱们这样说可能更好，就是说，因为转识与受心所相应，所以是“能受用”。“推心法”的“推”是推动，主要是指思心所，说思心所能够使我们造业。“受用”是受蕴，“分别”是想蕴，“推”就是行蕴。这受、想、行都是心法。这是受用缘起来说明转识和阿赖耶识的关系，下边儿说这两种识更互为缘。

如是二识更互为缘，如阿毘达磨大乘经中说伽陀曰：诸法于识藏，识于法亦尔，更互为果性，亦常为因性。

“如是二识更互为缘”，“二识”就是缘识和受者识，也就是本识和转识，这两个识互相为因缘。“如《阿毗达磨大乘经》中说伽陀曰”，在《阿毗达磨大乘经》中有这样的一个颂子。“诸法于识藏，识于法亦尔，更互为果性，亦常为因性”，“诸法于识藏”，诸法就是指一切杂染品类诸法，一切的杂染品类诸法都没有自性，以识为自性的，这就是转识的分别，所以，这儿说“诸法”就等于是说的转识。“于识藏”，转识相对于阿赖耶识来说，诸法是阿赖耶识的种子所变现的。也就是说，阿赖耶识种子是因，诸法是果，阿赖耶识的种子是因，一切法是果。“识于法亦尔”，阿赖耶识相对于转识杂染品类诸法来说，“亦尔”，也是有因果关系的，就是说，诸法是因，阿赖耶识是果。“更互为果性”，阿赖耶识和转识，是互相的果，你是我的果，我是你的果。“亦常为因性”，也可以说我是你的因，你是我的因。

若于第一缘起中，如是二识互为因缘，于第二缘起中复是何缘？是增上缘。

“若于第一缘起中”，“第一缘起”就是分别自性缘起。用四缘来观察分别自性缘起的时候，“如是二识互为因缘”，阿赖耶识与转识是互为因缘的。四缘就是因缘、所缘缘、增上缘、等无间缘，现在这阿赖耶识和转识是因缘而不是其他的三种缘。“于第二缘起中复是何缘”？“第二缘起”就是分别爱非爱缘起，它是四缘中的哪一缘呢？“是增上缘”，它是增上缘。“增上缘”就是说，你本身已经有力量了，我再去帮助你一下，这帮助就是增上、增加。增上缘的“增”就是增加，“上”是让你更加殊胜，我的帮助可以使令你更殊胜。分别爱非爱缘起中的无明缘行，行缘识……都是增上缘，无明缘行，行本身有自己的因缘，但无明就是来帮助他。

如是六识几缘所生？增上，所缘，等无间缘。

刚才说的是分别自性缘起、分别爱非爱缘起，这一句是说的受用缘起，受用缘起就是前六识。“如是六识几缘所生？”就是说，在四缘中，受用缘起得哪几缘？“增上，所缘，等无间缘”，前六识要增上缘、所缘缘、等无间缘等。增上缘就是指六识各自所依的根。所缘缘呢～～陈那论师有一本《观所缘缘论》，专讲所缘缘的，所缘缘其实就是认识对象。等无间缘就是前一剎那识灭掉了，空出了一个位子，后一剎那立马就生起，前后念的相续是“等无间缘”。所缘缘、等无间缘是心法才有的，色法没有所缘缘、等无间缘。这里说前六识是增上缘、所缘缘、等无间缘三缘，实际上因缘也是有的，这里没说而已，不过这里是从受用的角度说的，所以没说因缘。没说是没说，可不是没有。

如是三种缘起：谓穷生死，爱非爱趣，及能受用；具有四缘。

前面说了三种缘起，就是分别自性缘起、分别爱非爱缘起、能受用缘起。这里把分别自性缘起说成“穷生死”，这是指分别自性缘起的种子生现行，现行熏种子，无穷无尽，没有结束的一天。当你不再生死了，就是解脱了，到那时候，转识成智，都成了清净的种子，你认识到的一切都是清净的。“爱非爱趣”是第二个缘起，就是可爱的、不可爱的果报，这是因为你的善恶业成熟而得的果报，也就是造业受果。“及能受用”，前六识能受用苦乐的果报。由分别自性缘起的种子出现这些果报，爱非爱的增上缘，帮助这果报的出现，出现果报之后由能受用缘起受用。“具有四缘”，这三种缘起四缘都具足了。因缘、次第缘、所缘缘、增上缘都有了！心法四缘生，色法两缘生――因缘、增上缘，它没有等无间缘和所缘缘。

如是已安立阿赖耶识异门及相，复云何知如是异门及如是相，决定唯在阿赖耶识非于转识？

这儿要说阿赖耶识为染净依的事儿，前面已经说了阿赖耶识种种异门、三相等等，“复云何知如是异门及如是相，决定唯在阿赖耶识非于转识？”，你凭什么这么说呢？你凭什么说你说的种种异门是阿赖耶的而不是转识的？这就是反反复复地说明，因为小乘论师对小乘的说法是根深蒂固的，所以就得反反复复地说。前边儿引用经教的地方比较多，从这儿开始就该说道理较多了。无性论师在这儿有一个颂子，你们翻到342页，最里边儿倒数第一行，“颂言：圣教及正理，各别有功能，为生于信慧，无一不成故。”什么意思？就是说，圣教给正理是不一样的，圣教是让人生信的，而正理是让人生慧的，圣教给正理各有各的功能。无信不成，信为道源功德母，但无慧也不行，成佛凭的是慧，无慧就成不了佛。所以前边儿先引圣教说，下边儿说道理。

由若远离如是安立阿赖耶识，杂染清净皆不得成：谓烦恼杂染，若业杂染，若生杂染皆不成故；世间清净，出世清净亦不成故。

无著论师在这里是先简单地说一下，接下来再详细解释。“由若远离”，“远离”指远离阿赖耶识，没有阿赖耶识。说，如果没有阿赖耶识的话，“杂染清净皆不得成”，要是没有阿赖耶识的话，那么流转生死以及涅槃解脱等等都成立不了了，苦集灭道也都成立不了。前边儿杂染、清净皆不得成，下边儿举了一些例子，比如说“谓烦恼杂染”，烦恼杂染就是贪、嗔、痴、慢、疑、不正见之类；还有“若业杂染”，这就是福业、非福业、不动业之类的……贪、嗔、痴、慢、疑、不正见是杂染好说，但接下来说福业、非福业、不动业也是杂染，奇怪吧～～尤其是不动业。福业是招感欲界善果的业，非福业又叫罪业，就是招感欲界恶果的业。不动业是指招感色界及无色界善果之业，我们知道，要到色界、无色界，那是得凭禅定功夫的，这不动业就是按所修的禅定来说的，比如修四禅定，将来就会生到色界天去，如修四无色定，将来就会生到无色界天去，在色界天、无色界天受禅定之乐，不为外境所动，所以叫不动业。这不动业也是杂染的，怪得很。这就是因为没有菩提心而修奢摩他，没有菩提心而修禅定，照样是杂染的。“若生杂染”，按十二因缘来说，无明、爱、取是烦恼杂染，行、有是业杂染，识、名色、六入、触、受、生、老死是生杂染。三界六道众生的果报都是杂染。“皆不成故”说，要是没有阿赖耶识的话，这烦恼杂染、业杂染、生杂染都成立不了了。但现在这三种杂染都成立了，所以阿赖耶识就是有的。再说清净。要是没有阿赖耶识的话，清净也不得成立。清净有世间清净、出世清净。要是没有阿赖耶识，世间清净、出世清净都不能成立。这道理与杂染是一样的。“世间清净”就是现在修离欲之类的，在欲界里修，修好了就生到色界、无色界，这是世间有漏修行方法，叫“世间清净”。“出世清净”就是无漏的戒定慧、三十七道品、或八正道、四念处等这样的方法去修行，这是需要般若智慧的。

云何烦恼杂染不成？

刚才说了杂染不成、清净不成，这里要说为什么不成。先说为什么杂染不成，先说烦恼杂染。

以诸烦恼及随烦恼熏习所作彼种子体，于六识身不应理故。

“以诸烦恼及随烦恼熏习所作”，因为诸烦恼、随烦恼的熏习所作的那些种子，是不能在六识里摄藏的。“诸烦恼”是根本烦恼。“随烦恼”包括小随烦恼、中随烦恼、大随烦恼。它们“熏习所作”，说，烦恼、随烦恼在活动的时候，在我们的心识里面就熏习了，然后，“所作彼种子体”，一熏习就熏习成了种子。贪烦恼的活动熏习成贪的种子、嗔烦恼活动的时候熏习成嗔的种子等等，不会乱的。这种子都得摄藏在阿赖耶识里，“于六识身不应理故”，要是把它们摄藏在六识里面，是不对的。在咱们就拿所熏四义来看就行了，六识是不具备所熏四义的，所以不能摄藏在六识身里。六识身的“身”，是积聚的意思。

所以者何？

你光说我不对不行，你得说我为什么不对。

若立眼识贪等烦恼及随烦恼，俱生俱灭，此由彼熏成种非余。

这是拿眼识为例子来说的。说眼识摄持种子是不合理的。“若立眼识”，就是说，你认为不是阿赖耶识在摄藏种子，而是转识摄藏，比如说是眼识在摄藏，“眼识贪等烦恼及随烦恼俱生俱灭”，要是眼识摄藏的话，种子就是熏习而得，在熏习的时候，就得这眼识和贪等烦恼、随烦恼一起俱生俱灭。眼识只有与贪等俱生俱灭了，“此由彼熏成种”，这样的话，眼识才能摄藏烦恼熏习出来的种子。“非余”，如果眼识这样了，才能说是眼识摄藏种子而不是其他的耳识、鼻识，乃至于阿赖耶识，它们都不是，只有你眼识才是摄藏种子的。但实际上眼识不是，为什么不是呢？

即此眼识若已谢灭，余识所间，如是熏习，熏习所依皆不可得。

“即此眼识”，假如说眼识真的是摄藏种子的，我们知道，眼识的活动是刹那刹那的，眼识一活动，接着意识就活动，眼识的间断我们都能觉察到，“若已谢灭”，眼识前刹那活动，接下来它不活动了，为“余识所间”，眼识不活动了，别的识还活动，不然的话我们就是死人了。“如是熏习，熏习所依皆不可得”，眼识是摄藏种子的，它和烦恼同在一起活动，造成种子，现在眼识不活动了，那么种子到哪儿去？没地方了！“熏习所依”，烦恼熏习所依的识就是眼识，眼识不活动了，熏习的种子“皆不可得”，都不见了，抹光了。得等眼识再活动的时候从头儿再来。这样的话，善白作了，恶也不算了，这就与因果违背了。

从此先灭余识所间，现无有体眼识与彼贪等俱生，不应道理。以彼过去现无体故。

“从此先灭余识所间”，这一刹那眼识灭了，只有别识，“现无有体”，眼识灭了，当下就没有眼识的体了，“与彼贪等俱生，不应道理”，眼识既然灭了，它还能让烦恼与它俱生吗？当然不能了，既然不能了，它怎么能受熏持种？这当然是不合理的。因为眼识灭了，它现在没有实体，贪等就不可能给它在一起活动了。

如从过去现无体业，异熟果生，不应道理。

“现无体业”就是已经感过果的业。“现”是现在。你这业已经感过果了，可是现在却“异熟果生”，就是现在又生了异熟果报，这是“不应道理”的，这根本就不合理。宗喀巴大师在《菩提道次第广论》上就说：已经感过果的业就不能再改了。咱老百姓也说，“天下没有后悔药可买”的。

又此眼识贪等俱生所有熏习亦不成就。然此熏习不住贪中，由彼贪欲是能依故，不坚住故。

刚才说眼识摄藏种子是不行的，现在说眼识受熏也是不行的。“又此眼识，贪等俱生”，贪等烦恼和眼识一起活动，熏习也不成就。“然此熏习不住贪中”，熏习必须是俱生俱灭，此有生彼的因，这才是熏习。贪烦恼和眼识在一起熏习，是依止什么地方而熏习的呢？就是说熏习的种子住哪儿？种子住哪儿就是放在哪儿～～“不住贪中”依止于贪是不可以的，就是说种子是不能放在贪烦恼里，为啥？“由彼贪欲是能依故，不坚住故”，为啥不能依止于贪呢？种子不能放在贪烦恼里边儿，为啥？因为贪是能依止而不是所依止，它还要依止于别的呢～～它不自在，而且没力量，所依止应该是有力量的，所以它不是熏习处。也就是说，因为贪烦恼不是心王而是心所，它不自在，它是能依止，它不能作为种子的住处。还有一个原因，“不坚住故”，就是说贪不能够一类相续。它也是剎那就会灭掉的，它灭了，那还怎么熏习。

亦不得住所余识中。以彼诸识所依别故。

眼识熏习的烦恼种子，也不能住在余识，余识就是除了眼识之外的耳识、鼻识、舌识、身识等。眼识熏的烦恼种子，也不能住在余识那儿，为啥“以彼诸识所做别故”，因为眼识、耳识、鼻识、舌识、身识，各有各的所依，眼识依眼根，耳识依耳根……各不相同。各识还有各识的活动，也是各不相同。所以不能乱来的。

又无决定俱生灭故。

刚才说各识有各识的所依，现在说，再说了，眼识这个烦恼，不住贪上，住在了耳识上，但眼识和耳识是俱生俱灭的吗？不一定！住在鼻识上、舌识上、身识上等都是这道理。

亦复不得住自体中，由彼自体决定无有俱生灭故。

眼识熏习的种子，不住在贪中，也不住在余识中，这句话是说住在眼识中也不行。为啥？“由彼自体决定无有俱生灭故”，熏习就必须此与彼一起俱生俱灭，并且此有能生彼之因。眼识能给眼识俱生俱灭吗？根本就没有两个眼识一起俱生俱灭这回事！当然也就不能住自体中。

是故眼识贪等烦恼及随烦恼之所熏习，不应道理。

既不能住贪中，又不能住余识中，还不能住自体中，所以眼识认识色的时候，有贪等烦恼、随烦恼的熏习，眼识受烦恼熏习、受熏持种，是根本就不对的。外人说的眼识不对，只能按我说的阿赖耶识了。

又复此识非识所熏。如说眼识，所余转识亦复如是，如应当知。

这眼识它本身是不稳定的，所熏四义的第一就是坚住性，眼识连第一条就不具备，所以它根本就不是所熏。所熏的是阿赖耶识。眼识这样，耳识、鼻识等等转识也都是这样子。

复次，从无想等上诸地没来生此间，尔时烦恼及随烦恼所染初识，此识生时应无种子。

这儿是说修禅定的人，他禅定修成功了，生到什么天了――随着禅定功夫的不同所生之天也不同――生到什么天之后他现在又退下来了，这一段儿就说这些人的情况。“复次，从无想等上诸地没”，有一类众生。他们“从无想等上”――就是无想天上，无想天就是色界第四禅天。本来他修无想定成就了无想天之报，在无想天那儿，他的第六识不动了。他本来已经成就了，可是现在呢？他“诸地没”，就是从无想天那儿完了，就是死了，然后呢，他又“来生此间”，来到这儿受生，就是到欲界受生。“尔时烦恼及随烦恼所染初识”，他本来在色界天，“无想天等上”就是说不单单无想天，其他天也行，只要不是欲界就行了，不过无想天最特殊，在无想天没有六识活动，其他天可能还有六识活动。这里就以无想天为例。他本来在无想天，现在又到欲界来受生，既然到欲界受生，当然就有欲界众生的烦恼，根本烦恼、随烦恼都有了。“所染初识”是指刚到欲界的初一刹那，被欲界烦恼所染污的最初刹那、那一念识。也就是投胎的时候那一念识。“此识生时应无种子”，这最初一念识和烦恼一起发动，它有种子吗？它是最初一念识呀～～唯识中没有种子是不能发动的，从无想天下来的最初一念识有种子吗？

由所依止及彼熏习并已过去，现无体故。

“由所依止及彼熏习”，他刚从无想天下来，他所依止的根及彼熏习的种子，“并已过去，现无体故”，要是没有阿赖耶识的话，他们以前的一切烦恼所熏习的种子，本来都是摄藏在阿赖耶识里，你不承认阿赖耶识，那么，这些种子就没有地方摄藏，那就没有种子了！没有种子的话，从无想天（实际上应该说色界、无色界）来欲界受生的时候，最初一念识就生不起来。有阿赖耶识摄藏种子的话，只要因缘具备，种子就现行了，这样最初识就出来了。现在“由所依止及彼熏习并已过去”，所依止的根、熏习都没有了――在欲界的时候有，但从开始生到色界、无色界的时候，就没有了，现在你又回到欲界受生，所依止的根、熏习是没有的，最初一念识是生不起来的。

复次，对治烦恼识若已生，一切世间余识已灭，尔时若离阿赖耶识，所余烦恼及随烦恼种子在此对治识中，不应道理。

先说了欲界众生，前七转识为烦恼熏习是不行的，然后又说了色界天、无色界天的众生，要来欲界受生，是来不了的。看起来非阿赖耶不行。这会儿开始说佛教徒，在佛教徒修学圣道的时候，这儿长行中有一个“对治烦恼识”，啥叫“对治烦恼识”？就是说，我们在修学佛法的时候，我们要修止观，或者修其他的什么法门都可以，当我们修行成就的时候，清净无漏智出现，当然，并不是成佛了，在小乘佛法中是证初果，大乘佛法中是登初地，清净无漏智刚出现，它能够对治烦恼种子，这就叫“对治烦恼识”。这对治烦恼识生起来的时候，在这时候一般来说你有禅定，“一切世间余识已灭”，这是说，眼识、耳识、鼻识、舌识、身识，在这时都不现行，有漏的第六意识也不现行，因为“对治烦恼识”它是无漏的。“尔时若离阿赖耶识，所余烦恼及随烦恼种子在此对治识中，不应道理”，在这时候，他的烦恼断了一些儿，但烦恼还是很多的，因为还有这些烦恼，所以，“若离阿赖耶识”，要是不承认阿赖耶识，还有的那些烦恼、随烦恼种子该摄藏在哪儿呢？眼识、耳识、鼻识、舌识、身识都是不可以摄藏种子的，因为这时候它们都没有现行了。“在此对治识中，不应道理”，能不能说它们摄藏在对治识中？也不行！为啥？

此对治识自性解脱故。

因为这对治烦恼识，是无漏的，让它给烦恼在一起？那还不如杀了它。

与余烦恼及随烦恼不俱生灭故。

再说了，熏习一定是彼此一起俱生俱灭的，并且此有生彼之因，但是，这对治烦恼识和余烦恼、随烦恼不是俱生俱灭的。所以，你要是不承认有阿赖耶识，对治烦恼识初生起的时候，就该一下子证到阿罗汉果，就不应该有初果、二果、三果、四果的分别。所以不承认阿赖耶识是不对的。

复于后时世间识生，尔时若离阿赖耶识，彼诸熏习及所依止久已过去，现无体故，应无种子而更得生。

“复于后时”，证得初果以后，或得欢喜地以后。见道只是剎那间的事儿，然后立马就是修道位。修道的时间是非常长的，在这很长的时间内，修行人也不可能永久在定中，他是有出定的时候的，在他一出定的时候，无漏智就隐藏了，世间的分别心又出来了，他也可以见闻觉知，给我们一般人没什么不同。“复于后时世间识生”，就是指出定的时候分别心又生出来，这个“世间识生”就是指各个分别都生出来了。在世间识生出来的时候，“尔时若离阿赖耶识”，这时候要是没有阿赖耶识的话，“彼诸熏习及所依止，久已过去”，熏习的烦恼种子，以及所依止的，这里的“所依止”是指识，心所就是依心王的。烦恼种子、以及心识，它们都在见道的时候已经灭掉了，就因为你不承认阿赖耶识，所以它们才会灭掉的！是过去的事儿了。“现无体故”，它们是过去的事儿，不是现在的事儿，所以，你不承认阿赖耶识，那么，烦恼种子、心识现在都没有体性，既然现在他们没有体性，所以，“应无种子而更得生”，就是说，你已经见道了，无漏智慧出现，这些有漏的识、有漏的烦恼，这一切的种子都没有了，所以你出定的时候，出不来了，因为没有有漏种子。所以从修圣道得见道后的情形来看，也非得有阿赖耶识才行。

是故若离阿赖耶识，烦恼杂染皆不得成。

所以说，要是没有阿赖耶识，烦恼杂染是不能成立的。下边儿说业杂染不成立。

云何为业杂染不成？

前边儿说过，业杂染就是福业、非福业、不动业，其实也就是身、口、意所作的一切。要是没有阿赖耶识的话，业杂染染是不能成立的。为啥？

行为缘识不相应故。此若无者，取为缘有亦不相应。

“行为缘识不相应故”的“行”，就是业，业为缘的识，就是业感生的异熟识。我们知道，在十二缘起中，无明缘行、行缘识，“行”咱们说是业，就是身口意的活动，或者说是福业、罪业、不动业。这活动应该是和阿赖耶识俱生俱灭的。“行为缘识不相应故”，要是不承认阿赖耶识，那么，识是哪个？“行为缘识”的识是指谁？前六识当然是不行的，因为前六识间断，而且它也不能受熏，因为它一下善、一下恶，在善的时候，恶种子熏不进来，在它恶的时候，善种子又熏不进来。所以你只有承认阿赖耶识才行。不然的话，业杂染不能成立，那么你造了业，没有能受熏持种的，就没有因果了。“此若无者，取为缘有亦不相应”，要是没有阿赖耶识，不光行为缘识不能成立，“取为缘有”也不能成立。爱、取、有，爱是烦恼，它要是增长，要是特别地强，那就成取了，这就要造种种的业了，有业就要感果，这就成“有”了。在开始造业的时候，业只是业，它还没有感果，这不叫有。如果不承认阿赖耶识，以前所造的业不能够受熏持种，这就会出现虽然是造了业，但是一剎那间就过去了，过去也就没了，没了就感不了果了，所以一定得承认阿赖耶识。

云何为生杂染不成？

有三杂染：烦恼杂染、业杂染、生杂染，前边儿说过了烦恼杂染、业杂染，说，要是没有阿赖耶识，烦恼杂染、业杂染都不能成立。这生杂染怎么样呢？说，要是没有阿赖耶识，生杂染也是不能成立的。一个生命，从开始有到最后结束，在这一个过程中，你的心都是染污的，没有清净的时候，所以叫“生杂染”。

结相续时不相应故。若有于此非等引地没已生时，依中有位意起染污意识结生相续。此染污意识于中有中灭，于母胎中识羯罗蓝更相和合。

为啥没有阿赖耶识的话生杂染就成立不了呢？在一期生命中间，有生有死，现在先说的是生这儿，说，生必须得有阿赖耶识。在说生必须得有阿赖耶的时候，又分成两种情况，先说非等引地的情况。所谓“等引”，按印度话、梵语，就是三摩呬多，是色无色界定名，也就是说，得这禅定就是等引。“等”就是平等，就是不昏沉、不散乱，由这个定引导你达到这个境界，就叫等引。或者说，你得到了这定，就会引发出来种种的功德，所以叫等引。这等引定就是色界定、无色界定。长行中的“非等引地”，就是我们欲界。这里就是说，我们欲界众生，必须有阿赖耶识，有了阿赖耶识你才能够结生相续。“结相续时不相应故”就是说，要没有阿赖耶，结生相续就不能成立。什么是结生相续？这样说吧，有一个人，他死了，就是长行中说的，“于此非等引地没”，“没”就是死了。说，欲界有一个人死了，死了之后他还在欲界受生。

人这一生有四有：本有、死有、中有、生有。本有就是我们这个生命体存在；死有就是我们这个生命体最后一剎那死亡；死了以后有个中有，就是咱们常说的中阴身时候；然后再投生，在下一次生命初开始的刹那，叫生有。现在长行中说的是“依中有位”。咱们佛教还常说四生：胎、卵、湿、化，这中有就是化生，化生就是无而忽有，而本有可能是胎、卵、湿、化，不一定的，但中有只能是化生。在《唯识二十颂》中间就说过，“如化生有情”。现在这个欲界的人死了要投胎，在还没有投胎的时候，这中间有个中有位，中有时也是八识具备的。“起染污意识”，在中有位，染污的意识现行了，染污的意识一现行，就结生相续了。也就是说，这染污意识一现行，坏事儿了！中阴身就没有了，就开始入胎。“结相续时”的“结”，是结合的意思，也就是和“母胎中识羯罗蓝更相和合”，“羯罗蓝”按现在话应该是受精卵，识与受精卵和合，当然实际上是识执持受精卵，也就是识的种子是亲因缘，而精卵形成的受精卵是增上缘，我们把这种情况叫投胎了。“结相续时”的“相续”就是生命的轮转、轮回。刚才说了，说污染意一起，中阴身――中有――就没有了，就开始入胎，就是说，这染污意是中有的最后一剎那，立马的，中有没有了，这就是长行中的“于中有中灭”。中有没有了，中有是八识具备，中有没有了，则只剩下阿赖耶的种子了，种子就是是阿赖耶识，它来执持羯罗蓝，这就入母胎了，这时候因为转识都没有了，所以你是胡涂的，这个我们一般就称为隔世之迷，或者叫隔阴之迷。欲界众生的生命就这样开始。

若即意识与彼和合，既和合已依止此识于母胎中有意识转。若尔，即应有二意识于母胎中同时而转。

前边儿说在生命体初开始成立时，没有阿赖耶识是不行的，这是说生命体成立时的情况，“若即意识与彼和合”，按唯识说法，是中阴身有八识，在中阴结束的时候，转识就没有了，只有阿赖耶识，但小乘不这样说，他们说中阴身结束的时候，是前五识没有了，意识胡涂了。“若即意识与彼和合”，就是说，如果意识与羯罗蓝和合了，它就又生起了一念明了意识。“既和合已依止此识于母胎中有意识转”，在与羯罗蓝结合前中阴身不胡涂，但结合的时候中阴身没了，意识胡涂了，“于母胎中有意识转”，当到了母胎的时候，又一念明了意识生起，你不胡涂了。“若尔，即应有二意识于母胎中同时而转。”如果是这样的话，因为你不承认阿赖耶识，那这意识就有问题：羯罗蓝初结合的刹那有一念胡涂意识，后来又有一念明了的意识，这就有了两个意识同处于母胎，这绝对是不行的。所以说，是意识而不是阿赖耶识是不行的。

又即与彼和合之识是意识性，不应道理。

你不承认与羯罗蓝结合的是阿赖耶识，而说是意识，这不合理。为啥？

依染污故，时无断故，意识所缘不可得故。

为啥是意识就不合理呢？首先，“依染污故”，就是说，与羯罗蓝和合的那一念识，一定是染污的。因为染污才来与羯罗蓝和合的，“羯罗蓝”这个词意译就是凝滑、杂秽，它要不是染污的就不能与羯罗蓝和合。也就是说，和合识的前一念一定染污。所以，说意识就不对，因为我们第六意识活动，不绝对是染污的，它有时候染污，但有时候不染污，有时候它还无记，这不一定。所以，不能是意识。其次，“时无断故”，就是说，和合识开始以后，只要与羯罗蓝和合了，一直到最后它也不会间断，可六识是不是这样呢？不是的！比如在极度闷绝的时候，它就断了。所以不能是意识。“意识所缘不可得故”，再说了，你说是意识，可是这时意识的所缘境是啥？一般情况下，意识的所缘境，我们是清楚的，就是作梦的时候，梦见了啥我们也知道，当极度睡眠的时候，意识不活动了，那就没有所缘境了。你说现在是意识，它的所缘境就该有，那么，是啥？不可得，不知道它缘的啥，所以，不能是意识。

设和合识即是意识，为此和合意识即是一切种子识？为依止此识所生余意识是一切种子识？

这是无著论师退了一步来说的，“设和合识即是意识”，假如说和羯罗蓝和合的是意识，“为此和合意识即是一切种子识？”那你说的意识是不是就是大乘里说的一切种子识？是不是一回事儿？“为依止此识所生余意识是一切种子识？”这一问是针对前边儿两个意识在母胎中而说的，说是不是依止在结合的时候的结合识而生的识是一切种子识。也就是说，是前一念意识是一切种子识还是后来的意识是一切种子识？注意，“一切种子识”这个名字，在无著论师说这个名字的时候，此时的意思是指这一期生命的生命体从此而生的意思。我的意思就是说，咱们在读书的时候，要把论师也想想成一个正常的人。

若此和合识是一切种子识，即是阿赖耶识，汝以异名立为意识。

假如说与羯罗蓝相合的意识就是大乘里说的一切种子识，那它就是阿赖耶识，你非要叫它意识，也没有关系，只是名字不同而已，内容是一致的。

若能依止识是一切种子识，是则所依因识非一切种子识，能依果识是一切种子识，不应道理。

要是说那个和合识不是一切种子识，“能依止识”是一切种子识，“能依止识”就是后来生起意识。和合识是所依止，依止和合识生出来的意识，就是“能依止识”。这个能依止识是一切种子识，这就有问题了。要是能依止识是一切种子识，“是则所依因”――即和合识――不是一切种子识。和合识是因，果是因生出来的。这里呢，因是和合识，果是后生起的意识。现在，因不是一切种子识，因生起的果却是一切种子识，是不是颠倒了～～

是故成就此和合识非是意识，但是异熟识，是一切种子识。

所以，绝对不能说和合识是意识。你的不对就只有我的对了。

复次，结生相续已，若离异熟识，执受色根亦不可得。

刚才是说的生命体开始时，没有阿赖耶识不能成立，现在说有了生命体以后，得阿赖耶识来执受根身。“执受色根”的“色根”是眼根、耳根、鼻根、舌根、身根五净色根。第六意识的根是无色的。前五根要由阿赖耶识来执持它，它才能够有感觉，才能做识的依止处。只要是活生生的人，必须一直有阿赖耶识执持，所以，要没有阿赖耶识，就没有谁来执受色根了，你就不行了。“结生相续已”就是说这个生命体已经有了，阿赖耶识和羯罗蓝和合了了，这时“若离异熟识”，要是没有阿赖耶识，执受色根的力量就没有，那就成死人了，是一具尸体而已。

其余诸识各别依故，不坚住故，是诸色根不应离识。

小乘不承认阿赖耶识，那么执受身体就就该是别的识，比如说意识。这样行不行？不行！“其余诸识各别依故”，就是说，眼识依眼根，耳识依耳根……意识依意根，也就是说，各识只依自己的根，根本不用其它的根，我眼识根本用不着耳根，凭什么要我去执受耳根？！不干！“不坚住故”，说，眼识、耳识等一下活动，一下不活动，这一下它不活动了，那还咋执受呢？本来正在执受，忽然间他不活动了，不执受了，一不执受，你这身体就该烂了，这还得了～～现在我的六识不活动了，可我还活着，身体也没有烂，所以执受还是有的，这说明了执受的根本就不是六识，也就是说，你小乘的说法不对，你的不对，只能我大乘的对了。“诸色根不应离识”就是色根还在被识执受，这识是阿赖耶识。

若离异熟识，识与名色更互相依，譬如芦束相依而转，此亦不成。

要是没有阿赖耶识，“识与名色更互相依”这道理就说不通了，“识与名色更互相依”是佛说的，是圣教量，“识”是阿赖耶。“名色”的“名”就是五蕴里边的受、想、行、识，都叫做名，受、想、行是心所，受想行识的“识”是心王，就是眼识、耳识、鼻识、舌识、身识、意识，这意识就包括在“名”里面。“名色”的“色”，就是指羯罗蓝、受精卵。“识与名色更互相依”是说，阿赖耶识依名色，名色又以阿赖耶识为依止处，“更互相依”，就是说它们互相为依止处，我是你的依止处，你是我的依止处，这样才能成为一个完整的、活的生命体。如果把识说成意识而不是阿赖耶识，那么“名”里边就不能有意识了，名里就只有受、想、行，还有前五识，第六意识得分出来，如果把这样叫“识与名色更互相依”的话，就不对了，为啥呢？因为这个识与羯罗蓝初和合时，刚投胎前五根是没有的。识与羯罗蓝和合开始组成一个生命体的时候，前五根没有，自然前五识也没有，因为识要依根。那么名里面是啥？没有前五识，就得是意识，不然的话，受、想、行也没有了，名里边儿是意识了，“与名色更互相依”的、外边儿的，就不能是意识了，既然不能是你小乘说的意识，就只能是我大乘说的阿赖耶识了。接下来一句是个例子，“譬如芦束相依而转”，一捆芦苇，相依才能站住，识与名色也得相依，这样才能成立。所以，没有阿赖耶识，生命体就不成就。

若离异熟识，已生有情，识食不成。何以故？以六识中随取一识，于三界中已生有情能作食事不可得故。

这是说识食的。“食”，是资养生命体的，维持有情的生命的。佛教中说有段食、触食、思食、识食四种。我们现在的食就是段食，一段儿时间就得再吃，不吃就饿。触食的“触”，就是接触，对所接触的境界生起欢喜，这种欢喜也有资养生命的能力，叫触食。思食的“思”，是指希望，内心中充满希望，你就可以更好地活下去，要是一绝望的话，就很难活下去了。还有咱们说的哀莫大于心死。识食，就是阿赖耶识，阿赖耶识执持你的生命体，使你的生命体正常活动，阿赖耶识有这个能力。这里只说识食。“若离异熟识”，要是没有阿赖耶识，“已生有情，识食不成”，你就没有识食了。“何以故？”为啥？“以六识中随取一识”，你说没有阿赖耶识，那就取六识中的任一识好了。“于三界中已生有情能作食事不可得故”，三界六道众生，没有任何一识可以来作识食。比如说到色界天，《八识规矩颂》中说，“眼耳身三二地居”，眼识、耳识、身识，我们欲界众生有，初禅天众生有，但是初禅鼻识、舌识是没有的。也就是说，初禅天众生没有鼻识、舌识，但还有眼识、耳识、身识。到二禅以上，前五识都不动了，在无想天连第六意识也没有活动。也就是说，前六识任何一识都不是普遍的，所以，“随取一识”在三界中作识食都是不行的，也就是说，必须得有阿赖耶识来作识食。前六识会间断，一间断，识食成立不了了。

若从此没，于等引地正受生时，由非等引染污意识结生相续。

前边儿说的是非等引地，现在说等引地的情况。“等引地”就是色界、无色界天。“若从此没，于等引地正受生时”，这个人从欲界死后到色界天或无色界天受生了，这主要是他禅定修得好。注意一下，色界天、无色界天都是化生。他们到等引地受生时，是说正受生时，“由非等引染污意识结生相续”，就是说，前念还在非等引地，在非等引地就是散乱心，他们修学色界定、无色界定成功了，临死的时候是在散乱心中死的，他也不是在定中死去的。比如说阿罗汉，他们在入涅槃的时候也是在散乱心中入涅槃的。修禅定者是这样的，他修定得了初禅、二禅，乃至非想非非想定，然后出定，然后又初禅、二禅、三禅、四禅，再出定，再来一次，随心所欲，想啥时候入定就可以啥时候入定，但在入涅槃的时候，必须出定在散乱心状态。他要死了，要是在入定状态下，他是死不了的。当然，他的散乱心与我们凡夫的散乱心不一样。他从禅定中出来，那个不与定相应的意识，也是有染污的，不过他的这染污是对色界定、无色界定的爱着心理，他的这爱着心一动，生到色界天、无色界天了，然后生命在那儿相续，开始新一次生命。当然，生到色界天给生到无色界天还有不一样的地方，要是生到色界天，在欲界死后也有中阴身，然后到色界天去受生，要是到无色界天，则是欲界死没有中阴身直接到无色界受生。但不管有没有中阴身，反正在将到死界、无色界受生时，前一念都是染污意识，绝对不是清净的。

此非等引染污之心，彼地所摄。

这一句话是说，在非等引地死了后到等引地受生，在生到等引地的前一刹那，那一念染污意，不属于非等引地，而属于等引地。

离异熟识，余种子体定不可得。

在非等引地与等引地交接的时候，一定得有阿赖耶识，也就是说，到等引地受生时，前一念的染污意，也是有种子的，有种子就得有阿赖耶识，没有阿赖耶识，就没有种子了。生等引地的时候，前念是散乱心染污意，但生等引地是要定的，定的种子能在前念的散乱心里吗？好象不能吧～～因为种子的熏习，是此法与彼法俱生俱灭，此带有彼的因性，这样才有种子的，生等引地的禅定能与散乱心在一起俱生俱灭吗？当然不行了，根本就是不相容的。再说了，在将死的刹那，我的心是散乱的，此时生等引地的禅定境界并没有出现，怎么能在一起熏习？所以，只能说种子在阿赖耶识里。这都是说的建立阿赖耶的必要性。

复次，生无色界，若离一切种子异熟识，染污善心应无种子，染污善心应无依持。

“复次，生无色界”，这里把生无色界的情况单独说一下。“若离一切种子异熟识，染污善心应无种子”，这里的“善心”是指无色界定的心，不是指一般说的善，不是欲界善。染污意还爱着无色界定的心，爱着心是染污的，叫“染污心”。染污善心“应无种子”，染污心没有种子，善心也没有种子。因为小乘说没有阿赖耶识，只有意识，但前六识是间断的，而且前六识一下善、一下恶，很不稳定，它就没有受熏持种的功能。所以，要是没有阿赖耶识，无色界天的这个染污善心就没有办法安立种子了，没有种子，就不能到无色界受生。“染污善心应无依持”的“依持”，是说阿赖耶识里边的种子、你修成的无色界定的种子，是无色界定的所依止，也就是说，种子成就无色界定。另一个意思是说，生无色界的阿赖耶识――众生都有阿赖耶识，无色界众生也有――生到无色界的众生的阿赖耶识，这阿赖耶识是果，有阿赖耶识的摄持，你才能在无色界生存下去，这个也叫依持。这样呢，种子是亲因缘，阿赖耶识的摄持是增上缘。所以，这一句长行中的“应无种子”是说没有亲因缘，“应无依持”是说没有增上缘。四缘生法你现在就缺两缘，你怎么生？

又即于彼若出世心正现在前，余世间心皆灭尽故，尔时便应灭离彼趣。

这里是从出离三界的无漏境界来说的。接着前文，前边儿说的是要是没有阿赖耶识，无色界众生没有办法生，现在说，无色界众生生到无色界后，无色界众生是没有前五识的，如果你再不承认阿赖耶识的话，那就成只有意识了。“若出世心正现在前”，说，这个无色界众生要生起无漏心，“余世间心皆灭尽故”，无色界众生生起无漏心，你要是不承认阿赖耶识，那就只有意识了，因为无色界众生是没有前五识的，只有意识，因为它有意识，现在要生起无漏心，那就只能是意识生起无漏心了～～这时候有漏的前五识、有漏的意识都不能现前，这就是长行中的“余世间心皆灭尽故”。“尔时便应灭离彼趣”，有漏心都没有了，只剩下无漏的，当然就不会再在生死中流转了。本来，你要是承认阿赖耶识，比如说你现在在无色界天，你生到无色界天，这是因为以前修禅定的力量，这果报是阿赖耶识来执持。要是没有阿赖耶识的话，你出世心现前，那你就不能再是无色界众生了，但实际上你还是无色界众生，并不是你的出世心一现你就入无余涅槃了。

若生非想非非想处，无所有处出世间心现在前时，即应二趣悉皆灭离。

这一句是说非想非非想处天的情况。非想非非想处天是无色界天的最高一层天。能生到非想非非想天，自然定力是非常的高深，但到这儿后有一点儿麻烦，就是非想非非想定不能引发无漏慧，也就是说此时心识的明了性太低。你要想进一步得无漏慧，必须从非想非非想定出来，到无所有处定去。无所有处定比非想非非想处定要低，但是，为了再进步你就必须先退上一步。在无所有处定的境界中，心识的明了性相对来说强一些，因为心识明了性强，所以可以作为圣道的依止。慢点儿，注意：现在这个人在非想非非想处，他要到无所有处去，在非想非非想处的时候，心识的明了性太低，到无所有处明了性就强了，但在从非想非非想处到无所有处的刹那，他该算是在非想非非想处还是无所有处？你要是不承认阿赖耶的话，就出现了这样的问题。我们知道，他是得在这儿灭然后立马到那儿生，但他不可能在这儿灭的同时就在那儿生，虽然是立马就到那儿生，但毕竟不是同时的，总有一个过程，这过程当中它就得有阿赖耶识摄持。就是说，在你从非想非非想处到无所有处出世心现前的过程中，“即应二趣悉皆灭离”，在这儿你空起来了，你既不是非想非非想处众生，也不是无所有处众生。这主要就是第六意识灭了，在非想非非想处灭了，到无所有处再生，中间空了。所以一定得有阿赖耶识。

此出世识不以非想非非想处为所依趣，亦不应以无所有处为所依趣，亦非涅槃为所依趣。

这一句长行是对前边儿“即应二趣悉皆灭离”这一句话进行解释。“此出世识”，指与无漏智相应的识，它“不以非想非非想处为所依趣”，非想非非想处果报是有漏的，当然不能与无漏智相应。或者说，他从非想非非想处到无所有处，既然他从非想非非想处出来了，当然就不能算非想非非想处的人了。“亦不应以无所有处为所依趣”，他从非想非非想处出来，现在还没有生到无所有处，当然也不能算是无所有处的人。“亦非涅槃为所依趣”，这很明白，他现在是死，而不是涅槃，涅槃是无漏的，现在他是有漏的。再说了，涅槃是没有世间生死的境界，你还在生死。

又将没时，造善造恶，或下或上所依渐冷，若不信有阿赖耶识，皆不得成。

现在要说死的时候了。说死的时候也得有阿赖耶识。“又将没时”，就是众生将死的时候，注意是将死时而不是死了，是还没有死，“造善造恶，或下或上所依渐冷”，因为造业的不同，所以身体渐冷的情况不同。有这样的几句话，叫“顶圣眼生天，心窝生人间，饿鬼从腹出，地狱脚底板”（在明鲁庵法师普泰的《八识规矩补注》第二卷）。“所依渐冷”的“依”，就是身体。在你临死的时候，寿暖识分散，这个识就必须是阿赖耶识。小乘不承认阿赖耶识，只承认六识，现在无著论师就是说，要是没有阿赖耶识的话，或上或下渐冷的现象就不能成立。为啥呢？因为六识有间断的时候，在我们一生之中，他间断的情况很多，你无梦睡眠的时候，六识不现行了，可你并没有说就冷了呀，可是你在临死时六识不现行，你咋冷了呢？同样是六识不现行，怎么表现出来的情况不一样呢？看起来寿暖识的识不是六识，既然你小乘的说法不对，就只能是我大乘说的阿赖耶识了。

是故若离一切种子异熟识者，此生杂染亦不得成。

现在总结了：所以说，要是没有阿赖耶识，生杂染确实是成立不了。这样烦恼杂染、业杂染、生杂染都得有阿赖耶识来执持。这就是说，要是没有阿赖耶识，杂染不成。下边儿就要说清净的情况了，说，要是没有阿赖耶识，清净也不得成立。

云何世间清净不成？

清净有世间清净间和出世间清净，这里先说世间清净不能没有阿赖耶识。为啥不能没有阿赖耶识呢？

谓未离欲缠贪未得色缠心者，即以欲缠善心为离欲缠贪故勤修加行。

咱们先得知道世间清净是指啥。“谓未离欲缠贪”，比如欲界众生，欲界众生没有能够弃舍欲界烦恼里边的贪，“缠”就是烦恼，指一切烦恼，一切烦恼都可以叫缠。“贪”是烦恼中的一个。欲界烦恼中贪是最明显的，我们有贪。“未得色缠心”是指我们没有得到色界烦恼的禅定，初禅、二禅……都没有得到。就是说，我们还在欲界，还没有生到色界。“即以欲缠善心为离欲缠贪故勤修加行”，我感到欲界的贪太折磨我了，就想生色界天去，我怎么才能生色界天呢？“即以欲缠善心”，就是以现在内心里面的欲界的善，当然，我们现在的善也难说绝对清净，因为末那识，所以不绝对清净，但毕竟是善。我就凭这善心――想舍弃欲界烦恼生到色界天去这一念，当然这一念得十分的强烈，这是一个愿望。“为离欲缠贪故”，为了弃舍欲界的烦恼――贪心，“勤修加行”，精进修行。这“加行”就是努力修行。这时候是厌欲界，欣色界，就凭这厌和欣来推动自己修行，直到得了初禅，再厌初禅欣二禅，再厌二禅欣三禅……就这样努力修行。得了初禅后，要想进一步得二禅，你必须厌初禅、舍初禅，不然你得不了二禅，三禅、四禅也得这样。

此欲缠加行心，与色缠心不俱生灭故，非彼所熏，为彼种子不应道理。

在这个修行过程当中，一定得有阿赖耶识受熏持种，要没有阿赖耶识受熏持种，这个事儿就不能成就了。“此欲缠加行心”，“欲缠”，是指你还没有成就色界定，心还是在欲界的烦恼境界里。但是你已经努力修行了。在这个时候，“与色缠心不俱生”，你在用功修行的时候，色界定还没出现，所以，你欲界的加行心不能和色界定同时俱生俱灭、受熏持种。要是已经成就了色界定，欲缠心又不现前了，也就是说，它们两个根本不可能共存，不可能同时俱生俱灭，不能俱生俱灭，就不能受熏，不能受熏，也就不能持种。所以欲缠加行心是不能作为色缠心的种子的。

又色缠心过去多生余心间隔，不应为今定心种子，唯无有故。

小乘说，欲缠心不能作色缠心的种子，但我过去多少劫中，我得过色界定的，我心里有色界定的种子，这种子是可以做我现在成就色界定的因。无著论师说这还是不行。为什么呢？“又色缠心过去多生余心间隔”，过去得过色界定，这是有可能的，但那已经是过去的事儿了，这中间已经夹杂了散乱心，六识的散乱心来间隔，以前的定心已经灭掉了，在间隔中间，定心没有，那么过去熏习的心已经剎那剎那灭掉了，“不应为今定心种子”，它不能够作现在得色界定的种子，“唯无有故”，以前的定心已经剎那剎那灭掉了，没有了，没有了的东西还能来做种子吗？在大乘中说作种子是得一直摄持着的，不能是没有了的。

是故成就色缠定心一切种子异熟果识，展转传来为今因缘；加行善心为增上缘。如是一切离欲地中，如应当知。

正确的说法应该是这样的：你过去成就过色界定，是有种子的，而种子是在阿赖耶识里面摄持，不失掉坏、不变质，所以现在可以依那种子继续修行，成就色缠定心。这就是长行中说的，“是故成就色缠定心”，以前的种子是现在色界定生起的因缘，这一定得有“一切种子异熟果识”（也就是阿赖耶识），是它把种子展转传到现在。“为今因缘”就是作为现在得色界定的亲因缘。“加行善心为增上缘”，你现在的努力修行是增上缘，在这增上缘的作用下你的种子发生作用了。“如是一切离欲地中，如应当知”，一切离欲地都是这样的。也就是说，得有阿赖耶识。

如是世间清净，若离一切种子异熟识，理不得成。

这是一句总结。

云何出世清净不成？

刚才说了世间清净，说世间清净得有阿赖耶识，出世间清净是不是也得有阿赖耶识呢？当然得有！为什么？

谓世尊说依他言音及内各别如理作意，由此为因正见得生。

我们要想生起出世正见，需要两个因缘，一个是听闻正法，一个是如理思维，就是长行中说的“依他言音”、“如理作意”，这是佛教中的基本原则，是共许的。“如理作意”的“如”就是随顺的意思，随顺佛法义理。“由此为因正见得生”，有了“依他言音”、“如理作意”，那么正见才能生起来。

此他言音，如理作意，为熏耳识？为熏意识？为两俱熏？

这还是要说没有阿赖耶识不行的。说，要是没有阿赖耶识，那么这“如理作意”、“依他言音”就不能成就了。“如理作意”是从“他言音”里边引发出来的。“为熏耳识？为熏意识？”在“如理作意”的时候，这“如理作意”是熏习耳识呢？还是熏习意识？“为两俱熏？”还是耳识、意识都熏习？

若于彼法如理思惟，尔时耳识且不得起；意识亦为种种散动余识所间。

首先，不能说熏习耳识。为啥？“若于彼法如理思惟”，就是说，当你在听佛陀言音说法时，这时你如理思惟，在你专心思惟的时候，“尔时耳识且不得起”，你要是一门心思在思惟，耳识就不活动了，这怎么能熏耳识呢？耳识没有了、不活动了，它当然不能受熏，它不能受熏，它就不能同如理作意俱生俱灭。这耳识不起就是视而不见、听而不闻。听没听？听了！听见的啥？不知道！再说意识受熏，这也不行。“如理作意”其实就是慧心所，慧心所和第六意识在一起，但这不能说第六意识受熏。因为长行中说的“种种散动”，就是说一下子你会有其他事，就是说你一下子如理作意了，可一下你又要作别的事，你的贪心起来了，贪心等一起来，就把如理作意隔断了，这时不能如理作意了，一不如理作意，第六意识间断，就把受熏的东西都失掉了。这问题也挺大的。

若与如理作意相应生时，此闻所熏意识与彼熏习久灭过去，定无有体，云何复为种子能生后时如理作意相应之心？

这一句话是对上一句的解释，就是解释“意识亦为种种散动余识所间”。说，“若与如理作意相应生时”，就是说，如果第六意识受如理作意熏习。这一下熏习了，可一下子你又去作别的事儿了，作完了别的事儿你又回来接着如理思惟、如理作意。当意识与如理作意相应时，“此闻所熏意识与彼熏习久灭过去”。说，你当初听佛言音如理作意的闻熏习，就是说当时意识受了熏，有熏习的种子，这是“与彼熏习”。这个闻所熏的意识，就是你当时听佛说法的那个同时活动的那个意识，和当时如理作意熏习的力量，“久灭过去”，就是你现在要如理作意的时候，与当初听佛说法中间有一间隔，你那个意识的熏习已经过去了，灭掉了。“定无有体”，已经灭掉现在就没有了。就是说以前闻法的那个意识，和那个熏习，现在都没有了，“云何复为种子能生后时如理作意相应之心？”以前闻法的那个意识，和那个熏习，现在都没有了，咋还能做现在的种子？没有了的东西还能做种子？不行的！

又此如理作意相应是世间心，彼正见相应是出世心，曾未有时俱生俱灭。

再说了，“又此如理作意相应”者，听佛说法如理作意相应的心，是世间心。就是说，我们这时的如理作意，还是有漏的。“彼正见相应”，但是与正见相应的是出世心，那是无漏的。世间心、出世间心，或者说有漏心、无漏心是有差别的。“曾未有时俱生俱灭”，它们无始以来，从没有同时出现而能受熏习的。没有受熏，就没有种子。

是故此心非彼所熏。既不被熏，为彼种子，不应道理。

所以这有漏的第六识“非彼所熏”――不是出世的正见相应的识所熏习的，“既不被熏”，既然没有受过无漏的出世心的熏习，所以，它不能是正见的种子。

是故出世清净，若离一切种子异熟果识，亦不得成。

所以出世清净的正见，要是离了阿赖耶识，也是不行的。

此中闻熏习摄受彼种子不相应故。

没有阿赖耶识，凭前六识是不行的。你听闻佛法而能够如理作意所成就的清净的种子（即闻熏习），“摄受彼种子不相应故”，前六识摄受闻熏习的种子的条件不具备，没有受持的能力。清净的种子就是能引发正见的能力，前六识没有摄持引发正见的能力，因为它间断，所以只能凭阿赖耶识，阿赖耶识是相似相续的，它能够受熏持种。

复次，云何一切种子异熟果识为杂染因，复为出世能对治彼净心种子？

这是解释清净心的种子。先是讨论这样一个问题：阿赖耶杂染，它怎么能摄持清净种子呢？“复次，云何一切种子异熟果识为杂染因”，阿赖耶识是杂染的法的因缘，“复为出世能对治彼净心种子？”杂染的阿赖耶识能够作出世间的清净法、对治杂染法的净心的种子。听闻正法、如理作意，就可以对治一切杂染法。阿赖耶识是染污的，它怎么能为出世间的清净法作种子呢？

又出世心昔未曾习，故彼熏习决定应无，既无熏习从何种生？

这是要讨论的第二个问题：种子是熏习而来的，可我们直到现在还没有修习过正法，既然没有熏习过，有清净的种子吗？“出世心昔未曾习”，我们从来就没有学习过无漏的般若，“故彼熏习决定应无”，所以无漏的熏习是根本就没有的。“既无熏习从何种生？”既然无始以来从没熏习过，无漏的出世间智、无分别正见，从哪儿来呢？我们一直都是在烦恼中间打转儿，熏习的都是烦恼的种子，根本就没有熏习过无漏种子，无漏种子有吗？要是没有，那么圣道该怎么证呢？

是故应答，从最清净法界等流正闻熏习种子所生。

无漏种子从哪儿来？无著论师回答说，“从最清净法界等流正闻熏习种子所生”。第一个问题是不用回答的，是个雕虫问题。因为染根本就不能为净因，你问染污的阿赖耶怎么能为出世间的清净法作种子？根本就不可以！这个问题不成立。只有清净法可以作清净的种子。说，从最清净的法界等流出来的正闻熏习可以成就法界种子，清净的法界种子从那里来？是“从最清净法界等流”的。法界的“法”是指三乘圣法：声闻、缘觉、菩萨，“界”就是因，三乘圣法的因叫“法界”，也就是诸法实相，就是真如，它是最极清净的。佛证悟了诸法实相，远离了一切的垢染：烦恼障、所知障，是“最清净法界”。阿罗汉断除了烦恼障，所知障还没有断尽，不能说是“最清净”，只能说是清净。佛证悟真如之后，为众生宣说。我们听闻的正法就是佛陀的最清净法界里流出来的。我们听见佛的语言文字，实际上不是真如本身，并不是诸法实相本身，但和真如同类，是从真如流出来的。“等”就是相似，是和佛证悟的最清净法界相似，这叫等。佛陀真如显发的就是真如的情况，所以叫等流。“正闻熏习”，是指佛说的对，我们也没有听错，这叫正闻。如果我们听错了，误会了，就不是正闻了。现在就是正确地听闻佛法，就在我们的心里有了熏习，这就有了种子，这就叫“正闻熏习种子”。我们的正见，就是从正闻熏习的种子所引发的，叫“正闻熏习种子所生”。

此闻熏习，为是阿赖耶识自性？为非阿赖耶识自性？

这儿要说正闻熏习种子的所依。说这清净的正闻熏习的种子，所依是哪儿？染污的熏习被阿赖耶摄持，这清净的正闻熏习的种子呢？这一句长行就是说，这最净法界等流的正闻熏习，其体性是阿赖耶识自性呢还是不是阿赖耶识自性？这话就是说，阿赖耶识是有漏的，是有为法，有漏法居住的地方当然不是清净的。这正闻熏习要是和阿赖耶识同一体性的话，它就是有漏的了，它要不是与阿赖耶识同一体性的那才能说它是清净的。现在就是说：它清净还是不清净。

若是阿赖耶识自性，云何是彼对治种子？

如果阿赖耶识是正闻熏习的体性，正闻熏习也成杂染的了，“云何是彼对治种子？”正闻熏习还能对治染污种子吗？那么，我们听闻正法也不能够上进。

若非阿赖耶识自性，此闻熏习种子所依云何可见？

如果正闻熏习的种子不以阿赖耶识为自性，它和阿赖耶识不一样，阿赖耶识杂染，正闻熏习的种子清净，这样，阿赖耶识还让正闻熏习的清净的种子在自己这儿住吗？不是一家人不进一家门呀～～

乃至证得诸佛菩提，此闻熏习随在一种所依转处，寄在异熟识中，与彼和合俱转，犹如水乳；

正闻熏习是清净的，阿赖耶识是杂染的，它们体性不一样，但它们是可以共存共处的。这个得注意，一个杂染一个清净，水火不容的却和平共处～～在现行的时候水火不容，但在种子位不是明显的，所以可以共处。“乃至证得诸佛菩提”，从初发菩提心，开始修菩提行，一直到最后证得无上正等正觉。到证无上菩提时，阿赖耶识就变成无垢识，变成清净法界了。清净法界，当然正闻熏习的清净种子可以住在清净法界里，但在没有成佛的时候，“此闻熏习随在一种所依转处”，“此闻熏习”就是正闻熏习的清净种子，随着这一个众生而转，众生到哪儿，清净种子就到哪儿。“寄在异熟识中”，前七转识（最主要是第六识）熏习如来的正法，有了正闻熏习，正闻熏习的种子就寄居在异熟识中。“与彼和合俱转”，正闻熏习与彼阿赖耶识融合在一起，俱生俱灭，同时存在，“犹如水乳”，就是说，虽然正闻熏习和阿赖耶识不一致，但也可以同在一起。这恰恰成了不是冤家不聚头！

然非阿赖耶识，是彼对治种子性故。

虽然说正闻熏习住在阿赖耶识里，但正闻熏习“是彼对治种子性故”，就是说，正闻熏习尽给阿赖耶识捣蛋，它在里边儿还破坏阿赖耶识里的染污种子，就是要挖阿赖耶识的墙根。

此中依下品熏习成中品熏习。依中品熏习成上品熏习。

正闻熏习的种子也有下中上三品，下中上三品其实在就是闻思修三类。闻所成慧的时候是下品，思所成慧是中品，修所成慧就是上品。熏习不但是重复，而且还增大。我在《唯识三十颂》中说过，当我们作一次好事儿，就是对阿赖耶识里的善进行了一次炒作，象滚雪球一样，使它的善越来越大，你要是作一件坏事儿，也是一次炒作，使它的恶越滚越大。在《菩提道次第广论》中，有一个业果原理，其中有一点儿就是“业增长广大”，业是会增长的（主要是思心所的缘故）。“此中依下品熏习”，一开始的正闻熏习，当然是下品的、低级的。当然，我们现在听这《摄大乘论》就是正闻熏习，但这还不是下品熏习，下品熏习是指圆满地通达了什么是佛法，这才是闻所成慧，才是下品熏习。也就是咱们常说的开悟了，这才是下品。这境界实际上也是很高的。闻、思、修三者实际上是不可分割的，闻中间也有思、有修。由于听闻佛法，你不断地在内心中思惟观察，从这下品的闻所成慧开始，不断地熏习，这是开始的因。以下品熏习为因，“成中品熏习”，这是进步了，到了思所成慧。这时候你可以依据文字去通达佛法，也可以离文字相而通达佛法，这时你就能够降伏自己内心的烦恼了。你以中品熏习的思慧为因，继续努力修行，就成就了上品熏习。这时一定要修定，在禅定里再去观察诸法实相，这是上品熏习，就是修所成慧了。

依闻思修多分修作得相应故。

由闻慧而思慧，再到修慧，这样展转地努力、长期地精进。“多分修作”的“多分”就是好多次，你不能只干一次，你得好多次修。“多分修作得相应故”，就是说，多次重复修行，一直努力，这样才能够成就，不是一次就行了。

又此正闻熏习种子下中上品，应知亦是法身种子。

这正闻熏习所成就的种子，就是刚才说的下中上品，展转进步，刚才已经说了，它和阿赖耶识的体性不一样，它住在阿赖耶里边儿，但它是在挖阿赖耶的墙根儿，它到底是什么？“应知亦是法身种子”，它是法身的种子。就是说，我们现在听闻如来的最净法界等流正法，能够熏习，现在还没到无漏的境界，但他是法身种子。

与阿赖耶识相违。

正闻熏习所成就的种子，是法身种子，和阿赖耶识不一样，阿赖耶识里的杂染种子，是你在生死里流转的因，现在这下中上品正闻熏习种子，是你将来成道的因。

非阿赖耶识所摄。

正闻熏习的种子虽然住在阿赖耶识里，但它不属阿赖耶识所摄，阿赖耶识是杂染的，它叫你流转生死，正闻熏习叫你从生死里解脱出来，它是清净。

是出世间最净法界等流性故。

我们现在还有分别心、有执著，但正闻熏习所成就的种子是出世间最净法界等流性，这“是出世间最净法界等流性故”就是说，佛说的一切佛法，是最清净法界等流。我们的正闻熏习，是佛的最清净法界等流的正法的等流。这就说明了，我们千万不要自创一套，一定要尊重如来的出世间最清净法界等流，说法一定要有根据。我们现在的熏习，是无自性的熏习、是虚妄的熏习，而听闻正法的正闻熏习，是最清净法界等流，所以正闻熏习的种子可以对治虚妄熏习的种子。你们知道吧，中国有个摄论派，他们建立第九识阿摩罗识……没听说过？那就不说了。

虽是世间而是出世心种子性。

我们还在世间，但我们的正闻熏习，它是“出世心种子性”，它是无漏的无分别智种子，它就有使我们成就佛道的功能。

又出世心虽未生时，已能对治诸烦恼缠，已能对治诸险恶趣，已作一切所有恶业朽坏对治，又能随顺逢事一切诸佛菩萨。

虽然我们还是凡夫，但我们只要正闻熏习，正闻熏习所得的就是成佛的种子，就是法界种子。我们现在还没有无分别智，当然了，我们要是有了那就是成圣了，我们现在没有。虽然我们还是凡夫，但我们正闻熏习了，这就“已能对治诸烦恼缠”，就是说我们现在凭正闻熏习就可以对治一些烦恼缠。这“能对治诸烦恼缠”，本质就是指听闻佛法后，我们就可以凭佛法调伏自己，不造恶业。注意这个，在世亲的释里边儿，是说能够断增上贪等，在127页。就是说你已经种下了贪的种子，既然已经种下了，对不起，你必须得为自己的所为付出代价，你必须得受报，但现在正闻熏习的种子是可以使你已经种下的那贪种子别往大处扩(不给增上缘)。“已能对治诸险恶趣”，“诸险恶趣”就是三恶道。怎么个对治法？在《菩提道次第广论》中业感果的原则中有一个“哪个业现前哪个业受报”，在临终的时候，你可以凭正闻熏习的力量使得当下三恶道的业种子不现前，你一直正闻熏习、一直修学不懈，三恶道的种子就没有机会现行。妙老说是正闻熏习，不作十恶业，当然就不到诸险恶趣了。

“已作一切所有恶业朽坏对治”，这一个实际上还是说，让恶业种子没有增上缘，一法要生起得有四缘，现在你有亲因缘但没有增上缘，没有增上缘就永远不能现行，结果就使得恶种子就象瘪死了一样，不发生作用。这儿呢，在世亲释中有这样一句话，翻到127页，看最后一行，“此闻熏习，能治一切过去、未来、现在恶业。”这一句话有点儿难理解，尤其是过去的恶业，说这正闻熏习可以对治过去的恶业，这对治就是使它没有增上缘，现在、未来你不造恶业，就是对治了恶业。韩老在讲到这儿的时候，就有人提出过去已经造下了恶业，业感果原则中就有一个“已作不失”，你还能把它消灭掉吗？其实就是没有增上缘。这给净土宗的往生极乐世界不退转的道理是一样的。净空法师在讲往生极乐世界的时候说一往生就不退转就是八地菩萨，他就是讲错了。“又能随顺逢事一切诸佛菩萨”，这是说，你正闻熏习将来所逢的尽的善友，佛菩萨就是善友。

虽是世间，应知初修业菩萨所得亦法身摄。

“虽是世间”，就是说，我们现在虽然还是在世间，但我们正闻熏习、如理作意了，我们已经是初修业菩萨，我们正闻熏习、如理作意所得的种子，就是法身种子，我们的所为――闻、思、修三慧，都是可以成就法身的，这样，虽然还在世间，但已经属法身所摄了。也就是说，是以法身为自性而不是以阿赖耶识为自性。

声闻、独觉所得，唯解脱身摄。

我们初修业菩萨是发了无上菩提之心，所以我们是成佛，但是声闻、独觉，他们的正闻熏习，只能是“唯解脱身摄”，这是因为他不发无上菩提心，他只是出离心。这儿我们注意一下，有的众生可不是不发菩提心，而是根本就发不起来菩萨心。他也会一下子说，我要发菩提心，然后精进努力，可不久他就懈怠下来了，过一段时间他又说，我得发菩提心，再精进努力一下，而后又停了……这样一直在这儿反复，就是上进不了。有不少人，学佛好多年了，始终在初入门的水平徘徊，他听一次讲经又听一次，可他听的始终是入门的，他根本进不去，听这个他很高兴，正儿八经的典籍他学不了。咱们都读过《地藏菩萨本愿经》，里边儿就说，地藏菩萨把你救上来，可一会儿你就又掉下去了，叫“脱入暂出又复遭网”、“旋出旋入”，这就是因为你根本发不起菩提心。也正因为你发不起菩提心，所以才劳得佛菩萨一次次地救你。得知道什么是菩提心，我们不要把什么尕七犸鲷的都叫成菩提心。

又此熏习非阿赖耶识，是法身解脱身摄。

这是前边儿就说过的，现在又说了一下，强调一下。不要搞错了：正闻熏习，不属阿赖耶识所摄，而是法身所摄、解脱身所摄。菩萨是法身所摄，阿罗汉、辟支佛是解脱身所摄。

如如熏习，下中上品次第渐增，如是如是异熟果识次第渐减，即转所依。

正闻熏习是会前进的，由下而中，由中而上。“如如熏习”就是如是如是展转熏习，你只有展转熏习了，才能渐次向上。“如是如是异熟果识次第渐减”，正闻熏习所得的法身种子，他要挖阿赖耶识的墙根儿，他增长，自然阿赖耶识里的染污种子就渐渐地减少。“即转所依”，这样就把阿赖耶识渐渐转变了。

既一切种所依转已，即异熟果识及一切种子无种子而转，一切种永断。

“既一切种所依转已”，既然你不断地努力正闻熏习、如理作意，阿赖耶识就渐渐转变，“即异熟果识及一切种子无种子而转，一切种永断”，异熟是阿赖耶的果相，一切种是阿赖耶的因相，合起来就是阿赖耶识。说，阿赖耶识被正闻熏习对治了，“无种子而转”，阿赖耶识的杂染种子逐渐没有了，这样就是转识成智了，这样你就得涅槃了。此时智德、断德皆究竟圆满。

复次，云何犹如水乳？非阿赖耶识与阿赖耶识同处俱转，而阿赖耶识一切种尽，非阿赖耶识一切种增？

前边儿说在不断的正闻熏习、如理作意的时候，可以把阿赖耶识里的杂染种子清除，可是前边儿还有一个说法，15页第一行，“犹如水乳”，现在就说这个比喻，既然清净种子要把染污种子给清除掉，这恰恰是水火不容啊。“复次，云何犹如水乳？”为什么说犹如水乳？“非阿赖耶识与阿赖耶识同处俱转”，说，我们凡夫，听闻了法界等流的正法，这正闻熏习就是非阿赖耶识的净种，“与阿赖耶识同处俱转”，净种和阿赖耶识在一起活动，“同处俱转”，这时确实是水乳交融。“而阿赖耶识一切种尽，非阿赖耶识一切种增？”你不断地修习，修四念住、修六波罗蜜等，这样，阿赖耶识的杂染种子渐渐地没有了。“非阿赖耶识”的净种增加。这一句长行咱们这样说？听着我的语气：为什么要用水乳这样的比喻呢？非阿赖耶识的净种与阿赖耶识同处处俱转，但是阿赖耶识的杂染种子渐尽非阿赖耶识的渐种渐增啊～～

譬如于水鹅所饮乳。

比如水与乳交融，但是鹅去喝的时候，它只喝乳而不饮水，它能把乳喝尽把水留下，它就有这个本事。妙老说在《说一切有部律》中的解释是，因为鹅嘴里面有酸，这酸一触到水，乳就凝结了，乳一凝结就和水分离了，所以它只饮乳而不饮水。我不记得这解释法，以后查一查。这只是一个比喻，说现在修四念住，就可以一切杂染种，使无所得的净种增长。

又如世间得离欲时，非等引地熏习渐减，其等引地熏习渐增而得转依。

这还是比喻。世间人，本来没有发出离心，他“得离欲时”，就是修了禅定，要离开欲界了。这时，“非等引地熏习渐减”，“非等引”就是不是定，是欲。他要离开欲界了，欲的熏习就渐渐减少。要得禅定自然是一定要离欲的，内心里欲种子还有，但你用禅定，使欲心减少，“其等引地熏习渐增”，欲的熏习在减少，禅定的力量在增长，到最后禅定成功了，欲就没有了。这样“而得转依”，你的生命体就发生了彻底的转变――没有欲，而有定。现在就是说，杂染种子被出世间无分别智对治，杂染种子渐渐减少，清净的功德逐渐地增长了，和这修禅定的境界相类似。

又入灭定识不离身，圣所说故。

“又入灭定识不离身，圣所说故”，入了灭尽定，也得有阿赖耶识执持，这是佛的圣教量。妙老说六地以上的菩萨可以入灭尽定，小乘是三果，但这说法我持保留态度。

此中异熟识应成不离身，非为治此灭定生故。

“此中异熟识应成不离身”，阿赖耶识也还在执持。为什么这识要说是阿赖耶识？“非为治此灭定生故”，因为圣人修灭尽定目的就是想叫转识停下来，也就是要对治转识的活动，他不是为了对治阿赖耶识而修此定的，所以阿赖耶识没有被对治，它还存在。

又非出定此识复生，由异熟识既间断已，离结相续无重生故。

小乘有部论师说：在灭尽定中，不起识的活动，但出定后，识又起来了。这识是意识！要什么阿赖耶识，意识就可以。无著论师说，“又非出定此识复生”，就是说，刚才我说的识不离身不是指出定后识又生出来了，“由异熟识既间断已，离结相续无重生故”。第六意识可以没有了重生，但阿赖耶识不可以，“异熟识既间断已”，阿赖耶识要是断了，就“离结相续无重生故”，就是说它要是不执持身体了，则这个身体就不是身体了，而是尸体了，过几天它就坏了。所以，一定要有阿赖耶识，只第六意识是不行的。

又若有执以意识故灭定有心，此心不成：定不应成故。

再看经部的说法。经部也是说有六识就可以了，经部论师的说法与有部还不一样，经部论师说，入了灭尽定也是有意识的，并不是意识断了。不过长行中不是用的意识这个词，用的是“有心”，“又若有执以意识故灭定有心”，无著论师说，“此心不成”，这就是先说不离身那个识是第六意识不对，为啥不对？“定不应成故”，这是第一个理由。要是有意识的话，这灭尽定也就不是灭尽定了。因为经上说，色界四禅的无想定、超过非想非非想天以上的灭尽定，都叫做无心定，既然是无心定，你经部说还有意识，这不是与经典反了吗？经部进行了补救，说，因为没有前五识，所以叫无心定。无著论师说，要是有前五识，那根本就不是定，一切定都没有前五识。前五识没有了，但意识还有，这是定，但不是无心定。现在既然说无心定，就得没有前六识。所以经部的说法不对。下边儿是第二个理由。

所缘行相不可得故。

要是不是阿赖耶识而是第六意识的话，这就有问题了。意识所缘的，都是我们能够觉知到的事情，入定不入定我们应该都能觉知，这是意识，但实际上入了定的话，那时的心理我们现在根本就是琢磨不到的，所以不能说是第六意识。“所缘行相”的“行相”，就是识所表现出来的相貌，其中的这个“行”，心识是活泼泼的，它就是跳呀跳，古德给识下的定义就是“了别”，通俗点儿说就是分别，当然，了别给分别并不绝然相同。分别就有自性分别、随念分别、计度分别，其中的自性分别就是说，心识本就跳呀跳，它要不跳它就不是心识，跳就是活动，活动就是行，所以“行相”就是心识活动的相状，也就是心识的相分。如果说是第六意识，那么“所缘行相不可得”，就是说，在灭尽定里边儿，根本就表现不出第六意识的活动行相，也就是说没有第六意识的所缘境，所以说是第六意识是不合理的。

应有善根相应过故。不善无记不应理故。

认为识不离身的识是意识还有第三个过失。说，你说，在灭尽定里还有的识是第六意识，那么，第六意识所缘境有善、恶、无记三类，请问在灭尽定里的意识，它缘的是善境、恶境还是无记境？是恶吗？不象，因为灭尽定里不作坏事。它只能是善，因为佛说过灭尽定是圣者境界，所以只能是善，而且是无漏善。第六意识缘的善，“应有善根相应过”，就是说，第六意识本身，从自性上来说，不能说是善恶，它如果是善，就一定有善心所相应，它不可能是光杆儿司令。既然有善心所相应，问题大了，无贪、无嗔、轻安、不放逸、不害等都相应，这不成散乱心了吗？这还是灭尽定吗？“不善无记不应理故”，说是善的出问题了，说灭尽定不善行吗？说它无记行吗？当然也不行，它是圣者境界，怎么可能是不善？所以说，说灭尽定时的识是第六意识根本不对。

应有想受现行过故。

再看是灭尽定中识是意识的第四个过失。意识与善相应，善可不是普遍的，当我现在心念是烦恼的时候，就没有善来相应了，但是受、想是普遍的，意识活动，受、想就一定相应活动，灭尽定是善，则善心所必相应，善心所不是普遍的，意识里就有了不普遍的善和普遍的受、想等心所。我们知道，所谓灭尽定就是在受、想上下手，把受、想都灭掉了，可你现在却说还有受、想，这不是给经教违背了吗？

触可得故。于三摩地有功能故。

有想、有受了，那么触心所也得有，为啥？因为意识要是活动了，要活动就得有根、境、识的和合，根、境、识三和合就有触。有了触，就该“于三摩地有功能故”，说，你在入三摩地时――三摩地就是禅定、等持――你只要有触，必然有轻安，为什么，因为你入三摩地了，有轻安也可以证明你有触。这个“于三摩地有功能故”就是指触对于三摩地有作用，他的作用就是表现出轻安。我们不入定，则有触了，立时就有苦受、乐受、舍受等，而入定了，则只能是轻安这个感受。这样的话，第五个过失就又出来了。

应有唯灭想过失故。

这就是第五个过失。有触、有轻安，轻安是什么？就是在入定的时候，内心感到适然，实际上就是一种受，坏了，有受的话，还是灭尽定吗？灭尽定是在受、想二位下手，现在你还有受，你就只是把想给灭了，这就是无想定。无想定是外道定，灭尽定是圣者所修。宣化上人说灭尽定也是外道所修，我以前说只要知道他这么说过就行了，现在我要明确地告诉，他的说法是不对的。

应有其思信等善根现行过故。

“应有其思”，有了受、想，有了触心所，你就一定思心所。有“思”就要造业了。现在你入了灭尽定，你当然就只能造善业了，圣者所修，要是再造恶，那还不翻天了～～所以只造善业，既然造善业了，“信等善根现行过故”，信、惭、愧、无贪、无嗔、无痴、勤、轻安、不放逸、行舍、不害等十一个善心所是不是都要活动？当然了～～这样灭尽定就不是灭尽定了。“善根”咱们一般是指无贪、无嗔、无痴，一般把这三个叫三善根。

拔彼能依令离所依不应理故。

无著论师这样说人家小乘，小乘当然不同意了，说：在灭尽定中，只有第六意识，根本就没有那么些心所活动。所以，你说的问题是不存在的。无著论师就回答了，“拔彼能依令离所依不应理故”，这个“能依”就是指心所，刚才说的信、惭、愧、无贪、无嗔、无痴等，“所依”就是指第六意识。无著论师的意思就是说：你说入灭尽定者，把能依的心所给拔掉了，只留下了所依的第六意识，这是不合理的，因为受、想等心所，它和意识都有的，要有都有，要没都没，关系铁得很，想把它们分开，是没门儿的。遍行心所是永远都有的。

有譬喻故。

这是拿了个比喻。比如说我们说话，这叫语行，语行必须得寻、伺心所来相应，这样你才能说话，在《瑜伽师地论》中就有有寻有伺地，“地”就是大地，我们离开了大地就没法生活，西方神话中的安泰离不开大地，我们就是。地是我们的安身立命之本，“地”就是个比喻的说法。三行就包括身行、语行、意行，语行是离不开寻、伺，意行呢，它离不开想、思，想来构划，思来造作。这是根本就拆不开的。寻、伺没有，你就不能说话。受、想要没有的话，意识也就没有了。这就是拿说话的时候的情况来比喻意识与受、想等心所的关系。无著论师在这儿实际上并不曾具体讲是什么比喻，倒是释中举了具体的比喻，比如说我说的拿语行来比，这在世亲释中有，131页，“有譬喻故，谓世尊识诸身行灭、诸语行灭、诸意行灭。此中身行，谓出入息，其语行，谓寻与伺，其意行，谓思想等，如寻伺灭，语必不起，意亦如是……”等等。而无性释中拿的是无想定来比的。在36２页，“有譬喻故者，谓有无想定，是此中譬喻，如彼拔除不应理故，此应俱灭，或有大种所造譬喻……”这比喻实际上我们能举出很多，只要是二者不能分开的就是。

如非遍行此不有故。

小乘经部还不服，说，比如说身行，身行就是出入息，说，出入息没有了，但是身体并不是说也没有了呀～～象四禅以上者，没有出入息，但还有身体。所以我说的没有受、想，意也还可以存在，我这也是一个比喻。象这样的讨论咱们就知道，比喻这种论证方法确实说服力不够，所以在新因明中陈那论师就加强喻体，使它成为一个普遍性命题。现在咱们看无著论师的回答。“如非遍行此不有故”，“遍行”就是遍行心所，普遍于一切活动。就是说，这出入息给遍行可不一样，出入息不是遍行，可以没有。支持身体的还可以有其他原因，不是说出入息没有就一定没有身体，世亲释中说，“如世尊说离身行外有身住因，所谓饮食、命根、识等，由此虽无入息出息，而身安住。”出入息不是遍行，但受、想是遍行，受、想一直与意识相应，要是没有受、想，就没有意识了。所以，你小乘拿身行作比喻是不行的。

又此定中由意识故执有心者，此心是善不善无记皆不得成，故不应理。

“又此定中”，还是说灭尽定，“由意识故执有心者”，经部非说在灭尽定中有的是意识而不是阿赖耶识。“此心是善不善无记皆不得成”，第六意识一定有所缘境，所缘境就有善、恶、无记的区别，但是或善、或恶、或无记，在灭尽定里都说不过去。如果是善，前边儿已经说了，那就散乱了，不成其为灭尽定了，要是恶的，更离谱儿，灭尽定是圣者定，圣者还恶？无记也不是，圣人怎么能是无记呢？当把灭尽定时还有的识当成阿赖耶识的时候，就不存在这些问题了。

若复有执色心无间生是诸法种子。此不得成，如前已说。

“若复有执”，无性释中说指的是经部论师，经部论师有这样的说法，“色心无间生是诸法种子”，“色心无间生”就是说，比如色，前一剎那的色可以生后一剎那的色，而且前一剎那后一剎那之间还是没有间隔的，后一剎那色的种子就在前一剎那里边，前一剎的色有生后一剎那色的功能。心法也是这样，前一剎那的心可以生起后一剎那的心，之间没有间隔，后一刹那的心的种子就在前一刹那的心里边儿，前一刹那的心有生后一刹那心的功能。这样的说法当然是不对的了。佛教讲刹那生灭，灭不待因。世间只有一隐一现，前刹那后刹那完全是现行，道理主要是前边儿讲的熏习之类。

又从无色、无想天没，灭定等出，不应道理。又阿罗汉后心不成。

“又从无色、无想天没”，经部说前剎那色能生后剎那色，前刹那心能生后刹那心，现在无著论师就举例子了，说，一个无色界天的人，现在他死掉了，他到色界天受生，或者说他到欲界来受生。色界天、欲界天，这都有色，这色种子是从哪儿来的？他在无色界天的时候，他是无有色的，前刹那没有色，后刹那有色呀～～看起来并不是前刹那色生的后刹那色呀～～长行中的“无色”是破的前刹那色生后刹那色，“无想天没”则是破的前刹那心生后刹那心。一个人他本生在无想天，现在他死了，生到了欲界来，前刹那没有想，后刹那就有想了（“想”是心所法），看起来说前刹那心生后刹那心是不对的。看，如果是承认阿赖耶识还有这些问题吗？至于这个“灭定等出”，还是破的前刹那心生后刹那心，入灭尽定的时候，在灭尽定里，没有受、想，到出定的时候，受、想又有了，前刹那没有受想，怎么生后刹那的受想？所以说“不应道理”。要是承认阿赖耶识，就不会有这些乱七八糟。“又阿罗汉后心不成”，这一个是反过来说的。前边儿是说前刹那没有后刹那有，这一句说的是前刹那有后刹那没有。说，你经部说前刹那心生后刹那心，在阿罗汉要入无余涅槃的时候，前刹那是有心的，前刹那的心要生后刹那的心，这样一直生下去，你阿罗汉就永远入不了无余涅槃了。这也是一个困难。

唯可容有等无间缘。

这是无著论师的说法，说心的前后刹那，其实只是等无间缘，并不是前刹那心生后刹那心，要是前刹那生后刹那心的话，那就成亲因缘了。无性释里边儿说，“是故色心前后相生，但应容有等无间缘及增上缘，无有因缘。”心法的前后刹那是等无间缘的关系，而色法的前后刹那则是增上缘的关系，因为心法四缘生，而色法只有两缘生――亲因缘、增上缘，没有等无间缘、所缘缘。

如是若离一切种子异熟果识，杂染清净皆不得成，是故成就如前所说相阿赖耶识，决定是有。

这是对前边儿那么多说法的一个总结：一定得有阿赖耶识！有了阿赖耶识，杂染法也好，清净法也好，都能成立了。这个“异熟识”，他的梵文是这样写的，vipāka，这个vi就是异、区别，后边儿的pāka就是熟，在旧译中是把这个词译为果报，这样我们一见果报就很清楚，但新译中认为译为果报不准确，vipāka实际上准确来说应该是：A事物加上业力而成为B事物，这才是vipāka这个词的准确意思，所以译为异熟准确倒是准确了，可能不懂梵文一下子看见异熟会有些发楞，以后我们看见异熟要知道是A事物加上业力而成为B事物的意思。

此中三颂：

这儿呢，有三个颂子。一个一个来说。

菩萨于净心 远离于五识

无余心转依 云何汝当作

这就是进一步来解释非得有阿赖耶不行。这下边儿的三个颂子都是从转依方面来说的。什么叫转依？就是修学圣道，弃舍一切杂染的惑业苦，培养圣道的清净功德，把阿赖耶识转变。究竟转依要到成佛的时候，那时候阿赖耶识究竟清净，就成了大圆镜智。先看第一个颂子的“菩萨于净心，远离于五识”这两句。“净心”就是指无漏圣道现前，内心清净，也就是根本无分别智现前。说，发了无上菩提心的菩萨，不断地修学圣道，根本无分别智现前了。我们知道，修学圣道散乱心是不行的，一定得有禅定，当他在禅定的时候，根本智现前，这时候他没有五识活动，注意，这时候第六意识也是与圣道相应的。“无余”是指没有其它的染污意识、没有有漏意识，有的是清净无漏的、与第一义谛相应的般若境界。也就是说，只有无漏善，没有有漏善、恶、无记。

这时候你就必须得承认有阿赖耶识。要是不承认阿赖耶识，那么“心转依云何汝当作？”就是说，要是没有阿赖耶识，只有第六意识的清净心――转八识成四智是转第六识成什么智？妙观察智！要记住，转第八识成大圆镜智，转第七识成平等性智，转第六识成妙观察智，转前五识成成所作智。就是说，菩萨在初得圣道的时候，要是承认阿赖耶识，虽然第六识与无漏的般若相应的时候还有很多杂染种子在阿赖耶识里，你只要继续修学，就可以舍染得净，乃至究竟成佛。要是不承认阿赖耶识，既然没有阿赖耶识，那这些杂染种子也都没有了，那还咋转依呢？转依就是转染依成净依，“转”是转染成净，“依”是依持。染依就是阿赖耶识种子，净依则是法界种子。“云何”就是怎么办？“汝当作”就是你把转依怎么安排？

若对治转依 非断故不成

果因无差别 于永断成过

这是第二个颂子。对治与转依不一样，我们不能把对治当成转依。要是把对治当成转依，那就“非断故不成”，对治只是转依的开始，你现在修行到了证初果，小乘是证初果，大乘是登初地，这才算是入圣道了，“非断”是指它没有将杂染全部断掉，它只断了一丁点儿。对治是让染现行起不来，转依是染种子也消灭，这不一样。“故不成”就是指对治不是转依，因为杂染的种子还在。你要是非说对治就是转依的话，“果因无差别”，因果就乱套了，因果不分了，因不是因果不是果。就是说，你初得圣道，这是因还是果？这当然不能是果了，它只能是因，因为你大乘本是发心成佛的，成佛才是你要的果！你说我已经修行对治了，这初入圣道就是对治的果呀～～按转依的话，你这根本对种子没起作用呀，当然不是一点儿作用没有，只不过是微乎其微，可以忽略不计。再说了，你的修行到底是要成佛还是要登初地？当然是要成佛了。果是目的，没达到目的就都是因，达到目的才算是果。混淆果与因当然是不成的。“于永断成过”，“永断”就是把烦恼障、所知障通通断掉。这一句的意思就是说，你在初入圣道的时候你就说你是果了，而你是要成佛的，则入圣道就成为成佛了，既然成佛了，那就是一切障都断尽了，既然已经断尽了一切障了，所以你就不用再断了，因为不用再断了，所以你就永远断不尽二障了。还有第三个颂子。

无种或无体 若许为转依

无彼二无故 转依不应理

“无种”，没有种子，没有杂染的种子。“或无体”，没有识体。无种和无体实际上是不一样的，无种是转依，就是阿赖耶识里的杂染种子都没有了；而无体呢？则是说没有识体，没有阿赖耶识的识体，这就成了没有阿赖耶识（转识成智了）。要是不承认阿赖耶识，转依根本就没有办法确立。阿赖耶识里没有杂染种子，就成清净了，就是转识成智了，阿赖耶识转成的智是大圆镜智。“无种或无体，若许为转依”就是说，要是没有阿赖耶识，无种、无体是怎么回事儿呢？要是把这叫成转依的话，“无彼二无故”。要是没有阿赖耶识的话，那么，当我们清净心现前的时候，这清净心就是因为正闻熏习、如理作意而有的，当我们清净心现前的时候，因为没有阿赖耶，这清净心来对治谁？有阿赖耶识的话，清净心是对治杂染种子的，现在没有杂染种子、没有阿赖耶识识体，有劲没处使。

“无彼二无故”就是说，既然没有杂染种子、没有阿赖耶识的识体来被清净心对治，那么要清净心干吗？“转依不应理”，清净心就是对治杂染种子的，现在没有杂染种子可以对治，外人就说了，这不正好是清净么～～把这叫转依就行了。无著论师说这叫转依是不对的，所谓转依，就是转染依成净依，现在根本没有染依可转呀～～平白无故地送我一个好处，我不敢要，无功不受禄呀～～要是有阿赖耶识，那就不一样了。有阿赖耶识，当你初登圣地，这时候你还有阿赖耶识，阿赖耶识里边儿有很多杂染种子，你继续修呀修，就可以把杂染种子消灭掉，这叫“无种”，没有了杂染的种子，杂染的阿赖耶识也没有了，这叫“二无”。不承认阿赖耶识，这俩无都没有。这就没有办法成立转依了。只有承认阿赖耶识，修学圣道，把杂染识转为清净识（即大圆镜智），把杂染种子消灭掉，成为“无种”、“无体”，这样渐渐就可以转依了。不承认阿赖耶识，转依确实不能成就，所以不承认阿赖耶识是不合道理的。

复次，此阿赖耶识差别云何？略说应知或三种，或四种。

前边儿一直讲的是阿赖耶识总相方面的情况，从这儿开始，就是讲阿赖耶识的差别相，实际上就是阿赖耶识的熏习的情况、种子的作用的不同情况等。阿赖耶识的差别相是怎么回事儿呢？“略说应知或三种，或四种”，说，从种子的熏习情况来说，可以分三种情况，或者分成四种情况。

此中三种者，谓三种熏习差别故。

先说分成三种的，也就是说，熏习有三种情况的不同。三种熏习情况的不同，导致了阿赖耶识的三种差别。

一、名言熏习差别，二、我见熏习差别，三、有支熏习差别。

先列出名字，到所知相那儿再说。这儿只简单说一下，“名言熏习差别”，“名言”就是语言文字、概念了，名言有表义名言、显境名言二种，表义名言是诠义的音声，也就是诠解诸法的名、句、文之类，显境名言是指心、心所，也就是心里的种种分别。我们说一个事物，想把它描述清楚，就得有语言文字以及心里的思维等。“名言熏习”，就是你说话时，心得动、得想，你就是不说话，心里还是要动、要想的，也就是说，你只要心动，那就熏习阿赖耶识了。一熏习，阿赖耶识里就有了各种各样的种子，这些种子作为诸法生起的亲因缘，然后在缘具的情况下就生起诸法。各种各样的种子不同，所以叫“名言熏习差别”。“我见熏习差别”，这其实就是我们的分别心去执著诸法，诸法是什么？从本质上说就是名言。这里的分别心主要是指第七末那识，第七末那识执著第八阿赖耶识的见分为我，这执著是与生俱来的，因为这我执，所以有了种种的分别，也就是说，其他的分别都是这我执衍化出来的。我执有俱生我执、分别我执，但总起来都是我执，它是虚妄的。我执的熏习，造成种子，这叫“我见熏习差别”。“有支熏习差别”，“有”就是三有、三界：欲界、色界、无色界，“支”就是因，“有支”就是三有的因。因为有三有的因，所以你就生在三界之中。生在三界的因是啥？就是业力，或善业、或恶业等，这都是有漏的业。因为这个才使得我们感得三界之苦乐果报。这三种熏习从本质上来说，都是名言熏习。到所知相的时候再详细说。

四种者，一、引发差别、二、异熟差别，三、缘相差别，四、相貌差别。

先列出四种的名字，下边儿再解释。

此中引发差别者，谓新起熏习。

第一个是引发差别，啥是引发差别呢？这里说，引发差别就是“新起熏习”，既然是“新起”的，就说明了它不是以前有的。阿赖耶识里有名言种子，然后新起熏习（就是造业来熏习、炒作），而后感得果报。名言种子是亲因缘，这新起熏习是增上缘。

此若无者，行为缘识，取为缘有，应不得成。

新起熏习这个增上缘，也是很重要的。“此若无者”，要是这能引发的新起熏习没有的话，则十二缘起中的“行为缘识，取为缘有”，十二缘起是无明缘行，行缘识……爱缘取，取缘有，一直到生、老死。“行为缘识”的“行”是身、口、意三业的活动，它们一活动，就在阿赖耶识里熏成种子，也就对阿赖耶里的同类种子进行了炒作，使同类种子的力量更加强大。《菩提道次第广论》中有业增长广大，这是业果四原则之一，不过宗喀巴大师说的不清楚，只说有这样一个原则，但其原理并没有说清楚。这是宗喀巴大师的特征，几乎都是这样，都没有讲清原理，我带来了这本书，《下士道·深信业果》这儿，118页第二行，“业增长广大者。谓虽从其微少善业，亦能感发极大乐果，虽从微少诸不善业，亦能感发极大苦果，故如内身因果增长，诸外因果无能等者，此亦如集法句云，‘虽造微少恶，他世大怖畏，当作大苦恼，犹如入腹毒。虽造微少福，他世引大乐，亦作诸大义，如诸谷丰熟’。从轻微业起广大果，此复当由说宿因缘发定解者，如阿笈摩说，牧人喜欢，及彼手杖，所穿田蛙，五百水鹅，五百鱼龟，五百饿鬼，五百田夫及五百牛，所有因缘。并贤愚经说，金天金宝牛護因缘，当从阿笈摩及贤愚经、百业经等，求发定解……”象这样的说法实在来说，讲不清道理。说，造一点儿业，会感很大的果，当时我们学的时候是听日常法师的带子，日常法师讲的确实很好，也并没有说清楚原理。我记得日常法师举的金猫因缘什么的例子，经典中这样的例子很多，但原理是什么？它可不是象树一样，种下去发了芽就会长大的，业可不是这样的。其原理实际上就是展转熏习、互相作增上缘，我们说的增长广大是指：本来有一些业种，你再造业，熏成了种子，比如说是恶业，这样同类种子就多了一些，同类种子增多也还是各个种子是各个种子，只不过多了以后就人多势众，形成势力，互为增上缘，使得种子缘具的可能性更大，机会更多，就更容易感果，感果以后，我们知道，一个感果了，人的念头不是可以前后相续作等无间缘么～～等无间缘就是前念给后念让出位子，并在大体上给后念一个规定性，前一念是恶，后一念大体上也是恶，因为恶种子很多，恶就可以把持很长时间，这就叫增长广大。宗大师说他这本书总摄龙猛、无著二大车之道轨，反正对无著道轨是没说清，通书给我这样的感觉，可不是一丁点儿。

如果我们不新起熏习，那么，就只有里头先有的种子，那就没有增上缘，就不容易感果，你造业了，就有新起熏习。当然，造业本身它就有名言种子的作用，同时也有有支业力的活动，我见熏习差别更少不了（三种差别都有），不过这里不说它，就是说造业不是单纯的。名言种子的熏习是亲因缘，有支熏习（即业力的熏习）是增上缘。现在我们从业力这一方面来说，新起熏习是增上缘，它就是引发差别。这引发差别要是没有，我们三业的活动，不能在阿赖耶识里熏成种子，那就不能引发果报了。世亲说，他是把行缘识、取缘有放在一起的，说，是在136页，“诸行生灭熏习成识”，就是说，识是由诸行在生灭之间熏习成的。再看“取为缘有”不能成立。十二因缘中的“……触缘受，受缘爱，爱缘起，取缘有……”爱增长就叫“取”，另外一种说法就是取有欲取、见取、戒禁取、我语取四种，欲取是指由于对五欲的执爱――五欲是色、声、香、味、触――而造业。见取他认为自己的见解是最殊胜的，因而作出排斥别的的业。戒禁取是指把戒律进行死板的解释因而造下业，比如非说要结夏安居因而你夏天把庙门关上，使得谁都不乐意――政府不乐意、游客不乐意……我语取的“语”就是说，就是老说这是我，实际上还是执著于我，这是我！当这些执著活动的时候，就有业。爱特别强的时候，就影响了业。也就是说，以前它就有这业种子，只不过增上缘不够，还没有感果，现在爱特别强，就成了取，这一取，唉～～增上缘有了，就感果了。要是没有引发差别，行对识就没有力量，取对有没有力量，既然没有引发的力量，就感不了果。十二缘起中的这个“有”，取缘有的“有”，世亲是这样解释的，还是136页，“能有后生，故名为有”，就是说能够有后生，这就成了条件已经具备了，这就是决定了。我们现在很多事情实际上是不决定的，比如说，我造恶业了，比如我打某人了一个耳光，会得什么果报呢？受报应是一定的，但受什么报应实际上是不一定的，因为缘要是不同的话，果就不同，也要看条件。也就是说，什么是“有”，条件决定了才是。我们一般的就是“取缘有”，一取就有，你要是取了半天没取来呢？那就不是“有”了。

此中异熟差别者，谓行有为缘，于诸趣中异熟差别。此若无者，则无种子，后有诸法生应不成。

再说“异熟差别”，“异熟差别”实际上就是种子、果报种子。说，三界里各式各样的众生的果报种子都不一样，这就叫异熟差别，也就是名言种子。“此中异熟差别者，谓行有为缘”，“行有为缘”就是指十二缘起中的“行”、“有”，“于诸趣中异熟差别”，因为行、有，所以你的活动就在阿赖耶识里面种下了诸趣果报的差别种子，这种子种下了，从亲因缘来说，它是名言种子。“此若无者”，要是没有异熟差别，“则无种子”，阿赖耶识里就没有种子了，“后有诸法生应不成”，“后有”就是以后的果报，现在没有种子了，以后就没有果报再生起了。没有果报生起了，就断灭了。断灭了就是断见，这是外道，不是佛教。

此中缘相差别者，谓即意中我执缘相。

这四种分法中的“缘相差别”其实就是三种分法中的“我见熏习差别”。说，“缘相差别”就是“意中我执缘相”，就是第七末那识执著阿赖耶识为我。“意”就是末那识，在佛教中，一般心是指阿赖耶识，意是指末那识，识是指前六识。

此若无者，染污意中我执所缘，应不得成。

要是没有“缘相差别”，末那识执著为我就不成立了。“染污意”就是末那识，因为它老执著有我，所以叫染污，他身边儿还有四烦恼从不离开。阿赖耶识本身无分别――指没有随念分别、计度分别，转识有各种分别，苦、乐感觉，贪、嗔、痴等都有，但阿赖耶是平静的、不受苦乐影响的，末那识就把阿赖耶识的这相续不断的无分别明了性认成了“我”。

此中相貌差别者：谓即此识有共相，有不共相，无受生种子相，有受生种子相等。

第四种是相貌差别。这里总标一下，下边儿再说。

共相者，谓器世间种子。不共相者，谓各别内处种子。共相即是无受生种子，不共相即是有受生种子。

阿赖耶识的共相是啥？“谓器世间种子”，原来共相就是指器世间种子，器世间就是我们居住的世界。我们以前说过共变、不共变，共变就是指有情共业所变的境界。但我们知道，实际上每一个有情他所受用的只能是他自己变现的境界，那么可能有人要问了，比如这山，你可以受用，我也可以受用，他也可以受用，怎么能说是自己受用自己的所变境呢？关于这一个问题，佛教是这样说的，常举的例子是灯，比如说一个屋子里有很多盏灯，灯点亮的时候每一盏灯都可以照亮整个屋子，“其相相似，一一自别”，灯光相互涉入，其中的一盏灯灭了，屋里还照样是亮的。灯灯之间还有一个增上的功能。共变就是这样。器世间就是这样。现在说的共相不是指器世间，而是说器世间种子，就是生起器世间的功能。种子是因，器世间是果。啥是阿赖耶识的不共相呢？“谓各别内处种子”，就是每一个众生，他自己的“内处种子”。在《唯识二十颂》中有一句颂子，叫“为成内外处，佛说彼为十”，外处就是色、声、香、味、触，内处就是眼、耳、鼻、舌、身。这儿的眼、耳、鼻、舌、身是指净色根，净色根就是发识的功能，我们注意，因为净色根只是发识的功能，所以说绝对是不可以看见的，象佛滢法师在讲《八识规矩颂》的时候，因为他是医生出身，所以他就画一个眼睛的解剖图，说外边儿的眼球玻璃体等是浮尘根，里边儿的视神经是净色根，这个根本是不对的。视神经仍然是浮尘根。现在说的内处种子，内处是净色根。内处种子是阿赖耶识的不共相。接着无著论师说，“共相即是无受生种子，不共相即是有受生种子”，“共相”是器世间，“不共相”是我们的生命体。这儿说共相是“无受生种子”，就是没有感觉，这个“受”就是觉受，器世间是四大和合的，是没有感觉的，所以器世间种子生起器世间，就叫“无受生”――没有受生起，你打它它不会痛，也不会有嗔恨心，你保护它，它也不会有欢喜心。而“不共相”是有感受生出来的，你要是打他，他就会痛，然后他要报复你，你要是对他好，他就感激你，还会报你的恩等。

对治生时，唯不共相所对治灭。共相为他分别所持，但见清净。

我们现在在生死中流转，我们的正报、依报都是下劣的，依报是共相，正报是不共相。我们要是努力修行了，我们的正报、依报都变化了，也就是共相、不共相变化了，比如说我们念佛，结果我们生到了极乐世界，那么我们的依正二报就成了庄严的。这里的“对治生时”，就是指我们修学圣道的时候，因为我们觉得现在的共相、不共相都不好，于是想改变。在我们修学圣道的时候，“唯不共相所对治灭”，圣道把不共相给对治了，也就是把我们的各别内处种子给消灭掉。不共相是各别内处种子，我们现在的各别内处种子都是杂染的，当我们修学圣道，比如说得证罗汉果，就把这些杂染的烦恼种子给消灭了。“共相为他分别所持，但见清净”，“共相”是指世界，这世界是大家共同的业力所创造的种子而变现的，我们现在所面对的这个世界，是我们用烦恼创造出来的。当我们修行证得圣果的时候，象释迦牟尼，他成佛了，他就是在我们这个世界成的佛，可是我们的这个世界还在呀～～还是染污的，这是为什么？“为他分别所持”，这个“他”就是别人，没有证圣的人，就是说，我们现在这个世界是我们这些没有证圣果的人的分别心创造出来的。释迦牟尼他成佛了，他的世界是清净的，但我们没有，所以我们的世界是染污的。这也就是我前边儿说的各人受用各人的世界，我受用不了你的，你也受用不了我的，但我们的业报相似，所以你受用的看起来给我受用的差不多。“但见清净”就是指圣人所见的世界是清净的世界。

如瑜伽师於一物中种种胜解，种种所见皆得成立。

还是这个世界，我们看见的给佛眼所见的不一样，这一句话中举了一个瑜伽师的例子。瑜伽师就是指修禅定、修止观修成功了，与真实相应了的修行者。这些瑜伽师呢，“于一物中种种胜解，种种所见皆得成立”，就是对同一个事物，作种种的不同观想，观想什么就见什么。因为他禅定的力量很大，他在禅定中的思维表现在外的就给我们不一样。不是有一个故事么，人问文殊菩萨，你的五台山这道场怎么这么不堪呢？文殊菩萨用手往地上一指，于是他看见原来五台山是黄金为地。注意，是谁观想谁得见，可不是我观你见，这要搞对，搞错是会闹笑话的。老和尚修水观结果小和尚看见满屋子水。你把一个事物观想成什么都可以，随你自己，观想什么就见什么。

此中二颂：

这里有两个颂子，是对前边儿的论文的总结。

难断难遍知 应知名共结

瑜伽者心异 由外相大故

净者虽不灭 而于中见净

又清净佛土 由佛见清净

“难断难遍知，应知名共结”，“难断”是说烦恼很不容易断，需要我们精进修行，懈怠不得。“遍知”是指一切法的真实相。“难断难遍知”的“断”是目的、是果，“遍知”是因，你得先遍知了才能断，也就是说，你得通达了一切法的真实相，你才能把烦恼断掉，不然就是妄想。要想“知”，你就得闻、思、修。下边儿的第二句“应知名共结”是说，这是共相，前边儿说过，说共相是器世间种子。“难断”“难遍知”，可不是不能断、不能遍知，还是可以的，只不过是难一点儿而已。这个“结”字儿很有意思，结就是把两根绳绑成一个疙瘩，这一绑起来，很难解开。就是说共相很难破，释迦牟尼成佛了，可我们还是看见这个世界是脏的。

“瑜伽者心异。由外相大故”。“瑜伽者心异”是说瑜伽师在禅定中有不同的观想，因为有不同的观想，所以表现出来的就是种种的不同境界。“由外相大故”就是指前边儿的“难断难遍知，应知名共结”，说外边这器世间的相貌、体相太广大了，很多很多的众生各有各的感受、各有各的境界，也就是说太多了，很难断、很难遍知。“净者虽不灭，而于中见净”，这两句颂子要这样读，“净者，虽不灭，而于中见净”。“净者”是指证了圣位、没了烦恼的人。这个世界没有灭，圣者也不能来灭了这世界，这就是我们常说的“自作自受”，有些人说我可以替别人背业，这只是发愿而已，就象地藏菩萨的“地狱不空，誓不成佛；众生度尽，方证菩提”，这都是一样的，只是一个愿，不是事实。地狱绝对不能空，地狱要是空了，佛教的六道轮回就不能成立，六道轮回不能成立还是佛教吗？我们的这个世界是众生的烦恼所成就的世界，圣者也灭不了这个世界――神通不抵业力。但是这个世界在圣者的眼里是清净的世界，因为圣者所见到的是圣者的世界，根本就不是我刚晓所看见的世界。“又清净佛土，由佛见清净”，前边儿说的是净者，不是佛，指的是菩萨，他们还不是究竟圆满，现在说的是佛。说，要是究竟圆满的佛，他看见的是究竟清净的无漏世界。因为成佛的时候，他的识里――成佛后的识是清净的，叫无垢识――有无量无边的无漏的种子，无漏的种子所现出的当然是清净的世界。

复有别颂，对前所引种种胜解，种种所见皆得成立。

诸瑜伽师于一物 种种胜解各不同

种种所见皆得成 故知所取唯有识

另外还有一个颂子，实际上这个颂子就是前边儿的两个颂子的又一个说法。“对前所引种种胜解，种种所见皆得成立”，就是说，另外的这个颂子，是说瑜伽师在修行中，因为进行了不同的观想而表现出了种种的不同所见，这都是可以成立的。“诸瑜伽师于一物，种种胜解各不同，种种所见皆得成”，这三句颂子很简单，就是说，瑜伽师对一个事物进行不同的观想，因此所见各不相同。“故知所取唯有识”，通过瑜伽师对一个事物进行不同的观想就有不同的所见这么一个事儿，就可以知道实际上我们所认取的只是心识所变现出来的，根本就不是事实真相。我们所认识的世界就是我们心识所变现出来的。

此若无者，诸器世间，有情世间生起差别，应不得成。

这一句长行其实可以放在“复有别颂”的前边儿，要是没有“复有别颂”这个颂子，完全是可以的。“此若无者”就是指刚才说的共相种子、不共相种子，也就是无受生种子、有受生种子，说要是没有这个的话，那么“诸器世间”和“有情世间”，“生起差别，应不得成”。也就是说，要是没有共相种子、无受生种子，器世间生起差别就不能成立，没有这种子当然生不起现行。要是没有不共相种子，有情世间的生起差别也不能成立了。原因就是没有种子就生不起现行。

复有麤重相及轻安相

粗重相、轻安相也得说说。

麤重相者，谓烦恼随烦恼种子。轻安相者，谓有漏善法种子。

“麤重”的“麤”是恶的意思，指不好的东西，无性释中说，“恶故名粗”，在371页。“重”是沉没的意思，就是说这件事会使你沉没，使你不能上升。“麤重”就是指“烦恼随烦恼种子”，烦恼、随烦恼就是《百法明门论》中说过的。而“轻安相者，谓有漏善法种子”，说，轻安相是指的有漏善法种子，有漏就是不清净，但毕竟是善，这不清净就是因为末那识。

此若无者，所感异熟无所堪能，有所堪能所依差别，应不得成。

要是阿赖耶识里没有麤重相、轻安相，那么“所感异熟，无所堪能”就成立不了，“所感异熟，有所堪能”也成立不了。“无所堪能”就是指没有能力，没有的是修行的能力、行善的能力。“有所堪能”就是指有修行的能力。粗重相就是烦恼、随烦恼种子，如果没有粗重相――烦恼、随烦恼的种子，那么你就可以行善、可以修行，要是有烦恼种子，比如说现在烦恼种子现行了，你就作恶，因为作恶，你得到恶道受报，在恶道你修行的可能性就太小了。要是没有轻安相，就是说没有有漏善的种子，那么你就不能行善，有了轻安相，你就可以行善，可以行善就是有所堪能。“所依差别”的“所依”是指生命体，生命体的不一样就是所依差别。现在我们每个有情的所依差别都是不一样的，所以阿赖耶识是有麤重相的种子、有轻安相的种子，这都有。

复有有受尽相无受尽相

阿赖耶识还有受尽相的问题。

有受尽相者，谓已成熟异熟果善不善种子。无受尽相者，谓名言熏习种子，无始时来种种戏论流转种子故。

“有受尽相”就是你的果报有穷尽的时候。“受”就是内心的分别，你觉得苦、觉得乐等。这些感受是有时间性的，过一会儿就没有了。说，“有受尽相”是指“已成熟异熟果善不善种子”，阿赖耶识里的种子，有善的，有不善的，可多了，它们成熟的时候就招感果报。这些种子都是有受尽相的。它们在感果的时候你有苦乐之觉，但当它们力量尽了的时候，你的异熟果报体也就告一段落。“无受尽相”是指“名言熏习种子”，“名言熏习种子”就是内心的分别，你内心一分别就熏习种子了。这名言熏习的种子无著论师告诉说，它是“无始以来”的“种种戏论流转种子故”，就是说，它其实是各式各样的名言戏论，“戏论”就是没有实际意义的虚妄分别。我们说这是色、声、香、味、触，这是眼、耳、鼻、舌、身，就是这些境界困住了我们，但我们不知道这是没有真实意义的，在里边执著，产生种种戏论，这些戏论种子流转不断，这种子是“无受尽相”。这我在《唯识三十颂》中讲过的，其实就是业种子、名言种子。

此若无者，已作已作善恶二业，与果受尽，应不得成。又新名言熏习生起，应不得成。

阿赖耶识里要是没有“有受尽相”的种子，那么“已作已作善恶二业，与果受尽”就不能成立了。“已作已作善恶”实际上就是“已作善、已作恶”，“与果受尽，应不得成”是说，你作善就给你乐的果报，你作了恶就给你苦的果报，要是没有有受尽相，你这果报就要无限地受下去，可是事实上并不是，是有结束的时候的，有结束的时候就是有受尽相。要是阿赖耶识里没有“无受尽相”的种子，那么“新名言熏习生起，应不得成”，就是说，我们的阿赖耶识里边有以前旧有的名言种子，要是没有这旧有的名言种子，新的名言种子也就生不起来，为啥？因为我们现在之所以心能够分别，就是依赖于以前旧有的种子，旧有的种子现行了，心才能分别。我们现在可以分别，就说明了原来有种子，正因为原来有种子，现在的新名言种子才能熏习，有现在的熏习了，现在一熏习，就又熏习了种子，这样呢，这名言种子就无穷无尽地延续下去了。要是没有“无受尽相”的种子，新名言种子就不能生起。刚才已经说了，名言熏习种子就是内心的分别，心里的分别是无穷无尽的，它是不能结束的。有受尽相的善不善种子不是无穷无尽，就是说，有受尽相的种子，果报成就之后，一结束它就没有了。

复有譬喻相

阿赖耶识还有一个譬喻相。我们现在面对的任何都西都可以有譬喻相。

谓此阿赖耶识，幻焰梦翳为譬喻故。

这里的如幻、如焰、如梦、如翳，都是譬喻它不真实。“幻”，就是幻化师、魔术师，他用幻术变现出一个东西，他变出来的东西我们看上去好象是真的，但其实不是。“焰”就是阳焰，刚下过大雨不久骤然出了大太阳，快速蒸发，水蒸汽腾腾的，远远一看，像有水一样。看起来象有水，但实际上没有。“梦”，作梦，作梦的时候好象真的有什么东西，但实际上没有。“翳”，就是眼睛有毛病，因而看见月亮长了毛，实际上根本就没有。注意，这些例子我们要正确理解，不要搞错。比如说幻化师，他拿一块石头，三折腾两折腾的在台上变出一匹马来，他变出的这匹马是根本就没有的，但人用的石头是有的。“焰”也是这样，水是没有的，但腾腾的汽儿还是有的。“梦”更是，你梦见的那只大老虎是根本就没有的，但你作了一个大老虎的梦还是真的，不然你为什么吓出一身汗呢？“翳”也是，月亮毛是根本就没有的，但月亮还是有的。这个一定要说对。还有一点儿，你作梦见到了一只老虎，梦中的大老虎是没有的，但现实中是有大老虎的，不然你怎么知道梦见的是老虎而不是一只小狗？你还是能分清楚的！阿赖耶识也是不真实的，正因为它不真实，所以我们可以改变它。所以，现在有很多人把阿赖耶识讲成本体，这是彻底的错误，比如说太虚法师他们，他的四大弟子之一法舫法师在其《唯识史观及其哲学》中说，“阿赖耶识――本体论”，还有林国良教授的《成唯识论直解》等，都把阿赖耶识讲成本体。这都是有问题的书。

此若无者，由不实遍计种子故，颠倒缘相应不得成。

说，阿赖耶识如果没有虚妄性的话，“由不实遍计种子故”，“不实遍计”就是虚妄分别，“不实”是不真实，“遍计”是遍计执。“遍”是普遍，在时间上说，一直是虚妄分别，在空间上说，在任何地方都虚妄分别。本来是不真实的，如幻、如焰、如梦、如翳，可我们认为是真实的，起了种种的执著、分别。这样就熏成了种子，这就是“不实遍计种子”。因为不实遍计种子，“颠倒缘相应不得成”，“不实遍计种子”就是我们搞错了，把不真实的境界当成了真实的，这就是“颠倒”。阿赖耶识就是个颠倒的所缘，因为阿赖耶识所变现的一切境界都是虚幻的，但我们执著它，有我执、法执，这虚妄分别造成了虚妄分别的种子，由种子又变现了种种虚妄的境界，就这样流转。所以，要是阿赖耶识不是虚幻的，我们的“颠倒缘相”就没有了。

复有具足相不具足相：谓诸具缚者，名具足相。世间离欲者，名损减相。

阿赖耶识里还有具足相、不具足相。说，具足相就是“诸具缚者”，啥是具缚者？就是有烦恼系缚，他的烦恼都有，根本烦恼、随烦恼他都有，一点儿也不少。下边儿一句说，“世间离欲者，名损减相”，就是说，这不具足相又叫损减相，就是指“世间离欲”，所谓世间离欲，就是舍弃了世间的五欲――色、声、香、味、触，没有五欲就没有烦恼，没有烦恼就叫“损减相”。有时候世间的舍弃是有另外的含义，比如在《至高利益》中，副省长赵达功是一个标准的政客，他老婆刘璐璐贪钱把他气得要死：你说我们要那么多钱干什么？作为一个副省长，钱对他没有一点儿意义，他不贪钱！这里的世间离欲得是真舍！

有学声闻及诸菩萨，名一分永拔相。

刚才那一句“世间离欲”是说的世间非佛教徒，这一句是说的佛教徒。佛教徒他修学佛法，只是在学，还没有证到最高圣果――小乘最高圣果是四果阿罗汉，还没有证阿罗汉果就是有学声闻，这里的有学声闻是指已入圣道，但还没证最高的四果。咱们常说的“声闻”，“声”是指佛陀说的法语，“闻”就是指听了佛陀的法语而欢喜，所以就照着佛说的来作，实际上菩萨也是这样的，只不过他们没有发无上菩提心，所以被叫成声闻。“及诸菩萨”，很多的菩萨。“有学声闻及诸菩萨，名一分永拔相”，这是指入了圣道的声闻和菩萨，在凡夫位的不算。“名一分永拔相”就是指这些入了圣位的声闻和菩萨已经把一部分的烦恼消灭了，这里是“永拔”，就是彻底断除，把这一部分烦恼彻底断除了。

阿罗汉、独觉及诸如来，名烦恼障全永拔相，及烦恼所知障全永拔相，如其所应。

刚才说的声闻、菩萨，都是指见道位以上的圣人，刚见道就算。“阿罗汉、独觉及诸如来，名烦恼障全永拔相”，这里进一步，从初果到二果、三果、四果，菩萨呢，就是从初地到二地、三地……直到成佛。“阿罗汉”就是杀贼，他把爱烦恼贼、见烦恼贼等都消灭了。又叫无生，他没有生死了，他得大解脱了。也叫应供，他是众生的福田，能受得起人天的供养了。“独觉”是不需要师长教导，自己就能觉悟圣道。“及诸如来”，圆满的佛陀。这是三乘圣人：阿罗汉、独觉、如来。这三乘圣人，“名烦恼障全永拔相”，烦恼分为两类，一个烦恼障，一个所知障。烦恼障就是指我们的情绪方面的烦恼，这些烦恼扰乱我们的心神，障碍圣道，使我们留在这苦恼的地方不能解脱。“全永拔相”就是完全清除了，一点儿也没有留下来。

还有“及烦恼所知障全永拔相”，所知障是认识方面的障碍，阿罗汉、辟支佛把烦恼障消灭干净了，但还有所知障没有消灭。如果把烦恼障、所知障完全清除了，就成佛了。“如其所应”就是指该断的就断，阿罗汉、辟支佛要把烦恼障彻底消灭，佛要把烦恼障、所知障都彻底消灭。为什么罗汉只断烦恼障就可以了呢？因为罗汉是自度的，把烦恼障消除就自度了，我根本不用度他，所以所知障不用管。就象每一个人都会犯错误一样，我只要作事儿，总有犯错的时候，我干脆不作事儿，当然永远没有犯错的机会。所知障实际上就是障所知，就是一个错误，度众生就是我说的作事儿了，作事就有作对的有作错的，就是会犯错误，不度众生就是不作事儿，根本不会犯错误――根本用不着断所知障。“有学声闻”是永拔一分烦恼障，见道以上“诸菩萨”是永断烦恼所知障各一分，这叫“一分永拔相”。无学的阿罗汉、独觉，是拔去全分烦恼障，叫“烦恼障全永拔相”。诸如来要完全拔去烦恼所知二障，叫“烦恼所知全永拔相”。都不一样。

此若无者，如是次第杂染还灭应不得成。

具足相、损减相、一分永拔相、全永拔相，这就是差别。要是没有这差别相的话，“如是次第杂染还灭应不得成”，这杂染还灭的次第，就不能成就了。我们现在只有一个流转，要修行，那就有一个还灭的问题。还灭就是损减，把烦恼给损减掉。在这儿呢，妙老说，按唯识的说法，众生的种性不同，有的人可以成佛，他就能够烦恼障、所知障全断除，有的众生只能成罗汉、成辟支佛，他就有烦恼障全永拔相。有的众生没有三乘圣人的清净性，他就完全不能拔除，只能在生死里流转。这种说法按我的理解可能不是这样的。这要涉及到种子的本有、新熏问题。咱们放在课后专门说。

何因缘故善不善法能感异熟，其异熟果无覆无记？

这是说阿赖耶识是无覆无记性。“何因缘故”，就是为什么？下边儿说“善不善法能感异熟，其异熟果无覆无记”，就是说，我们做善业能招感可爱异熟果，我们做不善业能得到不可爱异熟果。造业时有善、不善的区别，得果报时有可爱、不可爱的不同。但这果报是可爱、不可爱而不能说是善还是不善，只能说是无覆无记。为啥因有善、恶而果没有呢？“无覆无记”的“覆”就是障碍、遮盖，“无覆”就是没有障碍，没有障碍是因为没有烦恼来相应，有烦恼来相应就叫有覆，无烦恼相应就叫无覆。《唯识三十颂》中说，末那识是有覆无记，就是因为它有四烦恼常与相应，它能障碍圣道。这阿赖耶识是“无覆”，它没有烦恼法来相应。“无记”就是不可以说它是善、是恶。前七转识做善、做恶，阿赖耶识始终是无记的。为什么不管我造善还是造恶所得的异熟果只是无覆无记呢？道理在哪儿？

由异熟果无覆无记，与善不善互不相违，善与不善互相违故。

因为阿赖耶识是无覆无记，这样它“与善不善互不相违”，就是说，这样它才可以接受七转识放进来的种子，前六识做善时熏成的种子它接受，你做恶时熏成的种子它也接受。假如说阿赖耶识不是无记而是善的，这就坏事儿了，为啥？“善与不善互相违故”，就是说，阿赖耶识要是善的话，前六识作恶时熏成的种子它就不接受了。所以，阿赖耶识必须无记，不无记不行！这样呢，佛教在建立阿赖耶识的时候就建立了一个无记的阿赖耶。

若异熟果善不善性，杂染还灭应不得成。是故异熟识唯无覆无记。

要是阿赖耶识不是无记而是善、不善性的话，杂染还灭就没法儿成立。比如说它是善的，善有世间善，有出世间善，它要是出世间善，“杂染应不得成”，就是说世间的流转生死就不能安立了，那我们就不会在生死中流转，也就没有轮回了。它要是世间善，世间的恶法也就不能成立，因为善恶是水火不容的，它不接受恶的熏习。它要是不善的话，“还灭应不得成”，就是说你修学不了圣道，修学圣道是善，可阿赖耶是恶，它不接受正闻熏习的法界种子。“是故异熟识唯无覆无记”，所以，阿赖耶识只能是无覆无记。只有这样，世间的杂染、出世间的还灭才能成立。


所知相分第三

现在该说第二卷了，这第二卷讲了三个问题，一个是所知相，一个是入所知相，一个是彼入因果。所知相是第二卷开始就是。入所知相是从36页开始，而彼入因果是从41页开始。前边儿已经说过，所知相主要就是讲三自性的。入所知相是讲唯识性的，而彼入因果是讲六波罗密的。为什么把这所知相、入所知相、彼入因果一起放在第二卷？没有原因，可能是当时玄奘法师译经时所用的帛就这么长，写到这儿这一卷儿写完了，写完了就卷起来，这就是一卷。

已说所知依，所知相复云何应观？

这个《摄大乘论》一共是讲了十相殊胜殊胜语，前边儿已经说完了所知依，所知依是成立阿赖耶识的，先以圣教量成立阿赖耶识，又以比量成立阿赖耶识。从烦恼的角度成立阿赖耶识，又从清净的角度来成立阿赖耶识，总之，我建立阿赖耶识的理由充分得很。并且把所知依阿赖耶的重要特点说了，比如说熏习。“已说所知依”，所知依阿赖耶识已经建立起来了，“所知相复云何应观？”那么所知相呢？它是怎么回事儿呢？在这里要说了。所知依是关于隐性因的问题，通过熏习来成就染净显性现行法的亲因缘，所知依阿赖耶的成立才使得一切显性现行法得以成立。我们就应该依此圣教量、比量了知一切显性现行法都是依隐性因而生的。既然已经知道了因，那么就得知道显性现行法的真妄性，这就是所知相。就是说，所知依是种子，所知相是现行。或者说，所知依是根本识，所知相是前七转识。这一句长行就是说，对一切缘生的现行法，由缘生的心识所显示真实性与虚假性，具体怎么来界定呢？下边儿要说的唯识三性理论，说的很详细，就是解释这个问题的。

此略有三种：一、依他起相，二、遍计所执相，三、圆成实相。

一上来先把三种相的名称标出来。说，在这一段我要说三种相。佛教的根本教义是缘起，这里就讲，从本质上来说，是阿赖耶识缘起。阿赖耶识是中心，它是依他起的。第二是“遍计所执相”，遍计执相是我们的烦恼、我们的虚妄分别、我们的执著。“遍计”的“遍”是普遍，“计”是计度、筹划。说，我们没有哪一会儿不筹划、不计度的，一直在用心算计，对任何事儿都用心算计。第三是“圆成实相”，这是圣人圆满成就的真实相。遍计所执相是凡夫的境界，圆成实相是圣人的境界，依他起相通于凡圣。所知相就是由依他起、遍计执、圆成实三相来界定的。三相实际上就是三种存在，或者说是三种存在模式。

此中何者依他起相？谓阿赖耶识为种子，虚妄分别所摄诸识。

三相的第一相是依他起，那么什么是依他起相呢？就是虚妄分别的这么多的识（我们现在所面对的一切法就是识所表现出来的相貌，根身、器界都算）。也就是说，依他起是诸识的特征相，这就表示诸识是依他起的生灭法。这识从哪儿来？“谓阿赖耶识为种子”，阿赖耶识里边儿有很多的种子，以这种子为亲因缘而生起的、而有的虚妄分别识。下边儿一句说，“虚妄分别所摄诸识”，这是说，这“诸识”的体性是“虚妄分别”，就是说是错误地去思惟、执著。这些识都是虚妄分别的。眼识、耳识、鼻识、舌识、身识，乃至于阿赖耶识，都是虚妄分别的。所谓“虚妄分别”，只要你没有见到法性，你的分别就是虚妄分别。虚妄分别都是错误的。当你登圣位了，见到法性了，他就不是虚妄分别了，你是清净的、是正确的。虚妄分别就是假有。这儿注意：假有就是真有！我为什么这么说？就是因为世界上除了“假有”根本没有别的，象什么“我”等常的东西根本就没有，所以这假有才是真的如实有。并不是说假有之外有什么真有，所谓的这个假有，就是指虚妄分别有。“虚妄分别所摄诸识”的“所摄”，就是指诸识都属于虚妄分别的。总的来说，这一句话就是说，虚妄分别心就是依他起相，这依他起相是以阿赖耶识为种子而生起的。这句话有三义，说，依他起相的因缘是“阿赖耶识的种子”；他的自性，是“虚妄分别所摄”；它的别相是由赖耶功能所现起的以妄识为自性的“诸识”。

此复云何？

刚才你说依他起相是“虚妄分别所摄诸识”，既然是“诸识”，当然就不是只有一个识，而是有很多个识，那么是什么识？有多少识？

谓身，身者，受者识，彼所受识，彼能受识，世识，数识，处识，言说识，自他差别识，善趣恶趣死生识。

诸识是指什么呢？这一句长行中举出了十一种识。实际上识到底有多少，并没有什么一定，一般都说八识，但《中边分别论》中就说四种识，还有六种识的说法等，这些只是开合的不同而已。到中国以后不是又出了九识说么～～只要圈儿转圆。咱们就看这部《摄大乘论》说的十一种识。第一个是“身”，所谓“身”，其实指的是我们的净色根，就是眼根、耳根、鼻根、舌根、身根。这五根一般不说它是识，现在这儿说它是识，是说五根本身就是识。“身者”，其实是“身者识”，什么是“身者”？世亲释中说就是“染污意”，在141页中。无性释在374页说，“眼等六内界者为性，如其所应，眼等五识所依意界，名身者识。”我们就记住是末那识就行了，因为末那识是前五识的共依。“受者识”，就是指无间灭意。前边儿说过两个意：等无间意、染污意。现在这个“受者识”就指那个等无间灭的意，因为这等无间灭的意，就是前一剎那的识灭了才能给后一刹那让出位子，所以前一剎那识灭了，可以容后一剎那识生起，这叫做“受”。“身者”和“受者”合起来就是意、意根。“彼所受识”，就是色、声、香、味、触、法六种境界，也就是常说的六尘。这六种境界是所接受的。一般也不把这六尘说成识，但这儿把它们说成识，就是“彼所受识”。下边儿是“彼能受识”，这是我们通常说的六识，眼识、耳识、鼻识、舌识、身识、意识，这是“能受识”。这样呢，就是十八界了：“身识”是通常说的五根；“身者识”和“受者识”是通常说的意根，这样就有六根；“彼所受识”是六尘；“彼能受识”是六识。六根、六境、六识，三六一十八界。接下来一个是“世识”，“世”是三世，过去、现在、未来，所以世识就是时间。时间是心不相应行法，但这里说它也是识。其实也就是说，世识是指对时间的了别。“数识”，“数”就是一、二、三、四、五、百、千、万等，这是对数目的了别。一般说它是心不相应行法，这里也说它是识。“处识”，“处”就是处所、地方。也就是器世间。对处所的了别，现在说这也是一种识，叫处识。“言说识”，就是我们的见闻觉知，我们有了见闻觉知之后，我们用语言把它表达出来，这也是一种了别，无著论师叫它“言说识”。“自他差别识”，就是我你他之间各有各的不同的了别，你不是我，你也不是他，我也不是他，这了别叫“自他差别识”。最后一个是“善趣恶趣死生识”，你要是造了善业，你就在善道里流转，你要是造了恶业，你就到恶趣里受生，但不管是善趣是恶趣，都是生了又死，死了又生，这是一个不断流转的过程，这也是了别，叫“善趣恶趣死生识”。这总共十一种识，就是说，无著论师在这里把宇宙万有分成了十一类，这十一类完全都是“识”，除了识以外，没有别的东西。这里是先把“虚妄分别所摄诸识”的“诸识”给列出来，后边儿再解释。

此中若身，身者，受者识，彼所受识，彼能受识，世识，数识，处识，言说识，此由名言熏习种子。

刚才那一段儿话把诸识的名字都列出来了，前边儿还说，“谓阿赖耶识为种子，虚妄分别所摄诸识”，那么“诸识”是指十一种识，“阿赖耶识为种子”该怎么说？又分三类，这一句话是第一类，说“身识、身者识、受者识、彼所受识、彼能受识、世识、数识、处识、言说识”这九个识，是由阿赖耶识里面的“名言熏习种子”所生的，也就是以名言熏习种子为因而生起来的。

若自他差别识，此由我见熏习种子。

总共十一种识，前九种是名言种子熏习的，这第十种识“自他差别识”，则是由“我见熏习种子”生起的。我见熏习，就是说，无始以来我们总是以自我为中心进行分别，这样而熏习的种子，这种子发动的时候，我们就有了自他差别的分别。“若”是指示代词。

若善趣恶趣死生识，此由有支熏习种子。

第十一种识――善趣恶趣死生识――是有支熏习种子，这是单独一类。我们在善趣里面、在恶趣里面流转生死，这是由阿赖耶识里面的“有支熏习种子”生起的。就是说，在善趣时我们有“身识、身者识、受者识、彼所受识、彼能受识、世识、数识、处识、言说识”，在恶趣里也有这“身识、身者识、受者识、彼所受识、彼能受识、世识、数识、处识、言说识”。

由此诸识，一切界趣，杂染所摄，依他起相，虚妄分别，皆得显现。

十一种识都是由阿赖耶识的三类种子为因而现起的，叫“阿赖耶识为种子”，接着说了，说这些识都是虚妄分别。“由此诸识，一切界趣杂染所摄”，前面列举的十一种识，可以含括一切界趣。“界”就是三界，欲界、色界、无色界。三界实际上是众生生命存在的三种形态。欲界是具有情欲烦恼的生命形态。情就是感情，欲则是欲望，佛教的欲包括在情中间，情有七种：喜、怒、忧、惧、爱、憎、欲。中医理论中的七情是喜、怒、忧、思、悲、恐、惊。欲在《大智度论》中有六种：色欲、形貌欲、威仪姿态欲、言语音声欲、细滑欲、人想欲。色界则是不具情欲，只有物质和精神活动的生命形态。而无色界则是不具情欲和物质活动，只具精神活动的生命形态。“趣”就是六道，地狱、饿鬼、畜生、人、阿修罗、天。一切界趣都有这十一种识，说是“杂染所摄”，前边儿说过，说“杂染”有烦恼杂染、业杂染、生杂染。烦恼杂染是十二因缘的无明、爱、取，业杂染是十二因缘的行、有，其他的识、名色、六入、触、受、生、老死是生杂染。十一种识含摄了一切界趣杂染，一切界趣杂染含括了十一种识，就是说一切界趣与十一种识互摄互融。其实也就是说，诸识存在于三界六趣。“依他起相”，前面说“阿赖耶识为种子，虚妄分别所摄诸识”是依他起，这儿说“由此诸识，一切界趣，杂染所摄，依他起相”，就是说烦恼杂染、业杂染、生杂染就是依他起相，三杂染也就是诸识，所以还是说诸识是依他起相。“虚妄分别，皆得显现”，诸识、三杂染怎么开合都没有关系，但一定要知道它们实际上是虚妄分别，不管是一切界趣，都是虚妄分别，都是识，这道理“皆得显现”，就可以显现出来。就是说，这一切都是识，这个道理可以显现出来了。当然，得注意一下，并不是说三界六道中任何一界一道都有十一识，比如说无色界，它有身识（五根）吗？你们咋连这也不敢肯定？！

如此诸识，皆是虚妄分别所摄，唯识为性。

“如此诸识”，就是刚才说的十一种识，一切界趣都有这十一种识，这识是“虚妄分别所摄”。这儿说了十一种识，对于其中的六识――彼能受识――之类的，我们好理解，我们能很明白地感觉到它们的虚妄分别性，但其中的六根――身识、身者识、受者识――以及六尘，就是我们的识所面对的色、声、香、味、触、法等，说这些也是虚妄分别所摄，这与我们平常的感觉如此的不相容，以致于我们在平常的背景之下很难理解。其实它们也是离开了识就不存在的，它们也是“唯识为性”，也就是说，这一切法也是以识为其体性。我们现在所面对的事儿，实际上只是心识所表现出来的一个影像，这影像是以心识为体性的。这个意思在不少书上都用“图景识”这样一个词来表示。心识本身就是虚妄分别。

是无所有非真实义显现所依

这还是说诸识的，说诸识都是虚妄分别，实际上是无所有的、非真实的，长行中这一句的“是无所有、非真实义显现所依”，在无性释中是把“无所有”和“非真实”分开了，翻到375页第8行，这里说，“所取色等名无所有，能取识等名非真实”，也就是说，“无所有”和“非真实”是不一样的，“无所有”是指根本就没有，而“非真实”是指颠倒了、错乱了，这就告诉我们：有能无所。现在我们一般人的想法里，要是有能则肯定得有所，要是无所的话，能也就不能称之为能了。就象说长，长是相对于短来说的，要是没有短，哪儿还有长？但在佛教中就是如此的奇妙，只有能没有所！佛教是一合相，是不二法门，没有二元对立，二元对立不是佛法！妙老在讲到这儿时说，这就是遍计执，对的，这就是遍计执，可我们不知道这就是遍计执。虽然说它是遍计执，但这遍计执也是有个来处的，它的来处是哪儿呢？就是依他起。长行中说“真实义”的“义”，我们说过好多次，“义”有二义，一个是境界为义，一个是道理为义，不管是境界也好，道理也好，从本质上来说，实际上是我执、法执。遍计所执本来是无所有的、是非真实的，但我们认识不清，老认为是真实的、是有的，所以就起种种的分别、种种的烦恼、种种的错误行为，因而感得了种种的果报。

如是名为依他起相。

这就是依他起。总结一下，所谓依他起，有两个要点儿：一个是“阿赖耶识为种子，虚妄分别所摄诸识”，另一个是“是无所有非真实义显现所依”。也可以说有三个要点儿：一、他的种子是阿赖耶；二、他的自性是虚妄分别所摄诸识；三、他是遍计执生起的所依。

此中何者遍计所执相？

说过了依他起就该说遍计执了。

谓于无义唯有识中似义显现。

因为后边儿还有详细解释，所以这儿只是简单地用一句话带了过去。前面说“是无所有、非真实义”，说了个“义”。这一句长行中说“谓于无义”，说的是啥？是说，现在我们内心里一直在进行种种的分别，但这分别都是在瞎胡闹，因为所分别的对象实际上根本就不存在，根本就没有所分别的这一些境界，根本就没有“义”。没有“义”有什么？“唯有识”，只有你的分别而已。笛卡尔说，我思故我在，我们说：思故思在――凭思只能证明思本身的存在，根本就不能证明“我”存在。“似义显现”，只有识的活动，识在跳呀跳，但它的跳呀跳，我们就把它当成了“义”。就是说，本来是分别心，因为无量劫来的熏习，心一动熏习就随着心动而动，这就表现出了种种的分别相。这分别相并不是“义”，但你觉得它是“义”，这就是长行中的“似义”――好象是“义”、象“义”似的。这些其实都是自己在乱想、乱分别。比如说一个人，你们迎面走，你想给打个招呼，可他象没有看见你一样，你立马心中就会有嗔念生起，然后你还会找出许多的理由来证明你生嗔念是如何如何的有理，我们就是这样。这就是“似义显现”。现在无著论师明白地告诉我们说“无义，唯有识”，你想的那个境界根本都不存在，只是你内心的分别。你不明白这个道理，老是去执著那根本就不存在的境界，就叫“遍计所执相”。心在动，因为心在动所以就表现出一个动的相貌，心的这个“动的相貌”与“心的动”是吻合的，一点儿也不会走样，“（心的）动”我们称为分别，你就根据这个相貌说心在分别，“动”的状况有很多，你就说分别有很多，你这“说”分别很多，就成了遍计执！一定注意：是“说”分别很多，这一“说”就成遍计执了！

此中何者圆成实相？

第三是圆成实相，那么什么是圆成实相呢？

谓即于彼依他起相，由似义相永无有性。

就是指对于依他起相，不要有虚妄分别，认清了我们分别的境界都是根本就不存在的，这就是圆成实相。长行中的“似义相永无有性”就是指分别出来的境界――似义相――是永远都不存在的，根本就没有存在过，从来就没有存在过。“似义”就是你所执著的境界、所分别的境界。“似义相永无有性”就是指你所分别的境界从来就没有过。妙老说，你在观察他的时候，知道他是没有自性的。我是这么想的，你观察它也好，不观察它也好，都不妨碍它是没有自性的，只不过是你观察它的时候知道了它是没有自性的，你要是不观察的时候，你不知道它没有自性。也就是说，这是说自己的认识的。不过，说实在的，你要是不观察它，你根本就不知道它，何来的不知道它没有自性～～妙老还说，“义”是我们分别心的所缘境，没有所缘境的时候，心也就不存在了，也就是依他起不存在了，在这时，所观察的不可得，能观察的也不可得，就是一个平等无分别的境界，不分别了也就没有相了，离一切相的境界，就叫“圆成实相”。对妙老的这个说法，我觉得他的表述并不完美。唯识中间是唯能无所的，所是根本就没有的，但能是有的。在依他起上不起遍计执，就是圆成实，依他起、圆成实本身就是“相”，自己离不了自己的。总括一下就是说，虚妄分别的心是依他起相。“遍计所执相”就是“似义显现”，是“无所有、非真实义”的显现。其实就是我们这个虚妄分别心所分别出来的境界，我们不知道这境界是无所有的、非真实的，把它当成了真的。更明白点儿说，其实遍计执相就是我执、法执，也就是所知障、烦恼障。“圆成实相”就是认清了遍计执相的真面目，知道它实际上是虚妄分别心分别出来的，它是不存在的，存在的只是虚妄分别心，这虚妄分别心是没有一个恒常的自性的，就就叫诸法空相，这就是圆成实性。再括一下，就是说，我们把有的说成有，把无的说成无，把该分开的分开（指把我、五蕴要分开，虚妄分别和我要分开――我是贯穿始终的，而五蕴、虚妄分别是相似相续的。贯穿始终是前后是同一个，而相似相续则前后不是同一个），把该合起来的合起来。

此中身，身者，受者识，应知即是眼等六内界。彼所受识，应知即是色等六外界。彼能受识，应知即是眼等六识界。其余诸识，应知是此诸识差别。

前边儿说过诸识有十一种，这儿把“身，身者，受者识”这三识拉出来示众，说这三识“应知即是眼等六内界”，就是说，这身识、身者识、受者识就是我们内六根：眼根、耳根、鼻根、舌根、身根、意根，“六内界”就是内六根。前边儿说过一下，“身”是前五根，“身者”是染污意，“受者识”是那个等无间灭意根。“身者”和“受者识”合起来就是第六意根。加上“身识”的前五根，就是六根。“彼所受识，应知即是色等六外界”，这是色、声、香、味、触、法六尘，是六根所受的境界。“彼能受识，应知即是眼等六识界”，这是眼识、耳识、鼻识、舌识、身识、意识。这合起来就是十八界了，十八界就把我们凡夫世界的一切法都包括尽了。“其余诸识，应知是此诸识差别”，“其余诸识”就指一共的十一个，减掉前边儿说过的“身识、身者识、受者识、彼所受识、彼能受识”五个，还余下的六个识，“世识、数识、处识、言说识、自他差别识、善趣恶趣死生识”，这其他的六个识就是“其余诸识”，这其余诸识怎么样呢？“应知是此诸识差别”，“此诸识”就是指刚说过的“身识、身者识、受者识、彼所受识、彼能受识”，说，余诸识是此诸识的差别，就是说，后前边儿的六个识是前面这五个识的差别相，要是离开前边儿的五识，就没有后边儿的六个识了。也就是说，后六识是依前五识的作用而安立的。象“世识”，就是十八界的时间，过去的十八界、现在的十八界、未来的十八界。“数识”，就是分别心的多少，有种种的数目。“处识”就是在不同的地方都有十八界。“言说识”则主要是指第六识，第六意识才可以安立种种的名言。当然广义的名言也可以包括其他识，色就是眼识的名言，种种色的不同，就是眼识的不同名言；声就是耳识的名言，种种声的不同，就是耳识的不同名言……其他的识情况给这是一样的。“自他差别识”，各人有各人的十八界就是自他差别识。“善趣恶趣死生识”，善趣有善趣的十八界、恶趣有恶趣的十八界。这样，十一种识就包括了一切法。

又此诸识皆唯有识，都无义故。

十一种识都是识，都没有“义”，也就是说，十八界里面，眼识、耳识、鼻识、舌识、身识、意识，这当然是识，至于眼根、耳根等净色根以及色、声、香、味等境，也都是识。这个理解起来有点儿不大合于我们的习惯。在我们一般说来，是不把它们叫识的。下边儿呢就来解释它们为何都是识，为何十一识都是识。

此中以何为喻显示？

佛教说法有一个最殊胜的方法，就是比喻。我们知道，我们常犯的一个毛病就是分能所，这是自然的习惯，无始以来我们就这样作，已经习惯了，改不了这个臭毛病。比喻这个方法可以既启迪智慧，又不使我们落入所边。现在这句长行就是说，能不能用个比喻来说明一下这十一识都是虚妄分别所摄、都无义呢？

应知梦等为喻显示。

说，好，我举一个比喻，拿梦来作一个比喻吧。这里的“梦等”，有个“等”字儿，表示还可以拿其他的比喻，比如说幻诳、鹿爱、翳眩这一些也可以拿来作比喻。下边儿先来解释梦这个比喻。

谓如梦中都无其义独唯有识。

用梦这样一个比喻就可以说明唯识无义的道理。韩老后来把“梦”给译成了“梦景”，这就更明了。说，梦里有很多的境界，但梦里的那些境界“都无其义”，也就是说，梦里的境界是虚妄分别，“独唯有识”，只有虚妄分别的心，而没有虚妄分别分别出来的那些境界。

虽种种色声香味触，舍林地山似义影现，而于此中都无有义。

在梦里我们可以见到各种各样的色、各种各样的声、各种各样香……看见了屋舍，看见了树林，看见的大山等等境界。“似义影现”这个“义”是境界，说，梦里所见到的境界和我们醒时所见到境界是相似的，我们不会作一个从来就没有见到过的境界的梦。象有时候会梦见说外语，我记得梦里会说的外语就是我会说的几句，有时候在梦里知道是说的外语，但根本就不知道说的是什么意思。梦里的境界和醒时的境界是相似的，叫“似义”。“影现”就是说它只是一个影子，并不是真的，事物的影子和真的事物是相似的。梦里的境界虽然虚妄不实，但和真的境界是有相似性。“而于此中都无有义”，梦里的种种境界，根本就是没有的。

由此喻显，应随了知一切时处皆唯有识。

根据梦这样一个比喻，我们“应随了知”――应该随顺梦的比喻去了知，了知啥呢？了知“一切时处皆唯有识”，应该了知我们现在所面对的一切境界也都是和作梦一样，是虚妄的、是不实在的。“一切时处”就是强调了我们现在不管啥时候，不管在啥地方认识到的都是虚妄的。“皆唯有识”，一切都是虚妄分别心分别出来的。

由此等言，应知复有幻诳，鹿爱，翳眩等喻。

这一句长行是解释前边儿的“梦等”的“等”字儿。说还可以拿“幻诳”来比喻，拿“鹿爱”来比喻，拿“翳眩”来比喻。“幻诳”就是幻化师在舞台上表演幻术――就象咱们说的魔术师，这个幻化师用一块石头之类的东西，三下、二下就变出一只大象来。“诳”就是骗，这个幻化师骗过了你的眼睛。这个幻化师幻化出来的大象是不存在的，但他拿来表演幻术的道具是有的，就是说，第八识里的种子是有的，但表现出来的根身器界是不真实的，我们都被诳了。阿赖耶识就是幻化师，幻化出来的境界就是根身器界。“鹿爱”是阳焰，这是佛教中经常出现的例子。大夏天，下过雨后天大晴，太阳一下子出来之后，很快蒸发，水蒸气立刻焰腾腾的，远远看去，就象水一样，可能是印度鹿比较多吧～～不过我也不知道印度是不是鹿比较多，我只知道印度大象比较多，我见鹿爱这个例子经常出现我就这么胡想的。说，人看见焰腾腾的认为是水，鹿也这样看，鹿渴了，就跑去要喝水，实际上并没有水，只是相似而已，似义显现。这种情况就叫鹿爱。这就是说，水是没有的，但焰腾腾的气是有的。“翳眩”，就是眼睛有了毛病，天空中并没有花，是明净的，可因为眼睛有“翳眩”，所以你看见空中有花，天花乱坠。在眼睛没毛病的人看来，花是没有的。比如常见书中或文学作品中说，一拳打下去，对方感到眼冒金星，金星有吗？根本就没有，但他看见了。看见也不是真的。这些都可以拿来比喻，通过这些比喻，我们可以知道，我们心里所分别的一切境界，都是虚妄不真实的、空无所有的，只有虚妄分别心而已。

若于觉时一切时处皆如梦等唯有识者，如从梦觉便觉梦中皆唯有识，觉时何故不如是转？

别人提了一个问题，说，比如说你举的例子，梦，在梦里的时候，我不知道那些山林、田园、屋舍是假的，但我醒来之后我就知道它不是真实的，有的只是梦中心识的分别。“若于觉时”就是如果到了醒来的时候，“觉”就是睡醒了。“一切时处”就是指梦里的一切境界，一切时一切处所面对的、所接触的，在梦里也是有时间有处所的。“皆如梦等”，都象梦一样，“唯有识”，只有内心的分别，根本就没有所分别的境界。“如从梦觉便觉梦中皆唯有识”，一个人做梦，他醒来以后就知道了梦里的境界都不是真实的。可我们现在是醒着的呀～～“何故不如是转”？为什么我感不到现在所面对的一切都是虚幻的呢？也就是说，当醒来的时候我就可以知道梦里的境界是虚幻的，可我们现在是醒着的，为什么感觉不到面对的一切境界的虚幻呢？“转”，生起，指生起我们面对的一切是虚幻的认识。

真智觉时亦如是转：

无著论师回答说，没有醒来，你就不知道作梦时候的境界是，只有醒来才知道。可现在我们还在无明大梦之中没有醒来，所以我们不知道我们现在所面对的一切是虚幻的。我们现在在文字上也知道一切都是虚幻的，但力量太小，所以我们得加强修行，要长时期的闻思修，当达到“真智觉时”，真智觉时就是见道时，也就是登初地时，到那时，根本无分别智现前，就“亦如是转”了。外人刚才的这一问，就说明了他不知道佛教说法的奥秘，佛教的比喻其实只是为了启迪智慧而已，你不要落在“所”边。

如在梦中此觉不转，从梦觉时此觉乃转，

“如在梦中”，就是说，我们现在还象在作梦一样，就是指无明大梦，“梦中此觉不转”，在梦中你根本生不起“面对的一切都是虚幻的”这样的认识。“从梦觉时”，从梦中醒过来了，“此觉乃转”，才能生起梦境不真实的认识。

如是未得真智觉时，此觉不转，

作梦和醒来的情况就是这样，那么我们现在在迷惑颠倒的时候、在无明大梦里，和无分别智现前时比较起来，当然“此觉不转”，唯识无义的认识没能生起。

得真智觉此觉乃转。

当我们从无明大梦中醒过来的时候，无分别智现前了，“得真智觉”就是得无分别智。“此觉乃转”，唯识无义的认识自然就生起来了。不过，初登圣地的菩萨，因为刚登初地，所以还有失念的时候，但这样的情况极少，而且他惊觉了马上就会恢复正念。也就是说，我们在作梦时不知道梦境的虚幻，我们在无明大梦中、没有无分别智时也不知道十八界一切法都是虚幻的，我们不知道我们愚痴，还自认为挺聪明呢～～

其有未得真智觉者，于唯识中云何比知？

圣人们有了真智觉，他们知道唯识无义是真理，但我们凡夫并没有得真智觉，我们凭什么知道“唯识无义”是正确的呢？你不能老拿比喻来说吧～～比喻毕竟不是严格的。

由教及理应可比知。

比喻你嫌不严格，那咱们就拿教理来说吧，凭教理也是可以知道唯识无义的。“教”是圣教量。“比知”就是推度而知、比量。圣教量当然是没话说的，那是佛陀说的、菩萨说的，我们相信佛、菩萨这些圣人是不会说错话的，因为他们是证悟了无分别境界的。圣者说唯识无境我相信。但光相信是不行的，我们要思惟、观察圣者所说的道理。经中常说，“谛听谛听，善思念之”。也就是说，从比喻来理解唯识无义当然也行，但力度毕竟还是差了一些，要是由佛菩萨的圣教量所说的理论去观察，那就更好了、更容易理解了。

此中教者，如十地经簿伽梵说：如是三界，皆唯有心。

这里就开始引用圣教量来说明唯识无境。第一个引的是《十地经》，就是《华严经·十地品》，在这部经里，簿伽梵这样说过，“薄伽梵”就是世尊，《十地经》中说，“如是三界，皆唯有心”。欲界、色界、无色界里的众生在流浪生死，他们虽然面对着那么多的境界，但这些境界其实只是一念分别心而已。其实在《华严经》中，类似的话可不少，比如说，“三界虚妄。但是心作。十二缘分。是皆依心。（大正藏9册0558页）”；“心是三界、心是三世。（大正藏9册0642页”；“复作是念。三界所有。唯是一心。(大正藏10册0194页)”；“知三界唯心。三世唯心。(大正藏10册0288页)”等。

又薄伽梵解深密经亦如是说。

佛在《解深密经·分别瑜伽品》中也这样说过。下边儿就介绍了一下《解深密经》中的这一段儿。

谓彼经中慈氏菩萨问世尊言：诸三摩地所行影像，彼与此心当言有异？当言无异？

在《解深密经·分别瑜伽品》里，“慈氏菩萨”问释迦牟尼佛，慈氏菩萨就是弥勒菩萨。说，“诸三摩地所行影像”，“三摩地”是定，这是说的得定者的情况，我们是散乱心，不说我们的情况。得了三摩地的人“所行影像”，“行”就是心识在境上的活动，“活动”就是心识对所缘境的分别。“影像”是三摩地里所现出来的境界，比如我现在就仔细地观察一尊佛像，观察得极其的详细，甚至于一片衣纹、一个发旋儿都清清楚楚了，然后我在禅定的时候就观想这佛像，这佛像就在禅定中显现出来了，这时候显现出来的佛像，就是影像。我们现在就读经，看经中描述的西方极乐世界的情况，我就按经书中描述的情况在心中想象，后来在禅定中我就观想这极乐世界，极乐世界的依正庄严就显现出来了，这也是影像。有些人不明白这个道理，就说是自己到极乐世界去了，纯是扯淡，比如一个宽敬法师，就写了一本《极乐世界游记》，因为他对净土的教理太外行，所以写得漏洞百出――极乐世界的人男女由一位菩萨控制，这是哪儿跟哪儿呀～～但有人就吃这一套儿，没办法的。我现在就想，我们一直给讲纯正的佛法，这确实是不行的！因为纯正的佛法与我们的三毒是不相应的，水火不容，我们的心已经被三毒占据了，清净的佛法被三毒所排斥。所以太圆满的教理不合适，我们只能讲一些相对来说不圆满的东西、不完善的东西。我是这么想的。世间是不圆满的，只适合用不圆满的教理，这样才对他的脾气，他才接受。可人们并不承认世间的不圆满――当然有时在口中还是承认的，只怕不是真诚的承认，比如，他说不圆满，你看他在离世的时候是不是也害怕？所以他并不真诚。因为他不承认世间的不圆满，所以你实际上拿了一个不圆满的理论来，你也必须得说你这是最圆满的，这样才能既满足了世人的虚荣心，又度化了他。也就是说，不能说真话，面对真话而不恐惧的人是不多的！宽敬法师绝对是有这样的情况、境界出现，不过出现境界后他给认错了，所以接着就出现了妄想。现在说，在三摩地里，你的心在影像上活动，在影像上思惟观察，这就叫“诸三摩地所行影像”。这个“诸三摩地”，这个“诸”就是指禅定有很多种，四禅八定可以，你甚至是首楞严大定也可以，都是心在影像上思惟。这时候，“彼与此心当言有异？当言无异？”“彼”是指影像，就是说，当你在禅定的时候，显现出来的那个影像和你能缘的心识，也就是能观察影像的忆念，应该说是有异呢？还是应该说无异？他们之间的关系是啥？有异无异就是指体性是一还是异。“异”就是各有各的体性，能分别的心和所分别的影像，是不是各有体性呢？实际上弥勒菩萨问的就是能取与所取的问题。

佛告慈氏：当言无异。

佛陀回答慈氏菩萨说“当言无异”，就是说三摩地所行影像与能缘影像的心念是无异的。

何以故？

为什么这么说呢？

由彼影像唯是识故；

因为三摩地里所缘的那个影像，他根本就是心，他就是能缘的分别心。

我说识所缘，唯识所现故。

上一句“由彼影像唯是识故”是总标，这下边儿的是解释。“我说识所缘”，“我”就是指佛。佛说“识所缘”，能分别的心在分别所缘的影像的时候，有能有所，有能分别、有所分别，能分别者是心，所分别者是境。但是，所缘的境，实际上是“唯识所现”，就是说，所缘的境界是识所变现的，他不能离识而有单独的体性可得。所以不能说它与识有异。在禅定中所分别的影像，比如说极乐世界，如果说是你分别不分别极乐世界它都在那里，那才是有异，但现在是，你入定观察了，极乐世界就显现，你没有入定观察，极乐世界就不显现。也就是说，八识显现出极乐世界，由第六识来分别，第六识一分别，可你分别的又是你第六识所变现的。所以说，“我说识所缘，唯识所现故”，识的所缘境，实际上是识自己变现出来的一个影像而已，根本就没有“义”。我们能不能不分别呢？不行，我们作不了主，我们的心就一直在跳呀跳。

世尊！若三摩地所行影像，即与此心无有异者，云何此心还取此心？

弥勒菩萨又问，说“若三摩地所行影像”，不用说了，修行人在禅定中心显现出影像来，“即与此心无有异者”，既然影像和能缘影像的心是没有别异的，书上是“即”，但我想应该是“既”。“云何此心还取此心？”为什么心能分别自己呢？这就是咱们常说的，“眼不自见”，眼睛只能看别人，不能看眼睛自己。还常说什么“水不洗水、尘不染尘”都是这个意思。“刀不自割”，刀子可以割别的东西，但不能把自己给割了。可是，现在心能认识心自己。它为什么特殊呢？

慈氏！无有少法能取少法，

有问题就提出来，既然提出来问题了，就得回答。问题是说：既然能缘心和所缘境没有别异，那么就不应该自己认识自己，既然能够自己认识自己，则必须有别异才行。看世尊怎么回答。“无有少法能取少法”，就是说，实际上任何事情都是自己在认识自己，根本就没有我去认识你、你去认识他的道理，都是自己认识自己。为什么这么说？当心去分别其它法的时候，比如说去认取色法吧，当然心法也行，道理是一样的，不过我们现在说心法认取色法。心法认识色法的时候，我们知道，心法也好、色法也罢，这都是有为法，有为法都是刹那生灭的，当心法去认识色法的时候，心剎那灭了，他根本就没有工夫去分别色法，他总不能说让我停下来分别一小会儿再灭，不能的，他要是一停，下一念就没法生起了，因果就断了，所以，它必须相续不断地生灭。这就怪了，心法要分别色法，可是心法根本就没有分别色法的时候，既然没有分别的时候，就是说，它根本就不可能有所分别。再看所分别的色法，所分别的色法也是在剎那生灭着，一下子就灭了，根本就不给心法一个分别它的机会，心法根本来不及分别色法，还没来得及分别这个色法，这个色法就灭了，也就是说，能分别的心法和所分别色法――所分别的可以是色法，也可以是心法，道理都一样――之间，根本就没有构成分别这样的关系，根本就是“法法不相及”的。所以佛说“无有少法能取少法”（根本就没有这个法去认取那个法这回事儿）。“无有少法能取少法”实质上就是说――两法根本是两回事儿，是没有办法发生作用的。也就是说，不相关的事情（“不相关”就是“两回事儿”的意思），是没有办法去发生作用的。

然即此心如是生时，即有如是影像显现。

说，我确实是分别了呀～～“此心如是生时”就是说，心识活动了。心识一活动，“即有如是影像显现”，活动的情况就用影像的形式表现出来了。我以前说过，我们的心识就是跳呀跳，它的跳呀跳是怎么个跳法呢？我们看不见摸不着，但是心识在跳呀跳的时候，他一点儿也不隐瞒自己的跳法，就用影像的形式把自己的跳表现出来，我们通过所表现出来的影像就知道心识当下在怎么跳。眼识的跳呀跳用色表现，色就是眼识的影像，耳识的跳呀跳用声表现，声就是耳识的影像……现在这一句长行就是说，心在跳的时候，就有影像显现出来，这不就是分别吗？

如质为缘还见本质。

“质”就是本质、本来面目。这是一个比喻，说，我们自己的真样子是什么样，自己看不见自己的脸的，所以说根本就不知道，但是，我们用了个镜子，我往那儿一站，镜子里就显现出我的样子，这就叫“如质为缘还见本质”。就是说，我们用自己的样子做本质为条件，在镜子里面又可以看见我们自己的样子。我们所看见的镜子里的那个样子，就是你原来那个本质的样子。也就是说，我们的心在分别境的时候，也还是从自己的心里面现出来种种的样子，然后我们自己来分别。离开了自己的心所现的种种影像，就没有别的了。“如质为缘还见本质”就表示你所缘取的事是从你自己的心里面出来的。这个比喻是很直接的。

而谓我今见于影像，

我们凡夫，说自己看见了一个影像。

及谓离质别有所见影像显现。

我们凡夫还说，有一个本质，有一个影像，有两个东西。也就是说，我们把能缘与所缘分开了。我们所犯的错误就是该分的不分，该合的不合。实际上是“如质为缘还见本质”，可我们非说是有一个本质，还有一个影像。

此心亦尔。

前边儿说的比喻，比喻说完了，说，我们这一念虚妄分别心――禅定里的人也是虚妄分别心――禅定里的人的“心所行影像”也是这道理。就是说是以心为条件认识心。

如是生时，相似有异所见影现。

“如是生时”，我们的分别心活动的时候，“相似有异所见影现”，好象有一个另外的影像显现出来，那只是好象而已，并不是真实情况。这一段儿话并不是《解深密经》原文，原文是这样的：“慈氏菩萨复白佛言。世尊。诸毘钵舍那三摩地所行影像。彼与此心当言有异当言无异。佛告慈氏菩萨曰。善男子。当言无异。何以故。由彼影像唯是识故。善男子。我说识所缘唯识所现故。世尊。若彼所行影像即与此心无有异者。云何此心还见此心。善男子。此中无有少法能见少法。然即此心如是生时。即有如是影像显现。善男子。如依善莹清净镜面。以质为缘还见本质。而谓我今见于影像。及谓离质别有所行影像显现。如是此心生时相似有异。三摩地所行影像显现……”这是原文。

即由此教理亦显现。

前面说“由教及理应可比知”，已经引了圣教，就该说道理了。

所以者何？

怎么回事儿呢？这就要开始讲道理了。

于定心中随所观见诸青瘀等所知影像，一切无别青瘀等事，但见自心。

“于定心中”，这个人有禅定工夫了，他在禅定里“随所观见”，他观见的什么呢？“诸青瘀等”，这是拿不净观来说的，其实观什么都行，观极乐世界的依正庄严也好。修不净观的人，他在野外看见了尸体，那个死尸已经青瘀脓烂了，污秽不堪，然后他在禅定中就观察这个青瘀脓烂的境况，这种影像也就是“所知影像”。在禅定中间你观察这个青瘀脓烂的影像，这个影像“无别青瘀等事”，就是说，它不是离开你的心而有的，不是心外之法，“但见自心”，你在禅定里面所观见的境界，就是看见你自己自心变现的事情，是你心作如是观而有的如是影像显现。

由此道理，菩萨于其一切识中，应可比知皆唯有识，无有境界。

根据这个道理，我们就可以知道，“菩萨于其一切识中”，“一切识”就是前头说的十一种识。菩萨在一切识中――注意，不单单是在禅定中，就是一切散乱心，那也是一样的。“应可比知”，你应该可以推知“唯识无义”，只有你内心的分别，根本就没有独立的境界。“皆唯有识，无有境界”就是“唯识无义”。

又于如是青瘀等中，非忆持识见所缘境，现前住故。

外人说，我还是不理解，我修不净观，我是因为在修不净观之前，就看见过死体污秽的情况，我记住了那个情况，我在禅定的时候，我只是在禅定中观察思惟，这怎么能是自己的心识的变现呢？这是我记住了外头的境界而已。“又于如是青瘀等中，非忆持识见所缘境”，说，不对！这个青瘀等相（青瘀等相就是指尸体的污秽情况），不是那个记忆中所见的境界，记忆中所见的境界和禅定里的境界是不同的。有什么不同呢？“现前住故”，就是说，禅定里的这个青瘀、脓烂之类情况，显现在禅定里是非常分明、非常稳定的。而我们记忆中的境界，那是不稳定、不明显的。“现前”就是很明白地、很分明地出现，“住”是稳定的意思。则“现前住故”就是说，境界很分明地出现在禅定中，也就是说，在禅定中它是很清楚地显现出来了，一点儿也不昏昧。妙老举了个例子，说象灯一样，灯要是不亮，则境界显现得就不分明，灯要是很亮，境界显现得就很分明。我们一般散乱心的记忆力不分明、不清楚，但禅定里出现的境界是很清楚、很稳定的，它和记忆力不同。

闻思所成二忆持识，亦以过去为所缘故，所现影像得成唯识。

这是拿散乱心、没得禅定的人来做比较。“闻思所成”，这时候还没得禅定，还是靠的闻所成慧和思所成慧，这时你的心还是散乱的，他的心识要显现出一件事是要凭记忆力的，这个“忆持识”就是说凭忆念摄持，识才能显现出境界来。“亦以过去为所缘故”，“忆持识”也得以过去的情况做所缘境，它缘的是过去了的境界。现在在心里面“所现影像”，这所现的影像还是以过去的所缘境为条件而现出来的，现影像是现在现影像，而不是过去。既然是现在，那还得是唯心所现，你以前看见过的情况，熏习到了心里，再观察思惟的时候，这就再现出来了。“得成唯识”，唯识无义的道理还是可以成立的。

由此比量，菩萨虽未得真智觉，于唯识中应可比知。

得真智觉的圣人，凭现量知道唯识无义，我们这些没得真智觉者，“由教及理应可比知”。我们就是“由此比量”，就是根据刚才说的圣教量以及比量推度出来，确实应该是唯识无义的。刚才已经从散乱心中、禅定中等分析了唯识无义的道理。

如是已说种种诸识，如梦等喻，即于此中眼识等识可成唯识，眼等诸识既是有色，亦唯有识云何可见？

前边儿已经用比喻、用圣教量、比量来说过了，说十一种识都是唯识无义的。但是呢，还有人产生疑问。“即于此中眼识等识”，说，十八界中，眼识、耳识、鼻识、舌识、身识、意识，它们唯识无义的道理还好理解，可是“眼等诸识既是有色，亦唯有识云何可见？”可是这五根――眼根、耳根、鼻根、舌根、身根，以及五尘――色、声、香、味、触，这都是色法，你无著说色法“亦唯有识”，也是唯识无义的，它们也是识，这我想不通。它们既然是识，识就是心法，色法也成心法了，这还得了～～这一个问题在印顺法师、妙境法师的解释中都说叫“有色非识疑”。看无著论师怎么回答。

此亦如前由教及理。

说，这个疑问，你还是把我前边儿说的圣教量、比量再琢磨琢磨就知道了，我已经说的很清楚了。实际上由这个“有色”的问题引出了下边儿很重要的问题。

若此诸识亦体是识，何故乃似色性显现，一类坚住，相续而转？

什么叫色法？有质碍！而心法是无质碍的。色法的形相坚住，这怎么能说它是识呢？“若此诸识亦体是识”，就是说，如果说五根（净色根）、五尘都是识，“何故乃似色性显现？”识是无形无象的、不稳定的，既然五根、五尘都是识，可为什么它们表现出有质碍、稳定这样的色法的状态呢？为什么它们表现得这么象色法呢？“似色性”就是类似于色法的性质。“一类坚住，相似而转”，这是色法的状态。“坚住”就是稳定。

与颠倒等诸杂染法为依处故；

无著论师回答了，但无著论师的回答，不是直接的回答，而是从迷悟的根本这儿回答的，是从我们凡夫迷惑颠倒的情况上回答的。我们知道，我们是凡夫，所以我们的认识是错误的，我们最大的错误就在于认为色法坚住，认为它是离心实有的。这是我们无始以来的虚妄熏习所致，我们的妄心一起，自然就现起似色的义相，这是根本的错误。这句长行是说，阿赖耶识无始以来的熏习，熏成种子，其中就有色法种子，当色法种子成为现行的时候，在我们凡夫看来，这色法（包括内根，眼根、耳根、鼻根、舌根、身根，以及外尘，色、声、香、味、触等）是我们凡夫的颠倒错误的依处，要是没有这色法，我们也就不会在这色法上产生错误的认识、颠倒的认识――这色法是离心独存的。这色法是我们的错误认识的依止处。这句长行把我们颠倒妄想的依止处说成了所缘境。颠倒想就是指所缘虑的一切的境界它本不是真实的，但是它表现出来一付真实的面貌，让我们认为它就是真实的。“一类坚住，相续而转”的色法不是真实的，我们误认为他是真实的。不过在一般经论上说是常、乐、我、净四颠倒。但我们要知道，这“一类坚住，相续而转”的一切色法，是我们常、乐、我、净四颠倒的依止处。这句长行中还有一个“等诸杂染法”，就是指前边儿说过的烦恼杂染、业杂染、生杂染。“与颠倒等诸杂染法”的“颠倒”就是指烦恼杂染说的，由烦恼杂染引出了业杂染，由业杂染引出了生杂染，这就是果报了。这三种杂染，实际上就是依“一类坚住，相续而转”的境界而有的。这一个可以参考《维摩诘经．观众生品》，里边儿文殊菩萨问维摩诘居士，“善不善孰为本？”就是我们做善做恶，谁是根本？维摩诘居士的回答就是：“身为本”！这身就是身体，是色法。色法实际上也是依他起的（只要是依他起则其本质就是识），也是识的种子变现的，但它因为有“一类坚住、相续而转”的特点，所以很容易被误会。

若不尔者，于非义中起义颠倒，应不得有。

“若不尔者”是说，色法是“一类坚住，相续而转”的，要是色法不“一类坚住，相续而转”了，“于非义中起义颠倒”，把没有义认成有义这样的颠倒见解。“非义”就是无所有、非真实，无所有和非真实是两回事儿，不要搞错了。“应不得有”，我们不会有这样的错误见解。这一句就是说，如果色法没有“一类坚住，相续而转”的特点儿，我们就不会有错误见解。

此若无者，烦恼所知二障杂染应不得有。

要是我们没有把“没有义认成有义”这样的错误见解，那么烦恼障、所知障也就没有了。这真是大实话，要是没有错误见解，当然就是正确的了。这个“烦恼所知二障杂染”的“杂染”就是指烦恼障、所知障。

此若无者，诸清净法亦应无有。

烦恼障、所知障这二种杂染法要是没有的话，我们就不用费心费力来修学佛法了，当然这诸清净法也不用了。因为清净法就是来对治烦恼障、所知障的。

是故诸识应如是转。

无著论师分析了这么半天，实际上还是要说，眼根、耳根、鼻根、舌根、身根，以及色、声、香、味、触五尘，它们仍然是“一类坚住，相续而转”的。这是无著论师从凡夫的颠倒迷惑上来解释“诸识（即十一种识）亦体是识”。

此中有颂：乱相及乱体，应许为色识，及与非色识，若无余亦无。

关于这个颂子我把别人的本子给说一下，对照一下也好。真谛是译为“乱因及乱体、色识无色识。若前识不有，后识不得生。”笈多译本是“乱因及乱体，所谓色识体、及非色识体。前无后亦无。”佛陀扇多译本是“妄念及妄想，说为色诸记、及无非色记。有彼非余者。”韩老给又译了一下，是“错乱因与错乱体，许为诸色了别识，与非色诸了别识。若色无，非色亦无。”几个本子对照一下可以帮助我们理解，我们看每一个译本其实就等于不同的法师给我们又讲了一遍这典籍，而且这法师是很有水平的法师，可不是象现在的那些半吊子法师。“乱相”就是颠倒错乱的境界，也就是刚才说的“于非义中起义颠倒”，它本来是虚妄的，但它不老实，偏偏显出一付真实的样子。注意，我说过的，我们的心识本就是跳呀跳，但它在跳呀跳的时候一点儿也不隐瞒自己的跳法，用影像的形式把自己的跳表现出来，我们通过所表现出来的影像就知道心识当下在怎么跳。眼识的跳呀跳用色表现，色就是眼识的影像，耳识的跳呀跳用声表现，声就是耳识的影像……可是，心识很狡猾，他是把自己的跳法儿用一个颠倒的影像来显示的，显反了，使得我们产生了错误的认识。当然，这责任应该由末那来负，因为末那被它身边的四个奸贼蒙蔽了。所以使得我们在认取心识的跳法时老弄反。这就出现了“乱相”。其他的译本多是“乱因”，要是乱因的话，则是说，我们的虚妄分别是以错乱的境界、颠倒的境界为因而产生的。“乱体”，颠倒错乱的本质是啥？是虚妄分别心！他是颠倒错乱的根本。“应许为色识，及与非色识”，“乱相”我们应该说它是“色识”，有质碍的色法其实也是阿赖耶识的种子所变现的，所以称之为识。“乱体”我们应该说它是“非色识”。乱体是没有质碍的、没有形相的，它是非色识。一个是“色识”，一个是“非色识”，一个是“乱相”，一个是“乱体”，这句“若无余亦无”是说色识与非色识，就是乱相和乱体之间的关系的。它们是什么关系呢？“若无余亦无”，就是说，要是没有了色识，那么非色识也就没有了；要是没有非色识，色识也就没有了，他们互相依止，一荣俱荣、一损俱损。只要我们的非色识、虚妄分别心一活动，就出“乱相”了，你一见有“乱相”，就知道是虚妄分别心在活动。

何故身，身者，受者识，所受识，能受识，于一切身中俱有和合转？

身、身者、受者识、所受识、能受识等这些识，为什么它们要合在一起呢？它们要活动的时候大家一起出力，它们为什么不分开？这“身、身者、受者识、所受识、能受识”其实就是十八界，也就是说，我们不要十八界，我们只要十三界、十五界行不行？众生生活在十八界中，我不高兴了，我想生活在十一界中，不行吗？说，不行！也就是说，众生有根、尘、识，能不能把有些给取掉？不行！

能圆满生受用所显故。

十八界是众生的一个果报，这果报就是对你以前所造的善恶业因的酬答，你造善就给好的十八界果报，让你受乐，你造恶就给不好的十八界果报，让你受苦。“能圆满生”是说，六根、六境、六识都俱足了，你才能圆满受用你的苦乐果报。比如说吧，你少舌根，你就无法享受味的果报……所以，一定得六根、六尘、六识三方面都俱足。生和“受用”是分着的。“所显故”是说，为了显示能圆满生及圆满受用的道理，所以一定得是十八界俱有和合转，必须这样。当然了，有的人不是六根全俱，但大体是根、尘、识都有。有的人是瞎子，有的人是聋子等，这情况有的。更别说无色界众生了。

何故如说世等诸识差别而转？

既然十八界可以括完一切法，为什么还要其他的识呢？十八界就是十一种识的前五种识，也就是说，无著论师你只要立五种识就可以了，为什么要立十一种识呢？后边儿又立了世识、数识、处识、言说识、自他差别识、善趣恶趣死生识，有必要吗？不要行不行？下边儿把六种识分着说，先说为什么要立世识。

无始时来生死流转无断绝故；

说，关于世识，因为无始以来众生就在生死里流转，从来就没有间断过，这就有了过去、现在、未来，对过去、现在、未来的分别，就是“世识”，不建立“世识”怎么能表述得清呢？

诸有情界无数量故；

这是说数识。“数”也是识的分别，重点是“无数量故”，“无数”就是不知道到底有多少，不能够用一个具体的数字描述。“量”是计量，把数目计量出来。数目实际上是个单位问题，单位也就是分段儿，既然能分段儿，那就是能分清左右前后，但实际上它们是相待的、假安立的，我说这儿是左，但我一换这儿又成右了。“诸有情界”，一切有情都这样，爱划段儿、爱分界，这就是它能划段儿，能就是识。注意：我说，“能”就是“识”。为了表述清楚划的段儿，就得建立数识。

诸器世界无数量故；

这是说处识。“器世界”常说的是“器世间”，就是所居住的地方。有正报的流转生死，就得有所居住的地方。“诸器世界”就是说，每一个有情实际上受用的是自己的业报所现的器世界，只不过各个有情的所现是互摄的，如灯灯互照。刚才说有情各是各，器世界当然也各是各，世界与世界不一样，为了表述清楚这个，就得建立处识。

诸所作事展转言说无数量故；

为啥要建立言说识？因为众生的心不能停下来，他要活动，要做种种事。做种种事就要展转地传达他的思想，这就有语言了，语言各不相同，为了表述清楚，所以要建立“言说识”。

各别摄取受用差别无数量故；

为啥要建立自他差别识？“各别摄取受用”，每一个众生都是要成就他自己的事情，就是业力不同，就有各个不同的果报。在20页中就说到了，这自他差别识，是由我见熏习种子。那么，每个众生的我见，成就自己的正报体，自己的就是自己的，别人的就是别人的，互不混淆，无量差别，为了表述清楚这个，所以要建立“自他差别识”。长行中有个“摄取”，有个“受用”，这是不一样的，摄取是把信息集中到我这儿，受用是指摄取的东西我来使用。

诸爱非爱业果异熟受用差别无数量故，所受生死种种差别无数量故。

这是善趣恶趣死生识。“诸爱非爱业”，“爱业”是可爱业，就是善业，造了善业就得到可爱的异熟果报。“非爱业”是恶业，造了恶业就得到非可爱的异熟果报。“所受生死种种差别无数量故”，因为业果的不同，所以受报也不同，就有了死生的种种差别，这差别无量无边，比如有的长寿，有的短寿，有的圆满，有的不圆满等等，为了表述清楚这个，所以要建立“善趣恶趣死生识”。这样，世识、数识、处识、言说识、自他差别识、善趣恶趣死生识，都还是得建立的。就是说，虽然众生都具十八界，但十八界有这么多的不同，所以还得有这些识。不过这些识还都是十八界，只是十八界的不同分位而已。

复次，云何安立如是诸识成唯识性？

前面把一切法分成十一类，说十一类都是识，离开了识就无义可得，这样就成立了唯识无义的理论。下边儿呢，是用了另外的方式来成立唯识性的。

略由三相：一、由唯识，无有义故；二、由二性，有相有见二识别故；三、由种种，种种行相而生起故。

“略由三相”，就是说，我要简单地从三个方面来成立诸识都是唯识无义的。“一、由唯识，无有义故”，一切法都是我们心识的虚妄分别，根本就没有实义。这是唯识的根本正义。“由二性，有相有见”。说，虽然只有识，但当它活动起来的时候，它有两种表现，就是“有相有见”，也就是一种是相识，一种见识。我们通常是把见识叫能分别，把相识叫所分别。“二性”就是相和见了。“三、由种种，种种行相而生起故”，说，心识能够现起种种的行相，所以世界才如此的五彩缤纷。就是说，能分别和所分别一交涉，也就是说，相识、见识一交涉，各式各样的情形都出现了，这就有了很多的差别。我们就用这三相、通过这三个方面来成立“诸识成唯识性”。这三相的第一相是根本，第二相和第三相不过是对第一相的细化――第一相说诸法唯识，在识现起的时候，有相、见二性，这就是第二相，在相、见二性的交涉中，有种种的行相，这是第三相。底下再详细说。

所以者何？

要开始解释了。

此一切识无有义故，得成唯识。

对第一相的说明。“一切识”就是十一识，“无有义故”，十一识所缘的境界都不是实在的。“得成唯识”，这就可以成立唯识无义的道理。“义”有二种说法，一个是境界叫义，一个是道理叫义，但其本质是我执、法执。这是“由唯识，无有义故”这一相。

有相见故，得成二种：

第二相是“由二性，有相有见二识别故”，解释说，“有相见故，得成二种”，有相识、见识，这就成了二种情况。这个有相有见就是相分见分。

若眼等识，以色等识为相，以眼识识为见；乃至以身识识为见；

对这“由二性，有相有见二识别故”还得进一步说明，因为前五识和第六意识的情况稍微有点儿不同。“若眼等识”，指眼识、耳识、鼻识、舌识、身识。这前五识的有相有见是怎么回事儿呢？“以色等识为相”，就是说，眼识以色境为所缘行相，不过色境也是识，所以长行中用了“色识”。耳识以声境为所缘行相，声境也是识，叫声识。鼻、舌、身都是这样的。“以眼识识为见”，眼识的识是“有见”。眼识一活动，就有所缘行相，这所缘行相就是“有相”，眼识识就是“有见”。耳识的情况是，耳识识为见，声音为他的所缘相。相应的，鼻识、舌识、身识情况也是这样。长行中有一个“眼识识”、“身识识”，这是咋回事儿呢？在韩老的译本中表述得比较清楚。韩老说唯识是唯了别识，把唯识译成唯了别识，这有什么不同呢？识有相分、见分，按韩老的说法，要是“唯识”的话，比如说眼识，就是指辨别色法构成了眼识，这只包括见分，而不包括相分，要是译成“唯了别识”的话，则见分、相分都包括了，是整个的识，而唯识实际上不是整个识，只是识的见分部分。这样一来，咱们就知道了，所谓“眼识识”，前边儿是“眼识”这两个字儿，其实只是眼识的见分部分，而加上后一个“识”字儿组成“眼识识”的时候，这就成了整个的识，包括见分、相分。“身识识”也是这个道理。

若意识，以一切眼为最初，法为最后诸识为相，以意识识为见。

意识和前五识有点儿不一样。意识是“以一切眼为最初，法为最后诸识为相”，就是识，第六意识把一切所缘境都包括在内了。这里举了“眼为最初，法为最后”，“眼为最初”就包括眼、耳、鼻、舌、身、意，“法为最后”包括色、声、香、味、触、法，这些都是意识的所缘相、相分、“有相”。“以意识识为见”，“意识识”是它的见识。“意识识”给前边儿说的“眼识识”、“身识识”道理是一样的。

由此意识有分别故，似一切识而生起故。

这是第三相，“由种种”，说的是意识。眼识只能以色为相，眼识识为见，这局限性很大，耳识、鼻识、舌识、身识都是一样的，局限性很大。这前五识彼此是不相通容的，眼识只能缘色而不能缘声，耳识只能缘声而不能缘色……而意识不是，意识把色、声、香、味、触、法、眼根、耳根、鼻根、舌根、身根等一切都作为所缘，为啥这样呢？“由此意识有分别故”，因为第六意识是有分别的，但前五识是没有分别的，当然了，识就是跳呀跳，它当然得分别，没有分别的能力它就不是识。不过分别有自性分别、随念分别、计度分别，前五识只有自性分别，它只有自性分别，我们就叫它无分别。“似一切识而生起故”，第六意识的分别能力，它可以表现得象眼识现出色境一样，也可以表现得象耳识现出声境一样等等，意识有这个能力。去年下半年学生们的考试，我就没有给出题目，我是测试他们的心念程度。我们两个对坐，为了方便，我让他们默念弥勒菩萨名号，这个其实是念什么名号都可以，不一定非要弥勒名号。然后我根据测出的来给他们打分。后来他们问我，我告诉他们，其实很简单：我先关闭根，不看、不听，净下来，立马他们的心念清晰程度就在我这儿显现出来了，也就是我觉察到了。他们有些人很紧张，有些人相对来说轻松一些。有些是在我这儿现出色境，有些是在我这儿现出声境，不过色境为多。我觉察到有些人的佛是清楚的，而有些不清楚，有些是象一幅画贴着一样，有些则画是晃动的，有些的声境是连续的，但有些是颤抖的……其实这就是我以他们的心识为疏所缘缘在我的心识上现出境界。这样考试还好的。意识是有这个能力的。眼识缘色，耳识缘声等等，意识是可以缘色，也可以缘声，香、味也都可以缘。这就叫“似一切识而生起故”――他能似眼识（即好象是眼识在起作用），也能似耳识，鼻识、舌识、身识都可以。分别三相成立唯识：由唯识、由二性、由种种。意识是具足三相的：它由唯识的义、由二性有相有见的义，由种种义（就是种种作用）。前五识，比如眼识，虽然没有分别，但他所缘的色也有种种义，青、黄、赤、白、长、短、方、圆等都能缘，第六意识的种种义就很明显了。

此中有颂：唯识二种种，观者意能入，由悟入唯心，彼亦能伏离。

这里有一个颂子，这个颂子就是对前边儿刚才说的三相的一个总结。“唯识二种种”，这是标出三相。“唯识”是第一相“由唯识”，“二”是第二相“由二性”，“种种”是第三相“由种种”。“观者意能入”，“观者”就是指修行者，修止观的行者。修行者就观察这三相成立唯识的意趣，“能入”，能够悟入唯识无义的道理，能悟入一切法本身都不可得，只是一个虚妄的分别心而已。就是说修行者只要观这三相就可以悟到唯识无义。“由悟入唯心”，由于这修行者，领悟了一切法只是一心，离开了这心就无法可得。他契入了这唯心无境，“彼亦能伏离”，契入唯识无义之后，再进一步就能把分别心也伏灭了、远离了。

又于此中，有一类师说一意识，彼彼依转得彼彼名，

刚才是用六识说的观点儿来解释“诸识成唯识性”，现在用一识说的观点儿来解释唯识的道理的。“又于此中，有一类师说一意识”，有些唯识行者说只有意识，就是刻意强调意识。他们说，“彼彼依转得彼彼名”，就是说，我们平常说的眼识，其实是意识依眼根进行的分别、认识。要是意识依耳根进行分别、认识，这就是我们平常说的耳识。意识还可以依鼻根、舌根、身根进行分别、认识，意识依鼻根进行分别就是我们平常说的鼻识，意识依舌根进行分别，就是我们平常说的舌识，意识依身根进行分别，就是我们平常说的身识。“彼彼依转”就是意识依眼根而转、依耳根而转、依鼻根而转、依舌根而转、依身根而转等，这个“转”是生起，就是意识生起活动。“得彼彼名”，实际上的意识，但我们把依眼根而起的活动叫眼识，依耳根而起的意识活动叫耳识，依鼻根而起的意识活动叫鼻识，依舌根而起的意识活动叫舌识，依身根而起的意识活动叫身识等。这儿注意一下，一类师是说，前五识的作用第六识都可以代替，我们可不要当成前五识根本没有，一类师是强调意识的作用。一类师或者叫一意识师，他是说五识不能离开意识而独有。印顺法师说一意识师是认为五识只是意识多方面的活动。他说眼识、耳识、鼻识、舌识、身识等，其实还是意识，他还举了一个例子，说比如有一个人，他深研学问我们叫他学者，他又善于绘画，我们又叫他为画家等，他要是再善于写诗，我们不妨就叫他诗人……

如意思业名身语业。

这是无著论师举的例子。“如意思业”，“意”是意识，“思”是思心所。我们有三业的不同，身业、语业、意业。意业就是思，我们思惟观察一个境界而作出决定，就叫意业。意业发动到身上的活动就叫身业。意业发动语言的活动，就叫语业。其实呢，还是意业，所以，身业、语业、意业从本质上来说，只是意业。前六识也是这样，从本质上说，是意识。

又于一切所依转时，似种种相二影像转：谓唯义影像，及分别影像。

关于这一句长行，二十三页就是这样，在无性释中，也是这样，在385页。但在世亲释中所引的论文给这儿差一个字儿，是“谓唯似义影像，及分别影像”，多一个“似”字，在148页。这一句长行是说啥哩。首先是有一个疑问，世亲释中说，“或有难言，眼等诸根无有分别，是故意识依彼转时，应无分别。如染污意为杂染依令杂染转，此亦应尔。”啥意思？就是说，前五识是依五净色根的，眼识依止眼根、耳识依止耳根、鼻识依止鼻根、舌识依止舌根、身识依止身根，可是我们知道，五净色根是无分别的，这就奇怪了。意识是依意根的，意根就是末那识，在《八识规矩颂》中，说到眼识现行的条件时，“九缘八七好相邻”，其中把所需的第六意识叫分别依，把第八阿赖耶识叫根本依，而其中的第七识、末那识，给叫成染净依。这末那识就是染污的，当然了，实际上它是无记的，不过是有覆无记。因为意识所依的根――末那识是染污的，不管是染污的也好，清净的也好，这总是分别吧～～因为意识所依的根是有分别的，所以意识就是有分别的。前五识所依的五净色根是无分别的，所以前五识也没有分别。意识所依的根是有分别的，所以意识也是有分别的，现在你一类师（一意识师）说前五识实际上是意识的分别作用而已――就是说，意识的作用宽，它就把自己的作用给分了块儿，把这一块儿叫眼识，把那一块儿叫耳识等等。这明明是一个有分别一个无分别呀？“有分别的”分下来之后成了无分别，这可能吗？无性释中间是这么说的，“或谓，若尔，如是意识应无分别，所依钝故。如眼等识。夫能依者，皆顺所依。如染污意为杂染依，意识俱转应成杂染。”就是说，要是按这样说的话，意识应该是无分别，为啥？因为你一类师说眼识、耳识、鼻识、舌识、身识实际上都是意识的分位，而眼识、耳识、鼻识、舌识、身识所依的眼根、耳根、鼻根、舌根、身根（都指净色根）都是无分别的。能依者要随顺所依，你不能所依无分别能依却有分别，这是不可能的。如果说意识以染污意（末那识）为杂染依，意识就应该是杂染的，有分别的。这样说复杂了点儿，实际上用几句话就可以说清楚：要是前五识是意识的分位的话，五净色根也就成意识的所依了，那么意识就成无分别了。注意有分别、无分别，分别有自性分别、随念分别、计度分别，所谓无分别就是指只有自性分别！既然有这样一个问题，就得回答，无著论师的这一句长行就是回答这个问题的。“又于一切所依转时”，就是说，意识以一切所依，既依五根，又依末那，当意识以五净色根为所依生起活动的时候（即意识向外攀缘的时候），“转”就是生起活动。当意识以五净色根为所依活动时，则会“似种种相二影像转”，“似种种相二影像转”就是说意识可以表现出种种的分别，当它以五净色根为所依生起活动的时候，就分别出各式各样的形像。长行中说是“二影像”，“二影像”是啥？“谓唯义影像，及分别影像”，“义影像”就是所分别的境界，“分别影像”就是“分别义影像者”。简单点儿说，就是一个是相分，一个是见分。

又一切处亦似所触影像而转，有色界中，即此意识依止身故，如余色根依止于身。

意识向外面攀缘的时候，就是前五识。上一句这么说。它要是向内攀缘呢？就是这一句长行要说的。“又一切处亦似所触影像而转”，“一切处”就是指欲界也好、色界也罢。说，意识还可以现出“似所触”的影像，当然了，是内现。前五识中身识是触，这儿意识现出的“似所触”影像可不是身识的所触，比如在禅定的时候，前五识不活动，当然包括身识，身识也不动，但感受还是有的，这感受就是意识的，也就是说，意识也似有觉受所触的影像生起。这个“亦似所触影像而转”就说的是禅定中的情况。在没有禅定的时候，身上感觉到痛呀痒呀的是身识，一入定，身识不活动了，但还会有轻安等，这就是意识。就是说，意识在禅定中，也还能生起象触到的境界认识活动。也就是说，禅定中第六意识取代了身识的作用，他也能感觉到，有这个作用。为什么在禅定中身识不活动了，意识能够取代身识呢？“有色界中，即此意识依止身故”，“有色界”就是欲界、色界，这二界都有色法、色身。在欲界、色界中，这个意识得以身根为依止，所以身所感受到的事情，意识都能感受到。“如余色根依止于身”，意识以身根为依止，就象眼根、耳根、鼻根、舌根都得依止身体一样，要是没有身体，你这眼根、耳根、鼻根、舌根长在哪儿呢？再说了，你要是身体健康，你前五识、前五根都好使；要是身体不好，那么前五识、前五根都要受影响。意识依止身根也有这样的关系，危险了都不对劲儿，要是好了，大家都很好。其实这就是说阿陀那识能执受根身。总之，一类师、一意识师是说，意识要是向外攀缘，就有了前五识，要是向内攀缘，就执受根身，就成了阿赖耶识。

此中有颂：

一意识师说，我的理论也不是瞎编的，也是有经典依据的。他引了三处圣教量，这个“此中有颂”是举出了《法句经》中的一个颂子。

若远行、独行 无身寐于窟

调此难调心 我说真梵志

“若远行、独行”，“远行”就是说，心识可以在任何时候思惟任何地方的情况，一点儿也不受限制，就是我们常说的，管得住人管不住心。这个“远行”就是指意识的活动范围很广大。“独行”是指只有意识可以在任何时候观察任何地方的情况，什么眼识、耳识、鼻识等都不行，在意识要去思惟观察很远的情况时，它只能自己一个儿去思惟，找不到可以与他同行的伴侣。“无身寐于窟”，“无身”是说意识只是认识的作用，它没有地、水、火、风的形相，也就是说，意识是无形无象的。“窟”是指四大构成的身体。“寐于窟”是指意识隐藏身体里，以身为依止处。“调此难调心，我说真梵志”，如果你能够把这个很难调伏的心给调伏了（意识相应的心所有很多烦恼法），那你就是一个真正的修行人。“我说真梵志”的“我说”，是指佛说，“梵志”就是清净的修行人。

又如经言：如是五根所行境界，意各能受，意为彼依。

印顺法师说这是引的《中阿含经》，不过在世亲释、无性释中都没有说是引的什么经。“如是五根所行境界”，就是眼根、耳根、鼻根、舌根、身根所活动的境界，“意各能受”，眼根在色上的活动，耳根在声上的活动等等，第六意识通通能够领受，就是说意识能够统一所有心识的活动。“意为彼依”，前五识去认取境界的时候，意识是他们的所依、后盾，要是意识不作它们的后盾了，前五识就不能活动了。这就是说，前五识是意识的分位。

又如所说十二处中，说六识身皆名意处。

说，好多经中都说到十二处，十二处就是外六处色、声、香、味、触、法和内六处眼、耳、鼻、舌、身、意。“十二处中，说六识身皆名意处”，我们知道，十二处加上六识就是十八界。这儿为什么没有六识？“六识身皆名意处”，说，六识都被包含在内六处的意处里了，都统一在意处里了。这就表示，不是有六个识，就是一意识。意处发出一个意识，意识就是六识，统一了六识。这是引佛陀的圣言量来成立一意识的观点。

若处安立阿赖耶识识为义识，应知此中余一切识是其相识，若意识识及所依止是其见识。

前边儿是举了两类观点，有的是多识说，有的是一识说，但不管多识说也好、一识说也罢，都可以成立唯识无义。前边儿是在转识上成立唯识无义，下边儿要是本识上成立唯识无义。“若处安立阿赖耶识识为义识”，如果一个地方安立了阿赖耶识识为义识。“义识”的“义”，无性释中说是因，在387页中有，“义是因义”。所以，这个“若处安立阿赖耶识识为义识”就是说，我们把阿赖耶识当成因识，它是一切法成立的因，就是因为它有种子。无著论师实际上是说它是相识、见识的因，也就是相分、见分的因，哪是相识、哪是见识下边儿说。“应知此中余一切识是其相识”，识共有十一种，这个余一切识包括身识（根、色身）、彼所受识（六尘、器世间）、世识、数识、处识、言说识、自他差别识、善趣恶趣死生识等，这是阿赖耶识的相，就是“相识”。“若意识识及所依止”，这个“意识识”就是第六意识，“及所依止”是指第六意识所依的根――末那识，“是其见识”，六识、七识是阿赖耶识的“见识”。

由彼相识是此见识生缘相故，似义现时能作见识生依止事。

这句话是解释相识的意思的。“由彼相识是此见识生缘相故”，相识就是色、声、香、味、触和眼、耳、鼻、舌、身等。它为啥叫相识？“是此见识生缘相故”，因为它们是六识和末那识（即见识）生起的所缘相。“相”就是所缘的境界。就是说，它们是被六识认取的。“似义现时能作见识生依止事”，当“似义”显现的时候（似义显现是从阿赖耶识的种子现出来）它可以作六识、七识生起的依止，就是说，“相”还有依止的意思，要是没有似义之相（即色、声、香、味、触和眼、耳、鼻、舌、身等），六识、七识也不能活动。这样一来，咱就明白了，阿赖耶识里的种子显现似义境界，显现出来以后又为心识自己所认识。我以前给说过自变而缘，就是这个意思。识自己变现出影像来自己认取，这样才能构成生命的相续。见识得依止相识。这一句话中没有解释见识，见识是了别，来了别这个所缘境界的。

如是名为安立诸识成唯识性。

这样就安立诸识成立了唯识无义的道理。就是说十一识都是唯识性。

诸义现前分明显现而非是有，云何可知？

这是提出了问题，“诸义现前分明显现”。“诸义”就是一切境界。说，我们面前的这些境界是如此的明了，这桌子我看得清清楚楚，这声音我听得明明白白，如此分明的现象，“而非是有，云何可知？”这么样清楚明了的境界，你唯识家非说无义，这到底是怎么回事儿？

如世尊言：若诸菩萨成就四法，能随悟入一切唯识都无有义。

佛陀说过，菩萨经过努力的修行，成就了四法，他就能觉悟到一切唯识的道理，觉悟到唯识无义的道理。所成就的四法是什么呢？

一者、成就相违识相智，如饿鬼旁生及诸天人，同于一事，见彼所识有差别故。

第一法就是“相违识相智”。“相违”就是互相违反，有你无我，有我无你，就是水火不容。“识”就是相违者的识。“相”，识一活动，立马就表现出一个相，也就是境界。“智”知道相违的相其实是相违者的识所变现出来的幻相，是不实在的，认清这个就是“智”。成就了这相违识相智，你就知道唯识无义的道理了。“如饿鬼旁生及诸天人”，比如说有一条河，人看见河里流的是水，饿鬼看见是脓血，天人看见是琉璃，等等，不同的众生所见都不相同。这就是说，我们各自认取到的都是我们自己所见的境界，这个就叫“相违识”。“同于一事，见彼所识有差别故”，“事”就是境界。不同的众生，对于同一个境界上产生的认识不一样，差别很大。这是为什么？就是因为这境界不是真实的，我们看见的流水不是真实的，诸天看见的琉璃也不真实，饿鬼看见的脓血也不真实……都是自己的业力所变现的、自己内心的种子所变现的。唯识所变的境界都不真实，也互不障碍。要是真实的话，离开我们的心有水的体性，离开天人的心有琉璃的体性，离开饿鬼的心有脓血的体性，那就要互相妨碍了。正因为不真实，根本就没有水的体性、琉璃的体性、脓血的体性，所以这个境界对众生的所见都无妨碍，这就证明了“唯识无义”。认清了只是自己内心的分别，而那件事并不真实，所以这叫“相违识相智”。这一法就是说同一件事各有自己的不同认识、看法儿。

二者、成就无所缘识现可得智，如过去未来梦影缘中有所得故。

这是第二法“无所缘识现可得智”。“无所缘”就是说识所缘的境界根本就没有。这个“无所缘识现可得智”是说，外边儿的境界是没有的，但我们的心识还是照样可以生起活动。外面的境界虽然没有，但我们的识还是明了的。比如说过去的事情，我们知道，事情只要是已经过去了，也就没有了，但是它还能够在我们的心识上显现，也就是可以忆念它，就象在眼前一样。过去的事情已经不存在了就成“无所缘”了，但还是“识现可得”。从这儿也可以知道“唯识无义”。对于未来的事儿也是这样，未来的事儿还没有产生，是无所缘，但我们也可以在心识之上显现出来，就是“识现可得”。过去的事儿、未来的事儿都象梦一样、象影一样的不真实，但是“无所缘、识现可得”，不真实也能在我们的心上面产生活动。境界都不实在，但都可以使我们的心识产生种种的分别的，这只是内心的分别，这样我们也可以觉悟到“唯识无义”。这是“成就无所缘识现可得智”。

三者、成就应离功用无颠倒智，如有义中能缘义识应无颠倒，不由功用知真实故。

第三法是“应离功用无颠倒智”，所谓“颠倒”，就是错误。“无颠倒”就是说，我们的在观察所缘境的时候不产生错误的见解。我们现在都产生错误见解，只有圣者才不产生错误见解，圣者的智才是“无颠倒智”，圣人得这无颠倒智，是经过长时期的学修才成就的，既然要经过长时期的学修，这就是要有功用，要由功用而成就无颠倒智。我们凡夫经过长时期的学修，也可以成就无颠倒智。我们成就了无颠倒智之后，学而无学、修而无修了，不需要再用功了（要用功就刻意了，这儿的不用功是不刻意学修自然在学修的意思），这就是“离功用无颠倒智”。“离功用”就是不用费事了。“如有义中”，要是我们认为一切义都有真实性的话，“能缘义识”――能缘虑一切义的这个分别心，分别心就是我们的执著心。这个执著心所执著的境界都是对的，“应无颠倒”，我们没有错误，我们是对的。那么，“不由功用知真实故”，根本就用不着修学了，因为我们的智慧本就是无颠倒智，那么我们就应该是已经解脱了。但是事实上我们仍然是在生死中流转，我们根本就没有解脱，这就反证了我们“认为一切义都有真实性”是不对的，可见，还是唯识无义是正确的。

四者、成就三种胜智随转妙智，

第四法是随转妙智，所谓随转妙智，就是一切境界随心转变，你要怎么改变，他就随你的心意而改变。这随转妙智有三种差别。

何等为三？

哪三种呢？

一、得心自在一切菩萨，得静虑者，随胜解力诸义显现。

“得心自在一切菩萨”就是指发无上菩提心的菩萨，经过了长时期的修行，心得自在了，就是说心在一切境界上都自在，就是境随心转了。“得静虑者”，前面是说的菩萨，这“得静虑者”是指声闻缘觉，他们得了四禅八定之类。“随胜解力”，得心自在的菩萨和得静虑的声闻缘觉，他们心里思惟的观想非常有力。这里的“胜解”就是指观想的力量极强、不动摇。“诸义显现”，他心里观想什么，就现出什么境界，就是说，境界随他的心而转。这是候得注意，自己有力自己观想自己见，不能是我观想出水而别人见水，这不对。楞严经中月光童子见屋里有水的故事违背佛法就在这儿，师父修水观，结果小徒弟见一汪子水，这是错的。从这儿就可以知道，外面的境界绝对不能是真实的，要是外境真实的话，它就不能随心而转了。这也就证明了唯识无义。这是大修行人的境界。

二、得奢摩他修法观者，才作意时诸义显现。

这是第二种随转妙智。“得奢摩他”，成就了奢摩他定的行者。妙老说这个奢摩他的成就，最起码要未到地定，最好还是要初禅、二禅、三禅、四禅，或无色界的四空定的前三种定：空无边处定、识无边处定、无所有处定，不过在世亲释、无性释中都没有说非要未到地定等。我们把它理解成禅定就行了。“修法观者”，成就了奢摩他的行者，在奢摩他里修学佛法的观行，象四念处观、无常观，无我观、不净观等等都行，“才作意时诸义显现”，你心里一作意，所观察的境界立马就现出来。观无常，无常义就现出来，观无我，无我义就现出来。这也可以证明唯识无义的道理。

三、已得无分别智者无分别智现在前时，一切诸义皆不显现。

“已得无分别智”，就是说你入圣道了，入圣道才能得无分别智，入圣道的圣者，他在观察真如无相的真理时，“一切诸义皆不显现”，这里的“一切诸义”就是指遍计所执的境界。说，入圣道的圣者，在观察真如的时候，一切遍计所执的境界，象色、声、香、味、触以及眼、耳、鼻、舌、身，还有色、受、想、行、识等等的境界都不显现，唯有真如的境界显现。这也可以证明“唯识无义”。因为要是有真实义的话，它就不可能不现，他不会随你的心识而转。

由此所说三种胜智随转妙智，及前所说三种因缘，诸义无义道理成就。

第四法随转妙智就有这三种差别。那么这三种随转妙智加上前面的三法，都可以证明唯识无义。“前所说三种因缘”就是前边儿的三法，“诸义无义”就是说所有的境界其实根本就不是境界，没有这境界。这四法到后边儿还要说，是在57页倒数第一行的颂子，就是把这四法又说了一遍。下边儿就开始正儿巴经解说三自性的名义了。

若依他起自性，实唯有识，似义显现之所依止，云何成依他起？何因缘故名依他起？

先说依他起自性。“若依他起自性，实唯有识”，前边儿对依他起下的定义是“阿赖耶识为种子，虚妄分别所摄诸识”，在20页。就是说，这依他起，其实就是分别心，他是阿赖耶识为种子而显现的，实际上只有识。“似义显现之所依止”，这个“似义显现”就是说，本来没有义只有识，但是好象有义显现出来，这实际上是我们的错觉，就是遍计所执。就是说，依他起是遍计所执的依止处。“云何成依他起”，既然它是遍计执的所依，他就应该是“他依起”，可是却成了“依他起”，这是为啥？“何因缘故名依他起？”把它叫成依他起的理由是啥？

从自熏习种子所生，依他缘起故名依他起；

无著论师回答说，怎么乱来呢～～你把两回事儿弄混淆了。依他起是遍计所执的所依，这是另一回事。我们现在说的依他起是从他自身来说的。从其自身来说，他是“从自熏习种子所生”。就是说，我们的心识，是从他自己的熏习成就的种子生出来的。就是说，我们的分别心一动，立马就在阿赖耶识里熏成了种子，你怎么分别就熏成怎么样的种子。我说实话就熏成实话种子，打人就熏成打人的种子，一点也不含胡、不隐藏的，我们会说假话。但熏习不会出差错的，你咋分别，阿赖耶识就咋样儿受熏，完全真实，一点儿也不虚伪。所以，我们的一念分别心，就是从自己以前的熏习的种子生出来的，表面上看好象的外境界作所缘缘才使心活动起来，但实际是由里面的种子现出来的。“依他缘起故名依他起”，依他起的“他”就是种子。说因为种子的缘故而生起所以叫依他起。这是回答的“云何成依他起？”回答说是：从自身上来说，因为它是由种子的缘故而生起的。

生剎那后无有功能自然住故，名依他起。

这是回答“何因缘故名依他起？”要从名义上来说了。“生剎那后”，种子生现行（现行是心识的活动）是刹那间就生起来了，只要因缘具足一下就生起活动了，但生起活动之后呢，“无有功能自然住故”，种子刹那间生起了一念分别心，可是生起来之后它没有能力继续存在，立马就灭。就是说，因缘具足它就生起，但生起后它没有能力自然安住。也就是即生即灭的。可是它一直相续不断的生灭，这个生灭的速度很快，快到了我们认为它没有生灭的程度。前一句长行是说，有亲因缘“自熏习种子”而生起活动，所以叫依他起。这一句长行是说，还有其它的因缘（增上缘）使之念念生念念灭、即生即灭，所以叫依他起。这儿呢，印顺法师说是“约依现法他而暂住说的”，印老说的就不对了，他这说法就不是唯识了。

若遍计所执自性，依依他起实无所有似义显现，云何成遍计所执？何因缘故名遍计所执？

遍计所执这儿也是两个问题。“若遍计所执自性，依依他起实无所有似义显现”，说，遍计所执是“依依他起”而有的“实无所有似义显现”，“依他起”是我们的分别心，这个遍计执“依依他起”就是说，遍计执是依我们的分别心而有的。既然它是依依他起而有的，就是说他也是依他起才对，“云何成遍计所执？”它怎么就成了遍计执呢？其中的“实无所有似义显现”就是说，遍计所执本身是没有的，它要是离开了分别心，什么都没有了，它没有独立的体性。它本来是没有的，可是后来又确实有了，它是怎么来的？就是“似义显现”――心识一活动，因为无始以来的熏习，它就现出境界了，那个现出的境界，就是“似义显现”，它就是遍计所执自性。既然现出了境界，那就是有，怎么能说没有？啊，“似义显现”，它象境界，可不是真是有境界。这就是说，它有很大的欺骗性。“何因缘故名遍计所执？”它凭什么叫遍计执呢？这也是两个问题，一个是说，遍计执既然是依依他起而有的，就应该也是依他起，它怎么就成了遍计执呢？第二个问题是，它叫遍计执的理由是啥？

无量行相意识遍计颠倒生相，故名遍计所执；

“无量行相意识”，意识是能遍计，似义显现是所遍计。“无量行相”是指意识在虚妄境界上有很多的行相，“行相”就是我们的分别心在似义的所缘境上活动、分别。意识的分别有无量无边的行相，所以把意识称为“无量行相意识”。“遍计颠倒”，“遍计”就是普遍地计度筹化，对任何事情它都要计度。因为这计度实际上是妄想分别，所以都是错误的、不合理的，所以称“颠倒”。这个“生相”就是指生起似义显现的相，也正是因为有这似义显现，意识才能生起。这遍计所执就是似义显现，似义显现能让意识生起，意识生起后，他又以似义显现为所缘相。这就是转圈儿的，因为有似义显现所以有意识生起，意识生起后又去缘这个似义显现。那么，遍计所执就是似义显现能生起无量行相意识的遍计颠倒，而又为无量行相遍计颠倒的所缘相，“故名遍计所执”――似义显现是意识的颠倒执著的境界，它就是遍计所执。

自相实无，唯有遍计所执可得，是故说名遍计所执。

遍计所执实际上是似义显现，既然是似义显现，就是说它并没有实在的自相，是自性空。“自相实无”就是指这个，常举的例子是认绳为蛇，我看见一条蛇，因为我以前心中就有蛇的概念，阿赖耶识里有蛇的种子，以暗的光线、绳子为助缘而生起蛇的认识，这就是遍计所执。但蛇实际上是没有的，就叫“自相实无”。遍计所执的境界是没有的（蛇没有），“唯有遍计所执”，所有的只是我的执著。其实我们的分别心所分别的境界，是心所变现出来的，是依他起的，但我们执著他是真实的，就成了遍计所执。我所执著的蛇是没有的，所有的只是分别心。于是我们立了遍计所执。依他起就是一切缘生法，遍计所执就是我们凡夫的虚妄分别心把这个缘生法搞错了。

若圆成实自性，是遍计所执永无有相，云何成圆成实？何因缘故名圆成实？

关于圆成实自性，也是提了两个问题。说，圆成实自性就是遍计所执没有了。没有遍计所执怎么就是圆成实呢？这就是“云何成圆成实？”还有一问是“何因缘故名圆成实？”它为啥叫圆成实？

由无变异性故名圆成实；又由清净所缘性故，一切善法最胜性故，由最胜义名圆成实。

这一句长行有两个要点儿，一个是无变异，一个是由最胜义。“由无变异性故”，这个“无变异”就是指人家是啥样儿就是啥样儿，你不要给人家改了，“变”的改变，“异”的异化。人家本来是依他起，你不要给人家弄成遍计执，你要是把人家弄成了遍计执，那就是“变异”了。人家本来没有自性，你要是给加上自性，就是变异了。这圆成实就是真如，真如的“真”就是真实的情况，本来是依他起，依他起就是真实情况，“如”是如如，就是不变异。你是凡夫的时候是依他起，你成佛了，还是依他起，这个“没有变异”就是圆成实。要是一变化，得，就成遍计执了。下边儿看“最胜义”。“又由清净所缘性故，一切善法最胜性故”，这最胜义里有两个意思，第一个是“由清净所缘性故”，就是说，圆成实是圣人清净智所缘的，凭凡夫的执著分别心是缘不到的，你必须经过修行，到无分别智现前，然后凭无分别智来缘这圆成实，这才行。这是“清净所缘性”。“一切善法最胜性故”，说，你成就了无分别智，你用无分别智思惟圆成实，可以得证无上菩提，无上菩提在一切善法是最殊胜的。或者说，圆成实是胜义善、是无为善，所以是“一切善法最胜性故”。这就是圆成实之为圆成实的理由。

复次，有能遍计，有所遍计，遍计所执自性乃成。

遍计执是凡夫的境界，无著论师就再着重说一下，因为我们都是凡夫，这论现在就是度化我们的。遍计所执有能遍计，还有所遍计。能遍计、所遍计都具备的时候，遍计所执自性才成立。只有能遍计没有所遍计，或者只有所遍计没有能遍计，则遍计所执性是不成立的。

此中何者能遍计？何者所遍计？何者遍计所执自性？

啥是能遍计？啥是所遍计？啥是遍计所执自性？

当知意识是能遍计，有分别故。

能遍计就是意识，因为意识“有分别故”，意识不象前五识，前五识是没有分别（没有分别就是只有自性分别）。因为意识有分别，所以是能遍计。

所以者何？

为啥意识有分别就说它是能遍计？有分别的还有其他识呀～～

由此意识用自名言熏习为种子，及用一切识名言熏习为种子，是故意识无边行相分别而转，普于一切分别计度，故名遍计。

因为第六意识，他有他自己的名言熏习种子。“用自名言熏习为种子”，意识有很多名言种子，前五识没有，比如看见光，眼识可以看见光，但没有“光”的概念，意识有这样的概念。所以第六意识是能遍计。“及用一切识名言熏习为种子”，他还能用其它识的名言熏习种子。就是说，当眼、耳、鼻、舌、身识活动的时候，意识来给他们安立名言，然后意识就说，这眼、耳、鼻、舌、身的活动被我占有了。就是说，意识是个强盗。本来它是去帮别人的，可帮着帮着占为自己所有了。比如说张三欠我三十万，我拿张三没有办法，于是我向法院起诉，结果法官他要了二十五万，我只得了五万，这就是法官取代我成了钱的主人，这法官就是强盗。意识就给这法官一样，取代了前五识。这样，种子就有两种了：“用自名言熏习为种子”，这是见分、见识；“用一切识名言熏习为种子”，这是相分、相识。这两种当然实际上是分不开的，你心一分别，见分、相分都有了。心一动，就熏成见分种子、相分种子。前五识当然也有见分、相分，但眼识是眼识的见、相，耳识是耳识的见、相，互不混淆，可意识包括了一切心识的活动，他能够用“自名言熏习为种子”，还能“用一切识名言熏习为种子”。“是故意识无边行相分别而转”，所以意识活动是无量无边的，因为意识的活动无量无边，所以世界才五彩缤纷。“普于一切分别计度，故名遍计”，因为意识有这么两种名言熏习种子，所以意识能够普遍于一切的境界去分别、计度，所以叫能遍计。总一下就是说，能遍计的是第六意识，因为他有两种名言种子：自名言熏习种子、用一切识名言熏习为种子。

又依他起自性，名所遍计。

能遍计的第六意识本身是依他起的，他也是种子生出的现行。意识是能遍计，所遍计是啥呢？是依他起。咱们常举认绳为蛇的例子，根本就没有蛇，所以我们不能说蛇是所遍计，而要说绳子是所遍计，蛇根本就没有，蛇只是你的妄想，所以，不能说蛇是所遍计，因为它根本没有，只能说绳子是所遍计，因为我们是在绳子上产生出来的错觉。所以长行说，“依他起自性，名所遍计”。所遍计是依他起自性。依他起自性就是识，识是依他起自性，识是阿赖耶识的种子现出来的活动。识在活动的时候，又会现出种种的“似义”，这“似义显现”，咱们说过，它是遍计所执。遍计所执给所遍计不一回事儿。现在说依他起自性是所遍计，圆成实是不是所遍计？不是！因为凡夫的缘不到圆成实，那是圣者的境界，是清净圣智所缘的境界，你根本就不可能把圆成实给弄成所遍计。所以说，遍计所执自性、圆成实自性不是所遍计，依他起是所遍计。能遍计的所缘对象，都是从种子生起的，是依他起，所以说依他起为所遍计。

又若由此相令依他起自性成所遍计，此中是名遍计所执自性。

当我们的意识活动的时候，本来的依他起自性被我们的颠倒执著给当成了所遍计的对象，这就成了遍计所执性。当然这责任主要在意识，可是这个所遍计――就是似义显现的境界，它自己带有很大的欺骗性，它自己是虚妄的，可它给真实实在太象了，以致于我们看不出它是虚妄的了。就象蜡人馆里的蜡人，一个真人站着不动的话，我就有可能把他当成蜡人，就是说，蜡人与真人太象了。

由此相者，是如此义。

“又若由此相”的“由此相”是啥意思？就是如此的意思、就这样儿。就是说，“此相”就这样儿！就是说，能遍计的意识颠倒执著，使得依他起成了所遍计，就这样儿成就了遍计所执自性。

所遍计是依他起自性，依他起自性是如幻如化的有，是不真实的。遍计所执自性则是去执著那“如幻的有”为“真实的有”。这是不一样的。遍计所执自性的成就有两个原因，一个是无明颠倒，一个是所遍计的境界本身有很大的欺骗性。所以，我们凡夫非执著所遍计的境界不可，当你经过长时期的闻思修才能改变过来。我们无始以来的熏习，执著依他起的分别心熏习在阿赖耶识里面的名言种子，现出来的一切虚妄境界，得到成佛的时候才究竟清净，不现虚妄境界了。你只得到无生法忍，虽然知道这境界是虚幻的，但这虚妄境界还是要现的。

复次，云何遍计能遍计度？缘何境界？取何相貌？由何执著？由何起语？由何言说？何所增益？

“云何遍计能遍计度？”“能‘遍计度’”的是意识，意识是“云何遍计”呢？就是说，这意识是怎么个遍计法儿而使自己成为了“能‘遍计度’”呢？下边儿分成六个情况来说，这六个情况是有次第的，一步挨一步。“缘何境界”？意识在遍计的时候，它得有所缘境。能遍计是意识，所遍计是依他起，具体来说，所遍计的境界到底是什么呢？“取何相貌”？意识在计度的时候，他执取什么相貌呢？“由何执著”？意识是能遍计、能执著，他是用什么来执著呢？“由何起语”？他由什么动身发语呢？意识不但自己执著，他还要把自己认为的传达给别人，让别人接受他的说法，这就需要名言，这名言从哪儿来？“由何言说”？意识要起名言了，他凭什么来说话呢？就是指他说话的材料是啥？象咱们说话，所用的材料就是声音，意识说话所用的材料是啥？“何所增益”？“增益”就是本来没有的你给加上去了。现在意识给增益上去什么了？这是六个问题，下边儿是回答。

谓缘名为境。

你问缘何境界，现在无著论师回答说是“缘名为境”，“名”就是名字、符号、名言，这个很重要的。桌子有桌子的名，椅子有椅子的名……桌子的名是诠表桌子这一法的，椅子的名是诠表椅子这一法的，互不混淆。我们就在名上产生执著，我就认为它就应该叫桌子，你要是说它叫张三，我就认为你是傻子，我认为它就应该叫桌子，它叫桌子才是最合适的等等。名是能诠，法是所诠。就是说，意识是以各法的“名”为所缘境。我们通过佛法的熏习，最后通达诸法实相，超越一切假名，就不在名上转了。

于依他起自性中取彼相貌。

你问意识在计度的时候缘取什么相貌，无著论师在这儿回答了。意识是缘取名的，以名为所缘境，名在三自性里也是依他起。你一分别，就熏习了名言种子，这个种子一动又出来种种的名，也就是种种的分别。就是说，名和内心的分别是不能分开的，就是说，名是依他起性，他也是由种子而来的。“于依他起自性中取彼相貌”，说，第六意识在依他起自性上，也就是在种种的名上“取彼相貌”――取彼与名相应的相貌。论文的话比较麻烦，我来举个例子。意识在缘取桌子这个名字的时候，立马就现出桌子这一法的相貌，它不会现出猪这一法的相貌。你问意识计度的时候缘取什么相貌，我就告诉你，意识缘取的是与它所缘取的名相应的相貌。你缘取苹果这个名字，则缘取的相貌绝对不是香蕉的相貌。

由见执著。

刚才你问意识这个能执著、能遍计是用什么来执著的，这里回答说是用见执著的。这个“见”就是见解。我有一个观点，这个观点是我经过努力精进才得出的，现在你有一个给我不同的说法，我就说你的是不对的，你们不能动摇我的观点儿，这就是见解。我们对某事儿没什么研究，那我们就对他谈不上执著，别人说什么就是什么，我没有发言权。现在我们执著，是我们都有自己的“见”，见解，有见解就有执著。

由寻起语。

意识执著了，他“缘名为境”、“取彼相貌”，并“由见执著”，然后他要把自己的感觉介绍给别人，要介绍就得有语言，“由寻起语”。“寻”就是寻伺。内心里面去寻伺分别自己所执著（不过当时自己不认为它是执著）的种种名相、相貌，而有了语言。就是说，语言从寻伺而来。

由见闻等四种言说而起言说。

你向别人介绍，所用的材料是“见闻觉知”这四种言说。见对应眼，材料是色；闻对应耳，材料是声；觉对应鼻、舌、身，材料是香、味、触；知对应意识，材料是法。一意识说就把前五识包括了。我们的言说，都是从见闻觉知得到消息，然后经过心识的翻译，用色、声、香、味、触、法表示出来。

于无义中增益为有。

意识给增益什么了呢？回答说，“于无义中”，在根本就没有的东西中，“无义”就是说根本没有，只是似义。“增益为有”根本就没有东西，现在你给增益了“有东西”，但这个“有东西”只是你的增益而已。关于增益，实际上你什么也没有给加上去。咱们常说头上安头，安上去了没有？根本就没有，但你非说你安上去了，这就叫增益。

由此遍计能遍计度。

就这样，意识成了“能‘遍计度’”。就是按着名、相、执著、寻、见闻觉知、增益这么个次第、样子，意识成了“能‘遍计度’”。

复次，此三自性为异为不异？

依他起自性、遍计所执自性、圆成实自性是异还是不异？就是说，它们是各不关连呢还是彼此联系？

应言非异非不异。

你不能说三性是异也不能说是不异。说它们非异，是因为依他起是一个平台，就是在依他起上建立的遍计执、圆成实，离开依他起就没有遍计执、圆成实。说它们“非不异”，是因为三性各有自己的别义，各有自身的相貌。比如说依他起与遍计执之间的关系：依他起是有，遍计所执是无，有望于无，可称为异，有与非有，可称不异。

谓依他起自性，由异门故成依他起；即此自性由异门故成遍计所执，即此自性由异门故成圆成实。

说，依他起自性是一个平台，从不同的角度来思维、观察就可建立依他起自性、遍计所执自性、圆成实自性。“由异门故成依他起”，就是从不同的角度观察，就有了依他起。也就是有了特殊的原因就有依他起。“异门”就是不同的角度。“即此自性由异门故成遍计所执”，换个角度、从不同的角度来观察依他起，就有了遍计所执。有特殊的原因而成了遍计执。“即此自性由异门故成圆成实。”你再换个角度来观察依他起，就有了圆成实。有特殊的原因就成了圆成实。在所知依那儿说是以阿赖耶为中心，这儿说依他起是中心，阿赖耶就是依他起性。在依他起上说遍计执，在依他起上说圆成实，都是在依他起上进行说明的。

由何异门此依他起成依他起？

你说由异门故成依他起，到底是啥异门呢？就是说，你到底是从哪一个角度来成就依他起的？

依他熏习种子起故。

说，我就是依识的各种活动所熏成的种子这个角度来成立依他起的。因为一切现行法都是由种子生起的。

由何异门即此自性成遍计所执？

遍计执是从哪个角度成立的？

由是遍计所缘相故，又是遍计所遍计故。

前边关于这个遍计所执自性，给分成能遍计、所遍计、遍计所执三方面说了一下，现在再说一下，“由是遍计所缘相故”，这就是所遍计，所遍计其实就是似义显现者，是无而似有、分明显现的，就是识所了别的境界。我们就根据这个所遍计成立的遍计所执。“又是遍计所遍计故”，这是第三方面遍计所执。能遍计的心去遍计、执著所遍计的对象，这就成就了遍计所执。所遍计是似义显现的，但似义显现本身是依他起的，所以依他起是所缘，这个依他起的所缘在能执著的心上显现时，就成就了“遍计所执”。这两句话，有两个意思：“由是遍计所缘相故”，因为有所遍计所以叫遍计所执（重点儿在对象），因为依他起的心要去遍计所遍计（重点儿在遍计），所以叫遍计执。

由何异门即此自性成圆成实？

圆成实是从哪个角度成立的呢？

如所遍计毕竟不如是有故。

第六意识的执著本身是依他起，执著的“似义显现”是“毕竟不如是有故”，似义显现究竟是没有的、毕竟是没有的。通达似义显现的无所有而显出来的诸法空相，就是圆成实。也就是说，这是从依他起上的所遍计根本就没有这个角度成立圆成实的。这样，一切法有三类：依他起、遍计执、圆成实。依他起是中心，向遍计所执那边儿去，是凡夫境界，向圆成实这边儿去，是圣者境界。就是说，凡夫的境界也好，圣者的境界也罢，都是建立在依他起上的。

此三自性各有几种？

三自性各分二类，这是问有几类。其实分类是因角度不同而有的类，并不是这一类给那一类隔着的。

谓依他起略有二种。

先说依他起的二类。

一者、依他熏习种子而生起故，二者、依他杂染清净性不成故，由此二种依他别故，名依他起。

“依他熏习种子而生起故”这一类，是说过的，第二类没有说过。“依他杂染清净性不成故”，就是说，难说它是杂染还是清净的，看你怎么去分别它了，要是凡夫虚妄分别心去分别它，执著这依他起的似义显现，这就是杂染的。要是我们正闻熏习，通达无分别智，用这无分别智来观察这似义显现，这依他起就是清净的。就是说，这依他起，随染净的因缘而杂净。“由此二种依他别故”，第一种是“依他熏习种子而生起故”，第二种是“杂染清净性不成故”。从本质上说，“杂染清净性”还是“依他熏习种子而生起”，杂染是依他熏习种子而生起，清净也是依他熏习种子而生起。“由此二种依他别故”的“别”是指名称不同，说根据能诠的名称把依他起表述为两种，可不是真有两种不同的依他起。

遍计所执亦有二种。一者、自性遍计执故，二者、差别遍计执故，由此故名遍计所执。

遍计所执自性也有两种，一个是自性遍计执，一个是差别遍计执。“自性遍计执”，就是指执著依他起的法是真实的，说这似义显现的一切法是真实的。说色法就执著色法真实，说心法就执著心法真实。“差别遍计执”是说，对每一法又有不同的执著。比如桌子，它是色法，你一下执著它常，一下又说它用着不舒服等，就是说诸法有不同的义用。这就是差别遍计执。凡夫的执著很明显的，圣人的执著很微细，只要没成佛，执著还是有的。

圆成实性亦有二种。一者、自性圆成实故，二者、清净圆成实故，由此故成圆成实性。

圆成实自性也分两种，一个是“自性圆成实”，就是诸法空性。它本身是不变的。第二是“清净圆成实故”，这是我们修行证果之后所显的。就是说，在凡夫的时候，具的是自性圆成实，当然这自性圆成实也通于佛。到你成佛之后，那是清净圆成实。从其本质上来说，圆成实没有凡圣之别。

复次，遍计有四种：一、自性遍计，二、差别遍计，三、有觉遍计，四、无觉遍计。

前边儿把三性总说了一下，说它们都有二类。这儿把遍计执再特别提出来说一下，再加两类，前边儿说遍计执有自性遍计、差别遍计，这儿给加上“有觉遍计”和“无觉遍计”。

有觉者，谓善名言。

啥是有觉遍计？“谓善名言”，就是有的人特别善于利用表义名言把自己所遍计出来的思想用文字表达出来。就是说他把自己所遍计的东西表达出来影响别人。他善说，特煽情。他能够把自己的想法说出来，有的人就是笨嘴拙舌的不会说。

无觉者，谓不善名言。

这是指内心有想法但表达不出来，表达不好。世亲释156页中说，“谓牛羊等，虽有分别，然於文字，不能解了。”我们说的时候，还包括小孩子等，哑巴算不算，我没有注意过。

如是遍计复有五种：

这是又用了一种分法，把遍计所执给分成了五种。

一、依名遍计义自性，谓如是名有如是义。

依名遍计义，就是说，看见名马上就遍计义。根据名去推度义。比如说你在一本杂志上看见一篇文章，作者是刚晓，马上就想到，我认识这个作者刚晓，他是河南灵山寺的等。这就是看见名就遍计义。你就记成：知道一个名字，但名字所诠的义不清楚，因之就根据名来推度义

二、依义遍计名自性，谓如是义有如是名。

依义遍计名是根据义去推度名。看见这个东西，马上就想到这是某。我只在书上看见过画的羚羊，没见过真的羚羊，一次看见一个东西有点儿象书上画的羚羊，我立马就想这就是羚羊吧～～这是依义遍计名。你记成见到事物而不知道它的名，因之去推度它的名。

三、依名遍计名自性，谓遍计度未了义名。

依名遍计名就是根据知道的名言去推知不知道的名言。无性释395页说，“谓如生在椰子洲人，闻说牛声，不了其义，数数分别，如是牛声。”椰子洲我也不知道是哪儿，反正是一个地方就行了。说，有一个地方，他们那儿没有牛，他们听说过牛，知道有一种动物叫牛。因此他们就用了各种各样他们知道的方法来了解牛。咱们就说，我只听说过牛，没见过牛，我想，牛是不是象咱们这儿的老虎那样呢？可能不是，听说牛是吃草的，那就应该是象鹿一样了吧～～这就是依名遍计名。

四、依义遍计义自性，谓遍计度未了名义。

依义遍计义，无性释中说，“谓曾未习想与有想更互相应，歘（xu，同欻，言迅速，忽然）见牛身，数数分别如是牛义。”“曾未习想”就是指眼前的这具体的但我不认识的牛，“有想”指我认识的家牛，我说，这个东西应该是野牛吧～～这就是依义遍计义。妙老说，就是依据已经明了名称的义，去遍计度未了名的义。

五、依二遍计二自性，谓遍计度此名此义如是体性。

“二”指名和义。用通达了名的义和通达了义的名，来推度既不知道名、也不知道义的东西。

复次，总摄一切分别略有十种。

说，我们的分别心有十种虚妄分别。这是分了十类。

一、根本分别，谓阿赖耶识。

阿赖耶识是一切分别的根本，一切分别都是阿赖耶识的种子生起现行，所以他是根本。一切的分别都以阿赖耶识为依止。这“根本分别”是有漏的、是虚妄分别。

二、缘相分别，谓色等识。

“色等识”就是色、声、香、味、触和眼根、耳根、鼻根、舌根、身根这些，他们都以识为自性。他们是识显现出来的相，同时，他们又引起识的分别，所以叫他们为“缘相分别”――眼识、耳识、鼻识、舌识就是因为色等而引起分别，所以叫“缘相分别”。因为他们本身以识为自性，所以叫做缘相分别。或者说，因为他们能够引起分别，所以叫缘相分别。

三、显相分别，谓眼识等并所依识。

“显相分别”指眼识、耳识、鼻识、舌识、身识等以及心所法，这六识以及心所法能起分别，能够显了一切相。“眼识等”就是眼等六识。“并所依识”是指第七末那识。也就是说，“显相分别”是见识，前边儿的“缘相分别”是相识。

四、缘相变异分别，谓老等变异，乐受等变异，贪等变异，逼害时节代谢等变异，捺洛迦等诸趣变异，及欲界等诸界变异。

刚才已经说过，缘相分别是“色等识”，这是第二种分别，现在这个“缘相变异分别”则是说，色等识有很多很多的变化。无著论师举了些变化的例子，比如说有“老等变异”，就是生老病死，这是人们最苦恼的事儿了，要死的时候都不想死，可没有办法。根身发生变化。还有“乐受等变异”，就是说三界中的众生都有苦受、乐受，你想只乐不苦，根本没门儿，而且佛陀还说，苦才是根本，苦是圣谛（注意，苦与苦圣谛当然是不同的，苦受是二元对立，而苦圣谛是一合相）。还有“贪等变异”，就是贪、瞋、痴这些烦恼，一下这个烦恼来，一下那个烦恼来，总不会让你如意的。还有“逼害时节代谢等变异”，“逼害变异”就是指我给你有矛盾，种族之间有冲突等，这就是逼害变异。“时节代谢变异”就是指春夏秋冬寒暑往来的新陈代谢。还有“捺洛迦等诸趣变异”，“捺洛迦”就是苦器，也就是咱们常说的地狱。这是指在六道中轮回。还有“及欲界等诸界变异”，这是指你在三界中一下到这儿受生一下到那儿受生。

五、显相变异分别，谓即如前所说变异所有变异。

第三种分别是显相分别，这“显相变异分别”则是显相分别进一步分别。无著论师说，“如前所说变异所有变异”，“如前所说变异”就是指前边儿说的四种变异，比如缘相变异，缘相变异是色、声、香、味、触以及眼根、耳根等，它们发生了变化，比如说我在红纸上写了些字儿贴在墙上，过了些日子褪色了，这就是色的变异，它的表演艺术也有很多种。根也会变异呀～～眼害眼了，先时轻，越来越重，眼得了这病，还会得那病等等，这变异也有很多种。再比如显相变异，显相变异是识，你要是根变异了，当然识也随着变异，根有多种变异，识自然也有多种变异。这就是“显相变异分别”。

六、他引分别，谓闻非正法类及闻正法类分别。

根本分别、缘相分别、显相分别三个是总说的，缘相变异分别、显相变异分别是俱生的分别。这他引分别是啥呢？这是学习得来的。“他引分别”，“他”就是别人，因为别人的影响而使你分别，就是增加你的知识。“闻非正法类”是恶知识影响你，“闻正法类”是善知识影响你，恶知识的影响，你的分别就不对，你得到邪知邪见。善知识影响你，你的分别就对，就得到正知正见。

七、不如理分别，谓诸外道闻非正法类分别。

“不如理分别”是指你受到了外道的影响，而生起不合理的虚妄分别。前边儿的“闻非正法类”是一般的恶知识。

八、如理分别，谓正法中闻正法类分别。

如理分别是指受佛法影响。这他引分别、不如理分别、如理分别是学习而得来的。

九、执著分别，谓不如理作意类，萨迦耶见为本，六十二见趣相应分别。

这个执著分别是不如理分别的进一步。把它划归不如理分别其实也行，这不过是特别指出来生死流转里面最重要的一个烦恼――我见。无著论师说执著分别是“不如理作意类”，就是因为作意不合理而产生萨迦耶见，“萨迦耶见为本”，“萨迦耶”就是“坏聚”，坏聚就是五蕴和合的身体能够坏能够聚。“萨迦耶见”就是我见。有人我见、有法我见，一般指人我见，或者说补特伽罗，又写成数取趣，“数取趣”就是一次次地在六道中受生。现在这执著分别就是说，因为不如理作意就有了萨迦耶见，因而执著有我。“萨迦耶见为本，六十二见趣相应分别”，不如理作意产生我见，以我见为因而有六十二见，就是各种各样的虚妄分别。六十二见有好多说法，你自己查一下字典。

十、散动分别，谓诸菩萨十种分别。

注意，这个散动分别，无著论师说的“谓诸菩萨十种分别”，菩萨把虚妄分别给总结成了十种散动。所谓散动，398页无性释中“散乱扰动，故名散动”，说它们“扰乱无分别智”“扰乱般若波罗密多”。其实就是烦恼。十种分别是啥？下边儿说。

一、无相散动。

实际上这很简单，但老法师们讲得很复杂。比如说妙老，讲得好长的。印顺法师讲过无相散动后还要来一段附论，说实在的，印顺法师这一段附论是不好的，不如不加，一加这个就说明了他的唯识极不纯粹，所以说，要学唯识不能学印顺法师的，他讲的唯识只是披了唯识的皮而已，根本不是唯识。所谓“无相散动”，其实就是用“无”来扰乱正智。这实际上就是顽空――什么都没有！按唯识的说法，就是遍计执是一点儿影子也没有的，但依他起你不能说没有！就是说，你梦见大老虎吃你，你吓得不得了，梦中的大老虎是没有的，但你确实是作了一个老虎要吃你的梦。这才是正智，是事实真相，你现在否定一切。这就叫“无相散动”。妙老在这儿说了几句话，我觉得不合适，他说，“什么叫做‘无相’？在三自性上看，遍计所执是空无所有的，是无所有的。这个无所有怎么样知道呢？就是在依他起上似义显现的境界上知道它是毕竟空寂的，一定要说到依他起。知道毕竟空的遍计执之后，依他起也是不可得了，这个时候名之为‘无相’”。我觉得不对。“无相散动”就是你执著“无”，导致你堕入顽空。

二、有相散动

无相散动是以“无”来扰乱正智，而这个有相散动，则是以“有”来扰乱正智。也就是说，有相散动是执“有”，说桌子就执著有桌子，说牛就执著牛为有，本来呢，事实真相是该有的有、该无的无，而无相散动是非说什么都无，有相散动是说什么都有。这主要就是执色、受、想、行、识。你执无不对，可执有也是不对的。

三、增益散动

“增益散动”就是因为你的增益而扰乱正智。本来是依他起，只是似义显现而已，可你却非要给增益上一个自性，但我们知道，实际上你并没有给增益上去，只不过是你以为给增益上去了而已。依他起的是心法、色法，它们是虚幻的，你给增益成真实的，这就是执著。

四、损减散动

“损减散动”就是因为你的减损而扰乱正智。本来是圆成实，就是诸法空相，这是真如，你非说是没有的，这就是要去减损真实。可我们知道，真实你是减损不了的，不过是你自以为了不起，自以为给减损了而已。圆成实不会因为你说减损就减损，依他起不会因为你说增益就增益。虽然说依他起、圆成实本身并不会因为你的执著而改变，但对于你来说，你的心念是变化了的，这就扰乱正智了。圆成实性是不灭的，你损减不了他。

五、一性散动

“一性散动”就是因为你执著一而扰乱正智。比如说，咱们知道，真理是一不是二，佛教讲不二法门、一合相等。于是你就执一。唯识三性，依他起、遍计执、圆成实，依他起是一个平台，我们在依他起上产生遍计执，这遍计执是错觉，如果我们在依他起上不产生遍计执的话，这就是圆成实。这我以前就说过。于是就有人说了，这样一来，圆成实和依他起就是一，你一这样说，完了，这就是一性散动。就是说，你认为圆成实与依他起是一的话，就障碍你得证圣道。这错在哪儿呢？圆成实性是圣者的清净智所缘的境界，而依他起是通于凡夫、圣者，依他起的是阿赖耶。圆成实是不生不灭、不垢不净、不增不减的，而依他起是一直在生灭变化的，这怎么能说是一呢？再简单点儿说，依他起是万法，圆成实是万法的体性、法性，法与法性当然不是一回事儿了。

六、异性散动

“异性散动”就是因为你执著异而扰乱正智。你执著圆成实和依他起是异，你说圆成实和依他起是两回事儿。实际上圆成实和依他起是不异的，因为修学圣道的人，一定要从色、受、想、行、识的依他起上去观察、思维，才能证悟圆成实。离开色、受、想、行、识去直接观察胜义谛，是了不可得的。遍计执和圆成实呢？也不能说是异，遍计执的色、受、想、行、识，它是一无所有的，它给依他起的色、受、想、行、识不一样。遍计执的色、受、想、行、识一无所有，正好显出圆成实的空性，就是说，它们不异。我说的是遍计执的色、受、想、行、识，可不是依他起的色、受、想、行、识，不一回事儿。

七、自性散动

“自性散动”就是因为你执著每一法都有自性而扰乱正智。实际上根本就没有自性，只有假名而已，它们本身都是自性空。

八、差别散动

“差别散动”就是因为你执著各有各的差别相而扰乱正智。也就是说，你认为生就是生，染污就是染污，凡夫就是凡夫，这种种的差别，这样的认识就扰乱你的正智。

第七的自性散动、第八的差别散动，正刚法师的《摄大乘论讲义》中的说法比较少见，我读几句他的原文：“这是因明的术语，也可以说是主语、谓语，它们都是能诠符号，对于能诠名的认识，世出世间是不同的。一般凡情众生认为主谓结构的能诠名所诠表是自足自成，自性有的实体法上的特征相。一个实体法可以从不同的角度提出种种的特征相，将这不同的特征放在一个句子不同位置中，就有了自性与差别的主谓不同。一般来讲，主语的特征相放在前面，谓语的特征相是放在后面。这种句子结构是凡情众生认识另外一个特征相的途径。这也是把主谓能诠名的所诠来作为自足自成，不待他的自性有的实在自体，以这样的实体法为基础来产生这种认识途径……”句子不是甚顺。

九、如名取义散动

听说一个名字，你就要去找与这个名字相符的事物。我说，请你帮拿把椅子来，你就去找椅子，你发现那儿有两张不同的椅子，你还竾劰半天。这也扰乱正智。当然，这里的名不一定是名字，是名言，就是说，也可以是一句话等。实际上名言只是假安立而已，我们根本用不着随顺这些名言去进行种种的分别。

十、如义取名散动

就是说，我们看见事物就要取名。这也扰乱正智。为什么这会扰乱正智？取名本是为了我们方便的，可我们用这个名字用久了之后，会在这个名字上产生执著，有了执著就会扰乱正智了。你要是不产生执著就没事儿。

为对治此十种散动，一切般若波罗蜜多中说无分别智。

这就有了十种散动，十种散动都是扰乱正智，为了对治这十种散动，所以佛在经典中说了无分别智，用无分别智可以对治这十种散动。“一切般若波罗蜜多”应该是指经典，并不具体指哪一部经，当然主要是指《般若经》，《大般若波罗蜜多经》，其他经典中也有讲无分别智的。

如是所治能治，应知具摄般若波罗蜜多义。

“如是”就是指前面说的。“所治”是所要对治的十种分别， “能治”指能对治的无分别智。咱们注意一下，这十种散动都是所对治，但在佛教中主要的是能对治。“应知具摄般若波罗蜜多义”，般若经中能对治、所对治都讲到了。在世亲释158页和无性释398页，都是在每一种散动后就引般若经中的对治经文。你自己翻一下看看就行了，我只挑几个点一下子。比如说为了对治无相散动，经说“实有菩萨”，这一个我们要搞清“有”。一般说的有，是遍计执，是增益出来的，但这个“有”是指真如。对真如一定要搞清楚，佛教中真如是体，可现在很多讲唯识的法师把阿赖耶讲成本体，这就不对。再比如为了对治有相散动，经说“不见有菩萨”，这一个重点儿给我们说了真如不能受熏、不能生起世界，可以受熏的、能生起世界的是阿赖耶。这是学佛者常犯的错误。比如说对治一性散动、异性散动。重点儿是我们要搞清依他起与遍计执的区别，我们现在讲佛教的时候老把遍计执讲成依他起，这个一定得分清等等不说了，自己看一下，看能不能抓住重点儿。

若由异门，依他起自性有三自性，云何三自性不成无差别？

这是问难。说，依他起是平台，在依他起上从不同的角度给说成了三自性――从凡夫的角度来说，是遍计执，从圣者的角度说圆成实，依他起本身是通于凡夫、圣者的。就象三法印一样，诸法无我是印中之印，从有为的角度说是诸行无常，从无为的角度说是涅槃寂静，诸法无我自己则是通于有为、无为。这就是从不同的角度来说的。说，既然三自性只不过是由于角度不同而说的，这岂不就是说，三自性实际上无差别吗？既然三自性没有差别，建立三自性还有必要吗？

若由异门成依他起，不即由此成遍计所执及圆成实。

虽然三自性只不过是角度不同而说的，但三自性还是得要的，就是说，遍计执、依他起、圆成实还是各是各儿的，为啥？就是因为这个依他熏习种子而生起的异门成立依他起，“不即由此成遍计所执及圆成实”，不是由这个“依他起由种子生”这个道理去成立遍计所执、成立圆成实。也就是说，依他起是由熏习种子而生起这个角度成立的，但遍计执和圆成实不是从熏习种子生起这个角度成立的。

若由异门成遍计所执，不即由此成依他起及圆成实。

遍计执是从哪个角度来成立的呢？它是由遍计所缘相和遍计所遍计的不同这个角度而成立的。“不即由此成依他起及圆成实”，依他起和圆成实可不是从这个角度而成立的。

若由异门成圆成实，不即由此成依他起及遍计所执。

圆成实是从遍计所执乃毕竟空这个角度而成立的，“不即由此成依他起及遍计所执”依他起和遍计所执可不是从这个角度成立的。这样一来，我们就知道，三自性各有各的角度，怎么能够混淆呢？当然不能了。

复次，云何得知如依他起自性，遍计所执自性显现而非称体？

又一个问难。“如依他起自性”，依他起自性是阿赖耶识为种子所现起的虚妄分别所摄诸识。这识在缘一切法的时候，就随他的分别而现出种种境界，就是似义显现，这些从种子生的一切法，色法、心法等，都是不真实的。虽然不真实，但不能说是没有，它是有的。这依他起显现的时候，“遍计所执自性”马上就也显现出来。就是说，在依他起上现出来遍计所执。但是，遍计所执在依他起自性上显现的时候，“而非称体”――不符合依他起的真相、事实真相。就是说，分别心在一切不真实的法上观察时，和依他起的真相是不相称的。比如说这张桌子，桌子本来是依他起，是阿赖耶识的种子所变现的。但第六意识来分别时，桌子就成遍计所执了。遍计所执的桌子和依他起的桌子是不相符的。你可能会说了，哪儿不相符？你怎么能让我明白它们是不相符的呢？“云何得知”就是怎么能让我明白？怎么能让我消除疑惑？这个问难就是这。也就是说，我执著了它是桌子，我不执著它不还是桌子吗？难道它还能因为我的执著而变成一只小狗？这一句话我认为它很重要，它把依他起、遍计执彻底分清了。就是说依他起与遍计执一定要分清。而这个分清不是现在说了就能分清，说了也还是分不清的，这是一定要在现实中慢慢来体验。名、事、义这三者我们现在老打马虎眼。名就是名言，也就是信息，事就是咱们说的东西儿，这两者其实是依他起，而义就是理想、目标，它是遍计所执。

由名前觉无，称体相违故；由名有众多，多体相违故；由名不决定，杂体相违故。

无着论师从三个方面来解释。“由名前觉无，称体相违故”，就是说在取名之前是没有分别心的。世亲释161页中说，“名为依他起，义为遍计所执，以依他起由名势力成所遍计故。”没有名前，法本是依他起的、因缘所生。比如说瓶，我执著也好，不执著也罢，反正都是瓶，在没有取名字之前，并没有什么分别心，就是说，你只是看见了它，也不能分别它说“这是一个瓶”。再比如说在深山老林中有一种果子，谁都没有见过，当然也就没有名字了，后来他被一个探险的植物学家发现，植物学家以还有自己不认识的植物为耻，他就研究这果子，经过研究发现了这果子的习性、价值等，并给取了名字，这样一来是不是别人就也开始分别它了～～“称体相违”就是名与义不一样。也就是依他起的名、事实本相与遍计所执的义不一致。如果依他起与遍计所执一样的话，那么有遍计执的时候就有名字，有名字就有种种分别、种种烦恼，这些烦恼是遍计所执。遍计执和依他起相称的话，在没有名字时你接触它，有烦恼吗？没有。张三老在背后骂我，但是我不知道，这时我见到张三，我心里没有烦恼，当别人把张三背后骂我的话告诉了我，我再看见张三，烦恼就有了，是不是这样？这就是遍计执和依他起不相称。不过我们要知道，唯识的依他起是离名言相的。我们通常说圆成实、第一义谛离名言相，这点儿要知道。依他起是如幻有，是阿赖耶识的种子所变现的，是有但不真实，遍计所执是在那个不真实的法上执著有真实性。遍计所执里能遍计的分别心与所遍计的境是不分离的。现在无著论师就是说，因为名的势力而使依他起成了遍计所执，所以我们凡夫虽然生活在遍计所执里，但并没有离开依他起。我再说一下名。无著论师说了，说因为名而使依他起成了遍计所执，名有这个功能吗？我就说一下名的几个作用，第一个作用是交流。咱们互相交流，要是没有名言，根本就没法交流。象音声、文字、姿态等等等算名言。第二个作用是储藏。就是记录，我们现在怎么知道春秋战国时候的情况，就是靠文字记载、考古发掘出来的文物等，这都是名言，我说过名言就是信息。考古当然也算。名言要是没有储藏作用，信息就没法传递。第三个是导向作用、指引作用、唤醒作用。报纸有一个舆论导向问题，就是这个。第四个是解释离言法性的作用，这是宗教中有的。

第二个方面是“由名有众多，多体相违故”。“名有众多”就是一个东西有很多名字，一般的，每一个名字所代表的含义都不一样，比如说，有人叫我紫晓，这是文友们这样叫，我以前写文章时用的名字，我还是池州地区作家协会的常务理事。叫我这个名字是从我写烂文章这个含义上叫的，当时写的时候不觉得烂，还挺感动自己的，现在回头再看觉得挺烂的。有人叫我老张，这是我的乡亲们这样叫，这是从乡亲这个含义上叫的。你们叫我刚晓，这是从出家人这个含义上叫的……在我们的思维习惯里，每一个名字，就有一个所诠的体、所表的含义。名字多了，则其体也多，但事实上只是一件事，并不是有很多的体，所以这与事实不符。所以，“名有众多”只是分别有种种，这是遍计执，依他起本身还是一件事，就是说，多体和依他起不合，这就证明多体是违背真相的，是不符合依他起的。“由名不决定，杂体相违故”，这是第三方面。名字也不是决定的，就是说如果我想把户口本上的名字改成观世音，这也行。我叫释迦牟尼也可以。我叫刚晓，你要是想叫刚晓也没什么不行的。我给自己取个名字叫老虎这不是也行吗～～就是说，一个名字指很多事物也中，只不过这不方便，体就杂了。所以根据名字而推测义这是会起烦恼的。这就从三个方面说了，依他起与遍计执是不相符的。

此中有二颂

用二个颂子把前边儿说的概括一下。

由名前觉无 多名，不决定

成称体，多体 杂体相违故

“由名前觉无”是第一方面，称体相违。“多名”是指第二方面，多体相违。“不决定”是第三方面，杂体相违。通过这三个方面，就知道遍计所执的虚妄分别执著和依他起是不相符的。

法无而可得 无染而有净

应知如幻等 亦复似虚空

“法无而可得”，说，遍计所执性是在似义显现（似义显现本身是依他起）的如幻诸法上生起种种的执著，执著他是真实的。就像把绳执著成蛇，这就出现了问题。所执著的蛇是无所有的，但是我分明看见蛇了，根本没有蛇就是“法无”，但我又确实看到了，这就是“而可得”，看到了所执著的境界。我们一般的说法，有桌子你才能看见桌子，没有桌子你能看见桌子吗？不能，但看蛇就是，没有法却“可得”。第三句“应知如幻等”是解释法无而可得这个问题的。幻化师幻化出一匹马，马不是真实的，但是你看见了。事实也象这一样，虽然没有真实的诸法，但还是能够认取的，这样你就生出颠倒想，生起执著。所执著的境界是没有的，可你认为是真实的、是不虚妄的。第二句是“无染而有净”，遍计所执是污染，由遍计所执而引起种种烦恼，要是遍计所执是毕竟空的，那就根本没有染污，因而也就没有离染这回事儿。有污染才可以除染污，污染就是遍计所执，现在你说遍计执空无所有，这就成了根本没染污，没有染污有断染污的事儿吗？没有。没有断污染之事儿又怎么能有清净呢？这问题大了，我们知道，自性本净，现在推出来了不能有清净这回事儿，这是咋了？“亦复似虚空”，无著论师拿比喻来说。就像虚空一样，虚空中飘浮着烟云尘雾，烟云尘雾并没有把虚空染污，可是烟云尘雾被风吹走以后才能显现出本来清净的虚空。也就是说，圆成实性并没有被遍计所执染污，但是得断除惑障之后才能显出他的清净。这在《圆觉经》中是拿金矿比喻的，“譬如销金矿，金非销故有，虽复本来金，终以销成就，一成真金体，不重复为矿。”

复次，何故如所显现实无所有，而依他起自性非一切一切都无所有？

“复次，何故如所显现实无所有”，说，为什么明明我看见的却是没有的呢？明明我看见蛇了，可却是没有的，没有我怎么却看见了呢？“而依他起自性非一切一切都无所有”，遍计执是没有的，但依他起自性是有的，依他起就是以阿赖耶识为种子而显现出来的一切如幻的诸法。遍计执没有，可依他起却有。为什么依他起不象遍计执那样也无有呢？遍计执从哪儿来，就是从依他起而来，要是没有遍计执，是不是依他起也不应该有？外人这一问是什么意思，比如说吧，有了儿子才能叫父亲，要是没有儿子，你是谁的父亲，也就是说，父亲是依儿子而有的，父亲比为遍计执，儿子比为依他起，既然遍计执是没有的，是不是儿子也是没有的？要依得互依呀～～就是说，生下儿子的时候，同时就具备了儿子和父亲，同时有的。“而依他起自性非一切一切都无所有”的“一切”是指我们凡夫现在所有的见闻觉知，这些都是遍计执，“依他起自性非一切”就是指依他起不是我们凡夫的见闻觉知，我们凡夫是见不到依他起的，我们凡夫所见到的一切遍计执，其实是根本就不存在的。

此若无者，圆成实自性亦无所有；

外人说遍计执没有，为什么依他起不也没有呢？无著论师说了，如果依他起也象遍计执一样没有的话，那么圆成实也就成立不了拉，为啥？因为圆成实性是我们在依他起上观察到似义显现无所有而显出来的，要是没有依他起，我们根本就不能这样思维观察了，既然不能这样思维观察，圆成实就显现不出来了。

此若无者，则一切皆无。

依他起要是没有了，一切法都无从建立了，我们是在依他起上成立遍计执、圆成实的，不要搞错，依他起是个平台。

若依他起及圆成实自性无有，应成无有染净过失。

依他起没有了，圆成实也就没有了。这样的话，“应成无有染净过失”，圆成实自性是圣人所证悟的境界。依他起的就是阿赖耶识，它是我们无始以来的种种烦恼杂染、业杂染、生杂染等集聚成的，是我们流转生死的根本。要是没有的话，生死没有了，当然解脱也就没有了。注意，我们经常是一说到圣人的境界就说是清净的，这是我们站在凡夫的立场上说的，我们说圣者给我们不一样，就说我们是烦恼的，他就该是清净的，也就是说，我们一听到清净就不由的用二元对立的清净来说，实际上佛教说的清净有二义，一个就是二元对立，而另一个是超越二元对立的，那是不垢不净，无以名之，假名为净，实际上圣人的境界是假名为净，可不是二元对立的净。不过无著论师在这句话中的染净之净是二元对立的清净，因为他不是在给圣者说法，所以要用二元对立。但是要知道，二元对立从本质上来说不是佛教。

既现可得杂染清净，是故不应一切皆无。

我们现在实际上是能够觉察到有众生的流转生死杂染（就是依他起），也有证悟圣道者（那就有清净的圆成实），既然我们觉察到了有凡夫有圣者，所以“不应一切皆无”，就是说，不能不承认有依他起、有圆成实性。这就是承认了三性。依他起、圆成实都有，不过是遍计所执没有而已！这儿也注意，我们说觉察到了生死凡夫，也觉察到了证悟圣道者，我们现在觉察到的证悟圣道者是谁？就是祖师，不过祖师到底是不是证悟圣道者，未必，但我们必须说他们是，这样我们才能弘法。比如说我们总说某祖师证果了，其实我们根本就不知道他到底证了没有，可我们要是说佛教中间没有证果者的话，还有人来学佛教吗～～遍计执就是执著那些幻有的假法是真实有，它实际上是没有的，但依他起是有的，依他起的有不同于遍计执所执的实有，而是幻有。本来是假有，凡夫非说是实有，这就是遍计执，圣者知道这假有并没有真实性可得，就是圆成实。

此中有颂：

这里有个颂子。颂子说的还是刚才说的，把刚才所说的含义用颂子再说一遍。

若无依他起 圆成实亦无

一切种若无 恒时无染净

要是没有依他起的话，圆成实也就没有了。要是依他起、圆成实都没有了，那么就永运没有染净的差别了。现在我们明明觉察到有染有净，所以必须得有依他起，有了依他起，才有在依他起上起的遍计执，这才能断遍计执证悟圆成实。这样，染净的因果都成立了，所以千万不可以否认依他起。

诸佛世尊于大乘中说方广教，

前面成立了所知依阿赖耶识，然后又解说了唯识无义的道理，既然知道了唯识无义的道理，那么就要用唯识无义的道理去疏通经典、解释经典。当然，只是选了一些经典来作代表的，它不可能把所有的经典都说说。第一个是先解释方广教。“方广”是十二部中的一部，《集论》中说是大乘经的总称。“方”就是法、佛法，或者说是法性、真理，“广”是指文句，用无量的文句来显示这甚深的佛法真理，方是指理，广是指教，方广教就是指大乘教典，说这里边儿说了很多可以证得无上菩提的法门，凭它可以破烦恼障、所知障。关于这一句，韩老是把它译成了“若诸佛陀薄伽梵宣说极广博大乘之教法”。一对照就知道了，玄奘法师译本中是“方广教”，其实就是大乘经的总称。先看大乘教典里边儿谈三性。我再强调一下，三性就是三种存在模式。

彼教中言：云何应知遍计所执自性？应知异门说无所有。

“彼教中言”，方广教里面说，“云何应知遍计所执自性”？方广教里是怎么讲说遍计所执自性呢？“应知异门说无所有”，“应知”就是应该知道，也就是实际上，方广教里是用了不同的理由、不同的方法来说一切法无所有的，也就是说在方广教里边儿就是着眼来讲遍计所执自性的。就是说，实际上在方广教里用了很多方法来说遍计执让我们明白它根本就是无所有的。里边儿说的有色、受、想、行、识不可得，也说过眼、耳、鼻、舌、身、意不可得，还说过阿耨多罗三藐三菩提不可得等等。佛教唯识把佛法归为三性，遍计所执自性是我们凡夫的境界，所以只说了这么简单的一句“无所有”。

云何应知依他起自性？应知譬如幻、焰、梦、像、光影、谷响、水月、变化。

方广教中是怎么来说这依他起性让我们容易明白呢？“应知譬如幻、焰、梦、像、光、影、谷响、水月、变化”，说，在方广教中是用了种种的比喻来说依他起的，这里举了八种比喻。接着还有对这八种比喻的说明，这儿先不说。我以前有一个佛教讲座，后来在香港给出版的，中间曾经说到，佛教说法有一个殊胜的法子，就是比喻，比喻既启迪智慧又不落所边，其他的方法很容易使我们落入所边。

云何应知圆成实自性？应知宣说四清净法。

方广教里是怎么说圆成实自性呢？说，主要是通过四种清净来说圆成实的。

何等名为四清净法？

是哪四种清净呢？

一者、自性清净，谓真如、空、实际、无相、胜义、法界。

第一是“自性清净”，所谓自性清净就是本来清净。你成佛之前它是清净的，你成佛后它还是清净的。说，既然成佛前它就是清净的，为什么我们觉察不到？有人说了，是客尘烦恼所障，这说法不能说不对，但我们明白吗？仔细想想其实我们不明白。如果说清净的佛性竟然能够被烦恼所障，那你这清净就是假的，你根本就不是清净。一灯能除千年暗，一智能灭万年愚，清净给烦恼是水火不容的。所以说我们实际上并没有把这个问题给弄清楚。只有一隐一现，没有真正显现！现在说自性清净，就是不增不减、不垢不净。这是指什么呢？说是指真如、空、实际、无相、胜义、法界。真如就存在于五蕴之中，它不是离开五蕴另有一个什么真如。佛教不讲本体，非要讲的话，应该是真如，可有多少大德都讲成阿赖耶是本体，根本就不对，阿赖耶是有为法，不可以作本体，只有无为的真如才可以。“真”是真实，“如”是没有差别。所谓没有差别，是指法的本体没有差别，虽然说缘生法各有各的因缘差别相，但其本体没有差别（其本体都是真如）。妙老举了《楞伽经》中的“涅槃离心意，唯此一法实，观世悉虚妄，如幻梦芭蕉”来说真如。“涅槃离心意”就是指佛所证悟的不生不灭的涅槃是离心意识的，这不可思议的境界不能用心意识去分别思惟的，要离名言相。“唯此一法实”就是指这么多的法，只有涅槃是真实的。“观世悉虚妄，如幻梦芭蕉”，世间的一切（有为）法都不真实，就像是幻化的、就象是作梦一样、就象芭蕉似的。幻化、梦这比喻常用，这“芭蕉”的比喻不常用，芭蕉树给别的树不一样，别的树有树干，但芭蕉树是一层一层包起来的，也就是说，我们看见芭蕉树的树干不是真实的树干，有树干，但不是真实的树干。幻术变化出来的马能看见但不是真实的。梦也是，能看见但不是真实的。它们都是虚妄的、靠不住的，但涅槃不是靠不住的。象净空法师说的，佛也不行，只有法身大士才行，就是胡说。在一切有为法中有诸法毕竟的道理，它是如如不动的，就叫真如，是自性清净的。注意一点儿，真如绝对不能受熏，象有些典籍中说的真如还要受熏、还要缘起世界，这是错误的。“空”，就是无障碍，空不障碍一切。不过用“空性”可能更好理解。“实际”的“实”是真实，“际”是究竟、边界，到了边际了也就是究竟了。“无相”，没有虚幻像、没有错乱相，就是我空、法空所显的真实性。我们给记成“无所相”，因为在唯识中是唯能无所，“能”是有的，只是没有“所”而已。“胜义”，“胜”是指佛的殊胜的智慧，“义”是境界，合起来就是佛的殊胜无分别智所证悟的境界。“法界”，“法”就是真如、空、实际、无相、胜义之类，“界”是因，“法界”就是圣人得成圣道的因。这是自性清净。当然，真如、空、实际、无相、胜义等，其实本是一回事儿，不过是随种种而立种种名而已。

二者、离垢清净，谓即此离一切障垢。

第二是离垢清净。就是经过三大阿僧祇劫的修行，远离了烦恼障、所知障的垢染。它和自性清净实际上是一种，就是在凡夫的时候叫自性清净，到成佛的时候，叫离垢清净。

三者、得此道清净，谓一切菩提分法波罗蜜多等。

第三是“得此道清净”，你要想得证圣果，你必须凭清净的教法，教法必须是清净的才能够保证你证悟的果是清净的。“得此道”的“道”就是道果。“谓一切菩提分法波罗蜜多”，“一切菩提分”就是三十七道品。三十七道品又称三十七菩提分。“菩提”是菩提果，有三种：声闻菩提、缘觉菩提、佛菩提，这里指佛菩提。“菩提分”的“分”就是因，成菩提的因。注意，三十七道品可不是小乘，是通于大小乘的。“波罗蜜多”就是六波罗密，或者说十波罗密。十波罗密后边儿还讲，现在就不说了。凭三十七道品、六波罗密等就可以证得无上菩提。

四者、生此境清净，谓诸大乘妙正法教。

第四是“生此境清净”，就是佛陀的言教，一般说成这样：能引生清净道的所缘境。这话别扭了一点儿，其实还是指佛菩萨所说的微妙正法。也就是说，诸佛的言教是生此境清净。你去学习这所缘境、正法，你就可以得到清净道。你学习正法，你就知道怎样修习三十七道品、六波罗蜜。

由此法教，清净缘故，非遍计所执自性；最清净法界等流性故，非依他起自性。

自性清净、离垢清净、得此道清净，都是清净的，现在说“诸大乘妙正法教”也是清净的，难道佛陀说的妙正法教就不能有方便法吗？为什么会有这样的问法呢？有人把佛法分为方便法、究竟法，认为究竟法好，方便法总是不圆满的，现在说这种想法是错误的。方便法也是圆满的。咱们都知道世俗谛、胜义谛，我们打心眼儿里有些不照世俗谛，其实世俗谛也是真理、胜义谛也是真理，我们还知道，真理只有一个，所以说世俗谛和胜义谛本是一个，不能不照它。方便法也好、究竟法也好，都是对真理的诠释，所以它们是一个。问“难道佛陀的法没有方便法”这问题者就是弄扭了。“由此法教，清净缘故”，说，妙正法教――也就是语言文字的佛法，他是能够引生清净无漏道果的因缘，所以他是清净的。“非遍计所执自性”，遍计所执是似义显现，妙正法教不是，你去思维妙正法教，可以使你得成圣道、使你成就菩提，他不是遍计所执。我们一般的名言是遍计所执了，但经论的名言，不是遍计所执，为啥它的名言不是呢？“最清净法界等流性故”，就是说，它是佛陀证悟真如之后，由大悲心等流出来的，它和最清净法界无二。而我们的名言是杂染识中等流出来的。佛陀证真如后，最清净法界等流出来的法，很善巧方便地对我们解说，这个解说方式很特别，既不落于普通的名言那种错误的行相，又能把我们导向一种特别的境界。这种法，跟世间所有的言说，都不一样。佛陀说法也是利用名言，但是他用特殊的技巧和方便，也就是非常善巧。所以佛说的法，跟其他世间的学问不一样。还有一句“非依他起自性”，咱们最前边儿就说过，依他起是啥？忘了？那就翻到20页看一下，“谓阿赖耶识，为种子虚妄分别所摄诸识。”这是依他起。而这妙正法教是如来的最净法界等流性，它不是杂染种子所现，所以他不是依他起性。只有三性，依他起、遍计执、圆成实，现在它不是遍计所执自性，又不是依他起自性，就只能是圆成实自性了。印顺法师说大乘妙正法教是文字般若，一切菩提分法波罗蜜多是观照般若，离垢清净、自性清净是实相般若。

如是四法，总摄一切清净法尽。

这四种清净，就总摄了一切清净法。

此中有二颂

接着说了二个颂子来进行概括。

幻等说于生 说无计所执

若说四清净 是谓圆成实

这是第一个颂子。“幻等说于生”，“幻等”就是幻化、焰、梦、像等八喻，“生”是缘生法。这第一句是说的依他起，说，幻、焰梦等这些比喻，就是说缘生法的，这是依他起。“说无计所执”，这一句是说遍计执的，说，遍计所执都是没有的，只不过是你执著为有而已。“无”就是指没有真实性。“若说四清净，是谓圆成实”，四种清净法是圆成实自性。韩老把它翻译成了这样：“显生依持如幻等，依于标志显示无。　　通过依此四清净、即是显示圆成实。”第一句是说依他起。第二句是遍计执，其中的“标志”就是名言。第三句、第四句是圆成实。

自性与离垢 清净道所缘

一切清净法 皆四相所摄

这个颂子就是四种清净。“自性”是自性清净，“离垢”是离垢清净，“清净道”是得此道清净，“所缘”是生此境清净。“一切清净法，皆四相所摄”，四种清净包括了一切清净。

复次，何缘如经所说于依他起自性说幻等喻？

刚才在说依他起性的时候，说了八个比喻，现在进一步把八个比喻说一下。把每一个比喻稍微解释几句。说，经典里用幻、焰、梦等八种比喻来讲依他起自性，为什么要用这比喻呢？

于依他起自性为除他虚妄疑故。

有的人对依他起自性有各种各样的疑惑，为了破除他们的疑惑，就用了这种种的比喻，也就是说，这比喻是为了破疑，也就是在告诉我们怎么样破遍计所执。

他复云何于依他起自性有虚妄疑？

到底在依他起上有什么样的疑问呢？下边儿开始具体说疑惑，并且说有什么样的疑惑该有什么样的比喻来解释。不过我们要知道，其实并不是一个比喻只能除一种疑惑，对应并不是那么的严密，实际上比喻有些是相通的。

由他于此有如是疑：云何实无有义而成所行境界？为除此疑说幻事喻。

“由他于此有如是疑”，因为有些人对依他起有这样的疑惑。“云何实无有义而成所行境界？”依他起是我们现前的虚妄分别心。说，到底怎么搞的，我们的心怎么能在根本就没有的事物上活动呢？“实无有义”，注意，一般“实无有义”是指遍计所执，但这里是指所遍计，遍计所执有能遍计，还有所遍计，这里只指所遍计。能遍计、所遍计都是依他起自性，这个一定要知道，千万不要弄错。所遍计是似义显现，似义显现就是由阿赖耶识的种子而表现出来的一切法，显现出来的法本身是没有真实性可言的，但现出来的相貌令你疑惑他是真实的，这相貌就有这欺骗性。“实无有义”就是指这个。比如说这张桌子，根本就没有桌子我怎么能在桌子上产生分别、产生执著呢？也就是说，根本就没有桌子，桌子怎么能够“成所行境界”？“成所行境界”就是成为引起（心识）现行的东西，“行”就是我们的心在似义显现上活动。既然根本就没有那个东西，我们的心就不该在那个东西上活动才对呀～～可实际上却是我们的心在桌子上活动了，这到底是怎么回事儿？“为除此疑说幻事喻”。幻术就是类似于现在说的魔术，大卫的魔术，那气势可不得了。一般的小魔术气势不足。我拿一块石头在台上，三摆弄两摆弄变出一只大象来，我变现出的这只大象其实是没有的，但在我们的眼前现出来的，确实是大象的形相，这就引起心识活动了。当我们通达了一切都是如幻如化的，这就和遍计所执性完全不同了。外人的疑惑是：根本就没有桌子，它能作为认识对象吗？经典中用幻化来作比喻：比如幻化出来的大象，根本就没有大象，但作认识对象还是没有问题的。

云何无义心心法转？为除此疑说阳焰喻。

这是说阳焰这个比喻所对治的疑问。“云何无义心心法转？”如果依他起不是真实的（遍计所执是一点儿影子也没有，依他起是没有真实性可得），那么我们的心怎么能够依它而现呢？就是说，如果没有桌子，为什么我的心在桌子上却产生了活动呢？这就说了阳焰喻。下过大雨之后忽然出了大太阳，水蒸气急速蒸发，象湖面一样，鹿太渴了，把它认成了水而要来喝水。这个比喻就是说，根本没有水，但是有一个水的虚诳像，虚诳像在我们乱识的攀缘下就活动起来了。这还是虚妄境界也能够使心依之而活动。这个比喻给幻术的比喻差不多，一直到下边儿的比喻。就是说你有疑惑，我说了个比喻，说了一个你还不十分明白，我就再说一个。看起来不是重复，实际上是义重――在有目的的重申、是强调、是进一步阐述。在《正理经》中把这也叫成重复。外人的疑惑是：没有桌子，我的心怎么能在桌子上产生分别？教典中说了阳焰喻：根本就没有湖水，但鹿也是可以在根本就不存在的湖水上产生认识的。

云何无义有爱非爱受用差别？为除此疑说所梦喻。

依他起不是真实存在的，为什么会在依他起上产生爱、非爱的受用差别呢？就是说，根本就没有桌子，我怎么会有喜欢这张桌子不喜欢这张桌子的不同感受呢？也就是说，没有这个真实义，可我却有可爱的受用境、不可爱的受用境，这是说不通的。“为除此疑说所梦喻”，梦里边儿的境界都知道是不真实的，但也有可爱的境界、恐怖的境等出现，这也是受用差别。就是说，境界的不真实并不耽误受用差别的建立。外人的疑惑：我怎么会对根本不存在的东西产生喜欢、讨厌的感受呢？经典中说梦喻：梦中的大老虎是不存在的，也不耽误产生恐惧的感受啊～～

云何无义净不净业爱非爱果差别而生？为除此疑说影像喻。

我们造恶业，就有不可爱的果报出现；我们造善业，就有可爱的果报出现。既然根本没有真实义，这善恶因果的道理能够成立吗？“为除此疑说影像喻”，“影像”就是照镜子时镜子里的影像。影像不是真的人，但影像是不是有的？确实有一个影像存在。因为外边儿有个真的人存在，所以镜子里相应地出现了影像。现在造业感果也是这样，虽然并没有真实的爱非爱果报实事差别（比如地狱狱卒打你，并不是真有狱卒），但因为有善恶之业因种子（阿赖耶识里有种子），爱非爱果报的差别，就像镜中影像似的。外人疑惑：既然没有义，我们就造不了善恶业（没有羊被我杀），所以善恶果报就有问题。经典中说了影像喻：只要有阿赖耶的业种子，就有善恶果报，果报就如虚幻的影像，业种子才是质。

云何无义种种识转？为除此疑说光影喻。

“云何无义种种识转”，这一个要与前边儿阳焰喻的疑惑分开，前边儿阳焰喻的疑惑是说，没有桌子我的心识怎么能在桌子上产生种种的分别？而这一个是说，没有境界就不能有种种识现行，境界虚幻，心识也必须虚幻。“无义种种识转”就是说，依他起是似义显现的，是名言种子的现行而出现了种种的分别心，这些分别心都是不真实的。现在的疑惑就是：既然分别心是不真实的，还能说有种种的识（分别心）生起吗？阳焰的比喻是说一切所缘的境界都是不真实的，就不应该有心识在境界上活动。这两个疑惑是不一样的。“为除此疑说光影喻”，就是说，光下面的影子是不真实的，但这不真实是相对于本质来说的，说本质是真实的，影是虚幻的。现在用光影做比喻，就是说，影虽不是真实的，但不能说影没有，还是有个影的。也就是说，我们心里的种种虚妄分别是不真实的，不真实也是有的，不过是有虚妄分别活动而已。

云何无义种种戏论言说而转？为除此疑说谷响喻。

依他起是没有真实义的，可为什么有种种见闻觉知的戏论言说生起呢？也就是说：要是没有真实义的话，我们的这些言说诠表还有意义吗？或者说，要是根本就没有实在的桌子，那么要桌子这个名字还有意义吗？“戏论”就是没有真实的意义的言论。“为除此疑说谷响喻”，“谷响”就是回声，对着空旷的山谷说话，就会有回音。回音就象有人说话一样，但实际上根本就没有人说话。这里用“回响”表示虚妄的意思。现在就是说，无义也会有种种戏论言说生起，就像空谷里的回音一样，虽然根本没有人说话，可也发出了声音。这里要注意一点儿，名言只是名言，与所诠表的义没有关系！名言本身是依他起的，名言所诠表的那个实际事物也是依他起的，只不过是没有你名言真正所指的那个莫须有的东西。

云何无义而有实取诸三摩地所行境转？为除此疑说水月喻。

真正的修行人说了，说，当我们得了三摩地之后，在禅定中现出种种的境界。一般说来，凡夫以散乱心所见的境界是虚幻的我们可以理解，但禅定者所现的境界也虚幻我们就不好理解了。为了让我们好理解这个禅定中的情况，经典中说了水月喻。这个比喻就是说，水中的月亮不是真实的，根本就没有一个月亮在水里边儿，不过是水清澈平静而已，水面平静了就会把天上的月亮映在水里面。我们的心是虚妄分别心，是散乱的，当我们修禅定的时候，就可以使它静下来，达到一定的程度，也就可以现出种种的境界，可是现出的种种境界也是不真实，像水中月似的。也就是说，不真实也会出现。

云何无义有诸菩萨无颠倒心，为办有情诸利乐事，故思受生？为除此疑说变化喻。

“有诸菩萨无颠倒心”，说，有些菩萨经过长期的修习，比如说到了等觉位的菩萨，或者说象文殊菩萨、观音菩萨等这些示现菩萨，他们根本没有颠倒心，没有遍计执。“为办有情诸利乐事”，他们为了度化众生，作利乐有情的种种事业，“故思受生”，就故意作出一点儿样子，作出一些受果报的样子。比如说释迦牟尼还头疼、还受金枪马麦之报等，这都是他们故意装出来的，装得太象了，以致于我们看不出来他是装的。法身大士是没有爱烦恼、见烦恼的，天台宗有一个说法，叫伏惑润生，或者叫留惑润生，就是说，如果他把一切的惑都断了的话，就出三界了，就没有办法度众生了，所以要留一点儿惑，来滋养生死。这的天台宗藏教的说法。法身大士是不需要的，有各种应化身来度各种众生。外人的这一个疑惑就是说，既然这是菩萨故意装出来的，就不是真的啰～～可是众生根本就是虚妄心，不是真实的，菩萨不是吃饱了撑的吗？还记得有一句话吗？实无众生可度！根本没有众生可度，菩萨作利乐有情的事儿干吗？“为除此疑说变化喻”，大神通者变化出种种境界，这是变化出来的，不是真实的，不过虽不真实变化还是有的。菩萨也是这样，众生是不真实的，是如幻如化的，但菩萨还是要做利益众生的事儿。利益众生了，众生还是无义的，并不是说利益众生了，众生就有义了。在众生来看，众生并不知道无义，所以众生还是觉得苦，这才需要菩萨来度众生。就是说，菩萨做种种的神通变化，来普度众生，也是无义的，但无义也不妨碍这件事的成就。中观也用这比喻，不过侧重点儿不同，中观说虽有种种相，但实际上是空无所有的。无著在这儿说，虽不是真实的，却显然可得。

世尊何故密意于梵问经中说：如来不得生死，不得涅槃？

长行中的《梵问经》就是《思益梵天所问经》。用三性的道理来解释《梵问经》中的问题。在这部经中，佛说了，“如来不得生死，不得涅槃”，这到底是啥意思？佛怎么这样说呢？佛这么说的密意是啥？关于“密意”下边儿有说明。佛本来说生死是苦的，涅槃才安乐，你看，佛初成道就讲苦、集、灭、道，现在他又说没有生死可得，也没有涅槃可得，这是咋回事儿？

于依他起自性中，依遍计所执自性及圆成实自性，生死涅槃无差别密意。

梵问经中为什么说无生死、无涅槃呢？就是因为这个。依他起自性就是指我们的分别心，一般说六识、八识，这部论说是十一识。在这依他起的一切识里，“依遍计所执自性”――随顺遍计所执自性，就是说，关于依他起，我们可以随顺染污的情形来说，也可以随顺清净的情形来说。这个“依遍计所执自性”，就是随顺遍计所执自性而说。而关于“遍计所执自性”，能遍计者还是识，就是妄想执著，随顺妄想执著时，就有生死流转的事情了。“及圆成实自性”，则是说，依他起自性，要是随顺清净圆成实自性来说的话，就有涅槃了。也就是说，生死也在依他起中，涅槃也在依他起中，也就是遍计执也在依他起中，圆成实也在依他起中。这样呢，在依他起上看，生死涅槃是无差别的。所以说“如来不得生死，不得涅槃”。

何以故？

为什么？也就是说，能不能说详细点儿？

即此依他起自性，由遍计所执分成生死，由圆成实分成涅槃故。

说，这依他起自性随顺了遍计所执性，就成为了生死，就不得涅槃。就是说，从随顺遍计执这一方面说，“如来不得涅槃”。这依他起自性要是随顺圆成实的时候，就成就了涅槃，就没有生死可得，“如来不得生死。”就是说，只是一个依他起自性，从它通于遍计所执自性、通于圆成实自性，就成为“不得生死，不得涅槃”。在《般若经》中则说，生死是因缘所生，因缘所生则无自性、毕竟空，所以“不得生死”，不得生死也就“不得涅槃”。没有生死可灭，也就没有涅槃可得。

阿毘达磨大乘经中薄伽梵说：法有三种：一、杂染分，二、清净分，三、彼二分。依何密意作如是说？

在《阿毘达磨大乘经》中，薄伽梵就把一切法分成了三种，“一、杂染分”，就是一切染污法。“分”就是部分，染污的部分。“二、清净分”，就是一切清净法。清净的部分。杂染分就是生死流转，清净分就是还灭涅槃。“三、彼二分”，就是通于污染、清净。“依何密意作如是说？”佛是根据什么样的深义而这样说的？

于依他起自性中，遍计所执自性是杂染分。

这句长行中的“依他起自性”就是这部论说的十一个识，这十一识都是依他起，而且这十一识包含了一切法。“遍计所执自性是杂染分”，遍计所执就是根本没有而妄执出来的，说这些就是杂染分，它包括烦恼杂染、业杂染、生杂染等。

圆成实自性是清净分。

“依他起自性”还是十一识，说，在这十一识上没有妄想执著，远离一切污染的就是清净的，这就是圆成实自性。

即依他起是彼二分。

依他起本身就是通于二分的，产生妄执了就是污染分，不产生妄执就是清净分。

依此密意作如是说。

这话本来是没有啥的，但妙老在这儿，说这和《大乘起信论》的真妄和合说是相通的，我倒不同意这说法，因为遍计所执是根本就不存在的，我们说它存在，这只是我们瞎搞，存在的是依他起，因为遍计执根本就不存在，所以没法和，根本和不起来。

于此义中以何喻显？

道理是这么个道理，但只讲道理很艰涩，能不能说个比喻呢？

以金土藏为喻显示。

这里就说了一个比喻，金、土、藏。金是金子，土是土石，藏是土石里含有金子的成份儿，也就是金矿石。这是比喻我们的虚妄分别心里不全是杂染，其实也有清净。这一个金矿的比喻实际上也是佛教中很常用的。在《圆觉经》等中都有。这就是我们常说的“一切众生皆有佛性”。

插问：说到佛性，还有一个无情有性的说法。

这个说法在天台的湛然大师这儿得到张扬。当然了，其根源象《楞严经》之类的，就有“草叶线缕皆有佛性”之说（原文为“草叶缕结，诘其根元咸有体性”，大正藏19册109页上栏），湛然大师在其《金刚錍》中有详细的论证。但其反面作用是极其明显的，在董平老师的《天台宗研究》中有一个说明，我看过，但我手边儿现在没这本书，一方法师有。可以说对无情有性的张扬是天台宗的一个败笔。（注：原文为，“……佛性的极大泛化却同时亦造成了足以消解佛教基本理论建构之目的指向的可能性，因为在无情有性的意义上，佛性已不再是众生独有的‘觉性’；佛性既遍在于一切有情无情，那末亦就不仅是一切众生平等，而且亦是众生与一切无情之物的平等。如果作为众生成佛之依据的佛性之义的确立乃是在本体论层面上对于主体性的一种建构，那末无情有性之说恰好又同样在本体论意义上解构了这种主体性。因此就无情有性之实质而言，它恰恰是对佛性学说之整体的一种本质消解。”）

譬如世间金土藏中三法可得：一地界，二土，三金。

这是具体来说金矿比喻。就是说，在这个金矿的比喻中，有三法可得：一是地界，二是土，三是金。“地界”的“界”就是藏的意思，其实就是金矿，金矿就是地界。在金矿石之中，里边儿有金子，有石头。这里“地界”就是比喻依他起，石头比喻遍计所执，金比喻圆成实性。

于地界中土非实有而现可得。

在这个比喻之中，地界是因，土、金是果。在金矿石还没有炼的时候，你并没有看到金子，你看到的只是土（石头），也就是说，在凡夫位，我们只能看见土，不过我们看到的不是真实的，虽然不是真实的，但确实是看见了。

金是实有而不可得；

金是真实的，可是我们却没有看见。土是“非实有”的，金是“实有”的。这是说，在金矿石里，我们看见了石头，但看不见金，当我们一炼，把石头给炼没了，石头是先有后没有，金子是一直有，先看不见后看见，从这个意义上说，土非实有而金实有。

火烧炼时，土相不现，金相显现。

这儿无著论师说炼金是用火烧的。这种方法现在是不用了，而且我也没听说过这种炼金子的方法，从前是土法炼金，在我们河南洛宁县西山底以前就有老百姓土法炼金，现在呢，国家开采，成了上宫金矿，就没有土法炼了，老百姓当然还是土法炼，不过抓住就不得了，因为矿成国家的了，老百姓不准开，你要炼就只能去偷国家的矿石，因为老百姓偷矿石，还酿成过暴乱，政府请了当地驻军去才摆平的。现在黄金的提炼一般得有研磨、加汞、去汞等步骤，不过金子的提炼方法很多，现在不管这个，就按火烧这种方法吧。用火烧炼时，从金矿里提炼出了金，土就不见了，金看见了。所以说土石非实有，金子实有。我们会想，土石也实有，黄金也实有，无著论师在这儿毕竟只是一个比喻而已。

又此地界，土显现时虚妄显现，金显现时真实显现，是故地界是彼二分。

在金矿中，当你在看见土石的时候，那是虚妄的，不是真实显现，它是经不起考验的，而金子是真实有，它能经得起考验，金子显现的时候，它就是清净的。“是故地界是彼二分”，也就是说，地界里有虚妄显现的土石、还有真实显现的金。“彼二分”就是指土石、金。

识亦如是，无分别智火未烧时，于此识中所有虚妄遍计所执自性显现，所有真实圆成实自性不显现。

这是说比喻是比喻啥的。“识亦如是”，识也象金矿一样通于二分，我们的虚妄分别识，就是阿赖耶识为种子、虚妄分别所摄诸识、十一识，都通于二分。“无分别智火未烧时”，无分别智是圣人的智慧，他好比是火，在无分别智之火没有烧我们的分别心的时候，就是指凡夫阶段，“于此识中所有虚妄遍计所执自性显现”，在凡夫阶段，我们的虚妄分别心里全是虚妄遍计所执自性所显现的境界，都是虚妄的。“所有真实圆成实自性不显现”，清净离垢的圆成实自性，或者说是离一切相的真如境界，它是不显现的。就是说，在凡夫的分别心里，绝对不会显现圣者的境界。这就给前边儿的“于地界中土非实有而现可得，金是实有而不可得”通上了。

此识若为无分别智火所烧时，于此识中所有真实圆成实自性显现，所有虚妄遍计所执自性不显现；

“此识”还是指我们的虚妄分别。说，我们的虚妄分别心被无分别智之火所烧炼时，情况就不一样了。就是说，修学戒定慧，到无生法忍的时候，就出现这样的境界。也就是说，我们的分别心，虽然周遍执著，很顽固地，但要是用无分别智去观察，修奢摩他（止）、修毗钵舍那（观）。先知境不可得，然后是心不可得，最后是智不可得。这时，“于此识中所有真实圆成实自性显现”，圆成实自性就现出来了。“所有虚妄遍计所执自性不显现”，虚妄遍计所执的妄想执著的境界，完全没有显现了。

是故此虚妄分别识依他起自性有彼二分，如金土藏中所有地界。

虚妄分别的识是依他起性，依他起自性里“有彼二分”，就是遍计所执自性的杂染分和圆成实自性的清净分，这二分。“如金土藏中所有地界”，就象比喻中说的，金矿石里有土石也有金子。我们的虚妄分别识里，有遍计所执自性，也有圆成实自性。

世尊有处说一切法常，有处说一切法无常，有处说一切法非常非无常，依何密意作如是说？

用三性也可以解释其他经典中的问题。现在就是解释其他经典。“世尊有处”，这里并没有具体说佛是在哪部经里说，只是说在有些地方。在有些经里，佛说一切法都是常住的，可是在有些经里又说一切法是无常的，在有些地方又说一切法非常非无常……这各种各样的说法，在表面上看是矛盾的，佛说话肯定不是无的放矢，一定有他的用意，那么，“依何密意作如是说”？这就提出了问题。

谓依他起自性，由圆成实性分是常，由遍计所执性分是无常，由彼二分非常非无常：依此密意作如是说。

“谓依他起自性”，这是指虚妄分别的识，说，因为圆成实自性，所以说是常。圆成实是诸法的空相，它是没有生灭的。“由遍计所执性分是无常”，因为遍计所执自性，所以说是无常。遍计所执是我们的妄想执著，当然是无常。“常”就是不变，遍计所执变化性很大，所以无常。再者，遍计所执本身是毕竟空的，依他起是如幻有、假有，遍计所执就是在如幻有上执著真实，这个真实根本就不可得的，是毕竟空的。“毕竟空”就是永远没有的意思。所以，无常有两个意思，一是变动很大，二是永远没有。“由彼二分非常非无常”，有圆成实自性所以是常，有遍计所执自性所以是无常，而依他起他本身，则是通于这两分的，也就是说，在依他起上看，又是非常，又是非无常。那么他是具足遍计执自性，所以是非常；他又具足了圆成实自性，是非无常。“依此密意作如是说”，佛陀就是因为这个所以说一切法常、一切法无常、一切法非常非无常。

如常、无常、无二，如是苦、乐、无二。净、不净、无二。空、不空、无二。我，无我，无二。寂静、不寂静、无二。有自性、无自性、无二。生、不生、无二。灭、不灭、无二。本来寂静、非本来寂静、无二。自性涅槃、非自性涅槃、无二。生死、涅槃、无二。亦尔。

“如常、无常、无二”，就象刚才说的，一切法常、一切法无常、无二。“无二”就是指非常非无常。同样的，我们还可以说“苦、乐、无二”，我们也可以说“净、不净、无二”，还可以说“空、不空、无二”等等。所谓“苦、乐、无二”，就是说，因有遍计所执而流转生死，这是苦，因有圆成实的大涅槃境界，这是乐，而依他起本身，是非苦非乐的，这叫“无二”。“净、不净、无二”也是这样，圆成实自性是清净的，他不受染污，所以是“净”。遍计所执是虚妄分别，是“不净”的。“无二”是指依他起自性，通于净不净。“空、不空、无二”也是这样。“空”是遍计所执自性，说它是我们的执著而已，其实根本就没有。“不空”是圆成实自性，说圆成实自性是不可破坏的。“无二”是指依他起自性。“我、无我、无二”也是这样，“我”是遍计执，说我根本就没有，但我执著其为有。“无我”是圆成实。要是反过来解释，说“我”是圆成实，圆成实自性是常恒不变的不可思议境界。说“无我”是遍计所执自性，说也能说通，不过不习惯，我们习惯了人无我、法无我，一下子说“无我”是遍计执，有点儿不习惯。“无二”是依他起自性。“寂静、不寂静、无二”还这样说。“寂静”是圆成实自性，“不寂静”是遍计执。“不寂静”就是流动、生灭变化，虚妄分别就有这些生灭变化。“无二”依他起自性。后边儿的“有自性、无自性、无二。生、不生、无二。灭、不灭、无二。本来寂静、非本来寂静、无二。自性涅槃、非自性涅槃、无二。生死、涅槃、无二。”都是这样说。就是说，从圆成实自性的角度来说如何如何，从遍计所执自性的角度来说如何如何，从依他起自性的角度来说无二。

如是等差别，一切诸佛密意语言，由三自性应随决了，如前说常无常等门。

“如是等差别”就是指前边儿说的常、无常，苦、乐，净、不净等等的不同情况。“一切诸佛密意语言”，说，这都是诸佛的密意语言，“由三自性应随决了”，这些语言表面上看好象是矛盾的，但你要是能用三自性去思维观察，就完全可以抉择、可以通达、可以明了，不会有疑问的。“如前说常无常等门”，就像刚才说的用三自性来解释常、无常一样。

此中有多颂：

下边儿无著论师用颂子的形式来说。

如法实不有 如现非一种

非法非非法 故说无二义

“如法实不有”，按遍计所执自性来说，我们遍计所执的一切法其实是没有的。“如现非一种”，虽然我们所执的境界是没有的，但是我们分明看见了许许多多的东西，“现”就是显现出来，“非一种”就是很多。“非法非非法，故说无二义”，“如法实不有”是“非法”――法不可得，“非非法”是“如现非一种”，“故说无二义”，“非法非非法”就是无二，也没有法，也没有非法。这一个颂子韩老又依藏文译了一下，是这样的，“如其诸法非是有，如众多行相显现，如是诸法及无法，显示无有二之义”。尤其是这个“无有二之义”，咱们现在太喜欢“二”了，干什么都要“二”，“二”就是二元对立。一说长，就立马知道是有个短来与之对应，说要是没有短的话，根本就没有长可言了。这种思维方式禁锢着我们。后来佛告诉我们根本就没有二，世界的真相是“不二”的、是“一合相”，于是我们就拼命地要把二给合起来，这在佛教中的表现就是什么禅净合一、禅净双修之类的，实际上这是不对的。

依一分开显 或有或非有

依二分说言 非有非非有

上一个颂子说“无二”，这个颂子是说三分，就是三自性。“依一分开显，或有或非有”，“一分”就是依他起自性，或者是单说遍计所执性、单说圆成实自性。“开显”就是解释明白，把道理显示出来。把依他起按圆成实自性这一方面来说的话，可以说是“有”，要是把依他起自性按遍计所执性这一方面来说的话，就是“非有”――不可得。“或有或非有”的这两个“或”字儿，是“有”的意思，就是“有有有非有”；也可以说是语助。“依二分说言，非有非非有”，“二分”是指依他起性通于二分。说，要是按依他起性自身来说的话，那就是非有非非有了。

如显现非有 是故说为无

由如是显现 是故说为有

这要说无和有了。“如显现非有”，遍计所执是非有，根本是连一点儿的影子也没有的。我们虚妄分别心的遍计所执所显现的一切法，用正智来观察时知道它们是没有的。“是故说为无”，所以说是没有的。“无”是指遍计所执的境界。“由如是显现”，这是指依他起。由于我们无始劫来的虚妄熏习，在阿赖耶识里留下了很多的虚妄种子，这些种子在缘具的情况下生起现行，生现行的时候，就显现出了一切法，“是故说为有”，因为有一切法的显现，所以就说“有”。

自然自体无 自性不坚住

如执取不有 故许无自性

“自然自体无”其实是“自然无、自体无”。这四句颂子其实是说无自性的，说为什么无自性呢？这四句颂子就说了四个理由：因为自然无，所以无自性；因为自体无，所以无自性；因为自性不坚住，所以无自性；因为如执取不有，所以无自性。关于“自然无”，170页世亲释中说，“自然无者，由一切法无离众缘自然有性。”这倒很明了，就是说一切法的生起一定要待众缘，他不可能不待众缘自然地就现出来，所以没有自然地生一切法的道理，这就是“自然无”――诸法皆不能自然而有。“自体无”世亲释说是“由法灭已不复更生故。”，就是说，事情过去就没有了，它的自体已经灭掉了。也就是说已经感过果的业没有再受报的可能了。世亲释、无性释都是这样说的。妙老说还有一个解释：这个因缘所生之法，因要是不同，所生法就一定不同，缘要是不同，这个法也一定不同。说从这儿就可以看出法是没有自体的。自体随因缘而变化，不能离开因缘而有不变的体性。我用手敲桌子，与我用铁锤敲桌子，发出的声音就不一样，可见声音是无自性的，说这叫“自体无”。“自性不坚住”，说，一法在生起的当下它就灭了，生即是灭，没有一刹那的安住，所以说是无自性的。“如执取不有”，关于无自性的理由，刚才说的自然无、自体无、不坚住这三个理由，是大、小乘共通的，而这第四个理由“如执取不有”，则是唯识不共于小乘的说法。“如执取不有”就是说，你这一念分别心在一切法上的执著，所执著的境界是没有的，就是说，遍计所执是不可得的。就象在绳子上面执著有蛇，蛇是根本就没有的。最后一句“故许无自性”，是通于四个理由的。

由无性故成 后后所依止

无生灭本寂 自性般涅槃

前边儿说了，因为自然无所以无自性，因为自体无所以无自性，因为不坚住所以无自性，因为执取不有所以无自性，我们就用这四无性来观察思维一切法，发现都不出这四种无自性，都是空无所有的。先看前两句，“由无性故，成后后所依止”，“后后所依止”就是指这个颂子第三句的“无生”，我们把这四句颂子放在一起看的话，实际上就是：因为无（自）性，所以“无生”。就是说，你用前边儿那个颂子中说的四无性来观察一切法，发现一切法都是无自性的、都是空无所有的，“空无所有”就是“无生”――无生就是不可得。既然“无生”就是没有“法”生，没有法生，也就没有法灭。有生才有灭，无生也就没有灭。既然无生灭，所以就是“本寂”。当我们这样观察一切法，发现它们本来就是寂灭的，本来就是不可得的。“自性般涅槃”是说，诸法本来寂灭、本性就是涅槃、就是不生不灭。“般涅槃”就是入于不生不灭的境界。前边儿那个颂子说了诸法无自性，这个颂子就说，因为无性，所以无生，这个无生要以无性为依止。这五个颂子最好背会。

复有四种意趣，四种秘密，一切佛言应随决了。

前边儿说过要说秘密意趣，就在这儿说。“意趣”就是别有用心，醉翁之意不在酒。“意”是心意，“趣”就是趣向，心趣向另外一个地方了。也就是另有所指。这是说佛陀说法不是字面意思，还有深义。“秘密”就是从表面上来看的话看不明白，他的真实用意不是明白地说出来的。也就是说，我们的水平不够，所以佛没有一下子给我们讲真话，而是用方便善巧的方法来慢慢引导的。现在这句话就是说，佛陀说法我们都可以随顺这四种意趣、四种秘密来抉择，都可以这样来说明。

四意趣者：一、平等意趣，谓如说言：我昔曾于彼时彼分，即名胜观正等觉者。

先来解释四种意趣的第一个，平等意趣。什么是平等意趣？无著论师举了这样一个例子，说，比如说佛经里面有这样的话，佛说：“我昔曾于彼时彼分，即名胜观正等觉者”，就是说，我过去曾在另一个时候、另一个地方，叫过毗婆尸佛。“我”是释迦牟尼佛的自称。“胜观”就是毗婆尸如来。“正等觉者”就是无上正等正觉者。佛说，我就是过去的毗婆尸佛，我们知道，释迦牟尼佛并不是毗婆尸佛，毗婆尸佛是过去七佛之一，明明不是为什么佛说他是呢？这就是“平等意趣”，佛这么说的意思，其实是想说佛佛道同、法身无别的，在平等意义上来说，此佛即是彼佛。释迦牟尼佛这句话你只能按平等意趣来解释，不然的话，就说不通了。

二、别时意趣，谓如说言：若诵多宝如来名者，便于无上正等菩提已得决定。又如说言：由唯发愿，便得往生极乐世界。

关于这别时意趣，无著论师是举了两个例子。“谓如说言”，就像佛在经典里说，“若诵多宝如来名者，便于无上正等菩提已得决定”。就是说，你念诵多宝如来的名号，就可以得证无上菩提。这就是咱们常说的，“一声阿弥陀，即时成正觉”。这别时意趣就是说，佛确实这么说了，但佛的意思可不是说你当下念一声佛号，当下就成正觉了，而是说，你现在念了佛，你终有成佛的时候。“别时”就是另外一个时候。“又如说言”，经上还有这样的说法，“由唯发愿，便得往生极乐世界”。只要你发愿往生极乐世界，你就生到了极乐世界。这都是别时意趣――另外的时候，不是当下。你当下念多宝如来，当下也成不了菩提的，你当下发愿往生，可你当下还没有往生。你当下念了多宝如来名号，你熏习种子，然后展转增上，终究要得无上菩提。你当下发愿，就在阿赖耶识里有了一个名言种子，然后熏习增上，是能够往生极乐世界的。正刚法师说这别时意趣是“针对懒惰众生而说”。

三、别义意趣，谓如说言：若已逢事尔所殑伽河沙等佛，于大乘法方能解义。

什么是别义意趣？“谓如说言”，比如经上这样说，“若已逢事尔所殑伽河沙等佛，于大乘法方能解义。”就是说，如果一个人发心承事、供养殑伽河沙那么多的佛，“殑伽河”就是恒河，本来这个“殑伽”的意思是天上来，在印度人的心目中，恒河是神圣的，是从天上来的，所以把恒河称为“殑伽河”，“殑伽河沙”，你说恒河里有多少沙子？不知道，但数量很大是绝对的。现在一个人发心要供养殑伽河沙那么多数量的佛。经上就说了，说有人要是发心供养恒河沙那么多的佛，则他对于大乘义理就能通达了。咱们知道，你如果一心注意该怎样供养佛陀，这与通达义理没有因果关系，供养佛陀是福德，而通达义理是智德。但这里佛就是这么说。这就是别义意趣――根本是两件事儿。

四、补特伽罗意乐意趣，谓如为一补特伽罗先赞布施，后还毁訾；

这一个我们习惯上是称为众生意乐意趣。“补特伽罗”就是众生、有情，严格来说是“数取趣”。“意乐”，通俗地说就是高兴、欢喜。这个众生意乐意趣就是说，佛陀说法是随着众生的欢喜而说的。现在都得这样，人们听不得真佛法的，于是就给说掺点儿假的佛法，他们把这个称为方便说法。其实是佛菩萨才能方便说法，他们有这个本事，我们没有这个本事，你一方便就只能出下流了。这里呢，无著论师也举了一个例子，“谓如为一补特伽罗先赞布施，后还毁訾”，这个例子很简单，就是说，佛对一个人先说布施有多大多大的功德，但到后来又说布施并不是好的佛法，只是一个善根而已，还喝斥布施。这是为什么？因为你悭，所以佛劝你布施，但后来你又执著你布施了有很大的功德，所以佛又喝斥布施。佛陀这么样说法给我们不一样在哪儿呢？我们是先作了事儿然后给自己找借口、找辩护的理由，而佛陀不是。这不是佛法有矛盾，而是佛的善巧，善巧了众生才能得到利益，你要是老板住一点儿，那不行。就是常说的，“有禅有净土，犹如带角虎，现世为人师，来世作佛祖”。你既知禅宗的奥秘又知道净土宗的奥秘，你需要用什么度我就用什么法门度，你适合修禅我就教你禅，你适合净土宗我就教你净土宗，这样的时候，我是现世就是可以为人师，我是够格的老师，来世我可以成佛作祖――菩萨以五明而成就，什么都得懂，你只懂你那一点儿就行了？不行的。人在修行的路上绝对不是只用一个法门的。我举过一个例子，比如说我到北京去，我得用到好多的交通工具，首先得走路下楼，然后是公交车，然后是电梯，然后是火车或者飞机，然后是打的，再走路上楼。也就是说，我们得知道我们当下的位置，我现在就在火车站候车室，可你让我坐公交车，这行吗？不行。长行中的“毁訾”，是说你该换方法了，也就是该舍弃了。舍弃是很重要的，比如说我已经证初果了，你必须得舍弃初果方才能证二果，你要是不舍弃初果，一直在享受初果的法喜，你就不能上进了。

如于布施，如是尸罗及一分修，当知亦尔。如是名为四种意趣。

佛陀“先赞布施，后还毁訾”，佛对布施这个法门是这样子的，“如是尸罗”，佛对尸罗这个法门也是这样子的。“尸罗”就是持戒。“及一分修”的“一分修”是禅定，是世间禅定。“当知亦尔”，也是这样的态度，就是说，佛会先赞叹后毁訾。佛陀就是这样让你展转进步的。“如是名为四种意趣”，这就是四种意趣。

四秘密者：

四秘密是什么呢？下边儿说明。刚才的四意趣是从佛菩萨说法方面而说的，这四秘密是从众生获得利益方面而说的。

一、令入秘密，谓声闻乘中或大乘中，依世俗谛理说有补特伽罗及有诸法自性差别。

四秘密的第一个是令入秘密。什么是令入秘密呢？实际上就是方便权巧。说，本来佛教是讲无我的，可是，人们一听说无我，于是就心生恐惧，对佛教产生恐怖感，于是不来学佛了。《宗镜录》中说，“先以欲钩牵，后令入佛智（大正藏48册529页下栏）”。也就是说，先不要给讲真话，听见真话而不恐惧的大丈夫的不多的。听说无我就不学佛了，于是佛说有我，有补特伽罗。佛这话就是“依世俗谛理”而说的，注意，很多人把世俗谛理解错，实际上世俗谛、胜义谛都是真理，我们老爱对世俗谛说长道短的，这是不可以的。这“依世俗谛理”的意思就是指从凡夫可以理解的角度来说的，是一个方便说法而已。你给他说有我，他就容易相信生死流转，就容易相信善恶果报，这样就不敢作恶，他害怕堕三恶道～～说有补特伽罗就有这好处，所以佛就这么说了。“及有诸法自性差别”，佛说这个是为了让修行者知道没有堕入断灭见。一说人无我、法无我，有的人说，这不是堕入断灭见了吗？佛就说“有诸法自性差别”――有色、受、想、行、识诸法的自性差别，这样他就不断灭了，这也是佛接引众生的一个方便。这令入秘密就是说，本来是诸法皆空，但佛为度化某一类众生，所以方便地说有我、有诸法，反着讲，这是一个方便。令入秘密是说按世俗谛说有补特伽罗等，让众生进入佛法而出离生死。

二、相秘密，谓于是处说诸法相显三自性。

关于这个相秘密，比较难说，为什么？因为光看论文，感觉不到秘在哪儿。实际上秘密就是不直接说，要曲里拐弯地说。印顺法师讲到这儿有一个附论，用《大乘庄严经论》说，“为令小乘悟入无我，要使他不恐怖，所以说诸法有自性差别，这是令入秘密（初时教）。依三无性说一切法空，是相秘密（第二时教）。二秘密的本意在此。”妙老法师在解释的时候，说，“‘说诸法相显三自性’，是以三无性为秘密，说三自性，佛的那个意趣是在三无性那里，就是隐藏那个三无性。”我是这么想的。我们凡夫世界里提倡说老实话，看见啥说啥，就是说要直接表述，现在佛不是，是要隐曲地说。“谓于是处”的“处”，就是指你认取的境界，你对于自己认取的境界，用语言表述出来，当我们用语言表述的时候，我们立马就会认为语言所指的义一定是有的。但实际上语言所表示的义是根本就没有的，即遍计所执是没有的。而圆成实是有的，是真的有，依他起是缘起有。所以，这儿的相秘密，应该是说，我们所面对的一切法，实际上都可以用三自性来表述。所以说，我们讲说三自性就是要表述我们所认识的境界背后所隐藏的秘密。印顺法师所引的《大乘庄严经论》，其中对于相秘密是这样说的，“相节者，应知于分别等三种自性，无体无起自性清净，说一切法故。（大正藏31册620页中栏）”《摄大乘论》中是“相秘密”，在《大乘庄严经论》中是“相节”，这是不同的译者所用的词不一样而已。相秘密是说佛说三性教，让众生悟入诸法的真实相。

三、对治秘密，谓于是处说行对治八万四千。

什么是对治秘密？“谓于是处说行对治八万四千”就是说，佛在这个地方说了八万四千法门，“行”就是动，就是心动，也就是烦恼。说，佛说了很多对治烦恼的方法，但当把你的烦恼对治完了之后，对治方法也就不要了。所以说，这对治秘密是说，佛说八万四千法门是要对治我们的烦恼的。

四、转变秘密，谓于是处以其别义，诸言诸字即显别义。

“转变”就是换个角度，不用你习惯了的说法来解释。“谓于是处以其别义”，佛说法的时候，用的还是我们的语言，但其作用给我们平常说的话完全不一样，平时我们说的话可以引来烦恼，但佛陀用这语言可以消除我们的烦恼。这个就叫转变秘密。

如有颂言：觉不坚为坚，善住于颠倒，极烦恼所恼，得最上菩提。

这是说转变秘密的一个颂子。“觉”是智慧。“坚”就是难调难伏，地藏经中说阎浮提众生，难调难伏，这就是坚。这里指我们的烦恼、妄想难调难伏，想让下它停下来是很难的。这里我给你说一下静坐，在静坐的时候，老师会教你一些法子，比如数息，当然了，什么法子都行。让你观呼吸，一、二、三、四就这么来，你会发现你连一百也数不到，甚至连五十数到的都很少。老师说，这是前方便。其实这是老师的一个诡计，他只是在告诉你，让你知道你的心有多乱而已。平时的时候，你的心太乱了，但你不觉得，你不知道你的心有多乱，你还认为你的心很静呢，这时候让你知道真相。当你知道你的心有多乱的时候，其实老师的目的已经达到了。

你坐下观佛像也可以，咱们这办公室里贴着一张阿弥陀佛像，你就来观这张佛像，我告诉你实话，其实观佛像并不能使你成佛，你的目的是成佛。你会说了，我是想成佛的，所以才来学习、修行，老师教我观佛像，可是这观佛像要是根本就不能使我成佛的话，我学这干吗？其实老师就是在让你知道你的心有多乱而已，先让你知道这个事实真相。观佛像即使观成了也不能使你成佛，何况你也不一定能观成呢～～为什么说观成了也不能成佛呢？我只能给你胡说一个理由，因为这理由根本就不对：佛像只是一半，只有脸前边儿这一半，没有背后这一半儿，观成了也是一半儿佛。那你说我应该怎么观，实际上应该这样观：观想我自己就是佛菩萨，佛菩萨是慈悲的，所以我也要是慈悲的，佛菩萨是智慧的，所以我也要是智慧的等……这样慢慢观你就成佛了，而不是你坐下观这张佛像。观这佛像的目的其实只是想让你知道你的心有多乱而已。

可能你会说，我知道我的心很乱，不，你还是得观，因为你不直观。对凡夫说法，直观最好。我记得小时候刚上学老认为一百是可大可大一个数了，忽然间学到一万，想不到一万是多大一个数，问老师：一万到底有多大？老师就说，这个星期天你就作作业，作业就是从一写到一万。结果从早上就开始写，小孩儿们写字儿再慢一点儿，写到下午也没有写到一万。星期一老师说，这下你知道一万有多大了吧～～这就直观了。扯远了。咱们还说这个颂子。我们的烦恼难调难伏，这就是“坚”，本来是坚的我们老认为它“不坚”，它太坚了以致于我们认为它不坚。就象电影银幕上的特写，胶片是一直活动的，一秒钟过几张？记不得了，就是因为跑得太快了以致于我们认为它静止了。这张桌子也是，因为它生灭得太快了，以致于我们认为它不生灭。颂子中的这个“不坚”，是指把烦恼给调伏，它很难调伏就叫“坚”。难调也得调，不是说不调了，一定要调伏，调伏了之后就叫“不坚”，调伏之后的“不坚”给我们凡夫认为的“不坚”，两个字儿是一样的，但意思完全不一样。这就叫转变秘密。

下一句是“善住于颠倒”，“颠倒”就是错误。把无常认为是常，这就是错误。把无我当成我，这也是颠倒。但是佛说的涅槃四德的常、乐、我、净，不可是我们的把无常认成常，把无我认成我，佛是把认清了无常的真面目叫常，把认清了无我的真面目叫我，也就是说，佛说的常、乐、我、净，给我们的错误见解从文字表述上是一样的，但本质完全是两回事儿，这叫转变秘密。也就是说“觉不坚为坚”是说的禅定，“善住于颠倒”是说的般若智。“极烦恼所恼”，众生有太多的烦恼，难调难伏，菩萨为了度化我们这些刚强众生，我们就特别讨厌这些菩萨，因为菩萨是逆我们而行的。我们习惯于作坏事儿、喜欢作坏事儿，比如说打牌上瘾，佛千方百计地来对治，这就使我们讨厌。关于上瘾，我就想到了佛教上瘾，我们现在有不少的佛教徒其实不是学佛，只不过是有些上瘾而已。比如说打七，他打一个七、二个七，十个七的，哪儿有打七的他就去赶场子。我们知道，学佛和对佛教上瘾根本是两码事儿。如果你是学佛的话，那里边没有痛苦、忧虑，如果你是对佛法有瘾的话，佛法也会使你产生忧虑――你变成了佛的盲从者。这样，你的生命就变得非常的复杂。

平时就得用功学佛，打七的时候只不过是强调一下要用功而已。我们惯于这样作，佛菩萨不让我们这样作，于是我们讨厌他。可佛菩萨又没有脾气，不管我们怎么讨厌他，他也不舍弃我们，使得我们极其的讨厌他。这就是“极烦恼所恼”。讨厌有时候的表现很奇怪，还可以用喜欢来表现，比如说佛菩萨来救我，我会爱上他这也不是不可能，这也是烦恼。“得最上菩提”，我们也要有禅定、有般若，得证无生法忍，然后去度众生，不怕被众生讨厌，也就是我们努力修习，最后我们就可以得证无上菩提。这个颂子有点儿物极必反的意味儿。

若有欲造大乘法释，略由三相应造其释：

这是说，有人想来解释大乘经典，想给大乘典籍作注释。这主要是发菩提心的缘故，如果要作这件事儿，得依三相来作，也就是说，要从三方面来解释大乘教法。哪三方面呢？

一者、由说缘起，二者、由说从缘所生法相，三者、由说语义。

第一是“说缘起”，就是从因上来解释。诸法之因是啥？阿赖耶！第二是说缘生，就是是从果上说。“由说从缘所生法相”，阿赖耶识是一切种子识，所生的一切法相，就是前面说的相识、见识等，就是七转了。第三是“由说语义”，也就是赞叹菩萨的功德。造论要从这三方面来造。

此中说缘起者，如说：言熏习所生，诸法此从彼，异熟与转识，更互为缘生。

先说“说缘起”。什么是说缘起？无著论师举例子说，比如说吧，“言熏习所生，诸法此从彼，异熟与转识，更互为缘生”。比如说这个颂子，“言”就是名言，每一法对应的都有能诠的名字，既然有能诠的名字儿，当然有所诠之义，这能诠、所诠就是名义，名义就是我们内心的分别，就是说有“名”的时候心才会分别，有能分别就有所分别。这样就够成了三件事：名、义、觉，这三法是不相离的，就是说，你只要心一动，名、义、觉就具备了，你心一动，就熏习阿赖耶识了，阿赖耶识里就把你所熏习的情况摄持了下来。这个“言熏习所生诸法”，就是说，由于有名言所以就熏习了种子，有了名言种子就会生出一切法，也就是说，诸法是名言种子所生，名言种子是能生，诸法是所生。“此从彼”，名言熏习能生诸法，那名言熏习是怎么有的？“此从彼”，就是说，此名言种子由诸法而生，因为诸法就是我们的分别心，我们的分别心一动就熏成了名言种子，名言种子一动就现出一切法。佛教的缘起就是这样的。

用最简单的话说，就是种子生现行、现行熏种子。说明白点儿，我们心一动就是缘起。因为心一动，一定是有名言种子，有名言种子它才能动，可你心一动，同时又熏成了名言种子，这就叫做缘起。一切法都是这样的，世间法、出世间法都是这样，不过世间法是杂染的，出世间法是清净的。“异熟与转识，更互为缘生”，这两句话其实还是前边儿两句儿，意思一样，重复一遍儿而已。“异熟”就是阿赖耶识，就是一切种子识。“转识”就是前七识，“转”就是生起，前七转识是以阿赖耶识为因缘而生起的。异熟识和转识是“更互为缘生”，“更互”就是相互辗转，辗转为因缘。异熟识和转识是互相为因缘而现起，这就叫缘起。这个颂子同时也告诉我们一点儿，就是自作自受，自己的转识与异熟识互为因缘，没有别的，容不得别人来插手，这就是自作自受！有人说要替别人消业，这都不是事实，只是一个愿而已，与人欢喜而已，佛菩萨也不可能替别人消业的。

复次，彼转识相法，有相、有见，识为自性。

下边儿开始说缘生。“彼转识相法”，“转识”是七转识，七转识是从阿赖耶识的名言种子而生起的。转识的相法“有相、有见”，前头说过的，识都有见分、相分。“相”是根身器界。根、境、识都是相识。这《摄大乘论》中开列了十一识：身、身者、受者识、彼所受识、彼能受识、世识、数识、处识、言说识、自他差别识、善趣恶趣死生识。哪是相识？哪是见识？忘了？翻到23页，看，“若眼等识，以色等识为相，以眼识识为见，乃至以身识识为见。若意识以一切眼为最初法为最后诸识为相，以意识识为见。”就是说，五根色识，色、声、香、味、触、法，这是境。眼识、耳识、鼻识、舌识、识身都是识，色、声、香、味、触、法也都是识，不过是相识。“见识”是眼识识、耳识识、鼻识识、舌识识、身识识、意识识，或者加上末那识识，这是“见识”。阿赖耶识它是因识。由阿赖耶识的因识现起这个相识和见识。“识为自性”，在我们习惯上，“见”是识，“相”好象不是识，比如说色、声等，这怎么是识呢？它也是以识为自性的，它离不开识，要离了识，他没有体性，他是阿赖耶识的名言种子所变现的，是如幻如化的，是虽有但不真实的，它是分别心的境界，要是离开了虚妄分别心，就无法可得。相也好、见也好，都被七转识包括。

又彼以依处为相，遍计所执为相，法性为相，由此显示三自性相。

这是说转识有三种相，就是三自性。刚才说了，转识就是相识、见识，“有相、有见”，三自性判摄一切法。“彼以依处为相”，“彼”就是转识。说，转识有依他起相。“依处”就是指依他起，因为依他起是遍计执、圆成实的依止处，所以叫依处。这是说，缘生转识是由阿赖耶识的种子现起的，是有依他起相的。第二相是“遍计所执为相”，遍计所执是依他起的似义显现被虚妄的执著心所执著，转识也被虚妄执著，这就是他的遍计所执相。遍计执是毕竟空的，毕竟空了还怎么遍计执呢？就是因为名！一有名字，心识在缘取名的时候，就有了遍计执，要是没有名字，遍计执是没有办法生起来。“法性为相”，就是说，你要是通达了遍计执是毕竟空的，法性就显现出来了，这是圣人的境界。

如说：从有相、有见 应知彼三相

这是无著论师引了佛说的二句偈：“从有相有见，应知彼三相”，在相识、见识里边儿，就具足三相。相识、见识都是从阿赖耶识的种子现起的，就是依他起相。依他起里面有名，有了名，就有执著心活动，这就是遍计所执相。但执著心的境界是毕竟空的，这就是圆成实相。

复次，云何应释彼相？

凭什么说在相识、见识里有三相呢？你说说我听听。下边儿就解释了。

谓遍计所执相，于依他起相中实无所有；圆成实相于中实有。

“谓遍计所执相”，先说遍计所执相，说，遍计所执相在“依他起相”里头是“实无所有”的，是根本就没有的。依他起相是相识、见识从阿赖耶识里的种子显现出来的，是似义显现、如幻如化的，他自己本身还是无有少法可得的，是不真实的，哪儿还管得了你遍计所执～～就是说，它自己还是泥菩萨过河，自身难保，还管你遍计所执？不管！依他起虽然不是真实的，但它似义显现的相貌好象是真实的，我们就在这上面产生执著了，这就成就了遍计所执相。这实际上只是你的执著而已，它根本是“实无所有”。这儿我插一点儿，为什么它不真实可似义显现的相貌要好象真实呢？为什么要这样？难道它不能不真实就老老实实地表现出自己不真实吗？为什么要迷惑众生呢？佛教中常举照镜子的例子，就是说，镜子里的相给自己是最象的了，要是我往镜子前一站却显出来了别人的像那才怪。我往镜子这儿一站，镜子里的像给我是最象的，象成什么样子呢？象成给我的实际情况完全相反，我的左成了像的右，我的右成了像的左。就是这样：给自己截然相反的是最象的。依他起也是这样，心识的活动给表现出来的相貌是截然相反的：我们看见有的实际上恰恰没有，我们看见没有的实际上恰恰有。佛菩萨知道这个，可我们不知道，所以佛是还灭生死，我们是流转生死。我们说有的佛说没有，我们说没有的佛说有。这才是真佛法。咱们的法师们现在在干什么？在随顺众生流转生死，然后给自己找借口，说是方便权巧，骗得了别人你骗不了自己的。现在说，依他起是似义显现，不是真实的，但执著心认为它真实，这就是遍计所执相。但是，我们修习佛法，慢慢地我们认清楚了，是没有一丁点儿的犹豫，绝对认清楚了，这样我们就把我们的认识转变了过来，知道了依他起是毕竟空的，遍计所执是无所有的，这时圆成实就显现了。你恍然大悟，圆成实原来真的有啊！

由此二种非有及有，非得及得，未见已见真者同时。

“由此二种非有及有”，“二种非有及有”就是遍计执非有、圆成实有。“非得及得，未见已见真者同时”，这句话应该是“非得及得，未见真者、已见真者同时”，“未见真者”就是我们这些没有见到圆成实性的人，就是凡夫。“已见真者”是指圣者，他们见到了圆成实。说，这两者是“同时”的，这个“同时”就是说圣者具备“非得及得”，凡夫也是“非得及得”，不过圣者是“非得”遍计执而“得”圆成实，凡夫是“非得”圆成实而“得”遍计执。

谓于依他起自性中，无遍计所执故，有圆成实故。

说，在依他起自性里，遍计所执是不可得的，是毕竟空，而圆成实性是有。

于此转时，若得彼即不得此，若得此即不得彼。

“于此转时”，“转”是生起现行，就是指我们的分别心在依他起里活动的时候，“于此”是指依他起活动的时候，“若得彼即不得此，若得此即不得彼”，要是得遍计所执就不能得圆成实，要是得圆成实就不能得遍计所执，不能二者同时兼得，就是鱼和熊掌不能同时兼得。

如说：

依他所执无 成实于中有

故得及不得 其中二平等

这是用偈颂再说一下。“依他所执无”，在依他起的似义显现相识、见识中，根本就没有遍计所执的境界可得。“成实于中有”，但在如幻如化的依他起里，圆成实的诸法空相是有的。“故得及不得，其中二平等”凡夫得到了遍计执，同时就得失去圆成实，圣者得了圆成实，你就得失去遍计执，有一得有一失，这是平等的，不能让一个兼得遍计执和圆成实。

说语义者，谓先说初句，后以余句分别显示。或由德处，或由义处。

“说语义”就是赞叹佛菩萨的功德。“先说初句，后以余句分别显示”，就是说，先说一个总纲、提要，然后再一句句来分别解释。这里又分成两段儿：“或由德处，或由义处”，就是说，或者从德处来说语义，或者从义处来说语义。“德处”的“德”指圆满无上菩提的佛陀的功德，就是果德。“义处”的“义”是指菩萨在因处修行时的功德。所以“或由德处，或由义处”实际上就是说，或从果方面来说，或从因方面来说。

由德处者，谓说佛功德：最清净觉，不二现行，趣无相法，住于佛住，逮得一切佛平等性，到无障处，不可转法，所行无碍，其所安立不可思议，游于三世平等法性，其身流布一切世界，于一切法智无疑滞，于一切行成就大觉，于诸法智无有疑惑，凡所现身不可分别，一切菩萨等所求智，得佛无二住胜彼岸，不相间杂如来解脱妙智究竟，证无中边佛地平等，极于法界，尽虚空性，穷未来际。

先从“德处”说，就是从果方面来说。是“最清净觉”，什么是最清净觉？下边无著论师用了二十一句话来解释。所谓“最清净觉”，就是有“不二现行”的功德，有“趣无相法”的功德等等。

最清净觉者，应知此句由所余句分别显示，如是乃成善说法性。

说，什么是最清净觉呢？下边儿有二十一句来“分别显示”，这二十一句就说清楚了什么是最清净觉，这是说得最圆满的，是“善说”。

最清净觉者，谓佛世尊最清净觉，应知是佛二十一种功德所摄。

“最清净觉”是什么？这是成佛以后的事情。其余的都不是最清净，只有佛陀的才是最清净。“应知是佛二十一种功德所摄”，“最清净觉”的内容就是佛的二十一种功德。下边儿一句一句来说二十一种功德。前边儿无著论师用了二十一句话，下边儿有二十一种功德，实际上可以一一对应。

谓于所知一向无障转功德，

这个与“不二现行”对应，就是对“不二现行”的解释。说，啥是“不二现行”？“谓于所知一向无障转”，就是说，佛对于所知的一切品类差别，连一点儿障碍都没有，知道得清清楚楚。所谓“不二现行”的“二”就是指有知道的、有不知道的，有障碍、无障碍，但佛不是，佛是“不二”，没有不知道的、没有障碍。我们把这个称为“一向无障转功德”，就是没有一点儿障碍，什么事情都清清楚楚，也就是大自在的境界。这个可以体现佛的“最清净觉”。

于有无无二相真如最胜清净能入功德，

这个与“趣无相法”对应，就是对“趣无相法”的解释。说，啥是“趣无相法”呢？“趣”就是趋向、进入。我初得无生法忍，证入了无相法，但还没有圆满，要继续精进修行。到成佛的时候就圆满证入无相法了。这个“于有无无二相真如最胜清净能入”，说，真如是无二相的。“无二相”的“二相”是有、无。真如就是圆成实性，他不是“无”。真如超越了有、无二相。“最胜清净”的“最胜”是说，佛陀超过了一切二乘圣者、超过了一切菩萨。“清净”就是远离一切尘垢。“能入”是指能够证得无相的真如。其实真如是二乘也可以得证，只不过二乘的不是最胜而已，佛陀才是最胜。

无功用佛事不休息住功德，

这一句对应于“住于佛住”。“住于佛住”的“住”有天住、梵住、圣住三种。“住”就是内心的境界，如果内心是在天的境界里活动，就叫天住。象我们现在，内心是散乱的，就叫散乱住，不过我们不把散乱住算作住。“天住”一般得是色界天、无色界天，我们说的天住是在色界天、无色界天里的四静虑，初禅、二禅、三禅、四禅。佛只住第四禅，佛要得证无上菩提，得在第四禅得证。得证阿罗汉者，有的在未到地定里就可以得证阿罗汉，有的在初禅、二禅、三禅、四禅，这不一定。辟支佛也可能是在初禅、二禅、三禅、四禅得证，也是不一定的，但要想成佛果，必须在第四禅得证。我们就把第四禅的天住叫“佛住”。再看“梵住”，梵住就是慈、悲、喜、舍四无量心。在梵住里边儿，我们把悲无量心叫“佛住”。因为大悲心是佛所具足的不共功德。第三是“圣住”，天住和梵住是通于凡夫的，凡夫也能住在里边，这个圣住是不共于凡夫的。圣住有什么？有空、无相、无愿三种，佛是住在空里，我们把空叫“佛住”。所以说，“住于佛住”，就是佛住于第四禅，住于悲无量心，住于空，这叫“住于佛住”。“住于佛住”是“无功用佛事不休息住功德”。这个“无功用佛事不休息住”是说，佛广度一切众生，但在度化众生的时候是无功用的，所谓“无功用”就是不刻意，也就是度而无度，随缘而度。“佛事”是指度化众生成佛的事业，可不是什么打普佛、放焰口等。“不休息住”，说，佛度化众生的时候不刻意，但也不不度，不停歇，一直在度众生，他是把不休息当成休息。

于法身中所依意乐作业无差别功德，

这一句与“逮得一切佛平等性”对应。“逮得”就是获得，获得一切佛的平等性。你得到这样的功德，就和一切佛是平等的。看“于法身中所依意乐作业无差别功德”，“所依意乐作业”，“所依”是佛度化众生的无边妙用，他凭的是什么？就是佛的清净的无分别智慧，就是说，是以无分别智为所依。“意乐”是后得智。“作业”是行动，普度众生的行动。一切佛的“所依、意乐、作业”是无差别的，这就是“逮得一切佛平等性”的功德。

修一切障对治功德，

这与“到无障处”对应，就是由有障碍的地方达到无障碍的地方了。要想到无障碍的地方，你就得努力修行，这“修一切障对治”，就是把烦恼障、所知障都对治掉。

降伏一切外道功德，

这与“不可转法”对应。“不可转”就是不能干扰，指佛所施设的教法、佛所证悟的真理是不能干扰的，你也干扰不了。佛所施设的教法就是五蕴、十二处、十八界，四念处、四正勤、四如意足，七觉支、八正道等等，你能否认吗？根本否认不了。佛所证悟的真理更是不可干扰了。因为佛的教、证是干扰不了的，所以佛能降伏一切外道。

生在世间不为世法所碍功德，

这与“所行无碍”对应。“所行无碍”的“行”就是活动，就是来来去去。佛有自己的世界，但他想到我们的世界来，是很随便的，他想来就来了，不受一点儿的限制、障碍，我想到什么地方去可不行，想到月亮上去，能吗？不是你想去就能去的。“生在世间不为世法所碍功德”，“生在世间”，就是说，佛为了度化世间众生，从佛的世界到众生的世界来。“不为世法所碍”，佛不受世间法的障碍，不被世间法所影响。世间法就是八法、八风：利、衰、毁、誉、称、讥、苦、乐。“利”就是得到了如意，“衰”就是失掉了如意。“毁”就是背后讲你的坏话，“誉”是背后讲你的好话。注意，不是当面讲，是背后讲。“称”是当面赞扬你，“讥”是当面耻笑你。“苦”是顺苦受，“乐”是顺乐受。世间人都受这八法的影响，而佛陀不受。

安立正法功德，

这一句与“其所安立不可思议”对应。安立的是什么？是“正法”，这都是名言安立，但这安立是不可思议的。这个安立是佛的后得智的功德。佛能够取无相法证入真如，那是根本智的功德。因有大悲心，所以能够为一切众生演说佛法，这是后得智的功德。佛的后得智是究竟圆满，所以叫“不可思议”。辟支佛一般是现神通度众生的，他不说法，这是因为他的后得智不圆满。阿罗汉是说法的，阿罗汉的说法是因为佛已经安立好了，他照着来就行了。

授记功德，

这“授记功德”与“游于三世平等法性”对应。“游于三世平等法性”是说，佛的大智慧能游于过去世、未来世、现在世一切法的差别性，因为佛有这种无障碍的境界，所以他能够授记。“授”就是“与”，就是把未来的事情给你说明清楚，这叫“授记功德”。“游于三世平等法性”的“平等”是指佛看未来的事情与看现在的事情一样清楚，同样清楚叫“平等”。

于一切世界示现受用变化身功德，

这给“其身流布一切世界”对应。“其身流布一切世界”是说佛身能到一切世界去度化众生。佛有三身，法性身、受用身、变化身。法性身是自受用身，而受用身和变化身是可以度化众生的。登地的菩萨所见的就是千丈大身，当然了，各地所见皆不相同。凡夫见的是丈六比丘身，这都不一样。畜生见的是畜生身，天人所见是天人身。长行中的“受用”就是受用身，“变化”就是变化身。也就是对不同的众生现不同的身，“应以何身得度即现何身度之”。我们常说的八相成道的这个佛是变化身。

断疑功德，

这与“于一切法智无疑滞”对应。说，佛对于世间法、出世间法种种法相、法性，佛都是了了分明无有疑惑的，所以能断一切众生的疑问。

令入种种行功德，

这一句给“于一切行成就大觉”对应。说，对于一切行为，佛都圆满觉悟了。“一切行”就包括众生的烦恼心行、罪障心行、业障心行，乃至于你遇见三宝、栽培善根的心行，清净的、染污的心行等等，佛都明了。佛能够教授一切众生，教导你学习佛法，契入佛法中的清净法门，这都叫“行”。佛能让你学习空、无相、无愿的法门，学习三十七道品的法门，学习六波罗蜜的法门等，反正能令你契入种种法门，令你得入圣道，佛有这样的功德。

当来法生妙智功德，

这一句与“于诸法智无有疑惑”对应，“当来法生妙智功德”是指佛能够观察到这个人什么时候可以入圣道，辟支佛、阿罗汉都不行。你想跟罗汉修行，罗汉观察你的宿世因缘，发现你没有善根，他就把你给舍弃了，他观察到某个人有善根，他就去度化，但佛来观察的时候，他超越罗汉的境界。

如其胜解示现功德，

这一句对于于“凡所现身不可分别”。“如其胜解示现功德”的“胜解”就是有力量的思想，强有力的观想。无量众生各有各的观想，佛陀都能随顺，“如其”就是随顺，随顺无量众生的不同的胜解，示现不同的身相出来度化他。

无量所依调伏有情加行功德，

这一句与“一切菩萨等所求智”相应。一切的菩萨都希求成就这样的智慧。就是说，佛有这种智慧，能够调伏众生。众生修行，也是发大心修行，可是当业障来了的时候，就不能进步了，但佛能调伏，他告诉你一个方法来忏悔业障，把这个障碍消除了你就能上进了。佛的这个圆满智慧，是无量的众生都可以依止的，我可以依止，你也可以依止。

平等法身波罗蜜多成满功德，

这一句与“得佛无二住胜彼岸”对应。“得佛无二”的“无二”，就是平等，就是无差别。“波罗蜜多”就是“彼岸”，你“波罗蜜多成满”了，就是成功了、圆满了，这就叫“住胜彼岸”。这是佛的涅槃境界。前边儿是度众生的，这是佛自身的功德。

随其胜解示现差别佛土功德，

这一句是与第十七句“不相间杂如来解脱妙智究竟”对应。刚才说的“如其胜解示现功德”是现身，这一句“随其胜解示现差别佛土功德”是现佛世界。这一句说，佛陀随顺众生的不同程度，众生有什么样的胜解，佛陀就示现什么样的佛土。“不相间杂如来解脱妙智究竟”的“不相间杂”就是不混乱，就是说，虽然同在一处，但佛所示现的无量差别的佛土是不混乱的，你所见的佛世界是这样，他所见的佛世界是那样，不可思议得很，这是佛的妙智究竟的境界。就是说，在这儿有初地菩萨、有二地菩萨，他们坐在一起听佛讲法，他们所见皆不相同。

三种佛身方处无分限功德，

这与“证无中边佛地平等”对应。“三种佛身”就是自性身、受用身、变化身。“方处”是所居住的地方。“无分限”，就是没有限制、没有间隔。比如说我们说阿弥陀佛在极乐世界，药师佛在东方净琉璃世界，阿弥陀佛的佛国给药师佛的佛国有间隔，这就叫有分限，但实际上这是我们凡夫的分别而已，因为我们凡夫有分别心，所以佛就随顺我们凡夫而说，但实际上是没有分别的。我们还说，佛陀的法身在什么地方，报身在什么地方，化身又在什么地方，这也是我们的分别而已，都不是事实真相，实际三种佛身没有分限，各佛土也是没有分限的。“证无中边佛地平等”的“中边”，“中”是中央，“边”是边地，有中有边，论中是“无中边”，就是没有中央和边地的不同。三身就没有中边的分别。

穷生死际常现利益安乐一切有情功德，

这和“极于法界”对应。“极于法界”的“法界”，就是佛的妙正法教，也就是十二部经。这个“穷生死际常现利益安乐一切有情功德”是说佛是穷生死际演说十二分教，不间断、长时期地去利益一切有情。“穷生死际”的“生死际”，就是有一个范围，在这个范围之内是有生死的，一过这个界儿、这个范围，就超越生死了。“穷生死际”就是穷尽了生死的范围，就是过了生死的界儿，众生过了生死的界儿，就是众生没有生死了。说，从现在开始，一直到众生都超越了生死，佛一直说法度众，度过生死之后就不需要佛来说法度你了。

无尽功德等。

这个“无尽功德”是对应于“尽虚空性”。“尽虚空性”也就是尽虚空界，虚空是无量无边的、无生无灭的、无有变异的，现在说佛的法身就象虚空一样，无有穷尽，利乐有情，永不休息。“无尽功德等”的这个“等”字，前边儿是二十一句，对应的功德只二十句，这就少了一句，前边儿还有一句“穷未来际”，现在没有什么功德来对应，那么就让这个“等”字儿来对应，“等”都说成佛的是“究竟功德”。

复次，由义处者，如说：若诸菩萨成就三十二法，乃名菩萨。

前面赞叹佛，这里又赞叹菩萨的道德，赞叹菩萨的境界。“如说：若诸菩萨成就三十二法，乃名菩萨”，说，菩萨成就三十二法，才能叫菩萨。哪三十二法呢？

谓于一切有情起利益安乐增上意乐故

这就开始说菩萨成就的三十二法了。首先呢，无著论师先总说一下。“于一切有情”，这是说菩萨的大悲心，是对于所有的众生的，菩萨度众生的时候，没有远近亲疏之分，所有人都度，你是我的仇人，我度，你是我的亲人，我也度。“利益安乐增上意乐”，菩萨利益众生，让众生得安乐的心，利益众生的心特别的切，所以叫“增上意乐”，就是说菩萨利益众生的心非常强烈，永不退转。“利益”是指菩萨教你的法子，不但可以让你现在得利益，而且让你将来也得利益，就是说菩萨教你的是长远的利益，现在的人的所为可能就是目下得利益，从长远来看可能是有坏处的。“安乐”就是从内心里感到快乐。利益和安乐有时候看起来不是那么的一致。比如说你打禅七，这是利益，可是你一下子努力地经行、禅坐，不得安稳的休息，你不一定觉得安乐。而你放逸，可能一下子你觉得安乐，但那不是利益。这一句的重点儿是“增上”――特别的强，我们有些凡夫也好心肠，但不一定是“增上”，菩萨绝对是增上。下边儿具体解释三十二法。无著论师是用了三十八句话来解释三十二法的。

令入一切智智故

为什么菩萨是“于一切有情起利益安乐增上意乐”？“令入一切智智故”，这是第一个原因。就是说菩萨利益安乐一切众生，他的目的，是教化众生使其都能够证入无上菩提。这个“令入一切智智故”是菩萨“于一切有情起利益安乐增上意乐”的第一个理由。无著论师在赞叹佛的时候，说佛是“最清净觉”，佛的最清净觉有二十一句来体现，对应的有二十一种功德。现在赞叹菩萨的时候，说菩萨有三十二法，用三十八句来体现，对应的有十六种业，现在我把对应的业放在三十八句这儿对应起来说，我给画一个表。三十二法、三十八句、十六种业对应起来。这样看起来就清楚了。

菩萨三十二法、三十八句、十六种业相摄表

32法 | 38句 | 16业
1、 | 1、令入一切智智 | 1、展转加行业
2、 | 2、自知我今何假智故 | 2、无颠倒业
3、 | 3、催伏慢故 | 3、不待他请自然加行业
4、 | 4、坚牢胜意乐故 | 4、不动坏业
5、 | 5、非假怜愍故 无染系故 | 5、无求染业
 | 6、于亲非亲平等心故 于恩非恩无爱恚故
 | 7、永作善友乃至涅槃为后边故 于生生中恒随转故
6、 | 8、应量而语故 语业 | 6、相称语身业
 | 9、含笑先言故 身业
7、 | 10、无限大悲故 | 7、于乐于苦于无二中平等业
8、 | 11、于所受事无退弱故 | 8、无下劣业
9、 | 12、无厌倦意故 | 9、无退转业
10、 | 13、闻义无厌故 | 10、摄方便业
11、 | 14、于自作罪深见过故 | 11、厌恶所治业
 | 15、于他作罪不瞋而诲故
12、 | 16、于一切威仪中恒修治菩提心故 | 12、无间作意业
13、 | 17、不希异熟而行施故 布施 | 13、胜进行业
14、 | 18、不依一切有趣受持戒故 持戒
15、 | 19、于诸有情无有恚碍而行忍故 忍辱
16、 | 20、为欲摄受一切善法勤精进故 精进
17、 | 21、舍无色界修静虑故 禅定
18、 | 22、方便相应修般若故 般若
19、 | 23、由四摄事摄方便故 四摄
20、 | 24、于持戒破戒善友无二故 亲近善友 | 14、成满加行业
21、 | 25、以殷重心听闻正法故 听闻正法
22、 | 26、以殷重心住阿兰若故 住阿兰若
23、 | 27、于世杂事不爱乐故 离恶寻思
24、 | 28、于下劣乘曾不欣乐故 作意功德
 | 29、于大乘中深见功德故
25、 | 30、远离恶友故 助伴功德
 | 31、亲近善友故
26、 | 32、恒修治四梵住故 无量清净 | 15、成满业
27、 | 33、常游戏五神通故 得大威力
28、 | 34、依趣智故 证得功德
29、 | 35、于住正行不住正行诸有情类不弃舍故 御众功德 | 16、安立彼业
30、 | 36、言决定故 决定无疑教授教诫故
31、 | 37、重谛实故 财法摄一故
32、 | 38、大菩提心恒为首故 无杂染心故

对应着这张表来看的话，那就清楚。这第一句“令入一切智智”是给后边儿的“展转加行业”对应的。“令入一切智智”是说，菩萨利益一切众生，让他证得无上菩提，对应的“展转加行”是说，菩萨利益一切众生，但不是一下子就直接让你接触到佛法，得慢慢来，先让你作世间善行，然后让你三皈五戒之类，一步步地上进，展转上进。或者说是教大家，让大家互相展转帮助，互相上进，最后你可以得证无上菩提。这就是“展转加行业”。

自知我今何假智故

这是第二个理由，你看对应的表格，是“无颠倒业”。什么是“无颠倒业”？要想知道无颠倒业，就先得知道颠倒业。第180页，世亲论师在释中举了一个例子，说比如“劝饮酒等”，说这就是颠倒业。现在的净空法师，就说我有半斤的酒量，可我只喝一两，这是可以的，还说佛要是知道大蒜可以治疗癌症的话，他也是让吃的，这就是典型的颠倒业。出现了这样的事儿怎么办？这里就说了，“自知我今何假智故”，就是说，菩萨自己要反省自己，我这么说到底对不对？是我的智慧出了问题还是什么？就是说，菩萨学了一些佛法，但我相还在，用我相来学佛法，是会出现颠倒的，所以要修无我观。不然的话，就老作错事儿，自以为在行菩萨道，但其实是颠倒业。

催伏慢故

这个与“不待他请自然加行业”对应。我慢是很不容易除掉的。作为一个菩萨，就要不断地精进六波罗蜜，要时时调伏自己的心，千万不要让我慢占据心灵。我们知道，到七地菩萨还有些微的我慢心，所以这很不容易除掉。菩萨要努力把它催伏。怎样催伏？就需要“不待他请自然加行业”，所谓“不待他请”就是不用等别人来请，你自然就努力，努力干吗？努力作利益众生的事，自然知道要催伏内心中的我慢之类不如法的东西。

坚牢胜意乐故

这个与“不动坏业”对应。说这个“坚牢胜意乐故”，有这么一句话，叫能在大庙睡觉，不在小庙办道，什么意思？就是说在大庙里大家精进的话，在这么一个环境中，你自然无法懈怠，而小庙里无人管就容易放逸。所以要给大家一起。总说的时候说是“于一切有情利益安乐增上的意乐”，现在这个“坚牢胜意乐故”则是自己的胜意乐。大家都是好的，你一个人没法儿坏。就是说，社会的安乐的，社会里的每个人自然都是安乐的。反过来说，如果每个人都是安乐的，则整个社会就是安乐的。现在就是说，我们要发菩提心，也要劝大家都发菩提心。如果只我一个发菩提心，我就不能舍弃众生，既然不能舍弃众生，那么，众生在生死中流转，我就也得在生死中流转，苦吗？你说，那我就不干了，我先管自己吧，这就不是大乘了。如果说我自己一个人跑到深山禅修，我会感到很适意，可是我到众生中的时候，我看到众生太苦了，眼不见心不乱，见了就知道了。作为一个菩萨，知道了众生的苦，利益一切众生的誓愿不能退转，这就是“坚牢胜意乐”，就是说菩提心非常坚固。或者说，众生很难度，我要度化他，他会诽谤我，要不然我要度化他，他会爱上我，总之，众生特别难度，我刚度他出来，可不一会儿，发现他又掉到恶道去了，你看看地藏经，就因为这些众生，所以劳得地藏菩萨在地狱中来往不停。虽然众生如此，可是菩萨的心仍然不舍弃众生，这就是“坚牢胜意乐”。

非假怜愍故，于亲非亲平等心故，永作善友乃至涅槃为后边故

这三句与后边儿的“无求染业”对应。“非假怜愍故”，菩萨是怜愍众生苦而行菩萨道的，来利益众生的，如果是“假”的，所谓“假”的，就是说他其实不是真怜愍众生苦，而是表面上如此，但其实是为了名利，要是这样的话，你的所为根本就不是菩萨道。所以菩萨要有真的怜愍众生，发真慈悲心。在表中这个“非假怜愍故”后边儿还有一个“无染系故”，因为是“非假怜愍”，是真是，当然就没有杂染束缚。“于亲非亲平等心故”，在凡夫这儿，因为亲、非亲，所以关系就有远有近，这就心不平等，而菩萨是不管是亲还是非亲，同样对待，不讲人情。表中这个“于亲非亲平等心故”后边儿还有一个“恩非恩无爱恚故”，这是说，亲者就觉有恩，非亲者就觉非恩，我们对有恩者会爱，对非恩者会出嗔恚，但菩萨不会。“永作善友乃至涅槃为后边故”因为你的心中是纯然的慈悲心、平等心，所以就可以永远为众生的善友，一切为了众生，你就可以在最后入涅槃，宁愿为众生殿后。表中的“永作善友乃至涅槃为后边故”后边还有一句“生生恒随转故”，这是说众生在生死中流转，即使你流转了，菩萨的慈悲心仍然救度你，不会因为救过你一次你却不上进又掉到恶道里来了而烦你了，不救你了，他还是会救度你的。这三条合起来是“无求染业”，所谓“无求染业”就是指菩萨对众生无所求，不要求众生来回报你，纯是慈悲利益众生。

应量而语故，含笑先言故

这给后边儿的“相称语身业”对应。“应量而语故”，“应量”就是吃饭的钵，吃饭的钵叫“应量器”，这个“应量而语”就是说，菩萨在说法的时候要应不同的众生而说。吃饭的时候，你得知道饥饱，不知道饥饱的话，已经够了你还一直吃，那会吃死人的。菩萨为众生说法也是这样，要知道量，到时候就不能再说了，也就是说，不要一直地说，你追着人家说你要念佛呀，人家会讨厌你的，你还以为你怕别人掉恶道受苦，人家现在听你说法就够苦了。所以要注意量。所以说什么话，说多少，这都要随着所要度的这个人而不同，这就叫相称语业。“含笑先言故”就是说说法的时候要面带微笑，这是给人欢喜的意思。现在我们说法的时候会有一种我比别人深刻的这种姿态，很不好。这是指身业，要给人欢喜。

无限大悲故

这个与后边儿的“于乐于苦于无二中平等业”对应。“于乐于苦于无二”，作为一个菩萨，看见众生受苦，我就忍不住要救度他们。众生的苦有三种，这里的“于乐”就是坏苦，“于苦”是苦苦，“于无二”是行苦，用八苦说也可以，不过这儿无著论师是用三苦说的。看到众生有苦苦、坏苦、行苦，菩萨就发起“无限大悲”，无限大悲是指所有的众生都度，要是只去度苦苦者而不度坏苦者，那就叫有限。所以菩萨的慈悲心是无限。

于所受事无退弱故

这一个对应后边儿的“无下劣业”。这个“所受事”是指菩萨自己所要作的事儿，也就是度众生这件事，菩萨对自己所要作的事儿“无退弱”，“退弱”就是指在度众生的过程中觉得这事儿太难了，我不干了，或者说，我不管他们了，我管住我自己就得了，这叫叫“退弱”，菩萨不是这样的，虽然度众生这件事很难，但菩萨是有勇气承担的，他的大悲心是勇猛的。这个“无下劣业”的“下劣”是指退弱，要是退弱了就是下劣，菩萨不退弱就是“无下劣业”。

无厌倦意故

这一个对应于后边儿的“无退转业”。“无厌倦”就是说度化众生这件事儿是要长时间作的，不是一天两天，那是要很多劫持续地作的，我们可能前几天还行，还能保持热忱，但过不了多久就没劲儿了，就是后劲儿不足，可菩萨不是，他是一直满腔热忱地去作而没有厌倦的时候。对应的“无退转业”，“无退转”给“无退弱”稍微有点儿不一样，“退弱”是指少度点儿吧，“退转”则是干脆只管自己，干脆不管别人了。

闻义无厌故

这给“摄方便业”对应。“闻义无厌”就是说在听闻佛法的时候，从不厌足，就是说没有说我学这些已经完全够了，已经圆满了，因为在菩萨的眼里，一切法都是佛法，而我们可能说这是佛法，那不是佛法等，有这样的分别，菩萨没有这样的分别。“闻义无厌”就是一直需要学习、一切都需要学习。“摄方便业”是说，在我没有度众生的时候，我觉得可以了，但当去度众生的时候，我才发现自己的不足还多得很。所以，什么样的东西都得掌握，这样才能广度众生，不然的话，总是有限的。

于自作罪深见过故，于他作罪不瞋而诲故

这两句对应后边儿的“厌恶所治业”。菩萨在还没有成佛的时候，总还有不圆满的地方，“于自作罪深见过故”，菩萨自己作错了事儿，自己就承认错误。咱们凡夫不是这样，作错事儿了还要给自己辩解，把责任推给别人。“深见过故”就是深深地知道自己作错了，这个“厌恶所治”的“厌恶”是远离，指以后不再犯这错误了。“于他作罪不瞋而诲故”，你收徒弟了，徒弟有了错误，“不瞋而诲”，不要不高兴，要去教诲他，让他也“厌恶所治”，远离自己的错误。当然，不一定的徒弟，是别人有错，就得教诲，不过要善巧。

于一切威仪中恒修治菩提心故

这给后边儿的“无间作意业”对应。“于一切威仪中”，一切威仪就是行住坐卧所有的威仪。“恒修治菩提心故”，就是时时提醒自己不要失掉正念，时时要策励自己的菩提心。走路的时候注意，睡觉的时候也注意。对应的“无间作意”，就是不间断地如理作意，提起正念。凡夫是一下提起，一下又跑了，但菩萨是时时能提起。

不悕异熟而行施故，不依一切有趣受持戒故，于诸有情无有恚碍而行忍故，为欲摄受一切善法勤精进故，舍无色界修静虑故，方便相应修般若故，由四摄事摄方便故

这七句是对应于“胜进行业”。“不悕异熟而行施故”是说的布施。菩萨的大智慧者，同时菩萨的福德也是很好的，所以他时常能够对众生有所布施，法布施、财布施都有。“不悕异熟”是不悕求因为布施而得到什么好的果报，也就是他的利益众生是无条件的。“不依一切有趣受持戒”是说的持戒，说，受三皈五戒等，最少可以保证不失人身，不到三恶道去。但菩萨不是这样想的，他是“不依一切有趣受持戒故”，说，菩萨是自然而持戒，不是为了不失人身所以要持戒，不是为了什么所以要持戒，他纯粹是自然的。“一切有趣”的“有”是三有，就是三界，欲界、色界、无色界，“趣”是六道，就是说，他的心不是为了三界中的、六道中的什么而持戒的。“于诸有情无有恚碍而行忍故”是说的忍辱。众生触恼他，他不嗔恚，你要是一嗔恚，那就给众生有隔阂了、有障碍了，菩萨没有。“为欲摄受一切善法勤精进故”，这是精进，菩萨不会去作什么无益的苦行呀等，他只是为了积集无量无边的功德而精进修学。这主要是四正勤。“舍无色界修静虑故”，这是禅定。“舍无色界修静虑故”是说，菩萨修色界四禅、无色界四空定，但他不生到无色界天，因为在无色界天他没有利益众生的事情可做，他要失业了，所以他要到能行菩萨道、能弘扬佛法、能广度众生的地方去。“方便相应修般若故”，这是般若，其中的“方便”这个词，是指大悲心。要是没有大悲心那是声闻乘罗汉。菩萨不忘一切众生苦。“由四摄事摄方便故”，前头是六度，这是四摄，用四摄来引导众生。“四摄”就是布施、爱语、利行、同事。“布施”，财布施、法布施，菩萨用财物布施众生，用法布施给众生，还有一个无畏施。“爱语”，就是为他说佛法，这才是真实的爱护他，为他讲解佛法来消除他的愚痴。这叫爱语。“利行”，要他发起正行，就是开始修行，修四念处、四正勤、修八正道等，这叫利行。“同事”就是劝众生也修道，劝众生和自己一样也修行，大家都努力，最后都得圣道。“四摄”实际上就是信、解、行、证。这六度四摄对应的是“胜进行业”，就是说，菩萨修行这六度四摄，不断地用功、自利利他，功德展转地胜进，进而得证无生法忍，然后可以由初地、二地，渐次增上，直到无上菩提。“胜进”的“胜”，是有力量。

于持戒破戒善友无二故，以殷重心听闻正法故，以殷重心住阿兰若故，于世杂事不爱乐故，于下劣乘曾不欣乐故，于大乘中深见功德故，远离恶友故，亲近善友故

这八句对应“成满加行业”。“于持戒破戒善友无二故”，说，菩萨也要亲近善知识。善知识有两种：一个是持戒的善知识，一个是破戒的善知识。对于这两种善知识，菩萨都要亲近，不能因为他破戒了就不亲近他了。只要他能为你开演佛法，能为你破疑，菩萨就去亲近。也就是说，我只取他的长处就行了。要想挑毛病的话，阿罗汉也有毛病。菩萨要亲近善士的时候，要只取其长处。注意一下，这里说的持戒善友、破戒善友，实际上是指具足圆满德相的善知识和德相有缺的善知识。在《菩提道次第广论》中间，给出的善知识德相有十个，我把原书拿来了，614页，这是科判中的，正文是在24页，这里清楚、简单，正文中麻烦。具戒、具定、具慧、多闻、通达实相或教理、功德胜己、善说法、具悲悯、有勇猛、无疲厌。这一句长行中的“持戒破戒”就是指这十相圆满不圆满。“以殷重心听闻正法故”，“亲近善士”是干吗的？就是为了“听闻正法”，在听闻正法的时候要有“殷重心”，就是不要等，想着以后还有机会，这不行。“以殷重心住阿兰若故”，菩萨自己也要用功修行，修行的时候要在寂静的地方，就是环境要适合修行，你在城市中度众生是适合的，但在自己精进的时候还是寂静的地方好，这是指自己能把握自己的菩萨，要是我们凡夫，那还是大众熏修为好。这时候的“殷重心”，是不偷懒，在寂静的地方精进修行，一刻也不懈怠。“于世杂事不爱乐故”，对世间的杂乱的事，心里不欢喜。这是因为他通达了佛法，以佛法的价值观来看，世间的事情没有价值，所以他不爱乐。“不爱乐”就是要“远离”，表上这儿有一个“离恶寻思”，就是说，在内心里远离这些恶的寻思，恶的寻思就是杂染分别、妄想，这些都没有。“于下劣乘曾不欣乐故”，对小乘不欢喜。“于大乘中深见功德故”，喜欢大乘。注意，这是说，不喜欢只顾自己，而不是说小乘佛法不好。我以前说过大乘佛法是把小乘佛法含括在里边儿的，现在我们有些人说大乘佛法与小乘佛法是对应的，这不对，实际上小乘佛法这个集合是属于大乘佛法这个集合的。在“于下劣乘曾不欣乐故”和“于大乘中深见功德故”的后边儿，表中有个“作意功德”，就是指菩萨时时不舍弃无上菩提的的愿力。“远离恶友故，亲近善友故”，就是远离恶知识，亲近善知识。在刚才说的亲近善知识中，有一个破戒善知识，那是指虽破戒但能演说正法，这个“恶知识”则是指破了戒，他还不能演说正法。这八句话对应的是“成满加行业”，就是说，这亲近善士、听闻正法、住阿兰若、离恶寻思、作意功德、助伴功德都是“加行”你修学这些加行，可以使你成就无上菩提。

恒修治四梵住故，常游戏五神通故，依趣智故

“恒修治四梵住”的“四梵住”就是四无量心。菩萨要让自己的慈、悲、喜、舍时时增长强大。表中“恒修治四梵住”的后边儿有个“无量清净”，是说，四无量心成就了，则你的行为是清净的。我们现在看起来好象也是在作佛事，可因为内心有三毒，所以不清净。“常游戏五神通故”，说，因为禅定的关系，菩萨能够很自在地成就五种神通――天眼通、天耳通、他心通、宿命通、如意通。没有禅定就没有神通。“依趣智故”，说，菩萨修学种种法门，现种种神通度化众生，但他内心里面是“依趣智”――趣入无相的智，“无相”就是真如，无相智也就是根本无分别智。菩萨的内心是与第一义谛相应。这三句是与“成满业”相对应的，就是说，菩萨证悟了第一义谛，成就了无上菩提的业相貌。

于住正行不住正行诸有情类不弃舍故，言决定故，重谛实故，大菩提心恒为首故

这四句是与“安立彼业”对应的。菩萨度化众生的时候，有的众生能安住正行，不断进步，但有的不能安住正行，他做恶、他放逸，菩萨对这种种的众生都不舍弃，都尽力教化。对于“安住正行”的，菩萨帮他，使他更快地进步，对于那些“不住正行”的，菩萨慈悲心也千方百计教化他，甚至现恶相吓唬他等。“言决定故”是指对众生来说，菩萨的话是决定的，说话算数，表中显示，这一个是“决定无疑教授教诫故”，就是指菩萨对众生的教授、教诫是决定的。“重谛实故”，说，菩萨是不随便说谎话的。我们凡夫习惯了说谎话，一发现自己说谎话了，就求忏悔改正，但下一次还说谎。菩萨“重谛实”，就是尊重事实真相。表中显示这一个是“财法摄一故”，就是说，菩萨也集财、也积集法，比如说，我为了让众生有一个拜佛的地方，所以我去化缘盖庙，我说我盖庙，我化来的钱就真的用在三宝事上，绝对不挪作他用。“大菩提心恒为首故”是说，菩萨不管是做什么事，都是以菩提心为出发点儿。表中显示这一个是“无杂染心”，就是说，除了菩提心，确实没有别的心了。这四句对应于“安立彼业”，就是说，让众生安立于佛法中。还有最后一个颂子所知相就完了。

如说：

由最初句故 句别德种类

由最初句故 句别义差别

颂子的前两句是指对佛功德的赞叹，“最清净觉”是总说。后边儿的是一句一句分别说。说佛有二十一种功德。颂子的后两句，是对菩萨的功德的赞叹，也是先总说，接着一句一句分别说。


入所知相分第四

摄大乘论的第四分是“入所知相分”，入所知相是讲唯识性的。咱看论文。

如是已说所知相，入所知相云何应见？

所知相已经说过了，该说说入所知相了。“入所知相”的“入”是契入，就是契入“所知相”，前边儿说遍计执是毕竟空的，依他起是如幻有的，圆成实性是圣人的真实境界，这只是口头上说，我们到底该怎么样落实呢？“云何应见”就是指我们该怎么样亲自体证所知相呢？

多闻熏习所依，非阿赖耶识所摄，如阿赖耶识成种子；如理作意所摄似法似义而生似所取事有见意言。

这句话里实有两个重点儿，多闻熏习、如理作意。也就是说，怎样才能契入所知相呢？只有两条：多闻熏习、如理作意。先看多闻熏习。所谓多闻，就是博学，然后对于所知相的三自性之理能够有深刻的信解。如果说你听了不少，但对于三自性的道理还是弄不清楚，你听的是些啥？是净空法师之流讲的前方便而已，甚至是些相似法，那不算多闻。多闻熏习的“熏习”，前头说过的，就是对佛最清净法界等流的正法不断地学习，这样呢，阿赖耶识就受它的熏染，你的正知正见就有了。“多闻熏习所依”，就是说，“多闻熏习”是所依，能依的是马上要说的“如理作意”，“如理作意”是能依。也就是说，依止多闻熏习而发起如理作意。也就是说，你想要“如理作意”，就得“多闻熏习”，就得多学佛法。

“非阿赖耶识所摄”，“多闻熏习”不属于阿赖耶识。我们日常生活中的见闻觉知这些事情是属于阿赖耶识的，都是杂染性的，现在这个多闻熏习呢，它是佛的最清净法界等流的正法，他不是杂染性的，所以不属于阿赖耶识，他是能对治阿赖耶识的，能净化阿赖耶识的、能消灭阿赖耶识的。

“如阿赖耶识成种子”，这是一个类比。我们日常生活中的杂染性的熏习，熏成阿赖耶识里的杂染种子。这“多闻熏习”也象阿赖耶识熏成杂染种子那样熏习，不过多闻熏习是熏成了清净的法界种子，这清净法界种子以后会发生清净的现行，可以使我们得成圣道。下边儿是“如理作意”。依据“多闻熏习”而发起“如理作意”，如理作意就是修唯识观。“如理作意”的“如”是随顺，所以，“如理作意”就是随顺真理去思惟观察。如理作意要以多闻熏习为依止，也就是以圣言量为依止，以最清净法界等流正法为依止。“如理作意所摄似法似义而生似所取事有见意言”的“法”，就是法界等流的正法，“义”就是法所诠显的道理。能诠的是“法”，所诠的是“义”。不过这儿是“似法似义”，这一“似”，就完了，成了相似的法相似的义。你听闻了佛法的法义，你修习唯识观法的时候，就在你的意识上现出你所学的法义，可是你意识现出来的法义和你所学习的法义只是相似而已，它们相似，但不是绝对相同，它们有一致性。也就是说，我们听闻佛法所熏的种子其实与佛陀亲证的只是类似而已，还不是亲证的离言说的那个。

“如理作意”的“如”给“似法似义”的“似”意思一样。说，依据你多闻熏习的法义，在你的意识里现出来一个像，这就是“似法似义而生”。这“似法似义”是“如理作意所摄”、是属于“如理作意”的。这儿有这样一个情况，比如说你只是死记硬背，把一个东西死背下来了，这一个是不行的，因为你死背下来那只是一个一个的名、字，名里边儿的义显现不出来。这个“如理作意所摄”是表示你对于法义通达了，不只有文，还有义，这才行。长行中的“似所取事”，这是一个类比，我们平时的分别，眼识、耳识、鼻识、舌识、身识、意识，认取所缘的境界。现在意识去分别这些尘劳的事情，尘劳的事情就在心里现出来，意识是能取，尘劳的境界是所取，这是“所取事”。现在你修唯识观的如理作意，与这个“所取事”相似。“有见意言”，具有能见作用的意识的言说。说，“似法似义”就是所见的相，但这个相是如理作意、是多闻熏习所依而来的，能见的就是唯识观的智慧，能观的智与所观的法义和合起来，就是完整的如理作意，这就叫唯识观。不过法也好、义也好，都是“意言”而已，“意言”就是第六意识的分别，咱们所有的一切都是意言。这一段就是说，修唯识观要多闻熏习、如理作意，这样去修唯识观，就能契入所知相。

此中谁能悟入所应知相？

能悟入所知相的是谁？也就是说，符合什么样的条件的人才能够悟入所知相？

大乘多闻熏习相续，已得逢事无量诸佛出现于世，已得一向决定胜解，已善积集诸善根故，善备福智资粮菩萨。

“大乘多闻熏习相续”，谁能够悟入所知相呢？符合什么条件的人才可以呢？首先一个条件是：他要在大乘佛法里边多闻熏习相续，就是说，对于大乘三自性的道理你要多闻熏习。其中的“相续”有这么几个意思：心的相续，就是熏习在阿赖耶识里相续；另一个是指五蕴，就是我们的生命体，说我们在学习佛法；第三个意思是说时间长，就是说要长时间地学习佛法，不断地熏习。这里说的“多闻熏习相续”就是指你要对三自性的道理一遍一遍地熏习，一遍一遍地思惟、观察，不断重复。这就是悟入所知相的第一个条件：对三自性，或者说是平等法性一遍遍地熏习的人。

“已得逢事无量诸佛出现于世”，“逢事”，“逢”就是遇见了，“事”是事奉、供养、礼拜等佛事。就是说，你遇见过很多佛出世，并且每一尊佛出世的时候你都亲近供养，这些人才能悟入所知相。就是说你遇见很多佛给你教，在你已经是多闻熏习相续了。

“已得一向决定胜解”，你多闻熏习相续了，也已经逢事无量诸佛了，可是你没有达到这样的程度，那还不行，达到什么样的程度呢？就是“已得一向决定胜解”，“一向”，就是一直，不是说一下子有一下子没有，就是指菩提心，你不能一下子发一下子退。“决定胜解”，“决定”就是不犹豫，对大乘佛法不犹豫，即使有恶知识来，也动摇不了你对大乘佛法的信心，就是说，你对大乘佛法的信解达到了相当坚定的程度。这样的人才能悟入所知相、悟入平等法性。注意，这个“决定”有通达的意思在里边儿，就是说，人家来讨论，三说两说把你给说住了，这就是不通达、不决定，你不能不讲理而只是坚信，这不行，这在内心潜意识中是不行的。

“已善积集诸善根故”，这是说你得积聚很多的善根，善根就是清净种子，就是资粮。善根该怎么积聚呢？就是修六波罗密，六波罗密是出世间契入圣道的善根。注意，到下边儿的时候，还会说六波罗密，这儿先提示一下，就是说，你因为观察生死流转的过失，生厌离心，观察圣者境界而生欢喜心，你以这样的厌离心、欢喜心为基础，想要了脱生死，想要得证涅槃，以这样的心情布施、持戒才是积聚善根。要是说你还是欢喜世间荣华富贵，你布施、持戒等，这不是积聚出世善根，因为你并不是想得证出世圣果，你还是在流转生死，不过是比一般人好一点，可能在天上，也可能在人间，所以这不是积聚出世善根。这一个是悟入所知相的第四个条件。这四条呢，第一条是大乘多闻熏习，这是因，没有这个是根本不行的，第二条是亲近善友，就是“逢事无量诸佛出现于世”，第三条是你得有这样的作意，就是发菩提心，“已得一向决定胜解”对佛法的信解很坚定，第四条就是任持力，修六波罗密多积聚善根，那不是一下子的事儿，是长时期的，称之为任持力。具备这四条的人才可以悟入所知相。

“善备福智资粮菩萨”，这是总结一下。说，什么人能够悟入所知相呢？具足了这四个条件的“善备福智资粮菩萨”――“善备”就是具备了，“福智资粮”就是福德、智慧两种资粮，佛是两足尊，两足就是福德、智慧。印顺法师的讲记中称为四种力：因力、善友力、作意力、任持力。这四条按次序就是：先多闻大乘教法，受其熏习，那就能常遇诸佛，因之就产生坚定的胜解力，更进一步去实践，积集无量善根，培植无量功德。你就记成“听闻正法，亲近善友，如理作意，法随法行”。

何处能入？谓即于彼有见似法似义意言，大乘法相等所生起；胜解行地，见道，修道，究竟道中，于一切法唯有识性，随闻胜解故，如理通达故，治一切障故，离一切障故。

要想悟入所知相、平等法性，那么，从哪儿悟入呢？这一句话就是说这个的。我们知道，要想悟入所知相，就得对境进行仔细的思维判别，也就是所观境，所以，要想悟入所知相，只能从所观境入手，所观境就是下手处，从这儿可以悟入所知相、悟入平等法性。但是你在悟入的时候，还有一个深浅次第的不同，这一句话中间讲有四个阶段，就是“胜解行地、见道、修道、究竟道”。慢慢说。

“谓即于彼有见似法似义意言”，说，修学佛法者，他心里有一个“似法似义意言”，“似法似义”实际上就是所观境，也就是所缘境。长行中“有见”的“见”是能缘之智。“有见似法似义意言”实际上就是在心识（意识）里如理作意，如理作意还是内心的分别。能分别的是识（智），所分别的是名相。在名相上如理作意就可以悟入所知相、悟入平等法性。这儿有一个问题，就是说，要悟入平等法性，可平等法性是离名言相、离言说相的，可我们在悟入的时候，也就是在如理作意的时候，这是有名言相的，也就是说，我们在修学佛法的时候，是从有名言相开始，达到无名言相的，也就是从有分别达到无分别，不是一开始就无分别。

初学佛法必须有圣言量名言相为依据。有人说了，三毒是用意识来分别的，现在修行了，要对所观境进行如理作意，还是用意识，它要是走老路怎么办？就是说，它把如理作意分别成三毒怎么办？所以，下一句说“大乘法相等所生起”，就是说，如理作意和虚妄分别是不一样的，为什么？因为如理作意的是大乘佛法，它是最清净法界等流正法所生起的，也就是说，它是佛陀所见的真实相，而我们的是虚妄相，这不一样。“大乘法相”是指用语言文字显示的大乘佛法。我们平时的虚妄分别只会增长烦恼，但依大乘法相去如理作意却是对治烦恼的，所以凭它能够悟入平等法性、能够悟入所知相。

接下来是悟入时的次第，“胜解行地，见道，修道，究竟道”，这个“胜解行地”就是唯识三十颂中的资粮位、加行位。你现在发心修行了，你修奢摩他、毗钵舍那，这就把生死给转过来了，以前是在生死中流转，现在要还灭了。你努力用功，不断进步，就由胜解行地到了见道位，再修道位，再到究竟道位，这就圆满了无上菩提，圆满证悟了平等法性。

“于一切法唯有识性，随闻胜解故”，在解释谁能悟入所知相那儿，第三条“一向决定胜解”，就是有了决定的胜解，这时候你开始修唯识观，当然，我们现在就可以修，不过这修力量太小，到“胜解行地”就很有力量了。在“胜解行地”，我们知道“一切法”唯有识性，一切法就是前头说的十一识。说，这十一识都是内心的分别，离开内心的分别就无法可得，这就是唯识无义的道理，你对这道理“随闻胜解”，所谓“随闻胜解”就是说，你边听边用智慧来思维观察这个道理，最后对这个道理产生绝不动摇的信解。这个“随闻胜解”的“闻”包括自己读经典，也包括听闻佛法，还包括你在禅定中的境界。

“如理通达故”，这就到“见道”位了，就是说，你对一切法唯有识的道理通达无碍了，这时你就登圣位，你是初地菩萨了。“治一切障故”，这是修道位了，见道了自然得修道，因为虽然见道了，但仍然还有烦恼障碍，需要对治，所以得修。“离一切障故”，这是究竟道，也就是究竟位，你成佛了，这时你就远离了一切障碍，究竟清净，得证无上菩提。总一下就是说，从什么地方下手来悟入平等法性呢？从“有见似法似义意言”这儿下手，就是从所观境下手，把所观境用三自性来分析，凡夫的分别心是在所缘境上起种种虚妄分别，而佛菩萨的教导则是（最）清净法界等流的。然后我们经过胜解行地、见道、修道、究竟道，就成就了，就圆满地证悟平等法性了。

由何能入？由善根力所任持故，谓三种相练磨心故，断四处故，缘法义境上观恒常殷重加行无放逸故。

要悟入平等法性、悟入所知相，我现在还是凡夫，有没有下手的方便呢？或者说，悟入的因是什么呢？“由善根力所任持故”，前边儿上一个框倒数第二行有“已善积集诸善根故”，给这个配合起来。说，这个修行人，他多闻熏习相续、又亲近过无量诸佛、已得一向决定胜解、已能善积诸善根故，前边儿说的四条他都符合，他“善根力所任持”，“任持”就是对某一个事儿有堪当的力量。现在这位修行者就任持他的三业，任持他的正念，也就是说凭善根的力量的摄持而不失正念，他就由此而悟入。你要想悟入所知相、悟入平等法性，你还需要“三种相练磨心”，所谓炼磨其实就是磨炼，就是把自己的错误磨掉。三种炼磨心下边儿专门解释。只有三种炼磨心还不得够，还需要“断四处”，就是断除四种过失。断四处下边儿也有专门解释。接下来是“缘法义境止观恒常殷重加行无放逸故”，这是修止观，“缘法义境”就是止观，“恒常殷重加行无放逸”，“恒常”是指不间断，“殷重”就是恭敬，要长时期不间断还很恭敬地努力修学止观，一点儿也不放逸，这样你才能悟入平等法性。

无量诸世界，无量人有情，剎那剎那证觉无上正等菩提，是为第一练磨其心。

这是要说三种相炼磨心，三种炼磨心实际上是对治三种退怯心的。先看第一炼磨心。“无量诸世界，无量人有情”，修行人虽然发了心，但毕竟还是凡夫，有时候会有犹豫、会有退弱，对自己能不能办到这件事儿心里有疑惑，为了对治我们的这个退怯心，我们要这样思维，说：“无量诸世界，无量人有情”，就是有那么多世界，那么多的人，“剎那剎那证觉无上正等菩提”，他们一下成一个佛一下成一个佛。因为世间那么多，人也有那么多，在娑婆世界是老久老久才有一个成佛的，在别的世界也是，但是当我们把这许多的世界看成一个整体的时候，你会发现一下这儿有一个成佛的，一下那个世界有一个，每一个刹那都有成佛的，你就想，既然这么多人成佛，看起来好象不是太难的。同样，你会发现每一刹那都有人见道，每一刹那都有初地登二地，每一刹那都有二地登三地……看起来这不是很难的事儿。这样就把自己的退怯心消除了。这是对刚发菩提心者的一个鼓励，这是第一炼磨心。

由此意乐，能行施等波罗蜜多；我已获得如是意乐，我由此故少用功力修习施等波罗蜜多，当得圆满，是为第二练磨其心。

第二练磨心是说，修行人被吓住了，有人给他说，六波罗蜜不是那么容易的，很难作到。这样的事儿很多，比如咱知道，有很多人说唯识最难了，但真难吗？好多人在唯识面前设置障碍，能够在唯识前边儿设置障碍的都是祖师大德们，他们站在唯识的前边儿挡住学人，吓唬学人。唯识是弥勒菩萨所说，弥勒菩萨是当来下生佛，是一生补处的菩萨，他能害众生吗？如果说弥勒菩萨说法还度不了你谁还能度了你，因为在此世间他是最高的了，释迦牟尼佛入灭了，没有人比弥勒更高的了。祖师你弘扬某一个法门，这没有关系，但你不能在弘扬那个法门的时候堵死这一个法门。从发心到成佛这一段时间里，你绝对不能只用一个法门的，你需要换当时当处适用的法门。我老说一个比喻，往北京去吧，我得用走路、公交车、火车、打的、再走路等，很多法子。只用一个法子，死路一条，比如说我现在还在楼上，我非要坐飞机，行吗？不行的！有人说唯识难，现在这儿无著论师说的是有人给说六波罗密难，结果呢，你被吓住了，你要后退了。无著论师在这儿告诉说，你应该这样，“由此意乐，能行施等波罗蜜多”，“意乐”首先是一个理解问题，必须有深刻的理解，也就是说，你得知道我布施了，会得什么样殊胜的功德，我持戒了，会得什么样殊胜的功德等。“意乐”有胜解的意思，还有一个欲的意思。欲就是希望，这里指善法欲。也就是说，我希望得禅定，得禅定之后我就可以度众生更有力。没有这样的意乐，你修六波罗密是修不起来的。就是说，修六波罗密要看你的动机、看目的，目的不一样你作同一件事儿结果大不相同。

“我已获得如是意乐，我由此故少用功力修习施等波罗蜜多，当得圆满”，修行人最初听人说六波罗蜜很难，心里恐惧了，这时候，我给你说，你要有这样的意乐：修布施有什么样殊胜的功德，修持戒有什么样的功德等，“由此意乐，能行施等波罗蜜多”，有了这样的意乐，你的思想就转变了。说，“我已获得如是意乐”，我只要有这样的意乐，有这样的信解，“我由此故少用功力”，有了这样的意乐，其实我不用怎么样费劲儿的，不用怎么样费劲儿我就可以修起布施波罗蜜、持戒波罗蜜等，一进入轨道，上了路，它自然就强大了，六波罗密不就圆满了吗？这第二炼磨心用原文不明白，我给说个不好的比喻。曹冲称象那个动画片，要把大象给赶到船上，大象不上，人们推呀拉呀大象就不上，曹冲跳在大象身上，用小杆儿挑一串儿香蕉，让大象只差一丁点儿又够不着，就把大象逗到船上了。这第二炼磨心就是这样，你觉得难，你就把功德当成一串香蕉，说，你只要稍微作一点儿就得到了殊胜的功德、清净的功德，就把你引去了。这样就上路了。

这一个主要是有此意乐，也就是有菩提心，有菩提心之后就好办了，有因一定有果。这是第二炼磨心。还不行？我这样说吧，有“此意乐”就是指真心欢喜，当你真心欢喜这个法门的时候，你不不怕了。比如说我，我是对唯识真有意乐，所以，那么多人都说唯识难、复杂，但我仍然学他了。当然，唯识根本不是我以前说的那个样子，我说的那是搀有假。不过因为我是凡夫，可能搀坏了，想把人给引到唯识里边儿却弄歪了，以后我尽量不用这法子了。有很多人一听说唯识太难，就不学了，实际上他根本就没接触过唯识，甚至说唯识太难的人也只是听别人说唯识太难而已。一听说唯识难就不学了的人，实际上是根本他对唯识就没有意乐。

若有成就诸有障善，于命终时即便可爱一切自体圆满而生；我有妙善无障碍善，云何尔时不当获得一切圆满，是名第三练磨其心。

这是第三练磨心。修行人要修波罗密，今天也布施，明天也布施，今天也持戒，明天也持戒，不断地干呀干，可是呢，距无上菩提还是很远，这样呢，他心退了，说，我啥时候才能到达目的地呢？他对自己到底能不能达到目的地产生了疑虑。这时候该怎么办呢？这就是第三炼磨心。说，你要这样思维，“若有成就诸有障善”，“有障善”就是用贪、嗔、痴修善法，说我是为了生天而来修十善法的。“于命终时”，用贪、嗔、痴来修十善法，善法是作了，但烦恼没破，这样，在你死的时候，“即便可爱一切自体圆满而生”，就可以达到你生天的目的，你想生天所以修十善，或者说你是想生到人间好的地方，这一生我的身体病秧秧的，我希望来生身体健康，所以我修十善，来生我会达到目的的。“自体”就是生命体，“可爱一切自体圆满”就是指生命体很好，健康、如意。就是说，“有障善”也能得这可爱的果报。“我有妙善无障碍善”，说，“有障善”就能得这样的果报，我现在是无障碍善――用清净心修善法，修六波罗密等，“云何尔时不当获得一切圆满？”就是说，我现在用清净心修行了，反而不能满愿，有这样的道理吗？有障善可以满愿，无障善却不能满愿，绝对不可能的！所以，我一定是可以得证无上菩提的。这就是第三炼磨心。

注意：这三炼磨心是说的胜解行地的菩萨，也就是资粮位、加行位的菩萨。

此中有颂：

这里呢，有几个颂子。用颂子来说说炼磨心。

人趣诸有情 处数皆无量

念念证等觉 故不应退屈

这是说第一炼磨心。我怕自己不能成佛，怕自己不是那根性，这怎么办呢？“人趣诸有情”，佛是在人间成佛的，我现在也是人。“处数皆无量”，好多地方的人都可以成佛，好多人可以成佛。“念念证等觉”，每一个刹那都有人在不同的地方成佛，“故不应退屈”，看起来成佛也不是很难的事儿，有什么好怕的，我也能成佛。这样就不会退心了。

诸净心意乐 能修行施等

此胜者已得 故能修施等

这是第二炼磨心。说，修行是很难的，我就害怕了。“诸净心意乐”就是说，我有清净心意乐――布施有殊胜的功德、持戒有殊胜的功德，我强烈地愿行布施、持戒等，“能修行施等”有了净心意乐，就可以修习六波罗蜜了。“此胜者已得”，“胜者”是指菩萨，说，菩萨有这样的意乐，我也有这样的意乐，“故能修施等”，菩萨有这样的意乐，可以修六波罗密，我有这样的意乐，所以我也可以修六波罗蜜多，看起来修行这件事儿我是能行来的，没什么好怕的。

善者于死时 得随乐自满

胜善由永断 圆满云何无

这是第三炼磨心。“善者于死时”，这个“善者”是指修有障善。说，修有障善的人在死时，“得随乐自满”，可以达到自己愿望，可以遂了自己的心愿。“胜善由永断，圆满云何无”，我修无障碍善，怎么可能不得圆满的菩提果呢？“胜善”就是无障善，“永断”是指断除障碍执著。三种炼磨心说完了，下边儿该断四处了。

由离声闻独觉作意，断作意故；

断四处就是说，修行人一般会在四个地方有过失，要把他断掉。第一个是作意处。作意就是注意，引起警觉。佛教的目的是成佛、度化众生，为了这个目的的实现所以要精进努力。但有的不是，他说，众生刚强，难调难化，我惹那麻烦干吗？我把自己度了就好了。这断作意就是指大乘行者千万不要起这样的心，要把这样的作意断掉。一定要远离这个过失。这里是用这一个作意作代表，其实是指不如理的作意都要断。

由于大乘诸疑离疑，以能永断异慧疑故；

第二个是“断异慧疑”。“大乘诸疑离疑”是说：有人攻击大乘非佛说等，很多令大乘行者起疑惑的地方，就是说，这个大乘行者因为对自己的教理教义还没有深切的体悟，一被外人攻击，就动心了――我这到底是不是真的不是佛教呢？真正的大乘人要断除这疑惑，一定要坚定这无上甚深的妙法。“断异慧疑”的“异慧”就是不合理的见解，就是指听起来觉得特别有道理，但实际上不对，就是指合理但不合事实。这一个就是说，大乘行者要坚持大乘见解。韩老是把这“异慧”译成了“二意”，说二意就是不决定、拿不定主意。

由离所闻所思法中我我所执，断法执故；

第三个是断法执。我们在修行的时候，会生起一种我在修行、我这样修行是对的，他们那样修行不对，有这样的想法就是法执。在我们没有修行的时候，我们有种种的烦恼，但修行的时候，又会起傲慢，这也是障碍。所以，要“离所闻所思法中我我所执”，也就是金刚经中说的，“须陀洹能作是念：我得须陀洹果不？”“阿罗汉能作是念：我得阿罗汉道不？”等，其实一切圣人都是无我的。这时要观我空、法空。我们说修行就是正闻熏习、如理作意，我们就要时刻观照自己，是不是在所闻、所思、所修里加了我执、法执，要加了的话，就不是正闻熏习了。

由于现前现住安立一切相中无所作意无所分别，断分别故。

第四个是断分别。“由于现前现住安立一切相中”，“现前现住”是指在没入定时，你认取一切法、一切境界，这一切的境界你的分别心都可以认取。“安立一切相”是指在禅定里认取的境界。如果你修白骨观，在禅定中就现出白骨来，这白骨就是你在定中安立的，其实根本就没有，是你自己在禅定中观想出来的。你观佛像也是这样，这叫“安立一切相”。不管你在禅定中也好，不在禅定中也好，对于这一切（所缘）境界都“无所作意无所分别”，“作意”是注意，它可以引起分别，“分别”是作意引起来的。也就是说，你对这境界不要分别，因为那根本是不实在的，只是你的分别心而已。我们知道，有时候你在禅定中观的境界能吓坏自己的。比如说有一个故事，说有一个人，一入定就见一只毒蜘蛛在他面前张牙舞爪，干扰得他不能修行。说，这其实是没有的，根本就没有毒蜘蛛。所以不要分别，只要无分别，就一定无作意，要是有作意就一定有分别的。实际上断法执那儿烦恼障的成分较多，而这断分别则所知障成分较多。

此中有颂：

这里有一个颂子，这个颂子是断分别的颂子。

现前自然住 安立一切相

智者不分别 得最上菩提

“现前”是指在禅定中境界现前，比如说你修白骨观因而在禅定中现出白骨。“现前自然住”是指在禅定中要任运，不要刻意分别。“安立一切相”，你在禅定中立的一切相其实都是假安立，观佛像也好，观什么都好，统统是安立，没有一个是真实的。“智者不分别”，你不要对它进行分别，一分别就会产生恐惧，或者产生希望，恐惧、希望，这就是你把敌人给招来了。“得最上菩提”，你要是分别了，你就离菩提果远了一步，只有不分别才行。这样，断四处就是说，首先要发大心，要远离自私心――声闻、独觉作意。第二是要对大乘产生正信、正见，第三要断我执、法执，第四个断分别。

由何云何而得悟入？由闻熏习种类如理作意所摄似法似义有见意言；

“由何云何而得悟入”就是“由何而得悟入”、“云何而得悟入”。“由何而得悟入”就是说，由什么因缘而能悟入所知相？这是指能观察之智是什么？在无性释中称为“作具”（435页）。凭什么悟入？“云何而得悟入”就是说，要怎么样观察才能悟入所知相？无性释中称为“所作”。怎么悟入？“由闻熏习种类如理作意所摄似法似义有见意言”，就是说，这个发心修行者，发了菩提心，他多闻熏习，所谓熏习，当然不是只听一次、二次，而是很多次，因为这多闻熏习，他就得了法界种子，注意，这和平时的熏习不一样，这是得法界种子。所以佛法在他的内心深处引起共鸣。“由闻熏习种类如理作意”，这如理作意是闻熏习的种类，就是说如理作意和闻熏习是同类的。听闻的是佛法，作意的也是佛法。在听闻佛法的时候，就种下了清净法界的种子，这种子一现行就是闻所成慧，你如理作意了，就是思所成慧，再进一步就成修所成慧了。“种类”就是种子。“似法似义有见意言”，在36页也有这话，“何处能入？谓即于彼有见似法似义意言……”意思就是：把所听闻的佛法所诠显的道理，在内心里观察思惟。在这个活动中，有能观察的见、有所观察的法义。这一句就是说，能观察之智、能悟入的因缘是：多闻熏习同类的如理作意，由此而得悟入平等法性。“似法”，就表示我们现在所学的法、所说的法，并不是佛陀亲证的，只不过是与佛陀亲证的相似而已，亲证的法根本没法儿表示出来。我们证悟唯识性所用的工具（作具）是“有见意言”――具有能见作用的意言。强调一个能见的作用。

由四寻思，谓由名、义、自性、差别假立寻思；及由四种如实遍智，谓由名、事、自性、差别假立如实遍智，如是皆同不可得故。

上一句说了凭什么悟入，这儿要说怎么悟入？怎么悟入，就凭四寻思观、四如实智。我们在修行的过程中，要多闻熏习、如理作意。这都不是短时期的，得发长远心。你的如理作意大致上可以分为“四寻思观”“四如实智”。你在散心时，是四寻思，在禅定里是四如实智，当然了，实际上四寻思观都是定中的，现在只是这么说而已，这是相对的说法，后边儿要说到。也就是说，对于佛所说的唯识无义的道理，你观察思惟，只是内心还没得到决定，这时是“四寻思”。在禅定中观察思维，得到了决定，这时是“四如实智”，这儿叫“四如实遍智”。

四寻思着重于诠表模式，就是说，这个东西应该叫什么名字之类的。四如实智是修四寻思观而得到的，它着重于决断模式，就是说，这个东西就应该叫这个名字。四如实智的“如实”就是是什么就是什么，不是什么就不是什么，要如其事实，是桌子就是桌子，你不能把它叫书本。没有五蕴就是没有五蕴，你不要把它给说成有！它根本一点儿影子都没有！

四寻思是什么呢？“谓由名、义、自性、差别假立寻思”。其实四寻思还是如理作意。四寻思有名、义、自性、差别。就是说，名寻思、义寻思、自性假立寻思、差别假立寻思。“名”就是能诠的名言，名是只存在于想法之中、妄想之中，它只是一个名字而已。所有的语言都是名。“义”是所诠显的义理。每一法都有名，每一个名的背后都有所表示的种种义，我们就依据这个名去思惟，依据这个义去思惟，这就叫名寻思、义寻思。名、义都是想象出来的。再从广义上来说，名、义都是名，名有两种，一种叫表义名言，一种叫显境名言，名就是表义名言，义就叫显境名言。

自性假立寻思、差别假立寻思，这个“自性”是说，每一法都有其自体，比如说这张桌子，桌子本身就是它的自性，桌子的形状、颜色等就是桌子的差别。“自性假立寻思”是说，凡夫所知的每一法，其自体都不是真实的，是唯心所变的，他本身是假有，你这样思维就是自性假立寻思。这个道理就是心经上的五蕴皆空。“差别假立寻思”是说，在一切法的自体上有种种的差别义，它是善还是恶？说，其实这些差别根本就是内心的分别，也是假有的、不真实的。你这样去思惟，就叫差别假立寻思。差别就是关于自体的描述。名、义、自性假立、差别假立这都是只存在于我们的妄想之中。“及由四种如实遍智”，说，还有四如实智。这是因为在禅定里思维观察四寻思观而得到的。“四种如实遍智”的“智”是决定、没有疑问的意思，“遍智”的“遍”是普遍。说，佛法说的真理不是局部真理，而普遍真理，是通于一切法的。四如实遍智就是“名、事、自性、差别假立如实遍智”，“名如实遍智”是指由名寻思所引起的“如实遍智”，“事如实遍智”是由前边儿的义寻思所引起的“如实遍智”，“自性假立如实遍智”就是自性假立寻思所引起的“如实遍智”，“差别假立如实遍智”是差别假立寻思所引起的“如实遍智”。“如实遍智”就是经过长期的思维观察，得到决定。“如是皆同不可得故”，说，名、义、自性、差别都是没有真实性的，要是没有我们内心的分别，一切法都不可得。“皆同不可得”就是“都是不可得的，都是无自性的”。

以诸菩萨如是如实为入唯识勤修加行，

修四寻思观、四如实遍智，那么，菩萨为什么这样修呢？我修别的是不是也可以呢？为什么要这样修？说，因为菩萨这样真实地修四寻思观、四如实遍智，就是为了契入唯识性、为了契入唯识无义。努力修这四寻思、四如实遍智的加行，是为了悟入平等法性、为了转凡成圣。也就是说，修这个唯识观能除众生的颠倒、苦恼，能得圣道。

即于似文似义意言，推求文名唯是意言，推求依此文名之义亦唯意言，推求名义自性差别唯是假立。

这是说四寻思。第一的名寻思。应该怎样思维观察名呢？“即于似文似义意言”，就是说，修行者把他所学的法义在心里显现，显现在心里的文义和所学的文义是相似的，这就叫“似文似义意言”，“文、义”就是能诠显义的名、文和所诠显的义，在内心里观察思维，观察思维这个“意言”，文（名）也是“意言”，义也是“意言”，都是意识的分别，所以叫“意言”。“推求文名唯是意言”，“推求”就是思维、观察。思惟“文名”，“文”就是字、词，用种种的字安立种种的“名”，这样思维这些名、字，“唯是意言”，它只是我们内心的第六意识的分别，离开了我们内心的分别，根本就没有这些名、字。我们说的“真如、法性、菩提”等，也都是名、字，也都是内心的分别。这些名、字虽然有所表达，但是这些名字儿并不是那件事本身，也就是说，我们内心里思惟菩提，并不是你得证了菩提。就象我饿了，我只说饭这个字儿是不会饱的。这就是说，这个名、字可以去表示那个义，但它本身并不是那个义，它只是假名，只是内心的分别。我们平常就是生活在这些名字上。我们习惯了认为名字是真实的，这是我们的执著。佛菩萨告诉我们这名字是不真实的，只是我们内心的分别。这是第一步，名不真实。

“推求依此文名之义亦唯意言”，我们知道了名的不真实，进一步去观察“依此文名”的义――这个名所诠表的义，结果我们发现这个义“亦唯意言”――也只是我们内心的分别。我要是分别了，就有这件事儿，我要是不分别，就没有这件事儿了。文也是内心的分别，义也是内心的分别，离开了内心的分别，文也不可得，义也不可得。我们再进一步思维观察，“推求名义自性差别唯是假立”，这是第三、第四个寻思。我们发现名的自性差别是假立的、义的自性差别也是假立的、都是内心分别而安立的，他没有真实性可得，都是虚妄的、不真实的。

若时证得唯有意言，尔时证知若名，若义，自性，差别皆是假立，自性差别义相无故，同不可得。

这是说的四如实遍智。你在作四寻思时，在心里思惟，你就能够契入名、义、自性、差别是不真实的，“若时证得唯有意言”，因为你长期的努力作四寻思观，最后超过了寻思的境界，“证得唯有意言”，这个“证得”就是通达，指通达了它们其实只是内心意识的分别。“尔时证知若名，若义，自性，差别皆是假立”，就是说，在这时候，你真的知道了名、义、自性、差别，其实都是虚妄的，都是不真实的，都是假立的。“自性差别义相无故”，为什么名、义、自性、差别都是假立的？“假立”就是假有、不真实，“立”是存在的意思，就是说，他们的存在是个假相而已。“自性差别义相无故”就是说，名的自性差别、义的自性差别，都是没有独立的体性的。长行中的“义相”就是离开了分别心有他自己的体性。这当然是没有的。离开了我们心的分别心，“名、义、自性、差别”都是没有体性的。你要是确实能证悟这个，就是四如实遍智。“同不可得”还是都不可得，都是不实在的。

由四寻思及由四种如实遍智，于此似文似义意言，便能悟入唯有识性。

说，菩萨行者因为努力地修学四寻思观，进一步又修学四如实遍智，注意，四如实智是四寻思观修好后自然就显现出来了的。最后知道了似文似义都是内心意识的分别，这样他就可以悟入唯识性。这个入所知相我们要和所知相配合起来，这是说遍计所执性是毕竟空的，我们平时认为它是真的，我们现在用四寻思观、四如实遍智知道它根本就是遍计执，不是真实的，它只是我们内心的分别而已。对于三性其实就是只要证见遍计执空，其他的依他起性、圆成实性自然显现。也就是说，我们的修行只要对遍计执性下手就行了。

于此悟入唯识性中，何所悟入？如何悟入？

“于此悟入唯识性中”，就是说你已经明白了名、义、自性、差别都是唯识，都是内心的分别。“何所悟入？如何悟入”？“何所悟入”是悟入的境界是什么？“如何悟入”是问怎么样能悟入这个境界。

入唯识性，相见二性，及种种性：

到底“何所悟入”呢？这一句就说了，说悟入名、义、自性、差别都是识，这是很笼统的说法，具体有三种不同：入唯识性、相见二性、种种性。什么是“入唯识性”？下一句解释。

若名，若义，自性，差别假，自性差别义，如是六种义皆无故；

所谓“入唯识性”，就是指“六种义皆无”。四寻思观、四如实遍智，都是四，这儿怎么是六呢？六是指哪六？“若名，若义，自性，差别假”，就是“名、名自性、名差别；义、义自性、义差别”，这就是六。中间的这个“假”是说，“名，义，自性，差别”这六个都是依内心的分别而有的，都不是实在的，都是假安立的。“自性差别义”就是说自性也好，差别也好，都是假有的。“如是六种义皆无故”，我们习惯了这六种都是真，但实际上却根本不是真实的，它们只是我们意识的分别。这就是入唯识性。

所取能取性现前故；

这是第二种，“相见二性”。说，“名、义、自性、差别”都没有真实性，只是我们内心意识的分别，当这个意识一起分别的时候，就有了所取的相、能取的见，“相、见二性”就显现了。本来只是识，但识有所取、有能取，所取的是我们的妄想，我们称为相分，能取的作用我们称为见分。这就是因为无始劫来名言的熏习，心一动名言种子就现出种种的差别相，相一现出来，就有相分、见分。

一时现似种种相义而生起故。

这是第三种，“种种性”。我们的意识分别时，就有了能取、所取，能取、所取都是虚妄分别，虽是虚妄分别，但是在分别时，刹那一下子同时就现出来相似的、虚妄的“种种相义”，长行中的“一时”就是一下子，“种种相义”就是指能分别心在所分别境上一下子现出很多差别的所分别境界。比如说，咱们看见这桌子，一下子就觉出桌子、桌子上的书本、钢笔、日历不一样，这是一下子现出的。你要是再进一步思维观察，你会发现这“种种相义”的生起也是虚妄的、也是没有真实体性的。这就说了“何所悟入”的三种不同，但说实在的，三种并不是独立的，根本就是一回事儿。

如暗中绳显现似蛇，

问题是何所悟入、如何悟入。这儿就开始说“如何悟入”了。无著论师是说了一个比喻。比如说在昏暗中有一段绳子，你把它认成了一条蛇，就是现出了蛇的相貌。

譬如绳上蛇非真实，以无有故。

所现出来的蛇相根本就不是真实的，因为根本就没有蛇。

若已了知彼义无者，蛇觉虽灭，绳觉犹在。

蛇相就是遍计执，你认清了蛇相是没有的，但绳相还是存在的。就是说，遍计执是没有的，依他起是有的。依他起的什么？别忘了，在所知相分那儿，一开始就讲，是“阿赖耶识为种子，虚妄分别所摄诸识”，可以说，依他起就是一切法唯识无义，就是我们的分别心。这分别心是缘起的、如幻如化的、不真实的、虚妄的。我们执著虚妄的一切法是真实的，就像把绳子认成是蛇。“若已了知彼义无者”，要是我们认清了蛇相根本是没有的，“蛇觉虽灭，绳觉犹存”，我们知道了蛇是没有的，但对绳子的认识还是有的。

若以微细品类分析，此又虚妄，

说，我们进一步再分析，发现这绳子也不是真实的。为什么绳子也不真实呢？

色香味触为其相故，

原来我们所谓的绳子，其实只是色、香、味、触所引起的认识而已，它是色、香、味、触组成了一个相貌而已。

此觉为依绳觉当灭。

我知道了它只是色、香、味、触引起的认识而已，它是色、香、味、触组成了一个相貌而已，当然不会再说绳是实在的了。

如是于彼似文似义六相意言，伏除非实六相义时，唯识性觉犹如蛇觉亦当除遣，

这一句长行中的“犹如蛇觉”，在论文中、世亲释中、无性释中，都是“蛇”，但印顺法师的《摄大乘论讲记》中把“蛇”改成了“绳”，他是在原文处给改的，我觉得改论文这个作法不好，要是你觉得不通的话，可以在讲的时候给说出来，但不要改人家的原文。韩老的译本中，也是“绳觉”。我觉得确实“绳”比“蛇”要好。“如是于彼似文似义”，刚才说了绳蛇的比喻，我们在修行的时候也象这一样，我们在修习中，思维观察似文似义，长行中的“六相”就是色、声、香、味、触、法，“六相意言”就是指六相都是内心的分别。你这样观察，就可以“伏除非实六相义”，就是说，可以把不真实遍计所执六相之义都给伏除、消灭。这样你就知道六相都是唯识无义的、都是虚妄的、都是如幻如化的境界。“唯识性觉犹如蛇（绳）觉亦当除遣”，你知道了六相都是内心的分别，这就是依他起。蛇觉灭了，绳觉还在。你再用六相去分别，绳觉就没有了，就是说，你来分析这内心的分别，发现它也是不真实的，这就契入圆成实性了。“唯识性”指圆成实性，唯识性本是圣者亲证的，我们现在“说的唯识性”不是真的唯识性，我们现在“说的唯识性”，实际上还是意识的言说。

由圆成实自性觉故。

为什么分别心也会灭？“由圆成实自性觉故”，就是因为你证入了圆成实自性。你一证入圆成实自性，就知道一切戏论、一切分别心都不是真实的。

如是菩萨悟入意言似义相故悟入遍计所执性，悟入唯识故悟入依他起性，云何悟入圆成实性？

这儿就是开始讲“悟入所知相”。所知相是讲三性的，三性就是三种存在。“如是菩萨悟入意言”，前边儿的比喻是一个整体，把三自性全包括了。那么，这个修行者他知道了我们所面对的一切，什么名呀、义呀等，都是没有真实义的，这样就知道了遍计所执是毕竟空的，这就是悟入遍计所执自性。“悟入唯识故悟入依他起性”，进一步你觉悟了一切法唯识，所取的境界和能取的分别心是不能分离的。我们都执著“所分别的色、声、香、味、触、法和我们能分别的心是没有关系的，你说也罢不说也罢，这张桌子它都是存在的”，这叫遍计执。现在你知道了所分别的境界和能分别的心是不分离的，他同我们的心是一体的，觉悟了这个，就是悟入了依他起性。你遣除了遍计执，知道一切法都是如幻如化的、不真实的。接下来就该悟入圆成实了，怎么才能悟入圆成实性呢？

若已灭除意言闻法熏习种类唯识之想，尔时菩萨已遣义想，一切似义无容得生，故似唯识亦不得生；

说，这位大乘行者，他灭除了“意言”，就是认清了现在所面对的一切只是意识的分别，“闻法熏习种类唯识之想”，“闻法熏习”就是多听佛法，听什么样的佛法、熏习什么样的佛法？当然是“唯识之想”，现在就是说，你要灭除唯识之想，当你把唯识之想灭除了，你就悟入圆成实自性了。注意，这时候是唯识当然还在，唯了别识还在，要灭除的是“唯识之想”，“唯识”给“唯识之想”，要分清。“尔时菩萨已遣义想”是指这时，这个大乘行者已经灭除了遍计执的“义想”了，灭除了遍计所执的义想才能悟入“唯识之想”。因为把义想灭除了，所以“一切似义无容得生”，义没有了，似义当然就没法生起了。“义”是我执、法执，“似义”是我执、法执在心里显出的影像，也就是对我执、法执的认识。最先你有我执、法执，你就可以有对我执、法执的认识，现在我执、法执没有了，当然就没有了对我执、法执的认识了。对我执、法执的认识是什么，就是“似（唯）识”，所以说，“故似唯识亦不得生”。所以说，我们是先观察遍计执毕竟空，我们内心所现的一切法如幻如化，这就是“已遣义想”，我们遣除义想，则“似义”也不能生起，似义不能生起，就是见识不能生起，这样，“似唯识亦不得生”，这样就悟入圆成实性。

由是因缘，住一切义无分别名，

因为你先破除了遍计执，所以就“一切似义无容得生”，进而“似唯识亦不得生”，因为这个缘故，“住一切义无分别名”，就是无分别智现前。“住一切义”就是真如、平等法性。因为无名所以无分别。或者我们称之为空性，这时是“言语道断、心行处灭”。

于法界中便得现见相应而住。

你悟入了圆成实性，就在平等法界里能够现见无分别智，与平等法性相应而住。“现见”的“现”就是无分别智。现在我们注意一下，平等法性到底什么样儿，我们不知道，佛陀就用语言给我们描述一下，他说是无分别智去现见，在我们的习惯中，只要是认识，就要有能认识、所认识，现在佛陀随顺我们这个语言、这个方式来介绍。实际上觉悟了圆成实相、平等法性的人是没有这个境界的。我们说，“于法界中便得现见相应而住”这不是分别吗？这也是分别，只不过是佛借用一下我们的语言而已。这里得注意一下，所谓住于法界，就是名、义都不存在了，这时候你就遍获众生心平等，遍获菩萨心平等，遍获如来心平等……接下来的一句长行就是这个。

尔时，菩萨平等平等所缘能缘无分别智已得生起，

“尔时”就是“于法界中便得现见相应而住”的时候，就是你在平等法界中以无分别智现见真如，无分别智和真如是相应而住的。“相应而住”就是“俱有、俱现”的。这句长行中的，“平等平等所缘能缘”，“所缘”的是真如，“能缘”的是无分别智，“平等”是无分别。说“能缘”的智是无分别的，注意，这儿是根本智，根本智是无分别的，“所缘”的真如也是无分别的。能缘、所缘都是无分别的，这就没有能、所的分别，这就是能、所双亡。无分别智现起，这就是“于法界中便得现见相应而住”，这就登地了。所以我们要记住这一点儿，登地之后就没有能、所问题。这里的“平等平等”，两个“平等”，是指能所双亡。

由此菩萨名已悟入圆成实性。

这时候，这位修行者就是悟入了圆成实性。这是不可思议的境界。

此中有颂：

这里有个颂子。

法，补特伽罗 法，义，略，广，性

不净，净，究竟 名所行差别

说，真如法界是在一切相皆不可得这种见解上安立的，也就是说，真如实际上是无以名之的，但不取个名字我们又没法说，没法说我们就不知道，于是佛就给安立了一个名字。说名既然是安立的，其实安立过很多的名字，这里就顺带说了十个名字。佛为什么要安立这么多名字？就是要告诉你这是安立，叫什么都没有关系。实在来说，这也是为了破我们的执著。世亲释中193页说，“如前所说住一切义无分别名，何等为名？几品类义？为答此问，以颂显示名类差别。”意思就是说，名只是假安立的，既然是假安立的，假安立了多少名呢？在无性释中440页说，“如前所说住一切义无分别名，今以伽陀显示此名自境差别。”意思大差不离。颂子中说了十个名，当然这只是代表，实际上安立名字很多很多。这些名字都是根据其所行境界差别而建立的。

第一个是“法”，这就是指五蕴、十二处、十八界这一些，说这些都是“法”。第二个名字是“补特伽罗”，就是流转生死的众生，就是人我。第三个名字又是“法”，这个法是指佛陀的教法，给前边儿的那个“法”不一样，第一个“法”是指一切法，第三个法是专指佛陀的教法。第四个名字是“义”，就是法所诠表的道理。第五个名字是“略”，是指总名，张三、李四、王五、赵六等等都是“人”，我们就说一个名字“人们”，这就是总名，总名简单，所以叫“略”。第六个名字是“广”，是指别名，你是张三，他是李四，他是王五等等，张三、李四、王五、赵六这就麻烦多了，所以叫“广”。第七个名字是“性”，世亲释193页中说，“谓诸字本母”，无性释440页中说，“谓阿等诸字，是词句因故”，因为世亲、无性这么解释了，所以一般都把这个“性”说成是能生的根本，字母是文字的根本。佛教是度众生的，所以我们不妨把这个“性”理解成种性，就是五种性的“种性”，能不能成佛就看它了，它是成佛之因。第八个名字是“不净”，就是说凡夫为烦恼所染污。第九个名字是“净”，就指说圣者断除一切烦恼。第十个名字是“究竟”，就是诸法实相，实在是没有分别、没有名字的，没有名字太不方便，就安立一个。“名所行差别”，这些名字都是从所活动的境界差别中安立的。

如是菩萨悟入唯识性故，悟入所知相；悟入此故，入极喜地，善达法界，生如来家，得一切有情平等心性，得一切菩萨平等心性，得一切佛平等心性，此即名为菩萨见道。

“如是菩萨悟入唯识性故”，这一位大乘行者证得了无生法忍，觉悟了平等法性，他也就悟入了所知相。一般来说，“悟入唯识性”就是体悟到了遍计所执是毕竟空的，见到了依他起。“悟入此故，入极喜地”，你经过长时期的对六波罗蜜的修行，悟入平等法性、悟入所知相了，这就登极喜地了。到这时就是入圣位了。“善达法界，生如来家”，这里到极喜地后的境界。“善”就是能，说，这时就有能力通达法界的真如实相，真的明白了什么是真如。我们现在只是在说真如，真正的真如什么样儿，我们不知道。有人说了，这是说食不饱，有什么用？不，有用，说食有促使你去找饭馆的作用，有促使你作饭的作用。

我这个人老爱说胡话，有人就说我，你说这有什么用？佛教中的丑恶现象连一点儿也没有因为你的揭露而变好一些。我说，不，只要允许说，就比不让你说好得多，只要让你说，不一定啥时候机缘成熟了就可以改了，要是不说，佛教自己已经不知道佛教自己有病了，还认为自己很健康，这才糟糕。也就是说，我们说真如，比打妄想要好得多。到登初地后，这是真的亲见真如，“生如来家”，就象小孩已经生下来了，他自然会长的。菩萨说，有一众生不成佛，我就不成佛。你不成佛也得成佛，这不是你愿意不愿意的事儿。你刚登地，就是如来家刚刚有了你这个小孩儿，长吧。佛以真如为家，这位菩萨也证见真如了，所以叫“生如来家”。佛以度化众生为事业，菩萨他是要继承佛陀的事业的，这也就是“生如来家”。

“得一切有情平等心性”，登初地就是圣人了，“一切有情”这里指凡夫，这一句是说，凡夫与圣人心性平等，无有差别。“心性”就是真如，真如是没有凡圣的差别的，就是在凡不减，在圣不增。这一句实际上是指菩萨没有觉得自己比凡夫高明，“得一切菩萨平等心性”，菩萨都是要度众生的，这位初得极喜地的菩萨也是要度众生的。这一句实际上是说，刚登地的菩萨并不觉得自己比其他大菩萨矮。“得一切佛平等心性”，佛是圆满的，初登极喜地的菩萨说虽然我现在还没有圆满，但我终究是要圆满的，我们在法性上是平等的。“此即名为菩萨见道”，这就是见道了。

复次，为何义故入唯识性？

我为什么要悟入唯识性？悟入唯识性有什么功德呢？

由缘总法出世止观智故，由此后得种种相识智故。

我们悟入唯识性可以成就根本智、后得智。悟入根本智、后得智后可以成就五种功德。“由缘总法”，就是因为这个修行者观察诸的总相，也就是从总体上观察诸法，发现真如是诸法的总相，是诸法的真实相。每一法当然都有属于自己特有的相，称为别相，当我们站在最高层来看的话，发现有通于一切法的总相，就是真如。“缘总法”，就是思维、观察这个真如。“出世止观智故”，缘总法的智慧不是世间智，它是出世间智。出世间智有的有分别、有的无分别，现在说的这个缘真如的是无分别的。现在说的这个无分别智是“止观智”――在止观里成就的智，是长期修习奢摩他、毗钵舍那（其实最好是把这“止观智”说成四寻思观、四如实智），得了无生法忍之后而成就的，这就是“缘总法出世止观智故”，这个我们称为“根本智”，它是无分别的，因为真如无相。“由此后得种种相识智故”，有了根本智之后，凭根本智可以成就“种种相识智”。“种种相识智”就是通达无量无边各式各样的法相的智慧，或者说是通达“一切法相都是识”的智慧，通达一切法都是唯识所现的智慧。这就是后得智。后得智是依根本无分别智而出现的，它是有分别的，它知道哪是善、哪是恶，哪是世间、哪是出世间等等，一切法相它都通达，它通达一切相皆是如幻如化而没有迷惑颠倒，所以叫“种种相识智”。当然，这都是成就了无生法忍以后才有的。

为断及相阿赖耶识诸相种子，为长能触法身种子，为转所依，为欲证得一切佛法，为欲证得一切智智入唯识性。

成就了根本智、后得智之后，就有五种功德。第一种功德是“为断及相阿赖耶识诸相种子”，得根本智、后得智这都是登初地之后才有的，说，虽然登初地了，但因为是刚登，所以烦恼仍然还有不少，还得努力修行。为了断除阿赖耶识的诸相的种子，“及相”的“及”是到，“相”是因，诸法之因是什么？就是阿赖耶识的种子。我们知道，阿赖耶识里的杂染种子是我们的虚妄分别心的执著而成就的，当我们的虚妄分别心在境界上起分别执著，就熏习了阿赖耶识里的杂染种子了，所以要断杂染种子，就要断杂染种子的因，把因断了，果也就自然断了。断杂染种子，就是不要执著，这就得凭根本智，根本智是有这个功能，它能灭除阿赖耶识里面的杂染种子，这是第一种功德。注意，“及相”的“相”与“诸相种子”的“相”不一样，“诸相种子”的“相”，在世亲释195页中说是“所缘相”，我们知道，有能缘有所缘，这里说是“所缘相”。

第二种功德是“为长能触法身种子”，我们登地了，但仍然还有很长的路要走，这就需要让清净种子增长，清净种子是“能触法身”，“触”就是证、圆满，能证悟法身的真如，要证悟法身，就必须悟入唯识性。悟入唯识性之后，就可以在消灭阿赖耶识的杂染种子的同时，增长清净法身的种子。“为转所依”是第三种功德。就是说，悟入唯识性后就可以转所依。我们在流转生死时候是阿赖耶识为所知依，现在得证无生法忍了，就把阿赖耶识转变成为清净法身的境界。“为欲证得一切佛法”，这是第四种功德。就是可以证得佛的功德。“一切佛法”这里指佛的十力、四无畏、十八不共法等。“为欲证得一切智智”，这是第五种功德，其实这个可以包括在上一种功德里，这里是强调一下这个而已。“一切智智”是佛所有的，菩萨是一切智而不是一切智智，它是无上菩提。我们也可以说是四种功德，把“为欲证得一切智智入唯识性”说成是对前边儿的总结。

不过一般是习惯于说是五种功德。当然，我们还可以这么说，在现在我们修习，是为了登圣位，到了登地以后，这就是已经登圣位了，登圣位之后该怎样进行新的修习呢？就是刚才那一句，“由缘总法出世止观智故，由此后得种种相识智故。”这就是止观与识的关系。“为断及相阿赖耶识诸相种子，为长能触法身种子，为转所依”等，就是说，菩萨的根本智、后得智可以决定一切，菩萨也能做因，也能做果，虽然做出因果，但是他对于这些能够如实了知，他不会颠倒错乱、不会对因果关系生出错误的看法。

又后得智于一切阿赖耶识所生一切了别相中，见如幻等性无倒转，是故菩萨譬如幻师，于所幻事，于诸相中及说因果，常无颠倒。

这是对后得智进行强调。“又后得智于一切阿赖耶识所生”，说，我们悟入唯识性、得证无生法忍之后，同时就成就了根本智和后得智。根本智是断惑证真的，后得智有什么作用？“于一切阿赖耶识所生”，这是指阿赖耶识所生的一切法，阿赖耶识是因，所生的一切法是果，其实就是前面所知相那儿说的相识、见识，由阿赖耶识现出相识和见识。或者说是一切众生，因为众生各有其阿赖耶。“一切了别相中”，“了别”就是识，有能了别、所了别，能了别是见识，所了别是相识，见、相二识都是阿赖耶识所生。各个众生的阿赖耶识所生的一切了别相，“见如幻等”，说，凭后得智可以知道阿赖耶所生的相、见二识一切法都是如幻如化的、都是不真实的。“性无倒转”，后得智可以认清相、见二识皆是如幻如化，因而不会执著它。也就是说，根本智与真如相应，而后得智了达一切法如幻如化。

菩萨与小乘圣者是不一样的，阿罗汉没有人我，断了烦恼，但没见真实，还是会受环境的影响，还是会退的，而大乘菩萨见了真实就没事儿了，就永远不会上当，当然到八地才彻底位不退。所以说菩萨“譬如幻师”，菩萨就象一个魔术师，他用幻术变化出一切事相，它知道这是自己幻化的，不会被这些幻化的事相所迷惑。其实我们也是幻化师，不过是我们幻化出来以后看久了忘了它是幻化的，给当成真实的了。就象我自己说谎话，说得我自己也相信了我的谎话是真实的，就是感动了自己。“于诸相中”，菩萨对于阿赖耶识所变现的一切事相，他都知道是如幻如化的，不会产生颠倒的认识。“及说因果”，菩萨要为众生说法，说世间因果、说出世间因果，这些他都能说得清清楚楚，不象我们说因果，只会说这是因果，具体的因果又说不清楚，菩萨不是这样的，“常无颠倒”，菩萨说法是不会有谬误的。菩萨说法凭的是后得智，这一个我们一定要知道。说法是凭后得智的。我们也要知道，在我们得入圣位的时候，是根本智、后得智同时有的。

于此悟入唯识性时，有四种三摩地，是四种顺抉择分依止。云何应知？

说，在我们悟入唯识性的时候，悟入唯识性就是见道，现在说在即将见道的时候，还没有见道就是加行位，在加行位时，也不是单独由观察思维的智慧就能悟入唯识性的，还应该有一个依止处。这个依止处是什么？这一句长行中就说是“四种三摩地”，“四种三摩地”就是四种定，这四种定是悟入唯识性的依止处。“是四种顺抉择分依止”。“依止”就是靠山，我们两个有矛盾，我不怕你，为什么？因为我有靠山。这四种定是悟入唯识性的依止，还是四种顺抉择分的依止。什么是“四种顺抉择分”？就是暖、顶、忍、世第一。“顺抉择分”的“顺”就是随顺，随顺什么？随顺抉择分！什么是“抉择分”？“抉”就是决定，没有犹豫了，没有一点儿的犹豫就是“抉”！“择”就是拣择、挑选，就是分辨正确与不正确，实际上就是思维观察的意思。经过思维观察得到一个决定的认识，这就叫“抉择”，当然，这是圣者才可以得到决定的认识。得到决定的认识，就没有疑问了。这是说，菩萨在修行的时候，观察名、义、自性、差别，发觉它们都是唯识所现，都是毕竟空的，这是见道的智慧，当你认识到这个时候，就是见道了。本来这个抉择是通于见道、修道、究竟道的，但在这儿只说见道，它是抉择的一部分，所以叫“抉择分”。现在说个个“顺抉择分”，说，这暖、顶、忍、世第一，还不是抉择分，但是它与抉择分相随顺，它本身不是圣者的智慧，但它可以引发圣人的智慧，它与圣人的智慧最亲近，所以见“顺抉择分”，这个“顺”也可以说是亲近、临近。有了四种三摩地，才能有四种顺抉择分。“云何应知”？这些儿我还不明白，无著论师你给我解释一下好不好？

应知由四寻思，于下品无义忍中，有明得三摩地，是暖顺抉择分依止。

无著论师就来解释了。四寻思观、四如实智与四种三摩地、四种顺抉择分是可以配合起来的。“应知由四寻思”，四寻思观就是名寻思、义寻思、自性假立寻思、差别假立寻思。“于下品无义忍中，有明得三摩地”，“无义忍”就是“义”是不可得的。这个“义”包括名、义、自性、差别，说，名、义、自性、差别都是唯心所现，没有真实性可得。对于这个事儿，你要认可，认可他是唯心所现。说，要是没有心识的分别，就没有名、义、自性、差别。“忍”，就是欢喜。对于“义”很欢喜，那就麻烦了，“无义忍”就是欢喜无义的境界。说，名、义、自性、差别都是我内心的分别，它们本身是无所有的，这样讲，你生起了欢喜心，认可这个道理，就叫“无义忍”。这里说的“无义忍”是初开始成就时的无义忍，这还不是很高的境界、不是很高的智慧，所以叫“下品无义忍”。“有明得三摩地”，“明”就是智慧，“无义忍”就是智慧。“得”，获得。就是开始成就这个智慧了，以前没有，现在成就了。“三摩地”就是定，这个定是这个智慧的依止处，就是说，“明得定”是“无义忍”的依止处、靠山。“是暖顺抉择分依止”，在“明得三摩地”里成就的下品无义忍就是暖顺抉择分依止。“暖”是温暖，它是一个比喻，是指修行到这儿的时候，马上要得证圣道了，心里很高兴，感到心里热乎乎的，所以叫暖。

于上品无义忍中，有明增三摩地，是顶顺抉择分依止。

有了无义忍之后，程度渐渐增加，由下品无义忍到了上品无义忍。到这儿就从暖位到了顶位。“顶”也是一个比喻，比喻你到了最高处。山高，站在山顶不是更高了吗？上到顶的时候，一览众山小，看得很清楚，就是指修“无义忍”到了上品，智慧比以前增长了。当然了，实际上你还是思维观察名、义、自性、差别的不可得，虽然这是一样的，但智慧可增长了不少，这是得“明增三摩地”，“明”是智慧，“增”是增长，“明增三摩地”就是因为你不断地修，智慧在增长。这是“顶顺抉择分”的依止处，就是说，在“明增三摩地”里边成就的上品无义忍就是“顶顺抉择分”的依止处。本来暖、顶、忍、世第一都是加行位，顶就是到顶了，但是到这儿后这善根还是会退的，有可能会失掉。到了忍、世第一就不退了。

复由四种如实遍智，已入唯识，于无义中已得决定，有入真义一分三摩地，是谛顺忍依止。

四寻思对应暖、顶，四如实智对应忍、世第一这两个顺抉择分。“复由四种如实遍智”，说，修行人由上品无义忍继续努力，就可以成就四如实遍智。“已入唯识，于无义中已得决定”，就是说，在这儿是觉察了所取的名、义、自性、差别不可得，但是还没有觉察到能取的识不可得。就是说，知道了遍计执不可得、毕竟空，这就是“已入唯识”。就是知道了所有的名、义、自性、差别都是识的分别，都是内心的分别，能够决定认知这道理了。这就是见到了依他起，这叫“入唯识”。“于无义中已得决定”就是说，在这时，对所取的义认清了，确确实实知道了我们执著所取的诸法与能取识是没有关系的。就是说我们眼前所见到见闻觉知的境界与我们的见闻觉知实际上没有关系。就是说，根本就没有见闻觉知的境界，除了我们心的变现，并没有什么见闻觉知的境界，那是毕竟空的，这就是“无义”。对这个道理得到了决定的认识，一点儿犹豫也没有，这就是“于无义中已得决定”。“有入真义一分三摩地，是谛顺忍依止”，达到了这个程度，那么所依止的三摩地，就是“入真义一分三摩地”，在《成唯识论》中叫它为印顺定。这俩名是一回事儿。“入真义”的“真义”就是唯识性，唯识性这里指圆成实性，就是离一切相的境界、诸法空相的境界。因为这时候还是所取的义不可得，能取的识还在，所以叫“一分”，要是义不可得、识也不可得那就是二分了，二分就是全部了、就是没分了，现在没有达到这个程度，所以是“一分入真义”。

“是谛顺忍依止”，“忍”有上、下三品。下品忍就是暖、顶二位的忍。暖、顶二位是观察所取义不可得，得到决定能印。中品忍就是观察能取的分别心不可得。到上品忍就是印可了分别心不可得。就是说，上品忍马上一剎那就到世第一位了，到世第一位时就印可了所取境不可得、能取心也不可得。过了世第一马上就见道，世第一包含一剎那，见道也是只包含一刹那，立刻就到修道位。在这句长行中说的是只知道所取义不可得，对于这个能取义的识也观察到了是不可得，只是还没有得到决定。“谛顺忍”的“谛”，就是真理，诸法无我是真理，这是“谛”。这里的“谛”就是指不颠倒、不错乱。说一切法无我不错乱的、是真实不虚的。“顺忍”是指你能够随顺诸法无我的道理、能够亲近诸法无我的道理、欢喜诸法无我的道理，这就叫“忍”，只是在这时，你还没有证悟诸法实相，你还不是圣人。“入真义一分三摩地”是“谛顺忍”的依止处。

从此无间伏唯识想，有无间三摩地，是世第一法依止。

从“谛顺忍”那个地方，“无间伏唯识想”，就是说，没有间隔，只一剎那间就到世第一位了，在世第一也没有间隔，一剎那你就见道。说，你一刹那间就把能取的分别心也伏灭了，也就是认清了能取的分别心的真相。既然所取义不可得，当然能取的分别心就没有办法生起，这样自然就入于不生不灭的境界了，这是“无间三摩地”。它是“世第一法依止”，“世第一”就是指在这个时候，觉察到了一切法不可得、心也不可得，有了这个智慧，这是一切世间法里最殊胜的。

应知如是诸三摩地，是现观边。

这一句长行就是总结。明得三摩地、明增三摩地、入真义一分三摩地、无间三摩地，就四种三摩地，说，这四种三摩地“是现观边”，“现观”就是无漏的智慧，无漏智慧现前就是见道，就是说，这是见道的边，跨过这个边界线就是见道了。“边”是界线，世第一法和见道位最临近，它是“边”。

如是菩萨已入于地，已得见道，已入唯识，于修道中云何修行？

见道之后就该修行了，其实我们现在说的修行，还很难说怎么样。见道之后的修行那才是真的修行，是无错缪的修行。“如是菩萨已入于地”，这时候登地了，进入欢喜地。“已得见道”，成就了无分别智，到见道位，见道位是刹那间的事儿，一见道立马就该是修道位的事儿。“已入唯识”，契入了唯识实性。“于修道中云何修行”？到底该怎么修行呢？

于如所说安立十地，摄一切经皆现前中，由缘总法出世后得止观智故，经于无量百千俱胝那庾多劫数修习故，而得转依。为欲证得三种佛身，精勤修行。

进入修道位就该修行了，到底该怎么修行呢？“于如所说”，说，到底该怎么修行呢？“安立十地”，十地欢喜地、离垢地、发光地、焰慧地、极难胜地、现前地、远行地、不动地、善慧地、法云地，这是修道至浅而深的位次。这个阶断实际上并不是真的有十段，而是佛给安立的，佛凭他的大智慧把发无上菩提心者得无生法忍后的位次给分了十个阶段。“摄一切经”，指在十地的修行中，要修所有经典中所说的法门，“皆现前中”，都要用到。指所有的法门都要用到，在修行的时候，你不是只用这个法门或者只用那个法门，要用好多的法门，不过这里的“摄一切经”是指好多经、好多法门，并不是绝对的全部经、全部法门。注意，这“摄一切经皆现前中”都是在禅定里，这是不可思议的。

“由缘总法出世后得止观智故”，这就用到根本智了。根本智缘真如，“缘总法”就是用根本智缘真如。“出世”就是出世间，有根本智就出世间了，出世间才证得根本智，然后再加上“后得止观智”，就是后得智。也就是说，我们得凭根本智、后得智去观“摄一切经皆现前”，就是说，得凭根本智、后得智去修学一切典籍所讲的法门。这才是修行，我们现在没有根本智、后得智，所以还不是修道位。注意，是一得根本智，立马就可以得后得智了。

“经于无量百千俱胝那庾多劫数修习故”，得修行多长时间？“无量百千俱胝那庾多劫”，就是很长时间。我们一般来说，三大阿僧祗劫是这么划的，从发心到登地的刹那得一大阿僧祗劫，登地后到初入八地得一大阿僧祗劫，八地到成佛得一大阿僧祗劫。现在说的修道是指从登地之后到成佛这一段，说得很长时间。不光得长时间修，而且得“数修习”，就是说，可不是修一下就行了，得不停地修、不断地重复。这样的话，“而得转依”，这样才能成就，才能得大涅槃、大菩提。“为欲证得三种佛身，精勤修行”，为了成就三种佛身，得精进地修行。

声闻现观，菩萨现观，有何差别？

凡夫修行是凭的分别心，而圣者是凭的无漏智慧。不过圣人有声闻乘圣人，有菩萨乘圣人等，他们的情况也不一样。“现观”就是无漏智慧，现在就是问，菩萨的无漏智和声闻的无漏智有啥不同。

谓菩萨现观与声闻异，由十一种差别应知：

菩萨的现观和声闻的现观有十一种不同。

一、由所缘差别，以大乘法为所缘故。

第一个不同之处是“所缘”不同。一般来说，“所缘”就是认识对象，在这里是指所学的东西。说，菩萨是广学无量法门，亲近无量无边的诸佛，而小乘则是只学佛法中的一部分而已。或者这么说，所读的典籍不同，小乘所学的典籍是小乘人听佛说后记录整理下来的。干脆就说，小乘有小乘的经论、大乘有大乘的经论，这经论是小乘人听佛说、大乘人听佛说后传下来的，自然有听闻者、整理者――也就是结集者的理解在里边儿。这样就形成了不同的经论。大乘是要学习小乘经论的，这一点儿可不要搞错。《地藏十轮经》中说，“尚迷二乘法，况能解大乘？譬如阙坏眼，不能见众色。如是阙坏信，不能解大乘。无力饮池河，讵能吞大海？不习二乘法，何能学大乘？先信二乘法，方能信大乘。”

二、由资持差别，以大福智二种资粮为资持故。

“资持”就是资粮、资本。说，菩萨有福德资粮、智慧资粮，而且资粮是充足的，所以他能得佛果，但小乘人则不是，小乘也能得圣道，也有资粮、资本――宿世栽培的善根，福德、智慧的资粮，但是小乘的福德资本不是很充足，所以成不了佛。这儿有这么一个情况，我们得注意一下。小乘资粮不充足，所以不能成佛，但大乘是开始资粮就充足吗？当然不是，大乘是在刚发菩提心的时候，资粮也不是很多的，但他在得了圣道以后，用无所得的智慧可以继续修六波罗蜜继续栽培福德智慧资粮，就是说，菩萨这支部队的后勤保障了，可以源源不断地续上资粮，而声闻乘这支部队的后勤供应有些问题，资粮完了就没有办法了。

三、由通达差别，以能通达补特伽罗法无我故。

二者所通达的不一样。菩萨可以通达“补特伽罗、法无我”，就是补特伽罗无我和法无我，菩萨可以通达这二无我，但声闻乘只能通达补特伽罗无我，通达不了法无我。

四、由涅槃差别，摄受无住大涅槃故。

所得的涅槃不一样。阿罗汉是先得有余涅槃，后得无余依涅槃。得了无余依涅槃后，阿罗汉就不管众生世界了，而菩萨不是，菩萨是得无住涅槃的。长行中的“摄受”就是成就的意思。所谓无住涅槃，就是有智慧不堕生死，有悲心不入涅槃。他证得涅槃了，但他还要到众生世界来度化众生。这给声闻乘是不一样的。

五、由地差别，依于十地而出离故。

“地差别”是说菩萨修行是十地，一地一地过，欢喜地、离垢地、发光地、焰慧地、极难胜地、现前地、远行地、不动地、善慧地、法云地，这样离一切障而圆满成就大菩提的，可声闻乘不是，声闻乘是四果，他可以一生就从初果须陀洹、斯陀含、阿那含，一直走到四果阿罗汉。

六、七、由清净差别，断烦恼习，净佛土故。

第六、第七两个合在一起，叫“清净差别”。什么意思？就是说，菩萨能断除烦恼，不但能断除爱烦恼、见烦恼，而且能断除爱烦恼、见烦恼的习气。阿罗汉能断烦恼，但没能断烦恼的习气。“习”就是习气，就是种子。这一个就很微妙，说小乘人因为还有习气在，所以偶尔还有失态的情况。还有一个不同是说，菩萨有清净的佛土，有缘者都可以到他这儿来，可声闻乘没有这样的事儿。因为他入无余涅槃就不度众生了，所以要净土没有用处。“断烦恼习”是菩萨自己的境界特别清净，“净佛土”则是普度众生用的。所以，第六应该是，清净差别，断烦恼习故；第七应该是清净差别，净佛土故。因为都是“清净差别”，所以可以合在一起。

八、由于自他得平等心差别，成熟有情加行无休息故。

这个“自他得平等心差别”是说，菩萨对自己、对他人都是一样的，他能对别人象对自己一样，他没有自他的差别，这就是平等，但罗汉不是。他入了无余涅槃之后，就不管别人了，他不是对待别人象自己一样。菩萨要“成熟有情”，就是令众生都成就，“加行”就是为度众生而努力修行，修加行，这样的努力就是“无休息”。菩萨不停地作这事儿。到后边儿要讲到六度，六度就是度众生的问题，就是菩萨对他人的问题。

九、由生差别，生如来家故。

“生差别”是说，菩萨能“生如来家”，如来以真如为家，就是说，菩萨能得真如、得无分别智，可以继承如来的事业。声闻乘罗汉是不可以的，因为罗汉不能尽未来际度化众生。这一个呢，韩老是译成了“由生于如来种姓故”，这就成了长时间积累的问题，成了菩萨成佛的问题。

十、由受生差别，常于诸佛大集会中摄受生故。

受生差别是说，菩萨能够在诸佛大集会里度化众生。这是指，菩萨到受用土度化众生，而罗汉没有这本事。“诸佛大集会”就指受用土，说菩萨能在诸佛集会说法的境界里摄受那些莲华化生的众生，罗汉则只能摄受父母所生之众生。第九的生差别与这个第十的受生差别我再说几句，不然的话不明确。第九的生差别是说，菩萨将来要成佛，这第十的受生差别是说，菩萨现在已经是佛的眷属了。长行中说是“常于诸佛大集会中摄受生故”，就是说，诸佛集会的时候菩萨就到场了。咱们知道，说诸佛都有自己的眷属，佛到那儿去，不是佛自己一个去，他都带自己的眷属，就象我们现在世间的一个大和尚去哪儿都要带上侍者一样。佛带去的眷属自然是佛的亲近者，菩萨可以。作为诸佛的眷属，就可以受用诸佛法乐。第九是说将来，第十是说现在。第九说将来成佛，第十说现在就是诸佛眷属。

十一、由果差别，十力，无畏，不共佛法无量功德果成满故。

这是说菩萨与声闻所得的果位不同。菩萨可以得“十力”、“（四）无畏”、“（十八）不共佛法”等，也就是说，菩萨是证圆满佛果，而声闻则只能证罗汉果，不如菩萨庄严。“十力”是指如来所具有的十种力用：a.知觉处非处智力，即能知一切事物的道理和非道理的智力；b.知三世业报智力，即能知一切众生三世因果业报的智力；c.知诸禅解脱三昧智力，即能知各种禅定及解脱三昧等的智力；d.知诸根胜劣智力，即能知众生根性的胜劣与得果大小的智力；e.知种种解智力，即能知一切众生种种知解的智力；f.知种种界智力，即能普知众生种种境界不同的智力；g.知一切至所道智力，即能知一切众生行道因果的智力；h.知天眼无碍智力，即能以天眼见众生生死及善恶业缘而无障碍的智力；i.知宿命无漏智力，即知众生宿命及知无漏涅槃的智力；j.知永断习气智力，于一切妄惑余气，永断不生，能如实知之的智力。“四无畏”是a.一切智无所畏，佛于大众中明言我为一切智人而无畏心。b.漏尽无所畏，佛于大众中明言我断尽一切烦恼而无畏心。c.说障道无所畏，佛于大众中说惑业等诸障法而无畏心。d.说尽苦道无所畏，佛于大众中说戒定慧等诸尽苦之正道而无畏心。“十八不共”就是身无失、口无失、念无失、无异想、无不定心、无不知己舍、欲无减、精进无减、念无减、慧无减、解脱无减、解脱知见无减、一切身业随智慧行、一切口业随智慧行、一切意业随智慧行、智慧知过去世无碍、智慧知未来世无碍、智慧知现在世无碍。

因为这十一种差别，所以我们说大乘佛法很殊胜。

此中有二颂：

这儿有二个颂子。

名事互为客 其性应寻思

于二亦当推 唯量及唯假

这两个颂子，第一个是说四寻思观，第二个颂子是四如实智。四寻思观就是四加行的暖位、顶位，而四如实智是忍位和世第一位。四寻思观一般是说成名、义、自性、差别，这儿说的是名、事、自性、差别，这关系不大，这样叫也可以。“名事互为客”，名和事互相来说，都是客人，都不是主人。也就是说，它二者互相依靠、互相依赖，而且都不实在。就是常说的依义立名、依名诠义。依据这件事儿而安立假名，同时，要是没有名，义也就显不出来。一般都是这么说的，“客”就是没有实在性，我们现在把它说成客尘烦恼，客尘烦恼是怎么来的，就是因为我们执有自性所以而有的，都是无明所现的，无明就是莫名其妙的意思。韩老用了这几个词，飘忽不定、莫名其妙、不知所由、突如其来等来形容无明。“其性应寻思”，说，名的体性、事的体性，是我们应该好好去观察观察、思维思惟。“义”应该是我执、法执，不过有时候说成蕴、处、界，五蕴、十二处、十八界。我们要观察名、事儿，要知道它们都是空性。要知道它们实际上都是飘忽不定的，都是由无明而有的。“于二亦当推，唯量及唯假”，对于名、事我们应该认清，对于自性、差别呢？我们也应该“推究”，这个“二”就是自性、差别，“推”就是推究，也就是思维、观察。经过推究，发现自性、差别其实也是妄想而已，根本就是虚假的。这儿的“量”是动词，就是思量、分别，或者说是测量，用眼测量色，用耳测量声……用意识测量自体、差别。就是说，我们在奢摩他里思维观察，发现自性、差别也只是内心的分别所示现的而已。因为内心的分别而安立出了种种名字，这根本就是假立出来的。下边儿是第二个颂子。

实智观无义 唯有分别三

彼无故此无 是即入三性

第一个颂子是四寻思，现在是四如实智。“实智观无义”，说，你继续思维名、事、自性、差别是无所有的，达到了决定的见解，一点儿也不犹豫，这是“实智观无义”，就是明白了遍计所执是无有的。“唯有分别三”，本来有名、事、自性、差别四个，你发现事，就是义，根本是没有的。这就只剩下名、自性、差别三个了。这就是悟入了依他起性。“彼无故此无”，“彼无”是指第二句是义无、事无。“此无”是指剩下的名、自性、差别都无。因为义无，所以名无、自性无、差别无。没有义，需要义的名吗？不需要，没有桌子，有桌子本身（自性）吗？没有！没有桌子、书本，有桌子与书本的差别吗？没有！这就是悟入了圆成实性。“是即入三性”，“实智观无义”是悟入遍计执，“唯有分别三”是悟入依他起，“彼无故此无”是悟入圆成实性，这样呢，三性就都悟入了。当然，这一个颂子我们也可以这么说，“如实观无义”，我们仔细思维名、义、自性、差别中的“义”，发现它是根本就不存在的，连一点儿影子也没有，“唯有分别三”是说，既然没有“义”，剩下的名的分别、自性的分别、差别的分别其实是“分别自己在分别”，这就是要想认识识，只能凭识自己来认识识。笛卡尔说“我思故我在”，我们说，思只能证明思存在，证明不了我存在，应该是“思故思在”。现在就是说，是分别在分别，分别自己把自己分别出名、自性、差别。

复有教授二颂，如分别瑜伽论说：

前边儿的二个颂子是无著论师自己写的，现在无著论师又引用弥勒菩萨的二个颂子。

菩萨于定位 观影唯是心

义相既灭除 审观唯自想

这二个颂子是《分别瑜伽论教授颂》，都说没有传到中国来，而且在印度也失传了，不过现在韩老根据这二个颂子，发现其实就是《庄严现观颂》，不过没有翻译过来，韩老就把它翻译出来了，《弥勒道场》网站上放的有。“菩萨于定位”，菩萨在定位中间修行，“观影唯是心”，“影”就是影像，是不真实的意思，名、义、自性、差别都是“影”。说，菩萨在定中思维观察，发现名、义、自性、差别等这些其实只是内心的分别而已。“义相既灭除”，“义相”就是有自体者。说有自体者既然已经被破斥了，也就是说，根本就没有“有自体”的“义相”存在。你的心在分别，但所分别的境界是不可得的。“审观唯自想”，“审观”就是仔细地审视、观察，非常认真地审视、观察，不是浮泛的审视、观察，是确确实实静下心来审视、观察。一般的观察我们容易打妄想，容易夹带杂念，这“审观”是不夹带杂念的。说，你经过仔细地审视观察，发现所分别的境是没有的，只是自己心在分别，这样就破除了对所缘境的执著。

如是住内心 知所取非有

次能取亦无 后触无所得

“如是住内心”，我们已经破除了对所缘境的执著，我们就安住于内心了。“住内心”的“住”是安稳的意思，就是说，我们的心就安稳了，因为我们知道了一切法都是内心的分别而已。“知所取非有”你知道了所认取的一切法都是虚妄分别而已，它们其实根本就没有自性、根本就不存在。“次能取亦无”，接着你知道了能取的分别的心也是无自性的。“后触无所得”，“触”就是认识到、证悟。这样你就证悟到离一切相的平等法性了。

复有别五现观伽陀，如大乘经庄严论说：

下边儿无著论师又引用了《大乘经庄严论》（按窥基法师的说法是《庄严大乘经论》）中的五个颂子。“现观”实际上就是修行。这五个颂子实际上是修行的五个位次。

福德智慧二资粮 菩萨善备无边际

于法思量善决已 故了义趣唯言类

这个颂子说是资粮位。也有人说只这个颂子的前两句是资粮位。世亲释202页说，“第一颂显资粮道，第二初半显加行道，后半第三显于见道，第四一颂显于修道，第五一颂显究竟道。”印顺法师说这“似乎是玄奘臆改的（《摄大乘论讲记》346页）”。“福德智慧二资粮”，福德资粮、智慧资粮，佛就是二足尊，二足就是福德、智德。现在菩萨也得修福、修智，福、智能帮助我们得入圣道，那是资本，所以称为资粮。在六波罗蜜之中，修布施、持戒、忍辱是修福德资粮。精进、禅定是通于福德、通于智慧的，般若则是智德资粮。“菩萨善备无边际”，说，菩萨准备的福、智资粮，很多很多，十分的充足，当然，“无边际”虽然是很多很多，但仍然不是圆满。就相当于咱们说的“恒河沙数”一样，对于我们来说，恒河沙就是无数的，但对于佛陀来说，恒河沙实际上是有数的。福德、智德都得修，两手都要抓，两手都要硬。

“于法思量善决已，故了义趣唯言类”，“思量”就是思维。菩萨在资粮位的时候，他不但修福德、智慧以积聚资粮，对于佛法也是学习的。就是说，菩萨对于经论中说的法，菩萨在修行的时候都观察、都思维。“善决”，就是指能进行善巧的决断，没有疑惑，知道法是无常的、无我的、是内心的变现。因为菩萨决定知道了这些，所以能够通达一切的义趣，一切的名、义、自性、差别，知道它们都是“意言”。“唯言类”是指它们都是意识的安立。“类”是现出，就是指一切法都是意识现出来的影像而已，都不真实。这一个“故了义趣唯言类”，我是这么理解的：“义”就是我执、法执，就是把绳看成蛇的“蛇（解）相”。现在就是说，所以菩萨认清了义都是因言（言即名言）而有的。我觉得这一句这样说比较准确。

若知诸义唯是言 即住似彼唯心理

便能现证真法界 是故二相悉蠲除

这是加行位。在资粮位的基础上，进一步修行。在资粮位，你已经知道了诸义――境界――实际上只是“言”（即名言），就是意识的分别，是似义显现而已，根本就不实在。颂子中“唯是言”的“唯”，是决定的意思，决定知道，没有一点儿的犹豫。知道那只是意识的分别。“即住似彼唯心理”，你知道了它们只是心识的分别，你就可以安住在“似彼唯心”的道理上了、安住在唯识无义的道理上了。注意：在这儿是安住于“似彼义相显现唯是心性”的道理，就是悟入了依他起性。有的人会对这个产生误会。我们要知道，佛教不是毁灭一切，所以我们不要因为诸法不实在而厌恶它。

第一、第二这两句颂子，我想这么说：菩萨知道了一离开语言就没有了什么所存在的、我们认为是有的东西。我们现在说的唯识，实际上是唯语言、唯名言。要是没有名言（一切信息，包括色、声、香、味、触等等），也就没有了义。离开言说，义的行相就不存在了。所以我们也只能“因言生解”――在语言上生起正确的认识。我们现在在语言上生起了错误的认识，菩萨转过来，在语言上生起正确的认识。“便能现证真法界，是故二相悉蠲除”，既然菩萨生起了正确的认识，那么就可以证悟平等法性，这样一来，就把能相、所相就都消灭了。这两句在妙老的本子里说是见道位，而不应该是加行位。不过我看说成加行位也是可以的，只要把这两句理解成别别时意趣就可以了。

体知离心无别物 由此即会心非有

智者了达二皆无 等住二无真法界

这是见道位。“体知离心无别物”，“体知”就是体悟、通达、了知。说，通达了离开了分别心就没有任何的法可得。“由此即会心非有”，所取的法不可得，能取的心也不可得。“会”就是领会。“智者了达二皆无”，“智者”就是菩萨。菩萨通达了能取、所取都不可得。“等住二无真法界”，“等住”就是平等地安住。菩萨了达了能取、所取皆不可得，自然就平等地安住在一真法界之中了，这就离一切戏论相。在见道之前，语言皆戏论，因为有语言、名言就会生出种种的义，现在见道了，没有这戏论了。

慧者无分别智力 周遍平等常顺行

灭依榛梗过失聚 如大良药消众毒

见道后就该修道了。颂子中的“慧者”，实际上就是前边儿那个颂子中的“智者”，还是菩萨。“无分别智”，这里指根本智、后得智。说，菩萨在见道的时候，具足了根本智、后得智，因为根本智、后得智的缘故，所以“周遍平等常顺行”，无分别根本智、后得智就有这个能力。“周遍”就是普遍于一切法，一切法都平等，皆是真如。“常顺行”，一直随顺这样的心修行。也就是随顺真如而行。“灭依榛梗过失聚，如大良药消众毒”，前两句是证真，后两句是断惑。“灭”是灭除、“依”是所知依，就是阿赖耶，也就是种子识。“榛梗”，“榛”是一种落叶灌木，我们一般不都说灌木丛么～～因为是灌木，所以这里是比喻丛杂无章，这是来形容阿赖耶识里的杂染种子的。“梗”就是阻碍、障碍。说因为阿赖耶识里的杂染种子而显现一切法，这一切法障碍我们，令我们烦恼。“过失聚”，阿赖耶识里是我们无始以来的执著心造出来的种种罪过的聚合体。现在我们随顺真如，把他们都给灭除掉。因为我们有无分别智，能够随顺真如，所以能够把们消灭掉，消灭掉它们，就能得大自在、得大解脱。“如大良药消众毒”，我们中毒了，就得有解药，现在这无分别智就是最好的药，它能把所有的毒都消灭。现在就是说用无分别智消灭阿赖耶识里的杂染种子。记住，修道位主要是凭无分别智。

佛说妙法善成立 安慧并根法界中

了知念趣唯分别 勇猛疾归德海岸

这是究竟位。“佛说妙法善成立”，佛说的无上甚深微妙法，“善成立”，这是凭后得智来善巧成立。“安慧并根法界中”，“安”是安住，安稳地住。“慧”指无分别智。“根”这里是指心。说，菩萨按佛陀所说的这些妙法来修学，能够安住在无分别智里，无分别智与真如相应，也就安住于真如。菩萨不但安住于真如，还可以安住于心里。心一般是指阿赖耶识，但在修道位已经“灭依榛梗过失聚，如大良药消众毒”了，就是把阿赖耶识里的杂染种子统统消灭了，这就成了无垢识了。也就是说，菩萨安住于无垢识里。还有一个“法界”，当然是清净法界了。就是说，菩萨安住于无分别智里、安住于无垢识里、安住于清净法界里。“了知念趣唯分别”，这个“了知”是后得智的。菩萨有根本智、后得智。用后得智通达“念趣唯分别”，就是通达我们所念的种种义趣，都是能分别心。“勇猛疾归德海岸”，用根本智断惑证真，用后得智通达一切法是内心的分别，所以你就能够勇猛精进地修学圣道，那就可以很快成就圆满无上菩提佛果了。


彼入因果分第五

这个“彼入因果分”是讲六波罗蜜多的。咱们还是消文。

如是已说入所知相，彼入因果云何可见？

这是一个过度句。《入所知相分》是讲悟入唯识性的，里边儿也说到了，悟入唯识性不单单是修唯识观，而且还要“善备福智资粮”，具体该怎么备？就是修六波罗蜜多。这就是《彼入因果分》要说的主要内容。

谓由施，戒，忍，精进，静虑，般若六种波罗蜜多。

“彼入因果分”的内容就是布施波罗蜜多、持戒波罗蜜多、忍辱波罗蜜多、精进波罗蜜多、静虑波罗蜜多、般若波罗蜜多。

云何由六波罗蜜多得入唯识？复云何六波罗蜜多成彼入果？

提了两个问题。说，为什么凭六波罗蜜多就可以悟入唯识性？为什么六波罗蜜多能成为证悟后的果呢？

谓此菩萨不着财位，不犯尸罗，于苦无动，于修无懈，于如是等散动因中不现行时心专一境，便能如理简择诸法得入唯识。

我们现在就得修六波罗蜜多。“谓此菩萨”，这位发了菩提心的修行者、菩萨，他只要发了菩提心，想得证圣位，一定得修学六波罗蜜多。“不著财位”，要指修学布施波罗蜜多。他对于财位都不贪著，“著”就是贪著，贪著就是贪爱、留连、执著。不著财位就是拿得起、放得下。“财”是财富，“位”是名位、地位。现在他发心学佛了，那就放下一切，专心学佛。

我想起来厚黑教主李宗吾，他有一篇《求官真言》，第一就是“空”，空闲的意思。说，求官的人，一定要把一切事儿都放下，不工不商、不农不贾，不读书、不学习，一心一意专门求官。还要有耐心，不能着急，今天无效，明天再来，今年无效，明年再来。现在学佛也是，专心学佛，放下一切，还要发长远心。“不犯尸罗”是指修学持戒波罗蜜多。要守持清净戒法。身心清净，才能修学。“于苦无动”，这是指忍辱波罗蜜多。“苦”是不如意的境界，“动”是动摇。就是说我们遭遇了种种不如意的境界，这时候你要耐得住，不能因为受了点苦道心就动摇了。也就是说意志要坚定。“于修无懈”，这是指精进波罗蜜多。就是说在修行的时候，不能懈怠。“于如是等散动因中不现行时心专一境”，“散动因”就是令心散乱、令心向外攀缘。什么样是散动？就是说散动的情况怎么样儿？比如说你“著财位”，要挣更多的钱，想挣更大的地位。这些就是散动因。在这些散动因没有现行的时候，你能够镇得住，没有散乱的事情，你的心安住于一境上。这样你才能够修习禅定之类，“便能如理简择诸法得入唯识”，只有这样，你才能够生发智慧，才能够悟入唯识性、悟入一真法界。

菩萨依六波罗蜜多入唯识已，证得六种清净增上意乐所摄波罗蜜多。

修六波罗蜜多，先要有清净意乐，这样的话你的六波罗蜜多才是六波罗蜜多，不然的话，你那实际上谈不上波罗蜜多。“菩萨依六波罗蜜多入唯识已”，菩萨因了修六波罗蜜多而悟入唯识性，悟入唯识性以后呢，“证得六种清净增上意乐所摄波罗蜜多”，他还是得修六波罗蜜多。这时候的六波罗蜜多与以前的六波罗蜜多有点儿不一样。这是“清净增上意乐所摄”的六波罗蜜多。“清净”的“增上意乐”！“清净”就是没有烦恼来染污，“增上”是特别有力量。在登地之前是烦恼力量比六波罗蜜多有力量，登地后是六波罗蜜多比烦恼有力量。

是故于此设离六种波罗蜜多现起加行，由于圣教得胜解故，及由爱重，随喜，欣乐诸作意故，恒常无间相应方便修习六种波罗蜜多速得圆满。

“是故”，所以，因为有了清净增上意乐而所以，所以什么？所以对于这六波罗蜜多，说，假如说你没有对于六波罗蜜多现起加行，“设离”的“设”是假如、假如，“离”是远离、没有，就是指你在修六波罗蜜多的时候没有“现起加行”。没有现起加行是什么样子？比如说我们在修六波罗蜜多的时候，我们努力提升道心，精进努力，这样我们才能有布施多、持戒波罗蜜多、忍辱波罗蜜多、精进波罗蜜多、禅定波罗蜜多、般若波罗蜜多，这样才对。

但是这儿是得了无生法忍的菩萨、入了圣位的菩萨，他已经证悟了唯识性，他不用刻意现起六波罗蜜多，为什么我们得刻意而菩萨不用刻意呢？“由于圣教得胜解故”，就是因为他对于六波罗蜜多法门有“胜解”――有特别有力的信解。“及由爱重，随喜，欣乐诸作意故”的“爱重”，就是爱重作意，“爱重”就是因为知道这个法门能够成就很大的功德，所以对这个法门产生敬爱、欢喜、恭敬、尊重等心念。这里指爱重六波罗蜜多。“随喜”，指别人在修六波罗蜜多法门，我也心里欢喜、赞叹。还有一个“欣乐”，就是说这位菩萨看见六波罗蜜多所成就的佛的境界，特别地欢喜，希望自己和一切众生都成就这样的功德、这样的境界。

“恒常无间相应方便修习六种波罗蜜多速得圆满”，因为爱重作意、随喜作意、欣乐作意，所以菩萨不用别人鼓励，自己就“恒常无间”（即长时期、不间断）地“相应方便修习六种波罗蜜多”，“方便修习”的“方便”就是善巧的意思，就是有智慧的意思，要想善巧没有智慧你怎么善巧？现在就是说，你要有智慧地修习六波罗蜜多，而且得不断地修，“相应”是指与智慧相应，有智慧你就不会出错了。我们现在不是也经常有些好心作了错事儿的情况吗？菩萨因为这样修习六波罗蜜多，所以“速得圆满”。咱们凡夫不是这样，我们得“现起加行”，要勉强自己，这样才能修行，一没鼓励就偷懒。入圣位的菩萨，他们不需要特别勉强，自己就能够修行六波罗蜜多，因为他们是自觉的，所以他的波罗蜜多很快地会圆满。而我们不是。

此中有三颂：已圆满白法；及得利疾忍；菩萨于自乘，甚深广大教；等觉唯分别，得无分别智；悕求胜解净，故意乐清净；前及此法流，皆得见诸佛；了知菩提近，以无难得故。

前边儿说了“清净增上意乐”，下边儿这三个颂子就是来介绍清净增上意乐的相貌、的表现的。“已圆满白法”，“白”就是清净的、善的，这是说他作了很多的功德，圆满地作了很多功德。也就是说所作的确实的功德，这功德是纯的功德。我们现在作的很多事儿，很难说是纯然的功德，可能对这部分人有益，但对另外一部分人来说，可能就是伤害。而这位菩萨的所作纯是利益众生的，不会在利益这位的时候无意中伤害了另一个人，这不会。这是清净增上意乐的第一个表现。“及得利疾忍”，“利疾”是锐利、迅速、不迟钝；“忍”就是无生法忍。也就是说，有了清净增上意乐的话，可以很快就得证无生法忍，就是登地、入圣位。印顺法师说就是暖、顶、忍、世第一法的忍，这个“忍”是与智慧相应。这是第二个表现。“菩萨于自乘，甚深广大教”，这里的“自乘”就是大乘。注意，我们一般情况下是把大乘小乘对应起来，实际上大乘是把小乘给包容进来的，大乘就是整个佛法。就是说，发无上菩提心的菩萨，他对于自己应该学习的大乘教法，努力地修学。“甚深广大教”指大乘佛法宣说的甚深法性道理、一切法无我的道理，是大智慧境界。“甚深”是指般若波罗蜜多，“广大”，是指除般若外的其他五波罗蜜多。第三个表现就是菩萨对甚深广大的大乘佛法，努力地修学。“等觉唯分别，得无分别智”，这是第四个表现。“等”是平等、普遍，“觉”是觉悟，“等觉”就是普遍地觉悟。就是说，菩萨普遍地觉悟到一切法都是内心的分别而已，一切法都是无义的，他就这样作意思维，最后成就了无分别智。无性释454页中说，“得无分别智者，即是对治。”就是说，用无分别智可以对治一切执著。

“悕求胜解净，故意乐清净”，这是清净增上意乐的第五种表现。说，菩萨有了清净增上意乐，就会有悕求、胜解。“悕求”，就是欲，善法欲，这里指欲得无上菩提。这悕求是由信心而来的。就象作生意，你看准了一个生意，相信它能发财，所以你去作，现在你相信这样作能得无上菩提，所以你就悕求得证无上菩提。“胜解”，就是特别决定的见解，你对它有绝对的信心。胜解是信心的因，悕求是信心的果。这个胜解是指菩萨对佛法、对第一义谛有有力的信心。对佛法既然已经有信心了，接下来的这个“净”字儿，就是指清净的信心，因为这是已经得证无生法忍了，所以，这清净的信心是与无分别智相应的。“故意乐清净”。“前及此法流，皆得见诸佛”，这是清净增上意乐的第六种表现。“前”指得无生法忍以前，就是登地以前。“此法流”则是指得证无生法忍时的情况。世亲释中说此法流是指在禅定中（世亲释205页原文是“言法流，谓定位中”），就是在禅定中见第一义谛。见第一义谛当然得在禅定里，在散乱心里是不可能的。“流”就是圣道，须陀洹不就是叫入流吗？就是入圣道。所以，“法流”是指三昧里的圣境。既然证圣了，当然就“皆得见诸佛”了。“了知菩提近，以无难得故”，这是清净增上意乐的第七个表现。“了知菩提近”是说，得了无生法忍，成就了清净增上意乐，见到了十方诸佛，有这个瑞相了，自己知道距离得证无上菩提不远了。“以无难得故”，成就了清净增上意乐，对于修六波罗蜜多广度众生觉得不难了。按原论文和世亲释，就只有这七种表现，但在无性释中是算出来了八种表现，在453页最后一行，他的八种相是把那个无分别智单独算成一相了。

由此三颂，总显清净增上意乐有七种相：

前面这三个颂子，包括了清净增上意乐的七相。七相就是哪呢？下边儿说了。

谓资粮故，堪忍故，所缘故，作意故，自体故，瑞相故，胜利故。

“资粮故”是“已圆满白法”。“堪忍故”是“及得利疾忍”，有了堪忍，你不管遇见什么境界都不冲动。“所缘故”是“菩萨于自乘，甚深广大教”。这个是要学习的东西。“作意故”是“等觉唯分别，得无分别智”，这就是思维观察、就是修学止观。“自体故”是“希求胜解净，故意乐清净”，这个“自体”是指清净增上意乐本身的相貌。“瑞相故”是“前及此法流，皆得见诸佛”，这是得清净增上意乐后所现的瑞相。“胜利故”是“了知菩提近，以无难得故”，这就是殊胜利益。

如其次第，诸句伽他应知显示。

前面的颂子就是这次第，一一配合起来就行了。

何因缘故波罗蜜多唯有六数？

为什么波罗蜜多是六波罗蜜多而不是四、五或者是七、八？当然了，在其它的典籍中也不一定就是六波罗蜜多，在《大毗婆沙论》上就只有四波罗蜜多：布施波罗蜜多、戒波罗蜜多、精进波罗蜜多、般若波罗蜜多。我们说的忍波罗蜜多，它给含括在戒波罗蜜多里了。有时候还说是十波罗蜜多。这里只说六波罗蜜多，为什么说六？下边儿有三个理由。

成立对治所治障故。证诸佛法所依处故，随顺成熟诸有情故。

这就是三个理由。“成立对治所治障故”，“所治障”，所要对治的障碍。布施波罗蜜多就是要对治悭吝的障碍等等，般若波罗蜜多就是要对治愚痴邪见障。六波罗蜜多就能够对治这些障碍了，所以六波罗蜜多就够了。这个是断德。“证诸佛法所依处故”，“证诸佛法”就是要证悟诸法实相，证悟诸佛的境界。说，六波罗蜜多是成就佛法的因缘。你修六波罗蜜多就能成佛了，所以只要六波罗蜜多就可以了。这一个是智德。“随顺成熟诸有情故”，“随顺”就是随顺佛法去教导众生，以使众生得解脱。“成熟”就是自己得解脱、众生得解脱。这是恩德吧。这是说，用六波罗蜜多就够度众生的了。“证诸佛法所依处”是智德。“成立对治所治障”是断德。“随顺成熟诸有情”是恩德，断德、智德、恩德都有了，断德、智德是自利，恩德是利他，三德、二利都有了就是圆满了。这三条理由实在来说，妙老说他非常好，我当时确实没有感觉到好在哪儿，因为我通过这三句话，根本看不出为什么非要六，难道十波罗蜜多不能用这三条理由？我看完全可以。光这三句话当然是看不透的。我们得往下看。

为欲对治不发趣因故，立施戒波罗蜜多。不发趣因，谓著财位及著室家。

这是解释断德“成立对治所治障故”的。“为欲对治不发趣因故”，“对治”就是消灭，把障碍给消灭掉。消灭什么障碍呢？“不发趣因”，要知道“不发趣”，就得先知道“发趣”。“趣”就是“向”，要到一个地方去叫“趣”，现在我们要到什么地方去？到涅槃那个地方去。我们这个地方是生死的地方，这个地方太苦了，我们要跳出生死到涅槃那个地方去，这就叫“发趣”。就是发出离心，发心出离生死，趣向涅槃。“不发趣”就是我不发心了脱生死得证涅槃。所以说，“为欲对治不发趣因”就是说，为了消灭我不发心了脱生死的因缘、障碍我发心修学圣道的因缘，“故立施戒波罗蜜多”，所以要成立布施波罗蜜多、持戒波罗蜜多，也就是说，这两个波罗蜜多是对治“不发趣因”的。“不发趣因，谓著财位及著室家。”这个呢，是举了一些不发趣因的实例。说，为什么我们会有不发趣因呢？因为我们“著财位及著室家”。人的烦恼到底有多少？根本没数儿，这里无著论师说了两种：财位、室家。著财位就是对治财富、位置的执著，重点儿是财富。所以这一个是要用布施波罗蜜多来对治。布施是把自己的东西送给需要的人，这一个我们一定要注意，是送给需要者，可我们现在常常是送给不需要者，咱们看看自己是不是，怕多是锦上添花～～布施一般是财布施，同时还有法布施和无畏施（后边儿再解说）。为什么用布施可以对治著财位呢？位置能凭布施对治？这是因为你只要有财，财是可以换来位置的。比如说现在有很多大商人都去弄个人大代表当当、弄个政协委员当当。古今一例。“著室家”则需要用持戒波罗蜜多来对治。这个主要是梵行的问题，淫心不除、尘不可出，这很要紧。到最后我再把六波罗蜜多专门说一下。现在先不详细说。现在我们用布施波罗蜜多来对治“著财位”，用持戒波罗蜜多来对治“著室家”，这样就把“不发趣因”消灭了，那么就不能不发趣了，就愿意修学圣道了。

为欲对治虽已发趣复退还因故，立忍进波罗蜜多。

我们有布施波罗蜜多、持戒波罗蜜多了，我们发心修学圣道了，可是呢，一遇到逆境，我们又退转了，说，这么苦，不想干了，这就是“虽已发趣复退还”，这可不妙，那么该怎么办呢？于是，为了对治这个情况建立了忍辱波罗蜜多、精进波罗蜜多。

退还因者，谓处生死有情违犯所生众苦，

退还因有什么样的情况呢？这儿举了例子。菩萨发心要度众生了，但正在流浪生死的众生呢，因为已经习惯了在生死，他们觉得生死是正当的，所以就处处“违犯”――违犯就是与菩萨作对，也就是众生打击菩萨。这时候有些菩萨就生起了不耐烦，想，我是为你们好你们还给我捣蛋，我不管你们了。这就是退心了。妙老还说了一种情况，就是说，菩萨开始的时候说法，是用慈悲心说的，说着说着呢，他看众生有不少的罪过，就用嗔心说法了。这也是退心。

及于长时善品加行所生疲怠。

这是另外一个例子。说，菩萨要弘扬佛法，要广度众生，自己还要努力修道，忙得很，这样呢，他太累了。“所生疲怠”，就是菩萨太累了，菩萨自己受不了了，因为疲惫而懈怠了。关于这一个，《四十二章经》中有个比喻，就是琴弦太紧了不行太松了也不行，必须处于适中的情况。为了对治这样的情况，所以建立了精进波罗蜜多。

为欲对治虽已发趣不复退还而失坏因故，立定慧波罗蜜多。

这一个是说为什么要建立禅定波罗蜜多、般若波罗蜜多。有些菩萨已经发大心了，而且也没有退转，但是呢，在修行的时候出现了偏差，就是迷路了。为了对治这个障碍，所以建立了禅定波罗蜜多、般若波罗蜜多。“失坏”，“失”是干脆方向错了，要往东，结果你走着走着方向转向西了。“坏”则是要往东结果方向有点儿偏，但不是正相反。在无性释456页中说，失坏因是外道（原文说，“如诸外道，是失坏因”）。

失坏因者，谓诸散动及邪恶慧。

这是举了一下“失坏因”的情况。“散动及邪恶慧”，所谓“散动”，就是心老爱往外跑、向外攀缘。这样呢，道心就提不起来，令你正念丧失。“邪恶慧”就是邪知邪见。邪知邪见是怎么来的？最主要的就是：没得禅定的时候，静坐后在那儿分别，一分别就有了邪知邪见，这是他自己在那儿执著。还有就是得了禅定，得禅定者的分别心更厉害，他也会分别出邪知邪见，而且这邪见更可怕。所以说，我们修禅定的时候，要以经教为所依，经教可以规范你的知见。你要是什么经教都不读，只在那儿静坐，这是十分的靠不住的。佛说过，在没入圣位的时候，是不能离开文字佛法的。我们看经典，大菩萨们还去听佛说法呢，何况我们。我们一定要一切以圣言量为标准。为了对治散动，建立禅定波罗蜜多，为了对治邪恶慧，建立般若波罗蜜多。

如是成立对治所治障故，唯立六数。

这样呢，一算，发现为了对治不发趣因，建立布施波罗蜜多、持戒波罗蜜多；为了对治退还因，建立忍辱波罗蜜多、精进波罗蜜多；为了对治失坏因，建立禅定波罗蜜多、般若波罗蜜多。这不就是六波罗蜜多吗？所以说只要六波罗蜜多就够了。

又前四波罗蜜多是不散动因，次一波罗蜜多不散动成就。此不散动为依止故，如实等觉诸法真义，便能证得一切佛法。如是证诸佛法所依处故，唯立六数。

根据上边儿说的“成立对治所治障故”，只要六波罗蜜多就可以了。下边儿呢，还有其他的说法。这是因为“证诸佛法所依处”，所以得要六波罗蜜多。我们知道，要“证诸佛法”，般若（波罗蜜多）是最重要的，没有般若（波罗蜜多）不能够得悟圣道，但是，只有般若（波罗蜜多）是不行的。

看长行。“前四波罗蜜多是不散动因”，说，布施波罗蜜多、持戒波罗蜜多、忍辱波罗蜜多、精进波罗蜜多，这四个波罗蜜多是让心静下来的，它们是心不散动的条件。“次一波罗蜜多不散动成就”，这是说禅定波罗蜜多的。前四波罗蜜多让心不散动，心不散动自然就容易得禅定了。印顺法师是把“次一波罗蜜多不散动成就”解释成般若波罗蜜多。他是说，“不散动”就是禅定波罗蜜多，前四波罗蜜多是禅定波罗蜜多的因，而后边儿的般若波罗蜜多是禅定波罗蜜多（不散动）所成就的果。无性释中说是静虑波罗蜜多（原文见456页）。

“此不散动为依止故”，说，这个禅定波罗蜜多可以让你的心不散乱。“依止”就是靠山，有了靠山你就安心，这里说禅定是靠山，要是有了禅定这个靠山，你的智慧就有力了，就可以把你的智慧发挥得相当的充分。“故如实等觉诸法真义”，这样，你就可以如实地觉悟“等觉诸法真义”。就是说，你就可以如实觉知，它是什么样你就觉知什么样儿。我们现在可不是的，明明是没有的，我们觉得有，明明是有的，我们却觉得没有，这就是颠倒见。真的如实知觉了，那你“便能证得一切佛法”。要证得“等觉诸法真义”，是凭般若的，但是，要没有禅定波罗蜜多，你是没有般若的，而要成就禅定波罗蜜多，你就得有前边儿四波罗蜜多。这是一个连环套儿。

“如是证诸佛法所依处故，唯立六数”，所以，你就得有六波罗蜜多，少一个也不行。前边儿一个理由是从对治障碍的角度来说的，说从对治障碍的角度来说，不用多了，只要六波罗蜜多就够了（这是说十波罗蜜多用不上）。现在又从证悟佛法这个角度来说，说得有六波罗蜜多，少了不得够（这是说四波罗蜜多少了点儿）。

由施波罗蜜多故，于诸有情能正摄受；

再看为什么要六波罗蜜多的第三个理由――随顺成熟诸有情。长行中说，“由施波罗蜜多故，于诸有情能正摄受”，这一句话是说得有人缘儿。你要想度化众生，你得给众生有良好的关系，让他们看见你就愿意接近你，这才行，如果他们一看见你就吓跑了，那还得了～～关系怎样建立？由施波罗蜜多而建立！这一个是很微妙的。在菩萨自己的角度来说，是布施波罗蜜多，财施、法施、无畏施，但在众生看来，他未必知道，可能有人会说你是在贿赂众生，这都有可能。

宗萨仁波切说：我们现在能看到不少师父与弟子相互贿赂的情况，弟子尽可能作师父喜欢的事儿，师父会对这个弟子说，“我教给你一个经法，这个经法是从来没有给别人的”，其实这个经法根本就不重要，但这样可以使弟子高兴。这些我们都不要管，菩萨你只要自己内心里知道自己这是布施就可以了。你只要布施了，就“于诸有情能正摄受”，“摄受”就是接引、度化。可以把众生接引到佛法里来，就叫摄受。有人把这个还解释成折伏，说，对于心性柔和的众生，就接引摄受，对于暴恶的众生，就要折伏他。说，这是菩萨度众生的两个态度。最开始的时候，我觉得这么解释太牵强，凭布施折伏众生是不现实的，但我又考虑了考虑，觉得可能他们是指凭法布施折伏众生的烦恼。这也有点儿象。

由戒波罗蜜多故，于诸有情能不毁害；

说，菩萨一定修持戒波罗蜜多，有了持戒波罗蜜多，才能“于诸有情能不毁害”，就是说，菩萨不作伤害众生的事儿而去救护他们。

由忍波罗蜜多故，虽遭毁害而能忍受；

这一个是反过来了。菩萨持戒了，不伤害众生，可众生反过来伤害你，这怎么办？要有忍辱波罗蜜多。有了忍辱波罗蜜多，菩萨虽然遭到众生的伤害，菩萨也容忍了，并不会去给众生记仇。只有这样，才能度化得了众生。

由精进波罗蜜多故，能助经营彼所应作。

众生伤害菩萨，菩萨宽容众生，一次、两次、三次……众生被感动了，于是也发心修学佛法，可是呢，众生有些力不从心，这是候菩萨有精进波罗蜜多，“能助经营彼所应作”，就是说，菩萨来帮助众生修行，这样众生感受到了菩萨的恩德，更容易接受菩萨的教化了。

即由如是摄利因缘，令诸有情于成熟事有所堪任。

前边儿说过，说这四个波罗蜜多是“不散动因”，那就把这四个波罗蜜多总结一下。“即由如是摄利因缘”，根据刚才说的这四个波罗蜜多摄受众生、饶益众生的情况，可以利益众生、可以接引众生到佛法里来，“令诸有情于成熟事有所堪任”，就是说，众生刚强，难调难伏，让他学佛很难很难，现在菩萨布施、持戒、忍辱、精进四波罗蜜多都用上，终于把众生感化了，他们愿意学佛了。对于解脱这件事儿，他们愿意作了。

从此已后，心未定者令其得定，心已定者令得解脱，于开悟时彼得成熟。

说，众生在菩萨的教导下，信心大增，修学佛法了，“从此已后，心未定者”，从这儿开始，定不下心的众生，“令其得定”，在菩萨的教导之下，心也定下来了。众生之所以心定不下来，就是因为欲望，心老向外攀缘。“心已定者令得解脱”，有的众生心能定下来，那么在菩萨的教导之下，更上层楼，学习般若，渐渐就解脱了。“于开悟时彼得成熟”，开始熏习般若，从闻思修开始，心里的智慧慢慢增长，达到了需要的程度，就开悟了，开悟就是登地。

如是随顺成熟一切有情，唯立六数，应如是知。

总之，这样随顺众生，慢慢教化，就可以使众生趋向正道，终得解脱。这样呢，我们发现，只要六个波罗蜜多，就可以了。

此六种相云何可见？

前边儿说了为什么是六波罗蜜多，现在要说六波罗蜜多的相了。这一句话是说，我怎么知道这是菩萨六波罗蜜多呢？它万一不是菩萨六波罗蜜多，而是声闻乘六波罗蜜多怎么办？那我不就抓瞎了～～它要是声闻六波罗蜜多，我修了半天，成罗汉了，这我不是走弯路了吗？所以，你得给我保证，这是菩萨六波罗蜜多。

由六种最胜故：

无著论师说，放心吧，六波罗蜜多绝对是菩萨乘，为什么呢？因为它有六种殊胜，所以这肯定是菩萨乘。哪六种殊胜呢？

一、 由所依最胜，谓菩提心为所依故。

第一是“所依最胜”，你要想修学六波罗蜜多，你的所依是什么？就是说，你得符合什么样的基本条件？菩提心！也就是说，没有菩提心是不行的。菩萨之所以要修学六波罗蜜多，就是为了成就无上菩提。这不是二乘、凡夫所有的。菩提心其实就是上求佛道下化众生之心。我们现在在作什么仪式的时候都有四弘誓愿，“众生无边誓愿度，烦恼无尽誓愿断，法门无量誓愿学，佛道无上誓愿成”，这只是念了念，菩提心可不是你念念就行的，这不是的。以菩提心为基础而修六波罗蜜多的，所以这肯定是大乘。《维摩经义疏》中说菩提心有名字菩提心、相似菩提心、分证真实菩提心等，实际上名字菩提心、相似菩提心根本就不是菩提心，所谓名字菩提心其实只是说是菩提心而已，名不符实。相似菩提心当然也只是似而已，根本就不是真的。我们把名字菩提心、相似菩提心都叫菩提心，只是为了鼓励学人而已。

二、由事最胜，谓具足现行故。

你发菩提心了，发心了接下来就是行动，你不可能说发心了而没有行动，要是没有行动则你的发心就可能只是胡说而已。这就有了“事最胜”。事最胜就是“具足现行”，比如说你修布施波罗蜜多，他可以把一切都布施众生，什么都可以布施。在经论中有说把自己的妻子儿女都能布施，现在不准这么解释，这样解释会给佛教带来负面影响，因为在以前是男权社会，妻子是被当成私有财产的，所以那么说，现在不要这么说。自己只能布施自己的一切。只要自己能布施自己的一切，毫不保留，这就叫具足布施，持戒、忍辱等都是一样的，六波罗蜜多都具足，就叫“具足现行”。“具足现行”这样的事儿是最殊胜的。

三、由处最胜，谓一切有情利益安乐事为依处故。

“处最胜”就是指他所作的一切所作处是最殊胜的，为什么说所作处殊胜呢？就是因为他的所作处是“一切有情”，有情众生是福田，菩萨是利益有情的，而且是平等地利益有情的。菩萨对众生作了什么呢？“利益安乐事”，“安乐”是说，菩萨现在这样作，众生现在就感到安乐。“利益”是说，菩萨现在作这事儿，可以让众生将来得到好处。总之，菩萨行六波罗蜜多，众生现在就能得到安乐，还能影响到将来，将来还能得到好处。我们现在作事儿就不是了，只为了眼前的一点儿甜头儿，什么都不顾了，象哪个皇帝说的，“我死之后，哪管它洪水滔天。”（法国皇帝路易十五）一般人不会象这样坏，但只顾眼前这现象还是很普遍的。当然，这也是因为智慧的缘故，我看不了多远。菩萨则是要顾及到长久情况的。你无衣无食，我给你衣食，但菩萨会在给你衣食的当下再点化你一下，使你的智慧得一点儿提升。这一个就是处最胜。

四、由方便善巧最胜，谓无分别智所摄受故。

“方便”是指所为来说的，“善巧”是指智慧来说的。你做一件事，有智慧给没有智慧就不一样，差别很大。现在菩萨则是凭“无分别智”来作这件事儿的。“无分别智”的“分别”，比如说我布施，我觉得有布施者，有所施的财、法，还有一个受施者，三方面具足。我们就是这样，但菩萨不是，菩萨是三轮体空，施者不可得，受者不可得，所施之物不可得。这样作事儿就叫“无分别智”，这是最方便善巧的。这是圣者的境界。长行中说是“无分别智所摄受”，这个“摄受”就是加持，因为无分别智的加持，你才能把事儿作得方便善巧。

五、由回向最胜，谓回向无上正等菩提故。

第五个是殊胜回向。为什么回向也殊胜呢？“谓回向无上正等菩提故”，就是说，因为菩萨行六波罗蜜多的回向是回向无上菩提。有些人发愿就是生天，所以他只回向生天。什么叫回向？佛教大辞典上说，“回者回转也，向者趣向也，回转自己所修之功德而趣向于所期，谓之回向。”简单地话说，就是把自己的功德分出去。比如说我挣钱（功德），我把我挣的钱分给我的父母、家人化，这就是回向给了父母、家人，我要是再分给我的亲戚朋友们化点儿，那就是回向给了亲戚朋友，你要是分给所有众生，就是回向给所有众生了。现在菩萨就是把功德都回向给了所有的众生，回向无上菩提，这就是回向最胜。

六、由清净最胜，谓烦恼所知二障无障所集起故。

第六是“清净最胜”，就是说，菩萨以菩提心为基础来修行，用无分别智来做事，可以断烦恼障、所知障，断了以后就没有这二障了，没有二障就是长行中的“无障”，这时候菩萨的心里完全是六波罗蜜多积聚起来的，这可不是凡夫、二乘人能比的，这叫清净最胜。这就是六种殊胜，因为有这六种殊胜，所以这样修行肯定成佛。

若施是波罗蜜多耶；设波罗蜜多是施耶？有施非波罗蜜多，应作四句。

六波罗蜜多还有四句分别，什么叫四句分别呢？就是有四种情况。哪四种情况呢？无著论师这里拿布施波罗蜜多作例子来说。“若施是波罗蜜多耶？”如果这个人行布施了，这个人就是修波罗蜜多了吗？“设波罗蜜多是施耶？”波罗蜜多就是布施吗？这是个问题，解答说，“有施非波罗蜜多，应作四句”，说，实际上有的布施并不是波罗蜜多，这有四种情况。具体是哪四种情况呢？论文中没有说，我来给说。就是一、是布施但并不是波罗蜜多。这是指离六种殊胜的布施，本来该那样儿，结果你没有，这就不圆满，亏大发了。比如说有的人作慈善事业，但他是为了买个名儿以作进身之阶，政府就可能给他个政协委员、人大代表之类的当当。这肯定不是波罗蜜多。二、是波罗蜜多但不是布施，比如说持戒波罗蜜多、精进波罗蜜多，这很明显。三、是布施也是波罗蜜多。这就是依六种殊胜而修布施。四、不是布施也不是波罗蜜多。这就很广了。你不依六种殊胜而修持戒、忍辱等就是。这就是四句分别。

如于其施，如是于余波罗蜜多，亦作四句，如应当知。

布施有这四句分别，其他五波罗蜜多也有这样的四句分别。

何因缘故如是六种波罗蜜多此次第说？谓前波罗蜜多随顺生后波罗蜜多故。

六波罗蜜多为啥是布施、持戒、忍辱、精进、禅定、般若这么一个顺序？难道不能是般若、持戒、禅定、布施、精进、忍辱？六波罗蜜多的次序能不能换换？打乱行不行？“谓前波罗蜜多随顺生后波罗蜜多故”，就是说，这六波罗蜜多，后一个是依前一个而生，般若波罗蜜多得依禅定波罗蜜多而生，要是没有禅定波罗蜜多，般若波罗蜜多是一定生不起来的。禅定波罗蜜多要想生起来，必须得有精进波罗蜜多，要有精进波罗蜜多，你必须得有忍辱波罗蜜多，要有忍辱波罗蜜多，你就得持戒波罗蜜多，要持戒波罗蜜多，你就得有布施波罗蜜多。

这是按前生后的次序而说，注意，我说的“生”是引发的意思。无著论师说“前波罗蜜多随顺生后波罗蜜多”，在印顺法师、妙老法师等，都又引了一下《大庄严经论》中的“后后波罗蜜多能清净前前波罗蜜多”。《大庄严经论》中的这句话给《摄大乘论》中无著论师的这句话意思是一致的。就是说，我要是能有持戒波罗蜜多，则我的布施波罗蜜多一定是清净的，我要是有忍辱波罗蜜多，则我的持戒波罗蜜多一定清净等，六波罗蜜多中，相对来说，布施波罗蜜多是最简单的。依次上进，最后到般若波罗蜜多。所以次序就是这样的了。

复次，此诸波罗蜜多训释名言，云何可见？

这是对波罗蜜多的名字进行训释，训释就是解释。下边儿呢，对总名、别名都进行解释。总名就是波罗蜜多，别名就是布施、持戒、忍辱、精进、禅定、般若。先看对总名的训释。

于诸世间、声闻、独觉施等善根最为殊胜，能到彼岸，是故通称波罗蜜多。

先解释什么是波罗蜜多。说，实际上世间的生死凡夫，二乘的声闻、缘觉，也都是能够有布施、持戒、忍辱等，但是他们的所作都没有菩萨的殊胜、究竟，“能到彼岸”，可以从生死这儿到大菩提处。这是最殊胜的。世间凡夫因为没有菩提心，行布施、持戒、忍辱等等只能得人天善果而已。阿罗汉和辟支佛这些圣人他们行布施、持戒、忍辱等，比较殊胜，可以涅槃，但不能得证阿耨多罗三藐三菩提，这是因为他们没有这愿。只有菩萨可以得到阿耨多罗三藐三菩提，所以我们把菩萨所行的布施、持戒、忍辱、精进、禅定、般若叫作“波罗蜜多”。阿罗汉、辟支佛的都不能称为波罗蜜多。“波罗蜜多”就是到彼岸、最殊胜的意思。

又能破裂悭吝、贫穷，及能引得广大财位福德资粮，故名为施；

这是别名，先说布施。“能破裂悭吝”，“悭吝”就是小气，只要是自己的东西，统统舍不得给别人，那怕是自己根本就用不着的。就是不肯帮助别人，这个自然是烦恼法了。“悭吝”为什么是烦恼？因为是贫穷之因。说，用布施可以破除悭吝这个烦恼，你要是能布施，那就可以破除悭吝，没了悭吝，你来世就不会得“贫穷”的果报了。布施还有没有其他的好处？有，“能引得广大财位福德资粮”，先说“引得广大财位”。说，你只要布施了，就不但能破除悭吝、贫穷，将来你还能得到广大的财富，有钱了当然地位就高了，现在的人大代表、政协委员有多少是大款，穷人是不能当的。

江泽民三个代表的第一条就是“代表中国先进生产力的发展要求”，看，上去就是代表富人！后边儿的“福德资粮”是说，你在佛法里受熏，这个习气可以引导你向于圣道。要是没有佛法的熏习，你可以作不少好事儿，这样你也可以得很大福德，因为有福德，所以你被福德给迷住了，因此你就颠倒放逸，这就不能向于圣道。你要是有佛法的熏习，同样是做功德，功德就会令你有智慧而不迷惑、不颠倒，这样你可以渐渐趋向圣道。所以，我们把这个叫布施。

又能息灭恶戒、恶趣，及能取得善趣、等持，故名为戒；

这是说持戒的。长行中说，“息灭恶戒、恶趣”。“恶戒”就是外道戒，最有名的是持牛戒之类的。说，以前有个人修行出了神通，他看见一头牛死后生到天上了，他就思维：牛也没有修行，他凭什么死后生天呢？琢磨来琢磨去，他发现原来是牛只吃草，于是他以后就只吃草，以期将来也生天。这就是恶戒。还有就是职业杀人者，比如枪决死刑犯人的行刑者，在佛法中这也是恶戒，因为你必须杀生，你不杀就犯国法。要把这些恶戒都息灭。“恶趣”是指你受持恶戒而得的果。你持恶戒，就到三恶道去受生。你要是持佛戒，灭了恶戒，也就灭了恶趣。“及能取得善趣”，你能够受佛法的戒律，就一定是在人天善趣受生，进而还能成就佛道。下边儿的“等持”应该是“及能取得等持”，“等持”就是定、三昧。说，你要是能持戒，不做非法的事儿，你就心安，在这个基础上，你可以静坐、摄心不乱，就很容易成就了。你要是干杀、盗、淫、妄等事儿，就造成人与人之间的冲突，你心就不安，烦恼的事就找你，你就修不成禅定。“息灭恶戒、恶趣”是灭恶，“能取得善趣、等持”是生善。善法能够灭恶，同时还能得到可爱的果报。施波罗蜜多是这样，戒波罗蜜多也这样。

又能灭尽忿怒、怨仇，及能善住自他安隐，故名为忍；

这是忍辱波罗蜜多。说，忍辱可以“灭尽忿怒”，就是没有忿怒的烦恼，令心平静。忍辱可以没有“怨仇”，就是没有怨家。你一忿怒，你就制造了一个敌人，你们就相互找麻烦。你要是灭尽自己的“忿怒”，也就灭除了“怨仇”。“及能善住自他安隐”，自己没有忿怒，就自己安隐、自在，没有敌人（敌人是相互的，双方彼此是敌人），就可以使别人安隐、自在。这忍辱其实是说我们在处理问题的时候，要平静地处理，不要在忿怒起来的时候去处理。平心静气地处理问题，犯错误的可能性就小。

又能远离所有懈怠、恶不善法，及能出生无量善法令其增长，故名精进；

这精进波罗蜜多，“能远离所有懈怠”，我们经常是该作的事儿提不起劲儿，不想去作，放逸的事情倒作得不少，懈怠和放逸一般都在一起。你要是有精进，就把懈怠、放逸给对治了。反正就一个空间，精进不去占领，懈怠、放逸就去占领了，我们现在希望精进占领。我们有精进，除了远离懈怠外，还不会作“恶不善法”，“恶”与“不善”，一般来说是一回事儿，但在佛教中其实不善的范围比恶要大，这在因明中有的：不能出现第三种情况，只有善、不善，或者恶、非恶，绝不能有第三条路可走。这“恶不善法”包括已经生起的和没有生起的，没有生起也好，已经生起也罢，都要凭精进对治。“及能出生无量善法”，说，因为精进，消灭了种种的烦恼，没有了烦恼法，就只剩善法了，有善法就有种种功德。“无量善法”就包括已经生起的和即将生起的，或者说是世间善、出世间善。“令其增长”就是已生起的善令增长，未生起的善令生起，未生起的恶不令起，已生起的恶令消灭，这就是四正勤。这就是精进。

又能消除所有散动，及能引得内心安住，故名静虑；

静虑波罗蜜多，“能消除所有散动”，就是说能对治内心的散乱，“及能引得内心安住”，内心的散乱被对治了，心慢慢就静下来了，因为静而生起轻安，渐渐禅定就生起来了。

又能除遣一切见趣、诸邪恶慧，及能真实品别知法，故名为慧。

这是般若波罗蜜多，般若波罗蜜多是最重要的，别的波罗蜜多其实都是般若波罗蜜多的基础。有了般若波罗蜜多，就可以“除遣一切见趣、诸邪恶慧”，“见趣”，就是各式各样的邪知邪见，象身见、边见、见取见、戒取见、邪见等都是。为什么叫“见趣”呢？这个“趣”，就是六道轮回，因为你有身见、边见等，所以你就在六道里轮回，故名“见趣”。“见”还有执著的意思，他认为自己的所见是最正确、最殊胜的，这叫“见”。“诸邪恶慧”就是种种邪恶的智慧。“慧”是观察决断，可是他观察的是什么？是怎样利用高科技犯罪，这些就是邪恶慧。“及能真实品别知法”，咱们给理解成“真实知法”、“真实品别知法”。“真实知法”是指能能见到诸法实相，这是根本智。“真实品别知法”则是后得智。“品别”就是各类，“品”就是类，各类皆不相同叫“别”，你通达一切法的差别相，这是凭后得智的。你成就了根本智、后得智，就不会犯错误，就是达到了圣人的境界，得大安乐、大解脱，所以叫做慧。

云何应知修习如是波罗蜜多？

波罗蜜多该怎样修呢？我们也得知道。

应知此修略有五种：

六波罗蜜多有五种修法。

一、现起加行修，

就是你主动去修六波罗蜜多，并拿出了实际行动。比如我行布施，就得具备施者、受者、所施之物或法，表现出来了布施。比如我行般若波罗蜜多，那就是要闻思修，在佛法的经律论上闻思修，我主动地闻思修。所谓“现起加行”，“现起”就是表现出来。对于禅波罗蜜多、精进波罗蜜多、忍波罗蜜多、戒波罗蜜多、施波罗蜜多都是这样，自己主动地做这件事。

二、胜解修，

就是学习经律论，对于六波罗蜜多有深刻的信解，进而引起强烈的意愿，愿意修六波罗蜜多。这个胜解修，重要的是修了就得到欢喜，愿意修。要是你修了，但觉得不情愿，那不是胜解修。象现在小师父们上殿，上也上了，但上得很难受，觉得是在受罪。

三、作意修，

就是四十一页最后边儿的爱重作意、随喜作意、欣乐作意。刚才的胜解修也就是四十一页这儿的“由于圣教得胜解”。

四、方便善巧修，

要想“方便善巧”得凭无分别智，由无分别智来修六波罗蜜多，也就是离相修六波罗蜜多。没有无分别智方便善巧，我们就有执著相，说，这是我在修布施、我在修持戒等，有这样的分别，就自己给自己设障碍。

五、成所作事修

这是成佛以后是行六波罗蜜多。

此中四修如前已说。

六波罗蜜多总共有五种修，其中的前四修前边儿都说过。就是四十一页，从倒数第四行到倒数第一行。

成所作事修者，谓诸如来任运佛事无有休息，于其圆满波罗蜜多，复更修习六到彼岸。

第五种“成所作事修”前边儿没有说，这里就多说几句。说这个“成所作事修”是“诸如来”――十方诸佛，“任运佛事”，“任运”就是不刻意，他在修六波罗蜜多的时候不是刻意地去作的，是自然去作的，没有分别心地去作，“佛事”这里就是指六波罗蜜多，因为是说诸佛作六波罗蜜多，所以叫“佛事”，或者说是这样作，可以令众生成佛，所以叫“佛事”。“无有休息”，说，佛在作六波罗蜜多的时候，一直不停地作，我们是不行的，因为我们会累、会疲劳，得了禅定的人就不同了，成佛自然更圆满了，他休息、不休息是一样的。“于其圆满波罗蜜多，复更修习六到彼岸”，诸佛修六波罗蜜多已经圆满了，但是因为哀愍众生，所以还是再修习六波罗蜜多，他这样作其实是在给众生作榜样，说，“我已经成佛了还在修，你们没有成佛的人有什么理由不精进呢？”

又作意修者，谓修六种意乐所摄爱重、随喜、欣乐作意：

这是着意把五种修中的作意修多解释一下。前边儿说过，作意修就是爱重作意、随喜作意、欣乐作意，这儿又说有六种意乐来摄这三种作意。也就是说，“爱重、随喜、欣乐”三种作意属于六种意乐。“爱重作意”里边有这六种意乐，“随喜作意”里有这六种意乐，“欣乐作意”里也有这六种意乐。

一、广大意乐，二、长时意乐，三、欢喜意乐，四、荷恩意乐，五、大志意乐，六、纯善意乐。

六种意乐是什么？就是广大意乐、长时意乐、欢喜意乐、荷恩意乐、大志意乐、纯善意乐。下边儿解释。

若诸菩萨，乃至若干无数大劫现证无上正等菩提，经尔所时，一一剎那，假使顿舍一切身命，以殑伽河沙等世界盛满七宝奉施如来，乃至安坐妙菩提座，如是菩萨布施意乐犹无厌足；

先说“广大意乐”，用布施波罗蜜多为例来说。先看“爱重作意”的“广大意乐”。说，要是菩萨发了无上菩提心，以无上菩提心为基础修学六波罗蜜多，一直修学了“若干无数大劫”，这时间就很长很长，修了这么久方才“现证无上正等菩提”，就是说，修到这么久才证得道果。在一般的说法中，是三大阿僧祗劫，从初发心到登地得一劫，到登八地又一劫，到成佛又一劫。“经尔所时”，就是经过了“若干无数大劫”，“一一剎那，假使顿舍一切身命”，就是说，在这无数大劫里，菩萨每一刹那都可以顿舍一切身命去利益众生。这里的“身命”就是身家性命，表示最看重的东西，意思就是说连最看重的东西都能为了利益众生而舍弃。舍弃身家性命是内施。

“以殑伽河沙等世界盛满七宝奉施如来”，“殑伽河沙”就是恒河沙，表示数量很多。说，菩萨用这么多的世界里的七宝来供奉如来，这里的“如来”指三世一切诸佛，包括已成的佛、未成的佛，也就是说，布施给需要者。“乃至安坐妙菩提座”，“安坐妙菩提座”就是指最后得无上菩提的金刚道，《八识规矩颂》中说，“金刚道后异熟空”，就是说，到了金刚道，你刹那就可以成佛了。“如是菩萨布施意乐犹无厌足”，说，菩萨这么长时间布施这么多财、法，内布施、外布施都作，他这么作了，可是，他的内心仍然没有满足，没有厌足。这就是布施爱重的“广大意乐”。

经尔所时，一一剎那，假使三千大千世界满中炽火，于四威仪常乏一切资生众具，戒，忍，精进，静虑，般若心恒现行，乃至安坐妙菩提座，如是菩萨所有戒，忍，精进，静虑，般若意乐犹无厌足；是名菩萨广大意乐。

布施爱重的广大意乐这样，其他五度呢？也是这样。“经尔所时”，这还是接着上边儿说的，经过“若干无数大劫”，“一一剎那，假使三千大千世界满中炽火”，在若干无数大劫之中，每一刹那，各处都是炽烈的猛火，菩萨在这么痛苦的环境之中，“于四威仪常乏一切资生众具”，“四威仪”就是行住坐卧。就是说，菩萨在这个令人痛苦的环境中修行，很难很难，想度众生，也很难很难。想行、行不了，就是想走走不了，想住没地儿住，想坐坐不了，想卧也没门，很难很难。“戒，忍，精进，静虑，般若心恒现行”，菩萨不怕困难，照样修行持戒、忍辱、精进、静虑、般若六波罗蜜多，修学六波罗蜜多的心还是时常现起。也就是说，在这么苦恼的境界里面照样修学六波罗蜜多。“乃至安坐妙菩提座”，一直到得成道果。“如是菩萨所有戒，忍，精进，静虑，般若意乐犹无厌足”，菩萨一直对于六波罗蜜多心不满足，还要修习，“是名菩萨广大意乐”，这就是广大意乐。

又诸菩萨，即于此中无厌意乐，乃至安坐妙菩提座，常无间息，是名菩萨长时意乐。

这是说“长时意乐”的。说，“又诸菩萨，即于此中”，菩萨修六波罗蜜多，经过“若干无数大劫”，其中每一刹那都修习，没有疲厌，一直到“安坐妙菩提座”，就是一直到证成道果，“常无间息”，这么长的时间里不间断、不休息，这就是修六波罗蜜多的“长时意乐”。

又诸菩萨以其六种波罗蜜多饶益有情，由此所作深生欢喜，蒙益有情所不能及，是名菩萨欢喜意乐。

菩萨修六波罗蜜多来利益一切众生，“由此所作深生欢喜”，这样作他才欢喜，能利益众生他很高兴，“蒙益有情所不能及”，蒙受菩萨利益的众生心里也欢喜、高兴，不过蒙受利益的众生的高兴不及菩萨心里的欢喜，也就是说，施者比受者高兴。印顺法师说，比如妈妈给儿子买了一个玩具，儿子很高兴，妈妈看儿子高兴，自己更高兴。这就是“欢喜意乐”。

又诸菩萨以其六种波罗蜜多饶益有情，见彼于己有大恩德，不见自身于彼有恩，是名菩萨荷恩意乐。

这些菩萨他以六波罗蜜多利益一切有情众生，“见彼于己有大恩德，不见自身于彼有恩”，就是说菩萨只看见众生对他有恩，说，众生成就了他的修行，成就了他的福、智二德，众生是我的福田，他不会觉得是自己对众生有恩。我们救了一个人，会觉得是自己救别人，而菩萨会觉得是别人成就自己的修行，这就是菩萨与我们的不同。“是名菩萨荷恩意乐”，这是荷恩意乐。就是菩萨感激众生。

又诸菩萨即以如是六到彼岸所集善根，深心回施一切有情，令得可爱胜果异熟，是名菩萨大志意乐。

这些菩萨用修行六波罗蜜多所集聚的善根，成就的功德，“深心回施一切有情”，“深心”就是恳切的心、信心，用这样恳切的心来回向一切众生，因为众生对我有恩，所以我要回向一切众生。“令得可爱胜果异熟”，就是说，让众生都得到好的果报，殊胜的果报。这是大志意乐。

又诸菩萨复以如是六到彼岸所集善根，共诸有情回求无上正等菩提，是名菩萨纯善意乐。

第六个是纯善意乐，纯善就是不夹杂污染法。菩萨用修行六波罗蜜多所集聚的善根，所成就的功德，回向一切有情，望一切有情与自己一样成就无上菩提。刚才是大志意乐是回向一切有情，希望他们得好的果报，现在这纯善意乐是说，希望一切有情不求世间果报，也不求二乘涅槃，而是与众生同证菩提，同成佛道。这叫纯善意乐。

如是菩萨修此六种意乐所摄爱重作意。

前面说作意有爱重作意、随喜作意、欣乐作意，三种作意与六种意乐相摄，“如是菩萨修此六种意乐”，刚才介绍的是六种意乐与爱重作意相摄。

又诸菩萨于余菩萨六种意乐修习相应无量善根，深心随喜，如是菩萨修此六种意乐所摄随喜作意。

“又诸菩萨于余菩萨六种意乐修习相应无量善根，深心随喜”，就是说，其他的菩萨修行六波罗蜜多了，这些菩萨他们就深深地随顺欢喜赞叹。我们凡夫会有嫉妒心，会障碍别人修行，这是因为烦恼没断，而菩萨不但不会嫉妒，而且会真诚地发欢喜心。“如是菩萨修此六种意乐所摄随喜作意”，看见别人布施我生欢喜心，这是随喜布施作意，看见别人持戒我生欢喜心，这是随喜持戒作意等等。我以这种心也可以修刚才说的六种意乐，所以，随喜作意也可以与六种意乐相摄。

又诸菩萨深心欣乐一切有情六种意乐所摄六种到彼岸修，亦愿自身与此六种到彼岸修恒不相离，乃至安坐妙菩提座，如是菩萨修此六种意乐所摄欣乐作意。

“又诸菩萨深心欣乐一切有情六种意乐所摄六种到彼岸修”，“欣乐”就是深深的欢乐、深深的作意，特别的欢乐、高兴。说，菩萨不但欢喜自己修六波罗蜜多，而且欢喜别人修六波罗蜜多，看见别人修六波罗蜜多，就特别的欢喜，特别欢喜有情能具足六种意乐修六波罗蜜多。“亦愿自身与此六种到彼岸修恒不相离”，也特别希望自己与这六波罗蜜多永不相离，永远用六种意乐修六波罗蜜多，“乃至安坐妙菩提座”，一直到成就了无上菩提，中间一会儿也不离开六波罗蜜多。这就是说，欣乐作意也可以与六种作意相摄。

若有闻此菩萨六种意乐所摄作意修己，但当能起一念信心，尚当发生无量福聚，诸恶业障亦当消灭，何况菩萨！

“若有闻此菩萨六种意乐所摄作意修已”，假如有一个人听到了这位菩萨用六种意乐修六波罗蜜多，他也生起了一念信心，说我也想这样用六种意乐来修六波罗蜜多，菩萨能作，我也能作，这个人只起了这样一个念头，“尚当发生无量福聚”，就因为这个人起了这样一个念头，就得到了很大的好处，“无量福聚”就是很大发福德、好处，“诸恶业障亦当消灭”，因为这样一个念头，这个人以前所造的很多罪业都消灭了。注意，别时意趣！“何况菩萨”，这个人起这样一个念头，就有这样的好处，何况你真实修行了，那该有多大的功德～～

此诸波罗蜜多差别云何可见？

说，六波罗蜜多是不是有不同呢？

应知一一各有三品。

说，六波罗蜜多是有不同的，每个波罗蜜多都有三种不同。

施三品者，一、法施，二、财施，三、无畏施。

布施有法施、财施、无畏施三种情况。“法施”，就是用清净心给人宣说正法，纠正人们思想上的错误，令他生起正知正见，以解脱生死。注意要以清净心宣说。“财施”，就是布施财物。法施是救人心灵，财施是救人身体上的困苦、生活上的困苦，他要是身心安顿了，就可以学佛了。有财施没法施，这不解决根本问题，但有法施没财施也不行，他连基本的生活保障也解决不了，根本就谈不上学佛。“无畏施”，就是解除众生的恐惧，令他的心灵得到安隐。不让众生有害怕的。

戒三品者，一、律仪戒，二、摄善法戒，三、饶益有情戒。

戒也有三种。就是摄律仪戒、摄善法戒、饶益有情戒。“摄律仪戒”的“律仪”，就是没有过失的意思。我们的身、语所表现出来的都不要有过失。远离一切过失，就是“律仪戒”，就是诸恶莫作。再看“摄善法戒”，“摄”就是积聚，积聚善法。其实摄律仪戒就是止恶，而摄善法戒就是行善、就是众善奉行。“饶益有情戒”，就是要作利益众生的事儿。我有一个讲演――《三戒印》就是这个。摄律仪戒、摄善法戒、饶益有情戒其实就是止恶、行善、利他，只要符合这个的，都是戒。

忍三品者，一、耐怨害忍，二、安受苦忍，三、谛察法忍。

忍也有三种。“耐怨害忍”，是指有众生伤害你、误会你，你要忍耐。菩萨度众生，众生不理解，有时候是会中伤你的，这要忍耐。“安受苦忍”，菩萨毕竟不是圆满的佛，你一直作利益众生的事儿，作久了你会感到疲劳，感到辛苦，这个时候你要忍耐。“谛察法忍”，这个谛察法忍是耐怨害忍、安受苦忍的基础，要是没有谛察法忍，则根本就不会有前两种忍。为什么能有耐怨害忍、安受苦忍？就因为“谛察法”的关系。“谛察法忍”就是认真地观察诸法实相，安住于第一义谛上。当有人中伤你的时候，你谛察诸法实相，一切皆空，你感到疲惫的时候，你观察诸法实相，这样就是谛察法忍。

精进三品者，一、被甲精进，二、加行精进，三、无怯弱，无退转，无喜足精进。

“被（pi）甲精进”的“甲”就是盔甲。这是一个比喻，比喻你要是发了菩提心，就象战士披了盔甲，就可以防护自己不受伤害。现在我要度化众生，不怕艰难地修行，这是“被甲精进”。第二是“加行精进”，刚才的被甲精进是发心修行，现在的加行精进则是开始真的干了。“加”就是一次次累加，就是努力不断的意思，不懈怠地修六波罗蜜多。第三是“无怯弱，无退转，无喜足精进”，“无怯弱”是说在修六波罗蜜多度化众生的时候，自己有问题了，比如说有病痛了，这时候“无怯弱”，就是心里不退怯，想，我一定要做成这件事。“无退转”不是自己有问题了，而是外边儿的障碍很大，众生伤害你，这是候你“无退转”，有强大的意愿继续修行六波罗蜜多。“无喜足”是说，你不得少为足，不会因为稍微有点儿成就就满足了，说，我是要得成佛道才行，现在还不能休息，没成佛我绝对不停下来。成佛了自然就停不下来了。

静虑三品者，一、安住静虑，二、引发静虑，三、成所作事静虑。

“安住静虑”是指修定成功了，身心都得到轻安。修得四禅八定。得到禅定就可以称为“上人”了。“引发静虑”是指得安住静虑后，继续努力，就可以引发一些不可思议的功德、情况，比如神通之类的。“成所作事静虑”，你有禅定，又有神通等，继续努力修行，广度众生、去作利益众生的事，这就简单多了。这叫“成所作事静虑”。安住静虑、引发静虑是行者自己成就的功德，成所作事静虑是利益众生的功德。

慧三品者，一、无分别加行慧，二、无分别慧，三、无分别后得慧。

“无分别加行慧”的这个“加行慧”，就是前面说的四寻伺、四如实智的智慧。为了成就无生法忍、成就圣道，加紧用功、努力修行，所以叫“加行慧”。这时发现名、义、自性、差别都不可得，这样思惟、观察，就照见五蕴皆空了。“无分别加行慧”是说，因为未成就无分别智，所以要努力用功修行，为了得到无分别智而加行，所以叫“无分别加行慧”。或者这么说：菩萨在修行的时候，观察名、义、自性、差别皆不可得，观一切法唯识无义，没有义的分别，终于得证了无分别智，所以叫“无分别加行慧”。从事实上来说，菩萨此时内心里还是有观察思惟的，还是有分别的，但他这样用功修行能得到无分别智，是为了得到无分别智，所以叫“无分别加行慧”。第二是“无分别慧”，就是因为“无分别加行慧”，修四行伺、四如实智，经暖、顶、忍、世第一，再向前一步刹那见道了，见道的当下根本智现前，这就是“无分别慧”。第三是“无分别后得慧”，第二的无分别慧是在登欢喜地时开始有，一直到得证佛果才能圆满。这“无分别后得慧”是成就“无分别慧”的时候立马就成了的。得了根本智立马就得后得智，有后得智就有后得慧。凭“后得慧”可以为一切众生宣说正法，所以说后得慧是有分别的，我们之所以说“无分别后得慧”，是因为它是由根本无分别智所成就的，它没有执著、是大解脱境界，所以说它是“无分别后得慧”。这无分别后得慧也是从见道以后就有，到得证佛果时才能圆满。

如是相摄云何可见？

在佛教中，说了很多善法，现在这六波罗蜜多与善法是什么样的关系呢？怎么相摄呢？怎么个摄属法呢？我们又怎么知道它摄属了呢？

由此能摄一切善法，是其相故，是随顺故，是等流故。

这六波罗蜜多能够摄属一切善法。我们怎么知道它摄属一切善法呢？有三个原因：“是其相故”，世亲释213页中说，“是其相故者，是般若相”，就是说，一切善法都是般若的相，“相就是表现出来的样子”，一切善法都是般若表现出来的样子。这样呢，般若波罗蜜多就把前五度给包括到里边儿了。刚才的一问是说六波罗蜜多与善法怎么相摄？世亲说般若把所有的善法都摄了，连同前五度也相摄了。在无性释464页中说，“是其相故者，是摄体相，谓此施等与彼施等更互相摄。”就是说，善法中的布施与六波罗蜜多中的布施互摄，善法中的持戒与六波罗蜜多中的持戒互摄。再看“是随顺故”，就是说，一切善法都随顺般若，随顺无上菩提，就是说，般若是领导，其他的都跟从般若。其他的善法就是《百法明门论》中的信、精进等等。随顺就是作增上缘。第三是“是等流故”，说一切善法最后都是得证菩提，菩提是一切善法的果，等流果。一切善法圆满了就是菩提果。

如是所治摄诸杂染，云何可见？是此相故，是此因故，是此果故。

六波罗蜜多等可以对治杂染法，布施波罗蜜多对治悭吝，持戒波罗蜜多对治破戒，忍辱波罗蜜多对治忿怒、忿恨，精进波罗蜜多对治懈怠，禅定波罗蜜多对治散动，般若波罗蜜多对治恶慧。六波罗蜜多对治六种障碍。这“云何可见”呢？也是三个理由：“是此相故”，“此相”就是表现出这样的相貌。你问：我怎么知道所对治的杂染法呢？回答说，表现出了悭吝、破戒、忿恨、懈怠、散动、恶慧这样的相貌，看见这相貌当然就知道有它要被对治。“是此因故”，第一个原因“是此相故”是说，布施对治悭吝，现在这个“是此因故”是说，布施还对治悭吝的因（即引起悭吝者），持戒、忍辱、精进、禅定、般若都是这样的。第三是“是此果故”，这是说布施可以对治悭吝的果（如贫穷下贱、堕三恶道等），这些恶果都没有了。持戒、忍辱、精进、禅定、般若也都是这样的。

如是六种波罗蜜多所得胜利，云何可见？

六波罗蜜多所得的利益，“胜利”就是殊胜的利益。这是问，修六波罗蜜多得到的胜利“云何可见”呢？

谓诸菩萨流转生死富贵摄故，大生摄故，大朋大属之所摄故，广大事业加行成就之所摄故，无诸恼害性薄尘垢之所摄故，善知一切工论明处之所摄故。

说，修六波罗蜜多的好处多了去了，有世间利益，有出世利益。“谓诸菩萨流转生死富贵摄故”，这是指发心菩萨，但还是凡夫位。因为发菩提心修六波罗，虽然还没有成佛，还在生死里流转，但因为修六波罗蜜多，所以他在生死里流转的时候，他老得大富大贵的果报。一般来说，这是修布施所得。“大生摄故”，“大生”就是广大的生命体，广大是指殊胜，不是指个子大小。你生到人道，是人中的人样子，你就是生到畜生道也是最漂亮的畜生。当然一般是说生到天上，没有说生到三恶道的。

“大朋大属之所摄故”，“大朋”是高明的朋友、高尚的朋友，就是说，你结交的都是高明的、高尚的朋友，咱们知道一句话，人以类聚、物以群分，你的朋友都是高尚的，你当然也是高尚的、高明的，不然你给人家站不到一起。“大属”的“属”是眷属，说你的眷属都是高尚的，比如你是孔子的第多少代孙，你要是没有修行，你想当孔子的子孙还当不了呢～“大朋”是指你的朋友是了不起的人，“大属”是说你的眷属是了不起的人。关于“大属”，咱们都知道，在《菩提道次第广论》中把种族圆满也当成一个殊胜。既然是大朋大属，当然你自己也是了不起的人。我们看你交的朋友就知道你的大致品位了。这一个一般说是修忍辱波罗蜜多而得来的。

“广大事业加行成就之所摄故”，这是修精进波罗蜜多而得来的。“广大事业加行成就”，看，可不是小事儿上成就，要成就就成就大事业。想成就大事业你不精进怎么可以？“加行”，努力去干。“无诸恼害性薄尘垢之所摄故”，这是修禅定波罗蜜多而得的。你静坐、你禅定，你就可以把烦恼给降伏掉。这就“无诸恼害性簿尘垢”，“无诸恼害”就是没有那些乱七八糟的烦恼，只有烦恼能够恼害你。“性簿尘垢”的“性”，就是心；“簿”就是少。就是说因为修禅定，所以他的心里的尘垢很少很少。这都是禅定的功德。我们现在的烦恼是很多的。“善知一切工论明处之所摄故”，这是修般若波罗蜜多所得的。“工论明处”的“明”是明了、知道了，有这样的知识。“善知一切工论明处”，一般是指五明，说知道了五明――内明、医方明、因明、声明、工巧明。内明实在来说各派都有各派的内明，佛教以三藏教典所诠为内明，婆罗门教以四吠陀所诠为内明等等不一而足。医方明包括医药学（医与药）。因明去年专门讲过了。声明是音韵学、文学等，就是音乐、写文章之类都包括。工巧明包括象建筑、雕塑等所有与技术有关的都是。这些你都知道，才叫“善知一切工论明处”，这是修般若而得来的。

胜生，无罪，乃至安坐妙菩提座，常能现作一切有情一切义利，是名胜利。

修六波罗蜜多不但有世间利益，还有出世利益。“胜生，无罪”，刚才说菩萨得到的世间利益有大富贵、大生、大朋大属之类的，当有了富贵、大生、大朋大属的胜利之后，他就不会再放逸地去做种种的罪业，凡夫得到这些的时候会放逸，而菩萨不会，菩萨只会更加胜生（好上加好）、无罪（不造罪）。“乃至安坐妙菩提座”，就是说，菩萨会更加努力，不会就呆在那儿享受，因为菩萨更加努力，所以不断地上进，一直到成就菩提妙果。“常能现作一切有情一切义利”，凡夫得到六种胜利时候是自己享受，最多分给亲人一些，但菩萨是普利一切众生，让所有一切众生离苦得乐。也就是度众生。所以出世利益有：无罪（不造恶业）、安坐妙菩提座（成佛）、现作一切有情一切义利（度众生）。“是名胜利”，这就是菩萨修六波罗蜜多所得到的胜利、功德。

如是六种波罗蜜多互相抉择，云何可见？

“抉择”就是拣择、观察，观察六波罗蜜多的深隐义。“互相抉择”是指六波罗蜜多互融互摄，只要有一个，则其他五个就有。现在就把这意思给说出来，这就是“抉择”。

世尊于此一切六种波罗蜜多，或有处所以施声说，或有处所以戒声说，或有处所以忍声说，或有处所以勤声说，或有处所以定声说，或有处所以慧声说。如是所说有何意趣？

说，佛对于六波罗蜜多的解释，在经典中都不一样，“或有处所以施声说”，有时候说布施，其实佛说的是六波罗蜜多，但用布施波罗蜜多作代表就完了。“或有处所以戒声说”，有时候佛只说持戒波罗蜜多，其实是说的六波罗蜜多，只不过是用持戒波罗蜜多作代表。“或有处所以忍声说”，有时候是用忍辱波罗蜜多作代表。“或有处所以勤声说”，有时候用精进波罗蜜多作代表。“或有处所以定声说”有时候用禅定波罗蜜多作代表。“或有处所以慧声说”，有时候以般若波罗蜜多为代表。“声”就是说，用布施来说，用持戒来说，用忍辱来说，用精进来说，用禅定来说，用般若来说。“如是所说有何意趣？”佛陀这么说的深义在哪儿呢？

谓于一切波罗蜜多修加行中，皆有一切波罗蜜多互相助成，如是意趣。

说，其实佛是说，你修六波罗蜜多，六波罗蜜多都得修，但是当你在修一波罗蜜多的时候，其它五波罗蜜多都来辅助，你修布施波罗蜜多，其它五波罗蜜多辅助，你修持戒波罗蜜多，其他五波罗蜜多辅助，你修般若波罗蜜多，其它五波罗蜜多照样辅助。所以说，不管你修哪一波罗蜜多，你六波罗蜜多其实都修到了，六波罗蜜多相互和合才能圆满。所以有时候佛说布施，有时候说持戒等等，其实就是说的六波罗蜜多。

此中有一嗢陀楠颂：

这儿有一个颂子。这个“嗢陀楠”，就是集施，就是说，把前边儿说的集起来施给大家，这样大家好记。

数，相及次第 训词，修，差别

摄，所治，功德 互抉择应知

“数”是讲为什么是六波罗蜜多而不是其他的数目。“相”就是说六波罗蜜多的体相，“次第”是说为什么六波罗蜜多一定是布施第一、持戒第二、忍辱第三……般若第六，能不能把这个次序打乱呢？“训词”就是对六波罗蜜多进行解释。“修”是说六波罗蜜多该怎样修。“差别”是说每一波罗蜜多都有三品的不同。“摄”是说六波罗蜜多与一切善法的摄属。“所治”，讲六波罗蜜多对治的弊端是什么。“功德”是说修六波罗蜜多能得到什么利益。“互抉择”，是说六波罗蜜多相互融摄、相辅相成。“应知”，第五品就讲了这么点儿东西，我们应该知道。

第五品到这儿就结束了，论文是结束了。不过论文比较拗口，我再用通俗的话把六波罗蜜多简单说说。

第一是布施波罗蜜多。布施波罗蜜多应该是把自己的奉献给需要者，只要对方需要，就给他。布施波罗蜜多其实最重要的是给对方时的心态。我把东西布施给庙里，到了晚上，庙里的功德箱被小偷偷了，我就觉得我的功德白作了。这就不是布施，因为在你的内心里那东西还是你的。你布施了，你就要彻底的放弃，你要说，那是佛的东西了，不是我的了，佛连我们布施给他的东西他自己也看不住，我们还能有什么办法？我们还有一个不好的习惯，我们布施给庙里些钱，还要要求庙里说，我这是盖观音殿的，你不能去印经书！说这叫专款专用。这是不对的，你布施给庙里了，已经不属于你的了，庙里怎么需要就怎么用，这才对。

当然，你可以在佛教书上找到许多因为不专款专用而受报的故事，比如有一个方丈，把信众布施让盖庙的钱在灾年拿来买了米，这方丈就受到堕地狱之报。这根本是无稽之谈，是不懂佛教的人的瞎编。我们要对这些伪佛法进行毫不留情的怦击。我们布施，就要把它彻底放掉，就象吐口水一样不在乎了。可我们在布施供养时，不是这样，你在佛前供养一支蜡烛，你一定要看着把这支蜡烛燃完，若香灯师把你的这支蜡烛收起来了，你就很不高兴。有人送我一些东西，他会说：“我这是送给你的，你不要送给别人。”你送给我了，已经是我所有的了，我应该有权支配才行呀～～你送我一件衣服，我穿了你才会高兴，这就是因为你对送给我的东西还有执著，这东西还是你的而不是我的。当然，我们布施也不是象扔废东西一样随便丢掉，我们可以选择给谁，可以选择什么时候给，但若你已经给了，就不要再执著了。在南方还有这样一种情况，就是我拿东西到庙里来供养，在佛前放一会儿，走的时候我自己还拿走。这是不对的，在《阿弥陀经》上就有这样的话，“其土众生，常以清旦，各以衣械盛众妙华，供养他方十万亿佛，即以食时，还到本国，饭食经行”。看，是“还到本国，饭食经行”。

第二是持戒波罗蜜多。实际上持戒波罗蜜多是指完全的投入、全身心地投入你的事业。当你说话时完全投入你所讲的话，做事时完全投入你所做的事……不不要老在想你这样作是不是犯戒了，你这样想的时候，你肯定犯戒。在佛教历史上，对戒律持悲观态度的恰恰是律宗的律师，弘一法师说自己五戒也没持好（记得不确），藕益法师说中国几百年没有一个够格的比丘。而玄奘法师则说，我绝对是一个菩萨。为什么呢？玄奘法师一生就作了两件事儿，前半生取经，后半生译经，有犯戒的机会吗？全身心地投入自己所作的事业，连犯戒的机会都没有。

第三是忍辱波罗蜜多。当我们真正修行的时候，会有许多的障碍，这是时候怎么办？我们要学着欣赏障碍，要感谢一切障碍。为什么要感谢障碍？我们得知道障碍为什么会来，因为在“我”的里边有好东西，所以障碍要来。若你从来没有障碍这就说明你根本没有修行，根本不需要障碍来打扰你，所以，障碍来了我们应该高兴。我们的修行越好，障碍会越大。如果说我们没有任何的困难，表示你的修行太差，不但佛菩萨没有理你，连障碍也没有理你。现在人没什么忍耐心，连成佛也想速成，净土宗就有点儿象快餐麦当劳。

第四是精进波罗蜜多。一般说精进就是努力念经、参禅等等，但实际上精进波罗蜜多是指精神愉悦。我们在念经的时候，是不是保持了愉快的心境呢？没有，拿起经本就想着快点儿念完，然后好去作别的。我们的生活因为学佛而复杂，家里有佛堂，你每天总上三支香，可这一天你只上了二支香，你就觉得这样不太好，可是，实际上认为“三”比较好，这本来就是捏造，编出许多“三”之所以好的理由。也就是说，我们的心非常复杂，人为的复杂起来。所以，我们的修行并没有产生快乐，修行对我们来说成了一种心灵的折磨。当你掀开第一页经时，你就希望这经快点儿念完。我们的念经，其实只是为了顾全我们的面子，因为我们说了我每天念一卷法华经，这念经并不是真的作得快乐，若真的快乐的话，作起来就不难，你会为了作它而努力。精进就是创造愉悦。我们要学着创造愉悦。

第五是禅定波罗蜜多。禅定波罗蜜多就是让我们认清烦恼。烦恼是我们修行的敌人。烦恼有各种伪装，它甚至可以表现成虔诚的信心等，烦恼会以我们意想不到的样式出现，禅定就是要你看清烦恼。佛教中有很多教你禅定的方法，最常用的是数息之类。说，首先我们要使心集中，当你试着集中心念时，佛教告诉你把心集中在呼吸上别乱跑。这个其实是一个诡计，佛教这么教你，说你别让心乱跑，其实是要让你知道你的心在东跑西跑。实际上平时我们的心就在乱跑，但我们在潜意识中不承认，别看你口头上承认，你的潜意识中并没有承认，因为你骄傲、你自认为了不起，你认为你能管住你自己。现在佛教当你心念集中，为什么这样呢？就是佛教抓住了人的心理：不让你去某个地方，你恰恰要去某个地方。这就是人的叛逆心理。我不让你去那个地方，你会想，那个地方到底有什么呢？为什么老师不让我去？老师的“不让你去”恰恰勾起了你想去的念头。现在佛教不让你的心东跑西跑，恰恰成就了你的心东跑西跑。现在佛教就是要让你知道你的心在东跑西跑，当你试着把心集中在呼吸上时，你发现根本无法集中。这样，你就很直观地知道了你的心其实很乱。当然，这个目标不一定非得是呼吸，一部经、一个咒语等都是可以的。实际上有很多人并不知道观呼吸的真实用意是什么，他并不知道观呼吸这个法子实际上是让你知道你的心有多乱，他认为这是《安般守意经》上说的法子，认为这就可以使你成就圣果，实际上这根本不是让你成就圣果的。有的人不知道，有的人是知道了也不会给你说的。还有人观佛像，老师让你观某一张观音像，这实际上就是制造出了一些问题。即使你观清楚了这张观音像也不能使你成佛的，何况大多数人根本就观不清楚。观想只是让你认清烦恼的一个法子而已。

第六是般若波罗蜜多。般若一般叫大智慧，没有染污就是般若。般若包括很多，没有什么东西般若不能包括。般若其实是心理的一种状态，无我、无二的状态。一般来说，佛教徒都以为自己很了解轮回这儿的情况，只不过是涅槃那儿的情况我们不了解而已，其实这是不对的。其实我们根本不知道轮回的情况，当然，我们看了几本书，知道轮回就是业力循环，就是六道，就是生、老、病、死等，实际上这只是书上的轮回。涅槃其实就是轮回的终止，当我们充分地了解了轮回之后，我们才有可能知道涅槃，否则，涅槃只是我们心中的一个传奇。

佛成道后初转法轮说的就是苦，可我们并不真的知道苦，比如生苦，我们根本就不知道。我们已经习惯了轮回，但我们并不真的了解轮回，所以，我们在理论上了解的解脱，只不过变成了我们轮回的另外一个部分而已。我们现在生活在二的世界，而佛法是不二法门，金刚经上说是一合相，我们认为，既然是“一合相”，必须有二个东西才能合起来，要是只一个东西则没法合。常用一个认绳为蛇的例子，我们看见一条蛇，但它实际上是一段绳子而已，这就有了一个境界，“蛇”，我们又造出来了一个境界，“没有蛇”，“蛇”这个境界是一个错误，“没有蛇”这个境界当然也是一个错误，两个境界都是错误的，怎么合？这就是我们犯的错误，先造出两个境界，然后让它们合起来。这根本就是不可能的。也就是说，轮回是一个错误，涅槃也是一个错误，两个错误是根本无法合起来的，合二为一是不可能的。当你知道了“根本就没有两个”的时候，这就是达到了最终的合一、最究竟的合一。当你认识到根本没有什么东西要合一，没有轮回、涅槃要合一；没有究竟、方便要合一，这就是最终的合一，这种合一是哪里都有，若你让每件事保持它自然的样子，则每件事情都是合一的。

但是，我们都不会让事情保持原来的样子，我们要无事生非，造出许多的麻烦，就象咱们说的，我们并不是让绳子保持绳子的样子，而是非要说它是一条蛇，我们的惧怕使绳子不保持绳子的样子而呈现出蛇的样子。一看清楚，我们马上又犯了一个错误，“没有蛇。”我们的心把这件简单的事情弄得这么复杂：说有一个境界叫“蛇”，另一个境界叫“没有蛇”，因为这样，所以没法合一。因为我们捏造了很多东西，所以合不起来了。我们现在就是看到绳子不要把绳子捏造成蛇，因为绳子放在昏黑处永远不会变成一条蛇，绳子放在明亮处，永远也变不成“没有蛇”。它就是绳子本身！认清这个，就是般若。


彼修差别分第六

现在开始第三卷，第三卷讲了彼修差别、增上戒学、增上心学、增上慧学、彼果断、彼果智六个问题。彼修差别是第三卷开始，增上戒学从51页开始，增上心学是从52页开始，增上慧学是从55页开始，彼果断从59页开始，彼果智从61页开始。这彼修差别是讲的十地。

如是已说彼入因果，彼修差别云何可见？由菩萨十地。

前面已经说到“彼入因果”，就是说六波罗密。六波罗蜜分两阶级，一个是因中六波罗蜜，一个是果上六波罗蜜。因中修六波罗蜜能悟入唯识性，悟入唯识性、得证无生法忍之后，又有殊胜的六波罗蜜的修行，这就到了十地的修六波罗蜜，但是在“彼入因果”那儿没有一样一样详细说。在这“彼修差别”处一地一地怎样修六波罗蜜多的情况、差别相，一个一个说说。各地的修法都有不同。

何等为十？

菩萨十地都有什么呢？

一、极喜地，二、离垢地，三、发光地，四、焰慧地，五、极难胜地，六、现前地，七、远行地，八、不动地，九、善慧地，十、法云地。

这是十地的名字。“地”就是法无我的分位，也就是法无我的圆满程度，根据其圆满程度给分成了十个阶段。刚开始有是极喜地，稍微多一点儿，就是离垢地……最后是法云地。由浅而深按次第分出十种不同。当然，法无我智所通达的真如、法界，本身是没有分位的，不能说有深浅的不同，只能说是通达真如之智有深浅。“地”有“能生”的意思，指能生功德。这一句话是先把名字给列出来。

如是诸地安立为十，云何可见？

为什么要分成十个层次？十一种行不行？五种行不行？既然是安立，你多安立点儿少安立点儿难道不可以？当然可以，但是佛是安立了十个层次，佛给安立十个层次的理由如下：

为欲对治十种无明所为障故。所以者何？以于十相所知法界，有十无明所治障住。

这就是安立十个层次、十地的理由。“为欲对治十种无明所治障故”，说是因为菩萨修行要消灭十种无明障碍，所以建立十地。十种无明就是所对治的障碍。“所以者何”？又是一问，为什么是十种无明呢？“以于十相所知法界，有十无明所治障住”，因为无分别智所证的法界有十种相貌，就是说，所知法界有十种相貌，在十种相貌这儿自然得有十种无明对应，所以一步步推，就得十地。

云何十相所知法界？

这问题是一个一个套着的，你既然说无分别智所证悟的法界有十种相，是哪十种相呢？

谓初地中由遍行义；

说，初地中无分别智证悟的是遍行法界，或者说是遍行真如。要证得遍行法界，就得断除异生性的无明障碍，也就是远离异生性的无明。“异生”就是凡夫的我相，就是我相、人相、众生相、寿者相的我相。异生性的无明就是我们执著有我、执著有法。在《百法明门论》中就有一个“异生性”，异生就是凡夫，异生性就是说凡夫各人都有各人的思维，这都是因为我执的缘故。众生的我执有俱生我执、分别我执，俱生我执就是与生俱来的我执，就是本能。而分别我执则是后天学习而来的。现在说的“异生性无明”是指这个分别我执的无明，不是俱生我执的无明。菩萨修四寻伺观、四如实智，观察名、义、自性、差别一切法唯识无义，这样的修可以把异生性障灭掉了，灭掉异生性的无明障碍，就显示出遍行法界。遍行法界的“遍”，是普遍的意思，“行”是一切有为法。说，离一切相的不生不灭的法界是普遍于一切有为法的，这是在初地的时候就证悟到了的。这一个得知道一下，在初地是远离异生性无明而显遍行法界。

第二地中由最胜义；

在二地中是远离一切邪行障、邪行无明而显最胜法界。初地是远离异生性无明，异生性无明是分别我执，而二地是远离邪行无明，邪行无明就是俱生我执、俱生无明了。后边儿所远离的也都是俱生无明。俱生无明是任运而起的，圣人也有这样的无明。邪行障、邪行无明，就是他不自觉地还有身口意犯戒之类的事情。所谓邪行，就是非正行、染污。象犯戒这回事儿，粗重的犯戒，当然初地菩萨是不会的了，但还有微细的犯戒之事情，这就是邪行障。初地菩萨继续努力修行，就可以断除这邪行障，断除了邪行障，就可以成就最胜法界。这最胜法界，是菩萨断除邪行无明而证悟的。

第三地中由胜流义；

在三地中远离迟钝性无明，而证悟胜流法界。所谓“迟钝”，是说菩萨闻思修的时候，有时候他还会忘记。在凡夫中有这样的情况，本来一个事情是很熟的，可是到用的时候忽然间怎么也想不起来。初地菩萨、二地菩萨也有类似于这样的事情，他正在闻思修，可忽然间也有一下想不起来的情况，这就是迟钝无明的缘故。到三地菩萨的时候，可以把这个迟钝无明给断除掉。把这个迟钝无明给断除了，就证悟胜流法界。

第四地中由无摄受义；

在四地中，是远离微细烦恼现行俱生身见无明，而证悟无摄受法界。所谓“微细烦恼现行俱生身见”，咱们知道身见就是我见，我们要是有我的话，自然还有我所，这是一种执著。现在说的是微细的烦恼现行。初地菩萨、二地菩萨、三地菩萨这些圣人，他们在没入定的时候，第六意识的活动中还有微细的我、我所这样的执著，到四地菩萨才能断除这个我、我所的微细烦恼，断除了这个烦恼，就证悟无摄受法界。“无摄受法界”的“摄受”，就是执著。你通达了一切法性是“无摄受”的，也就是断除去了微细烦恼现行的俱生身见。

第五地中由相续无差别义；

五地是远离下乘般涅槃无明，证悟相续无差别法界。下乘般涅槃就是二乘，声闻乘、缘觉乘。说二乘圣者，他们厌离生死、急求涅槃。他们观察这个色受想行识的五蕴身体犹如毒器，他们急着要入于不生不灭的涅槃境界而得自在安隐。这个“下乘般涅槃无明”是说，声闻、缘觉他们急求涅槃，他们不知道生死即是涅槃，所以他们厌恶生死，他们认为在生死之外有个涅槃。

初地、二地、三地的菩萨还有类似于这样的认识，他们倾向入于无为的境界是快乐的，对有为有厌离心，这也算是无明。我们凡夫学习佛法，我们厌离生死、欣乐涅槃，这是发道心，菩萨要是还这样，那就成无明了。这儿就是说，有些事情，在我们是可以作的，但在菩萨就是不可以作的，有些事情在我们是不可以作的，但在菩萨就是可以作的，所以说，重要的是认识自己，当我们认识到自己的境界了，方才真正的知道对还是不对。我们要追求涅槃，菩萨呢，他说生死就是涅槃，生死即涅槃是说，涅槃是存在于生死之中，不是灭了生死才能入涅槃的。这就是打破了二元对立。在金刚经上说一合相，在维摩经上说不二法门，都是要打破二元对立。打破了二元对立，知道了涅槃是存在于生死之中，这就证悟了“相续无差别”法界，“相续无差别法界”的“相续”，就是我们的生命体，我们生了又死，死了再生，就这样相续，这“相续”就指生死。对我们来说，相续是有差别的，这一生与那一生有差别，生死与涅槃也是有差别的，但是，到了五地菩萨就真的体认到了生死与涅槃无差别。

笫六地中由无杂染清净义；

第六地中是远离粗相现行无明而证悟无杂染清净法界。粗相现行无明是指十二因缘的还灭。在我们现在看来，我们在流转生死，是无明缘行、行缘识……最后到老死，这样正转是流转生死，要是倒转的话，该是还灭，现在说倒转也是无明。在六地菩萨看来，流转也好、还灭也罢，这都是粗显的，都是因为你还有执著，所以你要流转、你要还灭，这还是无明。初地、二地、三地、四地、五地，都还有这无明，到六地的时候，把这种无明就断了，断了这种无明，就证悟无杂染清净法界。

第七地中由种种法无差别义；

在七地中是断除细相现行无明而证悟种种法无差别法界。细相现行无明是指佛法，你对大乘佛法的执著。说，佛虽然说了许多法，但这些教法实际上也是名言相，也是毕竟空的，你对这些法要是有爱，它就也成了障碍。在七地之前，这是都还会有，到七地了，才能把圣教障碍给断了，这就证悟种种法无差别法界。

第八地中由不增不减义，相自在依止义，土自在依止义；

八地是远离无相作行无明，才能够证悟这个不增不减法界。在七地的时候，就应该是无相观了，不过它是起心动念在想这个无相到底是什么样子？这就是把无相当成了一个相，这就是有功用行，这就与无明相应了，成了障碍，菩萨到八地时，就远离了这个“无相作行无明”，证得不增不减法界。下边儿说“相自在依止义，土自在依止义”，“相自在”是说菩萨证悟了不增不减法界，他随心所欲地要变现什么相就变现什么相，就是说为了度众生“应以何身得度，即现何身而为说法”。他为度众生而现的相是随心所欲的，该现什么就现什么，想现什么就现什么。这就是相自在。“土自在”的“土”就是佛土，他为了度众生可以随心地变现出佛土来，他可以变现阿弥陀佛的极乐世界，还可以变现弥勒佛的兜率土，他变现出了弥勒菩萨的兜率土，弥勒菩萨不会来打假的，因为他是为了度众生而变现的。弥勒菩萨会很高兴的。这个就叫作土自在。证悟了不增不减法界，不增不减法界就是相自在的依止，是土自在的依止。这是八地菩萨无功用道的情况。

第九地中由智自在依止义；

九地菩萨是远离饶益事不作行无明，证悟“智自在法界”。“饶益事不作行”是说饶益众生的事情不做、不去度化众生。说菩萨修行到八地的时候，耽著于无相寂灭，还不能无功用地利乐有情，这时候佛会来说他，说你当初在发心修行的时候，就是要度众生的，于是八地菩萨就从甚深大定中出来，遍十方界普度众生去。这就是把“饶益事不作行无明”给除掉了、远离了，远离了这个“饶益事不作行无明”就证悟“智自在法界”。“智自在法界”的“智”就是四无碍辩才：法无碍、义无碍、词无碍、智无碍，有了这四无碍辩才，菩萨才能好好地度众生。

第十地中由业自在依止义，陀罗尼门、三摩地门自在依止义。

十地菩萨是远离“诸法中未得自在无明”，而证悟“业自在法界”。“业”就是身、口、意三业，十地菩萨可以在十方界广度众生，三业是自在的。长行中还有“陀罗尼门、三摩地门自在”，“陀罗尼”就是总持。“陀罗尼”有四种：法陀罗尼、义陀罗尼、咒陀罗尼、忍陀罗尼。法总持就是对佛陀的教法明记不忘；义总持是指对诸法的义理不忘失；咒总持是说菩萨依定而说咒，这咒可以除众生的灾患；忍总持是说菩萨持法之实相而不失。“陀罗尼门、三摩地门”的这个“门”，咱们知道，你要想进屋，这个屋必须有门，没门你就进不去，这就表示说，你要想通达陀罗尼、通达三摩地，也得有个门――下手处，或者说成方法，陀罗尼的文字就是陀罗尼的“门”，三摩地的解释文字就是三摩地的“门”――下手处。要是没有文字，道理就说不成。在金刚经中，须菩提问佛一个问题，佛先是默然，默然是最好的回答，但是须菩提不懂，佛就只得用语言文字来说。佛法的道理也是用文字表达出来的，所以说，文字就是一个“门”。“门”就是符号。“三摩地”是定，或者说成等持。陀罗尼门自在、三摩地门自在，就是说，十地菩萨有无量无边的陀罗尼，十地菩萨可以拿任何事物、东西作陀罗尼，还有无量无边的“三摩地门”。十地就说完了，就是说，要对治十种无明、十种障碍，所以说建立十地就可以了。

此中有三颂：

下边儿无著论师说了三个颂子，来把前边儿的内容再说一遍，以便于我们记忆。

遍行，最胜义 及与胜流义

如是无摄义 相续无别义

无杂染净义 种种无别义

不增不减义 四自在依义

先看一下这两个颂子。这两个颂子是把十法界相给说一下。“遍行”是初地遍行法界，“最胜”是二地最胜法界，“及与胜流”是三地胜流法界，“如是无摄义”是四地无摄受法界，“相续无别义”是五地相续无差别法界，“无杂染净义”是六地无杂染清净法界，“种种无别义”是七地种种法无差别法界，“不增不减义”是八地不增不减法界，“四自在依义”是说的九地、十地，九地是智自在法界，十地的业自在法界、陀罗尼门自在法界、三摩地门自在法界。

法界中有十 不染污无明

治此所治障 故安立十地。

这是第三个颂子。说，十相法界之中有十种染污、十种无明、十种障碍，“治此所治障”，十地菩萨要对治这十种障碍，所以要成立十地的不同。

复次，应知如是无明于声闻等非染污，于诸菩萨是染污。

刚才说了，建立十地是为了对治十种无明、十种障碍，但实际上来说，这十种无明在小乘中是不当成无明的，只是在大乘中才说是无明。“于声闻等非染污”就是说，在声闻乘看来，那不是染污。“于诸菩萨是染污”，对菩萨乘来说才是无明，因为菩萨要得证无上菩提，可不是自己入涅槃就够了的。妙老法师说，这十种障碍是只障碍菩提而不障碍涅槃。印顺法师说这十种无明是所知障而不是烦恼障。

复次，何故初地说名极喜？由此最初得能成辨自他义利胜功能故。

下边儿是解释十地的名字的含义的。说为什么初地叫极喜地呢？“由此最初得能成办自他义利胜功能故”，说，这是因为修行人刚刚进入圣道，刚刚能够成办自他的义利――刚刚成就了根本无分别智，断了烦恼，他要继续努力修行，就可以得证无上菩提。同时，他也成就了后得智，能教化众生。因为他有这样殊胜的功德，所以叫做极喜地。咱们用世俗情况来乇（tuo）的话，比如说有一个故事：某官员找裁缝作件衣服，裁缝问，你当官有多久了，然后裁缝给他说了一套道理，刚当官的人一般会趾高气扬的，表露出来春风得意，衣服要前短后长；当官久了的话，知道要巴结上级了，就得前长后短。现在这位行者就是刚入圣位，表露出来了，因为他表露的很清楚，所以叫极喜地。

何故二地说名离垢？由极远离犯戒垢故。

二地为什么叫离垢地？说是因为初地菩萨有时候还犯微细戒，到了二地的时候，才能不犯轻微戒，所以说是“极远离犯戒”――永远不犯戒了，犯戒就是垢染，不犯戒了，就是离垢。这主要是戒清净了。

何故三地说名发光？由无退转等持、等至所依止故，大法光明所依止故。

三地为什么叫发光地？“由无退转等持”，在三地的时候，成就了等持，就不会失掉了。等持是三摩地。还有一个“等至所依止”，“等止”是色界定、无色界定。三地就是“无退转等持、等至所依止”，要是没证到三地，你的定还是会退转的，所以说，三地是无退转等持、等止“所依止”――的靠山。“大法光明所依止故”，“大法”就是殊胜的法、殊胜的教法，“光明”是闻思修的智慧。三地之所以叫发光地，发光的就是“大法光明”，因为有大法光明，所以才有无退转的等持、等至，所以妙老说，“大法光明”是能依止、不退转的等持、等至是所依止。不退转的等持、等至都是定，不过是不同的定，而“大法光明”是慧，依定能够发慧，所以叫“依止”。修行有些情况是很特别的，我们是先有信佛按佛说的一步步修来的，而有的人不是，比如外道，他们可能是先修定的，已经得了四禅之类，到这时候遇到了佛法，才开始发菩提心、开始学佛法，这样的人可以很快得初地、二地……他在初地的时候就有等持、等至了，但我们一般来说，是到三地才能成就等持、等至的。

何故四地说名焰慧？由诸菩提分法焚灭一切障故。

四地为什么叫焰慧地？“焰”就是火，表示光明、智慧。“由诸菩提分法”，“菩提分”是三十七道品中的内容。因为菩萨修行三十七道品了，看，我们把四谛、十二因缘、三十七道品之类说成小乘法，其实是基础，是必须得学的。《地藏十轮经》中说，不习二乘法，何能修大乘？现在就是说，修行三十七道品而得智慧，这智慧就象火焰一样，所以叫“焰”。这个火焰能够“焚灭一切障故”，能烧掉一切的障碍，所以叫焰慧地。圣人也还是有无明的，要凭修行消灭。

何故五地名极难胜？由真谛智与世间智，更互相违，合此难合令相应故。

五地为啥叫极难胜地？“由真谛智与世间智，更互相违，合此难合令相应故”。“真谛智”是无分别的，说五地菩萨用真谛智观察苦集灭道等，得知一切法本空，是离一切名相的、是无分别的。“世间智”是有分别的，五地菩萨要广度众生，因为众生有种种名相、分别，所以菩萨就假借种种的名相、分别来开示众生。所以，“世间智”表现出来的就是有分别、缘名相。这样来看，“真谛智”与“世间智”是“更互相违”的――互相违反、不一致。“合此难合令相应故”，要是我们的话，把两个互相矛盾的事物合在一起是不可能的，水火不容，但五地菩萨能够把这两种互相违反的事物合起来，“令相应”，所以叫极难胜地。

何故六地说名现前？由缘起智为所依止，能令般若波罗蜜多现在前故。

六地为什么叫现前地？“由缘起智为所依止”，这个“缘起智”就是观察十二缘起的智慧。“由缘起智为所依止”就是说，依止于十二缘起的智慧而修行。你来观察无明缘行、行缘识、识缘名色、名色缘六入、六入缘触、触缘受、受缘爱、爱缘取、取缘有、有缘生、生缘老死，然后再拐回来，观察无明灭则行灭、行灭则识灭……一直到生灭则老死灭。经过这样的观察，最后你就“能令般若波罗蜜多现在前故”，就是说能使般若智慧、无分别智现前。无明灭则行灭，行灭则识灭……一直到生灭则老死灭，这是转凡成圣的还灭门，是清净缘起的境界。你要是正着流转的话，就是染污境界。清净出现，染污就没有了，但要是没有染污的话，二元对立的清净就也没有了，这就清净、染污都没有了、都不可得，就成了无分别。无分别智现前，就叫现前地。

何故七地说名远行？至功用行最后边故。

七地为啥叫远行地？长行中说是“至功用行最后边故”，“功用”的“功”就是努力，努力修行，就是勇猛精进。“至功用行最后边故”就是说，从开始修行就要努力精进，就是要刻意地努力，可是到七地的时候，这是到了刻意用功这个情况是最后边儿了，过了这个边以后就不用刻意用功了，成了不刻意用功自然用功，这叫远行地。

何故八地说名不动？由一切相、有功用行不能动故。

八地为什么叫不动地呢？有两个原因：一切相不能动、有功用行不能动。“一切相不能动”的“相”，就是指心里所缘虑的境界，心里有时缘虑世间相、有时缘虑出世间相，既然有相那就有分别。我们在开始修行的时候，我们说心不要为烦恼所动，不要为贪瞋痴所动，这就是清净，但到八地的时候，我们说那实际上还不是清净，要不为“一切相”所动才行，就是说我们也不能为清净法所动。再看“有功用行不能动”，这是指没有了要修行的念头，因为他一直在修行、自然不修行。因为这二个不动，所以叫不动地。

何故九地说名善慧？由得最胜无碍智故。

为什么九地叫善慧地呢、就是因为九地菩萨得了“最胜无碍智”，“最胜”就是最殊胜，“无碍”是无障碍，无障碍主要有法无障碍、义无障碍、词无障碍、智无障碍。法无障碍是指佛法，九地菩萨通达无量无边的佛法，“法”就是能诠显道理的名相。义无障碍是指佛法名相所诠显的道理九地菩萨都通达无碍，法华经他通达，华严经他也通达，大般若经他也通达，阿含经他也通达……所有的修多罗他都通达。词无障碍的“词”，就是语言文字，众生有无量无边，那么众生的语言就有无量无边，人有人言、兽有兽语，人还有各地的方言等等，这些呢，对九地菩萨来说，都不是障碍。智无障碍是智慧广大。

何故十地说名法云？由得总缘一切法智含藏一切陀罗尼门、三摩地门，譬如大云能覆如空广大障故，又于法身能圆满故。

十地为什么叫法云地？三个理由，“由得总缘一切法智含藏一切陀罗尼门，三摩地门”，法云地的“云”，本是一个比喻，云在空中飘，它含藏着水，现在拿云来比喻“总缘一切法智”，就是说十地菩萨的无分别智把一切智（真谛智、世间智，或者说成惑、智二障）都含藏了。还能“含藏一切陀罗尼门、三摩地门”，“陀罗尼”是总持（总是保持、一直保持，即“念”心所――令心明记不忘）十地菩萨的念能总持一切佛法、总持无量无边的修多罗。“三摩地”是禅定。十地菩萨的无分别智含藏有这么多的东西，所以叫法云地。第二个理由是“譬如大云能覆如空广大障故”，这里用了一个虚空的比喻。虚空是非常广大的，云彩是可以普遍于虚空里。“云”刚才说了，是比喻“总缘一切法智”。这个虚空则是比喻“广大障”，障有烦恼障、所知障。现在这一句长行就是说，十地菩萨所成就的一切法智犹如“大云能覆如空广大障”，“覆”就是盖、破坏。也就是说，十地菩萨的智能够破坏广大的、无量无边的烦恼障、所知障，能把这些染污法都完全破坏掉。所以说叫法云地。再看第三个理由。“又于法身能圆满故”，“法身”就是真如。法身圆满自然就是证悟真如。云是比喻无分别法智，无分别法法智能够证悟真如，所以叫法云地。这样就有三个理由：一切法智含藏一切陀罗尼门、三摩地门――这是成就的功德；大云能覆如空广大障故――这是破除一切烦恼；及于法身能圆满故――这是证悟法性之理。

得此诸地云何可见？

我怎么知道证悟了初地、二地，乃至十地？

由四种相：

有四种表现，根据这四种表现就知道了。

一、得胜解，谓得诸地深信解故。

胜解就是深刻的理解、殊胜的见解。你对十地的情况有深刻的见解。“得诸地深信解故”，你说你登初地了，可你对初地没有深刻的见解、殊胜的见解，你说你登五地了，可你对五地还没有殊胜的见解，这可能吗？你对十地没有深深地信解而且通达，你说你登十地了，这是根本不可能的。这是第一个条件。

二、得正行，谓得诸地相应十种正法行故。

这个正行，各地有各地的正行，“诸地相应十种正法行”，一般说正行就比较笼统地说，这儿说是十地各有其相应的正行。印顺法师、妙老都是用辨中边论中的十种正行说的，是书写、供养、施他、听闻、披读、受持、正开演、讽诵、思惟、修习。书写就是抄经；供养是用灯呀、花呀之类的供养，就是说你要把抄写的经恭恭敬敬地供养、尊重；施他是说你要多抄几本经书送给别人；听闻是指听经，要听别人讲经；披读是指要读诵经。受持是要不断地温习，要一次一次地读，不要忘了；正开演是要给别人讲解；讽诵就是要会背，背的时候还要象唱歌一样有韵味儿；思惟就是在闲静时要思惟经的道理，不要想些乱七八糟的东西；修习就是修行了。这十种里，前八种是闻慧，第九种是思惟、就是思慧，第十种是修慧，这都是正行。无性释473页也是这样，“得於教法十种法行：谓於诸地相应教法，书写、供养、转施、听闻、披读、受持、开示、讽诵、思惟、修习。”

三、得通达，谓于初地达法界时，遍能通达一切地故。

什么是得通达？长行中说，你一登初地，就明白了十地法界的情况。我们现在一般有一句话，是常说的，叫“初地不知二地事”，看起来不象，因为论上说的很清楚，“于初地达法界时，遍能通达一切地”，不过这一句可以这么说，通达了初地法界，就知道了十地法界，这是因为法界是无差别的。

四、得成满，谓修诸地到究竟故。

“得成满”是智慧的圆满成就，在第三相“得通达”时是一登初地就知道了二地、三地，乃至于十地法界的情况，现在的得成满是说，你不但知道了，而且亲自到了。长行说是“修诸地到究竟”，就是说圆满成就了初地的功德、圆满成就了二地的功德、圆满成就了三地的功德，一直到圆满成就了十地的功德。

在四相这里，印顺法师和妙老都说第一、第二相是地前，后二相才是地上。我觉得这是印顺法师、妙老说错了。无性释、世亲释中都没有说“第一、第二是地前，第三、第四是地上”的说法。初地有初地的胜解、正行、通达、圆满，二地有二地的胜解、正行、通达、圆满，乃至十地有十地的胜解、正行、通达、圆满，各不相同。

修此诸地，云何可见？

菩萨也是得修止观，你的止观该怎么修呢？初地怎么修、二地怎么修？

谓诸菩萨于地地中，修奢摩他，毗钵舍那，由五相修。

菩萨在诸地修止观，有五种修法。

何等为五？谓集总修，无相修，无功用修，炽盛修，无喜足修。

你说有五种修法，具体是哪五种修法呢？第一是“集总修”，所谓集总修，就是把所有的教法放在一起，观察这教法的根本相通之处，发现一切法都有空性。这是用无分别智观察真如。“集总”就是总括一切教法，一切修多罗、一切陀罗尼、一切止观等，反正是一切的一切。这个集总修就是说，在修布施波罗蜜多的时候，同时我就修了其他的波罗密多，修这一个法的同时我就修了其他所有的法。第二是“无相修”，就是离一切相，修布施离布施相，修持戒离持戒相，反正是修什么就离什么相。第三是“无功用修”，就是不刻意地修而一直在修。也就是不动念而修一切功德。第四是“炽盛修”，就是勇猛精进地修行。第五是“无喜足修”，就是当有了成就的时候，不得少为足，还要继续用功，最后达到无上菩提。菩萨修行，地地都要这么修。

如是五修，令诸菩萨成办五果：

这五修能够使菩萨成就五果。

谓念念中销融一切麤重依止，

菩萨修奢摩他、毗钵舍那的时候，“念念中销融一切麤重依止”，不管你是集总修，还是无相修、无功用修、炽盛修、无喜足修，你修行中的每一念都与真如相应，每一念都“销融”一切“麤重依止”。“销融”就是破坏，“麤重”就是烦恼种子，烦恼种子会产生种种的错误、种种的过失。这个“依止”就是烦恼种子的依止，当然就是阿赖耶。现在就是说，你修行了，在每地，念念都在破坏烦恼种子，烦恼种子怎么才能破坏，当然得深入法性，不深入法性是不能够破除烦恼种子的。这个咱们就知道了，外道行者，可以成就四禅八定，但烦恼种子不动，不管你有什么样的神通了等等，你仍然是凡夫，因为你烦恼没动么～～有一个禅宗公案，一个禅师与一个人一同走路，在一条河边儿，那个人踏水而过，禅师过不去，禅师说，早知道这样我就把你的腿打断。你有了神通也仍然是凡夫。你有没有修行就是看你的烦恼种子有没有去掉，你念念都在去烦恼种子，这就是你修行了，不然就不是。

离种种相得法苑乐，

世亲释220页和无性释473页中都是“离种种想得法苑乐”。我们现在按“种种相”说。这个是说，你在修行的时候，没有分别，这是我、那是法、这是佛、那是魔等等的想法、分别都没有，这也就是无分别之境界。到了无分别的境界，就“得法苑乐”，就是离一切的戏论分别，安住于无分别智，有种种法乐。“苑”就是花园，一个园子里种了很多漂亮的花，你到这里就心情愉悦，这是形容你得了法乐、真如三昧。

能正了知周遍无量无分限相大法光明，

“能正了知”，“正”就是没有错误，你的了知、认识没有错误就叫“正了知”。“周遍无量”，“周遍”就是一切。“能正了知周遍无量”就是对一切都正确地了知了。“无分限相”是没有分际、没有界限、没有隔碍，“相”就是表现出来的，这就是说没有表现出界限、隔碍的情况、相貌。长行中的“大法光明”，“大法”就是指佛说的佛法。这第三果就是说，无量的佛法是圆融无碍的，菩萨通达了一切佛法。第一果是能念念消融一切烦恼，第二果是能得真如三昧乐，三果是能通达无量的佛法。

顺清净分无所分别无相现行，

这是四果。“顺清净分”的“顺”是随顺，“清净”就是圆成实性、真如，“无所分别”，顺于真如的智慧是无分别智。“无相现行”是说无分别智是离一切相的。这是根本智。前头的“能正了知周遍无量无分限相大法光明”等，是有分别的，是后得智。

为令法身圆满成办，能正摄受后后胜因。

如果在修行的时候，只修奢摩他而不修毗钵舍那，这样呢，你就想着怎样得初禅、二禅、三禅、四禅，这样的情况是有的。而有的是修毗钵舍那的，你要毗钵舍那的话，你的目的就是见真如，这样呢，因为目的的不同，所以结果大不相同。从表面上看，他们都是在那儿静坐。我们现在说的是修毗钵舍那的情况。如果你修毗钵舍那，那么最开始的奢摩他，是帮助修毗钵舍那的手段，修毗钵舍那的目的是为了见法身、见真如。现在这个五果就是修奢摩他，也修毗钵舍那，目的是“为令法身圆满成办”，这是希望自己的修行能够圆满成办。世亲释221页说，“第十地法身说名圆满，第十一佛地法身说名成办。”无性释475页说，“第十地说名圆满，若在佛地，说名成办。”这是一致的，不过世亲把佛地说成十一地倒是很好玩儿的。最后边儿还有一句“能正摄受后后胜因”，这是总括起来说的。“摄受”就是成就，说菩萨由初地到十地，前前诸地的修行是成就后后诸地的胜因。“胜因”是殊胜的因，初地是二地的因，二地是三地的因……九地是十地的因，十地是佛地的因。这样呢，前前成就后后，菩萨的一切功德就逐渐圆满了。

由增胜故，说十地中别修十种波罗蜜多。

“增胜”就是指菩萨一直修呀修，所修的功德很多很多。“说十地中别修十种波罗蜜多”，本来呢，波罗蜜多是一摄一切的，但是各地还是各有侧重点儿的不同。初地侧重于修布施波罗蜜多，二地侧重于修持戒波罗蜜多，三地侧重于修忍辱波罗蜜多，四地侧重于修精进波罗密多，五地侧重于禅定波罗密多，六地侧重于般若波罗密多，七地侧重于方便善巧波罗密多，八地侧重于愿波罗密多，九地侧重于力波罗密多，十地侧重于智波罗密多。实际上从总相上来说呢，每一地都修六波罗蜜多、十波罗蜜多的，不过各有侧重而已。

于前六地所修六种波罗蜜多，如先已说。

十波罗蜜多的前六种，就是布施、持戒、忍辱、精进、禅定、般若，这是前六地各各侧重的，这六波罗蜜多在前边儿彼入因果处已经说过了，这儿就不说了。

后四地中所修四者：

这儿从七地侧重的开始说。七地、八地、九地、十地这四地侧重的四种是什么呢？

一、方便善巧波罗蜜多，谓以前六波罗蜜多所集善根，共诸有情回求无上正等菩提故。

七地侧重的是“方便善巧波罗蜜多”。什么叫“方便善巧”？无性释476页说，“方便善巧者，谓不捨生死而求涅槃，是则说名方便善巧。”现在这儿的长行是说，把前六地所修的六波罗密多所积聚的善根、所成就的功德，回向给无量众生，希求无量众生都成就佛道、成就无上菩提。这个就是方便善巧。

二、愿波罗蜜多，谓发种种微妙大愿，引摄当来波罗蜜多殊胜众缘故。

这是八地菩萨所侧重的。什么是愿波罗密多呢？发愿实际上就是作计划。“谓发种种微妙大愿”，菩萨所发的愿是种种微妙大愿，不是为自己，而是为众生，凭所发的愿，可以“引摄当来波罗蜜多殊胜众缘故”，菩萨凭他所发的愿，可以成就波罗密多的种种殊胜因缘，就是说，凭这个愿可以成就一方净土，方便众生修行成道。发愿就是计划，按这个计划来创造净土，有缘的众生也来帮助你成就。这是八地菩萨所侧重的。

三、力波罗蜜多，谓由思择、修习二力，令前六波罗蜜多无间现行故。

这是九地菩萨所侧重的。“力波罗蜜多”的“力”，长行中解释说是“思择、修习”，这个“力波罗密多”就是说，菩萨因为思择、修习的力量，可以让布施、持戒、忍辱、精进、禅定、般若六波罗蜜“无间现行”。“思择”就是思惟、简择、观察。“修习”就是采取行动。圣人就是因为思择、修习的力量，所以六波罗密多一直现行，而我们凡夫则一下就懈怠了。

四、智波罗蜜多，谓由前六波罗蜜多成立妙智，受用法乐，成熟有情故。

智波罗密多是说，因为菩萨一直修习布施、持戒、忍辱、精进、禅定、般若六波罗蜜多，而使自己成就了智慧，由智慧再来推动六波罗蜜多的现行，再增长自己的智慧，这样相互增上。“成立”就是成就，“妙智”就是不可思议的智慧。“受用法乐”，说因为菩萨有这样的妙智，所以你可以听懂佛法，听懂了佛法，你就得大法乐。然后是“成熟有情”，因为你有六波罗蜜多所成就的不可思议妙智，你在十方世界观察众生的根性，然后去广度众生，用各种善巧的方法令众生的善根得以成熟，以成就道果。这就是利益众生。

又此四种波罗蜜多，应知般若波罗蜜多无分别智后得智摄。

方便善巧波罗密多、愿波罗密多、力波罗密多、智波罗密多这四种，我们要知道它是“般若波罗蜜多无分别智后得智摄”，就是说，这四波罗密多实际上是六波罗密多中的般若波罗蜜多开出来的，是般若波罗密多无分别智（根本智）开出来的，就是说，般若波罗密多是根本智，因为有根本智，所以成就了这四波罗蜜多，这四波罗密多属于后得智。我们在说六波罗密多的时候，实际上已经把这四波罗密多包括进去了，这四波罗密多被包括在般若波罗密多里边儿了，要是按十波罗蜜多来说的话，这时的般若波罗蜜多只是无分别的根本智，后四波罗蜜多则是属于后得智。

又于一切地中，非不修习一切波罗蜜多。如是法门，是波罗蜜多藏之所摄。

这是说，虽然我们说初地修布施波罗密多，其实是十波罗密多都修的；我们说二地修持戒波罗密多，实际上其他九波罗密多他也是修的……十地都是这样子。这十波罗密多法门，实际上是一切大乘佛法的总称，一切大乘佛法都被包括在十波罗密多法门中了。

复次，凡经几时修行诸地可得圆满？

这是问修行得多长时间才能圆满。

有五补特伽罗，经三无数大劫：

“五补特伽罗”就是五个位次，每一个修行人都要经过五个位次。“经三无数大劫”，就是咱们常说的三大阿僧祗劫。就是说，修行人要经过五个位次、三大阿僧祗劫，然后成佛。

谓胜解行补特伽罗，经初无数大劫修行圆满；

五个位次的第一个是“胜解行”。菩萨从初发无上菩提心开始，这时候他还没有证悟真如，还是凡夫，但他对佛法有深刻的信解（我们把这叫胜解行菩萨），“经初无数大劫修行圆满”，这位菩萨要经一阿僧祇劫的修行才能圆满。也就是说，在胜解行地要一阿僧祗劫的时间。这一个实际上就是《唯识三十颂》中说的资粮位、加行位。这胜解行地按四十二位的说法来说的话，就是十住、十行、十回向。

清净增上意乐行补特伽罗，及有相行无相行补特伽罗，于前六地及第七地，经第二无数大劫修行圆满；

“清净增上意乐行”是指菩萨登地了，已得无生法忍了，见道了，入圣位了，十地菩萨都是清净增上意乐行。在十地菩萨里面，前六地菩萨是“有相行”，第七地是“无相行”。“相”就是表现出来，就是内心有所分别。修行的时候内心有分别就叫有相行，修行的时候内心无分别就叫无相行。这是说，从初地到七地圆满是一大阿僧祗劫。注意这个有分别，佛也是有分别的，佛的有分别是凭后得智分别的，佛的有分别但没有染污，我们的有分别是染污的，这不一样。

即此无功用行补特伽罗，从此已上至第十地，经第三无数大劫修行圆满。

在七地时的修行，还是有功用行，就是说心里还要动念头，从八地开始，成无功用行了。从八地经九地、十地到成佛，圆满了，“经第三无数大劫”，这又得一大阿僧祗劫。五个位次是：胜解行补特伽罗、清净增上意乐行补特伽罗、有相行、无相行补特伽罗、无功用行补特伽罗。其中的“清净增上意乐行补特伽罗”可以包括有相行、无相行、无功用行三个补特伽罗。这五补特伽罗的说法并不通用，到后来世亲在《唯识三十颂》中说五个位次是资粮位、加行位、见道位、修道位、究竟位。

此中有颂：

把这些内容用个颂子说一下。

清净，增上力 坚固心，升进

名菩萨初修 无数三大劫

这个颂里说了清净力、增上力、坚固心力、升进力。“清净”就是清净力，就是善根。菩萨五十二位不是十信、十住、十行、十回向么，把十信摄入十住，就成了四十二位。这个“清净”就是指十信位菩萨栽培的善根达到清净的程度了。这时的清净可不是没有烦恼，烦恼还是有的，但他们要是一提起正念，马上就可以战胜染污心，就指这清净。现在说清净力，就是正念战胜烦恼了，它有这个力量。“增上力”是说的善知识的力量。善知识有帮助你的力量，所以叫增上力。“清净力”是自己本身的力量，“增上力”是善知识的帮助力量。“坚固心”是指在遇到恶知识的时候，你的菩提心不动摇。“升进”就是说，由于自己的清净力，善知识的增上力，加上坚固心，你就时时用功修行，这样就一步步上升。“名菩萨初修”就是说，你要是有这四种力，你就是开始修行的菩萨了。“无数三大劫”，你就进入了三大阿僧祗劫的计算范围之内了。


增上戒学分第七

现在要说戒了，看论文。

如是已说因果修差别，此中增上戒殊胜，云何可见？

前面已经说过了彼入因果六波罗蜜，彼修差别十地，就该说说戒了。在六波罗蜜多、十地中都说到了戒，戒很重要，要专门说一下。“此中增上戒殊胜，云何可见”，菩萨戒比小乘戒要殊胜，它殊胜在哪儿呢？“增上戒”的“增上”是使动词，使戒增上，或者说戒使圣道增上。

如菩萨地正受菩萨律仪中说。

菩萨戒在《瑜伽师地论》里有专门的说明。“菩萨地”是《瑜伽师地论》中的一地，《瑜伽师地论》总共是十七地，里边儿有菩萨地，在菩萨地里专门讲有戒。那里有所以这里就没有多说。

复次，应知略由四种殊胜故此殊胜：一、由差别殊胜，二、由共不共学处殊胜，三、由广大殊胜，四、由甚深殊胜。

说，菩萨戒有四点儿胜过声闻戒，所以说菩萨戒殊胜。哪四点呢？就是差别殊胜、共不共学处殊胜、广大殊胜、甚深殊胜。下边儿有解释。

差别殊胜者，谓菩萨戒有三品别：一、律仪戒，二、摄善法戒，三、饶益有情戒。

菩萨戒有摄律仪戒、摄善法戒、饶益有情戒三种不同。“律仪戒”的“律”是能息灭恶法，可以息灭恶法的叫律。佛所制定出来的一条一条的戒条，可以灭除恶法，所以叫律。我们依教奉行，就叫“仪”。摄律仪戒是不作错误的事情。“摄善法戒”就是波罗蜜多，六波罗蜜多、十波罗蜜多。你修波罗蜜多了，就能成就、能积集无量无边的善法功德。这摄善法戒是说要作有功德的事情。“饶益有情戒”就是要利益一切有情。小乘戒只有律仪戒，没有摄善法戒、饶益有情戒，所以菩萨戒是殊胜的。

此中律仪戒，应知二戒建立义故；

律仪戒是摄善法戒、饶益有情戒建立的依止处，要是没有律仪戒，摄善法戒、饶益有情戒就建立不起来，依律仪戒才能建立起摄善法戒、饶益有情戒。也就是说，你得先远离一切罪过，然后才能够修学无量无边的善法、才能去利益众生。

摄善法戒，应知修集一切佛法建立义故；

摄善法戒是“修集一切佛法”的，就是说，一切佛法都是建立在这善法的基础之上的，摄善法戒是其他一切佛法的基础。你修学这个善法了，才能成就一切佛法。

饶益有情戒，应知成熟一切有情建立义故。

“饶益有情戒”是成熟一切有情的。这样来看，菩萨戒确实是比声闻戒殊胜，声闻乘不饶益有情，就没有饶益有情戒。声闻乘也不修十波罗蜜多这种成佛的法门，他没有发无上菩提心，所以也没有摄善法戒。声闻乘只求涅槃，所以只有摄律仪戒。

共不共学处殊胜者，谓诸菩萨一切性罪不现行故，与声闻共；相似遮罪有现行故，与彼不共。

菩萨戒比声闻戒殊胜的第二个表现是共不共学处殊胜。“学处”就是指的戒。有一本书叫《沙弥学处》，就是讲的沙弥戒，很厚的一本书。从学处上可以看出菩萨的殊胜――就是有共不共学处。“谓诸菩萨一切性罪不现行故”，这里边儿有个性罪，所谓性罪就是指，不管你受不受戒，都是不该作的，一作就算犯戒了，就是说，它本身就是染污，象杀、盗、淫、妄之类的就是。与性罪对应的是遮罪，所谓遮罪是指你要是受了戒那就不能作，作了是犯戒，你要是没受戒，是可以作的，作了不算犯戒。象酒戒就是，受戒了就不能喝酒，没受戒是可以喝酒的。现在说一切性罪不现行，就是说发无上菩提心的菩萨他是不做这种事情的，性罪是不会犯的。“与声闻共”，这给声闻戒是一样的，在声闻戒中也不能犯性罪。声闻乘不能做这种事，菩萨乘也不能做这种事。“相似遮罪有现行故，与彼不共”，这个遮罪对于菩萨来说，有时候是现行的，就是说，菩萨有时候是喝酒的，这要看具体情况。在声闻乘来说，受了戒就不能喝酒，这一个是声闻乘与菩萨乘不共的地方。“相似”，印顺法师说是玄奘法师译错了，不应该有。

于此学处，有声闻犯菩萨不犯，有菩萨犯声闻不犯。

关于这个遮罪，“有声闻犯菩萨不犯”，你是声闻乘，比如说你去割草了，这是不允许的，你割草就犯了声闻戒，但对于菩萨来说，他发了菩提心，只要是割草是为了利益众生，就可以割，这不犯戒。现在我们都是既受声闻戒又受菩萨戒，我们到底是可不可以割草？要看能不能利益众生。自己可以时时提醒自己，看自己当下是不是在利益众生，这个自己是知道的，骗得了别人骗不了自己，看自己是不是犯戒。我们不要已经作了之后再找借口就行了。“有菩萨犯声闻不犯”，还有的是声闻乘不犯但菩萨乘犯的。比如说在安居其间，有某个因缘请你去讲经，比丘就可以不去，说我正在安居，这时候比丘不去是不犯戒的。但对于菩萨来说，你要是不去就是犯戒了。

菩萨具有身语心戒，声闻唯有身语二戒，是故菩萨心亦有犯非诸声闻。

从身、口、意三业来说，菩萨戒身、语、心三方面都有，而声闻乘则只有身、语二方面的戒。菩萨戒起心动念就犯戒了，但声闻戒则是只要没有实行就不犯戒。就是说，菩萨戒比声闻戒严格得多，受了菩萨戒就不能起坏心，而声闻乘不管这个，只要没作出来就行。

以要言之，一切饶益有情无罪身语意业，菩萨一切皆应现行，皆应修学。

“以要言之”，总括起来简单地说，对于菩萨来说，只要是利益众生的身、语、意业，统统都得作，都得去实行。你要是不作，就是犯戒了。现在有一个情况，就是说虽然作了利益众生的事情，但是内心里极其不情愿，或者说你是坏心作了好事儿，这都不行，你必须是身、口、意一致的利益众生。长行中的“无罪身、语、意业”，你不能看见别人不如法了以嗔心来批评他，你应该以慈悲心批评他。

如是应知说名共不共殊胜。

从这儿我们就知道菩萨戒比声闻戒殊胜。

广大殊胜者，复由四种广大故：

第三种是广大殊胜，这广大殊胜又分四种情况。

一、由种种无量学处广大故，

菩萨发了菩提心，修学大乘教法，所应学的戒律有无量无边，比声闻乘多多了。比丘戒二百五十条，而菩萨戒有“三千威仪、八万细行”。

二、由摄受无量福德广大故，

这是说，你学菩萨戒，可以“摄受无量福德”，“摄受”就是成就、利益，菩萨戒所成就的福德是无量的，这可不是声闻戒所可比的。声闻乘偏重的是不作诸恶，而菩萨乘还有众善奉行、自净其意。

三、由摄受一切有情利益安乐意乐广大故，

菩萨能“摄受一切有情”，因为他受持菩萨戒，菩萨戒就要求饶益一切有情，“利益安乐意乐广大”菩萨要利益众生的心情，要让一切众生得安乐的心情，声闻乘是没有的。当然，不是说一点儿没有，而是说太少了，忽略不计了。“利益”就是让众生得利益，“安乐”是让众生得到好的果报。利益一般是近期的、现在的，而安乐一般是未来的。“广大”是指让一切众生都得到利益安乐。

四、由建立无上正等菩提广大故。

这是说菩萨的目的是让自己成佛、让一切众生成佛，这不是声闻乘能及的。这是广大殊胜的情况，最后还有一个甚深殊胜。

甚深殊胜者，谓诸菩萨由是品类方便善巧行杀生等十种作业，而无有罪，生无量褔，速证无上正等菩提。

这个甚深殊胜可不得了，“谓诸菩萨由是品类方便善巧行杀生等十种作业”，就是说，菩萨发了菩提心，因为有各种各样的情况，他为了度化众生，就得有各种各样的方式，而有些方式极其令人难以接受，比如说他得杀生。在一般的情况下，这是不可思议的，他的杀生是为了“速证无上菩提”――为了自己速证无上菩提，为了众生速证无上菩萨。菩萨此时的杀生，是没有罪的，是可以生无量福的。长行中有一个“方便善巧”，就是说，不要乱搞，不要乱杀，这必须是以智慧为后盾。在《慧上菩萨问大善权经》中有五百商人出海的故事，说在在定光佛的时候，曾有五百商人一同出海去采宝。其中有一个人，起了坏心，他想害了其它的商人，然后自己独霸财宝。其时，阎浮提有个大导师叫做大哀。海神知道这个人起了坏心，就用神通力告诉了大哀导师，海神说，“这些商人都曾发过大菩提心，假如说这个人真的杀了他们，其罪可是无量无边，请导师你想个办法，能够既不伤害这些商人，又不要使起了坏心的这个人恶业成就”。这个大哀导师想了七日七夜，想不出一个两全其美的方法。他想，“假如说我告诉那些商人，说这个人要害他们，那么商人一定要杀了这个人，杀人一定得恶报。若我一个人杀了这个起坏心的人，我一个人得恶报。与其商人们都得恶报，不如我一个人得恶报。”于是，大哀导师“（以权方便）害一贼命”，杀了起坏心的这个人。而其报应呢，大哀导师“命终之后生第十二光音天”。大哀导师是释迦牟尼的前生。我们要明白这个故事。菩萨杀生实际上也是要受报的，他救生有救生的果报、杀生有杀生的果报，这都是一样的。现在他生第十二光音天是因为救生而生的，可不是因为杀生而生的，这要搞清。这时候我们也要看清《摄大乘论》原文，说法是有秘密意趣的，这在第二卷就说到了，在31页，四意趣四秘密，千万不要搞错了。（别意意趣、对治秘密）

又诸菩萨现行变化身语两业，应知亦是甚深尸罗。

关于这个甚深殊胜，刚才说了一个方便善巧行十恶法，这又说了一个现行变化。“又诸菩萨现行变化身语两业”，说，菩萨为了度化众生，要用神通方便善巧地变化出很多众生，变化出来的这些众生在作恶事儿、坏事儿，这就是“现行变化身语两业”。就是说，这些众生在作坏事儿其实不是真实的。善财童子五十三参参到无厌足王的时候，那个无厌足王可是极其惨忍的，其实那是菩萨变化出来给迷惑颠倒的众生看的，不是真的。这是度众生的方便。“应知亦是甚深尸罗”，这也是甚深菩萨戒，如果需要你就得这样。

由此因缘，或作国王示行种种恼有情事，安立有情毘奈耶中。

因为菩萨有菩提心、大悲心，有种种因缘，所以说他在作国王的时候，就用神通变化出各种恼害众生的事儿，变现这干什么呢？有什么意义呢？“安立有情毘奈耶中”，菩萨既然是现作国王，当然会立法订规矩，要你守法，他再变现出一些恼害众生的情况出来，然后用律法收拾他，给众生作出一个样子来，使得众生不敢作恶。所以说，菩萨“示行种种恼有情事”的目的、结果，就是让大家受持戒律。“毘奈耶中”就是生活在戒律中，不能放逸。

又现种种诸本生事，示行逼恼诸余有情，真实摄受诸余有情，先令他心深生净信，后转成熟。

菩萨还示现种种本生事，“本生事”就是他自己过去生修行的时候所作过的事儿，“又现种种诸本生事”就是说，菩萨可以把他过去修行的时候所作的事儿再现一遍。他示现的是“逼恼诸余有情”，就是说，菩萨用神通力把自己过去生修行的时候逼恼其他众生的情况示现出来。因为是菩萨示现的，所以并不是真实的，菩萨示现出这个，就是要摄受众生的，“真实摄受诸余有情”，菩萨用自己的亲身经历来告诉大家、教育大家，因为是菩萨自己的亲身经历，所以感召力就强。我记得上中学时老师让写文章，就写一个人，老师说古今中外的人都可以写，有的同学写自己的邻居，而有一个同学写哥白尼，写身边儿的人的都给高分，你写哥白尼当然只能给很低的分数。这是正常的。菩萨用自己的亲身经历的情况来教化众生、利益众生。“先令他心深生净信”，菩萨用自己的亲身经历，让众生看看，先让众生的心，对善恶果报生起深信，生起深深地信心、清净的信心，有了清净的信心就容易修学善法了，只要修学善法，慢慢地善根就成熟了，就可以得圣道了。“后转成熟”就是以后慢慢展转增长，善根就成熟了，就得解脱了。

是名菩萨所学尸罗甚深殊胜。

这就是菩萨戒的甚深殊胜，这是小乘戒所不可比拟的。

由此略说四种殊胜，应知菩萨尸罗律仪最为殊胜。

前边儿已经简单地说了一下菩萨戒的四种殊胜，根据这四种殊胜，我们就应该知道菩萨戒是声闻戒所不及的。

如是差别菩萨学处，应知复有无量差别，如毘奈耶瞿沙方广契经中说。

刚才已经说了菩萨戒的这些不同之处，其实我们应该知道，菩萨戒还有很多殊胜、很多差别处，那就太多了，这里说不过来，要想知道的话，可以看看“毘奈耶瞿沙方广契经”，那里边儿就详细多了。“毘奈耶”就是戒，“瞿沙”，是妙音，“方广”是大乘，“契经”是典籍、经典。这一部经叫《毘奈耶瞿沙方广契经》，“毘奈耶”表示这是一部律典，“瞿沙”是人名，这部律典是瞿沙这个人问佛的。这是一部大乘典籍，可惜没有传到中国来。


增上心学分第八

这一部分是说的定。

如是已说增上戒殊胜，增上心殊胜云何可见？

说，增上戒的殊胜已经说完了，增上心的情况是怎么样的呢？这里没有用“定”，而用的是“心”、增上心。我们知道，心一般是指我们现前的虚妄分别心，因为是虚妄分别心，所以有很多的烦恼，若是我们能够修学世出世间善法，那就会逐渐地得到安乐、得到光明。增上心就是说，我菩萨修学圣道，先有增上戒令自己的身口清净，你不是身口清净就完了，你还要进一步调伏自己的心，让自己的心也清净，所以这里用了增上心，其实给定是一样的。

略由六种差别应知：一、由所缘差别故，二、由种种差别故，三、由对治差别故，四、由堪能差别故，五、由引发差别故，六、由作业差别故。

菩萨增上心有六种殊胜，就是所缘差别、种种差别、对治差别、堪能差别、引发差别、作业差别。根据这六种差别来显示菩萨增上心的殊胜之处。下边儿一个一个的差别来说。

所缘差别者，谓大乘法为所缘故。

“所缘差别”就是大乘所说的禅定、增上心所缘虑的对象与小乘的禅定是不一样的。“谓大乘法为所缘故”，就是说，大乘增上心所缘虑的对象是大乘教法，是大乘的教理行果。禅定是什么？就是静虑、思惟修，就是把心静下来专门思惟，现在菩萨增上心就是让你的心静下来专心思惟大乘教法。菩萨是为了成就佛道而修习禅定的，所以在禅定中是思惟大乘教法的。我们通过这《摄大乘论》，可以看出，无著论师一直在强调学习佛法的重要性，不管你修什么法门，都是以学习为基础，这给咱们中国佛教徒是格格不入的。净土宗要求专心念佛，禅宗要求专心参究，这差别很大。

种种差别者，谓大乘光明、集褔定王、贤守、健行等三摩地，种种无量故。

第二是种种差别。第一的“所缘差别”是说学习的是大乘教法，这第二的“种种差别”说的是所成就的禅定是各种各样的。长行中举出了四种三昧。第一是“大乘光明”三摩地，“大乘”是发无上菩提心，发大菩提心的人，他修学禅定成功了，他从禅定里发出光明智慧，能够照了大乘佛法的教理行果，能通达一切大乘佛法，这个就是“大乘光明三摩地”，这是强调智慧的。第二种禅定是“集福定王”三摩地，所谓“集福定王三摩地”，这是说，禅定虽然成就了，但禅定不是目的，我的目的是要成佛度众生的，于是，菩萨成就了禅定以后，还要继续积集无量无边的福德。这是得禅定以后，在禅定里继续积集无量的福德。“王”是自在的意思。“福”是福德，最简单的福就是咱老百姓说的身体健康、家庭和睦等，当然这里说的可不是这个。第三是“贤守”三摩地。“贤”是慈悲仁善，“守”是有慈悲心守护一切众生，怎么守护呢？就是教化一切众生，让众生都修学善法而不受恶报。这是说菩萨在禅定中教化众生。大乘光明三摩地、集福定王三摩地是菩萨自己培植福慧，贤守三摩地是菩萨利益众生。第四是“健行”三摩地，“健行”就是健者所行，“健”是刚健，也就是大丈夫，说，菩萨不为一切法所动摇的境界，叫刚健，他所修的三昧，叫做“健行”三摩地。长行中还有一个“等”字儿，是表示还有其它的三昧，三昧可不只这四种，有很多很多。

对治差别者，谓一切法总相缘智，以楔(xie)出楔道理，遣阿赖耶识中一切障粗重故。

“对治差别”是说登地的菩萨他在所成就的禅定里，也还是得修学的，主要是修习止观，他们修习止观是干什么的？我们修习是因为我们烦恼多，要对治烦恼，他们修习止观是干什么呢？也是来对治内心里的烦恼，难道菩萨还有烦恼，菩萨有的是细相烦恼，就是烦恼的种子。“谓一切法总相缘智”，这是说菩萨在禅定里继续修止观成就一切法总相缘智。法有总相、别相，就是总体、部分，我们是认识不了总体的。别相就是差别相，总相就是无差别相，无差别相就是真如。“总相缘智”就是缘一切法总相的智慧，实际上就是根本无分别智，又叫真如智、如理智。菩萨在禅定里发动这个真如智来修止观，就能除去阿赖耶识里的粗重种子、烦恼种子。这个就叫“对治差别”。

下边儿的“以楔出楔”是个比喻，“楔”，就是小木片，木匠要作桌子，桌子腿与桌子面怎么连起来，就是在桌子面上开孔，在桌子腿上作榫，把榫往孔里放，孔与榫有时候会很合适，而有时候不是那么合适，当孔大了一些而榫小了一些的时候，就用小木片打进去，这个小木片就叫楔。楔就是不主要、很小的意思，咱们在看书的时候，有些书一开始的一小段儿，叫“楔子”。还有的时候是这样，有一段木头，孔里放了一个东西，发现放错了，要把它拿出来，可怎么用力也拔不出来，我就从反面用一个木块钉住要拿出来的东西打击，就可以把要拿出来的东西拿出来，那个木块就叫楔子。这个“以楔出楔”就是这个意思，孔里有一个楔拿不出来了，我就又用一个楔钉住它，把要拿出来的楔打出来。这个比喻就是说，现在阿赖耶识里有烦恼种子，它是个坏楔，要把它拿掉，它堵住了我们的心窍，把这个孔堵住了，我们就用“一切法总相缘智”――就是修止观成就是总相缘智、根本无分别智、真如智，来把阿赖耶识里的烦恼种子打掉，把心窍打开。就是说，止观能破烦恼种子。“遣阿赖耶识中一切障粗重”就是遣除阿赖耶识中的一切障碍种子。这就是对治差别。小乘只能对治现行，而大乘不但可对治现行，还可以对治种子。

堪能差别者，住静虑乐，随其所欲即受生故。

“堪能”就是殊胜的能力。“堪能差别”是说，菩萨安住在甚深禅定中，他可以随自己的高兴而到任何地方去受生，他看哪个地方有人该当受教就到那个地方受生去教化那该当受教的人。

引发差别者，谓能引发一切世界无碍神通故。

“引发差别”是说，菩萨这增上心学禅定能够引发出“一切世界无碍神通”，“一切世界无碍”就是说可以到任何世界去，到娑婆世界可以，到极乐世界也可以，到净琉璃世界也可以……想到哪儿就到哪儿，没有一点儿障碍。这不是小乘所能及的。

作业差别者，谓能振动，炽然，遍满，显示，转变，往来，卷舒，一切色像皆入身中，所往同类，或显或隐，所作自在，伏他神通，施辩念乐，放大光明；引发如是大神通故。

刚才说的“引发差别”是说从增上心学禅定里面引发出无碍的神通，这个“作业差别”是说引发出来的神通可以作业，作种种不同的业，长行中就举了一些情况。“能振动”，这是指威力大，可不是引起地震。“炽然”是指光明无量。“遍满”是指利益所有众生，任何世界的任何众生他都可以利益。“显示”是表现出来以开示众生，表现出什么？只要能利益众生的，他都可以表现出来。“转变”，这是让四大互相转变，让水变成火，让火变成风，有这个境界。“往来”是说可以在任何世界来往。“卷舒”，卷就是把大的变小，舒就是把小的抻大。这都是自在的境界。

“一切色像皆入身中”，这句话实际上表述的就是《普门品》中的“应以何身得度即现何身度之”，就是说，菩萨变现了很多化身去度众生，这些化身就是论文中说的“色像”，化身是以色法的形式显现的，所以是“色”，它们只是化身，不是实在的，所以是“像”，像就是影像。接着一句是“所往同类”，就是说，菩萨化现了各种化身，这些化身都去度众生，要去度化牛的时候，就有一个菩萨化身的牛去度，要去度化天人的时候，就有一个菩萨化身的天人去度，要来度化人的时候，就有一个菩萨化身的人来度，这就叫“所往同类”。为什么这样呢？比如说你要来度化人，可是你却是化身的豺狼来度，人见你就跑，你怎么来度？所以要化身为同类的身像来度。“或显或隐”是说，化身的同类身像或者是很明显地现出来，让你看见，和你说话，但有的是“隐”的，就是让你看不见――也就是帮助了你，但你不知道是谁帮助你的。“所作自在”，是说菩萨想作的事儿没有作不成的，为什么？作不成的他就不作，也就是说，机缘没到的时候他根本不强作。

“伏他神通”是指菩萨的神通可以降伏恶人，你就是再恶的人，到菩萨这儿都不行，你恶菩萨比你还恶，让你恶不起来，你要是善良，菩萨给你帮助使你上进，你恶，菩萨给你作恶的逆缘，让你不能为恶。“施辩念乐”，“施辩”就是布施给你辩才，你没有辩才菩萨布施给你辨才，让你度众生的时候说法说得更好，能更好地度化众生，这就是咱们常说的“加持”。“念”就是“施念”，“乐”就是“施乐”。“念”就是“于曾习境明记不忘”，现在的“施念”就是说，有的修行者念力不行，老忘，菩萨就加持你，让你保持念力。念力是五力之一，在《阿弥陀经》上说极乐世界的鸟都在说法，说的就是五根、五力、七菩提、八正道等，其中的五力就是信力、精进力、念力、定力、慧力，其中就有念力。现在菩萨就是加持你的念力。

“施乐”就是使令听法的人心里得到法喜。妙老说也可以这么说：有些邪恶的鬼神放种种毒气，使这个地方流行瘟疫，菩萨用神通能消除这一切瘟疫，使大家身体健康，这也叫施乐。“放大光明”是菩萨在要说法是时候给有缘人发信号，通知他们。在咱们这个世界要通知是打个电话呀什么的，菩萨就是放光的，菩萨在这儿一放光，十方世界有缘的人，或者他方世界的菩萨就来了，来捧场听法。大乘经典上佛陀说法的时候很多都要放光。“引发如是大神通”，菩萨在增上心禅定里面就能引发这样广大的神通，来作利益众生的广大事业。这是不可思议的。

又能引发摄诸难行十难行故。

作业差别是六种殊胜的最后一个，不过作业差别讲的很多，刚才是说引发神通，现在说引发难行业。所谓“引发难行业”就是说，从禅定里能引发出来十种难行。论文中说“摄诸难行十难行”，就是说用十种难行可以收摄一切难行，一切难行都包括在这十种难行里了。

十难行者，一自誓难行，誓受无上菩提愿故。

十种难行是啥呢？第一个是“自誓难行”，“誓”就是誓愿，“愿”是希望作，“誓愿”则是决定要作、一定要作。论文中说“自誓难行”是指“誓受无上菩提愿”，就是说，菩萨决定要发成就无上菩提的大愿。“受”就是接受、领受，就是说我要接受无上菩提愿、要成就无上菩提愿。成就无上菩提就是成佛，成佛可不是容易的，菩萨说不容易我也要成，他不怕难。菩萨发这愿是自己要发这愿的，所以叫“自誓难行”。

二不退难行，生死众苦不能退故。

第二是“不退难行”。“不退难行”是说，菩萨发了无上菩提心，要学佛法、行六波罗蜜多、广度众生，在度化众生的时候，他也要受很多苦，比如说身体上的苦，象寒冷、酷暑，还有就是他度众生众生却触恼他等，虽然菩萨受了这许多的苦，但菩萨是不会退心的。

三不背难行，一切有情虽行邪行而不弃故。

第三个是“不背难行”。“背”就是舍弃。这是不背行难论文中说是“一切有情虽行邪行而不弃”，就是说菩萨去度众生，众生因为在生死里流转久了，你去教化他，可他不接受教化，或者说象地藏经中说的，地藏菩萨把你从险处救出来，可是一下子你就又掉下去了，菩萨再来救你，一下你又下去了，虽然如此，菩萨也不舍弃你。

四现前难行，怨有情所现作一切饶益事故。

第四是“现前难行”。就是说，菩萨去救度众生，可是众生对菩萨却恶意相向，他还要伤害菩萨、毁辱菩萨，菩萨对这样的众生也不会生嗔恨心，还是慈悲地来作一些利益你的事儿，照样来救度你。论文中的“怨有情”就是对菩萨有怨恨，你去救他可他却讨厌你。这一个现前难行就是咱们常说的以德报怨。大菩萨没有嗔恨心，你对他不好他也是不会嗔恨的，他只有怜悯心、慈悲心。

五不染难行，生在世间不为世法所染污故。

第五的“不染难行”就是指在这个世间但不受世间染污，就是不为世间一切所动。世间一切就是指八风：利、衰、毁、誉、称、讥、苦、乐。利是你得到了可爱的五欲，衰是失掉了可爱的五欲；毁是说你的坏话，誉是说你的好话，都是在背后说；称是当面说你好，讥是当面说你坏，让你好没面子；苦就是让你苦恼，乐是让你快乐。现在说这一切都不会动你的心。

六胜解难行，于大乘中虽未能了，然于一切广大甚深生信解故。

第六是“胜解难行”，说，这一位菩萨对于大乘教法中说的境界还没有证得，也就是说还没有得无分别智，但是他对于大乘的广大甚深教法还是恭恭敬敬地修学，以使自己生起深深的信解。这个也是不容易作到的。我还没有得到大乘的好处，我仍然恭敬大乘教法。我们现在有这样的人，他有不如意了，听人家说佛菩萨是有求必应的，那么就去求。比如说他得了癌，他就去让庙里给作一场佛事，或者去求活佛灌顶呀、给一个教授呀等，可是，他的病仍然没有好起来，于是他就抱怨说，佛教是骗人的，我真的去求菩萨了，可我并没有得到我想要的。我现在没有得到大乘佛教的好处但我仍然恭敬大乘佛法，这是不容易作到的，所以是难行。

七通达难行，具能通达补特伽罗法无我故。

第七是“通达难行”，就是说，这位菩萨他在增上心禅定里，他能完全通达人无我、法无我。“具能通达”的“具”就是彻底、完全。

八随觉难行，于诸如来所说甚深秘密言词能随觉故。

第八是“随觉难行”，“随”是随顺，“觉”是觉悟。随觉难行是指，佛陀的言教是为度众生而说的，但有一部分是佛陀秘意而说，就是说不是显了说，对于这些秘意而说的言教，菩萨能随顺佛陀的言教正意而觉悟。这一个随觉难行下边儿还有解释。

九不离不染难行，不舍生死而不染故。

第九是“不离不染难行”，这是说，菩萨能够不离生死，但是不受生死的染着。“不受生死的染着”就是指不会因为生死而生出许多的苦恼、造出来很多的新罪、过失，罗汉是离开了生死所以不受生死的染着，菩萨不用离开生死，就不受生死的染着。这是因为大悲心的缘故。

十加行难行，能修诸佛安住解脱一切障碍，穷生死际不作功用，常起一切有情一切义利行故。

第十是“加行难行”，“加”就是增加、增长，就是要努力精进修行的意思。论文中的“诸佛安住解脱一切障碍”是说，成佛了以后，就安住在一切障碍解脱的境界中，没有烦恼。刚登地的菩萨，还是有烦恼的，但他经过努力修行，就可以把烦恼断尽。“穷生死际不作功用”，说，佛安住在没有烦恼的境界中，是一直没有烦恼的，“穷生死际”就表示长远、长久，久到永远，因为佛本身是没有生死的，“不作功用”是说不用起心动念。虽然佛不用起心动念，但他可以“常起一切有情一切义利行”，就是说，他不用动度众生的念头而自然去度化众生。这是法身境界。十种难行是菩萨的，第十的加行难行是说菩萨在因位上就有此目的，以求达到度脱一切有情的目的。

复次，随觉难行中，于佛何等秘密言词彼诸菩萨能随觉了？

十种难行中第八是“随觉难行”，这里把随觉难行再进行一番解释。先提出问题，说菩萨对佛的什么秘密言词能随觉呢？

谓如经言：

比如经中这样说。

云何菩萨能行惠施？

菩萨是怎样修行布施波罗蜜多的呢？

若诸菩萨无少所施，然于十方无量世界广行惠施。

“若诸菩萨无少所施，然于十方无量世界广行惠施。”这就是秘密言词，我们就不懂了。这句话说，菩萨一点儿布施也没有作，可是他却是在十方世界作了最大的布施。既然他没作布施，怎么能是最大的布施呢？我们就不懂了。布施有财施、法施、无畏施，比如说财施，你说你财施了，可是你根本没有财物，这能说你是布施了～～这到底是怎么回事儿呢？看233页世亲释，“谓诸菩萨一切有情摄为自体，是故彼施即是己施”。就是说，菩萨通达了平等法性、通达了真如，他们照见五蕴皆空，发现真如是平等的，与佛平等、与一切菩萨平等、与一切众生平等，真如不分你我、没有界限，是一体的，所以说，别人在十方行布施，也就是这位菩萨在十方行布施。所以说这位菩萨“无少所施，然于十方无量世界广行惠施”。

再看一下487页无性释，无性释中有三种解释，第一种解释给世亲释意思一样，不过话稍有不同，“谓诸菩萨一切有情摄为己体，通达自他平等性故，彼行施时即菩萨施故无少施名能行施”。无性释的第二种解释是说，“以一切所有财物施于一切，是故说名无少所施”。这第二种解释有点文字游戏的味道，《摄大乘论》原文是说“诸菩萨无少所施”，无性就说，因为是多施，所以不是“少所施”，应该是“多所施”。第三种解释是说，“又所施物施者、受者皆不可得，三轮清净，是故说名无少所施。”这是三轮体空的意思，就是说菩萨观察财物、施者、受者皆不可得。世亲、无性就是这么解释的。

云何菩萨乐行惠施？若诸菩萨于一切施都无欲乐。

再看“乐行惠施”，就是欢喜，菩萨喜欢行布施。什么叫“菩萨乐行惠施”？怎么才是菩萨乐行布施呢？“若诸菩萨于一切施都无欲乐”，听佛菩萨说话可真别扭，什么叫菩萨乐行布施？如果菩萨对于一切布施都不喜欢就叫乐行布施？这不是对着干吗？我们凡夫行布施，都是有所求的，我在佛前放一串香蕉，我希望我的孙子今年考个好大学，我在佛前放五个苹果，我希望我的癌症好，这样所谓的布施，是有染着的，就象作生意一样，用一串香蕉就把佛给打发了，就想大赚一笔，佛老作赔本买卖？这不是布施。菩萨不是这样的，他是无相布施。因为菩萨是无相布施，所以是真的“乐行惠施”。这里就说了，什么才是“菩萨乐行惠施”？说，菩萨行无相布施、无染布施就是乐行惠施。

云何菩萨于惠施中深生信解？若诸菩萨不信如来而行布施。

经里边儿还说，什么是“菩萨于惠施中深生信解”？就是说，佛告诉我们修布施有大功德，我们相信佛是真语者、实语者，于是我们就布施，而且坚信我们行了布施会有功德，应该来说这就是“深生信解”。但现在经中说“若诸菩萨不信如来而行布施”是“菩萨于惠施中深生信解”，这可麻烦了～～“不信如来而行布施”这就是秘密言词，就是密意说法。这该怎么理解呢？ 这个不信可以说成不坏信，阿含有四不坏信，就是佛、法、僧、戒，对于佛、法、僧、戒的信心不可破坏，就是因为圣者见到了诸法实相，知道一切法是因缘所生、都是无我的境界，这时他对于佛法的信心是不可破坏的。菩萨知诸法离一切相，此中无佛无众生，无佛可得，无众生可得，这叫“不信如来”。菩萨证悟诸法实相，在诸法实相中发大悲心修行布施波罗蜜，这是“深生信解”――知道“所谓布施，即非布施，是名布施”，布施不可得，这是“不信如来而行布施”。也就是不执著于佛陀的教导而行布施，我是自然而然的布施。正刚法师说是：凡愚信佛，菩萨“以内心深处发出，自得施心，不依他缘。”

云何菩萨于施策励？若诸菩萨于惠施中不自策励。

什么是菩萨“于施策励”？“策”就是警策，自我警策，就是说，我这一阵儿懈怠了，忽然心念一转，我不该懈怠！我得精进！这是“策”。“励”是鼓励，我懈怠了，别人鼓励我说，你不该懈怠，你应该精进，这是“励”。什么是菩萨于施策励呢？经中说“若诸菩萨于惠施中不自策励”！得，又完了，“不自策励”就是“策励”。这该怎么理解？就是因为菩萨证悟真如，断除了悭吝心，没有悭吝心了，就是自然能布施，凡夫是需要策励的，但菩萨不是，他是任运地布施，这就是“于施策励”。这也是秘意说法。

云何菩萨于施耽乐？若诸菩萨无有暂时少有所施。

什么是“于施耽乐”，“耽乐”就是特别好乐，特别喜欢，对于布施特别喜欢，时时要布施，可不是这时心血来潮了布施一次，而是经常的，这是耽乐。我们也有这样的人，虽然自己不是很有钱，但看见可怜人就总是布施一些。现在说什么是“菩萨于施耽乐”？“若诸菩萨无有暂时少有所施”，说，就是菩萨一直布施、无量无边的布施。要布施总得你有财富，你常常布施，那得有多少财富？菩萨因为无量劫的修行，所以他有无穷的财富，他能够一直布施。这一个就是说，为什么菩萨特别喜欢布施？因为菩萨一直在布施，他有很多财富。

云何菩萨其施广大？若诸菩萨于惠施中离娑洛想。

什么是“菩萨其施广大”，说是“诸菩萨于惠施中离娑洛想”，这里的“离娑洛想”，在印顺法师、妙老那儿都是“沙洛”。世亲释234页说，“言娑洛者，显目坚实，密诠流散，今取密义离流散想……”无性释487页给世亲是一样的。用白话说就是，“娑洛”这个词从表面上说是坚实的意思，但实际上这儿用的是秘密义――是表示不坚实的。“于惠施中离娑洛想”的意思就是说，菩萨在布施的时候，心不散乱，是禅定中行布施，所以说“其施广大”。实际上就是说，菩萨在布施的时候，因其是禅定中布施，所以是清净心布施，禅定中观想，这就能施遍一切法界，所以是广大布施。为什么菩萨的布施是广大布施？因为菩萨的布施是在禅定中布施、观想布施。

云何菩萨其施清净？若诸菩萨殟(wen)波陀悭。

什么是“其施清净”？为什么菩萨的布施是清净布施？“若诸菩萨殟波陀悭”，这个“殟波陀”，世亲释中说，“殟波陀者，显目生起，密诠拔足”，就是说，习惯上这个词是生起的意思，一般这么用，但在这儿是拔足的意思，拔足就是脚从淤泥中拔出来了。这一句论文是“若诸菩萨殟波陀悭”，表面上是说菩萨生起了悭吝心的意思，但实际上这儿是密意说菩萨从悭吝心中抽身出来了，消灭了悭吝心。这一句就是说，为什么菩萨的布施是清净的布施？因为菩萨没有悭吝心。

云何菩萨其施究竟？若诸菩萨不住究竟。

为什么说菩萨的布施是究竟的布施？“若诸菩萨不住究竟”，“究竟”在世亲释、无性释中都说是无余涅槃的境界，这一句就是说，象阿罗汉之类也布施，但当到入无余涅槃的时候，阿罗汉就不布施了，现在菩萨可不是这样的，菩萨不住于无余涅槃的境界，菩萨是尽未来际一直行菩萨道，一直布施，一直饶益一切众生的，所以说菩萨的布施是究竟的布施。

云何菩萨其施自在？若诸菩萨于惠施中不自在转。

为什么菩萨的布施是自在布施呢？“若诸菩萨于惠施中不自在转”，这个“不自在转”是指障碍布施的烦恼，也就是种种的分别心，说，菩萨制伏了烦恼、种种的分别心，这些障碍都不能“自在转”了，所以菩萨能够自在地布施。这在世亲释、无性释中的说法是一致的。“不自在转”的“转”就是生起。

云何菩萨其施无尽？若诸菩萨不住无尽。

菩萨的布施是无穷无尽的布施，为什么菩萨的布施是“其施无尽”呢？就是因为“诸菩萨不住无尽”，“不住无尽”的“无尽”世亲释上说“此中无尽，意取涅槃”，所以“不住无尽”就是说，菩萨不住在涅槃里，所以他能一直布施、饶益众生，这就叫“其施无尽”。

如于布施，于戒为初，于慧为后，随其所应当知亦尔。

这是拿布施波罗密多为例来解释了一下，说有十种秘密言词。波罗密多总共有六波罗密多，除了布施波罗密多，还剩五种波罗密多，就是持戒波罗蜜多、忍辱波罗蜜多、精进波罗蜜多、禅定波罗蜜多、般若波罗蜜多，在这剩下的五种波罗密多中，“于戒为初”，持戒波罗密多是第一个，“于慧为后”，般若波罗密多是最后一个。“随其所应当知亦尔”，其他的五个波罗密多都是象布施波罗密多一样，有十种秘密言词。这就是随觉难行，因为佛陀说话可不是好理解的，可能就是反话，所以要“随觉”也不是容易的。这是用六度来解释随觉难行，下边儿用十恶来解释随觉难行。

云何能杀生？若断众生生死流转。

“云何能杀生”，在我们一般的说法中，佛教第一戒就是不杀生，这里却说能杀生，佛为什么这么说呢？他这么说是啥意思呢？是不是说我们可以杀生呢？不是的，佛说的“能杀生”意思是“断众生生死流转”，就是说，佛说的能杀生意思是截断众生生死的流转，让众生不在生死里受生，说这叫“能杀生”，我们要是搞不明白的话，一听见佛说“能杀生”，把“能杀生”理解成可以杀生，这就完蛋了，那我们就在六道中受苦出不来了。

云何不与取？若诸有情无有与者自然摄取。

不与而取就是偷盗。菩萨怎么能够不与取呢？佛这话是什么意思？原来是这样的，“若诸有情无有与者自然摄取”，就是说，菩萨去度化众生，没有人说把众生交给菩萨来度，菩萨主动发大悲心来度化。没有人把众生交与我，我自己要去度化，这就叫“不与取”。菩萨来度我们，我们还拽得不得了，不接受菩萨的度化，要是菩萨不主动来度化众生的话，众生就很难出离生死。“诸有情无有与者”就是众生没有人把自己交给菩萨，“自然摄取”就是菩萨自然来度化众生，这是菩萨大悲心的缘故。

云何欲邪行？若于诸欲了知是邪而修正行。

菩萨怎么能“欲邪行”呢，原来佛的意思是说，“若于诸欲了知是邪而修正行”，就是说，菩萨知道这个淫欲是不对的，所以他不行欲而修正行。也就是说，佛是说“菩萨（知）欲邪（故不为而修正）行”。

云何能妄语？若于妄中能说为妄。

菩萨怎么能说妄语呢？佛这话是什么意思？原来是“于妄中能说为妄”，就是说，菩萨知道一切法是虚妄的，所以告诉我们说这法是虚妄的。也就是说“菩萨能（够）说（虚）妄（的法是虚妄的这样的话）语”。应该这样解释。

云何贝戌(xu)尼？若能常居最胜空住。

“贝戌尼”就是离间语。菩萨怎么能够说“离间语”呢？“若能常居最胜空住”，原来佛说这话是这么一个意思：菩萨是告诉你要与别人保持一定的距离，这个“离间”，可不是挑拨离间。咱们知道，如果两个人太近了的话，不是好事儿，有的人因为太近日久生情，《楞严经》上说“情重则堕”。有的人因为太近了，用孔子的话说，叫“近之则不逊”（论语·阳货）……所以人与人之间一定要保持一个恰当的距离，即使夫妻之间也得允许有自己的社交空间。所以说，佛陀说“贝戌尼”的意思是让人与人之间有一定的距离，让太近的人拉开距离，这个“离间”，“离”就是离开，“间”是空间论。“胜空住”也是这意思――保持一个恰当的距离。

云何波鲁师？若善安住所知彼岸。

“波鲁师”是粗恶语。菩萨怎么能说粗恶语呢？也就是说，佛说波鲁师的含义到底是什么呢？世亲释235页说，“此波鲁师，显目粗恶语，密诠住彼岸，波表彼岸，鲁师表住，今取密义……”中间的这个“显目”的“显”是表现出来，“目”是名称，所以，“显目”就是从表面的名称上来说，前边儿已经说到过好几次“显目”了。这就是说，菩萨怎么能说粗恶语呢？佛这话是什么意思呢？“若善安住所知彼岸”，就是指，如果菩萨能够住在彼岸，那就叫粗恶语。“彼岸”就是涅槃、诸法实相。这一个很奇怪。咱可以用汉语来顺一下：在我们河南方言中，父母太喜欢这个小女儿了，当然这是幼儿的时候，小女儿特别调皮，父亲就会笑着说，“这个瞎闺女”。从字面上来看，“瞎”是坏的意思、表示厌恶，但这儿实际上“瞎”是表示喜欢。两个人吵嘴，甲说乙坏，乙就说甲，“你好～～”这一个“好”实际上表示“坏”的意思。佛经中间也有这样的情况，佛经中说的“波鲁师”粗恶语，实际上是说菩萨已经安住涅槃。是这么个意思。

云何绮间语？若正说法品类差别。

“绮间语”就是咱们平常说的“绮语”――谓乖背真实、巧饰言辞，令人好乐。菩萨怎么能说绮语呢？这里告诉我们说，菩萨的绮语是指“若正说法品类差别”，就是说菩萨用美妙的语言来宣说正法，说各种各样的、不同的佛法，菩萨能够用美妙的言词演说佛法，使众生悟入圣道，这就叫“菩萨绮间语”。

云何能贪欲？若有数数欲自证得无上静虑。

菩萨也有贪欲，“贪欲”的“贪”就是已经有了还想多要、多占，“欲”就是欲界的东西、五欲。菩萨的能贪欲是指啥？“若有数数欲自证得无上静虑”，“数数”就是一次又一次，也就是说，菩萨一次次地想要成就无上静虑，这就是菩萨的贪欲。我一次次地想成佛，这也是菩萨的贪。宣化上人说，我让你们都不要贪，我要贪，我要贪盖一个大庙，让人有地方修学佛法。就是这样。

云何能瞋恚？若于其心能正憎害一切烦恼。

菩萨也有瞋恚？怎么可能！菩萨怎么能有嗔恚心呢？有嗔恚心那还叫菩萨吗？论文中说，“若于其心能正憎害一切烦恼”，原来是这么回事儿，说，菩萨在修止观时，他发现内心里竟然还有烦恼，他就“憎害一切烦恼”，憎恶烦恼恰恰是正念。

云何能邪见？若一切处遍行邪性皆如实见。

一般说的邪见就是指不信因果、不知缘起等，现在说菩萨也有邪见，奇怪了，佛陀这话是什么意思？“若一切处遍行邪性皆如实见”，原来是这么回事儿：菩萨认清了一切邪见。按说，认清了一切邪见就该叫消灭了邪见才对呀～～不过这里佛陀叫它为“（菩萨）能邪见”。“一切处”就是说一切因缘生法的地方，本来一切都是依他起，可是却有了“遍行邪性”，就是遍计执性。本来是依他起性，却被认成了遍计执性，本来一切法都是以阿赖耶识为种子所变现的，你却非执著一切法都是真实的，这就叫“遍行邪性”。

甚深佛法者，云何名为甚深佛法？此中应释：

刚才是从十恶方面来解释随觉难行，现在要从甚深佛法方面来说随觉难行了。也就是从甚深佛法方面来说秘意说法。

谓常住法是诸佛法，以其法身是常住故；

这一句是说，只有常住法才是佛法，这是因为诸佛经无量劫的修行所成就的果报是永久存在的。“常住法”是指什么呢？论文中说是“其法身是常住”。就是说佛所成就的无量功德庄严的法身才是常住的，只有断除一切烦恼以后得证的法身才是常住的，这个才是真佛法。

又断灭法是诸佛法，以一切障永断灭故；

这一句说，断灭法是佛法。怪哉，刚说了常住法是佛法，马上就说，断灭法是佛法，佛说话怎么这样呢？佛陀这话是啥意思？难道是他非要把人搅糊涂他才高兴？这样显得他高明？不是的，佛陀这话是有秘意的。说，这是指“一切障永断灭”，就是说，佛菩萨经过长时期的修行，把所有的烦恼障、所知障都彻底的、永久的断灭了。断二障当然是佛法了。咱们也可以这么说，常住的是佛法、断灭的是佛法，除了断只有常，除了常只有断，现在断、常都是佛法，是不是一切都是佛法？

又生起法是诸佛法，以变化身现生起故；

这一句说“生起法是诸佛法”，生起就是原来没有现在因为因缘就有了、现出来了，这是佛法。这个是指“变化身现生起”，就是说，菩萨因为要度众生，众生在生死中流转，要度什么人就得接近什么人，因为是生死凡夫，你用清净法身来度，这行吗？不行！物以类聚、人以群分，你就得来给生死凡夫作朋友，打成一片，这样才能教化他。于是，佛陀就变化出一个身形，以人的样子来度人，以猪的样子来度猪……现在他这个变化身现出来了，这就是生起法，生起法就指这个。度众生是不是佛法，当然是！所以说“生起法是诸佛法”。

又有所得法是诸佛法，八万四千诸有情行及彼对治皆可得故；

“有所得法是佛法”，啥叫“有所得”？就是可以见闻觉知的法。这儿说的“有所得法”是指的什么？论文中说了，是指“八万四千诸有情行及彼对治”。“八万四千诸有情行”就是一切众生的内心活动，内心活动了有些表现在外的就是身行、语行、意行，也就是三业，实际上就是我们的烦恼。“彼对治”就是佛的变化身来为宣说的对治烦恼行的方法。我们有烦恼行，佛就说法来对治我们的烦恼行。我们的烦恼行是所对治的，佛说的法是能对治的。“皆可得故”，这两方面都是佛法。

又有贪法是诸佛法，自誓摄受有贪有情为己体故；

“有贪法是诸佛法”，我们有贪心，贪心就是染污、苦恼，佛也有贪心，他贪什么？“自誓摄受有贪有情为己体”，“誓”是发誓，发誓一定要怎么怎么地，“摄受”就是引导、利益。根本就没有人来要求佛，是佛自己主动来引导众生的，来度化众生的。“有贪有情”就是我们这些有贪心、有烦恼的人。咱们知道，心、佛、众生，三无差别，这是从体性上说的、从真如方面来说的，佛的真如、众生的真如没有区别，佛说我们凡夫的体性就是他佛的体性。他说他来摄受我们其实是在摄受他自己。我们说有你、我、他的区别，有凡夫与佛的区别，佛不这么看。“（摄）为己体”是指大家在真如上是一体的、是没有分别的。佛度化“有贪众生”，所以他也化现一个“有贪的化身”，这就叫佛也有贪心。

又有瞋法是诸佛法，又有痴法是诸佛法，又异生法是诸佛法，应知亦尔；

贪、嗔、痴三毒是在一起的，所以说了有贪法是诸佛法，只用了一句“应知亦尔”，对嗔、痴没有详细说。所谓“有瞋法是诸佛法”，就是说，佛为了度化我们这些有嗔众生，也得化现出“有嗔众生”的样子来度化我们，这就叫“有嗔法是诸佛法”。瞋就是讨厌、厌离，佛知道众生的本性是清净的，只是被烦恼贼所覆了，所以佛瞋这烦恼贼，就“自誓摄受有瞋有情为己体故”。痴也是这样。还有一个异生法是诸佛法。“异生”就是凡夫有情，因为凡夫众生各有各的见解、各有各的烦恼、各有各的业力、各有各的果报，所以叫“异生”。“异生法是诸佛法”也是“自誓摄受异生有情为己体故。”

又无染法是诸佛法，成满真如一切障垢不能染故；

“无染法是诸佛法”是指诸佛成就了圆满的清净真如，一切障碍、尘垢都不能染污它了。要想染污它，那就得有分别心，但佛是根本智、后得智，没有分别心，所以不能染。

又无污法是诸佛法，生在世间诸世间法不能污故；

染给污一般是放在一起的，这儿给分开了。这是指佛从离一切相的常寂光土，生到流转生死的众生世间来，可是众生世间的法不能污染佛的境界。刚才那个“无染法是佛法”是说佛内心究竟清净，没有烦恼障、所知障的染污；这个“无污法是佛法”是说佛来到世间，世间法不能染污。在清海无上师的说法中，我们本来是佛，我们下来度众生久了，结果我们变成众生了，现在我们修行，就是重新变回佛。

是故说名甚深佛法。

这就是甚深佛法。就是说，秘意说法就是这个。

又能引发修到彼岸，成熟有情，净佛国土，诸佛法故，应知亦是菩萨等持作业差别。

增上心这一段有六种差别，第六种是作业差别，作业差别又分神通业、难行业、四种业，现在该说四种业了，四种业就是佛在三摩地里面能引发出来四种作用。“修到彼岸”，说，菩萨在三摩地里修六到彼岸法门，广度众生。“成熟有情”，这是说菩萨在三摩地里成熟有情，或者是菩萨在三摩地里用种种方便、善巧、神通等去教化众生，成熟众生的善根。“净佛国土”，说，菩萨修种种功德，可以成就一个清净庄严的世界。“诸佛法故”是说，菩萨在三摩地里可以修种种的佛法。“应如亦是菩萨等持作业差别”，应该知道这四种是菩萨三摩地里发出来的不同作用。


增上慧学分第九

戒、定、慧是在一起的，说过了菩萨戒、定比声闻的戒、定殊胜之处，就该说菩萨慧的殊胜了。往下看。

如是已说增上心殊胜，增上慧殊胜云何可见？

“如是已说增上心殊胜”，前面已经说过了菩萨增上心殊胜之处，菩萨增上慧的殊胜又是从哪儿体现的呢？“增上慧殊胜云何可见”？

谓无分别智，

说，菩萨的增上慧就是“无分别智”，我们从无分别智上可以觉察菩萨的增上慧。

若自性，若所依，若因缘，若所缘，若行相，若任持，若助伴，若异熟，若等流，若出离，若至究竟，若加行、无分别、后得胜利，若差别，若无分别、后得譬喻，若无功用作事，若甚深。应知无分别智，名增上慧殊胜。

这是说无分别智有十六相，通过这十六相可以知道无分别智就是菩萨殊胜增上慧。这是说出了名字儿，下边儿再解释。“若自性，若所依……”的这个“若”，是语助。

此中无分别智，离五种相以为自性：

这里先把无分别智的自性给说一下。这里说的自性是指属于自己所有的样子，是自己区别于别人的特征的意思，可不是常住的、恒常的等意思。这儿说的实际上是无分别智的定义。说，无分别智有五种相，就是说，菩萨增上慧无分别智有五种相，这五种相是只属于菩萨增上慧的，是本质性特征。下边儿无著的说法很奇怪，他没有从正面来说，而是从反面来说，因为无分别智是亲证的，没法儿用语言说，所以只好说它不是什么、没有什么。这种方法就是遮诠。

一、离无作意故，

第一个就是说，无分别智不是“无作意”。作意是心所法，就是注意、警觉，我们的心识要现行的时候，必须有作意心所来引导。也就是说，作意是心与境结合的联系者。作意有如理的，有不如理的。我们是凡夫，我们有种种的烦恼，就是不如理作意，我们修行，就是要用佛法正道来引导，让我们的作意如理，如理作意可以节制烦恼。按我们一般的想法，是说，只要我们分别，一定有作意，要是没有作意，分别心就起不来，虽然有各种境界，要是心不动，就没有分别。现在是说无分别智的，无分别智是没有分别的，它没有分别，是不是就是无作意呢？论文中说，“离无作意故”，就是说，无分别智可不是没有作意，无分别智还是有作意的，无分别智有作意也还是无分别智。在237页中世亲举了“睡、醉、闷等”，492页无性举了“熟眠、醉等”，还是一回事儿。就象人睡熟了，或者喝醉了，这时候也是无作意的，如果说无作意是无分别智的话，熟眠、醉、闷就是无分别智了，这显然是不对的。所以，离无作意是无分别智的一个条件。

二、离过有寻有伺地故，

第二个是说，无分别智不是“离有寻有伺”。寻、伺就是对于事理进行由浅而深地推度。也就是观察思惟，浅浅地思惟观察，叫寻；深深地思惟观察，叫伺。这是不是分别心？当然是！我们欲界众生有这样的分别心，初禅天众生也有这样的分别心。但是，要是一超出欲界和初禅天，到二禅以上，那就没有寻、伺。寻、伺也是分别，现在说无分别智，无分别智就是没有分别的，那么，是不是说超过了有寻有伺地就是无分别智呢？不是的！论文中说，“离过有寻有伺地”，就是说过了有寻有伺地，到了二禅、三禅、四禅等，这都是超过了有寻有伺地的，可是，虽然它们无寻无伺，但它们仍是生死凡夫。这无分别智是圣人的境界，所以象二禅、三禅、四禅这样的无寻无伺也不是无分别智。

三、离想受灭寂静故，

第三个是说，无分别智不是“想受灭”。“想受灭”是定的一种，其实就是咱们说的灭尽定，入这种定的时候，想心所、受心所都不现行了。我们知道，想心所、受心所要是活动，就一定有第六意识活动。现在这个“想受灭定”是想心所、受心所灭了，当然第六意识也不起现行了。现在说无分别智，无分别智是没有分别的，那么入想受灭定没有了第六意识等，没有了第六意识就没有分别心了，那么入想受灭定是不是就是无分别智呢？论文说不是，“离想受灭寂静故”，因为灭尽定把想、受心所都制住了，连意识也制住了，意识是心王，这下可好，心王――意识，以及心所――想、受都不现行了！但是无分别智可不是心王、心所不现行，无分别智本身就是心所法――慧，既然有心所，当然就要有心王，灭尽定把心王给灭了，显然它不是无分别智。关于这个想受灭定、灭尽定，应该是小乘三果以上的圣人就可以得，而大乘呢，在宗喀巴大师的《入中论善显密义疏》中说，大乘前五地还不行，但到六地就可以剎那剎那的入灭尽定。还说入灭尽定是真如三昧，这就奇怪了，如果他的说法是对的，那就是无著论师错了。

四、离色自性故，

第四个是说，无分别智不是色自性（样的冥顽不灵）。无分别智是智，既然是智，它就得远离虚妄分别心的境界。好，于是我说，既然它是远离虚妄分别，那么这张桌子，桌子也不会有虚妄分别，桌子是色法，我们以桌子本身来代表色自性，就是说色自性也是无分别的，它是不是就是无分别智呢？这就是有些傻瓜修行修得成了木石之人。最有名的就是禅宗的那个公案：一个老妇人长期供养一个修行人，那一天这老妇人对孙女说，你今天给他送饭的时候上去抱住他，看他说什么。孙女于是在送饭的时候真的这样作了，这个和尚说，“三冬无暖气，枯木倚寒岩”，老妇人就把这和尚给赶走了。这个和尚就是修成了木石，修行人应该是修得有知觉但不执著，可不是修成了无知觉。现在说的就是这个，修行要得无分别智，他竟然说，色自性是无分别的，但色自性的无分别可不是无分别智。也就是说，无分别智是远离这个冥顽不灵的。

五、离于真义异计度故。

第五个是说，无分别智不是“于真义异计度”。我们在开始修行的时候，因为我们现在就说了好久要得无分别智，于是在止观的时候，就会还想得无分别智，因为一直这样想，久了就会出现一个虚幻的无分别的境界、样子，这实际上还是分别出来的，但是你认为这个样子就是无分别。在我们初开始修止观的时候，你的心跑呀跑的，这个你能认清它是有分别，但当到有一定的功夫了，心里没有了跑呀跑，观一切我空、法空，这时候可能你就会想，这大概就是无分别智的境界了吧。这样的想法，实际从本质上说，还是分别，还是计度，就是论文中说的“异计度”。在《唯识三十颂》中说，“现前立少物，谓是唯识性，以有所得故，非实住唯识”。“异计度”就是“现前立少物”的“少物”。在心里边儿变现出一个所缘缘――无分别智，这个所谓的无分别智因为其实是你在止观中变现出来的，所以它根本就不是真的无分别智。真的无分别是没有这个分别的。“于真义异计度”的“真义”就是指真如、无分别智，就是说，对于真如、无分别智没有分别出来的无分别智，真的无分别智是远离这个的。也就是说，对于真如不作异相计度。

离此五相，应知是名无分别智。

没有这五相，就是真的无分别智。这说的是无分别智的自性、定义，这个定义是从反面下的，说离了这五相就是无分别智。主要是因为无分别智不可言说。说过了无分别智的定义，就该说菩萨无分别智比小乘殊胜的地方在哪儿。是通过十六个方面来说的。这十六方面就是十六相，十六相的名目就是刚才说的“若自性、若所依、若因缘、若所缘”等。下边儿一个一个说。无著论师是用了一大堆颂子来说的。

于如所说无分别智成立相中，复说多颂：

菩萨无分别智（就是殊胜增上慧）之所以能够成立的十六相，用多个颂子来解说。

诸菩萨自性 远离五种相

是无分别智 不异计于真

这是解释十六相的第一相：“若自性”。“诸菩萨自性，远离五种相”，菩萨无分别智的自性，是什么样子呢？就是远离刚才说的五种相――不是“无作意”、不是“无寻无伺”、不是“想受灭”、不是“色自性”、不是“于真义异计度”，只要离了这五种相，“是无分别智”，那就是菩萨的无分别智。这菩萨的无分别智离五相里边，最重要的是第五条，“不异计于真”，因为这个“于真义异计度”是修行人修出来的境界，所以最难破除，要是产生了这样的执著，那可不得了。在佛教中讲了不少执著，大都能用辩论破除，但修行人的执著是最难破除的，他老认为这是自己修出来的，是自己亲自经历过的。

诸菩萨所依 非心而是心

是无分别智 非思义种类

这是十六相的第二相：“若所依”。菩萨无分别智的所依是什么呢？我们凡夫内心起分别的时候，有心王、有心所，我们凡夫的所谓智慧就是以心王为依止处。那么圣人呢？他们的无分别智的所依是什么？“诸菩萨所依，非心而是心”，就是说，菩萨无分别智的所依是非心、心，为什么会既是非心又是心呢？下边儿的颂子说，“是无分别智，非思义种类”，说，为什么菩萨无分别智的所依会既是非心而又是心呢，就是因为菩萨的无分别智“非思义种类”。“非思义”是说无分别智的所依“非心”的，“种类”是说无分别智的所依“是心”的。慢慢说。所谓“非心”，就是说无分别智的所依不是心，为什么？“非思义”，“非思义”是什么意思？说，心是思量、分别的意思。我们的心，一与境界接触，他马上就分别，要是不分别它就不是心了。如果无分别智以心为所依的话，那么无分别智就成有分别了。既然是无分别智，要是有分别，那就名不符实了。所以，它一定不能分别。既然它不分别了，分别就是心，所以它是“非心”。“非思义”的“思”就是思惟、思量，“义”就是境界，则“思义”就是对境界进行思惟！能对境界进行思惟、思量的是什么？是心！所以“非思义”就是“非心”。颂子的最后两个字儿是“种类”，“种类”这两个字儿是说“是心”的。说，为什么菩萨无分别智的所依又是心呢？就因为“种类”。“种类”是什么意思？咱们知道，无分别智的成就，就是依于心的，以心为依止去如理作意、努力修行，这样才能成就无分别智，所以它还是得以心为所依。现在颂子中说的“种类”，就是指心，不过是特殊的心，特殊在哪儿呢？你看咱们现在的心，有许多的贪、瞋、痴，但我们经过听闻佛法之后，这个心接受教化了，慢慢地修止观等法门，这样心起了变化，贪、嗔、痴越来越少，终于到了暖、顶、忍、世第一，再往上就到了初地，一到这儿，无分别智出现，心就由世间有漏心成了出世间无漏心。好，现在颂子中说的“种类”就是指，登地后的出世间无漏心与凡夫时的有漏心都是心，是一类的，不同之处是以前是贪瞋痴，现在成了出世间无漏心。现在这“种类”就指这个，说无分别智的所依还是心，不过是出世间无漏心，出世间无漏心也是心，它给以前的有漏心是同类。这样，我们就说无分别智的所依是“非心而是心”。

诸菩萨因缘 有言闻熏习

是无分别智 及如理作意

这是说十六相的第三相“若因缘”。无分别智成就的因缘是什么呢？这个颂子就是说了两个因缘。看颂子中的说法，“诸菩萨因缘，有言闻熏习”，这是第一个条件。佛教说一切法都是因缘所生，没有自然而有这回事儿。菩萨无分别智成就的第一个因缘就是“有言闻熏习”，什么叫“有言闻熏习”？这个“有”就是有，就不是没有；“言”是名言、文字，指佛菩萨的言教；“闻”就是听、听见，指我听见了佛菩萨的言教，或者说是看见了经书，也就是读经典了，多闻了。“有言闻”就强调了有名言，不能是离名言相，一定得有文字相、名言相。就是说得靠佛菩萨的教导。我们凡夫是用名言来说话、来思想的，佛菩萨为我们说法，也是用的名言，而且用的是我们能够理解的名言。佛菩萨用名言说法，我们听闻了，在听闻的当下就在心里熏习了清净种子，这就叫“闻熏习”。这样的闻熏习不是一次就够了的，而是要好多次，所以一般说成“多闻熏习”。这是无分别智成就的第一个条件。只有多闻熏习这一个条件还不够，还得有第二个条件“如理作意”，就是颂子是第四句话。“如理作意”就是正确的思惟，也就是按照佛教的思惟习惯进行思惟，修习止观、修习唯识观、修四寻伺观四如实智等，这都叫如理作意。你就这样努力，就一步步到了暖位、顶位、忍位、世第一位，然后登初欢喜，无分别智成就！所以，佛菩萨无分别智成就的因缘就是多闻熏习、如理作意。

妙老到这儿又多说了一段话，说，我们凡夫分别心多，可能又会提出一个疑问：佛说法是用名言来说法的，我们听佛说法后进行思唯用的还是名言，我们说是修止观，但在修的时候，内心里的作意还是名言……这都是分别心，为什么有分别却能作无分别智的因缘呢？他是这么解释的，说：佛说法用的名言、我们的思惟都是如理的、合乎佛法的，它能破除违反佛法的名言。妙老讲了好半天，实际上妙老的说法有些罗索了，咱们翻到36页，在《入所知相分第四》的第一行就有，“多闻熏习所依，非阿赖耶识所摄，如阿赖耶识成种子；如理作意所摄似法似义而生似所取事有见意言。”这一句话恰恰就回答了妙老说的这个疑问，就是说，我们平时的名言分别是熏习成了阿赖耶识的种子，但多闻熏习、如理作意熏习的却“非阿赖耶所摄”，在29页第二行中说是“最净法界等流性故”，就是说它熏习成了清净法界的种子，清净法界的种子就有消灭阿赖耶里的染污种子的作用。所以说妙老说的疑问是不成问题的。

诸菩萨所缘 不可言法性

是无分别智 无我性真如

这是说十六相的第四相，“若所缘”。菩萨无分别智的所缘境是什么呢？我们凡夫分别心的所缘境是各式各样的，而圣者无分别智的所缘境呢？颂子中说是“不可言法性”，所谓“不可言”，就是指离言说相、没有名言相。“不可言法性”是无分别智的所缘境。就是说，无分别智的所缘境是法性，这个法性是没有名言相的。光说不可言法性，确实挺抽象的，到底什么是“不可言法性”？还真琢磨不着，颂子中又说，“无我性真如”，就是说，所谓“不可言法性”，其实就是“无我性真如”，反过来说，这个“无我性真如”就是“不可言法性”，它是无分别智的所缘境。“无我”咱们知道，就是人无我、法无我，或者说是补特伽罗无我。无我就是说，人我、法我皆不可得，这是佛教的基本观念，用不着在这儿多说。我们来观察人我、法我，发现它们都不可得，这个不可得所显的理性我们一般称之为真如，所以说“无我性真如”，就是说“无我性”就是“真如”。好，说无分别智的所缘是什么呢？是法性、是真如，法性是不可言说的，所以颂子中说“不可言法性”，真如是无我性所显的，所以叫“无我性真如”。

诸菩萨行相 复于所缘中

是无分别智 彼所知无相

这是十六相的第五相：若行相。第四相的所缘是指无分别智的所缘境，这第五相的行相是说能缘的无分别智是啥样儿。“行相”就是心（这里是无分别智）在相上行，“行”就是活动，就是指能缘的无分别智在所缘境真如上活动的相貌，这就是“行相”。菩萨无分别智的行相，颂子中说是“复于所缘中，是无分别智，彼所知无相”。就是说，无分别智在所缘的无我性真如上面的活动是没有一切行相的。无分别智是光明的、是有了别性的，但是它没有相。我们凡夫的分别心，贪的时候有贪相，瞋的时候有瞋相……但无分别智在观察无我性真如时，它是无相的，要是有相就是有分别，它是无分别智，所以是无相的。

相应自性义 所分别非余

字展转相应 是谓相应义

无分别智证悟了无我性真如，他与无我性真如相应的时候，它是离一切相的。奇怪了，它要是离一切相，我们该怎么知道它相应了呢？它为什么要没有行相呢？咱们先看看一般凡夫心里的活动。“相应自性义”，说，我们凡夫的分别就是“相应自性义”，就是说，除了“相应自性义”，是没有别的分别的（即颂子“所分别非余”）。“相应自性义”是什么意思？该怎么个讲法儿？就是第三句颂子，“字展转相应”，所谓“字展转”就是一个字一个字连起来，我们说话的时候，是一个字儿一个字儿说，说话就是内心分别的外现，一个字一个字地连起来就成了名、词，一个名一个名连起来就成了句……名句再展转就与义相应了，名句是能诠显者，“义”是所诠显者。“字展转相应”的“相应”就是指能诠的名句和所诠的义相应。能诠的名与所诠的义相应，它们的相应实际上就显示了我们内心分别的自性、分别的体相。也就是说，我们凡夫分别心的活动，就是名、义的相应。颂子中的“所分别非余”，就是指我们凡夫分别心在境相上的活动，实际上就是名、义，除了这个是没有其他的东西的。这个颂子中出现了三次“相应”，都是指名与义的相应。其中第一句“相应自性义”是根本，第三句、第四句是对第一句颂子中的“相应”进行说明，说第一句颂子中的“相应”是指“字展转相应”，字儿展转的相应才是相应。

非离彼能诠 智于所诠转

非诠不同故 一切不可言

这个颂子是说为什么圣者无分别智离一切相、没有行相。“非离彼能诠，智于所诠转”，就是说，无分别智并不是离开能诠的名而于所诠的义上活动的。能诠的名句和所诠的义是相应的，无分别智也得利用能诠的名句去思惟观察所诠的义。凡夫分别心的活动，得假借能诠的名句在所诠的义上活动，无分别智的分别也是得假借能诠的名句才能在所诠的义上活动的，这就是“非离彼能诠，智于所诠转”。凡夫的分别心要是离开名句、没有名句，它还能活动吗？不能！无分别智也是这样，离了能诠就不能活动了。现在无分别智证悟无我性真如的时候，是没有名句的，没有名句怎么言说？不能言说，所以是不可言法性、法性是不可言。既然无分别智证悟真如没有名句，没有名句就是没有能诠，离了能诠就不能活动，不能活动自然是没有行相的。这就说清了“若行相”颂子中的“彼所知无相”的原因、道理。

下边儿两句颂子说，“非诠不同故，一切不可言”，看这两句颂子。在我们凡夫看来，义（即境）本来就有，只不过要是没有名我们就不知道而已，就象原始森林中有一种果子，我们没有认识到它它也照样存在，就是科学家们常说的，“我们没有认识到的东西还多得很”。佛教说实际情况不是这样的，实际情况应该是我们的思惟假借种种名去分别了，才有种种的义，要是不分别的话，义是没有的。凡夫觉得佛教说的不合理。凡夫非说义本来就有，我们之所以不知道，是因为没有名、句的关系，要是有了名句，我们就知道了、认识了，也就是说义是先有的，你不加名句它也有，加不加名句的不同仅在于你能不能认识而已，你认识它它存在，你不认识它它还存在，它就是一个客观存在！不以你的认识不认识而有所改变。佛教说凡夫的这个说法是不对的。你们明白了没有？凡夫与佛教的说法到底差别在哪儿？这话咱们倒是常说，其实我以前给你们说过的，这是定义的不同，凡夫说法里的“义”与佛教说法里的“义”其实是不一样的，凡夫说法里的“义”实际上说的是依他起，而佛教说的“义”实际上是我执、法执，我执、法执是遍计执。在一直说的时候，只是义呀义的，可能根本就没有顾得上区别二者的语境，在各自话语的语境中“义”是不同的，所以你说他不对，他说你不对。

颂子中的“非诠”，是指能诠的名句并不是决定能诠一切境的。也就是说，一名能诠种种义，一义能有种种名，所以，用名句去诠义的时候，根本是说不准的。也就是说，能诠的名和所诠的义根本是两码事儿。名句与义的不一致就是“非诠不同故”的“不同”。因为用任何的名句都不能恰如其分地表达所诠的义，所以，一切法其实都是不可言说的，这就是“一切不可言”。把玫瑰不叫玫瑰，它也照样芬芳！名与义并不是一一对应的。再说一下，因为有名，所以我们的分别心才能活动，一活动就有了种种的分别，这种种的分别就是义（它是遍计执），所以义与名是相应的，但与依他起是不相应的（义是遍计执），依他起不可言说、圆成实也不可言说，它们是离名言相的。我们借用名句去说种种话、作种种分别，那不能怪法本身，法本身是没有名言相的。

诸菩萨任持 是无分别智

后所得诸行 为进趣增长

这是十六相的第六相：若任持。“诸菩萨任持，是无分别智”，说，菩萨的所有行为，可都不是随便散漫的，它有一个任持者在摄持、加持，任持者就是无分别智。“任持”就是掌舵、主事儿。为什么说无分别智是任持者呢？下边儿说“后所得诸行，为进趣增长”，“后所得”是指后得智。后得智是有分别的，菩萨就是凭后得智去度众生的，菩萨修六波罗密多、作一切功德，都是后得智在干。谁让后得智干的？（根本）无分别智！有根本无分别智、有后得智，你才能够“进趣增长”――进步、前进，慢慢地就到了圆证无上菩提的境界。注意，要是没有无分别智，只凭后得智的话，因为后得智是有分别的，既然有分别，那么，你修布施、持戒等，就是有所得的境界，这布施、持戒就仅只是人天福报，要是有根本无分别智任持的话，就是三轮体空的境界，这就是无相布施、无相持戒，这是无上菩提的资粮。当然，要是没有根本无分别智的话，是不会有后得智的。作一切功德都是这样，因为根本无分别智的任持，所以一切功德都是无相的，这与无我性真如相应，是可以得证无上菩提的。这要是用六波罗密说，就好说了：前五波罗密得有般若波罗密来掌舵。

诸菩萨助伴 说为二种道

是无分别智 五到彼岸性

这是十六相的第七相：若助伴。第六相是说前五波罗密多得有般若波罗密多来掌舵、来领导，这第七相是说般若波罗密多得有前五波罗密多来帮助。“诸菩萨助伴，说为二种道”，菩萨无分别智的成就，得有二种道来帮助，“二种道”就是资粮道、依止道。资粮道是布施、持戒、忍辱、精进四波罗密多，依止道是禅定波罗密多。布施、持戒、忍辱、精进这四波罗密多，要是没有布施波罗蜜多，你就没有福德；要是没有持戒波罗密多，你就要到三恶道去了；要是没有忍辱波罗密多，你会有种种过失；要是没有精进波罗密多，你功德作不来。有了这四波罗密多的资粮，然后再有禅定波罗密多的依止，般若波罗蜜多就增长了，这样就成就了般若波罗蜜多无分别智。

诸菩萨异熟 于佛二会中

是无分别智 由加行证得

十六相的第八相是若异熟。异熟有异时而熟、异性而熟、变异而熟等。我们现在的造作是感得异熟，无分别智的对治有漏果报，得无相的涅槃境界，怎么也是异熟呢？这是说菩萨修学六波罗蜜多，积集福德、智慧的资粮，在还没得无生法忍的时候，心里也还是有一点儿执著，因为执著的关系，所以所作的功德还是有漏的，等到得证无生法忍，有了无分别智的时候，无漏的无分别智般若，加上大悲心，加持以前所作的有漏功德，就能得到殊胜的果报，这个果报就也叫异熟了。这一个颂子说，菩萨在没有成佛的时候，发心精进勇猛修行，菩萨在什么地方得修行的果报呢？“于佛二会中”――在佛陀的两大法会里得果报。佛陀两大法会是啥？变化身法会、受用身法会。变化身法会，是佛为度化这个生死流转的人到人间来示现八相成道而成佛，象释迦牟尼佛就是，这实际上是佛的神通变化。我们凡夫由于业力而来受生，佛来人间受生是神通变化成就的。

佛在人间说法的时候，菩萨可以在这法会中受精进修行的果报。受用身法会是指解脱了分段生死者，他们得证法性身，可以见到受用身佛，受用身法会不是在人间，是在佛的国土里，菩萨也可以在这受用身法会里受精进修行的果报。具体这果报是怎么成就的呢？颂子中说是“由加行证得”，就是说，这果报是由加行的无分别智而成就的，也就是暖、顶、忍、世第一位的菩萨，修唯识观，努力的修行，这时他就在变化身法会里得果报，这是凡夫异熟果所不能比的。或者说，他是已经证得无分别智的菩萨，那么他就在受用身法会里得果报。

诸菩萨等流 于后后生中

是无分别智 自体转增胜

这是十六相的第九相：若等流。“等流”就是前后相似，“等”就是相等、相似。这第九相是说，菩萨们一直精进修行，一直往上走，不会再退转（当然，在八地之前还是有退转的可能的），他的功德、智慧当是在增长这就是等流。菩萨的殊胜等流是“于后后生中，是无分别智，自体转增胜”。就是说，菩萨在前前生中修行得了功德，后后生中的功德是前前生中功德的等流。简单来说，说是初地是二地的因，二地是初地的等流，不过是二地比初地有所进步而已。二地是三地的因，三地是二地的等流，不过比二地有所进步而已。三地、四地，一直往后都是这样的。就是成佛，也是这样：十地是佛地的因，佛地是十地的等流，所以说后后生是前前生的等流。这等流就是无分别智的等流，在等流的过程中，无分别智的智体在逐渐增长。“自体转增胜”的“自体”就是指无分别智，无分别智的自体展转地殊胜、展转地增长。

诸菩萨出离 得成办相应

是无分别智 应知于十地

第十相是：若出离。“出离”就是断除烦恼障、所知障，从这二障中解脱出来。或者说是一步步上进，一直到达究竟圆满的境界，就是得涅槃了、得无上菩提了。菩萨的殊胜出离表现在哪儿？“得成办相应”，就是说，菩萨成就了无分别智，在成就无分别智的当下，就是相应出离了。“成办”就是圆满成就。成就无分别智是在登初地的时候，然后就到二地、三地、四地、五地……这样一直往上，最后把“出离”做圆满了，圆满就是“成办”，初地的时候是“得相应”，圆满是“成办相应”。“是无分别智，应知于十地”，菩萨无分别智的出离过程实际上就是登十地的过程，登初地时是得相应出离，二地、三地、四地……一直向上，到“出离”圆满，就成佛了。

诸菩萨究竟 得清净三身

是无分别智 得最上自在

增上慧第十一相是“若至究竟”。至究竟就是到了究竟圆满的境界。菩萨无分别智到究竟圆满的时候，就“得清净三身”了。“三身”就是法身、报身、化身。或者说成自性身、受用身、变化身。这三身是登初地就有了，不过是到佛地的时候才究竟圆满。菩萨无分别智究竟圆满的时候，不但是得清净三身，还有“得最上自在”――最殊胜的自在力，也就是十自在：寿命自在、心自在、财自在、业自在、生自在、愿自下、信解自在、如意自在、智自在、法自在。寿命自在是说菩萨寿命很长，菩萨是度众生的，寿命长就可以度化更多的众生。心自在是说可以在心里出生甚深三昧而入于深智。财自在是说菩萨庄严一切国土。业自在是说菩萨诸业自在而随时受报。生自在是说菩萨可以自在受生，想到哪个国土就到哪个国土。愿自在是说菩萨可以随愿随时随处成菩提。信解自在是说菩萨在一切世界见诸佛。如意自在是说菩萨可以示现一切大神通。智自在是说菩萨念念示现如来觉悟的十力。法自在是说菩萨可以示现无量无边的法门。这十种自在给六波罗密多配合，如布施成就命自在、心自在、财自在，持戒成就业自在、生自在，忍辱成就信解自在，精进成就愿自在，禅定成就如意自在，般若成就智自在、法自在。十种自在各经典还稍有不同，不过没关系的。

如虚空无染 是无分别智

种种极重恶 由唯信胜解

这是第十二相：若加行无分别后得胜利。就是加行智、无分别智、后得智所得到的胜利，“胜利”就是殊胜的利益。三智中重要是是根本无分别智。这十二相总共有三个颂子，第一个颂子是说加行智的胜利。“如虚空无染”，虚空是明静没有染污的，这里就用虚空来作一个比喻，比喻加行无分别智的功德，不被染法所染污。染污法就是颂子中说的“种种极重恶”――各种各样的罪过，就是十恶，或者说是极重的贪、瞋、痴，当然，要是有极重的贪、瞋、痴，自然造的是十恶。因为造十恶，当然要到三恶道受苦去。但这加行无分别智不受种种的恶法的染污。为什么加行无分别智不受恶法染污呢？“由唯信胜解”，就是因为菩萨对于唯识无义的道理有深刻的信解、深刻的信乐！因为有深刻的信解，所以菩萨三业清净，没有十恶，没有十恶当然就不会被十恶染污！

如虚空无染 是无分别智

解脱一切障 得成办相应

这第二个颂子是说根本智的胜利。还是用虚空来比喻的，说没有什么东西能够障碍虚空。“是无分别智，解脱一切障”，根本无分别智通达一切法空，离一切分别，就是因为它“解脱一切障”，把烦恼障、所知障都解脱了、都清除了。第四句“得成办相应”是说，根本无分别智在初地的时候得相应，到十地、成佛的时候是成办相应，也就是究竟圆满。“得成办相应”就是得相应、成办相应，得相应是初地，成办相应的圆满。

如虚空无染 是无分别智

常行于世间 非世法所染

第三个颂子是说后得智的胜利。还是用虚空来比喻的。“是无分别智，常行于世间”，说，这个后得无分别智是常行于世间的，这是因为菩萨有大悲心，要常在众生的世间弘扬佛法、广度众生。菩萨在世间活动的时候，“非世法所染”，世间的一切染污法都不能染污它，也就是世间八风――利、衰、毁、誉、称、讥、苦、乐都不能染污。

如哑求受义 如哑正受义

如非哑受义 三智譬如是

这是第十三相：若差别。这个“差别”就是指三种智的差别。这第十三相，无著论师是用了四个颂子来说的。这个差别的解释都是用的比喻。“如哑求受义”，比如说有一个哑巴，他要“求受义”――他寻求所受的法义。这是比喻的加行无分别智，说，加行无分别智这个人，他要求证真如，但是还没能证道，因为还没能证道，所以他不会说，他没法说出真如是什么样儿。所以颂子中说“如哑求受义”。“如哑正受义”，这个哑巴希求所受的法义求到了，正在享受，这时候虽然他心里明白，但是口不能说。这是说加行无分别智的人进一步成就了根本无分别智，这根本无分别智就是无我真如，证悟的时候是明了的，但根本无分别智离一切分别，根本没有名言相，不能说，所以颂子中说“如哑正受义”。“如非哑受义”，“非哑”，终于出来了一个不是哑巴的。这个非哑是比喻后得无分别智。这个“非哑”者领受法义了，他又能说出来，就是他能安立种种名言，把他所领受到的法义用善巧的语言给讲出来，引导别人，让别人也明白。这就是说后得无分别智，能反观自己所证悟的真如，并能够安立种种名言，所以颂子中说“如非哑受义”。“三智譬如是”，三智的差别我们可以用这样的一个比喻来说明。

如愚求受义 如愚正受义

如非愚受义 三智譬如是

刚才用一个哑巴来比喻，接着再用一个傻子作比喻。“愚”就是无所了知。“如愚求受义”，这个人有些笨，他要去求法义，不过他还没求到。这是加行无分别智的境界。因为没有求到真如，所以真如到底啥样儿？他没法说。“如愚正受义”，说，他求到了真如，但是因为笨，他不会说。这是根本无分别智证悟真如的时候的境界，离一切分别相。“如非愚受义”，“非愚”，不是傻子，他去求法义，求到了，他可以用善巧的语言表述出来真如到底啥样。这是比喻后得无分别智，能安立种种名言。

如五求受义 如五正受义

如末那受义 三智譬如是

第三个比喻。“如五求受义”的“五”是五识、前五识，眼识、耳识、鼻识、舌识、身识。“如五求受义”是说加行无分别智。这是拿前五识比喻加行无分别智。加行无分别智去寻求他所领受的法义、真如，还没有求到的时候，他不会说，就象前五识不会说话一样。“如五正受义”，前五识去求所受的义，是不会说的，前五识没有名言相，有名言相的是第六识。五识与五境相应的时候，只有个明了性，没有名字。所以，“如五正受义”就是比喻根本无分别智证悟真如的时候是离一切分别相的。“如末那受义”，这个末那是指意识，不是指第七识，末那是意根，所以这儿用来指意识。499页无性释中说，“如末那受义者，譬如意识能受境界，亦能分别。”要是把这个末那当成第七识染污意的话，就不合适了。第六识能安立名言，它会种种分别，这是后得无分别智。

如未解于论 求论受法义

次第譬三智 应知加行等

第四个比喻。“如未解于论”，比如说一个人学佛，他在学的时候，听人家的讲解，但是他还没有明白，还不知道论的真义是什么，这是比喻加行无分别智，说加行无分别智求证真如但还没有得证。第二句是“求论受法义”，要读成“求论、受法、义”。说，这一个学佛人听经典还没有听懂，但是他“求论”――希望能理解这个论（典籍）的真义，这是比喻加行无分别智。“受法”则是指已经得到了法义了。这是比喻根本无分别智的境界。“义”则是说这个学佛人不但明白了法义，而且还能为别人讲解。这是比喻后得无分别智的境界。“次第譬三智”，说，这个“未解于论，求论、受法、义”是按照次第来比喻三种智。比喻哪三种智呢？“应知加行等”，应该知道说的实际上就是加行无分别智、根本无分别智、后得无分别智。“加行”是加行无分别智，“等”是指根本无分别智、后得无分别智。

如人正闭目 是无分别智

即彼复开目 后得智亦尔

这是第十四相：若无分别后得譬喻。这是把根本无分别智和后得智再用比喻说一下。加行无分别智就不说了。“如人正闭目，是无分别智”，眼睛闭上，不看一切法，这就没分别了。这是比喻根本无分别智的境界。根本无分别智就是一切法都无相，没有一点儿的分别。“即彼复开目”，这家伙把眼睁开了，这一下就看见了青黄赤白等，一切法都分明地显现了出来，看见了他就要说，说这暗、那是明，这是长、那是短，这是生死流转、那是生死还灭等。这是比喻后得无分别智。

应知如虚空 是无分别智

于中现色像 后得智亦尔

这是又用了一个比喻来说明根本无分别智、后得无分别智。“应知如虚空”，虚空是清净无染的、是没有分别的，“是无分别智”，这可以比喻根本无分别智，根本无分别智是觉悟真如，也是遍一切处，而且清净无染、离一切分别相的。“于中现色像”，虚空中能现出各种各样的色相差别，“后得智亦尔”，这可以拿来比喻后得无分别智。

如末尼天乐 无思成自事

种种佛事成 常离思亦尔

说，菩萨无分别智与法性相应，离一切分别，最后成就无上菩提。可是他要说法度众，度众生就得适应众生种种的机，这是得有分别的，那么你凭无分别智怎么能利益众生呢？颂子中说，“如末尼天乐，无思成自事”，“末尼”，印度人说有一种宝珠叫末尼珠，用汉语说是如意珠。如意珠能够随主人的心意变现出种种东西，什么都可以，比如说你要衣服、饮食、财宝等，这宝珠都能遂你的心愿。这末尼宝珠是没有分别心的，谁拿住它它就听谁的。“天乐”，传说天人也听音乐，但那乐器是不用有人来奏的，没有演奏的人，它是随顺听者的心愿而发出音乐声。“无思成自事”就是指末尼宝珠自己是没有分别心的，天乐也是没有演奏者的，都是不用思维分别而自己成就的。“种种佛事成，常离思亦尔”，佛陀在无量无边的世界里度化无量无边的众生，为众生演说佛法，也是这样的，“常离思亦尔”，就是说，菩萨度众生也是不用刻意的思惟，就像末尼宝珠、天乐似的，自然在说法度众生，根本就不用进行思维分别。

非于此非余 非智而是智

与境无有异 智成无分别

这是第十六相：若甚深。这是菩萨增上慧无分别智的最后一相，是赞叹菩萨的无分别智非常深奥，当然，赞叹他的深奥也还是从他的所缘境上说的。“非于此”是说无分别智不是在此依他起上作他所缘境的，也就是说，他不缘一切诸行（诸行即有为法）的差别相。“非余”是指它是缘一切有为法的真如无我性，而真如无我性并不是离开有为法而有的。或者说，无分别智的所缘境“非于此”――不是这里的（对应于我们凡夫来说，我们凡夫的所缘境就是这里现前的一切有为法），而是无我性真如。无分别智怎么缘无我性真如呢？就是思惟观察这色、受、想、行、识等都是空、是无我。“非于此、非余”――无分别智的所缘境不是一切有为法，可也不是离开一切有为法。

“非智、而是智”，“智”就是智慧。无分别智能够观察、能够分别、能够思惟，不然的话它就不是智慧了，可它又是“无分别”的，无分别还是智慧吗？颂子中的“非智”是说它不是一般凡夫的智慧；颂子中的“而是智”，是说它是圣人的无分别智。或者给前边儿的“非于此、非余”配合起来，“非于此”是说它不是凡夫的分别，不在一切有为法上去取相分别，“非余”，是说它与第一义谛相应。“非于此其余，非智而是智”是说菩萨增上慧无分别智的相貌，下边儿的“与境无有异，智成为分别”是说无分别智的名称。“与境无有异”，说，菩萨为了使我们能够明白佛理，菩萨就说有能缘的智、有所缘的境。既然用这样的语言来说，也就有能缘的智和所缘的境的不同。可现在这个圣人的无分别智是与境没有差别的，这就叫“与境无有异”。在501页无性释中举例子说，“譬如虚空与虚空中所有光明。”这个比喻满不赖的，就象虚空和太阳的光明一样混在一起，你没法把它分开，这就是“无有异”。“智成无分别”，因为无有异，所以这个智慧是无分别的。就是说真如是离一切分别相，智慧对它是生不出分别相的。这个时候我们就给安立一个名字叫“无分别”。

应知一切法 本性无分别

所分别无故 无分别智无

这个颂子是说无分别的原因。说无分别的原因是本来就是无分别，而不是因为你有“无分别智”去通达它它才是无分别。也就是说，无分别是本具的。“应知一切法，本性无分别”，无分别智是因为我们的修行而成就的，可是无分别智所照见的法性却是本来就是无分别的，所以我们应该知道，遍计所执的一切法是本来就无有的。依他起、圆成实的一切法，它的体性本来就是无分别的。不过依他起我们可以说本来是有差别的，不过因为没有名言，所以不能分别，故而我们也说它无分别。这样一来，遍计所执本来是没有的，因为没有，所以无所谓体性。依他起有差别但没有名言表述，所以我们称无分别。圆成实离一切相、离一切名言，当然无分别。

“所分别无故”，这是一切法本性无分别的理由。说，我们现在有分别心所缘的一切法，这些法实际上是没有的，就是《所知相》那儿说的，因为我们无始以来的熏习，而使我们作种种的分别，我们通达了它的本相，就知道所分别的境界本身是没有的，只是我们的分别心的分别而已。说，我们可以这么理解：在真如上说一切法是没有差别相的。从依他起上说，我们的分别心一活动，就觉得有分别，这不是真实的，是如幻如化的、是空无所有的。

“无分别智无”，说，要是一切法本来无分别，我们的烦恼从哪儿来？没有分别就该没有烦恼，那我们就该是解脱的了～～我们用得着修行吗？根本不用！可我们怎么看也不象解脱者，我们的烦恼多得很！这是为什么？无著论师说，“‘无分别智’无”，就是因为我们没有成就无分别智。我们有佛性，可我们也有烦恼，我们无始以来就有佛性，可我们无始以来也有烦恼。因为我们无始以来就有佛性，所以我们本来无差别，可又因为我们无始以来就有烦恼，所以我们没有无分别智。

此中加行无分别智有三种，谓因缘、引发、数习生差别故。

智有三种：加行无分别智、根本无分别智、后得无分别智。每一种智还可以再分一下，先说加行无分别智。加行无分别智就是在修四寻伺观、四如实智的时候，是为了得证无生法忍而努力修行的，这时他所修学的四寻伺观、四如实智就叫加行智，因为加行智能引生根本无分别智，所以就叫它加行无分别智。这加行无分别智可以分为三种。就是因缘生、引发生、数习生。先看“因缘生”，这既然是加行无分别智，那么其因缘一定得是听闻正法的闻熏习，这听闻是多次的听闻，可不是听一下就够了的。正法咱们知道，那是最净法界等流出来的。听闻正法的闻熏习（即多闻熏习）所得的是清净法界的种子，有了这种子，再加上如理作意，那就可以证悟无生法忍、可以登地了。

再看“引发生”。这是说你在前一生就曾经努力修习过四寻伺观、四如实智，因为你前生就修习过，所以今生加行无分别智就出来了。我说的前生可不一定是这一生是人，下一生是狗的这一前生，它可能是念头的生灭，那么这前生就是前念，因为所谓“生”就是从无到有。这样，“引发”是指过去，这“引发”就是因前一生、过去的引发而生。“数习生”是今生、现在，现在你努力修学佛法，开始修行四寻伺观、四如实智，一直努力、努力、努力，这样呢，加行智也能出现，这叫“数习”。加行无分别智要是“因缘生”，则这个人是利根人，要是“引发生”则是中根人，“数习生”则是钝根人。“差别故”，加行无分别智有这样的差别。

根本无分别智亦有三种，谓喜足、无颠倒、无戏论无分别差别故。

“喜足”说的是凡夫、外道的境界，“无颠倒”说的是二乘的境界，“无戏论”说的是菩萨的境界。凡夫、外道在修行的过程中，比如说得到了四禅八定，他糊涂，他认为这是已经到了最究竟最圆满的地步，他知足了，所以无分别，这就是“喜足无分别”。声闻乘行者在修行的过程中，他修四谛、修四念处，得证罗汉果，这时候没有常乐我净的颠倒分别。把无常当成常的颠倒他们没有、破除了这颠倒相，达到无分别的境界，这叫“无颠倒无分别”。菩萨修止观修成功了，对于一切法都没有名言戏论，达到究竟圆满的境界，这叫“无戏论无分别”。

后得无分别智有五种，谓通达、随念、安立、和合、如意思择差别故。

后得智咱们知道，它是在得了根本之后而有的，是从根本智里边儿出来的。根本无分别智是无分别的，但后得无分别智却是有分别的，因为它是圣者之智，我们一般还是称它为后得无分别智。在根本智通达真如的时候，后得智就起这样的念头：我已经通达真如了！这就叫“通达思择”。第二种是“随念”，说，在根本智通达真如的时候，一定是在定中，后得智与根本智是紧紧相随的，所以也是在定中，但到出定的时候，他又回忆起以前修行的时候，他说我以前总在琢磨真如是什么样儿一个情况，这样的回忆就叫“随念思择”。这个“念”可不是令心于曾习境明记不忘，而是回忆过去。第三是“安立”。后得智为了给别人讲解真如、为了度化众生，就要安立种种的名言，所以这“安立思择”就是安立名言为人讲说。第四是“和合思择”。证见真如也还是得继续修习的呀，要继续修止观，观一切法无相。世亲释、无性释中都说是“谓总相观缘一切法，由此观故，进趣转依，或转依已，重起此观，是故说名和合思择。”总之，这个和合是指后得智把一切法用总念观，就是说，从总体上来考察，把一切法都当成一个整体。最后一个是“如意思择”，这是指从后得智中可以出现种种神通变化。

复有多颂成立如是无分别智：

这是引用经典中的颂子来说明无分别智的，印顺法师、妙老都说是引的《阿毘达磨大乘经》中的颂子。这是说无分别智一定是指一切法无义、唯识无义，只有这样这无分别智才能成立。下边儿是用了六个颂子来成立的，这六个颂子都是说一切法唯识无义，这就可以证明无分别智是正确的。

鬼傍生人天 各随其所应

等事心异故 许义非真实

翻到24页，回头复习一下。在第6行说，“如世尊言，若诸菩萨成就四法，能随悟入一切唯识，都无有义，一者成就相违识相智，如饿鬼旁生及诸天人，同于一事，见彼所识有差别故。二者、成就无所缘识现可得智，如过去未来梦影缘中有所得故。三者、成就应离功用无颠倒智，如有义中能缘义识应无颠倒，不由功用知真实故。四者、成就三种胜智随转妙智，何等为三……”现在57页这“复有多颂”说的给24页这儿说的其实是一回事儿，24页说的是成就四法就觉悟一切唯识无义，57页这儿说的是成就四法就可以知道无分别智无义。下边儿就说这第一个颂子。这第一个颂子就是说相违识相智的。“鬼”是饿鬼，“傍生”就是畜生，猪马牛羊等都是。“人”就是我们这一些。“天”是指天上的人。

“各随其所应，等事心异故”，“等事”就是同一件事儿。说本来是同一件事儿，可是各类众生所见的皆不相同。“心异”就指各类众生的内心不一样，业力不一样，导致所见的相也不一样儿。“各随其所应”是指各道的众生随其所应见而见，皆不相同。人见是水，饿鬼见是脓血。水里的鱼见的是住处，天人见的是七宝。“许义非真实”，所以我们就应该同意“义”（境界）根本不是真实的。这一个颂子就是相违识相智，就是说各类众生所见的是相违的，你看是七宝，我看是清水，是违背的，但我们都认为自己所见的是真实的，其实都不真实。我们所见虽然相违，但同时出现，不相障碍。从这儿我们可以知道唯识无义，这个就叫相违识相智，这是无分别智的第一种。

于过去事等 梦像二影中

虽所缘非实 而境相成就

这是说无所缘所得智的。无所缘就是没有所缘的境界。说，根本就没有所缘的境界，但我们确实是感到有一个所缘的事情。这就是唯识无义的道理，知道了这个道理就叫无所缘所得智。看颂文。“于过去事等”，对于过去了的事情，以及未来的事情。“等”就是指未来的事情。过去的事情已经过去了，过去不就没有了吗？未来的事情呢？未来的事情还没来，当然也是没有的。在我们起心动念的时候，心里就现出一个影像来，就是说，虽然没有事物，但有影像！这个影像是心识自己变现出来的，是心识自己变现出来一个影像作自己的所缘境。好，记住这个：没有事物来作所缘境，而是虚幻的影像来作所缘境的。刚才说的相违识相智证明唯识无义，没有义怎么让识起现行呢？虽然没有义，心识就自己现出一个影像来作所缘境。

“梦像二影中”，过去的事情没有了，未来的事情也没有，不单单是这样，这一句颂子又举了个情况，就是梦。说，梦里边儿的东西是只有一个影像而已，梦里的大老虎根本是没有的。颂子中的“二影”是指除了梦里边儿的情况是影像外，禅定里的情况也是只有影像而已。世亲释、无性释中都说是“三摩地”，三摩地就是定、禅定，禅定里的情况也是影像。这是说，梦中的情况是影像、禅定里的情况也是影像，它们都是因为心里老想这回事儿，也就是思惟观察的缘故，所以就现出你思惟观察的情况的样子。我们可能会说，梦里的情况并不是思惟观察的结果，不，绝对是思惟观察的结果，梦里的情况比较散乱，就说明我们对这些情况并不是专心思惟观察了，而是散乱观察了。定中的情况不乱，就是因为我们专心思惟观察了。不管怎么说，它们不是真实的。后两句说，“虽所缘非实，而境相成就”，就是说，所缘的境界是不真实的，过去的事情、未来的事情是没有了的，你一缘虑就有了影像；梦里的境界也是不真实的、禅定里你思惟缘虑什么事情就现什么，它也是不真实的。它们虽然都不真实，“而境相成就”，但你的分别心里是可以成就一个所缘境的相貌来。

若义义性成 无无分别智

此若无佛果 证得不应理

在24页上说第三种智是“三者成就应离功用无颠倒智”，我们就记成“无倒智”。我们凡夫的分别心所缘虑的境界是错误的，假如说是正确的话，那会怎么样呢？那我们是不是该解脱呢？当然，因为我们正确！正确不解脱难道让错误的解脱不成？可我们现在自己都觉察到自己的烦恼很多，这就说明我们根本没有解脱，可见我们不正确。颂子中说，“若义义性成”，“义”就是境界，实质上是我执、法执。如果说我们现在的心识所缘的境界，其体性是真实的，也就是说我们所缘的境界是正确的，那么就“无无分别智”了，无分别智就没有了，因为我们现在的境界是真实的、正确的，那就成有分别智是正确的，我们现在的有分别智我们自己都知道不对，可你要说它对，既然这是对的，那无分别智当然是不对的了。也就修证不到无分别智了。第三句、第四句颂子说“此若无佛果，证得不应理”，这两句颂子要这样读，“此若无，佛果证得不应理”。就是说，要是没有无分别智，还有佛吗？佛就是圆满无分别智，现在根本没有无分别智，当然也就没有佛了。现在既然已经有人成佛了，就是二千多年前的那位释迦牟尼，也就是说无分别智是可以成就的，所以说我们是不对的。

得自在菩萨 由胜解力故

如欲地等成 得定者亦尔

24页说第四种智是“四者成就三种胜智随转妙智”，我们就记成三种随转妙智。第一种是随自在者智转，第二种是随观察者智转，第三种是随无分别智转。无著论师在这儿用了三个颂子来说三种随转妙智，一个颂子说一种。先看第一种随转妙智――随自在者智转。它又叫境随心变智。这一种智是指“得自在菩萨”的，说，得了大自在的菩萨，它们“由胜解力故”，因为胜解力的缘故……这“胜解力”是在禅定中才有的，这菩萨有胜解力，然后呢，“如欲地等成”，就是说，他想把大地变现成黄金为地，变现成七宝为地，他愿意这样干，就可以成就，随着他的心思而在他的心里变现出来，这是因为我们的大地是虚妄的所以可以转变。这就叫境随心变智。最后一句是“得定者亦尔”，说，其实不是单单菩萨可以，只要是得禅定者，都可以有这境随心变智，这个得定者是指声闻乘的罗汉。到底包括不包括凡夫、外道得禅定者，我也不知道，世亲释251页中说“得定者亦尔者，谓余声闻等”。无性释505页中说，“得定者亦尔者，谓除菩萨馀声闻等”。就是说，世亲释、无性释中都有一个“等”字儿，这就肯定了不是单指声闻罗汉，还有别的，至于别的是指外道还是得禅定的凡夫，那我就不知道了。

成就简择者 有智得定者

思惟一切法 如义皆显现

这是随转妙智的第二种――随观察者智，这个智又叫境随心生智。“成就简择者”的“简择”，就是毗钵舍那，毗钵舍那就是“观”，止观的“观”，止是奢摩他，观是毗钵舍那。“成就简择者”就是指修毗钵舍那修圆满了的人。第二句说是“有智得定者”，“有智”就是菩萨，菩萨有智慧，所以叫“有智”。“得定者”就是指奢摩他修成了的人。“成就简择”了，又“得定”了，这不是毗钵舍那、奢摩他都有了吗？这就是止观双运的菩萨，这些止观双运的菩萨，“思惟一切法，如义皆显现”，就是说，这些菩萨思惟一切法唯识无义，在他心里就生起唯识无义的状况。他思惟一切法无常、无我、空，所以一切法都能在他的心里生起。妙老举例说，他在心里念佛，结果佛就生出来了。这就是境随心生智。“生”是从无到有，而“境随心变智”的“变”，是从有到有、从一种存在形式到另一种存在形式。

无分别智行 诸义皆不现

当知无有义 由此亦无识

这是随转妙智的第三种――随无分别智，又叫境随心灭智。“无分别智行”的“行”是现前，“无分别智行”就是指证得了无分别智，无分别智现前了，在无分别智正现前的时候，就叫“行”。在无分别智现前的时候，“诸义皆不现”――一切似义显现的境界都不现前了。这就是离一切相，是因为你心里不分别的缘故，所以“诸义皆不现”，你要是心里有分别，那就诸义皆现了。“当知无有义，由此亦无识”，所以说，从圣者的角度来看、从无分别智的角度来看，根本就没有“义”――境界。因为“义”没有、所缘的境没有，所以能缘的心识也是没有的。有的是什么呢？有的是“智”，就是转识成智的智！

般若波罗蜜多与无分别智，无有差别，

《大般若经》里说的般若波罗蜜多和这里说的无分别智其实是一回事儿。

如说：菩萨安住般若波罗蜜多非处相应，能于所余波罗蜜多修习圆满。

这是般若经里的话。“菩萨安住般若波罗蜜多非处相应”，就是说，菩萨安住于般若波罗蜜多，他的心没有其它的分别妄想。安住般若波罗密多就没有分别，不会说，我是安住于般若波罗密多上，他没有这样的想法，这其实给安住于实相是一回事儿。实相是没有分别的。“非处相应”是说，安住的般若波罗密多可不是一个地方，不是说有一个地方叫“般若波罗密多”，它是修证到的境界。修到这个境界之后呢？“能于所余波罗蜜多修习圆满”。就是说，当菩萨安住于般若波罗蜜多这个境界的时候，他就同时能够对于其他的布施波罗密多、持戒波罗密多、忍辱波罗密多、精进波罗密多、禅定波罗密多都能修习圆满，都能让它们逐渐增长，直到最后圆满。

云何名为非处相应修习圆满？谓由远离五种处故：

这是要把“非处相应”刻意解释一下，下边儿说了五种处。“处”就是处所、地方。无性释506页上说，“此中可居，故名为处。”“非处相应”就是说，远离了、弃舍了这五个可居的地方，就叫非处相应。下边儿具体解释这五个地方。

一、远离外道我执处故，

这是第一个。说，要“远离外道我执处”，外道也要修学般若波罗蜜多，在宗喀巴大师的理念里，内道与外道的界限是皈依三宝，没皈依的就是外道，皈依的就是内道。而禅宗是说“心外求道，名为外道”。现在我按宗喀巴大师的来说吧。没有皈依的人也是可以修学般若波罗密多的。什么是皈依了的呢？就是得皈依体了的人，没有得皈依体的，那不算皈依，因为他只是念了三遍皈依文而已。外道在修学般若波罗密多的时候，他会有我、我所的执著：我在修习般若波罗蜜多，我也是可以安住在般若波罗蜜多上的。这其实就是一个执著、是一个分别，现在就是说，菩萨要远离这样的分别、执著。外道本来有我执，现在修习佛法，把我执也带进了所学的佛法中。

二、远离未见真如菩萨分别处故，

什么是“远离未见真如菩萨分别处”？“未见真如”是指凡夫菩萨，这些菩萨只是发心修习，还在胜解行地，就是资粮位、加行位的菩萨。这些菩萨要假借名言而进行止观、进行作意，去观察诸法实相、观察唯识无义。在这时候，这些菩萨对真如就进行分别、思惟：真如实际上是不可言说的。这就已经是分别了，他只要分别，就说明了他没有证悟真如、没有安住于般若波罗蜜多。菩萨也要远离这样的分别。

三、远离生死涅槃二边处故，

这个“远离生死涅槃二边处”应该是比较明了的。我们一般都会有这样的执著：生死与涅槃是对立的，生死在这边，涅槃在那边儿，这是水火不容的，凡夫是在生死这边儿流浪，圣者是在涅槃里安住的。现在就是说，菩萨认为这样的看法是一个错误，必须要远离这样的错误看法。

四、远离唯断烦恼障生喜足处故，

小乘人只断烦恼障不断所知障，为什么会这样呢？就是因为烦恼障障碍涅槃，但所知障不障碍涅槃，所知障是障碍得大菩提的。小乘人的目的就是得涅槃的，得到涅槃的境界，他的目的就达到了。所以，他根本不在乎所知障的有无，断除了烦恼障，得到了涅槃他就满足了。现在说作为一个菩萨是要远离这个的。这就叫“唯断烦恼障生喜足处”。

五、远离不顾有情利益安乐住无余依涅槃界处故。

这还是说的小乘人。小乘人断了烦恼障就满足了，菩萨说这不行，这还不算成功，这是因为菩萨大悲心的缘故，他还要顾念众生，要“远离不顾有情利益安乐住无余依涅槃界处”。小乘人对于有情的利益安乐他不关心，菩萨是关心的。小乘人住于无余依涅槃界处就行了，他不度众生，菩萨不是的，他要圆成无上菩提，所以还要继续努力修习。菩萨离五处就叫“非处相应”。

声闻等智与菩萨智有何差别？由五种相应知差别：

声闻智与大乘菩萨的增上慧无分别智有什么不同呢？就是说菩萨增上慧无分别智比声闻智殊胜的地方表现在哪儿呢？具体来说，有五种表现，就是五种相。

一、由无分别差别，谓于五蕴等法无分别故。

菩萨说的无分别给小乘说的无分别不一样，小乘人得涅槃之后，没有了常乐我净的分别，知道我们现在说的都是颠倒，他就离四倒，说这就是无分别了。而大乘菩萨则是“于五蕴等法无分别”，就是说，五蕴、六处、十八界等等都没有分别，甚至佛的境界他也不分别、菩提和涅槃的境界他也无分别，这就比小乘殊胜得多。

二、由非少分差别，谓于通达真如，入一切种所知境界，普为度脱一切有情，非少分故。

这是“由非少分差别”就是说不是一点点的差别，就是多少之分，这里有三种。第一是对于真如的通达程度。菩萨不但通达补特伽罗无我真如，还能通达一切法无我真如，而声闻人只能通达补特伽罗无我真如，这就比菩萨乘少，他只是通达一部分真如，而菩萨是通达全部真如。当然了，不管你们的通达有什么不一样，但真如本身是一样的。第二是“入一切种所知境界”，是说，菩萨能够悟入一切所知的境界，而阿罗汉只能悟入苦、集、灭、道四谛的境界。就是说，阿罗汉没得一切种智，还有很多事情不知道。大菩萨则是通达一切法，这叫“入一切种所知境界”。第三是“普为度脱一切有情”，就是说，大菩萨是度化一切众生的，但阿罗汉则不是，他只度一点儿众生，就是说，你来找我了，我就给你说点儿，你不找我，那我也不找你，而菩萨则是主动去度众生的。

三、由无住差别，谓无住涅槃为所住故。

涅槃有有余依涅槃、无余依涅槃、无住涅槃、自性清净涅槃。菩萨证的是无住涅槃。所谓无住涅槃，是指有智慧不堕生死，有悲心不住涅槃，而声闻罗汉则不是，罗汉证的是有余依涅槃、无余依涅槃。

四、由毕竟差别，谓无余依涅槃界中无断尽故。

这是说，声闻乘成就阿罗汉果，最后入无余依涅槃，这就“所作皆办，不受后有”了。而菩萨不是，“无断尽”是指大悲心不断，没有穷尽的时候，一直度众生不停。

五、由无上差别，谓于此上无有余乘胜过此故。

阿罗汉是声闻乘，上边儿还有缘觉乘、菩萨乘，所以是有上的。而菩萨是无上乘，是最高的，也就是我们说的一佛乘，“谓于此上无有余乘胜过此”，没有比菩萨乘更高的，它是最殊胜的。

此中有颂：

这儿有一个颂子，用颂子说好记。

诸大悲为体 由五相胜智

世出世满中 说此最高远

“诸大悲为体”是说菩萨的无量功德是以大悲心为体。就是说，小乘智和菩萨智比较起来，最重要的区别是大悲心。“由五相胜智，世出世满中”，由于菩萨成就了五种殊胜智，所以是世间、出世间最圆满的，“说此最高远”，所以说菩萨乘是最殊胜的。

若诸菩萨成就如是增上尸罗，增上质多，增上般若功德圆满，于诸财位得大自在，何故现见有诸有情匮乏财位？

前边儿说过了增上戒、增上心、增上慧，下边儿呢，有人提了一个问题，需要解答一下。“若诸菩萨”，如果这些菩萨，他们发菩提心、精进修行，最后成就了殊胜的“增上尸罗”，有摄善法戒、摄律仪戒、摄众生戒。不但成就了增上尸罗，而且成就了“增上质多”，增上质多就是增上心，很多的三昧，象楞严三昧、贤首三昧、虚空三昧等等。还有呢，就是“增上般若”。把增上尸罗、增上质多、增上般若都成就了，这样就是“功德圆满”，三学的功德圆满成就了。“于诸财位得大自在”，菩萨三学圆满成就了，那么菩萨的财富、爵位等显示崇高身份的象征都应该具足才对，应该“得大自在”，随心所欲才对，菩萨既然这样，他要满众生愿，“何故现见有诸有情匮乏财位”？就是说，菩萨有大悲心，他是要帮助众生的，可是我们现在明明地看见有这么多困苦的众生，既缺乏财产，或者是钱，有的连饭也吃不上，有的人连上学的钱也没有，菩萨为什么不来帮助呢？还有些人是想要“位”，就是想当官，可能我不想当，因为我没有资本，我要是现在就是一个县长，我就想升一级，想当个市长，我要是现在是个市长，我就想升成省长，我要是省长，我就会想入阁，甚至当主席，你说现在你是一个处长，你有当主席的心吗？肯定没有。对于这个问题，无著论师下边儿用了五个理由来回答。

见彼有情于诸财位有重业障故；

说，菩萨有大悲心，他是愿意帮助众生解决个财位的匮乏问题，但是众生“于诸财位有重业障”，就是说，你有业力，你不应该受这财位，就是有些人说的，这个人的福太簿，要是给你财位你受不起。为什么你受不起呢？因为自己多生以来悭吝，或者是自己多生以来的嗔心就太重等等的情况，你作这样的心念的话，就该受下贱、少财位的果报，所以，菩萨想帮助你也帮不上你。这就是第一个原因：有情自己的业障太重。

见彼有情若施财位障生善法故；

这是说，众生有业障，但并不是所有的众生都业障重，有些也不重，对于这些人菩萨为什么不帮助呢？因为菩萨“见彼有情若施财位障生善法故”，就是说，这些众生业障不重，菩萨是可以布施给他的，但是，要是菩萨帮助他赚钱了，或者提高官位、名望了，这个人的傲慢心就起来了，看不起别人了，因为傲慢心会障碍善法，所以，菩萨也不帮助他，因为帮助他之后，对他没有利益，反而损害他。这是第二个原因：帮助他反而害了他。

见彼有情若乏财位厌离现前故；

这是说，有人向菩萨祈求的时候，菩萨经过观察，发现这个人“若乏财位，厌离现前”，就是说，菩萨发现这个人没有财位，更容易激起他的厌离心，更容易使他发心修道，也就是说，穷一点儿更好，所以菩萨也不满你的愿。这个咱们知道，有的人没财位的时候会自我安慰，而不知道修道，菩萨这儿说的不是只会自我安慰的人。

见彼有情若施财位即为积集不善法因故；

第二个原因是帮助他会障他生善，这第四个原因是说要是帮助了他，他有了财位之后，不单障碍善法生起，而且会使他造恶，这样的话，菩萨也不会给他财位。

见彼有情若施财位即便作余无量有情损恼因故：

这第五个原因是说，有的人有了财位之后，他会损害众生。对于这些人，菩萨也不会去给他财位的。第四、第二、第五这三条恰恰与三戒印相反，三戒印是止恶、行善、利他，第四条是造恶，第二条是不行善，第五条是损害他人。五个理由说完了，就是说，有这五种情况菩萨是不给你财位的。当然了，要是某个人本来就修福报修智慧，那么他自然有财位，佛菩萨也不会去障碍他得到财位。这就是佛菩萨对财位有大自在，可是不能满众生愿的五个原因。

是故现见有诸有情匮乏财位。

所以说我们能够看见有这么多有情没有财位，祈求菩萨了也没有满愿。

此中有颂：

把这五个理由用颂子再说一遍。

见业障现前 积集损恼故

现有诸有情 不感菩萨施

这个颂子要这样读，“见业、障、现前、积集、损恼故，现有诸有情，不感菩萨施。”“业”就是第一条原因“见彼有情于诸财位有重业障故”，就是因为众生有重的业。“障”是第二条原因“见彼有情若施财位障生善法故”，就是说给你财位了会障你生善。“现前”是第三条原因“见彼有情若乏财位厌离现前故”，没有财位更容易引生你的厌离心。“积集”是指第四条理由“见彼有情若施财位即为积集不善法因故”，你有了财位反而成了积集不善法、造恶的原因。“损恼”是第五条理由“见彼有情若施财位即便作余无量有情损恼因故”，若有财位反而使你损恼有情。“现有诸有情，不感菩萨施”象这样的有情，因为有这五种情况，菩萨是不会来布施给你财位的。


彼果断分第十

这第十的“果断”和第十一的“果智”是修行证果的情况。前边儿讲的都是因地情况。所知依、所知相这两部分，是讲的唯识境。入所知相、彼入因果、彼修差别、增上戒、增上心、增上慧这六部分是说的唯识行。彼果断、彼果智两部分是讲唯识果。这个“果断”主要是说无住涅槃的。咱们看论文。

如是已说增上慧殊胜，彼果断殊胜云何可见？

增上慧的殊胜已经说过了，说菩萨的增上慧不是小乘所能及的。而菩萨的“果断”殊胜之处是在哪儿体现出来的呢？

断谓菩萨无住涅槃，

“彼果断”的“断”字儿是什么意思呢？说，就是指菩萨的无住涅槃。涅槃有自性清净涅槃、有余涅槃、无余涅槃、无住涅槃，菩萨的无住涅槃就是菩萨的无余涅槃。阿罗汉的无余涅槃是他不干了、休息了，而菩萨的无余涅槃是无住、不休息，接着干。

以舍杂染不舍生死二所依止转依为相。

这一句话是总括无住涅槃的体相。“舍杂染不舍生死”，“舍杂染”是指没有烦恼，成就了般若波罗密多，也就是不住生死，有智慧不住生死。“不舍生死”是因为有大悲心，还要度化众生，也就是不住涅槃。“二所依止转依为相”，这个“二”是指遍计所执、圆成实，也有人说成涅槃、生死，这都可以。涅槃就是圆成实，生死就是遍计执。“二所依止”，遍计执、圆成实所依止的就是依他起。我说过的，依他起是一个平台，在依他起这个平台之上安立遍计执、圆成实。“转依为相”，就是给它转变过来，我们老认为遍计执是有的，要把这个错误的观念转变过来，要知道遍计执是根本就没有的，一定要舍弃，圆成实才是实在的，可我们现在以为圆成实是没有的，这观念也得转变过来。这是无住涅槃的相。

此中生死，谓依他起性杂染分；

我们凡夫住在生死里，住在烦恼里，虽然很苦恼，但是仍然是不愿放下的，这就是“住”的意思，也就是爱著、贪著。可是有的众生不是这样，他住在烦恼里，他难受，他就要想办法要解脱，阿罗汉呢，修行成功以后，他不住在生死烦恼里了，他住在涅槃里了，不过是他住在涅槃里不出来了，就是躲起来了。现在说的菩萨不是这样的，他解脱了，不住在生死里，但是也不躲在涅槃里不出来，这个就叫无住涅槃，这个无住涅槃是什么样子呢？在总括相里说是“舍杂染不舍生死”，“舍杂染”是说他已经成就了般若波罗蜜多，从烦恼中解脱出来了，没有了遍计执的杂染。没有杂染是可以入涅槃的，他只要想入涅槃就可以入涅槃。不过现在这些大菩萨他们不，因为有大悲心，所以他们不弃舍生死。

在天台宗中间有一个说法，藏教菩萨是伏惑润生，现在唯识说的不舍生死是什么呢？按一般的说法，不舍生死就是指不舍弃众生，有大悲心要度化众生。严格来说，不是这样的，唯识说的生死，是指“依他起性杂染分”，生死当然是杂染，说，因为阿赖耶识里有杂染种子，他一现行，就出现了种种的执著，我执、法执等，本来是似义显现的，非当成真实的，不知道所面对的一切法其实都是如幻如化的、唯心所现的，因为出现这样的认识，所以你就在生死中流转。这个生死，就是依他起性的杂染那一部份！杂染那一部份就是遍计所执。遍计所执就是似义显现，似义显现的是所遍计，而能遍计则是有无量行相的第六识。能遍计去遍计所遍计，就成就了遍计所执。遍计所执实际上是毕竟空的、是无所有的。这儿注意一下：当我们的虚妄分别起执著的时候，虽然它是毕竟空的，但你的心一动就熏成了种子，这种子就被阿赖耶识摄持，这就是依他起！这里要特别注意：我们的这个依他起，是由遍计执造成的依他起！也就是说，我们实际上根本没有见到依他起，要见到真的依他起，那得登地菩萨才行！现在说的生死，就是指依他起性这个杂染分，也就是说，杂染种子变出来的，还是依他起，可是我们在这上面进行虚妄分别，这是生死。

涅槃谓依他起性清净分：

什么是涅槃？说，涅槃是“依他起性清净分”。刚才说的杂染分，现在说清净分，杂染分是遍计执，清净分则是圆成实性。就是似义显现是毕竟空的，没有能取、所取，没有一切戏论的境界！也就是把遍计执的真面目搞清了，撕下了它的画皮。

二所依止谓通二分依他起性。

总相是说，“舍杂染不舍生死，二所依止转依为相”，有“舍杂染”，我就把什么是杂染说了一下。有一个“不舍生死”，我就把什么是生死说了一下。顺便我还把什么是涅槃说了一下。后边儿还有一个“二所依止转依为相”，我就得把“二所依止”说一下。所谓“二所依止”，就是指生死的依止处、涅槃的依止处。论文中说它是“通二分依他起性”，“通二分”就是既通于生死，又通于涅槃的；或者说是既通于遍计执，又通于圆成实。“通二分”的是谁呢？依他起性！“二所依止”是既是遍计执的依止处，又是圆成实的依止处，这只能是依他起了，依他起是建立遍计执、圆成实的平台。

转依，谓即依他起性对治起时，转舍杂染分，转得清净分。

在总相那句话中还有一个词也得说一下，就是“转依”，所谓转依，是说，在凡夫位的时候，我们凡夫的依他起性（本质上是遍计执）在起对治的时候……注意，怎么对治？就是正闻熏习、如理作意，这样我们就熏习清净法界的种子。啥时候起对治？就是在四加行位，虽然我们现在也可以修止观，但势力太微弱了，可以忽略不计。到加行位的时候，修四寻思观、四如实智，这时候可以对治。

还有一种说法是得无生法忍，就是登初地，这时候无分别智现前，这时候正儿八经的说对治。这就是论文中说的“对治起时”。这两种说法都可以。在“对治起时”，“转舍杂染分”，能对治烦恼障、所知障了。在登初地的时候舍弃分别我执、分别法执。“转得清净分”，把杂染去掉，舍这个就得那个，得到的就是清净的真如。注意，“转依”就是转变依止，唯识三性是以依他起为平台建立的，则依他起就是依止处，我们凡夫的依他起是杂染的，也就是说我们凡夫以为的依他起实际上遍计执，是遍计执造出来的一个依他起，我们现在根本是见不到依他起的，只能见遍计执。现在转依就是把我们的杂染依他起（就是假依他起）转过来，要以净依他起为依止处。

又此转依，略有六种：

彼果断就是讲的无住涅槃，但无住涅槃也不是一下子就得到的，他也有次第。根据情况的不同，有六种差别，我们称为六相。

一、损力益能转，谓由胜解力闻熏习住故，及由有羞耻令诸烦恼少分现行、不现行故。

第一相是“损力益能转”，这是在加行位的情况，或者说是胜解行地。在这时，还没有成就无分别智、没有见到真如，要修四寻伺观、四如实智，在修的时候“损力益能”，“损力”就是减损杂染分的力量、减损我们的执著的能力。你修四寻伺观、四如实智，就能去掉执著、减少染污。“益能”是增益清净的功能、增长无漏戒定慧的功能。不过在这加行位还是带相观空，还有所得，还没有证悟。

“谓由胜解力闻熏习住故”，“谓由胜解力”是说这位发菩提心的菩萨，他对于唯识无义已经有胜解了，有深刻的信解。“闻熏习住故”，这位菩萨的胜解力就是听闻正法而熏习来的，听闻了正法，就熏成了清净法界的种子，这种子住在了阿赖耶识里。“住”有保持不变的意思，就是说，我要一直努力听闻正法、努力修力，不能说我一下子干一下子又不干了，这叫“住”，这里的“闻熏习住”就是要一直听闻正法。

“及由有羞耻令诸烦恼少分现行、不现行故”，说，这位菩萨已经听闻正法了，听过以后你就得如理作意。这个“有羞耻”就是如理作意后生起了惭愧心，知道自己以前的所为不对，说，我要止观，要把以前的错误对治掉。“令诸烦恼少分现行”，因为你有羞耻感，有惭愧心，就要对自己的错误、烦恼采取行动，用四寻伺观、四如实智来修习对治，这样就可以令心里的烦恼小一点，“少分现行”是指还没有对治完，有一些还是会现行的，但有些已经被对治了。下边儿还有一个“不现行”，就是你修止观的力量很大，使烦恼都不现行了。

二、通达转，谓诸菩萨已入大地，于真实非真实、显现不显现现前住故，乃至六地。

“损力益能转”是初发心时的相貌，因为发心努力修行，随着修行功夫的增上，慢慢就转凡成圣了，这就该“通达转”了，就是通达真如了，这是不可思议的无分别圣境。“谓诸菩萨已入大地”，说，这些菩萨已经证得清净法界了，“已入大地”就是已经登地。“于真实非真实、显现不显现现前住故”，这一句话要这样理解，“真实显现现前住故”、“非真实显现现前住故”，当然，也可以说成“真实不显现现前住故”、“非真实不显现现前住故”。“现前住”就是指显现说的，“真实显现现前住”的“真实”是圆成实性，就是一切法寂灭相，说，圆成实在你的清净心里显现了，不但显现，而且安住不动，不是现在显现，过一下又没有了，不是这样的，这叫“现前住”。下边儿的“非真实不显现现前住”，“非真实”指的是似义显现的遍计所执性。在这个时候，不真实的境界不显现了，就是说，在无分别智现前的时候，遍计所执的诸义就都不现前了。但是得注意，因为这时候是刚登初地，所以功夫还不纯熟，只有在你作观的时候，真实才现前、无分别智才现前，你要是这会儿不作止观，非真实的遍计执就又现前了，非真实显现了，真实就不显现了，要是真实显现，非真实就不显现。他们两个不能并存。但不管怎么着，这时候对于真如他是通达的，就是说，虽然有时候遍计执还现前，但只要一提正念，真实立马就显现了。一登地就有这能耐：随时提起正念，立马真实就现前。这种情形从初地到六地都这样，都有间断性。

三、修习转，谓犹有障，一切相不显现，真实显现故，乃至十地。

通达转是见道了，见道后就该修道了。“修习转”就指修道位。按一般的分法，初登地就是见道，见道只有一刹那，随后就是修道位，但在这里说，从初地到六地都是通达转，六地以后到十地是修习转，这是怎么回事儿呢？这是从转依方面来说的，所以这么说，就是说，换了角度了。咱们还是说见道只需一刹那，随后就是修道位。这儿说修习转是从六地后说。这修习转是从六地后的七地开始，一直到十地。“谓犹有障”，在修习转这个境界里，确实是到无相的境界了，圆成实、真实已经能够现不间断地现前了，但他毕竟还不是佛，还有点儿所知障。“一切相不显现，真实显现”，就是遍计执不显现了，圆成实性显现，就是说他能长时期的修止观。从七地到十地的转依都叫修习转。

四、果圆满转，谓永无障，一切相不显现，最清净真实显现，于一切相得自在故。

经过修习之后，终于圆满了，就是“果圆满转”。“谓永无障”，果圆满转的表现有几个，第一就是“永无障”，永远也不会有障碍了，烦恼障、所知障完全清净。“一切相不显现”，一切障都清除了，当然就没有遍计执了。“最清净真实显现”，最清净法界、真如，圆满显现。“于一切相得自在”，得大自在了。

五、下劣转，谓声闻等唯能通达补特伽罗空无我性，一向背生死一向舍生死故。

前边儿四种转是菩萨自己修行成佛。下边儿是大乘和小乘对比。“下劣转”就是说的声闻、缘觉的情况。“谓声闻等唯能通达补特伽罗空无我性”，“声闻等”的“等”就是指的缘觉。说，声闻、缘觉只能悟入人无我，他没有悟入法无我。“一向背生死一向舍生死故”，“一向”是一直、完全；“背”是厌离。“一向背生死”是说他从开始修行的时候，就是一直厌离生死。“一向舍生死”是说他修须行成功之后就舍弃了生死到涅槃的境界里了，然后一直不出来了。

六、广大转，谓诸菩萨兼通达法空无我性，即于生死见为寂静，虽断杂染而不舍故。

这“广大转”是说菩萨的情况。“谓诸菩萨兼通达法空无我性”，菩萨不但通达人无我，同时还能通达法无我。“即于生死见为寂静”，就是生死即涅槃。“虽断杂染而不舍故”，菩萨断了杂染烦恼，但他悲心深重，不舍弃生死中流转的众生。

若诸菩萨住下劣转有何过失？不顾一切有情利益安乐事故，违越一切菩萨法故，与下劣乘同解脱故，是为过失。

“若诸菩萨住下劣转”，菩萨本是广大转，可现在他的菩提心退了，他要住在“下劣转”，就是要入无余涅槃，不再度众生了。这样就有了过失。“不顾一切有情利益安乐事故”，本来菩萨是要度一切众生，你现在不管了，不顾念众生的利益了，不管在六道里流转生死的众生了，只管自己涅槃，这是第一个过失。“违越一切菩萨法故”，这位菩萨在发心的时候是要成佛的，现在他违反了菩萨法，菩萨的大悲心很强，智慧也很大，他要度众生，现在他退失菩提心，这就犯了菩萨戒。这是第二个过失。“与下劣乘同解脱故”，菩萨退心了，就不再是菩萨了，就成了二乘人一样了，得不到无上菩萨。这是第三个过失。

若诸菩萨住广大转有何功德？

菩萨退失菩提心，有以上三个过失。菩萨要是不退失菩提心的话，有什么功德呢？下边儿说有二种功德。

生死法中以自转依为所依止得自在故；

这是第一个功德。菩萨在生死苦恼的境界，“以自转依为所依止”，“自转依”就是大乘法的转依，说菩萨以大乘法的转依作为依此处。大乘法的转依，就是转杂染依他起，而得清净依他起，也就是证悟清净法界，得大自在的。菩萨以这个转依作为依止处，就是无住涅槃的境界，以无住涅槃为所依止。“得自在故”，菩萨的烦恼障、所知障都没有了，内心里达到最极圆满的清净自在境界，这是自利的功德，是自己修行而得到的佛法利益。

于一切趣示现一切有情之身，于最胜生及三乘中，种种调伏方便善巧安立所化诸有情故，是为功德。

“一切趣”就是六道，说，菩萨得了无住涅槃，可以在六道中随意地“示现一切有情之身”――化现一切有情的身相，也就是“应以何身得度者，即现何身而为说法”。他“示现一切有情之身”度众生，希望众生“于最胜生及三乘中”……“最胜生”是六道中最好的境界，就是享天人之福，不到恶道去。“三乘中”就是在出世的声闻乘、缘觉乘、菩萨乘。菩萨教导众生修五戒十善，可以使众生安住在最胜生里，要是教导众生修四谛、十二因缘、六度四摄，就使众生安住在声闻乘、缘觉乘、菩萨乘里。“种种调伏方便善巧”，度众生可不是容易的事儿，你要帮助他，他有时候还讨厌你，有时候他会爱上你，这都不一定，菩萨呢，就用各种各样的方法来教化众生。因为他是菩萨，而且是得了无住涅槃的菩萨，所以他能够善巧地度化众生。

此中有多颂：

下边儿有好几个颂子。

诸凡夫覆真 一向显虚妄

诸菩萨舍妄 一向显真实

这是说转依就是解脱。“诸凡夫覆真”，“覆真”就是真实被掩盖起来了，看不见真实了。这是说我们这些凡夫，因为不肯修习，所以被猪油蒙了心，一真法界的境界被无明烦恼所遮蔽。“一向显虚妄”，我们一直看见的都是虚妄的情景，我们就生活在虚妄之中，在虚妄中受苦。“诸菩萨舍妄”，菩萨断除无明烦恼、断除遍计所执，他弃舍虚妄的情景，他知道内心所分别的境界都是不真实的，都是如梦如幻的，因为知道它们不真实，所以不执著。“一向显真实”，菩萨登地以后就一直是清净法界的境界，是无分别智证悟真如的境界，那是真实不虚的。

应知显不显 真义非真义

转依即解脱 随欲自在行

这第二个颂子正式说转依是解脱。第一、第二这两个颂子是一组。“应知显不显”，我们应该知道，真实义显现了、遍计执的不真实义不显现了，这就叫转依。“真义非真义”，“真义”是依他起性的清净分，“非真义”是依他起里的杂染分。杂染分的依他起经过长期的修行，不再显现了，这时候真义显现，这就叫转依。“转依”就是使依他起的杂染分不再显现，让清净分显现出来，也就是在我们现前的分别心上转染还净。转依要依靠唯识观的修习来完成。转依要是成功了，那么，“即解脱”，就是不可思议的解脱境界，就是把一切烦恼、惑业苦都消灭了。然后你就可以“随欲自在行”――随心所欲地度众生，没有什么可以障碍你。现在你想度众生则障碍很大，人事上的限制、地理环境上的限制等等。到转依成功了的时候则就不一样了。

于生死涅槃 若起平等智

尔时由此证 生死即涅槃

这是第三个颂子，这个颂子和下边儿的第四个颂子是一组，是说无住涅槃的。“于生死涅槃，若起平等智”，咱们知道，生死是杂染的、不自在的，而涅槃是清净的、自在的，它们完全是反个儿的。可是菩萨成就了无分别智，对它们二者产生了平等的认识，觉悟到生死和涅槃其实是不二的。生、死其实是自己内心的分别而已，既然只是内心的分别，那么分别是生的时候根本是没有生可得的，分别是死的时候也没有死可得，都是毕竟空的。“尔时由此证，生死即涅槃”，菩萨有平等智时，就证悟了生死就是涅槃：生死毕竟空，毕竟空就是不生不灭，不生不灭就是涅槃。有些人把它说成生死、涅槃都是内心的分别，分别是生死的时候根本是没有生死可得的，分别是涅槃的时候也没有涅槃可得，这种说法可不是菩萨的说法，一定要知道，那是二乘的“下劣转”，不是菩萨的“广大转”。

由是于生死 非舍非不舍

亦即于涅槃 非得非不得

说，因为生死即涅槃，所以“于生死非舍非不舍”。“非舍”是没有生死可舍，因为生死是毕竟空的，可舍吗？就和二乘说的舍生死不一样，菩萨没有生死可舍，这是法空的缘故。“非不舍”是说，菩萨觉悟了生死即涅槃，知道根本就没有生死的逼迫，既然没有生死的逼迫了，所以还不能说是没有舍，还是舍了的。菩萨觉悟了生死即涅槃，他在生死里度众生，可是没有生死的苦恼，所以是“非不舍”。没有生死可舍，也就没有涅槃可得。没有生死可舍，所以涅槃也就“非得”。生死“非不舍”，则涅槃也就“非不得”。我们觉得是把生死断掉，然后得到涅槃，但得涅槃的人并没有感到有所得。菩萨有智慧不堕生死，有悲心不舍众生，这就是无住涅槃：不住生死、不住涅槃。


彼果智分第十一

如是已说彼果断殊胜，彼果智殊胜云何可见？

前边儿说完了果断――无住涅槃，说无住涅槃可不是小乘可比的。现在说果智――无上菩提、大菩提。菩萨之果智殊胜又表现在哪儿呢？注意：果断是从断烦恼的角度来说的，而果智是从成就圣智的角度来说的。“果断”是断除一切烦恼，从这个角度来说叫断德，“果智”成就无量的智慧，从这个角度来说叫智德。

谓由三种佛身，应知彼果智殊胜：一、由自性身，二、由受用身，三、由变化身。

果智的殊胜这里说了，是成就“三种佛身”。先标出来三身，自性身、受用身、变化身，下边儿说明。

此中自性身者，谓诸如来法身，一切法自在转所依止故。

啥是自性身？“自性”就是本来就有，“身”是可为一切法的依止，就象我们这个身体是器官的依止处一样。“自性身”以真如为自性，它是一切功德法的依止处。成佛得大菩提的自性身是啥？“谓诸如来法身”，说，自性身就是我们常说的法身，法身这个名字的含义是啥？为什么叫法身？“法”指功德法，“身”是依止，合起来就是说：它是一切功德法的依止，所以叫法身。“一切法自在转所依止”，就是指无量无边的功德法，都以自性为依止、以法身为依止。当修得了无分别智的时候，自性就在一切法上生发出大自在的活动、无障碍的活动。

受用身者，谓依法身，种种诸佛众会所显，清净佛土，大乘法乐为所受故。

自性身可以生发出大自在的活动，受用身、变化身能不能由自性身生发？当然能！受用身、变化身本就是法身的一种作用。自性身（法身）这是成佛后的清净境界，是他自己的功德境界，而受用身、变化身则是佛的大悲心广度众生的境界，这是利他的功德。“受用身者，谓依法身，种种诸佛众会所显”，“谓依法身”，原来这受用身是以刚才说的法身为依止，也就是说，受用身是由法身生起的，“种种诸佛众会所显”，“种种诸佛会”是说菩萨成佛之后都要说法度众，当然这里说的可不是象阿含经里释迦牟尼给某个人说法解惑一样，而是象华严法会那样，有无量无边的法身大士来参加法会，来参加这大法会的都是圣位菩萨、法身菩萨，凡夫是参加不了这法会的。参加这法会的菩萨所见到的佛身就是受用身，佛的受用身就是教导这些法身菩萨的。

“种种诸佛众会所显”的“所显”，是指初地、二地、三地乃至十地，他们在大法会中所见到的佛都是不一样的，这是因为他们自己的功德、因缘不同。同在一个屋里，所看见的同一张桌子，也是各见各的面儿，都不一样。这就是说受用身对不同的众生来说所见不同。“清净佛土，大乘法乐为所受故”，法身佛为了度化众生，要用一些不同的方便，比如说他得现不同的身相，还得现出清净的佛土，还得说种种的微妙佛法等。菩萨见到这样的佛，听佛说这样的法，受到种种的法乐……这就叫“受”。菩萨在佛所现出的佛土里可以享用佛现出的一切，这就叫“用”、“受用”。也就是说，佛现出清净佛土、说大乘佛法，让菩萨来享用，也就是说，受用身是法身菩萨所见到的佛。

变化身者，亦依法身，从覩史多天宫现没、受生、受欲、踰城出家、往外道所修诸苦行、证大菩提、转大法轮、入大涅槃故。

而佛的变化身呢？“亦依法身”，也是以法身为依止的。现在我们说的变化身就是示现八相成道的佛，比如说释迦牟尼佛就是变化身。“从覩史多天宫现没”，“覩史多天”就是兜率天，“现没”就是示现不在兜率天了，从兜率天到人间来了。这是八相成道的第一相：降兜率。“受生”，第二相：在人间降生了。“受欲”，第三相：在人间享受五欲。“踰城出家”，悉达多太子在二十九岁这一年的一天夜里，带着车匿越城跑出来出家了。“往外道所修诸苦行”，释迦牟尼刚出家的时候也是到各处参访，著名的有六师外道，释迦牟尼到他们那儿参访。而后到雪山修了六年的苦行。“证大菩提”，释迦牟尼经过六年苦行，发觉不行，因之舍弃苦行，接受牧羊女的供养，到菩提树下禅定，发愿说，若不成道终不起座，夜睹明星而证得无上菩提。“转大法轮”，佛陀成道之后，弘法度众。“入大涅槃”，释迦牟尼佛在八十岁入灭了。这就是八相成道，各处说法稍有不同，有些地方没有参访外道这一相，而有降魔。这关系不大。这变化身是度化凡夫的。

此中说一嗢柁楠颂：

下边儿是分十种情况来解释菩萨果智的殊胜，这儿先用一个颂子来总标。

相证得自在 依止及摄持

差别德甚深 念业明诸佛

这个颂子就是十相，果智这一部分就是用这十相来显示的。这个颂子要读成“相、证得、自在、依止、及摄持、差别、德、甚深、念、业，明诸佛。”后边儿的“明诸佛”是说，就是用前边儿的相、证得、自在等十相来表明诸佛的果智殊胜的。下边儿就具体来解说大乘菩萨的果智十相。

诸佛法身以何为相？应知法身略有五相：

第一相就是“相”。说，诸佛法身的体相什么样儿呢？说，诸佛法身的体相有五种表现。

一、转依为相，谓转灭一切障杂染分依他起性故。转得解脱一切障于法自在转现前清净分依他起性故。

先看第一种表现：转依为相。转依就是从我们现前的分别心里修止观、修六波罗密多等，渐渐地就把烦恼障、所知障等杂染分依他起性破除了。杂染分依他起性就是由内心的执著熏成的烦恼种子。现在要把他们破除。“转灭”就是把这杂染分依他起给破除。在“转灭”的同时还有一得，有一失必有一得，得了啥？得了“解脱一切障”，就是说从一切障中解脱出来，解脱后是什么样子？“于法自在转”！就是心在一切法上都是自在的。我们没有灭除执著，所以我们见到可爱的境界心里就动，看见可恨的境界心里也动，从来就没有自在过，现在你的心自在了。

什么叫“自在”？就是自己愿意咋样儿就咋样儿，不受别人的影响，当然，佛教这是说的内心，指内心不受外界的影响，不受一切法的影响。现在你解脱一切障，就“于法自在转”了，没有什么能够影响你。大自在的境界现前了，没有烦恼的系缚了，那么，就是“现前清净分依他起性”。“清净分依他起性”可以说就是就是清净法界、圆成实性，也可以说是清净依他起，就是无量无边的功德、智慧现前。法身就是这样儿的：远离无量无边的杂染，有无量无边的功德庄严！这就是法身的转依相。

二、白法所成为相，谓六波罗蜜多圆满得十自在故。

第二种相是“白法所成为相”，“白法”就是无漏功德。无漏功德所成就的相就是白法所成相。也就是菩萨在成佛之前所修的六波罗蜜多修圆满了，这样，在成佛的时候就有十种大自在。哪十种自在呢？下边儿分着说一下。

此中寿自在，心自在，众具自在，由施波罗蜜多圆满故。

第一是“寿自在”，就是寿命问题，他想在这儿活多久就活多久。我们凡夫想活但就是活不了，阎王爷来抓，想活短点儿也不行，千古艰难唯一死，死是很难的。这个“寿自在”是指佛的自受用身，是无量寿！第二个是“心自在”，就是指世间一切尘劳杂染不能染污它，伤害不了他。《别译杂阿含·三一九》有象护尊者吓佛的故事，说象护当时是佛的侍者，佛夜里还经行不睡，象护太困了，但是佛教中是师父没睡，弟子不能先回屋睡，象护就想：世尊不睡，我应该想法让他睡。象护就装成一个“薄俱罗鬼”来吓佛，佛说，你可真愚痴，难道你不知道如来是没有一切畏怖吗？佛的心一切时、一切处、一切境界自在。第三个是“众具自在”，“众具”就是财富，要多少有多少。说，这寿自在、心自在、众具自在是由修布施波罗密多而得的。布施有法施、财施、无畏施，法施得寿自在，这是因为法施可以救众生慧命，所以在果上得寿自在。无畏施得心自在，这是因为无畏施是解除众生内心的恐怖的。财施得众具自在。

业自在，生自在，由戒波罗蜜多圆满故。

第四个自在是“业自在”，就是说，成就法身时，身、语、意三业自在。第五个是“生自在”，就是说，佛想到欲界受生就到欲界受生，想到色界受生就到色界受生。凡夫可是不自在的，是随业而流转的，业力使你到哪儿你就得到哪儿，想不去是没门儿的。但佛菩萨是自在的。这业自在、生自在是“由戒波罗蜜多圆满故”，这是因为持戒波罗密多圆满的缘故。因为持戒的人在因地时三业清净，他只作善，所以成佛时得业自在，因为他不作恶，所以在果地得生自在。

胜解自在，由忍波罗蜜多圆满故。

第六种自在是胜解自在。就是说你你内心里的想法特别有力，境界就随着你内心里的想法而现。比如说你内心里想水，因之你看见的就不是咱们看见的桌椅了，而成了水。也就是说，内心胜解可以转境。这个是自己的内心转自己的境，不是你的内心转我的境。在楞严上有月光童子的故事，老和尚作观小和尚看见水，这是错误的。这就是胜解自在，这是因为在因地修忍辱波罗密多而成就的。这是因为在因地修忍辱波罗密，能容忍众生的种种境界，所以感得果地的“外境”随心而转。

愿自在，由精进波罗蜜多圆满故。

第七个自在是愿自在。“胜解自在”是说把已经有的境界随心地转变，而这愿自在则是说，没有的境界随心所欲给现出来、创造出来。这个愿自在是因为在因地修精进波罗密多而成就的。在因地你作一件事儿一定至始至终要作成功，所以到果地就心里想作什么事情就一定成功。

神力自在五通所摄，由静虑波罗蜜多圆满故。

这是第八种自在，是说五种神通都具足了，无障碍了。就是天眼通、天耳通、他心通、神足通、宿命通。这五通是因为在因地修禅定波罗密多而成就的。

智自在，法自在，由般若波罗蜜多圆满故。

第九种自在是智自在，佛的大智慧是自在无碍的，通达一切法、一切众生，世、出世间的一切都通达。第十种自在是法自在，是说佛能够安立无量无边的法门而教化众生。这许多的法门都是佛陀安立的而已。这两种自在是因为因地修般若波罗密多而成就的。

这十种自在是白法所成相。

三、无二为相，谓有无无二为相，由一切法无所有故，空所显相是实有故。

菩萨果智十种殊胜相的第三相是无二相。“二”就是指世间法，因为世间法都是相对的，有长才有短，有大才有小，这就叫“二”。圣者的法身是超越世间的，是没有“二”的。无著论师在论文中说了三种“二”相。第一种是“谓有无无二”，就是既不是有，也不是无。具体来说，就是“由一切法无所有故”，指遍计所执的一切法都是没有的。我们现在觉得这遍计所执法是十分的真实，但佛说众生遍计执的境界是一无所得的。还有一句“空所显相是实有故”，就是说空性所显现的离一切相的境界是真实的。“由一切法无所有故”，所以非有；“空所显相是实有故”，所以非无。

有为无为无二为相，由业、烦恼非所为故，自在示现有为相故。

第二种无二相就是：有为无、无为也无，有为法无、无为法也无。“有为无”就是“由业、烦恼非所为故”，我们一般说的有为法，就是指所有的因缘所生法，而现在这儿说的有为法是指业、烦恼所造的一切法。法身的境界可不是有漏的业和烦恼所造成的，法身是大自在境界，绝对没有染污的业和烦恼的情况，所以叫“有为无”。下边儿一句说，“自在示现有为相故”，就是说，他是能够广度众生的，他不同于二乘人的无为境界。二乘人弃舍了业、烦恼，入无余涅槃了，但佛能自在无碍地示现种种利益众生的事业，现出有为的身相而为说法，所以“无为无”。“由业烦恼非所为故”是不同于世间的有为相，“自在示现有为相故”是不同于二乘的无为相。二乘人入无余涅槃后就不示现有为相了。

异性一性无二为相，由一切佛所依无差别故，无量相续现等觉故。

第三种无二相是：异性无、一性无。“异性”就是事物的彼此差别。“一性”是事物的体性不分彼此。我们觉得，这世间不是异就是一，不是一就是异，现在法身是超越了异、一的。“由一切佛所依无差别故”，这是说不异的，指的是一切佛的无分别智，根本是没有不同的。他们无量无边的功德所依止的清净法界、圆成实性，或者说真如，都是一样的。“无量相续现等觉故”，既然佛与佛没有差别，能不能说根本就没有无量无边的佛、只有一佛呢？不能这么说！这一句“无量相续现等觉故”就是说，佛从最初发心成佛的地方来看，差别还是有的。“相续”就是众生。无量的有情，各有各的因果系统，不相混乱，他们遇上三宝，发心修行，慢慢地成佛了，“现等觉故”，等觉、妙觉是菩萨的果位，马上就成佛了，觉悟诸法实相了，要成佛了，这样来看，就有无量无边的佛，不能只是一位佛。这就是不能说是一性。下边儿还说这个道理。

此中有二颂：

这两个颂子还是说“异性一性无二相”的。

我执不有故 于中无别依

随前能证别 故施设有异

“我执不有故”，说，凡夫是有我执的，因为有这我执，所以就在自己的这个因果系统里一直地相续轮回下去，每一个有情都有他自己的因果系统，但佛是无我的，他没有我执，他有的是无分别智，所以佛与佛之间是无分别的、他与众生也是无分别的。所以说“于中无别依”――在清净法界里没有彼此生命的不同所依，都是无分别的，只有一个清净法身。凡夫因为我执，所以轮回，要是能够修学佛法，到佛的境界时，就没有我执，见一切都是相互融摄的。就是说，没有异性，“异性无”。“随前能证别”，“随”是随顺，“前”是以前，指成佛以前，“能证别”就是修行时各阶段的差别，初地与二地有差别，与三地、四地都是有差别的等，这一句就是说，随顺他以前从作凡夫的时候，一直到转凡成圣，再到十地菩萨等，这还是有差别的。“故施设有异”，所以就安立了各自不同的名号。这是释迦牟尼佛，那是阿弥陀佛，那是药师佛等等的不同。所以，这后两句是指佛与佛在修行时的别愿不同而成就的情况，所以给安立了不同的名号。这种种的名号其实都是施设而已。既然施设了不同的名号，所以就是“一性无”。

种姓异非虚 圆满无初故

无垢依无别 故非一非多

这第二个颂子其实说的给前边儿是一样的，还是说的非一非异，不过是用不同的理由来说的。这里先用四个理由来说“非一”。“种姓异”，这是第一个理由。“种姓”就是指有人是声闻种性，有人是缘觉种性，有人是菩萨种性，这不一样。有的人他就是想成佛，有的人就是想作罗汉，这就是种性不一样的缘故。种性不同，就发心不同，导致修行证果的情况不同。所以佛不是只有一位，有多佛，非一！“非虚”，这是第二个理由。就是没有徒劳的意思，指发了菩提心，培植了很多福德智慧资粮，我们在凡夫位培植资粮很不容易，到八地菩萨以后，那是大自在、无功用行的境界，培植福德、智慧就比较容易了。如果只有一佛的话，我们的辛苦不是就没有意思了吗？我们根本不能成佛，那我们还辛苦什么劲儿～～“非虚”就是说，不，我们的辛苦不会白辛苦，是会成佛的。你只要发心，都是能成佛的。“圆满”是第三个理由。“种姓异”和“非虚”是因地时候的情况，这个“圆满”是成佛以后的情况。成佛以后，佛以三乘法普度一切众生，你是声闻乘我给你说声闻乘法，你是缘觉乘我给你说缘觉法，当然，一般来说，缘觉不用佛给说，但要是能说我也是给说的，你是菩萨乘我就给说菩萨乘法。

佛就是这样教化众生的，如果只有一佛，其他的都不能成佛，佛就不必要用菩萨乘来教化菩萨乘众生了，这样呢，就不是圆满的了，现在说是“圆满”，所以佛是“非一”。“无初故”，这是第四个理由。既然有这么多佛，那么，哪一位是第一个成佛的呢？说没有第一、没有最初。要是有第一的话，在第一的前边儿就该没有佛了，现在说是没有最初的。佛前还有佛，永远推不出个第一来。这四个理由来成立“非一”。下边儿说无多佛，就是“非异”。“无垢依无别”，“无垢依”就是清净法界。佛消除了所有的染污种子，得了究竟清净的无分别智，清净无分别智所依止的平等法性是没有差别的。既然无差别，你能说佛有很多吗？从清净法界上说，释迦牟尼佛与阿弥陀佛等是一样的。这就是“非异”、“异性无”。

四、常住为相，谓真如清净相故，本愿所引故，所应作事无竟期故。

这是说法身以“常住为相”，就是指佛的法身是常住不变的。为什么法身常住呢？下边儿有三个理由。“谓真如清净相故”，这是第一个理由。就是说佛陀无分别智所证悟的是清净真如，所谓“清净”就是没有戏论相，一切的戏论相都是染污的，离一切戏论的清净真如是常住。有为法是生灭变化的，而离一切相的无为法――真如，是没有戏论相的，是常住的，而佛的法身是以真如为体，所以佛的法身是常住而没有生灭变化的。“本愿所引故”，这是第二个理由。“本愿”的“本”，就是最初。说，佛陀最初在发愿的时候，发的就是普度一切众生皆成佛道的愿，因为众生有很多，所以他得尽未来际度。因为他有度众生的愿，众生很多，所以他就得继续存在，这就使得他得常住。所以说“本愿所引故”。“所应作事无竟期故”，这是第三个理由。佛陀要度众生，但度众生这件事儿，是没有终结的一天的，所以他得常住。

五、不可思议为相，谓真如清净自内证故，无有世间喻能喻故，非诸寻思所行处故。

法身有不可思议相，为什么说不可思议呢？有三个理由。“真如清净自内证故”，佛陀无分别智证悟了清净真如，没有证悟清净真如的人，是想不出清净真如的情况的，我们凡夫总是爱揣测，用我们的分别心来思维佛陀的境界，这是思维不到的。这一个“真如清净自内证故”是说，真如不是凡夫的分别心能推测出来的，是要用无分别智才能证悟的，所以对我们来说是不可思议的。“无有世间喻能喻故”，这是第二个理由。说凭世间的比喻是没法来比真如的清净境界的，因为世间的譬喻都是思量的境界，而清净真如是超出思量的境界的，是最究竟圆满的，这是不该去思议的。“非诸寻思所行处故”，这是第三个理由。说，真如的法身境界是无分别智，不是寻思这样的心所，活动的境界，所以不可思议，不能去思惟法身的境界。

十门分别的第一门――相，到这儿就完了。

复次，云何如是法身最初证得？

这是第二门。第一门说佛陀的法身有五相，那么这五相是啥时候、怎么样证得的呢？

谓缘总相大乘法境无分别智及后得智，五相善修，于一切地善集资粮，金刚喻定破灭微细难破障故，此定无间离一切障故得转依。

“谓缘总相大乘法境”，说，无量大乘法门的总相是真如，总相这个真如境界是由“无分别智及后得智”来缘取的。无分别智缘取真如是无相的，后得智缘取真如则是带着真如的相，就是说，后得智是为一切众生说法的。要想得证法身，你必须得修行，修行一共有“五相”，论文中说，得“五相善修”，什么是五相善修？翻回五十页，第一行说，“由五相修，何等为五？谓集总修、无相修、无功用修、炽盛修、无喜足修。如是五修，令诸菩萨成办。”现在说五相善修，就是这个。如果你能五相善修的话，那么就可以证得法身，在欢喜地就证得法身，然后一步步圆满，到成佛的时候究竟圆满，所以我们是把得到圆满无上菩提时的究竟圆满法身叫最初证得（究竟）法身。

“缘总相大乘法境无分别智及后得智”就是五相修里的“集总修”。这一句“于一切地善集资粮”是五修的总说、略说。“于一切地”，就是从从初发心一直到十地，从开始发心一直到十地，不断地“善集资粮”――一直积集福德、智慧资粮。“金刚喻定”是到后边儿的金刚道，在《八识规矩颂》中有一句“金刚道后异熟空”，那里说到了金刚道，金刚道是成佛前的刹那，在那时候可破一切而不被一切所破。金刚道定心成就了，就可以“破灭微细难破障故”，就是说到金刚道的时候，破除一切，不管你是再难破的障碍都统统被一扫而光。“金刚喻定”的“金刚”是不可破坏的意思，它可以破其它一切。得了这样的定，就可以连最微细的所知障、烦恼障的一切种子都破掉。

“此定无间离一切障故得转依”，“此定”就是指金刚喻定，这种定可以破最难破的微细障。“无间”，没有间断、一直地，指一直把一切障都远离，一切障想回来一会儿，是根本没得商量的，想都别想，这个门对它已经堵死了。这样呢，就得了转依。灭除一切障之后，大智慧现前、法身真如圆满出现，这就是转依。刚才你问法身啥时候、怎么样出现，现在就说，在金刚道的时候，破除一切障，真如圆满出现，这时候就证得圆满法身。

复次，法身由几自在而得自在？略由五种：

这是第三门。法身有几种自在呢？简单来说有五种自在。前边儿说过十自在，那是由六波罗密多圆满而得的十自在，那是偏重于因地说的（也就是一般说的转识成智），现在说的五自在，则偏重于果上来说，偏重于果上说就是转五蕴为自在。

一、由佛土、自身相好、无边音声、无见顶相自在，由转色蕴依故。

第一个是佛土自在。佛土是清净微妙的。“自身相好”，首先是佛自身的相好，庄严无比，这是大自在的境界。“自身相好”一般是说三十二相、八十种好。在《中阿含》十一卷中有《三十二相经》（见《大正藏》1册493页上栏－494页中栏），在《大般若经》三百八十一卷中有“三十二大士相，八十种随好”（见《大正藏》6册967页中栏－969页上栏）。《瑜伽师地论》四十九卷也有，都讲到三十二相以及八十随形好。无著论师在这儿举了一个自身相好的例子，他说的这两种相给一般说的三十二相里不一样。

“无边音声、无见顶相自在”，“无边音声”是说佛的音声不可限量，不管你与佛距离多远，只要与佛有缘，佛只要是度化你，不管你在哪儿，佛说的话你都能听到。也就是说，你参加佛陀的法会，你坐在前边儿、坐在后边儿，都听得一样清楚。要是在我们这个地方，远了就听不见了，在佛土里是不会的。《阿含经》里有目犍连尊者试佛的声音到底能传多远的故事，目犍连尊者一直跑到了奇光如来那里，还照样听见释迦牟尼佛的音声。“无见顶相”，就是看不见头顶，为什么看不见头顶，因为他太高大，你得仰视。这佛土自在是怎么成就的呢？“由转色蕴依故”，这是因为佛把有漏的色蕴转依成了无漏圆满的了。

二、由无罪无量广大乐住自在，由转受蕴依故。

第二个自在是乐住自在，这乐住自在是“无罪无量广大”的，“无罪”是说我们凡夫的三受，或者说五受，就是苦、乐、舍、喜、忧，都是有漏的、染污的，成佛时所得的受是无漏的、清净的。而且这“受”是无量广大的。佛有无量的甚深三昧，所以是广大的乐住，没有什么能够破坏。这乐住是怎么成就的呢？“由转受蕴依故”，是因为三大阿僧祇劫的修行，把有漏的受蕴转依了的缘故。

三、由辩说一切名身句身文身自在，由转想蕴依故。

第三个自在是“辩说一切名身句身文身自在”，名身、句身、文身是《百法明门论》中的内容。一个一个的名字，由名词组成一个一个句子，由句子组成一篇文章。“身”就是由众多聚集起来的意思。“辩说一切名身句身文身自在”就是说佛的法身为一切众生说法的时候，也能用名身、句身、文身进行辩说，也能假借名句文来表达佛法。这种自在是怎么成就的呢？“由转想蕴依故”，凡夫的想蕴是有漏的，佛陀的想蕴是无漏的，有漏的想漏转成无漏的了，这就成就了这种自在。

四、由现化、变易、引摄大众、引摄白法自在，由转行蕴依故。

刚才说过了色蕴、受蕴、想蕴转依后的自在，这是行蕴转依后得的自在。行蕴转依的自在有这么一些：现化自在、变易自在、引摄大众自在、引摄白法自在等。“现化自在”是指佛因为内心的自在而显现出种种的神变，无障无碍。“变易自在”是指能转变一切境界，能把水变成火，能把砖瓦变成宝贝，孙悟空有七十二般变化，佛有无量变化。“引摄大众自在”是指佛陀能善巧说法，引导众生趣向无上菩提。“引摄白法自在”指佛能引摄出无量无边的清净功德。这现化自在、变易自在、引摄大众自在、引摄白法自在，都是因为把转变了有漏行蕴的关系。

五、由圆镜、平等、观察、成所作智自在，由转识蕴依故。

第五种自在是四智自在。就是转第八识成大圆镜智，转末那识成平等性智，转第六识成妙观察智，转前五识成成所作智。翻到世亲释267页看第一行，“此中大圆镜智者，谓无忘失法，所知境界虽不现前，亦能记了，如善习诵书论光明。”再翻到无性释524页看第三行，“当知此中，转阿赖耶识故得大圆镜智，虽所识境不现在前，而能不忘，不限时处，于一切境，常不愚迷……”这两种解释差不多是一样的，就是说大圆镜智是不忘失法，我们现在干什么都老忘记，一段时间不用就忘了，但佛不会。大圆镜智是平等性智、妙观察智、成所作智的依止处，要是没有大圆镜智，其他三智就没有。我们凡夫的根身器界是由第八识现的，成佛时就由大圆镜智现出来根身器界。在凡夫的时候，由阿赖耶识摄持一切惑业苦的种子，成佛了以后，一切无漏的闻熏习的种子都摄持在大圆镜智里了。然后看“平等性智”。说，末那识在因位的时候执著自我、四烦恼常俱，所以不平等，到成佛的时候，（其实是到登初地的时候）出现平等性智。觉知一切众生心性平等、一切菩萨心性平等。第三是转第六识成“妙观察智”。妙观察智就是成佛的时候，能够随心的作意现出种种三昧、种种智慧，为一切众生宣说佛法。第四是“成所作智”，就是说佛陀一切都圆满了，所愿皆成，成就了所应该作的一切事情，教化一切众生。

复次，法身由几种处应知依止？略由三处：

这是十门分别的第四门，依止门。“法身”就是法的依止处，法身可以作什么的所依呢？就是说，有多少境界得依止法身呢？ 简单来说，有三种境界依止法身。

一、由种种佛住依止，

说，种种的佛住要依止法身才行。“佛住”就是说成佛以后，他因为要度化众生而不入无余涅槃，他既然不入无余涅槃，那么他就得有可住之处，他就得依法身而住。在世亲释267页说，“由种种佛住依止者，谓佛安住圣住、天住、及与梵住，故言种种，法身为此诸住所依，是故说名佛住所依。”525页无性释中说，“由种种佛住依止者，由诸如来所得法身，与所安住种种天住、圣住、梵住为所依止。诸天住中，如来多住第四静虑；诸圣住中，如来多住空解脱门；诸梵住中，多住其悲。如是种种如来所住。”无著的论文说得不很清楚，但世亲、无性的解释就清楚得多了。天住是指色界四静虑，佛心就住在四静虑里。梵住就是慈悲喜舍四无量心，佛心住在悲无量心里，这样他才度众生，没有悲怎么度众生？圣住就是空、无相、无愿三解脱门，佛心住在空解脱门这里，这样离一切相。这圣住的空住其实就是无相的大涅槃，而天住的第四静虑和梵住的悲无量心则是有相的，这是度众生的，这样呢，佛就是不住生死，不住涅槃，这是无住涅槃的境界。这三种住都以法身为依止。

此中有二颂：

这儿有两个颂子。这两个颂子是说佛住的无住涅槃与声闻、缘觉的涅槃不一样的地方。世亲释中说是“为显诸佛解脱殊胜，说二伽陀”。

诸佛证得五性喜 皆由等证自界故

离喜都由不证此 故求喜者应等证

第一句说，“诸佛证得五性喜”，就是说诸佛成就了五种不同的欢喜，为什么有这五种喜呢？“皆由等证自界故”，就是因为诸佛证悟了一真法界了。“自界”的“自”是遍于一切、特别广大的，什么东西遍于一切呢？当然是清净法界。因为佛证悟了一真法界，所以成就了五种欢喜。“离喜都由不证此”，“离喜”就是没有这五种欢喜，就是指声闻、缘觉，他们没有这五种欢喜。为什么他们没有这五种欢喜呢？“都由不证此”，完全是因为他们没有证悟清净法界。“故求喜者应等证”，所以说，要是想成就这五种喜，你就得努力去修证无上菩提、证悟一真法界。

由能无量及事成 法味义德俱圆满

得喜最胜无过失 诸佛见常无尽故

五种喜到底是哪五种喜？能无量、事成、法味、义、德，就是这五喜。“能无量”是指一真法界的功能是无量无边的，证悟了一真法界的佛，觉察到有这么多的能，有大欢喜，所以这是一喜。“事成”的“事”，就是所作的事情；“事成”就是说他所作的事情――度化众生，一定能成功，虽然有情无量无边，佛菩萨誓度之，佛菩萨知道这件事一定能成功，有大欢喜，所以这是第二喜。“法味”的“法”，就是佛教化众生所说的十二分教，这语言文字所表述的佛法，是最清净法界的正等流。佛菩萨证悟一真法界，觉得法味特别殊胜。这“法味”是以语言文字的佛法为缘而修行达到离文字第一义谛时，有大欢喜，这是第三喜。“义”是指经典所诠之义，经典有无量的义，佛菩萨随心想要某个法门某个法门就现出，所以有大欢喜，这是第四喜。在无性释中还有一句话，“复有说言，义谓涅槃”，要是指涅槃当然这也是一喜了。“德”，指证悟了一真法界，成就无量的功德，有大欢喜，这是第五喜。把“能无量、事成、法味、义、德”作为五喜，是无性释中的说法。世亲释中稍微有点儿不一样，世亲释中是把“义”和“德”合起来算成一种喜，而把下一句颂子“得喜最胜无过失”说成第五喜。“得喜最胜无过失”就是指成就了前边儿的“喜”（按无性说是已经五种了，按世亲说则是四种），这喜是最殊胜的，不是世间以及二乘所能及。“无过失”就是说这喜不会引起烦恼障、所知障的污染，是最极清净的喜。按世亲的说法，这是第五喜――因为前四喜而喜。我们现在要是有喜的话，会因喜而造业，就是咱们说的得意忘形。球迷因为打球输了而闹事，打球赢了也闹事儿。最后一句是“诸佛见常无尽故”，就是说，佛大悲心不入无余涅槃，他见到的这五种喜是一直地相续下去没有穷尽的。

二、由种种受用身依止，但为成熟诸菩萨故。

刚才说的是种种佛住依止法身，这是说“种种受用身依止”法身。“受用身”是法身大土所见到的佛身。但一般情况下，我们说受用有两种受用，一种是自受用，就是法身，第二种受用是他受用。他受用就是被法身大士所受用，也就是度化法身大士。受用身有很多种的不同，十地菩萨所见皆不相同。初地所见的与二地所见的就不一样，与三地所见的也不一样。观音菩萨所见的与文殊菩萨所见的也不一样，别看他们都是早已成佛的，这就象咱们同坐在一个屋里，也都是凡夫众生，但所看见的这张桌子也不一样，你看见的是那个边儿，我看见的是这个角。这受用身也得依止法身而有，他是法身示现出来的。法身显示受用身出来是干吗的？“但为成熟诸菩萨故”，说，显示受用身出来只是为了度化诸菩萨的。地上菩萨虽然也得了法身，但功德还没有圆满，还要依靠佛的教导，这时就由受用身佛来给说法，来成熟地上菩萨的修行。

三、由种种变化身依止，多为成熟声闻等故。

第三，种种的变化身也要依止法身。变化身也是各式各样的，变化身是凡夫见到的佛。法身佛示现变化身佛出来干吗的？“多为成熟声闻等故”，说，变化身大多是为了度化二乘人的，就是说，为凡夫培植声闻、辟支佛的善根，当然，也可以给有的众生培植成佛的善根。佛为了成熟这些人所以示现变化身。无著论师在论文中用了一个“多为”成熟声闻等故，就是指还有一少部分是成佛的。这样就说了三种依法身的情况：种种住、受用身、变化身。

应知法身由几佛法之所摄持？略由六种：

这是十门分别的第五门：摄持门。法身容含多少佛法？“摄持”就是容含、含摄等意思，也就是说，有多少佛法组成法身？由多少功德聚成法身？法身就是由功德聚在一块儿成就的。法身不是只有平等法性，还有很多功德。这里说了六种佛法功德。

一、由清净，谓转阿赖耶识得法身故。

六种佛法的第一种是清净佛法，这里说的清净佛法是指啥？“谓转阿赖耶识得法身故”，说，就是弃舍了阿赖耶识里的有漏种子，得到无分别智，证悟清净真如，就有了无量功德庄严的法身。一般说是转识成智，但这里说是转识得法身，法身通常是指平等法性说的，这就是说平等法性和大圆镜智是一回事儿，从真常不变的理性上说，叫它平等法性，从其大智慧光明来说，叫它大圆镜智。注意，平等法性是每一位佛都平等，都无差别。窥基法师说，当来下生弥勒佛就是释迦牟尼佛。释迦牟尼佛说，“我昔曾于彼时彼分，即名胜观正等觉者”――我释迦牟尼就是过去的毗婆尸佛。就是这个意思。

二、由异熟，谓转色根得异熟智故。

第二种佛法是异熟。异熟有异时而熟、异类而熟、变异而熟。“由异熟”是指法身是纯净无漏的，不是世间有漏的境界。虽然在世间修行时是有漏的，但到成佛时是无漏的，这是发生了变异，这主要是说异熟的变异而熟这个意思。“谓转色根得异熟智故”，“色根”就是前五根。在我们成佛时，就“转”色根――把色根给舍弃了，而后就“得异熟智”，成就了异熟的智慧。我们凡夫这个身体是由五根组成的，是物质性的，到成佛时弃舍色根，得异熟智，就是说，佛是以智为身！这样咱们就知道了，法身佛是没有色相的、没有形相的。所知相那儿说十一识，里边儿就说到，身也是识的所现。

三、由安住，谓转欲行等住得无量智住故。

第三种佛法是安住。“安住”是啥意思？论文中说了，“谓转欲行等住得无量智住”，其中这个“欲行等住”的“欲”是欲界，“行”就是活动，主要是指心的活动，“欲行”就是心在欲界活动，因为心在欲界活动，所以你就在欲界受报，你就是欲界众生。因为心里有欲望，所以你造业，所以你受苦，这是一连串儿的。“欲行等住”就是欲行住、色行住、无色行住，心在欲界活动就是欲行住，心在色界活动就是色行住，心在无色界活动就是无色行住。那个“等”字儿就是色行、无色行。众生在“欲行等住”就是在三界里流转，就有很多的烦恼，因而不能出离。好，现在好了，成佛了，就“转欲行等住”而成“无量智住”了，那个“转”是舍弃，以前我说过，“转”是生起，但在这儿是舍弃的意思。“转欲行等住”就是舍弃了三界的情况，得到的那个“无量智住”是咋回事儿呢？“无量智”就是不可思议的大智慧境界，各种各样的智慧都有了。

四、由自在，谓转种种摄受业自在，得一切世界无碍神通智自在故。

第四种佛法是“自在”。说，“转种种摄受业自在”，“摄受业”的“摄受”就是积聚，比如说积聚财富来享受，现在是“摄受业”，就是积聚了些业来受报。这个“摄受业自在”的“自在”可不是得大自在的那个自在，而是存在、生存的意思，比如说你要是不能积聚一定的资财，你就没法子生活，不能生存下去，比如说你是一个律师，你要是业务不好，你就没有生意，你律师就当不成了，所以，这个自在应该是“业务熟练”、过得舒服的意思。现在成佛了，就不是这样了，不在这上面自在了，要“转种种摄受业自在”，而“得一切世界无碍神通智自在”，就是说，成佛之后，成就无碍的神通，大自在的神通，到一切地方去救度众生都没有关系。佛陀的这“自在”才是真的自在。

五、由言说，谓转一切见闻觉知言说戏论，得令一切有情心喜辩说智自在故。

第五种佛法是“言说”，就是语言、思维。我们的言说是从哪儿来的？就是从一切的见闻觉知而来的，从见闻觉知而来的言说，都是虚妄的，实际上根本就是戏论，在凡夫的时候就是这样。现在成佛了，就要把这样的戏论给舍弃，只要舍弃了这个，就可以“得令一切有情心喜辩说智自在”，什么意思？就是说，佛有无障碍的微妙辩才，佛有自在地演说这微妙佛法的智慧，他能在没有三宝的地方建立三宝、成立佛教、教化众生，能令众生离苦得乐了。因为众生有见闻觉知的言说，佛菩萨就也善巧地设立这样的言说。

六、由拔济，谓转拔济一切灾横过失，得拔济一切有情一切灾横过失智故。

第六种佛法是“拔济”，这是佛的慈悲境界。论文说，“转拔济一切灾横过失”。说，我们虽然是凡夫，我们生在娑婆世界，有言，“业不重不生娑婆”，但我们也不是连一点儿的好事也不作，我们有时候也是会作一点儿的好事的，那么，这就是“拔济一切灾横过失”。现在成佛了，就把在凡夫时候作好事儿的不净心舍弃，就是说，在我们凡夫作好事儿时，会想，这是我在作好事儿，现在成佛了，这心就要舍弃，不要想这是我在作好事儿，你要把这当成一种自然的反应而已。“转拔济一切灾横过失”的“转”是舍弃，舍弃这个之后会怎么样呢？说，你会得“拔济一切有情一切灾横过失智”，这是一种智慧。王恩洋的解释更通俗，说我们的不如意有很多，这不如意就是“灾横过失”，比如说，你冷、你热等，现在你有智慧，你可以作出棉衣、造出空调，这就叫“拔济一切灾横过失”。比如说有病了，你可以给治好，这也是“拔济一切灾横过失”。但是，我们凡夫在作这些事儿的时候心不清净，所以要“转”，就是舍弃不清净心。成佛后就得“拔济一切有情一切灾横过失智”，就是把心念调清净了。

应知法身由此所说六种佛法之所摄持。

这是一句总结。说，法身就是这六种佛法组成的、成就的。

诸佛法身当言有异？当言无异？

接着这是十门分别的第六门：差别门。就是说，诸佛的法身是有异还是无异呢？

依止、意乐、业无别故，当言无异。无量依身现等觉故，当言有异。

说，这要看你从哪个角度来说了，要是按依止、意乐、业这些方面来说，就是无差别的，要是按无量依身这方面来说的话，那就是有异。论文中是“依止、意乐、业无别”，意思就是依止无差别、意乐无差别、业无差别。所谓“依止”就是指真如，因为一切佛都是以真如为依止处，所以，从真如这一方面来看，一切佛是无差别的。“意乐”，最通俗的说，意乐就是心里高兴。这是指佛的意愿都是清净无漏的，都是要利益一切有情的，从这点儿上来说，佛与佛之间没有差别。“业”就是所作的事儿（以及其影响），佛作的都是利益众生的事儿，从这点儿来说，佛与佛也是没有差别的。所以，从这三方面来说，“当言无异”，佛的法身是无差别。“无量依身现等觉故，当言有异”，这是换了角度了。说，每一位佛，最初都是凡夫，他们在凡夫时发了菩提心，每一位凡夫都是一个完整的因果系统、生死系统，各有各的生命。论文中的“依身”就是指所依的身体，身体各不相同，无量无边，经过修习，逐渐地成功了，“现等觉”――得无上菩提了。要是从这一方面来说，还是有差别的，所以不能说无异，“当言有异”。

如说佛法身，受用身亦尔，

对于佛的法身这样说了，对于受用身，也这样说。

意乐及业无差别故当言无异；

受用身也是度化众生的，当然其意乐、业也都是无差别的，“当言无异”，不能说有差别。

不由依止无差别故，

在说法身的时候，有三个无差别：依止、意乐、业，而说受用身的时候，只说了意乐、业，而没有说依止。这一句就说了，“不由依止无差别”，就是说，不能从依止这一方面来说佛与佛的受用身无差别，因为法身佛皆是依真如的，而受用身不是，每位佛的受用身，其依止是各不相同的，所以不能从这个角度来说无差别。

无量依止差别转故。

诸佛的受用身是各不相同的，是有差别的。

应知变化身如受用身说。

诸佛的变化身有无差别呢？这应该按受用身的情况来说，不能按法身的情况来说。也就是说，变化身，从意乐、业的角度来说无差别，从无量依身的角度来说，是有差别的。

应知法身几德相应？谓最清净四无量，解脱，胜处，遍处，无诤，愿智，四无碍解，六神通，三十二大士相，八十种好，四一切相清净，十力，四无畏，三不护，三念住，拔除习气，无忘失法，大悲，十八不共佛法，一切相妙智等功德相应。

这是十门分别的第七门：德门，要说法身的功德了。就是说，成佛之后，有多少种功德相应呢？应该来说，要成佛当然得无量的功德了，但这里主要是说大乘与二乘比起来有多少殊胜的，所以就有数了。下边儿就举了一些。长行中说这些功德是“最清净”的，这是表示大乘胜过二乘，二乘也有很多功德，也是清净的，不过要是给大乘比起来，那就是小巫见大巫了。下边儿的“四无量，解脱，胜处，遍处，无诤，愿智，四无碍解，六神通，三十二大士相，八十种好，四一切相清净，十力，四无畏，三不护，三念住，拔除习气，无忘失法，大悲，十八不共佛法，一切相妙智等功德相应”就是具体的功德名字，下边儿用颂子来一个一个地说。

此中有多颂：

下边儿有好多颂子，来解释长行中所举出来的功德。

怜愍诸有情 起和合远离

常不舍利乐 四意乐归礼

这个颂子是说四无量心，四无量心就是慈悲喜舍。“怜愍诸有情”，这一句通于慈悲喜舍四功德，说四无量心都是佛的怜愍心发起的，佛陀怜愍众生的苦恼。“起和合”是说慈无量心的。后边儿这三句颂子“起和合远离，常不舍利乐，四意乐归礼”其实应该是“起和合意乐、远离意乐、常不舍意乐、利乐意乐”，“起和合意乐”是慈无量心。众生有三种，一种是没有安乐的，对于这些众生，佛陀对于这样的众生起和合意乐。“和合”就是相应，意思就是说，对于没有安乐的众生，佛陀善巧地让他与安乐相应。这咱们也经常说，什么是慈？就是予乐、给他快乐，这就叫慈。这个起和合意乐就是这个意思。

“远离意乐”，这是对第二类众生：这些众生苦恼很多，佛陀对于这些众生呢，就善巧地让他远离苦恼。这是说的悲无量心。咱们常说：悲就是拔苦。“常不舍意乐”，这是对第三类众生说的。前面说过两种众生了，一种是没有安乐，一种是有苦的众生，这第三类是有乐的众生，对于有乐的众生呢，佛就希望安乐永远与他在一起。佛陀看众生安乐也很欢喜，这是喜无量心。“利乐意乐”，利乐意乐就是希望众生能成就利益安乐的事情。这是舍无量心。舍无量心的“舍”，是弃舍的意思，就是让众生舍弃心里的贪、嗔、痴。有安乐了我们一般会贪，有苦恼了我们一般会瞋，不苦不乐则我们就痴。“舍”就是希望众生弃舍贪、瞋、痴，这样就可以得到利益安乐。颂子的第四句是“四意乐归礼”，“四意乐”就是刚才说的，最后的这个“归礼”就是说要归敬具足四意乐的法身佛。

解脱一切障 牟尼胜世间

智周遍所知 心解脱归礼

前边儿论文中已经说到了，德有“四无量，解脱，胜处，遍处”等，这个颂子的第一句“解脱一切障”就是说的第二种功德，解脱。第二句“牟尼胜世间”说的是第三种功德，胜处。第三句“智周遍所知”说的是第四种功德，遍处。

一句一句来说。“解脱一切障”说的是解脱，小乘中有八解脱：（一）内有色想外观色，（二）内无色想外观色，（三）净背舍身作证，（四）空无边处，（五）识无边处，（六）无所有处，（七）非想非非想处，（八）灭受想处。这八解脱其实就是九次第定，这是小乘三果罗汉以上的圣者的境界。小乘修这八解脱，即使修成了，也还有障。第一解脱“内有色想外观色”（指为除内心的色想而修不净观，因为内心要是有色想，就会引起贪心，所以要修不净观来使贪心不生）和第二解脱“内无色想外观色”（内心的色想虽然除了，但欲界之贪欲太难断，所以还要进一步巩固，继续修不净观）是得色界初禅、二禅了进一步修不净观。对于这个“内有色想”、“内无色想”也有人这样说，“内有色想”是指得了色界定，“内无色想”则是指得了无色界定。第三解脱“净背舍身作证”又叫“净解脱身作证具足住”，前二种解脱是修不净观，这第三解脱不是了，是修净色观（净色观主要是观色为青色青光、黄色黄光、赤色赤光、白色白光）也不起贪心，可见这境界要比前二种高，前二种是不净观，这一个是净观。当然，起先是不清净的，随着修行功夫的增长，慢慢地就清净了。第四、第五、第六、第七种是依四无色定而起的，在定中观苦、空、无常、无我而得解脱。第八种其实就是灭尽定。

小乘是这样，而大乘呢，则是解脱一切障，“牟尼胜世间”这一句颂子说的是胜处、八胜处。就是说释迦牟尼佛所成就的是胜过其余一切人的胜处。小乘八胜处是：（一）内有色相外观色少，（二）内有色相外观色多，（三）内无色相外观色少，（四）内无色相外观色多，（五）内无色相外观色青，（六）外观色黄，（七）外观色赤，（八）外观色白。第一胜处是指，因为内心有色想，我在修行的时候，我先观一丁点儿的色，观它是不净的，我不能多观，因为我的心力不足，观多了的话，就观不起来了。第二胜处则是说，我的观力增长了，功夫纯熟了，我就多观，我观好多色都是不净的。第三胜处则是虽观色相不净但内心不存色想。功夫更加纯熟，我一下子观好多色相不净，都不存色想就是第四胜处。第五胜处是观外之青色，转变自在，对于所见的青色，没有法爱。第六胜处是指观黄色不起法执，第七、第八是给前边儿的五、六一样的。而大乘呢，成佛了，观一切都是随心自在的。颂子的第三句“智周遍所知”说的是第四种功德：遍处。小乘有十遍处，（一）青，（二）黄，（三）赤，（四）白，（五）地，（六）水，（七）火，（八）风，（九）空，（十）识。就是说青、黄、赤、白等这十法周遍一切处，大乘则更是殊胜，是说智慧周遍一切处。第四句颂子说，“心解脱归礼”，我要归敬解脱、胜处、遍处的法身佛。

能灭诸有情 一切惑无余

害烦恼有染 常哀愍归礼

这个颂子说的第五种功德：无诤。有诤就有烦恼，无诤就没有烦恼。“能灭诸有情，一切惑无余”，说，佛不但不会让众生生起烦恼，而且是能灭除众生的烦恼的。“无余”是指把所有的烦恼都灭掉。“害烦恼”就是把烦恼给害掉、灭掉。妙老说《大毗婆沙论》中记了一个事儿，有一次须菩提要出门，就先在定中观察，说我今天要从什么地方路过，会遇见什么人，这个人看见和尚会不高兴，于是须菩提就避开这条路，走另外一条路。不过我不记得《大毗婆沙论》中有这样一件事儿，我想翻翻书，书有二百卷，太多了，不好翻，就算了。有功夫你就自己找一下。现在佛可不是这样，要是有人见到佛会生起烦恼的话，那么佛会给他一个克制烦恼的方法，这就叫“害烦恼”。“有染常哀愍”说，对于有污染烦恼的众生，佛常常哀愍他们，要度化他们。“归礼”，归敬佛陀。

无功用无著 无碍常寂定

于一切问难 能解释归礼

这是说第六种功德，愿智。佛的愿智与小乘罗汉不一样，比如说罗汉想知道一个事儿，他就先拿起架子来入定，在定中一观察就知道了，但佛的愿智给这不一样。具体不一样的地方有哪些呢？颂子里说了五个地方。“无功用”，就是说，佛的愿智是任运的，不需要象罗汉一样先拿起架子入定。“无著”，佛断除了一切的知障，最极清净，对一切境界心里没有执著，阿罗汉在个别时候还有执著。“无碍”佛对一切事情都通达无碍，阿罗汉个别时候还有点儿碍。“常寂定”，佛是永远在禅定之中，而阿罗汉则入定是入定、出定是出定。“于一切问难能解释”，一切众生的一切问题佛都能解答，但阿罗汉个别问题还不能解答。最后的“归礼”这两个字儿，还是归敬佛陀的意思。

于所依能依 所说言及智

能说无碍慧 常善说归礼

这是说第七种功德：四无碍解。其实四无碍解就是应机说法，这有所说、能说两部分。先看所说的，我们知道，所说的就是法！说法度众。这个颂子咱们要这样读，“于所依、能依，所说；言及智，能说。无碍慧常善说。归礼。”就是说，“所说的是能依及所依；能说的是言及智。因为有无障碍的智慧，所以佛陀一直说法，而且是善巧地说。”佛菩萨所说的是法！四无碍解的第一无碍就是法无碍，就是颂子中的“所依”，有了法无碍，法所诠表的义呢？就是义无碍解，义无碍解就是“能依”。“义”就是义理，就是法所表示的意义。有法、有法所诠表的义。经典的文句就是法、经典所诠的义理就是义。佛都能通达无碍，这就是法无碍解、义无碍解。再看能说的，就是“言及智”，“言”就是指词无碍解，“智”是辩说无碍解。“言”就是能够把思想、义理给表达出来，“智”是善于表达的智慧、能力，智慧更重要。这就是四无碍解：法无碍解、义无碍解、言词无碍解、辩说无碍解。“无碍慧常善说”，佛有大智慧，一直在善巧地说法度众。“归礼”，我们要归敬佛陀。

为彼诸有情 故现知言行

往来及出离 善教者归礼

这是说第八种功德：六神通。“为彼诸有情”，佛是为了教化一切众生，而现起六神通的。六神通的第一个是“现”，是指神足通，也叫如意通，有了神足通，就能有各种情况，在天上飞，无有障碍。第二个是“知言”，是指天耳通，知道各类众生的语言。天耳通可不是只听见，而且要听懂。传说孔子的侄女婿公冶长能听懂鸟的话。第三个是知“行”，是指他心通，知道对方内心里的活动。第四个是知“往”，是指宿命通，知道过去无量劫来的事。第五个是知“来”，这是天眼通，能看见（即知道）未来的事情。第六个是“出离”，是指漏尽通，就是你知道众生的烦恼，因为知道，所以可以帮他断烦恼。最后一句说“善教者，归礼”，就是说，佛陀有这六种神通，善于教化众生，所以我要归礼佛陀。

诸众生见尊 皆审知善士

暂见便深信 开导者归礼

这是说第九种功德：三十二大士相，八十随好。“诸众生见尊”，众生看见世尊的三十二相、八十种好“皆审知善士”，就知道这是一个大善知识，他就给人一个这样的印象，“暂见便深信”，一看见他就对他生起甚深的信心、清净的信心。“开导者，归礼”，看见佛有三十二相、八十种好，没等他说话，我们就对他生起了净信，他要是再开导我们佛法，一定可以使我们得正知见，我们归敬这佛陀。

摄受住持舍 现化及变易

等持智自在 随证得归礼

这是说第十种功德：四一切相清净。四一切相清净就是所依清净、所缘清净、心清净、智清净。“摄受住持舍”就是说的所依清净，所依清净又叫身清净。“摄受”就是含摄、成就，成就了什么呢？成就了住持、弃舍。“住持”是身体，说，他成就的这个身体能继续住持下去、生存下去。就是说，他只要愿意，他就可以一直住持下去。“舍”是弃舍。就是说，他要是不愿意住持下去，他随时可以舍弃这个身体。我们凡夫不想死也不行，想死也死不了。佛菩萨则是很自在的。这是所依清净、身清净。“现化及变易”是所缘清净。就是说，所缘境很自在。“现化”就是指本来这儿没有房子，需要就化现出来一座房子来。“变易”是指本来已经有了，但是不如意，就把它给改变一下。“现化”是没有就变出一个，很自在的就化现出一个，这“变易”是有了但不满意，很自在的就给改成令其满意的。这是所缘清净。“等持”是指心自在、禅定自在。在禅定里边儿心自在。这是心清净。“智自在”是通达一切事理。就是智清净。“随证得，归礼”，我们要随顺佛陀证得四一切相清净：所依清净、所缘清净、心清净、智清净，佛陀已经具足了这样的功德，我归礼佛陀。

方便归依净 及大乘出离

于此诳众生 摧魔者归礼

这是第十一种功德：十力。“力”就是破烦恼，指智慧，十力就是十种智慧，这十种智慧有破烦恼的能力，所以叫十力。十力是：处非处智力、自业智力、静虑解脱等持等至智力、根胜劣智力、种种胜解智力、种种界智力、遍趣行智力、宿住随念智力、死生智力、漏尽智力。颂子中是用四类来解释十力的：方便、归依、净、大乘出离。

“方便”是因的意思，比如说善方便就是善果的因，恶方便就是恶果的因。善就不是恶果的因，恶就不是善果的因，这叫“方便”。最后一句有个“摧魔”，魔与佛不一样，佛说善方便是善果之因，魔则欺诳众生，把善的说成恶，把恶说成善，颠倒说来欺骗众生。十力的第一个就是处非处智力，佛就是用这个处非处智力来摧破魔王的。“处、非处”就是善处、恶处，佛就说了，善处自然是善，恶处自然是恶，恶处没有善报的。“处”也是因的意思。佛为众生宣说处非处智力，让众生转恶为善。

“归依”指的是第二力“自业智力”。世间一切的果报都是我们自己的业力所创造的，不是别人给我们的。别人作善、作恶你是不会受报的，你作了业只能你自己受报，这就是自作自受的原则。魔王告诉我们，一切的果报都是梵天在掌控。佛为了摧破魔王，就说了“自业智力”，说，你要是归依的话，就归依自己的业力（自性），也就是为自己的所为负责，自己的一切都是自己创造的。这是“归依”。

“净”是指第三力“静虑解脱等持等至智力”。就是说，我们相信善恶果报，我们作善事，不去造恶业，这终究还是不能得清净解脱的，我们一定要发出离心，修学圣道。魔王说：修四禅八定就能断烦恼，就能解脱。佛为了摧破魔王，就说了“禅解脱三昧智力”来破除魔王的欺诳，告诉我们只有修出世道才可以解脱，修世间的三昧只是暂时地降伏烦恼而已，那不是解脱。

“大乘出离”是说的后七力。魔王的谎言被摧破了，于是众生发出离心修学佛法，这时候魔王又来了，说，你就修这个好了，什么大乘佛法，根本就是谎言。佛了为摧破魔王，就说，小乘也不错，不过大乘比小乘殊胜多了，说了“根胜劣智力、种种胜解智力、种种界智力、遍趣行智力、宿住随念智力、死生智力、漏尽智力”，令他们回小向大。“根胜劣智力”就是佛来观察你过去世在佛法里培植的善根是胜还是劣，是有力还是无力。“根”是善根、根机。“种种胜解智力”是佛来观察你内心里好乐什么，对什么能产生胜解，然后用相应的方法来度化你。“种种界智力”是佛来观察你心中的烦恼种子，看你是贪烦恼重？还是瞋烦恼重？还是痴烦恼重？还是疑惑心烦恼重？还是我慢心重？还是我见烦恼重？等等，然后相应地来度化你。“界”就是烦恼种子。“遍趣行智力”是佛为众生说法，不管说的是什么法门，都是让你普遍地趣入圣道的，说六波罗密多也好，说三十七道品也好，别看好象有大乘法门有小乘法门，实际上目的都是让你成佛的。“死生智力”是让你解脱生死的。“宿住随念智力”是让你宿世的烦恼通通破除。“漏尽智力”是把有漏的一切都转成无漏的。“于此诳众生，摧魔者，归礼”，佛来为众生说法，魔就来欺骗众生。佛就说这十力，一方面摧破魔王，一方面开导众生。佛有这样功德，我归礼佛陀。

能说智及断 出离能障碍

自他利非余 外道伏归礼

这是说第十二种功德：四无畏。四无畏的第一个是“智”，佛陀通达一切智，对一切法通达无碍，有些书中干脆就是写作“正等觉无畏”。这是说，佛说：我成佛了！说得理直气壮，连一点儿畏惧之心也没有。我们要是说什么，心里有点儿含糊，那就不行。第二个是“断”，就是烦恼习气完全断除，又叫“漏尽无畏”。佛说：我完全断除了烦恼，说得理直气壮，连一点儿畏惧之心也没有。第三个是“出离”，又叫“尽苦道无畏”。这是说佛能说一切灭苦的法门、断烦恼的法门，开导众生。第四个是“能障碍”，又叫障道无畏、障法无畏。佛教导人们修行的法门，还能教导人们哪些是修道的障碍。“自他利”，四无畏就是自利、利他，没有别的东西。智、断是自利，出离、能障碍是利他。“非余外道”，佛陀能够自利利他，不是其他的外道可比的。“伏”是指佛陀可以降伏一切外道、“归礼”，我归敬佛陀。

处众能伏说 远离二杂染

无护无忘失 摄御众归礼

这是说第十三种功德“三不护”和第十四种功德“三念住”。“处众能伏说”，佛处在大众之中，能够降伏别人对佛的讥嫌，“说”就是讥嫌。有一个故事，说佛在说法，有一个女人装成个孕妇，说是怀了佛的孩子，佛也是有人讥嫌的，但讥嫌不了佛的，为什么？因为佛的身、口、意三业清净，没有什么可讥嫌的。我们凡夫就不一样了，我们有许多毛病，所以我们要谨慎些，时时提醒自己。“三不护”的“三”是身、口、意，佛的身、口、意是清净的。“不护”就是咱们通常说的不设防、不用刻意保护。“远离二杂染”，佛在大众中说法，听法的人有的很恭敬，佛也不会因为他很恭敬而产生欢喜心。有的在听法时不那么恭敬，不那么认真，佛也不会因之而起嗔恨心，这叫“远离二杂染”。佛一直是保持正念，对恭敬的人、不恭敬的人、说不上恭敬不恭敬的人都是正念，这就是“三念住”――对三类众生都保持正念，有三类众生，但佛的心念一直是正念。“无护无忘失”，“无护”指三不护，不需要刻意保护、隐藏；“无忘失”指三念住，佛不忘正念，“摄御众”，佛可以善巧地摄受、调御一切众生。“归礼”，佛有这样的功德，我归敬佛陀。

遍一切行住 无非圆智事

一切时遍知 实义者归礼

这是第十五种功德：拔除习气。“遍一切行住”，佛在行、住、坐、卧时，“无非圆智事”，他所表现出来的一切行、住、坐、卧等，没有不是大智慧的表现，一直是正念在支配，一直都很威仪。“圆智”就是圆满智慧。“一切时遍知，实义者，归礼”，不论什么时候，佛的智慧都是通达真实义的，我归敬有这样功德的佛陀。这一个是说佛拔除了一切的习气，没有一丁点儿失常的地方，一切时都是正念正知。

诸有情利乐 所作不过时

所作常无虚 无忘失归礼

这是第十六种功德：无忘失法。“诸有情利乐，所作不过时”，佛要做利益众生的事业，他要作的这件事情，永远都不过时，他永远也不会忘失。比如说他见张三，到将来什么时候就可以去度化了，他不会说到时候把这个事儿给忘了。度众生可不是乱度的，你不能提前去，也不能拖后，要把握好机缘。“所作不过时”就是指在众生机缘成熟该度的时候去度。“所作常无虚”是说，佛想要做什么事情时，那件事就一定能作成的，绝对不会成徒劳的了，佛不会作劳而无功的事儿。“无忘失，归礼”，佛有无忘失法的功德，我要归敬佛陀。

昼夜常六返 观一切世间

与大悲相应 利乐意归礼

这是第十七种功德：大悲。第一种功德就是四无量心，里边儿就有大悲心，但这里又特别提出来说一下。“昼夜常六返，观一切世间”，在当时是把昼夜各分为三时，初日分、中日分、后日分，初夜分、中夜分、后夜分。在昼夜的每个时候，佛都要观察世间一切众生的善根情形，看谁该得度了，那就去度他，该用什么法子就用该用的法子去度他。“与大悲相应”，佛陀是用悲心观察众生而后去度众生的。“利乐意，归礼”，佛陀的心里总是利乐众生的，我要归敬佛陀。

由行及由证 由智及由业

于一切二乘 最胜者归礼

这是第十八种功德：十八不共佛法。就是佛有十八种功德是比二乘圣人殊胜的。这十八不共佛法分成行、证、智、业四类。十八不共法就是啥？有好多种，咱们现在按无性释中的说法来说，翻到531页。“十八不共佛法者，谓不同义是不共义，即诸如来无有误失”，这是第一种，“无有误失”。第二种在第八行：“又诸如来无卒暴音”，这是第二种，“无卒暴音”。第三种在十二行：“又诸如来无忘失念”。第四种在十四行：“又诸如来无种种想”。第五种在倒数第四行：“又诸如来无不定心”。第六种在倒数第三行：“又诸如来无不择捨”。

以上这六种不共佛法是对应本颂的“行”，“行”是说佛所行的一切事儿。第一种不共的“无误失”就是没有错误、过失，指佛的身业都是对的。第二种不共的“无卒暴音”是指佛的口业说的。要是阿罗汉呢，比如说他一个人到旷野等地方，忽然间高兴了，他就会发出大笑、大叫等不威仪的声音，但佛绝对不会。第三种不共的“无忘失念”是指佛不会有忘记这样的情况。第四种不共的“无种种想”，是说佛没有各种各样的想法，佛只有度众生的念头，没有其他的想法。第五种不共是“无不定心”，是说佛一直在定中。第六种不共法是“无不择捨”，是说佛不会干出舍弃众生的事儿，要是阿罗汉，有时候会在没有细心观察所度化众生的心念就舍弃他的事儿。“证”对应的是十八不共法中的六个不共。在无性释531页倒数第一行中说，“又诸如来无有欲等六种退失”，六种退失是指啥的？在532页第二行上说，“欲退、精进退、念退、定退、慧退、解脱退”，接着无性释说，“如是六退，诸佛皆无”。所以说，颂子中的“证”对应的就是六不退――欲不退、精进不退、念不退、定不退、慧不退、解脱不退。说，阿罗汉对于无上菩提不感兴趣，他不要，他不想去得无上菩提，这叫欲退，佛菩萨没有这样的事儿。

佛法中的“退”有两种：一种是你已经得到了后来再失掉了，这叫已得退。另一种退是你没有得到，你根本就不想要，这叫未得退。这六种退都是这意思。现在这里阿罗汉没得无上菩提，他也不想得无上菩提了，所以这六种都是这样意思，就是退了。佛没有这六种退。再看“智”，“智”对应的是十八不共法里的“知过去世无碍”、“知现在世无碍”、“知未来世无碍”。在无性释中是532页第七行，“又诸如来於三世境若知若见无著无碍”。说，阿罗汉要想知道一件事，不管是过去的、未来的、现在的，他不能一举心就知道，但佛是一举心就知道了，或者说，阿罗汉想知道一件事儿，还多少有点儿障碍，佛是没有障碍的。最后是“业”，业有身、口、意三业，三业都是随智而行的。关于“业”，对应的是十八不共法里的身业随智慧行、口业随智慧行、意业随智慧行。佛的三业一定是清净的。“于一切二乘最胜者，归礼”，佛与二乘比起来，这十八种功德最殊胜，这是佛的十八不共法，是比二乘殊胜的地方，我要归敬佛陀。

由三身至得 具相大菩提

一切处他疑 皆能断归礼

这是说第十九种功德：一切相妙智。这个一切相妙智我们一般叫成一切种智，或者叫成一切智智。“由三身至得”，佛的三身已经成就了，圆满成就了，“至得”就是圆满成就。“具相大菩提”，成就了具足一切功德的大菩提，这就得到了一切相妙智、一切智智。“一切处他疑皆能断”，“他”指众生，说，一切处、一切众生，有任何的疑问，佛都能够决断。“归礼”，我归敬佛陀。

诸佛法身与如是等功德相应，复与所余自性、因、果、业、相应、转功德相应，是故应知诸佛法身无上功德。

前面说了佛有十九德，有些地方是说成二十德，关系不大。下边儿呢，又说了六种德。这是从另外的角度来说的。“诸佛法身与如是等功德相应”，一切佛成就了圆满的法身，与前面说的四无量心，乃至到十八不共法、一切相妙智等功德相应，“复与所余自性、因、果、业、相应、转功德相应”其实还可以说法身与自性功德、因功德、果功德、业功德、相应功德、转功德等六种功德相应。所以，我们要赞同佛陀的无上功德。

此中有二颂：

这儿再用两个颂子把这六种功德说一下。

尊成实胜义 一切地皆出

至诸众生上 解脱诸有情

“尊成实胜义”说的是自性功德。“尊”指佛陀，他为一切众生所尊敬。“成”是指本来成就，可不是后来造作的。“实”是真实，指佛陀所成就的功德是真实的。“胜义”是殊胜的义理、胜义谛、一真法界、真如等。说，佛以什么为体性？以一真法界为体性、为自性。“一切地皆出”，“一切地”是指修行时的地，就是从修行到十地，“皆出”是指法身的功德超出所有十地菩萨的功德。这一句是说的因功德。“至诸众生上”，这是说果功德的，在因地的修行，到了果地的时候，就在一切众生之上了，是一切众生所不能及的。“解脱诸有情”，这是业功德。说，成佛之后，佛要作什么事业呢？帮助一切的有情解脱、度众生，这就是佛干的事儿。

无尽无等德 相应现世间

及众会可见 非见人天等

“无尽无等德相应”是说的相应功德，“无尽”是指佛的功德无量无边，“无等”是指没有谁的功德能够与佛相等、与佛一样多。“现世间及众会可见，非见人天等”，这是说转功德的。“转”是生起、现起的意思。就是说，从自性的法身现出变化身来，再现出受用身来。“现世间”是指由法身现出变化身到世间来度化众生。“及众会”是指法身现出受用身在大法会中度化菩萨。“可见”是指现世间可见、众会可见，现世间可见就是指世间众生可见，众会可见是指法身菩萨可见。“非见人天等”是说，受用身可不是世间的人、天人以及二乘能够见到的。

下边儿该十门分别的第八门：甚深门。

复次，诸佛法身，甚深最甚深，此甚深相云何可见？

这是说佛的法身是甚深的，很不容易理解，论文中说，“甚深最甚深”，这是我们思维不到的境界，只能凭圣者给我们说了。这甚深相表现在哪儿呢？

此中有多颂：

为了说清甚深，无著论师给了十二个表现，就是从十二个方面来表现法身的甚深之处。十二种表现就用了十二个颂子。

佛无生为生 亦无住为住

诸事无功用 第四食为食

第一个颂子说的是“生住业住甚深”。这里边儿又分四条。“佛无生为生”，我们在生死中流转，因为造业，而得业报，这就是生生死死。佛的法身是没有这样的生死的，没有这样的生死我们就叫“无生”，没有这样的生死，就没有烦恼，是极清净庄严的，这不是世间相，但可以来世间现身说法，佛的法身是以这个为“生”，这是很难理解的。我们受生是因为有烦恼，佛虽然没有烦恼，但也会表现出生死相，象释迦牟尼，不是也只活了八十岁吗？这个道理是“甚深最甚深”的。我们根本没法说清，只能理解为佛是由大悲心而在世间现生死相，不是象我们这样因烦恼而有生死。这是“生甚深”――法身的生死很难理解。

“亦无住为住”，阿罗汉入无余涅槃了，就安住于涅槃，他在有余涅槃的时候，他有色受想行识，一入无余涅槃，前一剎那的色受想行识灭了，后一剎那不生，也就没有色受想行识相了，这就是“住于寂灭相”。我们是住在色声香味触法相上，这叫“住于有为相”，而佛是没有这样的住的，既不住有为相上，也不住无为相上，这不是“无住”吗？他就是住在“无住”上。“无住”就是佛的住，这是甚深最甚深的的境界。这是“住甚深”。“诸事无功用”，二乘人住于无余涅槃里，没有业，心也不动。我们凡夫则做这个做那个的。但佛不是这样的，他是心不动，但还在造业――他造利益众生的业。这是甚深最甚深的道理。“诸事无功用”就是不用动心就利益众生了。这是“业甚深”。

“第四食为食”，我们的生命得靠营养来维持，在佛教中有四种食：不清净依止住食、净不净依止住食、一向净依止住食、唯示现依止住食。这个“不清净依止住食”，就是我们欲界的众的果报。“依止”就是身体，欲界众生的果报身都是不清净的，都有烦恼，这样的生命需要段食、触食、思食、识食，有这四种饮食来资养生命的存在，就叫“不清净依止住食”。第二种是“净不净依止住食”，这是色界天、无色界天的众生，他们没有欲界的烦恼，所以叫净；但他本身还有烦恼，所以又叫不净。这又是净又是不净的生命体，也要饮食，他们没有段食，只有触食、思食、识食，这叫“净不净依止住食”。第三个是“一向净依止住食”，这是罗汉、辟支佛的境界，他们没有烦恼了，所以身体清净、心也清净。阿罗汉、辟支佛也得有段食、触食、思食、识食，但他们一直清净，所以叫“一向净依止住食”。第四个是“唯示现依止住食”，这是指佛，比如释迦牟尼，看起来他也段食、触食、思食、识食，但那只是示现而已，佛的法身根本不需要饮食，他是为了给众生做福田，所以表现出需要饮食而已，这叫“唯示现依止住食”。佛是以这四种食的“第四食为食”的。

无异亦无量 无数量一业

不坚业坚业 诸佛具三身

第二个颂子是“安立数业甚深”。这里边儿有三条。“无异亦无量”，这是“安立甚深”。“无异”是说一切佛都依止于清净法界，都以清净法界为自性，这是一样的。桌子以木为体性，粉笔以石膏为体性，佛以真如为体性，没有真如就没有佛了。“无异”就指一切佛的体性是没有差别的。“亦无量”是说，真如、清净法界是没有数量之别的，是不可以拿数量来修饰、限制。但是我们在这无差别之中安立了很多佛名，这是甚深最甚深的道理。“无数量一业”，这是“数甚深”。说，有无量无边的佛，佛的数量是不可计量的，太多了。不过这么多的佛作的是同样的一件事儿，就是利益众生、度化众生。“无数量”是指佛有很多，“一业”是说这么多的佛作的是同一件事儿。

“不坚业坚业，诸佛具三身”，这是业甚深。“不坚业”是指不坚固的业，就是有开始有结束的业，有生灭的业。“坚业”则是指没有生灭、不可破坏的业。在276页世亲释中说，“诸如来三身相应，其受用身事业坚住，其变化身业不坚住”。在545页无性释中说，“自性身业是其坚住，余二身业是不坚住”。就是说世亲与无性稍微有点儿不一样，咱们知道一下，不给作决断。

现等觉非有 一切觉非无

一一念无量 有非有所显

第三个颂子是说的“现等觉甚深”。“现等觉非有”，就是一切相妙智、一切智智成就了，觉悟了我是不可得的，法也是不可得，这叫“非有”，也就是遍计执无所有、毕竟空。“一切觉非无”，但也不是没有所觉，“非无”就是说在假立名相的道理上，还是得说有释迦佛、弥勒佛等。为什么这么说呢？“一一念无量”，在每一刹那都有菩萨在无量无边的世界里成佛。就是说，从第一义谛上来说，无佛道可成，但从俗谛上来说，还是有成佛这回事儿的。“有非有所显”，“有”是指从圆成实这一方面来说，一切佛的自性清净法界是有的，“非有”是指没有一切障碍，烦恼障、所知障都没有。

非染非离染 由欲得出离

了知欲无欲 悟入欲法性

第四个颂子说的是“离欲甚深”。“非染非离染”，“非染”就是贪、嗔、痴等一切的染污，这是用四寻思观、四如实智把那些染污都给灭除了；“非离染”是说染污的种子还没有断尽。这是怎么回事儿呢？“由欲得出离”，正因为菩萨有染污种子，所以菩萨才能度化众生出离生死。这是在菩萨位的情况，还没到佛地。“了知欲无欲，悟入欲法性”，菩萨是先断烦恼的现行，到金刚道时断烦恼种子，怎么断？“了知欲无欲”，就是说，他知道遍计所执的欲其实是根本就没有的，连一点儿的影子也没有。他知道遍计所执的境界（即所遍计）从本质上说，根本就是依他起，这样呢，能遍计、所遍计其实都是依他起，遍计所执是没有的，遍计所执的欲当然也是没有的。所遍计毕竟空，能遍计也毕竟空，在毕竟空里根本就没有欲可得。知道了这些，就是“悟入欲法性”了，就是证悟了佛的根本无分别智，证悟了一真法界。从烦恼法上也能证悟法性，这道理是甚深的。

诸佛过诸蕴 安住诸蕴中

与彼非一异 不舍而善寂

第五个颂子是“断蕴甚深”。“诸佛过诸蕴”，诸佛成就了无分别智，超越了色受想行识五蕴的境界，这是因为根本无分别智而证悟了遍计执是毕竟空的，这样，佛的心就不住于色受想行识五蕴上了，就与清净法界相应。“安住诸蕴中”，说，虽然诸佛已经超越了五蕴的境界，但因为大悲心，他不弃舍一切众生，他就还住在五蕴里，不过他的住给我们是不一样的，我们是住在有漏五蕴上，诸佛是住在无漏五蕴上，他住于五蕴而不受五蕴之苦，为什么呢？其实就是说，他的住于五蕴是化现而已。

“与彼非一异”，别看佛住在五蕴上，其实佛是超越了五蕴的。也就是说，佛实际上是住于清净法界，他所表现出来的住于五蕴的五蕴是清净法界化现出来的，你可以说它是五蕴，也可以说它根本就不是五蕴。也就是说，超越诸蕴的清净法界，和幻化的诸蕴是“非一异”的，为什么不是一？因为超越诸蕴的清净法界是无为法，而诸蕴是有为法，当然不能说是一！那又为什么是非异呢？因为离开了诸蕴，根本就没有清净法界可得，谁也不能离开诸蕴去证悟清净法界。这就叫“与彼非一异”。“不舍而善寂”，说，佛的大悲心是不弃舍色受想行识五蕴的，因为众生就是五蕴和合的，舍弃了五蕴就是舍弃了众生。所以“不舍”。“善寂”是指佛陀能够在有为的五蕴之上离一切相，证悟寂灭法性、清净法界。

诸佛事相杂 犹如大海水

我已现当作 他利无是思

第六个颂子是“成熟甚深”。“现等觉甚深”是成就一切种智，离欲甚深、断蕴甚深，是弃舍杂染的因果。这个成熟甚深，是说诸佛度化一切众生。“诸佛事相杂”，诸佛要作的事儿都是利益一切众生，这尊佛与那尊佛没有区别，所以说，一切佛所作的事儿放在一起是可以的。这其实是因为诸佛的自性都是真如，是一样的缘故，是不分彼此的，再说了，一切佛都是没有我执的，所以诸佛是可以和而为一的。其实这就是咱们说的一即一切、一切即一。“相杂”就是和而为一、不分彼此、揉在一起。“犹如大海水”，这是一个比喻，很多江河里的水，流到大海里以后，就融汇到一起了，不分彼此了。“我已现当作”是说，我过去就在作利益众生的事情、现在也还在作利益众生的事情，未来还是要作利益众生的事情。“已”是过去，“现”是现在，“当”是未来。“他利无是思”的“他利”就是利益众生；“无是思”是说，诸佛是没有这种分别心的。我们知道，诸佛的境界是合而为一的，没有你我的区别。

众生罪不现 如月于破器

遍满诸世间 由法光如日

第七个颂子是说“显现甚深”。诸佛一直在作度众生的事儿，可是我们从来就没有看见过，为什么我们看不见呢？“众生罪不现”，原来呀，是因为我们众生有太深的罪业。“如月于破器”是一个比喻。有一完好的罐，装满水，放在外边儿，就可以在水罐里显现出一个月亮，千江有水千江月。可是现在呢，你这个罐子破了，水漏了，这样呢，水罐还在，可是里边儿就现不出月亮来。我们就象一个破器，装不了水，自然显现不出佛。虽然罐破了，罐里显不出月亮，但月亮仍然在天上呀。我们是个破器，见不着佛，佛也还是照样在度众生。“遍满诸世间，由法光如日”，诸佛是遍满一切世间的，在世间任何地方都说法度众生，就像太阳一样，遍照一切大地，可你要是一个盲人，太阳照着大地你连一点儿也看不见。“法光如日”，佛陀的教法就象太阳一样，遍满一切世间。佛陀的教法就是光明。

或现等正觉 或涅槃如火

此未曾非有 诸佛身常故

第八个颂子是“示现等觉涅槃甚深”。“或现等正觉”，就是说，诸佛为了度化众生就来到人间示现八相成道，示现一个化身佛，其实是佛早就成佛了，不过是在这儿再显现一次而已。“或涅槃”，佛陀示现一下，成佛了，又离开人间了，这都是示现而已。示现成佛，是因为这儿有可度化的众生，要是没有可度化的众生，他就不在这儿示现了，把可度化的众生度完了，他也不需要长住世间，于是就示现涅槃，这就叫“或现等正觉，或涅槃”。“涅槃”本来是不生不灭的意思，但这儿要说成离开世间。“如火”，这是一个比喻，就象世间的火一样，有缘就烧起来了，烧完就灭了。佛的示现等正觉、示现涅槃也是这样子的。

“此未曾非有”，说，佛在世间示现，我们觉得世上有佛了，其实根本就没有一个老和尚叫佛，真正的佛是无形无相的，有形相的就不是真的。佛示现涅槃了，我们觉得世间没有佛了，其实根本就不是没有佛了。未曾没有佛，也未曾非有。示现成佛来到人间，我们叫“来”；示现涅槃，我们叫“走”，其实根本是来无所来，去无所去，这叫“此未曾非有”。“诸佛身常故”，我们觉得示现成佛是生，示现涅槃是灭，实际上佛根本是没有生灭的，示现的生灭根本不是真实的。这是“示现等觉涅槃甚深”。

佛于非圣法 人趣及恶趣

非梵行法中 最胜自体住

第九个颂子是“住甚深”。“佛于非圣法”，佛来到世间度化众生，世间的境界是非圣法的，因为非圣法，所以有很多的过失，即使说有点儿善法，也是不圆满的善、是有漏的善。可佛是最胜的境界，佛的自体是安住在清净法界里的，这于凡夫是不一样的。佛虽然来到世间，但他绝对不会退到非圣的境界来，他是不被世法所染的，“最胜自体住”，他还安住在圣法境界里。“人趣及恶趣”，说，佛来到人间度众生，或者到三恶道去度众生，“人趣”是人间，还包括天人，指三善道，“恶趣”是三恶道。这些众生佛都度，佛在度这些众生的时候，他的内心里还是“最胜自体住”，佛还是安住于最胜处，不被六道所染。“非梵行法中”，“梵行”就是清净行，这里就是指慈悲喜舍，说，佛所度化的众生几乎都没有慈悲喜舍，佛在度化他们的时候，绝对不会被他们染污，佛还是“最胜自体住”，住于慈悲喜舍的清净光明里。在清海无上师的说法里，说我们本来是佛，我们来度众生，度久了之后我们变成了众生，我们现在就是尽力地回到我们的来处。净空法师说：十法界里佛还不行，还会退，只有到了法身大士的地步才不会退转。这都是邪说。

佛一切处行 亦不行一处

于一切身现 非六根所行

第十个颂子是说的“显示自体甚深”。佛的自体就是真如。“佛一切处行”，佛到处行化去度众生，到各界去。佛本身有自己的境界，为了度众生，他就到一切境界去化现。“亦不行一处”，佛虽然到各处去度众生，其实他哪儿都没去。这是什么意思？就是说，佛是无分别智，到哪儿都是佛的境界，哪儿都是清净的真如境界，所以说，他是一直在清净真如境界里哪儿也没有去。这就是到一切处与不行一处的高度统一，这是不可思议的境界。“于一切身现，非六根所行”，说，佛不但心念一直安住于清净法界里，而且身相也很奇特。“于一切身现”是说佛有大悲心度化众生，能够到一切处去现身，现各种身度化众生。这正因为法身无相所以佛才能现各种身。“非六根所行”是指佛虽然现各种身，被各种众生见到，但佛的本身境界，凭众生的六根还是见不到的，就是说，佛是方便示现一切众生所能见到的身相，但佛的境界众生还是不能知道的。也就是说，佛可以方便示现，但佛的境界一直没变。

烦恼伏不灭 如毒咒所害

留惑至惑尽 证佛一切智

第十一个颂子说的是“断烦恼甚深”。“烦恼伏不灭”，烦恼令人不愉快，菩萨可以调伏烦恼，可以令它不活动，但是还没有把它们消灭，没有把它们的种子给断掉。“如毒咒所害”这是一个比喻，有一条毒蛇，它要咬人，所以要用咒术把它降伏，这样它就害不了人了，但是，你也用不着把它杀了呀～～它咬人是它的业力所使，它已经够苦了。到它业力尽了的时候，它自然就咬不了人了。“留惑至惑尽，证佛一切智”，到金刚道以后，成佛了，自然就把烦恼种子给断尽了，到成佛的时候，就是清净法界。凭大神通、大智慧就可以度众生了。在天台中有一个伏惑润生，就是还要保留烦恼种子，说要是没有它的话，就不能在生死中来了，那就没法度众生了。这是因为神通还不够、智慧还不够的缘故。到成佛的时候，智慧够了，就不用烦恼种子了，凭神通、智慧就可以到生死中现身度众了。

烦恼成觉分 生死为涅槃

具大方便故 诸佛不思议

第十二个颂子说的是“不可思议甚深”。“烦恼成觉分”，“烦恼”是流转生死的动力。“觉”是令人安乐的原因，“分”，妙老说是原因。烦恼是染污的，可是它能够成为无上菩提的因，这是不可思议的。“生死为涅槃”，生死是令人不如意的，而涅槃是大安乐、大解脱的境界，现在说生死就是涅槃，这是不可思议的说法，为什么这样说呢？“具大方便故”，因为佛菩萨有方便善巧的智慧。佛的生死其实只是示现而已，他根本就安住在最胜境界上，佛陀的烦恼也是示现而已，它其实根本就没有烦恼。“诸佛不思议”，这是诸佛的不思议境界，不是凡夫所能了知的。

应知如是所说甚深有十二种：

这样，我们就知道甚深有十二种甚深，具体是哪十二种呢？下边儿给说一下，因为前边儿没有说名字，只是解释，下儿给出名字。

谓生住业住甚深，安立数业甚深，现等觉甚深，离欲甚深，断蕴甚深，成熟甚深，显现甚深，示现等觉涅槃甚深，住甚深，显示自体甚深，断烦恼甚深，不可思议甚深。

第一颂是“生住业住甚深”。第二颂说的是“安立数业甚深”。第三颂说的是“现等觉甚深”。第四颂说的是“离欲甚深”。第五颂说的是“断蕴甚深”。第六颂说的是“成熟甚深”。第七颂说的是“显现甚深”。第八颂说的是“示现等觉涅槃甚深”。第九颂说的是“住甚深”。第十颂说的是“显示自体甚深”。第十一颂说的是“断烦恼甚深”。第十二颂说的是“不可思议甚深”。

若诸菩萨念佛法身，由几种念应修此念？

十门差别的第九门是“念”。“若诸菩萨念佛法身”，要是有菩萨欢喜修学念佛法身这个法门的话，“由几种念应修此念”？有多少种方法来修这念佛法门呢？也就是说，这个念佛法门怎么修行呢？

略说菩萨念佛法身，由七种念应修此念：

念佛法门广大甚深，现在说不了那么多，只能简单地说，最简单地说，有七个念佛的方法。

一者、诸佛于一切法得自在转，应修此念，于一切世界得无碍通故。

第一，我们要念“诸佛于一切法得自在转”――佛有自在转变世出世间一切法的威力，这需要我们在禅定中观察。佛为什么有样的威力呢？一切法怎么搞的，难道本身都不能决定，佛想怎么改变就怎么改变？为什么会这样？“于一切世界得无碍通故”，原来，是因为佛有无障碍的大神通，能够入一切法界的缘故，“得无碍通故”就是说佛有无障碍的大神通。

此中有颂

无著论师说了一个颂子。

有情界周遍 具障而阙因

二种决定转 诸佛无自在

佛在一切世界都能自在地往来、自在示现。真的这样吗？我看未必。我怎么会有这样的想法呢？我想，佛既然可以自在地到各处度众生，他无始以来就在度众生，那么众生不是早就该被度化了吗？我们不是早就该成佛道了吗？或者我们早就该成罗汉、成辟支佛了，可我们直到现在还在生死中流转，这就说明了佛并没有来度我们吗？我有这样的疑问，无著论师就用了这个颂子来回答我。“有情界周遍”，说，有情很多很多，佛确实是要度一切众生的，可是“具障而阙因，二种决定转”，我们到现在还在生死中流转。

“具障而阙因，二种决定转”这二句颂子说了四个原因，因为这四个原因，所以佛到现在还没有度得了我们，我们到现在还在生死中流转。第一个原因是“具障”，我们有烦恼障、业障、报障，所以佛要度化我们是非常的困难。现在有一个电影，好象是《青蛇的故事》，王祖贤演白蛇，张曼玉演青蛇。那里边儿法海有一句台词：人太难驯服了，比妖还难！就因为我们有这些障，所以还在生死中流转。烦恼障是我们情绪方面的。一种情况是我们因为三毒而不接受佛陀教化；另一种是接受佛陀的说法但作不到。这样的人只能在生死里流转。业障是指造了极重的恶业，比如造了五逆重罪，这些罪障碍了我们，所以我们在生死中流转。报障就是果报的问题。比如说你又聋又哑还是个瞎子，你又生在人间，你接受佛法的障碍就特别大。第二个原因是“阙因”，就是没有善根，这是因为无始以来你就没有对佛法的熏习，让你一下子接受佛法，这不现实。“二种决定转”这一句包含了二个原因，一个是业决定转，一个是报决定转。“业决定”是说你非要造这种罪，诸佛虽有大神通，他不让你造，可你偏要造，那么佛也就不干涉你了，佛有的是时间，他耐心大得很，他等着，到机缘成熟了再说。这是造业。下一个是“报决定”，这是说业你既然已经造下了，有了这罪业，你必须为你的所作负责任，你就得去受果报。佛也不能使你不受报。就因为这原因――具障、阙因、业决定、报决定，所以我们现在还在生死中流转而不得出离。“诸佛无自在”是说，诸佛也没有办法改变这种情况。

二者、如来其身常住，应修此念，真如无间解脱垢故。

这第二种念佛法儿，其实就是实相念佛，刚才说的第一种念佛法是观想念佛。“如来其身常住”，这很简单，因为佛法身其实就是清净法界、就是真如，自然是常住的。“应修此念”，那么，我们在念佛的时候，就要这么念佛，在禅定中这样观察，观察什么呢？“真如无间解脱垢故”，说，众生的身体是无常的，为什么佛身常住呢？因为佛以真如为身。“无间”在论文中是指成佛以后连一刻不清净的时候也没有了，在还没成佛的时候，他所成就的境界还是有个别间隔的。论文中的“垢”，就是烦恼障、所知障的垢，它可以搅局，但成了佛以后，它就搅不了局了。

三者、如来最胜无罪，应修此念，一切烦恼及所知障并离系故。

这是说，佛是最殊胜的，连一点儿的过失也都没有了。所以我们要这样念佛：佛没有了烦恼障、所知障，我现在学习佛法，也要象佛一样，也不能有烦恼障、所知障。要时时观想自己就象佛一样慈悲、智慧等等。

四者、如来无有功用，应修此念，不作功用一切佛事无休息故。

说，佛在度化众生时，“如来无有功用”，佛并没有刻意举心动念去度众生。我们应该这样念佛，“不作功用一切佛事无休息”，佛没有刻意努力去度众生，度化众生的事业是任运的、自然的，而且是永久的，佛不会说我这会儿不度了，没有这样的事儿。

五者、如来受大富乐，应修此念，清净佛土大富乐故。

这是说成佛以后，有无穷的富乐，主要是“清净佛土大富乐”。咱们看《阿弥陀经》，极乐世界是黄金为地，到处是七宝。佛的世界确实是大富乐。这是因为佛在因地的时候广修福慧的缘故，可不是无因缘的。这说的是佛的受用土。佛的富乐不是只自己享用，是可以与别人一起享用的。

六者、如来离诸染污，应修此念，生在世间一切世法不能染故。

这一个是说佛的变化土。“如来离诸染污”，佛来到凡夫世界度众生，凡夫世界是染污的，但佛离诸染污。“生在世间一切世法不能染”生在污染世界，但这世界无法污染他。

七者、如来能成大事，应修此念，示现等觉般涅槃等，一切有情未成熟者能令成熟，已成熟者令解脱故。

佛来到世间能够成就大事，就是广度众生。“示现等觉般涅槃等”，就是示现八相成道，示现在这儿成佛。“一切有情未成熟者能令成熟，”让一切众生培植善根，没有成熟善根的让他成熟善根，“已成熟者令解脱”，已经成熟善根的让他解脱。“成熟”就是得到，“成熟善根”就是得到善根。

此中有二颂：

这七念，无著论师用二个颂子给说一下，这样好记。

圆满属自心 具常住清净 无功用能施 有情大法乐

遍行无依止 平等利多生 一切佛智者 应修一切念

“圆满”，指前边儿的七条都是圆满的，是圆满的大自在境界。“属自心”，指第一条“于一切法得自在转”，一切法都随心。“属”就是随顺，随心所欲，想怎么着都能成就。“具常住”是指第二条“其身常住”。“清净”是第三条“如来最胜无罪”。“无功用”是第四条，“如来无功用”。“能施有情大法乐”是第五条，“如来受大富乐”。“遍行无依止”是第六条“如来离诸染污”。如来入一切法界，皆不受染污。“平等利多生”是第七条，“如来能成大事”。佛的悲心平等地度一切众生，能饶益一切众生。这七条都是圆满的。颂子中说“一切佛”，就是说一切佛都具足这七种圆满。“智者应修一切念”，有智慧的人就应该修学这个念佛法门。

复次，诸佛清净佛土相，云何应知？

佛的法身圆满，那么其依报如何清净呢？也得说说。

如菩萨藏百千契经序品中说，

先引用经文，这是圣言量。《菩萨藏百千契经》，印顺法师说是《华严经》，但你翻一下，下边儿的一段其实是《解深密经•序品》中的。我把《解深密经》也带来了，下边儿的一段文字在《解深密经》的第一、第二到第三页。在这部《菩萨藏百千契经》的“序品”里有这样的话。

谓：簿伽梵住最胜光曜七宝庄严，放大光明普照一切无边世界，

“簿伽梵”就是佛。“住最胜光曜七宝庄严”，佛住的是有殊胜的光明照耀的七宝庄严的宫殿里。这个宫殿放出大光明来照耀一切世界。这是说佛的净土显色圆满。显色就是青、黄、赤、白等颜色。这里说的佛应该是受用身佛。

无量方所妙饰间列，

这是说佛土形色圆满，形色是一个偏正词组，重点在“形”上，形色本是形象颜色，一偏正就成了着重于形了，所谓形色就指长、短、方、圆等。“无量方所”就是指这个大宫殿（这大宫殿是一个建筑群，当然，这是瞎说）的各处，“妙饰间列”，这宫殿装修得都可好了。“饰”是装饰，“间列”是布局合理。佛的世界是自在的境界，想怎么变都可以。

周圆无际其量难测，

“周圆”，你划一个平面图形，要求面积相等，那么圆形的周长最大。是不是这样，我有没有说错？平面几何的内容也忘了。这个“周圆”就表示最大，说的是宫殿最大。大到什么程度？“无际”，无限大。“其量难测”，没法测量、没法思维。这是说佛土的大小，俗话叫占地面积。这一句说的是佛土的分量圆满。

超过三界所行之处，

佛土超过了凡夫的世界。比我们的世界圆满。我们的世界是有漏业成就的，佛土是无漏业成就的。这是说的佛土的方所圆满。

胜出世间善根所起，

佛土是怎么成就的呢？“胜出世间善根所起”，是这样成就的。善根有世间的、有出世间，我好心作了一点儿善事儿，这是世间善根，“胜出世间善根”则是成就道业的善根，成就道业还有成就二乘道业和成就菩萨道业的不同，这里指的是成就菩萨乘的道业。有人说还兼顾成就二乘道业，比如说极乐世界就有许多的大菩萨，还有大阿罗汉等。这也是一种说法吧。这是佛土的因圆满。

最极自在净识为相，

这是佛土的果圆满。这佛土就是由胜出世间的因所创造、所成就的。佛土是“最极自在”的，“最极自在”就是达到自在境界的极致，大自在！“净识”就是无垢识。这句论文说，成了佛之后，是以无垢识为清净世界的体相。也就是说，佛土是“胜出世间善根”为因而有的，但它也是佛的清净心所现的，要是没有佛的无垢识，也就没有那个“七宝庄严，放大光明普照一切无边世界”的大宫殿。总之，就是说，佛土也是以识为体性。唯识无义。

如来所都，

这是主圆满。佛土是由如来所“都”的，“都”就是首领、头目的意思，这个我是查过字典的。就是说，在佛土里如来是头领。

诸大菩萨众所云集，

这是辅翼圆满。说，在佛土里可不是只佛住在那里，还有很多的菩萨也在那里住，他们在那里帮助如来弘扬佛法教化众生。这里我想还包括阿罗汉之类的，因为比如西方极乐世界就有很多阿罗汉之类的。反正这里指的是圣者。

无量天、龙、药叉、健达缚、阿素洛、揭路荼、紧捺洛、莫呼洛伽、人、非人等常所翼从，

这是眷属圆满。这是因为佛摄化一切众生的缘故。佛土里也有很多的天人；龙，龙是水族；还有药叉，药叉用汉语说就是暴恶鬼；还有健达缚，健达缚用汉语说是寻香，他是管音乐的神；阿素洛，用汉语说就是不端正。还有揭路荼，就是咱们说的大鹏金翅鸟；还有紧捺洛，这也是管音乐的，头上有角，但又象个人样子；还有莫呼洛伽，就是大蟒蛇；还有人与非人等。这就是咱们常说的天龙八部。这个咱们注意一下。虽然说这里说了有天龙八部，但这不是真的。你翻到无性释554页，倒数第四行，“此化非实”。什么意思？就是说，能到佛那儿去的，都得是大菩萨，大菩萨们都带惯了眷属，到这儿来参加法会，他习惯性地就化现出眷属来了，并不是真的天龙八部也来了。这就象冬天里我们戴帽子，到了春天天暖和了，因为戴了一冬的帽子，所以刚不戴帽子的时候还觉得头上戴着帽子一样。菩萨一直带眷属，现在一下子不带，也有还带着眷属的感觉，因为菩萨心力太强，所以在经典上也列出来（被见到）。

广大法味喜乐所持，

这是任持圆满。生活在佛土里的人也是要吃东西的，他们吃什么呢？“广大法味喜乐所持”，原来呀，是佛为他们说法，他们听佛说法，听众心里就有了喜乐的滋味。有了这喜乐，结果这儿的菩萨们就能够生活下去了，生命就可以存在了。这确实是不错的。

作诸众生一切义利，

这一句是事业圆满。你不能吃过饭不干事儿吧，他们作什么事儿呢？就作利益众生的事儿，利益众生的事儿他们都干。

蠲除一切烦恼灾横，

这是摄益圆满。“蠲除一切烦恼灾横”是说，在佛土里是没有一切的灾祸的，烦恼也没有，灾祸也没有。天灾人祸都没有，是一个清净的世界、安乐的世界。

远离众魔，

这是无畏圆满。在我们这个世界，有很多的魔，烦恼魔、五蕴魔、死魔、天魔等等，他们来恼乱我们的身心，我们要修行，他们偏来捣乱，但佛国净土里没有魔。因为没魔，所以我们无畏。

过诸庄严如来庄严之所依处，

这是住处圆满。这是说佛的世界的庄严是最庄严的，“过诸庄严”，超过了所有的庄严，比二乘的庄严庄严多了，凡夫世界的装修给佛土根本就没法比。“如来庄严之所依处”，佛土是佛的无量功德所庄严的地方，是最圆满的。

大念慧行以为游路，

这是路圆满。“大念慧行以为游路”，“大念”是闻慧，“慧”是指思慧，“行”是修慧。就是说，在佛土里是以闻所成慧、思所成慧、修所成慧为路的。我们凡夫要到什么地方去，要走公路、铁路，而菩萨要到佛地去，得走闻路、思路、修路。就是说，是以闻思修三慧为路的，沿着这条路就可以成佛。

大止妙观以为所乘，

我们在路上也不是步行的，在公路上就坐汽车，在铁路上就坐火车，现在在闻思修三慧的路上，是坐什么呢？坐的是无漏止观，也就是奢摩他、毘钵舍那。这个是乘圆满。

大空无相无愿解脱为所入门，

到了佛这儿了，还有一个门，你得进去，这个门是什么呢？是“空、无相、无愿”，这个咱们一般叫三解脱门。过了这个门就登堂入室了，就到常寂光净土了。

无量功德众所庄严，大宝华王之所建立大宫殿中。

这是依持圆满。依持就是依靠、靠山，经上说我每这个世界是以风轮为依持，要是没有风轮，我们这个世界就完蛋了。你看，现在环境污染，南极上空出现臭氧洞，这就是咱们这个世界的风轮出问题了，再不注意，问题就大了。咱们人以大地为依持，在地上生活，可以偶尔坐坐飞机，但不能永远离开大地。现在说佛土，则是以“无量功德众所庄严”的“大宝华王”为依持，就是说，佛土是建立在大宝华王上。注意，大宝华王就是我们的清净心。十八种圆满就说完了。

如是显示清净佛土显色圆满，形色圆满，分量圆满，方所圆满，因圆满，果圆满，主圆满，辅翼圆满，眷属圆满，住持圆满，事业圆满，摄益圆满，无畏圆满，住处圆满，路圆满，乘圆满，门圆满，依持圆满。

前边儿用论文说了一下清净佛土的十八种圆满，但没有说名字，当然，我说的时候给说了，人家原文上是没有说的，这儿无著论师给说了一下子。

复次，受用如是清净佛土，一向净妙，一向安乐，一向无罪，一向自在。

这是把清净佛土又用四种净德给说了一下。“受用如是清净佛土”，要是受用这清净佛土的话，也就是说，在这清净佛土生活的话，那会有什么好处呢？有四种好处：一向净妙，一向安乐，一向无罪，一向自在。“一向”就是一直。“净妙”就是清净微妙，没有不清净的事儿。一直是安乐的，从来不会有苦恼。一直是没有罪障的，一直是大自在的。

复次，应知如诸佛法界，于一切时能作五业：

十门分别的最后一门是业――诸佛法身（法身即清净法界）所作的事业。这里说佛所作的事业有五种，当然，五种都是利益有情的。

一者、救济一切有情灾横为业，于暂见时便能救济盲聋狂等诸灾横故。

法身佛所作的第一件事儿，是“救济一切有情灾横为业”，救济一切众生的灾横，水灾、火灾之类的他都救，这是他的事业，他要不干那他就不是佛了。“于暂见时便能救济”，他一看见他就要救，一下子也不停。无著论师还举了几个他救济的灾横例子，“盲聋狂等”，佛有法子使盲者得明，聋者得闻，“狂”就是魔症、精神病，让这些都恢复健康。“等”表示其他的衣食困难、水火盗贼之类的各种苦难。这确实是不可思议的境界。法身佛苦恼众生能见到吗？见不到！要知道这里说的法身佛包括受用身、变化身，这就见到了。这里就要说到广义的佛法了，五明都是佛法。

二者、救济恶趣为业，拔诸有情出不善处置善处故。

第二种是救济恶趣众生。刚才说的“盲聋狂”是指人道的苦难，现在说三恶道的苦难。对于恶道众生的苦难怎么办呢？“拔诸有情出不善处置善处”，佛可以令这些众生远离不善处而到善处去。怎么救法？你还没有落入恶道，他就劝你行善，使你不落恶道，你已经落入恶道的，他来打你、罚你（就是地狱狱卒）这样消你的业，让你赶快把业消完，快些出离恶道。

三者、救济非方便为业，令诸外道舍非方便求解脱行，置于如来圣教中故。

论文中的“非方便为业”是指外道的修行境界。“方便”就是解脱的方法，“非方便”则是指不正当的解脱方法，你想解脱，可是因为方法不对，修了半天也解脱不了，这就是“非方便”。有些外道修行是很努力的，但怎么也解脱不了。“令诸外道舍非方便求解脱行”，佛有办法使这些外道舍弃那些并不能使他解脱的修行方法，“置于如来圣教中”把他们安置到能够让他们解脱的如来圣教中，让他们照如来圣教而行就可以解脱了。

四者、救济萨迦耶见为业，授与能超三界道故。

第四、第五是说的佛教徒，第四是说小乘人有的有萨迦耶见，佛以“救济萨迦耶见为业”，“萨迦耶见”就是身见（执四大、五蕴和合的我恒常），你要是有身见，你就有苦恼，佛对这样的人也救度。“授与能超三界道”，对这些人，佛就教给他们能够超越三界的无我之道，给他们讲解四大、五蕴皆不可得，这空的道理可以令之得大解脱。

五者、救济乘为业，拯拔欲趣余乘菩萨，及不定种姓诸声闻等，安处令修大乘行故。

这一个是劝人发菩提心，行菩萨道，救度众生。在第四条中佛陀已经教给你超出三界的方法了，让你不再在生死中流转，但是你还没有发菩提心，所以大乘佛法很重要。“救济乘为业”，就是佛是广度众生，让人皆发菩提心，这就是他的事业。让人都成佛。“拯拔欲趣余乘菩萨”，“拯拔”就是救度，“欲趣余乘菩萨”是说，菩萨本来是发心救度众生的，可是众生难调难化，众生不上法船，这位菩萨就有些退心了，想着说：我不管别的众生了。还有“不定种姓诸声闻等”，在五种姓中有一类是不定种姓，就是说，要是遇到好的因缘，他就可以成佛，不然他就可以成二乘了，这就叫“不定种姓诸声闻”，有些是定姓的声闻、缘觉，现在只说这不定种姓诸声闻、缘觉。对于这些人，佛就来救度他，你是不定姓的声闻，佛劝你努力成佛，你是菩萨现在退心不想度众生了，佛就鼓励你。反正是让能够成佛的都成佛，有万分之一的希望就决不放弃。

佛做是就这五种事儿，前三种是接引众生来到佛法里，第四、第五两种是以真正的佛法来广度众生。这五种事儿，实际上只是一件事儿，度众生。

于此五业，应知诸佛业用平等。

一切佛作的都是这五种事儿，这是平等的、没有差别的。

此中有颂：

诸佛无差别，可我们有差别，因为我们不是佛。我们的差别从哪儿来呢？下边儿用了一个颂子来说明。

因依事性行 别故许业异

世间此力别 无故非导师

这个颂子说了我们的差别的五个理由。“因、依、事、性、行”。什么是“因”差别？就是原因的不同。有的人做十恶业，那就到三恶道去，而有的人做五戒十善，那就到人、天善道来，这就是因不同，因为因不同而使得业不同。第二个是“依”，就是身体，我们做事儿，要以身体为依止，不然的话就作不了事儿。这个依是各种各样的，人的身体都不一样的，有的人健康一些，有的人身体差一些等等。这样他的业就不一样。“事”就是做的事。有人作工人，有人作农民，有人作商人，有人作医生等等，这就是事不同。“性”则指个性、心，或者说是兴趣，有的人他的兴趣就在机械方面，那他就作工程师，有的人的兴趣就在表演上，那他就作演员等，这样也就表现出不同。“行”是采取行动作同样的事儿，有的人笨一点儿，就用一些笨方法，笨鸟先飞，而有的人聪明，用另外的法子，一下就搞定了。因不同、依不同、事不同、性不同、行不同，所以“许业异”，就导致了他的业不一样。“世间此力别”，世间众生在因力、依力、事力、性力、行力上有各种各样的差别，所以他的业力不一样。十方诸佛，都是因修六度万行而成就的，这是一样的，没有差别，而且作的都是利益众生的事儿，这也是一样的，可不象我们凡夫，各式各样。“无故非导师”，“无故”是指佛陀没有各种各样的差别，“非导师”是指各种的差别不是导师（佛陀）所有的，而是因为众生有，所以佛就随顺众生而显出差别。

若此功德圆满相应诸佛法身，不与声闻独觉乘共，以何意趣佛说一乘？

以下是解释问难的。因为有人对佛的法身还有疑问，所以这儿回答一下。下边儿一共提了八项疑问。“若此功德圆满相应诸佛法身”，就是说，诸佛的这些功德所成就的圆满法身，“不与声闻、独觉乘共”，诸佛的法身与声闻乘、独觉乘是不一样的，可是我们知道，《法华经》上说“唯有一佛乘，无二亦无三”，这是怎么回事儿呢？佛到底是以何意趣而这么说的呢？

此中有二颂：

这儿用了两个颂子来回答这个问题。

为引摄一类 及任持所余

由不定种姓 诸佛说一乘

“为引摄一类”，为了引摄一类众生。“摄”是摄持，就是照顾，照看着这一类众生，若他有不往成佛路上走的倾向，赶紧把他引过来。“及任持所余”，不单是照顾那一类众生，同时还要兼顾其他类众生。就是有主有次。“由不定种姓，诸佛说一乘”。说，“引摄一类”是引摄哪一类呢？原来是引摄的“不定声闻、独觉”，因为这些人，佛要是引导了、鼓励了，他就可能成佛，要是不给多费点儿心思的话，他们就成罗汉或者辟支佛了。“任持所余”也是不定性，有些菩萨也心不定，他在行菩萨道的时候，有困难他就灰心了，也有这样的菩萨，这叫不定性菩萨，佛在引摄不定性声闻的同时，还兼顾不定性菩萨。那些不定性声闻，从表面上看，他是二乘人，但他的内心里有大乘善根，佛引导他回小向大；这些不定性菩萨，表面上是菩萨，但他的内心里有动摇的因素，所以佛要断了他的杂念，所以说只有一佛乘，你没有别的路可以走，这样让他不退转。

法无我解脱 等故姓不同

得二意乐化 究竟说一乘

上一个颂子是说的佛说一佛乘的目的，这一个颂子是说佛说一佛乘的根据是什么。就是佛说一佛乘的理由是什么。“法无我解脱等”，意思是“法等、无我等、解脱等”（“等”是平等的意思）。的“法”，是指清净法界，清净法界呢，佛菩萨以及阿罗汉、辟支佛所证悟的都是一个，《华严经》卷第三十八·十地品第二十六之五中有说“法性真常离心念，二乘于此亦能得，不以此故为世尊，但以甚深无碍智”，这是佛对八地菩萨说的，意思就是说，你现在是证悟了真常法性的道理，你证悟的这个道理，二乘也能证得这真常法性。翻到世亲释288页第一行，“法谓真如，诸声闻等，同所归趣，所趣平等，故说一乘。”再翻到无性释558页倒数第三行，“法谓真如，诸声闻等乘虽差别，同趣真如，所趣真如无有差别，故说一乘。”世亲释和无性释的意思是一样的：声闻、独觉、菩萨所悟的清净法界、真如是一样的、平等的。

“无我”，这是说菩萨所证得的无我与声闻、独觉所证得的无我是一样的。声闻、缘觉证悟的是补特伽罗无我，菩萨所证悟的补特伽罗无我与声闻、缘觉是一样的。当然，他们还有不一样的，菩萨证得法无我了，声闻、缘觉是没有的。现在只说一样这一方面。“解脱”，这是说声闻、缘觉解脱了烦恼障，佛菩萨也解脱了烦恼障，这是一样的。“姓不同”指种姓不同，他是辟支佛种姓，他是声闻种姓，他是一佛乘种姓，这不一样。给前一句连起来是说，虽然种姓有不同，但所证悟的法、无我、解脱都没有差别，所以，从这一方面说呢，只有一佛乘。当然，这是说的不定姓声闻、不定姓缘觉、不定姓菩萨。

“得二意乐”，“二意乐”就是说，从人来说，你给佛的平等的，佛能成佛，我就也能成佛，所以是一佛乘；再从法上来说，一切法性平等，所以是一佛乘。“化”，佛陀化现成声闻、缘觉，就是说，佛在以前世也曾化现成声闻、缘觉，就是要告诉那些不定性的声闻乘人，声闻乘也是可以成佛的。“究竟说一乘”的“究竟”是指现在从究竟上来说一乘，因为刚才从法平等上说了一乘，从无我平等上说了一乘，从解脱平等上说了一乘，现在从究竟上说，也是一乘。从“究竟”上说，就是指佛是最究竟、最圆满的，没有超过佛乘的了。这样总结一下，就是说，佛说一佛乘的理由有八：法、无我、解脱、姓不同、二种意乐（人和法性）、化、究竟。这就是说，佛在经典里也说了一佛乘，就是因为这个所以说一佛乘的。

如是诸佛同一法身，而佛有多，何缘可见？

这是第二个疑问。“如是诸佛同一法身”，无量的诸佛都是以清净法界为法身。“而佛有多”，就是说，既然只有一个佛身，就只能有一位佛，可是却有很多佛，而且这么多佛还能同时存在，这是为什么？

此中有颂：

用个颂子来解答。

一界中无二 同时无量圆

次第转非理 故成有多佛

“一界中无二”，一个三千大千世界只有一尊佛。“同时无量圆”，同一个时候有许多人修行都圆满了。“次第转非理”，人家修行已经圆满了，你能不让人家成佛？这就必须有很多佛存在。修行可不是排座次要一个一个来，是可以同时修行的，你修你的我修我的。修行可以这样，当然成佛也是这样，可以同时成。不过化身佛度众生，那是另一回事儿，因为那是化现，你不能我来化现了你还来，这给众生添乱，所以是有次序的。

云何应知于法身中佛非毕竟入于涅槃，亦非毕竟不入涅槃？

下边儿是解释法身是不是涅槃的疑问。在小乘中说佛也入涅槃，在大乘中说法身既入涅槃，又不入涅槃。

此中有颂：

这儿用颂子回答。

一切障脱故 所作无竟故

佛毕竟涅槃 毕竟不涅槃

“一切障脱故”，成了佛就把烦恼障、所知障统统解脱了，这就是究竟证悟一切法寂灭。这就是佛入涅槃了。“所作无竟故”，成了佛也要一直度众生，要尽未来际度众生，所以就不能入涅槃。就是说，一证悟就是入了涅槃，已经入涅槃了，还要朝哪儿入，它本身就是涅槃，涅槃还怎么入涅槃？也就是说，涅槃没有入涅槃，既然没有入涅槃，那就是不入涅槃。这个颂子咱们要这样来，“一切障脱故，佛毕竟涅槃，所作无竟故，毕竟不涅槃”。

何故受用身非即自性身？由六因故：

受用身不是自性身。为什么呢？有六个原因。

一、色身可见故，

受用身是有色相的，而自性身是无色相的，可见受用身与自性身不一回事儿。

二、无量佛众会差别可见故，

有无量佛参加的大法会中，那些大菩萨所见的每一尊佛都各不相同，也就是有差别，要是自性身的话，则不会有这差别。可见受用身与自性身不一样。

三、随胜解见自性不定可见故，

在法会中初地菩萨、二地菩萨乃至十地菩萨，所见的受用身都不一样。刚才说的是有很多佛，每一尊佛都有不一样的地方。这第三说的是只有一尊佛，每一位菩萨所见到的都不一样。

四、别别而见自性变动可见故，

这一个是指你现在是初地，看见的佛是一个样儿，你登二地了，所见的佛又不一样，你登三地了，看见的佛又是一个样，你登十地了，看见的佛又是一个样儿。这是说你自见一个人。

五、菩萨声闻及诸天等种种众会间杂可见故，

在法会上，有菩萨、有声闻，还有缘觉，还有其他的众生，既然有这么多的众生来参加法会，所以这一定不是自性身，只能是受用身，这样才能各有所见。

六、阿赖耶识与诸转识转依非理可见故。

“阿赖耶识与诸转识转依”，转阿赖耶识是成自性身的，转诸转识成受用身。要是自性身就是受用身的话，就不该有阿赖耶识和诸转识的转依转成身的不同了，经上说“转阿赖耶识是成自性身的，转诸转识成受用身”，既然有这不同，就说明了自性身给受用身不一样，不然不是释迦牟尼吃饱了撑得胡说八道了吗？既然释迦牟尼是对的，当然就是我们错了。

佛受用身即自性身，不应道理。

所以说，受用身不是自性身，它们是两回事儿。

何因变化身非即自性身？由八因故，

这是说为什么变化身不是自性身。就是说，老比丘不是佛的真面目。这有八个理由。

谓诸菩萨从久远来，得不退定，于睹史多及人中生，不应道理。

“谓诸菩萨从久远来，得不退定”，菩萨从久远劫来就在修行，要三大阿僧祗劫才成佛的，在没有成佛之前，他早就得了不退转定。得了不退转定，一定是圣者了。从大乘说，最少是忍位才能得不退定，按小乘说，至少得是三果罗汉。他到这儿不是不修了，还是再修行着、上进着。现在好了，说“于睹史多及人中生”，到成佛之前的这一生，他从欲界睹史多天（即兜率天）没了后再来到人间受生～～这根本不合道理呀～～我再说一下，就是说，他早就得了不退转定，怎么会重退到人间来受生呢？所以这只能是示现身、变化身。要是真身（法身）绝对不会这样的。这是八因的第一、第二原因。能分清不能？第一个原因是：早就得了不退转定，怎么能从天上退下来呢？第二个原因是：早就得了不退转定，怎么能再到人间受生呢？所以只能是变化身。这是从八相成道的方面来说的。

又诸菩萨从久远来，常忆宿住，书算数印工巧论中及于受用欲尘行中不能正知，不应道理。

第三个原因说的是受学、受欲。“又诸菩萨从久远来，常忆宿住”，菩萨有宿命通，能忆念宿世情况，“书算数印工巧论”，他知道自己过去世已经学过这些，“书”是读过的书，“算数”就是算命、术数之类的，“印”是印刻等，“工巧论”就是工巧明这些，这些都是五明的情况，菩萨以五明成就，就是说，菩萨知道他过去世是修行过的，“于受用欲尘”他还知道自己过去世作错的事儿。这些他都知道。可是现在到人间了，他“不能正知”，就是都忘了，还得重新再学，“书算数印工巧论”还要重新再学，这算什么宿命通？根本就不是宿命通！这就矛盾了。以前有宿命通、有圣道，还知道受用欲尘的错误，可现在在人间又受用欲尘，这矛盾是怎么回事儿？这只能说他根本就不是佛的真身，这只是佛的方便示现，是变化身，示现的要去修学，去受用欲尘的。这都是为了度化众生而方便示现，示现出凡夫的情况，告诉我们凡夫，修行就能成道，我们凡夫这样就增加了信心：他是凡夫，他能修行成道，我也是凡夫，我也能成道！如果说他本来就是佛，我们会想：你本来就是佛，可我们不是呀～～我能行吗？。所以那根本就是变化身。

又诸菩萨从久远来，已知恶说、善说法教，往外道所不应道理。

诸菩萨久远劫来就通达佛法了，他已经明了了“恶说法教”和“善说法教”，哪是恶说，哪是善说，他清楚得很。但在这一生中，他还要去向六师外道请教，这不是胡涂吗？可见他并不是久远劫来就知道了。这根本就不合道理。所以，从他出家并向外道求教这一方面来看，他不是真佛，只是化身佛。这是第四条原因。

又诸菩萨从久远来，已能善知三乘正道，修邪苦行不应道理。

第五条原因是从修苦行来说。说，菩萨久远劫来就知道三乘正道，既然早就知道了，为什么还会有六年时间的邪修苦行？把自己弄得人不人鬼不鬼的，这是咋回事儿？所以，他只能是变化身。

又诸菩萨舍百拘胝诸赡部洲，但于一处成等正觉，转正法轮，不应道理。

第六、第七两条原因并在一起了。“又诸菩萨舍百拘胝诸赡部洲”，这是说，菩萨在修行的时候，是在各地行菩萨道的，成佛就应该到各地度化众生，因为他在各地都有有缘众生呀～～“百拘胝诸赡部洲”就是数百个南赡部洲那么大。菩萨他成佛了，为什么舍弃了其他洲而只在这一个地方说法度众呢？为什么只在这一个地方转法轮呢？这根本不合道理！就是说，佛是度一切众生的，可是你只在这儿成佛度众生，其他地方你不管了，这是不对的。所以说，只能说他是变化身佛而不是真佛、自性身佛。

若离示现成等正觉，唯以化身于所余处施作佛事，即应但于睹史多天成等正觉，何不施设遍于一切赡部洲中同时佛出？

如果说我们这儿的老比丘是真佛、是自性身的话，其他洲的会怎么说？人家也会说人家那儿的才是真身。“若离示现成等正觉，唯以化身于所余处施作佛事”，这一句话是说，只有我们这儿的佛是真身，其他地方的佛都是化身。对方也会这么说的。“离示现”就是不是示现，意思就是说这是真身、自性身，不是变化身。“唯以化身于所余处施作佛事”，在别的地方教化众生的是变化身。这样争论起来怎么办？佛是慈悲的，不是调斗人们来争吵的。“即应但于睹史多天成等正觉”，就应该只在兜率天成佛，这样不是更好吗？“何不施设遍于一切赡部洲中同时佛出”为什么他不在兜率天成佛，在其他的地方都是化身，这不是很公平吗？就是说，只有睹史多的是真佛，其余“百拘胝南赡部洲”的都是化身佛，同时都有佛，这是最好的了。

既不施设，无教无理。

无著说：可你小乘一直说这老比丘是真佛，其他地方的是化身佛。你这说法是既没有圣教依据，也不合理。完全是你的私心。这只是你自己在这儿安排，佛经中可没有这样说，没有圣教量的依据可是不行的。

虽有多化，而不违彼无二如来出现世言；

又有一个问题：很多的变化身佛，他们会不会打架？佛曾经说过，在一个世界只能有一尊化身佛，绝对不能有两尊佛同时出现于世，这样会给众生造成麻烦。无著论师在论文中就说了，“虽有多化，而不违彼无二如来出现世言”，虽然有很多的化身佛，这与“一个世界不能有两佛”的话不矛盾。为什么不矛盾呢？

由一四洲摄世界故，如二轮王不同出世。

因为佛说的一个世界里没有两位佛出现，就指的是一个四大部洲，一个四大部洲叫做一个世界，不是指很多的四大部洲叫一个世界。就象一个四大部洲没有两个转轮圣王出现世间，佛也是这样，没有二佛出现在一个四大部洲的情况。在一个四大部洲只有一位佛，所以这是可以的。从这儿也可以知道，在人间成就的只是变化身佛，不是自性佛。

此中有颂：

用颂子把这个道理再说一下。

佛微细化身 多处胎平等

为显一切种 成等觉而转

“佛微细化身”，佛有这微细的化身，可以到南阎浮提去入胎，这微细的化身，可以“多处胎平等”，可以到遍于三千大千世界去入胎，但每个地方的都是平等的变化身，没有说这儿是自性身，到另一个地方的是变化身，没有这样的事儿，都是变化身。“为显一切种，成等觉而转”，这是为了显示佛的自在境界，所以他到各个地方化现成佛。“一切种”就是一切种智，这是佛智。“而转”的“转”，是化现、显现，显现出这种不可思议的境界。这样，八相成道的佛我们就知道了是化身佛，不是真佛。

为欲利乐一切有情，发愿修行证大菩提，毕竟涅槃不应道理，愿行无果成过失故。

这是第八个理由。说佛当时在修行时发愿说要利益一切的众生，“为欲利乐一切有情”，后来等他成佛以后，没多久他就要涅槃了，这世界上还有很多众生在流浪生死，他能不管吗？他要是不管的话，他以前发的愿不就成空愿了吗？你最初发的愿岂不根本是谎话！所以说“不应道理”。“愿行无果成过失故”，成佛前你发愿，要度化一切有情，结果你没有做这件事，这是不对的。所以，入涅槃的只是化身佛。

这是用八个理由来说变化身不是自性身。

佛受用身及变化身，既是无常，云何经说如来身常？

受用身、变化身是无常的，而自性身是常的，可是佛经上说佛身常住，这是怎么回事儿？明明受用身、变化身无常呀～～

此二所依法身常故。

我们之所以说佛身常住，是因为受用身、变化身所依的自性身是常住的，所以我们就说受用身、变化身是常住的。它们是自性身变现出来的，根本就是一个假相，所以你不能说受用身、变化身是无常的，根本就没有，哪儿有它的无常？既然不能说是无常的，那就说常好了，这常，也是自性身常！记住，我们说法身常住的原因，是自性身常住。

又等流身及变化身，以恒受用无休废故，数数现化不永绝故；

上一句是从法身常住因而说受用身、变化身常住。而这一句则是说受用身、变化身本身也有常的意义。论文中的“等流身”就是受用身，因为受用身是从自性身里流出来的，受用身比变化身殊胜得多，虽然受用身不是自性身，但和自性身是相等的。从自性身中等流出来，就是说受用身是等流身所表现出来的作用。现在说，受用身“恒受用无休废故”，就是说，受用身长期受用大法乐，没有停止的时候，一直在大富乐清净境界中受大法乐。从这个角度我们说它“常”。变化身呢，“数数现化不永绝故”，说，变化身有生灭怎么也说常呢？原来，是因为他一次又一次地出现变化身，有因缘就出现一次，这一次的因缘尽了他就涅槃，后来又有因缘了，他就再出现一次，这样没有穷尽的时候，从这个角度来说，我们也说他“常”。

如常受乐，如常施食，如来身常应知亦尔。

这是一个比喻。“如常受乐”，我们快乐，是因为有智慧，而不是有钱没钱，要是有智慧的话自然会有一切，智慧是关键。有智慧就一直快乐，所以说，有智慧的人常受乐，其实这也是有间断，但有间断也是常受乐。“如常施食”，比如说一个人经常布施，我们说他常行布施，可不是说他一生就作这一件事，就站在街上布施，其实他也是有间断的，比如这一会儿他得回去吃饭，他得有别的事儿，他也得作，不过有间断我们也说他常布施。受用身、变化身也是这个道理，比如变化身，是有间断的，但有间断我们也说它“常”。

由六因故，诸佛世尊所现化身非毕竟住：

这是说化身一定得有涅槃，他不能不涅槃，不能毕竟住，有六个原因。

一、所作究竟，成熟有情已解脱故；

说，佛来到这个世间示现成佛，他所应该做的事情已经作完了。这一次的因缘已经尽了，该度化的都度化了，《佛遗教经》上说，“所应度者皆已度讫”，既然“度讫”了，就该走了、涅槃了。现在你已经没事儿了，下一次有因缘了，那就再示现。

二、为令舍离不乐涅槃，为求如来常住身故；

这是说我们有的人口是心非，说着是求涅槃的，可他说说只是说说，他实际上他不欢喜涅槃。“不乐涅槃”，只是嘴上讲讲涅槃，但实际上对涅槃没有好要心，“为令舍离不乐涅槃”，佛为了让你舍弃这个“对涅槃没有好要心”的心，所以他给你作一个榜样。“为求如来常住身故”，众生喜欢的是什么？喜欢的就是佛身常住，你有三十二相、八十种好的身形我看见就欢喜，佛现在示现涅槃就是要告诉你，这么好的三十二相、八十种好也是靠不住的，你要求如来常住，只有清净法身才能常住。入圣道的圣者不是不乐涅槃，而是乐涅槃了。

三、为令舍离轻毁诸佛，令悟甚深正法教故；

佛必须入涅槃的第三个理由，说，佛要是不入涅槃，你会讨厌他的。他不让我作这，不让我作那，今天说我，明天说我，你说一次、两次我听着，你老说我我受得了吗？在家里妈妈要老说我我还嫌她烦人呢～～“为令舍离轻毁诸佛”，这句话就是说为了不让你讨厌佛，佛涅槃了，人都有一个毛病，不珍惜已有的，老追求还没有到手的。佛是为了我们好，难道妈妈不是为了我好，难道妈妈还是想害我，我该讨厌还是讨厌。佛要入涅槃，就是省得你讨厌他。师父必须得管徒弟，戒律上说，师父收了徒弟而不教导是有罪的，你说你自己不守戒怨师父吗？不怨，但师父有罪！“令悟甚深正法教故”，说，佛要是不入涅槃，你就会想，反正佛还在，我以后再请教他好了，现在佛涅槃了，你就着急了，一有机会马上要精进：佛要是入涅槃了，我有不明白的地方怎么办呢？他就会觉得趁佛还在赶紧努力，一定要争取在佛涅槃之前成道，这样就不懈怠了。

四、为令于佛深生渴仰，恐数见者生厌怠故；

这个原因简单，就是因为我们不知道珍惜已有的，失去的才知可贵，所以佛要入涅槃。“为令于佛深生渴仰”，佛入涅槃了，你才知道遇佛是多么的不容易。“恐数见者生厌怠故”，你一直能见到佛，你就没有珍重想了。佛不入涅槃，你一讨厌他，反而增加你的罪过，佛入涅槃了，你生起渴仰之心，反倒能增加你的善根，既然这样有好处，能利益众生的事儿佛都愿意作，所以佛就涅槃了。有讨厌佛的吗？有，《大般涅槃经》上说，佛入涅槃了，迦叶尊者要赶过去，在路上遇见一个比丘，他就说：“佛入涅槃可就太好了，再没有人管我们了”，这样的事儿是有的。

五、令于自身发勤精进，知正说者难可得故；

“令于自身发勤精进”，这是真的修行人，很有道心的人，他说：佛在世的时候，我们还有个依靠，指望佛教导，现在佛要涅槃了，他要一涅槃，我就只能依靠自己了，所以我要趁现在更加努力精进。“知正说者难可得故”，要知道能说圆满正法的佛是很不容易遇到的，现在他要涅槃了，我要抓紧最后的机会，赶快精进成道。我们现在也能感到求法的艰难，有时候一个问题，想问个人实在找不到，问些老和尚，只能给说些正确的废话，根本解决不了实际问题。现在说这些人幸运，有佛，佛入涅槃，就是催促这些有懈怠心的人要警觉。

六、为诸有情极速成熟，令自精进不舍轭（e）故。

这一个是说，有一些佛教徒，他自己已经能够令善根成熟了，他有这个能力了，就不需要佛教导了。“为诸有情极速成熟”，“为”是因为；“诸有情”是有一部分有情；“极速成熟”，就是他有能力自己令自己精进、成就，“极速”是精进。“令自精进不舍轭故”，他可以让自己精进努力，这样的人不需要佛来教导了。“轭”是马车用的工具，要用马拉车，马就得带上这个，可以引申为管束。“不舍轭”就是自己就可以给自己鼓劲，就象马带上了轭一样，一直往前走。这是自己把自己给约束在正法里。印顺法师举的例子很好：就像病人已经快要痊愈了，医生守在旁边已经没有必要了，所以佛就入涅槃了。

这就是化身佛要入涅槃的六个原因。

此中有二颂：

再用二个颂子把这个意思说一下。

由所作究竟 舍不乐涅槃 离轻毁诸佛 深生于渴仰

内自发正勤 为极速成熟 故许佛化身 而非毕竟住

这还是化身佛要入涅槃的原因。由所作究竟、舍不乐涅槃、离轻毁诸佛、深生于渴仰、内自发正勤、为极速成熟，有这六个原因，“故许佛化身，而非毕竟住”，所以化身佛不能久住世间，一定要涅槃。

诸佛法身，无始时来无别无量，不应为得更作功用？

这是说你要想成佛你必须得自己努力修行。“诸佛法身”，一切佛的清净法身，“无始时来无别无量”，无始以来无量无边的佛，他们的法身都是没有差别的，是不能用数量来修饰、来形容的。一佛就是一切佛，一佛就能利乐一切众生。既然这样，我们“不应为得更作功用”？就是说，我们要是想成佛，佛就应该能够把这件事给我们做好，我们就不需要努力修行了吧？这种说法当然是不对的。

此中有颂：

这儿用一个颂子来解释。

佛得无别无量因 有情若舍勤功用

证得恒时不成因 断如是因不应理

“佛得无别无量因”，一切佛所证悟的清净法界是无别无量的，他能作一切众生精进修行的因缘（即是众生成佛的增上缘），佛的清净法界境界，其实一切众生也都是有的，就是性具呀～～天台宗就这么说的。“有情若舍勤功用”，说，佛确实是有不可思议的威力，可以作我们精进修行的增上缘，世亲释中叫“精进因”，无性释中叫“正勤因”，但是如果众生自己本身不修行，不努力，你还是不能成佛。其实这个咱们知道的，四缘成就，佛只能作增上缘，只有增上缘是不能成就的。“证得恒时不成因”，说，你自己要是不努力，诸佛所证得的清净法界长时间不能够与你本具的产生感应，这增上缘不起作用，不起作用就等于没有，这就是颂子中说的“不成因”――还不能成为助缘（指增上缘）。“断如是因不应理”，你要是断掉了你精进修行的力量，还想成佛，这就是不合理的。

阿毘达磨大乘经中摄大乘品，我阿僧伽略释究竟。

这部《阿毘达磨大乘经·摄大乘品》，到这儿我无著就给简单地说完了。“阿僧伽”就是无著论师。印度人写文章是把作者名写在后边儿的。所以无著论师也是把自己的名字放在了后边儿。